Palm API Guide

Palm OS

5.3

This file contains documentation on all Palm APIs for Palm OS. It includes the API function definitions for the following product lines:
  • Tungsten
  • Zire
  • Treo
  • LifeDrive
  • Treo 650
  • Treo 700p
  • Treo 680

The goal of this document is to provide developers a quick index of all the functions, their parameters and all the constant definitions.

Click on the following links to see:

  • Libraries
  • Header Files
  • Sample Codes

Newest members of Palm devices, Treo 680 smartphones:

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:23 2006 for Palm API Guide


Palm API Guide File List

Here is a list of all documented files with brief descriptions:
CameraLib.h | Public 68K include file for camera support for Treo 600 devices
CameraLibCommon.h | Public 68K common header file for camera support for Treo 600 devices
CarrierCustomLib.h | This is the main header file for the Carrier Customization Library
CarrierCustomLibErr.h | This file contains the error codes for the Carrier Customization Library
CarrierCustomLibTraps.h | This file contains the trap for the Carrier Customization Library
CarrierCustomLibTypes.h | This file contains public data types exported by the Carrier Customization Library
DefaultHelperLib.h | Default Helper library owns control over the Default Helpers database
DefaultHelperLibTypes.h | Public 68K common header file for Default Helper Library API
FavoritesDBLib.h | Contains the API to control the Favorites DB
FavoritesDBLibTypes.h | Public 68K common header file for FavoritesDB library API
FileBrowserLib68K.h | This file contains the FileBrowser Library APIs
FileBrowserLibCommon.h | Public 68K common header file for File Browser library API
HardwareUtils68K.h | Public common header file to the Hardware Utilities Library used by 68K applications
HS_HTTPLib68K.h | Public 68k include file for the HTTP Library
HS_HTTPLibApp.h | Public 68k header file containing the structures used in HTTP Library
HS_HTTPLibConst.h | Public 68k header file containing the constants used in HTTP Library
HsAppLaunchCmd.h | Public header file akin to Palm's AppLaunchCmd.h
HsChars.h |
HsCommon.h |
HsCreators.h | Public header file for the creator IDs used by Handspring
HsErrorClasses.h |
HsErrors.h |
HsExgMgr.h | Extensions to the Exchange Manager
HsExgMgrCommon.h |
HsExt.h | Header file that 68K programs include to access Handspring Extensions functionality
HsExtCommon.h | Common defines shared between HsExt.h (include for 68K programs) and HsExtArm.h (include for ARM programs)
HsExtKbdUtils.h |
HsExtTraps.h | Definitions of selectors used for the 68K trap based calls to HsExtensions
HsExtUtilBigButton.h |
HsExtUtilBigButtonCommon.h |
HsHelper.h |
HsKeyCodes.h |
HsKeyCommon.h | Header file with additional keyboard related definitions
HsKeyTypes.h | PalmOne's key constant definitions shared by DAL and Palm OS (see Palm OS' CmnKeyTypes.h)
HsNav.h | Header file that 68K programs include to access HsNav functionality
HsNavCommon.h | Public common header file for 5-way navigation support on Treo 600
HsPhone.h | Header file for the phone library (CDMA or GSM)
HsPhoneAudio.h | Header File for Phone Library API ---- AUDIO CATEGORY
HsPhoneAudioTypes.h | File contains Phone Audio data types
HsPhoneCallControlTypes.h | Types for Phone Library call control functionality
HsPhoneCDMA.h | Header File for Phone Library API ---- CDMA CATEGORY
HsPhoneCDMATypes.h | Header File for Phone Library API ---- NETWORK CATEGORY
HsPhoneErrors.h | Errors returned by API function in GSM/CDMA Library
HsPhoneEvent.h | Header file for the phone library (CDMA or GSM)
HsPhoneGSM.h | Header File for Phone Library API ---- GSM CATEGORY
HsPhoneGSMTypes.h | Header File for Phone Library API ---- NETWORK CATEGORY
HsPhoneIOTA.h | Header File for Phone Library API ---- IOTA CATEGORY
HsPhoneIOTATypes.h | Header File for Phone Library API ---- IOTA CATEGORY
HsPhoneLibrary.h | Header File for Phone Library API ---- LIBRARY CATEGORY
hsPhoneLocationTypes.h | File contains Phone Location data types
HsPhoneMisc.h | Header File for Phone Library API ---- MISC CATEGORY
HsPhoneMiscTypes.h | Header File for Phone Library API ---- NETWORK CATEGORY
HsPhoneNetwork.h | Header File for Phone Library API ---- NETWORK CATEGORY
HsPhoneNetworkTypes.h | Header File for Phone Library API ---- NETWORK CATEGORY
HsPhonePower.h | Header File for Phone Library API ---- POWER CATEGORY
HsPhoneSecurity.h | Header File for Phone Library API ---- SECURITY CATEGORY
HsPhoneSecurityTypes.h | Header File for Phone Library API ---- NETWORK CATEGORY
HsPhoneSMS.h | Header File for Phone Library API ---- SMS CATEGORY
HsPhoneSMSTypes.h | Header File for Phone Library API ---- NETWORK CATEGORY
HsPhoneTrace.h | Trace constants, types, and definitions for Phone Library
HsPhoneTraps.h | Traps of all functions exported by the Phone Library
HsPhoneTypes.h | Telephony data types that are common between ARM and 68K
HsSoundLib.h | Public 68K include file for main sound support for Treo 600 and Treo 650 smartphones
HsSoundLibCommon.h | Public 68K common header file for sound support for Treo 600 and Treo 650 smartphones
HtmlLib68K.h | Public 68K include file for HTML shared library
ImageLib.h | Public 68k include file for the Imaging Library
ImageLibCommon.h | Public 68k common header file for the Image Library API on Treo 600 devices
LocsLib.h | Public 68K include file for location/timezone/DST support on Palm devices
LocsLibCommon.h | Public 68K common header file for locations library
MmsHelperCommon.h | Public 68k common header files to be used with Default Helper Library
NetMasterLibErrors.h | This is the error declarations file for the NetMaster Library
NetMasterLibrary.h | This is the main header file for the NetMaster Library
NetMasterLibTarget.h | This is the target parameters file for the NetMaster Library
NetMasterLibTraps.h | Trap definitions for the NetMaster Library
NetMasterLibTypes.h | This file contains public data types exported by the NetMaster Library
NetPrefLibErrors.h | This is the error declarations file for the NetPref Library
NetPrefLibFieldInfoTable.h | This header file contains record field information for NetPref settings
NetPrefLibrary.h | This is the main header file for the NetPref Library
NetPrefLibTarget.h | This is the target parameters file for the NetPref Library
NetPrefLibTraps.h | Trap definitions for the NetPref Library
NetPrefLibTypes.h | This file contains public data types exported by the NetPref Library
PalmAudioPlayback.h | Public 68K include file that supports the stopping of audio playback on Treo 600 and Treo 650 smartphones
PalmBGService.h | Public 68K header file for palmOne Background Network Service Library
PalmCreators.h | Contains Palm-specific creator codes
PalmDisplayExtent.h | Public API for the Display Extent Library
PalmErrorBase.h | Include file for Error Management
PalmFeatures.h | Contains Palm-specific feature definitions
PalmGoLCD.h | Public include header file for the GoLCD Library
PalmGoLCDCommon.h | Public common header file for the GoLCD Library
PalmHiResTime.h | Exported High Resolution timer definitions
PalmLaunchCodes.h | Device specific launch codes
PalmLcdOverlay.h | Exported LCD Overlay functions
PalmLED.h | Palm's Generic LED dirver
PalmNative.h | Functions and macros to help building ARM code
PalmNetServices.h | NetServices provides a set of API to access 802.11
palmOne_68K.h |
palmOneCamera.h | Public 68K include file for camera support for Treo 650 devices. This version of the library adds functionality for Zire72, and Treo 650
palmOneCameraCommon.h | Public 68K common header file for camera support for Zire 72 and Treo 650 devices
palmOneCameraSlider.h | Public 68K file for camera slider notification for Zire 71 devices
palmOneCodecFormat.h | Public 68K common header file for Codec Plugin Manager API - Codec Formats
palmOneCodecPluginMgr.h | The Codec Plugin Manager is used to unify all different type of codecs that are available for PalmOne devices and provide a generic API for developers to access these codecs
palmOneCodecPluginMgrCommon.h | Public 68K common header file for Codec Plugin Manager API - Library Definitions
palmOneCreators.h | Contains Palm-specific creator codes
palmOneFeatures.h | Contains Palm-specific feature definitions
palmOneHiResTimer.h | Public 68k include file for Hi-Resolution timer for Palm OS
palmOneHiResTimerCommon.h | Public 68k common header file for Hi-Resolution Timer API
palmOneLcdOverlay.h | Public 68k include file for LCDOverlay API that can be used to display YCbCr images directly on the screen
palmOneLcdOverlayCommon.h | Public 68k common header file for LCDOverlay API
palmOnePhoto.h | Palm Photos API: This API is used to access Palm Photos database and manipulate images
palmOnePhotoCommon.h | Palm Photos API: This file contains all the defines, enumerations, structures needed by PalmPhoto.h
palmOneResources.h | Palm-specific system types and resources
palmOneSndFileStream.h | Public 68K include file for sound files stream support for Treo 600 and Treo 650 smartphones
palmOneStatusBar.h | Public common header file for palmOne defined Status Bar library
palmOneSystemCommon.h | This is the common public header for palmOne system definitions
palmOneVMFontLib.h | Defines APIs and structures for the Palm VersaMail Font Picker / Font Manager Service which lets users get / set font characteristics
PalmPin.h | Public API for the Pen Input Manager Library
PalmPower.h | Battery notification
PalmShimSettings.h | Shim settings for NetIFSettingGet()/Set()
PalmSoundCustomCtrl.h | Public 68K include file for the Sound Manager custom controls for the IMA_ADPCM codec for Treo 600 and Treo 650 smartphones
PalmSoundMgrExt.h | Public 68K include file for the Extended Sound Manager
PalmVMLaunch.h | Defines APIs and structures for launching VersaMail to add a new message from an application
PalmVMPlugin.h | Defines APIs and structures for the VersaMail Plugin Service which lets users write plugins to view/send attachments
PalmVPPI.h | This is the API for VPN panel plug-ins (VPPIs)
PalmWiFiCommon.h | Constants and structures common to the wifi network panel and driver
PalmWPPI.h | This is the API for Wi-Fi panel plug-ins (WPPIs)
PmConnectorLib.h | PalmOne library that exports multi-connector related APIs
PmConnectorLibCommon.h | Public 68k common header file for Multi-Connector Library for palmOne devices that use multi-connector
PmKeyLib.h | System Library that exports key-related APIs
PmKeyLibCommon.h | Public 68k common header file for system library that exports key-related APIs
PmLibErrors.h | Errors common to all our portable Pm Libraries
PmPalmOSNVFS.h | Public 68k header file containing the definitions and API for NVFS devices
PmSoundLibAudioGroup.h | Public 68K header file used to associate sound channels with Audio groups on Treo 600 and Treo 650 smartphones
PmSysGadgetLib.h | System Library that exports status-related APIs
PmSysGadgetLibCommon.h | Public 68k header file for system Library that exports system gadget related APIs
PmUIUtilLib.h | This is the public header for PmUIUtil library
PmUIUtilLibCommon.h | Public 68k common header file for system Library that exports UI utility API functions
Slider.h |
SmartTextEngine.h | Public 68K include file for Smart Text Engine shared library
SmartTextEngineDef.h | Public include file for Smart Text Engine shared library
SmartTextEngineErrors.h | Error codes for Smart Text Engine shared library
SmartTextEngineTraps.h | Trap definitions for the Smart Text Engine shared library
TonesLib.h | Public 68K include file that controls the MIDI tones on a device
TonesLibTypes.h | Public 68K header file for the Ring Tone library on Treo devices
TransparencyLib.h | Transparency Library that couples a Ccp channel and a serial port
TransparencyLibTypes.h | Public common header file for the Transparency Library on Treo devices
VMFontLibCommon.h | Public common header file for the Versamail Font Library
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:23 2006 for Palm API Guide


CameraLib.h File Reference

Detailed Description

Public 68K include file for camera support for Treo 600 devices.

Notes: The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application(ie, SysLibFind() returns a valid refnum). When the application is done with the library, it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal synchronization.

Include dependency graph for CameraLib.h:

Functions

  • Err CameraLibOpen (UInt16 refnum)
  • Err CameraLibClose (UInt16 refnum)
  • Err CameraLibSleep (UInt16 refnum)
  • Err CameraLibWake (UInt16 refnum)
  • Err CameraLibCapture (UInt16 refnum, void *buffer, UInt16 format)
  • Err CameraLibPreview (UInt16 refnum, void *buffer, UInt16 format, UInt32 width, UInt32 height)
  • Err CameraLibPreviewStart (UInt16 refnum, WinHandle windowH, UInt32 x, UInt32 y)
  • Err CameraLibPreviewStop (UInt16 refnum)
  • Err CameraLibRegisterGet (UInt16 refnum, UInt32 reg, UInt32 *valueP)
  • Err CameraLibRegisterSet (UInt16 refnum, UInt32 reg, UInt32 value)

Function Documentation

Err CameraLibCapture | ( | UInt16 | refnum,
 |  | void * | buffer,
 |  | UInt16 | format
 | ) |

Returns a full image (640X480) in the specified color space. This function is not really necessary, since CameraLibPreview could be used instead. This function might be deprecated in the future.

Parameters:
refnum,: IN: Library reference number.
buffer,: IN: Buffer to hold the image.
format,: IN: Format of the image you want returned.
Return values:
Err Error code.

Err CameraLibClose ( UInt16 refnum )

Closes the Camera library. Library should always be unloaded with SysLibRemove() after CameraLibClose() is called. See note at top of file.

Parameters:
refnum,: IN: Library reference number.
Return values:
Err Error code.

Err CameraLibOpen ( UInt16 refnum )

Standard library open routine. Library should always be loaded with SysLibLoad()(not SysLibFind()) before calling CameraLibOpen(). See note at top of file.

Parameters:
refnum,: IN: Library reference number.
Return values:
Err Error code.

Err CameraLibPreview | ( | UInt16 | refnum,
 |  | void * | buffer,
 |  | UInt16 | format,
 |  | UInt32 | width,
 |  | UInt32 | height
 | ) |

Returns an image using the window width and height (pixels) you specify. If the width and height are less the dimensions of a full camera image (640x480) a simple pixel sub-sampling algorithm is used to decimate the image.

Parameters:
refnum,: IN: Library reference number.
buffer,: IN: Buffer to hold the image.
format,: IN: Format of the image you want returned.
width,: IN: The width in pixels of the image you want captured.
height,: IN: The height in pixels of the image you want captured.
Return values:
Err Error code.

Err CameraLibPreviewStart | ( | UInt16 | refnum,
 |  | WinHandle | windowH,
 |  | UInt32 | x,
 |  | UInt32 | y
 | ) |

Puts the camera library in preview mode and establishes a preview window. While in this mode, QQVGA images are continuously copied to the LCD screen of the device. Call CameraLibPreviewStop to exit preview mode.

Parameters:
refnum,: IN: Library reference number.
windowH,: IN: Window handle of the PalmOS window that the image is to be displayed in.
x,: IN: Window-relative coordinate of the left edge of the image.
y,: IN: Window-relative coordinate of the top edge of the image.
Return values:
Err Error code.

Err CameraLibPreviewStop ( UInt16 refnum )

Stops preview mode.

See also:
CameraLibPreviewStart.
Parameters:
refnum,: IN: Library reference number.
Return values:
Err Error code.

Err CameraLibRegisterGet | ( | UInt16 | refnum,
 |  | UInt32 | reg,
 |  | UInt32 * | valueP
 | ) |

Gets the current setting of the camera register.

Parameters:
refnum,: IN: Library reference number.
reg,: IN: Register number.
valueP,: OUT: Pointer to where register data will be stored.
Return values:
Err Error code.

Err CameraLibRegisterSet | ( | UInt16 | refnum,
 |  | UInt32 | reg,
 |  | UInt32 | value
 | ) |

Sets the value of the camera register.

Parameters:
refnum,: IN: Library reference number.
reg,: IN: Register number.
value,: IN: The data value you want to set the register to.
Return values:
Err Error code.

Err CameraLibSleep ( UInt16 refnum )

Standard library sleep function.

Parameters:
refnum,: IN: Library reference number.
Return values:
Err Error code.

Err CameraLibWake ( UInt16 refnum )

Standard library wake function.

Parameters:
refnum,: IN: Library reference number.
Return values:
Err Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:24 2006 for Palm API Guide


CameraLibCommon.h File Reference

Detailed Description

Public 68K common header file for camera support for Treo 600 devices.

This file contains the library constants and error codes used in the APIs.

Image Format

  • #define kCameraImageFormatRGB1 1
  • #define kCameraImageFormatRGB4 2
  • #define kCameraImageFormatRGB8 3
  • #define kCameraImageFormatRGB16 4
  • #define kCameraImageFormatRGB24 5
  • #define kCameraImageFormatRGB32 6
  • #define kCameraImageFormatYCrCb 7
  • #define kCameraImageLittleEndian 0x8000
  • #define kCameraImageFormatYCbCr kCameraImageFormatYCrCb

Error Codes

  • #define errCam 0xaf00
  • #define errCamNoFrame (errCam + 0)
  • #define errInPreviewMode (errCam + 1)
  • #define errCamOverflow (errCam + 2)
  • #define errInvalidAddress (errCam + 3)
  • #define errCamWriteFailed (errCam + 4)

Function Traps

  • #define kCameraLibTrapOpen sysLibTrapOpen
  • #define kCameraLibTrapClose sysLibTrapClose
  • #define kCameraLibTrapSleep sysLibTrapSleep
  • #define kCameraLibTrapWake sysLibTrapWake
  • #define kCameraLibTrapCameraLibCapture (sysLibTrapCustom)
  • #define kCameraLibTrapCameraLibPreview (sysLibTrapCustom+1)
  • #define kCameraLibTrapCameraLibPreviewStart (sysLibTrapCustom+2)
  • #define kCameraLibTrapCameraLibPreviewStop (sysLibTrapCustom+3)
  • #define kCameraLibTrapCameraLibRegisterGet (sysLibTrapCustom+4)
  • #define kCameraLibTrapCameraLibRegisterSet (sysLibTrapCustom+5)

Defines

  • #define kCameraLibType sysFileTLibrary
  • #define kCameraLibCreator 'HsCa'
  • #define kCameraLibName "CameraLib"

Define Documentation

#define kCameraImageFormatRGB1 1

Whatever RGB1 Format is

#define kCameraImageFormatRGB16 4

Whatever RGB16 Format is

#define kCameraImageFormatRGB24 5

Whatever RGB24 Format is

#define kCameraImageFormatRGB32 6

Whatever RGB32 Format is

#define kCameraImageFormatRGB4 2

Whatever RGB4 Format is

#define kCameraImageFormatRGB8 3

Whatever RGB8 Format is

#define kCameraImageFormatYCbCr kCameraImageFormatYCrCb

not used

#define kCameraImageFormatYCrCb 7

Whatever RGBYCrCb Format is

#define kCameraImageLittleEndian 0x8000

Whatever LittleEndian Format is

#define kCameraLibCreator 'HsCa'

Camera library creator ID

#define kCameraLibName "CameraLib"

Camera library database name

#define kCameraLibType sysFileTLibrary

Default library type

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:24 2006 for Palm API Guide


CarrierCustomLib.h File Reference

Detailed Description

This is the main header file for the Carrier Customization Library.

Version:
1.0
Date:
12/01/2002
This includes all the other required headers, so there is no need to include Traps, Errors, and Types if this is included.

Usage Model:

This library is automatically loaded at boot time by HsExtensions. Apps that call this library should only have to call SysLibFind. They should never have to load the library. LibOpen and LibClose should not be called either.

Include dependency graph for CarrierCustomLib.h:

Defines

  • #define ENCRYPTED_DATABASE true
  • #define CCUSTOM_LIB_TRAP(trapNum) SYS_TRAP(trapNum)

Functions

  • Err CCustomLibOpen (UInt16 refNum)
  • Err CCustomLibClose (UInt16 refNum)
  • Err CCustomLibSleep (UInt16 refNum)
  • Err CCustomLibWake (UInt16 refNum)
  • Err CCustomLibVersionGet (UInt16 refNum, UInt32 *majorVerP, UInt32 *minorVerP, UInt32 *bugFixVerP)
  • Err CCustomLibGetCarrierSetting (UInt16 refNum, CCSMSettingsType settingsType, void *dataP)
  • Err CCustomLibGetCarrierCode (UInt16 refNum, UInt8 *length, char **dataP)
  • Err CCustomLibGetCarrierCodeLength (UInt16 refNum, UInt8 *lengthP, char *carrierCodeP)

Define Documentation

#define ENCRYPTED_DATABASE true

internal

Function Documentation

Err CCustomLibClose ( UInt16 refNum )

Closes library and frees up allocated resources Close the library and decrements the reference count. This should never be called by an application.

Parameters:
refNum,: IN: CCustomLib reference number (from SysLibFind or SysLibLoad)
Return values:
Err Error Code.

Err CCustomLibGetCarrierCode | ( | UInt16 | refNum,
 |  | UInt8 * | length,
 |  | char ** | dataP
 | ) |

Returns the carrier ID from the SIM. Makes a copy of MMC/MNC code and returns it.

Parameters:
refNum,: IN: CCustomLib reference number (from SysLibFind or SysLibLoad)
length,: IN,OUT: length of buffer passed in, length of buffer used/needed (not including terminator)
dataP,: OUT: pointer to store the value
Return values:
Err Error code.

Err CCustomLibGetCarrierCodeLength | ( | UInt16 | refNum,
 |  | UInt8 * | lengthP,
 |  | char * | carrierCodeP
 | ) |

Returns the actual length of the carrier ID. If no carrier code is passed it, returns the length of the current carrier ID. This length is usually 6 for North American countries and 5 for others.

Parameters:
refNum,: IN: CCustomLib reference number (from SysLibFind or SysLibLoad)
lengthP,: IN,OUT: length of carrier code. Uses the current carrier if no carrier code is passed in
carrierCodeP,: IN: optional carrier code
Return values:
Err Error code.

Err CCustomLibGetCarrierSetting | ( | UInt16 | refNum,
 |  | CCSMSettingsType | settingsType,
 |  | void * | dataP
 | ) |

Returns the specified setting. Returns the carrier settings for the given field. Any memory allocation must be freed by the calling application. Currently, only string types are allocated.

Parameters:
refNum,: IN: CCustomLib reference number (from SysLibFind or SysLibLoad)
settingsType,: IN: object type specified by settingsTypeEnum
dataP,: IN,OUT: allocated object containing data, undefined on err
Return values:
Err Error code.

Err CCustomLibOpen ( UInt16 refNum )

Open the library, initialize library globals Initializes the library globals, based on the last known carrier. This should never be called by an application, as it is automatically loaded by the system and opened.

Parameters:
refNum,: IN: CCustomLib reference number (from SysLibFind or SysLibLoad)
Return values:
Err Error Code.

Err CCustomLibSleep ( UInt16 refNum )

Standard library sleep routine

Parameters:
refNum,: IN: CCustomLib reference number (from SysLibFind or SysLibLoad)
Return values:
Err Error code.

Err CCustomLibVersionGet | ( | UInt16 | refNum,
 |  | UInt32 * | majorVerP,
 |  | UInt32 * | minorVerP,
 |  | UInt32 * | bugFixVerP
 | ) |

Get Library API Version number.

Parameters:
refNum,: IN: Library reference number
majorVerP,: OUT: Major version number
minorVerP,: OUT: Minor version number
bugFixVerP,: OUT: Bug fix version number
Return values:
Err Customization Library error code

Err CCustomLibWake ( UInt16 refNum )

Standard library wake routine

Parameters:
refNum,: IN: CCustomLib reference number (from SysLibFind or SysLibLoad)
Return values:
Err Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:25 2006 for Palm API Guide


CarrierCustomLibErr.h File Reference

Detailed Description

This file contains the error codes for the Carrier Customization Library.

Version:
1.0
Date:
12/17/2002

Defines

  • #define ccsmErrClass 0x9000
  • #define ccsmErrUnknownCarrier ccsmErrClass + 0x01
  • #define ccsmErrMemory ccsmErrClass + 0x02
  • #define ccsmErrPhoneLibLoad ccsmErrClass + 0x03
  • #define ccsmErrPhoneNotPowered ccsmErrClass + 0x04
  • #define ccsmErrInvalidArg ccsmErrClass + 0x05
  • #define ccsmErrUnknownSetting ccsmErrClass + 0x06
  • #define ccsmErrBufferTooSmall ccsmErrClass + 0x07
  • #define ccsmErrNotRegistered ccsmErrClass + 0x08
  • #define ccsmErrUnknownField ccsmErrClass + 0x09
  • #define ccsmErrLibUninitialized ccsmErrClass + 0x0A
  • #define ccsmErrUndefinedField ccsmErrClass + 0x0B
  • #define ccsmErrProfileUnspecified ccsmErrClass + 0x50
  • #define ccsmErrUnspecified ccsmErrClass + 0x51
  • #define ccsmErrUnimplemented ccsmErrClass + 0xA5

Define Documentation

#define ccsmErrBufferTooSmall ccsmErrClass + 0x07

0x9007 need more space in buffer

#define ccsmErrClass 0x9000

0x9000 Carrier customization library error base number

#define ccsmErrInvalidArg ccsmErrClass + 0x05

0x9005 invalid arguement error

#define ccsmErrLibUninitialized ccsmErrClass + 0x0A

0x900A library was not initialized

#define ccsmErrMemory ccsmErrClass + 0x02

0x9002 memory error

#define ccsmErrNotRegistered ccsmErrClass + 0x08

0x9008 radio is not registered

#define ccsmErrPhoneLibLoad ccsmErrClass + 0x03

0x9003 phone library not loaded

#define ccsmErrPhoneNotPowered ccsmErrClass + 0x04

0x9004 phone is not powered

#define ccsmErrProfileUnspecified ccsmErrClass + 0x50

0x9050 requested profile is not specified

#define ccsmErrUndefinedField ccsmErrClass + 0x0B

0x900B the field did not have a value specified

#define ccsmErrUnimplemented ccsmErrClass + 0xA5

0x90F5 Unimplemented feature

#define ccsmErrUnknownCarrier ccsmErrClass + 0x01

0x9001 carrier code on SIM card not recognized

#define ccsmErrUnknownField ccsmErrClass + 0x09

0x9009 requested field not in database record

#define ccsmErrUnknownSetting ccsmErrClass + 0x06

0x9006 unknown setting requested error

#define ccsmErrUnspecified ccsmErrClass + 0x51

0x9051 settings is not specified for carrier

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:25 2006 for Palm API Guide


CarrierCustomLibTraps.h File Reference

Detailed Description

This file contains the trap for the Carrier Customization Library.

Version:
1.0
Date:
12/11/2002

Function Trap Numbers

Trap IDs for the Carrier Customization Library's public functions. The order of the traps must be the same as the routines are listed in NetPrefLibDispatchTable.c.
  • #define CCustomLibTrapVersionGet (sysLibTrapCustom + 0)
  • #define CCustomLibTrapGetCarrierSetting (sysLibTrapCustom + 1)
  • #define CCustomLibTrapGetProfileSetting (sysLibTrapCustom + 2)
  • #define CCustomLibTrapGetCarrierProfile (sysLibTrapCustom + 3)
  • #define CCustomLibTrapReleaseCarrierProfile (sysLibTrapCustom + 4)
  • #define CCustomLibTrapGetCarrierCode (sysLibTrapCustom + 5)
  • #define CCustomLibTrapGetCarrierCodeLength (sysLibTrapCustom + 6)
  • #define CCustomLibTrapRefresh (sysLibTrapCustom + 7)
  • #define CCustomLibTrapRetrieveNVSetting (sysLibTrapCustom + 8)
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:25 2006 for Palm API Guide


CarrierCustomLibTypes.h File Reference

Detailed Description

This file contains public data types exported by the Carrier Customization Library.

Version:
1.0
Date:
12/16/2002

API Version numbers

Current library API version number. Returned by NetPrefLibVersionGet()
  • #define CCSMVersionMajor 0
  • #define CCSMVersionMinor 6
  • #define CCSMVersionBugFix 0

Carrier codes

  • #define kSprintMCCMNC "310000"
  • #define kVerizonMCCMNC "310555"
  • #define kBellMobilityMCCMNC "310505"
  • #define kGenericMCCMNC "310999"

Defines

  • #define kCCLibType 'libr'
  • #define kCarrierCustomizationCLibName "CarrierCustomization.lib"
  • #define kCarrierListDBName "CarrierProfiles2"
  • #define kNetworkListDBName "NetworkProfiles2"

Typedefs

  • typedef void * CCSMCarrierHandle
  • typedef UInt16 CCSMSettingsType
  • typedef UInt32 CCSMSystemFlagsType
  • typedef UInt32 CCSMPhoneFlagsType
  • typedef UInt32 CCSMRadioBandType
  • typedef UInt32 CCSMMessagingFlagsType
  • typedef UInt32 CCSMBrowserFlagsType

Enumerations

  • enum {
    kCCSMSettingsSystemReserved,
    kCCSMSettingsShowNetworkSelect,
    kCCSMSettingsIndicateRoaming,
    kCCSMSettingsEditableMSISDN,
    kCCSMSettingsShowEmergencyMode,
    kCCSMSettingsCarrierMSISDN,
    kCCSMSettingsRadioBand,
    kCCSMSettingsVoiceMailNumber,
    kCCSMSettingsPOP3Server,
    kCCSMSettingsSMTPServer,
    kCCSMSettingsSMSCNumber,
    kCCSMSettingsSMSEmailGateway,
    kCCSMSettingsMMSURL,
    kCCSMSettingsMMSWAPGateway,
    kCCSMSettingsMMSPort,
    kCCSMSettingsMMSMaxMsgSize,
    kCCSMSettingsPrimaryProxyServer,
    kCCSMSettingsPrimaryProxyPort,
    kCCSMSettingsPrimarySecureProxyServer,
    kCCSMSettingsPrimarySecureProxyPort,
    kCCSMSettingsSecondaryProxyServer,
    kCCSMSettingsSecondaryProxyPort,
    kCCSMSettingsSecondarySecureProxyServer,
    kCCSMSettingsSecondarySecureProxyPort,
    kCCMSSettingsPrimaryTrustedDomain,
    kCCMSSettingsSecondaryTrustedDomain,
    kCCMSSettingsUAProfilingURL,
    kCCSMSettingsHTTPHeaders,
    kCCSMSettingsNAIHeaderFormat,
    kCCSMSettingsMSISDNHeaderFormat,
    kCCSMSettingsEncryptMSISDN,
    kCCSMSettingsHomepageURL,
    kCCSMSettingsGPRSAutoAttach,
    kCCSMSettingsNAI,
    kCCSMSettingsBrowserFlags,
    kCCSMSettingsBrowserProxyFlags,
    kCCSMSettingsProxyUsername,
    kCCSMSettingsProxyPassword,
    kCCSMSettingsMessagingFlags,
    kCCSMSettingsSMSMaxMsgSize,
    kCCSMSettingsSMSValidityPeriod,
    kCCSMSettingsE911Timeout,
    kCCSMSettingsMMSUAProf,
    kCCSMSettingsMMSUAString,
    kCCSMSettingsMMSMaxVideoSize,
    kCCSMSettingsMMSVersionNumber,
    kCCSMSettingsEmailSMTPServer,
    kCCSMSettingsSPNSupported,
    kCCSMSettingsReserved = 0x8000
    }
  • enum CCSMSystemFlagsEnum { kCCSMSystemSettingReserved = 0x00000000 }
  • enum CCSMPhoneFlagsEnum {
    kCCSMPhoneSettingsReserved = 0x00000000,
    kCCSMPhoneSettingsNetworkSelect = 0x00000001,
    kCCSMPhoneSettingsRoamingIndicator = 0x00000002,
    kCCSMPhoneSettingsEditMSISDN = 0x00000004,
    kCCSMPhoneSettingsShowEmergencyMode = 0x00000008,
    kCCSMPhoneSettingsEnableTTY = 0x00000010,
    kCCSMPhoneSettingsUseEFSPN = 0x00000020
    }
  • enum CCSMRadioBandEnum {
    kCCSMRadioBandUnknown,
    kCCSMRadioBandEurope,
    kCCSMRadioBandNorthAmerica
    }
  • enum CCSMMessagingSettingsEnum {
    kCCSMMessagingSettingsReserved = 0x00000000,
    kCCSMMessagingSettingsStripPhonePlus = 0x00000001,
    kCCSMMessagingSettings11DigitRecipient = 0x00000002,
    kCCSMMessagingSettingsNormaliseMMSAddress = 0x00000004,
    kCCSMMessagingSettingsWAPProtocol20 = 0x00000008,
    kCCSMMessagingSettingsDisableMMSFallback = 0x00000010
    }
  • enum CCSMBrowserSettingsEnum {
    kCCSMBrowserSettingsReserved = 0x00000000,
    kCCSMBrowserSettingsEncryptMSISDN = 0x00000001,
    kCCSMBrowserSettingsCSDDisconnectOnExit = 0x00000002,
    kCCSMBrowserSettingsPDataDisconnectOnExit = 0x00000004,
    kCCSMBrowserSettingsDormantOnExit = 0x00000008,
    kCCSMBrowserSettingsHideDisconnect = 0x00000010,
    kCCSMBrowserSettingsVersionInWAPProfile = 0x00000020,
    kCCSMPrimaryProxyAuthenticate = 0x00000001,
    kCCSMPrimaryProxyLocked = 0x00000002,
    kCCSMPrimaryProxyHide = 0x00000004,
    kCCSMSecondaryProxyAuthenticate = 0x00010000,
    kCCSMSecondaryProxyLocked = 0x00020000,
    kCCSMSecondaryProxyHide = 0x00040000
    }

Define Documentation

#define kCarrierCustomizationCLibName "CarrierCustomization.lib"

Carrier Customization Library name

#define kCarrierListDBName "CarrierProfiles2"

Name of carrier list database

#define kCCLibType 'libr'

Standard library type

#define kNetworkListDBName "NetworkProfiles2"

Name of network list database

Typedef Documentation

typedef UInt32 CCSMBrowserFlagsType

Used with CCSMBrowserSettingsEnum

typedef void* CCSMCarrierHandle

pointer type to hold the carrier object

typedef UInt32 CCSMMessagingFlagsType

Used with CCSMMessagingSettingsEnum

typedef UInt32 CCSMPhoneFlagsType

used with CCSMPhoneFlagsEnum

typedef UInt32 CCSMRadioBandType

used with CCSMRadioBandEnum

typedef UInt16 CCSMSettingsType

used with the settingsTypeEnum

typedef UInt32 CCSMSystemFlagsType

Used with CCSMSystemFlagsEnum

Enumeration Type Documentation

anonymous enum

Enumeration for the type of carrier settings. The following are applicable to CDMA as well.

We want to keep the groups together. This helps keep track of which structure the setting resides in.

Enumerator:
kCCSMSettingsSystemReserved | system settings place holder
kCCSMSettingsShowNetworkSelect | <Boolean> enable/disable network select
kCCSMSettingsIndicateRoaming | <Boolean> enable/disable roaming indicator
kCCSMSettingsEditableMSISDN | <Boolean> User editable MSISDN
kCCSMSettingsShowEmergencyMode | <Boolean> enable/disable emergency mode indicator
kCCSMSettingsCarrierMSISDN | <char *> carrier MSISDN
kCCSMSettingsRadioBand | <UInt32> radio band to start search with
kCCSMSettingsVoiceMailNumber | <char *> carriers voice mail number
kCCSMSettingsPOP3Server | <char *> pop3 server -- will be deprecated
kCCSMSettingsSMTPServer | <char *> smtp server -- will be deprecated
kCCSMSettingsSMSCNumber | <char *> smsc number
kCCSMSettingsSMSEmailGateway | <char *> sms email gateway
kCCSMSettingsMMSURL | <char *> MMS URL
kCCSMSettingsMMSWAPGateway | <char *> MMS WAP gateway
kCCSMSettingsMMSPort | <UInt32> MMS port number
kCCSMSettingsMMSMaxMsgSize | <UInt32> max MMS message size (kbytes)
kCCSMSettingsPrimaryProxyServer | <char *> Proxy server
kCCSMSettingsPrimaryProxyPort | <UInt32> Proxy port
kCCSMSettingsPrimarySecureProxyServer | <char *> Secure proxy server
kCCSMSettingsPrimarySecureProxyPort | <UInt32> Secure proxy port
kCCSMSettingsSecondaryProxyServer | <char *> Proxy server
kCCSMSettingsSecondaryProxyPort | <UInt32> Proxy port
kCCSMSettingsSecondarySecureProxyServer | <char *> Secure proxy server
kCCSMSettingsSecondarySecureProxyPort | <UInt32> Secure proxy port
kCCMSSettingsPrimaryTrustedDomain | <char *> GSM: Primary trusted domain <char *> CDMA: phone:downloadserver.url
kCCMSSettingsSecondaryTrustedDomain | <char *> GSM Only: Secondary trusted domain
kCCMSSettingsUAProfilingURL | <char *> UA Profiling URL
kCCSMSettingsHTTPHeaders | <char *> carrier specific HTTP headers to send
kCCSMSettingsNAIHeaderFormat | <char *> header format to send NAI (see sprintf format)
kCCSMSettingsMSISDNHeaderFormat | <char *> header format to send MSISDN (see sprintf format)
kCCSMSettingsEncryptMSISDN | <Boolean> encrypt MSISDN header
kCCSMSettingsHomepageURL | <char *> home page string
kCCSMSettingsGPRSAutoAttach | <Boolean> flag whether or not to display the GPRS attached icon
kCCSMSettingsNAI | <char *> Slot 1 username. CDMA only
kCCSMSettingsBrowserFlags | <UInt32> flags that controls browser behaviour
kCCSMSettingsBrowserProxyFlags | <UInt32> flags that controls browser behaviour
kCCSMSettingsProxyUsername | <char *> proxy username
kCCSMSettingsProxyPassword | <char *> password for the proxy
kCCSMSettingsMessagingFlags | <UInt32> messaging flags
kCCSMSettingsSMSMaxMsgSize | <UInt32> max SMS message size (bytes)
kCCSMSettingsSMSValidityPeriod | <UInt32> SMS validity period network specific value
kCCSMSettingsE911Timeout | <UInt32> E911 timeout value (seconds)
kCCSMSettingsMMSUAProf | <char *> UA Prof
kCCSMSettingsMMSUAString | <char *> UA Prof string
kCCSMSettingsMMSMaxVideoSize | <Int32> MMS maximum video size
kCCSMSettingsMMSVersionNumber | <Int32> MMS version (11 = 1.1)
kCCSMSettingsEmailSMTPServer | <char *> SMTP Server
kCCSMSettingsSPNSupported | <Boolean> flag if SPN is supported
kCCSMSettingsReserved | reserved

enum CCSMBrowserSettingsEnum

enumeration for the browser settings flags

Enumerator:
kCCSMBrowserSettingsReserved | reserved setting
kCCSMBrowserSettingsEncryptMSISDN | send encrypted MSISDN
kCCSMBrowserSettingsCSDDisconnectOnExit | disconnect on exit for CSD connections
kCCSMBrowserSettingsPDataDisconnectOnExit | disconnect on exit for packet data connections
kCCSMBrowserSettingsDormantOnExit | force dormancy on exit
kCCSMBrowserSettingsHideDisconnect | hide disconnect button
kCCSMBrowserSettingsVersionInWAPProfile | Add version in WAP profile header
kCCSMPrimaryProxyAuthenticate | proxy properties
kCCSMPrimaryProxyLocked | proxy properties
kCCSMPrimaryProxyHide | proxy properties
kCCSMSecondaryProxyAuthenticate | proxy properties
kCCSMSecondaryProxyLocked | proxy properties
kCCSMSecondaryProxyHide | proxy properties

enum CCSMMessagingSettingsEnum

enumeration for the messaging settings flags

Enumerator:
kCCSMMessagingSettingsReserved | reserved setting
kCCSMMessagingSettingsStripPhonePlus | does the network require the phone number to be stripped
kCCSMMessagingSettings11DigitRecipient | flag if a number requires 10 or 11 digits (I assume US only)
kCCSMMessagingSettingsNormaliseMMSAddress | Flag if MMS address should be normalised or not
kCCSMMessagingSettingsWAPProtocol20 | *internal* Use WAP 2.0 for MMS?
kCCSMMessagingSettingsDisableMMSFallback | Flag to disable the fallback account when connecting

enum CCSMPhoneFlagsEnum

enumeration for the phone settings flags

Enumerator:
kCCSMPhoneSettingsReserved | reserved setting
kCCSMPhoneSettingsNetworkSelect | Network Select disable/enable
kCCSMPhoneSettingsRoamingIndicator | Roaming indicator yes/no
kCCSMPhoneSettingsEditMSISDN | Editable MSISDN
kCCSMPhoneSettingsShowEmergencyMode | use Emergency mode
kCCSMPhoneSettingsEnableTTY | enable TTY
kCCSMPhoneSettingsUseEFSPN | Use EF SPN if any

enum CCSMRadioBandEnum

enumeration for the radio band Used to optimize which band the radio starts scanning on.

Enumerator:
kCCSMRadioBandUnknown | unknown radio band
kCCSMRadioBandEurope | european radio
kCCSMRadioBandNorthAmerica | north american radio

enum CCSMSystemFlagsEnum

system settings

Enumerator:
kCCSMSystemSettingReserved reserved setting

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:25 2006 for Palm API Guide


DefaultHelperLib.h File Reference

Detailed Description

Default Helper library owns control over the Default Helpers database.

Defines

  • #define DEFAULTHELPERLIB_TRAP(x) SYS_TRAP( x )

Functions

  • Err DefaultHelperLibOpen (UInt16 refNum) DEFAULTHELPERLIB_TRAP(sysLibTrapOpen)
  • Err DefaultHelperLibClose (UInt16 refNum) DEFAULTHELPERLIB_TRAP(sysLibTrapClose)
  • Err DefaultHelperLibWake (UInt16 refNum) DEFAULTHELPERLIB_TRAP(sysLibTrapWake)
  • Err DefaultHelperLibSleep (UInt16 refNum) DEFAULTHELPERLIB_TRAP(sysLibTrapSleep)
  • Err DefaultHelperLibGetDefaultHelper (UInt16 refNum, UInt32 serviceID, UInt32 *defaultAppCreatorP) DEFAULTHELPERLIB_TRAP(defaultHelperLibTrapGetDefaultHelper)
  • Err DefaultHelperLibSetDefaultHelper (UInt16 refNum, UInt32 serviceID, UInt32 defaultAppCreator) DEFAULTHELPERLIB_TRAP(defaultHelperLibTrapSetDefaultHelper)

Define Documentation

#define DEFAULTHELPERLIB_TRAP ( x ) SYS_TRAP( x )

Helper macro.

Function Documentation

Err DefaultHelperLibClose ( UInt16 refNum )

Standard library close function

Parameters:
refNum,: IN: Default helper library reference number (from SysLibFind()/SysLibLoad())
Return values:
Err Error code.

Err DefaultHelperLibGetDefaultHelper | ( | UInt16 | refNum,
 |  | UInt32 | serviceID,
 |  | UInt32 * | defaultAppCreatorP
 | ) |

Given a specified serviceID, return the creator type of the default helper application.

Parameters:
refNum,: IN: Default helper library reference number (from SysLibFind()/SysLibLoad())
serviceID,: IN: Type of service to get info from.
defaultAppCreatorP OUT: Upon return of the function, a pointer to the creator type of the default application for the specified serviceID.
Return values:
Err Error code.

Err DefaultHelperLibOpen ( UInt16 refNum )

Standard library open function

Parameters:
refNum,: IN: Default helper library reference number (from SysLibFind()/SysLibLoad())
Return values:
Err Error code.

Err DefaultHelperLibSetDefaultHelper | ( | UInt16 | refNum,
 |  | UInt32 | serviceID,
 |  | UInt32 | defaultAppCreator
 | ) |

Given a specified serviceID, set the creator type of the default helper application.

Parameters:
refNum,: IN: Default helper library reference number (from SysLibFind()/SysLibLoad())
serviceID,: IN: Type of service to get info from.
defaultAppCreator,: IN: Creator type of the application to be set as the default application for the specified serviceID. If 0, then remove the helper service from the Default Apps database.
Return values:
Err Error code.

Err DefaultHelperLibSleep ( UInt16 refNum )

Standard library sleep function

Parameters:
refNum,: IN: Default helper library reference number (from SysLibFind()/SysLibLoad())
Return values:
Err Error code.

Err DefaultHelperLibWake ( UInt16 refNum )

Standard library wake function

Parameters:
refNum,: IN: Default helper library reference number (from SysLibFind()/SysLibLoad())
Return values:
Err Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:25 2006 for Palm API Guide


DefaultHelperLibTypes.h File Reference

Detailed Description

Public 68K common header file for Default Helper Library API.

Version:
1.0
This file contains the type information and constants for Default Helper Library.

Error Codes

  • #define defaultHelperLibErrClass 0x9000
  • #define defaultHelperLibErrCreateDBFailed (defaultHelperLibErrClass | 1)
  • #define defaultHelperLibErrNoMemory (defaultHelperLibErrClass | 2)
  • #define defaultHelperLibErrNoHelperApp (defaultHelperLibErrClass | 3)
  • #define defaultHelperLibErrDBNotFound (defaultHelperLibErrClass | 4)
  • #define defaultHelperLibErrDBWriteFailed (defaultHelperLibErrClass | 5)
  • #define defaultHelperLibErrUserCancel (defaultHelperLibErrClass | 6)
  • #define defaultHelperLibErrBadParams (defaultHelperLibErrClass | 7)

Function Traps

  • #define defaultHelperLibTrapGetDefaultHelper sysLibTrapCustom
  • #define defaultHelperLibTrapSetDefaultHelper sysLibTrapCustom+1

Defines

  • #define defaultHelperLibName "DefaultHelper-HsDh"
  • #define defaultHelperLibCreator 'HsDh'
  • #define defaultHelperLibType sysFileTLibrary

Define Documentation

#define defaultHelperLibCreator 'HsDh'

Default Helper Library creator ID

#define defaultHelperLibName "DefaultHelper-HsDh"

Default Helper Library name

#define defaultHelperLibType sysFileTLibrary

Standard library type

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:25 2006 for Palm API Guide


FavoritesDBLib.h File Reference

Detailed Description

Contains the API to control the Favorites DB.

Enumerations

  • enum FavDBLibPhoneViewEnum {
    favDBLibPhoneViewCallLog = 0,
    favDBLibPhoneViewDialPad,
    favDBLibPhoneViewContacts
    }

Functions

  • Err FavDBLibOpen (UInt16 refNum)
  • Err FavDBLibClose (UInt16 refNum)
  • Err FavDBLibWake (UInt16 refNum)
  • Err FavDBLibSleep (UInt16 refNum)
  • Err FavDBLibNewAppFavorite (UInt16 refNum, Word position, CharPtr labelP, WChar quickKey, Word flags, UInt32 appCreator, WordPtr indexP)
  • Err FavDBLibNewPhoneFavorite (UInt16 refNum, Word position, CharPtr labelP, WChar quickKey, Word flags, CharPtr numberP, CharPtr extraDigitsP, Boolean autoDialExtraDigits, UInt32 ringID, UInt16 ringToneType, WordPtr indexP)
  • Err FavDBLibNewMsgFavorite (UInt16 refNum, Word position, CharPtr labelP, WChar quickKey, Word flags, CharPtr contactIdP, WordPtr indexP)
  • Err FavDBLibNewWebFavorite (UInt16 refNum, Word position, CharPtr labelP, WChar quickKey, Word flags, CharPtr urlP, WordPtr indexP)
  • Err FavDBLibNewEmailFavorite (UInt16 refNum, Word position, CharPtr labelP, WChar quickKey, Word flags, CharPtr contactIdP, WordPtr indexP)
  • Err FavDBLibNewPhoneViewFavorite (UInt16 refNum, Word position, CharPtr labelP, WChar quickKey, Word flags, UInt16 phoneView, WordPtr indexP)
  • CharPtr FavDBLibResolveAddress (UInt16 refNum, CharPtr addressP, Word kind)
  • Boolean FavDBLibSeekSpeedDialRecord (UInt16 refNum, UInt16 *indexP, Int16 offset, Int16 direction)
  • Boolean FavDBLibGetRecordLabel (UInt16 refNum, UInt16 index, CharPtr *labelPP)
  • Err FavDBLibGetRecordId (UInt16 refNum, UInt16 index, UInt32 *uniqueIdP)
  • Err FavDBLibIsFavoriteWithId (UInt16 refNum, UInt32 keyId, BooleanPtr existsP)
  • Boolean FavDBLibGetSpeedDialInfo (UInt16 refNum, UInt16 index, CharPtr *numberPP, CharPtr *extraDigitsPP, BooleanPtr autoExtraDigitsP, BooleanPtr isVoicemailP)
  • Boolean FavDBLibLookupInSpeedDialDB (UInt16 refNum, CharPtr keyP, CharPtr *nameP)

Enumeration Type Documentation

enum FavDBLibPhoneViewEnum

List of different views in the phone applications.

Enumerator:
favDBLibPhoneViewCallLog | call log view
favDBLibPhoneViewDialPad | dial pad view
favDBLibPhoneViewContacts | contacts view

Function Documentation

Err FavDBLibClose ( UInt16 refNum )

Standard library close function

Parameters:
refNum,: IN: Favorites DB library reference number (from SysLibFind()/SysLibLoad())
Return values:
Err Error code.

Err FavDBLibGetRecordId | ( | UInt16 | refNum,
 |  | UInt16 | index,
 |  | UInt32 * | uniqueIdP
 | ) |

Get the unique ID of an entry given the record index in the Favorites DB.

Parameters:
refNum,: IN: library reference number.
index,: IN: index of the record to get unique id from.
uniqueIdP,: OUT: unique ID of the record.
Return values:
Err Error code.

Boolean FavDBLibGetRecordLabel | ( | UInt16 | refNum,
 |  | UInt16 | index,
 |  | CharPtr * | labelPP
 | ) |

Get the label from the favorite item given the record index.

Parameters:
refNum,: IN: library reference number.
index,: IN: index of the record to get label from.
labelPP,: OUT: pointer to the label string.
Return values:
Boolean True if found. Otherwise, false.

Boolean FavDBLibGetSpeedDialInfo | ( | UInt16 | refNum,
 |  | UInt16 | index,
 |  | CharPtr * | numberPP,
 |  | CharPtr * | extraDigitsPP,
 |  | BooleanPtr | autoExtraDigitsP,
 |  | BooleanPtr | isVoicemailP
 | ) |

Get full info about the favorite phone number given the record index.

Parameters:
refNum,: IN: library reference number.
index,: IN: index of the item in the DB.
numberPP,: OUT: pointer to the speed dial phone number.
extraDigitsPP,: OUT: pointer to the extra digits in the phone number.
autoExtraDigitsP,: OUT: if true, extra digits are auto-dialed.
isVoicemailP,: OUT: if true, phone number is a voicemail number.
Return values:
Boolean True if found.

Err FavDBLibIsFavoriteWithId | ( | UInt16 | refNum,
 |  | UInt32 | keyId,
 |  | BooleanPtr | existsP
 | ) |

Determine whether item with keyId is in the favorites DB.

Parameters:
refNum,: IN: library reference number.
keyId,: IN: unique id of the item whose info is to be obtained.
existsP,: OUT: true if item is found among favorites.
Return values:
Err Error code.

Boolean FavDBLibLookupInSpeedDialDB | ( | UInt16 | refNum,
 |  | CharPtr | keyP,
 |  | CharPtr * | nameP
 | ) |

no definition.

Parameters:
refNum,: IN: library reference number.
keyP,: IN: no definition.
nameP,: OUT: no definition.
Return values:
Boolean True if found.

Err FavDBLibNewAppFavorite | ( | UInt16 | refNum,
 |  | Word | position,
 |  | CharPtr | labelP,
 |  | WChar | quickKey,
 |  | Word | flags,
 |  | UInt32 | appCreator,
 |  | WordPtr | indexP
 | ) |

Create a new favorite application entry.

Parameters:
refNum,: IN: library reference number.
position,: IN: position of the new favorite app in the entries.
labelP,: IN: pointer to the label of the newly created entry.
quickKey,: IN: shortcut used to start favorite app.
flags | IN: no definition.
appCreator | IN: Creator ID of the new favorite app.
indexP | OUT: index of the new entry in the DB.
Return values:
Err Error code.

Err FavDBLibNewEmailFavorite | ( | UInt16 | refNum,
 |  | Word | position,
 |  | CharPtr | labelP,
 |  | WChar | quickKey,
 |  | Word | flags,
 |  | CharPtr | contactIdP,
 |  | WordPtr | indexP
 | ) |

Create a new favorite email entry.

Parameters:
refNum,: IN: library reference number.
position,: IN: position of the new favorite email in the entries.
labelP,: IN: pointer to the label of the newly created entry.
quickKey,: IN: shortcut used to start sending email to the new favorite .
flags,: IN: no definition.
contactIdP,: IN: Email address in string.
indexP,: OUT: index of the new entry in the DB.
Return values:
Err Error code.

Err FavDBLibNewMsgFavorite | ( | UInt16 | refNum,
 |  | Word | position,
 |  | CharPtr | labelP,
 |  | WChar | quickKey,
 |  | Word | flags,
 |  | CharPtr | contactIdP,
 |  | WordPtr | indexP
 | ) |

Create a new favorite messaging destination.

Parameters:
refNum,: IN: library reference number.
position,: IN: position of the new favorite contact in the entries.
labelP,: IN: pointer to the label of the newly created entry.
quickKey,: IN: shortcut used to start composing message to the contact.
flags,: IN: No definition.
contactIdP | IN: Mobile number/ Email address of the new favorites messaging contact.
indexP | OUT: index of the new entry in the DB.
Return values:
Err Error code.

Err FavDBLibNewPhoneFavorite | ( | UInt16 | refNum,
 |  | Word | position,
 |  | CharPtr | labelP,
 |  | WChar | quickKey,
 |  | Word | flags,
 |  | CharPtr | numberP,
 |  | CharPtr | extraDigitsP,
 |  | Boolean | autoDialExtraDigits,
 |  | UInt32 | ringID,
 |  | UInt16 | ringToneType,
 |  | WordPtr | indexP
 | ) |

Create a new favorite phone number.

Parameters:
refNum,: IN: library reference number.
position,: IN: position of the new favorite phone number in the entries.
labelP,: IN: pointer to the label of the newly created entry.
quickKey,: IN: shortcut used to call the number.
flags,: IN: no definition.
numberP,: IN: New favorite phone number in string.
extraDigitsP,: IN: Extra digits.
autoDialExtraDigits,: IN: Always include extra digit when dialing if true.
ringID,: IN: Ring tone ID for this number.
ringToneType,: IN: Ring tone type for this number.
indexP,: OUT: index of the new entry in the DB.
Return values:
Err Error code.

Err FavDBLibNewPhoneViewFavorite | ( | UInt16 | refNum,
 |  | Word | position,
 |  | CharPtr | labelP,
 |  | WChar | quickKey,
 |  | Word | flags,
 |  | UInt16 | phoneView,
 |  | WordPtr | indexP
 | ) |

Create a new favorite phone app view.

Parameters:
refNum,: IN: library reference number.
position,: IN: position of the new favorite in the entries.
labelP,: IN: pointer to the label of the newly created entry.
quickKey,: IN: shortcut used to launch phone app in the favorite view.
flags,: IN: no definition.
phoneView,: IN: See FavDBLibPhoneViewEnum for values.
indexP,: OUT: index of the new entry in the DB.
Return values:
Err Error code.

Err FavDBLibNewWebFavorite | ( | UInt16 | refNum,
 |  | Word | position,
 |  | CharPtr | labelP,
 |  | WChar | quickKey,
 |  | Word | flags,
 |  | CharPtr | urlP,
 |  | WordPtr | indexP
 | ) |

Create a new favorite URL.

Parameters:
refNum,: IN: library reference number.
position,: IN: position of the new favorite URL.
labelP,: IN: pointer to the label of the newly created entry.
quickKey,: IN: shortcut used to launch the URL.
flags,: IN: no definition.
urlP,: IN: the URL in string.
indexP,: OUT: index of the new entry in the DB.
Return values:
Err Error code.

Err FavDBLibOpen ( UInt16 refNum )

Standard library open function

Parameters:
refNum,: IN: Favorites DB library reference number (from SysLibFind()/SysLibLoad())
Return values:
Err Error code.

CharPtr FavDBLibResolveAddress | ( | UInt16 | refNum,
 |  | CharPtr | addressP,
 |  | Word | kind
 | ) |

No definition.

Parameters:
refNum,: IN: library reference number.
addressP,: IN: pointer to the address string to be resolved.
kind,: IN: no definition.
Return values:
CharPtr no definition.

Boolean FavDBLibSeekSpeedDialRecord | ( | UInt16 | refNum,
 |  | UInt16 * | indexP,
 |  | Int16 | offset,
 |  | Int16 | direction
 | ) |

No definition.

Parameters:
refNum,: IN: library reference number.
indexP,: IN,OUT: no definition.
offset,: IN: offset in the DB record indeces to start search from.
direction,: IN: Forward/backward search from offset.
Return values:
Boolean True if found. Otherwise, false.

Err FavDBLibSleep ( UInt16 refNum )

Standard library sleep function

Parameters:
refNum,: IN: Favorites DB library reference number (from SysLibFind()/SysLibLoad())
Return values:
Err Error code.

Err FavDBLibWake ( UInt16 refNum )

Standard library wake function

Parameters:
refNum,: IN: Favorites DB library reference number (from SysLibFind()/SysLibLoad())
Return values:
Err Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:25 2006 for Palm API Guide


FavoritesDBLibTypes.h File Reference

Detailed Description

Public 68K common header file for FavoritesDB library API.

This file contains the FavoritesDB library constants and error codes.

Error Codes

  • #define favoritesDBLibErrClass 0x9000
  • #define favoritesDBLibErrCreateDBFailed (favoritesDBLibErrClass | 1)
  • #define favoritesDBLibErrNoMemory (favoritesDBLibErrClass | 2)
  • #define favoritesDBLibErrDBNotFound (favoritesDBLibErrClass | 4)
  • #define favoritesDBLibErrDBWriteFailed (favoritesDBLibErrClass | 5)
  • #define favoritesDBLibErrUserCancel (favoritesDBLibErrClass | 6)
  • #define favoritesDBLibErrBadParams (favoritesDBLibErrClass | 7)

Function Traps

  • #define favoritesDBLibTrapNewAppFavorite sysLibTrapCustom
  • #define favoritesDBLibTrapNewPhoneFavorite sysLibTrapCustom+1
  • #define favoritesDBLibTrapNewMsgFavorite sysLibTrapCustom+2
  • #define favoritesDBLibTrapNewWebFavorite sysLibTrapCustom+3
  • #define favoritesDBLibTrapNewEmailFavorite sysLibTrapCustom+4
  • #define favoritesDBLibTrapNewPhoneViewFavorite sysLibTrapCustom+5
  • #define favoritesDBLibTrapResolveAddress sysLibTrapCustom+6
  • #define favoritesDBLibTrapSeekSpeedDialRecord sysLibTrapCustom+7
  • #define favoritesDBLibTrapGetRecordLabel sysLibTrapCustom+8
  • #define favoritesDBLibTrapGetRecordId sysLibTrapCustom+9
  • #define favoritesDBLibIsFavoriteWithId sysLibTrapCustom+10
  • #define favoritesDBLibTrapGetSpeedDialInfo sysLibTrapCustom+11
  • #define favoritesDBLibTrapLookupInSpeedDialDB sysLibTrapCustom+12

Defines

  • #define favoritesDBLibName "FavoritesDBLibrary"
  • #define favoritesDBLibCreator 'HsFD'
  • #define favoritesDBLibType sysFileTLibrary

Define Documentation

#define favoritesDBLibCreator 'HsFD'

Favorites DB library creator ID

#define favoritesDBLibName "FavoritesDBLibrary"

Favorites DB library name

#define favoritesDBLibType sysFileTLibrary

Standard library type

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:25 2006 for Palm API Guide


FileBrowserLib68K.h File Reference

Detailed Description

This file contains the FileBrowser Library APIs.

Version:
1.0

Defines

  • #define FILE_BROWSER_LIB_TRAP(trapNum) SYS_TRAP(trapNum)

Functions

  • Err FileBrowserLibOpen (UInt16 refNum) FILE_BROWSER_LIB_TRAP(sysLibTrapOpen)
  • Err FileBrowserLibClose (UInt16 refNum) FILE_BROWSER_LIB_TRAP(sysLibTrapClose)
  • Err FileBrowserLibSleep (UInt16 refNum) FILE_BROWSER_LIB_TRAP(sysLibTrapSleep)
  • Err FileBrowserLibWake (UInt16 refNum) FILE_BROWSER_LIB_TRAP(sysLibTrapWake)
  • Boolean FileBrowserLibHandleEvent (UInt16 refNum, EventType *eventP) FILE_BROWSER_LIB_TRAP(exgLibTrapHandleEvent)
  • Err FileBrowserLibConnect (UInt16 refNum, ExgSocketType *socketP) FILE_BROWSER_LIB_TRAP(exgLibTrapConnect)
  • Err FileBrowserLibAccept (UInt16 refNum, ExgSocketType *socketP) FILE_BROWSER_LIB_TRAP(exgLibTrapAccept)
  • Err FileBrowserLibDisconnect (UInt16 refNum, ExgSocketType *socketP, Err err) FILE_BROWSER_LIB_TRAP(exgLibTrapDisconnect)
  • Err FileBrowserLibPut (UInt16 refNum, ExgSocketType *socketP) FILE_BROWSER_LIB_TRAP(exgLibTrapPut)
  • Err FileBrowserLibGet (UInt16 refNum, ExgSocketType *socketP) FILE_BROWSER_LIB_TRAP(exgLibTrapGet)
  • UInt32 FileBrowserLibSend (UInt16 refNum, ExgSocketType *socketP, const void *bufP, UInt32 bufLen, Err *errP) FILE_BROWSER_LIB_TRAP(exgLibTrapSend)
  • UInt32 FileBrowserLibReceive (UInt16 refNum, ExgSocketType *socketP, void *bufP, UInt32 bufSize, Err *errP) FILE_BROWSER_LIB_TRAP(exgLibTrapReceive)
  • Err FileBrowserLibControl (UInt16 refNum, UInt16 op, void *valueP, UInt16 *valueLenP) FILE_BROWSER_LIB_TRAP(exgLibTrapControl)
  • Err FileBrowserLibRequest (UInt16 refNum, ExgSocketType *socketP) FILE_BROWSER_LIB_TRAP(exgLibTrapRequest)
  • Boolean FileBrowserLibShowOpenDialog (UInt16 refNum, UInt16 *volRefNumP, Char *path, UInt16 numExtensions, const Char **extensions, const Char *fileType, const Char *title, UInt32 flags) FILE_BROWSER_LIB_TRAP(kFileBrowserLibTrapShowOpenDialog)
  • Boolean FileBrowserLibShowSaveAsDialog (UInt16 refNum, UInt16 *volRefNumP, Char *path, UInt16 numExtensions, const Char **extensions, const Char *defaultExtension, const Char *fileType, const Char *title, UInt32 flags) FILE_BROWSER_LIB_TRAP(kFileBrowserLibTrapShowSaveAsDialog)
  • Err FileBrowserLibParseFileURL (UInt16 refNum, const Char *urlP, UInt16 *volRefNumP, Char **filePathP) FILE_BROWSER_LIB_TRAP(kFileBrowserLibTrapParseFileURL)
  • Boolean FileBrowserLibShowMultiselectDialog (UInt16 refNum, UInt16 *volRefNumP, Char *path, UInt16 *numFilesP, UInt16 maxFiles, Char **filenames, UInt16 numExtensions, const Char **extensions, const Char *fileType, const Char *title, UInt32 flags) FILE_BROWSER_LIB_TRAP(kFileBrowserLibTrapShowMultiselectDialog)

Function Documentation

Err FileBrowserLibAccept | ( | UInt16 | refNum,
 |  | ExgSocketType * | socketP
 | ) |

Entry point to accept an incoming connection

Parameters:
refNum,: IN: library reference number
socketP,: IN: the exchange socket
Return values:
Err Error code.

Err FileBrowserLibClose ( UInt16 refNum )

Standard File Browser library close function

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code

Err FileBrowserLibConnect | ( | UInt16 | refNum,
 |  | ExgSocketType * | socketP
 | ) |

Entry point to establish an exchange connection

Parameters:
refNum,: IN: library reference number
socketP,: IN: the exchange socket
Return values:
Err Error code.

Err FileBrowserLibControl | ( | UInt16 | refNum,
 |  | UInt16 | op,
 |  | void * | valueP,
 |  | UInt16 * | valueLenP
 | ) |

Entry point to execute various commands.

Parameters:
refNum,: IN: the library reference number
op,: IN: command to execute
valueP,: IN,OUT: buffer with incoming or outgoing data
valueLenP,: IN,OUT: size of buffer and size of result (not used for some operations)
Return values:
Err Error code.

Err FileBrowserLibDisconnect | ( | UInt16 | refNum,
 |  | ExgSocketType * | socketP,
 |  | Err | err
 | ) |

Entry point to disconnect an outgoing or incoming connection and clean up afterwards.

Parameters:
refNum,: IN: library reference number
socketP,: IN: the exchange socket
err,: IN: OS error code to report to user
Return values:
Err Error code.

Err FileBrowserLibGet | ( | UInt16 | refNum,
 |  | ExgSocketType * | socketP
 | ) |

Entry point to start a Get operation

Parameters:
refNum,: IN: library reference number
socketP,: IN: the exchange socket
Return values:
Err Error code.

Boolean FileBrowserLibHandleEvent | ( | UInt16 | refNum,
 |  | EventType * | eventP
 | ) |

Entry point to handle an event

Parameters:
refNum,: IN: library reference number
eventP,: IN: the event to handle
Return values:
Boolean True if the event was handled and should not be passed to a higher level handler.

Err FileBrowserLibOpen ( UInt16 refNum )

Standard File Browser library open function

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code

Err FileBrowserLibParseFileURL | ( | UInt16 | refNum,
 |  | const Char * | urlP,
 |  | UInt16 * | volRefNumP,
 |  | Char ** | filePathP
 | ) |

Entry point to parse a URL (file:) received in a sysAppLaunchCmdExgReceiveData launch resulting from the open dialog. Pass NULL for unwanted results. Caller must free the others.

Parameters:
refNum,: IN: library reference number
urlP,: IN: URL to be parsed
volRefNumP,: OUT: pass back the file's volume's volRefNum
filePathP,: OUT: pass back the file's path
Return values:
Err Error code

Err FileBrowserLibPut | ( | UInt16 | refNum,
 |  | ExgSocketType * | socketP
 | ) |

Entry point to start a Put operation. Creates a connection if one doesn't already exist.

Parameters:
refNum,: IN: library reference number
socketP,: IN: the exchange socket
Return values:
Err Error code.

UInt32 FileBrowserLibReceive | ( | UInt16 | refNum,
 |  | ExgSocketType * | socketP,
 |  | void * | bufP,
 |  | UInt32 | bufSize,
 |  | Err * | errP
 | ) |

Entry point to receive data for an object

Parameters:
refNum,: IN: the library reference number
socketP,: IN: the exchange socket
bufP,: OUT: buffer to store received data
bufSize,: IN: size of buffer
errP,: OUT: passed back error code
Return values:
UInt32 number of bytes received.

Err FileBrowserLibRequest | ( | UInt16 | refNum,
 |  | ExgSocketType * | socketP
 | ) |

Entry point to do a Request operation (Unimplemented)

Parameters:
refNum,: IN: the library reference number
socketP,: IN: the exchange socket
Return values:
Err Error code.

UInt32 FileBrowserLibSend | ( | UInt16 | refNum,
 |  | ExgSocketType * | socketP,
 |  | const void * | bufP,
 |  | UInt32 | bufLen,
 |  | Err * | errP
 | ) |

Entry point to send data for an object

Parameters:
refNum,: IN: library reference number
socketP,: IN: the exchange socket
bufP,: IN: the buffer containing data to send
bufLen,: IN: bytes to send
errP,: OUT: passed back error code
Return values:
UInt32 number of bytes sent.

Boolean FileBrowserLibShowMultiselectDialog | ( | UInt16 | refNum,
 |  | UInt16 * | volRefNumP,
 |  | Char * | path,
 |  | UInt16 * | numFilesP,
 |  | UInt16 | maxFiles,
 |  | Char ** | filenames,
 |  | UInt16 | numExtensions,
 |  | const Char ** | extensions,
 |  | const Char * | fileType,
 |  | const Char * | title,
 |  | UInt32 | flags
 | ) |

Entry point to pop up a dialog in which multiple files can be selected

Parameters:
refNum,: IN: library reference number
volRefNumP,: IN: the default volume and the result
path,: IN: the default path
numFilesP | OUT: number of files selected
maxFiles | IN: maximum number of files allowed to select
filenames | OUT: names of files selected
numExtensions,: IN: number of extensions to display
extensions,: IN: compatible extensions to display
fileType,: IN: optional MIME type or extension to get default directory on each volume
title,: IN: open dialog title
flags,: IN: any combo of kOpenFlag* flags
Return values:
Boolean True if one or more files are selected

Boolean FileBrowserLibShowOpenDialog | ( | UInt16 | refNum,
 |  | UInt16 * | volRefNumP,
 |  | Char * | path,
 |  | UInt16 | numExtensions,
 |  | const Char ** | extensions,
 |  | const Char * | fileType,
 |  | const Char * | title,
 |  | UInt32 | flags
 | ) |

Pop up an Open dialog

Parameters:
refNum,: IN: library reference number
volRefNumP,: IN: the default volume and the result
path,: IN: the default path and the result (must be at least kFileBrowserLibPathBufferSize bytes).
numExtensions,: IN: number of extensions to display
extensions,: IN: compatible extensions to display
fileType,: IN: optional MIME type or extension to get default directory on each volume
title,: IN: open dialog title
flags,: IN: any combo of kOpenFlag* flags
Return values:
Boolean True if a file is selected

Boolean FileBrowserLibShowSaveAsDialog | ( | UInt16 | refNum,
 |  | UInt16 * | volRefNumP,
 |  | Char * | path,
 |  | UInt16 | numExtensions,
 |  | const Char ** | extensions,
 |  | const Char * | defaultExtension,
 |  | const Char * | fileType,
 |  | const Char * | title,
 |  | UInt32 | flags
 | ) |

Pop up a Save dialog

Parameters:
refNum,: IN: library reference number
volRefNumP,: IN: the default volume and the result
path,: IN: the default path and the result (must be at least kFileBrowserLibPathBufferSize bytes)
numExtensions,: IN: number of extensions to display
extensions,: IN: valid extensions to display
defaultExtension IN: default extension to display initially
fileType,: IN: optional MIME type or extension to get default directory on each volume
title,: IN: open dialog title
flags,: IN: any combo of kSaveAsFlag* flags
Return values:
Boolean True if a file is saved

Err FileBrowserLibSleep ( UInt16 refNum )

Standard File Browser library sleep function

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code

Err FileBrowserLibWake ( UInt16 refNum )

Standard File Browser library wake function

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:25 2006 for Palm API Guide


FileBrowserLibCommon.h File Reference

Detailed Description

Public 68K common header file for File Browser library API.

Version:
1.0
This file contains the File Browser Library common definitions and error codes.

Include dependency graph for FileBrowserLibCommon.h:

Flags for Open dialog

  • #define kFileBrowserLibFlagNoFiles 0x00000002UL
  • #define kFileBrowserLibFlagNoFolders 0x00000004UL

Flags for Save As dialog

  • #define kFileBrowserLibFlagPromptOverwrite 0x00000008UL
  • #define kFileBrowserLibFlagRequireExtension 0x00000010UL
  • #define kFileBrowserLibFlagNoNewFolder 0x00000020UL

Flags for Open & Save As dialog

  • #define kFileBrowserLibFlagNoDirChange 0x00000040UL
  • #define kFileBrowserLibFlagNoSubDir 0x00000080UL

Error Codes

  • #define kFileBrowserLibErrorClass (oemErrorClass + 0x0400)
  • #define kFileBrowserLibErrStillOpen (kFileBrowserLibErrorClass | 0x01)
  • #define kFileBrowserLibErrPathTooLong (kFileBrowserLibErrorClass | 0x02)
  • #define kFileBrowserLibErrMemError (kFileBrowserLibErrorClass | 0x03)
  • #define kFileBrowserLibErrCantFind (kFileBrowserLibErrorClass | 0x04)
  • #define kFileBrowserLibErrInternal (kFileBrowserLibErrorClass | 0x05)
  • #define kFileBrowserLibErrCantOpen (kFileBrowserLibErrorClass | 0x06)
  • #define kFileBrowserLibErrCantParse (kFileBrowserLibErrorClass | 0x07)

Function Traps

  • #define kFileBrowserLibTrapShowOpenDialog (exgLibTrapLast)
  • #define kFileBrowserLibTrapShowSaveAsDialog (exgLibTrapLast + 1)
  • #define kFileBrowserLibTrapParseFileURL (exgLibTrapLast + 2)
  • #define kFileBrowserLibTrapShowMultiselectDialog (exgLibTrapLast + 3)

Defines

  • #define kFileBrowserLibName "FileBrowser-PFil"
  • #define kFileBrowserLibFlagOneVolume 0x00000001UL
  • #define kFileBrowserLibMaxPathLength 2047
  • #define kFileBrowserLibPathBufferSize (kFileBrowserLibMaxPathLength + 1)
  • #define exgRegEditCreatorID 0xff7b
  • #define exgRegEditExtensionID 0xff7d
  • #define exgRegEditTypeID 0xff7e
  • #define kFileBrowserLibCtlGetVersion exgLibCtlSpecificOp
  • #define kFileBrowserLibAPIVersion0 0
  • #define kFileBrowserLibAPIVersion1 1

Define Documentation

#define kFileBrowserLibFlagNoDirChange 0x00000040UL

stay within tree

#define kFileBrowserLibFlagNoFiles 0x00000002UL

no files; only folders

#define kFileBrowserLibFlagNoFolders 0x00000004UL

no folders; only files

#define kFileBrowserLibFlagNoNewFolder 0x00000020UL

no New Folder button

#define kFileBrowserLibFlagNoSubDir 0x00000080UL

stay within folder

#define kFileBrowserLibFlagOneVolume 0x00000001UL

Flags for Open and Save As dialogs

#define kFileBrowserLibFlagPromptOverwrite 0x00000008UL

warn before replacing

#define kFileBrowserLibFlagRequireExtension 0x00000010UL

only given extensions

#define kFileBrowserLibName "FileBrowser-PFil"

Use SysLibFind to find this library. There is no need to load it. This must match the database name since this is an Exchange Library In Application (ELIA).

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:25 2006 for Palm API Guide


HardwareUtils68K.h File Reference

Detailed Description

Public common header file to the Hardware Utilities Library used by 68K applications.

Version:
1.0
This file contains the library constants and function prototypes for the library.

Include dependency graph for HardwareUtils68K.h:

Library Constants

  • #define kHWUtilsType sysFileTLibrary
  • #define kHWUtilsCreator 'HWut'
  • #define kHWUtilsName "HardwareUtils"

Function Traps

  • #define kHWUtilsTrapOpen sysLibTrapOpen
  • #define kHWUtilsTrapClose sysLibTrapClose
  • #define kHWUtilsTrapBlinkLED (sysLibTrapCustom + 0)
  • #define kHWUtilsTrapSetBlinkRate (sysLibTrapCustom + 1)
  • #define kHWUtilsTrapEnableDisplay (sysLibTrapCustom + 2)
  • #define kHWUtilsTrapGetDisplayState (sysLibTrapCustom + 3)

Functions

  • Err HWUOpen (UInt16 refnum)
    Standard library open routine.
  • Err HWUClose (UInt16 refnum)
    Standard library close routine.
  • Err HWUBlinkLED (UInt16 refnum, Boolean b)
    Set the LED blink state.
  • Err HWUSetBlinkRate (UInt16 refnum, UInt16 rate)
    Set the blink rate of the LED light.
  • Err HWUEnableDisplay (UInt16 refnum, Boolean on)
    Set the state of the display.
  • Boolean HWUGetDisplayState (UInt16 refnum)
    Retrieve the current state of the display.

Function Documentation

Err HWUBlinkLED | ( | UInt16 | refnum,
 |  | Boolean | b
 | ) |

Set the LED blink state.

Parameters:
refnum,: IN: Library reference number
b,: IN: True if LED should be blinking. False otherwise.
Returns:
Error code

Err HWUClose ( UInt16 refnum )

Standard library close routine.

Parameters:
refnum,: IN: Library reference number
Returns:
Error code.

Err HWUEnableDisplay | ( | UInt16 | refnum,
 |  | Boolean | on
 | ) |

Set the state of the display.

Parameters:
refnum,: IN: Library reference number
on,: IN: True to enable display. False otherwise.
Returns:
Error code.

Boolean HWUGetDisplayState ( UInt16 refnum )

Retrieve the current state of the display.

Parameters:
refnum,: IN: Library reference number
Returns:
True if the display is on. False otherwise.

Err HWUOpen ( UInt16 refnum )

Standard library open routine.

Parameters:
refnum,: IN: Library reference number
Returns:
Error code.

Err HWUSetBlinkRate | ( | UInt16 | refnum,
 |  | UInt16 | rate
 | ) |

Set the blink rate of the LED light.

Parameters:
refnum,: IN: Library reference number
rate,: IN: The rate at which the LED should blink.
Returns:
Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:25 2006 for Palm API Guide


HS_HTTPLib68K.h File Reference

Detailed Description

Public 68k include file for the HTTP Library.

Version:
2.0
Date:

Include dependency graph for HS_HTTPLib68K.h:

Data Structures

  • struct HS_HTTPLibSplit_
  • struct HS_HTTPLibTime_
  • struct HS_HTTPLibAuthInfo_
  • struct HttpUASelectionRule

Typedefs

  • typedef HS_HTTPLibSplit_ HS_HTTPLibSplit
  • typedef HS_HTTPLibTime_ HS_HTTPLibTime
  • typedef void * HS_HTTPLibDataHandle
  • typedef void * HS_HTTPLibVHandle
  • typedef void * HS_HTTPLibString
  • typedef void * HS_HTTPLibFixedString
  • typedef void * HS_HTTPLibURLString
  • typedef HS_HTTPLibAuthInfo_ HS_HTTPLibAuthInfo
  • typedef void * HS_HTTPLibStream
  • typedef void * HS_HTTPLibSSL
  • typedef void * HS_HTTPLibCookies
  • typedef void * HS_HTTPLibCertPtr
  • typedef void * HS_HTTPLibCertList
  • typedef void * HS_HTTPLibClientCertList
  • typedef void * HS_HTTPLibSSLClassPtr
  • typedef Int32(* HS_HTTPLibCookieConfirmProc )(HS_HTTPLibCookies in_cookie, HS_HTTPLibURLString in_url, Char *in_header, Int32 in_header_len, HS_HTTPLibOpaque in_aux)
  • typedef Int32(* HS_HTTPLibServerCertConfirmProc )(HS_HTTPLibSSL in_ssl, Int32 in_verify_result, HS_HTTPLibCertList in_list, HS_HTTPLibOpaque in_aux)
  • typedef Int32(* HS_HTTPLibClientCertSelectProc )(HS_HTTPLibSSL in_ssl, HS_HTTPLibClientCertList in_list, HS_HTTPLibOpaque in_aux)
  • typedef Int32(* HS_HTTPLibTunnelingCallbackProc )(HS_HTTPLibStream stream, Char *buf, Int32 len, void *in_aux)
  • typedef void(* HS_HTTPLibWakeUpCallbackProc )(HS_HTTPLibOpaque in_aux)

Enumerations

  • enum {
    httpUASelectTypeHost,
    httpUASelectTypePath
    }

Functions

  • Err HS_HTTPLibOpen (UInt16 refnum)
    This function opens the HTTP library and increments the open count. This function will create and initialize the library’s common data at first opening.
  • Err HS_HTTPLibClose (UInt16 refnum, UInt16 *usecountP)
    This function decrements open count and finalizes the library’s common data at the last close.
  • Err HS_HTTPLibSleep (UInt16 refnum)
    Standard library sleep function.
  • Err HS_HTTPLibWake (UInt16 refnum)
    Standard library wake function.
  • UInt16 HS_HTTPLibOpenCount (UInt16 refnum)
    This function returns the open count of this library.
  • HS_HTTPLibHandle HS_HTTPLibInitialize (UInt16 refnum, HS_HTTPLibAppInfo *appInfoP, HS_HTTPLibNetLibInfo *netLibInfoP, HS_HTTPLibPeer *peerP)
    This function initializes the library instance and sets application dependent information in the global variables. The return value is the handle of library instance. If an error occurs during the initialization, the return value is NULL.
  • void HS_HTTPLibFinalize (UInt16 refnum, HS_HTTPLibHandle libH)
    This function finalizes the library instance.
  • HS_HTTPLibSSLClassPtr HS_HTTPLibSSLClass (UInt16 refnum, HS_HTTPLibHandle libH)
  • void HS_HTTPLibRegisterSSLClass (UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibSSLClassPtr sslClassP)
  • void HS_HTTPLibClearDNSCache (UInt16 refnum, HS_HTTPLibHandle libH)
    This function clears the DNS cache information.
  • void HS_HTTPLibCloseAllKeepAlive (UInt16 refnum, HS_HTTPLibHandle libH)
    This function closes the all idle keep alive sockets relating this application. Nonidle sockets are not closed by this function.
  • void HS_HTTPLibMakeProxy (UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibFixedString *out_proxy_host, Int32 *out_proxy_http_port, Int32 *out_proxy_https_port, HS_HTTPLibString *out_no_proxy_hosts)
    Set the proxy information of this application to out_proxy_host, out_proxy_http_port, out_proxy_https_port, out_no_proxy_hosts. If out_proxy_host is NULL, the value of *out_proxy_http_port, *out_proxy_https_port, *out_no_proxy_hosts are not set, otherwise the values of *out_proxy_http_port, *out_proxy_https are set. If out_no_proxy_hosts is NULL, *out_no_proxy_hosts is not set. The format of out_no_proxy_hosts is the list separated by “,”. The responsibility of delete *out_proxy_host, *out_no_proxy_hosts is caller.
  • void HS_HTTPLibSetHTTPPort (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_port)
    This function sets the default HTTP port number. If there is no indication in URL, this port number is used for TCP connection.
  • void HS_HTTPLibSetHTTPSPort (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_port)
    This function sets the default HTTPS port number. If there is no indication in https URL, this port number is used for TCP connection.
  • void HS_HTTPLibSetMaxRequestHeader (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_size)
    This function sets the maximal size of Request-Line. If in_size is -1, the maximal size is unlimited. Note that this function does not set the maximal size of Request- Header. See RFC2616 for the definitions of Request-Line and Request-Header.
  • void HS_HTTPLibSetMaxRequestBody (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_size)
    This function sets the maximal size of Request-Body. If in_size is -1, the maximal size is unlimited.
  • Boolean HS_HTTPLibSetProxy (UInt16 refnum, HS_HTTPLibHandle libH, Char *in_proxy_host, Int32 in_proxy_host_len, Int32 in_proxy_http_port, Int32 in_proxy_https_port, Char *in_no_proxy_hosts, Int32 in_no_proxy_hosts_len)
    This function sets the proxy server setting for this application. If in_proxy_host is NULL, in_proxy_host, in_proxy_http_port, in_proxy_https_port are not set. If in_no_proxy_hosts is NULL, in_no_proxy_hosts is not set. The format of in_no_proxy_hosts is comma (“,”) separated list.
  • Boolean HS_HTTPLibSetUserAgent (UInt16 refnum, HS_HTTPLibHandle libH, Char *in_useragent, Int32 in_useragent_len)
    This function sets the UserAgent string for the application. If in_useragent is NULL, setting is cleared.
  • Boolean HS_HTTPLibSetDefaultHeaders (UInt16 refnum, HS_HTTPLibHandle libH, Char *in_default_headers, Int32 in_default_headers_len)
    This function sets the default header, i.e. this string is added to the Request-header of the Request created at HS_HTTPLibStreamCreateRequest. If in_default_headers is NULL, the setting is cleared.
  • void HS_HTTPLibSetUseProxy (UInt16 refnum, HS_HTTPLibHandle libH, Boolean in_bool)
    This function sets whether this application uses proxy server.
  • void HS_HTTPLibSetHTTP11OverProxy (UInt16 refnum, HS_HTTPLibHandle libH, Boolean in_bool)
    This function sets whether this application permits HTTP1.1 over proxy server. If false is set, the application use HTTP/1.0.
  • void HS_HTTPLibSetSendReferer (UInt16 refnum, HS_HTTPLibHandle libH, Boolean in_bool)
  • void HS_HTTPLibSetSendProxyKeepAlive (UInt16 refnum, HS_HTTPLibHandle libH, Boolean in_bool)
  • void HS_HTTPLibSetSendCookie (UInt16 refnum, HS_HTTPLibHandle libH, Boolean in_bool)
    This function sets whether this application sends Cookie.
  • void HS_HTTPLibSetConnectTimeOut (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_msec)
    This function sets the limit of Connection timeout. If in_msec is -1, no timeout is set. The condition of timeout is in_msec has passed from TCP connect without HTTP connection established.
  • void HS_HTTPLibSetReqTimeOut (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_msec)
    This function sets the limit of sending Request timeout. If in_msec is -1, no timeout is set. The condition of timeout is in_msec has passed from the start of Request sending without sending done.
  • void HS_HTTPLibSetRspTimeOut (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_msec)
    This function sets the limit of receiving Response timeout. If in_msec is -1, no timeout is set. The condition of timeout is in_msec has passed from the end of sending request without receiving Response. Or in_msec has passed from the last receiving a part of Response without receiving any part of Response.
  • void HS_HTTPLibSetTunnelingCallback (UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibTunnelingCallbackProc in_cb, void *in_aux)
  • Boolean HS_HTTPLibIsUseProxy (UInt16 refnum, HS_HTTPLibHandle libH)
    This function returns whether this application uses proxy.
  • Boolean HS_HTTPLibIsHTTP11OverProxy (UInt16 refnum, HS_HTTPLibHandle libH)
    This function returns whether this application permits HTTP/1.1 over proxy.
  • Boolean HS_HTTPLibIsSendReferer (UInt16 refnum, HS_HTTPLibHandle libH)
  • Boolean HS_HTTPLibIsSendCookie (UInt16 refnum, HS_HTTPLibHandle libH)
    This function returns whether this application sends Cookie.
  • HS_HTTPLibStream HS_HTTPLibStreamNew (UInt16 refnum, HS_HTTPLibHandle libH)
    This function creates a new stream and returns the handle of stream instance. At this time, TCP/SSL socket is not opened.
  • void HS_HTTPLibStreamDelete (UInt16 refnum, HS_HTTPLibStream stream)
    This function deletes the stream instance. If this function is called without calling HS_HTTPLibStreamClose, this function closes the TCP/SSL socket by calling HS_HTTPLibStreamClose, however if the socket is in keep-alive, it is not closed.
  • Int32 HS_HTTPLibStreamCreateRequest (UInt16 refnum, HS_HTTPLibStream stream, Int32 in_method, Char *in_url, UInt32 in_url_len, Char *in_header, UInt32 in_header_len, Char *in_referer, UInt32 in_referer_len, Int32 in_version, Boolean in_no_cache, Boolean in_pipeline, Int32 in_ssl_flag)
    This function creates a request. If using proxy and SSL connection, CONNECT request message is made. If there are cached authenticate informations, add authenticate header. Add default headers and in_header to Request-Header.
  • Int32 HS_HTTPLibStreamCreateRequestWithChunkEncoding (UInt16 refnum, HS_HTTPLibStream stream, Int32 in_method, Char *in_url, UInt32 in_url_len, Char *in_header, UInt32 in_header_len, Char *in_referer, UInt32 in_referer_len, Int32 in_version, Boolean in_no_cache, Boolean in_pipeline, Int32 in_ssl_flag)
    This function creates request for chunk-encoding post. If using proxy and SSL connection, CONNECT request message is made. If there are cached authenticate informations, add authenticate header. Add default headers and in_header to Request-Header. Do not use this API unless you want to create chunk-encoding request. Transfer- Encoding: chunked is added to the request header.
  • Int32 HS_HTTPLibStreamSendRequest (UInt16 refnum, HS_HTTPLibStream stream, Int32 *out_sleep)
    This function sends the request. This call opens and connects a TCP connection if not already established. It automatically retries at where pipeline stalled if pipeline is enable.
  • Int32 HS_HTTPLibStreamSendRequestWithPostData (UInt16 refnum, HS_HTTPLibStream stream, Char *in_buf, Int32 in_len, Int32 *out_len, Int32 *out_sleep)
    This function sends the POST request. This call opens and connects a TCP connection if not already established. It automatically retries at where pipeline stalled if pipeline is enable.
  • Int32 HS_HTTPLibStreamSendRequestWithChunkEncoding (UInt16 refnum, HS_HTTPLibStream stream, Char *in_buf, Int32 in_offset, Int32 in_len, Boolean isFinish, Int32 *out_len, Int32 *out_sleep)
    This function sends chunk encoding data. This call opens and connects a TCP connection if not already established. It automatically retries at where pipeline stalled if pipeline is enable. The sequence of chunked data sending is 1. call HS_HTTPLibStreamCreateRequestWithChunkEncoding() 2. call HS_HTTPLibStreamSendRequestWithChunkEncoding() while return value is not httpErrorOK or error. 3. If there remains data, goto 2. 4. end If only one chunked data is sent, this API returns httpErrorOK. The address of data for one chunk is in_buf + in_offset, this value should not be changed while sending only one chunked data. isFinish is used to indicate the chunked data is the last chunk.
  • Int32 HS_HTTPLibStreamReceiveResponse (UInt16 refnum, HS_HTTPLibStream stream, Char *out_buf, Int32 in_len, Int32 *out_len, Int32 *out_sleep)
    This function receives response. It automatically retries at where pipeline stalled if pipeline is enable.
  • Int32 HS_HTTPLibStreamGetFlag (UInt16 refnum, HS_HTTPLibStream stream)
  • void HS_HTTPLibStreamSuspendTimer (UInt16 refnum, HS_HTTPLibStream stream)
  • void HS_HTTPLibStreamResumeTimer (UInt16 refnum, HS_HTTPLibStream stream)
  • void HS_HTTPLibStreamClose (UInt16 refnum, HS_HTTPLibStream stream)
    This function closes the HTTP stream. If the TCP/SSL socket is in keep-alive, it is not closed.
  • Boolean HS_HTTPLibStreamIsHeaderReceived (UInt16 refnum, HS_HTTPLibStream stream)
    This function returns whether the response header is completely received.
  • Int32 HS_HTTPLibStreamSetPostData (UInt16 refnum, HS_HTTPLibStream stream, Int32 in_encoding, Char *in_data, Int32 in_len)
    This function sets the POST data.
  • Int32 HS_HTTPLibStreamGetScheme (UInt16 refnum, HS_HTTPLibStream stream)
    This function returns the scheme given at the HS_HTTPLibStreamCreateRequest.
  • Int32 HS_HTTPLibStreamGetState (UInt16 refnum, HS_HTTPLibStream stream)
    This function returns the state of the stream. The state changes follow the below sequence (but skipping the states that are not relevant to the current request).
  • Int32 HS_HTTPLibStreamGetStatusCode (UInt16 refnum, HS_HTTPLibStream stream)
    This function returns the Status Code.
  • Int32 HS_HTTPLibStreamGetResponseHeaderLength (UInt16 refnum, HS_HTTPLibStream stream)
    This function returns the size of the response header.
  • HS_HTTPLibVHandle HS_HTTPLibStreamGetResponseHeader (UInt16 refnum, HS_HTTPLibStream stream)
    This function returns the handle of the response header. The responsibility to delete the handle is library, the application can not delete this return value. To lock/unlock the handle, the application should use the APIs,.
  • Int32 HS_HTTPLibStreamGetContentLength (UInt16 refnum, HS_HTTPLibStream stream)
    This function returns the content’s size (byte).
  • Int32 HS_HTTPLibStreamGetEntityLength (UInt16 refnum, HS_HTTPLibStream stream)
    This function returns the size of response body (byte).
  • Boolean HS_HTTPLibStreamAddHeaderLine (UInt16 refnum, HS_HTTPLibStream stream, Char *in_str, Int32 in_len)
    This function adds the line to the Request header. If there is already the same kind of header line, old one is deleted.
  • Boolean HS_HTTPLibStreamAddHeader (UInt16 refnum, HS_HTTPLibStream stream, Int32 in_type, Char *in_str, Int32 in_len)
    This function sets the value of corresponding header. If there is already the same kind of header line, old one is deleted.
  • Boolean HS_HTTPLibStreamGetHeader (UInt16 refnum, HS_HTTPLibStream stream, Int32 in_type, Int32 *out_off, Int32 *out_len)
    This function returns the offset and length of corresponding header value.
  • HS_HTTPLibCertList HS_HTTPLibMakeCertList (UInt16 refnum, HS_HTTPLibStream stream)
    This function returns the Server certification used for SSL. The responsibility to delete the return handle is the application. To delete the return value, the application should use HS_HTTPLibCertListDelete.
  • Boolean HS_HTTPLibHeaderSplitByX (UInt16 refnum, HS_HTTPLibSplit *inout_ss, Int32 in_id, Char *in_cs)
  • void HS_HTTPLibAuthInfoTidy (UInt16 refnum, HS_HTTPLibAuthInfo *in_info, Boolean in_new)
    This function initialize/finalize the HS_HTTPLibAuthInfo struct. The application should call this function setting in_new = true before using HS_HTTPLibAuthInfo. The application should call this function setting in_new = false after using HS_HTTPLibAuthInfo.
  • Boolean HS_HTTPLibSetUserPass (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_type, Int32 in_target, HS_HTTPLibSplit *in_challenge, HS_HTTPLibSplit *in_realm, Char *in_user, Int32 in_user_len, Char *in_pass, Int32 in_pass_len, Char *in_url, Int32 in_url_len, Char *in_host, Int32 in_host_len, Int32 in_port)
    This function sets the authentication information.
  • Boolean HS_HTTPLibFindAuthInfo (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_target, Char *in_url, Int32 in_url_len, Char *in_host, Int32 in_host_len, Int32 in_port, HS_HTTPLibSplit *in_realm, HS_HTTPLibAuthInfo *out_info)
  • Boolean HS_HTTPLibMakeAuthInfo (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_target, Char *in_url, Int32 in_url_len, Char *in_host, Int32 in_host_len, Int32 in_port, HS_HTTPLibSplit *in_realm, HS_HTTPLibAuthInfo *out_info)
    This function returns the authentication information to the out_info. Before calling this API, the application should intialize HS_HTTPLibAuthInfo by HS_HTTPLibAuthInfoTidy(out_info, true).
  • HS_HTTPLibString HS_HTTPLibAuthInfoUser (UInt16 refnum, HS_HTTPLibAuthInfo *in_info)
    This function returns the User Name. The application should not delete this return value.
  • HS_HTTPLibString HS_HTTPLibAuthInfoPass (UInt16 refnum, HS_HTTPLibAuthInfo *in_info)
    This function returns the Password. The application should not delete this return value.
  • HS_HTTPLibString HS_HTTPLibAuthInfoRealm (UInt16 refnum, HS_HTTPLibAuthInfo *in_info)
    This function returns the Realm. The application should not delete this return value.
  • Boolean HS_HTTPLibAuthCacheGetChallengeTokenSS (UInt16 refnum, HS_HTTPLibSplit *in_challenge_ss, Char *in_token, HS_HTTPLibSplit *out_ss)
  • void HS_HTTPLibSetCookieMode (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_mode, HS_HTTPLibCookieConfirmProc in_cb, HS_HTTPLibOpaque in_opaque)
    This function sets the Cookie mode.
  • void HS_HTTPLibSetCookieMax (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_max_total_cookies, Int32 in_max_cookies_per_domain, Int32 in_max_len_per_cookie)
    This function sets the max size of Cookie entries.
  • Int32 HS_HTTPLibSetCookie (UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibURLString in_url, Char *in_header, Int32 in_header_len)
    This function sets the Cookie abiding with the confirmation mode set by HS_HTTPLibSetCookieMode. The application should not use this API in callback function. The API HS_HTTPLibSetCookieX is designed for use in callback.
  • Int32 HS_HTTPLibSetCookieX (UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibURLString in_url, Char *in_header, Int32 in_header_len)
    This function sets the Cookie. This function is designed for callback confirm function.
  • HS_HTTPLibString HS_HTTPLibMakeCookiesString (UInt16 refnum, HS_HTTPLibHandle libH, Char *in_url, Int32 in_urllen, Boolean in_secure, Int32 *out_len)
  • HS_HTTPLibString HS_HTTPLibSaveCookiesEntries (UInt16 refnum, HS_HTTPLibHandle libH, Int32 *out_len)
  • Boolean HS_HTTPLibLoadCookiesEntries (UInt16 refnum, HS_HTTPLibHandle libH, Char *in_s, Int32 in_slen)
  • void HS_HTTPLibCookieMakeEmpty (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_flag)
    This function clears Cookies.
  • void HS_HTTPLibSetDNSMaxRetry (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_retry)
  • void HS_HTTPLibSetDNSRetryInterval (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_interval)
  • void HS_HTTPLibSetSSLVersionFlag (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_flag, Boolean in_on)
    Set the SSL version.
  • Int32 HS_HTTPLibSSLTimeout (UInt16 refnum, HS_HTTPLibHandle libH)
    Set the timeout period for SSL use.
  • Int32 HS_HTTPLibSSLOpenCertDB (UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibCertList *out_list)
    TBD.
  • void HS_HTTPLibSSLCloseCertDB (UInt16 refnum, HS_HTTPLibHandle libH)
    TBD.
  • HS_HTTPLibCertList HS_HTTPLibCertListNew (UInt16 refnum, Int32 in_type)
  • void HS_HTTPLibCertListDelete (UInt16 refnum, HS_HTTPLibCertList in_list)
    TBD.
  • HS_HTTPLibCertList HS_HTTPLibCertListClone (UInt16 refnum, HS_HTTPLibCertList in_list)
    TBD.
  • void * HS_HTTPLibCertListLock (UInt16 refnum, HS_HTTPLibCertList in_list)
    Lock the certificate list and return its pointer.
  • void HS_HTTPLibCertListUnlock (UInt16 refnum, HS_HTTPLibCertList in_list)
    Unlock the certificate list.
  • Int32 HS_HTTPLibCertListType (UInt16 refnum, HS_HTTPLibCertList in_list)
    TBD.
  • Int32 HS_HTTPLibCertListLength (UInt16 refnum, HS_HTTPLibCertList in_list)
    TBD.
  • Int32 HS_HTTPLibCertListBeginDecode (UInt16 refnum, HS_HTTPLibCertList in_list, Int32 in_index, HS_HTTPLibCertPtr *out_cert)
    TBD.
  • void HS_HTTPLibCertListEndDecode (UInt16 refnum, HS_HTTPLibCertList in_list, HS_HTTPLibCertPtr in_cert)
    TBD.
  • Int32 HS_HTTPLibCertListImportCert (UInt16 refnum, HS_HTTPLibCertList in_list, void *in_info, Boolean in_over_write)
    TBD.
  • Int32 HS_HTTPLibCertPeekVersion (UInt16 refnum, HS_HTTPLibCertPtr in_cert)
  • Int32 HS_HTTPLibCertPeekSerialNumber (UInt16 refnum, HS_HTTPLibCertPtr in_cert, Char **out_str)
  • Int32 HS_HTTPLibCertPeekSignAlgo (UInt16 refnum, HS_HTTPLibCertPtr in_cert)
  • Boolean HS_HTTPLibCertBeginPeekIssuerRDN (UInt16 refnum, HS_HTTPLibCertPtr in_cert, Int32 in_attr)
  • Int32 HS_HTTPLibCertPeekIssuerRDN (UInt16 refnum, HS_HTTPLibCertPtr in_cert, Char **out_str)
  • Int32 HS_HTTPLibCertPeekIssuerRDNStrType (UInt16 refnum, HS_HTTPLibCertPtr in_cert)
  • void HS_HTTPLibCertEndPeekIssuerRDN (UInt16 refnum, HS_HTTPLibCertPtr in_cert)
  • Boolean HS_HTTPLibCertBeginPeekSubjectRDN (UInt16 refnum, HS_HTTPLibCertPtr in_cert, Int32 in_attr)
  • Int32 HS_HTTPLibCertPeekSubjectRDN (UInt16 refnum, HS_HTTPLibCertPtr in_cert, Char **out_str)
  • Int32 HS_HTTPLibCertPeekSubjectRDNStrType (UInt16 refnum, HS_HTTPLibCertPtr in_cert)
  • void HS_HTTPLibCertEndPeekSubjectRDN (UInt16 refnum, HS_HTTPLibCertPtr in_cert)
  • void HS_HTTPLibCertPeekValidityStart (UInt16 refnum, HS_HTTPLibCertPtr in_cert, HS_HTTPLibTime *in_time)
  • void HS_HTTPLibCertPeekValidityEnd (UInt16 refnum, HS_HTTPLibCertPtr in_cert, HS_HTTPLibTime *in_time)
  • Int32 HS_HTTPLibCertPeekRSAPublicKeyBits (UInt16 refnum, HS_HTTPLibCertPtr in_cert)
  • HS_HTTPLibClientCertList HS_HTTPLibClientCertListNew (UInt16 refnum)
  • HS_HTTPLibClientCertList HS_HTTPLibClientCertListClone (UInt16 refnum, HS_HTTPLibClientCertList in_list)
    TBD.
  • void HS_HTTPLibClientCertListDelete (UInt16 refnum, HS_HTTPLibClientCertList in_list)
  • Int32 HS_HTTPLibClientCertListLength (UInt16 refnum, HS_HTTPLibClientCertList in_list)
    TBD.
  • Boolean HS_HTTPLibClientCertListIsValid (UInt16 refnum, HS_HTTPLibClientCertList in_list, Int32 in_index)
    TBD.
  • void HS_HTTPLibClientCertListSetValid (UInt16 refnum, HS_HTTPLibClientCertList in_list, Int32 in_index, Boolean in_valid)
    TBD.
  • void HS_HTTPLibSetSSLServerCertConfirmProc (UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibServerCertConfirmProc in_cb, HS_HTTPLibOpaque in_opaque)
    This function sets the server certificate callback function for this application.
  • void HS_HTTPLibServerCertConfirm (UInt16 refnum, HS_HTTPLibSSL in_ssl, Int32 in_verify_result, Boolean in_confirm)
    This function sets the result of confirmation. This function should be called in the callback function.
  • void HS_HTTPLibSetSSLClientCertSelectProc (UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibClientCertSelectProc in_cb, HS_HTTPLibOpaque in_opaque)
    This function sets the client certification select callback function.For now, there is no corresponding function in SSL library, the callback will not be called.
  • void HS_HTTPLibClientCertSelect (UInt16 refnum, HS_HTTPLibSSL in_ssl, Int32 in_index)
    This function sets the selected certification. For now, there is no corresponding function in SSL library, the callback will not be called.
  • void HS_HTTPLibSetNetLibProc (UInt16 refnum, HS_HTTPLibHandle libH, UInt16 netLibRefnum, HS_HTTPLibNetLibOpenProc in_open, HS_HTTPLibNetLibCloseProc in_close, HS_HTTPLibNetLibOnlineProc in_online, HS_HTTPLibNetLibOfflineProc in_offline)
    This function sets the callback functions concerning NetLib. But for now, there is no call to callback functions from Peer layer.
  • Int32 HS_HTTPLibDataHandle_Length (UInt16 refnum, HS_HTTPLibDataHandle in_handle)
  • void * HS_HTTPLibDataHandle_Lock (UInt16 refnum, HS_HTTPLibDataHandle in_handle)
  • void HS_HTTPLibDataHandle_Unlock (UInt16 refnum, HS_HTTPLibDataHandle in_handle)
  • void HS_HTTPLibDataHandle_Delete (UInt16 refnum, HS_HTTPLibDataHandle in_handle)
  • Int32 HS_HTTPLibVHandle_Length (UInt16 refnum, HS_HTTPLibVHandle in_vhandle)
    This function returns the length of the handle (byte).
  • void * HS_HTTPLibVHandle_Lock (UInt16 refnum, HS_HTTPLibVHandle in_vhandle)
    This function locks the handle of type HS_HTTPLibVHandle.
  • void HS_HTTPLibVHandle_Unlock (UInt16 refnum, HS_HTTPLibVHandle in_vhandle)
    This function unlocks the handle of type HS_HTTPLibVHandle.
  • void HS_HTTPLibVHandle_Delete (UInt16 refnum, HS_HTTPLibVHandle in_vhandle)
    This function deletes the handle of type HS_HTTPLibVHandle.
  • Int32 HS_HTTPLibString_Length (UInt16 refnum, HS_HTTPLibString in_str)
    This function returns the length of the handle (byte).
  • HS_HTTPLibString HS_HTTPLibStringNew (UInt16 refnum, Char *in_str, Int32 in_len)
    This function creates a new handle of type HS_HTTPLibString.
  • void * HS_HTTPLibString_Lock (UInt16 refnum, HS_HTTPLibString in_str)
    This function locks the handle of type HS_HTTPLibString.
  • void HS_HTTPLibString_Unlock (UInt16 refnum, HS_HTTPLibString in_str)
    This function unlocks the handle of type HS_HTTPLibString.
  • void HS_HTTPLibString_Delete (UInt16 refnum, HS_HTTPLibString in_str)
    This function deletes the handle of type HS_HTTPLibString.
  • Int32 HS_HTTPLibFixedString_Length (UInt16 refnum, HS_HTTPLibFixedString in_str)
    This function returns the length of the handle (byte).
  • HS_HTTPLibFixedString HS_HTTPLibFixedStringNew (UInt16 refnum, Char *in_str, Int32 in_len)
    This function creates a new handle of type HS_HTTPLibFixedString.
  • void * HS_HTTPLibFixedString_Lock (UInt16 refnum, HS_HTTPLibFixedString in_str)
    This function locks the handle of type HS_HTTPLibFixedString.
  • void HS_HTTPLibFixedString_Unlock (UInt16 refnum, HS_HTTPLibFixedString in_str)
    This function unlocks the handle of type HS_HTTPLibFixedString.
  • void HS_HTTPLibFixedString_Delete (UInt16 refnum, HS_HTTPLibFixedString in_str)
    This function deletes the handle of type HS_HTTPLibFixedString.
  • Int32 HS_HTTPLibURLString_Length (UInt16 refnum, HS_HTTPLibURLString in_str)
    This function returns the length of the handle (byte).
  • HS_HTTPLibURLString HS_HTTPLibURLStringNew (UInt16 refnum, Char *in_str, Int32 in_len)
    This function creates a new handle of type HS_HTTPLibURLString.
  • void * HS_HTTPLibURLString_Lock (UInt16 refnum, HS_HTTPLibURLString in_str)
    This function locks the handle of type HS_HTTPLibURLString.
  • void HS_HTTPLibURLString_Unlock (UInt16 refnum, HS_HTTPLibURLString in_str)
    This function unlocks the handle of type HS_HTTPLibURLString.
  • void HS_HTTPLibURLString_Delete (UInt16 refnum, HS_HTTPLibURLString in_str)
    This function deletes the handle of type HS_HTTPLibURLString.
  • void * HS_HTTPLibCertListGetCipherInfo (UInt16 refnum, void *iself)
    This returns the cipher info. SslCipherSuiteInfo is the structure defined in SslLib.h.
  • void HS_HTTPLibSetMaxKeepAliveTimeout (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_msec)
  • void HS_HTTPLibStreamGetRequestSent (UInt16 refnum, HS_HTTPLibStream stream, Int32 *out_total, Int32 *out_sent)
  • Boolean HS_HTTPLibStreamGetHeaderWithOffset (UInt16 refnum, HS_HTTPLibStream stream, Int32 in_type, Int32 in_ofs, Int32 *out_off, Int32 *out_len)
  • Boolean HS_HTTPLibSetUserPassX (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_type, Int32 in_target, HS_HTTPLibSplit *in_challenge, HS_HTTPLibSplit *in_realm, Char *in_user, Int32 in_user_len, Char *in_pass, Int32 in_pass_len, Char *in_url, Int32 in_url_len, Char *in_host, Int32 in_host_len, Int32 in_port, Boolean in_keep_user, Boolean in_keep_pass)
  • void HS_HTTPLibFindAuthCandidate (UInt16 refnum, HS_HTTPLibHandle libH, Int32 in_target, Char *in_url, Int32 in_url_len, Char *in_host, Int32 in_host_len, Int32 in_port, Char *in_realm, Int32 in_realm_len, HS_HTTPLibString *out_user, HS_HTTPLibString *out_pass, Boolean *out_keep_user, Boolean *out_keep_pass)
  • void HS_HTTPLibSetWakeUpCallback (UInt16 refnum, HS_HTTPLibHandle libH, HS_HTTPLibWakeUpCallbackProc in_proc, HS_HTTPLibOpaque in_opaque)
  • Boolean HS_HTTPLibSetUseragentSelectionRule (UInt16 refnum, HS_HTTPLibHandle libH, HttpUASelectionRule *rules, Int32 len)

Enumeration Type Documentation

anonymous enum

This sets the rules for HttpLib to use to select useragent for each request. The rule should be set as little as possible so that it does not slow down browser performance.

Function Documentation

Boolean HS_HTTPLibAuthCacheGetChallengeTokenSS | ( | UInt16 | refnum,
 |  | HS_HTTPLibSplit * | in_challenge_ss,
 |  | Char * | in_token,
 |  | HS_HTTPLibSplit * | out_ss
 | ) |

Parameters:
refnum,: IN:
*in_challenge_ss,: IN:
*in_token,: IN:
*out_ss,: IN:
Return values:
Err error code.

HS_HTTPLibString HS_HTTPLibAuthInfoPass | ( | UInt16 | refnum,
 |  | HS_HTTPLibAuthInfo * | in_info
 | ) |

This function returns the Password. The application should not delete this return value.

Parameters:
refnum,: IN: Library reference number.
*in_info,: IN: The pointer to the authentication information.
Returns:
The handle of password.

HS_HTTPLibString HS_HTTPLibAuthInfoRealm | ( | UInt16 | refnum,
 |  | HS_HTTPLibAuthInfo * | in_info
 | ) |

This function returns the Realm. The application should not delete this return value.

Parameters:
refnum,: IN: Library reference number.
*in_info,: IN: The pointer to the authentication information.
Returns:
The handle of Realm.

void HS_HTTPLibAuthInfoTidy | ( | UInt16 | refnum,
 |  | HS_HTTPLibAuthInfo * | in_info,
 |  | Boolean | in_new
 | ) |

This function initialize/finalize the HS_HTTPLibAuthInfo struct. The application should call this function setting in_new = true before using HS_HTTPLibAuthInfo. The application should call this function setting in_new = false after using HS_HTTPLibAuthInfo.

Parameters:
refnum,: IN: Library reference number.
*in_info,: IN: The pointer to the authenticate information struct.
in_new,: IN: True if initialize the member. False if initialize the member after deleting.
Returns:
None.

HS_HTTPLibString HS_HTTPLibAuthInfoUser | ( | UInt16 | refnum,
 |  | HS_HTTPLibAuthInfo * | in_info
 | ) |

This function returns the User Name. The application should not delete this return value.

Parameters:
refnum,: IN: Library reference number.
*in_info,: IN: The pointer to the authentication information.
Returns:
The handle of User Name.

Boolean HS_HTTPLibCertBeginPeekIssuerRDN | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert,
 |  | Int32 | in_attr
 | ) |

Parameters:
refnum,: IN:
in_cert,: IN:
in_attr,: IN:
Return values:
Err error code.

Boolean HS_HTTPLibCertBeginPeekSubjectRDN | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert,
 |  | Int32 | in_attr
 | ) |

Parameters:
refnum,: IN:
in_cert,: IN:
in_attr,: IN:
Return values:
Err error code.

void HS_HTTPLibCertEndPeekIssuerRDN | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert
 | ) |

Parameters:
refnum,: IN:
in_cert,: IN:
Return values:
Err error code.

void HS_HTTPLibCertEndPeekSubjectRDN | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert
 | ) |

Parameters:
refnum,: IN:
in_cert,: IN:
Return values:
Err error code.

Int32 HS_HTTPLibCertListBeginDecode | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertList | in_list,
 |  | Int32 | in_index,
 |  | HS_HTTPLibCertPtr * | out_cert
 | ) |

TBD.

Parameters:
refnum,: IN: Library reference number.
in_list,: IN: The handle of the server’s certification list.
in_index,: IN: -
*out_cert,: OUT: -
Return values:
Int32

HS_HTTPLibCertList HS_HTTPLibCertListClone | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertList | in_list
 | ) |

TBD.

Parameters:
refnum,: IN: Library reference number.
in_list,: IN: The handle of the server’s certification list.
Returns:
Handle to the clone of the certification list.

void HS_HTTPLibCertListDelete | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertList | in_list
 | ) |

TBD.

Parameters:
refnum,: IN: Library reference number.
in_list,: IN: The handle of the server’s certification list.
Returns:
None.

void HS_HTTPLibCertListEndDecode | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertList | in_list,
 |  | HS_HTTPLibCertPtr | in_cert
 | ) |

TBD.

Parameters:
refnum,: IN: Library reference number.
in_list,: IN: The handle of the server’s certification list.
in_cert,: IN: -
Returns:
None.

void* HS_HTTPLibCertListGetCipherInfo | ( | UInt16 | refnum,
 |  | void * | iself
 | ) |

This returns the cipher info. SslCipherSuiteInfo is the structure defined in SslLib.h.

The implementation of this API in ARM native version is mere macro.

Parameters:
refnum,: IN: Library reference number.
*iself,: IN: -
Return values:
nothing

Int32 HS_HTTPLibCertListImportCert | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertList | in_list,
 |  | void * | in_info,
 |  | Boolean | in_over_write
 | ) |

TBD.

Parameters:
refnum,: IN: Library reference number.
in_list,: IN: The handle of the server’s certification list.
*in_info,: IN: -
in_over_write,: IN: -
Return values:
Int32

Int32 HS_HTTPLibCertListLength | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertList | in_list
 | ) |

TBD.

Parameters:
refnum,: IN: Library reference number.
in_list,: IN: The handle of the server’s certification list.
Return values:
Int32

void* HS_HTTPLibCertListLock | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertList | in_list
 | ) |

Lock the certificate list and return its pointer.

Parameters:
refnum,: IN: Library reference number.
in_list,: IN: The handle of the server's certification list.
Returns:
Pointer to the certificate list.

HS_HTTPLibCertList HS_HTTPLibCertListNew | ( | UInt16 | refnum,
 |  | Int32 | in_type
 | ) |

Parameters:
refnum,: IN:
in_type,: IN:
Returns:

Int32 HS_HTTPLibCertListType | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertList | in_list
 | ) |

TBD.

Parameters:
refnum,: IN: Library reference number.
in_list,: IN: The handle of the server’s certification list.
Return values:
Int32

void HS_HTTPLibCertListUnlock | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertList | in_list
 | ) |

Unlock the certificate list.

Parameters:
refnum,: IN: Library reference number.
in_list,: IN: The handle of the server’s certification list.
Returns:
None.

Int32 HS_HTTPLibCertPeekIssuerRDN | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert,
 |  | Char ** | out_str
 | ) |

Parameters:
refnum,: IN:
in_cert,: IN:
**out_str,: IN:
Return values:
Err error code.

Int32 HS_HTTPLibCertPeekIssuerRDNStrType | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert
 | ) |

Parameters:
refnum,: IN:
in_cert,: IN:
Return values:
Err error code.

Int32 HS_HTTPLibCertPeekRSAPublicKeyBits | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert
 | ) |

Parameters:
refnum,: IN:
in_cert,: IN:
Return values:
Err error code.

Int32 HS_HTTPLibCertPeekSerialNumber | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert,
 |  | Char ** | out_str
 | ) |

Parameters:
refnum,: IN:
in_cert,: IN:
**out_str,: IN:
Return values:
Err error code.

Int32 HS_HTTPLibCertPeekSignAlgo | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert
 | ) |

Parameters:
refnum,: IN:
in_cert,: IN:
Return values:
Err error code.

Int32 HS_HTTPLibCertPeekSubjectRDN | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert,
 |  | Char ** | out_str
 | ) |

Parameters:
refnum,: IN:
in_cert,: IN:
**out_str,: IN:
Return values:
Err error code.

Int32 HS_HTTPLibCertPeekSubjectRDNStrType | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert
 | ) |

Parameters:
refnum,: IN:
in_cert,: IN:
Return values:
Err error code.

void HS_HTTPLibCertPeekValidityEnd | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert,
 |  | HS_HTTPLibTime * | in_time
 | ) |

Parameters:
refnum,: IN:
in_cert,: IN:
*in_time,: IN:
Return values:
Err error code.

void HS_HTTPLibCertPeekValidityStart | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert,
 |  | HS_HTTPLibTime * | in_time
 | ) |

Parameters:
refnum,: IN:
in_cert,: IN:
*in_time,: IN:
Return values:
Err error code.

Int32 HS_HTTPLibCertPeekVersion | ( | UInt16 | refnum,
 |  | HS_HTTPLibCertPtr | in_cert
 | ) |

Parameters:
refnum,: IN:
in_cert,: IN:
Return values:
Err error code.

void HS_HTTPLibClearDNSCache | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH
 | ) |

This function clears the DNS cache information.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
Returns:
None.

HS_HTTPLibClientCertList HS_HTTPLibClientCertListClone | ( | UInt16 | refnum,
 |  | HS_HTTPLibClientCertList | in_list
 | ) |

TBD.

Parameters:
refnum,: IN:
in_list,: IN:
Return values:
HS_HTTPLibClientCertList

void HS_HTTPLibClientCertListDelete | ( | UInt16 | refnum,
 |  | HS_HTTPLibClientCertList | in_list
 | ) |

Parameters:
refnum,: IN:
in_list,: IN:
Return values:
nothing

Boolean HS_HTTPLibClientCertListIsValid | ( | UInt16 | refnum,
 |  | HS_HTTPLibClientCertList | in_list,
 |  | Int32 | in_index
 | ) |

TBD.

Parameters:
refnum,: IN:
in_list,: IN:
in_index,: IN:
Return values:
Boolean

Int32 HS_HTTPLibClientCertListLength | ( | UInt16 | refnum,
 |  | HS_HTTPLibClientCertList | in_list
 | ) |

TBD.

Parameters:
refnum,: IN:
in_list,: IN:
Return values:
Nothing

HS_HTTPLibClientCertList HS_HTTPLibClientCertListNew ( UInt16 refnum )

Parameters:
refnum,: IN:
Return values:
Err error code.

void HS_HTTPLibClientCertListSetValid | ( | UInt16 | refnum,
 |  | HS_HTTPLibClientCertList | in_list,
 |  | Int32 | in_index,
 |  | Boolean | in_valid
 | ) |

TBD.

Parameters:
refnum,: IN:
in_list,: IN:
in_index,: IN:
in_valid,: IN:
Return values:
Nothing

void HS_HTTPLibClientCertSelect | ( | UInt16 | refnum,
 |  | HS_HTTPLibSSL | in_ssl,
 |  | Int32 | in_index
 | ) |

This function sets the selected certification. For now, there is no corresponding function in SSL library, the callback will not be called.

Parameters:
refnum,: IN: Library reference number.
in_ssl,: IN: -
in_index,: IN: -
Returns:
None.

Err HS_HTTPLibClose | ( | UInt16 | refnum,
 |  | UInt16 * | usecountP
 | ) |

This function decrements open count and finalizes the library’s common data at the last close.

Parameters:
refnum,: IN: Library reference number
usecountP,: OUT: Open count
Returns:
Error code.

void HS_HTTPLibCloseAllKeepAlive | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH
 | ) |

This function closes the all idle keep alive sockets relating this application. Nonidle sockets are not closed by this function.

This call should be made at library finalization if keep-alive sockets are active.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
Returns:
None.

void HS_HTTPLibCookieMakeEmpty | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_flag
 | ) |

This function clears Cookies.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: The handle of HTTP library instance.
in_flag,: IN: httpCookieClearAll clear all Cookies httpCookieClearSessionCookiesOnly clear session Cookies only
Returns:
None.

void HS_HTTPLibDataHandle_Delete | ( | UInt16 | refnum,
 |  | HS_HTTPLibDataHandle | in_handle
 | ) |

Parameters:
refnum,: IN:
in_handle,: IN:
Return values:
Err error code.

Int32 HS_HTTPLibDataHandle_Length | ( | UInt16 | refnum,
 |  | HS_HTTPLibDataHandle | in_handle
 | ) |

Parameters:
refnum,: IN:
in_handle,: IN:
Return values:
Err error code.

void* HS_HTTPLibDataHandle_Lock | ( | UInt16 | refnum,
 |  | HS_HTTPLibDataHandle | in_handle
 | ) |

Parameters:
refnum,: IN:
in_handle,: IN:
Return values:
Err error code.

void HS_HTTPLibDataHandle_Unlock | ( | UInt16 | refnum,
 |  | HS_HTTPLibDataHandle | in_handle
 | ) |

Parameters:
refnum,: IN:
in_handle,: IN:
Return values:
Err error code.

void HS_HTTPLibFinalize | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH
 | ) |

This function finalizes the library instance.

This call should be made when the application is finished using the library.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
Returns:
None.

void HS_HTTPLibFindAuthCandidate | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_target,
 |  | Char * | in_url,
 |  | Int32 | in_url_len,
 |  | Char * | in_host,
 |  | Int32 | in_host_len,
 |  | Int32 | in_port,
 |  | Char * | in_realm,
 |  | Int32 | in_realm_len,
 |  | HS_HTTPLibString * | out_user,
 |  | HS_HTTPLibString * | out_pass,
 |  | Boolean * | out_keep_user,
 |  | Boolean * | out_keep_pass
 | ) |

Parameters:
refnum,: IN:
libH,: IN:
in_target,: IN:
*in_url,: IN:
in_url_len,: IN:
*in_host,: IN:
in_host_len,: IN:
in_port,: IN:
*in_realm,: IN:
in_realm_len,: IN:
*out_user,: IN:
*out_pass,: IN:
*out_keep_user,: IN:
*out_keep_pass,: IN:
libH,: IN:
Return values:
Err error code.

Boolean HS_HTTPLibFindAuthInfo | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_target,
 |  | Char * | in_url,
 |  | Int32 | in_url_len,
 |  | Char * | in_host,
 |  | Int32 | in_host_len,
 |  | Int32 | in_port,
 |  | HS_HTTPLibSplit * | in_realm,
 |  | HS_HTTPLibAuthInfo * | out_info
 | ) |

Parameters:
refnum,: IN:
libH,: IN:
in_target,: IN:
*in_url,: IN:
in_url_len,: IN:
*in_host,: IN:
in_host_len,: IN:
in_port,: IN:
*in_realm,: IN:
*out_info,: IN:
Return values:
Err error code.

void HS_HTTPLibFixedString_Delete | ( | UInt16 | refnum,
 |  | HS_HTTPLibFixedString | in_str
 | ) |

This function deletes the handle of type HS_HTTPLibFixedString.

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
nothing

Int32 HS_HTTPLibFixedString_Length | ( | UInt16 | refnum,
 |  | HS_HTTPLibFixedString | in_str
 | ) |

This function returns the length of the handle (byte).

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
Int32

void* HS_HTTPLibFixedString_Lock | ( | UInt16 | refnum,
 |  | HS_HTTPLibFixedString | in_str
 | ) |

This function locks the handle of type HS_HTTPLibFixedString.

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
void *

void HS_HTTPLibFixedString_Unlock | ( | UInt16 | refnum,
 |  | HS_HTTPLibFixedString | in_str
 | ) |

This function unlocks the handle of type HS_HTTPLibFixedString.

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
nothing

HS_HTTPLibFixedString HS_HTTPLibFixedStringNew | ( | UInt16 | refnum,
 |  | Char * | in_str,
 |  | Int32 | in_len
 | ) |

This function creates a new handle of type HS_HTTPLibFixedString.

Parameters:
refnum,: IN: Library reference number.
*in_str,: IN: The pointer to the string.
in_len,: IN: The length of in_str.
Return values:
HS_HTTPLibFixedString

Boolean HS_HTTPLibHeaderSplitByX | ( | UInt16 | refnum,
 |  | HS_HTTPLibSplit * | inout_ss,
 |  | Int32 | in_id,
 |  | Char * | in_cs
 | ) |

Parameters:
refnum,: IN:
*inout_ss,: IN:
in_id,: IN:
*in_cs,: IN:
Return values:
Err error code.

HS_HTTPLibHandle HS_HTTPLibInitialize | ( | UInt16 | refnum,
 |  | HS_HTTPLibAppInfo * | appInfoP,
 |  | HS_HTTPLibNetLibInfo * | netLibInfoP,
 |  | HS_HTTPLibPeer * | peerP
 | ) |

This function initializes the library instance and sets application dependent information in the global variables. The return value is the handle of library instance. If an error occurs during the initialization, the return value is NULL.

This call should be made after the application has called HS_HTTPLibOpen and assigned the HS_HTTPLibAppInfo, HS_HTTPLibNetLibInfo, and HS_HTTPLibPeer global variables with the application’s parameters. A reciprocal call to HS_HTTPLibFinalize should be made when the application is finished using the library.

Parameters:
refnum,: IN: Library reference number
*appInfoP,: IN:
*netLibInfoP,: IN:
*peerP,: IN:
Return values:
HS_HTTPLibHandle non NULL if successful. NULL if failed

Boolean HS_HTTPLibIsHTTP11OverProxy | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH
 | ) |

This function returns whether this application permits HTTP/1.1 over proxy.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
Returns:
True if this application permits HTTP/1.1 over proxy. False if this application does not permit HTTP/1.1 over proxy.

Boolean HS_HTTPLibIsSendCookie | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH
 | ) |

This function returns whether this application sends Cookie.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
Returns:
True if this application sends Cookie. False if this application does not send Cookie.

Boolean HS_HTTPLibIsSendReferer | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH
 | ) |

Parameters:
refnum,: IN:
libH,: IN:
Return values:
Err error code.

Boolean HS_HTTPLibIsUseProxy | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH
 | ) |

This function returns whether this application uses proxy.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
Returns:
True if this application uses proxy. False if this application does not uses proxy.

Boolean HS_HTTPLibLoadCookiesEntries | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Char * | in_s,
 |  | Int32 | in_slen
 | ) |

Parameters:
refnum,: IN:
libH,: IN:
*in_s,: IN:
in_slen,: IN:
Return values:
Err error code.

Boolean HS_HTTPLibMakeAuthInfo | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_target,
 |  | Char * | in_url,
 |  | Int32 | in_url_len,
 |  | Char * | in_host,
 |  | Int32 | in_host_len,
 |  | Int32 | in_port,
 |  | HS_HTTPLibSplit * | in_realm,
 |  | HS_HTTPLibAuthInfo * | out_info
 | ) |

This function returns the authentication information to the out_info. Before calling this API, the application should intialize HS_HTTPLibAuthInfo by HS_HTTPLibAuthInfoTidy(out_info, true).

After using the authentication information, the application should finalize HS_HTTPLibAuthInfoTidy by HS_HTTPLibAuthInfoTidy(out_info, false).

Parameters:
refnum,: IN: Library reference number.
libH,: IN: The handle of HTTP library instance.
in_target,: IN: The authentication target. httpAuthTargetPage Authentication Information for Page httpAuthTargetProxy Authentication Information for Proxy
*in_url,: IN: The pointer to the URL (httpAuthTargetPage only).
in_url_len,: IN: The length of in_url.
*in_host,: IN: The pointer to the proxy host name (httpAuthTargetProxy only).
in_host_len,: IN: The length of in_host.
in_port,: IN: The port of proxy (httpAuthTargetProxy only).
*in_realm,: IN: The realm.
*out_info,: OUT: The pointer to the authentication information.
Returns:
True if setting successful. False if failed (no information in cache or memory shortage).

HS_HTTPLibCertList HS_HTTPLibMakeCertList | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |

This function returns the Server certification used for SSL. The responsibility to delete the return handle is the application. To delete the return value, the application should use HS_HTTPLibCertListDelete.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
Returns:
The handle of SSL server certification chain. NULL if no server certification or memory shortage.

HS_HTTPLibString HS_HTTPLibMakeCookiesString | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Char * | in_url,
 |  | Int32 | in_urllen,
 |  | Boolean | in_secure,
 |  | Int32 * | out_len
 | ) |

Parameters:
refnum,: IN:
libH,: IN:
*in_url,: IN:
in_urllen,: IN:
in_secure,: IN:
*out_len,: IN:
Return values:
Err error code.

void HS_HTTPLibMakeProxy | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | HS_HTTPLibFixedString * | out_proxy_host,
 |  | Int32 * | out_proxy_http_port,
 |  | Int32 * | out_proxy_https_port,
 |  | HS_HTTPLibString * | out_no_proxy_hosts
 | ) |

Set the proxy information of this application to out_proxy_host, out_proxy_http_port, out_proxy_https_port, out_no_proxy_hosts. If out_proxy_host is NULL, the value of *out_proxy_http_port, *out_proxy_https_port, *out_no_proxy_hosts are not set, otherwise the values of *out_proxy_http_port, *out_proxy_https are set. If out_no_proxy_hosts is NULL, *out_no_proxy_hosts is not set. The format of out_no_proxy_hosts is the list separated by “,”. The responsibility of delete *out_proxy_host, *out_no_proxy_hosts is caller.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
*out_proxy_host,: OUT: The pointer to handle of proxy host string
*out_proxy_http_port,: OUT: The pointer to HTTP port number
*out_proxy_https_port,: OUT: The pointer to HTTPS port number
*out_no_proxy_hosts,: OUT: The pointer to handle of the list string of hosts connect without using proxy server.
Returns:
None.

Err HS_HTTPLibOpen ( UInt16 refnum )

This function opens the HTTP library and increments the open count. This function will create and initialize the library’s common data at first opening.

Parameters:
refnum,: IN: Library reference number
Returns:
Error code.

UInt16 HS_HTTPLibOpenCount ( UInt16 refnum )

This function returns the open count of this library.

Parameters:
refnum,: IN: Library reference number
Returns:
Open count.

void HS_HTTPLibRegisterSSLClass | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | HS_HTTPLibSSLClassPtr | sslClassP
 | ) |

Parameters:
refnum,: IN:
libH,: IN:
sslClassP,: IN:
Return values:
Err error code.

HS_HTTPLibString HS_HTTPLibSaveCookiesEntries | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 * | out_len
 | ) |

Parameters:
refnum,: IN:
libH,: IN:
*out_len,: IN:
Return values:
Err error code.

void HS_HTTPLibServerCertConfirm | ( | UInt16 | refnum,
 |  | HS_HTTPLibSSL | in_ssl,
 |  | Int32 | in_verify_result,
 |  | Boolean | in_confirm
 | ) |

This function sets the result of confirmation. This function should be called in the callback function.

Parameters:
refnum,: IN: Library reference number.
in_ssl,: IN: -
in_verify_result,: IN: -
in_confirm,: IN: -
Returns:
None.

void HS_HTTPLibSetConnectTimeOut | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_msec
 | ) |

This function sets the limit of Connection timeout. If in_msec is -1, no timeout is set. The condition of timeout is in_msec has passed from TCP connect without HTTP connection established.

With this function the different connection timeouts can be set at library initialization.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
in_msec,: IN: Time Limit (msec)
Return values:
Nothing

Int32 HS_HTTPLibSetCookie | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | HS_HTTPLibURLString | in_url,
 |  | Char * | in_header,
 |  | Int32 | in_header_len
 | ) |

This function sets the Cookie abiding with the confirmation mode set by HS_HTTPLibSetCookieMode. The application should not use this API in callback function. The API HS_HTTPLibSetCookieX is designed for use in callback.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: The handle of HTTP library instance.
in_url,: IN: The handle of URL.
*in_header,: IN: The pointer to the header string.
in_header_len,: IN: The length of in_header.
Returns:
httpErrorOK Cookie is set. httpErrorNoMem memory shortage httpErrorInval failed by other reason

void HS_HTTPLibSetCookieMax | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_max_total_cookies,
 |  | Int32 | in_max_cookies_per_domain,
 |  | Int32 | in_max_len_per_cookie
 | ) |

This function sets the max size of Cookie entries.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: The handle of HTTP library instance.
in_max_total_cookies,: IN: The size of max Cookie entries.
in_max_cookies_per_domain,: IN: The size of Cookie entries per one domain.
in_max_len_per_cookie,: IN: The max size of one Cookie.
Returns:
None.

void HS_HTTPLibSetCookieMode | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_mode,
 |  | HS_HTTPLibCookieConfirmProc | in_cb,
 |  | HS_HTTPLibOpaque | in_opaque
 | ) |

This function sets the Cookie mode.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: The handle of HTTP library instance.
in_mode,: IN: The mode of receiving Cookie. httpCookieNotifyBeforeSet Confirm before Cookie set httpCookieAlwaysSet Cookie is always set httpCookieNeverSet Cookie is not set
in_cb,: IN: The confirm callback function.
in_opaque,:,: IN: The opaque which is given to the callback function.
Returns:
None.

Int32 HS_HTTPLibSetCookieX | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | HS_HTTPLibURLString | in_url,
 |  | Char * | in_header,
 |  | Int32 | in_header_len
 | ) |

This function sets the Cookie. This function is designed for callback confirm function.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: The handle of HTTP library instance.
in_url,: IN: The handle of URL.
*in_header,: IN: The pointer to the header string.
in_header_len,: IN: The length of in_header.
Returns:
httpErrorOK Cookie is set. httpErrorNoMem memory shortage httpErrorInval failed by other reason

Boolean HS_HTTPLibSetDefaultHeaders | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Char * | in_default_headers,
 |  | Int32 | in_default_headers_len
 | ) |

This function sets the default header, i.e. this string is added to the Request-header of the Request created at HS_HTTPLibStreamCreateRequest. If in_default_headers is NULL, the setting is cleared.

This call allows the application to set the application defined standard headers without having the populate each request with HS_HTTPLibStreamAddHeader.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
*in_default_headers,: IN: The string of default header
in_default_headers_len,: IN: The length of in_default_headers
Returns:
True if setting is successful. False if failed. (The main reason is memory shortage.)

void HS_HTTPLibSetDNSMaxRetry | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_retry
 | ) |

Parameters:
refnum,: IN:
libH,: IN:
in_retry,: IN:
Return values:
Err error code.

void HS_HTTPLibSetDNSRetryInterval | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_interval
 | ) |

Parameters:
refnum,: IN:
libH,: IN:
in_interval,: IN:
Return values:
Err error code.

void HS_HTTPLibSetHTTP11OverProxy | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Boolean | in_bool
 | ) |

This function sets whether this application permits HTTP1.1 over proxy server. If false is set, the application use HTTP/1.0.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
in_bool,: IN: True if permitting HTTP/1.1 over proxy server False if not permitting HTTP/1.1 over proxy server
Returns:
None.

void HS_HTTPLibSetHTTPPort | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_port
 | ) |

This function sets the default HTTP port number. If there is no indication in URL, this port number is used for TCP connection.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
in_port,: IN: The HTTP port number
Returns:
None.

void HS_HTTPLibSetHTTPSPort | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_port
 | ) |

This function sets the default HTTPS port number. If there is no indication in https URL, this port number is used for TCP connection.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
in_port,: IN: The HTTPS port number
Returns:
None.

void HS_HTTPLibSetMaxKeepAliveTimeout | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_msec
 | ) |

Parameters:
refnum,: IN:
libH,: IN:
in_msec,:,: IN:
Return values:
Err error code.

void HS_HTTPLibSetMaxRequestBody | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_size
 | ) |

This function sets the maximal size of Request-Body. If in_size is -1, the maximal size is unlimited.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
in_size,: IN: The maximal size (byte)
Returns:
None.

void HS_HTTPLibSetMaxRequestHeader | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_size
 | ) |

This function sets the maximal size of Request-Line. If in_size is -1, the maximal size is unlimited. Note that this function does not set the maximal size of Request- Header. See RFC2616 for the definitions of Request-Line and Request-Header.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
in_size,: IN: The maximal size (byte)
Returns:
None.

void HS_HTTPLibSetNetLibProc | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | UInt16 | netLibRefnum,
 |  | HS_HTTPLibNetLibOpenProc | in_open,
 |  | HS_HTTPLibNetLibCloseProc | in_close,
 |  | HS_HTTPLibNetLibOnlineProc | in_online,
 |  | HS_HTTPLibNetLibOfflineProc | in_offline
 | ) |

This function sets the callback functions concerning NetLib. But for now, there is no call to callback functions from Peer layer.

Parameters:
refnum,: IN: Library reference number.
libH,: IN:
netLibRefnum,: IN:
in_open,: IN:
in_close,: IN:
in_online,: IN:
in_offline,: IN:
Returns:
None.

Boolean HS_HTTPLibSetProxy | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Char * | in_proxy_host,
 |  | Int32 | in_proxy_host_len,
 |  | Int32 | in_proxy_http_port,
 |  | Int32 | in_proxy_https_port,
 |  | Char * | in_no_proxy_hosts,
 |  | Int32 | in_no_proxy_hosts_len
 | ) |

This function sets the proxy server setting for this application. If in_proxy_host is NULL, in_proxy_host, in_proxy_http_port, in_proxy_https_port are not set. If in_no_proxy_hosts is NULL, in_no_proxy_hosts is not set. The format of in_no_proxy_hosts is comma (“,”) separated list.

This call can be grouped with other proxy setting calls if the application is making the same type of request for all the requests.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
*in_proxy_host,: IN: The proxy host name
in_proxy_host_len,: IN: The length of in_proxy_host string
in_proxy_http_port,: IN: The HTTP port of proxy server
in_proxy_https_port,: IN: The HTTPS port of proxy server
*in_no_proxy_hosts,: IN: The list of hosts not using proxy
in_no_proxy_hosts_len,: IN: The length of in_no_proxy_hosts
Returns:
True if setting is succeed. False if failed.(the main reason is memory shortage)

void HS_HTTPLibSetReqTimeOut | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_msec
 | ) |

This function sets the limit of sending Request timeout. If in_msec is -1, no timeout is set. The condition of timeout is in_msec has passed from the start of Request sending without sending done.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
in_msec,: IN: Time Limit (msec)
Returns:
None.

void HS_HTTPLibSetRspTimeOut | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_msec
 | ) |

This function sets the limit of receiving Response timeout. If in_msec is -1, no timeout is set. The condition of timeout is in_msec has passed from the end of sending request without receiving Response. Or in_msec has passed from the last receiving a part of Response without receiving any part of Response.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
in_msec,: IN: Time Limit (msec)
Return values:
Nothing

void HS_HTTPLibSetSendCookie | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Boolean | in_bool
 | ) |

This function sets whether this application sends Cookie.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
in_bool,: IN: True if sending Cookie False if not sending Cookie
Returns:
None.

void HS_HTTPLibSetSendProxyKeepAlive | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Boolean | in_bool
 | ) |

Parameters:
refnum,: IN:
libH,: IN:
in_bool,: IN:
Return values:
Err error code.

void HS_HTTPLibSetSendReferer | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Boolean | in_bool
 | ) |

Parameters:
refnum,: IN:
libH,: IN:
in_bool,: IN:
Return values:
Err error code.

void HS_HTTPLibSetSSLClientCertSelectProc | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | HS_HTTPLibClientCertSelectProc | in_cb,
 |  | HS_HTTPLibOpaque | in_opaque
 | ) |

This function sets the client certification select callback function.For now, there is no corresponding function in SSL library, the callback will not be called.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: -
in_cb,: IN: -
in_opaque,: IN: -
Returns:
None.

void HS_HTTPLibSetSSLServerCertConfirmProc | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | HS_HTTPLibServerCertConfirmProc | in_cb,
 |  | HS_HTTPLibOpaque | in_opaque
 | ) |

This function sets the server certificate callback function for this application.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: -
in_cb,: IN: -
in_opaque,: IN: -
Returns:
Nothing

void HS_HTTPLibSetSSLVersionFlag | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_flag,
 |  | Boolean | in_on
 | ) |

Set the SSL version.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: The handle of HTTP library instance.
in_flag,: IN: -
in_on,: IN: -
Returns:
None.

void HS_HTTPLibSetTunnelingCallback | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | HS_HTTPLibTunnelingCallbackProc | in_cb,
 |  | void * | in_aux
 | ) |

Parameters:
refnum,: IN:
libH,: IN:
in_cb,: IN:
*in_aux,: IN:
Return values:
Err error code.

void HS_HTTPLibSetUseProxy | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Boolean | in_bool
 | ) |

This function sets whether this application uses proxy server.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
in_bool,: IN: True if using proxy server. False if not using proxy server.
Returns:
None.

Boolean HS_HTTPLibSetUserAgent | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Char * | in_useragent,
 |  | Int32 | in_useragent_len
 | ) |

This function sets the UserAgent string for the application. If in_useragent is NULL, setting is cleared.

This call allows the application to set the user agent identfication in the requests.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
*in_useragent,: IN: The string of User Agent
in_useragent_len,: IN: The length of in_useragent
Returns:
True if setting is successful. False if failed.(The main reason is memory shortage.)

Boolean HS_HTTPLibSetUseragentSelectionRule | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | HttpUASelectionRule * | rules,
 |  | Int32 | len
 | ) |

Parameters:
refnum,: IN:
libH,: IN:
*rules,: IN:
len,: IN:
Return values:
Err error code.

Boolean HS_HTTPLibSetUserPass | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_type,
 |  | Int32 | in_target,
 |  | HS_HTTPLibSplit * | in_challenge,
 |  | HS_HTTPLibSplit * | in_realm,
 |  | Char * | in_user,
 |  | Int32 | in_user_len,
 |  | Char * | in_pass,
 |  | Int32 | in_pass_len,
 |  | Char * | in_url,
 |  | Int32 | in_url_len,
 |  | Char * | in_host,
 |  | Int32 | in_host_len,
 |  | Int32 | in_port
 | ) |

This function sets the authentication information.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: The handle of HTTP library instance.
in_type,: IN: The authentication type. httpAuthTypeBasic Basic authentication httpAuthTypeDigest Digest Authentication
in_target,: IN: The authentication target. httpAuthTargetPage Authentication Information for Page httpAuthTargetProxy Authentication Information for Proxy
*in_challenge,: IN: The challenge.
*in_realm,: IN: The realm.
*in_user,: IN: The pointer to the User ID.
in_user_len,: IN: The length of in_user.
*in_pass,: IN: The pointer to the Password.
in_pass_len,: IN: The length of in_pass.
*in_url,: IN: The pointer to the URL (httpAuthTargetPage only).
in_url_len,: IN: The length of in_url.
*in_host,: IN: The pointer to the proxy host name (httpAuthTargetProxy only).
in_host_len,: IN: The length of in_host.
in_port,: IN: The port of proxy (httpAuthTargetProxy only).
Returns:
True if setting successful. False if failed (memory shortage).

Boolean HS_HTTPLibSetUserPassX | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | Int32 | in_type,
 |  | Int32 | in_target,
 |  | HS_HTTPLibSplit * | in_challenge,
 |  | HS_HTTPLibSplit * | in_realm,
 |  | Char * | in_user,
 |  | Int32 | in_user_len,
 |  | Char * | in_pass,
 |  | Int32 | in_pass_len,
 |  | Char * | in_url,
 |  | Int32 | in_url_len,
 |  | Char * | in_host,
 |  | Int32 | in_host_len,
 |  | Int32 | in_port,
 |  | Boolean | in_keep_user,
 |  | Boolean | in_keep_pass
 | ) |

Parameters:
refnum,: IN:
libH,: IN:
in_type,: IN:
in_target,: IN:
*in_challenge,: IN:
*in_realm,: IN:
*in_user,: IN:
in_user_len,: IN:
*in_pass,: IN:
in_pass_len,: IN:
*in_url,: IN:
in_url_len,: IN:
*in_host,: IN:
in_host_len,: IN:
in_port,: IN:
in_keep_user,: IN:
in_keep_pass,: IN:
Return values:
Err error code.

void HS_HTTPLibSetWakeUpCallback | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | HS_HTTPLibWakeUpCallbackProc | in_proc,
 |  | HS_HTTPLibOpaque | in_opaque
 | ) |

Parameters:
refnum,: IN:
libH,: IN:
in_proc,: IN:
in_opaque,: IN:
Return values:
Err error code.

Err HS_HTTPLibSleep ( UInt16 refnum )

Standard library sleep function.

Parameters:
refnum,: IN: Library reference number
Returns:
Error code.

HS_HTTPLibSSLClassPtr HS_HTTPLibSSLClass | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH
 | ) |

Parameters:
refnum,: IN:
libH,: IN:
Return values:
Err error code.

void HS_HTTPLibSSLCloseCertDB | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH
 | ) |

TBD.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: The handle of HTTP library instance.
Returns:
None.

Int32 HS_HTTPLibSSLOpenCertDB | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH,
 |  | HS_HTTPLibCertList * | out_list
 | ) |

TBD.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: The handle of HTTP library instance.
*out_list,: OUT: -
Return values:
Int32

Int32 HS_HTTPLibSSLTimeout | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH
 | ) |

Set the timeout period for SSL use.

Parameters:
refnum,: IN: Library reference number.
libH,: IN: The handle of HTTP library instance.
Returns:
Timeout.

Boolean HS_HTTPLibStreamAddHeader | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Int32 | in_type,
 |  | Char * | in_str,
 |  | Int32 | in_len
 | ) |

This function sets the value of corresponding header. If there is already the same kind of header line, old one is deleted.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
in_type,: IN: The type of header (See httpHeaderIDEnum).
*in_str,: IN: The pointer to the header value string.
in_len,: IN: The length of in_str.
Returns:
True if successful False failed (memory shortage)

Boolean HS_HTTPLibStreamAddHeaderLine | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Char * | in_str,
 |  | Int32 | in_len
 | ) |

This function adds the line to the Request header. If there is already the same kind of header line, old one is deleted.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
*in_str,: IN: The pointer to the header strong to add.
in_len,: IN: The length of in_str.
Returns:
True if successful. False failed (memory shortage)

void HS_HTTPLibStreamClose | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |

This function closes the HTTP stream. If the TCP/SSL socket is in keep-alive, it is not closed.

Parameters:
refnum,: IN: Library reference number
stream,: IN: The handle of stream instance.
Returns:
None.

Int32 HS_HTTPLibStreamCreateRequest | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Int32 | in_method,
 |  | Char * | in_url,
 |  | UInt32 | in_url_len,
 |  | Char * | in_header,
 |  | UInt32 | in_header_len,
 |  | Char * | in_referer,
 |  | UInt32 | in_referer_len,
 |  | Int32 | in_version,
 |  | Boolean | in_no_cache,
 |  | Boolean | in_pipeline,
 |  | Int32 | in_ssl_flag
 | ) |

This function creates a request. If using proxy and SSL connection, CONNECT request message is made. If there are cached authenticate informations, add authenticate header. Add default headers and in_header to Request-Header.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
in_method,: IN: The HTTP method httpMethodGET GET httpMethodPOST POST
*in_url,: IN: The URL string.
in_url_len,: IN: The length of in_url.
*in_header,: IN: The header string to add the Request-Header. Each line is terminated by <CR><LF>.
in_header_len,: IN: The length of in_header.
*in_referer,: IN: The referer string.
in_referer_len,: IN: The length of in_referer.
in_version,: IN: The version httpVersion_0_9 HTTP/0.9 httpVersion_1_0 HTTP/1.0 httpVersion_1_1 HTTP/1.1
in_no_cache,: IN: True if no-cache is added to the header False if no-cache is not added to the header
in_pipeline,: IN: True if doing pipeline False if not doing pipeline
in_ssl_flag,: IN: The flag sent to SSL instance. httpSSLFlagConnV2 connect by v2 protocol httpSSLFlagConnV3 connect by v3 protocol httpSSLFlagConnTLS connect by TLS(v3.1) protocol httpSSLFlagConnV2V3 autoselect within v2,v3 httpSSLFlagConnV2TLS autoselect within v2,tls httpSSLFlagConnV3TLS autoselect within v3,tls httpSSLFlagConnV2V3TLS autoselect within v2,v3,tls
Returns:
httpErrorOK succeed httpErrorNoMem memory shortage httpErrorReqHeaderSizeOver if Request header size is over the maximal setting. If the Request-Line size is set to unlimited, httpErrorReqHeaderSizeOver is not returned.

Int32 HS_HTTPLibStreamCreateRequestWithChunkEncoding | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Int32 | in_method,
 |  | Char * | in_url,
 |  | UInt32 | in_url_len,
 |  | Char * | in_header,
 |  | UInt32 | in_header_len,
 |  | Char * | in_referer,
 |  | UInt32 | in_referer_len,
 |  | Int32 | in_version,
 |  | Boolean | in_no_cache,
 |  | Boolean | in_pipeline,
 |  | Int32 | in_ssl_flag
 | ) |

This function creates request for chunk-encoding post. If using proxy and SSL connection, CONNECT request message is made. If there are cached authenticate informations, add authenticate header. Add default headers and in_header to Request-Header. Do not use this API unless you want to create chunk-encoding request. Transfer- Encoding: chunked is added to the request header.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
in_method,: IN: The HTTP method httpMethodGET GET httpMethodPOST POST
*in_url,: IN: The URL string.
in_url_len,: IN: The length of in_url.
*in_header,: IN: The header string to add the Request-Header. Each line is terminated by <CR><LF>.
in_header_len,: IN: The length of in_header.
*in_referer,: IN: The referer string.
in_referer_len,: IN: The length of in_referer.
in_version,: IN: The version httpVersion_0_9 HTTP/0.9 httpVersion_1_0 HTTP/1.0 httpVersion_1_1 HTTP/1.1
in_no_cache,: IN: True if no-cache is added to the header False if no-cache is not added to the header
in_pipeline,: IN: True if doing pipeline False if not doing pipeline
in_ssl_flag,: IN: The flag sent to SSL instance. httpSSLFlagConnV2 connect by v2 protocol httpSSLFlagConnV3 connect by v3 protocol httpSSLFlagConnTLS connect by TLS(v3.1) protocol httpSSLFlagConnV2V3 autoselect within v2,v3 httpSSLFlagConnV2TLS autoselect within v2,tls httpSSLFlagConnV3TLS autoselect within v3,tls httpSSLFlagConnV2V3TLS autoselect within v2,v3,tls
Returns:
httpErrorOK succeed httpErrorNoMem memory shortage httpErrorReqHeaderSizeOver if the Request header size is over the maximal setting. If the Request-Line size is set to unlimited, httpErrorReqHeaderSizeOver is not returned.

void HS_HTTPLibStreamDelete | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |

This function deletes the stream instance. If this function is called without calling HS_HTTPLibStreamClose, this function closes the TCP/SSL socket by calling HS_HTTPLibStreamClose, however if the socket is in keep-alive, it is not closed.

Parameters:
refnum,: IN: Library reference number
stream,: IN: The handle of stream instance.
Returns:
None.

Int32 HS_HTTPLibStreamGetContentLength | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |

This function returns the content’s size (byte).

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
Returns:
The Content-Length (byte) -1 if not received

Int32 HS_HTTPLibStreamGetEntityLength | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |

This function returns the size of response body (byte).

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
Returns:
The size of response body (byte) -1 if not received

Int32 HS_HTTPLibStreamGetFlag | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |

Parameters:
refnum,: IN:
stream,: IN:
Return values:
Err error code.

Boolean HS_HTTPLibStreamGetHeader | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Int32 | in_type,
 |  | Int32 * | out_off,
 |  | Int32 * | out_len
 | ) |

This function returns the offset and length of corresponding header value.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
in_type,: IN: The type of header (See httpHeaderIDEnum).
*out_off,: IN: The offset to the header value.
*out_len,: IN: The length of corresponding header value.
Returns:
True if successful False there is no corresponding header

Boolean HS_HTTPLibStreamGetHeaderWithOffset | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Int32 | in_type,
 |  | Int32 | in_ofs,
 |  | Int32 * | out_off,
 |  | Int32 * | out_len
 | ) |

Parameters:
refnum,: IN:
stream,: IN:
in_type IN:
in_ofs,: IN:
*out_off,: IN:
*out_len,: IN:
Return values:
Err error code.

void HS_HTTPLibStreamGetRequestSent | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Int32 * | out_total,
 |  | Int32 * | out_sent
 | ) |

Parameters:
refnum,: IN:
stream,: IN:
*out_total,: IN:
*out_sent,: IN:
Return values:
Err error code.

HS_HTTPLibVHandle HS_HTTPLibStreamGetResponseHeader | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |

This function returns the handle of the response header. The responsibility to delete the handle is library, the application can not delete this return value. To lock/unlock the handle, the application should use the APIs,.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
Returns:
non NULL the handle of header NULL if not received

Int32 HS_HTTPLibStreamGetResponseHeaderLength | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |

This function returns the size of the response header.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
Returns:
header size (byte) -1 if not received

Int32 HS_HTTPLibStreamGetScheme | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |

This function returns the scheme given at the HS_HTTPLibStreamCreateRequest.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
Returns:
httpSchemeHTTP HTTP httpSchemeHTTPS HTTPS

Int32 HS_HTTPLibStreamGetState | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |

This function returns the state of the stream. The state changes follow the below sequence (but skipping the states that are not relevant to the current request).

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
Returns:
httpStreamStateNew The instance is created httpStreamStateDormant The instance is dormant httpStreamStateReqCreated The request is created httpStreamStateReqResolve Name resolve begins httpStreamStateReqResolving Name resolving httpStreamStateReqOpen TCP/SSL open httpStreamStateReqConnect TCP connect begins httpStreamStateReqConnecting TCP connecting httpStreamStateReqProxyConnect Proxy Tunneling begins httpStreamStateReqProxyConnecting Proxy Tunneling httpStreamStateReqSSLHandShaking SSL HandShaking httpStreamStateReqSSLHandShaked SSL handShake done httpStreamStateReqSending Sending the request httpStreamStateReqSent Sending the request done httpStreamStateRspHeaderWaiting Waiting the response header httpStreamStateRspContinue Waiting response receiving done for Status-Code 100 httpStreamStateRspHeaderReceiving Receiving the response header httpStreamStateRspHeaderReceived Receiving the response header done httpStreamStateRspEntityReceiving Receiving the response body

Int32 HS_HTTPLibStreamGetStatusCode | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |

This function returns the Status Code.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
Returns:
httpStatusCodeContinue 100 httpStatusCodeSwitchingProtocols 101 httpStatusCodeOK 200 httpStatusCodeCreated 201 httpStatusCodeAccepted 202 httpStatusCodeNonAuthoritativeInformation 203 httpStatusCodeNoContent 204 httpStatusCodeResetContent 205 httpStatusCodePartialContent 206 httpStatusCodeMultipleChoices 300 httpStatusCodeMovedPermanently 301 httpStatusCodeFound 302 httpStatusCodeSeeOther 303 httpStatusCodeNotModified 304 httpStatusCodeUseProxy 305 httpStatusCodeTemporaryRedirect 307 httpStatusCodeBadRequest 400

Boolean HS_HTTPLibStreamIsHeaderReceived | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |

This function returns whether the response header is completely received.

This function is typically called after HS_HTTPLibStreamReceiveResponse when receiving the response header.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
Returns:
True if header is completely received. False if header is not received.

HS_HTTPLibStream HS_HTTPLibStreamNew | ( | UInt16 | refnum,
 |  | HS_HTTPLibHandle | libH
 | ) |

This function creates a new stream and returns the handle of stream instance. At this time, TCP/SSL socket is not opened.

Parameters:
refnum,: IN: Library reference number
libH,: IN: The handle of HTTP library instance
Returns:
non NULL if successful. NULL if failed (the main reason is memory shortage).

Int32 HS_HTTPLibStreamReceiveResponse | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Char * | out_buf,
 |  | Int32 | in_len,
 |  | Int32 * | out_len,
 |  | Int32 * | out_sleep
 | ) |

This function receives response. It automatically retries at where pipeline stalled if pipeline is enable.

Because the data streaming could block and resume at where the pipeline was stalled, the application can call this function in a loop until the receiving is finished.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
*out_buf,: OUT: The pointer to the receive buffer.
in_len,: IN: The size of the receive buffer (byte).
*out_len,: OUT: The received size (byte).
*out_sleep,: OUT: The time of the application can sleep (msec) This value is not used for application.
Returns:
httpErrorOK receiving done httpErrorWouldBlock application can call this function consecutively httpErrorIOSleep application can sleep httpErrorNoMem memory shortage httpErrorTCPRead cannot read TCP httpErrorTCPWrite cannot write TCP httpErrorSSLHandShake cannot SSL handshake httpErrorSSLRead cannot read SSL httpErrorSSLWrite cannot write SSL httpErrorReqTimedout request timeout httpErrorRspTimedout response timeout httpErrorAuthUnknown unknown authentication type httpErrorAuthNoHeader authentication request without authentication header httpErrorAuthFormat wrong format of authentication header httpErrorRedirectFormat wrong format of redirect header httpErrorRedirectCanceled redirect is canceled by user httpErrorRspHeaderSizeOver size over of response header httpErrorReqTooManyContinue it exceeds the limit times of Continue

void HS_HTTPLibStreamResumeTimer | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |

Parameters:
refnum,: IN:
stream,: IN:
Return values:
Err error code.

Int32 HS_HTTPLibStreamSendRequest | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Int32 * | out_sleep
 | ) |

This function sends the request. This call opens and connects a TCP connection if not already established. It automatically retries at where pipeline stalled if pipeline is enable.

Because the data streaming could block and resume at where the pipeline was stalled, the application can call this function in a loop until the sending is finished.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
*out_sleep,: OUT: The time of the application can sleep (msec). This value is not used for application.
Returns:
httpErrorOK sending done httpErrorWouldBlock application can call this function consecutively httpErrorIOSleep application can sleep httpErrorNoMem memory shortage httpErrorDNSInval DNS message invalid httpErrorDNSNoServer DNS server is not found httpErrorDNSTimedout Timeout at DNS resolve httpErrorDNSNotFound DNS server can not find the name httpErrorTCPOpen cannot open TCP httpErrorTCPConnec cannot connect TCP httpErrorTCPRead cannot read TCP httpErrorTCPWrite cannot write TCP httpErrorSSLConnect cannot Proxy Tunneling httpErrorSSLHandShake cannot SSL handshake httpErrorSSLRead cannot SSL read httpErrorSSLWrite cannot SSL write httpErrorReqTimedout request timeout httpErrorRspTimedout response timeout at Proxy Tunneling (SSL only)

Int32 HS_HTTPLibStreamSendRequestWithChunkEncoding | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Char * | in_buf,
 |  | Int32 | in_offset,
 |  | Int32 | in_len,
 |  | Boolean | isFinish,
 |  | Int32 * | out_len,
 |  | Int32 * | out_sleep
 | ) |

This function sends chunk encoding data. This call opens and connects a TCP connection if not already established. It automatically retries at where pipeline stalled if pipeline is enable. The sequence of chunked data sending is 1. call HS_HTTPLibStreamCreateRequestWithChunkEncoding() 2. call HS_HTTPLibStreamSendRequestWithChunkEncoding() while return value is not httpErrorOK or error. 3. If there remains data, goto 2. 4. end If only one chunked data is sent, this API returns httpErrorOK. The address of data for one chunk is in_buf + in_offset, this value should not be changed while sending only one chunked data. isFinish is used to indicate the chunked data is the last chunk.

Parameters:
refnum,: IN: Library reference number
stream,: IN: The handle of stream instance.
*in_buf,: IN: The pointer to POST data.
in_offset,: IN: The offset to POST data.
in_len,: IN: The length of in_buf.
isFinish,: IN: True if the send data is the last chunk. False if send data is not the last chunk.
*out_len,: OUT: The size of sending data at this time (byte).
*out_sleep,: OUT: The time of the application can sleep (msec) This value is not used for application.
Returns:
httpErrorOK sending done httpErrorWouldBlock application can call this function consecutively httpErrorIOSleep application can sleep httpErrorNoMem memory shortage httpErrorDNSInval DNS message invalid httpErrorDNSNoServer DNS server is not found httpErrorDNSTimedout Timeout at DNS resolve httpErrorDNSNotFound DNS server can not find the name httpErrorTCPOpen cannot open TCP httpErrorTCPConnec cannot connect TCP httpErrorTCPRead cannot read TCP httpErrorTCPWrite cannot write TCP httpErrorSSLConnect cannot Proxy Tunneling httpErrorSSLHandShake cannot SSL handshake httpErrorSSLRead cannot read SSL httpErrorSSLWrite cannot write SSL httpErrorReqTimedout request timeout httpErrorRspTimedout response timeout at Proxy Tunneling (SSL only)

Int32 HS_HTTPLibStreamSendRequestWithPostData | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Char * | in_buf,
 |  | Int32 | in_len,
 |  | Int32 * | out_len,
 |  | Int32 * | out_sleep
 | ) |

This function sends the POST request. This call opens and connects a TCP connection if not already established. It automatically retries at where pipeline stalled if pipeline is enable.

Because the data streaming could block and resume at where the pipeline was stalled, the application can call this function in a loop until the sending is finished.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
*in_buf,: IN: The pointer to POST data.
in_len,: IN: The length of in_buf.
*out_len,: OUT: The size of sending data at this time (byte).
*out_sleep,: OUT: The time of the application can sleep (msec) This value is not used for application.
Returns:
httpErrorOK sending done httpErrorWouldBlock application can call this function consecutively httpErrorIOSleep application can sleep httpErrorNoMem memory shortage httpErrorDNSInval DNS message invalid

Int32 HS_HTTPLibStreamSetPostData | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream,
 |  | Int32 | in_encoding,
 |  | Char * | in_data,
 |  | Int32 | in_len
 | ) |

This function sets the POST data.

Parameters:
refnum,: IN: Library reference number.
stream,: IN: The handle of stream instance.
in_encoding,: IN: The type of encoding. httpPostURLENCODED URL encoding httpPostPLAINTEXT plain text (non encoding) httpPostMULTIPART multi-part encoding
*in_data,: IN: The pointer to the POST data.
in_len,: IN: The length of in_data.
Returns:
httpErrorOK setting done httpErrorNoMem memory shortage httpErrorReqBodySizeOver the size of request body exceeds limit. If the application does not set the limit by HS_HTTPLibSetMaxRequestBody, httpErrorReqBodySizeOver is not returned.

void HS_HTTPLibStreamSuspendTimer | ( | UInt16 | refnum,
 |  | HS_HTTPLibStream | stream
 | ) |

Parameters:
refnum,: IN:
stream,: IN:
Return values:
Err error code.

void HS_HTTPLibString_Delete | ( | UInt16 | refnum,
 |  | HS_HTTPLibString | in_str
 | ) |

This function deletes the handle of type HS_HTTPLibString.

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
Nothing

Int32 HS_HTTPLibString_Length | ( | UInt16 | refnum,
 |  | HS_HTTPLibString | in_str
 | ) |

This function returns the length of the handle (byte).

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
Int32

void* HS_HTTPLibString_Lock | ( | UInt16 | refnum,
 |  | HS_HTTPLibString | in_str
 | ) |

This function locks the handle of type HS_HTTPLibString.

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
void *

void HS_HTTPLibString_Unlock | ( | UInt16 | refnum,
 |  | HS_HTTPLibString | in_str
 | ) |

This function unlocks the handle of type HS_HTTPLibString.

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
Nothing

HS_HTTPLibString HS_HTTPLibStringNew | ( | UInt16 | refnum,
 |  | Char * | in_str,
 |  | Int32 | in_len
 | ) |

This function creates a new handle of type HS_HTTPLibString.

Parameters:
refnum,: IN: Library reference number.
*in_str,: IN: The pointer to the string.
in_len,: IN: The length of in_str.
Return values:
HS_HTTPLibString

void HS_HTTPLibURLString_Delete | ( | UInt16 | refnum,
 |  | HS_HTTPLibURLString | in_str
 | ) |

This function deletes the handle of type HS_HTTPLibURLString.

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
nothing

Int32 HS_HTTPLibURLString_Length | ( | UInt16 | refnum,
 |  | HS_HTTPLibURLString | in_str
 | ) |

This function returns the length of the handle (byte).

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
Int32

void* HS_HTTPLibURLString_Lock | ( | UInt16 | refnum,
 |  | HS_HTTPLibURLString | in_str
 | ) |

This function locks the handle of type HS_HTTPLibURLString.

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
void *

void HS_HTTPLibURLString_Unlock | ( | UInt16 | refnum,
 |  | HS_HTTPLibURLString | in_str
 | ) |

This function unlocks the handle of type HS_HTTPLibURLString.

Parameters:
refnum,: IN: Library reference number.
in_str,: IN: The handle.
Return values:
nothing

HS_HTTPLibURLString HS_HTTPLibURLStringNew | ( | UInt16 | refnum,
 |  | Char * | in_str,
 |  | Int32 | in_len
 | ) |

This function creates a new handle of type HS_HTTPLibURLString.

Parameters:
refnum,: IN: Library reference number.
*in_str,: IN: The pointer to the string.
in_len,: IN: The length of in_str.
Return values:
HS_HTTPLibURLString

void HS_HTTPLibVHandle_Delete | ( | UInt16 | refnum,
 |  | HS_HTTPLibVHandle | in_vhandle
 | ) |

This function deletes the handle of type HS_HTTPLibVHandle.

Parameters:
refnum,: IN: Library reference number.
in_vhandle,: IN: The handle.
Return values:
Nothing

Int32 HS_HTTPLibVHandle_Length | ( | UInt16 | refnum,
 |  | HS_HTTPLibVHandle | in_vhandle
 | ) |

This function returns the length of the handle (byte).

Parameters:
refnum,: IN: Library reference number.
in_vhandle,: IN: The handle.
Return values:
Int32

void* HS_HTTPLibVHandle_Lock | ( | UInt16 | refnum,
 |  | HS_HTTPLibVHandle | in_vhandle
 | ) |

This function locks the handle of type HS_HTTPLibVHandle.

Parameters:
refnum,: IN: Library reference number.
in_vhandle,: IN: The handle.
Return values:
void *

void HS_HTTPLibVHandle_Unlock | ( | UInt16 | refnum,
 |  | HS_HTTPLibVHandle | in_vhandle
 | ) |

This function unlocks the handle of type HS_HTTPLibVHandle.

Parameters:
refnum,: IN: Library reference number.
in_vhandle,: IN: The handle.
Return values:
Nothing

Err HS_HTTPLibWake ( UInt16 refnum )

Standard library wake function.

Parameters:
refnum,: IN: Library reference number
Returns:
Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:26 2006 for Palm API Guide


HS_HTTPLibApp.h File Reference

Detailed Description

Public 68k header file containing the structures used in HTTP Library.

Version:
2.0
Date:

Data Structures

  • struct HS_HTTPLibOpaque_
  • struct HS_HTTPLibIPAddr_
  • struct HS_HTTPLibAppinfo_
  • struct HS_HTTPLibNetLibInfo_
  • struct HS_HTTPLibPeer_

Defines

  • #define HS_HTTPLibID 'AsHT'
  • #define HS_HTTPLibDBType 'libr'
  • #define HS_HTTPLibName "HTTPLibrary"
  • #define sysNotifyStopEvent 'test'
  • #define httpIPAddrTypeV4 4
  • #define httpIPAddrLenV4 4

Typedefs

  • typedef MemHandle HS_HTTPLibHandle
  • typedef HS_HTTPLibOpaque_ * HS_HTTPLibOpaque
  • typedef HS_HTTPLibIPAddr_ HS_HTTPLibIPAddr
  • typedef HS_HTTPLibAppinfo_ HS_HTTPLibAppInfo
  • typedef Boolean(* HS_HTTPLibNetLibOpenProc )(HS_HTTPLibHandle in_libH, HS_HTTPLibOpaque in_aux)
  • typedef Boolean(* HS_HTTPLibNetLibCloseProc )(HS_HTTPLibHandle in_libH, HS_HTTPLibOpaque in_aux)
  • typedef Boolean(* HS_HTTPLibNetLibOnlineProc )(HS_HTTPLibHandle in_libH, HS_HTTPLibOpaque in_aux)
  • typedef Boolean(* HS_HTTPLibNetLibOfflineProc )(HS_HTTPLibHandle in_libH, HS_HTTPLibOpaque in_aux)
  • typedef HS_HTTPLibNetLibInfo_ HS_HTTPLibNetLibInfo
  • typedef Int32(* HS_TCPOpenPeer )(Int32 in_domain, HS_HTTPLibOpaque in_aux)
  • typedef void(* HS_TCPClosePeer )(Int32 in_desc, HS_HTTPLibOpaque in_aux)
  • typedef Int32(* HS_TCPIsConnectedPeer )(Int32 in_desc, HS_HTTPLibOpaque in_aux)
  • typedef Int32(* HS_TCPConnectPeer )(Int32 in_desc, HS_HTTPLibIPAddr *in_addr, Int32 in_port, HS_HTTPLibOpaque in_aux)
  • typedef Int32(* HS_TCPReadPeer )(Int32 in_desc, Char *out_buf, Int32 in_len, HS_HTTPLibOpaque in_aux)
  • typedef Int32(* HS_TCPWritePeer )(Int32 in_desc, Char *in_buf, Int32 in_len, HS_HTTPLibOpaque in_aux)
  • typedef Int32(* HS_TCPCanReadWritePeer )(Int32 in_desc, Int32 in_rw, HS_HTTPLibOpaque in_aux)
  • typedef HS_HTTPLibPeer_ HS_HTTPLibPeer

Typedef Documentation

typedef MemHandle HS_HTTPLibHandle

structure for application

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:26 2006 for Palm API Guide


HS_HTTPLibConst.h File Reference

Detailed Description

Public 68k header file containing the constants used in HTTP Library.

Version:
2.0
Date:

constants

  • #define kHTTPLibTrapOpen sysLibTrapOpen
  • #define kHTTPLibTrapClose sysLibTrapClose
  • #define kHTTPLibTrapSleep sysLibTrapSleep
  • #define kHTTPLibTrapWake sysLibTrapWake
  • #define kHTTPLibTrapOpenCount (sysLibTrapCustom + 0)
  • #define kHTTPLibTrapInitialize (sysLibTrapCustom + 1)
  • #define kHTTPLibTrapFinalize (sysLibTrapCustom + 2)
  • #define kHTTPLibTrapSSLClass (sysLibTrapCustom + 3)
  • #define kHTTPLibTrapRegisterSSLClass (sysLibTrapCustom + 4)
  • #define kHTTPLibTrapClearDNSCache (sysLibTrapCustom + 5)
  • #define kHTTPLibTrapCloseAllKeepAlive (sysLibTrapCustom + 6)
  • #define kHTTPLibTrapMakeProxy (sysLibTrapCustom + 7)
  • #define kHTTPLibTrapSetHTTPPort (sysLibTrapCustom + 8)
  • #define kHTTPLibTrapSetHTTPSPort (sysLibTrapCustom + 9)
  • #define kHTTPLibTrapSetMaxRequestHeader (sysLibTrapCustom + 10)
  • #define kHTTPLibTrapSetMaxRequestBody (sysLibTrapCustom + 11)
  • #define kHTTPLibTrapSetProxy (sysLibTrapCustom + 12)
  • #define kHTTPLibTrapSetUserAgent (sysLibTrapCustom + 13)
  • #define kHTTPLibTrapSetDefaultHeaders (sysLibTrapCustom + 14)
  • #define kHTTPLibTrapSetUseProxy (sysLibTrapCustom + 15)
  • #define kHTTPLibTrapSetHTTP11OverProxy (sysLibTrapCustom + 16)
  • #define kHTTPLibTrapSetSendReferer (sysLibTrapCustom + 17)
  • #define kHTTPLibTrapSetSendProxyKeepAlive (sysLibTrapCustom + 18)
  • #define kHTTPLibTrapSetSendCookie (sysLibTrapCustom + 19)
  • #define kHTTPLibTrapSetConnectTimeOut (sysLibTrapCustom + 20)
  • #define kHTTPLibTrapSetReqTimeOut (sysLibTrapCustom + 21)
  • #define kHTTPLibTrapSetRspTimeOut (sysLibTrapCustom + 22)
  • #define kHTTPLibTrapIsUseProxy (sysLibTrapCustom + 23)
  • #define kHTTPLibTrapIsHTTP11OverProxy (sysLibTrapCustom + 24)
  • #define kHTTPLibTrapIsSendReferer (sysLibTrapCustom + 25)
  • #define kHTTPLibTrapIsSendCookie (sysLibTrapCustom + 26)
  • #define kHTTPLibTrapStreamNew (sysLibTrapCustom + 27)
  • #define kHTTPLibTrapStreamDelete (sysLibTrapCustom + 28)
  • #define kHTTPLibTrapStreamCreateRequest (sysLibTrapCustom + 29)
  • #define kHTTPLibTrapStreamCreateRequestWithChunkEncoding (sysLibTrapCustom + 30)
  • #define kHTTPLibTrapStreamSendRequest (sysLibTrapCustom + 31)
  • #define kHTTPLibTrapStreamSendRequestWithPostData (sysLibTrapCustom + 32)
  • #define kHTTPLibTrapStreamSendRequestWithChunkEncoding (sysLibTrapCustom + 33)
  • #define kHTTPLibTrapStreamReceiveResponse (sysLibTrapCustom + 34)
  • #define kHTTPLibTrapStreamGetFlag (sysLibTrapCustom + 35)
  • #define kHTTPLibTrapStreamClose (sysLibTrapCustom + 36)
  • #define kHTTPLibTrapStreamIsHeaderReceived (sysLibTrapCustom + 37)
  • #define kHTTPLibTrapStreamSetPostData (sysLibTrapCustom + 38)
  • #define kHTTPLibTrapStreamGetScheme (sysLibTrapCustom + 39)
  • #define kHTTPLibTrapStreamGetState (sysLibTrapCustom + 40)
  • #define kHTTPLibTrapStreamGetStatusCode (sysLibTrapCustom + 41)
  • #define kHTTPLibTrapStreamGetResponseHeaderLength (sysLibTrapCustom + 42)
  • #define kHTTPLibTrapStreamGetResponseHeader (sysLibTrapCustom + 43)
  • #define kHTTPLibTrapStreamGetContentLength (sysLibTrapCustom + 44)
  • #define kHTTPLibTrapStreamGetEntityLength (sysLibTrapCustom + 45)
  • #define kHTTPLibTrapStreamAddHeaderLine (sysLibTrapCustom + 46)
  • #define kHTTPLibTrapStreamAddHeader (sysLibTrapCustom + 47)
  • #define kHTTPLibTrapStreamGetHeader (sysLibTrapCustom + 48)
  • #define kHTTPLibTrapMakeCertList (sysLibTrapCustom + 49)
  • #define kHTTPLibTrapHeaderSplitByX (sysLibTrapCustom + 50)
  • #define kHTTPLibTrapAuthInfoTidy (sysLibTrapCustom + 51)
  • #define kHTTPLibTrapSetUserPass (sysLibTrapCustom + 52)
  • #define kHTTPLibTrapFindAuthInfo (sysLibTrapCustom + 53)
  • #define kHTTPLibTrapMakeAuthInfo (sysLibTrapCustom + 54)
  • #define kHTTPLibTrapAuthInfoUser (sysLibTrapCustom + 55)
  • #define kHTTPLibTrapAuthInfoPass (sysLibTrapCustom + 56)
  • #define kHTTPLibTrapAuthInfoRealm (sysLibTrapCustom + 57)
  • #define kHTTPLibTrapAuthCacheGetChallengeTokenSS (sysLibTrapCustom + 58)
  • #define kHTTPLibTrapSetCookieMode (sysLibTrapCustom + 59)
  • #define kHTTPLibTrapSetCookieMax (sysLibTrapCustom + 60)
  • #define kHTTPLibTrapSetCookie (sysLibTrapCustom + 61)
  • #define kHTTPLibTrapMakeCookiesString (sysLibTrapCustom + 62)
  • #define kHTTPLibTrapSaveCookiesEntries (sysLibTrapCustom + 63)
  • #define kHTTPLibTrapLoadCookiesEntries (sysLibTrapCustom + 64)
  • #define kHTTPLibTrapCookieMakeEmpty (sysLibTrapCustom + 65)
  • #define kHTTPLibTrapSetDNSMaxRetry (sysLibTrapCustom + 66)
  • #define kHTTPLibTrapSetDNSRetryInterval (sysLibTrapCustom + 67)
  • #define kHTTPLibTrapSetSSLVersionFlag (sysLibTrapCustom + 68)
  • #define kHTTPLibTrapSSLTimeout (sysLibTrapCustom + 69)
  • #define kHTTPLibTrapSSLOpenCertDB (sysLibTrapCustom + 70)
  • #define kHTTPLibTrapSSLCloseCertDB (sysLibTrapCustom + 71)
  • #define kHTTPLibTrapCertListNew (sysLibTrapCustom + 72)
  • #define kHTTPLibTrapCertListDelete (sysLibTrapCustom + 73)
  • #define kHTTPLibTrapCertListClone (sysLibTrapCustom + 74)
  • #define kHTTPLibTrapCertListLock (sysLibTrapCustom + 75)
  • #define kHTTPLibTrapCertListUnlock (sysLibTrapCustom + 76)
  • #define kHTTPLibTrapCertListType (sysLibTrapCustom + 77)
  • #define kHTTPLibTrapCertListLength (sysLibTrapCustom + 78)
  • #define kHTTPLibTrapCertListBeginDecode (sysLibTrapCustom + 79)
  • #define kHTTPLibTrapCertListEndDecode (sysLibTrapCustom + 80)
  • #define kHTTPLibTrapCertListImportCert (sysLibTrapCustom + 81)
  • #define kHTTPLibTrapCertPeekVersion (sysLibTrapCustom + 82)
  • #define kHTTPLibTrapCertPeekSerialNumber (sysLibTrapCustom + 83)
  • #define kHTTPLibTrapCertPeekSignAlgo (sysLibTrapCustom + 84)
  • #define kHTTPLibTrapCertBeginPeekIssuerRDN (sysLibTrapCustom + 85)
  • #define kHTTPLibTrapCertPeekIssuerRDN (sysLibTrapCustom + 86)
  • #define kHTTPLibTrapCertPeekIssuerRDNStrType (sysLibTrapCustom + 87)
  • #define kHTTPLibTrapCert_EndPeekIssuerRDN (sysLibTrapCustom + 88)
  • #define kHTTPLibTrapCertBeginPeekSubjectRDN (sysLibTrapCustom + 89)
  • #define kHTTPLibTrapCertPeekSubjectRDN (sysLibTrapCustom + 90)
  • #define kHTTPLibTrapCertPeekSubjectRDNStrType (sysLibTrapCustom + 91)
  • #define kHTTPLibTrapCert_EndPeekSubjectRDN (sysLibTrapCustom + 92)
  • #define kHTTPLibTrapCert_PeekValidityStart (sysLibTrapCustom + 93)
  • #define kHTTPLibTrapCert_PeekValidityEnd (sysLibTrapCustom + 94)
  • #define kHTTPLibTrapCert_PeekRSAPublicKeyBits (sysLibTrapCustom + 95)
  • #define kHTTPLibTrapClientCertListNew (sysLibTrapCustom + 96)
  • #define kHTTPLibTrapClientCertListClone (sysLibTrapCustom + 97)
  • #define kHTTPLibTrapClientCertListDelete (sysLibTrapCustom + 98)
  • #define kHTTPLibTrapClientCertListLength (sysLibTrapCustom + 99)
  • #define kHTTPLibTrapClientCertListIsValid (sysLibTrapCustom + 100)
  • #define kHTTPLibTrapClientCertListSetValid (sysLibTrapCustom + 101)
  • #define kHTTPLibTrapSetSSLServerCertConfirmProc (sysLibTrapCustom + 102)
  • #define kHTTPLibTrapServerCertConfirm (sysLibTrapCustom + 103)
  • #define kHTTPLibTrapSetSSLClientCertSelectProc (sysLibTrapCustom + 104)
  • #define kHTTPLibTrapClientCertSelect (sysLibTrapCustom + 105)
  • #define kHTTPLibTrapSetNetLibProc (sysLibTrapCustom + 106)
  • #define kHTTPLibTrapDataHandle_Length (sysLibTrapCustom + 107)
  • #define kHTTPLibTrapDataHandle_Lock (sysLibTrapCustom + 108)
  • #define kHTTPLibTrapDataHandle_Unlock (sysLibTrapCustom + 109)
  • #define kHTTPLibTrapDataHandle_Delete (sysLibTrapCustom + 110)
  • #define kHTTPLibTrapVHandle_Length (sysLibTrapCustom + 111)
  • #define kHTTPLibTrapVHandle_Lock (sysLibTrapCustom + 112)
  • #define kHTTPLibTrapVHandle_Unlock (sysLibTrapCustom + 113)
  • #define kHTTPLibTrapVHandle_Delete (sysLibTrapCustom + 114)
  • #define kHTTPLibTrapString_Length (sysLibTrapCustom + 115)
  • #define kHTTPLibTrapStringNew (sysLibTrapCustom + 116)
  • #define kHTTPLibTrapString_Lock (sysLibTrapCustom + 117)
  • #define kHTTPLibTrapString_Unlock (sysLibTrapCustom + 118)
  • #define kHTTPLibTrapString_Delete (sysLibTrapCustom + 119)
  • #define kHTTPLibTrapFixedString_Length (sysLibTrapCustom + 120)
  • #define kHTTPLibTrapFixedStringNew (sysLibTrapCustom + 121)
  • #define kHTTPLibTrapFixedString_Lock (sysLibTrapCustom + 122)
  • #define kHTTPLibTrapFixedString_Unlock (sysLibTrapCustom + 123)
  • #define kHTTPLibTrapFixedString_Delete (sysLibTrapCustom + 124)
  • #define kHTTPLibTrapURLString_Length (sysLibTrapCustom + 125)
  • #define kHTTPLibTrapURLStringNew (sysLibTrapCustom + 126)
  • #define kHTTPLibTrapURLString_Lock (sysLibTrapCustom + 127)
  • #define kHTTPLibTrapURLString_Unlock (sysLibTrapCustom + 128)
  • #define kHTTPLibTrapURLString_Delete (sysLibTrapCustom + 129)
  • #define kHTTPLibTrapCertListGetCipherInfo (sysLibTrapCustom + 130)
  • #define kHTTPLibTrapSetCookieX (sysLibTrapCustom + 131)
  • #define kHTTPLibTrapSetTunnelingCallback (sysLibTrapCustom + 132)
  • #define kHTTPLibTrapSetMaxKeepAliveTimeout (sysLibTrapCustom + 133)
  • #define kHTTPLibTrapStreamResumeTimer (sysLibTrapCustom + 134)
  • #define kHTTPLibTrapStreamSuspendTimer (sysLibTrapCustom + 135)
  • #define kHTTPLibTrapStreamGetRequestSent (sysLibTrapCustom + 136)
  • #define kHTTPLibTrapStreamGetHeaderWithOffset (sysLibTrapCustom + 137)
  • #define kHTTPLibTrapSetUserPassX (sysLibTrapCustom + 138)
  • #define kHTTPLibTrapFindAuthCandidate (sysLibTrapCustom + 139)
  • #define kHTTPLibTrapSetWakeUpCallback (sysLibTrapCustom + 140)
  • #define kHTTPLibTrapSetUseragentSelectionRule (sysLibTrapCustom + 141)
  • #define httpStreamRead 0x00000001
  • #define httpStreamWrite 0x00000002
  • #define httpStreamReadWrite (httpStreamRead|httpStreamWrite)
  • #define httpStreamTextCRLF "\015\012"
  • #define httpStreamTextCRLFCRLF "\015\012\015\012"
  • #define httpStreamTextCRCR "\015\015"
  • #define httpStreamTextLFLF "\012\012"

string encoding in post

  • #define httpPostURLENCODED 0x00000001
  • #define httpPostPLAINTEXT 0x00000002
  • #define httpPostMULTIPART 0x00000004

SSL Version

  • #define httpSSLFlagConnV2 0x00000001
  • #define httpSSLFlagConnV3 0x00000002
  • #define httpSSLFlagConnTLS 0x00000004
  • #define httpSSLFlagConnV2V3 (httpSSLFlagConnV2 | httpSSLFlagConnV3)
  • #define httpSSLFlagConnV2TLS (httpSSLFlagConnV2 | httpSSLFlagConnTLS)
  • #define httpSSLFlagConnV3TLS (httpSSLFlagConnV3 | httpSSLFlagConnTLS)
  • #define httpSSLFlagConnV2V3TLS (httpSSLFlagConnV2 | httpSSLFlagConnV3 | httpSSLFlagConnTLS)

Typedefs

  • typedef enum httpAuthType_ httpAuthTypeEnum
  • typedef enum httpAuthTarget_ httpAuthTargetEnum
  • typedef enum httpAuthPath_ httpAuthPathEnum
  • typedef enum httpError_ httpErrorEnum
  • typedef enum httpHeaderType_ httpHeaderTypeEnum
  • typedef enum httpStreamState_ httpStreamStateEnum
  • typedef enum httpScheme_ httpSchemeEnum
  • typedef enum httpMethod_ httpMethodEnum
  • typedef enum httpVersion_ httpVersionEnum
  • typedef enum httpStatusCode_ httpStatusCodeEnum
  • typedef enum httpCookie_ httpCookieEnum
  • typedef enum httpHeaderID_ httpHeaderIDEnum

Enumerations

  • enum httpAuthType_ {
    httpAuthTypeNone = -1,
    httpAuthTypeBasic = 0,
    httpAuthTypeDigest,
    httpAuthTypeTypes
    }
  • enum httpAuthTarget_ {
    httpAuthTargetPage = 0,
    httpAuthTargetProxy,
    httpAuthTargetTargets
    }
  • enum httpAuthPath_ {
    httpAuthPathSame,
    httpAuthPathAncestor,
    httpAuthPathDescendant,
    httpAuthPathCousin
    }
  • enum httpError_ {
    httpErrorOK = 0,
    httpErrorGeneric = -1,
    httpErrorWouldBlock = -2,
    httpErrorIOSleep = -3,
    httpErrorNoMem = -6,
    httpErrorInval = -8,
    httpErrorDNSInval = -200,
    httpErrorDNSNoServer,
    httpErrorDNSTimedout,
    httpErrorDNSNotFound,
    httpErrorTCPOpen,
    httpErrorTCPConnect,
    httpErrorTCPRead,
    httpErrorTCPWrite,
    httpErrorSSLConnect,
    httpErrorSSLHandShake,
    httpErrorSSLRead,
    httpErrorSSLWrite,
    httpErrorReqTimedout,
    httpErrorRspTimedout,
    httpErrorCacheNone,
    httpErrorCacheExpire,
    httpErrorAuthUnknown,
    httpErrorAuthNoHeader,
    httpErrorAuthFormat,
    httpErrorRedirectFormat,
    httpErrorRedirectCanceled,
    httpErrorReqHeaderSizeOver,
    httpErrorReqBodySizeOver,
    httpErrorRspHeaderSizeOver,
    httpErrorReqTooManyContinue,
    httpErrorTLSIntolerant
    }
  • enum httpHeaderType_ {
    httpHeaderTypeGeneral = 0,
    httpHeaderTypeRequest,
    httpHeaderTypeResponse,
    httpHeaderTypeEntity,
    httpHeaderTypeOther,
    httpHeaderTypeTypes
    }
  • enum httpStreamState_ {
    httpStreamStateNew = 0,
    httpStreamStateDormant,
    httpStreamStateReqCreated,
    httpStreamStateReqResolve,
    httpStreamStateReqResolving,
    httpStreamStateReqOpen,
    httpStreamStateReqConnect,
    httpStreamStateReqConnecting,
    httpStreamStateReqProxyConnect,
    httpStreamStateReqProxyConnecting,
    httpStreamStateReqSSLHandShaking,
    httpStreamStateReqSSLHandShaked,
    httpStreamStateReqSending,
    httpStreamStateReqSent,
    httpStreamStateRspHeaderWaiting,
    httpStreamStateRspContinue,
    httpStreamStateRspHeaderReceiving,
    httpStreamStateRspHeaderReceived,
    httpStreamStateRspEntityReceiving,
    httpStreamStateRspEntityReceived,
    httpStreamStateObsolete,
    httpStreamStateDelete,
    httpStreamStateStates
    }
  • enum httpScheme_ {
    httpSchemeHTTP = 0,
    httpSchemeHTTPS,
    httpSchemeSchemes
    }
  • enum httpMethod_ {
    httpMethodOPTIONS = 0,
    httpMethodGET,
    httpMethodHEAD,
    httpMethodPOST,
    httpMethodPUT,
    httpMethodDELETE,
    httpMethodTRACE,
    httpMethodCONNECT,
    httpMethodMethods
    }
  • enum httpVersion_ {
    httpVersion_0_9 = 0,
    httpVersion_1_0,
    httpVersion_1_1,
    httpVersionVersions
    }
  • enum httpStatusCode_ {
    httpStatusCodeContinue = 100,
    httpStatusCodeSwitchingProtocols = 101,
    httpStatusCodeOK = 200,
    httpStatusCodeCreated = 201,
    httpStatusCodeAccepted = 202,
    httpStatusCodeNonAuthoritativeInformation = 203,
    httpStatusCodeNoContent = 204,
    httpStatusCodeResetContent = 205,
    httpStatusCodePartialContent = 206,
    httpStatusCodeMultipleChoices = 300,
    httpStatusCodeMovedPermanently = 301,
    httpStatusCodeFound = 302,
    httpStatusCodeSeeOther = 303,
    httpStatusCodeNotModified = 304,
    httpStatusCodeUseProxy = 305,
    httpStatusCodeTemporaryRedirect = 307,
    httpStatusCodeBadRequest = 400,
    httpStatusCodeUnauthorized = 401,
    httpStatusCodePaymentRequired = 402,
    httpStatusCodeForbidden = 403,
    httpStatusCodeNotFound = 404,
    httpStatusCodeMethodNotAllowed = 405,
    httpStatusCodeNotAcceptable = 406,
    httpStatusCodeProxyAuthenticationRequired = 407,
    httpStatusCodeRequestTimeout = 408,
    httpStatusCodeConflict = 409,
    httpStatusCodeGone = 410,
    httpStatusCodeLengthRequired = 411,
    httpStatusCodePreconditionFailed = 412,
    httpStatusCodeRequestEntityTooLarge = 413,
    httpStatusCodeRequestURITooLarge = 414,
    httpStatusCodeUnsupportedMediaType = 415,
    httpStatusCodeRequestedRangeNotSatisfiable = 416,
    httpStatusCodeExpectationFailed = 417,
    httpStatusCodeInternalServerError = 500,
    httpStatusCodeNotImplemented = 501,
    httpStatusCodeBadGateway = 502,
    httpStatusCodeServiceUnavailable = 503,
    httpStatusCodeGatewayTimeout = 504,
    httpStatusCodeHTTPVersionNotSupported = 505
    }
  • enum httpCookie_ {
    httpCookieNotifyBeforeSet = 0,
    httpCookieAlwaysSet,
    httpCookieNeverSet
    }
  • enum httpHeaderID_ {
    httpHeaderIDCacheControl,
    httpHeaderIDConnection,
    httpHeaderIDDate,
    httpHeaderIDPragma,
    httpHeaderIDTrailer,
    httpHeaderIDTransferEncoding,
    httpHeaderIDUpgrade,
    httpHeaderIDVia,
    httpHeaderIDWarning,
    httpHeaderIDKeepAlive,
    httpHeaderIDProxyConnection,
    httpHeaderIDAccept,
    httpHeaderIDAcceptCharset,
    httpHeaderIDAcceptEncoding,
    httpHeaderIDAcceptLanguage,
    httpHeaderIDAuthorization,
    httpHeaderIDExpect,
    httpHeaderIDFrom,
    httpHeaderIDHost,
    httpHeaderIDIfMatch,
    httpHeaderIDIfModifiedSince,
    httpHeaderIDIfNoneMatch,
    httpHeaderIDIfRange,
    httpHeaderIDIfUnmodifiedSince,
    httpHeaderIDMaxForwards,
    httpHeaderIDProxyAuthorization,
    httpHeaderIDRange,
    httpHeaderIDReferer,
    httpHeaderIDTE,
    httpHeaderIDUserAgent,
    httpHeaderIDCookie,
    httpHeaderIDAcceptRanges,
    httpHeaderIDAge,
    httpHeaderIDETag,
    httpHeaderIDLocation,
    httpHeaderIDProxyAuthenticate,
    httpHeaderIDRetryAfter,
    httpHeaderIDServer,
    httpHeaderIDVary,
    httpHeaderIDWWWAuthenticate,
    httpHeaderIDSetCookie,
    httpHeaderIDAuthenticationInfo,
    httpHeaderIDProxyAuthenticationInfo,
    httpHeaderIDAllow,
    httpHeaderIDContentEncoding,
    httpHeaderIDContentDisposition,
    httpHeaderIDContentLanguage,
    httpHeaderIDContentLength,
    httpHeaderIDContentLocation,
    httpHeaderIDContentMD5,
    httpHeaderIDContentRange,
    httpHeaderIDContentType,
    httpHeaderIDExpires,
    httpHeaderIDLastModified,
    httpHeaderIDRefresh,
    httpHeaderIDENUMS
    }
  • enum {
    httpCookieClearAtFinalize,
    httpCookieClearAll,
    httpCookieClearSessionCookiesOnly
    }
  • enum { httpDNSModeIPV4Only = 0 }
  • enum {
    httpCetListTypeUnknown = 0,
    httpCetListTypeServer,
    httpCetListTypeClient,
    httpCetListTypeBrowser,
    httpCetListTypeTypes
    }

Define Documentation

#define httpSSLFlagConnTLS 0x00000004

connect by TLS(v3.1) protocol

#define httpSSLFlagConnV2 0x00000001

connect by v2 protocol

#define httpSSLFlagConnV2TLS (httpSSLFlagConnV2 | httpSSLFlagConnTLS)

connect by v2 protocol

#define httpSSLFlagConnV2V3 (httpSSLFlagConnV2 | httpSSLFlagConnV3)

connect by v2 protocol

#define httpSSLFlagConnV2V3TLS (httpSSLFlagConnV2 | httpSSLFlagConnV3 | httpSSLFlagConnTLS)

connect by v2 protocol

#define httpSSLFlagConnV3 0x00000002

connect by v3 protocol

#define httpSSLFlagConnV3TLS (httpSSLFlagConnV3 | httpSSLFlagConnTLS)

connect by v2 protocol

Enumeration Type Documentation

enum httpCookie_

constant for cookie mode

enum httpError_

errors

Enumerator:
httpErrorReqHeaderSizeOver | method GET
httpErrorReqBodySizeOver | method POST

enum httpHeaderType_

header type

enum httpMethod_

constant for http method

enum httpScheme_

constant for http stream protocol scheme

enum httpStatusCode_

constant for http status code

enum httpStreamState_

constant for http stream state

enum httpVersion_

constant for http version

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:26 2006 for Palm API Guide


HsAppLaunchCmd.h File Reference

Detailed Description

Public header file akin to Palm's AppLaunchCmd.h.

Version:
1.0
Date:
04/20/2000

Include dependency graph for HsAppLaunchCmd.h:

Data Structures

  • struct AddrCallerIDParamsType
  • struct AddrListLookupTypeGetParamsType
  • struct AddrPhonebookAppParamsType
  • struct AddrCreateNewRecordParamsType
  • struct AddrHsLookupUserDataType
  • struct AddrHsLookupUserDataV2Type
  • struct AddrPhotoCallerIDParamsType
  • struct DialPnlIsDialingAvailableParamsType
  • struct DialPnlDispatchDialParamsType
  • struct PhoneAppLaunchCmdDialType
  • struct PhoneAppLaunchCmdSetWallpaperType
  • struct PhoneAppLaunchCmdSendDTMFToneType
  • struct PhoneAppLaunchCmdGetDialPrefFlagType
  • struct PhoneAppLaunchCmdGetALSLineNumberType
  • struct HsDialPrefsUSDialingRulesType
  • struct PhoneAppLaunchCmdCallerIDLookupType
  • struct SoundPrefsLaunchCmdParamType
  • struct webBrowserMinimalModeLaunchInfo
  • struct webBrowserURLWithSvcIDLaunchInfo

Defines

  • #define LaunchWithCommand(type, creator, command, commandParams)
  • #define CallWithCommand(type, creator, command, commandParams)
  • #define addrLookupNoMinLength 1
  • #define AddrHsLookupUserDataVersion 0
  • #define AddrHsLookupUserDataVersion2 1
  • #define phoneAppLaunchCmdDial (sysAppLaunchCmdCustomBase)
  • #define phoneAppLaunchCmdRedial (sysAppLaunchCmdCustomBase+1)
  • #define phoneAppLaunchCmdViewCalls (sysAppLaunchCmdCustomBase+2)
  • #define phoneAppLaunchCmdPowerOn (sysAppLaunchCmdCustomBase+3)
  • #define phoneAppLaunchCmdDialVoiceMail (sysAppLaunchCmdCustomBase+4)
  • #define phoneAppLaunchCmdViewHistory (sysAppLaunchCmdCustomBase+5)
  • #define phoneAppLaunchCmdViewSpeed (sysAppLaunchCmdCustomBase+6)
  • #define phoneAppLaunchCmdViewKeypad (sysAppLaunchCmdCustomBase+7)
  • #define phoneAppLaunchCmdViewPhoneHome (sysAppLaunchCmdCustomBase+8)
  • #define phoneAppLaunchCmdActivation (sysAppLaunchCmdCustomBase+10)
  • #define phoneAppLaunchCmdSetWallpaper (sysAppLaunchCmdCustomBase+11)
  • #define phoneAppLaunchCmdStartNetInitUSSD (sysAppLaunchCmdCustomBase+12)
  • #define phoneAppLaunchCmdDialSTKSETUPCALL (sysAppLaunchCmdCustomBase+13)
  • #define phoneAppLaunchCmdNetworkSearch (sysAppLaunchCmdCustomBase+14)
  • #define phoneAppLaunchCmdSendDTMFTone (sysAppLaunchCmdCustomBase+15)
  • #define phoneAppLaunchCmdViewMissedCalls (sysAppLaunchCmdCustomBase+16)
  • #define phoneAppLaunchCmdDisplayDialPrefs (sysAppLaunchCmdCustomBase+17)
  • #define phoneAppLaunchCmdGetDialPrefFlag (sysAppLaunchCmdCustomBase+18)
  • #define phoneAppLaunchCmdGetUSDialingRules (sysAppLaunchCmdCustomBase+19)
  • #define phoneAppLaunchOptionsMenu (sysAppLaunchCmdCustomBase+20)
  • #define phoneAppLaunchCmdGetALSLineNumber (sysAppLaunchCmdCustomBase+21)
  • #define phoneAppLaunchCmdBluetoothDial (sysAppLaunchCmdCustomBase+22)
  • #define phoneAppLaunchCmdBluetoothDialVoiceMail (sysAppLaunchCmdCustomBase+23)
  • #define phoneAppLaunchCmdCallerIDLookup (sysAppLaunchCmdCustomBase+25)
  • #define phoneAppLaunchCmdRegisterAllViews (sysAppLaunchCmdCustomBase+27)
  • #define hsDialPrefsAutoAreaCodeLength 11
  • #define hsDialPrefs6DigitPrefixLength 11
  • #define hsDialPrefs5DigitPrefixLength 11
  • #define hsDialPrefs4DigitPrefixLength 11
  • #define hsDialPrefsMaxDialingPrefixLength 11
  • #define pmPhoneAppNotifyHomeAppEvent 'pEvt'
  • #define pmPhoneAppNotifySetWallpaper 'pWlp'
  • #define soundPrefsLaunchCmdPhone (sysAppLaunchCmdCustomBase)
  • #define soundPrefsLaunchCmdSMS (sysAppLaunchCmdCustomBase+1)
  • #define soundPrefsLaunchCmdIM (sysAppLaunchCmdCustomBase+2)
  • #define soundPrefsLaunchCmdEmail (sysAppLaunchCmdCustomBase+3)
  • #define soundPrefsLaunchCmdCalendar (sysAppLaunchCmdCustomBase+4)
  • #define soundPrefsLaunchCmdMMS (sysAppLaunchCmdCustomBase+5)
  • #define soundPrefsLaunchCmdGeneral (sysAppLaunchCmdCustomBase+6)
  • #define sysAppLaunchWebBrowserLaunchBookmarkDialog (sysAppLaunchCmdCustomBase)
  • #define sysAppLaunchWebBrowserGetHomePage (sysAppLaunchCmdCustomBase + 1)
  • #define sysAppLaunchWebBrowserSetHomePage (sysAppLaunchCmdCustomBase + 2)
  • #define sysAppLaunchWebBrowserAutoCrawl (sysAppLaunchCmdCustomBase + 3)
  • #define sysAppLaunchWebBrowserTutorialMode (sysAppLaunchCmdCustomBase + 4)
  • #define sysAppLaunchWebBrowserMinimalMode (sysAppLaunchCmdCustomBase + 5)
  • #define sysAppLaunchWebBrowserURLWithSvcID (sysAppLaunchCmdCustomBase + 6)
  • #define cameraAppLaunchCmdStopPreview (sysAppLaunchCmdCustomBase)
  • #define pmNotifyHighPriorityUITask 'pmUT'
  • #define pmNotifyHighPriorityAudioTask 'pmAT'

Typedefs

  • typedef AddrLookupParamsType AddrHsLookupParamsType
  • typedef AddrHsLookupParamsType * AddrHsLookupParamsPtr
  • typedef struct AddrCallerIDParamsType * AddrCallerIDParamsPtr
  • typedef UInt16 AddrListLookupTypeEnum
  • typedef struct AddrPhonebookAppParamsType * AddrPhonebookAppParamsPtr
  • typedef struct AddrCreateNewRecordParamsType * AddrCreateNewRecordParamsPtr
  • typedef struct AddrHsLookupUserDataType * AddrHsLookupUserDataPtr
  • typedef struct AddrHsLookupUserDataV2Type * AddrHsLookupUserDataV2Ptr
  • typedef struct AddrPhotoCallerIDParamsType * AddrPhotoCallerIDParamsPtr
  • typedef struct PhoneAppLaunchCmdDialType * PhoneAppLaunchCmdDialPtr
  • typedef struct PhoneAppLaunchCmdSetWallpaperType * PhoneAppLaunchCmdSetWallpaperPtr
  • typedef struct PhoneAppLaunchCmdSendDTMFToneType * PhoneAppLaunchCmdSendDTMFTonePtr
  • typedef struct PhoneAppLaunchCmdGetDialPrefFlagType * PhoneAppLaunchCmdGetDialPrefFlagPtr
  • typedef struct PhoneAppLaunchCmdGetALSLineNumberType * PhoneAppLaunchCmdGetALSLineNumberTypePtr
  • typedef struct PhoneAppLaunchCmdCallerIDLookupType PhoneAppLaunchCmdCallerIDLookupPtr
  • typedef struct SoundPrefsLaunchCmdParamType * SoundPrefsLaunchCmdParamPtr

Enumerations

  • enum AddrCustomActionCodes {
    addrAppLaunchCmdHsLookup = sysAppLaunchCmdCustomBase + 0x2300,
    addrAppLaunchCmdCallerID
    }
  • enum AddrCustomNotificationCodes {
    addrAppNotificationHsLookup = sysAppLaunchCmdCustomBase + 0x2300,
    addrAppNotificationCmdCallerID,
    addrAppNotificationPhonebookApp,
    addrAppNotificationListLookupTypeGet = 'HsLL',
    addrAppNotificationCreateNewRecord = 'HsNR',
    addrAppNotificationDialPrefs = 'HsDP',
    addrAppNotificationBeamBusinessCard = 'HsBB',
    addrAppNotificationPhotoCallerID = 'HsPC'
    }
  • enum AddressHsLookupFields {
    addrLookupVoicePhones = 0x70,
    addrLookupAnyPhones,
    addrLookupSMSPhones,
    addrLookupSMSPhonesNoEmail
    }
  • enum {
    addrListLookupTypeLastName,
    addrListLookupTypeFirstName,
    addrListLookupTypeCompany,
    addrListLookupTypeIntelligent
    }
  • enum PhoneAppDialMethodEnum {
    PhoneAppDialMethodNormal = 0,
    PhoneAppDialMethodSATSetupCall
    }
  • enum {
    hsDialPrefsAddAreaCodeUnknown = 0,
    hsDialPrefsAddAreaCodeNo,
    hsDialPrefsAddAreaCodeYes,
    hsDialPrefsAdd4DigitPrefixUnknown,
    hsDialPrefsAdd4DigitPrefixNo,
    hsDialPrefsAdd4DigitPrefixYes,
    hsDialPrefsAdd5DigitPrefixUnknown,
    hsDialPrefsAdd5DigitPrefixNo,
    hsDialPrefsAdd5DigitPrefixYes,
    hsDialPrefsAdd6DigitPrefixUnknown,
    hsDialPrefsAdd6DigitPrefixNo,
    hsDialPrefsAdd6DigitPrefixYes
    }
  • enum SoundPrefsView {
    soundPrefsViewTones,
    soundPrefsViewVolume
    }

Define Documentation

#define AddrHsLookupUserDataVersion 0

Version number of the addrAppNotificationHsLookup command and structures

#define AddrHsLookupUserDataVersion2 1

Version number of the addrAppNotificationHsLookup command for the V2 structure

#define addrLookupNoMinLength 1

Flag definitions for AddrCallerIDParamsType flags field If this flag is set, we match numbers that are shorter than the usual minimum required length. We match the *entire* string, not substrings.

#define CallWithCommand | ( | type,
 |  | creator,
 |  | command,
 |  | commandParams | )

Value:

{ \
    UInt16              cardNo; \
    LocalID             dbID; \
    DmSearchStateType   searchState; \
    UInt32 result; \
    Err err; \
    DmGetNextDatabaseByTypeCreator(true, &searchState, type, \
        creator, true,  &cardNo, &dbID); \
    ErrNonFatalDisplayIf(!dbID, "Could not find db"); \
    if (dbID) \
      { \
        err = SysAppLaunch(cardNo, dbID, 0, command, (Ptr) commandParams, &result); \
        ErrNonFatalDisplayIf(err, "Could not launch db"); \
      } \
  }
internal

#define cameraAppLaunchCmdStopPreview (sysAppLaunchCmdCustomBase)

Stop any active Camera preview

#define hsDialPrefsAutoAreaCodeLength 11

MAX Length of the dialing prefixes for 7,6,5 and 4 digit numbers respectively, including zero-terminator.

#define LaunchWithCommand | ( | type,
 |  | creator,
 |  | command,
 |  | commandParams | )

Value:

{ \
    UInt16              cardNo; \
    LocalID             dbID; \
    DmSearchStateType   searchState; \
    Err                     err; \
    DmGetNextDatabaseByTypeCreator(true, &searchState, type, \
        creator, true,  &cardNo, &dbID); \
    ErrNonFatalDisplayIf(!dbID, "Could not find db"); \
    if (dbID) \
      { \
        err = SysUIAppSwitch(cardNo, dbID, command, (Ptr) commandParams); \
        ErrNonFatalDisplayIf(err, "Could not launch db"); \
      } \
  }
Author:
dia
History:8 12-oct-1999 dia - Created by Douglas Anderson 20-apr-2000 dia - New APIs for dialing.

#define phoneAppLaunchCmdActivation (sysAppLaunchCmdCustomBase+10)

Launch the ## Application

#define phoneAppLaunchCmdDial (sysAppLaunchCmdCustomBase)

Launch the phone application and dial the passed number

#define phoneAppLaunchCmdDialSTKSETUPCALL (sysAppLaunchCmdCustomBase+13)

Launch the phone application and dial the passed number for SATK SETUP CALL

#define phoneAppLaunchCmdDialVoiceMail (sysAppLaunchCmdCustomBase+4)

Launch the phone application and dial a number

#define phoneAppLaunchCmdDisplayDialPrefs (sysAppLaunchCmdCustomBase+17)

Display Dial Prefs

#define phoneAppLaunchCmdGetALSLineNumber (sysAppLaunchCmdCustomBase+21)

Launch the phone application and display the Options menu

#define phoneAppLaunchCmdGetDialPrefFlag (sysAppLaunchCmdCustomBase+18)

Query for the carrier flag to determine if Dial Prefs menu option should be displyed

#define phoneAppLaunchCmdGetUSDialingRules (sysAppLaunchCmdCustomBase+19)

Query for the carrier flag to determine if Dial Prefs menu option should be displyed

#define phoneAppLaunchCmdNetworkSearch (sysAppLaunchCmdCustomBase+14)

Launch the phone application to display the UI to ask the user if they would like to search again.

#define phoneAppLaunchCmdPowerOn (sysAppLaunchCmdCustomBase+3)

Launch the phone application and prompt to power on the phone

#define phoneAppLaunchCmdRedial (sysAppLaunchCmdCustomBase+1)

Launch the phone application and dial the last number dialed.

#define phoneAppLaunchCmdSendDTMFTone (sysAppLaunchCmdCustomBase+15)

Launch the phone application and send DTMF tone to the network

#define phoneAppLaunchCmdSetWallpaper (sysAppLaunchCmdCustomBase+11)

Set the Wallpaper

#define phoneAppLaunchCmdStartNetInitUSSD (sysAppLaunchCmdCustomBase+12)

Start the Network-initiated USSD

#define phoneAppLaunchCmdViewCalls (sysAppLaunchCmdCustomBase+2)

Launch the phone application and display the active calls view.

#define phoneAppLaunchCmdViewHistory (sysAppLaunchCmdCustomBase+5)

Launch the phone application and display the call history view.

#define phoneAppLaunchCmdViewKeypad (sysAppLaunchCmdCustomBase+7)

Launch the phone application and display the keypad view.

#define phoneAppLaunchCmdViewMissedCalls (sysAppLaunchCmdCustomBase+16)

Launch the phone application and display missed calls in the call history view.

#define phoneAppLaunchCmdViewPhoneHome (sysAppLaunchCmdCustomBase+8)

Launch the phone application and display the Phone Home view

#define phoneAppLaunchCmdViewSpeed (sysAppLaunchCmdCustomBase+6)

Launch the phone application and display the speed dial view.

#define phoneAppLaunchOptionsMenu (sysAppLaunchCmdCustomBase+20)

Launch the phone application and display the Options menu

#define pmNotifyHighPriorityAudioTask 'pmAT'

Notification to request stop/pause audio preview/playback. In the event of high priority UI action like an incoming phone call, if the responsible application does not take action the sender of this notification may take appropriate action in order to handle the high priority task

#define pmNotifyHighPriorityUITask 'pmUT'

Notification to request stop/pause video preview/playback. In the event of high priority UI action like an incoming phone call, if the responsible application does not take action the sender of this notification may take appropriate action in order to handle the high priority task

#define pmPhoneAppNotifyHomeAppEvent 'pEvt'

This notification is broadcast by the Phone application

#define pmPhoneAppNotifySetWallpaper 'pWlp'

The parameter for pmPhoneAppNotifyHomeAppEvent notification is of type PhnEventPtr(as defined in HsPhoneEvent.h

#define soundPrefsLaunchCmdCalendar (sysAppLaunchCmdCustomBase+4)

Launch Sound Prefs in Calendar Prefs view

#define soundPrefsLaunchCmdEmail (sysAppLaunchCmdCustomBase+3)

Launch Sound Prefs in Email Prefs view

#define soundPrefsLaunchCmdGeneral (sysAppLaunchCmdCustomBase+6)

Launch Sound Prefs in the General Prefs view

#define soundPrefsLaunchCmdIM (sysAppLaunchCmdCustomBase+2)

Launch Sound Prefs in IM Prefs view

#define soundPrefsLaunchCmdMMS (sysAppLaunchCmdCustomBase+5)

Launch Sound Prefs in the MMS Prefs view

#define soundPrefsLaunchCmdPhone (sysAppLaunchCmdCustomBase)

Launch sounds Prefs in Phone Prefs view

#define soundPrefsLaunchCmdSMS (sysAppLaunchCmdCustomBase+1)

Launch Sound Prefs in SMS Prefs view

#define sysAppLaunchWebBrowserAutoCrawl (sysAppLaunchCmdCustomBase + 3)

Launch the browser in autocrawl mode

#define sysAppLaunchWebBrowserGetHomePage (sysAppLaunchCmdCustomBase + 1)

Retrieve the browser's home page

#define sysAppLaunchWebBrowserLaunchBookmarkDialog (sysAppLaunchCmdCustomBase)

Launch the browser in the bookmark dialog

#define sysAppLaunchWebBrowserMinimalMode (sysAppLaunchCmdCustomBase + 5)

Launch the browser in minimal mode

#define sysAppLaunchWebBrowserSetHomePage (sysAppLaunchCmdCustomBase + 2)

Set the browser's home page

#define sysAppLaunchWebBrowserTutorialMode (sysAppLaunchCmdCustomBase + 4)

Launch the browser in tips/tutorial mode

Typedef Documentation

typedef AddrHsLookupParamsType* AddrHsLookupParamsPtr

Parameter block is the same as OS 3.1's block for sysAppLaunchCmdLookup

typedef AddrLookupParamsType AddrHsLookupParamsType

Parameter block is the same as OS 3.1's block for sysAppLaunchCmdLookup

typedef UInt16 AddrListLookupTypeEnum

AddrListLookupTypeEnum -> UInt16

Enumeration Type Documentation

anonymous enum

Various address book lookup methods.

Enumerator:
addrListLookupTypeLastName | phone lookup will be by last name...
addrListLookupTypeFirstName | phone lookup will be by first name...
addrListLookupTypeCompany | phone lookup will be by company (currently unused)...
addrListLookupTypeIntelligent | phone lookup will be intelligent (either name or some other matching) (currently unused)...

anonymous enum

Data structure that goes with phoneAppLaunchCmdGetUSDialingRules launch cmd

Enumerator:
hsDialPrefsAddAreaCodeUnknown | we don't know yet, so prompt when appropriate
hsDialPrefsAddAreaCodeNo | no auto-area code
hsDialPrefsAddAreaCodeYes | add area code automatically before dialing

enum AddrCustomActionCodes

Launch codes start at customBase + 0x2300 so that hopefully there won't be any conflict with any launch codes that PalmSource or others add to the address book. IMPORTANT: See also AddrCustomNotificationCodes .

Enumerator:
addrAppLaunchCmdHsLookup | Launch Contacts for lookup
addrAppLaunchCmdCallerID | Launch Contacts for callerID lookup

enum AddrCustomNotificationCodes

Switch to using notifications rather than launch codes to avoid potential conflicts if PalmSource modifies the address book app.

enum AddressHsLookupFields

Expansion to the Palm OS AddressLookupFields.

Enumerator:
addrLookupVoicePhones | All phone fields except fax and email.
addrLookupAnyPhones | All phone fields (including email)
addrLookupSMSPhones | Mobile, other and email fields
addrLookupSMSPhonesNoEmail | Mobile and other fields

enum PhoneAppDialMethodEnum

Phone application dial methods.

Enumerator:
PhoneAppDialMethodNormal | Normal PhnLibDial()
PhoneAppDialMethodSATSetupCall | Use SIM Toolkit and respond "affirmative" to the SIM's request to set up a call.

enum SoundPrefsView

Different sound pref dialog views.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:27 2006 for Palm API Guide


HsChars.h File Reference

Detailed Description

Definitions of Handspring's character codes. (see Palm's Chars.h)

Copyright (c) 2002 Handspring Inc., All Rights Reserved

Id
//device/handheld/dev/sdk/2.2/incs/common/system/HsChars.h#4

Defines

  • #define hsChrRangeMin 0x1600
  • #define hsChrRangeMax 0x16FF
  • #define hsChrNoop 0x1607
  • #define hsChrSymbol 0x1609
  • #define hsChrPostProcess hsChrSymbol
  • #define hsChrAnswer 0x160A
  • #define hsChrLidStatusChg 0x160B
  • #define hsChrRadioPower 0x160C
  • #define hsChrModifierKey 0x160D
  • #define hsChrShiftPageUp 0x160E
  • #define hsChrShiftPageDown 0x160F
  • #define hsChrShutdownNetlib 0x1610
  • #define hsChrMuteOn 0x1611
  • #define hsChrMuteOff 0x1612
  • #define hsChrOptHard1 vchrHard5
  • #define hsChrOptHard2 vchrHard6
  • #define hsChrOptHard3 vchrHard7
  • #define hsChrOptHard4 vchrHard8
  • #define hsChrOptHardPower vchrHard9
  • #define hsChrOptReserved vchrHard10
  • #define hsChrOptHard11 vchrHard12
  • #define hsChrOptHard13 vchrHard14
  • #define hsChrWakeup 0x1618
  • #define hsChrKeyboardLock 0x1619
  • #define hsChrDeleteWord 0x161A
  • #define hsChrVolumeUp 0x161B
  • #define hsChrVolumeDown 0x161C
  • #define hsChrNetMasterUIExecute 0x161D
  • #define hsChrLowBatteryShutdown 0x161E
  • #define hsChrSide 0x161F
  • #define hsChrDarkMode 0x1620
  • #define vchrHard11 0x021A
  • #define vchrHard12 0x021B
  • #define vchrHard13 0x021C
  • #define vchrHard14 0x021D
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:27 2006 for Palm API Guide


HsCommon.h File Reference

Detailed Description

Version:
1.0
Date:
Main Handspring Palm OS API Header file

Most functions or API's are specific to either the 68K environment or the ARM environment but both of them sometimes share the same structures, types, constants etc.. The common header files are for those shared components that are used by both the 68K and ARM parts of a library, extention etc. In general, a developer would never have to include this file seperataely. It is already included in both the 68K/Hs.h and the ARM/Hs.h.

Author:
Kiran Prasad

Include dependency graph for HsCommon.h:

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:28 2006 for Palm API Guide


HsCreators.h File Reference

Detailed Description

Public header file for the creator IDs used by Handspring.

Version:
1.0
Date:
01/08/2000

Misc. App Creator IDs

  • #define hsFileCAdvCalculator 'HsPr'
  • #define hsFileCCardSetup 'HsCd'
  • #define hsFileCSampleCardWelcome 'CWel'
  • #define hsFileCHandTerminal 'HTrm'
  • #define hsFileCFileMover 'FlMv'
  • #define hsFileCFileInstaller 'FlIn'
  • #define hsFileCDateBook3H 'HsDB'
  • #define hsFileCBackup 'HsBk'
  • #define hsFileCBackupWelcome 'HsBw'

Phone App Creator IDs

  • #define hsFileCPhone 'HsPh'
  • #define hsFileCPhone2 'HsP2'
  • #define hsFileCPhoneStub68k 'Pm68'
  • #define hsFileCPhoneMainView 'PmPm'
  • #define hsFileCPhoneDialPadView 'PmPd'
  • #define hsFileCPhonePeopleView 'PmPp'
  • #define hsFileCPhoneFavoritesView 'PmPf'
  • #define hsFileCPhoneCallLogView 'PmPl'
  • #define hsFileCPhoneActiveCallView 'PmPa'
  • #define hsFileCPhoneIncomingCallView 'PmPi'
  • #define hsFileCPhoneAppFavoritesLibrary 'PmPF'
  • #define hsFileCPhoneTips 'PhTp'
  • #define hsFileCPhoneSecurity 'HsSE'
  • #define hsFileCPhoneWizard 'HsPw'
  • #define hsFileCPhoneRingerPanel 'HsRN'
  • #define hsFileCDisplayPanel 'HsDs'
  • #define hsFileCKeyguardPanel 'HsKg'
  • #define hsFileCSMS 'SMSh'
  • #define hsFileCSimPhoneBook 'HsPB'
  • #define hsFileCSimServices 'HsSS'
  • #define hsFileCIM 'HsIM'
  • #define hsFileCSmartTextEngine 'HsST'
  • #define hsFileCTexter 'HsCh'
  • #define hsFileCMessageStore 'HsMS'
  • #define hsFileSMSTreoTransport 'Trn0'
  • #define hsFileMMSTreoTransport 'Trn1'
  • #define hsFileSMSPalmTransport 'Trn2'
  • #define hsFileMMSPalmTransport 'Trn3'
  • #define hsFilePhoneBluetoothConnect 'PhBt'

Misc. App Creator IDs

  • #define hsFileCImagine 'HsIm'
  • #define hsFileCAddrBookExtensions 'HsAX'
  • #define hsFileCDialingPanel 'HsDi'
  • #define hsFileCAddrBookOneFingerMode 'HsAl'
  • #define hsFileCPinballGame 'HsPg'
  • #define hsFileCSetISP 'HsJS'

Web Browser Creator IDs

  • #define hsFileCBlazer 'BLZ1'
  • #define hsFileCBlazer3 'BLZ5'
  • #define hsFileCBlazer3TutorialLauncher 'HsTM'
  • #define hsFileCBlazer3TipsSharedContent 'HsSC'

Misc. App Creator IDs

  • #define hsFileCCityTime 'CiAa'
  • #define hsFileCKeyboardDemo 'kDem'
  • #define hsFileCFirmwareUpdater 'HsFU'
  • #define hsFileCGPRSUpdater 'HsGU'
  • #define hsFileCRomUpdater 'hROM'
  • #define hsFileCCDMAUpdater 'HsCU'
  • #define hsFileCCDMAActivation 'HsAc'
  • #define hsFileCGSMActivation 'HsGA'
  • #define hsFileCIOTA 'Iota'
  • #define hsTetheredTreo 'HsTt'
  • #define hsFileCDebugPrefs 'hsCn'
  • #define hsFileCCamera 'Bcam'
  • #define hsFileCCameraTips 'BcTp'
  • #define hsFileCDuoHack 'DuHk'
  • #define hsFileCTutorialContent 'TMTp'
  • #define hsFileCEmailTipsContent 'HsTC'
  • #define hsFileCNavSample 'HsNS'
  • #define hsFileCSave2Card 'HsSD'
  • #define hsFileCBrightness 'brtP'
  • #define hsFileCGettingStartedApp 'GSGa'

Library Creator IDs

  • #define hsFileCSampleSerLib 'HsCs'
  • #define hsFileCTaskLib 'HsTS'
  • #define hsFileCFfsCSegLib 'FfMg'
  • #define hsFileCLdbMgr 'HsLm'
  • #define hsFileCModemSerLib 'HsMs'
  • #define hsFileCFlMgr 'FLMG'
  • #define hsFileCFluMgr 'FlMg'
  • #define hsFileCHwmCSegLib 'Hhwm'
  • #define hsFileCCDMAPhoneLib 'HsCL'
  • #define hsFileCCDMAMsgLib 'HsMg'
  • #define hsFileCGSMPhoneLib 'GSM!'
  • #define GSMLibRingsDBCreatorID 'GSMr'
  • #define hsFileCTransparencyLib 'HsTL'
  • #define hsFileCComChannelProvider 'HsCP'
  • #define hsFileSMSExchangeLib 'HsSX'
  • #define hsFileCFakeNetLib 'netl'
  • #define hsFileCPatchedNetLib 'netb'
  • #define hsFileCameraLib 'HsCa'
  • #define hsFileCARMTelephonyWrapper 'PIL!'
  • #define hsFileCTelephonyInterfaceLayer 'TIL!'
  • #define hsFileCCodecWrapper 'CdWr'
  • #define hsFileBrowserCoreLib 'AcBC'
  • #define hsFileSoundLib 'HsAu'
  • #define hsAmrLib 'AMRL'
  • #define hsAmrEncLib 'AENL'
  • #define hsAmrDecLib 'ADEL'
  • #define hsFileCMCLLib 'MCLL'
  • #define pmFileCKeyLib 'PmKe'
  • #define pmFileCUIUtilLib 'PmUU'
  • #define pmFileCSystemLib 'PmSy'
  • #define pmFileCSysGadgetLib 'PmSg'
  • #define hsFileCSerLib 'A8xZ'
  • #define hsFileCModuleSerLib 'HsSs'
  • #define hsFileCVirtualModemSerLib 'FakM'
  • #define hsFileCVirtualGSMSerLib 'VGSM'
  • #define hsFileCDirectRadioSerLib 'DirR'
  • #define hsFileCHsSerWrapperLib 'Hssw'
  • #define hsFileSPI1SerLib 'HsSp'
  • #define hsFileCHsSSLLib109a 'hSSL'
  • #define hsFileCUsbLib 'HsUs'
  • #define hsFileCSerDrvrUSBConsole 'HsUc'
  • #define hsFileCSerDrvrUSBDesktop 'HsUd'
  • #define hsFileCSerDrvrUSBRemFS 'HsUr'
  • #define hsFileCSerDrvrUSBGeneric 'HsUg'
  • #define hsFileCSerDrvrUSBGeneric2 'HsUh'
  • #define hsFileCSerDrvrAuto 'HsSA'
  • #define hsFileCSerDrvrCradle 'HsCS'
  • #define hsFileCSDLib 'Hssd'
  • #define hsFileCCCLib 'CCLb'
  • #define hsFileCOldGrfLib 'HsGf'
  • #define hsFileCTonesLib 'HsTo'

Defines

  • #define hsFileCLangSpoofer 'HsLS'
  • #define hsFileCAddrTester 'HsAT'
  • #define hsFileCMailWrapper 'HsMW'
  • #define hsFileCUsbTester 'HsU2'
  • #define hsFileCPhoneWrapper 'HsPW'
  • #define hsFileCSetMem 'Hssm'
  • #define hsFileCSerialCoupler 'Hssc'
  • #define hsFileCUartCoupler 'Hsuc'
  • #define hsFileCSpringWriter 'Hss1'
  • #define hsFileCUsbResetTest 'Hsur'
  • #define hsFileCGasTest 'Hsgt'
  • #define hsFileCIsolateMemoryChip 'Isom'
  • #define hsFileCCameraTest 'HsZZ'
  • #define hsFileCUseSerial 'HSUS'
  • #define hsFileCTraceViewer 'HsTV'
  • #define hsFileCPmUIUtilLibTest 'PmUT'
  • #define hsFileTCardSetup 'HsSU'
  • #define hsFileTCardSetupShell 'HApp'
  • #define hsFileTSndFile 'SndF'
  • #define hsFileCAutomaticHelper 'Auto'
  • #define hsFileCPhoneServicesPanel 'hsPS'
  • #define hsFileCLCDAdjustPanel 'HsLA'
  • #define hsFileCMultiChannelRingToneDB 'MCnl'
  • #define hsFileCDefaultAppsPanel 'HsDH'
  • #define hsFileCButtonPrefsPanel 'HsBt'
  • #define hsFileCHandspringPalmOSUpdate 'Hspt'
  • #define hsFileCHandspringSystemResource 'HsSr'
  • #define hsFileTHandspringHal 'HwAl'
  • #define hsFileTHandspringPatch 'HsPt'
  • #define hsFileTHandspringUIObj 'HsUi'
  • #define hsFileCHandspringExt 'HsEx'
  • #define hsFileCNavExt 'HsEp'
  • #define hsFileCModemMgrExt 'HsMM'
  • #define hsFileCDataMgrExt 'HsDM'
  • #define hsFileCProgressMgrExt 'HsPM'
  • #define hsFileCUIExt 'HsUI'
  • #define hsFileTCodeSeg 'CSeg'
  • #define hsFileCFFSInfoTok1 'Ffs1'
  • #define hsFileCFfsCrType 'Ffs2'
  • #define hsFileCCardAccessTime 'HsAT'
  • #define hsFileCCardWelcomeDuringReset 'HsWR'
  • #define hsFileCCardWelcomeAppTypeCreator 'HsWT'
  • #define hsFileCSmartSmallromToken 'HsSR'
  • #define hsFileCBuiltinHsExtToken 'HsHX'
  • #define hsBluetoothIdToken 'BTid'
  • #define htcManufacturingInfoToken 'HTCM'
  • #define pmLimitLocaleToken 'LLid'
  • #define pmDebugLockoutToken 'Dblk'
  • #define pmTSCalToken 'TScb'
  • #define pmKbdLayoutToken 'KBlo'
  • #define pmTSTokenValidToken 'TStv'
  • #define hsFileTModemSetupPatch 'HsMp'
  • #define hsCompressedDbCreatorId 'Lz7C'
  • #define hsCompressedDbTypeId 'Lz7C'
  • #define hsKbdLayoutDbTypeCreator 'KbLy'
  • #define hsFileCTextEncodingConverterLib 'TecL'
  • #define hsFileCTextEncodingConverterTable 'TecD'
  • #define hsRscTextEncodingConverterTable 'TecT'
  • #define hsFileCPowerKey '000P'
  • #define hsFileCKeyguard 'kLoc'
  • #define pmSlotDriverActivityIndicator 'PmAI'
  • #define pmROMTokenWrite 'TOKw'
  • #define pmROMTokenRead 'TOKr'
  • #define hsNotifyRemSleepRequestEvent 'REMq'
  • #define hsNotifyRemSleepEvent 'REMs'
  • #define hsNotifySetInitialFldStateEvent 'HsFg'
  • #define pmNotifyGetNewMsgCountFromHelper 'gMgC'
  • #define pmNotifyBroadcastNewMsgCount 'bMgC'
  • #define pmNotifyBrightModeKeyEvent 'PmBM'
  • #define pmNotifyTraceSettingsChangedEvent (hsFileCTraceViewer)
  • #define hsRscTKbdChrLookupData 'HsKb'
  • #define hsRscKbdChrDataID 2000
  • #define hsRscKbdChrShiftDataID 2001
  • #define hsRscKbdChrOptDataID 2002
  • #define hsRscTKbdKeyCodeLookupData 'HsKc'
  • #define hsRscKbdKeyCodeDataID 2000
  • #define hsRscTPostProcessLists 'HsPp'
  • #define hsRscTNavFocusColor 'HsFc'
  • #define hsRscTutorial 'HsTM'
  • #define exFileCArcSoftCamera 'CmLo'
  • #define exFileCArcSoftMedia 'Foto'
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:28 2006 for Palm API Guide


HsErrorClasses.h File Reference

Detailed Description

Version:
1.0
Date:
06/17/1999
Author:
Vitaly Kruglikov
Public header file for the error classes used by Handspring viewer modules.

Include dependency graph for HsErrorClasses.h:

Defines

  • #define hsAppErrorClass appErrorClass
  • #define hsFfsErrorClass (appErrorClass | 0x0100)
  • #define hsFlmErrorClass (appErrorClass | 0x0200)
  • #define hsFlashErrorClass (appErrorClass | 0x0300)
  • #define hsFttErrorClass (appErrorClass | 0x0400)
  • #define hsFtcErrorClass (appErrorClass | 0x0500)
  • #define hsTasLibErrorClass (appErrorClass | 0x0600)
  • #define hsHwmErrorClass (appErrorClass | 0x0800)
  • #define hsSrmExtErrorClass (appErrorClass | 0x0A00)
  • #define hsSTEErrorClass (appErrorClass | 0x0C00)
  • #define hsOEMErrorClass oemErrorClass
  • #define hsOEMRadioErrorClass (hsOEMErrorClass)
  • #define hsNetMasterErrorClass (hsOEMErrorClass + 0x0100)
  • #define hsNetPrefLibErrorClass (hsOEMErrorClass + 0x0200)
  • #define hsPhoneLibErrorClass_2 (hsOEMErrorClass + 0x0300)
  • #define hsCcpErrorClass (hsOEMErrorClass + 0x0400)
  • #define hsSoundLibErrorClass (hsOEMErrorClass + 0x0500)
  • #define hsExtErrorClass (hsOEMErrorClass + 0x0600)
  • #define hsMSLErrorClass (hsOEMErrorClass + 0x0700)
  • #define pmLibErrorClass (hsOEMErrorClass + 0x0800)
  • #define hsPhoneLibErrorClass_1 (0x4000)
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:29 2006 for Palm API Guide


HsErrors.h File Reference

Detailed Description

Errors that are not part of any particular component but can be returned by many different system components.

Copyright (c) 2002 Handspring Inc., All Rights Reserved

Author:
Kiran Prasad
Id
//device/handheld/dev/sdk/2.2/incs/common/system/HsErrors.h#7

Defines

  • #define hsErrRadioOff (hsOEMRadioErrorClass | 0x01)
  • #define hsErrRadioNotRegistered (hsOEMRadioErrorClass | 0x02)
  • #define hsErrVoiceCallActive (hsOEMRadioErrorClass | 0x03)
  • #define hsErrSimNotReady (hsOEMRadioErrorClass | 0x04)
  • #define hsErrPhoneLocked (hsOEMRadioErrorClass | 0x05)
  • #define hsErrPhoneNotActivated (hsOEMRadioErrorClass | 0x06)

Define Documentation

#define hsErrPhoneLocked (hsOEMRadioErrorClass | 0x05)

Your Radio is currently locked and therefore we can perform the action requested.

#define hsErrPhoneNotActivated (hsOEMRadioErrorClass | 0x06)

Phone is not activated.

#define hsErrRadioNotRegistered (hsOEMRadioErrorClass | 0x02)

The radio is currently not registered and you can not perform the action reuqested.

#define hsErrRadioOff (hsOEMRadioErrorClass | 0x01)

The radio is currently off and you can not perform the action requested.

#define hsErrSimNotReady (hsOEMRadioErrorClass | 0x04)

For GSM Radio Only, Your SIM is not ready to perform this action. This can either mean there is no SIM or it is not fully read yet.

#define hsErrVoiceCallActive (hsOEMRadioErrorClass | 0x03)

The radio is currently on an active voice call and so your request can not be handled.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:29 2006 for Palm API Guide


HsExgMgr.h File Reference

Detailed Description

Extensions to the Exchange Manager.

Version:
Date:
These functions are not currently supported by Palm, but the plan to in future releases. They gave us these functions in sample code, and we are moving into the system for OS 5 products so applications can take advantage of them.

Include dependency graph for HsExgMgr.h:

Functions

  • Err HsExtExgSelectTarget (UInt16 id, const Char *dataTypeP, UInt32 *targetP)
  • Err HsExtExgLocalAccept (ExgSocketPtr exgSocketP)
  • Err HsExtExgLocalDisconnect (ExgSocketPtr exgSocketP, Err err)

Function Documentation

Err HsExtExgLocalAccept ( ExgSocketPtr exgSocketP )

Parameters:
exgSocketP,: IN:
Return values:

Err HsExtExgLocalDisconnect | ( | ExgSocketPtr | exgSocketP,
 |  | Err | err
 | ) |

Parameters:
exgSocketP,: IN:
err,: IN:
Return values:

Err HsExtExgSelectTarget | ( | UInt16 | id,
 |  | const Char * | dataTypeP,
 |  | UInt32 * | targetP
 | ) |

Parameters:
id,: IN:
*dataTypeP,: IN:
*targetP,: IN:
Return values:

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:29 2006 for Palm API Guide


HsExgMgrCommon.h File Reference

Detailed Description

Extensions to the Exchange Manager.

These defines are not currently supported by Palm, but the plan to in future releases. They gave us these in sample code, and we are moving into the system for OS 5 products so applications can take advantage of them.

Copyright (c) 2002 Handspring Inc., All Rights Reserved

Author:
Arun Mathias

Defines

  • #define hsExgGetScheme "_get"
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:29 2006 for Palm API Guide


HsExt.h File Reference

Detailed Description

Header file that 68K programs include to access Handspring Extensions functionality.

Include dependency graph for HsExt.h:

Defines

  • #define SYS_SEL_TRAP(trapNum, selector)
  • #define HsAboutHandspringAppWithYearId(yearId)
  • #define HsAboutHandspringAppWithYearCredId(yearId, creditsId)

Functions

  • void HsAboutHandspringApp (UInt16 appCardNo, LocalID appDbId, Char *copyrightYearStrP, Char *extraCreditsStrP)
  • Err HsGetVersionString (UInt16 selector, Char *outStrP, UInt16 *sizeP)
    Retrieve a null terminated version string.
  • Err HsAttrGet (UInt16 attr, UInt32 param, UInt32 *valueP)
    Get any Handspring specific attributes that aren’t appropriate to be accessed through a feature. (e.g., dynamic information about device state).
  • Err HsAttrSet (UInt16 attr, UInt32 param, UInt32 *valueP)
    Set Handspring specific attributes.
  • Err HsPrefGet (UInt16 pref, void *bufP, UInt32 *prefSizeP)
    HsExtensions maintains and utilizes a set of preferences that are not a part of the Palm OS system preferences. They can be retrieved using this function.
  • Err HsPrefSet (UInt16 pref, void *bufP, UInt32 prefSize)
    HsExtensions maintains and utilizes a set of preferences that are not a part of the Palm OS system preferences. They can be set using this function.
  • Err HsGetPhoneLibrary (UInt16 *refNum)
    Function that gets the reference number to the phone library. It decides whether it should return the GSM or the CDMA library based on the type of device. If the library is not loaded, it loads the library.
  • Err HsStatusSetGadgetType (void *frmP, UInt16 gadgetID, UInt16 type)
    Tell the system that a gadget on the form is a certain type of status gadget so that the system can properly draw and update it.
  • void HsStatusUpdateGadgets (void)
    Explicitly update all status gadgets on the current form.
  • Err HsGrfSetStateExt (Boolean capsLock, Boolean numLock, Boolean optLock, Boolean upperShift, Boolean optShift, Boolean autoShift)
    Extended version of GrfSetState to allow setting an option and option lock state.
  • Err HsGrfGetStateExt (Boolean *capsLockP, Boolean *numLockP, Boolean *optLockP, UInt16 *tempShiftP, Boolean *autoShiftedP)
    Extended version of GrfGetState to include detection of option and option lock state.
  • Boolean HsPutObjectAfterTitle (void *voidFrmP, UInt16 objID, UInt8 titleOffset)
    Places a UI object to the right of the form title. This function is useful for adjusting object positions for localized titles.
  • UInt32 HsInfo (UInt16 item, UInt16 paramSize, void *paramP)
    This call will return info on a particular attribute of the Handspring extensions.
  • UInt16 HsEvtMetaEvent (EventPtr eventP)
  • Err HsSpringboardNotSupported (void)
    Used to determine if the device supports the Springboard expansion slot or not.
  • void * HsGetTrapAddress (UInt16 trapNum)
    Works like SysGetTrapAddress, but for Handspring trap numbers.
  • Err HsNetworkDropConnection (void)
    This function will completely close the currently active TCP/IP network connection. The open count will be 0 after this call is made.
  • void HsUnimplemented (void)
  • void * HsGetARMActiveFormPtr (void)
  • FontID HsTwoFontSelect (FontID originalFont)
    Allows the user to select a small or a large font size.
  • void HsOpenDialNumberDialog (char *numberP, char *nameP, Boolean callerID)
    Opens a window with the number filled in the address text field.
  • Err HsTurnRadioOn (void)
    Turn the radio (cell phone) on if it’s off.
  • Err HsCreateNewMessage (char *addressP, char *nameP, char *msgP)
    Launches the messaging application (SMS) to the new message form with some fields optionally prefilled with the specified values.
  • Err HsCreateNewEmail (char *addressP, char *ccP, char *subjectP, char *msgP)
    Launches the email application to the new email form with some fields optionally prefilled with the specified values.
  • Err HsBrowseUrl (char *urlP)
    Launches the browser to the specified URL.
  • Err HsNavGetFocusRingInfo (const FormType *formP, UInt16 *objectIDP, Int16 *extraInfoP, RectangleType *boundsInsideRingP, HsNavFocusRingStyleEnum *ringStyleP)
    If a form has a system drawn focus ring, gets info about the ring.
  • Err HsNavDrawFocusRing (FormType *formP, UInt16 objectID, Int16 extraInfo, RectangleType *boundsInsideRingP, HsNavFocusRingStyleEnum ringStyle, Boolean forceRestore)
    Tells the system to draw a focus ring for an object.
  • Err HsNavRemoveFocusRing (FormType *formP)
    Removes system-drawn ring from around currently focused object.
  • void HsNavObjectTakeFocus (const FormType *formP, UInt16 objID)
    Sends a frmObjectFocusTake event for an object.
  • void HsNavGetFocusColor (HsNavFocusColorEnum color, RGBColorType *rgbColorP)
    Obtains a focus color.
  • void HsNavSetFocusColor (HsNavFocusColorEnum color, RGBColorType *rgbColorP, RGBColorType *oldRgbColorP)
    Sets new focus color.
  • Err HsIndicatorState (UInt16 count, UInt16 indicatorType, UInt16 *stateP)
    Set or get the state of the LED or Vibrator.
  • Err HsLightMode (Boolean set, UInt16 *modeP)
    Get or set the current mode.
  • Err HsLightCircumstance (Boolean add, UInt16 circumstance)
    Add/remove special lighting circumstances.
  • UInt16 HsCurrentLightCircumstance (void)
  • void HsKeyCurrentStateExt (UInt32 keys[3])
    Converts HsKeysPressed() results into a bitfield.
  • void HsKeySetMaskExt (const UInt32 keyMaskNew[3], UInt32 keyMaskOld[3])
    Glue to HsKeyEnabled() based on bitfields.
  • UInt16 HsKeysPressed (UInt16 count, const UInt16 keyCodes[], Boolean pressed[])
    Get the current state of specified keys.
  • Err HsKeyStop (UInt16 keyCode)
    Stop a key from sending any more autorepeat events until it is released.
  • Boolean HsKeyEnableKey (UInt16 keyCode, Boolean enabled)
    Enable/disable a key from generating key events.
  • UInt16 HsKeyChrCodeToKeyCode (UInt16 chrCode)
    Determine which key generates a certain character.
  • void HsKeyKeyCodeToChrCode (UInt16 keyCode, UInt16 modifiersIn, UInt16 *chrP, UInt16 *modifiersOutP)
    Translate a key code to the character generated by that key.
  • Boolean HsKeyEventIsFromKeyboard (EventPtr eventP)
    Determine if an event came from the physical keyboard.
  • Boolean HsExtDoSaveAsDialog (Char *name)
    Displays a dialog to the user allowing them to confirm the saving of data, and the name that they wish to assign.
  • UInt16 HsTxtPrepFindString (const Char *inSrcP, UInt16 inSrcLen, Char *outDstP, UInt16 inDstSize)
  • UInt32 HsTxtNumChars (Char const *textP)
  • void HsTxtTruncateString (Char *textP, UInt16 maxPixels, Boolean keepLabel)
  • Boolean HsTxtIsAscii (Char *textP, UInt16 textLen)
  • Boolean HsIsHTTPLibraryLoaded (void)
  • Int16 HsNavLstGetTempSelection (const FormType *formP, UInt16 listID)
    Obtains the temporarily selected item of an embedded list.
  • void HsNavLstSetTempSelection (const FormType *formP, UInt16 listID, Int16 itemNum)
    Sets the temporarily selected item for an embedded list.

Define Documentation

#define HsAboutHandspringAppWithYearCredId | ( | yearId,
 |  | creditsId | )

Value:

do                                                                      \
      {                                                                     \
        UInt16  appCardNo;                                                  \
        LocalID appDbId;                                                    \
        MemHandle   yearStrH, extraStrH;                                    \
        Char*   yearStrP;                                                   \
        Char*   extraStrP;                                                  \
                                                                            \
        yearStrH = DmGetResource (strRsc, yearId);                          \
        yearStrP = MemHandleLock (yearStrH);                                \
        extraStrH = DmGetResource (strRsc, creditsId);                      \
        extraStrP = MemHandleLock (extraStrH);                              \
        SysCurAppDatabase(&appCardNo, &appDbId);                            \
        HsAboutHandspringApp (appCardNo, appDbId, yearStrP, extraStrP);     \
        MemPtrUnlock (extraStrP);                                           \
        DmReleaseResource (extraStrH);                                      \
        MemPtrUnlock (yearStrP);                                            \
        DmReleaseResource (yearStrH);                                       \
      }                                                                     \
    while (0)

#define HsAboutHandspringAppWithYearId ( yearId )

Value:

do                                                                      \
      {                                                                     \
        UInt16  appCardNo;                                                  \
        LocalID appDbId;                                                    \
        MemHandle   yearStrH;                                               \
        Char*   yearStrP;                                                   \
                                                                            \
        yearStrH = DmGetResource (strRsc, yearId);                          \
        yearStrP = MemHandleLock (yearStrH);                                \
        SysCurAppDatabase(&appCardNo, &appDbId);                            \
        HsAboutHandspringApp (appCardNo, appDbId, yearStrP, NULL);          \
        MemPtrUnlock (yearStrP);                                            \
        DmReleaseResource (yearStrH);                                       \
      }                                                                     \
    while (0)

Function Documentation

void HsAboutHandspringApp | ( | UInt16 | appCardNo,
 |  | LocalID | appDbId,
 |  | Char * | copyrightYearStrP,
 |  | Char * | extraCreditsStrP
 | ) |

Parameters:
appCardNo,: IN:
appDbId,: IN:
copyrightYearStrP,: IN:
extraCreditsStrP,: IN:
Return values:
Error code.

Err HsAttrGet | ( | UInt16 | attr,
 |  | UInt32 | param,
 |  | UInt32 * | valueP
 | ) |

Get any Handspring specific attributes that aren’t appropriate to be accessed through a feature. (e.g., dynamic information about device state).

See also:
HsAttrEnum
Parameters:
attr,: IN: Which attribute is being retrieved. Most attributes are defined in “HsExtCommon.h” in the HsAttrEnum enumeration.
param,: IN: Meaning depends on ’attr’ (currently implemented attributes only take 0 for this argument).
valueP,: IN: Cast depending on attr (refer HsAttrEnum for data type this argument should point to).
Return values:
Err 0 if no error

Err HsAttrSet | ( | UInt16 | attr,
 |  | UInt32 | param,
 |  | UInt32 * | valueP
 | ) |

Set Handspring specific attributes.

See also:
HsAttrEnum
Parameters:
attr,: IN: Which attribute is being set.
param,: IN: Meaning depends on ’attr’ (currently implemented attributes only take 0 for this argument).
valueP,: IN: Cast depending on attr (refer HsAttrEnum for data type this argument should point to).
Return values:
Err 0 if no error hsErrNotSupported otherwise.

Err HsBrowseUrl ( char * urlP )

Launches the browser to the specified URL.

This function can be used by any application that wants to launch the web browser to a specified URL without using the helper APIs.

Parameters:
urlP,: IN: A pointer to a string that contains the phone number to put into the number field.
Return values:
Err 0 on success or the error that occurred.

Err HsCreateNewEmail | ( | char * | addressP,
 |  | char * | ccP,
 |  | char * | subjectP,
 |  | char * | msgP
 | ) |

Launches the email application to the new email form with some fields optionally prefilled with the specified values.

This function can be used by any application that wants to launch the email application and have some of the fields prefilled without using the helper APIs.

Parameters:
addressP,: IN: A pointer to a string that contains the address to put in the To: field.
ccP,: IN: A pointer to a string that contains the address to put in the cc: field. (optional)
subjectP,: IN: A pointer to a string that contains the subject of the new email. (optional)
msgP,: IN: A pointer to a string that contains the message text of the new email. (optional)
Return values:
Err 0 on success or the error that occurred.

Err HsCreateNewMessage | ( | char * | addressP,
 |  | char * | nameP,
 |  | char * | msgP
 | ) |

Launches the messaging application (SMS) to the new message form with some fields optionally prefilled with the specified values.

This function can be used by any application that wants to launch the messaging application and have some of the fields prefilled without using the helper APIs.

Parameters:
addressP,: IN: A pointer to a string that contains the phone number to put into the To: field. (optional)
nameP,: IN: A pointer to a string that contains the name to put above the To: field. (optional)
msgP,: IN: A pointer to a string that contains the message text of the new message. (optional)
Return values:
Err 0 on success or the error that occurred.

UInt16 HsEvtMetaEvent ( EventPtr eventP )

Parameters:
eventP,: IN:
Return values:
UInt16 Error code.

Boolean HsExtDoSaveAsDialog ( Char * name )

Displays a dialog to the user allowing them to confirm the saving of data, and the name that they wish to assign.

Parameters:
name,: IN: Comes in as the default name and returns the name the user chose
Return values:
Boolean True if the user confirmed that the save should take place. False otherwise.

Err HsGetPhoneLibrary ( UInt16 * refNum )

Function that gets the reference number to the phone library. It decides whether it should return the GSM or the CDMA library based on the type of device. If the library is not loaded, it loads the library.

Parameters:
refNum,: IN: Library reference number to be used in other function.
Return values:
Err 0 if no error.

void* HsGetTrapAddress ( UInt16 trapNum )

Works like SysGetTrapAddress, but for Handspring trap numbers.

For every HsExt function implemented in ARM native, there exists a wrapper 68K function that simply calls the HsExt function in question. This may seem roundabout, but HsGetTrapAddress is retained for backward compatibility.

Parameters:
trapNum,: IN: the address of the trap handler for the given selector.
Return values:
void* If the selector is invalid, returns the address of HsUnimplemented().

Err HsGetVersionString | ( | UInt16 | selector,
 |  | Char * | outStrP,
 |  | UInt16 * | sizeP
 | ) |

Retrieve a null terminated version string.

Parameters:
selector,: IN: Selects which version string to get
outStrP,: IN: Buffer to receive the NULL terminated version string. The buffer should be large enough to hold hsVersionStringSize bytes
sizeP,: IN: If not NULL, returns the number of bytes stored in *outStrP, including the NULL terminator
Return values:
0 if no error

Err HsGrfGetStateExt | ( | Boolean * | capsLockP,
 |  | Boolean * | numLockP,
 |  | Boolean * | optLockP,
 |  | UInt16 * | tempShiftP,
 |  | Boolean * | autoShiftedP
 | ) |

Extended version of GrfGetState to include detection of option and option lock state.

Parameters:
capsLockP,: IN: returns true if caps lock on
numLockP,: IN: returns true if num lock on
optLockP,: IN: returns true if opt lock on
tempShiftP,: IN: returns current temporary shift
autoShiftedP,: IN: returns TRUE if shift not set by the user but by the system, for example, at the beginning of a line.
Return values:
Err Always returns 0.

Err HsGrfSetStateExt | ( | Boolean | capsLock,
 |  | Boolean | numLock,
 |  | Boolean | optLock,
 |  | Boolean | upperShift,
 |  | Boolean | optShift,
 |  | Boolean | autoShift
 | ) |

Extended version of GrfSetState to allow setting an option and option lock state.

The original GrfSetState does not have an autoShift parameter because it always assumed that anyone setting the shift state through the API call wanted an automatic shift. We do not make this assumption. The shift state can be set by calling either HsGrfSetStateExt() or GrfSetState(). Either way, we have to make sure that both the keyboard shift state and the Graffiti engine’s shift state get set correctly.

Parameters:
capsLock,: IN: Set to turn caps lock on
numLock,: IN: Set to true to turn num lock on
optLock,: IN: Set to true to turn option lock on
upperShift,: IN: Set to true to put into upper shift
optShift,: IN: Set to true to put into option shift
autoShift,: IN: Valid only if upperShift is true. Set to true if the graffiti engine should consider the upper shift an auto shift.
Return values:
Err Always returns 0.

Err HsIndicatorState | ( | UInt16 | count,
 |  | UInt16 | indicatorType,
 |  | UInt16 * | stateP
 | ) |

Set or get the state of the LED or Vibrator.

Parameters:
count,: IN: Count of how many times to blink or pulse the indicator, or one of the HsIndicatorCountEnum values to either run forever or get the current state.
indicatorType,: IN: HsIndicatorTypeEnum (LED or vibrator)
stateP,: IN: Pointer to HsIndicatorStateEnum If setting, points to state to set. If getting, as IN param points to “none” state of the source to query (or kIndicatorStateNull to query whatever source has priority). As OUT param, contains the result of the query (kIndicatorStateNull if querying for the active source and there is none)
Return values:
Err 0 if no error

UInt32 HsInfo | ( | UInt16 | item,
 |  | UInt16 | paramSize,
 |  | void * | paramP
 | ) |

This call will return info on a particular attribute of the Handspring extensions.

This call is designed to return info that won’t fit into a Palm OS feature call (a UInt32).

Parameters:
item,: IN: which info to return
paramSize,: IN: size of paramP block passed in
paramP,: IN: info is returned here
Return values:
UInt32 0 if no error

Boolean HsIsHTTPLibraryLoaded ( void )

Return values:
Boolean

UInt16 HsKeyChrCodeToKeyCode ( UInt16 chrCode )

Determine which key generates a certain character.

Parameters:
chrCode,: IN: the character to search for
Return values:
UInt16 The key code.

void HsKeyCurrentStateExt ( UInt32 keys[3] )

Converts HsKeysPressed() results into a bitfield.

This function provides compatibility with earlier Handspring SDKs. The preferred method of querying key states is to call HsKeysPressed().

Parameters:
keys,: IN: Array of three bitfields representing which keys are depressed.

Boolean HsKeyEnableKey | ( | UInt16 | keyCode,
 |  | Boolean | enabled
 | ) |

Enable/disable a key from generating key events.

Parameters:
keyCode,: IN: which key to enable/disable
enabled,: IN: true to enable, false to disable
Return values:
Boolean true if previously enabled.

Boolean HsKeyEventIsFromKeyboard ( EventPtr eventP )

Determine if an event came from the physical keyboard.

Parameters:
eventP,: IN: The event to check
Return values:
Boolean True if the event came from the keyboard

void HsKeyKeyCodeToChrCode | ( | UInt16 | keyCode,
 |  | UInt16 | modifiersIn,
 |  | UInt16 * | chrP,
 |  | UInt16 * | modifiersOutP
 | ) |

Translate a key code to the character generated by that key.

Parameters:
keyCode,: IN: The key to lookup
modifiersIn,: IN: Modifier mask indicating which character should be returned
chrP,: IN: The character produced by the key
modifiersOutP,: IN: The keyMask bits that must be set if a keyDown event is formed with the character. (Not including the bits set in modifiersIn)

void HsKeySetMaskExt | ( | const UInt32 | keyMaskNew[3],
 |  | UInt32 | keyMaskOld[3]
 | ) |

Glue to HsKeyEnabled() based on bitfields.

This function provides compatibility with earlier Handspring SDKs. The preferred method of enabling keys is to call HsKeyEnableKey().

Parameters:
keyMaskNew,: IN: new enabled mask
keyMaskOld,: IN: previous enabled mask

UInt16 HsKeysPressed | ( | UInt16 | count,
 |  | const UInt16 | keyCodes[],
 |  | Boolean | pressed[]
 | ) |

Get the current state of specified keys.

This extends KeyCurrentState().

Parameters:
count,: IN: number of elements in keyCodes[] and pressed[]
keyCodes[],: IN: Array of keyCodes to test
pressed[],: IN: Each element is set to true if the key specified by the corresponding element in keyCodes[] is pressed, and set to false if it’s not pressed. It is acceptable to pass NULL if only the return value is of interest.
Return values:
UInt16 Count of keys in keyCodes[] that are pressed

Err HsKeyStop ( UInt16 keyCode )

Stop a key from sending any more autorepeat events until it is released.

Parameters:
keyCode,: IN: key to stop
Return values:
Err errNone if the keyCode is the last key pressed and it’s still held.

Err HsLightCircumstance | ( | Boolean | add,
 |  | UInt16 | circumstance
 | ) |

Add/remove special lighting circumstances.

This function does reference counting on added circumstances, so be sure to not add a circumstance without eventually removing it (unless you intended that). Note that some circumstances don’t take effect until some point in time later (in SysHandleEvent). That’s because some circumstances only take effect when the device is idle for some amount of time.

Parameters:
add,: IN: If true, we’re adding a circumstance, If false, we’re removing it.
circumstance,: IN: The circumstance we’re adding or taking away (refer HsLightCircumstanceEnum).
Return values:
Err An error code; 0 if no error

Err HsLightMode | ( | Boolean | set,
 |  | UInt16 * | modeP
 | ) |

Get or set the current mode.

Parameters:
set,: IN: If true, we’ll switch to *modeP; if false we’ll put the current mode in *modeP
modeP,: IN: If we’re setting, we’ll switch to this mode (refer HsLightModeEnum). If we’re getting, we’ll put the current mode here.
Return values:
Err An error code; 0 if no error.

Err HsNavDrawFocusRing | ( | FormType * | formP,
 |  | UInt16 | objectID,
 |  | Int16 | extraInfo,
 |  | RectangleType * | boundsInsideRingP,
 |  | HsNavFocusRingStyleEnum | ringStyle,
 |  | Boolean | forceRestore
 | ) |

Tells the system to draw a focus ring for an object.

Parameters:
formP,: IN: Form containing object whose ring is being drawn
objectID,: IN: ID of object getting the focus ring
extraInfo,: IN: Any info that caller wants associated with the focus ring. For example, the system uses this field to store the temporarily-selected item of a focused, embedded list. Caller should pass hsNavFocusRingNoExtraInfo (0xFFFF) if there is no associated info.
boundsInsideRingP,: IN: Points to the bounds around which the ring should be drawn
ringStyle,: IN: Enumeration value that represents the desired style for the ring. hsNavFocusRingStyleObjectTypeDefault can be passed if caller just wants the default ring style for the object’s type.
forceRestore,: IN: If ring is already on the object, whether to force restoration of what’s behind the ring before redrawing the ring.
Return values:
Err Returns errNone if no error, error code otherwise.

void HsNavGetFocusColor | ( | HsNavFocusColorEnum | color,
 |  | RGBColorType * | rgbColorP
 | ) |

Obtains a focus color.

Parameters:
color,: IN: Enumeration value that specifies which focus color to get
rgbColorP,: IN: On exit, points to the focus color

Err HsNavGetFocusRingInfo | ( | const FormType * | formP,
 |  | UInt16 * | objectIDP,
 |  | Int16 * | extraInfoP,
 |  | RectangleType * | boundsInsideRingP,
 |  | HsNavFocusRingStyleEnum * | ringStyleP
 | ) |

If a form has a system drawn focus ring, gets info about the ring.

Parameters:
formP,: IN: Ptr to form whose ring info is to be obtained
objectIDP,: IN: If not NULL, on exit will point to the object with the system-drawn focus ring
extraInfoP,: IN: If not NULL, on exit will point to any extra info associated with the focus ring. Extra info is any info that the caller wants to associate with a ring. hsNavFocusRingNoExtraInfo (0xFFFF) is used to represent no extra info.
boundsInsideRingP,: IN: If not NULL, on exit will point to the bounds inside the system-drawn focus ring
ringStyleP,: IN: If not NULL, on exit will point to the style of the focus ring
Return values:
Err Error code.

Int16 HsNavLstGetTempSelection | ( | const FormType * | formP,
 |  | UInt16 | listID
 | ) |

Obtains the temporarily selected item of an embedded list.

Parameters:
formP,: IN: Pointer to the form containing the list whose temporary selection is to be obtained
listID,: IN: ID of list whose temporary selection is to be obtained
Return values:
Int16 Returns the temporarily selected list item

void HsNavLstSetTempSelection | ( | const FormType * | formP,
 |  | UInt16 | listID,
 |  | Int16 | itemNum
 | ) |

Sets the temporarily selected item for an embedded list.

Parameters:
formP,: IN: Pointer to the form containing the list whose temporary selection is to be set
listID,: IN: ID of list whose temporary selection is to be set
itemNum,: IN: Number of the item that should be temporarily selected

void HsNavObjectTakeFocus | ( | const FormType * | formP,
 |  | UInt16 | objID
 | ) |

Sends a frmObjectFocusTake event for an object.

Parameters:
formP,: IN: Ptr to form that contains the object
objID,: IN: ID of the object

Err HsNavRemoveFocusRing ( FormType * formP )

Removes system-drawn ring from around currently focused object.

Parameters:
formP,: IN: Ptr to form containing the object with the ring
Return values:
Err Returns errNone if no error, error code otherwise

void HsNavSetFocusColor | ( | HsNavFocusColorEnum | color,
 |  | RGBColorType * | rgbColorP,
 |  | RGBColorType * | oldRgbColorP
 | ) |

Sets new focus color.

Parameters:
color,: IN: Enumeration value that specifies which focus color to set
rgbColorP,: IN: Points to the new color
oldRgbColorP,: IN: If not NULL, on exit it will point to the old focus color

Err HsNetworkDropConnection ( void )

This function will completely close the currently active TCP/IP network connection. The open count will be 0 after this call is made.

Return values:
Err 0 if successful.

void HsOpenDialNumberDialog | ( | char * | numberP,
 |  | char * | nameP,
 |  | Boolean | callerID
 | ) |

Opens a window with the number filled in the address text field.

This function can be used by any application that wants to dial a phone number, but first give the user the option of editing the number. This functionality originally existed in the STE, but was moved to the system.

Parameters:
numberP,: IN: A pointer to a string that contains the phone number to put into the number field.
nameP,: IN: A pointer to a string that contains the name to put into the title of the dialog.
callerID,: IN: If this is true, then we will attempt to match the phone number with an entry in the address book. If a match is found, then the title of the dialog will contain the name.

Err HsPrefGet | ( | UInt16 | pref,
 |  | void * | bufP,
 |  | UInt32 * | prefSizeP
 | ) |

HsExtensions maintains and utilizes a set of preferences that are not a part of the Palm OS system preferences. They can be retrieved using this function.

See also:
HsPrefEnum
Parameters:
pref,: IN: IN which preference to retrieve (refer HsPrefEnum)
bufP,: IN: IN buffer to store preference (refer HsPrefEnum for the size of the buffer needed).
prefSizeP,: IN: IN/OUT on entry, size of bufP on exit, size of stored pref. If larger than size of bufP, then hsErrBufferTooSmall is returned.
Return values:
Err 0 if no err hsErrInvalidParam if pref is invalid hsErrBufferTooSmall if *prefSizeP was smaller than actual pref

Err HsPrefSet | ( | UInt16 | pref,
 |  | void * | bufP,
 |  | UInt32 | prefSize
 | ) |

HsExtensions maintains and utilizes a set of preferences that are not a part of the Palm OS system preferences. They can be set using this function.

See also:
HsPrefEnum
Parameters:
pref,: IN: which pref to retrieve, a HsPrefEnum
bufP,: IN: buffer to store pref
prefSize,: IN: size of pref to store
Return values:
Err 0 if no err hsErrInvalidParam if pref is invalid

Boolean HsPutObjectAfterTitle | ( | void * | voidFrmP,
 |  | UInt16 | objID,
 |  | UInt8 | titleOffset
 | ) |

Places a UI object to the right of the form title. This function is useful for adjusting object positions for localized titles.

Parameters:
voidFrmP,: IN: ptr to form containing the object
objID,: IN: id of the object being positioned
titleOffset,: IN: number of pixels between title bar and status gadget
Return values:
Boolean True if the object was moved from it’s original position. False otherwise

Err HsSpringboardNotSupported ( void )

Used to determine if the device supports the Springboard expansion slot or not.

On springboard devices, this function is unimplemented. To determine whether the device has a Springboard extension slot or not, use HsGetTrapAddress() to obtain the trap addresses of this function and HsUnimplemented. If they are equal, the device has the Springboard extension slot, otherwise it doesn’t.

Return values:
Err All of the Springboard functions return an error on the Treo 600.

Err HsStatusSetGadgetType | ( | void * | frmP,
 |  | UInt16 | gadgetID,
 |  | UInt16 | type
 | ) |

Tell the system that a gadget on the form is a certain type of status gadget so that the system can properly draw and update it.

Tell the system that a gadget on the form is a certain type of status gadget so that the system can properly draw and update it. A form can only have one gadget for each status type. If more than one gadget is set to a certain type, only the last one set will be recorded. This function can also be used to erase and release a gadget whose type has already been set. To do this, type should be set to 0.

NOTE The gadget dimensions in the current implementation are hardcoded to values of 10 X 12 pixels for the battery gadget and 16 X 12 pixels for signal gadget. Scaling is not supported, so define your gadget resources accordingly.

Parameters:
frmP,: IN: pointer to the form with the gadget (we will convert to an ID before saving but want a ptr to be passed as a param to ensure that the caller is setting the gadget for a loaded form)
gadgetID,: IN: id of the gadget whose type is being specified
type,: IN: type of the gadget (pass a member of HsStatusGadgetTypeEnum—defined in HsExt.h or 0 to erase and release a gadget)
Return values:
Err 0 if no error.

void HsStatusUpdateGadgets ( void )

Explicitly update all status gadgets on the current form.

Err HsTurnRadioOn ( void )

Turn the radio (cell phone) on if it’s off.

Return values:
Err 0 if successful.

FontID HsTwoFontSelect ( FontID originalFont )

Allows the user to select a small or a large font size.

This is just like the Palm OS routine FontSelect, except it gives the user a choice of only a small and a large font. If the originalFont is not bold, then the two choices are stdFont and largeFont. If the original choice is bold, then the two choices are boldFont and largeBoldFont.

Parameters:
originalFont,: IN: The original font ID (used to select the current font).
Return values:
FontID The new font ID.

Boolean HsTxtIsAscii | ( | Char * | textP,
 |  | UInt16 | textLen
 | ) |

Parameters:
textP,: IN:
textLen,: IN:
Return values:
Boolean

UInt32 HsTxtNumChars ( Char const * textP )

Parameters:
textP,: IN:
Return values:
UInt32

UInt16 HsTxtPrepFindString | ( | const Char * | inSrcP,
 |  | UInt16 | inSrcLen,
 |  | Char * | outDstP,
 |  | UInt16 | inDstSize
 | ) |

Parameters:
inSrcP,: IN:
inSrcLen,: IN:
outDstP,: IN:
inDstSize,: IN:
Return values:
UInt16

void HsTxtTruncateString | ( | Char * | textP,
 |  | UInt16 | maxPixels,
 |  | Boolean | keepLabel
 | ) |

Parameters:
textP,: IN:
maxPixels,: IN:
keepLabel,: IN:

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:30 2006 for Palm API Guide


HsExtCommon.h File Reference

Detailed Description

Common defines shared between HsExt.h (include for 68K programs) and HsExtArm.h (include for ARM programs).

  • #define hsAttrSysActiveHotSync 0x0001
  • #define hsAttrSysActiveProgress 0x0002
  • #define hsAttrPhoneTypeCDMA 0x0001
  • #define hsAttrPhoneTypeGSM 0x0002
  • #define hsOLDErrorClass (appErrorClass+0x0100)
  • #define hsErrNotSupported (hsOLDErrorClass | 0x01)
  • #define hsErrInvalidCardNum (hsOLDErrorClass | 0x02)
  • #define hsErrReadOnly (hsOLDErrorClass | 0x03)
  • #define hsErrInvalidParam (hsOLDErrorClass | 0x04)
  • #define hsErrBufferTooSmall (hsOLDErrorClass | 0x05)
  • #define hsErrInvalidCardHdr (hsOLDErrorClass | 0x06)
  • #define hsErrCardPatchAlreadyInstalled (hsOLDErrorClass | 0x07)
  • #define hsErrCardPatchNotInstalled (hsOLDErrorClass | 0x08)
  • #define hsErrNotEnoughPower (hsOLDErrorClass | 0x09)
  • #define hsErrCardNotInstalled (hsOLDErrorClass | 0x0A)
  • #define hsErrInvalidPeriod (hsOLDErrorClass | 0x0B)
  • #define hsErrPeriodicNotInstalled (hsOLDErrorClass | 0x0C)
  • #define hsErrFixedStorageRequired (hsOLDErrorClass | 0x0D)
  • #define hsErrPeriodicAlreadyInstalled (hsOLDErrorClass | 0x0E)
  • #define hsErrInUse (hsOLDErrorClass | 0x0F)
  • #define hsErrIndicatorInvalidSequence (hsOLDErrorClass | 0x10)
  • #define hsErrIndicatorInvalidCap (hsOLDErrorClass | 0x11)
  • #define hsErrIndicatorDisabled (hsOLDErrorClass | 0x12)
  • #define hsErrUnderflow (hsExtErrorClass | 0x13)
  • #define hsErrUserNoRadio (hsExtErrorClass | 0x14)
  • #define hsErrOutOfCoverage (hsExtErrorClass | 0x15)
  • #define hsErrAppStopEvent (hsExtErrorClass | 0x16)
  • #define hsErrOutOfMemory (hsExtErrorClass | 0x17)
  • #define hsErrSIMMissing (hsExtErrorClass | 0x18)
  • #define hsErrGPRSNotAttached (hsExtErrorClass | 0x19)
  • #define hsErrTimeOut (hsExtErrorClass | 0x1A)
  • #define hsErrUserInterrupted (hsExtErrorClass | 0x1B)
  • #define hsLibAliasDefault "Serial Library"
  • #define hsLibAliasHotSyncLocal "*HsLoc SerLib"
  • #define hsLibAliasHotSyncModem "*HsMdm SerLib"
  • #define hsLibAliasIrda "*Irda SerLib"
  • #define hsLibAliasConsole "*Cons SerLib"
  • #define hsLibNameBuiltInSerial "BuiltIn SerLib"
  • #define hsFtrCreator 'hsEx'
  • #define hsFtrIDVersion 0
  • #define hsFtrIDModDate 1
  • #define hsFtrIDLdbMgrLibRefNum 2
  • #define hsFtrIDNoMemSemaphore 3
  • #define hsFtrIDBugsFixed 4
  • #define hsFtrIDTypeOfKeyboard 5
  • #define hsFtrValKeyboardBasic 0x0001
  • #define hsFtrValKeyboardQwerty 0x0002
  • #define hsFtrValKeyboardJog 0x0004
  • #define hsFtrValKeyboardCommCentric 0x0008
  • #define hsFtrValKeyboardCustomApps 0x0010
  • #define hsFtrIDRadioAttributes 6
  • #define hsFtrValRadioAvailable 0x0001
  • #define hsFtrValRadioBuiltin 0x0002
  • #define hsFtrIDPowerKeyResponse 7
  • #define hsFtrValPowerKeyDoubleClkBacklight 0x0001
  • #define hsFtrValPowerKeyTripleClkInvert 0x0002
  • #define hsFtrValPowerKeyHoldRadioPower 0x0004
  • #define hsFtrIDStatusGadgetRev 8
  • #define hsFtrValStatusGadgetRev1 0x0001
  • #define hsFtrIDGrfAreaDisabled 9
  • #define hsFtrIDKeyboardLayout 10
  • #define hsFtrValKeyboardLayout_enUS 0x0001
  • #define hsFtrValKeyboardLayout_deDE 0x0002
  • #define hsFtrValKeyboardLayout_frFR 0x0003
  • #define hsFtrIDToneOnLidOpen 11
  • #define hsFtrIDCurrentAppOnSleep 12
  • #define hsFtrValCurrentAppOnSleepPhoneAppSpeedDialView 0x0001
  • #define hsFtrIDTestingBootMode 13
  • #define hsFtrIDNavigationSupported 14
  • #define hsFtrIDHardwareApiRevision 15
  • #define hsDispFtrCreator 'DisA'
  • #define hsDispFtrIDDisplayAttributes 0

Values for the display attributes, which is a bitfield.

  • #define hsDispFtrValLCDControllerTypeMask 0x000000FF
  • #define hsDispFtrValDragonballVZ 0x00000000
  • #define hsDispFtrValSed1375 0x00000001
  • #define hsDispFtrValSed1376 0x00000002
  • #define hsDispFtrValSed13A3 0x00000003
  • #define hsDispFtrValOmapX10 0x00000004
  • #define hsDispFtrValBulverdePxa27X 0x00000005
  • #define hsDispFtrValLCDDisplayTypeMask 0x0000FF00
  • #define hsDispFtrValBwStn 0x00000100
  • #define hsDispFtrValColorStn 0x00000200
  • #define hsDispFtrValColorTft 0x00000300
  • #define hsDispFtrValColorOled 0x00000400

Available Shades

This feature contains the number of shades of gray, red, green, and blue available on this display. Note that this will _never_ be bigger than the number of shades available on the controller, since the display is fundamentally limited by what you can set the controller to. See masks below for accessing...
  • #define hsDispFtrIDDisplayShades 1
  • #define hsDispFtrIDControllerShades 2
  • #define hsDispFtrValGrayOffset 24
  • #define hsDispFtrValRedOffset 16
  • #define hsDispFtrValGreenOffset 8
  • #define hsDispFtrValBlueOffset 0

Special values for hsPrefKeyguardAutoEnableTime

  • #define hsKeyguardAutoDisabled 0
  • #define hsKeyguardAutoPowerOff 0xFFFF

Values for hsPrefKeyguardFlags

  • #define hsKeyguardFlagPowerOnDialog 0x0001

Bit definitions for hsPrefTouchscreenDisableFlags

  • #define hsTouchscreenDisableFlagIncomingCall 0x0001
  • #define hsTouchscreenDisableFlagDuringCall 0x0002

Bit Flag for Light Circumstances

application may call HsCurrentLightCircumstance() to get current enabled light circumstances

test bit to see if light circumstance is enabled or disabled

  • #define hsLightCircumstanceAlertWokeDeviceFlagBit 0x0001
  • #define hsLightCircumstanceQuickTypingFlagBit 0x0002
  • #define hsLightCircumstanceUserNotLookingFlagBit 0x0004
  • #define hsLightCircumstanceUserNotLookingLongTimeFlagBit 0x0008
  • #define hsLightCircumstanceKeylightOffFlagBit 0x0010

HAL IDs

Handspring generally doesn't differentiate different HALs and uses the same ID in multiple places... Use the device ID to figure out which devide you're on. If you're looking to see which version of HsExtensions is available, see the HsExtensions feature (hsFtrIDVersion)...
  • #define hsHALIDHandspringOs35_40 'Hs01'
  • #define hsHALIDHandspringOs5Rev1 'H5_1'
  • #define hsHALIDHandspringOs5Rev1Sim 'H5s1'
  • #define hsHALIDHandspringOs5Rev2 'H5_2'
  • #define hsHALIDHandspringOs5Rev2Sim 'H5s2'
  • #define hsHALIDHandspringOs5Rev3 'P052'
  • #define hsHALIDHandspringOs5Rev3Sim 'S052'
  • #define hsHALIDHandspringOs5Rev4 'P053'
  • #define hsHALIDHandspringOs5Rev4Sim 'S053'

Device IDs

Older devices don't use 4-character constants; newer devices do. Sometimes devices will have the same ID if they are extremely similar. You may need to use alternate means to differentiate between such products.
  • #define hsDeviceIDVisor 0x00
  • #define hsDeviceIDVisorPlatinum 0x08
  • #define hsDeviceIDVisorEdge 0x09
  • #define hsDeviceIDVisorPrism 0x0A
  • #define hsDeviceIDTreo180 0x0B
  • #define hsDeviceIDTreo270 0x0D
  • #define hsDeviceIDTreo300 0x0E
  • #define hsDeviceIDVisorNeo 0x8A
  • #define hsDeviceIDVisorPro 0x8B
  • #define hsDeviceIDTreo90 0x8C

Defines

  • #define hsVersionStringSize 32
  • #define hsAttrRingSwitchMute 0
  • #define hsAttrRingSwitchLoud 0x8000
  • #define hsWordCorrectMaxWordLen 25
  • #define hsMaxSaveAsNameSize 32
  • #define hsDeviceIDTreo600 kPalmOneDeviceIDTreo600
  • #define hsDeviceIDTreo600Sim kPalmOneDeviceIDTreo600Sim
  • #define hsDeviceIDOs5Device1 kPalmOneDeviceIDTreo600
  • #define hsDeviceIDOs5Device1Sim kPalmOneDeviceIDTreo600Sim

Enumerations

  • enum HsVerStrEnum {
    hsVerStrComplete,
    hsVerStrSerialNo,
    hsVerStrHardware,
    hsVerStrProductName,
    hsVerStrCarrierID,
    hsVerStrProductRev,
    hsVerStrROMBuild,
    hsVerStrFirmwareVer,
    hsVerStrPalmOSVer,
    hsVerStrLifeTime
    }
  • enum HsAttrEnum {
    hsAttr68KLidOpen,
    hsAttr68KSysSleepReason,
    hsAttr68KDisplayOn,
    hsAttr68KRingSwitch,
    hsAttr68KPostProcessRsc,
    hsAttr68KSysActive,
    hsAttr68KActiveCalls,
    hsAttr68KPhoneType,
    hsAttr68KKeyboardLocked,
    hsAttr68KKeyLockNextWakeTicks,
    hsAttrLidOpen = 0x80,
    hsAttrSysSleepReason,
    hsAttrDisplayOn,
    hsAttrRingSwitch,
    hsAttrPostProcessRsc,
    hsAttrSysActive,
    hsAttrActiveCalls,
    hsAttrPhoneType,
    hsAttrKeyboardLocked,
    hsAttrKeyLockNextWakeTicks,
    hsAttrKeyboardDB,
    hsAttrDigitizerLock,
    hsAttrE911Mode,
    hsAttrDitherSuppress,
    hsAttrHotSyncSuppress,
    hsAttrPhoneRadioPowerState,
    hsAttrAllKeysWakeFromSleep,
    hsForcePrefAutoOffDurationSecs,
    hsAttrKeyguardDialogOn,
    hsAttrReserved_SDK20_1,
    hsAttrReserved_SDK20_2,
    hsAttrReserved_SDK20_3,
    hsAttrReserved_SDK20_4,
    hsAttrReserved_SDK20_5,
    hsAttrReserved_SDK20_6,
    hsAttrReserved_SDK20_7
    }
  • enum HsPrefEnum {
    hsPrefSerialLibDef,
    hsPrefSerialLibHotSyncLocal,
    hsPrefSerialLibHotSyncModem,
    hsPrefSerialLibIrda,
    hsPrefSerialLibConsole,
    hsPrefJogScanCharAppCreator,
    hsPrefLidStatusChgCharAppCreator,
    hsPrefOptHard1CharAppCreator,
    hsPrefOptHard2CharAppCreator,
    hsPrefOptHard3CharAppCreator,
    hsPrefOptHard4CharAppCreator,
    hsPrefTempShiftTimeOut,
    hsPrefLidClosedAutoOffSeconds,
    hsPrefLCDRefreshRate,
    hsPrefNetworkTimeSelected,
    hsPrefKeyguardAutoEnableTime,
    hsPrefKeyguardAutoEnableAutoOffExtraTime,
    hsPrefKeyguardFlags,
    hsPrefTouchscreenDisableFlags,
    hsPrefOptHardPowerCharAppCreator,
    hsPrefOptReservedCharAppCreator,
    hsPrefPowerOnAppCreator,
    hsPrefSideHardCharAppCreator,
    hsPrefBlinkGreenLEDInCoverage,
    hsPrefHard11CharAppCreator,
    hsPrefOptHard11CharAppCreator,
    hsPrefUserNotLookingTime,
    hsPrefNetworkTZSelected,
    hsPrefLast
    }
  • enum HsStatusGadgetTypeEnum {
    hsStatusGadgetBattery = 1,
    hsStatusGadgetSignal = 2
    }
  • enum HsLightModeEnum {
    hsLightModeNormal = 0,
    hsLightModeNight = 1,
    hsLightModeNumPresets,
    hsLightModeReserved = 0x7FFF
    }
  • enum HsLightCircumstanceEnum {
    hsLightCircumstanceFirst = 0,
    hsLightCircumstanceAlertWokeDevice = 0,
    hsLightCircumstanceQuickTyping = 1,
    hsLightCircumstanceUserNotLooking = 2,
    hsLightCircumstanceUserNotLookingLongTime = 3,
    hsLightCircumstanceKeylightOff = 4,
    hsLightCircumstanceNumCircumstances,
    hsLightCircumstanceReserved = 0x7FFF
    }
  • enum HsIndicatorTypeEnum {
    kIndicatorTypeLed,
    kIndicatorTypeVibrator,
    kIndicatorTypeCount
    }
  • enum HsIndicatorCountEnum {
    kIndicatorCountGetState = 0,
    kIndicatorCountForever = 0xFFFF
    }
  • enum HsIndicatorStateEnum {
    kIndicatorStateNull = 0x0000,
    kIndicatorForceNone = 0x0100,
    kIndicatorForceOn = 0x0101,
    kIndicatorForceRed = 0x0101,
    kIndicatorForceGreen,
    kIndicatorForceRedGreen,
    kIndicatorForceOff = 0x0180,
    kIndicatorRingNone = 0x0200,
    kIndicatorRingActive,
    kIndicatorRingContact,
    kIndicatorRingRoam,
    kIndicatorAlertNone = 0x0300,
    kIndicatorAlertAlert,
    kIndicatorAlertMail,
    kIndicatorAlertCalendar,
    kIndicatorAlertSMS,
    kIndicatorAlertVoicemail,
    kIndicatorAlertPending,
    kIndicatorBattNone = 0x0400,
    kIndicatorBattCharge,
    kIndicatorBattTrickle,
    kIndicatorBattFull,
    kIndicatorBattLow,
    kIndicatorUsageNone = 0x0600,
    kIndicatorUsageVoiceCall,
    kIndicatorUsageDataCall,
    kIndicatorSignalNone = 0x0500,
    kIndicatorSignalBad,
    kIndicatorSignalGood,
    kIndicatorSignalRoam
    }

Define Documentation

#define hsAttrPhoneTypeCDMA 0x0001

Type of phone. Possible values of hsAttrPhoneType CDMA Phone

#define hsAttrPhoneTypeGSM 0x0002

GSM Phone

#define hsAttrRingSwitchLoud 0x8000

Sounds-on position

#define hsAttrRingSwitchMute 0

Possible values of hsAttrRingSwitch For now there are only two values, but it's left open to have a control that works more like a volume control and has a range of settings. The value of the "loud" setting was chosen so that it can be decided later to make this a bit field or a scalar value. Silent position

#define hsAttrSysActiveHotSync 0x0001

Current system activity. Possible bits for hsAttrSysActivity Hot sync in progress

#define hsAttrSysActiveProgress 0x0002

Progress dialog is up (e.g. beaming)

#define hsDeviceIDTreo180 0x0B

Treo 180

#define hsDeviceIDTreo270 0x0D

Treo 270

#define hsDeviceIDTreo300 0x0E

Treo 300

#define hsDeviceIDTreo600 kPalmOneDeviceIDTreo600

Treo 600

#define hsDeviceIDTreo600Sim kPalmOneDeviceIDTreo600Sim

Treo 600 Simulator

#define hsDeviceIDTreo90 0x8C

Treo 90

#define hsDeviceIDVisor 0x00

Visor, Visor Deluxe

#define hsDeviceIDVisorEdge 0x09

Visor Edge

#define hsDeviceIDVisorNeo 0x8A

Visor Neo (some Neos may have 0x08)

#define hsDeviceIDVisorPlatinum 0x08

Visor Platinum, some Visor Neos

#define hsDeviceIDVisorPrism 0x0A

Visor Prism

#define hsDeviceIDVisorPro 0x8B

Visor Pro

#define hsDispFtrCreator 'DisA'

Display Attribute Features

#define hsDispFtrIDControllerShades 2

This feature contains the number of shades of gray, red, green, and blue available on this controller. This can be larger than the number of shades that the display can show, since the controller can do hardware dithering to deal with the fact that the display can't show all the shades.

Software dithering is handled separately. If there is software dithering, it can be suppressed. See hsAttrDitherSuppress

#define hsDispFtrIDDisplayAttributes 0

Attributes about the display / controller combination...

#define hsDispFtrValBulverdePxa27X 0x00000005

Intel Bulverde PXA 270, 271, etc.

#define hsDispFtrValBwStn 0x00000100

The black and white STN used in black and white Visors and Treos.

#define hsDispFtrValColorOled 0x00000400

Organic LED

#define hsDispFtrValColorStn 0x00000200

Color STN

#define hsDispFtrValColorTft 0x00000300

Color TFT (used in Prism)

#define hsDispFtrValGrayOffset 24

You can use these bitmasks to get the number of shades ...note that the actual number of shades is the (value+1). This is needed so in the future we can support displays/controllers that can have 256 shades.

#define hsDispFtrValOmapX10 0x00000004

TI OMAP 1510/310

#define hsErrAppStopEvent (hsExtErrorClass | 0x16)

The blocking call was interrupted by AppStop event

#define hsErrBufferTooSmall (hsOLDErrorClass | 0x05)

Error codes

#define hsErrCardNotInstalled (hsOLDErrorClass | 0x0A)

Error codes

#define hsErrCardPatchAlreadyInstalled (hsOLDErrorClass | 0x07)

Error codes

#define hsErrCardPatchNotInstalled (hsOLDErrorClass | 0x08)

Error codes

#define hsErrFixedStorageRequired (hsOLDErrorClass | 0x0D)

Error codes

#define hsErrGPRSNotAttached (hsExtErrorClass | 0x19)

Failed to attach GPRS, or timed out while waiting to register

#define hsErrIndicatorDisabled (hsOLDErrorClass | 0x12)

Error codes

#define hsErrIndicatorInvalidCap (hsOLDErrorClass | 0x11)

Error codes

#define hsErrIndicatorInvalidSequence (hsOLDErrorClass | 0x10)

Error codes

#define hsErrInUse (hsOLDErrorClass | 0x0F)

Error codes

#define hsErrInvalidCardHdr (hsOLDErrorClass | 0x06)

Error codes

#define hsErrInvalidCardNum (hsOLDErrorClass | 0x02)

Error codes

#define hsErrInvalidParam (hsOLDErrorClass | 0x04)

Error codes

#define hsErrInvalidPeriod (hsOLDErrorClass | 0x0B)

Error codes

#define hsErrNotEnoughPower (hsOLDErrorClass | 0x09)

Error codes

#define hsErrNotSupported (hsOLDErrorClass | 0x01)

Error codes

#define hsErrOutOfCoverage (hsExtErrorClass | 0x15)

Failed to register on carrier's network, or timed out while waiting to register.

#define hsErrOutOfMemory (hsExtErrorClass | 0x17)

Request failed because of insufficient memory

#define hsErrPeriodicAlreadyInstalled (hsOLDErrorClass | 0x0E)

Error codes

#define hsErrPeriodicNotInstalled (hsOLDErrorClass | 0x0C)

Error codes

#define hsErrReadOnly (hsOLDErrorClass | 0x03)

Error codes

#define hsErrSIMMissing (hsExtErrorClass | 0x18)

The SIM is missing, invalid, wrong unlock code, or some other SIM problem detected that prevented network registration from completing.

#define hsErrTimeOut (hsExtErrorClass | 0x1A)

The requiested operation timed out, without completing its objective

#define hsErrUnderflow (hsExtErrorClass | 0x13)

Unexpected numerical underflow encountered

#define hsErrUserInterrupted (hsExtErrorClass | 0x1B)

The requiested operation was interrupted or cancelled by user, before completing its objective

#define hsErrUserNoRadio (hsExtErrorClass | 0x14)

The user replied "No" when prompted to turn on wireless mode

#define hsFtrCreator 'hsEx'

This is the Handspring feature id. Apps can tell if they're on a handspring device if they get 0 err back from: err = FtrGet (hsFtrCreator, hsFtrIDVersion, &value)

#define hsFtrIDBugsFixed 4

This features contains boolean flags to let developers know that a bug present in older devices has been fixed.

#define hsFtrIDCurrentAppOnSleep 12

This feature and value (s) is used to see if PhoneApp should be relaunched when waking up.

THIS FEATURE IS DEPRICATED

#define hsFtrIDGrfAreaDisabled 9

If this feature is set, the graffiti area is disabled

#define hsFtrIDHardwareApiRevision 15

This feature can be used to determine the hardware "API" revision. It changes when there's a revision of the hardware, but the device is otherwise the same. Very few apps should ever need this. Drivers should generally ask the HAL directly for this info (though HALAttr) since that's more efficient.

#define hsFtrIDKeyboardLayout 10

This feature tells which keyboard layout is being used

#define hsFtrIDLdbMgrLibRefNum 2

Feature number indicating that the Launcher Database Mgr library is loaded. The value of the feature is the refNum of the loaded library. Call FtrGet (hsFtrCreator, hsFtrIDLdbMgrLibRefNum, ...) to get this feature.

THIS FEATURE IS DEPRICATED

#define hsFtrIDModDate 1

Library alias names that SysLibFind maps to a real library name according to the appropriate hsPrefSerialLibXXX setting.

By Convention, library alias names start with a '*'. The exception is the "Serial Library" name which is mapped in order to be compatible with pre-existing applications that already use it. hsPrefSerialLibDef

#define hsFtrIDNavigationSupported 14

If this feature exists, then our navigation support exists. The version of the navigation support is stored in the feature's value.

#define hsFtrIDNoMemSemaphore 3

If this feature is present, then we won't use the optimization to grab the memory semaphore before doing multiple data manager calls.

#define hsFtrIDPowerKeyResponse 7

This feature defines how the power putton behaves Note: In HsExtensions 1.0 for PalmOS 5.2.1 this feature is set, but ignored

#define hsFtrIDRadioAttributes 6

This feature describes the radio hardware available

#define hsFtrIDStatusGadgetRev 8

This feature indicates the functionality of the status gadgets API

#define hsFtrIDTestingBootMode 13

This feature indicates whether the Manufacturing test app is present on the device.

#define hsFtrIDToneOnLidOpen 11

This features contains the DB Id to open and play the resource with type 'smfr' with resource id 1 when the lid opens

THIS FEATURE IS DEPRICATED

#define hsFtrIDTypeOfKeyboard 5

This feature tells what type of hardware keys a device has.

#define hsFtrIDVersion 0

Version of Handspring extensions 0xMMmfsHHh, where:

MM.mm.f are the major, minor, and fix revs of PalmOS which is modified by this version of HsExtensions

s is the release stage (3-release,2-beta,1-alpha,0-development)

HH.h are the major and minor rev of HsExtensions for the relevant version of PalmOS

#define hsFtrValCurrentAppOnSleepPhoneAppSpeedDialView 0x0001

PhoneApp current view is Speed dial

#define hsFtrValKeyboardBasic 0x0001

The masks used to interpret the hardware keyboard feature Basic keys (pwr/scroll/app)

#define hsFtrValKeyboardCommCentric 0x0008

DEPRICATED - Communicator centric buttons

#define hsFtrValKeyboardCustomApps 0x0010

Non-standard app keys (Standard is: date/addr/todo/memo) replaces hsFtrValKeyboardCommCentric

#define hsFtrValKeyboardJog 0x0004

Jog keys (jog-up, jog-down,jog-scan)

#define hsFtrValKeyboardLayout_deDE 0x0002

German

#define hsFtrValKeyboardLayout_enUS 0x0001

The values used to interpret the keyboard layout feature English

#define hsFtrValKeyboardLayout_frFR 0x0003

French

#define hsFtrValKeyboardQwerty 0x0002

Qwerty keys (A-Z, Period, Space, Backspace, Enter, Menu, Option, Shift)

#define hsFtrValPowerKeyDoubleClkBacklight 0x0001

Double click for backlight

#define hsFtrValPowerKeyHoldRadioPower 0x0004

Hold for radio power

#define hsFtrValPowerKeyTripleClkInvert 0x0002

Triple click for invers (requires DblClkBacklight)

#define hsFtrValRadioAvailable 0x0001

Radio is present and available for use

#define hsFtrValRadioBuiltin 0x0002

Radio is part of the base hardware and not on a module

#define hsFtrValStatusGadgetRev1 0x0001

Revision 1 of API

#define hsHALIDHandspringOs35_40 'Hs01'

Used by all Handspring OS 3.5 HALs and 4.0 HALs

#define hsHALIDHandspringOs5Rev1 'H5_1'

Used by Handspring's 5.0 HALs

#define hsHALIDHandspringOs5Rev1Sim 'H5s1'

Used by Handspring's 5.0 Simulator HALs

#define hsHALIDHandspringOs5Rev2 'H5_2'

Used by Handspring's 5.2 HALs

#define hsHALIDHandspringOs5Rev2Sim 'H5s2'

Used by Handspring's 5.2 Simulator HALs

#define hsHALIDHandspringOs5Rev3 'P052'

Used by Handspring's 5.3 HALs

#define hsHALIDHandspringOs5Rev3Sim 'S052'

Used by Handspring's 5.3 Simulator HALs

#define hsHALIDHandspringOs5Rev4 'P053'

Used by Handspring's 5.4 HALs

#define hsHALIDHandspringOs5Rev4Sim 'S053'

Used by Handspring's 5.4 Simulator HALs

#define hsKeyguardAutoDisabled 0

Never

#define hsKeyguardAutoPowerOff 0xFFFF

When device powers off

#define hsKeyguardFlagPowerOnDialog 0x0001

Show keyguard dialog at power-on

#define hsLibAliasConsole "*Cons SerLib"

hsPrefSerialLibConsole

#define hsLibAliasDefault "Serial Library"

Library alias names that SysLibFind maps to a real library name according to the appropriate hsPrefSerialLibXXX setting.

By Convention, library alias names start with a '*'. The exception is the "Serial Library" name which is mapped in order to be compatible with pre-existing applications that already use it. hsPrefSerialLibDef

#define hsLibAliasHotSyncLocal "*HsLoc SerLib"

hsPrefSerialLibHotSyncLocal

#define hsLibAliasHotSyncModem "*HsMdm SerLib"

hsPrefSerialLibHotSyncModem

#define hsLibAliasIrda "*Irda SerLib"

hsPrefSerialLibIrda

#define hsLibNameBuiltInSerial "BuiltIn SerLib"

Actual library name of the Dragonball's built-in serial library. This is the default value of the hsPrefDefSerialLib pref setting which SysLibFind uses to map an incoming library name to an actual library name.

#define hsMaxSaveAsNameSize 32

This is the buffer size that should be sent to HsExtDoSaveAsDialog()

#define hsOLDErrorClass (appErrorClass+0x0100)

Error codes

#define hsWordCorrectMaxWordLen 25

Max length (in bytes) of a word (corrected or not) in the word correction dictionary. With null, word can be 26 bytes.

Enumeration Type Documentation

enum HsAttrEnum

Parameters to HsAttrGet/Set calls

Enumerator:
hsAttr68KLidOpen UInt16
See also:
hsAttrLidOpen
hsAttr68KSysSleepReason UInt16
See also:
hsAttrSysSleepReason
hsAttr68KDisplayOn UInt16
See also:
hsAttrDisplayOn
hsAttr68KRingSwitch UInt16
See also:
hsAttrRingSwitch
hsAttr68KPostProcessRsc UInt32
See also:
hsAttrPostProcessRsc
hsAttr68KSysActive UInt16
See also:
hsAttrSysActive
hsAttr68KActiveCalls UInt16
See also:
hsAttrActiveCalls
hsAttr68KPhoneType UInt32
See also:
hsAttrPhoneType
hsAttr68KKeyboardLocked Boolean
See also:
hsAttrKeyboardLocked
hsAttr68KKeyLockNextWakeTicks UInt32
See also:
hsAttrKeyLockNextWakeTicks
hsAttrLidOpen | false=lid closed, true=lid open (returns hsErrNotSupported if no lid)
hsAttrSysSleepReason | Same as the SleepEventParamType.reason from the last sysNotifySleepRequestEvent unless the real reason is different (e.g. hsSysSleepLid)
hsAttrDisplayOn | true = display is on, false = dispay is off
hsAttrRingSwitch | State of ring switch, can be either hsAttrRingSwitchMute or hsAttrRingSwitchLoud
hsAttrPostProcessRsc | Pointer to resource containing the post-processing lists
hsAttrSysActive | Bits representing various system activity. Current implementation sets only the hsAttrSysActiveHotSync bit if the HotSync dialog is active
hsAttrActiveCalls | Number of active voice calls
hsAttrPhoneType | returns hsAttrPhoneTypeCDMA if a CDMA phone or hsAttrPhoneTypeGSM if a GSM phone
hsAttrKeyboardLocked | true = keyguard active
hsAttrKeyLockNextWakeTicks | deprecated
hsAttrKeyboardDB | DmOpenRef of database containing keyboard layout resources
hsAttrDigitizerLock | true = digitizer is locked
hsAttrE911Mode | true = phone is in 911 mode
hsAttrDitherSuppress | count of requests to supress dithering Set to non-zero to increment, set to zero to decrement
hsAttrHotSyncSuppress | count of requests to suppress HotSync Set to non-zero to increment, set to zero to decrement
hsAttrPhoneRadioPowerState | notifies HsExt that cell phone radio was just powered on or off; non-zero if cell phone radio was powered on, zero if powered down. Power on does *not* imply completion of SIM detection or registration
hsAttrAllKeysWakeFromSleep | (Refcount) sets the device in a mode where _all_ keys wake the device from sleep and are processed. This is intended in special cases where we've powered off the screen to save power (or something similar), but the user still thinks the device of the device as on. As a side effect, this will stop 'keyboard lock' from starting when the device turns off. Set to non-zero to increment, set to zero to decrement

enum HsIndicatorCountEnum

Pass a numeric count or one of these special values to HsIndicatorState()

Enumerator:
kIndicatorCountGetState | retrieve the current state
kIndicatorCountForever | run forever

enum HsIndicatorStateEnum

There are several different sources of turning on the indicator, (Charge, Signal, Ring, App) with each source being in exactly one state at any moment. The high byte of these enum values indicates the source, and the low byte indicates which state that source is in. Each source has a hard-coded priority, so only the indication of the highest priority source not in its "None" state will appear on the indicator. The value of the high byte does not represent the priority.

A virtual state that is used to get the state that is currently active on the indicator (the highest priority active source). This value is also the result when there is no active source. (States with * aren't used at present)

Enumerator:
kIndicatorForceNone | Don't force anything
kIndicatorForceOn | Force the indicator on
kIndicatorForceRed | Force the red led on
kIndicatorForceGreen | Force the green led on
kIndicatorForceRedGreen | Force both leds on (orange)
kIndicatorForceOff | Force both leds off
kIndicatorRingNone | Phone not ringing
kIndicatorRingActive | Phone ringing
kIndicatorRingContact | *Phone ringing, CID recognized
kIndicatorRingRoam | *Phone ringing, roaming
kIndicatorAlertNone | Alert not active
kIndicatorAlertAlert | Generic alert
kIndicatorAlertMail | Incoming mail
kIndicatorAlertCalendar | Datebook alarm
kIndicatorAlertSMS | Incoming SMS
kIndicatorAlertVoicemail | Voicemail waiting
kIndicatorAlertPending | Attention alert pending
kIndicatorBattNone | Not connected to a charger
kIndicatorBattCharge | Battery is charging
kIndicatorBattTrickle | Battery is topping off
kIndicatorBattFull | Battery is fully charged
kIndicatorBattLow | *Battery is low (and not on a charger)
kIndicatorUsageNone | Not in use
kIndicatorUsageVoiceCall | Phone on an active voice call
kIndicatorUsageDataCall | Phone on an active data call
kIndicatorSignalNone | Radio turned off
kIndicatorSignalBad | Out of coverage
kIndicatorSignalGood | In coverage
kIndicatorSignalRoam | *In coverage, roaming

enum HsLightCircumstanceEnum

These circumstances modify the mode and allow us to handle different logical circumstances on devices with different hardware.

  • These are applied in the following order: 1. Alert woke device 2. keylight off 3. Quick typing 4. User not looking 5. User not looking for a long time
Enumerator:
hsLightCircumstanceAlertWokeDevice | An important alert woke the device up from sleep.
hsLightCircumstanceQuickTyping | We want the user to be able to access the keyboard easily
hsLightCircumstanceUserNotLooking | We suspect the user isn't looking at the device if they're not actively using the device, so we'll dim the screen (but we don't actually want to turn it off).
hsLightCircumstanceUserNotLookingLongTime | similar to above, but if the inactivity persists then we want to turn the screen off
hsLightCircumstanceNumCircumstances | Num circumstances. SUBJECT TO CHANGE.
hsLightCircumstanceReserved | Reserved circumstance to force compiler to use 16-bit for enum...

enum HsLightModeEnum

These are different modes that can be used to affect the light manager, which is in charge of temporary changes in the lighting situation.

Enumerator:
hsLightModeNormal | Light mode is at normal presets
hsLightModeNight | Light mode is at night-mode presets
hsLightModeNumPresets | Num presets. SUBJECT TO CHANGE.
hsLightModeReserved | Reserved mode to force compiler to use 16-bit for enum...

enum HsPrefEnum

Equates for the HsPrefGet/Set calls

Enumerator:
hsPrefSerialLibDef | Char[] : Name of serial library to substitute for hsLibAliasDefault
hsPrefSerialLibHotSyncLocal | Char[] : Name of serial library to substitute for hsLibAliasHotSyncLocal
hsPrefSerialLibHotSyncModem | Char[] : Name of serial library to substitute for hsLibAliasHotSyncModem
hsPrefSerialLibIrda | Char[] : Name of serial library to substitute for hsLibAliasIrda
hsPrefSerialLibConsole | Char[] : Name of serial library to substitute for hsLibAliasConsole
hsPrefJogScanCharAppCreator | UInt32 : Creator type of app to launch in response to hsChrJogScan
hsPrefLidStatusChgCharAppCreator | UInt32 : Creator type of app to launch in response to hsChrLidStatusChg
hsPrefOptHard1CharAppCreator | UInt32 : Creator type of app to launch n response to hsChrOptHard1
hsPrefOptHard2CharAppCreator | UInt32 : Creator type of app to launch in response to hsChrOptHard2
hsPrefOptHard3CharAppCreator | UInt32 : Creator type of app to launch in response to hsChrOptHard3
hsPrefOptHard4CharAppCreator | UInt32 : Creator type of app to launch in response to hsChrOptHard4
hsPrefTempShiftTimeOut | UInt32 : Number of ticks until a temporary shift state (upper shift or option shift) times out.
hsPrefLidClosedAutoOffSeconds | UInt16 : Number of seconds for auto-off when the lid is closed
hsPrefLCDRefreshRate | UInt16 : Type of refresh rate for lighting see HsLCDRefreshRateEnum
hsPrefNetworkTimeSelected | UInt16: used by CDMA devices - should it read the time from the network
hsPrefKeyguardAutoEnableTime | UInt16: How many seconds to wait before enabling keyguard
hsPrefKeyguardAutoEnableAutoOffExtraTime | UInt16 : How many seconds to wait before enabling keyguard when hsPrefKeyguardAutoEnableTime is set to hsKeyguardAutoPowerOff and the device powers off due to the auto-off timer
hsPrefKeyguardFlags | UInt16 : Flags controlling keyguard's behaviour
hsPrefTouchscreenDisableFlags | UInt16: Used by the phone app to determine when to disable touchscreen
hsPrefOptHardPowerCharAppCreator | UInt32 : Creator type of app to launch in response to hsChrOptHardPower
hsPrefOptReservedCharAppCreator | UInt32 : Creator type of app to launch in response to hsChrOptReserved (for future use)
hsPrefPowerOnAppCreator | UInt32 : Creator type of app to launch instead of the normally mapped app when the app key turned the power on
hsPrefSideHardCharAppCreator | UInt32 : Creator type of app to launch instead of the normally mapped app when the side key is pressed
hsPrefBlinkGreenLEDInCoverage | UInt16 : Set to true if we want the green LED to blink when the device is in coverage
hsPrefHard11CharAppCreator | UInt32 : Creator type of app to launch in response to vchrHard11
hsPrefOptHard11CharAppCreator | UInt32 : Creator type of app to launch in response to hsChrOptHard11
hsPrefUserNotLookingTime | Int32 : After this many seconds since the last action, the user has stopped looking at the device. (auto display/kbd dim)
hsPrefNetworkTZSelected | UInt16: used by phones - should it read the time zone from the network

enum HsStatusGadgetTypeEnum

Equates for supporting system handled status gadgets

Enumerator:
hsStatusGadgetBattery | Status gadget is a battery meter
hsStatusGadgetSignal | Status gadget is a signal strength indicator

enum HsVerStrEnum

Enumerator:
hsVerStrComplete | Composite, formatted for display in info dialog
hsVerStrSerialNo | Complete serial number (ROM token 'snum' is limited to 12 digits)
hsVerStrHardware | Revision of the hardware
hsVerStrProductName | Like, "Treo 600"
hsVerStrCarrierID | Carrier ID code for carrier branding
hsVerStrProductRev | Complete product; covering hardware, radio firmware and software
hsVerStrROMBuild | ROM buld number (not the same as the build number in sysFtrNumROMVersion)
hsVerStrFirmwareVer | Version of the radio firmware
hsVerStrPalmOSVer | See sysFtrNumROMVersion
hsVerStrLifeTime | Radio life timer

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:30 2006 for Palm API Guide


HsExtKbdUtils.h File Reference

Detailed Description

Version:
Date:

Functions

  • Int16 HsPostProcessPopupList (Boolean overrideFont, FontID overrideFontID)

Function Documentation

Int16 HsPostProcessPopupList | ( | Boolean | overrideFont,
 |  | FontID | overrideFontID
 | ) |

Parameters:
overrideFont,: IN:
overrideFontID,: IN:
Return values:
Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:30 2006 for Palm API Guide


HsExtTraps.h File Reference

Detailed Description

Definitions of selectors used for the 68K trap based calls to HsExtensions.

Version:
Date:

This is the system trap that we base all HsExt calls off of.

  • #define sysTrapHsSelector sysTrapOEMDispatch

OS-5

  • #define hsSelUtilGetObjectUsable 0x73
  • #define hsSelUtilFrmGetDefaultButtonID 0x74
  • #define hsSelUtilFrmGetEventHandler 0x75
  • #define hsSelUtilLstGetItemsText 0x76
  • #define hsSelUtilLstGetTopItem 0x77
  • #define hsSelUtilCtlGetControlStyle 0x78

Trace Functions

  • #define hsSelTraceLevelsSet 0x79
  • #define hsSelTraceLevelsGet 0x7A
  • #define hsSelTrace 0x7B
  • #define hsSelTraceData 0x7C
  • #define hsSelTraceRecordsDump 0x7D
  • #define hsSelTraceClear 0x7E
  • #define hsSelTraceOutputLevelsSet 0x7F
  • #define hsSelTraceOutputLevelsGet 0x80
  • #define hsSelTraceText 0x81
  • #define hsSelTraceFunction 0x82
  • #define hsSelTraceError 0x83
  • #define hsSelTraceFunctionError 0x84
  • #define hsSelTraceEvent 0x85

Mutex functions -- 68K bridge to ARM-native functions

  • #define hsSelUtilMutexCreate 0x89
  • #define hsSelUtilMutexDelete 0x8A
  • #define hsSelUtilMutexReserve 0x8B
  • #define hsSelUtilMutexRelease 0x8C

Additional Trace Utility functions

  • #define hsSelTraceOpenDB 0xB0
  • #define hsSelTraceCloseDB 0xB1

multi-byte friendly Txt routines

  • #define hsSelTxtNumChars 0xBB
  • #define hsSelTxtTruncateString 0xBC
  • #define hsSelTxtIsAscii 0xBD

This range is reserved for last-minute fixes in OS-5H1-C/D/E

  • #define hsSelReserved5H1_C0 0xC0
  • #define hsSelReserved5H1_C1 0xC1
  • #define hsSelReserved5H1_C2 0xC2
  • #define hsSelReserved5H1_C3 0xC3

New AcDc traps

  • #define hsSelDispatchService 0xC4
  • #define hsSelOpenDialNumberDialogExt 0xC5
  • #define hsSelAttnGetAttentionExt 0xC6
  • #define hsSelUtilBbutInstallNewButton 0xC7
  • #define hsSelUtilBbutSetLabel 0xC8
  • #define hsSelAttnUpdateExt 0xC9
  • #define hsSelUtilAttnIndicatorAllow 0xCA
  • #define hsSelUtilBbutSetBitmap 0xCB
  • #define hsSelMenuSetCurMenuCurItem 0xCC
  • #define hsSelTraceSetCommitInterval 0xCD
  • #define hsSelTraceGetCommitInterval 0xCE
  • #define hsSelWriteROMTokens 0xCF

Defines

  • #define sysTrapOEMDispatch 0xA349
    OEM trap in Palm OS 3.0 and later trap table (formerly sysTrapSysReserved4).
  • #define hsSelectorBase 0
  • #define hsSelInfo 0x0
  • #define hsSelPrvInit 0x1
  • #define hsSelPrvCallSafely 0x2
  • #define hsSelPrvCallSafelyNewStack 0x3
  • #define hsSelDatabaseCopy 0x4
  • #define hsSelExtKeyboardEnable 0x5
  • #define hsSelCardAttrGet 0x6
  • #define hsSelCardAttrSet 0x7
  • #define hsSelCardEventPost 0x8
  • #define hsSelPrvErrCatchListP 0x9
  • #define hsSelPrefGet 0xA
  • #define hsSelPrefSet 0xB
  • #define hsSelDmGetNextDBByTypeCreator 0xC
  • #define hsSelDmGetNextDBInit 0xD
  • #define hsSelCardHdrUpdate 0xE
  • #define hsSelAppEventHandlerSet 0xF
  • #define hsSelAppEventPost 0x10
  • #define hsSelUsbCommStatePtr 0x11
  • #define hsSelCardPatchInstall 0x12
  • #define hsSelCardPatchRemove 0x13
  • #define hsSelEvtResetAutoOffTimer 0x14
  • #define hsSelDmDatabaseUniqueIDSeed 0x15
  • #define hsSelAboutHandspringApp 0x16
  • #define hsSelDmDatabaseIsOpen 0x17
  • #define hsSelDmDatabaseIsProtected 0x18
  • #define hsSelDlkForceSlowSync 0x19
  • #define hsSelPrvHandleCardChangeEvent 0x1A
  • #define hsSelCardPower 0x1B
  • #define hsSelDmDatabaseDeleted 0x1C
  • #define hsSelDmLockFileSystem 0x1D
  • #define hsSelPrvLaunchCompareFunc 0x1E
  • #define hsSelPrvLEDCommand 0x1F
  • #define hsInstallSerialWrapper 0x20
  • #define hsUninstallSerialWrapper 0x21
  • #define hsPeriodicRegister 0x22
  • #define hsPeriodicUnregister 0x23
  • #define hsPeriodicPeriodsAvailable 0x24
  • #define hsSelPrvSetButtonDefault 0x25
  • #define hsSelPrvFindAppFromIDs 0x26
  • #define hsSelAttrGet 0x27
  • #define hsSelAttrSet 0x28
  • #define hsSelKeyCurrentStateExt 0x29
  • #define hsSelKeySetMaskExt 0x2A
  • #define hsSelGrfSetStateExt 0x2B
  • #define hsSelGrfGetStateExt 0x2C
  • #define hsSelKeyChrToOptChr 0x2D
  • #define hsSelKeyChrToRegChr 0x2E
  • #define hsSelPrvKeyHandleEvent 0x2F
  • #define hsSelWordCorrectInvoke 0x30
  • #define hsSelWordCorrectUndo 0x31
  • #define hsSelPrvUpdateBatteryGadget 0x32
  • #define hsSelPrvUpdateSignalGadget 0x33
  • #define hsSelStatusSetGadgetType 0x34
  • #define hsSelSysKeyboardReferenceDialog 0x35
  • #define hsSelPutObjectAfterTitle 0x36
  • #define hsSelEvtMetaEvent 0x37
  • #define hsSelStatusUpdateGadgets 0x38
  • #define hsSelLstPopupListExt 0x39
  • #define hsSelDmCreateDatabasesFromImages 0x3A
  • #define hsSelPrvLaunchDemoApp 0x3B
  • #define hsSelPrefGetAppKeyCreator 0x3C
  • #define hsSelUtilFrmDoDialogWithCallback 0x3D
  • #define hsSelHsGetTrapAddress 0x3E
  • #define hsSelHsSetTrapAddress 0x3F
  • #define hsSelUnimplemented 0x40
  • #define hsSelIndicator 0x41
  • #define hsSelUtilSclUpdateScrollBar 0x42
  • #define hsSelUtilSclScroll 0x43
  • #define hsSelUtilSclScrollPage 0x44
  • #define hsSelPrvInitPostProcess 0x45
  • #define hsSelPostProcPopupList 0x46
  • #define hsSelPeriodicUnregisterFromSelf 0x47
  • #define hsSelNetworkDropConnection 0x48
  • #define hsSelPrvSetupGoToCustomForm 0x49
  • #define hsSelPrvSetupInstallFormEventHandler 0x4A
  • #define hsSelUtilSliHandleKeyDown 0x4B
  • #define hsSelUtilWinGetMaxDepth 0x4C
  • #define hsSelLightMode 0x4D
  • #define hsSelLightCircumstance 0x4E
  • #define hsSelUtilBbutInstallFromResource 0x4F
  • #define hsSelUtilBbutHitBigButton 0x50
  • #define hsSelUtilFrmDoDialog 0x51
  • #define hsSelUtilStrCSpn 0x52
  • #define hsSelUtilFrmDoTimedDialog 0x53
  • #define hsSelReserved352H5_54 0x54
  • #define hsSelReserved352H5_55 0x55
  • #define hsSelReserved352H5_56 0x56
  • #define hsSelReserved352H5_57 0x57
  • #define hsSelReserved352H5_58 0x58
  • #define hsSelReserved352H5_59 0x59
  • #define hsSelReserved352H5_5A 0x5A
  • #define hsSelReserved352H5_5B 0x5B
  • #define hsSelReserved352H5_5C 0x5C
  • #define hsSelReserved352H5_5D 0x5D
  • #define hsSelReserved352H6_5E 0x5E
  • #define hsSelReserved352H6_5F 0x5F
  • #define hsSelReserved352H6_60 0x60
  • #define hsSelReserved352H6_61 0x61
  • #define hsSelReserved352H6_62 0x62
  • #define hsSelReserved352H6_63 0x63
  • #define hsSelReserved352H6_64 0x64
  • #define hsSelReserved352H6_65 0x65
  • #define hsSelReserved352H6_66 0x66
  • #define hsSelReserved352H6_67 0x67
  • #define hsSelReserved352H6_68 0x68
  • #define hsSelReserved352H6_69 0x69
  • #define hsSelReserved352H6_6A 0x6A
  • #define hsSelPrvShowKeyboardLockOnDialog 0x6B
  • #define hsSelPrvHandleKeyboardLock 0x6C
  • #define hsSelSpringboardNotSupported 0x6D
  • #define hsSelReserved41_6E 0x6E
  • #define hsSelReserved41_6F 0x6F
  • #define hsSelReserved41_70 0x70
  • #define hsSelReserved41_71 0x71
  • #define hsSelReserved41_72 0x72
  • #define hsSelGetPhoneLibrary 0x86
  • #define hsSelUtilFrmSetLabel 0x87
  • #define hsSelUtilCtlGetFont 0x88
  • #define hsSelGetARMActiveFormPtr 0x8E
  • #define hsSelTwoFontSelect 0x8F
  • #define hsSelOpenDialNumberDialog 0x90
  • #define hsSelTurnRadioOn 0x91
  • #define hsSelCreateNewMessage 0x92
  • #define hsSelCreateNewEmail 0x93
  • #define hsSelBrowseUrl 0x94
  • #define hsSelNavGetFocusColor 0x95
  • #define hsSelNavSetFocusColor 0x96
  • #define hsSelNavGetFocusRingInfo 0x97
  • #define hsSelNavDrawFocusRing 0x98
  • #define hsSelNavRemoveFocusRing 0x99
  • #define hsSelNavLstGetTempSelection 0x9A
  • #define hsSelNavLstSetTempSelection 0x9B
  • #define hsSelIndicatorState 0x9C
  • #define hsSelKeysPressed 0x9D
  • #define hsSelKeyEnableKey 0x9E
  • #define hsSelKeyChrCodeToKeyCode 0x9F
  • #define hsSelKeyKeyCodeToChrCode 0xA0
  • #define hsSelKeyEventIsFromKeyboard 0xA1
  • #define hsSelTraceContextInit 0xA2
  • #define hsSelTraceContextDelete 0xA3
  • #define hsSelDoSaveAsDialog 0xA4
  • #define hsSelExgSelectTarget 0xA5
  • #define hsSelExgLocalAccept 0xA6
  • #define hsSelExgLocalDisconnect 0xA7
  • #define hsSelUtilAttnNagInfo 0xA8
  • #define hsSelCrashLogGetLast 0xA9
  • #define hsSelCrashLogDisplayLast 0xAA
  • #define hsSelTxtPrepFindString 0xAB
  • #define hsSelUtilFrmSetHelpID 0xAC
  • #define hsSelUtilFrmSetLabelFont 0xAD
  • #define hsNeverUsedBeforeAvailableForUse1 0xAE
  • #define hsSelSupressDbgLockout 0xB2
  • #define hsSelIsDbgLockoutSupressed 0xB3
  • #define hsSelKeyStop 0xB4
  • #define hsSelGetVersionString 0xB5
  • #define hsSelUtilEnableAttentionMgr 0xB6
  • #define hsSelNavObjectTakeFocus 0xB7
  • #define hsSelPostProcessPopupList 0xB8
  • #define hsSelTraceSetMaxRecords 0xB9
  • #define hsSelTraceGetMaxRecords 0xBA
  • #define hsSelWaitForGPRSAttach 0xBE
  • #define hsSelIsHTTPLibraryLoaded 0xBF
  • #define hsGetCurrentLightCircumstance 0xD0
  • #define hsSelLast 0xD1
  • #define hsNumSels (hsSelLast - hsSelectorBase)

Define Documentation

#define hsSelDmCreateDatabasesFromImages 0x3A

DO NOT CHANGE used in object patch!

#define hsSelPrvLaunchDemoApp 0x3B

DO NOT CHANGE used in object patch!

#define hsSelPrvSetupGoToCustomForm 0x49

DO NOT CHANGE used in object patch!

#define hsSelPrvSetupInstallFormEventHandler 0x4A

DO NOT CHANGE used in object patch!

#define sysTrapOEMDispatch 0xA349

OEM trap in Palm OS 3.0 and later trap table (formerly sysTrapSysReserved4).

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:30 2006 for Palm API Guide


HsExtUtilBigButton.h File Reference

Detailed Description

Version:
3.0
Date:
12/18/2001
Description: This file contains routines for managing 'big' buttons, which are thumbable buttons with a bitmap and some text (common in applications designed to be used for telephony)

History: 2001-12-18 dia Creaded by Doug Anderson 2002-01-22 dia Supports or
as line endings now. Note that '
' is not supported (it's treated as two separate line endings)

Functions

  • Err HsUtilBbutInstallFromResource (FormType *frmP)
  • void HsUtilBbutInstallNewButton (FormType *frmP, UInt16 gadgetID, const Char *textP, FontID font, UInt8 flags)
  • void HsUtilBbutSetLabel (FormType *frmP, UInt16 gadgetID, const Char *newLabel)
  • void HsUtilBbutSetBitmap (FormType *frmP, UInt16 gadgetID, const BitmapPtr bitmapP)
  • void HsUtilBbutHitBigButton (FormType *frmP, UInt16 gadgetIndex)

Function Documentation

void HsUtilBbutHitBigButton | ( | FormType * | frmP,
 |  | UInt16 | gadgetIndex
 | ) |

Parameters:
frmP,: IN:
gadgetIndex,: IN:
Return values:
Error code.

Err HsUtilBbutInstallFromResource ( FormType * frmP )

Parameters:
frmP,: IN:
Return values:
Error code.

void HsUtilBbutInstallNewButton | ( | FormType * | frmP,
 |  | UInt16 | gadgetID,
 |  | const Char * | textP,
 |  | FontID | font,
 |  | UInt8 | flags
 | ) |

Parameters:
frmP,: IN:
gadgetID,: IN:
textP,: IN:
font,: IN:
flags,: IN:
Return values:
Error code.

void HsUtilBbutSetBitmap | ( | FormType * | frmP,
 |  | UInt16 | gadgetID,
 |  | const BitmapPtr | bitmapP
 | ) |

Parameters:
frmP,: IN:
gadgetID,: IN:
bitmapP,: IN:
Return values:
Error code.

void HsUtilBbutSetLabel | ( | FormType * | frmP,
 |  | UInt16 | gadgetID,
 |  | const Char * | newLabel
 | ) |

Parameters:
frmP,: IN:
gadgetID,: IN:
newLabel,: IN:
Return values:
Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:30 2006 for Palm API Guide


HsExtUtilBigButtonCommon.h File Reference

Detailed Description

<Common code for Big Buttons that can be used by ARM and 68K code.>

<This file contains all defines and enums that are used by Big Buttons. There are some structs here too that might need to be moved to 68K/ARM specific code. Moved code from HsExtUtilBigButton.h >

Copyright (c) 2002 Handspring Inc., All Rights Reserved

Author:
Arun Mathias
Id
//depot/Components/Extensions/HsExtensions/1.0A/Incs/IncsPublic/Common/HsExtUtilBigButtonCommon.h#3

Data Structures

  • struct HsBigButtonMappingType
  • struct HsBigButtonReourceType

Defines

  • #define bbutGadgetMiscSelectSelector 7014
  • #define bbutGadgetMiscSelectData ((void*)0xBADC0DE1)
  • #define hsBigButtonRscType 'bBut'

Define Documentation

#define bbutGadgetMiscSelectData ((void*)0xBADC0DE1)

Magic # to make conflicts even less likely for detecting big button presses.

#define bbutGadgetMiscSelectSelector 7014

This selector gets sent with a frmGadgetMiscEvent to let you know that the gadget has been selected. The numbers are picked semi-randomly so that generic code (like HsUtilFrmDoDialogWithCallback()) can tell that this is actually a button press without doing the wrong thing for other people's gadget events.

Note that in most code, you shouldn't need to worry about checking the data, since you know exactly what gadgets are on your form and what kind of events they send. Randomish number so people can easily detect big button presses

#define hsBigButtonRscType 'bBut'

This is the type of big button resources. The ID should match the ID of the form... Registered: yes

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:30 2006 for Palm API Guide


HsHelper.h File Reference

Detailed Description

Version:
1.0
Date:
Description: Public header file for the Handspring helper functions

Include dependency graph for HsHelper.h:

Data Structures

  • struct PmGetNewMsgCountNotifyParamType
    Param structure for pmNotifyGetNewMsgCountFromHelper notifications. More...
  • struct PmBroadcastNewMsgCountNotifyParamType
    Param structure for pmNotifyBroadcastNewMsgCount notifications. More...

Defines

  • #define sysNotifyHelperEvent 'hlpr'
  • #define HelperEnumerateEnqueueEntry(enumEvtDataP, entryP)

Typedefs

  • typedef struct PmGetNewMsgCountNotifyParamType * PmGetNewMsgCountNotifyParamPtr
  • typedef struct PmBroadcastNewMsgCountNotifyParamType * PmBroadcastNewMsgCountNotifyParamPtr

Define Documentation

#define HelperEnumerateEnqueueEntry | ( | enumEvtDataP,
 |  | entryP | )

Value:

do                                                \
    {                                                 \
    (entryP)->nextP = (enumEvtDataP)    ;     \
    (enumEvtDataP) = (entryP);                \
    }                                                 \
  while (0)
MACRO: HelperEnumerateEnqueueEntry

Enqueues a node of type HelperEvtEnumerateNodeType. Each node must be individually allocated from the heap by the helper.

PROTOTYPE: void HelperEnumNodeEnqueue(HelperNotifyEnumerateType* enumEvtDataP, HelperNotifyEnumerateListType* entryP);

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:31 2006 for Palm API Guide


HsKeyCodes.h File Reference

Detailed Description

Version:
1.0
Date:
This file defines the key codes. These match the vchrs for virtual key characters, but vchars are only used in the legacy event loop. Everywhere else, they are considered deprecated in favor of key now. These are NOT ascii, unicode or otherwise although, for standard QWERTY US keboards, the key codes for the letters are the same as the lowercase ASCII values, but only so it's easier to determine what you're looking at.

Note: This is a Palm OS 6 header that we got early in order to make the Handspring key driver as close as possible to what it should be in the future. This header will be depricated in favor of Palm's official header once it's in their SDK.

Enumerations

  • enum KeyCodeType {
    keyNull = 0x0000,
    keyBackspace = 0x0008,
    keyTab = 0x0009,
    keyReturn = 0x000a,
    keyPageUp = 0x000b,
    keyPageDown = 0x000c,
    keyNumericEnter = 0x000d,
    keyEscape = 0x001b,
    keyLeftArrow = 0x001c,
    keyRightArrow = 0x001d,
    keyUpArrow = 0x001e,
    keyDownArrow = 0x001f,
    keySpace = 0x0020,
    keySingleQuote = 0x0027,
    keyComma = 0x002c,
    keyDash = 0x002d,
    keyPeriod = 0x002e,
    keySlash = 0x002f,
    keyZero = 0x0030,
    keyOne = 0x0031,
    keyTwo = 0x0032,
    keyThree = 0x0033,
    keyFour = 0x0034,
    keyFive = 0x0035,
    keySix = 0x0036,
    keySeven = 0x0037,
    keyEight = 0x0038,
    keyNine = 0x0039,
    keySemiColon = 0x003b,
    keyLessThan = 0x003c,
    keyEquals = 0x003d,
    keyAt = 0x0040,
    keyOpenBracket = 0x005b,
    keyBackslash = 0x005c,
    keyCloseBracket = 0x005d,
    keyBacktick = 0x0060,
    keyA = 0x0061,
    keyB = 0x0062,
    keyC = 0x0063,
    keyD = 0x0064,
    keyE = 0x0065,
    keyF = 0x0066,
    keyG = 0x0067,
    keyH = 0x0068,
    keyI = 0x0069,
    keyJ = 0x006a,
    keyK = 0x006b,
    keyL = 0x006c,
    keyM = 0x006d,
    keyN = 0x006e,
    keyO = 0x006f,
    keyP = 0x0070,
    keyQ = 0x0071,
    keyR = 0x0072,
    keyS = 0x0073,
    keyT = 0x0074,
    keyU = 0x0075,
    keyV = 0x0076,
    keyW = 0x0077,
    keyX = 0x0078,
    keyY = 0x0079,
    keyZ = 0x007a,
    keyNextField = 0x0103,
    keyMenu = 0x0105,
    keyLaunch = 0x0108,
    keyFind = 0x010A,
    keyPrevField = 0x010C,
    keyLockDevice = 0x0112,
    keyThumbWheelUp = 0x012E,
    keyThumbWheelDown = 0x012F,
    keyThumbWheelPush = 0x0130,
    keyThumbWheelBack = 0x0131,
    keyRockerUp = 0x0132,
    keyRockerDown = 0x0133,
    keyRockerLeft = 0x0134,
    keyRockerRight = 0x0135,
    keyRockerCenter = 0x0136,
    keyHard1 = 0x0204,
    keyHard2 = 0x0205,
    keyHard3 = 0x0206,
    keyHard4 = 0x0207,
    keyHardPower = 0x0208,
    keyHardCradle = 0x0209,
    keyHardCradle2 = 0x020A,
    keyHardContrast = 0x020B,
    keyHardAntenna = 0x020C,
    keyHardBrightness = 0x020D,
    keyHard5 = 0x0214,
    keyHard6 = 0x0215,
    keyHard7 = 0x0216,
    keyHard8 = 0x0217,
    keyHard9 = 0x0218,
    keyHard10 = 0x0219,
    keyHard11 = 0x021A,
    keyHard12 = 0x021B,
    keyHard13 = 0x021C,
    keyHard14 = 0x021D,
    hsKeyMfgTest = 0x1600,
    hsKeySymbol = 0x1609,
    hsKeyRadioPower = 0x160C,
    keyLeftShift = 0xe000,
    keyRightShift = 0xe001,
    keyLeftControl = 0xe002,
    keyRightControl = 0xe003,
    keyLeftCommand = 0xe004,
    keyRightCommand = 0xe005,
    keyLeftAlt = 0xe006,
    keyRightAlt = 0xe007,
    keySide = 0xe008,
    keyHelp = 0xe009,
    keyNumLock = 0xe00a,
    keyScrollLock = 0xe00b,
    keyCapsLock = 0xe00c,
    keyInsert = 0xe00d,
    keyDelete = 0xe00e,
    keyHome = 0xe00f,
    keyEnd = 0xe010,
    keyPrintScreen = 0xe011,
    keyPause = 0xe012,
    keyNumericPeriod = 0xe013,
    keyNumericPlus = 0xe014,
    keyNumericDash = 0xe015,
    keyNumericAsterisk = 0xe016,
    keyNumericSlash = 0xe017,
    keyNumericEquals = 0xe018,
    keyNumericZero = 0xe020,
    keyNumericOne = 0xe021,
    keyNumericTwo = 0xe022,
    keyNumericThree = 0xe023,
    keyNumericFour = 0xe024,
    keyNumericFive = 0xe025,
    keyNumericSix = 0xe026,
    keyNumericSeven = 0xe027,
    keyNumericEight = 0xe028,
    keyNumericNine = 0xe029,
    keyF1 = 0xe031,
    keyF2 = 0xe032,
    keyF3 = 0xe033,
    keyF4 = 0xe034,
    keyF5 = 0xe035,
    keyF6 = 0xe036,
    keyF7 = 0xe037,
    keyF8 = 0xe038,
    keyF9 = 0xe039,
    keyF10 = 0xe03a,
    keyF11 = 0xe03b,
    keyF12 = 0xe03c,
    keyF13 = 0xe03d,
    keyF14 = 0xe03e,
    keyF15 = 0xe03f,
    keyBack = 0xe050,
    keyForward = 0xe051,
    keyStopInternet = 0xe052,
    keyRefresh = 0xe053,
    keySearch = 0xe054,
    keyFavorites = 0xe055,
    keyHomePage = 0xe056,
    keyMail = 0xe057,
    keyMute = 0xe058,
    keyVolumeUp = 0xe059,
    keyVolumeDown = 0xe05a,
    keyPlay = 0xe05b,
    keyPauseAudio = 0x305c,
    keyPlayPause = 0xe05d,
    keyStopAudio = 0xe05e,
    keyPrevTrack = 0xe05f,
    keyNextTrack = 0xe060,
    keyFastForward = 0xe061,
    keyRewind = 0xe062,
    keyEject = 0xe063,
    keyMedia = 0xe064,
    keyMyComputer = 0xe065,
    keyMyDocuments = 0xe066,
    keyMyMusic = 0xe067,
    keyMyPictures = 0xe068,
    keyCalculator = 0xe069,
    keyLogOff = 0xe06a
    }
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:31 2006 for Palm API Guide


HsKeyCommon.h File Reference

Detailed Description

Header file with additional keyboard related definitions.

Defines

  • #define vchrHardRockerCenter 0x013D
  • #define keyBitThumbWheelUp 0x00001000
  • #define keyBitThumbWheelDown 0x00002000
  • #define keyBitThumbWheelPress 0x00004000
  • #define keyBitThumbWheelBack 0x00008000
  • #define keyBitRockerUp 0x00010000
  • #define keyBitRockerDown 0x00020000
  • #define keyBitRockerLeft 0x00040000
  • #define keyBitRockerRight 0x00080000
  • #define keyBitRockerCenter 0x00100000
  • #define sysFtrNumUIHardwareFlags 27
  • #define sysFtrNumUIHardwareHas5Way 0x00000001
  • #define sysFtrNumUIHardwareHasThumbWheel 0x00000002
  • #define sysFtrNumUIHardwareHasThumbWheelBack 0x00000004
  • #define sysFtrNumUIHardwareHasKbd 0x00000008
  • #define willSendUpKeyMask 0x0800
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:31 2006 for Palm API Guide


HsKeyTypes.h File Reference

Detailed Description

palmOne's key constant definitions shared by DAL and Palm OS (see Palm OS' CmnKeyTypes.h)

Defines

  • #define keyBitNumPower 0
  • #define keyBitNumPageUp 1
  • #define keyBitNumPageDown 2
  • #define keyBitNumHard1 3
  • #define keyBitNumHard2 4
  • #define keyBitNumHard3 5
  • #define keyBitNumHard4 6
  • #define keyBitNumCradle 7
  • #define keyBitNumAntenna 8
  • #define keyBitNumContrast 9
  • #define keyBitNumJogUp 12
  • #define keyBitNumJogDown 13
  • #define keyBitNumJogPress 14
  • #define keyBitNumJogBack 15
  • #define keyBitNumRockerUp 16
  • #define keyBitNumRockerDown 17
  • #define keyBitNumRockerLeft 18
  • #define keyBitNumRockerRight 19
  • #define keyBitNumRockerCenter 20
  • #define keyBitExt1Q 0x00000001
  • #define keyBitNumExt1Q 0
  • #define keyBitExt1W 0x00000002
  • #define keyBitNumExt1W 1
  • #define keyBitExt1E 0x00000004
  • #define keyBitNumExt1E 2
  • #define keyBitExt1R 0x00000008
  • #define keyBitNumExt1R 3
  • #define keyBitExt1T 0x00000010
  • #define keyBitNumExt1T 4
  • #define keyBitExt1Y 0x00000020
  • #define keyBitNumExt1Y 5
  • #define keyBitExt1U 0x00000040
  • #define keyBitNumExt1U 6
  • #define keyBitExt1I 0x00000080
  • #define keyBitNumExt1I 7
  • #define keyBitExt1O 0x00000100
  • #define keyBitNumExt1O 8
  • #define keyBitExt1P 0x00000200
  • #define keyBitNumExt1P 9
  • #define keyBitExt1A 0x00000400
  • #define keyBitNumExt1A 10
  • #define keyBitExt1S 0x00000800
  • #define keyBitNumExt1S 11
  • #define keyBitExt1D 0x00001000
  • #define keyBitNumExt1D 12
  • #define keyBitExt1F 0x00002000
  • #define keyBitNumExt1F 13
  • #define keyBitExt1G 0x00004000
  • #define keyBitNumExt1G 14
  • #define keyBitExt1H 0x00008000
  • #define keyBitNumExt1H 15
  • #define keyBitExt1J 0x00010000
  • #define keyBitNumExt1J 16
  • #define keyBitExt1K 0x00020000
  • #define keyBitNumExt1K 17
  • #define keyBitExt1L 0x00040000
  • #define keyBitNumExt1L 18
  • #define keyBitExt1Bksp 0x00080000
  • #define keyBitNumExt1Bksp 19
  • #define keyBitExt1Opt 0x00100000
  • #define keyBitNumExt1Opt 20
  • #define keyBitExt1Z 0x00200000
  • #define keyBitNumExt1Z 21
  • #define keyBitExt1X 0x00400000
  • #define keyBitNumExt1X 22
  • #define keyBitExt1C 0x00800000
  • #define keyBitNumExt1C 23
  • #define keyBitExt1V 0x01000000
  • #define keyBitNumExt1V 24
  • #define keyBitExt1B 0x02000000
  • #define keyBitNumExt1B 25
  • #define keyBitExt1N 0x04000000
  • #define keyBitNumExt1N 26
  • #define keyBitExt1M 0x08000000
  • #define keyBitNumExt1M 27
  • #define keyBitExt1Period 0x10000000
  • #define keyBitNumExt1Period 28
  • #define keyBitExt1Enter 0x20000000
  • #define keyBitNumExt1Enter 29
  • #define keyBitExt1Shift 0x40000000
  • #define keyBitNumExt1Shift 30
  • #define keyBitExt1Space 0x80000000
  • #define keyBitNumExt1Space 31
  • #define keyBitsAllExt1 0xFFFFFFFF
  • #define keyBitExt2Symbol 0x00000001
  • #define keyBitNumExt2Symbol 0
  • #define keyBitExt2CmdMenu 0x00000002
  • #define keyBitNumExt2CmdMenu 1
  • #define keyBitExt2Launcher 0x00000020
  • #define keyBitNumExt2Launcher 5
  • #define keyBitExt2Unused6 0x00000040
  • #define keyBitNumExt2Unused6 6
  • #define keyBitExt2MfgTest 0x00000080
  • #define keyBitNumExt2MfgTest 7
  • #define keyBitExt2VolumeUp 0x00000100
  • #define keyBitNumExt2VolumeUp 8
  • #define keyBitExt2VolumeDown 0x00000200
  • #define keyBitNumExt2VolumeDown 9
  • #define keyBitExt2Side 0x00000400
  • #define keyBitNumExt2Side 10
  • #define keyBitExt2Zero 0x00000800
  • #define keyBitNumExt2Zero 11
  • #define keyBitExt2RShift 0x00001000
  • #define keyBitNumExt2RShift 12
  • #define keyBitExt2Hard11 0x00002000
  • #define keyBitNumExt2Hard11 13
  • #define keyBitsAllExt2 0xFFFFFFFF
  • #define keyBitNumUnused 0xFFFF
  • #define specialHoldKeyMask (autoRepeatKeyMask | doubleTapKeyMask)
  • #define specialReleaseKeyMask (autoRepeatKeyMask | poweredOnKeyMask)
  • #define specialAvail3KeyMask (doubleTapKeyMask | poweredOnKeyMask)
  • #define specialAvail4KeyMask (autoRepeatKeyMask | doubleTapKeyMask | poweredOnKeyMask)
  • #define specialKeyMask (autoRepeatKeyMask | doubleTapKeyMask | poweredOnKeyMask)
  • #define hsGrfTempShiftOpt (grfTempShiftLower+1)
  • #define hsGlfOptLock (glfNumLock << 1)
  • #define hsGsiOptLock 0xFE
  • #define hsGsiShiftOpt 0xFF
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:31 2006 for Palm API Guide


HsNav.h File Reference

Detailed Description

Header file that 68K programs include to access HsNav functionality.

Version:
Date:

Include dependency graph for HsNav.h:

Functions

  • UInt16 FrmCountObjectsInNavOrder (const FormType *formP)
    Obtains the number of objects in a form’s navigation tab order.
  • Err FrmGetNavOrder (const FormType *formP, FrmNavHeaderType *navHeaderP, FrmNavOrderEntryType *navOrderP, UInt16 *numObjectsP)
    Obtains information about the navigation order of a form.
  • Err FrmSetNavOrder (FormType *formP, FrmNavHeaderType *navHeaderP, FrmNavOrderEntryType *navOrderP)
    Sets the navigation order of a form. If the object with the current focus is removed from the order, the object will be redrawn in its non-focused state and the form will have no current focus. Makes a COPY of all information passed-in.
  • Err FrmGetNavEntry (const FormType *formP, UInt16 targetObjectID, UInt16 *afterObjectIDP, UInt16 *aboveObjectIDP, UInt16 *belowObjectIDP, FrmNavObjectFlagsType *objectFlagsP)
    Gets the navigation information for a single object in the form.
  • Err FrmSetNavEntry (FormType *formP, UInt16 targetObjectID, UInt16 afterObjectID, UInt16 aboveObjectID, UInt16 belowObjectID, FrmNavObjectFlagsType objectFlags)
    Edits the navigation information for a single object in the form.
  • Err FrmGetNavState (const FormType *formP, FrmNavStateFlagsType *stateFlagsP)
    Gets the current navigation state of a form.
  • Err FrmSetNavState (FormType *formP, FrmNavStateFlagsType stateFlags)
    Sets the navigation state of a form.
  • Err FrmNavDrawFocusRing (FormType *formP, UInt16 objectID, Int16 extraInfo, RectangleType *boundsInsideRingP, FrmNavFocusRingStyleEnum ringStyle, Boolean forceRestore)
  • Err FrmNavRemoveFocusRing (FormType *formP)
  • Err FrmNavGetFocusRingInfo (const FormType *formP, UInt16 *objectIDP, Int16 *extraInfoP, RectangleType *boundsInsideRingP, FrmNavFocusRingStyleEnum *ringStyleP)
  • void FrmNavObjectTakeFocus (const FormType *formP, UInt16 objID)

Function Documentation

UInt16 FrmCountObjectsInNavOrder ( const FormType * formP )

Obtains the number of objects in a form’s navigation tab order.

Parameters:
formP,: IN: Pointer to the form whose navigation information is to be obtained.
Return values:
UInt16 Returns the number of objects in the navigation tab order.

Err FrmGetNavEntry | ( | const FormType * | formP,
 |  | UInt16 | targetObjectID,
 |  | UInt16 * | afterObjectIDP,
 |  | UInt16 * | aboveObjectIDP,
 |  | UInt16 * | belowObjectIDP,
 |  | FrmNavObjectFlagsType * | objectFlagsP
 | ) |

Gets the navigation information for a single object in the form.

Parameters:
formP,: IN: Pointer to the form whose navigation order is being obtained
targetObjectID,: IN: The ID of the object whose navigation information is being obtained
afterObjectIDP,: IN: On exit, will point to the ID of the object which is to the left of the target object. If the target object is the first one in the tab order, will point to an ID of 0. Caller can pass NULL if they do not need this information.
aboveObjectIDP,: IN: On exit, will point to the ID of the object that is above the target object. An ID of 0 means the target object is in the top row of the form. Caller can pass NULL if they do not need this information.
belowObjectIDP,: IN: On exit, will point to the ID of the object that is below the target object. An ID of 0 means the target object is in the bottom row of the form. Caller can pass NULL if they do not need this information.
objectFlagsP,: IN: On exit, will point to the object flags for the target object. Caller can pass NULL if they do not need this information.
Return values:
Err Returns 0 if no error, error code otherwise.

Err FrmGetNavOrder | ( | const FormType * | formP,
 |  | FrmNavHeaderType * | navHeaderP,
 |  | FrmNavOrderEntryType * | navOrderP,
 |  | UInt16 * | numObjectsP
 | ) |

Obtains information about the navigation order of a form.

Parameters:
formP,: IN: Pointer to the form whose focus order is to be obtained
navHeaderP,: IN: If not NULL, filled with the header information for the form’s navigation order
navOrderP,: IN: If not NULL, will point to an array with info for each object in the navigation order
numObjectsP,: IN: On entry, the number of entries allocated in the navigation order array. On exit, the number of entries filled in the navigation order array.
Return values:
Err Returns 0 if no error, error code otherwise.

Err FrmGetNavState | ( | const FormType * | formP,
 |  | FrmNavStateFlagsType * | stateFlagsP
 | ) |

Gets the current navigation state of a form.

Parameters:
formP,: IN: Pointer to the form whose navigation state is to be obtained.
stateFlagsP,: IN: On exit, points to a state flags field that describes the current navigation state
Return values:
Err Returns 0 if no error, error code otherwise

Err FrmNavDrawFocusRing | ( | FormType * | formP,
 |  | UInt16 | objectID,
 |  | Int16 | extraInfo,
 |  | RectangleType * | boundsInsideRingP,
 |  | FrmNavFocusRingStyleEnum | ringStyle,
 |  | Boolean | forceRestore
 | ) |

Parameters:
formP,: IN:
objectID,: IN:
extraInfo,: IN:
boundsInsideRingP,: IN:
ringStyle,: IN:
forceRestore,: IN:
Return values:
Err Error code.

Err FrmNavGetFocusRingInfo | ( | const FormType * | formP,
 |  | UInt16 * | objectIDP,
 |  | Int16 * | extraInfoP,
 |  | RectangleType * | boundsInsideRingP,
 |  | FrmNavFocusRingStyleEnum * | ringStyleP
 | ) |

Parameters:
formP,: IN:
objectIDP,: IN:
extraInfoP,: IN:
boundsInsideRingP,: IN:
ringStyleP,: IN:
Return values:
Err Error code.

void FrmNavObjectTakeFocus | ( | const FormType * | formP,
 |  | UInt16 | objID
 | ) |

Parameters:
formP,: IN:
objID,: IN:

Err FrmNavRemoveFocusRing ( FormType * formP )

Parameters:
formP,: IN:
Return values:
Err Error code.

Err FrmSetNavEntry | ( | FormType * | formP,
 |  | UInt16 | targetObjectID,
 |  | UInt16 | afterObjectID,
 |  | UInt16 | aboveObjectID,
 |  | UInt16 | belowObjectID,
 |  | FrmNavObjectFlagsType | objectFlags
 | ) |

Edits the navigation information for a single object in the form.

Parameters:
formP,: IN: Pointer to the form whose navigation order is being changed
targetObjectID,: IN: The ID of the object which is being edited, added, or removed.
afterObjectID,: IN: The ID of the object which will be to the left of the target object. The object that is currently to the right of the after object will then be to the right of the target object. An ID of 0 means the target object should be placed at the beginning of the order. An ID of 0xFFFF (frmInvalidObjectId) means that the target object should be completely removed from the navigation order.
aboveObjectID,: IN: The ID of the object that will be above the target object. An ID of 0 means the target object is in the top row of the form.
belowObjectID,: IN: The ID of the object that will be below the target object. An ID of 0 means the target object is in the bottom row of the form.
objectFlags,: IN: The new object flags for the target object.
Return values:
Err Returns 0 if no error, error code otherwise.

Err FrmSetNavOrder | ( | FormType * | formP,
 |  | FrmNavHeaderType * | navHeaderP,
 |  | FrmNavOrderEntryType * | navOrderP
 | ) |

Sets the navigation order of a form. If the object with the current focus is removed from the order, the object will be redrawn in its non-focused state and the form will have no current focus. Makes a COPY of all information passed-in.

Parameters:
formP,: IN: Pointer to the form whose focus order is to being set
navHeaderP,: IN: Sets the header information for the form’s navigation order. This parameter cannot be NULL.
navOrderP,: IN: Specifies the new navigation order for the form. The number of entries in the array must be equal to the header parameter’s numberOfObjects field. Caller can pass NULL if they do not want to change the form’s navigation order (they just want to change the header information).
Return values:
Err Returns 0 if no error, error code otherwise

Err FrmSetNavState | ( | FormType * | formP,
 |  | FrmNavStateFlagsType | stateFlags
 | ) |

Sets the navigation state of a form.

Parameters:
formP,: IN: Pointer to the form whose navigation state is being set
stateFlags,: IN: State flags that describe the new navigation state
Return values:
Err Returns 0 if no error, error code otherwise

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:32 2006 for Palm API Guide


HsNavCommon.h File Reference

Detailed Description

Public common header file for 5-way navigation support on Treo 600.

This file contains the common constant and structures used to support 5-way navigation in an application.

Include dependency graph for HsNavCommon.h:

Data Structures

  • struct FrmNavOrderEntryTag
  • struct FrmNavHeaderTag

Defines

  • #define hsNavAPIVersion 2
  • #define hsNavFocusRingWidth 6
  • #define hsNavFocusRingWidthSingleDensity 3
  • #define hsNavFocusRingNoExtraInfo ((Int16)0xFFFF)
  • #define frmNavFocusRingNoExtraInfo ((Int16)0xFFFF)
  • #define formNavRscType 'fnav'
  • #define TxtCharIsRockerKey(m, c)
  • #define sysTrapNavSelector 0xA46F
  • #define NavSelectorFrmCountObjectsInNavOrder 0x0
  • #define NavSelectorFrmGetNavOrder 0x1
  • #define NavSelectorFrmSetNavOrder 0x2
  • #define NavSelectorFrmGetNavEntry 0x3
  • #define NavSelectorFrmSetNavEntry 0x4
  • #define NavSelectorFrmGetNavState 0x5
  • #define NavSelectorFrmSetNavState 0x6
  • #define NavSelectorFrmNavDrawFocusRing 0x7
  • #define NavSelectorFrmNavRemoveFocusRing 0x8
  • #define NavSelectorFrmNavGetFocusRingInfo 0x9
  • #define NavSelectorFrmNavObjectTakeFocus 0xA
  • #define uilibErrorClass 0x3A00
  • #define uilibErrInvalidParam (uilibErrorClass | 1)
  • #define uilibErrCurrentFocusInvalid (uilibErrorClass | 2)
  • #define uilibErrObjectFocusModeOff (uilibErrorClass | 3)
  • #define uilibErrObjectNotFound (uilibErrorClass | 4)
  • #define uilibErrNoNavInfoForForm (uilibErrorClass | 5)
  • #define uilibErrInvalidFocusObject (uilibErrorClass | 6)
  • #define uilibErrFormDoesNotHaveFocus (uilibErrorClass | 7)
  • #define kFrmNavHeaderFlagsObjectFocusStartState 0x00000001
  • #define kFrmNavHeaderFlagsAppFocusStartState 0x00000002
  • #define kFrmNavHeaderFlagsAutoGenerated 0x80000000
  • #define kFrmNavHeaderFlagsStartStateMask 0x00000003
  • #define kFrmNavHeaderFlagsDefaultStartStateValue 0x00000000
  • #define kFrmNavHeaderFlagsObjectFocusStartStateValue 0x00000001
  • #define kFrmNavHeaderFlagsAppFocusStartStateValue 0x00000002
  • #define kFrmNavHeaderFlagsInvalidStartStateValue 0x00000003
  • #define kFrmNavObjectFlagsSkip 0x0001
  • #define kFrmNavObjectFlagsForceInteractionMode 0x0002
  • #define kFrmNavObjectFlagsIsBigButton 0x8000
  • #define kFrmNavStateFlagsInteractionMode 0x00000001
  • #define kFrmNavStateFlagsObjectFocusMode 0x00000002
  • #define kFrmNavInfoVersion 1
  • #define sysFtrNumFiveWayNavVersion 32

Typedefs

  • typedef UInt16 HsNavFocusColorEnum
  • typedef UInt16 HsNavFocusRingStyleEnum
  • typedef UInt16 FrmNavFocusRingStyleEnum
  • typedef UInt32 FrmNavHeaderFlagsType
  • typedef UInt16 FrmNavObjectFlagsType
  • typedef UInt32 FrmNavStateFlagsType
  • typedef FrmNavOrderEntryTag FrmNavOrderEntryType
  • typedef FrmNavHeaderTag FrmNavHeaderType

Enumerations

  • enum HsNavFocusColorEnumTag {
    hsNavFocusColorInsideBottomRightRing = 0,
    hsNavFocusColorInsideTopLeftRing = 1,
    hsNavFocusColorMiddleRing = 2,
    hsNavFocusColorOutsideRing = 3,
    hsNavFocusColorSecondaryHighlight = 4,
    hsNavFocusColorRing1 = 5,
    hsNavFocusColorRing2 = 6,
    hsNavFocusColorRing3 = 7,
    hsNavFocusColorRing4 = 8,
    hsNavFocusColorRing5 = 9,
    hsNavFocusColorRing6 = 10
    }
  • enum HsNavFocusRingStyleEnumTag {
    hsNavFocusRingStyleObjectTypeDefault = 0,
    hsNavFocusRingStyleSquare = 1,
    hsNavFocusRingStyleRound = 2,
    hsNavFocusRingStyleHorizontalBars = 3,
    hsNavFocusRingStyleInvalid = 0xFFFF
    }
  • enum FrmNavFocusRingStyleEnumTag {
    frmNavFocusRingStyleObjectTypeDefault = 0,
    frmNavFocusRingStyleSquare = 1,
    frmNavFocusRingStyleRound = 2,
    frmNavFocusRingStyleHorizontalBars = 3,
    frmNavFocusRingStyleInvalid = 0xFFFF
    }

Define Documentation

#define TxtCharIsRockerKey | ( | m,
 |  | c | )

Value:

((((m) & commandKeyMask) != 0) && \
                                    ((((c) >= vchrRockerUp) && ((c) <= vchrRockerCenter))))

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:32 2006 for Palm API Guide


HsPhone.h File Reference

Detailed Description

Header file for the phone library (CDMA or GSM).

Notes: This is the generic header file that should be used by any code that uses the CDMA or GSM phone libraries. If you add a function to this file please makes sure you update both the CDMA and GSM libraries with this function and update the ARM wrapper library if appropriate.

Include dependency graph for HsPhone.h:

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:34 2006 for Palm API Guide


HsPhoneAudio.h File Reference

Detailed Description

Header File for Phone Library API ---- AUDIO CATEGORY.

Notes: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the Audio category. These API calls are used to play tones and other audio on an active phone connection.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:34 2006 for Palm API Guide


HsPhoneAudioTypes.h File Reference

Detailed Description

File contains Phone Audio data types.

Include dependency graph for HsPhoneAudioTypes.h:

Data Structures

  • struct PhnRingingProfileType
  • struct PhnRingingInfoType

Phone slider switch

  • #define kSliderLow 0
  • #define kSliderHigh 1
  • #define kSliderPositions 2

Typedefs

  • typedef UInt8 PhnTTYSetting
  • typedef struct PhnRingingInfoType * PhnRingingInfoPtr
  • typedef UInt8 PhnAudioSendMode

Enumerations

  • enum _PhnTTYSetting {
    phnTTYSettingAll,
    phnTTYSettingVoiceCarryOver,
    phnTTYSettingHearCarryOver,
    phnTTYSettingOff
    }
  • enum _PhnAudioSendMode {
    phnAudioLocalMode,
    phnAudioSilentMode,
    phnAudioNetworkMode
    }

Enumeration Type Documentation

enum _PhnTTYSetting

Enumerator:
phnTTYSettingAll | Send/Receive Text
phnTTYSettingVoiceCarryOver | Send Voice/ Receive Text
phnTTYSettingHearCarryOver | Send Text / Receive Voice
phnTTYSettingOff | Send/Receive Voice -- NORMAL mode

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:35 2006 for Palm API Guide


HsPhoneCallControlTypes.h File Reference

Detailed Description

Types for Phone Library call control functionality.

Data Structures

  • struct PhnConnectionType

Defines

  • #define isValidPhnConnectStateType(c) ((c >= phnConnectionActive) && (c <= phnConnectionDormant))

Typedefs

  • typedef UInt8 PhnConnectStateType
  • typedef struct PhnConnectionType * PhnConnectionPtr

Enumerations

  • enum _PhnConnectStateType {
    phnConnectionActive,
    phnConnectionHeld,
    phnConnectionDialing,
    phnConnectionAlerting,
    phnConnectionIncoming,
    phnConnectionWaiting,
    phnConnectionUnknown,
    phnConnectionDormant
    }

Define Documentation

#define isValidPhnConnectStateType ( c ) ((c >= phnConnectionActive) && (c <= phnConnectionDormant))

meaning of feature bits in a GSMSATEventMenuRec

Enumeration Type Documentation

enum _PhnConnectStateType

Phone connection state

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:35 2006 for Palm API Guide


HsPhoneCDMA.h File Reference

Detailed Description

Header File for Phone Library API ---- CDMA CATEGORY.

Notes: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the public portion of the CDMA category. These API calls are used for features specific to CDMA networks.

Include dependency graph for HsPhoneCDMA.h:

Functions

  • CharPtr PhnLibAPGetField (UInt16 refNum, PhnAddressHandle address, PhnAddressField field)
    This function returns the field’s value for a given address in a newly allocated block. This function returns 0 if there was an error while retrieving the data.

Function Documentation

CharPtr PhnLibAPGetField | ( | UInt16 | refNum,
 |  | PhnAddressHandle | address,
 |  | PhnAddressField | field
 | ) |

This function returns the field’s value for a given address in a newly allocated block. This function returns 0 if there was an error while retrieving the data.

Parameters:
refNum,: IN:
address,: IN:
field,: IN:
Return values:
CharPtr

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:35 2006 for Palm API Guide


HsPhoneCDMATypes.h File Reference

Detailed Description

Header File for Phone Library API ---- NETWORK CATEGORY.

NOTES: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the CDMA category. These API calls are used to interact with the wireless network.

Include dependency graph for HsPhoneCDMATypes.h:

Data Structures

  • struct PhnPDPList
  • struct PhnPDPWrite
  • struct PhnPDPPayload
  • struct PhnPDDataType
  • struct _PhnCDMAMediaTVSettings

Defines

  • #define indicatorNoCallerIDChar '?'
  • #define indicatorBlockedCallerIDChar '!'
  • #define indicatorRemainingCallerIDChar '~'
  • #define phnPDPUidLen 15
  • #define phnMaxNAILen 72
  • #define phnMaxMNHASharedSecretLen 48
  • #define phnMaxMNAAASharedSecretLen 48
  • #define phnMaxSvcStrLen 22
  • #define phnMaxDialStrLen 15
  • #define phnMaxMslLen 6
  • #define phnMaxUrlLen 128
  • #define phnOtaspMobdirCommitFlag 0x0001
  • #define phnOtaspFTCCommitFlag 0x0002
  • #define phnOtaspRoamListCommitFlag 0x0004
  • #define phnOtaspSPCCommitFlag 0x0008
  • #define phnOtaspIMSICommitFlag 0x0010
  • #define phnOtaspNamLockCommitFlag 0x0020
  • #define phnOtaspAkeyCommitFlag 0x0040
  • #define phnOtasp3GPDCommitFlag 0x0080
  • #define phnOtaspMIPStatCommitFlag 0x0100
  • #define phnOtaspMIPRetryCommitFlag 0x0200
  • #define phnOtaspSPCFail 0x0400
  • #define phnOtaspCommitFlag 0x0800
  • #define phnOtaspInitProgReqFlag 0x1000
  • #define phnOtaspProgInProgressFlag 0x2000
  • #define phnOtaspSSDCommitFlag 0x4000
  • #define phnOtaspSuccessful 0x02FF
  • #define phnOtaspUnsuccessful 0x03FF
  • #define isValidPhnOneXDataFailType(d) ((d >= phnOneXFailPrev) && (d <= phnOneXFailUnknown))
  • #define isValidPhnPDPWriteAck(w) ((w >= phnPDPWriteOK) && (w <= phnPDPWriteInternalModemErr))
  • #define isValidPDPReadAck(r) ((r >= phnPDPReadOK) && (r <= phnPDPReadInternalModemErr))
  • #define isValidPhnPDPIndexType(t) ((t >= phnPDPDefaultIndex) && (t <= phnPDPGenericIndex))
  • #define isValidPhnPDPCopyAck(c) ((c >= phnPDPCopyOK) && (c <= phnPDPCopyInternalModemErr))
  • #define isValidPhnPDPDeleteAck(d) ((d >= phnPDPDeleteOK) && (d <= phnPDPDeleteInternalModemErr))
  • #define isValidPhnPDPReplaceAck(r) ((r >= phnPDPReplaceOK) && (r <= phnPDPReplaceInternalModemErr))
  • #define PhnCDMAMediaTVSettingsMajorVersion 0x0001
  • #define PhnCDMAMediaTVSettingsMinorVersion 0x0000
  • #define PhnCDMAMediaTVSettingsVersion (((UInt32)PhnCDMAMediaTVSettingsMajorVersion << 16) | PhnCDMAMediaTVSettingsMinorVersion)

Typedefs

  • typedef UInt8 PhnPDPIndexType
  • typedef UInt8 PhnPDPCopyAck
  • typedef UInt8 PhnPDPDeleteAck
  • typedef UInt8 PhnPDPReplaceAck
  • typedef UInt8 PhnPDPConnectionType
  • typedef UInt32 PhnPDPService
  • typedef struct PhnPDDataType * PhnPDDataPtr
  • typedef UInt8 PhnSysPrefSetting
  • typedef UInt32 PhnGenericCDMAPreference
  • typedef UInt32 PhnGenericCDMASMSEncodingType
  • typedef UInt32 PhnCDMAFirmwareType
  • typedef UInt32 PhnCDMAVoicemailType
  • typedef _PhnCDMAMediaTVSettings PhnCDMAMediaTVSettingsType

Enumerations

  • enum PhnOneXDataFailType {
    phnOneXFailPrev = 0,
    phnOneXFailNoSrv = 1,
    phnOneXFailNetworkSORej = 2,
    phnOneXFailModemSORej = 3,
    phnOneXFailNetworkBusy = 4,
    phnOneXFailUnknown = 5
    }
  • enum PhnPDPAUncerttype {
    PhnPDPAUncert0_5_M = 0x00,
    PhnPDPAUncert0_75_M,
    PhnPDPAUncert1_M,
    PhnPDPAUncert1_5_M,
    PhnPDPAUncert2_M,
    PhnPDPAUncert3_M,
    PhnPDPAUncert4_M,
    PhnPDPAUncert6_M,
    PhnPDPAUncert8_M,
    PhnPDPAUncert12_M,
    PhnPDPAUncert16_M,
    PhnPDPAUncert24_M,
    PhnPDPAUncert32_M,
    PhnPDPAUncert48_M,
    PhnPDPAUncert64_M,
    PhnPDPAUncert96_M,
    PhnPDPAUncert128_M,
    PhnPDPAUncert192_M,
    PhnPDPAUncert256_M,
    PhnPDPAUncert384_M,
    PhnPDPAUncert512_M,
    PhnPDPAUncert768_M,
    PhnPDPAUncert1024_M,
    PhnPDPAUncert1536_M,
    PhnPDPAUncert2048_M,
    PhnPDPAUncert3072_M,
    PhnPDPAUncert4096_M,
    PhnPDPAUncert6144_M,
    PhnPDPAUncert8192_M,
    PhnPDPAUncert12288_M,
    PhnPDPAUncertGREATER_12288_M,
    PhnPDPAUncertNOT_COMPUTABLE_M,
    PhnPDPAUncertMAX
    }
  • enum PhnMIPFailType {
    phnMIPSuccess,
    phnMIPNoSimBindings,
    phnMIPFaReasonUnspecified = 64,
    phnMIPFaAdminProhibited = 65,
    phnMIPFaInsufficientResources = 66,
    phnMIPFaMobileNodeAuth = 67,
    phnMIPFaHomeAgentAuth = 68,
    phnMIPFaReqLifetimeTooLong = 69,
    phnMIPFaPoorlyFormedReq = 70,
    phnMIPFaPoorlyFormedReply = 71,
    phnMIPFaReqedEncapUnavail = 72,
    phnMIPFaReservedNUnavail = 73,
    phnMIPFaCantRevTun = 74,
    phnMIPFaMustRevTun = 75,
    phnMIPFaBadTtl = 76,
    phnMIPFaInvalidCareOfAddr = 77,
    phnMIPFaRegistration_Timeout = 78,
    PhnMIPFADelvStyleUnsupported = 79,
    phnMIPFaHome_Network_Unreachable = 80,
    phnMIPFaHa_Host_Unreachable = 81,
    phnMIPFaHa_Port_Unreachable = 82,
    phnMIPFaHa_Unreachable = 88,
    PhnMIPFANonzeroHomeAddrReq = 96,
    PhnMIPFAMissingNai = 97,
    phnMIPFaForeign_Agent = 98,
    PhnMIPFAMissingHomeAddr = 99,
    PhnMIPFAError1 = 100,
    PhnMIPFAError2 = 101,
    phnMIPFaUnknown_Challenge = 104,
    phnMIPFaMissing_Challenge = 105,
    phnMIPFaStale_Challenge = 106,
    phnMIPHaReasonUnspecified = 128,
    phnMIPHaAdminProhibited = 129,
    phnMIPHaInsufficientResources = 130,
    phnMIPHaMobileNodeAuth = 131,
    phnMIPHaForeignAgentAuth = 132,
    phnMIPHaRegIdMismatch = 133,
    phnMIPHaPoorlyFormedReq = 134,
    phnMIPHaTooManySimMobBindings = 135,
    phnMIPHaUnknownHaAddr = 136,
    phnMIPHaCantRevTun = 137,
    phnMIPHaMustRevTun = 138,
    phnMIPHaReqEncapNotAvail = 139,
    phnMIPHAError1 = 140,
    phnMIPHAError2 = 141
    }
  • enum PhnPDPWriteAck {
    phnPDPWriteOK,
    phnPDPWriteInvalidIndex,
    phnPDPWriteIndexInUse,
    phnPDPWriteNotAllowedAtIndex,
    phnPDPWriteInvalidNAILen,
    phnPDPWriteInvalidNAIName,
    phnPDPWriteDuplicateNAI,
    phnPDPWriteInvalidAAALen,
    phnPDPInvalidHALen,
    phnPDPWriteInvalidSvcStrLen,
    phnPDPWriteInvalidDialStrLen,
    phnPDPWriteIndexNotPrevSet,
    phnPDPWriteInternalModemErr
    }
  • enum PhnPDPReadAck {
    phnPDPReadOK,
    phnPDPReadInvalidIndex,
    phnPDPReadNotAllowedAtIndex,
    phnPDPReadIndexNotSet,
    phnPDPReadInternalModemErr
    }
  • enum _PhnPDPIndexType {
    phnPDPDefaultIndex,
    phnPDPTempIndex,
    phnPDPGenericIndex
    }
  • enum _PhnPDPCopyAck {
    phnPDPCopyOK,
    phnPDPCopyInvalidFromIndex,
    phnPDPCopyFromIndexNotActive,
    phnPDPCopyNotAllowedAtFromIndex,
    phnPDPCopyInvalidToIndex,
    phnPDPCopyToIndexInUse,
    phnPDPCopyNotAllowedAtToIndex,
    phnPDPCopyInvalidNAILen,
    phnPDPCopyInvalidNAIName,
    phnPDPCopyDuplicateNAI,
    phnPDPCopyInvalidAAALen,
    phnPDPCopyInvalidSvcStrLen,
    phnPDPCopyInternalModemErr
    }
  • enum _PhnPDPDeleteAck {
    phnPDPDeleteOK,
    phnPDPDeleteInvalidIndex,
    phnPDPDeleteIndexActive,
    phnPDPDeleteIndexNotUsed,
    phnPDPDeleteNotAllowedAtIndex,
    phnPDPDeleteInternalModemErr
    }
  • enum _PhnPDPReplaceAck {
    phnPDPReplaceOK,
    phnPDPReplaceInvalidIndex,
    phnPDPReplaceInvalidNotUsed,
    phnPDPReplaceNotAllowedAtIndex,
    phnPDPReplaceInvalidLen,
    phnPDPReplaceInternalModemErr
    }
  • enum _PhnPDPConnectionType {
    phnPDPConnectionTypeSIP = 0,
    phnPDPConnectionTypeMIPWithSIPFallback,
    phnPDPConnectionTypeMIP,
    phnPDPConnectionTypeInvalid
    }
  • enum _PhnPDPService {
    phnPDPServiceUnknown = 0x00000000,
    phnPDPServiceInternet = 0x00000001,
    phnPDPServiceWAP = 0x00000002,
    phnPDPServicePrivate = 0x00000004,
    phnPDPServiceMMS = 0x00000008,
    phnPDPServiceBrowser = 0x00000010,
    phnPDPServiceMail = 0x00000020,
    phnPDPServiceIM = 0x00000040,
    phnPDPServiceDownloads = 0x00000080,
    phnPDPServiceCorporateGateway = 0x00000100,
    phnPDPServicePictureMail = 0x00000200
    }
  • enum _PhnSysPrefSetting {
    phnSysPrefHomeOnly,
    phnSysPrefAOnly,
    phnSysPrefBOnly,
    phnSysPrefStandard
    }
  • enum _PhnGenericCDMAPreference {
    phnGenericCDMASMSEncoding,
    phnGenericCDMAVoiceMailNumber,
    phnGenericCDMAVoiceMailOption,
    phnGenericCDMAAllowPDPSlotModification
    }
  • enum _PhnGenericCDMASMSEncodingType {
    phnSMSEncodingGSM = 0,
    phnSMSEncodingASCII,
    phnSMSEncodingISO8859_1
    }
  • enum _PhnCDMAFirmwareType {
    phnCDMAFirmwareSprint = 0,
    phnCDMAFirmwareVerizon,
    phnCDMAFirmwareBellMobility,
    phnCDMAFirmwareEarthlink,
    phnCDMAFirmwareCrowdy,
    phnCDMAFirmwareAlltel
    }
  • enum _PhnCDMAVoicemailType {
    phnCDMAVoicemailMDN = 0,
    phnCDMAVoicemailMDN1,
    phnCDMAVoicemailDigits
    }

Define Documentation

#define indicatorBlockedCallerIDChar '!'

CDMA Only -- Means the caller ID is blocked

#define indicatorNoCallerIDChar '?'

workaround for differing header files in sdk-3.5 and sdk-internal CDMA Only -- Means there is no caller ID

#define indicatorRemainingCallerIDChar '~'

CDMA Only -- Means the caller ID is the remaining caller (3+ calls scenario)

#define phnMaxDialStrLen 15

HI_ONEX_MAX_DIAL_STR_LEN

#define phnMaxMNAAASharedSecretLen 48

HI_ONEX_MAX_MN_AAA_SHARED_SECRET_LEN

#define phnMaxMNHASharedSecretLen 48

HI_ONEX_MAX_MN_HA_SHARED_SECRET_LEN

#define phnMaxMslLen 6

HI_ONEX_MSL_LEN

#define phnMaxNAILen 72

Max length of NAI

#define phnMaxSvcStrLen 22

HI_ONEX_MAX_SVC_STR_LEN

#define phnMaxUrlLen 128

Max URL length

#define phnPDPUidLen 15

Max PDP UID length

Enumeration Type Documentation

enum _PhnCDMAFirmwareType

Enumerator:
phnCDMAFirmwareCrowdy CDMA rest of world

enum _PhnPDPConnectionType

We changed the ordering of enum to match the TIL type and to keep it consistent with Crowdy NV table for the PDP. Previously, this type was only used by NetPref we impact was minimal. The new ordering also allows us to overload the NetMaster "isMobileIPValue" record value with this value. This way any of 'if (isMobileIPValue)' will return true for both MIP and MIP with fallback. Later we can check the specific in Netmaster as needed

Enumerator:
phnPDPConnectionTypeSIP | PDP contains Simple IP settings
phnPDPConnectionTypeMIPWithSIPFallback | PDP contains MobileIP settings. Also allows Simple IP fallback - for Crowdy
phnPDPConnectionTypeMIP | PDP contains Mobile IP settings

enum _PhnPDPService

Bit mask that identifies the services a given profile should be used for

Enumerator:
phnPDPServiceInternet | Profile to be used for generic internet
phnPDPServiceWAP | Profile to be used for WAP
phnPDPServicePrivate | Profile to be used for application specfic gateway
phnPDPServiceMMS | Profile to be used for MMS
phnPDPServiceBrowser | Profile to be used for Browser
phnPDPServiceMail | Profile to be used for email
phnPDPServiceIM | Profile to be used for IM
phnPDPServiceDownloads | Profile to be used for downloads
phnPDPServiceCorporateGateway | Profile to be used for corporate network
phnPDPServicePictureMail | Profile for Picture Mail

enum PhnOneXDataFailType

Enumerator:
phnOneXFailPrev | current used PREV does not support the type of data call attempted
phnOneXFailNoSrv | modem did not have service when the data call was attempted
phnOneXFailNetworkSORej | The network rejected the service option for the data call
phnOneXFailModemSORej | The modem does not support or restricts the service option for the data call
phnOneXFailNetworkBusy | The network was busy

enum PhnPDPAUncerttype

Enumerator:
PhnPDPAUncert0_5_M | Standard deviation of 0.5 meters
PhnPDPAUncert0_75_M | Standard deviation of 0.75 meters
PhnPDPAUncert1_M | Standard deviation of 1 meter
PhnPDPAUncert1_5_M | Standard deviation of 1.5 meters
PhnPDPAUncert2_M | Standard deviation of 2 meters
PhnPDPAUncert3_M | Standard deviation of 3 meters
PhnPDPAUncert4_M | Standard deviation of 4 meters
PhnPDPAUncert6_M | Standard deviation of 6 meters
PhnPDPAUncert8_M | Standard deviation of 8 meters
PhnPDPAUncert12_M | Standard deviation of 12 meters
PhnPDPAUncert16_M | Standard deviation of 16 meters
PhnPDPAUncert24_M | Standard deviation of 24 meters
PhnPDPAUncert32_M | Standard deviation of 32 meters
PhnPDPAUncert48_M | Standard deviation of 48 meters
PhnPDPAUncert64_M | Standard deviation of 64 meters
PhnPDPAUncert96_M | Standard deviation of 96 meters
PhnPDPAUncert128_M | Standard deviation of 128 meters
PhnPDPAUncert192_M | Standard deviation of 192 meters
PhnPDPAUncert256_M | Standard deviation of 256 meters
PhnPDPAUncert384_M | Standard deviation of 384 meters
PhnPDPAUncert512_M | Standard deviation of 512 meters
PhnPDPAUncert768_M | Standard deviation of 768 meters
PhnPDPAUncert1024_M | Standard deviation of 1,024 meters
PhnPDPAUncert1536_M | Standard deviation of 1,536 meters
PhnPDPAUncert2048_M | Standard deviation of 2,048 meters
PhnPDPAUncert3072_M | Standard deviation of 3,072 meters
PhnPDPAUncert4096_M | Standard deviation of 4,096 meters
PhnPDPAUncert6144_M | Standard deviation of 6,144 meters
PhnPDPAUncert8192_M | Standard deviation of 8,192 meters
PhnPDPAUncert12288_M | Standard deviation of 12,2288 meters
PhnPDPAUncertGREATER_12288_M | Standard deviation that is greater than 12,288 meters
PhnPDPAUncertNOT_COMPUTABLE_M | Standard deviation is not computable

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:36 2006 for Palm API Guide


HsPhoneErrors.h File Reference

Detailed Description

Errors returned by API function in GSM/CDMA Library.

NOTES: This file is meant to contain all error codes that are returned by an API in the phone library. If the error is not being returned by an API call, please do not add it to this file, but keep it in a private header file in the libraries.

Include dependency graph for HsPhoneErrors.h:

Typedefs

  • typedef Err PHNErrorCode

Enumerations

  • enum PHNErrorCodeRange_1 {
    phnErrorClass = hsPhoneLibErrorClass_1,
    phnErrParam,
    phnErrUnknownError,
    phnErrNoResponse,
    phnErrNotOpen,
    phnErrStillOpen,
    phnErrMemory,
    phnErrUnknownID,
    phnErrNoPower,
    phnErrNoNetwork,
    phnErrNoConnection,
    phnErrNotAllowed,
    phnErrIllegalFacility,
    phnErrIllegalCondition,
    phnErrIllegalStatus,
    phnErrIllegalIndex,
    phnErrIllegalChars,
    phnErrIllegalMsg,
    phnErrIllegalType,
    phnErrIllegalNumber,
    phnErrTimeout,
    phnErrUnknownApp,
    phnErrUnknownNumber,
    phnErrBufferTooSmall,
    phnErrPasswordRequired,
    phnErrResponsePending,
    phnErrCancelled,
    phnErrNoRecipient,
    phnErrPhoneFailure,
    phnErrPhoneNotConnected,
    phnErrPhoneAdaptorLinkReserved,
    phnErrNotSupported,
    phnErrPhPINRequired,
    phnErrPhFPINRequired,
    phnErrPhFPUKRequired,
    phnErrNoSIM,
    phnErrPINRequired,
    phnErrPUKRequired,
    phnErrSIMFailure,
    phnErrSIMBusy,
    phnErrSIMWrong,
    phnErrIncorrectPassword,
    phnErrPIN2Required,
    phnErrPUK2Required,
    phnErrMemoryFull,
    phnErrInvalidMemIndex,
    phnErrNotFound,
    phnErrMemFailure,
    phnErrStringTooLong,
    phnErrInvalidTextChars,
    phnErrDialStringTooLong,
    phnErrInvalidDialChars,
    phnErrNoNetworkService,
    phnErrNetworkTimeout,
    phnErrNetworkNotAllowed,
    phnErrNetPINRequired,
    phnErrNetPUKRequired,
    phnErrNetSubPINRequired,
    phnErrNetSubPUKRequired,
    phnErrSPPINRequired,
    phnErrSPPUKRequired,
    phnErrCorpPINRequired,
    phnErrCorpPUKRequired,
    phnErrIllegalMS,
    phnErrIllegalME,
    phnErrGPRSNotAllowed,
    phnErrPLMNNotAllowed,
    phnErrLocAreaNotAllowed,
    phnErrRoamingNotAllowed,
    phnErrOptionNotSupported,
    phnErrReqOptionNotSubscribed,
    phnErrOptionTempOutOfOrder,
    phnErrUnspecifiedGPSRError,
    phnErrAuthenticationFailure,
    phnErrInvalidMobileClass,
    phnErrUnassignedNumber,
    phnErrOperDeterminedBarring,
    phnErrCallBarred,
    phnErrSMSXferRejected,
    phnErrDestOutOfService,
    phnErrUnidentifedSubscriber,
    phnErrFacRejected,
    phnErrUnknownSubscriber,
    phnErrNetworkOutOfOrder,
    phnErrTemporaryFailure,
    phnErrCongestion,
    phnErrResourcesUnavailable,
    phnErrReqFacNotSubscribed,
    phnErrReqFacNotImplemented,
    phnErrInvalidSMSReference,
    phnErrInvalidMsg,
    phnErrInvalidMandInfo,
    phnErrMsgTypeNonExistent,
    phnErrMsgNoCompatible,
    phnErrInfoElemNonExistent,
    phnErrProtocolError,
    phnErrInterworking,
    phnErrTelematicIWNotSupported,
    phnErrSMType0NotSupported,
    phnErrCannotReplaceMsg,
    phnErrUnspecifiedTPPIDError,
    phnErrAlphabetNotSupported,
    phnErrMsgClassNotSupported,
    phnErrUnspecifiedTPDCSError,
    phnErrCmdCannotBeActioned,
    phnErrCmdUnsupported,
    phnErrUnspecifiedTPCmdError,
    phnErrTPDUNotSupported,
    phnErrSCBusy,
    phnErrNoSCSubscription,
    phnErrSCSystemFailure,
    phnErrInvalidSMEAddr,
    phnErrDestSMEBarred,
    phnErrSMRejectedDuplicate,
    phnErrTPVPFNotSupported,
    phnErrTPVPNotSupported,
    phnErrSMSStorageFull,
    phnErrNoSMSStorage,
    phnErrErrorInMS,
    phnErrSIMApplToolkitBusy,
    phnErrMEFailure,
    phnErrSMSServReserved,
    phnErrInvalidParameter,
    phnErrFiller,
    phnErrFiller2,
    phnErrFiller3,
    phnErrMemoryFailure,
    phnErrSCAddrUnknown,
    phnErrNoCNMAAckExpected,
    phnErrFDNMismatch,
    phnErrEmergencyCallsOnly,
    phnErrACMLimitExceeded,
    phnErrHoldError,
    phnErrNumberBlacklisted,
    phnErrLidClosed,
    phnErrSATUnavailable,
    phnErrSATInactive,
    phnErrUNUSED,
    phnErrRadioNotAvailable,
    phnErrIntermediateResult,
    phnErrUnexpectedResponse,
    phnErrDuplicatePage,
    phnErrFirmwareBootNotInprogress,
    phnErrFirmwareBootInprogress,
    phnErrMMFailed,
    phnErrLowerLayer,
    phnErrCPError,
    phnErrCommandInProgress,
    phnErrSATNotSupported,
    phnErrSATNoInd,
    phnErrNeedResetModule,
    phnErrCOPSAbort,
    phnErrCSDUnassignedNumber,
    phnErrCSDNoRouteToDestination,
    phnErrCSDChannelUnacceptable,
    phnErrCSDOperatorBarring,
    phnErrCSDNumberBusy,
    phnErrCSDNoUserResponse,
    phnErrCSDNoAnswer,
    phnErrCSDCallRejected,
    phnErrCSDNumberChanged,
    phnErrCSDDestinationOutOfOrder,
    phnErrCSDInvalidNumberFormat,
    phnErrCSDFacilityRejected,
    phnErrCSDNoCircuitAvailable,
    phnErrCSDNetworkOutOfOrder,
    phnErrCSDTempFailure,
    phnErrCSDSwitchingCongestion,
    phnErrCSDAccessInfoDiscarded,
    phnErrCSDReqCircuitNotAvailable,
    phnErrCSDResourceNotAvailable,
    phnErrCSDQOSNotAvailable,
    phnErrCSDFacilityNotSubscribed,
    phnErrCSDIncomingCallsBarredCUG,
    phnErrCSDBearerNotCapable,
    phnErrCSDBearerNotAvailable,
    phnErrCSDServiceNotAvailble,
    phnErrCSDBearerNotImplemented,
    phnErrCSDACMOutOfRange,
    phnErrCSDFacilityNotImplemented,
    phnErrCSDRestrictedBearer,
    phnErrCSDServiceNotImplented,
    phnErrCSDInvalidTransID,
    phnErrCSDUserNotMemberCUG,
    phnErrCSDIncompatibleDestination,
    phnErrCSDInvalidTransitNetwork,
    phnErrCSDSemanticallyIncorrectMessage,
    phnErrCSDInvalidMandatoryInfo,
    phnErrCSDMessageTypeNotImplemented,
    phnErrCSDMessageTypeNotCompatible,
    phnErrCSDInfoNotImplemented,
    phnErrCSDIEError,
    phnErrCSDMessageNotCompatible,
    phnErrCSDRecoveryOnTimerExpiry,
    phnErrCSDProtocolError,
    phnErrGPRSRoamingNotAllowed,
    phnErrGPRSNetworkRequestDetach,
    phnErrGPRSNoService,
    phnErrGPRSNoAccess,
    phnErrGPRSServiceRefused,
    phnErrGPRSNetworkRequestPDPDeactivate,
    phnErrGPRSPDPDactivateLCCLinkActivation,
    phnErrGPRSPDPDeactivateNwkRactivate,
    phnErrGPRSPDPDactivateGMMAbort,
    phnErrGPRSPDPDeactivateSNDCPFailure,
    phnErrGPRSPDPActivateFailGMMError,
    phnErrGPRSPDPActivateFailNetReject,
    phnErrGPRSPDPActivateFailNoNSAPI,
    phnErrGPRSPDPActivateFailSMRefuse,
    phnErrCSDFDNError,
    phnErrCSDCallOperationNotAllowed,
    phnErrCSDCallBarringOutgoing,
    phnErrCSDCallBarringIncoming,
    phnErrCSDCallImpossible,
    phnErrCSDLowerLayerFailure,
    phnErrGPRSAPNMissing,
    phnErrNoCarrier,
    phnErrSMSFDNError,
    phnErrNullParam,
    phnErrBadServiceCode,
    phnErrBadATResult,
    phnErrBadATCmd,
    phnErrSIMDataDownload,
    phnErrLAST_1
    }
  • enum PHNErrorCodeRange_2 {
    phnErrorClass_2 = hsPhoneLibErrorClass_2,
    phnErrSaveNV,
    phnErrReadNV,
    phnErrFiller4,
    phnErrFiller5,
    phnErrDuplicatePlaceHoldler,
    phnErrFiller6,
    phnErrBatteryLowAlert,
    phnErrBatteryCharging,
    phnErrBadCRC,
    phnErrNoAppRegistered,
    phnErrSndDelClass,
    phnErrSndDelInvalidRingerID,
    phnErrSndDelUnusedRingerID,
    phnErrSndDelUndeletableRingerID,
    phnErrSndDelInternalMdmError,
    phnErrSndSaveClass,
    phnErrSndSaveFileNameInvalid,
    phnErrSndSaveBadDataLen,
    phnErrSndSaveBadRingerID,
    phnErrSndSaveBadSoundType,
    phnErrSndSaveOutOfMem,
    phnErrSndSaveInternalModem,
    phnErrSndSaveBadRsp,
    phnErrSndSaveContClass,
    phnErrSndSaveContBadDataLen,
    phnErrSndSaveContSeqNum,
    phnErrSndSaveContOutOfMem,
    phnErrSndSaveContInternalModem,
    phnErrModemBusy,
    phnErrModemOffline,
    phnErrIOTACommitFailed,
    phnErrIOTACommitInProgress,
    phnErrIS683ProtRevNotSupported,
    phnErrInvalidNAM,
    phnErrNAMMismatched,
    phnErrIOTASessionActive,
    phnErrIOTANoSession,
    phnErrNVUnInitialized,
    phnErrNvBadItem,
    phnErrPoweringDown,
    phnErrDenied,
    phnErrNotYetSupported,
    phnErrSMSMemoryFull,
    phnErrSMSMemoryOK,
    phnErrCauseCode16,
    phnErrMissingCarKitDriver,
    phnErrLAST_2
    }

Typedef Documentation

typedef Err PHNErrorCode

PHN Library result codes

Enumeration Type Documentation

enum PHNErrorCodeRange_1

Enumerator:
phnErrParam | 0x4001 - invalid [in] params or invalid state machine.
phnErrUnknownError | 0x4002 poorly used error code; in GSM library indicates unexpected error code from radio, or various random parameters having unexpected values
phnErrNoResponse | 0x4003 Fail to receive event from modem.
phnErrNotOpen | 0x4004 phone library is not loaded for universal function or PhnLibOpen is not called before the function is called.
phnErrStillOpen | 0x4005 opencount of phone lib is > 0 after PhnLibClose is called.
phnErrMemory | 0x4006 insufficient memory to perform the operation
phnErrUnknownID | 0x4007 id from list is valid (e.g. from GSM connection list, SMS msg list, address book, etc)
phnErrNoPower | 0x4008 when phone is off.
phnErrNoNetwork | 0x4009 No service.
phnErrNoConnection | 0x400a NOT USED IN GSM LIBRARY
phnErrNotAllowed | 0x400b operation not allowed (WISMO CME ERROR: 3, CMS ERROR: 302)
phnErrIllegalFacility | 0x400c invalid GSM barring facility specified when activating/deactivating call barring
phnErrIllegalCondition | 0x400d provided condition for operation is invalid (such as GSM call forwarding condition)
phnErrIllegalStatus | 0x400e invalid GSM SMS Message Status detected
phnErrIllegalIndex | 0x400f index out of range in list (such as SIM PhoneBook or segmented SMS msg)
phnErrIllegalChars | 0x4010 character out of GSM valid set in SMS or other text
phnErrIllegalMsg | 0x4011 NOT USED IN GSM LIBRARY
phnErrIllegalType | 0x4012 unexpected type encountered (for example unexpected SMS message type for operation)
phnErrIllegalNumber | 0x4013 unexpected character in DTMF string or GSM phone number
phnErrTimeout | 0x4014 NOT USED IN GSM LIBRARY
phnErrUnknownApp | 0x4015 NOT USED IN GSM LIBRARY
phnErrUnknownNumber | 0x4016 given GSM phone number not found in address book
phnErrBufferTooSmall | 0x4017 NOT USED IN GSM LIBRARY
phnErrPasswordRequired | 0x4018 required GSM password or PIN is missing or invalid
phnErrResponsePending | 0x4019 operation failed because radio was busy processing another command
phnErrCancelled | 0x401a operation cancelled by user (e.g. cancel while entering password)
phnErrNoRecipient | 0x401b operation failed because GSM SMS message had no recipients specified
phnErrPhoneFailure | 0x401c Error reading/writing value to phone.
phnErrPhoneNotConnected | 0x401d WISMO CME ERROR: 1
phnErrPhoneAdaptorLinkReserved | 0x401e WISMO CME ERROR: 2
phnErrNotSupported | 0x401f Operation not supported (WISMO CME ERROR: 4; CMS ERROR: 303)
phnErrPhPINRequired | 0x4020 WISMO CME ERROR: 5 (PH-SIM PIN required (SIM lock))
phnErrPhFPINRequired | 0x4021 WISMO CME ERROR: 6
phnErrPhFPUKRequired | 0x4022 WISMO CME ERROR: 7
phnErrNoSIM | 0x4023 WISMO CME ERROR: 10 (SIM not inserted)
phnErrPINRequired | 0x4024 WISMO CME ERROR: 11 (SIM PIN required)
phnErrPUKRequired | 0x4025 WISMO CME ERROR: 12 (SIM PUK required)
phnErrSIMFailure | 0x4026 WISMO CME ERROR: 13 (SIM failure)
phnErrSIMBusy | 0x4027 WISMO CME ERROR: 14; CMS ERROR: 314; NOT DOCUMENTED IN WISMO DOC
phnErrSIMWrong | 0x4028 WISMO CME ERROR: 15; CMS ERROR: 315; NOT DOCUMENTED IN WISMO DOC
phnErrIncorrectPassword | 0x4029 WISMO CME ERROR: 16 (Incorrect password)
phnErrPIN2Required | 0x402a WISMO CME ERROR: 17 (SIM PIN2 required)
phnErrPUK2Required | 0x402b WISMO CME ERROR: 18 (SIM PUK2 required)
phnErrMemoryFull | 0x402c WISMO CME ERROR: 20 (Memory full )
phnErrInvalidMemIndex | 0x402d WISMO CME ERROR: 21 (Invalid index)
phnErrNotFound | 0x402e WISMO CME ERROR: 22 (Not found)
phnErrMemFailure | 0x402f WISMO CME ERROR: 23 NOT DOCUMENTED IN WISMO DOC
phnErrStringTooLong | 0x4030 WISMO CME ERROR: 24 (Text string too long)
phnErrInvalidTextChars | 0x4031 WISMO CME ERROR: 25 NOT DOCUMENTED IN WISMO DOC
phnErrDialStringTooLong | 0x4032 WISMO CME ERROR: 26 (Dial string too long)
phnErrInvalidDialChars | 0x4033 WISMO CME ERROR: 27 (Invalid characters in dial string)
phnErrNoNetworkService | 0x4034 WISMO CME ERROR: 30 (No network service); signal faded on CDMA
phnErrNetworkTimeout | 0x4035 WISMO CME ERROR: 31; CMS ERROR: 332 NOT DOCUMENTED IN WISMO DOC
phnErrNetworkNotAllowed | 0x4036 WISMO CME ERROR: 32 (Network not allowed - emergency calls only)
phnErrNetPINRequired | 0x4037 WISMO CME ERROR: 40 (Network personalisation PIN required (Network lock))
phnErrNetPUKRequired | 0x4038 WISMO CME ERROR: 41
phnErrNetSubPINRequired | 0x4039 WISMO CME ERROR: 42
phnErrNetSubPUKRequired | 0x403a WISMO CME ERROR: 43
phnErrSPPINRequired | 0x403b WISMO CME ERROR: 44
phnErrSPPUKRequired | 0x403c WISMO CME ERROR: 45
phnErrCorpPINRequired | 0x403d WISMO CME ERROR: 46
phnErrCorpPUKRequired | 0x403e WISMO CME ERROR: 47
phnErrIllegalMS | 0x403f WISMO CME ERROR: 103
phnErrIllegalME | 0x4040 WISMO CME ERROR: 106
phnErrGPRSNotAllowed | 0x4041 WISMO CME ERROR: 107
phnErrPLMNNotAllowed | 0x4042 WISMO CME ERROR: 111
phnErrLocAreaNotAllowed | 0x4043 WISMO CME ERROR: 112
phnErrRoamingNotAllowed | 0x4044 WISMO CME ERROR: 113
phnErrOptionNotSupported | 0x4045 WISMO CME ERROR: 132
phnErrReqOptionNotSubscribed | 0x4046 WISMO CME ERROR: 133
phnErrOptionTempOutOfOrder | 0x4047 WISMO CME ERROR: 134
phnErrUnspecifiedGPSRError | 0x4048 WISMO CME ERROR: 148
phnErrAuthenticationFailure | 0x4049 WISMO CME ERROR: 149
phnErrInvalidMobileClass | 0x404a WISMO CME ERROR: 150
phnErrUnassignedNumber | 0x404b WISMO CMS ERROR: 1
phnErrOperDeterminedBarring | 0x404c WISMO CMS ERROR: 8
phnErrCallBarred | 0x404d WISMO CMS ERROR: 10 or 18 Call guard option does not allow call
phnErrSMSXferRejected | 0x404e WISMO CMS ERROR: 21
phnErrDestOutOfService | 0x404f WISMO CMS ERROR: 27
phnErrUnidentifedSubscriber | 0x4050 WISMO CMS ERROR: 28
phnErrFacRejected | 0x4051 WISMO CMS ERROR: 29
phnErrUnknownSubscriber | 0x4052 WISMO CMS ERROR: 30
phnErrNetworkOutOfOrder | 0x4053 WISMO CMS ERROR: 38
phnErrTemporaryFailure | 0x4054 WISMO CMS ERROR: 41
phnErrCongestion | 0x4055 WISMO CMS ERROR: 42, APEX 2,10,16,17
phnErrResourcesUnavailable | 0x4056 No resources/network busy
phnErrReqFacNotSubscribed | 0x4057 GSM Error
phnErrReqFacNotImplemented | 0x4058 GSM Error
phnErrInvalidSMSReference | 0x4059 GSM Error
phnErrInvalidMsg | 0x405a GSM Error
phnErrInvalidMandInfo | 0x405b GSM Error
phnErrMsgTypeNonExistent | 0x405c GSM Error
phnErrMsgNoCompatible | 0x405d GSM Error
phnErrInfoElemNonExistent | 0x405e GSM Error
phnErrProtocolError | 0x405f GSM Error
phnErrInterworking | 0x4060 GSM Error
phnErrTelematicIWNotSupported | 0x4061 GSM Error
phnErrSMType0NotSupported | 0x4062 GSM Error
phnErrCannotReplaceMsg | 0x4063 GSM Error
phnErrUnspecifiedTPPIDError | 0x4064 GSM Error
phnErrAlphabetNotSupported | 0x4065 GSM Error
phnErrMsgClassNotSupported | 0x4066 GSM Error
phnErrUnspecifiedTPDCSError | 0x4067 GSM Error
phnErrCmdCannotBeActioned | 0x4068 GSM Error
phnErrCmdUnsupported | 0x4069 GSM Error
phnErrUnspecifiedTPCmdError | 0x406a GSM Error
phnErrTPDUNotSupported | 0x406b GSM Error
phnErrSCBusy | 0x406c GSM Error
phnErrNoSCSubscription | 0x406d GSM Error
phnErrSCSystemFailure | 0x406e GSM Error
phnErrInvalidSMEAddr | 0x406f GSM Error
phnErrDestSMEBarred | 0x4070 GSM Error
phnErrSMRejectedDuplicate | 0x4071 GSM Error
phnErrTPVPFNotSupported | 0x4072 GSM Error
phnErrTPVPNotSupported | 0x4073 GSM Error
phnErrSMSStorageFull | 0x4074 GSM Error
phnErrNoSMSStorage | 0x4075 GSM Error
phnErrErrorInMS | 0x4076 GSM Error
phnErrSIMApplToolkitBusy | 0x4077 GSM Error
phnErrMEFailure | 0x4078 GSM Error
phnErrSMSServReserved | 0x4079 WISMO CMS ERROR: 301 (SMS service of ME reserved)
phnErrInvalidParameter | 0x407a GSM Error
phnErrFiller | 0x407b GSM Error
phnErrFiller2 | 0x407c GSM Error
phnErrFiller3 | 0x407d GSM Error
phnErrMemoryFailure | 0x407e Memory access failure
phnErrSCAddrUnknown | 0x407f GSM Error
phnErrNoCNMAAckExpected | 0x4080 GSM Error
phnErrFDNMismatch | Errors returned by the firmware (NO CARRIER) 0x4081 GSM Error
phnErrEmergencyCallsOnly | 0x4082 GSM Error
phnErrACMLimitExceeded | 0x4083 GSM Error
phnErrHoldError | 0x4084 GSM Error
phnErrNumberBlacklisted | 0x4085 GSM Error
phnErrLidClosed | 0x4086
phnErrSATUnavailable | 0x4087 GSM Error
phnErrSATInactive | 0x4088 GSM Error
phnErrUNUSED | 0x4089 GSM Error
phnErrRadioNotAvailable | 0x408a GSM Error
phnErrIntermediateResult | 0x408b GSM Error
phnErrUnexpectedResponse | 0x408c GSM Error
phnErrDuplicatePage | 0x408d GSM Error
phnErrFirmwareBootNotInprogress | 0x408e GSM Error
phnErrFirmwareBootInprogress | 0x408f GSM Error
phnErrMMFailed | These error codes map directly to Wismo error codes, but maybe could be used by other radios? 0x4090 GSM Error
phnErrLowerLayer | 0x4091 GSM Error
phnErrCPError | 0x4092 GSM Error
phnErrCommandInProgress | 0x4093 GSM Error
phnErrSATNotSupported | 0x4094 GSM Error
phnErrSATNoInd | 0x4095 GSM Error
phnErrNeedResetModule | 0x4096 GSM Error
phnErrCOPSAbort | 0x4097 GSM Error
phnErrCSDUnassignedNumber | CSD CEER Errors 0x4098 GSM Error
phnErrCSDNoRouteToDestination | 0x4099 GSM Error
phnErrCSDChannelUnacceptable | 0x409a GSM Error
phnErrCSDOperatorBarring | 0x409b GSM Error
phnErrCSDNumberBusy | 0x409c GSM Error
phnErrCSDNoUserResponse | 0x409d GSM Error
phnErrCSDNoAnswer | 0x409e GSM Error
phnErrCSDCallRejected | 0x409f GSM Error
phnErrCSDNumberChanged | 0x40a0 GSM Error
phnErrCSDDestinationOutOfOrder | 0x40a1 GSM Error
phnErrCSDInvalidNumberFormat | 0x40a2 GSM Error
phnErrCSDFacilityRejected | 0x40a3 GSM Error
phnErrCSDNoCircuitAvailable | 0x40a4 GSM Error
phnErrCSDNetworkOutOfOrder | 0x40a5 GSM Error
phnErrCSDTempFailure | 0x40a6 GSM Error
phnErrCSDSwitchingCongestion | 0x40a7 GSM Error
phnErrCSDAccessInfoDiscarded | 0x40a8 GSM Error
phnErrCSDReqCircuitNotAvailable | 0x40a9 GSM Error
phnErrCSDResourceNotAvailable | 0x40aa GSM Error
phnErrCSDQOSNotAvailable | 0x40ab GSM Error
phnErrCSDFacilityNotSubscribed | 0x40ac GSM Error
phnErrCSDIncomingCallsBarredCUG | 0x40ad GSM Error
phnErrCSDBearerNotCapable | 0x40ae GSM Error
phnErrCSDBearerNotAvailable | 0x40af GSM Error
phnErrCSDServiceNotAvailble | 0x40b0 GSM Error
phnErrCSDBearerNotImplemented | 0x40b1 GSM Error
phnErrCSDACMOutOfRange | 0x40b2 GSM Error
phnErrCSDFacilityNotImplemented | 0x40b3 GSM Error
phnErrCSDRestrictedBearer | 0x40b4 GSM Error
phnErrCSDServiceNotImplented | 0x40b5 GSM Error
phnErrCSDInvalidTransID | 0x40b6 GSM Error
phnErrCSDUserNotMemberCUG | 0x40b7 GSM Error
phnErrCSDIncompatibleDestination | 0x40b8 GSM Error
phnErrCSDInvalidTransitNetwork | 0x40b9 GSM Error
phnErrCSDSemanticallyIncorrectMessage | 0x40ba GSM Error
phnErrCSDInvalidMandatoryInfo | 0x40bb GSM Error
phnErrCSDMessageTypeNotImplemented | 0x40bc GSM Error
phnErrCSDMessageTypeNotCompatible | 0x40bd GSM Error
phnErrCSDInfoNotImplemented | 0x40be GSM Error
phnErrCSDIEError | 0x40bf GSM Error
phnErrCSDMessageNotCompatible | 0x40c0 GSM Error
phnErrCSDRecoveryOnTimerExpiry | 0x40c1 GSM Error
phnErrCSDProtocolError | 0x40c2 GSM Error
phnErrGPRSRoamingNotAllowed | GPRS CEER Errors 0x40c3 GSM Error
phnErrGPRSNetworkRequestDetach | 0x40c4 GSM Error
phnErrGPRSNoService | 0x40c5 GSM Error
phnErrGPRSNoAccess | 0x40c6 GSM Error
phnErrGPRSServiceRefused | 0x40c7 GSM Error
phnErrGPRSNetworkRequestPDPDeactivate | 0x40c8 GSM Error
phnErrGPRSPDPDactivateLCCLinkActivation | 0x40c9 GSM Error
phnErrGPRSPDPDeactivateNwkRactivate | 0x40ca GSM Error
phnErrGPRSPDPDactivateGMMAbort | 0x40cb GSM Error
phnErrGPRSPDPDeactivateSNDCPFailure | 0x40cc GSM Error
phnErrGPRSPDPActivateFailGMMError | 0x40cd GSM Error
phnErrGPRSPDPActivateFailNetReject | 0x40ce GSM Error
phnErrGPRSPDPActivateFailNoNSAPI | 0x40cf GSM Error
phnErrGPRSPDPActivateFailSMRefuse | 0x40d0 GSM Error
phnErrCSDFDNError | MORE CSD Errors 0x40d1 GSM Error
phnErrCSDCallOperationNotAllowed | 0x40d2 GSM Error
phnErrCSDCallBarringOutgoing | 0x40d3 GSM Error
phnErrCSDCallBarringIncoming | 0x40d4 GSM Error
phnErrCSDCallImpossible | 0x40d5 GSM Error
phnErrCSDLowerLayerFailure | 0x40d6 GSM Error
phnErrGPRSAPNMissing | More GPRS Errors 0x40d7 GSM Error
phnErrNoCarrier | More Errors 0x40d8 GSM Error
phnErrSMSFDNError | 0x40d9 GSM Error : SMS Fixed Dialing error (CMS ERROR: 531)
phnErrNullParam | 0x40da GSM Error : provided parameter is unexpectedly null
phnErrBadServiceCode | 0x40db GSM Error : intermediate response has unexpected service code
phnErrBadATResult | 0x40dc GSM Error : AT response from radio is missing or invalid
phnErrBadATCmd | 0x40dd GSM Error : AT cmd to radio is missing or invalid
phnErrSIMDataDownload | 0x40de GSM Error : SIM Data Download error (CMS ERROR: 213)
phnErrLAST_1 | IMPORTANT: the last valid error code for this error class is 0x40FF. If you exceed this range, you will collide with the next error class that belongs to PalmSource, and will have all kinds of conflicts, such as wrong error strings and wrong interpretation of errors by applications.

enum PHNErrorCodeRange_2

NOTE: The last error code allowed in Phone library error class #1 is 0x40FF. We reserve a second error base to allow for more error codes below. hsPhoneLibErrorClass_2 is 0x7300.

Enumerator:
phnErrSaveNV | 0x7301 CDMA Error : Fail to save params to Modem's NV.
phnErrReadNV | 0x7302 CDMA Error : Fail to read params from Modem's NV.
phnErrFiller4 | 0x7303 Filler -- you can use this error but dont remove.
phnErrFiller5 | 0x7304 Filler -- you can use this error but dont remove.
phnErrDuplicatePlaceHoldler | 0x7305 *************************************************
phnErrFiller6 | 0x7306 Filler -- you can use this error but dont remove.
phnErrBatteryLowAlert | 0x7307 CDMA Error : Phone battery is under the first low alert level.
phnErrBatteryCharging | 0x7308 CDMA Error : Phone battery is being charged.
phnErrBadCRC | 0x7309 CDMA Error : bad CRC observed
phnErrNoAppRegistered | 0x730a CDMA Error : Need to have at least an app to register for the corresponding service.
phnErrSndDelClass | SOUND Management Errors 0x730b CDMA Error : Should never send this value!!!
phnErrSndDelInvalidRingerID | 0x730c CDMA Error : The ringer index is not a valid ringer ID index
phnErrSndDelUnusedRingerID | 0x730d CDMA Error : The ringer index does not contain an active ringer idx to delete
phnErrSndDelUndeletableRingerID | 0x730e CDMA Error : The ringer index is a perminent ringer index
phnErrSndDelInternalMdmError | 0x730f CDMA Error : An internal modem error occurred when attempting to delete the file.
phnErrSndSaveClass | 0x7310 CDMA Error : Should never send this value!!!
phnErrSndSaveFileNameInvalid | 0x7311 CDMA Error : The null terminated string was not found as the file name.
phnErrSndSaveBadDataLen | 0x7312 CDMA Error : The file data length and/or the block data length is invalid.
phnErrSndSaveBadRingerID | 0x7313 CDMA Error : The ringer index specified is invalid (not a write-able index or out of range)
phnErrSndSaveBadSoundType | 0x7314 CDMA Error : The file type is invalid or not currently supported
phnErrSndSaveOutOfMem | 0x7315 CDMA Error : First block of file could not be written due to limited memory
phnErrSndSaveInternalModem | 0x7316 CDMA Error : An internal modem error occurred when attempting to download this block of the file (file is discarded).
phnErrSndSaveBadRsp | 0x7317 CDMA Error : Modem thinks that the file is downloaded completely, but the host still has not sent all or vice versa.
phnErrSndSaveContClass | 0x7318 CDMA Error : Should never use this value
phnErrSndSaveContBadDataLen | 0x7319 CDMA Error : The block data length of the file data in this block is invalid.
phnErrSndSaveContSeqNum | 0x731a CDMA Error : The sequence number is not in series with previous file download command.
phnErrSndSaveContOutOfMem | 0x731b CDMA Error : Next block of file could not be written due to limited memory.
phnErrSndSaveContInternalModem | 0x731c CDMA Error : An internal modem error occurred when attempting to download this block of the file.
phnErrModemBusy | 0x731d
phnErrModemOffline | 0x731e
phnErrIOTACommitFailed | IOTA errors 0x731f CDMA Error : IOTA commit failed
phnErrIOTACommitInProgress | 0x7320 CDMA Error : IOTA commit is in progress
phnErrIS683ProtRevNotSupported | 0x7321 CDMA Error : The IOTA protocol revision is not supported
phnErrInvalidNAM | 0x7322 CDMA Error : The NAM selected is invalid
phnErrNAMMismatched | 0x7323 CDMA Error : The NAM selected is not the same as the NAM currently used in the current session
phnErrIOTASessionActive | 0x7324 CDMA Error : An IOTA session is active
phnErrIOTANoSession | 0x7325 CDMA Error : No IOTA session currently
phnErrNVUnInitialized | 0x7326 CDMA Error : Uninitialized NV item
phnErrNvBadItem | 0x7327 CDMA Error : Bad or restricted NV item
phnErrPoweringDown | 0x7328 Error: The radio is currently powering down and we can not do anything
phnErrDenied | 0x7329 Request denied
phnErrNotYetSupported | 0x732A Feature not yet supported
phnErrSMSMemoryFull | 0x732B No more memory to receive incoming SMS
phnErrSMSMemoryOK | 0x732C There is now enough memory to receive incoming SMS
phnErrCauseCode16 | 0x732D GSM04.08: Cause code 16
phnErrMissingCarKitDriver | 0x732E The wired car kit driver is missing

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:37 2006 for Palm API Guide


HsPhoneEvent.h File Reference

Detailed Description

Header file for the phone library (CDMA or GSM).

NOTES: Header file for the phone library (CDMA or GSM)

This file defines the Notification Events between the Phone Library (either GSM or CDMA) and applications. These events allow applications to react to changes of state in the Phone Library.

Applications wishing to receive notification events from the Phone Library must register using the PhnLibRegister call. The services parameter to PhnLibRegister is a bitmap identifying the classes of events that are of interest. To unregister for notifications the app can call PhnLibRegister with the services parameter set to zero.

Notifications are sent to applications based on their unique creatorID. Confusion may occur if multiple versions of a single app exist with the same creatorID. In this case notifications will be sent to the latest version of the app (even if this app was not the one that registered). In general, you should try to avoid this situation where possible.

Each notification event is identified by a unique event code (see PhnEventCode). The event code then determines the contents of the remainder of the event.

There are three styles of notifications from the Phone Library:

(1) universal broadcast notifications are sent to all registrants for a given service. (for example, a change in the network registration status)

(2) exclusive broadcast notifications are sent to registrations one at a time. The first app that acknowledges the notification by setting the acknowedge flag will be presumed to own that notification. Only this app should handle and respond to the notification. For example, an incoming call or incoming SMS message will be acknowleged by an app that wants to answer the call or process the SMS message.

(3) direct notifications are sent directly to a specific app with a known interest in some occurence in the phone library. These are typically used after an application has taken ownership of a particular call, message, or dialog. By sending notifications directly to the owning app we avoid confusion with multiple apps sending competing instructions.

Include dependency graph for HsPhoneEvent.h:

Data Structures

  • struct PhnDisconnectEventType
  • struct PhnSubscriberAddrInfo
  • struct PhnConferenceDesc
  • struct PhnError
  • struct PhnSMSParams
  • struct PhnKeyPressedParams
  • struct PhnRegistrationType
  • struct PhnPowerEventType
  • struct PhnIndicationType
  • struct PhnPasswordEventType
  • struct PhnProgressEventType
  • struct PhnMovedMsgDescType
  • struct PhnMovedMsgsParamsType
  • struct PhnUSSDEventType
  • struct PhnSATEventType
  • struct PhnSATEventDisplayText
  • struct PhnSATEventGetInkey
  • struct PhnSATEventHeader
  • struct PhnSATEventGetInput
  • struct PhnSATEventSetupCall
  • struct PhnSATEventPlayTone
  • struct PhnSATEventMenuRec
  • struct PhnSATEventMenu
  • struct PhnSATEventSendSMS
  • struct PhnSATEventRefresh
  • struct PhnSATEventLaunchBrowser
  • struct PhnSATEventIdleModeText
  • struct PhnSATEventRunAT
  • struct PhnSATEventDataSvc
  • struct PhnSATEventSendDTMF
  • struct PhnPhoneEquipmentMode
  • struct PhnMiscDbgRptType
  • struct PhnOnexMipRRQType
  • struct WUNotificationEventType
  • struct UPNotificationEventType
  • struct WAPNotificationEventType
  • struct PhnEventType
  • union PhnEventType::Data

Palm Notifications

  • #define NAITextLength 72
  • #define NAITextSize (NAITextLength + 1)
  • #define PasswordLength 16
  • #define PasswordSize (PasswordLength + 1)

WAP defines

Text Header elements
  • #define phnWAPEvent 'Hwap'
  • #define WAPMsgLength 160
  • #define WAPMsgSize (WAPMsgLength + 1)

WakeUp notification

  • #define WUHeaderEscapeSeq "//"
  • #define WUTextHeader "//WU"
  • #define WUTextHeaderLength 4
  • #define WUFieldDelimiter ';'
  • #define phnWUEvent 'Hwak'

UP stuff

Text Header elements
  • #define UPHeaderEscapeSeq "//"
  • #define UPTextHeader "//UP"
  • #define UPTextHeaderLength 4
  • #define phnUPEvent 'Hsup'
  • #define UPDataSize 160

Defines

  • #define phnAddressDigitsMax 32
  • #define phnUserDataMax 255
  • #define phnNotifySubscriber 'CLIP'
  • #define phnNotifyEquipMode 'Heqp'
  • #define phnLibLaunchCmdEvent 0xabad
  • #define phnLibLaunchCmdRegister 0xabae
  • #define isValidPhnIndicationKind(i) ((i >= indicationSIMReady) && (i <= indicationSIMChanged))
  • #define isValidPhnEventCode(e) ((e >= phnEvtCardInsertion) && (e < kMaxPhnEvtSupported))
  • #define PhnSMSParamsVersion 2
  • #define isValidPhnModuleButtonType(m) (m < phnButtonLast)
  • #define isValidPhnProgressType(p) (p <= kShowSegment)
  • #define isValidPhnOpenDialogType(o) (o <= kDialogSendUSSD)
  • #define isValidPhnMiscDbgUpdateKind(x) ((x >= eDbgUpdateNone) && (x <= eDbgUpdateQuit))
  • #define isValidPhnMsgIDType(m) ((m >= kMsgIdReserved) && (m <= kMsgIdUserAck))
  • #define isValidPhnDataChannelType(x) ((x == phnDataAvailable) || (x == phnDataNotAvailable))
  • #define WAPNotificationTypeVersion 3
  • #define PhnEventRecord PhnEventType

Typedefs

  • typedef UInt8 PhnSMSType
  • typedef UInt8 PhnSMSClass
  • typedef Err(* ContinuePowerOnOffCallback )(UInt16 refNum)
  • typedef char PhnPassword [maxPasswordLen+2]
  • typedef PhnSATEventHeader PhnSATEventHeader
  • typedef struct PhnOnexMipRRQType * PhnOnexMipRRQPtr
  • typedef WUNotificationEventType WUNotificationEventType
  • typedef UPNotificationEventType UPNotificationEventType
  • typedef UInt8 PhnWAPPushContent
  • typedef UInt16 PhnWAPPushAppId
  • typedef WAPNotificationEventType WAPNotificationEventType
  • typedef struct PhnEventType * PhnEventPtr

Enumerations

  • enum PhnIndicationKind {
    indicationSIMReady,
    indicationSIMMessages,
    indicationNetworkSearch,
    indicationPasswordAccepted,
    indicationNetworkAvailable,
    indicationStartingRadio,
    indicationPoweringOffRadio,
    indicationResettingRadio,
    indicationAuthFailure,
    indicationSIMChanged,
    indicationInitComplete,
    indicationOtaspMsg
    }
  • enum PhnEventCode {
    phnEvtCardInsertion,
    phnEvtRegistration,
    phnEvtError,
    phnEvtKeyPress,
    phnEvtPower,
    phnEvtPassword,
    phnEvtProgress,
    phnEvtIndication,
    phnEvtConnectInd,
    phnEvtConnectConf,
    phnEvtSubscriber,
    phnEvtDisconnectInd,
    phnEvtDisconnectConf,
    phnEvtBusy,
    phnEvtUpdate,
    phnEvtConference,
    phnEvtVoiceMail,
    phnEvtMessageInd,
    phnEvtSegmentInd,
    phnEvtMessageStat,
    phnEvtMessageDel,
    phnEvtMessageMoved,
    phnEvtSATNotification,
    phnEvtUSSDInd,
    phnEvtPhoneEquipmentMode,
    phnEvtGPRSRegistration,
    phnEvtMMSInd,
    phnEvtMemoryFull,
    phnEvtMemoryOK,
    phnEvtWAPInd,
    phnEvtDebugReport,
    phnEvtSSModeChanged,
    phnEvtPDDataChanged,
    phnEvtOneXStatus,
    phnEvtMIPFailed,
    phnEvtIOTAStatus,
    phnEvtDataChannel,
    phnEvtOneXMipRRQInd,
    phnEvtOneXDataFail,
    phnEvtStartDial,
    phnEvtStartIncomingCall,
    phnEvtAlertingPreConnected,
    phnEvtAlerting,
    phnEvtPreConnected,
    phnEvtDataSessionStatus,
    phnEvtDataSessionDisconnected,
    phnEvtNetworkTime,
    kMaxPhnEvtSupported
    }
  • enum PhnSMSTypeEnum {
    defaultType = 0,
    discardType0 = 0x40,
    replaceType1 = 0x41,
    replaceType2 = 0x42,
    replaceType3 = 0x43,
    replaceType4 = 0x44,
    replaceType5 = 0x45,
    replaceType6 = 0x46,
    replaceType7 = 0x47
    }
  • enum PhnSMSClassEnum {
    classUnknown = 0,
    class0,
    class1,
    class2,
    class3
    }
  • enum PhnModuleButtonType {
    phnButtonHeadset,
    phnButtonRedial,
    phnButtonAnswerCall,
    phnButtonRejectCall,
    phnButtonIgnoreCall,
    phnButtonHoldCall,
    phnButtonConferenceCall,
    phnButtonLast
    }
  • enum PhnProgressType {
    kOpenDialog,
    kCloseDialog,
    kSetText,
    kSetRecipient,
    kShowSegment
    }
  • enum PhnOpenDialogType {
    kDialogSetBarring,
    kDialogGetBarring,
    kDialogSetForwarding,
    kDialogGetForwarding,
    kDialogSetCallWaiting,
    kDialogGetCallWaiting,
    kDialogGetOperatorList,
    kDialogSetOperator,
    kDialogOperatorSelection,
    kDialogImmediateSend,
    kDialogDeferredSend,
    kDialogSendUSSD
    }
  • enum PhnMiscDbgUpdateKind {
    eDbgUpdateNone,
    eDbgUpdateYes,
    eDbgUpdateQuit
    }
  • enum PhnMsgIDType {
    kMsgIdReserved,
    kMsgIdDeliverMT,
    kMsgIdSubmitMO,
    kMsgIdcancelMO,
    kMsgIdDeliveryMTAck,
    kMsgIdUserAck
    }
  • enum PhnDataChannelType {
    phnDataAvailable,
    phnDataNotAvailable
    }
  • enum PhnWAPPushContentType {
    kWAPContentTypeUnknown = 0,
    kWAPContentTypeIOTA,
    kWAPContentTypeMMS,
    kWAPContentTypeMMSText,
    kWAPContentTypeServiceLoad,
    kWAPContentTypeServiceLoadText,
    kWAPContentTypeServiceIndicator,
    kWAPContentTypeServiceIndicatorText
    }
  • enum PhnWAPPushAppIdType {
    kWAPAnyApp = 0x00,
    kWAPPushSIA = 0x01,
    kWAPWmlUa = 0x02,
    kWAPWtaUa = 0x03,
    kWAPMmsUa = 0x04,
    kWAPPushSyncml = 0x05,
    kWAPLocUa = 0x06,
    kWAPSyncmlDm = 0x07,
    kWAPDrmUa = 0x08,
    kWAPEmnUa = 0x09,
    kWAPWvUa = 0x0A,
    kWAPMsLocalcontentUa = 0x8000,
    kWAPMsIMclientUa = 0x8001,
    kWAPdocomoImodeMailUa = 0x8002,
    kWAPdocomoImodeMrUa = 0x8003,
    kWAPdocomoImodeMfUa = 0x8004,
    kWAPMotorolaLocationUa = 0x8005,
    kWAPMotorolaNowUa = 0x8006,
    kWAPMotorolaOtaprovUa = 0x8007,
    kWAPMotorolaBrowserUa = 0x8008,
    kWAPMotorolaSplashUa = 0x8009,
    kWAPUnused = 0x800A,
    kWAPNaiMvswCommand = 0x800B,
    kWAPopenwaveIotaUa = 0x8010
    }

Define Documentation

#define phnLibLaunchCmdEvent 0xabad

Phone Event notification. Used to be 0x2bad, which is less than Palm's custom base. Have to get Palm to allow that.

#define phnLibLaunchCmdRegister 0xabae

Sent to application to register with GSM library

#define phnNotifyEquipMode 'Heqp'

GSM notificaiton for equip mode change

#define phnNotifySubscriber 'CLIP'

GSM notification with caller ID

#define phnUPEvent 'Hsup'

start sequence of the header

#define phnWUEvent 'Hwak'

start sequence of the header

#define UPDataSize 160

maximum size of the data sent from this message

#define UPHeaderEscapeSeq "//"

start sequence of the header

#define UPTextHeader "//UP"

beginning of an UP header

#define UPTextHeaderLength 4

length of the header

#define WAPNotificationTypeVersion 3

Structure passed to the callbacks registered for WAP notifications

#define WUFieldDelimiter ';'

wakeup message fields are separated by a semi-colon

#define WUHeaderEscapeSeq "//"

start sequence of the header

#define WUTextHeader "//WU"

beginning of an wakeup header

#define WUTextHeaderLength 4

length of the header

Typedef Documentation

typedef UInt8 PhnSMSClass

SMS Class types

typedef UInt8 PhnSMSType

SMS Replacement types

Enumeration Type Documentation

enum PhnDataChannelType

Enumerator:
phnDataNotAvailable Used by apps that need to know when they can use the data channel

enum PhnEventCode

PhnEventCode is unique identifier for notifications between the Phone Library and applications. It is used in the eventType field in the header of notification events (PhnEventType).

Enumerator:
phnEvtCardInsertion | 0x0000 < NOT USED. OBSOLETE
phnEvtRegistration Network Registration has changed.

The Phone Library is responsible for registering the device to the carrier network, including handling roaming and losses of service. This notification occurs when the network registration state has changed. See PhnRegistrationStatus for possible state values.

This notification will be universally broadcast to applications registered for any service. 0x0001 < Phone able to find service

phnEvtError Error detected

This notification occurs on various error scenarios in the Phone Library. These may occur when unexpected errors are reported from the radio, or when an operation in progress has failed.

This notification is universally broadcast to applications in the service area where the error was detected (e.g. Voice, SMS, ...). 0x0002 < indicator of something important happens to the phone that needs to bring up alert

phnEvtKeyPress phone-related keypress has occured on device

This notification occurs when the user presses a phone-related key on the device. Currently the only supported key is the headset button that can be used for basic call control. In general, buttons available will be device dependent.

This notification is exclusively broadcast to all applications registered for the Voice Service. 0x0003 < Headset button pressed.

phnEvtPower change in power state of radio

This notification occurs when the power state of the radio is changing. Applications may want to change their state, and take action based on the expected availability of the radio.

This notification is universally broadcast to all registered applications. 0x0004

phnEvtPassword Password Dialog Control

This notification helps an application control the entry of a PIN on a device that is locked.

This notification is exclusively broadcast to all registered applications. Application that acknowledges the notification is presumed to own handling the password situation. 0x0005

phnEvtProgress outgoing call progress dialog

This notification is sent to help applications display the progress of an oubound call operation.

This notification is exclusively broadcast to all registered applications. Application that acknowledges the notification is presumed to be the only one to take any action on the outgoing call. 0x0006

phnEvtIndication indication of various changes of state in Phone Library

This notification is sent on various changes of state in the Phone Library. Most of these are related to activation and registration with the carrier network. Applications that display gauges with state info will often need to be updated after this notification.

Indications are often used to direct GUI interactions in applications that interact with the user. For example, the Network Search notification might cause an app to put up a special Network Search dialog.

See PhnIndicationKind for list of available indications.

The broadcast rules for indications vary depending on the type of indication. 0x0007

phnEvtConnectInd incoming call received

This notification is exclusively broadcast to applications registered for the Voice Service. First application to acknowledge the notification will be presumed to control the call. Normally application would answer the call, or forward it to another destination. 0x0008

phnEvtConnectConf call has connected

Despite the name, this event is used BOTH when a call goes into connected state (e.g. is answered), and when a call joins a conference.

This notification is exclusively broadcast to applications registered for the Voice Service. First application to acknowledge the notification will be presumed to control the call or conference. 0x0009

phnEvtSubscriber Number/name of call has changed

This notification is universally broadcast to all applications registered for the Voice Service. 0x000A

phnEvtDisconnectInd call has disconnected

This notification occurs when the remote party of an active voice call disconnects. Note that if the call is in conference (or 3-way calling) mode, then a different phnEvtDisconnectConf notification will be sent instead (see below).

This notification is universally broadcast to all applications registered for the Voice or Data Services. 0x000B

phnEvtDisconnectConf call in conference (or 3-way calling) mode has disconnected

This notification occurs when a conference call is in progress, and one of the remote parties disconnects.

This notification is universally broadcast to all applications registered for the Voice Service. 0x000C An ACK for a disconnection command on a specific connection ID is received

phnEvtBusy Outbound call attempt failed because remote party (or network) reported busy

This notification is universally broadcast to all applications registered for the Voice Service. 0x000D

phnEvtUpdate Change in Call Status; Application may need to update its state

This notification is sent on various changes in call state in the Phone Library. An application receiving this notification should poll for the connection status of any calls of interest, and update its own state as needed.

This notification is universally broadcast to all applications registered for the Voice Service. 0x000E

phnEvtConference 3-way call mode

This notification occurs when a call goes into conferrence (or 3-way calling) mode.

This notification is universally broadcast to all applications registered for the Voice Service. 0x000F

phnEvtVoiceMail Incoming VoiceMail Message

This notification occurs when the Phone Library detects that there are pending VoiceMail messages available.

This notification is universally broadcast to all applications registered for the Voice Service. 0x0010

phnEvtMessageInd Incoming SMS message received

This notification occurs when the Phone Library receives an incoming SMS (Simple Message Service) message.

This notification will be exclusively broadcast to applications registered for the SMS service. The Application that acknowledges the notification is assumed to own the message, and should take any appropriate actions. 0x0011

phnEvtSegmentInd Incoming segment of SMS Message received

This notification occurs when the Phone Library receives a segment of a multi-segment SMS (Simple Message Service) message. Single segment SMS messages will generate a MessageInd notification (see above).

This notification will be exclusively broadcast to applications registered for the SMS service. The Application that acknowledges the notification is assumed to own the segment, and should take any appropriate actions. 0x0012

phnEvtMessageStat Status of outgoing SMS message has changed

This notification occurs when the status of a particular SMS message has changed. For example, an SMS message might move from the pending queue to the sent queue after being successfully delivered.

This notification will be sent directly to the application that created the message, and is NOT broadcast based on app registrations. 0x0013

phnEvtMessageDel SMS message deleted from local DB on device

This notification occurs when an SMS message is deleted from the local Database on the device.

This notification will be sent directly to the application that created the message, and is NOT broadcast based on app registrations. 0x0014

phnEvtMessageMoved SIM Contains SMS Messages

This notification indicates that the SIM (Subscriber Information Module) on a GSM phone contains SMS (Simple Messaging Service) messages. This is not an indication of new messages, just that messages are stored. This notification is typically sent during Phone Library activation. In many cases, the application may want to move the SMS messages to a local DB on the device, freeing memory for future incoming messages.

This notification will use exclusive broadcast to applications registered for the SMS service. The application that acknowledges the notification is responsible for taking any action on moving the SMS messages on the SIM (if desired). 0x0015

phnEvtSATNotification SIM Application Toolkit (SAT) event

The SIM Application Toolkit allows for simple applications that can be placed on the SIM (Subscriber Identity Module) in a GSM phone. This notification will be sent when a SAT application is requesting input/output to/from the user.

This notification will use exclusive broadcast to applications registered for the SIM Toolkit Service. The Application that first acknowedges the notification will be presumed to own the SAT session, and should handle needed user dialog as appropriate. 0x0016

phnEvtUSSDInd USSD input/output requested from network

USSD (Unstructured Supplementary Services Data) is a supplementary service to GSM networks that allows simple text dialogs with applications based in the network. This notification is sent when the network is requesting USSD input/output to/from the user. (see +CUSD event in radio documentation for more details)

This notification will use exclusive broadcast to applications registered for the Voice Service. The Application that first acknowledges the notification will be presumed to own the USSD session. Typically, that app will want to display any USSD message to the user, and handle any response from the user back to the network. 0x0017

phnEvtPhoneEquipmentMode Phone Equipment state has changed

On communicator devices there are pieces of equipment that directly impact how the radio is used. Examples of equipment include headset jacks, car kits, lids, etc. The equipment modes available will vary with the model of communicator being used. This notification will be sent when ever the Phone Library detects that an available equipment mode has changed. See the type PhnEquipmentMode for the available set of mode values.

This notification will be universally broadcast to all applications registered for any service. 0x0018

phnEvtGPRSRegistration GPRS Attach Registration has changed. (GSM/GPRS systems only)

GPRS (General Packet Radio Services) is an extension to the GSM wireless network that provides higher speed, always on data connections. The radio must attach to the GPRS network before any GPRS sessions can be established. This notification will be sent when ever the status of the GPRS attach registration changes. See type PhnRegistrationStatus for available registration states.

This notification will be universally broadcast to applications registered for any service. 0x0019

phnEvtMMSInd incoming MMS message available

This notification will be sent when the Phone Library receives an incoming MMS (Multi-media Message Service) message.

This notification will use exclusive broadcast to applications registered for the MMS service. Application that first acknowledges the notification will be presumed to own the message. Typically, that app will want to notify the user that there is a message available, and move the message into a system DB, freeing memory for future messages. 0x001A

phnEvtMemoryFull SMS Memory Full

This notification indicates that memory for SMS messages is currently full, and no new SMS messages can be received until some memory is freed. A phnEvtMemoryOK notification will be sent when memory becomes available.

CURRENTLY USED BY CDMA PHONE LIBRARY ONLY 0x001B

phnEvtMemoryOK SMS Memory no longer full

This notification indicates that memory for SMS messages is no longer full, and new SMS messages can be received.

CURRENTLY USED BY CDMA PHONE LIBRARY ONLY 0x001C - < Memory is not full anymore, can receive messages Description

phnEvtWAPInd WAP Message received via SMS (WAP in IS-637 standard)

NOT CURRENTLY USED (WAP notifications use standard Palm notifications) 0x001D

phnEvtDebugReport Radio Debug Info

Periodically sent from Phone Library to Activation App when in debug mode.

CURRENTLY USED BY CDMA PHONE LIBRARY ONLY 0x001E

phnEvtSSModeChanged System Selection mode has changed

Radio mode has changed (e.g. to PCS mode)

CURRENTLY USED BY CDMA PHONE LIBRARY ONLY 0x001F

phnEvtPDDataChanged Position Info has changed

indication of change in physical location of device. This may be determined by GPS, network triangulation (AFLT), or some other technique.

- rename this event & some of its data structures to be cleaner.

CURRENTLY USED BY CDMA PHONE LIBRARY ONLY 0x0020

phnEvtOneXStatus 1XRTT Status has changed

1XRTT is a high speed data protocol used in CDMA radios. This notification indicates that the status of the 1XRTT connection has changed.

CURRENTLY USED BY CDMA PHONE LIBRARY ONLY 0x0021

phnEvtMIPFailed Mobile IP connection failed

Mobile IP is a flavor of the TCP/IP protocol for use on mobile devices. It allows applications to use a single IP address while in motion. This notification occurs when a Mobile IP session fails to be established.

CURRENTLY USED BY CDMA PHONE LIBRARY ONLY 0x0022

phnEvtIOTAStatus IOTA Status has changed

Internet Over The Air (IOTA) is a protocol for a network to update the radio using an internet connection (as opposed to Over The Air (OTA)). This notification occurs as an IOTA session changes (e.g. is established, committed, ended, etc).

CURRENTLY GENERATED BY CDMA PHONE LIBRARY ONLY 0x0023

phnEvtDataChannel Data Channel availability has changed

This notification occurs if there is a change in the ability for an application to send/receive data using the radio. For example on Class B radios, data is not available when a voice call is in progress.

- this notification should be generated by GSM Phone Library too.

CURRENTLY GENERATED BY CDMA PHONE LIBRARY ONLY 0x0024

phnEvtOneXMipRRQInd Mobile IP Registration successful

Mobile IP is a flavor of the TCP/IP protocol for use on mobile devices. It allows applications to use a single IP address while in motion. This notification occurs when a Mobile IP session is successfully established. The notification phnEvtMIPFailed will occur if the session fails.

CURRENTLY GENERATED BY CDMA PHONE LIBRARY ONLY 0x0025

phnEvtOneXDataFail 1XRTT Session has failed (mid-session)

1XRTT is a high speed data protocol used in CDMA radios. This notification indicates that the 1XRTT session has failed, and is not available. Note that 1XRTT session may be left in Dormant state.

CURRENTLY GENERATED BY CDMA PHONE LIBRARY ONLY 0x0026

phnEvtStartDial Start Dialing of Outbound Call

This notification is sent when an outbound call begins dialing before the call is connected. This notification is universally broadcast to all applications registered for the Voice service. Notification uses same notification data as Connect indication. 0x0027

phnEvtStartIncomingCall Start of incoming call

This notification is sent when an incoming call if first detected. This notification is used to perform special pre-call processing like turning off of MMS playback before a call. Any processing on this notification must be very quick (less than a few hundred miliseconds) as it could potentially delay an incoming call from being answered.

APPLICATIONS MUST NOT ANSWER THE CALL OR DO ANY CALL CONTROL BASED ON THIS NOTIFICATION. A separate phnEvtConnectInd notification will be follow for this purpose. The phnEvtConnectInd notification is normally processed by the Phone App, and uses exclusive broadcast. Thus it may not be received by all applications. The phnEvtStartIncomingCall notification is sent to all applications registered for Voice Service using Universal Broadcast. The acknowledgement flag is NOT used. 0x0028

phnEvtAlertingPreConnected Alerting/Preconnected of Outbound Call

This notification is sent when an outbound call is alerting or preconnected. This notification is universally broadcast to all applications registered for the Voice service. Notification uses same notification data as Connect indication. 0x0029

phnEvtAlerting Alerting of Outbound Call (NOT USED, for future implementation)

NOT USED This notification is sent when an outbound call is alerting. This notification is universally broadcast to all applications registered for the Voice service. Notification uses same notification data as Connect indication. 0x002A

phnEvtPreConnected Preconnected of Outbound Call (NOT USED, for future implementation)

NOT USED This notification is sent when an outbound call is preconnected. This notification is universally broadcast to all applications registered for the Voice service. Notification uses same notification data as Connect indication. 0x002B

phnEvtDataSessionStatus | Data session status change This should replace the OneXStatus, as this will encompass more info than OneXStatus 0x002C
phnEvtDataSessionDisconnected | Data session disconnected This is sent up when the data call is disconnected. We can't use the phnEvtDisconnectInd because the structure uses the Err class. 0x002D
phnEvtNetworkTime | Returns the network time and DST obtained from network to date time panel 0x002E
kMaxPhnEvtSupported | Must be at last position

enum PhnIndicationKind

unique identifier for Indication notification. This value will be contained in PhnEventType notification events of phnEvtIndication type.

Enumerator:
indicationNetworkSearch | to display Network search banner
indicationStartingRadio | to update UI from radio being off
indicationPoweringOffRadio | notify app that the radio is turning off.
indicationResettingRadio | tell the app that the radio is resetting.
indicationAuthFailure | notify app that network authentication failed.
indicationSIMChanged | sent when the GSM library detects that the IMSI value has changed
indicationInitComplete | sent when the GSM library is done with it initialization when the radio is powered on
indicationOtaspMsg | sent otasp msg from network

enum PhnModuleButtonType

Phone buttons

enum PhnSMSClassEnum

Enumerator:
class0 immediate display

enum PhnSMSTypeEnum

Enumerator:
discardType0 | Type 0 messages should be discarded.
replaceType1 | Replace Short Message Type 1.
replaceType2 | Replace Short Message Type 2.
replaceType3 | Replace Short Message Type 3.
replaceType4 | Replace Short Message Type 4.
replaceType5 | Replace Short Message Type 5.
replaceType6 | Replace Short Message Type 6.
replaceType7 | Replace Short Message Type 7.

enum PhnWAPPushAppIdType

WAP push message - message type http://www.wapforum.org/wina/push-app-id.htm

Enumerator:
kWAPAnyApp | Any Application
kWAPPushSIA | WAP Push SIA
kWAPWmlUa | WML User Agent
kWAPWtaUa | WTA User Agent
kWAPMmsUa | This ID will used for application dispatching to MMS User Agent in the handling of MMS notfication using WAP Push. See WAP-206-MMSCTR for more detail.
kWAPPushSyncml | SyncML PUSH Application ID: used to push a SyncML Alert from a SyncML server side. The SyncML Alert is an indication for starting a SyncML session e.g., for data synchronization. Requested by the WAP WAG Synchronisation Drafting Committee.
kWAPLocUa | This ID is used for application dispatching to Location User Agent in the handling of Location Invocation document. See WAP-257-LOCPROT for details. Requested by the WAP WAG Location Drafting Committee.
kWAPSyncmlDm | This ID is used for SyncML Device Management. Requested by the SyncML Device Management Expert Group.
kWAPDrmUa | This ID is used for DRM User Agent. Requested by the WAP WAG Download DC.
kWAPEmnUa | This ID is used for Email Notification (EMN) User Agent. Requested by the WAP WAG PUSH DC.
kWAPWvUa | This ID is used for Wireless Village (EMN) User Agent. Requested by Wireless Village.
kWAPMsLocalcontentUa | An application to receive pages to be stored and access locally. These are not wta channels. Usually the pages will be downloaded as multi-part mime.
kWAPMsIMclientUa | An application which will act as an instant messaging client on a phone.
kWAPdocomoImodeMailUa | Used to identify the i-mode mail application user agent on a mobile device.
kWAPdocomoImodeMrUa | Used to identify the i-mode message request application user agent on a mobile device.
kWAPdocomoImodeMfUa | Used to identify the i-mode message free application user agent on a mobile device.
kWAPMotorolaLocationUa | An application that receives message notifications from the location server.
kWAPMotorolaNowUa | An application that presents personalized information to the user.
kWAPMotorolaOtaprovUa | An application that receives provisioning messages from the server.
kWAPMotorolaBrowserUa | A web browsing application.
kWAPMotorolaSplashUa | An application that receives splash screen content from the server.
kWAPNaiMvswCommand | Used by administrators to issue commands to individual devices.
kWAPopenwaveIotaUa | Used for application dispatching to the IP-based OTA Provisioning Service Agent in the handling of IOTA notfications using WAP Push.

enum PhnWAPPushContentType

WAP push message - message content type

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:38 2006 for Palm API Guide


HsPhoneGSM.h File Reference

Detailed Description

Header File for Phone Library API ---- GSM CATEGORY.

Notes: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the SMS category. These API calls are used for features that only apply to GSM networks.

Include dependency graph for HsPhoneGSM.h:

Functions

  • Err PhnLibSetActiveLine (UInt16 refNum, Int16 line)
    Sets the active line number.
  • Err PhnLibGetFDNList (UInt16 refNum, PhnAddressList *aList, PhnPhoneBookInfoPtr info)
    Retrieve the Fixed Dialing Numbers from the SIM.
  • Err PhnLibSetFDNEntry (UInt16 refnum, UInt16 index, char *name, char *number)
    Set entry in the Fix Dialing field on the SIM.
  • Err PhnLibGetPhoneBook (UInt16 refNum, PhnAddressList *numbers, PhnPhoneBookInfoPtr info)
    This routine reads the PhoneBook of phone numbers from your SIM (GSM only). This command can take several seconds if the PhoneBook is large.
  • Err PhnLibSetPhoneBook (UInt16 refnum, PhnAddressList numbers)
    This routine writes the PhoneBook of phone numbers from your SIM (GSM only). This command can take several seconds if the PhoneBook is large.
  • Err PhnLibSetPhoneBookEntry (UInt16 refnum, UInt16 index, char *name, char *number)
    Set entry in SIM Phone Book.
  • UInt32 PhnLibGetPhoneBookIndex (UInt16, PhnAddressHandle address)
    This routine gets the index of the given PhoneBook address on your SIM (GSM only).
  • Err PhnLibGetSDNList (UInt16 refNum, PhnAddressList *aList, PhnPhoneBookInfoPtr info)
  • Err PhnLibSendUSSD (UInt16 refNum, CharPtr cmd)
    Send USSD value to radio.
  • Err PhnLibSATGetMainMenu (UInt16 refNum, MemHandle *menuHandlePtr)
    Retrieve SAT main menu.
  • Err PhnLibSATSendRequest (UInt16 refNum, SATRequestType request, SATDecisionType decision, UInt32 data, UInt32 length)
    Send application’s request to firmware.
  • Err PhnLibSATEndSession (UInt16 refNum)
    Terminate an active SAT session.
  • Boolean PhnLibSIMInfo (UInt16 refNum, CharPtr *imsi)
    This routine reads the IMSI number from the SIM (Subscriber Information Module) on your GSM device. IMSI stands for International Mobile Subscriber Identify, and is used to uniquely identify a user to the wireless network.
  • GSMSIMStatus PhnLibGetSIMStatus (UInt16 refNum)
    This routine returns status of the SIM (Subscriber Information Module) on your GSM device. The SIM is managed by the radio module on the handset. The SIM must be present and active before the radio is allowed to make phone calls (other than emergency calls). The SIM also stores various user information and settings.
  • Boolean PhnLibGPRSAttached (UInt16 refNum)
    Check if we are currently attached to the GPRS Network.
  • Err PhnLibGPRSPDPContextDefine (UInt16 refNum, UInt16 contextId, PhnGPRSPDPType pdpType, const char *apn, UInt16 apnLen, const char *pdpAddr, UInt16 pdpAddrLen, UInt16 pdpDataCompression, UInt16 pdpHdrCompression)
    This function will store the given settings as a profile in the radios flash memory. The profile id will be the same as the context id that you pass with valid values between 1 and 32.
  • Err PhnLibGPRSPDPContextListConstruct (UInt16 refNum, struct PhnGPRSPDPContextListNodeType **listHeadPP)
    Get a linked list of pdp contexts currently stored on the device. It is necessary to call the Destruct after use of the list to free the memory.
  • Err PhnLibGPRSPDPContextListDestruct (UInt16 refNum, struct PhnGPRSPDPContextListNodeType **headNodePP)
    Function that cleans up the list of pdp contexts created by the construct functions.
  • Err PhnLibGPRSQualityOfServiceGet (UInt16 refNum, PhnGPRSQOSType qosType, UInt16 contextId, UInt16 *precedence, UInt16 *delay, UInt16 *reliability, UInt16 *peakThroughput, UInt16 *meanThroughput)
    Set either the Required or Minimum QOS service parameters. If 0 is passed for the parameter, the network will decide the settings. Valid settings are listed below.
  • Err PhnLibGPRSQualityOfServiceSet (UInt16 refNum, PhnGPRSQOSType qosType, UInt16 contextId, UInt16 precedence, UInt16 delay, UInt16 reliability, UInt16 peakThroughput, UInt16 meanThroughput)
    Set either the Required or Minimum QOS service parameters. If 0 is passed for the parameter, the network will decide the settings. Valid settings are listed below.
  • Err PhnLibSendLongDTMF (UInt refNum, Char digit, PhnAudioSendMode sendMode, Boolean on)
  • Err PhnLibGetICCID (UInt refNum, CharPtr *iccid)
  • Err PhnLibGetSpn (UInt refNum, CharPtr *spn)

Function Documentation

Err PhnLibGetFDNList | ( | UInt16 | refNum,
 |  | PhnAddressList * | aList,
 |  | PhnPhoneBookInfoPtr | info
 | ) |

Retrieve the Fixed Dialing Numbers from the SIM.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
aList,: IN: Returned with the list of numbers
info,: IN:
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibGetICCID | ( | UInt | refNum,
 |  | CharPtr * | iccid
 | ) |

Parameters:
refNum,: IN:
iccid,: IN:
Return values:
Err Error code.

Err PhnLibGetPhoneBook | ( | UInt16 | refNum,
 |  | PhnAddressList * | numbers,
 |  | PhnPhoneBookInfoPtr | info
 | ) |

This routine reads the PhoneBook of phone numbers from your SIM (GSM only). This command can take several seconds if the PhoneBook is large.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
numbers,: IN:
info,: IN:
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

UInt32 PhnLibGetPhoneBookIndex | ( | UInt16 | ,
 |  | PhnAddressHandle | address
 | ) |

This routine gets the index of the given PhoneBook address on your SIM (GSM only).

Parameters:
unused,: IN: for the future, set to 0.
address,:
Return values:
Index number.

Err PhnLibGetSDNList | ( | UInt16 | refNum,
 |  | PhnAddressList * | aList,
 |  | PhnPhoneBookInfoPtr | info
 | ) |

Parameters:
refNum,: IN:
aList,: IN:
info,: IN:
Return values:
Err Error code.

GSMSIMStatus PhnLibGetSIMStatus ( UInt16 refNum )

This routine returns status of the SIM (Subscriber Information Module) on your GSM device. The SIM is managed by the radio module on the handset. The SIM must be present and active before the radio is allowed to make phone calls (other than emergency calls). The SIM also stores various user information and settings.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
Return values:
Sim Status

Err PhnLibGetSpn | ( | UInt | refNum,
 |  | CharPtr * | spn
 | ) |

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad
spn,: IN: Service Provider Name from SIM
Return values:
Err Error code.

Boolean PhnLibGPRSAttached ( UInt16 refNum )

Check if we are currently attached to the GPRS Network.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
Return values:
True if we are attached

Err PhnLibGPRSPDPContextDefine | ( | UInt16 | refNum,
 |  | UInt16 | contextId,
 |  | PhnGPRSPDPType | pdpType,
 |  | const char * | apn,
 |  | UInt16 | apnLen,
 |  | const char * | pdpAddr,
 |  | UInt16 | pdpAddrLen,
 |  | UInt16 | pdpDataCompression,
 |  | UInt16 | pdpHdrCompression
 | ) |

This function will store the given settings as a profile in the radios flash memory. The profile id will be the same as the context id that you pass with valid values between 1 and 32.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
contextId,: IN:
pdpType,: IN:
*apn,: IN:
apnLen,: IN:
*pdpAddr,: IN:
pdpAddrLen,: IN:
pdpDataCompression,: IN:
pdpHdrCompression,: IN:
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibGPRSPDPContextListConstruct | ( | UInt16 | refNum,
 |  | struct PhnGPRSPDPContextListNodeType ** | listHeadPP
 | ) |

Get a linked list of pdp contexts currently stored on the device. It is necessary to call the Destruct after use of the list to free the memory.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
listHeadPP,: IN: Pointer to a pointer where the head of the linked list will be stored.
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibGPRSPDPContextListDestruct | ( | UInt16 | refNum,
 |  | struct PhnGPRSPDPContextListNodeType ** | headNodePP
 | ) |

Function that cleans up the list of pdp contexts created by the construct functions.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
headNodePP,: IN: Pointer to a pointer to the head of the list.
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibGPRSQualityOfServiceGet | ( | UInt16 | refNum,
 |  | PhnGPRSQOSType | qosType,
 |  | UInt16 | contextId,
 |  | UInt16 * | precedence,
 |  | UInt16 * | delay,
 |  | UInt16 * | reliability,
 |  | UInt16 * | peakThroughput,
 |  | UInt16 * | meanThroughput
 | ) |

Set either the Required or Minimum QOS service parameters. If 0 is passed for the parameter, the network will decide the settings. Valid settings are listed below.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
qosType,: IN: Required or Minimum.
contextId,: IN: id of the profile that you are setting with these QOS Values.
precedence,: IN: (1-3) 1 being highest priority
delay,: IN: (1-3) Predictive 4 - Best Effort
reliability,: IN: (1-5) - Unknown
peakThroughput,: IN: (1-9) 1 is the lowest and 9 the highest
meanThroughput,: IN: (1-9) 1 is the lowest and 9 the highest
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibGPRSQualityOfServiceSet | ( | UInt16 | refNum,
 |  | PhnGPRSQOSType | qosType,
 |  | UInt16 | contextId,
 |  | UInt16 | precedence,
 |  | UInt16 | delay,
 |  | UInt16 | reliability,
 |  | UInt16 | peakThroughput,
 |  | UInt16 | meanThroughput
 | ) |

Set either the Required or Minimum QOS service parameters. If 0 is passed for the parameter, the network will decide the settings. Valid settings are listed below.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
qosType,: IN: Required or Minimum.
contextId,: IN: id of the profile that you are setting with these QOS Values.
precedence,: IN: (1-3) 1 being highest priority
delay,: IN: (1-3) Predictive 4 - Best Effort
reliability,: IN: (1-5) - Unknown
peakThroughput,: IN: (1-9) 1 is the lowest and 9 the highest
meanThroughput,: IN: (1-9) 1 is the lowest and 9 the highest
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibSATEndSession ( UInt16 refNum )

Terminate an active SAT session.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
Return values:
0 if succeeded or an error from PhnLibSATSendRequest() session

Err PhnLibSATGetMainMenu | ( | UInt16 | refNum,
 |  | MemHandle * | menuHandlePtr
 | ) |

Retrieve SAT main menu.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
menuHandlePtr,: IN: Pointer to a GSMSATEventMenuPtr.
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.” And the pointer is filled with a pointer to a main menu or phnErrSATUnavailable if there is no active session.

Err PhnLibSATSendRequest | ( | UInt16 | refNum,
 |  | SATRequestType | request,
 |  | SATDecisionType | decision,
 |  | UInt32 | data,
 |  | UInt32 | length
 | ) |

Send application’s request to firmware.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
request,: IN: Request type
decision,: IN: Decision Type
data,: IN: Data to send
length,: IN: Length of data to send (only for Input)
Return values:
0 if succeed phnErrIllegalCondition:unrecognized parameters or an unneeded param is not zero. phnErrSATUnavailable:SAT is not available phnErrSATInactive : no active SAT session; must call PhnLibSATGetMainMenu() before calling this function().

Err PhnLibSendLongDTMF | ( | UInt | refNum,
 |  | Char | digit,
 |  | PhnAudioSendMode | sendMode,
 |  | Boolean | on
 | ) |

Parameters:
refNum,: IN:
digit,: IN:
sendMode,: IN:
on,: IN:
Return values:
Err Error code.

Err PhnLibSendUSSD | ( | UInt16 | refNum,
 |  | CharPtr | cmd
 | ) |

Send USSD value to radio.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
cmd,: IN: USSD value to be sent
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibSetActiveLine | ( | UInt16 | refNum,
 |  | Int16 | line
 | ) |

Sets the active line number.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
line,: IN: Line number to be set to active.
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibSetFDNEntry | ( | UInt16 | refnum,
 |  | UInt16 | index,
 |  | char * | name,
 |  | char * | number
 | ) |

Set entry in the Fix Dialing field on the SIM.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
index,: IN: index into SIM
name,: IN: name value for SIM entry
number,: IN: phone number for SIM entry
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibSetPhoneBook | ( | UInt16 | refnum,
 |  | PhnAddressList | numbers
 | ) |

This routine writes the PhoneBook of phone numbers from your SIM (GSM only). This command can take several seconds if the PhoneBook is large.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
numbers,: IN:
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibSetPhoneBookEntry | ( | UInt16 | refnum,
 |  | UInt16 | index,
 |  | char * | name,
 |  | char * | number
 | ) |

Set entry in SIM Phone Book.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
index,: IN: index into SIM Phone Book
name,: IN: name value for SIM Phone Book entry
number,: IN: phone number for SIM Phone Book entry
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Boolean PhnLibSIMInfo | ( | UInt16 | refNum,
 |  | CharPtr * | imsi
 | ) |

This routine reads the IMSI number from the SIM (Subscriber Information Module) on your GSM device. IMSI stands for International Mobile Subscriber Identify, and is used to uniquely identify a user to the wireless network.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
imsi,: IN: imsi number is a string pointer.
Return values:
Boolean

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:39 2006 for Palm API Guide


HsPhoneGSMTypes.h File Reference

Detailed Description

Header File for Phone Library API ---- NETWORK CATEGORY.

NOTES: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the GSM category. These API calls are used to interact with the wireless network.

Include dependency graph for HsPhoneGSMTypes.h:

Data Structures

  • struct PhnPhoneBookInfoType
  • struct PhnGPRSPDPContextType
  • struct PhnGPRSPDPContextListNodeType
  • #define GSMLockSelectorOperatorLock ('PN')
  • #define GSMLockSelectorProviderLock ('PP')
  • #define phnNetPrefGPRSPDPContextID 1
  • #define GSMLibRingsDbName "System Ring Tones"
  • #define kLineNumberUnknown 0

Special response values for PhnSATEventGetInkey (besides a single character)

  • #define phnSATInkeyResponseValueYes ((UInt32)'YES_')
  • #define phnSATInkeyResponseValueNo ((UInt32)'NO__')

Defines

  • #define isValidSATNotificationType(s)
  • #define isValidPhnGPRSPDPType(t) ((t >= phnGPRSPDPTypeIP) && (t <= phnGPRSPDPTypePPP))
  • #define isValidPhnGPRSQOSType(t) ((t >= kGPRSQOSTypeRequired) && (t <= kGPRSQOSTypeMinimum))
  • #define isValidGSMSIMMessagesDialogKind(d) ((d >= gsmMessagesConfirmMove) && (d <= gsmMessagesCantReceive))
  • #define isValidGSMSATEventToneTypeEnum(x) (((x >= phnSATEventToneTypeDial) && (x <= phnSATEventToneTypeNegativeBeep)) || (x == phnSATEventToneTypeNoneSpecified))
  • #define isValidGSMSATEventSetupCallCallTypeEnum(x) ((x >= phnSATEventSetupCallCallTypeVoice) && (x <= phnSATEventSetupCallCallTypeFax))

Typedefs

  • typedef struct PhnPhoneBookInfoType * PhnPhoneBookInfoPtr
  • typedef UInt8 SATRequestType
  • typedef UInt8 SATDecisionType
  • typedef UInt8 SATNotificationType
  • typedef UInt16 SATSetupCallType
  • typedef UInt32 SATRefreshFile
  • typedef UInt16 SATRefreshType
  • typedef UInt8 PhnGPRSPDPType
  • typedef UInt8 PhnGPRSQOSType
  • typedef UInt8 GSMSIMMessagesDialogKind
  • typedef UInt8 GSMSATEventMenuFlag
  • typedef UInt8 GSMSATEventInputFormatEnum
  • typedef UInt8 GSMATEventInputEchoModeEnum
  • typedef UInt8 GSMSATEventToneTimeUnitEnum
  • typedef UInt16 GSMSATEventToneTypeEnum
  • typedef UInt8 GSMSATEventSetupCallCallTypeEnum
  • typedef UInt8 GSMSATDataSvcType

Enumerations

  • enum _SATRequestType {
    kSATSelectMainMenuItem,
    kSATClearText,
    kSATSetInkey,
    kSATSetInput,
    kSATMakeCall,
    kSATSelectItem = 6,
    kSATReqLaunchBrowser,
    kSATReqIdleModeText,
    kSATReqDataSrv,
    kSATReqPlayTone,
    kSATReqRefresh,
    kSATCancel = 95,
    kSATUnknownNotification,
    kSATApplicationBusy,
    kSATUserNotResponse,
    kSATEndSession,
    kSATReqSendDTMF
    }
  • enum _SATDecisionType {
    kSATSessionAborted,
    kSATItemSelected,
    kSATHelpRequested,
    kSATNavigateBack
    }
  • enum _SATNotificationType {
    kSATMainMenuAvailable,
    kSATDisplayText,
    kSATGetInkey,
    kSATGetInput,
    kSATSetupCall,
    kSATPlayTone,
    kSATDisplaySubmenus,
    kSATRefresh,
    kSATSendSS,
    kSATSendSMS,
    kSATSendUSSD,
    kSATLaunchBrowser,
    kSATIdleModeText,
    kSATRunAT,
    kSATDataSvc,
    kSATSendDTMF,
    kSATTimeout = 98,
    kSATSessionEnd = 99
    }
  • enum _SATSetupCallType {
    kSATSetupCallModeNotBusy,
    kSATSetupCallWithRedialModeNotBusy,
    kSATSetupCallHoldOtherCalls,
    kSATSetupCallWithRedialHoldOtherCalls,
    kSATSetupCallDisconnectOtherCalls,
    kSATSetupCallWithRedialDisconnectOtherCalls,
    kSATSetupCallMax
    }
  • enum _SATRefreshFile { kSATEFSimPhoneBook = 0x00000001 }
  • enum _SATRefreshType {
    kSATInitWithFullFileChange,
    kSATFileChange,
    kSATInitWithFileChange,
    kSATInit,
    kSATSIMReset,
    kSATMax
    }
  • enum _PhnGPRSPDPType {
    phnGPRSPDPTypeIP = 1,
    phnGPRSPDPTypePPP = 2
    }
  • enum _PhnGPRSQOSType {
    kGPRSQOSTypeRequired = 1,
    kGPRSQOSTypeMinimum = 2
    }
  • enum _GSMSIMMessagesDialogKind {
    gsmMessagesConfirmMove,
    gsmMessagesCantReceive
    }
  • enum _GSMSATEventMenuFlag {
    phnSATEventMenuFlagHelp = 1,
    phnSATEventMenuFlagNextAct = 2
    }
  • enum _GSMSATEventInputFormatEnum {
    phnSATEventInputFormatDigit = 0,
    phnSATEventInputFormatSMSChar = 1,
    phnSATEventInputFormatUCS2 = 2,
    phnSATEventInputFormatUnpacked = 3,
    phnSATEventInputFormatPacked = 4,
    phnSATEventInputFormatYesNo = 5,
    phnSATEventInputFormatUnknown = 255
    }
  • enum _GSMATEventInputEchoModeEnum {
    phnSATEventInputEchoModeShowInput = 0,
    phnSATEventInputEchoModeHideInput = 1
    }
  • enum _GSMSATEventToneTimeUnitEnum {
    phnSATEventToneTimeUnitMinutes = 0,
    phnSATEventToneTimeUnitSeconds = 1,
    phnSATEventToneTimeUnitDeciSeconds = 2
    }
  • enum _GSMSATEventToneTypeEnum {
    phnSATEventToneTypeNoneSpecified = 0xFFFF,
    phnSATEventToneTypeDial = 0,
    phnSATEventToneTypeBusy = 1,
    phnSATEventToneTypeCongestion = 2,
    phnSATEventToneTypeRadioAck = 3,
    phnSATEventToneTypeDropped = 4,
    phnSATEventToneTypeError = 5,
    phnSATEventToneTypeCallWaiting = 6,
    phnSATEventToneTypeRinging = 7,
    phnSATEventToneTypeGeneralBeep = 8,
    phnSATEventToneTypePositiveBeep = 9,
    phnSATEventToneTypeNegativeBeep = 10
    }
  • enum _GSMSATEventSetupCallCallTypeEnum {
    phnSATEventSetupCallCallTypeVoice = 0,
    phnSATEventSetupCallCallTypeData = 1,
    phnSATEventSetupCallCallTypeFax = 2
    }
  • enum _GSMSATDataSvcTypeEnum {
    phnSATEventDataSvcTypeOpenChannel = 1,
    phnSATEventDataSvcTypeSendData = 2,
    phnSATEventDataSvcTypeRcvData = 3,
    phnSATEventDataSvcTypeCloseChannel = 4
    }

Define Documentation

#define GSMLibRingsDbName "System Ring Tones"

Name of GSM RingTone DB

#define isValidSATNotificationType ( s )

Value:

(((s >= kSATMainMenuAvailable) && (s <= kSATSendUSSD)) \
              || (s == kSATTimeout) || (s == kSATSessionEnd))

Enumeration Type Documentation

enum _GSMATEventInputEchoModeEnum

Enumerator:
phnSATEventInputEchoModeShowInput | Show input as entered
phnSATEventInputEchoModeHideInput | Display bullets or boxes instead of entered characters

enum _GSMSATDataSvcTypeEnum

Possible values of serviceType for PhnSATEventDataSvc

enum _GSMSATEventInputFormatEnum

Possible values of format for PhnSATEventGetInkey and PhnSATEventGetInput

Enumerator:
phnSATEventInputFormatDigit | Get Inkey or Get Input 0-9, #, *, or +
phnSATEventInputFormatSMSChar | Get Inkey or Get Input SMS character set
phnSATEventInputFormatUCS2 | Get Inkey or Get Input
phnSATEventInputFormatUnpacked | Get Input only
phnSATEventInputFormatPacked | Get Input only
phnSATEventInputFormatYesNo | Get Inkey or Get Input
phnSATEventInputFormatUnknown | KEEP THIS ONE AT THE END

enum _GSMSATEventMenuFlag

Enumerator:
phnSATEventMenuFlagHelp | help is available
phnSATEventMenuFlagNextAct | nextAction is valid

enum _GSMSATEventSetupCallCallTypeEnum

Possible values of callType for PhnSATEventSetupCall

Enumerator:
phnSATEventSetupCallCallTypeVoice | SIM wants to set up a voice call
phnSATEventSetupCallCallTypeData | SIM wants to set up a data call
phnSATEventSetupCallCallTypeFax | SIM wants to set up a fax

enum _GSMSATEventToneTimeUnitEnum

Possible values of timeUnit for PhnSATEventPlayTone

Enumerator:
phnSATEventToneTimeUnitMinutes | Duration specified in minutes
phnSATEventToneTimeUnitSeconds | Duration specified in seconds
phnSATEventToneTimeUnitDeciSeconds | Duration specified in 1/10 seconds

enum _GSMSATEventToneTypeEnum

Possible values of toneType for PhnSATEventPlayTone

Enumerator:
phnSATEventToneTypeNoneSpecified Means just do a normal beep...

enum _SATDecisionType

decision we are sending to SIM

enum _SATNotificationType

type of notification sent by SAT

Enumerator:
kSATRefresh application do not get this notification

enum _SATRequestType

SIM Application Toolkit's data types type of request/respond we are sending

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:39 2006 for Palm API Guide


HsPhoneIOTA.h File Reference

Detailed Description

Header File for Phone Library API ---- IOTA CATEGORY.

Notes: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the IOTA category. These API calls are used for features specific to IOTA operation on CDMA networks.

Include dependency graph for HsPhoneIOTA.h:

Defines

  • #define isValidPhnIOTAStatus(i) ((i >= phnIOTAUnknown) && (i <= phnIOTANAMSelect))

Define Documentation

#define isValidPhnIOTAStatus ( i ) ((i >= phnIOTAUnknown) && (i <= phnIOTANAMSelect))

error codes returned by phone library functions No definition.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:40 2006 for Palm API Guide


HsPhoneIOTATypes.h File Reference

Detailed Description

Header File for Phone Library API ---- IOTA CATEGORY.

NOTES: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the IOTA category. These API calls are used for features specific to IOTA operation on CDMA networks.

Include dependency graph for HsPhoneIOTATypes.h:

Data Structures

  • struct PhnIOTAReportType
  • struct PhnIOTAPhnTlsRcUrlType
  • struct PhnIOTAPhnNAISIPEdgeProxyType
  • struct PhnIOTAPhnProxyAddrWdpType
  • struct PhnIOTAPhnNAISIPCfgSvr
  • struct PhnIOTAPhnNAIPPGType
  • struct PhnIOTAPhnNAIIMStore
  • struct PhnIOTAPhnNAISIPDataxchType
  • struct PhnIOTAPhnNAISIPDatagwyType
  • struct PhnIOTAPhnSIPRetryTimerType
  • struct PhnIOTAPhnSIPRetryCntType
  • struct PhnIOTAPhnDlsLockType
    Holds lock state of user's ability to change the download server URL address. More...
  • struct PhnIOTAPhnHomepagetype
  • struct PhnIOTAPhnTrustedDomainType
  • struct tagIOTANotificationEventType

Text Header elements

  • #define IOTAHeaderEscapeSeq "X-Wap-Application-Id: "
  • #define IOTATextHeader "X-Wap-Application-Id: x-wap-application:iota.ua"
  • #define IOTATextHeaderLength 47
  • #define IOTATextHeaderTerminator '\n'

Defines

  • #define phnIOTAEvent 'Hita'
  • #define isValidPhnIOTAItemType(i) ((i >= phnIOTAPhnBootNAIUrl) && (i <phnLibIOTAItemLast))
  • #define kIOTACertMaxBlocks 132
  • #define kIOTACertMaxBlockLen 127
  • #define kIOTAProxyADDRMaxLen 20
  • #define kIOTANaiSipEdgePxyMaxBlocks 4
  • #define kIOTAPxyAddrWdpMaxBlocks 4
  • #define kIOTAUrlMaxLen 128
  • #define kIOTAUrlArrayMaxLen 65
  • #define kIOTASipCfgBlocks 4
  • #define kIOTANaiPpgMaxBlocks 4
  • #define kIOTANaiIMStoreMaxBlocks 8
  • #define kIOTANaiSipDataxchMaxBlocks 8
  • #define kIOTANaiSipDdatgwyMaxBlocks 8
  • #define kIOTAPhnSipRetryTimerMaxLen 9
  • #define kIOTAPhnSipRetryTimerMaxBloacks 4
  • #define kIOTAPhnSipRetryCntMaxLen 9
  • #define kIOTAPhnSipRetryCntMaxBlocks 4
  • #define kIOTATrustedDomainMaxLen 64

Typedefs

  • typedef UInt8 PhnIOTAItemType
  • typedef tagIOTANotificationEventType IOTANotificationEventType

Enumerations

  • enum PhnIOTAStatus {
    phnIOTAUnknown = 0,
    phnIOTAStart,
    phnIOTAEnd,
    phnIOTACommit,
    phnIOTANAMSelect
    }
  • enum PhnIOTAItemEnum {
    phnIOTAItemBootURL = 0x00,
    phnIOTAItemBootNAIURL = 0x01,
    phnIOTAItemTrustedDomain = 0x02,
    phnIOTAItemHomepageURL = 0x03,
    phnIOTAItemVendingURL = 0x04,
    phnIOTAItemDownloadServerURL = 0x05,
    phnIOTAItemDownloadServerLock = 0x06,
    phnIOTAItemConnectionTimeout = 0x07,
    phnIOTAItemPriWAPPushProxyGatewayURL = 0x08,
    phnIOTAItemSecWAPPushProxyGatewayURL = 0x09,
    phnIOTAItemPriProxyWDPAddress = 0x0A,
    phnIOTAItemSecProxyWDPAddress = 0x0B,
    phnIOTAItemPriSIPConfigServer = 0x0C,
    phnIOTAItemSecSIPConfigServer = 0x0D,
    phnIOTAItemPriSIPEdgeProxyGateway = 0x0E,
    phnIOTAItemSecSIPEdgeProxyGateway = 0x0F,
    phnIOTAItemPriDataExchangeURL = 0x10,
    phnIOTAItemSecDataExchangeURL = 0x11,
    phnIOTAItemPriDataGatewayURL = 0x12,
    phnIOTAItemSecDataGatewayURL = 0x13,
    phnIOTAItemPriSIPRetryTimer = 0x14,
    phnIOTAItemSecSIPRetryTimer = 0x15,
    phnIOTAItemPriSIPRetryCount = 0x16,
    phnIOTAItemSecSIPRetryCount = 0x17,
    phnIOTAItemPriIMMessageStore = 0x18,
    phnIOTAItemSecIMMessageStore = 0x19,
    phnIOTAItemRootCertificate1 = 0x40,
    phnIOTAItemRootCertificate2 = 0x41,
    phnIOTAItemRootCertificate3 = 0x42,
    phnIOTAItemRootCertificate4 = 0x43,
    phnIOTAItemPRLStorageSize = 0x50,
    phnIOTAItemSIPUsername = 0x51,
    phnIOTAItemSIPPassword = 0x52,
    phnIOTAItemLastNVItem = 0x60,
    phnIOTAItemUnknown = 0xFF
    }

Define Documentation

#define IOTAHeaderEscapeSeq "X-Wap-Application-Id: "

start sequence of the header

#define IOTATextHeader "X-Wap-Application-Id: x-wap-application:iota.ua"

beginning of an IOTA header

#define IOTATextHeaderLength 47

length of the header

#define IOTATextHeaderTerminator '\n'

IOTA headers terminate at the line feed

#define kIOTACertMaxBlocks 132

Index should be < 12, starting from 0

Typedef Documentation

typedef struct tagIOTANotificationEventType IOTANotificationEventType

Structure passed to the callbacks registered for incoming IOTA notifications

typedef UInt8 PhnIOTAItemType

let's hope it never gets beyond 256 items

Enumeration Type Documentation

enum PhnIOTAItemEnum

Items stored in the radio NV (mostly for Sprint support). Some of these items may be used for other carriers in the future. Most of these items will be match the initial TIL implementation since we are focusing on Sprint support. We may be able to leverage the NVFlash support in the future and get away from the radio NV for most of these (unless we need UPST support).

Enumerator:
phnIOTAItemBootURL | provisioning URL
phnIOTAItemBootNAIURL | provisioning URL
phnIOTAItemTrustedDomain | trusted domain for provisioning. All URLs must come from this
phnIOTAItemHomepageURL | default browser homepage
phnIOTAItemVendingURL | vending URL
phnIOTAItemDownloadServerURL | download server URL
phnIOTAItemDownloadServerLock | state of items downloaded from the download server (locked or not)
phnIOTAItemConnectionTimeout | timeout for IOTA connections
phnIOTAItemPriWAPPushProxyGatewayURL | Primary WAP push gateway
phnIOTAItemSecWAPPushProxyGatewayURL | Secondary WAP push gateway
phnIOTAItemPriProxyWDPAddress | WDP address. Translate to the NGG for profile 1
phnIOTAItemSecProxyWDPAddress | WDP address. Translate to the NGG for profile 1
phnIOTAItemPriSIPConfigServer | Primary Config server
phnIOTAItemSecSIPConfigServer | Secondary Config server
phnIOTAItemPriSIPEdgeProxyGateway | Primary SIP Proxy Edge gateway
phnIOTAItemSecSIPEdgeProxyGateway | Secondary SIP Proxy Edge gateway
phnIOTAItemPriDataExchangeURL | Primary Data Exchange URL
phnIOTAItemSecDataExchangeURL | Secondary Data Exchange URL
phnIOTAItemPriDataGatewayURL | Primary Data Gateway URL
phnIOTAItemSecDataGatewayURL | Secondary Data Gateway URL
phnIOTAItemPriSIPRetryTimer | Primary SIP Retry timer
phnIOTAItemSecSIPRetryTimer | Secondary SIP Retry timer
phnIOTAItemPriSIPRetryCount | Primary SIP Retry count
phnIOTAItemSecSIPRetryCount | Secondary SIP Retry count
phnIOTAItemPriIMMessageStore | Primary IM Message store
phnIOTAItemSecIMMessageStore | Secondary IM Message store
phnIOTAItemRootCertificate1 | Root certificate #1
phnIOTAItemRootCertificate2 | Root certificate #2
phnIOTAItemRootCertificate3 | Root certificate #3
phnIOTAItemRootCertificate4 | Root certificate #4
phnIOTAItemPRLStorageSize | max PRL size radio supports
phnIOTAItemSIPUsername | Username for SIP accounts
phnIOTAItemSIPPassword | password for SIP accounts
phnIOTAItemLastNVItem | last IOTA NV Item
phnIOTAItemUnknown | unknown item

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:41 2006 for Palm API Guide


HsPhoneLibrary.h File Reference

Detailed Description

Header File for Phone Library API ---- LIBRARY CATEGORY.

Notes: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the LIBRARY category. These API calls are used for basic Palm Library operation.

Include dependency graph for HsPhoneLibrary.h:

Functions

  • Err PhnLibOpen (UInt16 refNum)
    Open the phone library. Global space has been created on SysLibLoad already. This function just manages the openCount.
  • Err PhnLibClose (UInt16 refNum)
    Closes up a phone library. This function does not free global space. It just manages the openCount.
  • Err PhnLibSleep (UInt16 refNum)
    (For System Use Only)
  • Err PhnLibWake (UInt16 refNum)
    (For System Use Only)
  • Err PhnLibGetLibAPIVersion (UInt16 refNum, UInt32 *dwVerP)
    This function is used to indicate the version number of the current Phone Library.
  • void PhnLibUninstall (UInt16 refNum)
    This is an unsupported function starting with Treo 600.
  • Err PhnLibRegister (UInt16 refNum, DWord creator, UInt16 services)
    Register or unregister (when services == 0) an application so that notifications from the Phone Library (Chapter 13) can be broadcasted to registered applications.

Function Documentation

Err PhnLibClose ( UInt16 refNum )

Closes up a phone library. This function does not free global space. It just manages the openCount.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
Return values:
Err Error code.

Err PhnLibGetLibAPIVersion | ( | UInt16 | refNum,
 |  | UInt32 * | dwVerP
 | ) |

This function is used to indicate the version number of the current Phone Library.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
dwVerP,: IN: Version number
Return values:
Err Error code.

Err PhnLibOpen ( UInt16 refNum )

Open the phone library. Global space has been created on SysLibLoad already. This function just manages the openCount.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
Return values:
Err Error code.

Err PhnLibRegister | ( | UInt16 | refNum,
 |  | DWord | creator,
 |  | UInt16 | services
 | ) |

Register or unregister (when services == 0) an application so that notifications from the Phone Library (Chapter 13) can be broadcasted to registered applications.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
creator,: IN: Creator ID of application registering for notifications
services,: IN: Bitfield of services for which notifications are desired. See PhnServiceClassType for bit definitions. Register with a value of 0 to unregister for notifications.
Return values:
0 for success; otherwise failed

Err PhnLibSleep ( UInt16 refNum )

(For System Use Only)

Parameters:
refNum,: IN:
Return values:
Err Error code.

void PhnLibUninstall ( UInt16 refNum )

This is an unsupported function starting with Treo 600.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
Return values:
Nothing

Err PhnLibWake ( UInt16 refNum )

(For System Use Only)

Parameters:
refNum,: IN:
Return values:
Err Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:41 2006 for Palm API Guide


hsPhoneLocationTypes.h File Reference

Detailed Description

File contains Phone Location data types.

Include dependency graph for hsPhoneLocationTypes.h:

Typedefs

  • typedef UInt8 PhnPDSessionConfigParamType

Enumerations

  • enum _PhnPDSessionConfigParamType {
    PhnPDConfigIPAddr = 1,
    PhnPDConfigPortID,
    PhnPDConfigGPSLock,
    PhnPDConfigPTLMMode
    }

Typedef Documentation

typedef UInt8 PhnPDSessionConfigParamType

error codes returned by phone library functions

Enumeration Type Documentation

enum _PhnPDSessionConfigParamType

Enumerator:
PhnPDConfigIPAddr | Binary value of the Position Determination Entity (PDE) IP Address
PhnPDConfigPortID | Binary value of the PDE Port ID.
PhnPDConfigGPSLock | Level of GPS lock set in the modem.
PhnPDConfigPTLMMode | The protocol transport layer mechanism to be used to talk to the PDE.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:42 2006 for Palm API Guide


HsPhoneMisc.h File Reference

Detailed Description

Header File for Phone Library API ---- MISC CATEGORY.

Notes: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the Miscellaneous category. These API calls are Miscellaneous calls that don't fit into any other category. Many of them are device control.

Include dependency graph for HsPhoneMisc.h:

Functions

  • Err PhnLibGetLineState (UInt16 refNum, UInt16 line, PhnLineStatePtr lineState)
    Retrieve the Line state.
  • Err PhnLibGetRadioState (UInt16 refNum, PhnRadioStatePtr radioState)
    Retrieve state information about the radio.
  • Boolean PhnLibCardInfo (UInt16 refNum, CharPtr *manufacturer, CharPtr *model, CharPtr *version, CharPtr *serial)
  • Err PhnLibConnectionAvailable (UInt16 refNum, PhnConnectionEnum connection, Boolean *pAvailable)
    Checks to see if a connection can be made.
  • Err PhnLibStartVibrate (UInt16 refNum, Boolean pulse, Boolean repeat)
    This API have been deprecated. Please use “HsIndicatorState.”.
  • Err PhnLibStopVibrate (UInt16 refNum)
    This API have been deprecated. Please use “HsIndicatorState.”.
  • Err PhnLibErrorRate (UInt16 refNum, WordPtr errorRate)
  • void PhnLibGetErrorText (UInt16 refNum, Err error, CharPtr buffer, UInt16 bufferLen)
  • UInt16 PhnLibGetCallCountByService (UInt16 refNum, PhoneServiceClassType service)
    Locate the call item that has the specified service if such item exists return the total number of call items that has the same service.
  • Err PhnLibGetEchoCancellation (UInt16 refNum, Boolean *echoCancellationOn)
  • Err PhnLibSetEchoCancellation (UInt16 refNum, Boolean echoCancellationOn)
  • Err PhnLibGetEquipmentMode (UInt16 refNum, PhnEquipmentMode *equipmentMode)
  • Err PhnLibSetEquipmentMode (UInt16 refNum, PhnEquipmentMode equipmentMode)
  • Err PhnLibGetHeadsetConnectedInfo (UInt16 refNum, Boolean *headsetConnected)
  • Err PhnLibGetMicrophone (UInt16 refNum, Int16 *gain)
  • Err PhnLibSetMicrophone (UInt16 refNum, Int16 gain)
  • Boolean PhnLibCardInfoEx (UInt16 refNum, CharPtr *manufacturer, CharPtr *model, CharPtr *modemSWRev, CharPtr *esn, CharPtr *prlRev, CharPtr *hostSWRev, CharPtr *modemHWRev, CharPtr *priChecksum, Word *eriVer, Boolean *isEriSet)
  • Err PhnLibGetPhoneCallStatus (UInt16 refNum, UInt32 *phnFlags)
  • Err PhnLibMute (UInt16 refNum, Boolean toMute)
  • Err PhnLibIsCallMuted (UInt16 refNum, Boolean *isMute)
  • Boolean PhnLibIsPhoneActivated (UInt16 refNum)
  • Err PhnLibMiscDebugInfo (UInt16 refNum, Boolean bSet, VoidPtr debugInfoP, UInt16 infoLen)
  • Err PhnLibAttrGet (UInt16 refNum, UInt16 attr, UInt32 flags, void *dataP)
  • Err PhnLibAttrSet (UInt16 refNum, UInt16 attr, UInt32 flags, void *dataP)
  • Err PhnLibGetDeviceID (UInt16 refNum, CharPtr *deviceId)
  • Err PhnLibGetNoiseCancellation (UInt16 refNum, Boolean *noiseCancellationP)
  • Err PhnLibSetNoiseCancellation (UInt16 refNum, Boolean noiseCancellation)

Function Documentation

Err PhnLibAttrGet | ( | UInt16 | refNum,
 |  | UInt16 | attr,
 |  | UInt32 | flags,
 |  | void * | dataP
 | ) |

Parameters:
refNum,: IN:
attr,: IN:
flags,: IN:
dataP,: IN:
Return values:
Err Error code.

Err PhnLibAttrSet | ( | UInt16 | refNum,
 |  | UInt16 | attr,
 |  | UInt32 | flags,
 |  | void * | dataP
 | ) |

Parameters:
refNum,: IN:
attr,: IN:
flags,: IN:
dataP,: IN:
Return values:
Err Error code.

Boolean PhnLibCardInfo | ( | UInt16 | refNum,
 |  | CharPtr * | manufacturer,
 |  | CharPtr * | model,
 |  | CharPtr * | version,
 |  | CharPtr * | serial
 | ) |

Parameters:
refNum,: IN:
manufacturer,: IN:
model,: IN:
version,: IN:
serial IN:
Return values:
Err Error code.

Boolean PhnLibCardInfoEx | ( | UInt16 | refNum,
 |  | CharPtr * | manufacturer,
 |  | CharPtr * | model,
 |  | CharPtr * | modemSWRev,
 |  | CharPtr * | esn,
 |  | CharPtr * | prlRev,
 |  | CharPtr * | hostSWRev,
 |  | CharPtr * | modemHWRev,
 |  | CharPtr * | priChecksum,
 |  | Word * | eriVer,
 |  | Boolean * | isEriSet
 | ) |

Parameters:
refNum,: IN:
manufacturer,: IN:
model,: IN:
modemSWRev,: IN:
esn,: IN:
prlRev,: IN:
hostSWRev,: IN:
modemHWRev,: IN:
priChecksum,: IN:
*eriver,: IN:
*isEriSet,: IN:
Return values:
Err Error code.

Err PhnLibConnectionAvailable | ( | UInt16 | refNum,
 |  | PhnConnectionEnum | connection,
 |  | Boolean * | pAvailable
 | ) |

Checks to see if a connection can be made.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
connection,: IN: Type of connection to be made.
pAvailable,: IN: Result indicating if a connection is available.
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibErrorRate | ( | UInt16 | refNum,
 |  | WordPtr | errorRate
 | ) |

Parameters:
refNum,: IN:
errorRate,: IN:
Return values:
Err Error code.

UInt16 PhnLibGetCallCountByService | ( | UInt16 | refNum,
 |  | PhoneServiceClassType | service
 | ) |

Locate the call item that has the specified service if such item exists return the total number of call items that has the same service.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
service,: IN: The specified connection service (can OR bit combination)
Return values:
Number of call items that has the same status.

Err PhnLibGetDeviceID | ( | UInt16 | refNum,
 |  | CharPtr * | deviceId
 | ) |

Parameters:
refNum,: IN:
deviceId,: IN:
Return values:
Err Error code.

Err PhnLibGetEchoCancellation | ( | UInt16 | refNum,
 |  | Boolean * | echoCancellationOn
 | ) |

Parameters:
refNum,: IN:
echoCancellationOn,: IN:
Return values:
Err Error code.

Err PhnLibGetEquipmentMode | ( | UInt16 | refNum,
 |  | PhnEquipmentMode * | equipmentMode
 | ) |

Parameters:
refNum,: IN:
equipmentMode,: IN:
Return values:
Err Error code.

void PhnLibGetErrorText | ( | UInt16 | refNum,
 |  | Err | error,
 |  | CharPtr | buffer,
 |  | UInt16 | bufferLen
 | ) |

Parameters:
refNum,: IN:
error,: IN:
buffer,: IN:
bufferLen,: IN:
Return values:
Err Error code.

Err PhnLibGetHeadsetConnectedInfo | ( | UInt16 | refNum,
 |  | Boolean * | headsetConnected
 | ) |

Parameters:
refNum,: IN:
headsetConnected,: IN:
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibGetLineState | ( | UInt16 | refNum,
 |  | UInt16 | line,
 |  | PhnLineStatePtr | lineState
 | ) |

Retrieve the Line state.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
line,: IN: Line to query for
lineState,: IN: State of the Line
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibGetMicrophone | ( | UInt16 | refNum,
 |  | Int16 * | gain
 | ) |

Parameters:
refNum,: IN:
gain,: IN:
Return values:
Err Error code.

Err PhnLibGetNoiseCancellation | ( | UInt16 | refNum,
 |  | Boolean * | noiseCancellationP
 | ) |

Parameters:
refNum,: IN:
noiseCancellationP,: IN:
Return values:
Err Error code.

Err PhnLibGetPhoneCallStatus | ( | UInt16 | refNum,
 |  | UInt32 * | phnFlags
 | ) |

Parameters:
refNum,: IN:
phnFlags,: IN:
Return values:
Err Error code.

Err PhnLibGetRadioState | ( | UInt16 | refNum,
 |  | PhnRadioStatePtr | radioState
 | ) |

Retrieve state information about the radio.

Parameters:
refNum,: IN: Library reference number obtained from SysLibLoad.
radioState,: IN: State of the Radio
Return values:
0 for success; otherwise failed and returned an error code as defined in “Phone Library Error Codes.”

Err PhnLibIsCallMuted | ( | UInt16 | refNum,
 |  | Boolean * | isMute
 | ) |

Parameters:
refNum,: IN:
isMute,: IN:
Return values:
Err Error code.

Boolean PhnLibIsPhoneActivated ( UInt16 refNum )

Parameters:
refNum,: IN:
Return values:
Err Error code.

Err PhnLibMiscDebugInfo | ( | UInt16 | refNum,
 |  | Boolean | bSet,
 |  | VoidPtr | debugInfoP,
 |  | UInt16 | infoLen
 | ) |

Parameters:
refNum,: IN:
bSet,: IN:
debugInfoP IN:
infoLen,: IN:
Return values:
Err Error code.

Err PhnLibMute | ( | UInt16 | refNum,
 |  | Boolean | toMute
 | ) |

Parameters:
refNum,: IN:
toMute,: IN:
Return values:
Err Error code.

Err PhnLibSetEchoCancellation | ( | UInt16 | refNum,
 |  | Boolean | echoCancellationOn
 | ) |

Parameters:
refNum,: IN:
echoCancellationOn,: IN:
Return values:
Err Error code.

Err PhnLibSetEquipmentMode | ( | UInt16 | refNum,
 |  | PhnEquipmentMode | equipmentMode
 | ) |

Parameters:
refNum,: IN:
equipmentMode,: IN:
Return values:
Err Error code.

Err PhnLibSetMicrophone | ( | UInt16 | refNum,
 |  | Int16 | gain
 | ) |

Parameters:
refNum,: IN:
gain,: IN:
Return values:
Err Error code.

Err PhnLibSetNoiseCancellation | ( | UInt16 | refNum,
 |  | Boolean | noiseCancellation
 | ) |

Parameters:
refNum,: IN:
noiseCancellation,: IN:
Return values:
Err Error code.

Err PhnLibStartVibrate | ( | UInt16 | refNum,
 |  | Boolean | pulse,
 |  | Boolean | repeat
 | ) |

This API have been deprecated. Please use “HsIndicatorState.”.

Parameters:
refNum,: IN:
pulse,: IN:
repeat,: IN:
Return values:
Err Error code.

Err PhnLibStopVibrate ( UInt16 refNum )

This API have been deprecated. Please use “HsIndicatorState.”.

Parameters:
refNum,: IN:
Return values:
Err Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:43 2006 for Palm API Guide


HsPhoneMiscTypes.h File Reference

Detailed Description

Header File for Phone Library API ---- NETWORK CATEGORY.

NOTES: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the SMS category. These API calls are used to interact with the wireless network.

Include dependency graph for HsPhoneMiscTypes.h:

Data Structures

  • struct PhnRadioStateType
  • struct PhnLineStateType
  • struct PhnCdmaSystemInfoType

Defines

  • #define isValidPhnVibrateType(t) ((t >= phnVibrateOff) && (t <= phnVibrateOn))
  • #define isValidPhnConnectionEnum(e) ((e >= voiceConnection) && (e <= oneXConnection))
  • #define isValidPhnEquipmentMode(m) (m <= phnEquipmentModeLast)
  • #define kRadioStateVersion 1
  • #define kLineStateVersion 1

Typedefs

  • typedef struct PhnRadioStateType * PhnRadioStatePtr
  • typedef struct PhnLineStateType * PhnLineStatePtr
  • typedef UInt8 PhnLibAttrType
  • typedef UInt8 * PhnLibAttrPtr
  • typedef UInt8 PhnOprtModeType
  • typedef struct PhnCdmaSystemInfoType * PhnCdmaSystemInfoPtr

Enumerations

  • enum PhnVibrateType {
    phnVibrateOff,
    phnVibrateOn
    }
  • enum PhnConnectionEnum {
    voiceConnection = 1,
    csdConnection = 2,
    gprsConnection = 3,
    oneXConnection = 4
    }
  • enum PhnEquipmentMode {
    phnHandsetMode,
    phnHeadsetMode,
    phnSpeakerPhoneMode,
    phnCarKitMode,
    phnHandsetLidCloseMode,
    phnAutoMode,
    phnBluetoothHeadsetMode,
    phnBluetoothHandsfreeMode,
    phnInvalidEquipmentMode,
    phnEquipmentModeLast
    }
  • enum _PhnLibAttrType {
    phnGsmAttrFirst = 0,
    phnGsmNoFWVersionCompatibilityCheck,
    phnGsmSimBookSimMaxEntries,
    phnGsmSimBookSimUsedEntries,
    phnGsmRadioAudioSet,
    phnGsmFWControlLED,
    phnGsmAttrLast
    }
  • enum _PhnOprtModeType {
    phnOprtModeNone = -1,
    phnOprtModePwroff,
    phnOprtModeOffline,
    phnOprtModeOfflineA,
    phnOprtModeOnline,
    phnOprtModeLPM,
    phnOprtModeReset,
    phnOprtModeMax
    }

Enumeration Type Documentation

enum _PhnLibAttrType

Phone Library Attributes

enum _PhnOprtModeType

Enumerator:
phnOprtModeNone | FOR INTERNAL USE OF CM ONLY!
phnOprtModePwroff | phone is powering off
phnOprtModeOffline | phone is offline Digital
phnOprtModeOfflineA | phone is offline analog
phnOprtModeOnline | phone is online
phnOprtModeLPM | phone is in LPM - Low Power Mode
phnOprtModeReset | phone is resetting - i.e. power-cycling

enum PhnConnectionEnum

Phone Connection Type

enum PhnEquipmentMode

Enumerator:
phnHandsetMode | sets default mode to handset mode
phnHeadsetMode | sets default mode to headdset mode
phnSpeakerPhoneMode | sets default mode to speaker phone mode
phnCarKitMode | set carkit mode
phnAutoMode | automatic mode where modem internaly decides the mode
phnInvalidEquipmentMode | Used to flag an invalid mode

enum PhnVibrateType

Vibrate mode while ringing.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:43 2006 for Palm API Guide


HsPhoneNetwork.h File Reference

Detailed Description

Header File for Phone Library API ---- NETWORK CATEGORY.

Notes: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the Network category. These API calls are used to interact with the wireless network.

Include dependency graph for HsPhoneNetwork.h:

Functions

  • Err PhnLibBoxInformation (UInt16 refNum, PhnMsgBoxDataType *data)
    Gets information on a specific voicemail box as specified in the data argument.
  • Err PhnLibBoxInformationEx (UInt16 refNum, PhnMsgBoxDataType *data, Boolean bGetInfo)
    Gets or Set information on a specific voicemail box as specified in the data argument.
  • Err PhnLibGetBoxNumber (UInt16 refNum, PhnMsgBoxType type, UInt16 line, CharPtr *number)
    Return the number of the voice box of the given type for the given line as it is stored on the SIM.
  • Err PhnLibHomeOperatorID (UInt16 refNum, char *buffer, Int16 *bufferSizeP)
    Get value for home network’s operator ID (MCC+MNC) string.
  • Err PhnLibCurrentOperatorID (UInt16 refNum, char *buffer, Int16 *bufferSizeP)
    Get value for current network’s operator ID (MCC+MNC) string.
  • Err PhnLibCurrentOperator (UInt16 refNum, PhnOperatorID *id, CharPtr *name, GSMRegistrationMode *mode)
    Get value for current network’s operator string.
  • Err PhnLibSetOperator (UInt16 refNum, PhnOperatorType *op, GSMRegistrationMode regMode)
    Set value of operator for radio to register to.
  • Err PhnLibRoaming (UInt16 refNum, PhnRoamStatus *roamStatus)
    Return the roaming status.
  • Boolean PhnLibRegistered (UInt16 refNum)
    Checks if the phone found any network cellular service.
  • Err PhnLibSignalQuality (UInt16 refNum, UInt16 *quality)
    Return the signal strength.
  • Err PhnLibSignalQualityEx (UInt16 refNum, UInt16 *quality, Boolean *bEcio, UInt16 *ecioLvl)
    Get the signal quality and ecio level information.
  • Err PhnLibCurrentProvider (UInt16 refNum, char **name)
    Get value for current network’s provider.
  • Err PhnLibGetOperatorList (UInt16 refNum, PhnOperatorListPtr *list)
    Get list of operators available to radio.
  • Err PhnLibGetOwnNumbers (UInt16 refNum, PhnAddressList *ownNumbers)
    Return a list of phone numbers from the device. These numbers could be voicemail box, data line or fax line (if supported).
  • Err PhnLibSetOwnNumbers (UInt16 refnum, PhnAddressList ownNumbers)

  • Err PhnLibSetCallWaiting (UInt16 refNum, Boolean enabled)
    Enable/disable call waiting for phone calls on radio.
  • Err PhnLibGetCallWaiting (UInt16 refNum, BooleanPtr enabled)
    Get call waiting setting for phone calls on radio.
  • Err PhnLibSetCLIP (UInt16 refNum, Boolean enable)
  • Err PhnLibGetCLIP (UInt16 refNum, Boolean *enabled)
    (TBC)
  • Err PhnLibGetForwarding (UInt16 refNum, PhnForwardType condition, PhnAddressHandle *destination)
    Returns the forwarded number stored in smartphone radio.
  • Err PhnLibSetCLIR (UInt16 refNum, GSMDialCLIRMode mode)
  • Err PhnLibGetCLIR (UInt16 refNum, GSMDialCLIRMode *mode, PhnCLIRStatus *status)
    (TBC)
  • Err PhnLibSetBarring (UInt16 refNum, PhnBarFacilityType facility, CharPtr password)
    Used to Activate a Barring Service.
  • Err PhnLibGetBarring (UInt16 refNum, PhnBarFacilityType facility, Boolean *enabled)
    Get Barring Service state for given facility.
  • Err PhnLibDeactivateBarring (UInt16 refNum, PhnBarFacilityType facility, CharPtr password)
    Used to Deactivate a Barring Service.
  • Err PhnLibGetEnhancedRoamIndicator (UInt16 refNum, char *roamTxt, PhnRoamIconState *iconState)
    Retrieves the roaming indicator text that needs to be displayed if the phone is in enhanced roaming mode.
  • Err PhnLibGetRoamPrefMode (UInt16 refNum, PhnRoamPrefSelectionType *roamPrefP)
    (TBD)
  • Err PhnLibSetRoamPrefMode (UInt16 refNum, PhnRoamPrefSelectionType roamPref)
    Set the roaming mode. This API is the same as used when the user checks or unchecks the “Enable Digital roaming” in the Phone Preference on Treo 600. If set, then digital roaming will be allowed.
  • Err PhnLibSetRoamPrefInfo (UInt16 refNum, PhnRoamPrefInfoPtr pInfo)
  • Err PhnLibGetOperatorLock (UInt16 refNum, UInt16 facilityType, Boolean *enabled)
    This function indicate if the Operator has locked the phone to its network (i.e. it can’t be used on other network).
  • Boolean PhnLibNetworkAvailable (UInt16 refNum)
    (TBD)
  • Err PhnLibSetForwarding (UInt16 refNum, PhnForwardType condition, PhnForwardModeType mode, PhnAddressHandle destination)
    Set call forwarding settings.
  • Err PhnLibUsableSignalStrengthThreshold (UInt16 refNum, WordPtr threshold)
    This function gives the threshold level of signal quality at which the radio is capable of sending data.
  • Err PhnLibGetDataSessionInfo (UInt16 refNum, PhnDataSessionStateType *dataSessionStateP)
    Returns the current state of the data session as well as the available data session type currently available on the network.

Function Documentation

Err PhnLibBoxInformation | ( | UInt16 | refNum,
 |  | PhnMsgBoxDataType * | data
 | ) |

Gets information on a specific voicemail box as specified in the data argument.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
data,: IN: See “PhnMsgBoxDataType” for details
Return values:
0 for success; otherwise failed.

Err PhnLibBoxInformationEx | ( | UInt16 | refNum,
 |  | PhnMsgBoxDataType * | data,
 |  | Boolean | bGetInfo
 | ) |

Gets or Set information on a specific voicemail box as specified in the data argument.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
data,: IN: See “PhnMsgBoxDataType” for details
bGetInfo,: IN: Indicates whether the operation is a get (True) or set (False).
Return values:
0 for success; otherwise failed.

Err PhnLibCurrentOperator | ( | UInt16 | refNum,
 |  | PhnOperatorID * | id,
 |  | CharPtr * | name,
 |  | GSMRegistrationMode * | mode
 | ) |

Get value for current network’s operator string.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
id,: IN: returned operator ID value
name,: IN: returned operator name string
mode,: IN: returned registration mode for current operator
Return values:
0 for success; otherwise failed

Err PhnLibCurrentOperatorID | ( | UInt16 | refNum,
 |  | char * | buffer,
 |  | Int16 * | bufferSizeP
 | ) |

Get value for current network’s operator ID (MCC+MNC) string.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
*buffer,: IN: buffer to hold returned string
bufferSizeP,: IN:
Return values:
0 for success; otherwise failed

Err PhnLibCurrentProvider | ( | UInt16 | refNum,
 |  | char ** | name
 | ) |

Get value for current network’s provider.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
name,: IN: returned provider name string
Return values:
0 for success; otherwise failed

Err PhnLibDeactivateBarring | ( | UInt16 | refNum,
 |  | PhnBarFacilityType | facility,
 |  | CharPtr | password
 | ) |

Used to Deactivate a Barring Service.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
facility,: IN: barring condition to be deactivated
password,: IN:
Return values:
0 for success; otherwise failed

Err PhnLibGetBarring | ( | UInt16 | refNum,
 |  | PhnBarFacilityType | facility,
 |  | Boolean * | enabled
 | ) |

Get Barring Service state for given facility.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
facility,: IN: barring condition to get state for
enabled,: IN: returned state of given barring service; true = activated.
Return values:
0 for success; otherwise failed

Err PhnLibGetBoxNumber | ( | UInt16 | refNum,
 |  | PhnMsgBoxType | type,
 |  | UInt16 | line,
 |  | CharPtr * | number
 | ) |

Return the number of the voice box of the given type for the given line as it is stored on the SIM.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
type,: IN: See “PhnMsgBoxType” for details. On Treo™ 600 smartphone by palmOne, only the kBoxVoice type is supported
line,: IN: On a GSM/GPRS device, line can be either “1” or “2”. This is dependant on if the subscriber account supports 1 or 2 line(s) (on GSM, this is called Alternative Line Service). On the CDMA device, it is currently not used.
number,: IN: Returns the number as a string.
Return values:
PhnLibGetBoxNumber returns 0 if the number could be determined without encountering an error.

Err PhnLibGetCallWaiting | ( | UInt16 | refNum,
 |  | BooleanPtr | enabled
 | ) |

Get call waiting setting for phone calls on radio.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
enabled,: IN: return value of call waiting service on radio. true if call waiting is enabled false if call waiting is disabled value is undefined if return value of function is not 0 (ERROR)
Return values:
0 for success; otherwise failed

Err PhnLibGetCLIP | ( | UInt16 | refNum,
 |  | Boolean * | enabled
 | ) |

(TBC)

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
enabled,: IN:
Return values:
Err Error code.

Err PhnLibGetCLIR | ( | UInt16 | refNum,
 |  | GSMDialCLIRMode * | mode,
 |  | PhnCLIRStatus * | status
 | ) |

(TBC)

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
mode,: IN:
status,: IN:
Return values:
Err Error code.

Err PhnLibGetDataSessionInfo | ( | UInt16 | refNum,
 |  | PhnDataSessionStateType * | dataSessionStateP
 | ) |

Returns the current state of the data session as well as the available data session type currently available on the network.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
dataSessionStateP,: OUT: data structure to be filled out. version field must be set
Return values:
0 for success; otherwise failed

Err PhnLibGetEnhancedRoamIndicator | ( | UInt16 | refNum,
 |  | char * | roamTxt,
 |  | PhnRoamIconState * | iconState
 | ) |

Retrieves the roaming indicator text that needs to be displayed if the phone is in enhanced roaming mode.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
roamTxt,: IN: Pointer to a char of “PhnEnhancedRoamIndMaxLength” maximum length.
*iconState,: IN:
Return values:
phnErrNotAllowed if called when the phone is not in enhanced roaming.

Err PhnLibGetForwarding | ( | UInt16 | refNum,
 |  | PhnForwardType | condition,
 |  | PhnAddressHandle * | destination
 | ) |

Returns the forwarded number stored in smartphone radio.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
condition,: IN: forwarding condition to get values for. Currently CDMA only supports “phnForwardUnconditional” as defined in “PhnForwardType”.
destination,: IN: returned forwarding address for given forwarding condition
Return values:
Err 0 for success; otherwise failed

Err PhnLibGetOperatorList | ( | UInt16 | refNum,
 |  | PhnOperatorListPtr * | list
 | ) |

Get list of operators available to radio.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
list,: IN: container for returned list of operator values
Return values:
0 for success; otherwise failed

Err PhnLibGetOperatorLock | ( | UInt16 | refNum,
 |  | UInt16 | facilityType,
 |  | Boolean * | enabled
 | ) |

This function indicate if the Operator has locked the phone to its network (i.e. it can’t be used on other network).

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
facilityType,: IN: optional facility type, or 0 (TBC)
enabled,: IN: pointer to output value
Return values:
True if a network was found even if we are unable to register to it. False if no network can be found.

Err PhnLibGetOwnNumbers | ( | UInt16 | refNum,
 |  | PhnAddressList * | ownNumbers
 | ) |

Return a list of phone numbers from the device. These numbers could be voicemail box, data line or fax line (if supported).

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
ownNumbers,: IN: Pointer to the list of phone box number of the device.
Return values:
0 for success; otherwise failed

Err PhnLibGetRoamPrefMode | ( | UInt16 | refNum,
 |  | PhnRoamPrefSelectionType * | roamPrefP
 | ) |

(TBD)

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
Mode,: IN: see PhnRoamPrefSelectionType
Return values:
Err Error code.

Err PhnLibHomeOperatorID | ( | UInt16 | refNum,
 |  | char * | buffer,
 |  | Int16 * | bufferSizeP
 | ) |

Get value for home network’s operator ID (MCC+MNC) string.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
*buffer,: IN: Buffer to hold returned string
bufferSizeP,: IN:
Return values:
0 for success; otherwise failed

Boolean PhnLibNetworkAvailable ( UInt16 refNum )

(TBD)

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
Return values:
Err Error code.

Boolean PhnLibRegistered ( UInt16 refNum )

Checks if the phone found any network cellular service.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
Return values:
true if service is found. false if no service

Err PhnLibRoaming | ( | UInt16 | refNum,
 |  | PhnRoamStatus * | roamStatus
 | ) |

Return the roaming status.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
roamStatus,: IN: PhnLibRoaming returns the roaming status.
Return values:
0 if no error; error code otherwise

Err PhnLibSetBarring | ( | UInt16 | refNum,
 |  | PhnBarFacilityType | facility,
 |  | CharPtr | password
 | ) |

Used to Activate a Barring Service.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
facility,: IN: Barring condition to be set
password,: IN: Password to set Barring. This will be used when changing barring option.
Return values:
0 for success; otherwise failed

Err PhnLibSetCallWaiting | ( | UInt16 | refNum,
 |  | Boolean | enabled
 | ) |

Enable/disable call waiting for phone calls on radio.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
enabled,: IN: flag to enable/disable call waiting
Return values:
0 for success; otherwise failed

Err PhnLibSetCLIP | ( | UInt16 | refNum,
 |  | Boolean | enable
 | ) |

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
enable,: IN: True to enable CLIP. False to disable it.
Return values:
Err Error code.

Err PhnLibSetCLIR | ( | UInt16 | refNum,
 |  | GSMDialCLIRMode | mode
 | ) |

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
mode,: IN: (TBC)
Return values:
0 for success; otherwise failed.

Err PhnLibSetForwarding | ( | UInt16 | refNum,
 |  | PhnForwardType | condition,
 |  | PhnForwardModeType | mode,
 |  | PhnAddressHandle | destination
 | ) |

Set call forwarding settings.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
condition,: IN: forwarding condition to be set
mode,: IN: forwarding condition value to be set
destination,: IN: forwarding address value
Return values:
Err 0 for success; otherwise failed

Err PhnLibSetOperator | ( | UInt16 | refNum,
 |  | PhnOperatorType * | op,
 |  | GSMRegistrationMode | regMode
 | ) |

Set value of operator for radio to register to.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
op,: IN: operator to register to
regMode,: IN: type of registration to make
Return values:
0 for success; otherwise failed

Err PhnLibSetOwnNumbers | ( | UInt16 | refnum,
 |  | PhnAddressList | ownNumbers
 | ) |

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
ownNumbers,: IN:
Return values:
0 for success; otherwise failed

Err PhnLibSetRoamPrefInfo | ( | UInt16 | refNum,
 |  | PhnRoamPrefInfoPtr | pInfo
 | ) |

Parameters:
refNum,: IN:
pInfo,: IN:
Return values:
Err Error code.

Err PhnLibSetRoamPrefMode | ( | UInt16 | refNum,
 |  | PhnRoamPrefSelectionType | roamPref
 | ) |

Set the roaming mode. This API is the same as used when the user checks or unchecks the “Enable Digital roaming” in the Phone Preference on Treo 600. If set, then digital roaming will be allowed.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
Mode,: IN: see PhnRoamPrefSelectionType
Return values:
Error status

Err PhnLibSignalQuality | ( | UInt16 | refNum,
 |  | UInt16 * | quality
 | ) |

Return the signal strength.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
quality,: IN: Phone signal strength in dBm
Return values:
0 if no error

Err PhnLibSignalQualityEx | ( | UInt16 | refNum,
 |  | UInt16 * | quality,
 |  | Boolean * | bEcio,
 |  | UInt16 * | ecioLvl
 | ) |

Get the signal quality and ecio level information.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
quality,: IN: Phone signal strength in dBm
*bEcio,: IN:
*ecioLvl,: IN:
Return values:
0 for success; otherwise failed

Err PhnLibUsableSignalStrengthThreshold | ( | UInt16 | refNum,
 |  | WordPtr | threshold
 | ) |

This function gives the threshold level of signal quality at which the radio is capable of sending data.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
threshold,: IN: (TBC)
Return values:
0 for success; otherwise failed

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:44 2006 for Palm API Guide


HsPhoneNetworkTypes.h File Reference

Detailed Description

Header File for Phone Library API ---- NETWORK CATEGORY.

NOTES: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the SMS category. These API calls are used to interact with the wireless network.

Include dependency graph for HsPhoneNetworkTypes.h:

Data Structures

  • struct PhnMsgBoxDataType
  • struct PhnOperatorType
  • struct PhnOperatorListType
  • struct PhnRoamPrefInfoType
  • struct PhnMMIEntryType
    MMI Decode struct. More...
  • struct PhnMMIResultType
    MMI result struct. More...
  • struct PhnOneXStatus
  • struct PhnDataSessionStateType
  • struct PhnNetworkTime

Defines

  • #define kMaxPhoneNumberLen 16
  • #define minPasswordLen 4
  • #define maxPasswordLen 8
  • #define maxPasswordLenCDMA 4
  • #define phnEnhancedRoamIndMaxLength 40
  • #define isValidPhnCLIRStatus(s) ((s >= clirNotProvisioned) && (s <= clirTemporaryAllowed))
  • #define isValidGSMDialClirStatus(d) ((d >= gsmDialCLIRNotProvisioned) && (d <= gsmDialCLIRTemporaryAllowed))
  • #define isValidPhnOperatorStatus(s) ((s >= phnOpUnknown) && (s <= phnOpForbidden))
  • #define isValidPhnMsgBoxType(n) (n < PhnMsgBoxTypeMAX)
  • #define MAX_LONGOPERATORNAME_LENGTH 24
  • #define MAX_SHORTOPERATORNAME_LENGTH 16
  • #define isValidGSMRegistrationMode(r) (r <= gsmRegModeManualAutomatic)
  • #define isValidPhnForwardType(f) (f < phnForwardLast)
  • #define isValidPhnBarFacilityType(b) (b <= phnBarAll)
  • #define isValidPhnRegistrationStatus(r) (r <= registrationRoaming)
  • #define isValidPhnForwardModeType(f) (f <= phnForwardModeErasure)
  • #define kMaxMMISequenceLen 64
  • #define kMaxImeiLen 24
  • #define isValidPhnBandSelection(f) (f <= band1900_850)
  • #define isValidRoamMode(x) (x < phnRoamPrefLast)
  • #define isValidPhnOneXProtRevType(p) (p <= phnOneXStatusPRev7)
  • #define isValidPhnPacketDataSessionType(p) (p <= phnPacketDataSessionActive)
  • #define isValidPhnMIPSessionType(m) (m <= phnMIPSession)
  • #define isValidDataService(x) (x < phnDataServiceLast)
  • #define isValidPacketDataEndStatus(x) (x < phnPacketDataEndStatusLast)
  • #define PhnDataSessionStateTypeMajorVersion 0x0001L
  • #define PhnDataSessionStateTypeMinorVersion 0x0000L
  • #define PhnDataSessionStateTypeVersion (((UInt32)PhnDataSessionStateTypeMajorVersion << 16) | PhnDataSessionStateTypeMinorVersion)

Typedefs

  • typedef UInt8 PhnMsgBoxType
  • typedef struct PhnOperatorListType * PhnOperatorListPtr
  • typedef UInt8 PhnRoamStatus
  • typedef UInt8 PhnForwardType
  • typedef UInt8 PhnBarFacilityType
  • typedef UInt8 * PhnBarFacilityPtr
  • typedef struct PhnRoamPrefInfoType * PhnRoamPrefInfoPtr
  • typedef UInt8 PhnForwardModeType
  • typedef UInt8 PhnMMIActionCode
  • typedef UInt8 PhnMMIServiceCode
  • typedef UInt8 PhnCallControlType
  • typedef struct PhnMMIEntryType * PhnMMIEntryPtr
  • typedef struct PhnMMIResultType * PhnMMIResultPtr
  • typedef UInt8 PhnBandSelection
  • typedef UInt8 PhnRoamPrefSelectionType
  • typedef UInt8 PhnOneXProtRevType
  • typedef UInt8 PhnPacketDataSessionType
  • typedef UInt8 PhnMIPSessionType
  • typedef UInt16 PhnDataServiceType
  • typedef UInt16 PhnPacketDataEndStatusType

Enumerations

  • enum GSMCLIPStatus {
    gsmCLIPNotProvisioned,
    gsmCLIPProvisioned,
    gsmCLIPUnknown
    }
  • enum PhnCLIRStatus {
    clirNotProvisioned,
    clirProvisioned,
    clirUnknown,
    clirTemporaryRestricted,
    clirTemporaryAllowed
    }
  • enum GSMCLIRDisplayStatus {
    gsmCLIRSubscription,
    gsmCLIRInvocation,
    gsmCLIRSuppression
    }
  • enum PhnOperatorStatus {
    phnOpUnknown,
    phnOpAvailable,
    phnOpCurrent,
    phnOpForbidden
    }
  • enum PhnMsgBoxEnum {
    kBoxVoice,
    kBoxTelefax,
    kBoxEMail,
    kBoxOther,
    kBoxData,
    PhnMsgBoxTypeMAX
    }
  • enum GSMRegistrationMode {
    gsmRegModeAutomatic,
    gsmRegModeManual,
    gsmRegModeDeregister,
    gsmRegModeFormat,
    gsmRegModeManualAutomatic
    }
  • enum PhnRoamStatusEnum {
    PhnRoamStatusOff,
    PhnRoamStatusOn,
    PhnRoamStatusBlink,
    PhnRoamStatusEnhancedIndicator
    }
  • enum PhnForwardEnum {
    phnForwardUnconditional,
    phnForwardOnBusy,
    phnForwardOnNoReplay,
    phnForwardOnNotReachable,
    phnForwardTelefax,
    phnForwardData,
    phnForwardCancelAll,
    phnForwardConditionalAll,
    phnForwardLast
    }
  • enum PhnBarFacilityTypeEnum {
    phnBarOutNone,
    phnBarOutAll,
    phnBarOutInternational,
    phnBarOutInternationalExceptHome,
    phnBarInNone,
    phnBarInAll,
    phnBarInWhenRoaming,
    phnBarAll
    }
  • enum PhnRegistrationStatus {
    registrationNone,
    registrationHome,
    registrationSearch,
    registrationDenied,
    registrationUnknown,
    registrationRoaming
    }
  • enum PhnForwardModeEnum {
    phnForwardModeDisable,
    phnForwardModeEnable,
    phnForwardModeInterrogate,
    phnForwardModeRegistration,
    phnForwardModeErasure
    }
  • enum PhnMMIActionCodeEnum {
    mmiActionNoAction = 0,
    mmiActionActivate = 0x01,
    mmiActionDeactivate = 0x02,
    mmiActionInterrogate = 0x04,
    mmiActionRegister = 0x08,
    mmiActionErasure = 0x10,
    mmiActionUnlock = 0x20,
    mmiActionHandspring = 0x40
    }
  • enum PhnMMIServiceCodeEnum {
    mmiServiceInvalid = 0,
    mmiServiceChangePIN,
    mmiServiceChangePIN2,
    mmiServiceUnlockPIN,
    mmiServiceUnlockPIN2,
    mmiServiceIMEI,
    mmiServiceCallerId,
    mmiServiceNumberSent,
    mmiServiceCOLP,
    mmiServiceCOLR,
    mmiServiceCallWaiting,
    mmiServiceForwardUnconditional,
    mmiServiceForwardBusy,
    mmiServiceForwardNoReply,
    mmiServiceForwardNotReachable,
    mmiServiceForwardAll,
    mmiServiceForwardConditionalAll,
    mmiServiceBAOC,
    mmiServiceBAOIC,
    mmiServiceBAOICX,
    mmiServiceBAIC,
    mmiServiceBAICR,
    mmiServiceAllBarringServ,
    mmiServiceAllOutBarringServ,
    mmiServiceAllInBarringServ,
    mmiServiceChangeBarPwd,
    mmiServiceUSSD,
    mmiServicePhoneNumber,
    mmiServiceCallControl,
    mmiServiceSelectorOperatorLock,
    mmiServiceSelectorProviderLock,
    mmiServiceNNN,
    mmiServiceUnimplemented
    }
  • enum PhnCallControlTypeEnum {
    mmiControlReleaseAllHeld = 0,
    mmiControlReleaseAllActive,
    mmiControlReleaseCallx,
    mmiControlSwap,
    mmiControlActivateCallx,
    mmiControlConference,
    mmiControlTransfer
    }
  • enum PhnRoamIconState {
    PhnRoamIconOn,
    PhnRoamIconOff,
    PhnRoamIconFlash
    }
  • enum PhnTeleserviceType {
    phnTeleserviceUnknown = 0,
    phnTeleserviceVoice = 1,
    phnTeleserviceData = 2,
    phnTeleserviceFax = 4,
    phnTeleserviceDefault = 7,
    phnTeleserviceSMS = 8,
    phnTeleserviceDataCircSync = 16,
    phnTeleserviceDataCircAsync = 32,
    phnTeleserviceDedicatedPack = 64,
    phnTeleserviceDedicatedPAD = 128
    }
  • enum PhnTeleserviceMmiCodeType {
    phnTeleserviceUnknownMmiCode = 0,
    phnTeleserviceVoiceMmiCode = 11,
    phnTeleserviceAllMmiCode = 12,
    phnTeleserviceFaxMmiCode = 13,
    phnTeleserviceSMSMmiCode = 16,
    phnTeleserviceAllExceptSMSCode = 19,
    phnTeleserviceDataCircSyncMmiCode = 24,
    phnTeleserviceDataCircAsyncMmiCode = 25,
    phnTeleserviceDedicatedPackMmiCode = 26,
    phnTeleserviceDedicatedPADMmiCode = 27
    }
  • enum _PhnBandSelection {
    bandGSM_EGSM = 0,
    band1800,
    band900_1800,
    band1900,
    bandAuto,
    band850,
    band1900_850
    }
  • enum _PhnRoamPrefSelectionTypeEnum {
    phnRoamPrefHomeOnly,
    phnRoamPrefAny,
    phnRoamPrefRoamOnly,
    phnRoamPrefLast
    }
  • enum _PhnOneXProtRevType {
    phnOneXStatusPRevNoSvc,
    phnOneXStatusPRev1,
    phnOneXStatusPRev3,
    phnOneXStatusPRev4,
    phnOneXStatusPRev6,
    phnOneXStatusPRev7
    }
  • enum _PhnPacketDataSessionType {
    phnPacketDataSessionNone,
    phnPacketDataSessionDormant,
    phnPacketDataSessionActive
    }
  • enum _PhnMIPSessionType {
    phnMIPSessionNone,
    phnMIPSession
    }
  • enum _PhnDataServiceType {
    phnDataServiceNone,
    phnDataServiceCSD,
    phnDataService1xRTT,
    phnDataService1xEVDO,
    phnDataServiceGPRS,
    phnDataServiceEdge,
    phnDataServiceLast
    }
  • enum _PhnPacketDataEndStatusEnum {
    phnPacketDataEndStatusUnknown,
    phnPacketDataEndStatusNormal,
    phnPacketDataEndStatusReorder,
    phnPacketDataEndStatusRetry,
    phnPacketDataEndStatusTimeout,
    phnPacketDataEndStatusIntercept,
    phnPacketDataEndStatusReject,
    phnPacketDataEndStatusNoReason,
    phnPacketDataEndStatusAuthFailed,
    phnPacketDataEndStatusDropped,
    phnPacketDataEndStatusLast
    }

Define Documentation

#define kMaxPhoneNumberLen 16

workaround for differing header files in sdk-3.5 and sdk-internal Max length of phone number

#define MAX_LONGOPERATORNAME_LENGTH 24

Operator info

#define maxPasswordLen 8

Phone password/PIN maximum length

#define minPasswordLen 4

Phone password/PIN minimum length

Typedef Documentation

typedef UInt8 PhnForwardModeType

Phone call forwarding mode

typedef UInt8 PhnForwardType

Phone call forwarding reason set a type for this enumeration

typedef UInt8 PhnRoamStatus

Possible roaming status' GSM devices only use first two set a type for this enumeration

Enumeration Type Documentation

enum _PhnDataServiceType

This defines the different data service types.

enum _PhnMIPSessionType

This is now deprecated. It is only implemented to maintain backwards compatibility Currently, the only user is NetMaster

Enumerator:
phnMIPSession A Mobile IP session exists.

enum _PhnOneXProtRevType

This is now deprecated. It is only implemented to maintain backwards compatibility Currently, the only user is NetMaster

Enumerator:
phnOneXStatusPRevNoSvc | Service is not available.
phnOneXStatusPRev1 | J-STD-008 service is in use.
phnOneXStatusPRev3 | IS-95A service is in use.
phnOneXStatusPRev4 | IS-95B service is in use.
phnOneXStatusPRev6 | IS-2000 release 0 service is in use.
phnOneXStatusPRev7 | IS-2000 release A service is in use.

enum _PhnPacketDataEndStatusEnum

List of errors on why a data call was disconnected.

Enumerator:
phnPacketDataEndStatusUnknown | Unknown end status
phnPacketDataEndStatusNormal | Normal
phnPacketDataEndStatusReorder | reoder
phnPacketDataEndStatusRetry | retry
phnPacketDataEndStatusTimeout | call
phnPacketDataEndStatusIntercept | Intercept
phnPacketDataEndStatusReject | Service Option rejected
phnPacketDataEndStatusNoReason | No reason given
phnPacketDataEndStatusAuthFailed | authentication failed
phnPacketDataEndStatusDropped | dropped call
phnPacketDataEndStatusLast | place holder for last

enum _PhnPacketDataSessionType

Describes the current packet data session state. Currently there are 3 states. Active, dormant, or none.

Enumerator:
phnPacketDataSessionNone | No packet data session exists.
phnPacketDataSessionDormant | Packet data session dormant
phnPacketDataSessionActive | Packet data session active

enum _PhnRoamPrefSelectionTypeEnum

This defines the roaming mode of the radio.

Enumerator:
phnRoamPrefHomeOnly | Home network only (no roaming)
phnRoamPrefAny | Any network (roaming allowed)
phnRoamPrefRoamOnly | Roam network only (roaming only)
phnRoamPrefLast | end of list enum

enum GSMCLIPStatus

GSM CLIP Subscription Status

enum GSMCLIRDisplayStatus

GSM CLIR Display Status

Enumerator:
gsmCLIRSubscription presentation indicator is used according to the subscription of the CLIR service

enum PhnBarFacilityTypeEnum

Phone call barring options

enum PhnCallControlTypeEnum

Call Control Codes

enum PhnCLIRStatus

Enumerator:
clirNotProvisioned | sent: restricted presentation of the calling line
clirProvisioned | not sent: don't restrict presentation of the calling line
clirUnknown | status not available
clirTemporaryRestricted | not sent, override allowed
clirTemporaryAllowed | sent: override allowed

enum PhnMMIActionCodeEnum

MMI Action Code

enum PhnMMIServiceCodeEnum

MMI Service Code

Enumerator:
mmiServiceBAOC | bar all outging calls
mmiServiceBAOIC | bar all outging international calls
mmiServiceBAOICX | bar all outging international calls expect home
mmiServiceBAIC | bar all incoming calls
mmiServiceBAICR | bar all incoming calls while roaming
mmiServiceAllBarringServ | bar all services
mmiServiceAllOutBarringServ | bar all outgoing services
mmiServiceAllInBarringServ | bar all incoming services
mmiServiceChangeBarPwd | Change barring password
mmiServiceUnimplemented | defined by GSM standard but not implemented in our phone

enum PhnMsgBoxEnum

Enumerator:
PhnMsgBoxTypeMAX THIS MUST BE LAST ENTRY.... NOT A VALID VALUE

enum PhnOperatorStatus

Phone operator status

enum PhnRoamStatusEnum

Enumerator:
PhnRoamStatusEnhancedIndicator If this is the roaming status, call PhnLibGetEnhancedRoamIndicator

enum PhnTeleserviceMmiCodeType

Telephone Service MMI code Types

enum PhnTeleserviceType

Telephone Service Types

Enumerator:
phnTeleserviceDefault Voice + Data + Fax

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:44 2006 for Palm API Guide


HsPhonePower.h File Reference

Detailed Description

Header File for Phone Library API ---- POWER CATEGORY.

Notes: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the POWER category. This category provides routines to query & manage the radio power.

Include dependency graph for HsPhonePower.h:

Functions

  • Err PhnLibSetModulePower (UInt16 refNum, Boolean on)
  • PhnPowerType PhnLibModulePowered (UInt16 refNum)
  • Err PhnLibContinuePhonePowerOn (UInt16 refNum)
  • Err PhnLibContinuePhonePowerOff (UInt16 refNum)

Function Documentation

Err PhnLibContinuePhonePowerOff ( UInt16 refNum )

Parameters:
refNum,: IN:
Return values:
Err Error code.

Err PhnLibContinuePhonePowerOn ( UInt16 refNum )

Parameters:
refNum,: IN:
Return values:
Err Error code.

PhnPowerType PhnLibModulePowered ( UInt16 refNum )

Parameters:
refNum,: IN:
Return values:
Err Error code.

Err PhnLibSetModulePower | ( | UInt16 | refNum,
 |  | Boolean | on
 | ) |

Parameters:
refNum,: IN:
on,: IN:
Return values:
Err Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:45 2006 for Palm API Guide


HsPhoneSecurity.h File Reference

Detailed Description

Header File for Phone Library API ---- SECURITY CATEGORY.

Notes: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the public portion of the Security category. These API calls are used to protect access to device and phone features.

Include dependency graph for HsPhoneSecurity.h:

Functions

  • Err PhnLibGetPhoneLock (UInt16 refNum, Boolean *lock, Boolean *autoLockCheckBoxState)
  • Err PhnLibSetPhoneLock (UInt16 refNum, Boolean enable, PhnLockMode lockMode, CharPtr password)
  • Err PhnLibSetOperatorLock (UInt16 refNum, UInt16 facilityType, Boolean enable, CharPtr password)
  • Err PhnLibGetRemainingPasswordTries (UInt16 refNum, Int16 *pinTries, Int16 *pin2Tries, Int16 *pukTries, Int16 *puk2Tries)
  • Err PhnLibCRSM (UInt16 refNum, UInt16 command, UInt32 fileId, UInt16 p1, UInt16 p2, UInt16 p3, UInt8 *data, UInt16 dataSize, UInt16 *sw1, UInt16 *sw2, char **response, UInt16 *responseSize)

Function Documentation

Err PhnLibGetPhoneLock | ( | UInt16 | refNum,
 |  | Boolean * | lock,
 |  | Boolean * | autoLockCheckBoxState
 | ) |

Parameters:
refNum,: IN:
lock,: IN:
autoLockCheckBoxState,: IN:
Return values:
Err Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:46 2006 for Palm API Guide


HsPhoneSecurityTypes.h File Reference

Detailed Description

Header File for Phone Library API ---- NETWORK CATEGORY.

NOTES: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the Security category. These API calls are used to interact with the wireless network.

Include dependency graph for HsPhoneSecurityTypes.h:

Defines

  • #define isValidPhnPasswordType(p) (p <= phnPasswordBarrAC)

Typedefs

  • typedef UInt8 PhnPasswordType

Enumerations

  • enum PhnPasswordTypeEnum {
    phnPasswordUnknown,
    phnPasswordNone,
    phnPasswordSIMPIN,
    phnPasswordSIMPUK,
    phnPasswordPhSIMPIN,
    phnPasswordPh1SIMPIN,
    phnPasswordPh1SIMPUK,
    phnPasswordSIMPIN2,
    phnPasswordSIMPUK2,
    phnPasswordNetworkPIN,
    phnPasswordNetworkPUK,
    phnPasswordNetworkSubsetPIN,
    phnPasswordNetworkSubsetPUK,
    phnPasswordServiceProviderPIN,
    phnPasswordServiceProviderPUK,
    phnPasswordCorporatePIN,
    phnPasswordCorporatePUK,
    phnPasswordBarrAO,
    phnPasswordBarrOI,
    phnPasswordBarrOX,
    phnPasswordBarrAI,
    phnPasswordBarrIR,
    phnPasswordBarrAB,
    phnPasswordBarrAG,
    phnPasswordBarrAC
    }

Define Documentation

#define isValidPhnPasswordType ( p ) (p <= phnPasswordBarrAC)

workaround for differing header files in sdk-3.5 and sdk-internal

Enumeration Type Documentation

enum PhnPasswordTypeEnum

Phone password types See GSM 07.07, section 8.3 for a list of passwords. The following list is based on on version 6.2.0 of the recommendation.

It is assumed that all PINs and PUKs below are network-based PINS and PUKs. Function Change() uses a different timeout for such PINs and/or PUKs.

Enumerator:
phnPasswordUnknown | FAULT or none of the strings below
phnPasswordNone | READY
phnPasswordSIMPIN | SIM PIN
phnPasswordSIMPUK | SIM PUK
phnPasswordPhSIMPIN | PH-SIM PIN
phnPasswordPh1SIMPIN | PH-FSIM PIN
phnPasswordPh1SIMPUK | PH-FSIM PUK
phnPasswordSIMPIN2 | SIM PIN2
phnPasswordSIMPUK2 | SIM PUK2
phnPasswordNetworkPIN | PH-NET PIN
phnPasswordNetworkPUK | PH-NET PUK
phnPasswordNetworkSubsetPIN | PH-NETSUB PIN
phnPasswordNetworkSubsetPUK | PH-NETSUB PUK
phnPasswordServiceProviderPIN | PH-SP PIN
phnPasswordServiceProviderPUK | PH-SP PUK
phnPasswordCorporatePIN | PH-CORP PIN
phnPasswordCorporatePUK | PH-CORP PUK
phnPasswordBarrAO | all outgoing call
phnPasswordBarrOI | outgoing intÕl calls
phnPasswordBarrOX | outgoing intÕl calls except to home country
phnPasswordBarrAI | all incoming calls
phnPasswordBarrIR | incoming calls when roaming outside home country
phnPasswordBarrAB | all barring services
phnPasswordBarrAG | all outgoing barring services
phnPasswordBarrAC | all incoming barring services

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:46 2006 for Palm API Guide


HsPhoneSMS.h File Reference

Detailed Description

Header File for Phone Library API ---- SMS CATEGORY.

Notes: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the SMS category. These API calls are used to send/receive Short Message Service (SMS) messages.

Include dependency graph for HsPhoneSMS.h:

Functions

  • PhnAddressHandle PhnLibNewAddress (UInt16 refNum, const CharPtr number, PhnDatabaseID id)
  • CharPtr PhnLibGetField (UInt16 refNum, PhnAddressHandle address, PhnAddressField field)
    This function returns the field’s value for a given address in a newly allocated block. This function returns 0 if there was an error while retrieving the data.
  • PhnDatabaseID PhnLibGetID (UInt16 refNum, PhnAddressHandle address)
  • Err PhnLibSetField (UInt16 refNum, PhnAddressHandle address, PhnAddressField field, const char *data)
    This function lets the specified field of address to the given data. This function returns 0 if the field was modified without an error.
  • Err PhnLibSetNumber (UInt16 refNum, PhnAddressHandle address, const char *number)
  • Err PhnLibSetID (UInt16 refNum, PhnAddressHandle address, PhnDatabaseID id)
  • char * PhnLibAddressToText (UInt16 refNum, PhnAddressHandle address, SMSAddressFormat format)
  • Boolean PhnLibHasName (UInt16 refNum, PhnAddressHandle address)
  • Boolean PhnLibEqual (UInt16 refNum, PhnAddressHandle a, PhnAddressHandle b)
  • DmOpenRef PhnLibGetDBRef (UInt16 refNum)
  • Err PhnLibReleaseDBRef (UInt16 refNum, DmOpenRef db)
  • PhnDatabaseID PhnLibNewMessage (UInt16 refNum, SMSMessageType type)
    Create a new message of the given message type and return the ID of the new record in the message database. All fields are either empty (e.g. message’s text) or contain default values (e.g. sending options).
  • Err PhnLibDeleteMessage (UInt16 refNum, PhnDatabaseID msgID, Boolean archive)
    This function deletes the message with the given msgID from the message database.
  • Err PhnLibSendMessage (UInt16 refNum, PhnDatabaseID msgID, Boolean progress)
    This function sends the message to all the recipients.
  • Err PhnLibSendPendingMessages (UInt16 refNum)
  • Err PhnLibSetText (UInt16 refNum, PhnDatabaseID msgID, const char *data, Int16 size)
    This function sets the text of the message to the given text.
  • Err PhnLibSetDate (UInt16 refNum, PhnDatabaseID msgID, UInt32 date)
    This function sets the date of the given message. The date must be given in Palm OS format (as returned by TimGetSeconds).
  • Err PhnLibSetOptions (UInt16 refNum, PhnDatabaseID msgID, const SMSSendOptions *options)
    This function updates the sending options for the given message.
  • Err PhnLibSetAddresses (UInt16 refNum, PhnDatabaseID msgID, const PhnAddressList list)
    This function updates the list of addresses with the given list of addresses.
  • Err PhnLibSetStatus (UInt16 refNum, PhnDatabaseID msgID, SMSMessageStatus status)
    This function sets the status of the given message.
  • Err PhnLibSetFlags (UInt16 refNum, PhnDatabaseID msgID, UInt32 flags)
    This function updates a message’s flags.
  • Err PhnLibSetOwner (UInt16 refNum, PhnDatabaseID msgID, UInt32 owner)
    This function updates the given message’s owner.
  • Err PhnLibGetText (UInt16 refNum, PhnDatabaseID msgID, MemHandle *data)
    This function copies the text of the message into a new block of memory that must be disposed of by the caller.
  • Err PhnLibGetDate (UInt16 refNum, PhnDatabaseID msgID, UInt32 *date)
    This function returns the date of the given message in Palm OS format.
  • Err PhnLibGetOptions (UInt16 refNum, PhnDatabaseID msgID, SMSSendOptions *options)
    This function returns the sending options for the given message.
  • Err PhnLibGetAddresses (UInt16 refNum, PhnDatabaseID msgID, PhnAddressList *list)
    This function returns the list of addresses for the given message.
  • Err PhnLibGetStatus (UInt16 refNum, PhnDatabaseID msgID, SMSMessageStatus *status)
    This function returns the status field of the message.
  • Err PhnLibGetFlags (UInt16 refNum, PhnDatabaseID msgID, UInt32 *flags)
    This function returns the message’s flags.
  • Err PhnLibGetOwner (UInt16 refNum, PhnDatabaseID msgID, UInt32 *owner)
    This function returns the message’s owner.
  • Err PhnLibGetType (UInt16 refNum, PhnDatabaseID msgID, SMSMessageType *type)
    This function returns the message’s type. A client application typically uses the type to map messages to categories.
  • Boolean PhnLibIsLegalCharacter (UInt16 refNum, char c)
    This function returns true if the given Palm OS character is a legal GSM character. If this function returns false, the given character does not exist within the GSM alphabet.
  • char PhnLibMapCharacter (UInt16 refNum, char c)
    This function maps the given Palm OS character to its equivalent in the GSM alphabet.
  • Err PhnLibSetServiceCentreAddress (UInt16 refNum, const PhnAddressHandle address)
    This function sets the number of the service center to be used for sending the SMS messages.
  • Err PhnLibGetServiceCentreAddress (UInt16 refNum, PhnAddressHandle *address)
    This function returns the number of the service center currently used for sending messages in a newly allocated address.
  • Int16 PhnLibLength (UInt16 refNum, const char *text, Boolean inMessages, Boolean substitution)
    This function returns the length of the given text in characters or messages.
  • Err PhnLibGetLengthDetails (UInt16 refNum, const char *text, const char *address, PhnLibLengthInfoType *info)
  • const char * PhnLibGetSubstitution (UInt16 refNum, char c)
    This function returns the substitution string for a given GSM character.
  • PhnAddressList PhnLibNewAddressList (UInt16 refNum)
    This function returns a new address list. The list is initially empty and must be disposed of by the caller using PhnLibDisposeAddressList() or MemHandleFree().
  • Err PhnLibDisposeAddressList (UInt16 refNum, PhnAddressList list)
    This function disposes of the memory used by the given address list. It should be called after your done with PhnLibNewAddressList().
  • Err PhnLibAddAddress (UInt16 refNum, PhnAddressList list, const PhnAddressHandle address)
    This function adds a copy of address to the end of list. The address is not disposed of.
  • Err PhnLibGetNth (UInt16 refNum, const PhnAddressList list, Int16 index, PhnAddressHandle *address)
    This function retrieves an item with the given index from list and returns it as a new block on the heap specified by address.
  • Err PhnLibSetNth (UInt16 refNum, PhnAddressList list, Int16 index, const PhnAddressHandle address)
    This function replaces the data of the item with the given index from list by the given address.
  • Err PhnLibCount (UInt16 refNum, PhnAddressList list, UInt16 *count)
    This function returns the length of the given list. If list is 0, this function returns phnErrParam.
  • Err PhnLibGetSMSRingInfo (UInt16 refNum, PhnRingingInfoPtr info)
  • Err PhnLibSetSMSRingInfo (UInt16 refNum, PhnRingingInfoPtr info)
  • Err PhnLibGetSMSGateway (UInt16 refNum, char **smsGateway)
  • Err PhnLibGetSMSPreference (UInt16 refNum, PhnSMSPrefPtr prefP)
  • Err PhnLibSetSMSPreference (UInt16 refNum, PhnSMSPrefPtr prefP)
  • Err PhnLibAPGetNth (UInt16 refNum, PhnAddressList list, Int16 index, PhnAddressHandle *address)
  • Err PhnLibSendSMSMTAck (UInt16 refNum, UInt8 transactionId, Boolean ack)
  • Err PhnLibQuerySMSMT (UInt16 refNum)
  • Err PhnLibSetSMSCallbackNumber (UInt16 refNum, const CharPtr number, PhnDatabaseID msgID)

Function Documentation

Err PhnLibAddAddress | ( | UInt16 | refNum,
 |  | PhnAddressList | list,
 |  | const PhnAddressHandle | address
 | ) |

This function adds a copy of address to the end of list. The address is not disposed of.

Parameters:
refNum,: IN:
list,: IN:
address,: IN:
Return values:
Err Error code.

char* PhnLibAddressToText | ( | UInt16 | refNum,
 |  | PhnAddressHandle | address,
 |  | SMSAddressFormat | format
 | ) |

Parameters:
refNum,: IN:
address,: IN:
format,: IN:
Return values:
Char

Err PhnLibAPGetNth | ( | UInt16 | refNum,
 |  | PhnAddressList | list,
 |  | Int16 | index,
 |  | PhnAddressHandle * | address
 | ) |

Parameters:
refNum,: IN:
list,: IN:
index,: IN:
Return values:
Err Error code.

Err PhnLibCount | ( | UInt16 | refNum,
 |  | PhnAddressList | list,
 |  | UInt16 * | count
 | ) |

This function returns the length of the given list. If list is 0, this function returns phnErrParam.

Parameters:
refNum,: IN:
list,: IN:
count,: IN:
Return values:
Err Error code.

Err PhnLibDeleteMessage | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | Boolean | archive
 | ) |

This function deletes the message with the given msgID from the message database.

Parameters:
refNum,: IN:
msgID,: IN:
archive,: IN:
Return values:
This function returns 0 if there was no error during the deletion of the record. If there is no message with the given id, this function returns phnErrUnknownID.

Err PhnLibDisposeAddressList | ( | UInt16 | refNum,
 |  | PhnAddressList | list
 | ) |

This function disposes of the memory used by the given address list. It should be called after your done with PhnLibNewAddressList().

Parameters:
refNum,: IN:
list,: IN:
Return values:
Err Error code.

Boolean PhnLibEqual | ( | UInt16 | refNum,
 |  | PhnAddressHandle | a,
 |  | PhnAddressHandle | b
 | ) |

Parameters:
refNum,: IN:
a,: IN:
b,: IN:
Return values:
Boolean

Err PhnLibGetAddresses | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | PhnAddressList * | list
 | ) |

This function returns the list of addresses for the given message.

Parameters:
refNum,: IN:
msgID,: IN:
list,: IN:
Return values:
Err Error code.

Err PhnLibGetDate | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | UInt32 * | date
 | ) |

This function returns the date of the given message in Palm OS format.

Parameters:
refNum,: IN:
msgID,: IN:
date,: IN:
Return values:
Err Error code.

DmOpenRef PhnLibGetDBRef ( UInt16 refNum )

Parameters:
refNum,: IN:
Return values:
DmOpenRef

CharPtr PhnLibGetField | ( | UInt16 | refNum,
 |  | PhnAddressHandle | address,
 |  | PhnAddressField | field
 | ) |

This function returns the field’s value for a given address in a newly allocated block. This function returns 0 if there was an error while retrieving the data.

Parameters:
refNum,: IN:
address,: IN:
fied,: IN:
Return values:
CharPtr

Err PhnLibGetFlags | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | UInt32 * | flags
 | ) |

This function returns the message’s flags.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
msgID,: IN:
flags,: IN:
Return values:
Err Error code.

PhnDatabaseID PhnLibGetID | ( | UInt16 | refNum,
 |  | PhnAddressHandle | address
 | ) |

Parameters:
refNum,: IN:
address,: IN:
Return values:
PhnDatabaseID

Err PhnLibGetLengthDetails | ( | UInt16 | refNum,
 |  | const char * | text,
 |  | const char * | address,
 |  | PhnLibLengthInfoType * | info
 | ) |

Parameters:
refNum,: IN:
text,: IN:
address,: IN:
info,: IN:
Return values:
Err Error code.

Err PhnLibGetNth | ( | UInt16 | refNum,
 |  | const PhnAddressList | list,
 |  | Int16 | index,
 |  | PhnAddressHandle * | address
 | ) |

This function retrieves an item with the given index from list and returns it as a new block on the heap specified by address.

Parameters:
refNum,: IN:
list,: IN:
index,: IN:
address,: IN:
Return values:
Err Error code.

Err PhnLibGetOptions | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | SMSSendOptions * | options
 | ) |

This function returns the sending options for the given message.

Parameters:
refNum,: IN:
msgID,: IN:
options,: IN:
Return values:
Err Error code.

Err PhnLibGetOwner | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | UInt32 * | owner
 | ) |

This function returns the message’s owner.

Parameters:
refNum,: IN: Library reference number returned by HsGetPhoneLibrary().
msgID,: IN:
owner,: IN:
Return values:
Error code.

Err PhnLibGetServiceCentreAddress | ( | UInt16 | refNum,
 |  | PhnAddressHandle * | address
 | ) |

This function returns the number of the service center currently used for sending messages in a newly allocated address.

Parameters:
refNum,: IN:
address,: IN:
Return values:
Error code.

Err PhnLibGetSMSGateway | ( | UInt16 | refNum,
 |  | char ** | smsGateway
 | ) |

Parameters:
refNum,: IN:
smsGateway,: IN:
Return values:
Err Error code.

Err PhnLibGetSMSPreference | ( | UInt16 | refNum,
 |  | PhnSMSPrefPtr | prefP
 | ) |

Parameters:
refNum,: IN:
prefP,: IN:
Return values:
Err Error code.

Err PhnLibGetSMSRingInfo | ( | UInt16 | refNum,
 |  | PhnRingingInfoPtr | info
 | ) |

Parameters:
refNum,: IN:
info,: IN:
Return values:
Err Error code.

Err PhnLibGetStatus | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | SMSMessageStatus * | status
 | ) |

This function returns the status field of the message.

Parameters:
refNum,: IN:
msgID,: IN:
status,: IN:
Return values:
Err Error code.

const char* PhnLibGetSubstitution | ( | UInt16 | refNum,
 |  | char | c
 | ) |

This function returns the substitution string for a given GSM character.

Parameters:
refNum,: IN:
c,: IN:
Return values:
const

Err PhnLibGetText | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | MemHandle * | data
 | ) |

This function copies the text of the message into a new block of memory that must be disposed of by the caller.

Parameters:
refNum,: IN:
msgID,: IN:
data,: IN:
Return values:
Err Error code.

Err PhnLibGetType | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | SMSMessageType * | type
 | ) |

This function returns the message’s type. A client application typically uses the type to map messages to categories.

Parameters:
refNum,: IN:
msgID,: IN:
type,: IN:
Return values:
Err Error code.

Boolean PhnLibHasName | ( | UInt16 | refNum,
 |  | PhnAddressHandle | address
 | ) |

Parameters:
refNum,: IN:
address,: IN:
Return values:
Boolean

Boolean PhnLibIsLegalCharacter | ( | UInt16 | refNum,
 |  | char | c
 | ) |

This function returns true if the given Palm OS character is a legal GSM character. If this function returns false, the given character does not exist within the GSM alphabet.

Parameters:
refNum,: IN:
c,: IN:
Return values:
Boolean

Int16 PhnLibLength | ( | UInt16 | refNum,
 |  | const char * | text,
 |  | Boolean | inMessages,
 |  | Boolean | substitution
 | ) |

This function returns the length of the given text in characters or messages.

Parameters:
refNum,: IN:
text,: IN:
inMessages,: IN:
substitution,: IN:
Return values:
Int16

char PhnLibMapCharacter | ( | UInt16 | refNum,
 |  | char | c
 | ) |

This function maps the given Palm OS character to its equivalent in the GSM alphabet.

Parameters:
refNum,: IN:
c,: IN:
Return values:
char

PhnAddressHandle PhnLibNewAddress | ( | UInt16 | refNum,
 |  | const CharPtr | number,
 |  | PhnDatabaseID | id
 | ) |

Parameters:
refNum,: IN:
number,: IN:
id,: IN:
Return values:
PhnAddressHandle

PhnAddressList PhnLibNewAddressList ( UInt16 refNum )

This function returns a new address list. The list is initially empty and must be disposed of by the caller using PhnLibDisposeAddressList() or MemHandleFree().

Parameters:
refNum,: IN:
Return values:
PhnAddressList

PhnDatabaseID PhnLibNewMessage | ( | UInt16 | refNum,
 |  | SMSMessageType | type
 | ) |

Create a new message of the given message type and return the ID of the new record in the message database. All fields are either empty (e.g. message’s text) or contain default values (e.g. sending options).

Parameters:
refNum,: IN:
type,: IN: Incoming or Outcoming message. See SMSMessageType for more details.
Return values:
Returns either the ID of the new message record or phnErrUnknownID if there was not sufficient memory to allocate a new message.

Err PhnLibQuerySMSMT ( UInt16 refNum )

Parameters:
refNum,: IN:
Return values:
Err Error code.

Err PhnLibReleaseDBRef | ( | UInt16 | refNum,
 |  | DmOpenRef | db
 | ) |

Parameters:
refNum,: IN:
db,: IN:
Return values:
Err Error code.

Err PhnLibSendMessage | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | Boolean | progress
 | ) |

This function sends the message to all the recipients.

Parameters:
refNum,: IN:
msgID,: IN:
progress,: IN:
Return values:
phnErrUnknownID,: If there is no message with the given ID. phnErrIllegalStatus: If the message’s status is not kNone or kPending phnErrNotAllowed: If the error flag is set. It is not permitted to send messages when the error flag is set.

Err PhnLibSendPendingMessages ( UInt16 refNum )

Parameters:
refNum,: IN:
Return values:
Err Error code.

Err PhnLibSendSMSMTAck | ( | UInt16 | refNum,
 |  | UInt8 | transactionId,
 |  | Boolean | ack
 | ) |

Parameters:
refNum,: IN:
transactionID,: IN:
acK,: IN:
Return values:
Err Error code.

Err PhnLibSetAddresses | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | const PhnAddressList | list
 | ) |

This function updates the list of addresses with the given list of addresses.

Parameters:
refNum,: IN:
msgID,: IN:
list,: IN:
Return values:
Err Error code.

Err PhnLibSetDate | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | UInt32 | date
 | ) |

This function sets the date of the given message. The date must be given in Palm OS format (as returned by TimGetSeconds).

Parameters:
refNum,: IN:
msgID,: IN:
date,: IN:
Return values:
Err Error code.

Err PhnLibSetField | ( | UInt16 | refNum,
 |  | PhnAddressHandle | address,
 |  | PhnAddressField | field,
 |  | const char * | data
 | ) |

This function lets the specified field of address to the given data. This function returns 0 if the field was modified without an error.

Parameters:
refNum,: IN:
address,: IN:
field,: IN:
data,: IN:
Return values:
Err Error Code.

Err PhnLibSetFlags | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | UInt32 | flags
 | ) |

This function updates a message’s flags.

Parameters:
refNum,: IN:
msgID,: IN:
flags,: IN:
Return values:
Err Error code.

Err PhnLibSetID | ( | UInt16 | refNum,
 |  | PhnAddressHandle | address,
 |  | PhnDatabaseID | id
 | ) |

Parameters:
refNum,: IN:
address,: IN:
id,: IN:
Return values:
Err Error code.

Err PhnLibSetNth | ( | UInt16 | refNum,
 |  | PhnAddressList | list,
 |  | Int16 | index,
 |  | const PhnAddressHandle | address
 | ) |

This function replaces the data of the item with the given index from list by the given address.

Parameters:
refNum,: IN:
list,: IN:
index,: IN:
address,: IN:
Return values:
Err Error code.

Err PhnLibSetNumber | ( | UInt16 | refNum,
 |  | PhnAddressHandle | address,
 |  | const char * | number
 | ) |

Parameters:
refNum,: IN:
address,: IN:
number,: IN:
Return values:
Err Error Code.

Err PhnLibSetOptions | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | const SMSSendOptions * | options
 | ) |

This function updates the sending options for the given message.

Parameters:
refNum,: IN:
msgID,: IN:
options,: IN:
Return values:
Err Error code.

Err PhnLibSetOwner | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | UInt32 | owner
 | ) |

This function updates the given message’s owner.

Parameters:
refNum,: IN:
msgID,: IN:
owner,: IN
Return values:
Err Error code.

Err PhnLibSetServiceCentreAddress | ( | UInt16 | refNum,
 |  | const PhnAddressHandle | address
 | ) |

This function sets the number of the service center to be used for sending the SMS messages.

Parameters:
refNum,: IN:
address,: IN:
Return values:
Err Error code.

Err PhnLibSetSMSCallbackNumber | ( | UInt16 | refNum,
 |  | const CharPtr | number,
 |  | PhnDatabaseID | msgID
 | ) |

Parameters:
refNum,: IN:
number,: IN:
msgID,: IN:
Return values:
Err Error code.

Err PhnLibSetSMSPreference | ( | UInt16 | refNum,
 |  | PhnSMSPrefPtr | prefP
 | ) |

Parameters:
refNum,: IN:
prefP,: IN:
Return values:
Err Error code.

Err PhnLibSetSMSRingInfo | ( | UInt16 | refNum,
 |  | PhnRingingInfoPtr | info
 | ) |

Parameters:
refNum,: IN:
info,: IN:
Return values:
Err Error code.

Err PhnLibSetStatus | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | SMSMessageStatus | status
 | ) |

This function sets the status of the given message.

Parameters:
refNum,: IN:
msgID,: IN:
status,: IN:
Return values:
Err Error code.

Err PhnLibSetText | ( | UInt16 | refNum,
 |  | PhnDatabaseID | msgID,
 |  | const char * | data,
 |  | Int16 | size
 | ) |

This function sets the text of the message to the given text.

Parameters:
refNum,: IN:
msgID,: IN:
data,: IN:
size,: IN:
Return values:
0,: if the text was updated successfully. phnErrIllegalChars: If the text contains illegal characters

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:47 2006 for Palm API Guide


HsPhoneSMSTypes.h File Reference

Detailed Description

Header File for Phone Library API ---- NETWORK CATEGORY.

NOTES: All implementations of the Handspring Phone Library support a common API. This API is broken up into various categories for easier management. This file defines the SMS category. These API calls are used to interact with the wireless network.

Include dependency graph for HsPhoneSMSTypes.h:

Data Structures

  • struct Address
  • struct AddrDescriptor
  • struct AddressType
  • struct AddressAppRecordHeader
  • struct AddressAppRecord
  • struct PhnSMSPrefType
  • struct SMSSendOptions
  • struct SmsHeader
  • struct NBSNotificationEventType
  • struct PhnLibLengthInfoType
  • struct _PhnLibMMSServerInfo

Identifier elements definitions

  • #define NBSHeaderID 0x00
  • #define NBSHeaderIDLen 0x03
  • #define Addressing8bitID 0x04
  • #define Addressing8bitIDLen 0x02
  • #define Addressing16bitID 0x05
  • #define Addressing16bitIDLen 0x04

Text Header elements

  • #define NBSHeaderEscapeSeq "//"
  • #define NBSTextHeader "//SCK"
  • #define NBSTextHeaderLength 5

8bit addressing text header lengths, not including the //SCK

  • #define Full8bitTextHeader 0x0A
  • #define Minimum8bitTextHeader 0x02

16bit addressing text header lengths, not including the //SCKL

  • #define Full16bitTextHeader 0x0F
  • #define Minimum16bitTextHeader 0x05

NBS Port Numbers (Nokia Smart Messaging Spec)

  • #define NBSPort_MimeVCard 0xE2
  • #define NBSPort_MimeVCalendar 0xE4

Defines

  • #define isValidAddressAppRecordFieldEnum(x) ((x >= kName) && (x < kRecordFieldEnumCount))
  • #define TextHeaderTerminator ' '
  • #define phnNBSEvent 'Hnbs'
  • #define isValidSMSMessageType(m) ((m >= kMTIncoming) && (m <= kMTOutgoing))
  • #define isValidSMSMessageStatus(m) ((m >= kNone) && (m <= kSent))
  • #define kMMSStringMaxLen 128
  • #define kMMSPixPlaceMaxLen 20
  • #define PhnLibMMSServerInfoSettingsMajorVersion 0x0001
  • #define PhnLibMMSServerInfoSettingsMinorVersion 0x0000
  • #define PhnLibMMSServerInfoVersion (((UInt32)PhnLibMMSServerInfoSettingsMajorVersion << 16) | PhnLibMMSServerInfoSettingsMinorVersion)

Typedefs

  • typedef enum AddressAppRecordFieldEnum AddressAppRecordFieldEnum
  • typedef UInt8 AddressAppPhoneLabelType
  • typedef Address Address
  • typedef AddrDescriptor AddrDescriptor
  • typedef AddressType AddressType
  • typedef AddressAppRecordHeader AddressAppRecordHeader
  • typedef struct PhnSMSPrefType * PhnSMSPrefPtr
  • typedef NBSNotificationEventType NBSNotificationEventType
  • typedef UInt32 SmsCauseCode
  • typedef UInt8 SmsErrorCode
  • typedef _PhnLibMMSServerInfo PhnLibMMSServerInfoType

Enumerations

  • enum AddressAppRecordFieldEnum {
    kName,
    kFirstName,
    kCompany,
    kPhone1,
    kPhone2,
    kPhone3,
    kPhone4,
    kPhone5,
    kAddress,
    kCity,
    kState,
    kZipCode,
    kCountry,
    kTitle,
    kCustom1,
    kCustom2,
    kCustom3,
    kCustom4,
    kNote,
    kRecordFieldEnumCount
    }
  • enum AddressAppPhoneLabel {
    addrWorkLabel,
    addrHomeLabel,
    addrFaxLabel,
    addrOtherLabel,
    addrEmailLabel,
    addrMainLabel,
    addrPagerLabel,
    addrMobileLabel,
    addrNoLabel
    }
  • enum SMSMessageType {
    kMTIncoming,
    kMTOutgoing
    }
  • enum SMSMessageStatus {
    kNone,
    kReceiving,
    kReceived,
    kPending,
    kSending,
    kSent
    }
  • enum SMSMessageFlags {
    kGreekSymbols = 1L << 0,
    kMissingPart = 1L << 1,
    kAutoDelete = 1L << 2,
    kNotification = 1L << 3,
    kDontEncode = 1L << 4,
    kSubstitution = 1L << 5,
    kFailed = 1L << 6,
    kStatusReport = 1L << 7,
    kFreeReply = 1L << 8,
    kInternetEMail = 1L << 9,
    kTextSegments = 1L << 10,
    kSMSErrorType1 = 1L << 11,
    kSMSErrorType2 = 1L << 12,
    kSMSErrorType3 = 1L << 13,
    kSMSHighPriority = 1L << 14,
    kSMSLowPriority = 1L << 15,
    kRead = 1L << 16,
    kDeferredDelivery = 1L << 17,
    kWAPMsg = 1L << 18
    }
  • enum SMSAddressFormat {
    smsFmtIgnoreKind = 0,
    smsFmtMatchKind = 8,
    smsFmtExceptKind = 16,
    smsFmtAllKinds = 24,
    smsFmtLastNameFirst = 32,
    smsFmtShortLabel = 64
    }
  • enum {
    kParseError = -1,
    kDoneParsing = 0,
    kParseInformationID,
    kParseInformationLength,
    kParseInformationData
    }
  • enum _SmsCauseCode {
    SmsCauseAddressVacant = 0,
    SmsCauseAddressTranslationFailure,
    SmsCauseNetworkResourceShortage,
    SmsCauseNetworkFailure,
    SmsCauseInvalidTeleserviceId,
    SmsCauseOtherNetworkProblem,
    SmsCauseOtherNetworkProblemMoreFirst = 6,
    SmsCauseOtherNetworkProblemMoreLast = 31,
    SmsCauseNoPageResponse = 32,
    SmsCauseDestinationBusy,
    SmsCauseNoAck,
    SmsCauseDestinationResourceShortage,
    SmsCauseSmsDeliveryPostponed,
    SmsCauseDestinationOutOfService,
    SmsCauseDestinationNoLongerAtThisAddress,
    SmsCauseOtherTerminalProblem,
    smsCauseOtherTerminalProblemMoreFirst = 40,
    SmsCauseOtherTerminalProblemMoreLast = 47,
    SmsCauseSmsDeliveryPostponedMoreFirst = 48,
    SmsCauseSmsDeliveryPostponedMoreLast = 63,
    SmsCauseRadioIfResourceShortage = 64,
    SmsCauseRadioIfIncompatible,
    SmsCauseOtherRadioIfProblem,
    SmsCauseOtherRadioIfProblemMoreFirst = 67,
    SmsCauseOtherRadioIfProblemMoreLast = 95,
    SmsCauseUnexpected_Parm_Size = 96,
    SmsCauseSmsOriginationDenied,
    SmsCauseSmsTerminationDenied,
    SmsCauseSupplServiceNotSupported,
    SmsCauseSmsNotSupported,
    SmsCauseReserved101,
    SmsCauseMissingExpectedParm,
    SmsCauseMissingMandatoryParm,
    SmsCauseUnrecognizedParmValue,
    SmsCauseUnexpectedParmValue,
    SmsCauseUserDataSizeError,
    SmsCauseOtherGeneralProblems,
    SmsCauseOtherGeneralProblemsMoreFirst = 108,
    SmsCauseOtherGeneralProblemsMoreLast = 255
    }
  • enum _SmsErrorCode {
    SmsErrorNone,
    SmsErrorReserved,
    SmsErrorTemporary,
    SmsErrorPermanent
    }

Define Documentation

#define Addressing16bitID 0x05

16-bit address information identifier

#define Addressing16bitIDLen 0x04

4 bytes... src port(2), dest port(2)

#define Addressing8bitID 0x04

8-bit address information identifier

#define Addressing8bitIDLen 0x02

2 bytes... src port(1), dest port(1)

#define Full16bitTextHeader 0x0F

length for full header with 16-bit addressing //SCKLddddoooorrttnn

#define Full8bitTextHeader 0x0A

length for full header with 8-bit addressing //SCKddoorrttnn

#define kMMSPixPlaceMaxLen 20

pix place address

#define kMMSStringMaxLen 128

MMS info structure. URL, MML, and user agent

#define Minimum16bitTextHeader 0x05

length for minimum header with 16-bit addressing //SCKLdddd

#define Minimum8bitTextHeader 0x02

length for minimum header with 8-bit addressing //SCKdd

#define NBSHeaderEscapeSeq "//"

start sequence of the header

#define NBSHeaderID 0x00

NBS fragment header information identifier

#define NBSHeaderIDLen 0x03

three bytes

#define NBSTextHeader "//SCK"

beginning of an NBS text header

#define NBSTextHeaderLength 5

length of the header

#define TextHeaderTerminator ' '

text based headers terminate at the next space

Enumeration Type Documentation

anonymous enum

NBS

enum _SmsCauseCode

SMS error codes obtained from the network in CDMA The first half of the enums are from IS-41D SMS cause codes with the exact binary values as in IS-41D. They are in the range of 0x00 to 0xFF. This does not have the cause codes from the range 0x80000 upwards as the radio doesnt support them

enum _SmsErrorCode

SMS error codes types

enum AddressAppPhoneLabel

Item description here

enum AddressAppRecordFieldEnum

Palm OS address book functions

Enumerator:
kRecordFieldEnumCount must be the last field

enum SMSMessageStatus

Item description here

enum SMSMessageType

SMS stuff

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:48 2006 for Palm API Guide


HsPhoneTrace.h File Reference

Detailed Description

Trace constants, types, and definitions for Phone Library.

Trace Subcomponent IDs. These are used in TraceContext to identify area of Phone Library providing

a particular trace/error entry. These are helpful to allow useful filtering of trace log data.
  • #define PHN_SUBCOMPONENTID_LIB 'LIB!'
  • #define PHN_SUBCOMPONENTID_SMS 'SMS!'
  • #define PHN_SUBCOMPONENTID_NOT 'NOT!'
  • #define PHN_SUBCOMPONENTID_RDO 'RDO!'
  • #define PHN_SUBCOMPONENTID_READ 'READ'
  • #define PHN_SUBCOMPONENTID_WRIT 'WRIT'
  • #define PHN_SUBCOMPONENTID_SIM 'SIM!'
  • #define PHN_SUBCOMPONENTID_STK 'STK!'

Define Documentation

#define PHN_SUBCOMPONENTID_LIB 'LIB!'

general Phone Library (library activation/shutdown, API, etc)

#define PHN_SUBCOMPONENTID_NOT 'NOT!'

Phone Notification Mgr

#define PHN_SUBCOMPONENTID_RDO 'RDO!'

Radio operation

#define PHN_SUBCOMPONENTID_READ 'READ'

low level communication with radio - read

#define PHN_SUBCOMPONENTID_SIM 'SIM!'

sim operation

#define PHN_SUBCOMPONENTID_SMS 'SMS!'

SMS Messaging

#define PHN_SUBCOMPONENTID_STK 'STK!'

sim toolkit

#define PHN_SUBCOMPONENTID_WRIT 'WRIT'

low level communication with radio - write

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:48 2006 for Palm API Guide


HsPhoneTraps.h File Reference

Detailed Description

Traps of all functions exported by the Phone Library.

NOTES:

Defines

  • #define PHN_LIB_TRAP(trapNum) SYS_TRAP(trapNum)
  • #define PhnLibTrapGetLibAPIVersion (0+sysLibTrapCustom)
  • #define PhnLibTrapUninstall (1+sysLibTrapCustom)
  • #define PhnLibTrapRegister (2+sysLibTrapCustom)
  • #define PhnLibTrapFirstAppForService (3+sysLibTrapCustom)
  • #define PhnLibTrapNewAddress (4+sysLibTrapCustom)
  • #define PhnLibTrapGetField (5+sysLibTrapCustom)
  • #define PhnLibTrapGetID (6+sysLibTrapCustom)
  • #define PhnLibTrapSetField (7+sysLibTrapCustom)
  • #define PhnLibTrapSetNumber (8+sysLibTrapCustom)
  • #define PhnLibTrapSetID (9+sysLibTrapCustom)
  • #define PhnLibTrapAddressToText (10+sysLibTrapCustom)
  • #define PhnLibTrapHasName (11+sysLibTrapCustom)
  • #define PhnLibTrapEqual (12+sysLibTrapCustom)
  • #define PhnLibTrapDial (13+sysLibTrapCustom)
  • #define PhnLibTrapSendDTMF (14+sysLibTrapCustom)
  • #define PhnLibTrapDisconnect (15+sysLibTrapCustom)
  • #define PhnLibTrapActivate (16+sysLibTrapCustom)
  • #define PhnLibTrapConference (17+sysLibTrapCustom)
  • #define PhnLibTrapHold (18+sysLibTrapCustom)
  • #define PhnLibTrapGetConnectionInfo (19+sysLibTrapCustom)
  • #define PhnLibTrapSetBarring (20+sysLibTrapCustom)
  • #define PhnLibTrapGetBarring (21+sysLibTrapCustom)
  • #define PhnLibTrapSetForwarding (22+sysLibTrapCustom)
  • #define PhnLibTrapGetForwarding (23+sysLibTrapCustom)
  • #define PhnLibTrapSetCallWaiting (24+sysLibTrapCustom)
  • #define PhnLibTrapGetCallWaiting (25+sysLibTrapCustom)
  • #define PhnLibTrapSetPhoneLock (26+sysLibTrapCustom)
  • #define PhnLibTrapGetPhoneLock (27+sysLibTrapCustom)
  • #define PhnLibTrapSetCLIP (28+sysLibTrapCustom)
  • #define PhnLibTrapGetCLIP (29+sysLibTrapCustom)
  • #define PhnLibTrapSetOperatorLock (30+sysLibTrapCustom)
  • #define PhnLibTrapGetOperatorLock (31+sysLibTrapCustom)
  • #define PhnLibTrapChangePassword (32+sysLibTrapCustom)
  • #define PhnLibTrapPasswordDialog (33+sysLibTrapCustom)
  • #define PhnLibTrapCurrentOperator (34+sysLibTrapCustom)
  • #define PhnLibTrapCurrentProvider (35+sysLibTrapCustom)
  • #define PhnLibTrapGetOperatorList (36+sysLibTrapCustom)
  • #define PhnLibTrapSetOperator (37+sysLibTrapCustom)
  • #define PhnLibTrapGetOwnNumbers (38+sysLibTrapCustom)
  • #define PhnLibTrapSetOwnNumbers (39+sysLibTrapCustom)
  • #define PhnLibTrapGetRingingInfo (40+sysLibTrapCustom)
  • #define PhnLibTrapSetRingingInfo (41+sysLibTrapCustom)
  • #define PhnLibTrapGetToneIDs (42+sysLibTrapCustom)
  • #define PhnLibTrapGetToneName (43+sysLibTrapCustom)
  • #define PhnLibTrapPlayTone (44+sysLibTrapCustom)
  • #define PhnLibTrapStopTone (45+sysLibTrapCustom)
  • #define PhnLibTrapFindEntry (46+sysLibTrapCustom)
  • #define PhnLibTrapSelectAddress (47+sysLibTrapCustom)
  • #define PhnLibTrapGetMicrophone (48+sysLibTrapCustom)
  • #define PhnLibTrapSetMicrophone (49+sysLibTrapCustom)
  • #define PhnLibTrapGetVolume (50+sysLibTrapCustom)
  • #define PhnLibTrapSetVolume (51+sysLibTrapCustom)
  • #define PhnLibTrapRegistered (52+sysLibTrapCustom)
  • #define PhnLibTrapRoaming (53+sysLibTrapCustom)
  • #define PhnLibTrapSignalQuality (54+sysLibTrapCustom)
  • #define PhnLibTrapErrorRate (55+sysLibTrapCustom)
  • #define PhnLibTrapBattery (56+sysLibTrapCustom)
  • #define PhnLibTrapCardInfo (57+sysLibTrapCustom)
  • #define PhnLibTrapSIMInfo (58+sysLibTrapCustom)
  • #define PhnLibTrapGetSIMStatus (59+sysLibTrapCustom)
  • #define PhnLibTrapParamText (60+sysLibTrapCustom)
  • #define PhnLibTrapGetErrorText (61+sysLibTrapCustom)
  • #define PhnLibTrapGetDBRef (62+sysLibTrapCustom)
  • #define PhnLibTrapReleaseDBRef (63+sysLibTrapCustom)
  • #define PhnLibTrapNewMessage (64+sysLibTrapCustom)
  • #define PhnLibTrapDeleteMessage (65+sysLibTrapCustom)
  • #define PhnLibTrapSendMessage (66+sysLibTrapCustom)
  • #define PhnLibTrapSetText (67+sysLibTrapCustom)
  • #define PhnLibTrapSetDate (68+sysLibTrapCustom)
  • #define PhnLibTrapSetOptions (69+sysLibTrapCustom)
  • #define PhnLibTrapSetAddresses (70+sysLibTrapCustom)
  • #define PhnLibTrapSetStatus (71+sysLibTrapCustom)
  • #define PhnLibTrapSetFlags (72+sysLibTrapCustom)
  • #define PhnLibTrapSetOwner (73+sysLibTrapCustom)
  • #define PhnLibTrapGetText (74+sysLibTrapCustom)
  • #define PhnLibTrapGetDate (75+sysLibTrapCustom)
  • #define PhnLibTrapGetOptions (76+sysLibTrapCustom)
  • #define PhnLibTrapGetAddresses (77+sysLibTrapCustom)
  • #define PhnLibTrapGetStatus (78+sysLibTrapCustom)
  • #define PhnLibTrapGetFlags (79+sysLibTrapCustom)
  • #define PhnLibTrapGetOwner (80+sysLibTrapCustom)
  • #define PhnLibTrapGetType (81+sysLibTrapCustom)
  • #define PhnLibTrapIsLegalCharacter (82+sysLibTrapCustom)
  • #define PhnLibTrapMapCharacter (83+sysLibTrapCustom)
  • #define PhnLibTrapSetServiceCentreAddress (84+sysLibTrapCustom)
  • #define PhnLibTrapGetServiceCentreAddress (85+sysLibTrapCustom)
  • #define PhnLibTrapLength (86+sysLibTrapCustom)
  • #define PhnLibTrapGetSubstitution (87+sysLibTrapCustom)
  • #define PhnLibTrapNewAddressList (88+sysLibTrapCustom)
  • #define PhnLibTrapDisposeAddressList (89+sysLibTrapCustom)
  • #define PhnLibTrapAddAddress (90+sysLibTrapCustom)
  • #define PhnLibTrapGetNth (91+sysLibTrapCustom)
  • #define PhnLibTrapSetNth (92+sysLibTrapCustom)
  • #define PhnLibTrapCount (93+sysLibTrapCustom)
  • #define PhnLibTrapSetModulePower (94+sysLibTrapCustom)
  • #define PhnLibTrapModulePowered (95+sysLibTrapCustom)
  • #define PhnLibTrapModuleButtonDown (96+sysLibTrapCustom)
  • #define PhnLibTrapBoxInformation (97+sysLibTrapCustom)
  • #define PhnLibTrapGetBoxNumber (98+sysLibTrapCustom)
  • #define PhnLibTrapGetDataApplication (99+sysLibTrapCustom)
  • #define PhnLibTrapSetDataApplication (100+sysLibTrapCustom)
  • #define PhnLibTrapDebug (101+sysLibTrapCustom)
  • #define PhnLibTrapGetPhoneBook (102+sysLibTrapCustom)
  • #define PhnLibTrapSetPhoneBook (103+sysLibTrapCustom)
  • #define PhnLibTrapSetPhoneBookEntry (104+sysLibTrapCustom)
  • #define PhnLibTrapGetPhoneBookIndex (105+sysLibTrapCustom)
  • #define PhnLibTrapBatteryCharge (106+sysLibTrapCustom)
  • #define PhnLibTrapGetEchoCancellation (107+sysLibTrapCustom)
  • #define PhnLibTrapSetEchoCancellation (108+sysLibTrapCustom)
  • #define PhnLibTrapGetEquipmentMode (109+sysLibTrapCustom)
  • #define PhnLibTrapSetEquipmentMode (110+sysLibTrapCustom)
  • #define PhnLibTrapGetSMSRingInfo (111+sysLibTrapCustom)
  • #define PhnLibTrapSetSMSRingInfo (112+sysLibTrapCustom)
  • #define PhnLibTrapPlayDTMF (113+sysLibTrapCustom)
  • #define PhnLibTrapStartVibrate (114+sysLibTrapCustom)
  • #define PhnLibTrapStopVibrate (115+sysLibTrapCustom)
  • #define PhnLibTrapSendUSSD (116+sysLibTrapCustom)
  • #define PhnLibTrapSATGetMainMenu (117+sysLibTrapCustom)
  • #define PhnLibTrapSATSendRequest (118+sysLibTrapCustom)
  • #define PhnLibTrapSATEndSession (119+sysLibTrapCustom)
  • #define PhnLibTrapHomeOperatorID (120+sysLibTrapCustom)
  • #define PhnLibTrapCurrentOperatorID (121+sysLibTrapCustom)
  • #define PhnLibTrapUsableSignalStrengthThreshold (122+sysLibTrapCustom)
  • #define PhnLibTrapConnectionAvailable (123+sysLibTrapCustom)
  • #define PhnLibTrapGetPhoneCallStatus (124+sysLibTrapCustom)
  • #define PhnLibTrapSendSilentDTMF (125+sysLibTrapCustom)
  • #define PhnLibTrapSetCLIR (126+sysLibTrapCustom)
  • #define PhnLibTrapGetCLIR (127+sysLibTrapCustom)
  • #define PhnLibTrapMute (128+sysLibTrapCustom)
  • #define PhnLibTrapIsCallMuted (129+sysLibTrapCustom)
  • #define PhnLibTrapGetSMSGateway (130+sysLibTrapCustom)
  • #define PhnLibTrapDeactivateBarring (131+sysLibTrapCustom)
  • #define PhnLibTrapGPRSAttached (132+sysLibTrapCustom)
  • #define PhnLibTrapGPRSPDPContextDefine (133+sysLibTrapCustom)
  • #define PhnLibTrapGPRSPDPContextListConstruct (134+sysLibTrapCustom)
  • #define PhnLibTrapGPRSPDPContextListDestruct (135+sysLibTrapCustom)
  • #define PhnLibTrapGetRemainingPasswordTries (136+sysLibTrapCustom)
  • #define PhnLibTrapGPRSQualityOfServiceGet (137+sysLibTrapCustom)
  • #define PhnLibTrapGPRSQualityOfServiceSet (138+sysLibTrapCustom)
  • #define PhnLibTrapSetBoxNumber (139+sysLibTrapCustom)
  • #define PhnLibTrapGetBinary (140+sysLibTrapCustom)
  • #define PhnLibTrapNetworkAvailable (141+sysLibTrapCustom)
  • #define PhnLibTrapSetFDNEntry (142+sysLibTrapCustom)
  • #define PhnLibTrapGetFDNList (143+sysLibTrapCustom)
  • #define PhnLibTrapDecodeMMI (144+sysLibTrapCustom)
  • #define PhnLibTrapExecuteMMI (145+sysLibTrapCustom)
  • #define PhnLibTrapSetActiveLine (146+sysLibTrapCustom)
  • #define PhnLibTrapSetBand (147+sysLibTrapCustom)
  • #define PhnLibTrapGetBand (148+sysLibTrapCustom)
  • #define PhnLibTrapGetCustomServiceProfile (149+sysLibTrapCustom)
  • #define PhnLibTrapIsEmergencyNumber (150+sysLibTrapCustom)
  • #define PhnLibTrapAttrGet (151+sysLibTrapCustom)
  • #define PhnLibTrapAttrSet (152+sysLibTrapCustom)
  • #define PhnLibTrapGetSDNList (153+sysLibTrapCustom)
  • #define PhnLibTrapSendLongDTMF (154+sysLibTrapCustom)
  • #define PhnLibTrapGetICCID (155+sysLibTrapCustom)
  • #define PhnLibTrapGetSpn (156+sysLibTrapCustom)
  • #define PhnLibTrapGPRSAttachRequest (157+sysLibTrapCustom)
  • #define PhnLibTrapSetNoiseCancellation (158+sysLibTrapCustom)
  • #define PhnLibTrapGetNoiseCancellation (159+sysLibTrapCustom)
  • #define PhnLibTrapCRSM (160+sysLibTrapCustom)
  • #define PhnLibTrapGetDedicatedDataMode (161+sysLibTrapCustom)
  • #define PhnLibTrapSetDedicatedDataMode (162+sysLibTrapCustom)
  • #define PhnLibTrapGetMVNOName (163+sysLibTrapCustom)
  • #define GSMReserved7 (164+sysLibTrapCustom)
  • #define GSMReserved8 (165+sysLibTrapCustom)
  • #define GSMReserved9 (166+sysLibTrapCustom)
  • #define GSMReserved10 (167+sysLibTrapCustom)
  • #define GSMReserved11 (168+sysLibTrapCustom)
  • #define GSMReserved12 (169+sysLibTrapCustom)
  • #define GSMReserved13 (170+sysLibTrapCustom)
  • #define GSMReserved14 (171+sysLibTrapCustom)
  • #define GSMReserved15 (172+sysLibTrapCustom)
  • #define GSMReserved16 (173+sysLibTrapCustom)
  • #define GSMReserved17 (174+sysLibTrapCustom)
  • #define GSMReserved18 (175+sysLibTrapCustom)
  • #define GSMReserved19 (176+sysLibTrapCustom)
  • #define GSMReserved20 (177+sysLibTrapCustom)
  • #define GSMReserved21 (178+sysLibTrapCustom)
  • #define GSMReserved22 (179+sysLibTrapCustom)
  • #define PhnLibTrapAPGetNth (180+sysLibTrapCustom)
  • #define PhnLibTrapGetMSID (181+sysLibTrapCustom)
  • #define PhnLibTrapGetPhnOprtMode (182+sysLibTrapCustom)
  • #define PhnLibTrapSetPhnOprtMode (183+sysLibTrapCustom)
  • #define PhnLibTrapSendSMSMTAck (184+sysLibTrapCustom)
  • #define PhnLibTrapQuerySMSMT (185+sysLibTrapCustom)
  • #define PhnLibTrapIsPhoneActivated (186+sysLibTrapCustom)
  • #define PhnLibTrapUpdateMessageCount (187+sysLibTrapCustom)
  • #define PhnLibTrapGetSMSPreference (188+sysLibTrapCustom)
  • #define PhnLibTrapSetSMSPreference (189+sysLibTrapCustom)
  • #define PhnLibTrapGetSpMode (190+sysLibTrapCustom)
  • #define PhnLibTrapLedAlert (191+sysLibTrapCustom)
  • #define PhnLibTrapExit911Mode (192+sysLibTrapCustom)
  • #define PhnLibTrapMiscDebugInfo (193+sysLibTrapCustom)
  • #define PhnLibTrapGetHeadsetConnectedInfo (194+sysLibTrapCustom)
  • #define PhnLibTrapExitPowerSaveMode (195+sysLibTrapCustom)
  • #define PhnLibTrapGetToneLength (196+sysLibTrapCustom)
  • #define PhnLibTrapSetToneLength (197+sysLibTrapCustom)
  • #define PhnLibTrapUnlockPhoneLock (198+sysLibTrapCustom)
  • #define PhnLibTrapLoadCDMATime (199+sysLibTrapCustom)
  • #define PhnLibTrapGetCallCountByService (200+sysLibTrapCustom)
  • #define PhnLibTrapGetDefaultDataApps (201+sysLibTrapCustom)
  • #define PhnLibTrapModemIssueResetInfo (202+sysLibTrapCustom)
  • #define PhnLibTrapGetRoamPrefMode (203+sysLibTrapCustom)
  • #define PhnLibTrapSetRoamPrefMode (204+sysLibTrapCustom)
  • #define PhnLibTrapGetRoamPrefInfo (205+sysLibTrapCustom)
  • #define PhnLibTrapSetRoamPrefInfo (206+sysLibTrapCustom)
  • #define PhnLibTrapIsSpecialNumber (207+sysLibTrapCustom)
  • #define PhnLibTrapSetSpecialNumbers (208+sysLibTrapCustom)
  • #define PhnLibTrapGetSpecialNumbers (209+sysLibTrapCustom)
  • #define PhnLibTrapGetDTMFburstMode (210+sysLibTrapCustom)
  • #define PhnLibTrapSetDTMFburstMode (211+sysLibTrapCustom)
  • #define PhnLibTrapSetupDataConfig (212+sysLibTrapCustom)
  • #define PhnLibTrapGetTotalDataTxBytes (213+sysLibTrapCustom)
  • #define PhnLibTrapGetTotalDataRxBytes (214+sysLibTrapCustom)
  • #define PrvPhnLibTrapCheckPowerSync (215+sysLibTrapCustom)
  • #define PhnLibTrapSetPhoneSSMode (216+sysLibTrapCustom)
  • #define PhnLibTrapEnableDM (217+sysLibTrapCustom)
  • #define PhnLibTrapPowerSaveDisable (218+sysLibTrapCustom)
  • #define PhnLibTrapCloseNetIF (219+sysLibTrapCustom)
  • #define PhnLibTrapGetMdmPosition (220+sysLibTrapCustom)
  • #define PhnLibTrapGetPDSessionConfigParam (221+sysLibTrapCustom)
  • #define PhnLibTrapSetPDSessionConfigParam (222+sysLibTrapCustom)
  • #define PhnLibTrapStopPDSession (223+sysLibTrapCustom)
  • #define PhnLibTrapSndSave (224+sysLibTrapCustom)
  • #define PhnLibTrapSndDelete (225+sysLibTrapCustom)
  • #define PhnLibTrapListPDP (226+sysLibTrapCustom)
  • #define PhnLibTrapSetPDP (227+sysLibTrapCustom)
  • #define PhnLibTrapGetPDP (228+sysLibTrapCustom)
  • #define PhnLibTrapCopyPDP (229+sysLibTrapCustom)
  • #define PhnLibTrapDeletePDP (230+sysLibTrapCustom)
  • #define PhnLibTrapReplacePDPPassword (231+sysLibTrapCustom)
  • #define PhnLibTrapGetTotalPDPs (232+sysLibTrapCustom)
  • #define PhnLibTrapGetOneXStatus (233+sysLibTrapCustom)
  • #define PhnLibTrapUpdateCustomizedNV (234+sysLibTrapCustom)
  • #define PhnLibTrapSetMdmAutoMsgMask (235+sysLibTrapCustom)
  • #define PhnLibTrapGetPhoneSSMode (236+sysLibTrapCustom)
  • #define PhnLibTrapGetPDPIndexRange (237+sysLibTrapCustom)
  • #define PhnLibTrapGetCktSwitchProfile (238+sysLibTrapCustom)
  • #define PhnLibTrapStartIOTASession (239+sysLibTrapCustom)
  • #define PhnLibTrapEndIOTASession (240+sysLibTrapCustom)
  • #define PhnLibTrapTunnelIS683ReqMsg (241+sysLibTrapCustom)
  • #define PhnLibTrapSelectNAM (242+sysLibTrapCustom)
  • #define PhnLibTrapGetNAMInUse (243+sysLibTrapCustom)
  • #define PhnLibTrapCommitIOTAParams (244+sysLibTrapCustom)
  • #define PhnLibTrapReadIOTAItem (245+sysLibTrapCustom)
  • #define PhnLibTrapWriteIOTAItem (246+sysLibTrapCustom)
  • #define PhnLibTrapGetIOTAStatus (247+sysLibTrapCustom)
  • #define PhnLibTrapSetCurrentUsageHandler (248+sysLibTrapCustom)
  • #define PhnLibTrapSendDTMFBurst (249+sysLibTrapCustom)
  • #define PhnLibTrapAPNewAddress (250+sysLibTrapCustom)
  • #define PhnLibTrapAPGetField (251+sysLibTrapCustom)
  • #define Reserved2 (252+sysLibTrapCustom)
  • #define PhnLibTrapCardInfoEx (253+sysLibTrapCustom)
  • #define PhnLibTrapBoxInformationEx (254+sysLibTrapCustom)
  • #define PhnLibTrapSignalQualityEx (255+sysLibTrapCustom)
  • #define PhnLibTrapReplacePDPNAI (256+sysLibTrapCustom)
  • #define PhnLibTrapReplacePDPSvcString (257+sysLibTrapCustom)
  • #define PhnLibTrapPDPLockUnlock (258+sysLibTrapCustom)
  • #define PhnLibTrapPhoneRestore (259+sysLibTrapCustom)
  • #define PhnLibTrapVerifyICDVer (260+sysLibTrapCustom)
  • #define PhnLibTrapGetToneIDsEx (261+sysLibTrapCustom)
  • #define PhnLibTrapPlayToneEx (262+sysLibTrapCustom)
  • #define PhnLibTrapEnhancedRoamIndicator (263+sysLibTrapCustom)
  • #define PhnLibTrapNewMOMessage (264+sysLibTrapCustom)
  • #define PhnLibTrapGetTTYSetting (265+sysLibTrapCustom)
  • #define PhnLibTrapSetTTYSetting (266+sysLibTrapCustom)
  • #define PhnLibTrapGetRadioState (267+sysLibTrapCustom)
  • #define PhnLibTrapGetLineState (268+sysLibTrapCustom)
  • #define PhnLibTrapGetLengthDetails (269+sysLibTrapCustom)
  • #define PhnLibTrapGetPicturesToken (270+sysLibTrapCustom)
  • #define PhnLibTrapSetPicturesToken (271+sysLibTrapCustom)
  • #define PhnLibTrapGetPicturesServerInfo (272+sysLibTrapCustom)
  • #define PhnLibTrapSendPendingMessages (273+sysLibTrapCustom)
  • #define PhnLibTrapForceDataDormant (274+sysLibTrapCustom)
  • #define PhnLibTrapGetSysPrefMode (275+sysLibTrapCustom)
  • #define PhnLibTrapSetSysPrefMode (276+sysLibTrapCustom)
  • #define PhnLibTrapGetLifeTimer (277+sysLibTrapCustom)
  • #define PhnLibTrapGetVoicePrivacyMode (278+sysLibTrapCustom)
  • #define PhnLibTrapSetVoicePrivacyMode (279+sysLibTrapCustom)
  • #define PhnLibTrapGetMMSServerInfo (280+sysLibTrapCustom)
  • #define PhnLibTrapGetSMSSegmentInfo (281+sysLibTrapCustom)
  • #define PhnLibTrapDebugHook (282+sysLibTrapCustom)
  • #define PhnLibTrapContinuePhonePowerOn (283+sysLibTrapCustom)
  • #define PhnLibTrapContinuePhonePowerOff (284+sysLibTrapCustom)
  • #define PhnLibTrapSetSMSCallbackNumber (285+sysLibTrapCustom)
  • #define PhnLibTrapGetDeviceId (286+sysLibTrapCustom)
  • #define PhnLibTrapSendFlash (287+sysLibTrapCustom)
  • #define PhnLibTrapGetCDMASystemInfo (288+sysLibTrapCustom)
  • #define PhnLibTrapGetHomepageFromRadio (289+sysLibTrapCustom)
  • #define PhnLibTrapGetProxyInfo (290+sysLibTrapCustom)
  • #define PhnLibTrapIsRadioGenericCDMA (291+sysLibTrapCustom)
  • #define PhnLibTrapGetGenericCDMAPreference (292+sysLibTrapCustom)
  • #define PhnLibTrapIsCarrierDefinedEmergencyNumber (293+sysLibTrapCustom)
  • #define PhnLibTrapGetDialPrefix (294+sysLibTrapCustom)
  • #define PhnLibTrapSetDialPrefix (295+sysLibTrapCustom)
  • #define PhnLibTrapGetDataSessionInfo (296+sysLibTrapCustom)
  • #define PhnLibTrapGetMediaTVSettings (297+sysLibTrapCustom)
  • #define PhnLibTrapOffHold (298+sysLibTrapCustom)
  • #define PhnLibTrapGetMMSServerInfoEx (299+sysLibTrapCustom)
  • #define PhnLibTrapGetDataLife (300+sysLibTrapCustom)
  • #define PhnLibTrapLast (300+sysLibTrapCustom)

Define Documentation

#define GSMReserved10 (167+sysLibTrapCustom)

0xA8AC

#define GSMReserved11 (168+sysLibTrapCustom)

0xA8AD

#define GSMReserved12 (169+sysLibTrapCustom)

0xA8AE

#define GSMReserved13 (170+sysLibTrapCustom)

0xA8AF

#define GSMReserved14 (171+sysLibTrapCustom)

0xA8B0

#define GSMReserved15 (172+sysLibTrapCustom)

0xA8B1

#define GSMReserved16 (173+sysLibTrapCustom)

0xA8B2

#define GSMReserved17 (174+sysLibTrapCustom)

0xA8B3

#define GSMReserved18 (175+sysLibTrapCustom)

0xA8B4

#define GSMReserved19 (176+sysLibTrapCustom)

0xA8B5

#define GSMReserved20 (177+sysLibTrapCustom)

0xA8B6

#define GSMReserved21 (178+sysLibTrapCustom)

0xA8B7

#define GSMReserved22 (179+sysLibTrapCustom)

0xA8B8

#define GSMReserved7 (164+sysLibTrapCustom)

0xA8A9

#define GSMReserved8 (165+sysLibTrapCustom)

0xA8AA

#define GSMReserved9 (166+sysLibTrapCustom)

0xA8AB

#define PhnLibTrapActivate (16+sysLibTrapCustom)

0xA815

#define PhnLibTrapAddAddress (90+sysLibTrapCustom)

0xA85F

#define PhnLibTrapAddressToText (10+sysLibTrapCustom)

0xA80F

#define PhnLibTrapAPGetField (251+sysLibTrapCustom)

0xA900 CDMA Only

#define PhnLibTrapAPGetNth (180+sysLibTrapCustom)

0xA8B9 CDMA Only

#define PhnLibTrapAPNewAddress (250+sysLibTrapCustom)

0xA8FF CDMA Only

#define PhnLibTrapAttrGet (151+sysLibTrapCustom)

0xA89C GSM Only

#define PhnLibTrapAttrSet (152+sysLibTrapCustom)

0xA89D GSM Only

#define PhnLibTrapBattery (56+sysLibTrapCustom)

0xA83D

#define PhnLibTrapBatteryCharge (106+sysLibTrapCustom)

0xA86F GSM Only

#define PhnLibTrapBoxInformation (97+sysLibTrapCustom)

0xA866

#define PhnLibTrapBoxInformationEx (254+sysLibTrapCustom)

0xA903 CDMA Only

#define PhnLibTrapCardInfo (57+sysLibTrapCustom)

0xA83E

#define PhnLibTrapCardInfoEx (253+sysLibTrapCustom)

0xA902 CDMA Only

#define PhnLibTrapChangePassword (32+sysLibTrapCustom)

0xA825

#define PhnLibTrapCloseNetIF (219+sysLibTrapCustom)

0xA8E0 CDMA Only

#define PhnLibTrapCommitIOTAParams (244+sysLibTrapCustom)

0xA8F9 CDMA Only

#define PhnLibTrapConference (17+sysLibTrapCustom)

0xA816

#define PhnLibTrapConnectionAvailable (123+sysLibTrapCustom)

0xA880 GSM Only

#define PhnLibTrapContinuePhonePowerOff (284+sysLibTrapCustom)

0xA921

#define PhnLibTrapContinuePhonePowerOn (283+sysLibTrapCustom)

0xA920

#define PhnLibTrapCopyPDP (229+sysLibTrapCustom)

0xA8EA CDMA Only

#define PhnLibTrapCount (93+sysLibTrapCustom)

0xA862

#define PhnLibTrapCRSM (160+sysLibTrapCustom)

0xA8A5

#define PhnLibTrapCurrentOperator (34+sysLibTrapCustom)

0xA827

#define PhnLibTrapCurrentOperatorID (121+sysLibTrapCustom)

0xA87E GSM Only

#define PhnLibTrapCurrentProvider (35+sysLibTrapCustom)

0xA828 GSM Only

#define PhnLibTrapDeactivateBarring (131+sysLibTrapCustom)

0xA888 GSM Only

#define PhnLibTrapDebug (101+sysLibTrapCustom)

0xA86A GSM Only

#define PhnLibTrapDebugHook (282+sysLibTrapCustom)

0xA91F

#define PhnLibTrapDecodeMMI (144+sysLibTrapCustom)

0xA895 GSM Only

#define PhnLibTrapDeleteMessage (65+sysLibTrapCustom)

0xA846

#define PhnLibTrapDeletePDP (230+sysLibTrapCustom)

0xA8EB CDMA Only

#define PhnLibTrapDial (13+sysLibTrapCustom)

0xA812

#define PhnLibTrapDisconnect (15+sysLibTrapCustom)

0xA814

#define PhnLibTrapDisposeAddressList (89+sysLibTrapCustom)

0xA85E

#define PhnLibTrapEnableDM (217+sysLibTrapCustom)

0xA8DE CDMA Only

#define PhnLibTrapEndIOTASession (240+sysLibTrapCustom)

0xA8F5 CDMA Only

#define PhnLibTrapEnhancedRoamIndicator (263+sysLibTrapCustom)

0xA90C CDMA only

#define PhnLibTrapEqual (12+sysLibTrapCustom)

0xA811

#define PhnLibTrapErrorRate (55+sysLibTrapCustom)

0xA83C GSM Only

#define PhnLibTrapExecuteMMI (145+sysLibTrapCustom)

0xA896 GSM Only

#define PhnLibTrapExit911Mode (192+sysLibTrapCustom)

0xA8C5 CDMA Only

#define PhnLibTrapExitPowerSaveMode (195+sysLibTrapCustom)

0xA8C8 CDMA Only

#define PhnLibTrapFindEntry (46+sysLibTrapCustom)

0xA833 GSM Only

#define PhnLibTrapFirstAppForService (3+sysLibTrapCustom)

0xA808 GSM Only

#define PhnLibTrapForceDataDormant (274+sysLibTrapCustom)

0xA917 CDMA Only

#define PhnLibTrapGetAddresses (77+sysLibTrapCustom)

0xA852

#define PhnLibTrapGetBand (148+sysLibTrapCustom)

0xA899 GSM Only

#define PhnLibTrapGetBarring (21+sysLibTrapCustom)

0xA81A GSM Only

#define PhnLibTrapGetBinary (140+sysLibTrapCustom)

0xA891 GSM Only

#define PhnLibTrapGetBoxNumber (98+sysLibTrapCustom)

0xA867

#define PhnLibTrapGetCallCountByService (200+sysLibTrapCustom)

0xA8CD

#define PhnLibTrapGetCallWaiting (25+sysLibTrapCustom)

0xA81E

#define PhnLibTrapGetCDMASystemInfo (288+sysLibTrapCustom)

0xA925 CDMA ONLY

#define PhnLibTrapGetCktSwitchProfile (238+sysLibTrapCustom)

0xA8F3 CDMA Only

#define PhnLibTrapGetCLIP (29+sysLibTrapCustom)

0xA822 GSM Only

#define PhnLibTrapGetCLIR (127+sysLibTrapCustom)

0xA884 GSM Only

#define PhnLibTrapGetConnectionInfo (19+sysLibTrapCustom)

0xA818

#define PhnLibTrapGetCustomServiceProfile (149+sysLibTrapCustom)

0xA89A GSM Only

#define PhnLibTrapGetDataApplication (99+sysLibTrapCustom)

0xA868 GSM Only

#define PhnLibTrapGetDataLife (300+sysLibTrapCustom)

0xA931 CDMA ONLY

#define PhnLibTrapGetDataSessionInfo (296+sysLibTrapCustom)

0xA92D

#define PhnLibTrapGetDate (75+sysLibTrapCustom)

0xA850

#define PhnLibTrapGetDBRef (62+sysLibTrapCustom)

0xA843

#define PhnLibTrapGetDedicatedDataMode (161+sysLibTrapCustom)

0xA8A6

#define PhnLibTrapGetDefaultDataApps (201+sysLibTrapCustom)

0xA8CE CDMA Only

#define PhnLibTrapGetDeviceId (286+sysLibTrapCustom)

0xA923

#define PhnLibTrapGetDialPrefix (294+sysLibTrapCustom)

0xA92B CDMA ONLY

#define PhnLibTrapGetDTMFburstMode (210+sysLibTrapCustom)

0xA8D7 CDMA Only

#define PhnLibTrapGetEchoCancellation (107+sysLibTrapCustom)

0xA870 GSM Only

#define PhnLibTrapGetEquipmentMode (109+sysLibTrapCustom)

0xA872

#define PhnLibTrapGetErrorText (61+sysLibTrapCustom)

0xA842

#define PhnLibTrapGetFDNList (143+sysLibTrapCustom)

0xA894 GSM Only

#define PhnLibTrapGetField (5+sysLibTrapCustom)

0xA80A

#define PhnLibTrapGetFlags (79+sysLibTrapCustom)

0xA854

#define PhnLibTrapGetForwarding (23+sysLibTrapCustom)

0xA81C

#define PhnLibTrapGetGenericCDMAPreference (292+sysLibTrapCustom)

0xA929 CDMA ONLY

#define PhnLibTrapGetHeadsetConnectedInfo (194+sysLibTrapCustom)

0xA8C7 CDMA Only

#define PhnLibTrapGetHomepageFromRadio (289+sysLibTrapCustom)

0xA926 CDMA ONLY

#define PhnLibTrapGetICCID (155+sysLibTrapCustom)

0xA8A0 GSM Only

#define PhnLibTrapGetID (6+sysLibTrapCustom)

0xA80B

#define PhnLibTrapGetIOTAStatus (247+sysLibTrapCustom)

0xA8FC CDMA Only

#define PhnLibTrapGetLengthDetails (269+sysLibTrapCustom)

0xA912

#define PhnLibTrapGetLibAPIVersion (0+sysLibTrapCustom)

0xA805

#define PhnLibTrapGetLifeTimer (277+sysLibTrapCustom)

0xA91A

#define PhnLibTrapGetLineState (268+sysLibTrapCustom)

0xA911

#define PhnLibTrapGetMdmPosition (220+sysLibTrapCustom)

0xA8E1 CDMA Only

#define PhnLibTrapGetMediaTVSettings (297+sysLibTrapCustom)

0xA92E CDMA ONLY

#define PhnLibTrapGetMicrophone (48+sysLibTrapCustom)

0xA835 GSM Only

#define PhnLibTrapGetMMSServerInfo (280+sysLibTrapCustom)

0xA91D CDMA Only

#define PhnLibTrapGetMMSServerInfoEx (299+sysLibTrapCustom)

0xA930 CDMA ONLY

#define PhnLibTrapGetMSID (181+sysLibTrapCustom)

0xA8BA CDMA Only

#define PhnLibTrapGetMVNOName (163+sysLibTrapCustom)

0xA8A8

#define PhnLibTrapGetNAMInUse (243+sysLibTrapCustom)

0xA8F8 CDMA Only

#define PhnLibTrapGetNoiseCancellation (159+sysLibTrapCustom)

0xA8A4

#define PhnLibTrapGetNth (91+sysLibTrapCustom)

0xA860

#define PhnLibTrapGetOneXStatus (233+sysLibTrapCustom)

0xA8EE CDMA Only

#define PhnLibTrapGetOperatorList (36+sysLibTrapCustom)

0xA829

#define PhnLibTrapGetOperatorLock (31+sysLibTrapCustom)

0xA824 GSM Only

#define PhnLibTrapGetOptions (76+sysLibTrapCustom)

0xA851

#define PhnLibTrapGetOwner (80+sysLibTrapCustom)

0xA855

#define PhnLibTrapGetOwnNumbers (38+sysLibTrapCustom)

0xA82B

#define PhnLibTrapGetPDP (228+sysLibTrapCustom)

0xA8E9 CDMA Only

#define PhnLibTrapGetPDPIndexRange (237+sysLibTrapCustom)

0xA8F2 CDMA Only

#define PhnLibTrapGetPDSessionConfigParam (221+sysLibTrapCustom)

0xA8E2 CDMA Only

#define PhnLibTrapGetPhnOprtMode (182+sysLibTrapCustom)

0xA8BB CDMA Only

#define PhnLibTrapGetPhoneBook (102+sysLibTrapCustom)

0xA86B GSM Only

#define PhnLibTrapGetPhoneBookIndex (105+sysLibTrapCustom)

0xA86E GSM Only

#define PhnLibTrapGetPhoneCallStatus (124+sysLibTrapCustom)

0xA881

#define PhnLibTrapGetPhoneLock (27+sysLibTrapCustom)

0xA820

#define PhnLibTrapGetPhoneSSMode (236+sysLibTrapCustom)

0xA8F1 CDMA Only

#define PhnLibTrapGetPicturesServerInfo (272+sysLibTrapCustom)

0xA915 CDMA Only

#define PhnLibTrapGetPicturesToken (270+sysLibTrapCustom)

0xA913 CDMA Only

#define PhnLibTrapGetProxyInfo (290+sysLibTrapCustom)

0xA927 CDMA ONLY

#define PhnLibTrapGetRadioState (267+sysLibTrapCustom)

0xA910

#define PhnLibTrapGetRemainingPasswordTries (136+sysLibTrapCustom)

0xA88D GSM Only

#define PhnLibTrapGetRingingInfo (40+sysLibTrapCustom)

0xA82D

#define PhnLibTrapGetRoamPrefInfo (205+sysLibTrapCustom)

0xA8D2 CDMA Only

#define PhnLibTrapGetRoamPrefMode (203+sysLibTrapCustom)

0xA8D0 CDMA Only

#define PhnLibTrapGetSDNList (153+sysLibTrapCustom)

0xA89E GSM Only

#define PhnLibTrapGetServiceCentreAddress (85+sysLibTrapCustom)

0xA85A

#define PhnLibTrapGetSIMStatus (59+sysLibTrapCustom)

0xA840 GSM Only

#define PhnLibTrapGetSMSGateway (130+sysLibTrapCustom)

0xA887 GSM Only

#define PhnLibTrapGetSMSPreference (188+sysLibTrapCustom)

0xA8C1 CDMA Only

#define PhnLibTrapGetSMSRingInfo (111+sysLibTrapCustom)

0xA874 GSM Only

#define PhnLibTrapGetSMSSegmentInfo (281+sysLibTrapCustom)

0xA91E CDMA Only

#define PhnLibTrapGetSpecialNumbers (209+sysLibTrapCustom)

0xA8D6 CDMA Only

#define PhnLibTrapGetSpMode (190+sysLibTrapCustom)

0xA8C3 CDMA Only

#define PhnLibTrapGetSpn (156+sysLibTrapCustom)

0xA8A1 GSM Only

#define PhnLibTrapGetStatus (78+sysLibTrapCustom)

0xA853

#define PhnLibTrapGetSubstitution (87+sysLibTrapCustom)

0xA85C

#define PhnLibTrapGetSysPrefMode (275+sysLibTrapCustom)

0xA918 CDMA Only

#define PhnLibTrapGetText (74+sysLibTrapCustom)

0xA84F

#define PhnLibTrapGetToneIDs (42+sysLibTrapCustom)

0xA82F

#define PhnLibTrapGetToneIDsEx (261+sysLibTrapCustom)

0xA90A CDMA only

#define PhnLibTrapGetToneLength (196+sysLibTrapCustom)

0xA8C9 CDMA Only

#define PhnLibTrapGetToneName (43+sysLibTrapCustom)

0xA830

#define PhnLibTrapGetTotalDataRxBytes (214+sysLibTrapCustom)

0xA8DB CDMA Only

#define PhnLibTrapGetTotalDataTxBytes (213+sysLibTrapCustom)

0xA8DA CDMA Only

#define PhnLibTrapGetTotalPDPs (232+sysLibTrapCustom)

0xA8ED CDMA Only

#define PhnLibTrapGetTTYSetting (265+sysLibTrapCustom)

0xA90E

#define PhnLibTrapGetType (81+sysLibTrapCustom)

0xA856

#define PhnLibTrapGetVoicePrivacyMode (278+sysLibTrapCustom)

0xA91B CDMA Only

#define PhnLibTrapGetVolume (50+sysLibTrapCustom)

0xA837

#define PhnLibTrapGPRSAttached (132+sysLibTrapCustom)

0xA889 GSM Only

#define PhnLibTrapGPRSAttachRequest (157+sysLibTrapCustom)

0xA8A2 GSM Only

#define PhnLibTrapGPRSPDPContextDefine (133+sysLibTrapCustom)

0xA88A GSM Only

#define PhnLibTrapGPRSPDPContextListConstruct (134+sysLibTrapCustom)

0xA88B GSM Only

#define PhnLibTrapGPRSPDPContextListDestruct (135+sysLibTrapCustom)

0xA88C GSM Only

#define PhnLibTrapGPRSQualityOfServiceGet (137+sysLibTrapCustom)

0xA88E GSM Only

#define PhnLibTrapGPRSQualityOfServiceSet (138+sysLibTrapCustom)

0xA88F GSM Only

#define PhnLibTrapHasName (11+sysLibTrapCustom)

0xA810

#define PhnLibTrapHold (18+sysLibTrapCustom)

0xA817

#define PhnLibTrapHomeOperatorID (120+sysLibTrapCustom)

0xA87D GSM Only

#define PhnLibTrapIsCallMuted (129+sysLibTrapCustom)

0xA886

#define PhnLibTrapIsCarrierDefinedEmergencyNumber (293+sysLibTrapCustom)

0xA92A CDMA ONLY

#define PhnLibTrapIsEmergencyNumber (150+sysLibTrapCustom)

0xA89B GSM Only

#define PhnLibTrapIsLegalCharacter (82+sysLibTrapCustom)

0xA857

#define PhnLibTrapIsPhoneActivated (186+sysLibTrapCustom)

0xA8BF CDMA Only

#define PhnLibTrapIsRadioGenericCDMA (291+sysLibTrapCustom)

0xA928 CDMA ONLY

#define PhnLibTrapIsSpecialNumber (207+sysLibTrapCustom)

0xA8D4 CDMA Only

#define PhnLibTrapLast (300+sysLibTrapCustom)

0xA931

#define PhnLibTrapLedAlert (191+sysLibTrapCustom)

0xA8C4 CDMA Only

#define PhnLibTrapLength (86+sysLibTrapCustom)

0xA85B

#define PhnLibTrapListPDP (226+sysLibTrapCustom)

0xA8E7 CDMA Only

#define PhnLibTrapLoadCDMATime (199+sysLibTrapCustom)

0xA8CC CDMA Only

#define PhnLibTrapMapCharacter (83+sysLibTrapCustom)

0xA858

#define PhnLibTrapMiscDebugInfo (193+sysLibTrapCustom)

0xA8C6 CDMA Only

#define PhnLibTrapModemIssueResetInfo (202+sysLibTrapCustom)

0xA8CF CDMA Only

#define PhnLibTrapModuleButtonDown (96+sysLibTrapCustom)

0xA865

#define PhnLibTrapModulePowered (95+sysLibTrapCustom)

0xA864

#define PhnLibTrapMute (128+sysLibTrapCustom)

0xA885

#define PhnLibTrapNetworkAvailable (141+sysLibTrapCustom)

0xA892 GSM Only

#define PhnLibTrapNewAddress (4+sysLibTrapCustom)

0xA809

#define PhnLibTrapNewAddressList (88+sysLibTrapCustom)

0xA85D

#define PhnLibTrapNewMessage (64+sysLibTrapCustom)

0xA845

#define PhnLibTrapNewMOMessage (264+sysLibTrapCustom)

0xA90D CDMA only

#define PhnLibTrapOffHold (298+sysLibTrapCustom)

0xA92F

#define PhnLibTrapParamText (60+sysLibTrapCustom)

0xA841 GSM Only

#define PhnLibTrapPasswordDialog (33+sysLibTrapCustom)

0xA826 GSM Only

#define PhnLibTrapPDPLockUnlock (258+sysLibTrapCustom)

0xA907 CDMA Only

#define PhnLibTrapPhoneRestore (259+sysLibTrapCustom)

0xA908 CDMA Only

#define PhnLibTrapPlayDTMF (113+sysLibTrapCustom)

0xA876

#define PhnLibTrapPlayTone (44+sysLibTrapCustom)

0xA831

#define PhnLibTrapPlayToneEx (262+sysLibTrapCustom)

0xA90B CDMA only

#define PhnLibTrapPowerSaveDisable (218+sysLibTrapCustom)

0xA8DF CDMA Only

#define PhnLibTrapQuerySMSMT (185+sysLibTrapCustom)

0xA8BE CDMA Only

#define PhnLibTrapReadIOTAItem (245+sysLibTrapCustom)

0xA8FA CDMA Only

#define PhnLibTrapRegister (2+sysLibTrapCustom)

0xA807

#define PhnLibTrapRegistered (52+sysLibTrapCustom)

0xA839

#define PhnLibTrapReleaseDBRef (63+sysLibTrapCustom)

0xA844

#define PhnLibTrapReplacePDPNAI (256+sysLibTrapCustom)

0xA905 CDMA Only

#define PhnLibTrapReplacePDPPassword (231+sysLibTrapCustom)

0xA8EC CDMA Only

#define PhnLibTrapReplacePDPSvcString (257+sysLibTrapCustom)

0xA906 CDMA Only

#define PhnLibTrapRoaming (53+sysLibTrapCustom)

0xA83A

#define PhnLibTrapSATEndSession (119+sysLibTrapCustom)

0xA87C GSM Only

#define PhnLibTrapSATGetMainMenu (117+sysLibTrapCustom)

0xA87A GSM Only

#define PhnLibTrapSATSendRequest (118+sysLibTrapCustom)

0xA87B GSM Only

#define PhnLibTrapSelectAddress (47+sysLibTrapCustom)

0xA834 GSM Only

#define PhnLibTrapSelectNAM (242+sysLibTrapCustom)

0xA8F7 CDMA Only

#define PhnLibTrapSendDTMF (14+sysLibTrapCustom)

0xA813

#define PhnLibTrapSendDTMFBurst (249+sysLibTrapCustom)

0xA8FE CDMA Only

#define PhnLibTrapSendFlash (287+sysLibTrapCustom)

0xA924 CDMA ONLY

#define PhnLibTrapSendLongDTMF (154+sysLibTrapCustom)

0xA89F GSM Only

#define PhnLibTrapSendMessage (66+sysLibTrapCustom)

0xA847

#define PhnLibTrapSendPendingMessages (273+sysLibTrapCustom)

0xA916

#define PhnLibTrapSendSilentDTMF (125+sysLibTrapCustom)

0xA882

#define PhnLibTrapSendSMSMTAck (184+sysLibTrapCustom)

0xA8BD CDMA Only

#define PhnLibTrapSendUSSD (116+sysLibTrapCustom)

0xA879 GSM Only

#define PhnLibTrapSetActiveLine (146+sysLibTrapCustom)

0xA897 GSM Only

#define PhnLibTrapSetAddresses (70+sysLibTrapCustom)

0xA84B

#define PhnLibTrapSetBand (147+sysLibTrapCustom)

0xA898 GSM Only

#define PhnLibTrapSetBarring (20+sysLibTrapCustom)

0xA819 GSM Only

#define PhnLibTrapSetBoxNumber (139+sysLibTrapCustom)

0xA890 GSM Only

#define PhnLibTrapSetCallWaiting (24+sysLibTrapCustom)

0xA81D

#define PhnLibTrapSetCLIP (28+sysLibTrapCustom)

0xA821 GSM Only

#define PhnLibTrapSetCLIR (126+sysLibTrapCustom)

0xA883 GSM Only

#define PhnLibTrapSetCurrentUsageHandler (248+sysLibTrapCustom)

0xA8FD CDMA Only

#define PhnLibTrapSetDataApplication (100+sysLibTrapCustom)

0xA869 GSM Only

#define PhnLibTrapSetDate (68+sysLibTrapCustom)

0xA849

#define PhnLibTrapSetDedicatedDataMode (162+sysLibTrapCustom)

0xA8A7

#define PhnLibTrapSetDialPrefix (295+sysLibTrapCustom)

0xA92C CDMA ONLY

#define PhnLibTrapSetDTMFburstMode (211+sysLibTrapCustom)

0xA8D8 CDMA Only

#define PhnLibTrapSetEchoCancellation (108+sysLibTrapCustom)

0xA871 GSM Only

#define PhnLibTrapSetEquipmentMode (110+sysLibTrapCustom)

0xA873

#define PhnLibTrapSetFDNEntry (142+sysLibTrapCustom)

0xA893 GSM Only

#define PhnLibTrapSetField (7+sysLibTrapCustom)

0xA80C

#define PhnLibTrapSetFlags (72+sysLibTrapCustom)

0xA84D

#define PhnLibTrapSetForwarding (22+sysLibTrapCustom)

0xA81B

#define PhnLibTrapSetID (9+sysLibTrapCustom)

0xA80E

#define PhnLibTrapSetMdmAutoMsgMask (235+sysLibTrapCustom)

0xA8F0 CDMA Only

#define PhnLibTrapSetMicrophone (49+sysLibTrapCustom)

0xA836 GSM Only

#define PhnLibTrapSetModulePower (94+sysLibTrapCustom)

0xA863

#define PhnLibTrapSetNoiseCancellation (158+sysLibTrapCustom)

0xA8A3

#define PhnLibTrapSetNth (92+sysLibTrapCustom)

0xA861

#define PhnLibTrapSetNumber (8+sysLibTrapCustom)

0xA80D

#define PhnLibTrapSetOperator (37+sysLibTrapCustom)

0xA82A

#define PhnLibTrapSetOperatorLock (30+sysLibTrapCustom)

0xA823

#define PhnLibTrapSetOptions (69+sysLibTrapCustom)

0xA84A

#define PhnLibTrapSetOwner (73+sysLibTrapCustom)

0xA84E

#define PhnLibTrapSetOwnNumbers (39+sysLibTrapCustom)

0xA82C GSM Only

#define PhnLibTrapSetPDP (227+sysLibTrapCustom)

0xA8E8 CDMA Only

#define PhnLibTrapSetPDSessionConfigParam (222+sysLibTrapCustom)

0xA8E3 CDMA Only

#define PhnLibTrapSetPhnOprtMode (183+sysLibTrapCustom)

0xA8BC CDMA Only

#define PhnLibTrapSetPhoneBook (103+sysLibTrapCustom)

0xA86C GSM Only

#define PhnLibTrapSetPhoneBookEntry (104+sysLibTrapCustom)

0xA86D GSM Only

#define PhnLibTrapSetPhoneLock (26+sysLibTrapCustom)

0xA81F

#define PhnLibTrapSetPhoneSSMode (216+sysLibTrapCustom)

0xA8DD CDMA Only

#define PhnLibTrapSetPicturesToken (271+sysLibTrapCustom)

0xA914 CDMA Only

#define PhnLibTrapSetRingingInfo (41+sysLibTrapCustom)

0xA82E

#define PhnLibTrapSetRoamPrefInfo (206+sysLibTrapCustom)

0xA8D3 CDMA Only

#define PhnLibTrapSetRoamPrefMode (204+sysLibTrapCustom)

0xA8D1 CDMA Only

#define PhnLibTrapSetServiceCentreAddress (84+sysLibTrapCustom)

0xA859

#define PhnLibTrapSetSMSCallbackNumber (285+sysLibTrapCustom)

0xA922

#define PhnLibTrapSetSMSPreference (189+sysLibTrapCustom)

0xA8C2 CDMA Only

#define PhnLibTrapSetSMSRingInfo (112+sysLibTrapCustom)

0xA875 GSM Only

#define PhnLibTrapSetSpecialNumbers (208+sysLibTrapCustom)

0xA8D5 CDMA Only

#define PhnLibTrapSetStatus (71+sysLibTrapCustom)

0xA84C

#define PhnLibTrapSetSysPrefMode (276+sysLibTrapCustom)

0xA919 CDMA Only

#define PhnLibTrapSetText (67+sysLibTrapCustom)

0xA848

#define PhnLibTrapSetToneLength (197+sysLibTrapCustom)

0xA8CA CDMA Only

#define PhnLibTrapSetTTYSetting (266+sysLibTrapCustom)

0xA90F

#define PhnLibTrapSetupDataConfig (212+sysLibTrapCustom)

0xA8D9 CDMA Only

#define PhnLibTrapSetVoicePrivacyMode (279+sysLibTrapCustom)

0xA91C CDMA Only

#define PhnLibTrapSetVolume (51+sysLibTrapCustom)

0xA838

#define PhnLibTrapSignalQuality (54+sysLibTrapCustom)

0xA83B

#define PhnLibTrapSignalQualityEx (255+sysLibTrapCustom)

0xA904 CDMA Only

#define PhnLibTrapSIMInfo (58+sysLibTrapCustom)

0xA83F

#define PhnLibTrapSndDelete (225+sysLibTrapCustom)

0xA8E6 CDMA Only

#define PhnLibTrapSndSave (224+sysLibTrapCustom)

0xA8E5 CDMA Only

#define PhnLibTrapStartIOTASession (239+sysLibTrapCustom)

0xA8F4 CDMA Only

#define PhnLibTrapStartVibrate (114+sysLibTrapCustom)

0xA877

#define PhnLibTrapStopPDSession (223+sysLibTrapCustom)

0xA8E4 CDMA Only

#define PhnLibTrapStopTone (45+sysLibTrapCustom)

0xA832

#define PhnLibTrapStopVibrate (115+sysLibTrapCustom)

0xA878

#define PhnLibTrapTunnelIS683ReqMsg (241+sysLibTrapCustom)

0xA8F6 CDMA Only

#define PhnLibTrapUninstall (1+sysLibTrapCustom)

0xA806

#define PhnLibTrapUnlockPhoneLock (198+sysLibTrapCustom)

0xA8CB CDMA Only

#define PhnLibTrapUpdateCustomizedNV (234+sysLibTrapCustom)

0xA8EF CDMA Only

#define PhnLibTrapUpdateMessageCount (187+sysLibTrapCustom)

0xA8C0 CDMA Only

#define PhnLibTrapUsableSignalStrengthThreshold (122+sysLibTrapCustom)

0xA87F GSM Only

#define PhnLibTrapVerifyICDVer (260+sysLibTrapCustom)

0xA909 CDMA Only

#define PhnLibTrapWriteIOTAItem (246+sysLibTrapCustom)

0xA8FB CDMA Only

#define PrvPhnLibTrapCheckPowerSync (215+sysLibTrapCustom)

0xA8DC CDMA Only

#define Reserved2 (252+sysLibTrapCustom)

0xA901 CDMA Only

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:50 2006 for Palm API Guide


HsPhoneTypes.h File Reference

Detailed Description

Telephony data types that are common between ARM and 68K.

Include dependency graph for HsPhoneTypes.h:

Type and creator of CDMA and GSM phone libraries.

  • #define phnLibDbType 'libr'
  • #define phnLibCDMADbCreator 'PIL!'
  • #define phnLibCDMAName "Phone Library"
  • #define phnLibOldCDMADbCreator hsFileCCDMAPhoneLib
  • #define phnLibOldCDMAName "PhoneLib.prc"
  • #define phnLibGSMDbCreator hsFileCGSMPhoneLib
  • #define phnLibGSMDbName "Phone Library"
  • #define phnLibGSMName "GSMLibrary.lib"
  • #define phnVoiceCall1Active 0x0001
  • #define phnVoiceCall2Active 0x0002
  • #define phnCSDCallActive 0x0004
  • #define phnGPRSCallActive 0x0008
  • #define phnPacketDataCallActive 0x0008
  • #define phnPacketDataCallDormant 0x0010
  • #define phnCall1StatusActive 0x0020
  • #define phnCall2StatusActive 0x0040
  • #define phnCall1StatusDialing 0x0080
  • #define phnCall2StatusDialing 0x0100
  • #define phnCall1StatusIncoming 0x0200
  • #define phnCall2StatusIncoming 0x0400
  • #define phnCall1StatusAlerting 0x0800
  • #define phnCall2StatusAlerting 0x1000

CDMA Threshold level for signal bar (based on Generic Handset requirement)

  • #define maxDBm4signalLevel0 105
  • #define maxDBm4signalLevel1 95
  • #define maxDBm4signalLevel2 85
  • #define maxDBm4signalLevel3 75
  • #define maxDB4ecioLevel0 15
  • #define maxDB4ecioLevel1 13
  • #define maxDB4ecioLevel2 11
  • #define maxDB4ecioLevel3 9

Volume

  • #define phnVolumeMin 0
  • #define phnVolumeMax 7

Enumerations and Typedefs

  • #define phnLibUnknownID 0xff000000
  • #define phnLibNoLookupNeededID 0xff000001
  • #define phnLibFtrNumResetFlag 10
  • #define phnLibFtrNumBottomBRate 11
  • #define phnLibFtrNumBlockATCmd 12
  • #define phnLibFtrValBlockATCmd 'noAT'

Defines

  • #define isValidPhoneServiceClassType(s) ((s & phnServiceAll) != 0)
  • #define isValidPhnAddressField(a) ((a >= phnAddrFldPhone) && (a <= phnAddrFldLastName))
  • #define isValidGSMDialCLIRMode(d) ((d >= gsmDialCLIRDefault) && (d <= gsmDialCLIRTemporarySuppression))
  • #define isValidPhnPowerType(p) (p <= phnPowerSave)
  • #define isValidPhnLockMode(m) ((m >= autoLockMode) && (m <= immediateLockMode))

Typedefs

  • typedef UInt16 PhnConnectionID
  • typedef UInt32 PhnDatabaseID
  • typedef VoidHand PhnAddressHandle
  • typedef VoidHand PhnAddressList
  • typedef UInt32 PhnOperatorID
  • typedef UInt16 PhoneServiceClassType
  • typedef UInt8 PhnAddressField
  • typedef UInt8 GSMDialCLIRMode
  • typedef UInt8 PhnPowerType
  • typedef UInt8 GSMSIMStatus
  • typedef UInt8 PhnLifeTimer
  • typedef UInt8 PhnLockMode

Enumerations

  • enum _PhoneServiceClassType {
    phnServiceVoice = 1,
    phnServiceSMS = 2,
    phnServiceActivation = 4,
    phnServiceData = 8,
    phnServiceIOTA = 16,
    phnServiceSIMToolkit = 32,
    phnServiceAFLT = 64,
    phnServiceMisc = 128,
    phnServiceEssentials = 256,
    phnServiceMMS = 512,
    phnServiceWAP = 1024,
    phnServiceAll,
    phnServiceMax = 0xFFFF
    }
  • enum _PhnAddressField {
    phnAddrFldPhone,
    phnAddrFldFirstName,
    phnAddrFldLastName
    }
  • enum _GSMDialCLIRMode {
    gsmDialCLIRDefault,
    gsmDialCLIRTemporaryInvocation,
    gsmDialCLIRTemporarySuppression
    }
  • enum _PhnPowerType {
    phnPowerOff,
    phnPowerOn,
    phnPowerStartCharging,
    phnPowerStopCharging,
    phnPowerLow,
    phnPowerSave
    }
  • enum _GSMSIMStatus {
    simMissing,
    simFailure,
    simWrong,
    simNotReady,
    simReady,
    simUnknown,
    simPresent
    }
  • enum {
    lifeTimeVoice,
    lifeTimeData
    }
  • enum PhnLockModeEnum {
    autoLockMode,
    immediateLockMode
    }

Define Documentation

#define maxDB4ecioLevel0 15

if below maxDBm4signalLevel3 then display 4 bars, mid percent = 90 Threshold ecio level for signal bar (based on Generic Handset requirement) will display no bar

#define maxDB4ecioLevel1 13

will display 1 bar

#define maxDB4ecioLevel2 11

will display 2 bars

#define maxDB4ecioLevel3 9

will display 3 bars

#define maxDBm4signalLevel0 105

will display no bar, mid percent = 10

#define maxDBm4signalLevel1 95

will display 1 bar, mid percent = 30

#define maxDBm4signalLevel2 85

will display 2 bars, mid percent = 50

#define maxDBm4signalLevel3 75

will display 3 bars, mid percent = 70

#define phnCall1StatusActive 0x0020

The first call's status is phnConnectionActive

#define phnCall1StatusAlerting 0x0800

The first call's status is phnConnectionIncoming

#define phnCall1StatusDialing 0x0080

The first call's status is phnConnectionDialing

#define phnCall1StatusIncoming 0x0200

The first call's status is phnConnectionIncoming

#define phnCall2StatusActive 0x0040

The second call's status is phnConnectionActive

#define phnCall2StatusAlerting 0x1000

The second call's status is phnConnectionIncoming

#define phnCall2StatusDialing 0x0100

The second call's status is phnConnectionDialing

#define phnCall2StatusIncoming 0x0400

The second call's status is phnConnectionIncoming

#define phnCSDCallActive 0x0004

There is a data call currently active

#define phnGPRSCallActive 0x0008

There is a GPRS (GSM) session active

#define phnLibCDMADbCreator 'PIL!'

CDMA Library creator

#define phnLibCDMAName "Phone Library"

CDMA Library name

#define phnLibDbType 'libr'

Phone Library type

#define phnLibGSMDbCreator hsFileCGSMPhoneLib

GSM Library creator

#define phnLibGSMDbName "Phone Library"

GSM Library database name

#define phnLibGSMName "GSMLibrary.lib"

GSM Library name

#define phnLibOldCDMADbCreator hsFileCCDMAPhoneLib

Old CDMA Library creator

#define phnLibOldCDMAName "PhoneLib.prc"

Old CDMA Library name

#define phnPacketDataCallActive 0x0008

There is an active 1X (CDMA) call

#define phnPacketDataCallDormant 0x0010

There is a dormany 1X (CDMA) call

#define phnVoiceCall1Active 0x0001

There is a voice call active on line1

#define phnVoiceCall2Active 0x0002

There is a voice call active on line2

#define phnVolumeMax 7

Maximum volume level

#define phnVolumeMin 0

Minimum volume level

Typedef Documentation

typedef UInt16 PhnConnectionID

Connection ID

typedef UInt32 PhnDatabaseID

Database ID

Enumeration Type Documentation

anonymous enum

LifeTimer Enums

enum _GSMDialCLIRMode

GSM CLIR Mode

enum _GSMSIMStatus

Status of the SIM on GSM radio only

enum _PhnAddressField

Phone address fields

enum _PhnPowerType

Power state of the radio

Enumerator:
phnPowerSave Modem goes to deep sleep after failing to search for service

enum _PhoneServiceClassType

Classes of service for which applications can register

Enumerator:
phnServiceVoice | 0x0001
phnServiceSMS | 0x0002
phnServiceActivation | 0x0004
phnServiceData | 0x0008
phnServiceIOTA | 0x0010
phnServiceSIMToolkit | 0x0020
phnServiceAFLT | 0x0040
phnServiceMisc | 0x0080
phnServiceEssentials | 0x0100
phnServiceMMS | 0x200
phnServiceWAP | 0x400
phnServiceMax | Reserved.

enum PhnLockModeEnum

Enumerator:
autoLockMode | option Lock Phone on Power Down is chosen
immediateLockMode | option Lock Phone immediately is chosen

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:50 2006 for Palm API Guide


HsSoundLib.h File Reference

Detailed Description

Public 68K include file for main sound support for Treo 600 and Treo 650 smartphones.

This header file and associated header files support the specific sound functionality of the Treo smartphones. You should use the Palm OS Sound Manager APIs for most of your work.

Notes: The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application(ie, SysLibFind() returns a valid refnum). When the application is done with the library, it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal synchronization.

Include dependency graph for HsSoundLib.h:

Preference Macros

  • #define PmSndSetPreference(libRef, prefID, prefValue) HsSndSwitchSetPort( libRef, pmSndSwitchID_Preferences, (HsSndPortID) (prefValue), (HsSndPortClass) (prefID) );
  • #define PmSndGetPreference(libRef, prefID, prefValuePtr) HsSndSwitchGetPort( libRef, pmSndSwitchID_Preferences, (HsSndPortID *) (prefValuePtr), (HsSndPortClass) (prefID) );

Special Function Macros

  • #define PmSndStreamSetAttackEnvID(libRef, stream, attackEnvID) HsSndFormatPlay( libRef, (HsSndFormatType) pmSndFormatSetAttackEnvID, (HsSndCmdType) attackEnvID, (void*)0, (UInt32) stream )
  • #define PmSndStreamPause(libRef, stream) HsSndFormatPlay( libRef, (HsSndFormatType) pmSndFormatPauseStream, (HsSndCmdType) 0, (void*) 0, (UInt32) stream )
  • #define PmSndStreamResume(libRef, stream) HsSndFormatPlay( libRef, (HsSndFormatType) pmSndFormatResumeStream, (HsSndCmdType) 0, (void*) 0, (UInt32) stream )
  • #define PmSndStreamStoppable(libRef, stream) HsSndFormatPlay( libRef, (HsSndFormatType) pmSndFormatSetStoppable, (HsSndCmdType) 0, (void*) 0, (UInt32) stream )

Functions

  • Err HsSndOpen (UInt16 libRef)
  • Err HsSndClose (UInt16 libRef)
  • UInt32 HsSndGetVersion (UInt16 libRef)
  • Err HsSndPortGetInfo (UInt16 libRef, HsSndPortID portID, HsSndPortInfo *portInfoP)
  • Err HsSndPortSetParam (UInt16 libRef, HsSndPortID portID, HsSndParam paramSel, Int16 value, Int16 *returnValue)
  • Err HsSndSwitchGetPort (UInt16 libRef, HsSndSwitchID switchID, HsSndPortID *portIDP, HsSndPortClass portClass)
  • Err HsSndSwitchSetPort (UInt16 libRef, HsSndSwitchID switchID, HsSndPortID portID, HsSndPortClass portClass)
  • Err HsSndTonePlay (UInt16 libRef, UInt32 freq, UInt16 amp, UInt32 duration, UInt32 toneType)
  • Err HsSndToneStop (UInt16 libRef)
  • Err HsSndFormatPlay (UInt16 libRef, HsSndFormatType format, HsSndCmdType command, void *commandData, UInt32 commandFlags)
  • Err HsSndFormatRecord (UInt16 libRef, HsSndFormatType format, HsSndCmdType command, void *commandData, UInt32 commandFlags)
  • Err HsSndGetUserVolume (UInt16 libRef, HsSndMode mode, Int16 *volumeP)
  • Err HsSndSetUserVolume (UInt16 libRef, HsSndMode mode, Int16 volume)
  • Err PmSndClkGetTicksPerSecond (UInt16 libRef, PmClkTickRef clkRef, UInt32 *ticksPerSecondP)
  • Err PmSndClkGetTickCount (UInt16 libRef, PmClkTickRef clkRef, PmSndU64 *clockTicksP)
  • Err PmSndGetPosition (UInt16 libRef, SndStreamRef streamRef, PmSndU64 *sampleNumberP, PmClkTickRef clkRef, PmSndU64 *clockTicksP)

Function Documentation

Err HsSndClose ( UInt16 libRef )

Close the Sound library instance.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad)
Returns:
Library error code.

Err HsSndFormatPlay | ( | UInt16 | libRef,
 |  | HsSndFormatType | format,
 |  | HsSndCmdType | command,
 |  | void * | commandData,
 |  | UInt32 | commandFlags
 | ) |

Play formatted audio data, such as MIDI, AMR, and so forth.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad).
format,: IN: Audio format to be played.
command,: IN: Command to execute. Should be set to hsSndCmdPlay.
commandData,: IN: Command to the sound buffer structure HsSndBufferData
commandFlags,: IN: Command flags for the play command.
Returns:
Library error code.

Err HsSndFormatRecord | ( | UInt16 | libRef,
 |  | HsSndFormatType | format,
 |  | HsSndCmdType | command,
 |  | void * | commandData,
 |  | UInt32 | commandFlags
 | ) |

Records formatted audio data, such as MIDI, AMR, and so forth. (Currently a stub and not implemented yet).

Parameters:
libRef,: IN: Library reference number (from SysLibLoad).
format,: IN: Audio format to be recorded.
command,: IN: Command to execute. Should be set to hsSndCmdPlay.
commandData,: IN: Pointer to the sound buffer structure HsSndBufferData.
commandFlags,: IN: The command flags for the record command.
Returns:
Library error code.

Err HsSndGetUserVolume | ( | UInt16 | libRef,
 |  | HsSndMode | mode,
 |  | Int16 * | volumeP
 | ) |

Get the user volume setting for the specified sound mode.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad).
mode,: IN: The audio configuration mode.
volumeP,: IN: The sound level.
Returns:
Library error code.

UInt32 HsSndGetVersion ( UInt16 libRef )

Returns the library version number.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad)
Returns:
Library error code.

Err HsSndOpen ( UInt16 libRef )

Open and initialize the Sound library instance.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad)
Returns:
Library error code.

Err HsSndPortGetInfo | ( | UInt16 | libRef,
 |  | HsSndPortID | portID,
 |  | HsSndPortInfo * | portInfoP
 | ) |

Returns information about the sound port.

Parameters:
libRef,: IN: Library reference number
portID,: IN: Sound port ID.
*portInfoP,: IN: Pointer to an HsSndPortInfo structure provided by the caller.
Returns:
Library error code.

Err HsSndPortSetParam | ( | UInt16 | libRef,
 |  | HsSndPortID | portID,
 |  | HsSndParam | paramSel,
 |  | Int16 | value,
 |  | Int16 * | returnValue
 | ) |

Set a sound port's audio parameter.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad)
portID,: IN: Sound port ID.
paramSel,: IN: Parameter selector.
value,: IN: Value to set.
returnValue,: OUT: Pointer to the updated value.
Returns:
Library error code.

Err HsSndSetUserVolume | ( | UInt16 | libRef,
 |  | HsSndMode | mode,
 |  | Int16 | volume
 | ) |

Set the user volume for the specified sound mode.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad).
mode,: IN: The audio configuration mode.
volume,: IN: The sound level.
Returns:
Library error code.

Err HsSndSwitchGetPort | ( | UInt16 | libRef,
 |  | HsSndSwitchID | switchID,
 |  | HsSndPortID * | portIDP,
 |  | HsSndPortClass | portClass
 | ) |

Get the current sound port for a particular switch.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad)
switchID,: IN: Switch ID.
portIDP,: OUT: Port ID returned to the caller.
portClass,: IN: Port class selector.
Returns:
Library error code.

Err HsSndSwitchSetPort | ( | UInt16 | libRef,
 |  | HsSndSwitchID | switchID,
 |  | HsSndPortID | portID,
 |  | HsSndPortClass | portClass
 | ) |

Set the current sound port for a particular switch.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad)
switchID,: IN: Switch ID.
portID,: IN: The new port ID for the audio switch.
portClass,: IN: Port class selector.
Returns:
Library error code.

Err HsSndTonePlay | ( | UInt16 | libRef,
 |  | UInt32 | freq,
 |  | UInt16 | amp,
 |  | UInt32 | duration,
 |  | UInt32 | toneType
 | ) |

Play a sound.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad).
freq,: IN: Frequency of the tone.
amp,: IN: Amplitude of the tone.
duration,: IN: Duration of the tone.
toneType,: IN: Type of tone to play.
Returns:
Library error code.

Err HsSndToneStop ( UInt16 libRef )

Stop playing a sound that was started with HsSndTonePlay().

Parameters:
libRef,: IN: Library reference number (from SysLibLoad).
Returns:
Library error code.

Err PmSndClkGetTickCount | ( | UInt16 | libRef,
 |  | PmClkTickRef | clkRef,
 |  | PmSndU64 * | clockTicksP
 | ) |

Get current clock tick count.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad).
clkRef,: IN: Clock reference number (see HsSoundLibCommon.h).
clockTicksP OUT: Returns the current clock tick count.
Returns:
Library error code.

Err PmSndClkGetTicksPerSecond | ( | UInt16 | libRef,
 |  | PmClkTickRef | clkRef,
 |  | UInt32 * | ticksPerSecondP
 | ) |

Get the number of clock ticks per second

Parameters:
libRef,: IN: Library reference number (from SysLibLoad).
clkRef,: IN: Clock reference number (see HsSoundLibCommon.h).
ticksPerSecondP OUT: Returns the tick per second
Returns:
Library error code.

Err PmSndGetPosition | ( | UInt16 | libRef,
 |  | SndStreamRef | streamRef,
 |  | PmSndU64 * | sampleNumberP,
 |  | PmClkTickRef | clkRef,
 |  | PmSndU64 * | clockTicksP
 | ) |

Get current stream sample position and current clock tick count.

Parameters:
libRef,: IN: Library reference number (from SysLibLoad).
streamRef | IN: Sound stream channel reference id.
sampleNumberP,: OUT: Returns the current sample number for the stream.
clkRef,: IN: Clock reference number (see HsSoundLibCommon.h).
clockTicksP | OUT: Returns the current clock tick count.
Returns:
Library error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:51 2006 for Palm API Guide


HsSoundLibCommon.h File Reference

Detailed Description

Public 68K common header file for sound support for Treo 600 and Treo 650 smartphones.

This file contains the common constants and structures to be used with the sound library.

Include dependency graph for HsSoundLibCommon.h:

Data Structures

  • struct HsSndPortInfo
    Holds sound port information. More...
  • struct HsSndBufferData
    Holds sound buffer information. More...
  • struct HsSndMidiProgressMsg

HsSoundLib information

  • #define hsSndLibVersion 0x010B0000
  • #define hsSoundLibCreatorID hsFileSoundLib
  • #define hsSoundLibTypeID sysFileTLibrary
  • #define hsSoundLibName "HsSoundLib"

Sound library event notifications

  • #define hsSndNotify hsFileSoundLib
  • #define hsSndNotifyUnplugged 'hOff'
  • #define hsSndNotifyHeadset 'hSet'
  • #define hsSndNotifyHeadphones 'hPho'
  • #define hsSndNotifyHybrid 'hHyb'
  • #define hsSndNotifyAnswerButton 'hAns'
  • #define hsSndNotifyAnswerHold 'hHol'
  • #define hsSndNotifyAnswerRelease 'hRel'
  • #define hsSndNotifyRingerSwitchOn 'hROn'
  • #define hsSndNotifyRingerSwitchOff 'hROf'
  • #define hsSndNotifyHighPriority 'hHPr'
  • #define hsSndNotifyAlert 'hAlr'
  • #define hsSndNotifyCarkitActive 'hCar'
  • #define hsSndNotifyCarkitInactive 'hCOf'
  • #define hsSndNotifyAthenaAudio 'hAta'

Sound library resource types

  • #define hsSndRsrcAudioTableType 'hTbl'
  • #define hsSndRsrcAudioTableID 25000

Sound library error codes

  • #define hsSndErrBase hsSoundLibErrorClass
  • #define HS_SND_ERR(x) ((Err)((x) + hsSndErrBase))
  • #define hsSndErr_Failed (HS_SND_ERR(1))
  • #define hsSndErr_NotSupported (HS_SND_ERR(2))
  • #define hsSndErr_InvalidPort (HS_SND_ERR(3))
  • #define hsSndErr_PortCannotMute (HS_SND_ERR(4))
  • #define hsSndErr_PortCannotVolume (HS_SND_ERR(5))
  • #define hsSndErr_PortCannotBoost (HS_SND_ERR(6))
  • #define hsSndErr_PortCannotPan (HS_SND_ERR(7))
  • #define hsSndErr_InvalidSwitch (HS_SND_ERR(8))
  • #define hsSndErr_UnknownSndParam (HS_SND_ERR(9))
  • #define hsSndErr_UnknownPortClass (HS_SND_ERR(10))
  • #define hsSndErr_PortIDNotInClass (HS_SND_ERR(11))
  • #define hsSndErr_PortMuteLocked (HS_SND_ERR(12))
  • #define hsSndErr_PortVolumeLocked (HS_SND_ERR(13))
  • #define hsSndErr_PortBoostLocked (HS_SND_ERR(14))
  • #define hsSndErr_PortPanLocked (HS_SND_ERR(15))
  • #define hsSndErr_DoMidiProgressMsg (HS_SND_ERR(16))
  • #define hsSndErr_UnknownClkRef (HS_SND_ERR(17))
  • #define hsSndErr_InvalidPrefValue (HS_SND_ERR(18))
  • #define hsSndErr_LastPublicError (HS_SND_ERR(63))

Sound mode volume controls

Use with HsSndGetUserVolume and HsSndSetUserVolume.
  • #define hsSndMode_Current ((HsSndMode) 0x0000)
  • #define hsSndMode_Receiver ((HsSndMode) 0x0001)
  • #define hsSndMode_Speakerphone ((HsSndMode) 0x0002)
  • #define hsSndMode_SpeakerHost ((HsSndMode) 0x0003)
  • #define hsSndMode_Headset ((HsSndMode) 0x0004)
  • #define hsSndMode_Headphones ((HsSndMode) 0x0005)
  • #define hsSndMode_HeadphonesHost ((HsSndMode) 0x0006)
  • #define hsSndMode_Carkit ((HsSndMode) 0x0007)
  • #define hsSndMode_Reserved ((HsSndMode) 0x0008)

Tone type parameter

  • #define hsSndToneType_Square 0

Utility Macros - I

  • #define HS_AC97(n) ((n) | hsSndBayID_AC97)
  • #define HS_RDIO(n) ((n) | hsSndBayID_Radio)
  • #define HsSndParamValue_SetWithLock(v) (((v) & ~hsSndParamMode_Mask) | hsSndParamMode_LockParam)
  • #define HsSndParamValue_SetWithUnlock(v) (((v) & ~hsSndParamMode_Mask) | hsSndParamMode_UnlockParam)
  • #define HsSndParamValue_RemoveMode(v) (((v) & 0x8000)? (v) | hsSndParamMode_Mask : (v) & ~hsSndParamMode_Mask)

Sound switch configuration types

Used with HsSndSwitchID.
  • #define hsSndSwitchID_InRadioSpkr HS_AC97(0x00010000)
  • #define hsSndSwitchID_OutRadioMic HS_AC97(0x00020000)
  • #define hsSndSwitchID_InMic HS_AC97(0x00030000)
  • #define hsSndSwitchID_InHostPlay HS_AC97(0x00040000)
  • #define hsSndSwitchID_OutHostRec HS_AC97(0x00050000)

Sound port configuration types

Used with HsSndPortID.
  • #define hsSndPortID_Off 0x00000000
  • #define hsSndPortID_Current HS_AC97(0x00000000)
  • #define hsSndPortID_OutReceiver HS_AC97(0x00000001)
  • #define hsSndPortID_OutSpeaker HS_AC97(0x00000002)
  • #define hsSndPortID_OutHeadset HS_AC97(0x00000003)
  • #define hsSndPortID_OutHeadphones HS_AC97(0x00000004)
  • #define hsSndPortID_OutSpeakerAuto HS_AC97(0x00000005)
  • #define hsSndPortID_InLineRec HS_AC97(0x00000006)
  • #define hsSndPortID_InBaseMic HS_AC97(0x00000007)
  • #define hsSndPortID_InHeadsetMic HS_AC97(0x00000008)
  • #define hsSndPortID_InMicAuto HS_AC97(0x00000009)
  • #define hsSndPortID_OutRadioMic HS_AC97(0x0000000A)
  • #define hsSndPortID_InRadioSpkr HS_AC97(0x0000000B)
  • #define hsSndPortID_OutHostRec HS_AC97(0x0000000C)
  • #define hsSndPortID_InHostPlay HS_AC97(0x0000000D)
  • #define hsSndPortID_OutBtHeadset HS_AC97(0x0000000E)
  • #define hsSndPortID_OutBtHandsfree HS_AC97(0x0000000F)
  • #define hsSndPortID_InHostBaseMic HS_AC97(0x00000010)
  • #define hsSndPortID_InHostHeadsetMic HS_AC97(0x00000011)
  • #define hsSndPortID_InHostPhone HS_AC97(0x00000012)
  • #define hsSndPortID_InCarkit HS_AC97(0x00000013)
  • #define hsSndPortID_OutCarkit HS_AC97(0x00000014)
  • #define hsSndPortID_LastPort HS_AC97(0x00000014)

RadioBayID

  • #define hsSndBayID_Radio 0x02000000

Sound switch configuration type for Radio patch bay

Used with HsSndSwitchID.
  • #define hsSndSwitchID_RadioCall HS_RDIO(0x00010000)

Sound port configuration type for hsSndSwitchID_RadioCall

hsSndPortID_Off is already defined for all patch bays. Use it to turn off the switch indicating no radio call connected.
  • #define hsSndPortID_ConnectCall HS_RDIO(0x00000020)

Sound port classes

Used when passing a HsSndPortClass parameter in HsSndSwitchGetPort and HsSndSwitchSetPort functions.
  • #define hsSndPortClass_Virtual ((UInt16) 0)
  • #define hsSndPortClass_Real ((UInt16) 1)
  • #define hsSndPortClass_BaseDefault ((UInt16) 2)
  • #define hsSndPortClass_Anchor ((UInt16) 3)

Sound parameters

Used when passing a parameter of type HsSndParam.
  • #define hsSndParam_Volume ((UInt16) 1)
  • #define hsSndParam_Mute ((UInt16) 2)
  • #define hsSndParam_Boost ((UInt16) 3)
  • #define hsSndParam_Pan ((UInt16) 4)

Sound parameter expansion macros

Used to add sound parameter values for additional sound parameter control. For example, muteState = HsSndParamValue_SetWithLock(hsSndMute_Enable);.
  • #define hsSndParamMode_Mask 0x7000
  • #define hsSndParamMode_Normal 0x0000
  • #define hsSndParamMode_LockParam 0x4000
  • #define hsSndParamMode_UnlockParam 0x2000

Mute parameters

Used to enable or disable a hsSndParam_Mute parameter.
  • #define hsSndMute_Enable 1
  • #define hsSndMute_Disable 0

Boost parameters

Used to enable or disable a hsSndParam_Boost parameter.
  • #define hsSndBoost_Enable 1
  • #define hsSndBoost_Disable 0

Pan parameters

Used as special hsSndParam_Pan parameters otherwise use actual Pan value.
  • #define hsSndPan_Middle ((Int16) 0x0000)
  • #define hsSndPan_Right ((Int16) 0x7FFF)
  • #define hsSndPan_Left ((Int16) 0x8000)
  • #define hsSndPan_RightNormal ((Int16) 0x07FF)
  • #define hsSndPan_LeftNormal ((Int16) 0x0800)

Sound port flag settings

Used with the "flags" variable in HsSndPortInfo structure.
  • #define hsSndPortFlags_Enabled 0x00000001
  • #define hsSndPortFlags_Disabled 0x00000000
  • #define hsSndPortFlags_EnableMask 0x00000001
  • #define hsSndPortFlags_MuteOn 0x00000002
  • #define hsSndPortFlags_MuteOff 0x00000000
  • #define hsSndPortFlags_MuteMask 0x00000002
  • #define hsSndPortFlags_TypeDigital 0x00000004
  • #define hsSndPortFlags_TypeAnalog 0x00000000
  • #define hsSndPortFlags_TypeMask 0x00000004
  • #define hsSndPortFlags_BoostOn 0x00000008
  • #define hsSndPortFlags_BoostOff 0x00000000
  • #define hsSndPortFlags_BoostMask 0x00000008
  • #define hsSndPortFlags_CanInputOnly 0x00000000
  • #define hsSndPortFlags_CanOutputOnly 0x00000010
  • #define hsSndPortFlags_CanIOSelect 0x00000020
  • #define hsSndPortFlags_CanIOBothways 0x00000030
  • #define hsSndPortFlags_CanIOMask 0x00000030
  • #define hsSndPortFlags_InputOn 0x00000040
  • #define hsSndPortFlags_InputOff 0x00000000
  • #define hsSndPortFlags_InputMask 0x00000040
  • #define hsSndPortFlags_OutputOn 0x00000080
  • #define hsSndPortFlags_OutputOff 0x00000000
  • #define hsSndPortFlags_OutputMask 0x00000080
  • #define hsSndPortFlags_CanMute_Yes 0x00000100
  • #define hsSndPortFlags_CanMute_No 0x00000000
  • #define hsSndPortFlags_CanMuteMask 0x00000100
  • #define hsSndPortFlags_CanBoost_Yes 0x00000200
  • #define hsSndPortFlags_CanBoost_No 0x00000000
  • #define hsSndPortFlags_CanBoostMask 0x00000200
  • #define hsSndPortFlags_CanPan_Yes 0x00000400
  • #define hsSndPortFlags_CanPan_No 0x00000000
  • #define hsSndPortFlags_CanPanMask 0x00000400
  • #define hsSndPortFlags_CanVol_Yes 0x00000800
  • #define hsSndPortFlags_CanVol_No 0x00000000
  • #define hsSndPortFlags_CanVolMask 0x00000800
  • #define hsSndPortFlags_Mute_Locked 0x00001000
  • #define hsSndPortFlags_Mute_Unlocked 0x00000000
  • #define hsSndPortFlags_Mute_LockMask 0x00001000
  • #define hsSndPortFlags_Boost_Locked 0x00002000
  • #define hsSndPortFlags_Boost_Unlocked 0x00000000
  • #define hsSndPortFlags_Boost_LockMask 0x00002000
  • #define hsSndPortFlags_Pan_Locked 0x00004000
  • #define hsSndPortFlags_Pan_Unlocked 0x00000000
  • #define hsSndPortFlags_Pan_LockMask 0x00004000
  • #define hsSndPortFlags_Vol_Locked 0x00008000
  • #define hsSndPortFlags_Vol_Unlocked 0x00000000
  • #define hsSndPortFlags_Vol_LockMask 0x00008000

Command flag settings

Used with the "Commandflags" parameter in HsSndFormatPlay function.
  • #define hsSndCmdFlags_noWait 0x00000001
  • #define hsSndCmdFlags_yesWait 0x00000000
  • #define hsSndCmdFlags_waitMask 0x00000001

Sound buffer flag settings

Used with the "flags" parameter in HsSndBufferData.
  • #define hsSndBufFlags_canInterrupt 0x0001
  • #define hsSndBufFlags_cannotInterrupt 0x0000
  • #define hsSndBufFlags_interruptMask 0x0001
  • #define hsSndBufFlags_yesRepeat 0x0002
  • #define hsSndBufFlags_noRepeat 0x0000
  • #define hsSndBufFlags_repeatMask 0x0002
  • #define hsSndBufFlags_yesEndDelay 0x0004
  • #define hsSndBufFlags_noEndDelay 0x0000
  • #define hsSndBufFlags_endDelayMask 0x0004
  • #define hsSndBufFlags_attackEnvNone 0x0000
  • #define hsSndBufFlags_attackEnvRings 0x0010
  • #define hsSndBufFlags_attackEnvVibeNone 0x0020
  • #define hsSndBufFlags_attackEnvVibeRings 0x0030
  • #define hsSndBufFlags_attackEnvMask 0x00F0

Buffer amplitude settings

Used with HsSndBufferData.amplitude field.
  • #define hsSndAmplitude_silent ((UInt32) 0)
  • #define hsSndAmplitude_unity ((UInt32) 1024)

Buffer control macros

Use these macros to set or get the proper control in HsSndBufferData.controls field.
  • #define HsSndBufControl_SetRepeat(controls, value) (controls = ((controls & 0xFFFFFF00) | (((UInt32) value) & 0xFF) ))
  • #define HsSndBufControl_GetRepeat(controls) (controls & 0x000000FF)
  • #define HsSndBufControl_SetEndDelay(controls, value) (controls = ((controls & 0xFFFF00FF) | ((((UInt32) value) & 0xFF) << 8)))
  • #define HsSndBufControl_GetEndDelay(controls) ((controls & 0x0000FF00) >> 8)
  • #define hsSndBufControl_repeatForever (0xFF)

Gain Envelope Definitions

Used as attackEnvID parameter to function PmSndStreamSetAttackEnvID.
  • #define pmSndAttackEnvIDRings (hsSndBufFlags_attackEnvRings)
  • #define pmSndAttackEnvIDVibeRing (hsSndBufFlags_attackEnvVibeRings)
  • #define pmSndBayID_AUDP 0x0F000000
  • #define PM_AUDP_CLASS_MASK 0x4000
  • #define PM_AUDP_CLASS(n) ((n) | PM_AUDP_CLASS_MASK)
  • #define pmSndPrefID_AppsGroupHoldType PM_AUDP_CLASS(0x0001)
  • #define pmSndPrefID_JackOutIfMicUnused PM_AUDP_CLASS(0x0002)
  • #define pmSndPrefID_PhoneRxGainLimit PM_AUDP_CLASS(0x0003)
  • #define pmSndPrefID_WakeOnAnswerBtn PM_AUDP_CLASS(0x0004)
  • #define pmSndPrefID_AudioTable PM_AUDP_CLASS(0x0005)
  • #define pmSndPrefID_GsmMccArray PM_AUDP_CLASS(0x0006)
  • #define pmSndPrefID_AthenaActive PM_AUDP_CLASS(0x0007)
  • #define pmSndPrefID_SleepMode PM_AUDP_CLASS(0x0008)
  • #define pmSndPrefID_AGCEvent PM_AUDP_CLASS(0x0009)
  • #define pmSndPrefID_AthenaAudio PM_AUDP_CLASS(0x000A)
  • #define pmSndPref_WakeOnAnswerBtn_Disable (0)
  • #define pmSndPref_WakeOnAnswerBtn_Enable (1)
  • #define pmSndPref_AthenaActive_No (0)
  • #define pmSndPref_AthenaActive_Yes (1)
  • #define pmSndPref_AthenaAudio_NoRouting (0)
  • #define pmSndPref_AthenaAudio_IfMicPresent (16)
  • #define pmSndPref_AthenaAudio_Unconditional (32)
  • #define PM_AUDP(n) ((n) | pmSndBayID_AUDP)
  • #define pmSndSwitchID_Preferences PM_AUDP(0x00400000)
  • #define pmAudioClkTickRef ((PmClkTickRef) 0x00000001)
  • typedef UInt16 PmSndPrefID
  • typedef UInt32 PmClkTickRef

Defines

  • #define hsSndBayID_AC97 0x01000000
  • #define hsSndMidiMsg_SetVolume 1
  • #define hsSndMidiProgressMsg_Signature 'MidP'
  • #define hsSndPortInfo_Signature 'SPRT'
  • #define hsSndBufferData_Signature 'SBDA'

Typedefs

  • typedef unsigned long long PmSndU64
  • typedef UInt8 hsSndSysBeepType
  • typedef Int16 HsSndMode
  • typedef UInt16 HsSndCmdType
  • typedef UInt32 HsSndPortID
  • typedef UInt32 HsSndSwitchID
  • typedef UInt16 HsSndParam
  • typedef UInt16 HsSndPortClass
  • typedef UInt16 HsSndFormatType
  • typedef struct HsSndPortInfo * HsSndPortInfoPtr
  • typedef Err(* HsSndBufferProc )(void *userdata, UInt32 flags, void *buffer, UInt32 bytesUsed, UInt32 time)
    Callback function used under various conditions with sound.

Enumerations

  • enum hsSndSysBeepTag {
    hsSndCardInsert = 64,
    hsSndCardRemove,
    hsSndSyncStart,
    hsSndSyncStop,
    hsSndChargerAttach,
    hsSndChargerDetach,
    hsSndRadioOn,
    hsSndRadioOff,
    hsSndBatFull,
    hsSndBatLow,
    hsSndBatShutdown,
    hsSndDeepWake,
    hsSndDeepSleep,
    hsSndRadioInServiceArea,
    hsSndRadioOutServiceArea
    }
  • enum HsSndCmdEnumTag {
    hsSndCmdPlay = 1,
    hsSndCmdStop
    }
  • enum HsSndFormatEnumTag {
    hsSndFormatMidi = 2,
    hsSndFormatAmr,
    pmSndFormatSetAttackEnvID,
    pmSndFormatPauseStream,
    pmSndFormatResumeStream,
    pmSndFormatSetStoppable
    }

Define Documentation

#define HS_AC97 ( n ) ((n) | hsSndBayID_AC97)

Associates the AC97 Bay ID with other element IDs

#define HS_RDIO ( n ) ((n) | hsSndBayID_Radio)

Associates the Radio Bay ID (hsSndBayID_Radio) with other element IDs

#define hsSndAmplitude_silent ((UInt32) 0)

Boost control on port is active.

#define hsSndAmplitude_unity ((UInt32) 1024)

Boost control on port is inactive.

#define hsSndBayID_AC97 0x01000000

An AC97 compatible chip is supported as the analog sound patch bay.

#define hsSndBayID_Radio 0x02000000

A defined patch bay for Telephony use.

#define hsSndBoost_Disable 0

Disables boost on a port.

#define hsSndBoost_Enable 1

Activates boost on a port.

#define hsSndBufFlags_attackEnvMask 0x00F0

Mask reserves up to 16 different envelope IDs.

#define hsSndBufFlags_attackEnvNone 0x0000

(Default) No attack envelope to be used.

#define hsSndBufFlags_attackEnvRings 0x0010

Use special attack envelope style suitable for call ringtones.

#define hsSndBufFlags_attackEnvVibeNone 0x0020

Use special attack envelope with initial vibration before envelope

#define hsSndBufFlags_attackEnvVibeRings 0x0030

Use special attack envelope for ringtones with initial vibration before envelope

#define hsSndBufFlags_canInterrupt 0x0001

Playback can be interrupted by user events.

#define hsSndBufFlags_cannotInterrupt 0x0000

(Default) Playback cannot be interrupted by user events.

#define hsSndBufFlags_endDelayMask 0x0004

No definition.

#define hsSndBufFlags_interruptMask 0x0001

No definition.

#define hsSndBufFlags_noEndDelay 0x0000

(Default) No delay after last batch of audio data processed.

#define hsSndBufFlags_noRepeat 0x0000

(Default) Buffer used only once.

#define hsSndBufFlags_repeatMask 0x0002

No definition.

#define hsSndBufFlags_yesEndDelay 0x0004

Delay completion of playback using the "delay" count in HsSndBufferData.controls.

#define hsSndBufFlags_yesRepeat 0x0002

Repeat the buffer using the "repeat" count in HsSndBufferData.controls.

#define hsSndCmdFlags_noWait 0x00000001

Use wait period for the play command.

#define hsSndCmdFlags_waitMask 0x00000001

No definition.

#define hsSndCmdFlags_yesWait 0x00000000

No wait period for the play command.

#define hsSndErr_DoMidiProgressMsg (HS_SND_ERR(16))

Special message returned by Midi progress callback to request a dynamic volume change.

#define hsSndErr_Failed (HS_SND_ERR(1))

The operation or request failed.

#define hsSndErr_InvalidPort (HS_SND_ERR(3))

An invalid port was passed to a function. Operation failed.

#define hsSndErr_InvalidPrefValue (HS_SND_ERR(18))

Unsupported or invalid audio preference value

#define hsSndErr_InvalidSwitch (HS_SND_ERR(8))

An invalid switch was passed to a function. Operation failed.

#define hsSndErr_LastPublicError (HS_SND_ERR(63))

just a marker for last public library error code, private sound error codes start at 64

#define hsSndErr_NotSupported (HS_SND_ERR(2))

Attempt to use functionality that is not supported in this version.

#define hsSndErr_PortBoostLocked (HS_SND_ERR(14))

Unable to change boost state when hsSndParamMode_Normal is the default.

#define hsSndErr_PortCannotBoost (HS_SND_ERR(6))

Unable to change boost state on a port that does not have boost capabilities.

#define hsSndErr_PortCannotMute (HS_SND_ERR(4))

Unable to change mute state on a port that does not have mute capabilities.

#define hsSndErr_PortCannotPan (HS_SND_ERR(7))

Unable to change pan settings on a port that does not have panning capabilities.

#define hsSndErr_PortCannotVolume (HS_SND_ERR(5))

Unable to change volume gains on a port that does not have volume capabilities.

#define hsSndErr_PortIDNotInClass (HS_SND_ERR(11))

The portID/portClass combination is not supported.

#define hsSndErr_PortMuteLocked (HS_SND_ERR(12))

Unable to change mute state when hsSndParamMode_Normal is the default.

#define hsSndErr_PortPanLocked (HS_SND_ERR(15))

Unable to change pan value when hsSndParamMode_Normal is the default.

#define hsSndErr_PortVolumeLocked (HS_SND_ERR(13))

Unable to change volume parameter when hsSndParamMode_Normal is the default.

#define hsSndErr_UnknownClkRef (HS_SND_ERR(17))

Unknown clock reference passed to synchronization clock utility

#define hsSndErr_UnknownPortClass (HS_SND_ERR(10))

An unknown HsSndPortClass value was passed to a function call.

#define hsSndErr_UnknownSndParam (HS_SND_ERR(9))

An unknown HsSndParam selector was passed to a function call.

#define hsSndLibVersion 0x010B0000

Version of the sound library.

#define hsSndMode_Carkit ((HsSndMode) 0x0007)

Mode when wired carkit is attached and active to the device.

#define hsSndMode_Current ((HsSndMode) 0x0000)

Pass to spefify the currently active sound mode.

#define hsSndMode_Headphones ((HsSndMode) 0x0005)

Mode when any audio goes to stereo headphones.

#define hsSndMode_HeadphonesHost ((HsSndMode) 0x0006)

Mode when radio is off and headphones used exclusively by system and third party audio.

#define hsSndMode_Headset ((HsSndMode) 0x0004)

Mode when any audio goes to a mono headphones.

#define hsSndMode_Receiver ((HsSndMode) 0x0001)

Mode when Radio audio goes to receiver speaker.

#define hsSndMode_Reserved ((HsSndMode) 0x0008)

Reserved for future definition. Do not use.

#define hsSndMode_SpeakerHost ((HsSndMode) 0x0003)

Mode when radio is off and speaker used exclusively by system and third party audio.

#define hsSndMode_Speakerphone ((HsSndMode) 0x0002)

Mode when Radio audio goes to loud speaker (speaker phone)

#define hsSndMute_Disable 0

Disables mute on a port.

#define hsSndMute_Enable 1

Activates mute on a port.

#define hsSndNotify hsFileSoundLib

HsSoundLib broadcaster's ID

#define hsSndNotifyAlert 'hAlr'

An alert sound is about to start playing.

#define hsSndNotifyAnswerButton 'hAns'

While a headset or hybrid was connected, the answer-button event was detected.

#define hsSndNotifyAnswerHold 'hHol'

After hsSndNotifyAnswerButton notification, this event is sent if answer-button is still held down for some time.

#define hsSndNotifyAnswerRelease 'hRel'

After hsSndNotifyAnswerButton notification, this event is sent when answer-button released.

#define hsSndNotifyAthenaAudio 'hAta'

Automatic audio switches will route to Athena connector from now on.

#define hsSndNotifyCarkitActive 'hCar'

Wired carkit has been activated, audio goes to carkit path.

#define hsSndNotifyCarkitInactive 'hCOf'

Wired carkit is no longer active, audio routes normally.

#define hsSndNotifyHeadphones 'hPho'

Headset jack connected and configured for stereo headphones.

#define hsSndNotifyHeadset 'hSet'

Headset jack connected and configured for mono headset with microphone.

#define hsSndNotifyHighPriority 'hHPr'

A high priority sound is about to start playing.

#define hsSndNotifyHybrid 'hHyb'

A hybrid headset/headphone is currently attached to the headset jack.

#define hsSndNotifyRingerSwitchOff 'hROf'

Notifies that ringer switch is in the silent (no sounds to back speaker) position.

#define hsSndNotifyRingerSwitchOn 'hROn'

Notifies that ringer switch is in the on (play sounds to back speaker) position.

#define hsSndNotifyUnplugged 'hOff'

No accesory is currently attached to the headset jack.

#define hsSndPan_Left ((Int16) 0x8000)

Pan all the way to the left. Cannot use with hsSndParamMode (defaults to Normal mode).

#define hsSndPan_LeftNormal ((Int16) 0x0800)

Pan all the way to the left. Can use with any hsSndParamMode.

#define hsSndPan_Middle ((Int16) 0x0000)

Pan at midpoint between left and right.

#define hsSndPan_Right ((Int16) 0x7FFF)

Pan all the way to the right. Cannot use with hsSndParamMode (defaults to Normal mode).

#define hsSndPan_RightNormal ((Int16) 0x07FF)

Pan all the way to the right. Can use with any hsSndParamMode.

#define hsSndParam_Boost ((UInt16) 3)

Changes the boost state of a port.

#define hsSndParam_Mute ((UInt16) 2)

Change the mute state of a port.

#define hsSndParam_Pan ((UInt16) 4)

Change the panning value of a port.

#define hsSndParam_Volume ((UInt16) 1)

Changes the volume of a port

#define hsSndParamMode_LockParam 0x4000

Limits parameter so it can only be changed with hsSndParamMode_LockParam or hsSndParamMode_UnlockParam.

#define hsSndParamMode_Mask 0x7000

The 3 upper bits after the sign bit in parameter values are reserved for the parameter mode.

#define hsSndParamMode_Normal 0x0000

Default parameter mode allowing parameter to be changed with any other hsSndParamMode.

#define hsSndParamMode_UnlockParam 0x2000

Removes hsSndParamMode_LockParam so it can be changed with any other hsSndParamMode.

#define HsSndParamValue_RemoveMode ( v ) (((v) & 0x8000)? (v) | hsSndParamMode_Mask : (v) & ~hsSndParamMode_Mask)

Removes LockParam or UnLockParam from parameter value.

#define HsSndParamValue_SetWithLock ( v ) (((v) & ~hsSndParamMode_Mask) | hsSndParamMode_LockParam)

Adds LockParam to parameter value.

#define HsSndParamValue_SetWithUnlock ( v ) (((v) & ~hsSndParamMode_Mask) | hsSndParamMode_UnlockParam)

Adds UnLockParam to parameter value.

#define hsSndPortClass_Anchor ((UInt16) 3)

Use to obtain the fixed port in a switch that doesn't change--the port that is patched to other ports. Valid only with HsSndSwitchGetPort.

#define hsSndPortClass_BaseDefault ((UInt16) 2)

Default port to use when restoring a Built-In port (For example, user unplugged headset while "auto" port was enabled.)

#define hsSndPortClass_Real ((UInt16) 1)

Current physical port. Use to change port parameters. Applies only to actual ports, not "auto" ports.

#define hsSndPortClass_Virtual ((UInt16) 0)

Symbolic port definition that applies to any port. Use for portID save and restore operations.

#define hsSndPortFlags_Boost_Locked 0x00002000

If locked, can only be changed with lock/unlock boost parameter changes/

#define hsSndPortFlags_Boost_LockMask 0x00002000

No definition.

#define hsSndPortFlags_Boost_Unlocked 0x00000000

Boost can be changed with any type of boost parameters.

#define hsSndPortFlags_BoostMask 0x00000008

No definition.

#define hsSndPortFlags_BoostOff 0x00000000

Boost control on port is inactive.

#define hsSndPortFlags_BoostOn 0x00000008

Boost control on port is active.

#define hsSndPortFlags_CanBoost_No 0x00000000

Port has no boost control.

#define hsSndPortFlags_CanBoost_Yes 0x00000200

Port has boost control available.

#define hsSndPortFlags_CanBoostMask 0x00000200

No definition.

#define hsSndPortFlags_CanInputOnly 0x00000000

Port is for sound input exclusively.

#define hsSndPortFlags_CanIOBothways 0x00000030

Port can be for sound input and output simultaneously.

#define hsSndPortFlags_CanIOMask 0x00000030

No definition.

#define hsSndPortFlags_CanIOSelect 0x00000020

Port can switch between being for sound input or output.

#define hsSndPortFlags_CanMute_No 0x00000000

Port has no mute control.

#define hsSndPortFlags_CanMute_Yes 0x00000100

Port has mute control available.

#define hsSndPortFlags_CanMuteMask 0x00000100

No definition.

#define hsSndPortFlags_CanOutputOnly 0x00000010

Port is for sound output exclusively.

#define hsSndPortFlags_CanPan_No 0x00000000

Port has No pan control.

#define hsSndPortFlags_CanPan_Yes 0x00000400

Port has pan control available.

#define hsSndPortFlags_CanPanMask 0x00000400

No definition.

#define hsSndPortFlags_CanVol_No 0x00000000

Port has No volume control.

#define hsSndPortFlags_CanVol_Yes 0x00000800

Port has volume control available.

#define hsSndPortFlags_CanVolMask 0x00000800

No definition.

#define hsSndPortFlags_Disabled 0x00000000

Port is disabled.

#define hsSndPortFlags_Enabled 0x00000001

Port is enabled and in use.

#define hsSndPortFlags_EnableMask 0x00000001

No definition.

#define hsSndPortFlags_InputMask 0x00000040

No definition.

#define hsSndPortFlags_InputOff 0x00000000

Port as sound input is disabled.

#define hsSndPortFlags_InputOn 0x00000040

Port as sound input is enabled.

#define hsSndPortFlags_Mute_Locked 0x00001000

If locked, can only be changed with lock/unlock mute parameter changes.

#define hsSndPortFlags_Mute_LockMask 0x00001000

No definition.

#define hsSndPortFlags_Mute_Unlocked 0x00000000

Mute can be changed with any type of mute parameters.

#define hsSndPortFlags_MuteMask 0x00000002

No definition.

#define hsSndPortFlags_MuteOff 0x00000000

Volume is as specified. (Not muted).

#define hsSndPortFlags_MuteOn 0x00000002

Volume is muted.

#define hsSndPortFlags_OutputMask 0x00000080

No definition.

#define hsSndPortFlags_OutputOff 0x00000000

Port as sound output is disabled.

#define hsSndPortFlags_OutputOn 0x00000080

Port as sound output is enabled.

#define hsSndPortFlags_Pan_Locked 0x00004000

If locked, can only be changed with lock/unlock pan parameter changes.

#define hsSndPortFlags_Pan_LockMask 0x00004000

No definition.

#define hsSndPortFlags_Pan_Unlocked 0x00000000

Pan can be changed with any type of pan parameters.

#define hsSndPortFlags_TypeAnalog 0x00000000

Sound data through port is analog.

#define hsSndPortFlags_TypeDigital 0x00000004

Sound data through port is digital.

#define hsSndPortFlags_TypeMask 0x00000004

No definition.

#define hsSndPortFlags_Vol_Locked 0x00008000

If locked, can only be changed with lock/unlock volume parameter changes.

#define hsSndPortFlags_Vol_LockMask 0x00008000

No definition.

#define hsSndPortFlags_Vol_Unlocked 0x00000000

Volume can be changed with any type of volume parameters.

#define hsSndPortID_ConnectCall HS_RDIO(0x00000020)

Virtual port to indicate a radio call is now connected.

#define hsSndPortID_Current HS_AC97(0x00000000)

Special meta port ID used to specify currently active user port.

#define hsSndPortID_InBaseMic HS_AC97(0x00000007)

Microphone at the base of the smartphone body.

#define hsSndPortID_InCarkit HS_AC97(0x00000013)

Input port used when wired carkit is activated.

#define hsSndPortID_InHeadsetMic HS_AC97(0x00000008)

Microphone on a mono headset. Ccomes from left channel as input.

#define hsSndPortID_InHostBaseMic HS_AC97(0x00000010)

Input port that controls source base port for host recording.

#define hsSndPortID_InHostHeadsetMic HS_AC97(0x00000011)

Input port controlling source headset port for host recording.

#define hsSndPortID_InHostPhone HS_AC97(0x00000012)

Input port used by host if phone or TTY is active.

#define hsSndPortID_InHostPlay HS_AC97(0x0000000D)

Input from the Host converted to analog for output to speakers.

#define hsSndPortID_InLineRec HS_AC97(0x00000006)

Configures headset jack as input, precluding headset use (special port for test purposes).

#define hsSndPortID_InMicAuto HS_AC97(0x00000009)

Atomatic port, according to headset insertion. Use with hsSndSwitchID_OutRadioMic.

#define hsSndPortID_InRadioSpkr HS_AC97(0x0000000B)

Input from the Radio speaker output.

#define hsSndPortID_LastPort HS_AC97(0x00000014)

Update at end. Ssame ID as last defined port in sequence.

#define hsSndPortID_Off 0x00000000

Special meta port ID used to turn off a sound switch.

#define hsSndPortID_OutBtHandsfree HS_AC97(0x0000000F)

Output port used by InRadioSpkr switch to put Call in bluetooth handsfree mode.

#define hsSndPortID_OutBtHeadset HS_AC97(0x0000000E)

Output port used by InRadioSpkr switch to put Call in bluetooth headset mode.

#define hsSndPortID_OutCarkit HS_AC97(0x00000014)

Output port used when wired carkit is activated.

#define hsSndPortID_OutHeadphones HS_AC97(0x00000004)

Configures the headset port for full left and right stereo output, no inputs.

#define hsSndPortID_OutHeadset HS_AC97(0x00000003)

Audio output to mono headset (right channel output). Left can be used as input.

#define hsSndPortID_OutHostRec HS_AC97(0x0000000C)

Output to the Host digitized recording input.

#define hsSndPortID_OutRadioMic HS_AC97(0x0000000A)

Output connected to the Radio microphone input.

#define hsSndPortID_OutReceiver HS_AC97(0x00000001)

Receiver speaker.

#define hsSndPortID_OutSpeaker HS_AC97(0x00000002)

Back speaker for system audio and speakerphone functions,

#define hsSndPortID_OutSpeakerAuto HS_AC97(0x00000005)

Automatic port, according to headset insertion. Use with hsSndSwitchID_InRadioSpkr.

#define hsSndRsrcAudioTableID 25000

Default audio table ID which can be loaded automatically during reset.

#define hsSndRsrcAudioTableType 'hTbl'

Resource contains audio table that can be loaded to audio driver.

#define hsSndSwitchID_InHostPlay HS_AC97(0x00040000)

Controls which speaker to direct PalmOS audio to.

#define hsSndSwitchID_InMic HS_AC97(0x00030000)

Test control for Mfg to directly connect Mic input into any destination speaker.

#define hsSndSwitchID_InRadioSpkr HS_AC97(0x00010000)

Controls the destination port for data coming from the Radio.

#define hsSndSwitchID_OutHostRec HS_AC97(0x00050000)

Controls from which port to digitize and send to PalmOS for recording.

#define hsSndSwitchID_OutRadioMic HS_AC97(0x00020000)

Controls the source microphone to connect to the Radio.

#define hsSndSwitchID_RadioCall HS_RDIO(0x00010000)

Keeps track of the audio connection of a Radio call.

#define hsSndToneType_Square 0

Used when calling HsSndTonePlay.

#define hsSoundLibCreatorID hsFileSoundLib

Creator ID of the sound library.

#define hsSoundLibName "HsSoundLib"

Name of the sound library.

#define hsSoundLibTypeID sysFileTLibrary

Type of the sound library.

#define PM_AUDP ( n ) ((n) | pmSndBayID_AUDP)

utility to associate the Preference Bay ID with other element ID

#define PM_AUDP_CLASS ( n ) ((n) | PM_AUDP_CLASS_MASK)

utility to associate preferences class marker to prefIDs

#define PM_AUDP_CLASS_MASK 0x4000

The ringtone attack envelope ramp-up to low volume initially, and to full volume after about 4 seconds

#define pmAudioClkTickRef ((PmClkTickRef) 0x00000001)

use as PmClkTickRef when requiring audio tick clock

#define pmSndAttackEnvIDRings (hsSndBufFlags_attackEnvRings)

The ringtone attack envelope ramp-up to low volume initially, and to full volume after about 4 seconds

#define pmSndAttackEnvIDVibeRing (hsSndBufFlags_attackEnvVibeRings)

Vibrate for 4 seconds, then behave as pmSndAttackEnvIDRings

#define pmSndBayID_AUDP 0x0F000000

we are reserving SndBayID 15 for audio preference purposes

#define pmSndPref_AthenaActive_No (0)

disable routing to Athena path for automatic switches

#define pmSndPref_AthenaActive_Yes (1)

enable routing to Athena path for automatic switches

#define pmSndPref_AthenaAudio_IfMicPresent (16)

when Athena audio class detected, only route if Mic is also present

#define pmSndPref_AthenaAudio_NoRouting (0)

no athena audio routing when Athena audio connection detected. Handled elsewhere or through pmSndPrefID_AthenaActive

#define pmSndPref_AthenaAudio_Unconditional (32)

cause unconditional audio routing if Athena audio class detected

#define pmSndPref_WakeOnAnswerBtn_Disable (0)

disable wake up on answer button feature

#define pmSndPref_WakeOnAnswerBtn_Enable (1)

enable wake up on answer button feature

#define pmSndPrefID_AGCEvent PM_AUDP_CLASS(0x0009)

set to temporarily activate AGC if required (only useful when AGC has been disabled before hand)

#define pmSndPrefID_AppsGroupHoldType PM_AUDP_CLASS(0x0001)

specify how to hold application audio (mute/pause)

#define pmSndPrefID_AthenaActive PM_AUDP_CLASS(0x0007)

set to activate audio paths to multi-connector, clear to return to normal (used for wired carkit mode)

#define pmSndPrefID_AthenaAudio PM_AUDP_CLASS(0x000A)

set to activate or deactivate automatic routing of audio to Athena connector

#define pmSndPrefID_AudioTable PM_AUDP_CLASS(0x0005)

pass pointer to PmSndGain8Table to load for use, pass zero to return to default

#define pmSndPrefID_GsmMccArray PM_AUDP_CLASS(0x0006)

pass pointer to PmSndGsmMccArray to load for use, pass zero to return to default

#define pmSndPrefID_JackOutIfMicUnused PM_AUDP_CLASS(0x0002)

shall we force jack out to stereo if Mic not in use?

#define pmSndPrefID_PhoneRxGainLimit PM_AUDP_CLASS(0x0003)

set if gain-limit phone Rx to receiver speaker

#define pmSndPrefID_SleepMode PM_AUDP_CLASS(0x0008)

set to zero for normal sleep, other values for partial audio sleep modes (for internal use only)

#define pmSndPrefID_WakeOnAnswerBtn PM_AUDP_CLASS(0x0004)

set to be able to wake device when headset answer button is pressed

#define pmSndSwitchID_Preferences PM_AUDP(0x00400000)

used with the HsSoundLib Switch calls to set and get sound preference data

Typedef Documentation

typedef Err(* HsSndBufferProc)(void *userdata, UInt32 flags, void *buffer, UInt32 bytesUsed, UInt32 time)

Callback function used under various conditions with sound.

Parameters:
userdata | IN Userdata passed when setting the callback routine
flags | IN Copy of the HsSndBufferData flags field
buffer | IN Pointer originally passed in HsSndBufferData
bytesUsed | OUT How many bytes have been consumed from the buffer
time | OUT Number of milliseconds available for callback processing
Returns:
Error code.

typedef UInt16 HsSndCmdType

Holds sound command type

typedef UInt16 HsSndFormatType

Holds sound format type

typedef Int16 HsSndMode

Holds audio mode type

typedef UInt16 HsSndParam

Used as a parameter to HsSndPortSetParam function.

typedef UInt16 HsSndPortClass

Used as a parameter to HsSndSwitchGetParam function.

typedef UInt32 HsSndPortID

Holds sound port ID information.

typedef UInt32 HsSndSwitchID

Holds sound switch ID information.

typedef UInt8 hsSndSysBeepType

Holds beep tone type.

See also:
hsSndSysBeepTag

typedef UInt32 PmClkTickRef

The ringtone attack envelope ramp-up to low volume initially, and to full volume after about 4 seconds

typedef UInt16 PmSndPrefID

The ringtone attack envelope ramp-up to low volume initially, and to full volume after about 4 seconds

Enumeration Type Documentation

enum HsSndCmdEnumTag

Sound command values

The HsSndCmdType is used as the first parameter to the function HsSndFormatPlay. Use these command values.

Enumerator:
hsSndCmdPlay | Use to initiate a playback session.
hsSndCmdStop | Use to terminate the current playback session.

enum HsSndFormatEnumTag

Sound formats

Enumerator:
hsSndFormatMidi | Midi format.
hsSndFormatAmr | Obsolete. Use Codec Plug-in Manager or streaming component.
pmSndFormatSetAttackEnvID | For internal use only (escape code used by PmSndStreamSetAttackEnvID macro function).
pmSndFormatPauseStream | For internal use only (escape code used by PmSndStreamPause macro function).
pmSndFormatResumeStream | For internal use only (escape code used by PmSndStreamResume macro function).
pmSndFormatSetStoppable | For internal use only (escape code used by PmSndStreamStoppable macro function).

enum hsSndSysBeepTag

Beeps

Provides additional system sounds for PalmOS SndPlaySystemSound.

Enumerator:
hsSndCardInsert | No definition.
hsSndCardRemove | No definition.
hsSndSyncStart | No definition.
hsSndSyncStop | No definition.
hsSndChargerAttach | No definition.
hsSndChargerDetach | No definition.
hsSndRadioOn | No definition.
hsSndRadioOff | No definition.
hsSndBatFull | No definition.
hsSndBatLow | No definition.
hsSndBatShutdown | No definition.
hsSndDeepWake | No definition.
hsSndDeepSleep | No definition.
hsSndRadioInServiceArea | No definition.
hsSndRadioOutServiceArea | No definition.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:53 2006 for Palm API Guide


HtmlLib68K.h File Reference

Detailed Description

Public 68K include file for HTML shared library.

Include dependency graph for HtmlLib68K.h:

Data Structures

  • struct HtmlLibFormWidgetProc
    The following are necessary form widget creation/deletion routines that need to get set using HtmlLibSetFormWidgetProc. Please see sample code after looking at HtmlLibSetFormWidgetProc. More...
  • struct HtmlLibFocusTargetInfo

HtmlLib error codes

  • #define htmlErrInUse (htmlErrorClass | 1)
  • #define htmlErrOutOfMemory (htmlErrorClass | 2)
  • #define htmlErrInvalidParam (htmlErrorClass | 3)
  • #define htmlErrNotFound (htmlErrorClass | 4)
  • #define htmlErrNotInitialized (htmlErrorClass | 5)
  • #define htmlErrCantOpen (htmlErrorClass | 6)

Typedef

  • #define htmlTargetImage 0x01
  • #define htmlTargetEmbed 0x02
  • #define htmlTargetIFrame 0x03
  • #define htmlTargetElement 0x04
  • #define htmlTargetInputText 0x05
  • #define htmlTargetInputPassword 0x06
  • #define htmlTargetInputCheckbox 0x07
  • #define htmlTargetInputRadio 0x08
  • #define htmlTargetInputSubmit 0x09
  • #define htmlTargetInputReset 0x0a
  • #define htmlTargetInputFile 0x0b
  • #define htmlTargetInputButton 0x0c
  • #define htmlTargetInputTextarea 0x0d
  • #define htmlTargetInputSelect 0x0e
  • typedef UInt8 HtmlDisplayMode
  • typedef UInt16 HtmlProgressStatus
  • typedef UInt32 HtmlSubmitFormMethod
  • typedef Int8 HtmlScrollDirection
  • typedef Int8 HtmlScrollbarMode
  • typedef UInt16 HtmlFocusTargetType
  • typedef Boolean NewControlProc (UInt16 id, UInt16 style, const Char *textP, Coord x, Coord y, Coord width, Coord height, UInt16 font, UInt8 group, Boolean leftAnchor)
  • typedef Err NewListProc (UInt16 id, Coord x, Coord y, Coord width, Coord height, UInt16 font, Int16 visibleItems, Int16 triggerId)
  • typedef Boolean NewFieldProc (UInt16 id, Coord x, Coord y, Coord width, Coord height, UInt16 font, UInt32 maxChars, UInt16 editable, UInt16 underlined, UInt16 singleLine, UInt16 dynamicSize, UInt16 justification, UInt16 autoShift, UInt16 hasScrollBar, UInt16 numeric)
  • typedef void DeleteObjectProc (UInt16 index)

HtmlDisplayMode

  • #define htmlHandheldDisplayMode 0x01
  • #define htmlFaithfulDisplayMode 0x02

HtmlProgressStatus

  • #define htmlProgressDone 0x0001
  • #define htmlProgressBusy 0x0002
  • #define htmlProgressOutOfMemory 0x0003
  • #define htmlProgressError 0x0004

HtmlSubmitFormMethod

  • #define htmlHttpMethodGet 0x00000001
  • #define htmlHttpMethodPost 0x00000002

HtmlDirections

  • #define htmlDirLeft 0x01
  • #define htmlDirRight 0x02
  • #define htmlDirUp 0x03
  • #define htmlDirDown 0x04

HtmlScrollMode

  • #define htmlNormalScrollbarMode 0x01
  • #define htmlNoPageScrollbarMode 0x02

Callback Functions

  • typedef void HtmlLibLinkSelCallback (MemHandle htmlLibH, Char *url, void *cbData)
  • typedef Boolean HtmlLibScanPhoneNumberCallback (MemHandle htmlLibH, Char *buffer, Int32 length, Int32 *patternStart, Int32 *patternEnd)
  • typedef void HtmlLibInclusionCallback (MemHandle htmlLibH, Char *url, void *cbData)
  • typedef void HtmlLibSubmitFormCallback (MemHandle htmlLibH, Char *url, HtmlSubmitFormMethod method, Char *query, void *cbData)

Defines

  • #define HtmlLibID 'AsHL'
  • #define HtmlLibDBType 'libr'
  • #define HtmlLibName "HtmlLibrary"
  • #define htmlLibProgressEvent (0x7000)
  • #define htmlErrorClass (appErrorClass)

Functions

  • Err HtmlLibOpen (UInt16 refnum)
  • Err HtmlLibClose (UInt16 refnum)
  • Err HtmlLibSleep (UInt16 refnum)
  • Err HtmlLibWake (UInt16 refnum)
  • MemHandle HtmlLibInitialize (UInt16 refnum, RectangleType bounds, Err *errP)
  • MemHandle HtmlLibInitializeWithHeapSize (UInt16 refnum, RectangleType bounds, Err *errP, UInt32 heapMinSize, UInt32 heapDesiredSize, UInt32 *heapActualSizeP)
  • void HtmlLibFinalize (UInt16 refnum, MemHandle htmlLibH)
  • void HtmlLibResizeScreen (UInt16 refnum, MemHandle htmlLibH, RectangleType newBounds)
  • void HtmlLibSetDisplayMode (UInt16 refnum, MemHandle htmlLibH, HtmlDisplayMode mode)
  • void HtmlLibSetLinkSelectionCallback (UInt16 refnum, MemHandle htmlLibH, HtmlLibLinkSelCallback *callback, void *cbData)
  • void HtmlLibSetScanPhoneNumberCallback (UInt16 refnum, MemHandle htmlLibH, HtmlLibScanPhoneNumberCallback *callback)
  • void HtmlLibSetInclusionCallback (UInt16 refnum, MemHandle htmlLibH, HtmlLibInclusionCallback *callback, void *cbData)
  • void HtmlLibSetSubmitFormCallback (UInt16 refnum, MemHandle htmlLibH, HtmlLibSubmitFormCallback *callback, void *cbData)
  • UInt16 HtmlLibProgress (UInt16 refnum, MemHandle htmlLibH, Int32 stayTime)
  • Boolean HtmlLibNotifyUIEvent (UInt16 refnum, MemHandle htmlLibH, EventType *eventP)
  • Err HtmlLibFindText (UInt16 refnum, MemHandle htmlLibH, Char *searchString, Boolean wrapSearch)
  • Boolean HtmlLibGetTextSelection (UInt16 refnum, MemHandle htmlLibH, Char **selectedText)
  • void HtmlLibClearScreen (UInt16 refnum, MemHandle htmlLibH)
  • void HtmlLibAbortRenderData (UInt16 refnum, MemHandle htmlLibH)
  • MemHandle HtmlLibCreateContentObject (UInt16 refnum, MemHandle htmlLibH)
  • void HtmlLibDestroyContentObject (UInt16 refnum, MemHandle contentH)
  • Err HtmlLibAddTextData (UInt16 refnum, MemHandle contentH, Char *url, Char *mimeType, Char *charset, void *data, Int32 dataLen)
  • Err HtmlLibAddImageData (UInt16 refnum, MemHandle contentH, Char *url, Char *mimeType, void *data, Int32 dataLen)
  • void HtmlLibRenderData (UInt16 refnum, MemHandle contentH)
  • void HtmlLibRedrawScreen (UInt16 refnum, MemHandle htmlLibH)
  • void HtmlLibSetScrollbars (UInt16 refnum, MemHandle htmlLibH, UInt16 *scrollbars, UInt16 size)
  • Err HtmlLibGetVScrollPosition (UInt16 refnum, MemHandle htmlLibH, Int16 *valueP)
  • Err HtmlLibSetVScrollPosition (UInt16 refnum, MemHandle htmlLibH, Int16 newPosition)
  • Boolean HtmlLibCanScroll (UInt16 refnum, MemHandle htmlLibH, HtmlScrollDirection direction)
  • Err HtmlLibSetScrollbarMode (UInt16 refnum, MemHandle htmlLibH, HtmlScrollbarMode mode)
  • Err HtmlLibSetBiggerFont (UInt16 refnum, MemHandle htmlLibH, Boolean value)
  • void HtmlLibSetFormWidgetProc (UInt16 refnum, MemHandle htmlLibH, HtmlLibFormWidgetProc *proc)
  • Boolean HtmlLibGetTargetInfo (UInt16 refnum, MemHandle htmlLibH, HtmlLibFocusTargetInfo *htmlTargetInfo)
  • Err HtmlLibSetImageMemoryLimit (UInt16 renum, MemHandle htmlLibH, Int32 limit)

Define Documentation

#define htmlLibProgressEvent (0x7000)

This is the Html Library event. When an application receives this event, it should call HtmlLibProgress.

Typedef Documentation

typedef void DeleteObjectProc(UInt16 index)

See also:
HtmlLibFormWidgetProc

typedef void HtmlLibInclusionCallback(MemHandle htmlLibH, Char *url, void *cbData)

Should be defined and set as the function to be called when rendering a page requires additional content.

HtmlLib calls this callback function with the appropriate arguments (where the url is the url of the additional content the library requires).

typedef void HtmlLibLinkSelCallback(MemHandle htmlLibH, Char *url, void *cbData)

Should be defined (to handle a link selection) and set as the function to be called when a link (url) is selected.

typedef Boolean HtmlLibScanPhoneNumberCallback(MemHandle htmlLibH, Char *buffer, Int32 length, Int32 *patternStart, Int32 *patternEnd)

Should be defined and set as the function to be called when it's necessary to determine if a string of numbers contains a phone number.

Here, buffer contains the string of numbers that are being checked, and this is passed in by the library when the library calls this function. Length is the buffer's length, also passed in by the library. The last two arguments (patternStart and patternEnd) should get set in this callback function if the string of numbers passed in is determined to be a phone number (and thus the return value of the function is to be true). Now, patternStart is the place in the buffer that the phone number starts, and patternEnd is the place in the buffer that the pattern ends. For example, if the entire contents of the buffer passed in happened to be a phone number, then the start would be 0 and the end would be "length - 1", and the return value would be true. However, if what was passed in was not determined to be a phone number, then the return value of the callback function should be false, and the last two arguments do not need to be set.

typedef void HtmlLibSubmitFormCallback(MemHandle htmlLibH, Char *url, HtmlSubmitFormMethod method, Char *query, void *cbData)

Note:
Forms are not supported; thus, use this at your own risk.
Should be defined and set as the function to be called when a submit is activated.

HtmlLib calls this callback function with the appropriate arguments. The following is an example (included in the sample code):

 void HtmlSubmitFormCallback(MemHandle htmlLibH, Char *url, HtmlSubmitFormMethod method, Char *query, void *cbData)
 {
     FrmCustomAlert(SubmitFormAlert, url,
        (method == htmlHttpMethodPost ? "Post" : "Get"), query);
 }

typedef Boolean NewControlProc(UInt16 id, UInt16 style, const Char *textP, Coord x, Coord y, Coord width, Coord height, UInt16 font, UInt8 group, Boolean leftAnchor)

See also:
HtmlLibFormWidgetProc

typedef Boolean NewFieldProc(UInt16 id, Coord x, Coord y, Coord width, Coord height, UInt16 font, UInt32 maxChars, UInt16 editable, UInt16 underlined, UInt16 singleLine, UInt16 dynamicSize, UInt16 justification, UInt16 autoShift, UInt16 hasScrollBar, UInt16 numeric)

See also:
HtmlLibFormWidgetProc

typedef Err NewListProc(UInt16 id, Coord x, Coord y, Coord width, Coord height, UInt16 font, Int16 visibleItems, Int16 triggerId)

See also:
HtmlLibFormWidgetProc

Function Documentation

void HtmlLibAbortRenderData | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH
 | ) |

This function aborts rendering of the current content.

Parameters:
refNum | IN: the library reference number
contentH | IN: Memory Handle of the current content, returned by HtmlLibCreateContentObject

Err HtmlLibAddImageData | ( | UInt16 | refnum,
 |  | MemHandle | contentH,
 |  | Char * | url,
 |  | Char * | mimeType,
 |  | void * | data,
 |  | Int32 | dataLen
 | ) |

This function adds images to HtmlLib. (You can use this to respond to Inclusion callback - please see section 2.1 Image Rendering).

Parameters:
refNum | IN: the library reference number
contentH | IN: Memory Handle returned by HtmlLibCreateContentObject
url | IN: url of the image
mimeType | IN: mime type of the image (for example, "image/jpeg")
data | IN: image data
dataLen | IN: image data size
Returns:
Error code.

Err HtmlLibAddTextData | ( | UInt16 | refnum,
 |  | MemHandle | contentH,
 |  | Char * | url,
 |  | Char * | mimeType,
 |  | Char * | charset,
 |  | void * | data,
 |  | Int32 | dataLen
 | ) |

This function adds text data to the content data object created by HtmlLibCreateContentObject. Application should call HtmlLibRenderData when it has finished adding text data, for the data to be rendered.

Note:
There is a limit of 64K of text data per content object (and not just per call of HtmlLibAddTextData).
Parameters:
refNum | IN: the library reference number
contentH | IN: Memory Handle returned by HtmlLibCreateContentObject
url | IN: url of the page you are adding to (unique, to make sure nothing is written over)
mimeType | IN: mime type of the text (such as "text/plain", "text/html")
charset | IN: the character set (such as "us-ascii")
data | IN: a reference to the text data to be added
dataLen | IN: length of the data
Returns:
This function returns an error code (returns errNone if successful).

Boolean HtmlLibCanScroll | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | HtmlScrollDirection | direction
 | ) |

This function lets you know whether scrolling is possible in the indicated direction.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
direction | IN: htmlDirLeft, htmlDirRight, htmlDirUp, htmlDirDown
Returns:
Function outputs true if scrolling in the indicated direction is possible.

void HtmlLibClearScreen | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH
 | ) |

This function clears the rendering screen. It must be called before content object is destroyed.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize

Err HtmlLibClose ( UInt16 refnum )

Standard library close routine.

Parameters:
refun IN: the library reference number
Returns:
Error code.

MemHandle HtmlLibCreateContentObject | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH
 | ) |

Creates a content object (structure in memory that contains content to be rendered).

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
Returns:
This function returns the memory handle of a content data object.

void HtmlLibDestroyContentObject | ( | UInt16 | refnum,
 |  | MemHandle | contentH
 | ) |

This function destroys the content data object created by HtmlLibCreateContentObject.

Note:
Be cautious when destroying a content object - make sure it is not busy doing something else, like rendering data. You can use HtmlLibProgress to check for the status (busy or not), or you can call HtmlLibAbortRenderData first.
Parameters:
refNum | IN: the library reference number
contentH | IN: Memory Handle returned by HtmlLibCreateContentObject

void HtmlLibFinalize | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH
 | ) |

Finalizes the library when you are done using it

Note:
If you need to use the library again after it has been finalized, you will need to re-initialize it.
Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize

Err HtmlLibFindText | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | Char * | searchString,
 |  | Boolean | wrapSearch
 | ) |

Applications should call this function to find a given text string on the page. Page will automatically scroll to show search result.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
searchString | IN: the given text string we are looking for on the page
wrapSearch | IN: true if you would like to wrap search
Returns:
Error code (errNone, htmlErrNotFound).

Boolean HtmlLibGetTextSelection | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | Char ** | selectedText
 | ) |

Applications should use this function to retrieve the current selected text. Caller application must free the pointer returned in selectedText using MemPtrFree.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
selectedText | IN: the selected text that we are retrieving
Returns:
This function returns false if no current selection, otherwise returns true.

Err HtmlLibGetVScrollPosition | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | Int16 * | valueP
 | ) |

This function obtains the current scroll position in pixels from the top of the page.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
valueP | IN: at function's return, this contains the position in pixels from the top of the page
Returns:
Error code.

MemHandle HtmlLibInitialize | ( | UInt16 | refnum,
 |  | RectangleType | bounds,
 |  | Err * | errP
 | ) |

Html Library initialization function. Initializes the library, after the library has been loaded.

Parameters:
refNum | IN: the library reference number
bounds | IN: the screen area the library will draw the rendered content (bounds within 160 x 160 grid)
errP | IN: error code if library fails to initialize. The error code can be one of (htmlErrInUse, htmlErrOutOfMemory, htmlErrInvalidParam, htmlErrInUse, htmlErrCantOpen)
Returns:
A memory handle to the HTML library context.

Boolean HtmlLibNotifyUIEvent | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | EventType * | eventP
 | ) |

Applications should call this function to notify HTML library of a UI event (any event that your application gets that the library should handle, such as a screen tap, or a key press). It is worth noting that you may create your own events and call this function for the library to handle it. By the same token, you can filter which events to pass to this function - you do not have to pass through every event.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
eventP | IN: the event you would like the library to handle
Returns:
True if the library considers this event handled.

Err HtmlLibOpen ( UInt16 refnum )

Standard library open routine.

Parameters:
refun IN: the library reference number
Returns:
Error code.

UInt16 HtmlLibProgress | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | Int32 | stayTime
 | ) |

Applications should call this function to allow HTML library to process content and draw to screen.

Note:
The Html Library will run only if you call this!
Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
stayTime | IN: maximum time (in milliseconds) for HTML library to do processing. (At least 1300 is recommend.)
Returns:
Status - htmlProgressDone, htmlProgressBusy, htmlProgressOutOfMemory, and other error codes.

void HtmlLibRedrawScreen | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH
 | ) |

This redraws the HtmlLib rendering screen (for example, when application receives a frmUpdate event).

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize

void HtmlLibRenderData | ( | UInt16 | refnum,
 |  | MemHandle | contentH
 | ) |

Applications should call this function after adding text data by HtmlLibAddTextData (or image data by HtmlLibAddImageData, see section 2.1 Image Rendering) to have HTML library start rendering the content.

Parameters:
refNum | IN: the library reference number
contentH | IN: Memory Handle returned by HtmlLibCreateContentObject that contains the text data to be rendered

void HtmlLibResizeScreen | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | RectangleType | newBounds
 | ) |

Resize the screen area.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
newBounds | IN: the new bounds of the screen area (bounds within 160 x 160 grid)
Returns:
errNone if resize is successful, otherwise returns an error code (errInvalidParam)

Err HtmlLibSetBiggerFont | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | Boolean | value
 | ) |

This function will control the size of the font used by HtmlLib.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: htmlLib handle
value | IN: true if you would like bigger font (bigger font corresponds to the Large font option in Blazer), and false otherwise (false would correspond to the Small font option in Blazer).
Returns:
Error code.

void HtmlLibSetDisplayMode | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | HtmlDisplayMode | mode
 | ) |

Sets the display mode (faithful rendering, which corresponds to Blazer's Wide Page Mode, or handheld wrapped, which corresponds to Blazer's Optimized Mode).

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
mode | IN: display mode (htmlFaithfulDisplayMode or htmlHandheldDisplayMode)

void HtmlLibSetFormWidgetProc | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | HtmlLibFormWidgetProc * | proc
 | ) |

This function sets the function pointers of some necessary form widget creation/deletion routines. The following is sufficient for most purposes (and included in the sample application):

  static HtmlLibFormWidgetProc *widgetProc = NULL;

    widgetProc = MemPtrNew(sizeof(HtmlLibFormWidgetProc));
    if (widgetProc) {
      //functions defined in sample code
        widgetProc->newControlProc = RendererNewControlProc;
        widgetProc->newFieldProc = RendererNewFieldProc;
        widgetProc->newListProc = RendererNewListProc;
        widgetProc->deleteObjectProc = RendererDeleteObjectProc;
    }

    HtmlLibSetFormWidgetProc(refNum, htmlLibH, widgetProc);

A standard example of the necessary form widget creation/deletion routines are provided below, and can be found in the sample code.

 static Boolean
 RendererNewControlProc(UInt16 ID,
       UInt16 style, const Char *textP,
       Coord x, Coord y, Coord width, Coord height,
       UInt16 font, UInt8 group, Boolean leftAnchor)

  {
       ControlType *ctlP;
       FormType *formP = FrmGetActiveForm();
       ctlP = CtlNewControl((void**)&formP, ID, style, textP, x, y, width, height, font, group, leftAnchor);
       if (ctlP) {
           return true;
       }
       return false;
  }

  static Boolean
  RendererNewFieldProc(UInt16 id,
       Coord x, Coord y, Coord width, Coord height,
       UInt16 font, UInt32 maxChars, UInt16 editable, UInt16 underlined,
       UInt16 singleLine, UInt16 dynamicSize, UInt16 justification,
       UInt16 autoShift, UInt16 hasScrollBar, UInt16 numeric)

  {
       FieldType *fieldP;
       FormType *formP = FrmGetActiveForm();
       fieldP = FldNewField((void**)&formP, id, x, y, width, height, (FontID)font,
                       maxChars, (Boolean)editable, (Boolean)underlined, (Boolean)singleLine,
                       (Boolean)dynamicSize, (JustificationType)justification, (Boolean)autoShift,
                       (Boolean)hasScrollBar, (Boolean)numeric);
       if (fieldP) {
           return true;
       }
       return false;
  }

  static Err
  RendererNewListProc(UInt16 id,
       Coord x, Coord y, Coord width, Coord height,
       UInt16 font, Int16 visibleItems, Int16 triggerId)
  {
       FormType *formP = FrmGetActiveForm();
       return LstNewList((void**)&formP, id, x, y, width, height, font,
                           visibleItems, triggerId);
  }

  static void
  RendererDeleteObjectProc(UInt16 index)
  {
       FormType *formP = FrmGetActiveForm();
       FrmRemoveObject(&formP, index);
  }

Parameters:
refNum | IN: HTML library reference number
htmlLibH | IN: htmlLib handle
proc | IN: function pointers of form widget creation/deletion routines.

void HtmlLibSetInclusionCallback | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | HtmlLibInclusionCallback * | callback,
 |  | void * | cbData
 | ) |

Specify the function that you want the library to call when rendering a page requires additional content (an image that hasn't been added, an external style sheet, etc).

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
callback | IN: a pointer to the function you want called when rendering a page that requires additional content.
cbData | I/O: the library does nothing with this parameter except pass it on as one of the arguments to your callback function. To not take advantage of this feature, just pass in NULL.
Note:
: The callback function should be in the following form: void HtmlLibInclusionCallback(MemHandle htmlLibH, Char *url, void *cbData);
HtmlLib calls this callback function with the appropriate arguments (where the url is the url of the additional content the library requires).

See also:
HtmlLibInclusionCallback

void HtmlLibSetLinkSelectionCallback | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | HtmlLibLinkSelCallback * | callback,
 |  | void * | cbData
 | ) |

Specify the function that you want the library to call when a link is followed.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
callback | IN: a pointer to the function you want called when a link is followed.
cbData | I/O: the library does nothing with this parameter except pass it on as one of the arguments to your callback function. To not take advantage of this feature, just pass in NULL.
Note:
The callback function should be in the following form: void HtmlLinkSelCallback(MemHandle htmlLibH, Char *url, void *cbData); The library will call this function, supplying the appropriate arguments (where the url is the url of the link which was selected).
See also:
HtmlLibLinkSelCallback

void HtmlLibSetScanPhoneNumberCallback | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | HtmlLibScanPhoneNumberCallback * | callback
 | ) |

Specify the function that you want the library to call to determine whether some string of numbers contains a phone number.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
callback | IN: a pointer to the function that HtmlLib will call to determine whether a string of numbers is a phone number, and should be handled as such.
Note:
The callback function should be in the following form: Boolean HtmlLibScanPhoneNumberCallback(MemHandle htmlLibH, Char *buffer, Int32 length, Int32 *patternStart, Int32 *patternEnd);
See also:
HtmlLibScanPhoneNumberCallback

Err HtmlLibSetScrollbarMode | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | HtmlScrollbarMode | mode
 | ) |

This function sets the page's scrollbar mode, without affecting the scrollbars of a textarea. A reason to use htmlNoPageScrollbarMode and not htmlNormalScrollbarMode is if you would like to use your own scrollbars, and use HtmlLib(Set/Get)VScrollPosition to do so.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
mode | IN: scrollbar mode (htmlNormalScrollbarMode to enable scrolling or htmlNoPageScrollbarMode for no scrolling)
Returns:
Error code. (htmlErrNotInitialized, htmlErrInUse)

void HtmlLibSetScrollbars | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | UInt16 * | scrollbars,
 |  | UInt16 | size
 | ) |

This function passes an array of scrollbars to HtmlLib. Html library will not display any scrollbar if application does not call this function (scrollbars cannot be added dynamically). Application is recommended to pass no less than 4 (or at the very least 2) scrollbars, and up to 9 scrollbars. For example (after defining RenderScroll0ScrollBar and RenderScroll1ScrollBar):

  UInt16 scrollbars[2] = {RenderScroll0ScrollBar, RenderScroll1ScrollBar};
  HtmlLibSetScrollbars(gRefNum, gHtmlLibH, scrollbars, 2);

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
scrollbars | IN: array of scrollbars
size | IN: size of the array of scrollbars

void HtmlLibSetSubmitFormCallback | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | HtmlLibSubmitFormCallback * | callback,
 |  | void * | cbData
 | ) |

Note:
: Forms are not supported; thus, use this at your own risk.
This functions lets you specify the function that you want the library to call when a "submit" is activated.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
callback | IN: a pointer to the function you want called when a "submit" is activated
cbData | I/O: the library does nothing with this parameter except pass it on as one of the arguments to your callback function. To not take advantage of this feature, just pass in NULL.
Note:
The callback function should be in the following form:
HtmlLibSubmitFormCallback(MemHandle htmlLibH, Char *url, HtmlSubmitFormMethod method, Char *query, void *cbData);

HtmlLib calls this callback function with the appropriate arguments.

See also:
HtmlLibSubmitFormCallback

Err HtmlLibSetVScrollPosition | ( | UInt16 | refnum,
 |  | MemHandle | htmlLibH,
 |  | Int16 | newPosition
 | ) |

This function sets the current scroll position in pixels from the top of the page. If the total page height of the current page is less than this, this scrolls the page to the bottom.

Parameters:
refNum | IN: the library reference number
htmlLibH | IN: the memory handle returned by HtmlLibInitialize
newPosition | IN: the position in pixels from the top of the page
Returns:
Error code.

Err HtmlLibSleep ( UInt16 refnum )

Standard library sleep routine.

Parameters:
refun IN: the library reference number
Returns:
Error code.

Err HtmlLibWake ( UInt16 refnum )

Standard library wake routine.

Parameters:
refun IN: the library reference number
Returns:
Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:54 2006 for Palm API Guide


ImageLib.h File Reference

Detailed Description

Public 68k include file for the Imaging Library.

This file contains routines for capturing, storing, iterating, resizing, and manipulating images. The imaging library is a client of both the camera driver and the JPEG library.

Include dependency graph for ImageLib.h:

Functions

  • Err ImageLibOpen (UInt16 libRef)
  • Err ImageLibClose (UInt16 libRef)
  • Err ImageLibGetVersion (UInt16 libRef, UInt32 *dwVerP)
  • Err ImageLibCameraExists (UInt16 libRef, Boolean *existsP)
  • Err ImageLibImageCapture (UInt16 libRef, Boolean fullsize, Boolean playShutterSound, Boolean drawImmediately, Coord x, Coord y, UInt16 *newRecNoP)
  • Err ImageLibImageSave (UInt16 libRef, UInt16 recIndex, const char *name, UInt16 category)
  • BitmapType * ImageLibPreviewBitmapCreate (UInt16 libRef, Err *errP)
  • Err ImageLibPreviewBitmapFill (UInt16 libRef, BitmapType *imageP)
  • Err ImageLibPreviewDraw (UInt16 libRef, Coord x, Coord y)
  • BitmapType * ImageLibImageBitmapCreate (UInt16 libRef, UInt16 recIndex, Err *errP)
  • Err ImageLibImageBitmapFill (UInt16 libRef, UInt16 recIndex, BitmapType *imageP)
  • Err ImageLibImageDraw (UInt16 libRef, UInt16 recIndex, Coord x, Coord y)
  • BitmapType * ImageLibThumbnailBitmapCreate (UInt16 libRef, UInt16 recIndex, Err *errP)
  • Err ImageLibThumbnailBitmapFill (UInt16 libRef, UInt16 recIndex, BitmapType *imageP)
  • Err ImageLibThumbnailDraw (UInt16 libRef, UInt16 recIndex, Coord x, Coord y)
  • Err ImageLibBitmapDelete (UInt16 libRef, BitmapType *bmp)
  • Err ImageLibDeleteImage (UInt16 libRef, UInt16 recIndex)
  • Err ImageLibResizeImage (UInt16 libRef, UInt16 recIndex)
  • Err ImageLibGetImageDatabases (UInt16 libRef, DmOpenRef *dbMainP, DmOpenRef *dbNoteP, DmOpenRef *dbImageP)
  • Err ImageLibGetImageInfo (UInt16 libRef, UInt16 recIndex, Char *name, Boolean *fullSizeP, UInt32 *createdP, UInt32 *sizeP, UInt16 *categoryP, Char *categoryName, Boolean *lockedP, UInt32 *uidP)
  • Err ImageLibSetImageInfo (UInt16 libRef, UInt16 recIndex, const char *name, UInt16 *categoryP)
  • Err ImageLibCopyImageToVFS (UInt16 libRef, UInt16 recIndex, UInt16 volRefNum, const char *fileName)
  • Err ImageLibCopyImageFromVFS (UInt16 libRef, UInt16 volRefNum, const char *fileName, const char *name, UInt16 category, UInt16 *newRecIndexP)
  • BitmapType * ImageLibImageBitmapCreateFromVFS (UInt16 libRef, UInt16 volRefNum, const char *fileName, Err *errP)
  • Err ImageLibImageBitmapFillFromVFS (UInt16 libRef, UInt16 volRefNum, const char *fileName, BitmapType *imageP)
  • Err ImageLibImageDrawFromVFS (UInt16 libRef, UInt16 volRefNum, const char *fileName, Coord x, Coord y)
  • BitmapType * ImageLibThumbnailBitmapCreateFromVFS (UInt16 libRef, UInt16 volRefNum, const char *fileName, Err *errP)
  • Err ImageLibThumbnailBitmapFillFromVFS (UInt16 libRef, UInt16 volRefNum, const char *fileName, BitmapType *imageP)
  • Err ImageLibThumbnailDrawFromVFS (UInt16 libRef, UInt16 volRefNum, const char *fileName, Coord x, Coord y)
  • Err ImageLibDoAttachImageDialog (UInt16 libRef, UInt16 *recIndexP, UInt16 *volRefNumP, char *fileName, UInt16 initialCategory, Boolean showConfirmation, Boolean internalImagesOnly, const char *dialogTitle, const char *btnTitle)
  • Err ImageLibCopyImageToBuffer (UInt16 libRef, UInt16 recIndex, MemPtr bufP)
  • Err ImageLibCopyImageToFile (UInt16 libRef, UInt16 recIndex, FileHand fileH)
  • Err ImageLibInsertImageFromBuffer (UInt16 libRef, MemPtr bufP, UInt32 size, const char *name, UInt16 category, UInt16 *newRecIndexP)
  • Err ImageLibInsertImageFromFile (UInt16 libRef, FileHand fileH, const char *name, UInt16 category, UInt16 *newRecIndexP)
  • ImageIteratorHandle ImageLibIterateImages (UInt16 libRef, UInt16 category, UInt16 sortType, UInt16 *imageCountP, Err *errP)
  • ImageIteratorHandle ImageLibIterateVFSImages (UInt16 libRef, UInt16 volRefNum, const char *path, Boolean recurseBelow, UInt16 sortType, UInt16 *imageCount, Err *errP)
  • Err ImageLibIterSort (UInt16 libRef, ImageIteratorHandle iter, UInt16 sortType)
  • Err ImageLibIterGetImageInfo (UInt16 libRef, ImageIteratorHandle iter, UInt16 index, char *name, UInt16 nameLen, UInt16 *categoryP, UInt16 *recIndexP, UInt16 *volRefNumP, UInt32 *createdP, UInt32 *sizeP, char *path, UInt16 pathLen, Boolean *lockedP)
  • Err ImagelibIterGetCount (UInt16 libRef, ImageIteratorHandle iter, UInt16 *imageCountP)
  • Err ImageLibIterDeleteImage (UInt16 libRef, ImageIteratorHandle iter, UInt16 index)
  • Err ImageLibIterRemoveImage (UInt16 libRef, ImageIteratorHandle iter, UInt16 index)
  • Err ImageLibIterFree (UInt16 libRef, ImageIteratorHandle iter)
  • Err ImageLibIterDrawImage (UInt16 libRef, ImageIteratorHandle iter, UInt16 index, Coord x, Coord y)
  • Err ImageLibIterDrawThumbnail (UInt16 libRef, ImageIteratorHandle iter, UInt16 index, Coord x, Coord y)
  • Err ImageLibIterSearch (UInt16 libRef, ImageIteratorHandle iterH, const char *name, Boolean partialMatch, UInt16 *index)
  • void ImageLibSetProgressCallback (UInt16 libRef, ImageLibProgressCallbackType callback)
  • Err ImageLibCopyImage (UInt16 libRef, UInt16 recIndex, const char *newName, UInt16 *newRecIndexP)
  • Err ImageLibFindImageByID (UInt16 libRef, UInt32 uniqueID, UInt16 *recIndexP)
  • Err ImageLibPreviewStart (UInt16 libRef, void *windowH, Coord x, Coord y)
  • Err ImageLibPreviewStop (UInt16 libRef)
  • Err ImageLibDrawJPEG (UInt16 libRef, MemPtr jpegDataP, UInt32 jpegSize, Coord left, Coord top, Boolean fitToScreen, Coord width, Coord height)
  • Err ImageLibTurnCameraOff (UInt16 libRef)
  • Err ImageLibSetImageID (UInt16 libRef, UInt16 recIndex, const char *mediaIDP, const char *containerIDP)
  • Err ImageLibGetImageID (UInt16 libRef, UInt16 recIndex, char *mediaIDP, char *containerIDP)
  • Err ImageLibGetDimensions (UInt16 libRef, UInt16 recIndex, Coord *width, Coord *height, Boolean fitToDimensions)
  • Err ImageLibGetDimensionsVFS (UInt16 libRef, UInt16 volRefNum, const char *fileName, Coord *width, Coord *height, Boolean fitToDimensions)
  • Err ImageLibIterGetDimensions (UInt16 libRef, ImageIteratorHandle iter, UInt16 index, Coord *width, Coord *height, Boolean fitToDimensions)
  • Err ImageLibGetDimensionsJPEG (UInt16 libRef, MemPtr jpegDataP, UInt32 jpegSize, Coord *width, Coord *height, Boolean fitToDimensions)
  • Err ImageLibResize (UInt16 libRef, UInt16 recIndex, Coord *widthP, Coord *heightP, Boolean maintainAspectRatio)
  • Err ImageLibResizeVFS (UInt16 libRef, UInt16 volRefNum, const char *fileName, Coord *widthP, Coord *heightP, Boolean maintainAspectRatio)
  • Err ImageLibIterResize (UInt16 libRef, ImageIteratorHandle iter, UInt16 index, Coord *widthP, Coord *heightP, Boolean maintainAspectRatio)
  • Err ImageLibResizeJPEG (UInt16 libRef, MemPtr jpegInputP, UInt32 inputSize, Coord *widthP, Coord *heightP, Boolean maintainAspectRatio, MemPtr *outputPP, UInt32 *outputSizeP)
  • Err ImageLibIterRefresh (UInt16 libRef, ImageIteratorHandle iter, UInt16 index, const char *newVFSName)
  • Err ImageLibSetJPEGQuality (UInt16 libRef, Int32 value)
  • Int32 ImageLibGetJPEGQuality (UInt16 libRef)
  • Err ImageLibLockImage (UInt16 libRef, UInt16 recIndex)
  • Int32 ImageLibGetAveragePictureSize (UInt16 libRef, Boolean fullsize)
  • void ImageLibCheckLockedImages (UInt16 libRef, const Char *phoneNumber)

Function Documentation

Err ImageLibBitmapDelete | ( | UInt16 | libRef,
 |  | BitmapType * | bmp
 | ) |

Deletes a bitmap created by the library.

Use ImageLibBitmapDelete to delete any bitmap that was created and returned by the imaging library (ImageLibPreviewBitmapCreate, ImageLibImageBitmapCreate and ImageLibThumbnailBitmapCreate).

Parameters:
libRef,: IN: Library reference number.
bmp,: IN: Bitmap to delete.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibCameraExists | ( | UInt16 | libRef,
 |  | Boolean * | existsP
 | ) |

Detects presence of camera driver.

The imaging library loads the camera driver dynamically. If the driver was found and was loaded successfully, ImageLibCameraExists writes true to existsP, otherwise it writes false.

This routine will attempt to load the camera driver if it hasn't already been loaded. The driver will remain loaded until the imaging library is unloaded, or until ImageLibTurnCameraOff is called.

See also:
ImageLibTurnCameraOff
Parameters:
libRef,: IN: Library reference number.
existsP,: OUT: true if camera successfully loaded. Otherwise false.
Return values:
Err 0 on success or error code on failure.

void ImageLibCheckLockedImages | ( | UInt16 | libRef,
 |  | const Char * | phoneNumber
 | ) |

Verifies the locked images match the given phone number. If they don't, all locked images are purged from the database.

Parameters:
libRef,: IN: Library reference number.
phoneNumber,: IN: String containing the phone number to verify against.

Err ImageLibClose ( UInt16 libRef )

Library close function for 68k clients of the library. This routine maps to the sysLibTrapClose trap.

This function is an empty stub (see comments for ImageLibOpen). All library cleanup is done from PilotMain.

This function is not available to ARM clients of the library.

See also:
ImageLibOpen
Parameters:
libRef,: IN: Library reference number.
Return values:
Err 0 on success or error code on failure.

Err ImageLibCopyImage | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | const char * | newName,
 |  | UInt16 * | newRecIndexP
 | ) |

Creates a copy of an image in the database.

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of the image to copy.
newName,: IN: Name of the newly copied image.
newRecIndexP,: OUT: Index of the newly copied image. Pass NULL if you don't care about this value.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibCopyImageFromVFS | ( | UInt16 | libRef,
 |  | UInt16 | volRefNum,
 |  | const char * | fileName,
 |  | const char * | name,
 |  | UInt16 | category,
 |  | UInt16 * | newRecIndexP
 | ) |

Copies an image from a VFS volume to the database.

volRefNum should be obtained via a call to VFSVolumeEnumerate

If a picture with a matching name and category already exists in the database, that image is not overwritten. After the call, there will be two images with the same name and category.

Parameters:
libRef,: IN: Library reference number.
volRefNum,: IN: Ref number of the VFS volume
fileName,: IN: Filename of the image (ie "/DCIM/picture001.jpg")
name,: IN: Name of the image in the database (ie "picture001")
category,: IN: Category that the image should be assigned to
newRecIndexP,: OUT: Record index of the newly stored picture. Pass NULL if you don't care what the new index is.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibCopyImageToBuffer | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | MemPtr | bufP
 | ) |

Copies a JPEG from the image database to a chunk of memory at bufP. The allocated memory block must be large enough to hold the entire blob of JPEG data. The size of the JPEG can be determined with ImageLibGetImageInfo.

Fullsize images may requires that bufP be larger than 64 kB. Use FtrPtrNew or MemChunkNew to create buffers larger than 64 kB. Otherwise, consider using ImageLibCopyImageToFile instead.

See also:
ImageLibGetImageInfo

ImageLibCopyImageToFile

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of the picture
bufP,: IN,OUT: Pointer to the block of memory that should receive the image.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibCopyImageToFile | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | FileHand | fileH
 | ) |

Copies a JPEG from the image database to a Palm OS file stream. The library writes to the file stream at its current postion. When done, the library leaves the file handle pointing to the end of the file. To see the jpeg data, the file handle should be rewound to its original location.

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of the picture
fileH,: IN: Handle to an open file stream.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibCopyImageToVFS | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | UInt16 | volRefNum,
 |  | const char * | fileName
 | ) |

Copies an image from the database to a VFS volume.

Copies an image from the database to a VFS volume, overwriting any previous file that existed on the volume with the same name.

volRefNum should be obtained via a call to VFSVolumeEnumerate

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of the picture
volRefNum,: IN: Ref number of the VFS volume
fileName,: IN: Filename of the image (ie "/DCIM/picture.jpg")
Return values:
Err 0 on success, non-zero on error.

Err ImageLibDeleteImage | ( | UInt16 | libRef,
 |  | UInt16 | recIndex
 | ) |

Delete a picture from the database.

This routine deletes an image and its thumbnail from the database.

Deleting a picture invalidates the record indices of all subsequent images in the database. Records are deleted with DmRemoveRecord. They are not archived.

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: index of image to delete.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibDoAttachImageDialog | ( | UInt16 | libRef,
 |  | UInt16 * | recIndexP,
 |  | UInt16 * | volRefNumP,
 |  | char * | fileName,
 |  | UInt16 | initialCategory,
 |  | Boolean | showConfirmation,
 |  | Boolean | internalImagesOnly,
 |  | const char * | dialogTitle,
 |  | const char * | btnTitle
 | ) |

Displays the attach image dialog.

Displays the attach image dialog. Allows to user to select a picture from a list. After choosing an image, the selection is written to the output parameters recIndexP, volRefNum, and filename.

If the user cancels the dialog, the return value is still 0. The values in recIndexP and volRefNumP indicate that the dialog was cancelled.

Parameters:
libRef,: IN: Library reference number.
recIndexP,: OUT: If the user selects an image from the database, recIndexP will contain the index of the image. If the user selects an image from a VFS volume, or they cancel the dialog, or an error occurs, recIndexP will contain kInvalidRecIndex.
volRefNumP,: OUT: If the user selects an image from the VFS system, volRefNumP will contain the volume ref number of the selected image. In all other cases, volRefNumP will contain vfsInvalidVolRef.
fileName,: OUT: If the user selects an image from the VFS system, the full path of the file will be copied into fileNameP. fileName should be capable of holding the largest possible VFS filename. If the user does not select a VFS file, fileName[0] will be NULL.
initialCategory,: IN: The initial category that should be highlighted in the category dropdown. Pass 0 for unfiled. Pass dmAllCategories to show all pictures from the database.
showConfirmation,: IN: If true, a confirmation dialog will be displayed that shows the image in full size. If false, the confirmation dialog is skipped.
internalImagesOnly,: IN: If true, images from VFS volumes are not displayed to the user.
dialogTitle,: IN: The string to display as the title of the dialog. Pass null to display a localized default.
btnTitle,: IN: The string to display as the title of the OK button. Pass null to display a localized default.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibDrawJPEG | ( | UInt16 | libRef,
 |  | MemPtr | jpegDataP,
 |  | UInt32 | jpegSize,
 |  | Coord | left,
 |  | Coord | top,
 |  | Boolean | fitToScreen,
 |  | Coord | width,
 |  | Coord | height
 | ) |

Decompresses a blob of JPEG data and draws it to the current draw window. The picture is drawn at left,top, which are relative to the draw window.

If the image needs to be resized, its aspect ratio is maintained. To determine how an image will be resized beforehand, call ImageLibGetDimensionsJPEG.

See also:
ImageLibGetDimensionsJPEG
Parameters:
libRef,: IN: Library reference number.
jpegDataP,: IN: Pointer to a JPEG image in memory.
jpegSize,: IN: Size of the source image in bytes.
left,: IN: x location to draw the image, relative to the current draw window.
top,: IN: y location to draw the image, relative to the current draw window.
fitToScreen,: IN: If true, the JPEG is resized to fit in a box defined by width and height. If false, image is not resized.
width,: IN: Max width of drawn image. Ignored if fitToScreen is false.
height,: IN: Max height of drawn image. Ignored if fitToScreen is false.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibFindImageByID | ( | UInt16 | libRef,
 |  | UInt32 | uniqueID,
 |  | UInt16 * | recIndexP
 | ) |

Determines the record index of an image in the database given a unique ID. The image is found by calling DmFindRecordByID on the main database.

If you need to store a permanent reference to a picture in the database, it is best to store its unique ID. You can obtain the unique ID of an image by calling ImageLibGetImageInfo. To access an image by unique ID, call ImageLibFindImageByID to retrieve the record index, and then use the record index to access the picture.

See also:
ImageLibGetImageInfo
Parameters:
libRef,: IN: Library reference number.
uniqueID,: IN: Unique ID of the image to find.
recIndexP,: OUT: Record index of the image.
Return values:
Err 0 on success, non-zero on error.

Int32 ImageLibGetAveragePictureSize | ( | UInt16 | libRef,
 |  | Boolean | fullsize
 | ) |

Returns the average size that a picture will be at the current compression factor.

Parameters:
libRef,: IN: Library reference number.
fullsize,: IN: True to return average of last 20 fullsize captures. False to return average of palm size captures.
Return values:
Int32 0 Average size.

Err ImageLibGetDimensions | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | Coord * | width,
 |  | Coord * | height,
 |  | Boolean | fitToDimensions
 | ) |

Retrieves the dimensions of an image in the database.

This routine allows clients of the library to query the dimensions of an image in the database. If fitToDimensions is false, the routine copies the full dimensions of the image to widthP and heightP. The initial values of widthP and heightP are ignored. If fitToDimensions is true, the routine calculates how big the image will be after it is downsized to fit in a box determined by the initial values of widthP and heightP.

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of image.
width,: IN,OUT: On output, contains the width of the image. On input, if fitToDimensions is true, determines the max width that the image should be.
height,: IN,OUT: On output, contains the height of the image. On input, if fitToDimensions is true, determines the max height that the image should be.
fitToDimensions,: IN: If true, tells the library to return the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibGetDimensionsJPEG | ( | UInt16 | libRef,
 |  | MemPtr | jpegDataP,
 |  | UInt32 | jpegSize,
 |  | Coord * | width,
 |  | Coord * | height,
 |  | Boolean | fitToDimensions
 | ) |

Retrieves the dimensions of a blob of JPEG data in memory.

This routine allows clients of the library to query the dimensions of an arbitrary blob of JPEG data. The routine follows the same semantics as ImageLibGetDimensions.

See also:
ImageLibGetDimensions
Parameters:
libRef,: IN: Library reference number.
jpegDataP,: IN: Pointer to a JPEG image in memory.
jpegSize,: IN: Size of the source image in bytes.
width,: IN,OUT: On output, contains the width of the image. On input, if fitToDimensions is true, determines the max width that the image should be.
height,: IN,OUT: On output, contains the height of the image. On input, if fitToDimensions is true, determines the max height that the image should be.
fitToDimensions,: IN: If true, tells the library to return the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibGetDimensionsVFS | ( | UInt16 | libRef,
 |  | UInt16 | volRefNum,
 |  | const char * | fileName,
 |  | Coord * | width,
 |  | Coord * | height,
 |  | Boolean | fitToDimensions
 | ) |

Retrieves the dimensions of an image on a VFS volume.

This routine allows clients of the library to query the dimensions of an image that resides on a VFS volume. The routine follows the same semantics as ImageLibGetDimensions.

See also:
ImageLibGetDimensions
Parameters:
libRef,: IN: Library reference number.
volRefNum,: IN: Ref number of the VFS volume
fileName,: IN: Filename of the image (ie "/DCIM/picture.jpg")
width,: IN,OUT: On output, contains the width of the image. On input, if fitToDimensions is true, determines the max width that the image should be.
height,: IN,OUT: On output, contains the height of the image. On input, if fitToDimensions is true, determines the max height that the image should be.
fitToDimensions,: IN: If true, tells the library to return the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibGetImageDatabases | ( | UInt16 | libRef,
 |  | DmOpenRef * | dbMainP,
 |  | DmOpenRef * | dbNoteP,
 |  | DmOpenRef * | dbImageP
 | ) |

Return the references to the database that are used to store pictures.

The image library opens each database when it is loaded, and closes them when it is unloaded. Do not close the database references that are returned by this function because the references are still being used by the imaging library.

The data in each database is stored in little endian format.

The main database contains one record for each image in the database. Each record has a fixed size and contains information about the picture. The image database contains the actual JPEG data for each image. The main database acts as a master table and the images database is a child table.

The notes database is not currently used.

The category of an image is determined by the category of its record in the main database. Categories are not used in the image table.

Parameters:
libRef,: IN: Library reference number.
dbMainP,: OUT: Reference to the main database. Pass NULL for this parameter if you don’t want to retrieve it.
dbNoteP,: OUT: Reference to the note database. Pass NULL for this parameter if you don’t want to retrieve it.
dbImageP,: OUT: Reference to the images database.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibGetImageID | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | char * | mediaIDP,
 |  | char * | containerIDP
 | ) |

Gets the media and container IDs for an image in the database.

The media ID and container ID should both be at least 21 bytes in size. The library copies 21 bytes to the supplied buffers.

See also:
ImageLibSetImageID
Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of image.
mediaIDP,: IN: Media ID.
containerIDP,: IN: Container ID.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibGetImageInfo | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | Char * | name,
 |  | Boolean * | fullSizeP,
 |  | UInt32 * | createdP,
 |  | UInt32 * | sizeP,
 |  | UInt16 * | categoryP,
 |  | Char * | categoryName,
 |  | Boolean * | lockedP,
 |  | UInt32 * | uidP
 | ) |

Retrieves information about an image stored in the database.

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of the picture
name,: OUT: Buffer to receive the name of the image. The buffer should be at least 32 characters long (31 + null terminator). Pass NULL for this parameter if you don't want to retrieve it.
fullSizeP,: OUT: true if image is 640x480, false if palm size. Pass NULL for this parameter if you don't want to retrieve it.
createdP,: OUT: Timestamp when picture was creatd. Pass NULL for this parameter if you don't want to retrieve it.
sizeP,: OUT: Size of the image data in bytes. Pass NULL for this parameter if you don't want to retrieve it.
categoryP,: OUT: Category that that picture is assigned to. Pass NULL for this parameter if you don't want to retrieve it.
categoryName,: OUT: Text description of the picture's category (ie 'Unfiled'). Pass NULL for this parameter if you don't want to retrieve it.
lockedP,: OUT: true if image is locked.
uidP,: OUT: Unique ID of the image.
Return values:
Err 0 on success, non-zero on error.

Int32 ImageLibGetJPEGQuality ( UInt16 libRef )

Returns the compression factor used for JPEG compression operations.

Parameters:
libRef,: IN: Library reference number.
Return values:
Int32 Compression value. [1,99]

Err ImageLibGetVersion | ( | UInt16 | libRef,
 |  | UInt32 * | dwVerP
 | ) |

Retrieves the version number of the image library.

Parameters:
libRef,: IN: Library reference number.
dwVerP,: OUT: Pointer to library version variable.
Return values:
Err 0 on success or error code on failure.

BitmapType* ImageLibImageBitmapCreate | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | Err * | errP
 | ) |

Creates a 16 bit bitmap for holding an image from the database. If recIndex is a valid image index, that image is loaded into the resulting bitmap. Otherwise, the result is an empty picture.

When called from a 68k application, the return value should be treated as opaque. The bitmap can safely be passed to the Palm OS bitmap routines, but 68k applications should not attempt to dereference members of the bitmap structure directly.

Bitmaps created with this function should be disposed of by calling ImageLibBitmapDelete. Do note call BmpDelete or MemPtrFree.

If an error occurs, this function returns NULL and writes an error code to errP. If the function returns a non-NULL bitmap value, then *errP will always be 0.

If recIndex is kInvalidRecIndex, the result is an empty 160x120 bitmap. If recIndex is not kInvalidRecIndex, the result is a bitmap that contains the given image from the database. The returned bitmap will be 160x120 if the image in the database is 160x120, 320x240, 640x480, or any other image larger than 160x120 with a 4:3 aspect ratio. If the image has a non-standard size, it is downsized to fit in a 160x120 box. The aspect ratio of the picture is preserved. Images that are less than 160x120 are not scaled at all.

See also:
ImageLibBitmapDelete

ImageLibPreviewStop

ImageLibPreviewStart

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of image to fill bitmap with. Use kInvalidRecIndex to create an empty 160x120, 16 bit bitmap.
errP,: OUT: If the function succeeds, 0 is written to errP. Otherwise, a non-zero error code is written. This parameter should not be NULL.
Return values:
BitmapType* On success, the result is a new bitmap with a bit depth of 16. On error, the result is NULL.

BitmapType* ImageLibImageBitmapCreateFromVFS | ( | UInt16 | libRef,
 |  | UInt16 | volRefNum,
 |  | const char * | fileName,
 |  | Err * | errP
 | ) |

Creates a 16 bit bitmap for holding an image from a VFS volume. The library decompresses the image from the volume and stores it in the result.

When called from a 68k application, the return value should be treated as opaque. The bitmap can safely be passed to the Palm OS bitmap routines, but 68k applications should not attempt to dereference members of the bitmap structure directly.

Bitmaps created with this function should be disposed of by calling ImageLibBitmapDelete. Do note call BmpDelete or MemPtrFree.

If an error occurs, this function returns NULL and writes an error code to errP. If the function returns a non-NULL bitmap value, then *errP will always be 0.

The picture is always resized to fit in a 160x120 box. If the image needs to be resized, its aspect ratio is maintained.

See also:
ImageLibBitmapDelete
Parameters:
libRef,: IN: Library reference number.
volRefNum,: IN: Ref number of the VFS volume
fileName,: IN: Filename of the image (ie "/DCIM/picture.jpg")
errP,: OUT: If the function succeeds, 0 is written to errP. Otherwise, a non-zero error code is written. This parameter should not be NULL.
Return values:
BitmapType* On success, the result is a new bitmap with a bit depth of 16. On error, the result is NULL.

Err ImageLibImageBitmapFill | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | BitmapType * | imageP
 | ) |

Fills a bitmap with an image from the database.

The imageP argument should represent a bitmap created with ImageLibImageBitmapCreate.

The image from the database is resampled as necessary to fit the dimensions of imageP. When the image is a jpeg, the DCT scaling features of the IJG library are used to get the image size close to the destination size. From there, the image is resampled with a filter to match the dimensions of imageP. If the aspect ratio of imageP does not match the aspect ratio of the picture, the picture is stretched to fit.

See also:
ImageLibImageBitmapCreate

ImageLibBitmapDelete

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: index of image to fill bitmap with.
imageP,: IN,OUT: Bitmap to fill.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibImageBitmapFillFromVFS | ( | UInt16 | libRef,
 |  | UInt16 | volRefNum,
 |  | const char * | fileName,
 |  | BitmapType * | imageP
 | ) |

Fills a 16 bit bitmap with an image from a VFS volume. The library decompresses the image from the volume and stores it in the supplied bitmap. The image is resized to fit the dimensions of the supplied bitmap.

The imageP argument should represent a bitmap created with ImageLibImageBitmapCreate or ImageLibImageBitmapCreateFromVFS.

The image is resampled as necessary to fit the dimensions of imageP. When the image is a jpeg, the DCT scaling features of the IJG library are used to get the image size close to the destination size. From there, the image is resampled with a filter to match the dimensions of imageP. If the aspect ratio of imageP does not match the aspect ratio of the picture, the picture is stretched to fit.

See also:
ImageLibImageBitmapCreate

ImageLibImageBitmapCreateFromVFS

ImageLibBitmapDelete

Parameters:
libRef,: IN: Library reference number.
volRefNum,: IN: Ref number of the VFS volume
fileName,: IN: Filename of the image (ie "/DCIM/picture001.jpg")
imageP,: IN,OUT: Bitmap to fill.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibImageCapture | ( | UInt16 | libRef,
 |  | Boolean | fullsize,
 |  | Boolean | playShutterSound,
 |  | Boolean | drawImmediately,
 |  | Coord | x,
 |  | Coord | y,
 |  | UInt16 * | newRecNoP
 | ) |

Captures an image and stores it in the database.

Images are appended to the end of the database.

The camera driver always captures 640x480 images. If fullSize is false, the data from the camera is downsampled to 160x120 using a filtering algorithm.

Captures are currently done in 16 bit RGB mode. Capturing an image requires at least 600 kB of free space in the dynamic heap (640x480x2).

Captured pictures are stored in uncompressed palmOS bitmap format. To compress an image as a JPEG, call ImageLibImageSave.

See also:
ImageLibImageSave
Parameters:
libRef,: IN: Library reference number.
fullsize,: IN: true capture a 640x480 image. false to capture 160x120
playShutterSound,: IN: true to play a camera shutter sound.
drawImmediately,: IN: true to immediately draw the captured image to the current draw window.
x,: IN: x location to draw the captured image. Relative to the current draw window. Ignored if drawImmediately is false.
y,: IN: y location to draw the captured image. Relative to the current draw window. Ignored if drawImmediately is false.
newRecNoP,: OUT: index of the new image. If the capture fails, kInvalidRecIndex is written to this value. Pass NULL if you don’t care what the new index is.
Return values:
Err 0 on success or error code on failure.

Err ImageLibImageDraw | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | Coord | x,
 |  | Coord | y
 | ) |

Draws an image from the database to the current draw window.

Draws an image from the database to the current draw window at x,y. x and y are window relative coordinates.

If necessary, the image is downsized to fit in a 160x120 box. The aspect ratio of the picture is preserved.

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: index of image to draw.
x,: IN: x location to draw the preview image, relative to the current draw window.
y,: IN: y location to draw the preview image, relative to the current draw window.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibImageDrawFromVFS | ( | UInt16 | libRef,
 |  | UInt16 | volRefNum,
 |  | const char * | fileName,
 |  | Coord | x,
 |  | Coord | y
 | ) |

Draws an image from from a VFS volume to the current draw window at x,y. x and y are window relative coordinates.

If necessary, the image is downsized to fit in a 160x120 box. The aspect ratio of the picture is preserved.

Parameters:
libRef,: IN: Library reference number.
volRefNum,: IN: Ref number of the VFS volume
fileName,: IN: Filename of the image (ie "/DCIM/picture001.jpg")
x,: IN: x location to draw the image, relative to the current draw window.
y,: IN: y location to draw the image, relative to the current draw window.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibImageSave | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | const char * | name,
 |  | UInt16 | category
 | ) |

Compresses a captured image to JPEG format.

Compresses a captured image to JPEG, sets the image name, and sets the category of the picture. After saving, the uncompressed bitmap data is discarded and replaced with the JPEG version of the image.

This routine should only be invoke on newly captured images, and it should only be called once per picture.

See also:
ImageLibImageCapture
Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of the image to compress.
name,: IN: Name of the picture
category,: IN: Category to store the image in
Return values:
Err 0 on success or error code on failure.

Err ImageLibInsertImageFromBuffer | ( | UInt16 | libRef,
 |  | MemPtr | bufP,
 |  | UInt32 | size,
 |  | const char * | name,
 |  | UInt16 | category,
 |  | UInt16 * | newRecIndexP
 | ) |

Inserts a JPEG blob into the image database, storing it with the supplied name and category.

Parameters:
libRef,: IN: Library reference number.
bufP,: IN: Pointer to a JPEG image in memory.
size,: IN: Size of the source image in bytes.
name,: IN: Name of the new image (ie "Picture001")
category,: IN: The category to store the image in. Pass 0 for unfiled.
newRecIndexP,: OUT: Index of the newly created image. Pass NULL if you don’t care about this value.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibInsertImageFromFile | ( | UInt16 | libRef,
 |  | FileHand | fileH,
 |  | const char * | name,
 |  | UInt16 | category,
 |  | UInt16 * | newRecIndexP
 | ) |

Insert an image into the database from a Palm OS file stream. The file stream is read from its current position to the end of the stream. When the routine is finished, it leaves the stream open and performs a FileSeek back to the original position.

Parameters:
libRef,: IN: Library reference number.
fileH,: IN: Handle to an open file stream that contains a JPEG starting at its current position.
name,: IN: Name of the new image (ie "Picture001")
category,: IN: The category to store the image in. Pass 0 for unfiled.
newRecIndexP,: OUT: Index of the newly created image. Pass NULL if you don’t care about this value.
Return values:
Err 0 on success, non-zero on error.

ImageIteratorHandle ImageLibIterateImages | ( | UInt16 | libRef,
 |  | UInt16 | category,
 |  | UInt16 | sortType,
 |  | UInt16 * | imageCountP,
 |  | Err * | errP
 | ) |

Creates an iterator for working with a collection of images in the database. When finished, the iterator refers to a data structure that contains images The iterator can be used to step through images, draw images, sort images, and search for images by name.

The returned iterator handle can be passed to other iterator routines that take an iterator handle. The handle should be freed by calling ImageLibIterFree.

See also:
ImageLibIterFree
Parameters:
libRef,: IN: Library reference number.
category,: IN: The category to search. Pass 0 for unfiled. Pass dmAllCategories to iterate through all images in the databse.
sortType,: IN: Initial sort order of the datastructure (kNoSortOrder, kSortByName, or kSortByDate)
imageCountP,: OUT: Number of images in the iterator data structure. Pass NULL if you don't care about this value.
errP,: OUT: 0 on success, non-zero on error. This parameter should not be null.
Return values:
ImageIteratorHandle Opaque iterator handle.

ImageIteratorHandle ImageLibIterateVFSImages | ( | UInt16 | libRef,
 |  | UInt16 | volRefNum,
 |  | const char * | path,
 |  | Boolean | recurseBelow,
 |  | UInt16 | sortType,
 |  | UInt16 * | imageCount,
 |  | Err * | errP
 | ) |

Creates an iterator for working with a collection of images on a VFS volume. When finished, the iterator refers to a data structure that contains images. The iterator can be used to step through images, draw images, sort images, and search for images by name.

The returned iterator handle can be passed to other iterator routines that take an iterator handle. The handle should be freed by calling ImageLibIterFree.

See also:
ImageLibIterFree
Parameters:
libRef,: IN: Library reference number.
volRefNum,: IN: VFS volume to search.
path,: IN: Directory to start searching in.
recurseBelow,: IN: true to recurse in all subdirectories of path. false to search in path only.
sortType,: IN: Initial sort order of the datastructure (kNoSortOrder, kSortByName, or kSortByDate)
imageCount,: OUT: Number of images in the iterator data structure. Pass NULL if you don't care about this value.
errP,: OUT: 0 on success, non-zero on error. This parameter should not be null.
Return values:
ImageIteratorHandle Opaque iterator handle.

Err ImageLibIterDeleteImage | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iter,
 |  | UInt16 | index
 | ) |

Deletes an image (either from the database or from a VFS volume)

Permanently deletes an image given a reference to the image in an iterator. Given an iterator and an index to an image in the iterator, this routine determines whether the image resides in the internal database or on a VFS volume. If it resides on a VFS volume, the routine attempts to delete it by calling VFSFileDelete. If it is an internal image, the picture is nuked by calling ImageLibDeleteImage. After the image is deleted, it is removed from the iterator chain. All subsequent images in the iterator data structure move down one spot. The count of images in the iterator chain is decremented by one.

The iterator handle should be created with ImageLibIterateImages or ImageLibIterateVFSImages.

Deleting an image invalidates the iterator index for all subsequent images in the iterator chain. If you need to delete a range of images in an iterator, it is best to loop from back to front.

Parameters:
libRef,: IN: Library reference number.
iter,: IN: Handle to an iterator.
index,: IN: Index of the image to delete. This is an index into the iterator, not an index to the image database.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibIterDrawImage | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iter,
 |  | UInt16 | index,
 |  | Coord | x,
 |  | Coord | y
 | ) |

Draws an image in an iterator chain to the current draw window at x,y. x and y are window relative coordinates.

If the image resides in the internal database, this routine calls ImageLibImageDraw to draw it. If it is a VFS image the call is dispatched to ImageLibImageDrawFromVFS

Parameters:
libRef,: IN: Library reference number.
iter,: IN: Handle to an iterator.
index,: IN: Index of the image to draw. This is an index into the iterator, not an index to the image database.
x,: IN: x location to draw the preview image, relative to the current draw window.
y,: IN: y location to draw the preview image, relative to the current draw window.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibIterDrawThumbnail | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iter,
 |  | UInt16 | index,
 |  | Coord | x,
 |  | Coord | y
 | ) |

Draws a thumbnail for an image in an iterator chain to the current draw window at x,y. x and y are window relative coordinates.

If the image resides in the internal database, this routine calls ImageLibThumbnailDraw to draw it. If it is a VFS image the call is dispatched to ImageLibThumbnailDrawFromVFS

Parameters:
libRef,: IN: Library reference number.
iter,: IN: Handle to an iterator.
index,: IN: Index of the image to draw. This is an index into the iterator, not an index to the image database.
x,: IN: x location to draw the preview image, relative to the current draw window.
y,: IN: y location to draw the preview image, relative to the current draw window.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibIterFree | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iter
 | ) |

Frees the memory associated with an iterator chain.

The iterator handle should be created with ImageLibIterateImages or ImageLibIterateVFSImages.

Once the iterator has been freed, it should not be used anymore.

Parameters:
libRef,: IN: Library reference number.
iter,: IN: Handle to an iterator.
Return values:
Err 0 on success, non-zero on error.

Err ImagelibIterGetCount | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iter,
 |  | UInt16 * | imageCountP
 | ) |

Retrieves the number of images stored in the iterator data structure.

The iterator handle should be created with ImageLibIterateImages or ImageLibIterateVFSImages.

Iterator routines that take an index should ensure that the index is less than the value returned in imageCountP.

See also:
ImageLibIterateImages

ImageLibIterateVFSImages

Parameters:
libRef,: IN: Library reference number.
iter,: IN: Handle to an iterator.
imageCountP,: OUT: Number of images in the iterator data structure.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibIterGetDimensions | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iter,
 |  | UInt16 | index,
 |  | Coord * | width,
 |  | Coord * | height,
 |  | Boolean | fitToDimensions
 | ) |

Retrieves the dimensions of an image in an iterator chain.

This routine allows clients of the library to query the dimensions of an image in an iterator chain. The routine follows the same semantics as ImageLibGetDimensions.

See also:
ImageLibGetDimensions
Parameters:
libRef,: IN: Library reference number.
iter,: IN: Iterator handle
index,: IN: Index of the image in the iterator. [0,imageCount)
width,: IN,OUT: On output, contains the width of the image. On input, if fitToDimensions is true, determines the max width that the image should be.
height,: IN,OUT: On output, contains the height of the image. On input, if fitToDimensions is true, determines the max height that the image should be.
fitToDimensions,: IN: If true, tells the library to return the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibIterGetImageInfo | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iter,
 |  | UInt16 | index,
 |  | char * | name,
 |  | UInt16 | nameLen,
 |  | UInt16 * | categoryP,
 |  | UInt16 * | recIndexP,
 |  | UInt16 * | volRefNumP,
 |  | UInt32 * | createdP,
 |  | UInt32 * | sizeP,
 |  | char * | path,
 |  | UInt16 | pathLen,
 |  | Boolean * | lockedP
 | ) |

Retrieves information about a single image in an iterator chain.

The iterator handle should be created with ImageLibIterateImages or ImageLibIterateVFSImages.

Pass NULL for any OUT parameter that you don't care about.

See also:
ImageLibIterateImages

ImageLibIterateVFSImages

Parameters:
libRef,: IN: Library reference number.
iter,: IN: Handle to an iterator.
index,: IN: Index of the image in the iterator. [0,imageCount)
name,: OUT: Buffer to receive the name of the image. For VFS images, this is the full path and filename of the image (ie "/dcim/picture001.jpg"). For internal images, this is the name of the picture (ie "Picture001")
nameLen,: IN: Size in bytes of the name buffer.
categoryP,: OUT: Category of the picture if it is stored in the image database. 0xFF if it is a VFS picture.
recIndexP,: OUT: Record index of the picture if it is stored in the image database. kInvalidRecIndex if it is a VFS picture.
volRefNumP,: OUT: VFS volume ref number of the picture if it is stored on a VFS volume. vfsInvalidVolRef if it is stored in the internal database.
createdP,: OUT: Timestamp when picture was creatd. Pass NULL for this parameter if you don't want to retrieve it.
sizeP,: OUT: Size of the image data in bytes. Pass NULL for this parameter if you don't want to retrieve it.
path,: OUT: Directory that the picture is stored in if it is a VFS image (ie /DCIM). Empty string if it is an internal image.
pathLen,: IN: Size in bytes of the path buffer.
lockedP,: OUT: true if the image is locked. False otherwise. VFS images are never locked.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibIterRefresh | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iter,
 |  | UInt16 | index,
 |  | const char * | newVFSName
 | ) |

Refreshes the information for an image in an iterator chain. If the image is stored in the image database, this routine updates the name, recIndex, category, size, timestamp, and locked status of the image. If it is a VFS picture, this routine updates the timestamp and size of the picture.

Call this function when an iterator refers to an image that has changed since the iterator was created. For example, if you downsize or resize an iternal image, call ImageLibIterRefresh to update the iterator information for that image.

If you rename a VFS picture that is referenced by an iterator chain, you can pass its new name for the newVFSName argument. Pass the full path and filename of the image. If you pass a string for this argument, the name of file in the iterator chain will be updated. Pass NULL for the newVFSName parameter if the iterator image refers to an internal picture or a VFS picture that whose name has not been changed (If you don't know what this is about, pass NULL).

Parameters:
libRef,: IN: Library reference number.
iter,: IN: Handle to an iterator.
index,: IN: Index of the image in the iterator. [0,imageCount)
newVFSName,: IN: If picture is a VFS file, pass its new name for this parameters
Return values:
Err 0 on success, non-zero on error.

Err ImageLibIterRemoveImage | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iter,
 |  | UInt16 | index
 | ) |

Removes an image from an iterator chain without deleting it from its original location.

Removes an image from an iterator chain without deleting it from its original location. Once an image is removed, it can no longer be accessed via the iterator. However, the image is still accessible from its original location (either in the image database or on a VFS card).

The iterator handle should be created with ImageLibIterateImages or ImageLibIterateVFSImages.

Removing an image invalidates the iterator index for all subsequent images in the iterator chain. If you need to remove a range of images in an iterator, it is best to loop from back to front.

Parameters:
libRef,: IN: Library reference number.
iter,: IN: Handle to an iterator.
index,: IN: Index of the image to remove. This is an index into the iterator, not an index to the image database.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibIterResize | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iter,
 |  | UInt16 | index,
 |  | Coord * | widthP,
 |  | Coord * | heightP,
 |  | Boolean | maintainAspectRatio
 | ) |

Resizes an image in an iterator chain.

This routine resizes an image in an iterator chain to any size. The routine follows the same semantics as ImageLibResize.

See also:
ImageLibResize
Parameters:
libRef,: IN: Library reference number.
iter,: IN: Iterator handle
index,: IN: Index of the image in the iterator. [0,imageCount)
widthP,: IN/OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
heightP,: IN/OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
maintainAspectRatio,: IN: If true, tells the library to maintain the aspect ratio of the image. In this case, the input values of widthP and heightP serve as maximum guidelines. If false, the image is stretched to fit the input values of widthP and heightP. the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibIterSearch | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iterH,
 |  | const char * | name,
 |  | Boolean | partialMatch,
 |  | UInt16 * | index
 | ) |

Searches for an image in an iterator chain by name. To match, a picture's name must the name string starting in the first character. If partical match is true, then the entire string must match. Case is ignored for all comparisons. Pattern matching and wildcards are not supported.

Parameters:
libRef,: IN: Library reference number.
iterH,: IN: Handle to an iterator.
name,: IN: String to search for.
partialMatch,: IN: If true, only the beginning of a picture name must match. If false, the entire name must match.
index,: OUT: Contains the index of the first picture that matches the search string. kInvalidRecIndex if no match found.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibIterSort | ( | UInt16 | libRef,
 |  | ImageIteratorHandle | iter,
 |  | UInt16 | sortType
 | ) |

Sorts the images in an iterator chain. Note that this only reorganizes images in the iterator data structure. This does not alter the way images are stored in the database or on a card. images, sort images, and search for images by name.

The iterator handle should be created with ImageLibIterateImages or ImageLibIterateVFSImages.

See also:
ImageLibIterateImages

ImageLibIterateVFSImages

Parameters:
libRef,: IN: Library reference number.
iter,: IN: Handle to an iterator.
sortType,: IN: New sort order of the datastructure (kNoSortOrder, kSortByName, kSortByDate, kSortByNameDesc, or kSortByDateDesc)
Return values:
Err 0 on success, non-zero on error.

Err ImageLibLockImage | ( | UInt16 | libRef,
 |  | UInt16 | recIndex
 | ) |

Returns the compression factor used for JPEG compression operations.

Once an image is locked, it is locked forever and can't be unlocked.

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of the image to compress.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibOpen ( UInt16 libRef )

Library open call for 68k clients of the library. This routine maps to the sysLibTrapOpen trap.

It is customary for shared libraries to provide open and close functions. The open and close functions in ImageLib are empty stubs that exist for the sole purpose of adhering to past convention. This function does nothing and will always return errNone. All library initialization is done from PilotMain.

This function is not available to ARM clients of the library.

Parameters:
libRef,: IN: Library reference number.
Return values:
Err 0 on success or error code on failure.

BitmapType* ImageLibPreviewBitmapCreate | ( | UInt16 | libRef,
 |  | Err * | errP
 | ) |

Creates a preview bitmap. If Compresses a captured image to JPEG, sets the image name, and sets the category of the picture. After saving, the uncompressed bitmap data is discarded and replaced with the JPEG version of the image.

When called from a 68k application, the return value should be treated as opaque. The bitmap can safely be passed to the Palm OS bitmap routines, but 68k applications should not attempt to dereference members of the bitmap structure directly.

Bitmaps created with this function should be disposed of by calling ImageLibBitmapDelete. Do note call BmpDelete or MemPtrFree.

If an error occurs, this function returns NULL and writes an error code to errP. If the function returns a non-NULL bitmap value, then *errP will always be 0.

This function does not perform an image preview. The resulting bitmap is empty. To fill the bitmap with a preview image, pass it to ImageLibPreviewBitmapFill.

See also:
ImageLibPreviewBitmapFill

ImageLibBitmapDelete

Parameters:
libRef,: IN: Library reference number.
errP,: OUT: 0 on success, non-zero on error. This parameter should not be null.
Return values:
BitmapType On success, the result is a new 160x120 bitmap whose bit depth matches the bit depth of the screen. On failure, the result is NULL

Err ImageLibPreviewBitmapFill | ( | UInt16 | libRef,
 |  | BitmapType * | imageP
 | ) |

Fills a bitmap with a preview image from the camera.

The imageP argument should represent a bitmap created with ImageLibPreviewBitmapCreate.

See also:
ImageLibPreviewBitmapCreate

ImageLibBitmapDelete

ImageLibPreviewStop

ImageLibPreviewStart

Parameters:
libRef,: IN: Library reference number.
imageP,: IN,OUT: Bitmap to fill with a preview.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibPreviewDraw | ( | UInt16 | libRef,
 |  | Coord | x,
 |  | Coord | y
 | ) |

Draws a preview image to the current draw window.

Snaps a preview image with the camera driver and then draws it to the current draw window at x,y. x and y are relative coordinates.

See also:
ImageLibPreviewStop

ImageLibPreviewStart

Parameters:
libRef,: IN: Library reference number.
x,: IN: x location to draw the preview image, relative to the current draw window.
y,: IN: y location to draw the preview image, relative to the current draw window.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibPreviewStart | ( | UInt16 | libRef,
 |  | void * | windowH,
 |  | Coord | x,
 |  | Coord | y
 | ) |

Turns on the direct draw preview mode of the camera.

This routine serves as a front end to the camera driver's CameraLibPreviewStart function. After being called, the camera will display preview images to the supplied window at the given coordinates.

See also:
ImageLibPreviewStop
Parameters:
libRef,: IN: Library reference number.
windowH,: IN: Window handle where preview images should be drawn. This should generally be a screen window.
x,: IN: x location to draw the preview image. Relative to windowH.
y,: IN: y location to draw the preview image. Relative to windowH.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibPreviewStop ( UInt16 libRef )

Turns off the direct draw preview mode of the camera.

This routine serves as a front end to the camera driver's CameraLibPreviewStop function. It halts previews that were initiated by a call to ImageLibPreviewStart.

See also:
ImageLibPreviewStart
Parameters:
libRef,: IN: Library reference number.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibResize | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | Coord * | widthP,
 |  | Coord * | heightP,
 |  | Boolean | maintainAspectRatio
 | ) |

Resizes an image in the database to any arbitrary size.

This routine resizes an image in the database to any size. The routine can maintain the existing aspect ratio of the image, or it can stretch it to fit any size.

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of image.
widthP,: IN,OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
heightP,: IN,OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
maintainAspectRatio,: IN: If true, tells the library to maintain the aspect ratio of the image. In this case, the input values of widthP and heightP serve as maximum guidelines. If false, the image is stretched to fit the input values of widthP and heightP. the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibResizeImage | ( | UInt16 | libRef,
 |  | UInt16 | recIndex
 | ) |

Deprecated:
Resizes a fullsize picture in the database to 160x120 (palm size). The original fullsize image is replaced with the palm size version.

If the original image is a full size 640x480 jpeg, the image is downsampled using the DCT scaling features of the IJG library. This means that the JPEG is decompressed directly to 160x120, and then compressed again and saved back to the database.

If the original image is not a 640x480 jpeg, it is scaled as much as possible using the IJG scaling features. After decompression, the picture is resampled with a filter to get its dimensions to 160x120.

ImageLibResizeImage is deprecated. Use ImageLibResize instead.

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: index of image to resize.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibResizeJPEG | ( | UInt16 | libRef,
 |  | MemPtr | jpegInputP,
 |  | UInt32 | inputSize,
 |  | Coord * | widthP,
 |  | Coord * | heightP,
 |  | Boolean | maintainAspectRatio,
 |  | MemPtr * | outputPP,
 |  | UInt32 * | outputSizeP
 | ) |

Resizes a JPEG in memory.

This routine resizes a JPEG in memory to any size. The routine follows the same semantics as ImageLibResize, except that it creates a new JPEG in memory as a result.

See also:
ImageLibResize
Parameters:
libRef,: IN: Library reference number.
jpegInputP,: IN: Pointer to a JPEG image in memory.
inputSize,: IN: Size of the source image in bytes.
widthP,: IN,OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
heightP,: IN,OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
maintainAspectRatio,: IN: If true, tells the library to maintain the aspect ratio of the image. In this case, the input values of widthP and heightP serve as maximum guidelines. If false, the image is stretched to fit the input values of widthP and heightP. the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
outputPP,: OUT: Pointer to the newly sized JPEG. The caller is responsible for freeing this memory.
outputSizeP,: OUT: Size in bytes of the newly sized JPEG.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibResizeVFS | ( | UInt16 | libRef,
 |  | UInt16 | volRefNum,
 |  | const char * | fileName,
 |  | Coord * | widthP,
 |  | Coord * | heightP,
 |  | Boolean | maintainAspectRatio
 | ) |

Resizes an image on a VFS volume to any arbitrary size.

This routine resizes a VFS image to any size. The routine follows the same semantics as ImageLibResize.

See also:
ImageLibResize
Parameters:
libRef,: IN: Library reference number.
volRefNum,: IN: Ref number of the VFS volume
fileName,: IN: Filename of the image (ie "/DCIM/picture.jpg")
widthP,: IN,OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
heightP,: IN,OUT: On output, contains the new width of the image. On input, if maintainAspectRatio is true, determines the max width that the image should be. If maintainAspectRatio is false, determines the exact width that the image should be after resizing.
maintainAspectRatio,: IN: If true, tells the library to maintain the aspect ratio of the image. In this case, the input values of widthP and heightP serve as maximum guidelines. If false, the image is stretched to fit the input values of widthP and heightP. the dimensions that an image would be if it was forced to draw in a box bounded by widthP and heightP.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibSetImageID | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | const char * | mediaIDP,
 |  | const char * | containerIDP
 | ) |

Sets the media and container IDs for an image in the database.

The media ID and container ID should both be 21 bytes in size. The image library copies 21 bytes from the supplied buffers into the main record for the image.

See also:
ImageLibGetImageID
Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of image.
mediaIDP,: IN: Media ID.
containerIDP,: IN: Container ID.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibSetImageInfo | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | const char * | name,
 |  | UInt16 * | categoryP
 | ) |

Assigns information about an image stored in the database.

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: Index of the picture
name,: IN: Name of the picture. Pass NULL for this parameter if you don't want to set it.
categoryP,: OUT: Category that that picture is assigned to. Pass NULL for this parameter if you don't want to set it.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibSetJPEGQuality | ( | UInt16 | libRef,
 |  | Int32 | value
 | ) |

Sets the compression factor for all JPEG compression operations performed by the imaging library. The compression factor shoule be a value in the range of 1-99.

Parameters:
libRef,: IN: Library reference number.
value,: IN: new compression quality.
Return values:
Err 0 on success, non-zero on error.

void ImageLibSetProgressCallback | ( | UInt16 | libRef,
 |  | ImageLibProgressCallbackType | callback
 | ) |

Sets a progress callback function. The image library will invoke this routine periodically during long processing, such as compressing or decompressing a jpeg or resizing an image.

All of the APIs that decompress or resize images use the callback mechanism. ImageLibImageSave also invokes it.

max is the total number of operations that must be performed. For a JPEG compression or decompression, this equates to the number of horizontal scan lines in the image. The progress value will range from 0 to max. The imaging library will invoked the callback repeatedly. On each pass, the progress variable will increase by some unspecified amount. The operation argument determines the type of operation being performed. Possible values are kResizeOperation, kJPEGOperation, and kVFSOperation.

The callback function should have the following signature:

 void callback(Int32 progress, Int32 max, Int8 operation);

Parameters:
libRef,: IN: Library reference number.
callback,: IN: Address of the callback function. Pass NULL to reset the callback to nothing.
Return values:
void

BitmapType* ImageLibThumbnailBitmapCreate | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | Err * | errP
 | ) |

Creates a 16 bit bitmap for holding an thumbnail image . If recIndex is a valid image index, the thumbnail for that image is loaded into the resulting bitmap. Otherwise, the result is an empty bitmap.

When called from a 68k application, the return value should be treated as opaque. The bitmap can safely be passed to the Palm OS bitmap routines, but 68k applications should not attempt to dereference members of the bitmap structure directly.

Bitmaps created with this function should be disposed of by calling ImageLibBitmapDelete. Do note call BmpDelete or MemPtrFree.

If an error occurs, this function returns NULL and writes an error code to errP. If the function returns a non-NULL bitmap value, then *errP will always be 0.

The thumbnail is generated on the fly if the image in the database does not have a thumbnail record.

See also:
ImageLibBitmapDelete
Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: index of image to fill the thumbnail bitmap with. Use kInvalidRecIndex to create an empty 40x30, 16 bit bitmap.
errP,: OUT: If the function succeeds, 0 is written to errP. Otherwise, a non-zero error code is written. This parameter should not be NULL.
Return values:
BitmapType* On success, the result is a new bitmap with a bit depth of 16. On error, the result is NULL.

BitmapType* ImageLibThumbnailBitmapCreateFromVFS | ( | UInt16 | libRef,
 |  | UInt16 | volRefNum,
 |  | const char * | fileName,
 |  | Err * | errP
 | ) |

Creates a 16 bit bitmap for holding an thumbnail image for a VFS JPEG.

When called from a 68k application, the return value should be treated as opaque. The bitmap can safely be passed to the Palm OS bitmap routines, but 68k applications should not attempt to dereference members of the bitmap structure directly.

Bitmaps created with this function should be disposed of by calling ImageLibBitmapDelete. Do note call BmpDelete or MemPtrFree.

If an error occurs, this function returns NULL and writes an error code to errP. If the function returns a non-NULL bitmap value, then *errP will always be 0.

The thumbnail is generated on the fly from VFS file. For large images, this operation can be slow.

See also:
ImageLibBitmapDelete
Parameters:
libRef,: IN: Library reference number.
volRefNum,: IN: Ref number of the VFS volume
fileName,: IN: Filename of the image (ie "/DCIM/picture001.jpg")
errP,: OUT: If the function succeeds, 0 is written to errP. Otherwise, a non-zero error code is written. This parameter should not be NULL.
Return values:
BitmapType* On success, the result is a new bitmap with a bit depth of 16. On error, the result is NULL.

Err ImageLibThumbnailBitmapFill | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | BitmapType * | imageP
 | ) |

Fills a bitmap with an thumbnail image from the database.

The imageP argument should represent a bitmap created with ImageLibThumbnailBitmapCreate.

The image from the database is resampled as necessary to fit the dimensions of imageP. If the aspect ratio of imageP does not match the aspect ratio of the picture, the picture is stretched to fit.

See also:
ImageLibThumbnailBitmapCreate

ImageLibBitmapDelete

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: index of image
imageP,: IN,OUT: Bitmap to fill.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibThumbnailBitmapFillFromVFS | ( | UInt16 | libRef,
 |  | UInt16 | volRefNum,
 |  | const char * | fileName,
 |  | BitmapType * | imageP
 | ) |

Fills a bitmap with a thumbnail image from a VFS volume. *

The imageP argument should represent a bitmap created with ImageLibThumbnailBitmapCreate or ImageLibThumbnailBitmapCreateFromVFS.

The image is resampled as necessary to fit the dimensions of imageP.

See also:
ImageLibThumbnailBitmapCreate

ImageLibThumbnailBitmapCreateFromVFS

ImageLibBitmapDelete

Parameters:
libRef,: IN: Library reference number.
volRefNum,: IN: Ref number of the VFS volume
fileName,: IN: Filename of the image (ie "/DCIM/picture001.jpg")
imageP,: IN,OUT: Bitmap to fill.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibThumbnailDraw | ( | UInt16 | libRef,
 |  | UInt16 | recIndex,
 |  | Coord | x,
 |  | Coord | y
 | ) |

Draws an thumbnail image from the database to the current draw window at x,y. x and y * are window relative coordinates.

Parameters:
libRef,: IN: Library reference number.
recIndex,: IN: index of image
x,: IN: x location to draw the preview image, relative to the current draw window.
y,: IN: y location to draw the preview image, relative to the current draw window.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibThumbnailDrawFromVFS | ( | UInt16 | libRef,
 |  | UInt16 | volRefNum,
 |  | const char * | fileName,
 |  | Coord | x,
 |  | Coord | y
 | ) |

Draws an thumbnail image from a VFS image to the current draw window at x,y. x and y * are window relative coordinates.

Parameters:
libRef,: IN: Library reference number.
volRefNum,: IN: Ref number of the VFS volume
fileName,: IN: Filename of the image (ie "/DCIM/picture001.jpg")
x,: IN: x location to draw the preview image, relative to the current draw window.
y,: IN: y location to draw the preview image, relative to the current draw window.
Return values:
Err 0 on success, non-zero on error.

Err ImageLibTurnCameraOff ( UInt16 libRef )

Deactivates the camera hardware by unloading the camera driver.

Parameters:
libRef,: IN: Library reference number.
Return values:
Err 0 on success, non-zero on error.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:55 2006 for Palm API Guide


ImageLibCommon.h File Reference

Detailed Description

Public 68k common header file for the Image Library API on Treo 600 devices.

Version:
1.0
This file contains common defines and error codes to be used with Imaging Library API.

Include dependency graph for ImageLibCommon.h:

Preview Image Dimensions

Preview height and width in standard pixels. On a double density device, the bitmap returned would be twice these dimensions.
  • #define kPalmSizeImageWidth 160
  • #define kPalmSizeImageHeight 120
  • #define kFullSizeImageWidth 640
  • #define kFullSizeImageHeight 480
  • #define kThumbnailImageWidth 40
  • #define kThumbnailImageHeight 30
  • #define kPreviewBitmapWidth (kPalmSizeImageWidth)
  • #define kPreviewBitmapHeight (kPalmSizeImageHeight)

Sort Orders

  • #define kNoSortOrder (0)
  • #define kSortByName (1)
  • #define kSortByDate (2)
  • #define kSortByNameDesc (3)
  • #define kSortByDateDesc (4)

Image Operation Codes

  • #define kResizeOperation (0)
  • #define kJPEGOperation (1)
  • #define kVFSOperation (2)

Error Codes

  • #define imageLibErrorClass (appErrorClass | 0x1000)
  • #define imageLibErrBadParam (imageLibErrorClass)
  • #define imageLibErrNoCamera (imageLibErrorClass + 1)
  • #define imageLibErrInternalFailure (imageLibErrorClass + 2)
  • #define imageLibErrWriteFailure (imageLibErrorClass + 3)
  • #define imageLibErrReadFailure (imageLibErrorClass + 4)
  • #define imageLibErrBadData (imageLibErrorClass + 5)
  • #define imageLibErrBadImageType (imageLibErrorClass + 6)
  • #define imageLibErrBadImageDepth (imageLibErrorClass + 7)
  • #define imageLibErrBadDimensions (imageLibErrorClass + 8)
  • #define imageLibErrInitializationFailed (imageLibErrorClass + 9)
  • #define imageLibErrBadColorspace (imageLibErrorClass + 10)
  • #define imageLibErrBadThumbnailType (imageLibErrorClass + 11)
  • #define imageLibErrThumnailExists (imageLibErrorClass + 12)
  • #define imageLibErrBadScaleFactor (imageLibErrorClass + 13)
  • #define imageLibErrBadBitmapType (imageLibErrorClass + 14)
  • #define imageLibErrImageAlreadyDownsized (imageLibErrorClass + 15)
  • #define imageLibErrImageLocked (imageLibErrorClass + 16)

Defines

  • #define ImageLibCreatorID 'imgL'
  • #define ImageLibTypeID 'libr'
  • #define ImageLibName "ImageLibrary"
  • #define kInvalidRecIndex ((UInt16)0xFFFF )
  • #define kImageFilenameLength (dmDBNameLength)

Typedefs

  • typedef void * ImageIteratorHandle
  • typedef void(* ImageLibProgressCallbackType )(Int32 progress, Int32 max, Int8 operation)

Define Documentation

#define ImageLibCreatorID 'imgL'

Imaging library creator ID

#define ImageLibName "ImageLibrary"

Imaging library database name

#define ImageLibTypeID 'libr'

Standard library type

#define kImageFilenameLength (dmDBNameLength)

max filename length

#define kInvalidRecIndex ((UInt16)0xFFFF )

define for invalid record index

Typedef Documentation

typedef void* ImageIteratorHandle

Handle returned by ImageLibIterateImages or ImageLibIterateVFSImages.

typedef void(* ImageLibProgressCallbackType)(Int32 progress, Int32 max, Int8 operation)

Passed in when calling ImageLibSetProgressCallback

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:55 2006 for Palm API Guide


LocsLib.h File Reference

Detailed Description

Public 68K include file for location/timezone/DST support on Palm devices.

Include dependency graph for LocsLib.h:

Functions

  • Err LocsLibOpen (UInt16 iLibRefNum)
  • Err LocsLibClose (UInt16 iLibRefNum)
  • Err LocsLibSleep (UInt16 iLibRefNum)
  • Err LocsLibWake (UInt16 iLibRefNum)
  • Err LocsLibGetVersion (UInt16 iLibRefNum, UInt32 iSDKVersion, UInt32 *oVersionP)
  • Boolean LocsLibLaunchEditListDialogue (UInt16 iLibRefNum, LocsLibSelLocsType *ioSelLocsP)
  • Boolean LocsLibLaunchSelDialogue (UInt16 iLibRefNum, LocsLibSelLocsType *ioSelLocsP)
  • void LocationCopy (UInt16 iLibRefNum, LocationType *thisP, const LocationType *iLocToCopyP)
  • void LocationFinal (UInt16 iLibRefNum, LocationType *thisP)
  • UInt16 LocationGetSize (UInt16 iLibRefNum, const LocationType *thisP)
  • void LocationInit (UInt16 iLibRefNum, LocationType *thisP)
  • Boolean LocationIsDSTPast (UInt16 iLibRefNum, DSTType *iDstDateP)
  • Err LocationMakeGeneric (UInt16 iLibRefNum, LocationType *thisP, CountryType iCountryCode, Int16 iUTC)
  • void LocationSetName (UInt16 iLibRefNum, LocationType *thisP, const Char *iNameP)
  • Err LocDBChangeRecord (UInt16 iLibRefNum, DmOpenRef dbP, UInt16 *ioRecordIndexP, const LocationType *iLocationP)
  • Int16 LocDBCompareRecordsSimple (UInt16 iLibRefNum, LocDBRecordType **iRecord01P, LocDBRecordType **iRecord02P, Int32 iFlags)
  • void LocDBConvertRecord (UInt16 iLibRefNum, LocationType *ioLocationP, const LocDBRecordType *iRecordP)
  • void LocDBCopyLocation (UInt16 iLibRefNum, LocDBRecordType *ioRecordP, const LocationType *iLocationP)
  • Err LocDBDeleteRecord (UInt16 iLibRefNum, DmOpenRef dbP, UInt16 iRecordIndex)
  • LocDBRecordType * LocDBFindCustomRecord (UInt16 iLibRefNum, DmOpenRef iDbP, UInt16 *ioRecordIndex, MemHandle *oRecordH)
  • Err LocDBFindFirst (UInt16 iLibRefNum, DmOpenRef dbP, UInt16 *oRecordIndexP, LocDBRecordType *iMatchValueP)
  • Err LocDBFindFirstByName (UInt16 iLibRefNum, DmOpenRef dbP, UInt16 *oRecordIndexP, const Char *iNameP)
  • Err LocDBFindFirstByUTCCountry (UInt16 iLibRefNum, DmOpenRef dbP, UInt16 *oRecordIndexP, CountryType iCountry, Int16 iUTC)
  • UInt16 LocDBFindFirstInList (UInt16 iLibRefNum, UInt16 iLocsListItemsCount, LocDBRecordType **iLocsListP, const LocationType *iMatchLocationP)
  • MemHandle LocDBGetCustomList (UInt16 iLibRefNum, DmOpenRef iDbP, UInt16 *oListCount)
  • LocDBRecordType ** LocDBGetRecordList (UInt16 iLibRefNum, DmOpenRef iDbP, UInt16 *oListCount, CmpFuncPtr iCompareF, Int32 iCompareFlags)
  • LocDBRecordType * LocDBGetRecord (UInt16 iLibRefNum, DmOpenRef dbP, UInt16 iRecordIndex, MemHandle *oRecordHP)
  • Err LocDBInitDBs (UInt16 iLibRefNum, DmOpenRef *oDefDbPP, DmOpenRef *oCusDbPP)
  • Err LocDBNewRecord (UInt16 iLibRefNum, DmOpenRef dbP, UInt16 *oRecordIndexP, const LocationType *iLocationP)
  • LocalID LocDBOpenCustom (UInt16 iLibRefNum, const LocDBInfoType *iDbInfoP, UInt16 iOpenMode, DmOpenRef *oDbPP, const DmOpenRef iDefDbP)
  • LocalID LocDBOpenDefault (UInt16 iLibRefNum, DmOpenRef *oDbPP)
  • UInt16 LocDBRecordSize (UInt16 iLibRefNum, const LocDBRecordType *iLocRecordP)
  • Err LocDBSetRecordCustom (UInt16 iLibRefNum, LocDBRecordType *ioLocRecordP, UInt8 iValue)
  • Err LocDBSort (UInt16 iLibRefNum, DmOpenRef iDbP, LocDBSortOrderType iSortOrder)
  • void LocsLibDSTAlarmClear (UInt16 iLibRefNum)
  • Boolean LocsLibDSTAlarmIsDST (UInt16 iLibRefNum, const DSTType *iDSTStartP, const DSTType *iDSTEndP, UInt32 iTimeInSecs)
  • UInt32 LocsLibDSTAlarmSet (UInt16 iLibRefNum, const DSTType *iDstStartP, const DSTType *iDstEndP)
  • Err LocDBNewRecordV20 (UInt16 iLibRefNum, DmOpenRef dbP, UInt16 *oRecordIndexP, LocationType *iLocationP)
  • LocationType * LocDBGetRecordV20 (UInt16 iLibRefNum, DmOpenRef dbP, UInt16 iRecordIndex, MemHandle *oRecordHP)
  • void LocDBConvertRecordV20 (UInt16 iLibRefNum, LocationType *destRecordP, const LocationType *srcRecordP)
  • Err LocDBChangeRecordV20 (UInt16 iLibRefNum, DmOpenRef dbP, UInt16 *ioRecordIndexP, LocationType *iLocationP)
  • LocationType ** LocDBGetRecordListV20 (UInt16 iLibRefNum, DmOpenRef iDbP, UInt16 *oListCount, CmpFuncPtr iCompareF, Int32 iCompareFlags)
  • Err LocDBGetNearestLocation (UInt16 iLibRefNum, DmOpenRef iDb1P, DmOpenRef iDb2P, PosType *iPosP, LocationType *oLocP)
  • void LocationInitV20 (UInt16 iLibRefNum, LocationType *thisP)
  • void LocationFinalV20 (UInt16 iLibRefNum, LocationType *thisP)
  • Err LocDBGetVersion (UInt16 iLibRefNum, UInt16 cardNo, const Char *dbNameP, UInt16 *version)
  • void LocationSetNote (UInt16 iLibRefNum, LocationType *thisP, const Char *iNameP)
  • void LocationSetPosition (UInt16 iLibRefNum, LocationType *thisP, const PosType *iPosP)
  • Boolean LocsLibLocationNote (UInt16 iLibRefNum, const Char *iNameP, Boolean noteStatus)
  • UInt16 LocationGetSizeV20 (UInt16 iLibRefNum, LocationType *locationP)
  • void LocationCopyV20 (UInt16 iLibRefNum, LocationType *thisP, const LocationType *iLocToCopyP)
  • LocationType * LocDBFindCustomRecordV20 (UInt16 iLibRefNum, DmOpenRef iDbP, UInt16 *ioRecordIndex, MemHandle *oRecordH)

Function Documentation

void LocationCopy | ( | UInt16 | iLibRefNum,
 |  | LocationType * | thisP,
 |  | const LocationType * | iLocToCopyP
 | ) |

Copy from one location data into another

Parameters:
iLibRefNum,: IN: Library reference number
thisP,: IN: Pointer to the location object to copy to
iLocToCopyP IN: Pointer to the location to be copied

void LocationCopyV20 | ( | UInt16 | iLibRefNum,
 |  | LocationType * | thisP,
 |  | const LocationType * | iLocToCopyP
 | ) |

Copy from one location data into another

Parameters:
iLibRefNum,: IN: Library reference number
thisP,: IN: Pointer to the location object to copy to
iLocToCopyP IN: Pointer to the location to be copied

void LocationFinal | ( | UInt16 | iLibRefNum,
 |  | LocationType * | thisP
 | ) |

Destructor for location objects

Parameters:
iLibRefNum,: IN: Library reference number
thisP,: IN: Pointer to the location object to destroy

void LocationFinalV20 | ( | UInt16 | iLibRefNum,
 |  | LocationType * | thisP
 | ) |

Destructor for location objects v 2.0 (support for note)

Parameters:
iLibRefNum,: IN: Library reference number
thisP,: IN: Pointer to the location object to destroy

UInt16 LocationGetSize | ( | UInt16 | iLibRefNum,
 |  | const LocationType * | thisP
 | ) |

Calculate the size in bytes of the location object with the name field size included, but without the size of the pointer to the name field.

Parameters:
iLibRefNum,: IN: Library reference number
thisP,: IN: Pointer to the location object to size
Returns:
Size in bytes

UInt16 LocationGetSizeV20 | ( | UInt16 | iLibRefNum,
 |  | LocationType * | locationP
 | ) |

Calculate the size in bytes of the location object with the name and note field size included, but without the size of the pointer to the name and note field.

Parameters:
iLibRefNum,: IN: Library reference number
locationP,: IN: Pointer to the location object to size
Returns:
Size in bytes

void LocationInit | ( | UInt16 | iLibRefNum,
 |  | LocationType * | thisP
 | ) |

Constructor for location objects; initialize the given location data structure.

Parameters:
iLibRefNum,: IN: Library reference number
thisP,: IN: Pointer to the location object to initialize

void LocationInitV20 | ( | UInt16 | iLibRefNum,
 |  | LocationType * | thisP
 | ) |

Constructor for location objects v 2.0 (support for note); initialize the given location data structure.

Parameters:
iLibRefNum,: IN: Library reference number
thisP,: IN: Pointer to the location object to initialize

Boolean LocationIsDSTPast | ( | UInt16 | iLibRefNum,
 |  | DSTType * | iDstDateP
 | ) |

Determine if a given DST date is in the past relative to the current time

Parameters:
iLibRefNum,: IN: Library reference number
iDstDateP,: IN: Pointer to a DST date to use for determining if that date is in the past relative to the current time.
Returns:
True if given DST date is in the past.

Err LocationMakeGeneric | ( | UInt16 | iLibRefNum,
 |  | LocationType * | thisP,
 |  | CountryType | iCountryCode,
 |  | Int16 | iUTC
 | ) |

Create a generic location using the given country and UTC values.

Parameters:
iLibRefNum,: IN: Library reference number
thisP,: IN: Pointer to the location object to initialize with generic location data
iCountryCode,: IN: Country code for generic location
iUTC,: IN: UTC (timezone is minutes east west of prime meridian) for generic location; also used to create the location name.
Returns:
errNone if success.

void LocationSetName | ( | UInt16 | iLibRefNum,
 |  | LocationType * | thisP,
 |  | const Char * | iNameP
 | ) |

Mutator for changing location name value

Parameters:
iLibRefNum,: IN: Library reference number
thisP,: IN: Pointer to the location object to change
iNameP,: IN: Pointer to the new name

void LocationSetNote | ( | UInt16 | iLibRefNum,
 |  | LocationType * | thisP,
 |  | const Char * | iNameP
 | ) |

Copy note to location note field

Parameters:
iLibRefNum,: IN: Library reference number
thisP,: IN: Pointer to the location object to change.
iNoteP,: IN: Pointer to the new note.

void LocationSetPosition | ( | UInt16 | iLibRefNum,
 |  | LocationType * | thisP,
 |  | const PosType * | iPosP
 | ) |

Initialize position values of location

Parameters:
iLibRefNum,: IN: Library reference number
thisP,: IN: Pointer to the city object to initialize.
iPosP,: IN: Pointer to PosType to set values of location

Err LocDBChangeRecord | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | dbP,
 |  | UInt16 * | ioRecordIndexP,
 |  | const LocationType * | iLocationP
 | ) |

Modify a record and re-sort the db if needed.

Parameters:
iLibRefNum,: IN: Library reference number
dbP,: IN: Pointer to the given location database to be modified.
ioRecordIndexP,: I/O: Pointer to the record index of the location record to be modified. If the record is moved, this value is updated with the new index.
iLocationP,: IN: Pointer to the new location data that is used to update the record.
Returns:
errNone if success.

Err LocDBChangeRecordV20 | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | dbP,
 |  | UInt16 * | ioRecordIndexP,
 |  | LocationType * | iLocationP
 | ) |

Modify a record and re-sort the db if needed.

Parameters:
iLibRefNum,: IN: Library reference number
dbP,: IN: Pointer to the given location database to be modified.
ioRecordIndexP,: I/O: Pointer to the record index of the location record to be modified. If the record is moved, this value is updated with the new index.
iLocationP,: IN: Pointer to the new location data that is used to update the record.
Returns:
errNone if success.

Int16 LocDBCompareRecordsSimple | ( | UInt16 | iLibRefNum,
 |  | LocDBRecordType ** | iRecord01P,
 |  | LocDBRecordType ** | iRecord02P,
 |  | Int32 | iFlags
 | ) |

Comparison function to be used with system sort routines.

Note: the system sort functions, like SysQSort, treat the elements of the passed list as is; i.e.: instead of passing the elements to this function, pointers to the elements are passed. Thus, it is necessary to here to use double pointers and dereferencing to to compare the actual records.

Parameters:
iLibRefNum,: IN: Library reference number
iRecord01P,: IN: Pointer to the first location record.
iRecord02P,: IN: Pointer to the second location record.
iFlags IN: Sort order.
Returns:
-n if 1st is lesser, +n if 2nd is lesser, 0 if the two are the same, except for DST data, which isn't compared.

void LocDBConvertRecord | ( | UInt16 | iLibRefNum,
 |  | LocationType * | ioLocationP,
 |  | const LocDBRecordType * | iRecordP
 | ) |

This function will format and copy locked record (LocationType) data into another locationType

Parameters:
iLibRefNum,: IN: library reference number
ioLocationP,: I/O: Pointer to the location object that is filled with the converted record data.
iRecordP,: IN: Pointer to the record whose data is converted to the location object format.

void LocDBConvertRecordV20 | ( | UInt16 | iLibRefNum,
 |  | LocationType * | destRecordP,
 |  | const LocationType * | srcRecordP
 | ) |

This function will format and copy locked record (LocationType) data into another locationType

Parameters:
iLibRefNum,: IN: library reference number
destRecordP,: IN: Pointer to the location object that is filled with the converted record data.
srcRecordP,: IN: Pointer to the record whose data is converted to the location object format.

void LocDBCopyLocation | ( | UInt16 | iLibRefNum,
 |  | LocDBRecordType * | ioRecordP,
 |  | const LocationType * | iLocationP
 | ) |

Copy the data in a given location object into a given location db record format. Note: the caller must allocate enough memory to the record object to hold the location data!

Parameters:
iLibRefNum,: IN: Library reference number
ioRecordP,: I/O: Pointer to a record that is filled with the location object data.
iLocationP,: IN: Pointer to the location object whose data is copied to the record.

Err LocDBDeleteRecord | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | dbP,
 |  | UInt16 | iRecordIndex
 | ) |

Deletes a record from the cities database.

Parameters:
iLibRefNum,: IN: Library reference number
dbP,: IN: Pointer to the database containing the record to delete.
iRecordIndex,: IN: Index of the record to delete.
Returns:
errNone if success.

LocDBRecordType* LocDBFindCustomRecord | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | iDbP,
 |  | UInt16 * | ioRecordIndex,
 |  | MemHandle * | oRecordH
 | ) |

Finds a record having the custom bit set.

Parameters:
iLibRefNum,: IN: Library reference number
iDbP,: IN: Pointer to a locations record database.
ioRecordIndex,: I/O: Index of the record to begin searching from, and index of the found record.
oRecordH,: OUT: Pointer to the record handle; set by this function.
Returns:
Pointer to the record found or NULL. Caller is responsible for freeing record when done.

LocationType* LocDBFindCustomRecordV20 | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | iDbP,
 |  | UInt16 * | ioRecordIndex,
 |  | MemHandle * | oRecordH
 | ) |

Finds a record having the custom bit set.

Parameters:
iLibRefNum,: IN: Library reference number
iDbP,: IN: Pointer to a locations record database.
ioRecordIndex,: I/O: Index of the record to begin searching from, and index of the found record.
oRecordH,: OUT: Pointer to the record handle; set by this function.
Returns:
Pointer to the record found or NULL. Caller is responsible for freeing record when done.

Err LocDBFindFirst | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | dbP,
 |  | UInt16 * | oRecordIndexP,
 |  | LocDBRecordType * | iMatchValueP
 | ) |

Returns the record index for the first record matching the given location data.

Parameters:
iLibRefNum,: IN: Library reference number
dbP,: IN: Pointer to the given cities database to search for a match.
oRecordIndexP,: OUT: Pointer to record index var to store the record index of the matching record found in the search. Set to dmMaxRecordIndex if no match is found.
iMatchLocationP,: IN: Pointer to the location data for which to find the first matching record in the given database.
Returns:
Error code for a failure, or errNone if success. If no match is found, the index value is set to the value dmMaxRecordIndex.

Err LocDBFindFirstByName | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | dbP,
 |  | UInt16 * | oRecordIndexP,
 |  | const Char * | iNameP
 | ) |

Sequential search of the locations database records for a match to the given city name.

Parameters:
iLibRefNum,: IN: Library reference number
dbP,: IN: Pointer to the record db to search.
oRecordIndexP,: OUT: Pointer to an index var to set with the index of the matching record, or dmMaxRecordIndex if no match.
iNameP,: IN: Pointer to the name string for which to find a match.
Returns:
errNone if no problems. No match indicated by oRecordIndexP set to dmMaxRecordIndex.

Err LocDBFindFirstByUTCCountry | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | dbP,
 |  | UInt16 * | oRecordIndexP,
 |  | CountryType | iCountry,
 |  | Int16 | iUTC
 | ) |

Sequential search of the locations database records for the first location matching the given country and UTC values.

Parameters:
iLibRefNum,: IN: Library reference number
dbP,: IN: Pointer to the record db to search.
oRecordIndexP,: OUT: Pointer to an index var to set with the index of the matching record, or dmMaxRecordIndex if no match.
iCountry,: IN: The country code for which to find a match.
iUTC,: IN: The UTC for which to find a match.
Returns:
errNone if no problems. No match indicated by oRecordIndexP set to dmMaxRecordIndex.

UInt16 LocDBFindFirstInList | ( | UInt16 | iLibRefNum,
 |  | UInt16 | iLocsListItemsCount,
 |  | LocDBRecordType ** | iLocsListP,
 |  | const LocationType * | iMatchLocationP
 | ) |

Returns the record index for the first record in the given list matching the given location data.

Note: This complements the get list functions, which return a list of pointers to location records in a db.

Parameters:
iLibRefNum,: IN: Library reference number
iLocsListItemsCount,: IN: Number of record items in the list.
iLocsListP,: IN: Pointer to the list of location records.
iMatchLocationP,: IN: Pointer to the location data for which to find the first matching record in the given list.
Returns:
The index of the list item matching the given location, or if no match found, then dmMaxRecordIndex.

MemHandle LocDBGetCustomList | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | iDbP,
 |  | UInt16 * | oListCount
 | ) |

Returns a handle to a list of pointers to location records having the custom bit set. It is the responsibility of the caller to free the memory for the returned list.

Parameters:
iLibRefNum,: IN: Library reference number
iDbP,: IN: Pointer to a locations record database.
oListCount,: OUT: Number of records found with custom bit set.
Returns:
Handle to the list of location record pointers or NULL. Note: Caller is repsonsible for freeing memory associated with the list of pointers to records.

Err LocDBGetNearestLocation | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | iDb1P,
 |  | DmOpenRef | iDb2P,
 |  | PosType * | iPosP,
 |  | LocationType * | oLocP
 | ) |

Get a valid location from the locations DB nearest to the location specified

Parameters:
iLibRefNum,: IN: Library reference number
iDefDb,: IN: Reference to default location database
iCustDb,: IN: Reference to custom location database
iPosP,: IN: Pointer to reference position
oLocP,: OUT: Pointer to location, nearest city will return in this pointer
Returns:
Error if database not found.

LocDBRecordType* LocDBGetRecord | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | dbP,
 |  | UInt16 | iRecordIndex,
 |  | MemHandle * | oRecordHP
 | ) |

Returns a pointer to a locked record chunk in the given db. It is the responsibility of the caller to unlock and release the record when done using the record. It is must to call LocDBCovertRecordV20 to get formated data in another LocationType variable.

Parameters:
iLibRefNum,: IN: library reference number
dbP,: IN: Pointer to a database having the desired record.
iRecordIndex,: IN: Index of the record in the given db.
oRecordHP,: OUT: Pointer to the record handle; set by this function.
Returns:
Pointer to the locked record or NULL; if non-NULL, caller is responsible for unlocking and releasing the record.

LocDBRecordType** LocDBGetRecordList | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | iDbP,
 |  | UInt16 * | oListCount,
 |  | CmpFuncPtr | iCompareF,
 |  | Int32 | iCompareFlags
 | ) |

Get an array of pointers to those records from the the given database.

Parameters:
iLibRefNum,: IN: Library reference number
iDbP,: IN: Pointer to an open locations database.
oListCount,: OUT: Pointer to the list count to be set with the number of items in the locations list.
iCompareF,: IN: Function pointer for the function to use when sorting the list. Pass NULL if the list should not be sorted.
iCompareFlags,: IN: Any flags for comparison/sort behavior.
Returns:
Pointer to the array of location data, or NULL. Note: Caller is responsible for freeing this memory.

LocationType** LocDBGetRecordListV20 | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | iDbP,
 |  | UInt16 * | oListCount,
 |  | CmpFuncPtr | iCompareF,
 |  | Int32 | iCompareFlags
 | ) |

Get an array of pointers to those records from the the given database.

Parameters:
iLibRefNum,: IN: Library reference number
iDbP,: IN: Pointer to an open locations database.
oListCount,: OUT: Pointer to the list count to be set with the number of items in the locations list.
iCompareF,: IN: Function pointer for the function to use when sorting the list. Pass NULL if the list should not be sorted.
iCompareFlags,: IN: Any flags for comparison/sort behavior.
Returns:
Pointer to the array of location data, or NULL. Note: Caller is responsible for freeing this memory.

LocationType* LocDBGetRecordV20 | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | dbP,
 |  | UInt16 | iRecordIndex,
 |  | MemHandle * | oRecordHP
 | ) |

Returns a pointer to a locked record chunk in the given db. It is the responsibility of the caller to unlock and release the record when done using the record. It is must to call LocDBCovertRecordV20 to get formated data in another LocationType variable.

Parameters:
iLibRefNum,: IN: library reference number
dbP,: IN: Pointer to a database having the desired record.
iRecordIndex,: IN: Index of the record in the given db.
oRecordHP,: OUT: Pointer to the record handle; set by this function.
Returns:
Pointer to the locked record or NULL; if non-NULL, caller is responsible for unlocking and releasing the record.

Err LocDBGetVersion | ( | UInt16 | iLibRefNum,
 |  | UInt16 | cardNo,
 |  | const Char * | dbNameP,
 |  | UInt16 * | version
 | ) |

Get version of database

Parameters:
iLibRefNum,: IN: Library reference number
cardNo,: IN: cardNo for database
dbNameP,: IN: Pointer to database name to search
versionP,: OUT: Pointer to version, version no will return in this variable
Returns:
Error if database not found.

Err LocDBInitDBs | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef * | oDefDbPP,
 |  | DmOpenRef * | oCusDbPP
 | ) |

Open the default db and open and initialize the custom db.

Parameters:
iLibRefNum,: IN: library reference number
oDefDbPP,: OUT: Pointer to the default db pointer to initialize.
oCusDbPP,: OUT: Pointer to the custom db pointer to initialize.
Returns:
On success the default and custom db pointers are initialized.

Err LocDBNewRecord | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | dbP,
 |  | UInt16 * | oRecordIndexP,
 |  | const LocationType * | iLocationP
 | ) |

Generates a new record for the given database.

Parameters:
iLibRefNum,: IN: library reference number
dbP,: IN: Pointer to the given location database into which the location data is to be inserted as a new record.
oRecordIndexP,: OUT: Pointer to the given record index value to be initialized with the new location record's index.
iLocationP,: IN: Pointer to the given location data from which to generate the new location record.
Returns:
errNone if success.

Err LocDBNewRecordV20 | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | dbP,
 |  | UInt16 * | oRecordIndexP,
 |  | LocationType * | iLocationP
 | ) |

Generates a new record for the given database.

Parameters:
iLibRefNum,: IN: library reference number
dbP,: IN: Pointer to the given location database into which the location data is to be inserted as a new record.
oRecordIndexP,: OUT: Pointer to the given record index value to be initialized with the new location record's index.
iLocationP,: IN: Pointer to the given location data from which to generate the new location record.
Returns:
errNone if success.

LocalID LocDBOpenCustom | ( | UInt16 | iLibRefNum,
 |  | const LocDBInfoType * | iDbInfoP,
 |  | UInt16 | iOpenMode,
 |  | DmOpenRef * | oDbPP,
 |  | const DmOpenRef | iDefDbP
 | ) |

Open the custom db and return the dbID and an initialized db pointer.

Parameters:
iLibRefNum,: IN: library reference number
iDbInfoP,: IN: Pointer to a database info struct having db name, crid, type, and card number.
iOpenMode,: IN: Read and write mode to open the database for.
oDbPP,: OUT: Pointer to a db reference that is set by this function.
iDefDbP,: IN: Pointer to the default db from which to init the custom db if necessary. Initialization occurs if the custom db must be created, and then any records marked as custom in the given default db are copied into the custom db.
Returns:
Zero (0) on failure the dbP is set to NULL; the database ID is returned on success and the dbP is set to the address of the database.

LocalID LocDBOpenDefault | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef * | oDbPP
 | ) |

Open the default db and return the dbID and an initialized db pointer.

Parameters:
iLibRefNum,: IN: library reference number
oDbPP,: OUT: Pointer to a db reference that is set by this function.
Returns:
Error code (errNone if successful). Zero (0) on failure and the dbP is set to NULL; occurs if the default db isn't found and the install from ROM fails. The database ID is returned on success and the dbP is set to the address of the database.

UInt16 LocDBRecordSize | ( | UInt16 | iLibRefNum,
 |  | const LocDBRecordType * | iLocRecordP
 | ) |

Determines the size in bytes of a record.

Parameters:
iLibRefNum,: IN: library reference number
iLocRecordP,: IN: Pointer to the record for which to determine the size.
Returns:
Size of the given record in bytes.

Err LocDBSetRecordCustom | ( | UInt16 | iLibRefNum,
 |  | LocDBRecordType * | ioLocRecordP,
 |  | UInt8 | iValue
 | ) |

Set the custom field of the record.

Parameters:
iLibRefNum,: IN: library reference number
ioLocRecordP,: I/O: Pointer to the record for which to set the custom field.
iValue,: IN: Value to which the custom field is set.
Returns:
errNone if success.

Err LocDBSort | ( | UInt16 | iLibRefNum,
 |  | DmOpenRef | iDbP,
 |  | LocDBSortOrderType | iSortOrder
 | ) |

Sorts the given location data database.

Parameters:
iLibRefNum,: IN: library reference number
iDbP,: IN: Pointer to the location db to sort.
iSortOrder,: IN: Sort order desired.
Returns:
errNone if success.

Err LocsLibClose ( UInt16 iLibRefNum )

Standard library close routine.

Parameters:
iLibRefNum,: IN: Library reference number.
Returns:
Error code.

void LocsLibDSTAlarmClear ( UInt16 iLibRefNum )

Clear an existing DST alert alarm from the system.

Parameters:
iLibRefNum,: IN: library reference number

Boolean LocsLibDSTAlarmIsDST | ( | UInt16 | iLibRefNum,
 |  | const DSTType * | iDSTStartP,
 |  | const DSTType * | iDSTEndP,
 |  | UInt32 | iTimeInSecs
 | ) |

Check if the current time is within a daylight saving time range.

Parameters:
iLibRefNum,: IN: library reference number
iDSTStartP,: IN: Pointer to the start DST date.
iDSTEndP,: IN: Pointer to the end DST date.
iTimeInSecs,: IN: The time in seconds against which to check the given DST date range.
Returns:
True if in the DST range.

UInt32 LocsLibDSTAlarmSet | ( | UInt16 | iLibRefNum,
 |  | const DSTType * | iDstStartP,
 |  | const DSTType * | iDstEndP
 | ) |

Set the DST alert alarm to the given DST date.

Parameters:
iLibRefNum,: IN: library reference number
iDstP,: IN: Pointer to the DST date data.
Returns:
Time in seconds for which the DST alert was set, or 0 if not set (e.g.: if the given DST date data indicates DST is not observed).

Err LocsLibGetVersion | ( | UInt16 | iLibRefNum,
 |  | UInt32 | iSDKVersion,
 |  | UInt32 * | oVersionP
 | ) |

Get the version of the library on the device.

Parameters:
iLibRefNum,: IN: Library reference number.
iSDKVersion,: IN: Currently used library version in the SDK
oVersionP,: OUT: Version of the library on the device.
Returns:
Error code.

Boolean LocsLibLaunchEditListDialogue | ( | UInt16 | iLibRefNum,
 |  | LocsLibSelLocsType * | ioSelLocsP
 | ) |

Runs the event loop for handling the Locations dialogues. Note: the preSelect, noEditOnSelect, and sendChangeNotify values of the caller data block don't apply for this API.

Parameters:
iLibRefNum,: IN: Library reference number.
ioSelLocsP,: I/O: Pointer to a selected locations object that contains data on selected locations. e.g.: The Clock 2.0 app displays several selected locations and the associated times. If any of those locations are removed or renamed, the Clock 2.0 app needs to know so it can update the display. This object is updated if any of the selected locations are renamed or removed. Use the dirty bits to determine quickly if any data were changed and if so, which. Pass NULL to ignore.
Returns:
True if changes are made.

Boolean LocsLibLaunchSelDialogue | ( | UInt16 | iLibRefNum,
 |  | LocsLibSelLocsType * | ioSelLocsP
 | ) |

Run the location selection dialogue, and then the Edit Location dialogue if the user tapped [OK] in the location selection dialogue and if the caller didn't specify to skip that dialogue.

Parameters:
iLibRefNum,: IN: Library reference number.
ioSelLocsP,: I/O: Pointer to a selected locations object that contains data on selected locations. e.g.: The Clock 2.0 app displays several selected locations and the associated times. If any of those locations are removed or renamed, the Clock 2.0 app needs to know so it can update the display. This object is updated if any of the selected locations are renamed or removed. Use the dirty bits to determine quickly if any data were changed and if so, which. Must not be NULL.
Returns:
True if changes are made.

Err LocsLibOpen ( UInt16 iLibRefNum )

Standard library open routine.

Parameters:
iLibRefNum,: IN: Library reference number.
Returns:
Error code.

Err LocsLibSleep ( UInt16 iLibRefNum )

Standard library sleep routine.

Parameters:
iLibRefNum,: IN: Library reference number.
Returns:
Error code.

Err LocsLibWake ( UInt16 iLibRefNum )

Standard library wake routine.

Parameters:
iLibRefNum,: IN: Library reference number.
Returns:
Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:56 2006 for Palm API Guide


LocsLibCommon.h File Reference

Detailed Description

Public 68K common header file for locations library.

This file contains the library constants and error codes used in the APIs.

Include dependency graph for LocsLibCommon.h:

Data Structures

  • struct DSTDataTag
  • struct Coordinate
  • struct PosType
  • struct LocationDataTag
  • struct LocDBInfoTag
  • struct LocDBRecordTag
  • struct LocsLibNotifyLocsDataTag
  • struct LocsLibNotifyDataTag
  • struct LocsLibSelLocsTag

Library Versions

  • #define kLocsLibVersion01 sysMakeROMVersion (1, 0, 0, sysROMStageDevelopment, 1)
  • #define kLocsLibVersion0121 sysMakeROMVersion (1, 2, 1, sysROMStageDevelopment, 1)
  • #define kLocsLibVersion013 sysMakeROMVersion (1, 3, 0, sysROMStageDevelopment, 1)
  • #define kLocsLibVersionCurrent kLocsLibVersion013

Error Codes

  • #define locLErrorClass (appErrorClass | 0x0100)
  • #define locLErrNone 0
  • #define locLErrCantFindLocsDB (locLErrorClass | 1)
  • #define locLErrBadParam (locLErrorClass | 2)
  • #define locLErrBadRefNum (locLErrorClass | 3)
  • #define locLErrNoGlobals (locLErrorClass | 4)
  • #define locLErrNoMemForGlobals (locLErrorClass | 5)
  • #define locLErrNoLibSysReference (locLErrorClass | 6)
  • #define locLErrCantOpenLibRsc (locLErrorClass | 7)
  • #define locLErrMemAllocFail (locLErrorClass | 8)
  • #define locLErrBadVersion (locLErrorClass | 9)
  • #define locLErrNotOpen (locLErrorClass | 10)
  • #define locLErrStillOpen (locLErrorClass | 11)

Notifications

  • #define kLocsLibNotifyLocChangeEvent kLocsFileCLocsLib
  • #define kLocsLibNotifyLocEditEvent kLocsLibNotifyLocChangeEvent + 1
  • #define kLocsLibNotifyLocDeleteEvent kLocsLibNotifyLocChangeEvent + 2
  • #define kLocsLibNotifyLocAddEvent kLocsLibNotifyLocChangeEvent + 3

Bit Masks

  • #define kLocsLibSel01 0x00000001
  • #define kLocsLibSel02 0x00000002
  • #define kLocsLibSel03 0x00000004
  • #define kLocsLibSel04 0x00000008
  • #define kLocsLibSel05 0x00000010
  • #define kLocsLibSel06 0x00000020
  • #define kLocsLibSel07 0x00000040
  • #define kLocsLibSel08 0x00000080
  • #define kLocsLibSel09 0x00000100
  • #define kLocsLibSelMax 0x80000000

Database Names and Types

  • #define kLocFileCDatabase (UInt32)('locL')
  • #define kLocFileTDefLocDB (UInt32)('DATA')
  • #define kLocFileTCusLocDB (UInt32)('DATC')
  • #define kLocFileNDefaultDB "locLDefLocationDB"
  • #define kLocFileNCustomDB "locLCusLocationDB"

DST Alarm Constants

  • #define kLocsLibDSTAlert (UInt32)(1)
  • #define kLocsLibDSTStartAlert (UInt32)(2)
  • #define kLocsLibDSTEndAlert (UInt32)(3)

Accessor Macros

  • #define LocationGetUTC(locationP) (locationP)->uTC
  • #define LocationGetDSTStart(locationP) &((locationP)->dSTStart)
  • #define LocationGetDSTEnd(locationP) &((locationP)->dSTEnd)
  • #define LocationGetDSTAdj(locationP) (locationP)->dSTAdjustmentInMinutes
  • #define LocationGetCountry(locationP) (locationP)->country
  • #define LocationGetCustom(locationP) (locationP)->custom
  • #define LocationGetReserved(locationP) (locationP)->reserved
  • #define LocationGetName(locationP) (locationP)->name

Helper Macros

  • #define LocDBCompareUTC(iUTC01, iUTC02) (iUTC01 - iUTC02)
  • #define LocDBCompareCountries(iCountry01, iCountry02) (iCountry01 - iCountry02)
  • #define LocDBCompareNames(iName01, iName02) (StrCompare (iName01, iName02))
  • #define LocDBGetUTC(locRecP) (locRecP)->uTC
  • #define LocDBGetCountry(locRecP) (locRecP)->country

Function Traps

  • #define locsLibTrapGetVersion (sysLibTrapCustom + 0)
  • #define locsLibTrapLaunchEditListDlg (sysLibTrapCustom + 1)
  • #define locsLibTrapLaunchSelDialogue (sysLibTrapCustom + 2)
  • #define locsLibTrapLocCopy (sysLibTrapCustom + 3)
  • #define locsLibTrapLocFinal (sysLibTrapCustom + 4)
  • #define locsLibTrapLocGetSize (sysLibTrapCustom + 5)
  • #define locsLibTrapLocInit (sysLibTrapCustom + 6)
  • #define locsLibTrapLocIsDSTPast (sysLibTrapCustom + 7)
  • #define locsLibTrapLocMakeGeneric (sysLibTrapCustom + 8)
  • #define locsLibTrapLocSetName (sysLibTrapCustom + 9)
  • #define locsLibTrapDBChangeRecord (sysLibTrapCustom + 10)
  • #define locsLibTrapDBCmpRecordsSimple (sysLibTrapCustom + 11)
  • #define locsLibTrapDBConvertRecord (sysLibTrapCustom + 12)
  • #define locsLibTrapDBCopyLocation (sysLibTrapCustom + 13)
  • #define locsLibTrapDBDeleteRecord (sysLibTrapCustom + 14)
  • #define locsLibTrapDBFindCustomRecord (sysLibTrapCustom + 15)
  • #define locsLibTrapDBFindFirst (sysLibTrapCustom + 16)
  • #define locsLibTrapDBFindFirstByName (sysLibTrapCustom + 17)
  • #define locsLibTrapDBFindFirstByUTCCtry (sysLibTrapCustom + 18)
  • #define locsLibTrapDBFindFirstInList (sysLibTrapCustom + 19)
  • #define locsLibTrapDBGetCustomList (sysLibTrapCustom + 20)
  • #define locsLibTrapDBGetRecordList (sysLibTrapCustom + 21)
  • #define locsLibTrapDBGetRecord (sysLibTrapCustom + 22)
  • #define locsLibTrapDBInitDBs (sysLibTrapCustom + 23)
  • #define locsLibTrapDBNewRecord (sysLibTrapCustom + 24)
  • #define locsLibTrapDBOpenCustom (sysLibTrapCustom + 25)
  • #define locsLibTrapDBOpenDefault (sysLibTrapCustom + 26)
  • #define locsLibTrapDBRecordSize (sysLibTrapCustom + 27)
  • #define locsLibTrapDBSetRecordCustom (sysLibTrapCustom + 28)
  • #define locsLibTrapDBSort (sysLibTrapCustom + 29)
  • #define locsLibTrapDSTAlarmClear (sysLibTrapCustom + 30)
  • #define locsLibTrapDSTAlarmIsDST (sysLibTrapCustom + 31)
  • #define locsLibTrapDSTAlarmSet (sysLibTrapCustom + 32)
  • #define locsLibTrapLocDBNewRecordV20 (sysLibTrapCustom + 33)
  • #define locsLibTrapLocDBGetRecordV20 (sysLibTrapCustom + 34)
  • #define locsLibTrapLocDBConvertRecordV20 (sysLibTrapCustom + 35)
  • #define locsLibTrapLocDBChangeRecordV20 (sysLibTrapCustom + 36)
  • #define locsLibTrapLocDBGetRecordListV20 (sysLibTrapCustom + 37)
  • #define locsLibTrapLocDBGetNearestLocation (sysLibTrapCustom + 38)
  • #define locsLibTrapLocationInitV20 (sysLibTrapCustom + 39)
  • #define locsLibTrapLocationFinalV20 (sysLibTrapCustom + 40)
  • #define locsLibTrapLocDBGetVersion (sysLibTrapCustom + 41)
  • #define locsLibTrapLocationSetNote (sysLibTrapCustom + 42)
  • #define locsLibTrapLocationSetPosition (sysLibTrapCustom + 43)
  • #define locsLibTrapLocsLibLocationNote (sysLibTrapCustom + 44)
  • #define locsLibTrapLocationGetSizeV20 (sysLibTrapCustom + 45)
  • #define locsLibTrapLocationCopyV20 (sysLibTrapCustom + 46)
  • #define locsLibTrapLocDBFindCustomRecordV20 (sysLibTrapCustom + 47)

Defines

  • #define kLocsLibName "LocsLib-locL"
  • #define kLocsFileCLocsLib (UInt32)('locL')
  • #define kLocsLibFtrNumRefNum (UInt16)(1)
  • #define kLocNameMaxLength (UInt16)(100)
  • #define kLocNoteMaxLength (UInt16)(4096)
  • #define kLocNoDisplayInCustom (UInt8)(0)
  • #define kLocDisplayInCustom (UInt8)(1)
  • #define kUndefinedPosition (Int16)999
  • #define kLocsLibListUpdateClass 0x0400
  • #define kLocsLibListUpdate (UInt16)(kLocsLibListUpdateClass | 1)
  • #define kLocDBVersion (UInt16)(2)
  • #define kLocDBMaxLocNameLength kLocNameMaxLength
  • #define kLocDBTypeDefault (UInt8)(0)
  • #define kLocDBTypeCustom (UInt8)(1)
  • #define LocationSetUTC(locationP, newUTC) ((locationP)->uTC = newUTC)
  • #define LocationSetDSTStart(locationP, newDstStart) ((locationP)->dSTStart = newDstStart)
  • #define LocationSetDSTEnd(locationP, newDstEnd) ((locationP)->dSTEnd = newDstEnd)
  • #define LocationSetDSTAdj(locationP, newDstAdj) ((locationP)->dSTAdjustmentInMinutes = newDstAdj)
  • #define LocationSetCountry(locationP, newCountry) ((locationP)->country = newCountry)
  • #define LocationSetCustom(locationP, newCustom) ((locationP)->custom = newCustom)
  • #define LocationSetReserved(locationP, newReserved) ((locationP)->reserved = newReserved)
  • #define LocationAreDSTDatesEqual(iDST01P, iDST02P)

Typedefs

  • typedef UInt8 LocDBSortOrderType
  • typedef DSTDataTag DSTType
  • typedef LocationDataTag LocationType
  • typedef LocDBInfoTag LocDBInfoType
  • typedef LocDBRecordTag LocDBRecordType
  • typedef LocsLibNotifyLocsDataTag LocsLibNotifyLocsDataType
  • typedef LocsLibNotifyDataTag LocsLibNotifyDataType
  • typedef LocsLibSelLocsTag LocsLibSelLocsType

Enumerations

  • enum _LocDBSortOrderType {
    kSortByNameCountryTZ,
    kSortByCountryTZName,
    kSortByCountryCodeTZName
    }

Define Documentation

#define kLocDBMaxLocNameLength kLocNameMaxLength

Max # of bytes for a location name stored.

#define kLocDBTypeCustom (UInt8)(1)

the location database is custom

#define kLocDBTypeDefault (UInt8)(0)

the location database is the default one

#define kLocDBVersion (UInt16)(2)

Current version of the location DB format

#define kLocDisplayInCustom (UInt8)(1)

display location in custom database

#define kLocNoDisplayInCustom (UInt8)(0)

don't display location in custom database

#define kLocsFileCLocsLib (UInt32)('locL')

Library creator ID

#define kLocsLibFtrNumRefNum (UInt16)(1)

The feature number used to refer to the stored library reference number

#define kLocsLibName "LocsLib-locL"

Library name

#define kUndefinedPosition (Int16)999

flag: position of location in database in undefined

#define LocationAreDSTDatesEqual | ( | iDST01P,
 |  | iDST02P | )

Value:

(   (iDST01P)->hour    == (iDST02P)->hour    \
                    && (iDST01P)->dayOrd  == (iDST02P)->dayOrd  \
                    && (iDST01P)->weekOrd == (iDST02P)->weekOrd \
                    && (iDST01P)->month   == (iDST02P)->month)

Typedef Documentation

typedef struct DSTDataTag DSTType

< Daylight saving time (DST) data format

Enumeration Type Documentation

enum _LocDBSortOrderType

Location database sort constants

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:57 2006 for Palm API Guide


MmsHelperCommon.h File Reference

Detailed Description

Public 68k common header files to be used with Default Helper Library.

Version:
1.0
This file contains the type and structure parameters for the MMS Helper Service Class. Developers should register to this service using Default Helper library if it wants to handle MMS.

Data Structures

  • struct _HelperServiceMMSObjectType
  • struct _HelperServiceMMSDetailsType
    Helpers of this Service Class send an MMS message. More...

Defines

  • #define kHelperServiceClassIDMMS 'mms_'

Typedefs

  • typedef _HelperServiceMMSObjectType HelperServiceMMSObjectType
  • typedef _HelperServiceMMSDetailsType HelperServiceMMSDetailsType
    Helpers of this Service Class send an MMS message.

Define Documentation

#define kHelperServiceClassIDMMS 'mms_'

New helper class registered with PalmSource for sending by MMS

Typedef Documentation

typedef struct _HelperServiceMMSDetailsType HelperServiceMMSDetailsType

Helpers of this Service Class send an MMS message.

"To" address(es) are passed in the 'pData' element of the main structure (HelperNotifyExecuteType)

The 'pDetails' struct member may optionally point to HelperServiceMMSDetailsType for this service class.

typedef struct _HelperServiceMMSObjectType HelperServiceMMSObjectType

Structure to hold the MMS object. This structure is part of the linked list which is pointed by the object member of HelperServiceMMSDetailsType

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:57 2006 for Palm API Guide


NetMasterLibErrors.h File Reference

Detailed Description

This is the error declarations file for the NetMaster Library.

Version:
1.0
Date:
01/31/2002

Include dependency graph for NetMasterLibErrors.h:

Net Master Error Codes

  • #define netMasterErrClass (hsNetMasterErrorClass)
  • #define netMasterErrMemory (netMasterErrClass + 0x01)
  • #define netMasterErrStorage (netMasterErrClass + 0x02)
  • #define netMasterErrBadArg (netMasterErrClass + 0x03)
  • #define netMasterErrNetNotInstalled (netMasterErrClass + 0x04)
  • #define netMasterErrDispatchTable (netMasterErrClass + 0x05)
  • #define netMasterErrNoNetPrefLib (netMasterErrClass + 0x06)
  • #define netMasterErrConfigNotFound (netMasterErrClass + 0x07)
  • #define netMasterErrConfigFailed (netMasterErrClass + 0x08)
  • #define netMasterErrNo1xService (netMasterErrClass + 0x09)
  • #define netMasterErrMIPFailed (netMasterErrClass + 0x0A)
  • #define netMasterErrBadPort (netMasterErrClass + 0x0B)

MIP Error Codes

Sprint's Mobile-IP (MIP) error codes.
  • #define netMasterErrMIPNoSimBindings (netMasterErrClass + 0x0C)
  • #define netMasterErrMIPReasonUnspecified64 (netMasterErrClass + 0x0D)
  • #define netMasterErrMIPAdminProhibited65 (netMasterErrClass + 0x0E)
  • #define netMasterErrMIPInsufficientResources66 (netMasterErrClass + 0x0F)
  • #define netMasterErrMIPMobileNodeAuth67 (netMasterErrClass + 0x10)
  • #define netMasterErrMIPHomeAgentAuth68 (netMasterErrClass + 0x11)
  • #define netMasterErrMIPReqLifetimeTooLong69 (netMasterErrClass + 0x12)
  • #define netMasterErrMIPPoorlyFormedReq70 (netMasterErrClass + 0x13)
  • #define netMasterErrMIPPoorlyFormedReply71 (netMasterErrClass + 0x14)
  • #define netMasterErrMIPReqedEncapUnavail72 (netMasterErrClass + 0x15)
  • #define netMasterErrMIPReservedNUnavail73 (netMasterErrClass + 0x16)
  • #define netMasterErrMIPCantRevTun74 (netMasterErrClass + 0x17)
  • #define netMasterErrMIPMustRevTun75 (netMasterErrClass + 0x18)
  • #define netMasterErrMIPBadTtl76 (netMasterErrClass + 0x19)
  • #define netMasterErrMIPInvalidCareOfAddr77 (netMasterErrClass + 0x1A)
  • #define netMasterErrMIPRegistration_Timeout78 (netMasterErrClass + 0x1B)
  • #define netMasterErrMIPDelivStyleNotSupported79 (netMasterErrClass + 0x1C)
  • #define netMasterErrMIPHome_Network_Unreachable80 (netMasterErrClass + 0x1D)
  • #define netMasterErrMIPHa_Host_Unreachable81 (netMasterErrClass + 0x1E)
  • #define netMasterErrMIPHa_Port_Unreachable82 (netMasterErrClass + 0x1F)
  • #define netMasterErrMIPHa_Unreachable88 (netMasterErrClass + 0x20)
  • #define netMasterErrMIPNonZeroHaRequested96 (netMasterErrClass + 0x21)
  • #define netMasterErrMIPMissingNai97 (netMasterErrClass + 0x22)
  • #define netMasterErrMIPForeign_Agent98 (netMasterErrClass + 0x23)
  • #define netMasterErrMIPMissingHa99 (netMasterErrClass + 0x24)
  • #define netMasterErrMIPErrorFa1_100 (netMasterErrClass + 0x25)
  • #define netMasterErrMIPErrorFa2_101 (netMasterErrClass + 0x26)
  • #define netMasterErrMIPUnknown_Challenge104 (netMasterErrClass + 0x27)
  • #define netMasterErrMIPMissing_Challenge105 (netMasterErrClass + 0x28)
  • #define netMasterErrMIPStale_Challenge106 (netMasterErrClass + 0x29)
  • #define netMasterErrMIPReasonUnspecified128 (netMasterErrClass + 0x2A)
  • #define netMasterErrMIPAdminProhibited129 (netMasterErrClass + 0x2B)
  • #define netMasterErrMIPInsufficientResources130 (netMasterErrClass + 0x2C)
  • #define netMasterErrMIPMobileNodeAuth131 (netMasterErrClass + 0x2D)
  • #define netMasterErrMIPForeignAgentAuth132 (netMasterErrClass + 0x2E)
  • #define netMasterErrMIPRegIdMismatch133 (netMasterErrClass + 0x2F)
  • #define netMasterErrMIPPoorlyFormedReq134 (netMasterErrClass + 0x30)
  • #define netMasterErrMIPTooManySimMobBindings135 (netMasterErrClass + 0x31)
  • #define netMasterErrMIPUnknownHaAddr136 (netMasterErrClass + 0x32)
  • #define netMasterErrMIPCantRevTun137 (netMasterErrClass + 0x33)
  • #define netMasterErrMIPMustRevTun138 (netMasterErrClass + 0x34)
  • #define netMasterErrMIPReqEncapNotAvail139 (netMasterErrClass + 0x35)
  • #define netMasterErrMIPErrorHa1_140 (netMasterErrClass + 0x36)
  • #define netMasterErrMIPErrorHa2_141 (netMasterErrClass + 0x37)
  • #define netMasterErrMIPUsernameSuspension801 (netMasterErrClass + 0x38)
  • #define netMasterErrMIPReserved2 (netMasterErrClass + 0x39)
  • #define netMasterErrMIPReserved3 (netMasterErrClass + 0x3A)
  • #define netMasterErrMIPReserved4 (netMasterErrClass + 0x3B)

Net Master Error Codes

  • #define netMasterErrAutoLoginNotPossible (netMasterErrClass + 0x3C)
  • #define netMasterErrCDMACarrierNetworkBusy (netMasterErrClass + 0x3D)
  • #define netMasterErrOneXServiceUnavailable (netMasterErrClass + 0x3E)
  • #define netMasterErrAuthReqDuringBGLogin (netMasterErrClass + 0x3F)
  • #define netMasterErrUIRPCTimeout (netMasterErrClass + 0x40)
  • #define netMasterErrInternalConnWouldBeImpossible (netMasterErrClass + 0x41)
  • #define netMasterErrNetGuardReqDuringBGLogin (netMasterErrClass + 0x42)
  • #define netMasterErrGPRSGenLoginErr (netMasterErrClass + 0x43)
  • #define netMasterErrNoOneXServiceWhileRoaming (netMasterErrClass + 0x44)

Reserved for future use

  • #define netMasterErrUnused45 (netMasterErrClass + 0x45)
  • #define netMasterErrUnused46 (netMasterErrClass + 0x46)
  • #define netMasterErrUnused47 (netMasterErrClass + 0x47)
  • #define netMasterErrUnused48 (netMasterErrClass + 0x48)
  • #define netMasterErrUnused49 (netMasterErrClass + 0x49)
  • #define netMasterErrUnused4A (netMasterErrClass + 0x4A)
  • #define netMasterErrUnused4B (netMasterErrClass + 0x4B)
  • #define netMasterErrUnused4C (netMasterErrClass + 0x4C)
  • #define netMasterErrUnused4D (netMasterErrClass + 0x4D)
  • #define netMasterErrUnused4E (netMasterErrClass + 0x4E)

Net Master Error Codes

  • #define netMasterErrOneXServiceNotEnabled (netMasterErrClass + 0x4F)

Define Documentation

#define netMasterErrAuthReqDuringBGLogin (netMasterErrClass + 0x3F)

Authentication UI prompt (such as username/password or script plug-in) was requested during background login -- this is not supported presently.

#define netMasterErrAutoLoginNotPossible (netMasterErrClass + 0x3C)

auto-login did not take place

#define netMasterErrBadArg (netMasterErrClass + 0x03)

invalid argument, unknown ID

#define netMasterErrBadPort (netMasterErrClass + 0x0B)

Invalid port number -- we remap this from serErrBadPort.

#define netMasterErrCDMACarrierNetworkBusy (netMasterErrClass + 0x3D)

"network busy" event was received from the carrier's network.

#define netMasterErrClass (hsNetMasterErrorClass)

hsNetMasterErrorClass is defined in HsErrorClasses.h as 0x7100

#define netMasterErrConfigFailed (netMasterErrClass + 0x08)

Attempt to configure network settings failed

#define netMasterErrConfigNotFound (netMasterErrClass + 0x07)

NetPref config not found

#define netMasterErrDispatchTable (netMasterErrClass + 0x05)

Unrecognized dipatch table format

#define netMasterErrGPRSGenLoginErr (netMasterErrClass + 0x43)

Generic GPRS login error -- returned when we don't have enough specific info about the cause of login failure.

#define netMasterErrInternalConnWouldBeImpossible (netMasterErrClass + 0x41)

auto-login did not take place

#define netMasterErrMemory (netMasterErrClass + 0x01)

runtime memory error

#define netMasterErrMIPFailed (netMasterErrClass + 0x0A)

Generic Mobile-IP failure

#define netMasterErrMIPReserved2 (netMasterErrClass + 0x39)

Reserved for future use

#define netMasterErrMIPReserved3 (netMasterErrClass + 0x3A)

Reserved for future use

#define netMasterErrMIPReserved4 (netMasterErrClass + 0x3B)

Reserved for future use

#define netMasterErrMIPUsernameSuspension801 (netMasterErrClass + 0x38)

801 Username suspension due to repeated incorrect passwords being sent

#define netMasterErrNetGuardReqDuringBGLogin (netMasterErrClass + 0x42)

Net Guard prompt would have been required during background login. Prompting is presently not supported during background login.

#define netMasterErrNetNotInstalled (netMasterErrClass + 0x04)

NetLib has not been installed

#define netMasterErrNo1xService (netMasterErrClass + 0x09)

1xRTT is not available

#define netMasterErrNoNetPrefLib (netMasterErrClass + 0x06)

NetPref library not found

#define netMasterErrNoOneXServiceWhileRoaming (netMasterErrClass + 0x44)

Sprint OneX service is unavailable while roaming

#define netMasterErrOneXServiceNotEnabled (netMasterErrClass + 0x4F)

modem doesn't support requested service

#define netMasterErrOneXServiceUnavailable (netMasterErrClass + 0x3E)

< requested service unavailable

#define netMasterErrStorage (netMasterErrClass + 0x02)

storage memory error

#define netMasterErrUIRPCTimeout (netMasterErrClass + 0x40)

UI RPC timed out during a background-initiated login. This is an internal error that might occur if the current UI app is not processing events for a long time.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:57 2006 for Palm API Guide


NetMasterLibrary.h File Reference

Detailed Description

This is the main header file for the NetMaster Library.

Version:
1.0
Date:
01/31/2002
Usage Model

The NetMaster library is preloaded by the system software before the system sends sysAppLaunchCmdSystemReset.

Clients of NetMaster library need to call SysLibFind (netMasterLibName,...) to get a library refNum of NetMaster.

If SysLibFind returns a non-zero error, clients MUST assume that NetMaster was not loaded for a good reason (such as when the user performed a "safe" reset), or is simply not present on the system and fail gracefully.

Clients MUST NOT load NetMaster themselves (such as via SysLibLoad or SysLibInstall) -- keep in mind that if the system didn't load it, there was a good reason for it!

Include dependency graph for NetMasterLibrary.h:

Defines

  • #define NETMASTER_LIB_TRAP(trapNum) SYS_TRAP(trapNum)

Functions

  • Err NetMasterLibVersionGet (UInt16 refNum, UInt32 *majorVerP, UInt32 *minorVerP, UInt32 *bugFixVerP)
  • Err NetMasterNetLibOpenWithOptions (UInt16 refNum, NetMasterNetLibOpenOptionsType netLibOpenOptions, UInt16 *netIFErrsP)
  • Err NetMasterAutoLoginSettingGet (UInt16 refNum, NetMasterAutoLoginType *settingsP)
  • Err NetMasterAutoLoginSettingSet (UInt16 refNum, NetMasterAutoLoginType flagsToClear, NetMasterAutoLoginType flagsToSet)
  • Boolean NetMasterNetLibOpenIfFullyUp (UInt16 refNum, UInt16 *netLibRefNumP)
  • Boolean NetMasterNetLibIsFullyUp (UInt16 refNum)
  • Err NetMasterNetInterfacesShutDown (UInt16 refNum, Err reasonErrCode, NetMasterNetIFShutDownOptionsType shutDownOptions)
  • Boolean NetMasterNetLibIsLoggingIn (UInt16 refNum, Boolean *isLogonActiveP, Boolean *isPrgDialogUpP, Boolean *waitingInErrorStateP)
  • Err NetMasterSCNetAttach (UInt16 refNum, UInt32 netPrefRecID, NetMasterNetLibOpenOptionsType netLibOpenOptions, NetMasterLoginPriorityEnum loginPriority, Int32 anchorTimeoutSec, NetMasterDataContextIDType *dataCxtIDP, Boolean *isNetIFErrorP)
  • Err NetMasterSCNetDetach (UInt16 refNum, NetMasterDataContextIDType dataCxtID)
  • Err NetMasterSCContextAnchorTimeoutSet (UInt16 refNum, NetMasterDataContextIDType dataCxtID, Int32 requestedAnchorTimeoutSec, Int32 *oActualAnchorTimeoutSecP)
  • Err NetMasterSCSessionIDGetFromContext (UInt16 refNum, NetMasterDataContextIDType dataCxtID, NetMasterDataSessionIDType *sessionP)
  • Err NetMasterSCSessionCountGet (UInt16 refNum, Int16 *activeSessionCountP)
  • Err NetMasterSCSessionsEnumerate (UInt16 refNum, NetMasterDataSessionIDType sessionIDs[], Int16 maxEntries, Int16 *entriesStoredP)
  • Err NetMasterSCSessionSvcRecIDGet (UInt16 refNum, NetMasterDataSessionIDType sessionID, UInt32 *primaryNetPrefIDP, UInt32 *actualNetPrefIDP)
  • Err NetMasterSCSessionIsActive (UInt16 refNum, NetMasterDataSessionIDType sessionID, Boolean *isActiveP)
  • Err NetMasterSCSessionShutDown (UInt16 refNum, NetMasterDataSessionIDType sessionID, NetMasterNetIFShutDownOptionsType shutDownOptions)

Function Documentation

Err NetMasterAutoLoginSettingGet | ( | UInt16 | refNum,
 |  | NetMasterAutoLoginType * | settingsP
 | ) |

Get the "auto-login" settings

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind).
settingsP,: OUT: Any of the NetMasterAutoLoginType constants bitwise-or’ed together.
Return values:
Err Error code.

Err NetMasterAutoLoginSettingSet | ( | UInt16 | refNum,
 |  | NetMasterAutoLoginType | flagsToClear,
 |  | NetMasterAutoLoginType | flagsToSet
 | ) |

NetMasterAutoLoginSettingSet:

set the "auto-login" settings

Parameters:
refNum,: IN: NetMasterLib reference number.
flagsToClear,: IN: Flags to clear -- any of the NetMasterAutoLoginType constants bitwise-or'ed together or netMasterAutoLoginClearAll to clear all flags; the flag clearing operation is performed before the flag setting operation. Pass 0 to skip the clearing operation.
flagsToSet,: IN: Flags to set -- any of the NetMasterAutoLoginType constants bitwise-or'ed together. Pass 0 to skip the setting operation.
Return values:
Err Error code.

Err NetMasterLibVersionGet | ( | UInt16 | refNum,
 |  | UInt32 * | majorVerP,
 |  | UInt32 * | minorVerP,
 |  | UInt32 * | bugFixVerP
 | ) |

Get Library API Version number.

Parameters:
refNum,: IN: Library reference number
majorVerP,: OUT: Major version number
minorVerP,: OUT: Minor version number
bugFixVerP,: OUT: Bug fix version number
Return values:
Err NetMaster Library error code

Err NetMasterNetInterfacesShutDown | ( | UInt16 | refNum,
 |  | Err | reasonErrCode,
 |  | NetMasterNetIFShutDownOptionsType | shutDownOptions
 | ) |

Shut down NetLib's interfaces, if they are presently up; does nothing if they are presently down; blocking; If NetLib is in the process of logging on to the IP network (Connection progress dialog is up), will simulate the press of the Cancel key and return without waiting for interfaces to shut down.

WARNING: will dead-lock if called from the context of a Notification Manager notification. This is because Notification Manager erroneously grabs the Memory Manager semaphore before sending a notification, and this causes a dead-lock when the TCP/IP stack's background task calls into Memory Manager or Data Manager API as part of the shut-down.

Shut down NetLib’s interfaces, if they are presently up; does nothing if they are presently down.

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind)
reasonErrCode,: IN: Error code that is the reason for this call to NetMasterNetInterfacesShutDown; 0 if not an error, or reason is unknown. Future version of this API may use the error code to display an alert or log a debug trace.
shutDownOptions,: IN: Shutdown options. See NetMasterNetIFShutDownOptionsType.
Return values:
Err Error code.

Boolean NetMasterNetLibIsFullyUp ( UInt16 refNum )

Function: NetMasterNetLibIsFullyUp

Summary: Checks if NetLib is fully up -- i.e. all of its interfaces are up.

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind
Return values:
Boolean True if NetLib is fully up, false if at least one interface is down.

Boolean NetMasterNetLibIsLoggingIn | ( | UInt16 | refNum,
 |  | Boolean * | isLogonActiveP,
 |  | Boolean * | isPrgDialogUpP,
 |  | Boolean * | waitingInErrorStateP
 | ) |

Test if NetLib is in the Logging On state. Returns true if some client is presently inside NetLibOpen or NetLibOpenConfig.

Parameters:
refNum,: IN: NetMaster library reference number.
isLogonActiveP,: OUT: True if NetLib is in the middle of logging in and an error has not yet been encountered. This parameter is OPTIONAL -- pass NULL to ignore.
isPrgDialogUpP,: OUT: If NetLib's Service Connection Progress dialog is up, NetMasterIsLoggingIn will set isPrgDialogUpP to true; false otherwise. This parameter is OPTIONAL -- pass NULL to ignore.
waitingInErrorStateP,: OUT: If NetLib's Service Connection Prorgress dialog is in the error acknowledegement state (displaying an error message to the user, waiting for OK), NetMasterIsLoggingIn will set waitingInErrorStateP to true; false otherwise. This parameter is OPTIONAL -- pass NULL to ignore.
Return values:
Boolean True if some client is presently inside NetLibOpen or NetLibOpenConfig.

Boolean NetMasterNetLibOpenIfFullyUp | ( | UInt16 | refNum,
 |  | UInt16 * | netLibRefNumP
 | ) |

Function: NetMasterNetLibOpenIfFullyUp

Summary: Open NetLib only if all of its current interfaces are already fully up. If this call succeeds (returns true), it is semantically equivalent to a successful NetLibOpen call, which implies that the caller is responsible for calling NetLibClose to match this call when done with NetLib. If NetMasterNetLibOpenIfFullyUp fails (returns false), the caller *MUST NOT* make a matching call to NetLibClose.

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind or SysLibLoad)
netLibRefNumP,: OUT: NetLib refnum on success, undefined on failure
Return values:
Boolean True if opened, false if not (failure)

Err NetMasterNetLibOpenWithOptions | ( | UInt16 | refNum,
 |  | NetMasterNetLibOpenOptionsType | netLibOpenOptions,
 |  | UInt16 * | netIFErrsP
 | ) |

An extension, of sorts, of the NetLibOpen function -- allows the caller to specify special options, such as "auto-dismiss on error". See the definition of NetMasterNetLibOpenOptionsType for more details.

The refNum parameter must be the refnum of NetMaster library (not of NetLib).

IMPORTANT: This call is semantically equivalent to calling NetLibOpen; if this call succeeds (returns 0 error code), the caller is responsible for calling NetLibClose when done with NetLib; if this call fails (non-zero error code returned), the caller must *NOT* make the matching call to NetLibClose.

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind()).
netLibOpenOptions,: IN: See NetMasterNetLibOpenOptionsType.
netIFErrsP OUT: Error returned by the net interface if open failed.
Return values:
Err Error code.

Err NetMasterSCContextAnchorTimeoutSet | ( | UInt16 | refNum,
 |  | NetMasterDataContextIDType | dataCxtID,
 |  | Int32 | requestedAnchorTimeoutSec,
 |  | Int32 * | oActualAnchorTimeoutSecP
 | ) |

Changes the data context's session anchor timeout value. The requested anchor timeout value is in seconds. The system will apply internal limits to the value if necessary. The actual value is returned via the optional output arugment oActualAnchorTimeoutSecP (pass NULL to ignore).

IMPORTANT: If the application is in a state where the anchor timeout that it initially requested when calling NetMasterSCNetAttach is now bigger than necessary, the application MUST reduce its anchor timeout to the minimum acceptable value so that other services may be activated more quickly when necessary.

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind).
dataCxtID,: IN: Data context created by NetMasterSCNetAttach.
requestedAnchorTimeoutSec,: IN: Requested anchor timeout in seconds.
oActualAnchorTimeoutSecP,: OUT: Actual anchor timeout that was applied (pass NULL to ignore). Undefined on error.
Return values:
Err Error code.

Err NetMasterSCNetAttach | ( | UInt16 | refNum,
 |  | UInt32 | netPrefRecID,
 |  | NetMasterNetLibOpenOptionsType | netLibOpenOptions,
 |  | NetMasterLoginPriorityEnum | loginPriority,
 |  | Int32 | anchorTimeoutSec,
 |  | NetMasterDataContextIDType * | dataCxtIDP,
 |  | Boolean * | isNetIFErrorP
 | ) |

Attach to the network using the specified service; this will call NetLibOpen and execute any required fallback services, as necessary on the caller’s behalf.

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind).
netPrefRecID,: IN: NetPref Record ID of the network profile to attach.
netLibOpenOptions,: IN: Special options, such as “auto-dismiss on error”; 0 = no options.
loginPriority,: IN: Login priority. Most applications should use the netMasterLoginPriorityDefault priority.
anchorTimeoutSec,: IN: It is bigger than maximum allowed for the given device configuration. This value is used by the system to decide when a data session may be considered idle, and may be shut down to make room for a different login request. This value is treated as a hint only, and the system makes no guarantees about the longevity of the data session. The duration is in seconds, which may be 0. For system default, pass netMasterAnchorTimeoutDefault (RECOMMENDED!)
dataCxtIDP,: OUT: Data context on success, undefined on failure.
isNetIFErrorP,: OUT: When non zero error code is returned, this boolean indicates whether the error was from the network interface. For foreground-initiated logins, the implication is that if it *is* an error from the network interface, an error message was most likely already displayed to the user via the standard progress dialog UI. If the error is *not* from the network interface, no error has been displayed to the user. Pass NULL to ignore this parameter.
Return values:
Err Error code.

Err NetMasterSCNetDetach | ( | UInt16 | refNum,
 |  | NetMasterDataContextIDType | dataCxtID
 | ) |

Detach from the data session that was successfully established by NetMasterSCNetAttach.

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind).
dataCxtID,: IN: Data context created by NetMasterSCNetAttach.
Return values:
Err Error code.

Err NetMasterSCSessionCountGet | ( | UInt16 | refNum,
 |  | Int16 * | activeSessionCountP
 | ) |

Get the current count of network data sessions that are active (believed to be logged in).

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind).
activeSessionCountP,: OUT: Count of active data sessions.
Return values:
Err Error code.

Err NetMasterSCSessionIDGetFromContext | ( | UInt16 | refNum,
 |  | NetMasterDataContextIDType | dataCxtID,
 |  | NetMasterDataSessionIDType * | sessionP
 | ) |

Given a data context, get the associated data session ID. 0 or more data contexts may be associated with a data session. A data session represents a single network login instance. i.e., if you had two concurrent network login instances, such as GPRS and 802.11 for example, there would be two network data sessions.

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind).
dataCxtID,: IN: Data context created by NetMasterSCNetAttach.
sessionP,: OUT: Data session ID on success, undefined on failure.
Return values:
Err Error code.

Err NetMasterSCSessionIsActive | ( | UInt16 | refNum,
 |  | NetMasterDataSessionIDType | sessionID,
 |  | Boolean * | isActiveP
 | ) |

Checks if the given session is still on the active list (believed to be logged in).

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind).
sessionID,: IN: Data session ID.
isActiveP,: OUT: True if the given session is believed to be logged in, false if it’s not logged in.
Return values:
Err Error code.

Err NetMasterSCSessionsEnumerate | ( | UInt16 | refNum,
 |  | NetMasterDataSessionIDType | sessionIDs[],
 |  | Int16 | maxEntries,
 |  | Int16 * | entriesStoredP
 | ) |

Fill an array with session ID's of the currently active data sessions. Initially, only one active data session may be supported, but this may increase with the hardware and system software capabilities.

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind).
sessionIDs,: OUT: Array for returning session IDs on success, contents undefined on failure.
maxEntries,: IN: Max # of session ID’s that may be stored in the caller’s array sessionIDs.
entriesStoredP,: OUT: On success, number of entries that were actually returned in the sessionIDs array, which may be less than maxEntries (possibly 0); undefined on failure.
Err Error code.

Err NetMasterSCSessionShutDown | ( | UInt16 | refNum,
 |  | NetMasterDataSessionIDType | sessionID,
 |  | NetMasterNetIFShutDownOptionsType | shutDownOptions
 | ) |

Request shut down of the given network session. This function may block for a significant period of time (typically multiple seconds) while the network interfaces are being brought down.

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind).
sessionID,: IN: data session ID.
shutDownOptions,: IN: shutdown options. See NetMasterNetIFShutDownOptionsType.
Return values:
Err Error code.

Err NetMasterSCSessionSvcRecIDGet | ( | UInt16 | refNum,
 |  | NetMasterDataSessionIDType | sessionID,
 |  | UInt32 * | primaryNetPrefIDP,
 |  | UInt32 * | actualNetPrefIDP
 | ) |

Retrieves the unique ID's of the actual and primary NetPref records that were used to establish the data session. The two may be different if the primary record had a fallback, the primary failed, and the fallback record succeeded. In other words, *actualNetPrefIDP indicates the NetPref record ID that succeeded in establishing the connection.

Parameters:
refNum,: IN: NetMasterLib reference number (from SysLibFind).
sessionID,: IN: Data session ID.
primaryNetPrefIDP,: OUT: NetPref record ID of the primary record used in connection establishment.
actualNetPrefIDP,: OUT: NetPref record ID of the actual record with which connection establishment succeeded. This may be the same as the primary record or a fallback of the primary record.
Return values:
Err Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:58 2006 for Palm API Guide


NetMasterLibTarget.h File Reference

Detailed Description

This is the target parameters file for the NetMaster Library.

Version:
1.0
Date:
01/31/2002
We break out these definitions so that other portable modules could access them without PalmOS-specific definitions

Defines

  • #define netMasterLibCreatorID 'HsNM'
  • #define netMasterLibTypeID 'libr'
  • #define netMasterLibName "HsNetMasterLibrary.lib"

Define Documentation

#define netMasterLibCreatorID 'HsNM'

NetMaster Library database creator

#define netMasterLibName "HsNetMasterLibrary.lib"

Internal library name which can be passed to SysLibFind()

#define netMasterLibTypeID 'libr'

Standard library database type

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:58 2006 for Palm API Guide


NetMasterLibTraps.h File Reference

Detailed Description

Trap definitions for the NetMaster Library.

Version:
1.0
Date:
01/31/2002

NetMaster Function Trap Numbers

  • #define netMasterLibTrapLibVersionGet (sysLibTrapCustom + 0)
  • #define netMasterLibTrapSCNetAttach (sysLibTrapCustom + 1)
  • #define netMasterLibTrapLibInit (sysLibTrapCustom + 2)
  • #define netMasterLibTrapAutoLoginSettingGet (sysLibTrapCustom + 3)
  • #define netMasterLibTrapAutoLoginSettingSet (sysLibTrapCustom + 4)
  • #define netMasterLibTrapServiceSetUp (sysLibTrapCustom + 5)
  • #define netMasterLibTrapNetLibOpenIfFullyUp (sysLibTrapCustom + 6)
  • #define netMasterLibTrapNetLibIsFullyUp (sysLibTrapCustom + 7)
  • #define netMasterLibTrapPhoneServiceClassesGet (sysLibTrapCustom + 8)
  • #define netMasterLibTrapHandlePhoneEvent (sysLibTrapCustom + 9)
  • #define netMasterLibTrapControl (sysLibTrapCustom + 10)
  • #define netMasterLibTrapNetInterfacesShutDown (sysLibTrapCustom + 11)
  • #define netMasterLibTrapNetLibIsLoggingIn (sysLibTrapCustom + 12)
  • #define netMasterLibTrapNetLibOpenWithOptions (sysLibTrapCustom + 13)
  • #define netMasterLibTrapImplementNetLibOpenConfig (sysLibTrapCustom + 14)
  • #define netMasterLibTrapImplementNetLibConnectionRefresh (sysLibTrapCustom + 15)
  • #define netMasterLibTrapImplementNetLibHandlePowerOff (sysLibTrapCustom + 16)
  • #define netMasterLibTrapOverrideErrorGetAndClear (sysLibTrapCustom + 17)
  • #define netMasterLibTrapOverrideMdmInitStrGetPtr (sysLibTrapCustom + 18)
  • #define netMasterLibTrapLoginSMFlagsSetAndGet (sysLibTrapCustom + 19)
  • #define netMasterLibTrapDataSessionErrorNotify (sysLibTrapCustom + 20)
  • #define netMasterLibTrapSCNetDetach (sysLibTrapCustom + 21)
  • #define netMasterLibTrapSCSessionIDGetFromContext (sysLibTrapCustom + 22)
  • #define netMasterLibTrapSCSessionCountGet (sysLibTrapCustom + 23)
  • #define netMasterLibTrapSCSessionsEnumerate (sysLibTrapCustom + 24)
  • #define netMasterLibTrapSCSessionSvcRecIDGet (sysLibTrapCustom + 25)
  • #define netMasterLibTrapSCSessionIsActive (sysLibTrapCustom + 26)
  • #define netMasterLibTrapSCSessionShutDown (sysLibTrapCustom + 27)
  • #define netMasterLibTrapLoginExecuteFromUI (sysLibTrapCustom + 28)
  • #define netMasterLibTrapSCContextAnchorTimeoutSet (sysLibTrapCustom + 29)
  • #define netMasterLibTrapPPPPayloadReport (sysLibTrapCustom + 30)
  • #define netMasterLibTrapDataCounterGetAndReset (sysLibTrapCustom + 31)
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:58 2006 for Palm API Guide


NetMasterLibTypes.h File Reference

Detailed Description

This file contains public data types exported by the NetMaster Library.

Version:
1.0
Date:
01/31/2002
For usage model:
See also:
NetMasterLibrary.h

Data Structures

  • struct NetMasterClientEventVPNConnInstallType
    Data block for netMasterClientEventVPNConnInstall. More...
  • struct NetMasterClientEventInfoType
    This structure is passed as the 'detailsP' of the notification. More...

NetMaster API Version Number

Current library API version number returned by NetMasterLibVersionGet()
  • #define netMasterLibVersionMajor 0
  • #define netMasterLibVersionMinor 4
  • #define netMasterLibVersionBugFix 0

Defines

  • #define netMasterClientEventNotificationTypeID 'HnMe'
  • #define netMasterClientCurrentEventVersion 1
  • #define netMasterAnchorTimeoutDefault (-1)

Typedefs

  • typedef UInt32 NetMasterAutoLoginType
  • typedef UInt32 NetMasterNetIFShutDownOptionsType
  • typedef UInt16 NetMasterClientEventEnum
  • typedef UInt32 NetMasterNetLibOpenOptionsType
  • typedef UInt32 NetMasterLoginPriorityEnum
  • typedef UInt32 NetMasterDataContextIDType
  • typedef UInt32 NetMasterDataSessionIDType

Enumerations

  • enum {
    netMasterAutoLoginWhenWirelessOn = 0x00000001UL,
    netMasterLoginNetGuardEnabled = 0x00000002UL,
    netMasterAutoLoginClearAll = 0xFFFFFFFFUL
    }
  • enum {
    netMasterNetIFShutDownOptDismissPrgDialog = 0x00000001UL,
    netMasterNetIFShutDownOptCurrentOnly = 0x00000002UL,
    netMasterNetIFShutDownOptResetNetGuard = 0x00000004UL
    }
  • enum {
    netMasterClientEventUnknown = 0,
    netMasterClientEventVPNConnInstall,
    netMasterClientEventLAST
    }
  • enum {
    netMasterNetLibOpenOptAutoDismiss = 0x00000001UL,
    netMasterNetLibOpenOptBypassNetGuard = 0x00000002UL,
    netMasterNetLibOpenOptPrimaryProfileOnly = 0x00000004UL
    }
  • enum {
    netMasterLoginPriorityDefault = 0,
    netMasterLoginPriorityLow = 1,
    netMasterLoginPriorityHigh = 2
    }

Define Documentation

#define netMasterAnchorTimeoutDefault (-1)

Default value to pass as the anchorTimeoutSec parameter to NetMasterSCNetAttach

#define netMasterClientCurrentEventVersion 1

Increment this version # when adding fields to NetMasterClientEventInfoType, except when just adding a new event data pointer to eventData

#define netMasterClientEventNotificationTypeID 'HnMe'

The application that wishes to receive these notifications registers via Palm OS Notification Manager's SysNotifyRegister() for the event type netMasterClientEventNotificationTypeID to receive the events listed in NetMasterClientEventEnum. See Palm OS Notification Manager documentation for registration and notification handling details.

Typedef Documentation

typedef UInt32 NetMasterAutoLoginType

TCP/IP Network Auto-login definitions used by NetMasterAutoLoginSettingGet() and NetMasterAutoLoginSettingSet()

typedef UInt16 NetMasterClientEventEnum

NetMaster library client event selector

typedef UInt32 NetMasterDataContextIDType

Data Context type used by NetMasterSCNetAttach, NetMasterSCNetDetach and friends.

typedef UInt32 NetMasterDataSessionIDType

Data Session type used by NetMasterSCSessionIDGetFromContext and friends.

typedef UInt32 NetMasterLoginPriorityEnum

Login priority values that may be passed to NetMasterSCNetAttach

typedef UInt32 NetMasterNetIFShutDownOptionsType

NetLib interface shutdown options for NetMasterNetInterfacesShutDown

typedef UInt32 NetMasterNetLibOpenOptionsType

Special NetLibOpenConfig options passed to NetMasterNetLibOpenWithOptions()

Enumeration Type Documentation

anonymous enum

Enumerator:
netMasterAutoLoginWhenWirelessOn | For CDMA 1xRTT: Automatically log in to the TCP/IP network when the wireless mode is turned on and network is acquired; For GSM GPRS: Attempt to attach when the radio is powered on (ideally a combined attach)
netMasterLoginNetGuardEnabled | Prompt the user before connecting to the Internet; Also known as the "NetGuard" feature.

anonymous enum

Enumerator:
netMasterNetIFShutDownOptDismissPrgDialog | If the Progress dialog is up, dismiss it even if it is in the error display state
netMasterNetIFShutDownOptCurrentOnly | If set, and the session being connected at the moment has a fallback, this will allow the fallback to be processed (for example, when aborting GPRS logon, but allowing the fallback, if any, to take place)
netMasterNetIFShutDownOptResetNetGuard If set, will cause the cached NetGuard setting to be cleared: apps that Disconnect the network connection as the result of user request (such as Disconnect button or menu item), MUST set this flag -- this causes the system to put up the NetGuard prompt during a subsequent data network login, if dictated by the netMasterLoginNetGuardEnabled setting.

If *not* set, will cause the cached NetGuard setting to be preserved.

anonymous enum

Enumerator:
netMasterClientEventVPNConnInstall Queries the VPN vendor to install its own connection profile name, if any; NetMaster library broadcasts this event to all registered clients from the context of the UI task when a client application calls NetLibOpen() or NetLibOpenConfig(). Parameter block: NetMasterClientEventInfoType:NetMasterClientEventVPNConnInstallType

anonymous enum

Enumerator:
netMasterNetLibOpenOptAutoDismiss netMasterNetLibOpenOptAutoDismiss:

If set, auto-dismiss the progress dialog if error occurs

netMasterNetLibOpenOptBypassNetGuard netMasterNetLibOpenOptBypassNetGuard:

If set, bypass the NetGuard feature -- for use by IOTA service only!!!

IMPORTANT: *not* available on systems before Palm OS 5.0

netMasterNetLibOpenOptPrimaryProfileOnly If this flag is set by the client, then the connection will be attempted only with the requested NetPref record, and the fallback network profile, if any, will be ignored.

IMPORTANT: *not* available on systems before Palm OS 5.0

anonymous enum

Enumerator:
netMasterLoginPriorityDefault | The vast majority of background and foreground applications SHOULD ALWAYS use the Default login priority. This allows Data Session Control system software to optimize end-user experience on the device by following specific data session management rules requested by network operators.
netMasterLoginPriorityLow | The Low login priority is the *least* disruptive to existing data sessions that were established with a different network service profile than the one that you're requesting.
netMasterLoginPriorityHigh | The High login priority is the *most* disruptive to existing data sessions that were established with a different network service profile than the one that you're requesting. This will typically cause even active foreground data sessions to be torn down. This priority is reserved for *internal use only*, and should be avoided by other developers as its usage will typically break the data session management model of the device, resulting in poor end-user experience.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:58 2006 for Palm API Guide


NetPrefLibErrors.h File Reference

Detailed Description

This is the error declarations file for the NetPref Library.

Version:
1.0
Date:
12/12/2001

Include dependency graph for NetPrefLibErrors.h:

Defines

  • #define netPrefErrClass (hsNetPrefLibErrorClass)
  • #define netPrefErrMemory (netPrefErrClass + 0x01)
  • #define netPrefErrStorage (netPrefErrClass + 0x02)
  • #define netPrefErrBadArg (netPrefErrClass + 0x03)
  • #define netPrefErrRecNotSaved (netPrefErrClass + 0x04)
  • #define netPrefErrRecGone (netPrefErrClass + 0x05)
  • #define netPrefErrCCSMIncomplete (netPrefErrClass + 0x06)
  • #define netPrefErrCSDNotAllowed (netPrefErrClass + 0x07)
  • #define netPrefErrNoCCSMSettings (netPrefErrClass + 0x08)
  • #define netPrefErrNVSync (netPrefErrClass + 0x09)
  • #define netPrefErrNVRead (netPrefErrClass + 0x0A)
  • #define netPrefErrCCSMNoCarrierMatch (netPrefErrClass + 0x0B)
  • #define netPrefErrRadioIsOff (netPrefErrClass + 0x0C)
  • #define netPrefErrPhoneLibOpenFailed (netPrefErrClass + 0x0D)
  • #define netPrefErrNVWrite (netPrefErrClass + 0x0E)
  • #define netPrefErrReadOnlyField (netPrefErrClass + 0x0F)
  • #define netPrefErrFieldNotInSet (netPrefErrClass + 0x10)
  • #define netPrefErrNVWritePDPInUse (netPrefErrClass + 0x11)

Define Documentation

#define netPrefErrBadArg (netPrefErrClass + 0x03)

invalid argument, unknown ID

#define netPrefErrCCSMIncomplete (netPrefErrClass + 0x06)

missing or incomplete CCSM table

#define netPrefErrCCSMNoCarrierMatch (netPrefErrClass + 0x0B)

No matching entry in the CCSM Carrier List DB

#define netPrefErrClass (hsNetPrefLibErrorClass)

hsNetMasterErrorClass is defined in HsErrorClasses.h

#define netPrefErrCSDNotAllowed (netPrefErrClass + 0x07)

CSD is not allowed

#define netPrefErrFieldNotInSet (netPrefErrClass + 0x10)

Attempting to modify a field that is not in the record's set.

#define netPrefErrMemory (netPrefErrClass + 0x01)

runtime memory error

#define netPrefErrNoCCSMSettings (netPrefErrClass + 0x08)

settings were not found in the CCSM Carrier Settings DB

#define netPrefErrNVRead (netPrefErrClass + 0x0A)

Error reading setting from the radio's NV storage

#define netPrefErrNVSync (netPrefErrClass + 0x09)

Error synchronizing settings with the radio's NV storage

#define netPrefErrNVWrite (netPrefErrClass + 0x0E)

Error writing setting to the radio's NV storage

#define netPrefErrNVWritePDPInUse (netPrefErrClass + 0x11)

Couldn't save data to PDP in radio's NV because the PDP is in use (logged in most likely).

#define netPrefErrPhoneLibOpenFailed (netPrefErrClass + 0x0D)

Error while opening PhoneLib

#define netPrefErrRadioIsOff (netPrefErrClass + 0x0C)

Operation failed because the radio (wireless mode) is off.

#define netPrefErrReadOnlyField (netPrefErrClass + 0x0F)

Attempting to modify the data of a read-only field.

#define netPrefErrRecGone (netPrefErrClass + 0x05)

record could not be found

#define netPrefErrRecNotSaved (netPrefErrClass + 0x04)

cannot perform the requested operation on the new record until it is saved.

#define netPrefErrStorage (netPrefErrClass + 0x02)

storage memory error

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:59 2006 for Palm API Guide


NetPrefLibFieldInfoTable.h File Reference

Detailed Description

This header file contains record field information for NetPref settings.

Version:
1.0
Date:
01/11/2002

Functions

  • NetPrefRecFieldInfoPreamble () NetPrefRecFieldInfoFIRST(netPrefRecFieldUnknown
  • NetPrefRecFieldInfoGrpStart (netPrefRecFieldExtendedSTART, 1) NetPrefRecFieldInfoExtended(netPrefRecFieldUInt32Reserved1
  • < 2:i32rsvd1 > NetPrefRecFieldInfoExtended (netPrefRecFieldSvcMediumAlias, 3, netPrefFieldTypeUInt16, 0, 0,< 3:medium >, 10) NetPrefRecFieldInfoExtended(netPrefRecFieldBinding
  • < 2:i32rsvd1 >< 4:bind > NetPrefRecFieldInfoExtended (netPrefRecFieldBindingIndex, 5, netPrefFieldTypeUInt16, 0, 0,< 5:bindidx >, 11) NetPrefRecFieldInfoExtended(netPrefRecFieldSvcGatewayType
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp > NetPrefRecFieldInfoExtended (netPrefRecFieldFallbackID, 7, netPrefFieldTypeUInt32, 0, 0,< 7:fback >, 9) NetPrefRecFieldInfoExtended(netPrefRecFieldAPN
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn > NetPrefRecFieldInfoExtended (netPrefRecFieldMdmInitStr, 9, netPrefFieldTypeStr, 0, 0,< 9:mdmins >, 10) NetPrefRecFieldInfoExtended(netPrefRecFieldIsMobileIP
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip > NetPrefRecFieldInfoExtended (netPrefRecFieldHAAddrPrimary, 11, netPrefFieldTypeUInt32, 0, 0,< 11:ha1 >, 8) NetPrefRecFieldInfoExtended(netPrefRecFieldHAAddrSecondary
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 > NetPrefRecFieldInfoExtended (netPrefRecFieldMnHaSS, 13, netPrefFieldTypeBin, 0, 0,< 13:hapsw >, 10) NetPrefRecFieldInfoExtended(netPrefRecField1xRTTTunneling
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl > NetPrefRecFieldInfoExtended (netPrefRecFieldMnHaSpi, 15, netPrefFieldTypeUInt32, 0, 0,< 15:haspi >, 10) NetPrefRecFieldInfoExtended(netPrefRecFieldMnAaaSpi
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp > NetPrefRecFieldInfoExtended (netPrefRecFieldDialStr, 17, netPrefFieldTypeStr, 0, 0,< 17:dials >, 10) NetPrefRecFieldInfoExtended(netPrefRecFieldRecProtection
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect > NetPrefRecFieldInfoExtended (netPrefRecFieldPDPIndex, 19, netPrefFieldTypeUInt32, 0, 0,< 19:pdpidx >, 11) NetPrefRecFieldInfoExtended(netPrefRecFieldPDPChangeID
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg > NetPrefRecFieldInfoExtended (netPrefRecFieldCreatorID, 21, netPrefFieldTypeUInt32, 0, 0,< 21:crid >, 9) NetPrefRecFieldInfoExtended(netPrefRecFieldCreatorData
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata > NetPrefRecFieldInfoExtended (netPrefRecFieldGPRSQOS, 23, netPrefFieldTypeBin, 0, 0,< 23:gprsqos >, 12) NetPrefRecFieldInfoExtended(netPrefRecField1xRTTQOS
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos > NetPrefRecFieldInfoExtended (netPrefRecFieldBinReserved1, 25, netPrefFieldTypeBin, 0, 0,< 25:binrsvd1 >, 13) NetPrefRecFieldInfoExtended(netPrefRecFieldNaiStr
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai > NetPrefRecFieldInfoExtended (netPrefRecFieldMnAaaSs, 27, netPrefFieldTypeBin, 0, 0,< 27:mnaaass >, 12) NetPrefRecFieldInfoExtended(netPrefRecFieldVJCompSlots
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots > NetPrefRecFieldInfoExtended (netPrefRecFieldFallbackInfo, 29, netPrefFieldTypeBin, 0, 0,< 29:fbkinfo >, 12) NetPrefRecFieldInfoGrpEnd(netPrefRecFieldExtendedEND) NetPrefRecFieldInfoGrpStart(netPrefRecFieldLegacySTART
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots > NetPrefRecFieldInfoLegacy (netPrefRecFieldInterfaceID, 1001, netPrefFieldTypeUInt32, 0, 0,< 1001:ifid >, 11) NetPrefRecFieldInfoLegacy(netPrefRecFieldIPAddrIsDynamic
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip > NetPrefRecFieldInfoLegacy (netPrefRecFieldIPAddr, 1003, netPrefFieldTypeUInt32, 0, 0,< 1003:ipaddr >, 13) NetPrefRecFieldInfoLegacy(netPrefRecFieldDNSAddrIsDynamic
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns > NetPrefRecFieldInfoLegacy (netPrefRecFieldDNSAddrPrimary, 1005, netPrefFieldTypeUInt32, 0, 0,< 1005:pridns >, 13) NetPrefRecFieldInfoLegacy(netPrefRecFieldDNSAddrSecondary
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns >< 1006:secdns > NetPrefRecFieldInfoLegacy (netPrefRecFieldCloseWaitTime, 1007, netPrefFieldTypeUInt32, 0, 0,< 1007:cwtm >, 11) NetPrefRecFieldInfoLegacy(netPrefRecFieldInactivityTimer
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm > NetPrefRecFieldInfoLegacy (netPrefRecFieldEstablishmentTimeout, 1009, netPrefFieldTypeUInt16, 0, 0,< 1009:estbtm >, 13) NetPrefRecFieldInfoLegacy(netPrefRecFieldVJCompEnable
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr > NetPrefRecFieldInfoLegacy (netPrefRecFieldUseModem, 1011, netPrefFieldTypeUInt8, 0, 0,< 1011:usemdm >, 13) NetPrefRecFieldInfoLegacy(netPrefRecFieldServiceName
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam > NetPrefRecFieldInfoLegacy (netPrefRecFieldUsername, 1013, netPrefFieldTypeStr, 0, 0,< 1013:usrnam >, 13) NetPrefRecFieldInfoLegacy(netPrefRecFieldPassword
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw > NetPrefRecFieldInfoLegacy (netPrefRecFieldDomainName, 1015, netPrefFieldTypeStr, 0, 0,< 1015:domain >, 13) NetPrefRecFieldInfoLegacy(netPrefRecFieldHostTable
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab > NetPrefRecFieldInfoLegacy (netPrefRecFieldSMTPHost, 1017, netPrefFieldTypeStr, 0, 0,< 1017:smtphst >, 14) NetPrefRecFieldInfoLegacy(netPrefRecFieldPOPHost
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab >< 1018:pophst > NetPrefRecFieldInfoLegacy (netPrefRecFieldNewsServer, 1019, netPrefFieldTypeStr, 0, 0,< 1019:newssrv >, 14) NetPrefRecFieldInfoLegacy(netPrefRecFieldLoginScript
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab >< 1018:pophst >< 1020:script > NetPrefRecFieldInfoLegacy (netPrefRecFieldConnection, 1021, netPrefFieldTypeStr, 0, 0,< 1021:connnam >, 14) NetPrefRecFieldInfoLegacy(netPrefRecFieldDialPrefixEnable
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab >< 1018:pophst >< 1020:script >< 1022:enprefx > NetPrefRecFieldInfoLegacy (netPrefRecFieldCallWaitingEnable, 1023, netPrefFieldTypeUInt8, 0, 0,< 1023:encalwt >, 14) NetPrefRecFieldInfoLegacy(netPrefRecFieldCallingCardEnable
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab >< 1018:pophst >< 1020:script >< 1022:enprefx >< 1024:encalcd > NetPrefRecFieldInfoLegacy (netPrefRecFieldPulseDialEnable, 1025, netPrefFieldTypeUInt8, 0, 0,< 1025:enpulse >, 14) NetPrefRecFieldInfoLegacy(netPrefRecFieldPhoneNumber
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab >< 1018:pophst >< 1020:script >< 1022:enprefx >< 1024:encalcd >< 1026:phone > NetPrefRecFieldInfoLegacy (netPrefRecFieldDialPrefix, 1027, netPrefFieldTypeStr, 0, 0,< 1027:dlprefx >, 14) NetPrefRecFieldInfoLegacy(netPrefRecFieldCallWaitingString

Variables

  • netPrefFieldTypeUInt32
  • < 2:i32rsvd1 > netPrefFieldTypeUInt16
  • < 2:i32rsvd1 >< 4:bind > netPrefFieldTypeUInt32
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp > netPrefFieldTypeStr
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn > netPrefFieldTypeUInt8
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip > netPrefFieldTypeUInt32
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 > netPrefFieldTypeUInt16
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl > netPrefFieldTypeUInt32
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp > netPrefFieldTypeUInt32
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect > netPrefFieldTypeBin
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg > netPrefFieldTypeBin
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata > netPrefFieldTypeBin
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos > netPrefFieldTypeStr
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai > netPrefFieldTypeUInt8
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots > netPrefFieldTypeUInt8
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip > netPrefFieldTypeUInt8
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns > netPrefFieldTypeUInt32
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns >< 1006:secdns > netPrefFieldTypeUInt16
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm > netPrefFieldTypeUInt8
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr > netPrefFieldTypeStr
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam > netPrefFieldTypeStr
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw > netPrefFieldTypeStr
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab > netPrefFieldTypeStr
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab >< 1018:pophst > netPrefFieldTypeZStrList
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab >< 1018:pophst >< 1020:script > netPrefFieldTypeUInt8
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab >< 1018:pophst >< 1020:script >< 1022:enprefx > netPrefFieldTypeUInt8
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab >< 1018:pophst >< 1020:script >< 1022:enprefx >< 1024:encalcd > netPrefFieldTypeStr
  • < 2:i32rsvd1 >< 4:bind ><
    6:gtwytyp >< 8:apn ><
    10:mip >< 12:ha2 >< 14:1xtnl >< 16:aaasp >< 18:protect >< 20:pdpchg >< 22:crdata >< 24:1xrttqos >< 26:nai >< 28:vjslots >< 1002:dynip >< 1004:dyndns >< 1006:secdns >< 1008:inactm >< 1010:vjcmpr >< 1012:svcnam >< 1014:usrpsw >< 1016:hosttab >< 1018:pophst >< 1020:script >< 1022:enprefx >< 1024:encalcd >< 1026:phone > netPrefFieldTypeStr
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:59 2006 for Palm API Guide


NetPrefLibrary.h File Reference

Detailed Description

This is the main header file for the NetPref Library.

Version:
1.0
Date:
06/24/2002
USAGE MODEL: The model for using the NetPref library is that you "link" it in when needed and "unlink" it as you're done -- i.e. we don't leave it permanently installed as we do with some other libraries. This helps us avoid some unpleasant HotSync issues (such as trying to install over a protected database). For examples of linking and unlinking, grep for calls to NetPrefUtilNetPrefLibLink and NetPrefUtilNetPrefLibUnlink in NetworkPanel.c (Network panel src folder). NetPrefUtilNetPrefLibLink and NetPrefUtilNetPrefLibUnlink are defined in Viewer.c/h -- you may include the .c file with your code, or just copy and paste out of those functions.

Include dependency graph for NetPrefLibrary.h:

Defines

  • #define NETPREF_LIB_TRAP(trapNum) SYS_TRAP(trapNum)
  • #define NetPrefUtilLoginScriptLen(refNum, cxtP, scriptP)

Functions

  • Err NetPrefLibOpen (UInt16 refNum, struct NetPrefContextTypeTag **cxtPP)
  • Err NetPrefLibClose (UInt16 refNum, struct NetPrefContextTypeTag *cxtP)
  • Err NetPrefLibSleep (UInt16 refNum)
  • Err NetPrefLibWake (UInt16 refNum)
  • Err NetPrefLibVersionGet (UInt16 refNum, UInt32 *majorVerP, UInt32 *minorVerP, UInt32 *bugFixVerP)
  • Err NetPrefRecCountGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, UInt16 *countP)
  • Err NetPrefRecIDGetByIndex (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, UInt16 recIndex, UInt32 *recIDP)
  • Err NetPrefRecIndexGetByID (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, UInt32 recID, UInt16 *recIndexP)
  • Err NetPrefRecNew (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, UInt32 dupRecID, struct NetPrefRecordTypeTag **recPP)
  • Err NetPrefRecLoad (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, UInt32 recID, struct NetPrefRecordTypeTag **recPP)
  • Err NetPrefRecBindingErrorGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP)
  • Err NetPrefRecRelease (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag **recPP)
  • Err NetPrefRecSave (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP)
  • Boolean NetPrefRecIsAttached (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP)
  • Err NetPrefRecObjAlloc (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag **recPP)
  • Err NetPrefRecObjCopy (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *srcRecP, struct NetPrefRecordTypeTag *dstRecP)
  • Err NetPrefRecIDGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, UInt32 *recIDP)
  • Err NetPrefRecIndexGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, UInt16 *recIndexP)
  • Err NetPrefRecDelete (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, UInt32 recID)
  • Err NetPrefRecFieldGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, void **fieldValuePP, UInt32 *fieldLenP, NetPrefRecFieldViewType *viewFlagsP)
  • Err NetPrefRecFieldAttrsGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, NetPrefRecFieldAttrType *fieldAttrsP)
  • Err NetPrefRecFieldSet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, void *fieldValueP, UInt32 fieldLen)
  • Err NetPrefRecFieldViewSet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, NetPrefRecFieldViewType flagsToClear, NetPrefRecFieldViewType flagsToSet)
  • void NetPrefRecReadOnlyOverrideStart (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP)
  • void NetPrefRecReadOnlyOverrideEnd (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP)
  • Err NetPrefRecFieldSetDefine (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum *recFieldIDArrayP, UInt16 newNumFields, NetPrefRecFieldViewType *initialViewFlagsP, NetPrefFieldSetDefineOptionsType options)
  • Err NetPrefRecFieldAddToSet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, NetPrefRecFieldViewType *initialViewFlagsP)
  • Err NetPrefRecFieldSetDefineStd (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefSvcMediumEnum svcMedium, NetPrefRecFieldViewType *initialViewFlagsP, NetPrefFieldSetDefineOptionsType options)
  • Err NetPrefRecFieldSetGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum *recFieldIDArrayP, UInt16 numEntriesAvailable, UInt16 *numFieldsInSetP)
  • Err NetPrefRecIsDirty (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, UInt8 *isDirtyP)
  • void NetPrefRecDirtyFlagsReset (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP)
  • void NetPrefRecMarkDirty (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP)
  • Err NetPrefDefaultTargetGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, NetPrefSvcTargetEnum svcTarget, UInt32 *recIDP)
  • Err NetPrefDefaultTargetSet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, NetPrefSvcTargetEnum svcTarget, UInt32 recID)
  • Err NetPrefUpdateFromRadioNV (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, Boolean force)
  • Err NetPrefHandleHotSyncNotify (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, UInt16 cmd, void *cmdPBP)
  • Boolean NetPrefRecLongFieldGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, UInt32 *resultP, NetPrefRecFieldViewType *viewFlagsP)
  • Boolean NetPrefRecShortFieldGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, UInt16 *resultP, NetPrefRecFieldViewType *viewFlagsP)
  • Boolean NetPrefRecByteFieldGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, UInt8 *resultP, NetPrefRecFieldViewType *viewFlagsP)
  • NetPrefRecFieldViewType NetPrefRecFieldViewGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID)
  • Err NetPrefRecLongFieldSetAsFlags (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, UInt32 flagsToClear, UInt32 flagsToSet)
  • Err NetPrefRecFieldSetFromBinHandle (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, MemHandle dataH)
  • Err NetPrefRecFieldSetFromStrHandle (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, MemHandle dataH)
  • Err NetPrefRecFieldSetFromStrPtr (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, char *strP)
  • Boolean NetPrefRecConnectionInfoGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, UInt32 *portCreatorIDP, Boolean *isModemP)
  • NetPrefSvcMediumEnum NetPrefRecMediumDerive (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, UInt32 defWirelessDriverID)
  • Err NetPrefRecIPAddrFieldSet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, NetPrefRecFieldEnum recFieldID, UInt32 ipAddr)
  • UInt32 NetPrefUtilZStringListSizeGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, char *zStrListP)
  • void NetPrefRecPhoneStringCompose (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, struct NetPrefRecordTypeTag *recP, Char *destP, UInt16 maxLen)
  • NetPrefPlatformEnum NetPrefUtilPlatformIDGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP)
  • UInt32 NetPrefUtilDefWirelessDriverIDGet (UInt16 refNum, struct NetPrefContextTypeTag *cxtP, NetPrefPlatformEnum platform)

Define Documentation

#define NetPrefUtilLoginScriptLen | ( | refNum,
 |  | cxtP,
 |  | scriptP | )

Value:

NetPrefUtilZStringListSizeGet ((refNum), (cxtP), \
                                               (scriptP))

Function Documentation

Err NetPrefLibClose | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag * | cxtP
 | ) |

Standard library close routine.

Parameters:
refnum,: IN: Library reference number
Return values:
Err Library error code

Err NetPrefLibOpen | ( | UInt16 | refNum,
 |  | struct NetPrefContextTypeTag ** | cxtPP
 | ) |

Standard library open routine.

Parameters:
refnum,: IN: Library reference number
Return values:
Err Library error code

Err NetPrefLibSleep ( UInt16 refNum )

Standard library sleep routine.

Parameters:
refnum,: IN: Library reference number
Return values:
Err Library error code

Err NetPrefLibVersionGet | ( | UInt16 | refNum,
 |  | UInt32 * | majorVerP,
 |  | UInt32 * | minorVerP,
 |  | UInt32 * | bugFixVerP
 | ) |

Get Library API Version number.

Parameters:
refnum,: IN: Library reference number
majorVerP,: OUT: Major version number
minorVerP,: OUT: Minor version number
bugFixVerP,: OUT: Bug fix version number
Return values:
Err NetPref Library error code

Err NetPrefLibWake ( UInt16 refNum )

Standard library wake routine.

Parameters:
refnum,: IN: Library reference number
Return values:
Err Library error code

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:59 2006 for Palm API Guide


NetPrefLibTarget.h File Reference

Detailed Description

This is the target parameters file for the NetPref Library.

Version:
1.0
Date:
12/12/2001
We break out these definitions so that other portable modules could access them without PalmOS-specific definishions

Defines

  • #define netPrefLibCreatorID 'HsNP'
  • #define netPrefLibTypeID 'libr'
  • #define netPrefLibName "HsNetPrefLibrary.lib"

Define Documentation

#define netPrefLibCreatorID 'HsNP'

NetPref Library database creator

#define netPrefLibName "HsNetPrefLibrary.lib"

Internal library name which can be passed to SysLibFind()

#define netPrefLibTypeID 'libr'

Standard library database type

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:59 2006 for Palm API Guide


NetPrefLibTraps.h File Reference

Detailed Description

Trap definitions for the NetPref Library.

Version:
1.0
Date:
12/12/2001

Trap IDs

Trap IDs for the NetPref Library's public functions.

The order of the traps must be the same as the routines are listed in NetPrefLibDispatchTable.c.

  • #define netPrefLibTrapVersionGet (sysLibTrapCustom + 0)
  • #define netPrefLibTrapRecCountGet (sysLibTrapCustom + 1)
  • #define netPrefLibTrapRecIDGetByIndex (sysLibTrapCustom + 2)
  • #define netPrefLibTrapRecNew (sysLibTrapCustom + 3)
  • #define netPrefLibTrapRecLoad (sysLibTrapCustom + 4)
  • #define netPrefLibTrapRecRelease (sysLibTrapCustom + 5)
  • #define netPrefLibTrapRecSave (sysLibTrapCustom + 6)
  • #define netPrefLibTrapRecIDGet (sysLibTrapCustom + 7)
  • #define netPrefLibTrapRecIndexGet (sysLibTrapCustom + 8)
  • #define netPrefLibTrapRecDelete (sysLibTrapCustom + 9)
  • #define netPrefLibTrapRecFieldGet (sysLibTrapCustom + 10)
  • #define netPrefLibTrapRecFieldSet (sysLibTrapCustom + 11)
  • #define netPrefLibTrapDefaultTargetGet (sysLibTrapCustom + 12)
  • #define netPrefLibTrapDefaultTargetSet (sysLibTrapCustom + 13)
  • #define netPrefLibTrapRecObjCopy (sysLibTrapCustom + 14)
  • #define netPrefLibTrapRecIsDirty (sysLibTrapCustom + 15)
  • #define netPrefLibTrapRecIndexGetByID (sysLibTrapCustom + 16)
  • #define netPrefLibTrapRecFieldViewSet (sysLibTrapCustom + 17)
  • #define netPrefLibTrapRecFieldAttrsGet (sysLibTrapCustom + 18)
  • #define netPrefLibTrapUpdateFromRadioNV (sysLibTrapCustom + 19)
  • #define netPrefLibTrapRecFieldSetDefine (sysLibTrapCustom + 20)
  • #define netPrefLibTrapRecFieldSetGet (sysLibTrapCustom + 21)
  • #define netPrefLibTrapRecFieldSetDefineStd (sysLibTrapCustom + 22)
  • #define netPrefLibTrapRecFieldAddToSet (sysLibTrapCustom + 23)
  • #define netPrefLibTrapRecReadOnlyOverrideStart (sysLibTrapCustom + 24)
  • #define netPrefLibTrapRecReadOnlyOverrideEnd (sysLibTrapCustom + 25)
  • #define netPrefLibTrapRecDirtyFlagsReset (sysLibTrapCustom + 26)
  • #define netPrefLibTrapRecMarkDirty (sysLibTrapCustom + 27)
  • #define netPrefLibTrapRecObjAlloc (sysLibTrapCustom + 28)
  • #define netPrefLibTrapRecIsAttached (sysLibTrapCustom + 29)
  • #define netPrefLibTrapRecBindingErrorGet (sysLibTrapCustom + 30)
  • #define netPrefLibTrapHandleHotSyncNotify (sysLibTrapCustom + 31)
  • #define netPrefLibTrapRecShortFieldGet (sysLibTrapCustom + 32)
  • #define netPrefLibTrapRecByteFieldGet (sysLibTrapCustom + 33)
  • #define netPrefLibTrapRecFieldViewGet (sysLibTrapCustom + 34)
  • #define netPrefLibTrapRecLongFieldSetAsFlags (sysLibTrapCustom + 35)
  • #define netPrefLibTrapRecFieldSetFromBinHandle (sysLibTrapCustom + 36)
  • #define netPrefLibTrapRecFieldSetFromStrHandle (sysLibTrapCustom + 37)
  • #define netPrefLibTrapRecFieldSetFromStrPtr (sysLibTrapCustom + 38)
  • #define netPrefLibTrapRecConnectionInfoGet (sysLibTrapCustom + 39)
  • #define netPrefLibTrapRecMediumDerive (sysLibTrapCustom + 40)
  • #define netPrefLibTrapRecIPAddrFieldSet (sysLibTrapCustom + 41)
  • #define netPrefLibTrapUtilZStringListSizeGet (sysLibTrapCustom + 42)
  • #define netPrefLibTrapRecPhoneStringCompose (sysLibTrapCustom + 43)
  • #define netPrefLibTrapUtilPlatformIDGet (sysLibTrapCustom + 44)
  • #define netPrefLibTrapUtilDefWirelessDriverIDGet (sysLibTrapCustom + 45)
  • #define netPrefLibTrapRecLongFieldGet (sysLibTrapCustom + 46)
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:04:59 2006 for Palm API Guide


NetPrefLibTypes.h File Reference

Detailed Description

This file contains public data types exported by the NetPref Library.

Version:
1.0
Date:
12/12/2001

Include dependency graph for NetPrefLibTypes.h:

Data Structures

  • struct NetPrefGPRSQOSType
    NetPrefGPRSQOSType -- GPRS Quality Of Service (QOS) info. More...
  • struct NetPrefFallbackInfoType
    Fallback info structure. More...

Current library API version number

Returned by NetPrefLibVersionGet()
  • #define netPrefLibVersionMajor 0
  • #define netPrefLibVersionMinor 2
  • #define netPrefLibVersionBugFix 0

Required Macros for Record Field Identifier

Define the required macros and then include NetPrefLibFieldInfoTable.h in order to define the record field indentifier values (see NetPrefLibFieldInfoTable.h for usage notes and currently defined fieldIDs)
  • #define NetPrefRecFieldInfoPreamble()
  • #define NetPrefRecFieldInfoFIRST(fieldID, idValue) fieldID = idValue,
  • #define NetPrefRecFieldInfoGrpStart(fieldID, idValue) fieldID = idValue,
  • #define NetPrefRecFieldInfoGrpEnd(fieldID) fieldID,
  • #define NetPrefRecFieldInfoExtended(fieldID, idValue, type, maxSize, flags, tagText, tagSize) fieldID = idValue,
  • #define NetPrefRecFieldInfoLegacy(fieldID, idValue, type, maxSize, flags, tagText, tagSize) fieldID = idValue,
  • #define NetPrefRecFieldInfoLAST(fieldID) fieldID

Record File View Attributes

  • #define netPrefRecFieldViewRead 0x00000001UL
  • #define netPrefRecFieldViewWrite 0x00000002UL
  • #define netPrefRecFieldViewVisible 0x00000004UL
  • #define netPrefRecFieldViewEditable 0x00000008UL
  • #define netPrefRecFieldViewExternal 0x00000010UL
  • #define netPrefRecFieldViewCache 0x00000020UL
  • #define netPrefRecFieldViewPrivate 0x00000040UL

Record File Attributes

  • #define netPrefRecFieldAttrInSet 0x10000000UL
  • #define netPrefRecFieldAttrDirty 0x20000000UL

Defines

  • #define netPref1xRTTTunnelingDefault netPref1xRTTTunnelingReverse
  • #define netPrefRecFieldViewCurrentlyValidFlags
  • #define netPrefRecFieldViewClearAll 0xFFFFFFFFUL
  • #define netPrefMaxPhoneStringSize 80

Typedefs

  • typedef UInt16 NetPrefRecFieldEnum
  • typedef UInt32 NetPrefRecIDType
  • typedef UInt16 NetPrefFieldTypeEnum
  • typedef UInt16 NetPrefSvcMediumEnum
  • typedef UInt16 NetPrefSvcBindingEnum
  • typedef UInt16 NetPref1xRTTTunnelingEnum
  • typedef UInt16 NetPrefSvcTargetEnum
  • typedef UInt32 NetPrefRecFieldViewType
  • typedef UInt32 NetPrefRecFieldAttrType
  • typedef UInt32 NetPrefNetCloseWaitEnum
  • typedef UInt16 NetPrefNetIdleTimeoutEnum
  • typedef UInt32 NetPrefRecProtectionType
  • typedef UInt32 NetPrefSvcGatewayType
  • typedef UInt32 NetPrefFieldSetDefineOptionsType
  • typedef UInt8 NetPrefFallbackAlgrorithmEnum
  • typedef UInt8 NetPrefFallbackStatusFlagsType
  • typedef UInt16 NetPrefMutexStickyFBAStatusEnum
  • typedef UInt16 NetPrefPlatformEnum

Enumerations

  • enum
  • enum {
    netPrefFieldTypeStr = 1,
    netPrefFieldTypeUInt8 = 2,
    netPrefFieldTypeUInt16 = 3,
    netPrefFieldTypeUInt32 = 4,
    netPrefFieldTypeBin = 5,
    netPrefFieldTypeZStrList = 6
    }
  • enum {
    netPrefSvcMediumUnknown = 0,
    netPrefSvcMediumDialUp = 1,
    netPrefSvcMediumDirect = 2,
    netPrefSvcMedium1xRTT = 3,
    netPrefSvcMediumGPRS = 4,
    netPrefSvcMediumQNC = 5,
    netPrefSvcMediumGISDN = 6,
    netPrefSvcMediumGCSD = 7,
    netPrefSvcMediumCCSD = 8,
    netPrefSvcMediumOEM = 9,
    netPrefSvcMediumLAST
    }
  • enum {
    netPrefSvcBindingUnknown = 0,
    netPrefSvcBindingIOTA = 1,
    netPrefSvcBindingCCSM = 2,
    netPrefSvcBindingCustom = 3,
    netPrefSvcBindingLAST
    }
  • enum {
    netPref1xRTTTunnelingUnknown = 0,
    netPref1xRTTTunnelingReverse = 1,
    netPref1xRTTTunnelingForward = 2,
    netPref1xRTTTunnelingLAST
    }
  • enum {
    netPrefSvcTargetUnknown = 0,
    netPrefSvcTargetInternet = 1,
    netPrefSvcTargetWAP = 2,
    netPrefSvcTargetReserved1 = 3,
    netPrefSvcTargetMMS = 4,
    netPrefSvcTargetBrowser = 5,
    netPrefSvcTargetMail = 6,
    netPrefSvcTargetIM = 7,
    netPrefSvcTargetDownloads = 8,
    netPrefSvcTargetCorporate = 9,
    netPrefSvcTargetPictureMail = 10,
    netPrefSvcTargetLAST
    }
  • enum {
    netPrefNetCloseWaitEndOnPowerOff = 0xffffffffUL,
    netPrefNetCloseWaitMaintainSession = 0xfffffffeUL,
    netPrefNetCloseWaitCarrierDefault = 0xfffffffdUL
    }
  • enum { netPrefNetIdleTimeoutNever = (UInt16) 0 }
  • enum {
    netPrefRecProtectionDeletionMask = 0x00000007UL,
    netPrefRecProtectionDeletionAfterWarning = 0x0UL,
    netPrefRecProtectionDeletionNotAllowed = 0x1UL,
    netPrefRecProtectionDuplicationMask = (0x7UL << 3),
    netPrefRecProtectionDuplicationAllowed = (0x0UL << 3),
    netPrefRecProtectionDuplicationNotAllowed = (0x1UL << 3),
    netPrefRecProtectionEditingMask = (0x7UL << 6),
    netPrefRecProtectionEditingAllowed = (0x0UL << 6),
    netPrefRecProtectionEditingNotAllowed = (0x1UL << 6),
    netPrefRecProtectionEditingAfterWarning = (0x2UL << 6)
    }
  • enum {
    netPrefSvcGatewayUnknown = 0UL,
    netPrefSvcGatewayInternet = 0x00000001UL,
    netPrefSvcGatewayWAP = 0x00000002UL,
    netPrefSvcGatewayPrivate = 0x00000004UL,
    netPrefSvcGatewayMMS = 0x00000008UL,
    netPrefSvcGatewayBrowser = 0x00000010UL,
    netPrefSvcGatewayMail = 0x00000020UL,
    netPrefSvcGatewayIM = 0x00000040UL,
    netPrefSvcGatewayDownloads = 0x00000080UL,
    netPrefSvcGatewayCorporate = 0x00000100UL,
    netPrefSvcGatewayPictureMail = 0x00000200L,
    netPrefSvcGatewayLAST
    }
  • enum {
    netPrefFieldSetDefineOptionNone = 0,
    netPrefFieldSetDefineOptionKeepData = 0x00000001UL
    }
  • enum {
    netPrefFallbackAlgrorithmBasic = 0,
    netPrefFallbackAlgrorithmMutexSticky = 1,
    netPrefFallbackAlgrorithmLAST
    }
  • enum { netPrefFallbackStatusFlagInitialized = 0x01 }
  • enum {
    netPrefMutexStickyFBAStatusUnknown = 0,
    netPrefMutexStickyFBAStatusFailed = 1,
    netPrefMutexStickyFBAStatusSucceeded = 2
    }
  • enum {
    netPrefPlatformUnknown = 0,
    netPrefPlatformGSM = 1,
    netPrefPlatformCDMA = 2,
    netPrefPlatformLAST
    }

Define Documentation

#define netPref1xRTTTunnelingDefault netPref1xRTTTunnelingReverse

Default 1xRTT Tunneling value

#define netPrefMaxPhoneStringSize 80

Max size of a phone number, *not including* zero-terminator

#define netPrefRecFieldAttrDirty 0x20000000UL

R/O: set if the field's data or flags have been modified in the current instance of the record object

#define netPrefRecFieldAttrInSet 0x10000000UL

R/O: set if the field's data or flags are part of the record's field set.

#define netPrefRecFieldViewCache 0x00000020UL

the external field value is cached locally

#define netPrefRecFieldViewClearAll 0xFFFFFFFFUL

Special value to pass in the flagsToClear parameter to NetPrefRecFieldViewSet in order to clear all field view flags

#define netPrefRecFieldViewCurrentlyValidFlags

Value:

(   netPrefRecFieldViewRead     \
                      | netPrefRecFieldViewWrite    \
                      | netPrefRecFieldViewVisible  \
                      | netPrefRecFieldViewEditable \
                      | netPrefRecFieldViewExternal \
                      | netPrefRecFieldViewCache    \
                      | netPrefRecFieldViewPrivate)

#define netPrefRecFieldViewEditable 0x00000008UL

field value is user-editable

#define netPrefRecFieldViewExternal 0x00000010UL

Field value is stored exernally -- such as in the CCSM table, radio module's flash memory, etc., i.e. not in the NetPref database

#define netPrefRecFieldViewPrivate 0x00000040UL

PRESENTLY NOT RESPECTED; If set, do not display the actual value to the user

#define netPrefRecFieldViewRead 0x00000001UL

read allowed by application

#define netPrefRecFieldViewVisible 0x00000004UL

field value is user-visible

#define netPrefRecFieldViewWrite 0x00000002UL

write allowed by application

Typedef Documentation

typedef UInt16 NetPref1xRTTTunnelingEnum

1xRTT Tunneling identifiers (use with netPrefRecField1xRTTTunneling)

typedef UInt8 NetPrefFallbackAlgrorithmEnum

Fallback algorithm

typedef UInt32 NetPrefFieldSetDefineOptionsType

Options for NetPrefRecFieldSetDefineStd and NetPrefRecFieldSetDefine

typedef UInt16 NetPrefFieldTypeEnum

Field type identifiers

typedef UInt16 NetPrefMutexStickyFBAStatusEnum

Flags used in the "Mutex Sticky" fallback algoritm status structure.

typedef UInt32 NetPrefNetCloseWaitEnum

Special values used with netPrefRecFieldCloseWaitTime. Other, standard, values are expressed in milliseconds. IMPORTANT: Beginning with Palm OS 5.0, netPrefRecFieldInactivityTimer must be used to configure the idle timeout of the TCP/IP stack. The "CloseWait" settting is used to control NetLib's CloseWait behavior only

typedef UInt16 NetPrefNetIdleTimeoutEnum

Special values used with netPrefRecFieldInactivityTimer. Other, standard, values are expressed in seconds.

typedef UInt32 NetPrefRecFieldAttrType

Record field attributes (retrieved via NetPrefRecFieldAttrsGet)

typedef UInt16 NetPrefRecFieldEnum

Record field identifiers

typedef UInt32 NetPrefRecFieldViewType

Record field view attributes bitwise-or'ed together

typedef UInt32 NetPrefRecIDType

NetPref Record ID type

typedef UInt32 NetPrefRecProtectionType

Record protection settings -- used with netPrefRecFieldRecProtection

typedef UInt16 NetPrefSvcBindingEnum

Service Binding identifiers (use with netPrefRecFieldBinding);

typedef UInt32 NetPrefSvcGatewayType

Record Service gateway type -- used with netPrefRecFieldSvcGatewayType; 1 or more values can be bitwise or'ed together to mark a record as supporting those gateway types; absense of any service type falgs implies Internet.

NOTE: These values need to correlate with NetPrefSvcTargetEnum.

IMPORTANT: These settings are to be used for carrier-provisioned services only, and are applied by the system's configurator app!!! Others MUST treat these settings as read-only!

typedef UInt16 NetPrefSvcMediumEnum

Service Medium identifiers (used with netPrefRecFieldSvcMediumAlias)

typedef UInt16 NetPrefSvcTargetEnum

Service Target identifiers used with NetPrefDefaultTargetGet() and NetPrefDefaultTargetSet().

NOTE: These values need to correlate with NetPrefSvcGatewayType.

IMPORTANT: These settings are to be used for carrier-provisioned services only, and are applied by the system's configurator app!!! Others MUST treat these settings as read-only!

Enumeration Type Documentation

anonymous enum

Enumerator:
netPrefFieldTypeStr | ascii string -- size must include zero - terminator
netPrefFieldTypeBin | binary
netPrefFieldTypeZStrList | string list: list of zero-terminated strings terminated by empty string. Size must include zero-terminator

anonymous enum

Enumerator:
netPrefFieldSetDefineOptionNone Pass this value for "no options"

anonymous enum

Enumerator:
netPrefFallbackAlgrorithmBasic | Basic algorithm: each time: try primary; if fails, try fallback;
netPrefFallbackAlgrorithmMutexSticky | Mutually exclusive, sticky algorithm: The primary and fallback record MUST be cross-linked -- each MUST specify the other as its fallback; both records MUST also be tagged with this algorithm. Regardless of which of the cross-linked services is requested during login (unless "primary only" is requested -- see NetMaster API), the algorithm will attempt to connect with the one that succeeded last time. The first time or if both failed last time, it will try the requested service first. If the attempt fails, it will try the one specified as its fallback.

anonymous enum

Enumerator:
netPrefMutexStickyFBAStatusUnknown | Indicates that the last login status of the corresponding network service is unknown.
netPrefMutexStickyFBAStatusFailed | Indicates that the last login attempt using the corresponding network service failed.
netPrefMutexStickyFBAStatusSucceeded | Indicates that the last login attempt using the corresponding network service succeeded.

anonymous enum

Enumerator:
netPrefSvcMediumUnknown | reserve 0
netPrefSvcMediumDialUp | basic dial-up - communication driver selection determines service attributes [DEFAULT]
netPrefSvcMediumDirect | basic, non-modem type of connection
netPrefSvcMedium1xRTT | CDMA 3G PDP service
netPrefSvcMediumGPRS | GSM 2.5G PDP service
netPrefSvcMediumQNC | CDMA Quick Net Connect
netPrefSvcMediumGISDN | GSM ISDN over CSD service
netPrefSvcMediumGCSD | GSM circuit switched data service (AKA wireless dial-up)
netPrefSvcMediumCCSD | CDMA circuit switched data service (AKA wireless dial-up)
netPrefSvcMediumOEM | This service is a place-holder for an external OEM plugin
netPrefSvcMediumLAST | ALWAYS KEEP THIS ENTRY AT THE END!!!

anonymous enum

Enumerator:
netPrefSvcBindingUnknown | reserve 0
netPrefSvcBindingIOTA | Provisioned via IOTA
netPrefSvcBindingCCSM | Default Wireless profile based on the CCSM tables
netPrefSvcBindingCustom | Created by user or "user agent" on behalf of the user [DEFAULT]
netPrefSvcBindingLAST | ALWAYS KEEP THIS ENTRY AT THE END!!!

anonymous enum

Enumerator:
netPref1xRTTTunnelingUnknown | reserve 0
netPref1xRTTTunnelingReverse | reverse tunneling
netPref1xRTTTunnelingForward | forward tunneling
netPref1xRTTTunnelingLAST | ALWAYS KEEP THIS ENTRY AT THE END!!!

anonymous enum

Enumerator:
netPrefSvcTargetUnknown | reserve 0
netPrefSvcTargetInternet | provides access to the Internet
netPrefSvcTargetWAP | provides access to WAP
netPrefSvcTargetReserved1 | reserved
netPrefSvcTargetMMS | provides access to MMS
netPrefSvcTargetBrowser | provides access to Web via web browser
netPrefSvcTargetMail | provides access to e-mail
netPrefSvcTargetIM | provides access to Instant Messaging
netPrefSvcTargetDownloads | provides access to Downloads
netPrefSvcTargetCorporate | provides access to Corporate network
netPrefSvcTargetPictureMail | provides access to Picture Mail
netPrefSvcTargetLAST | ALWAYS KEEP THIS ENTRY AT THE END!!!

anonymous enum

Enumerator:
netPrefNetCloseWaitEndOnPowerOff | Use this value to configure the network interface to be shut down when the device (i.e. LCD screen) powers off.
netPrefNetCloseWaitMaintainSession | Use this value to configure the network interface to *not* be shut down when the device (i.e. LCD screen) powers off.
netPrefNetCloseWaitCarrierDefault | Use this value to configure the CloseWait behavior with the carrier- default value.

anonymous enum

Enumerator:
netPrefNetIdleTimeoutNever Never time out due to data idleness

anonymous enum

Enumerator:
netPrefRecProtectionDeletionMask | Record deletion options
netPrefRecProtectionDuplicationMask | Duplication options
netPrefRecProtectionEditingMask | Editing options

anonymous enum

Enumerator:
netPrefSvcGatewayUnknown | reserved
netPrefSvcGatewayInternet | Generic Internet "gateway"
netPrefSvcGatewayWAP | Generic WAP gateway
netPrefSvcGatewayPrivate | Application-specific "gateway"
netPrefSvcGatewayMMS | Generic MMS "gateway"
netPrefSvcGatewayBrowser | Web via web browser
netPrefSvcGatewayMail | e-mail
netPrefSvcGatewayIM | Instant Messaging
netPrefSvcGatewayDownloads | Downloads
netPrefSvcGatewayCorporate | Corporate network
netPrefSvcGatewayPictureMail | Picture Mail
netPrefSvcGatewayLAST | ALWAYS KEEP THIS ENTRY AT THE END!!!

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:00 2006 for Palm API Guide


PalmAudioPlayback.h File Reference

Detailed Description

Public 68K include file that supports the stopping of audio playback on Treo 600 and Treo 650 smartphones.

This header file and associated header files support the specific sound functionality of the Treo smartphones. You should use the Palm OS Sound Manager APIs for most of your work.

Notes: This header contains a notification to call for stopping any existing background audio playback.

Any application ( usually video capture ) that needs to stop and eventually resume audio playback should use this header. Stopping or resuming playback is done by throwing a notification.

Audio playback applications should register for this notification and stop playback when they get the stop action code. They can optionally resume action when they get a notification with a resume action code. However resume is not a mandatory feature neither for the calling application nor for the audio application. In other words, the audio application may never get a resume after a stop action code.

Usage for any application requesting stop of audio playback:

PalmAudioPlaybackRequestStop('cccc'); // to stop background playback PalmAudioPlaybackRequestResume('cccc'); // to resume background playback

The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application(ie, SysLibFind() returns a valid refnum). When the application is done with the library, it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal synchronization.

Include dependency graph for PalmAudioPlayback.h:

Data Structures

  • struct PalmAudioPlaybackNotifyEventTypeTag

PalmAudioPlayback information and notification

  • #define kPalmAudioPlaybackNotify1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)
  • #define kPalmAudioPlaybackNotifyVersion kPalmAudioPlaybackNotify1
  • #define kPalmAudioPlaybackCreator 'apbP'
  • #define kPalmAudioPlaybackNotifyEvent kPalmAudioPlaybackCreator

Audio playback action codes

  • #define kPalmAudioPlaybackActionCodeRequestStop ((PalmAudioPlaybackActionCodeType)1)
  • #define kPalmAudioPlaybackActionCodeRequestResume ((PalmAudioPlaybackActionCodeType)2)

Audio playback helper macros

  • #define PalmAudioPlaybackRequestStop(creator)
  • #define PalmAudioPlaybackRequestResume(creator)
  • #define PalmAudioPlaybackSendRequest(requestP, creator)

Typedefs

  • typedef UInt16 PalmAudioPlaybackActionCodeType
  • typedef PalmAudioPlaybackNotifyEventTypeTag PalmAudioPlaybackNotifyEventType

Define Documentation

#define kPalmAudioPlaybackActionCodeRequestResume ((PalmAudioPlaybackActionCodeType)2)

Playback resume action code.

#define kPalmAudioPlaybackActionCodeRequestStop ((PalmAudioPlaybackActionCodeType)1)

Playback stop action code.

#define kPalmAudioPlaybackCreator 'apbP'

PalmAudioPlayback creator ID.

#define kPalmAudioPlaybackNotifyEvent kPalmAudioPlaybackCreator

Playback notification event ID.

Applications playing audio should register for this notification and stop or optionally resume playback depending on the action code the application receives.

#define kPalmAudioPlaybackNotifyVersion kPalmAudioPlaybackNotify1

Version of the PalmAudioPlayback library.

#define PalmAudioPlaybackRequestResume ( creator )

Value:

{ \
        PalmAudioPlaybackNotifyEventType request = \
        { \
            kPalmAudioPlaybackNotifyVersion, \
            kPalmAudioPlaybackActionCodeRequestResume, \
            0 \
        }; \
        PalmAudioPlaybackSendRequest(&request, creator); \
    }
Request to resume playback. Any application that needs to request that audio playback be resumed should use this macro. "creator" is the creator id of the calling function.

#define PalmAudioPlaybackRequestStop ( creator )

Value:

{ \
        PalmAudioPlaybackNotifyEventType request = \
        { \
            kPalmAudioPlaybackNotifyVersion, \
            kPalmAudioPlaybackActionCodeRequestStop, \
            0 \
        }; \
        PalmAudioPlaybackSendRequest(&request, creator); \
    }
Request to stop playback. Any application that needs to request a stop of audio playback should use this macro. "creator" is the creator id of the calling function.

#define PalmAudioPlaybackSendRequest | ( | requestP,
 |  | creator | )

Value:

{ \
        SysNotifyParamType      notify; \
        MemSet(&notify, sizeof(SysNotifyParamType), 0); \
        notify.notifyType       = kPalmAudioPlaybackNotifyEvent; \
        notify.broadcaster      = creator; \
        notify.notifyDetailsP   = (void*)requestP; \
        SysNotifyBroadcast(&notify); \
    }
Actual broadcast of kPalmAudioPlaybackNotifyEvent notification. Used by Stop and Resume macros.

Typedef Documentation

typedef UInt16 PalmAudioPlaybackActionCodeType

Holds action codes for the kPalmAudioPlaybackNotifyEvent broadcast.

typedef struct PalmAudioPlaybackNotifyEventTypeTag PalmAudioPlaybackNotifyEventType

Audio playback notification structure.

Structure that is sent as part of notifyDetailsP when a kPalmAudioPlaybackNotifyEvent is thrown.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:01 2006 for Palm API Guide


PalmBGService.h File Reference

Detailed Description

Public 68K header file for palmOne Background Network Service Library.

Version:
1.0
This file contains the function prototypes and structures for the Background Service which lets users make a background network connection.

Include dependency graph for PalmBGService.h:

Data Structures

  • struct BGResult
    Structure containing Result of response for a protocol request. More...

Function Traps

  • #define bgTrapAPIVersion (sysLibTrapCustom+0)
  • #define bgTrapCancelRqst (sysLibTrapCustom+1)
  • #define bgTrapINetLibRqst (sysLibTrapCustom+3)
  • #define bgTrapNetLibRqst (sysLibTrapCustom+4)

Library Constants

  • #define bgServiceLibName "BGService.Lib"
  • #define bgServiceCreatorID 'asc9'
  • #define bgServiceType 'appl'

Error Codes

  • #define IBG_SUCCESS 0
  • #define IBG_ERRNOTPOSSIBLE 2
  • #define IBG_ERRTIMEOUT 3
  • #define IBG_ERRREQUEST 4
  • #define IBG_ERRRSPTOOBIG 6
  • #define IBG_ERRSHUTDOWN 7
  • #define IBG_ERRRQSTDONE 8
  • #define IBG_MAXBUFSZ 100

Typedefs

  • typedef UInt32(* BGRecvResponseFP )(UInt32 rqstId, BGResult *presult, MemHandle *responseH, UInt32 respSz, UInt32 *opaque)
    Background Request's Response Callback function.

Functions

  • Err BGServiceOpen (UInt16 libRefNum)
    Opens the Background Service library. This function should be called prior to calling the other Background Service functions.
  • Err BGServiceClose (UInt16 libRefNum)
    Closes the Background Service library. This function should be called after your application has finished with the Background Service library.
  • Err BGServiceVersion (UInt16 libRefNum, UInt32 *pversion)
    Returns the version number of Background Service.
  • Err BGServiceCancelRqst (UInt16 libRefNum, UInt32 rqstId)
    Cancels a current request identified by the Request id.
  • Err BGServiceINetRqst (UInt16 libRefNum, char *purl, char *ppostBuf, BGRecvResponseFP precvFunc, UInt32 opaque, MemHandle respH, UInt32 *prqstId)
    Perform a INetLib request via the HTTP POST command.
  • Err BGServiceNetRqst (UInt16 libRefNum, char *notUsed, char *pserver, UInt16 port, char *prqst, char *pterm, BGRecvResponseFP precvFunc, UInt32 opaque, UInt8 reserved, MemHandle respH, UInt32 *prqstId)
    Perform a NetLib request on the default network connection ( for now ).

Define Documentation

#define bgServiceCreatorID 'asc9'

Background services Creator ID.

#define bgServiceLibName "BGService.Lib"

Background services library name.

#define bgServiceType 'appl'

Background services Type.

#define IBG_ERRNOTPOSSIBLE 2

Return Value indicating on i705 that radio is NOT on or WebClipping is NOT configured in i705 Wireless panel.

#define IBG_ERRREQUEST 4

Return Value indicating an error occurred processing the request. If a network error occurred, look at the protocolErr and protocolErrString members in the returned BGResult value for details.

#define IBG_ERRRQSTDONE 8

Return Value indicating a request cannot be cancelled with BGServiceCancelRqst() because the request was already started.

#define IBG_ERRRSPTOOBIG 6

Return Value indicating the response handle passed with the request is not large enough to contain the response gotten from the server. In this case a partial response may be contained in the response handle, but it is truncated.

#define IBG_ERRSHUTDOWN 7

Return Value indicating the BGService cannot process the request due to a HotSync or systen reset occurring

#define IBG_ERRTIMEOUT 3

Return Value indicating the request made could not be completed because of a network timeout, or request took longer than 20 minutes to complete for BGServiceNetRqst() or greater than 2 minutes for BGServiceINetRqst().

#define IBG_MAXBUFSZ 100

Maximum size of protocolErrString.

#define IBG_SUCCESS 0

Return Value indicating success.

Typedef Documentation

typedef UInt32( * BGRecvResponseFP)(UInt32 rqstId, BGResult *presult, MemHandle *responseH, UInt32 respSz, UInt32 *opaque)

Background Request's Response Callback function.

Parameters:
rqstId | IN: Request id that identifies a particular request the response is for
presult | IN: Contains the response protocol error message if any.
responseH | IN: Handle to the response string.
respSz | IN: Size of response
opaque | IN: Opaque value passed back to the callback, can be used for userdata
Returns:
One of the IBG_xxx return codes defined above. Currently any return value is ignored.

Function Documentation

Err BGServiceCancelRqst | ( | UInt16 | libRefNum,
 |  | UInt32 | rqstId
 | ) |

Cancels a current request identified by the Request id.

Parameters:
libRefNum,: IN: Reference number of the library.
rqstId,: IN: Request ID of the BgRequest to be cancelled.
Returns:
IBG_SUCCESS on success, otherwise IBG_ERRRQSTDONE if request was not found or has begun already.

Err BGServiceClose ( UInt16 libRefNum )

Closes the Background Service library. This function should be called after your application has finished with the Background Service library.

Parameters:
libRefNum,: IN: Reference number of the Background Service library.
Returns:
The error code returned from the library. If this is errNone, the function was sucessful.
 err = BGServiceClose(bgServiceLibRefNum);

See also:
BGServiceOpen

Err BGServiceINetRqst | ( | UInt16 | libRefNum,
 |  | char * | purl,
 |  | char * | ppostBuf,
 |  | BGRecvResponseFP | precvFunc,
 |  | UInt32 | opaque,
 |  | MemHandle | respH,
 |  | UInt32 * | prqstId
 | ) |

Perform a INetLib request via the HTTP POST command.

Parameters:
libRefNum,: IN: Reference number of the library.
purl,: IN: Url of server to issue request to. Formatted for INetLibURLCrack command
ppostBuf,: IN: Any post data for request, formatted for INetLibSockHTTPReqSend command - No additional formatting is performed.
precvFunc,: IN: Response callback function
opaque,: IN: Opaque value passed back to callback routine when called
respH,: IN: Pre-allocated memory handle to hold response. Must be big enough to hold largest response ( for INet typically less than 10K )
prqstId,: IN: Returned id given to request for later identification or canceling
Returns:
IBG_SUCCESS if accepted, otherwise another error code defined above

Err BGServiceNetRqst | ( | UInt16 | libRefNum,
 |  | char * | notUsed,
 |  | char * | pserver,
 |  | UInt16 | port,
 |  | char * | prqst,
 |  | char * | pterm,
 |  | BGRecvResponseFP | precvFunc,
 |  | UInt32 | opaque,
 |  | UInt8 | reserved,
 |  | MemHandle | respH,
 |  | UInt32 * | prqstId
 | ) |

Perform a NetLib request on the default network connection ( for now ).

Parameters:
libRefNum,: IN: Reference number of the library.
notUsed,: IN: Always pass NULL.
pserver,: IN: Server to issue request to. Hostnames are looked up via DNS calls, although slows down requests. Better to use IP addresses if possible.
port,: IN: Port to make call on
prqst,: IN: Protocol specific string to make once connection is made to server.
pterm,: IN: Server response terminator to look for to know have gotten complete response from server, or 0 if don't have a terminator. Of course using a terminator greatly speeds up receiving response.
precvFunc,: IN: Response callback function
opaque,: IN: Opaque value passed back to callback routine when called
reserved,: IN: Reserved for future use, must always be 0
respH,: IN: Pre-allocated memory handle to hold response. Must be big enough to hold largest response ( for INet typically less than 10K )
prqstId,: IN: Returned id given to request for later identification or canceling
Returns:
IBG_SUCCESS if accepted, otherwise another error code defined above

Err BGServiceOpen ( UInt16 libRefNum )

Opens the Background Service library. This function should be called prior to calling the other Background Service functions.

Parameters:
libRefNum,: IN: Reference number of the Background Service library.
Returns:
The error code returned from the library. If this is errNone, the function was sucessful.
 UInt16 bgServiceLibRefNum = 0;
 err = SysLibFind(bgServiceLibName, &bgServiceLibRefNum);
 if( err == sysErrLibNotFound )
 {
     err = SysLibLoad(bgServiceType, bgServiceCreatorID, &bgServiceLibRefNum);
         if( !err ) {
             err = BGServiceOpen(bgServiceLibRefNum);
         }
 }

See also:
BGServiceClose

Err BGServiceVersion | ( | UInt16 | libRefNum,
 |  | UInt32 * | pversion
 | ) |

Returns the version number of Background Service.

Parameters:
libRefNum,: IN: Reference number of the library.
pversion,: IN: Pointer to version number returned
Returns:
Always IBG_SUCCESS

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:01 2006 for Palm API Guide


PalmCreators.h File Reference

Detailed Description

Contains Palm-specific creator codes.

Version:
1.0
Date:
02/29/2002
Temporary shim to the new filename and location.

Include dependency graph for PalmCreators.h:

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:02 2006 for Palm API Guide


PalmDisplayExtent.h File Reference

Detailed Description

Public API for the Display Extent Library.

Version:
1.0

Include dependency graph for PalmDisplayExtent.h:

Library type and creator

  • #define dexLibName "rotmgr"
  • #define dexLibCreator 'rotM'
  • #define dexLibType sysFileTLibrary
  • #define dexFtrNumVersion (0)

Library Traps

  • #define kDexLibTrapOpen sysLibTrapOpen
  • #define kDexLibTrapClose sysLibTrapClose
  • #define kDexLibTrapDexGetDisplayAddress (sysLibTrapCustom + 4)
  • #define kDexLibTrapDexGetDisplayDimensions (sysLibTrapCustom + 5)

Functions

  • void * DexGetDisplayAddress (UInt16 refnum)
    Get the physical screen buffer (Display Address).
  • void DexGetDisplayDimensions (UInt16 refnum, Coord *width, Coord *height, UInt16 *rowBytes)
    Get the physical screen width, height, and rowbytes.

Define Documentation

#define dexFtrNumVersion (0)

PalmDisplayExtent feature number.

#define dexLibCreator 'rotM'

PalmDisplayExtent Creator ID.

#define dexLibName "rotmgr"

PalmDisplayExtent library name.

#define dexLibType sysFileTLibrary

PalmDisplayExtent type.

Function Documentation

void* DexGetDisplayAddress ( UInt16 refnum )

Get the physical screen buffer (Display Address).

Parameters:
refnum,: IN: Reference number of the Display Extent Manager library.
Return values:
Returns a pointer to the physical screen buffer.
Remarks:
You should only use this function if direct screen access is required. This function returns a pointer to the physical display. If you need to do direct screen access in 90, 180, and 270 rotation, use this function. If you use the regular APIs (eg something like BmpGetBits(WinGetBimatp(WinDisplay()))) you would get a back buffer pointer instead and would not see anything until you force a screen copy of this back buffer. Note that the address points to the top-left corner of the device in potrait mode always.
      // this code draws 6400 red pixels in the screen.

        RGBColorType color = { 0, 255, 0, 0 };
        IndexedColorType index = WinRGBToIndex(&color);
        UInt8 *bufferP = (UInt8*)DexGetDisplayAddress(gDexLibRefNum);
        UInt32 x = 0;

        for( x = 0; x < 6400; x++)
             bufferP[x] = index;
 *

void DexGetDisplayDimensions | ( | UInt16 | refnum,
 |  | Coord * | width,
 |  | Coord * | height,
 |  | UInt16 * | rowBytes
 | ) |

Get the physical screen width, height, and rowbytes.

Parameters:
refnum,: IN: Reference number of the Display Extent Manager library.
width | IN: Pointer to the width of the screen.
height | IN: Pointer to the height of the screen.
rowBytes | IN: Pointer to the rowbytes of the screen.
Return values:
Nothing

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:02 2006 for Palm API Guide


PalmErrorBase.h File Reference

Detailed Description

Include file for Error Management.

Version:
1.0

Include dependency graph for PalmErrorBase.h:

Error Classes for OEM components

  • #define softGraffitErrorClass (oemErrorClass | 200)
  • #define statusBarErrorClass (oemErrorClass | 300)

Defines

  • #define oemErrorClass 0x7000

Define Documentation

#define oemErrorClass 0x7000

OEM/Licensee errors (0x7000-0x7EFF shared among ALL partners)

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:02 2006 for Palm API Guide


PalmFeatures.h File Reference

Detailed Description

Contains Palm-specific feature definitions.

Version:
1.0
Date:
02/29/2002
Temporary shim to the new filename and location.

Include dependency graph for PalmFeatures.h:

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:03 2006 for Palm API Guide


PalmGoLCD.h File Reference

Detailed Description

Public include header file for the GoLCD Library.

Version:
1.1
You can use the functions in this API to enable or disable fullscreen writing, enable and disable the Graffiti 2 shift indicator (GSI) as a control for full-screen writing, enable and disable Graffiti 2 inking, and even change the colors of Graffiti 2 inking and the GSI.

You can check whether the GoLCD Manager is installed by examining its feature set. Call FtrGet as follows:

 err = FtrGet (goLcdCreator, goLcdFtrNumVersion, &value);

Include dependency graph for PalmGoLCD.h:

Functions

  • Err GoLcdLibOpen (UInt16 libRefNum)
    Opens the GoLCD library. This function should be called prior to calling the other GoLCD functions.
  • Err GoLcdLibClose (UInt16 libRefNum)
    Closes the GoLCD library. This function should be called after your application has finished with the GoLCD library.
  • GoLcdStatusType GoLcdGetStatus (UInt16 libRefNum)
    Returns whether the GoLCD functionality is enabled, disabled, or not available on this device.
  • GoLcdStatusType GoLcdSetStatus (UInt16 libRefNum, GoLcdStatusType status)
    Enables or disables the GoLCD functionality.
  • void GoLcdGetInkState (UInt16 libRefNum, GoLcdInkStateType *stateP, GoLcdColorModeType *colorModeP, RGBColorType *rgbP)
    Returns the current state of GoLCD inking.
  • void GoLcdSetInkState (UInt16 libRefNum, GoLcdInkStateType state, GoLcdColorModeType colorMode, RGBColorType *rgbP)
    Sets the state of GoLCD inking.
  • void GoLcdGetGsiState (UInt16 libRefNum, GoLcdGsiStateType *stateP, GoLcdColorModeType *colorModeP, RGBColorType *rgbP)
    Returns the GSI state associated with GoLCD.
  • void GoLcdSetGsiState (UInt16 libRefNum, GoLcdGsiStateType state, GoLcdColorModeType colorMode, RGBColorType *rgbP)
    Sets the GSI state associated with GoLCD.
  • UInt32 GoLcdGetTimeout (UInt16 libRefNum, GoLcdModeType mode)
    Returns the length, in system ticks, of the time-out value of GoLCD.
  • UInt32 GoLcdSetTimeout (UInt16 libRefNum, GoLcdModeType mode, UInt32 ticks)
    Sets the length, in system ticks, of the time-out value of GoLCD.
  • void GoLcdGetBounds (UInt16 libRefNum, RectangleType *rectP)
    Returns the current bounds defined for use with GoLCD.
  • void GoLcdSetBounds (UInt16 libRefNum, RectangleType *rectP)
    Sets the bounds defined for use with GoLCD.

Function Documentation

void GoLcdGetBounds | ( | UInt16 | libRefNum,
 |  | RectangleType * | rectP
 | ) |

Returns the current bounds defined for use with GoLCD.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
rectP,: IN: Points to the returned rectangle.
Remarks:
GoLCD ignores any succession of pen events (a series of penDownEvents followed by a penUpEvent) if the initial penDownEvent occurs outside its bounds. By default, its bounds are the entire display and users can start drawing full-screen writing characters anywhere except for the right-most scroll bar and the menu bar area.
 RectangleType gCurrentBounds;
 GoLcdGetBounds(gGoLcdLibRefNum, &gCurrentBounds);

See also:
GoLcdSetBounds

void GoLcdGetGsiState | ( | UInt16 | libRefNum,
 |  | GoLcdGsiStateType * | stateP,
 |  | GoLcdColorModeType * | colorModeP,
 |  | RGBColorType * | rgbP
 | ) |

Returns the GSI state associated with GoLCD.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
stateP,: IN: Points to the returned GoLCD GSI state.
colorModeP,: IN: Points to the returned GoLCD color mode for GSI.
rgbP,: IN: Valid only if colorMode is set to goLcdColorOverride. Points to an RGB color value corresponding to the current color used for inking. (The RGBColorType is defined in the header file Bitmap.h.)
Remarks:
In normal operation, the GSI is drawn in the lower-right portion of the screen when the user enters the shift keystroke. The functionality of the GSI can be changed into an enable and disable control for GoLCD. This function returns the current state of the GSI.
 GoLcdGsiStateType gCurrentGoLcdGsiState = goLcdGsiNormal;
 GoLcdColorModeType gCurrentGoLcdColorMode = goLcdColorDefault;
 RGBColorType gCurrentColor;
 GoLcdGetGsiState(gGoLcdLibRefNum, &gCurrentGoLcdGsiState, &gCurrentGoLcdColorMode, &gCurrentColor);

See also:
GoLcdSetGsiState

void GoLcdGetInkState | ( | UInt16 | libRefNum,
 |  | GoLcdInkStateType * | stateP,
 |  | GoLcdColorModeType * | colorModeP,
 |  | RGBColorType * | rgbP
 | ) |

Returns the current state of GoLCD inking.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
stateP,: IN: Points to the returned GoLCD ink state.
colorModeP,: IN: Points to the returned GoLCD color mode for ink.
rgbP,: IN: Valid only if colorMode is set to goLcdColorOverride. Points to an RGB color value corresponding to the current color used for inking. (The RGBColorType is defined in the header file Bitmap.h.)
 GoLcdInkStateType gCurrentGoLcdInkState = goLcdInkDisabled;
 GoLcdColorModeType gCurrentGoLcdColorMode = goLcdColorDefault;
 RGBColorType gCurrentColor;
 GoLcdGetInkState(gGoLcdLibRefNum, &gCurrentGoLcdInkState, &gCurrentGoLcdColorMode, &gCurrentColor);

See also:
GoLcdSetInkState

GoLcdStatusType GoLcdGetStatus ( UInt16 libRefNum )

Returns whether the GoLCD functionality is enabled, disabled, or not available on this device.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
Return values:
GoLcdStatusType Returns the current GoLCD status.
See also:
GoLcdStatusType
 GoLcdStatusType gCurrentGoLcdStatus = goLcdNotAvailable;
 gCurrentGoLcdStatus = GoLcdGetStatus(gGoLcdLibRefNum);
 switch(gCurrentGoLcdStatus) {
     case goLcdDisabled:
         // GoLcd is disabled
         break;
     case goLcdEnabled:
         // GoLcd is Enabled
         break;
     case goLcdNotAvailable:
     default:
         // Not available
         break;
 }

See also:
GoLcdSetStatus

UInt32 GoLcdGetTimeout | ( | UInt16 | libRefNum,
 |  | GoLcdModeType | mode
 | ) |

Returns the length, in system ticks, of the time-out value of GoLCD.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
mode,: IN: Specifies the GoLCD mode.
Return values:
UInt32 Returns the length (in system ticks) of the time-out value.
Remarks:
GoLCD starts in goLcdPenTapMode. When a penDownEvent is received, a timer is started. If a penUpEvent is received before the timer reaches the time-out value for this mode, the pen events are passed on to the event handler for the application control. Otherwise, if the pen events exceed the time-out value and the x, y coordinates change significantly, GoLCD enters goLcdGraffitiMode and treats the pen events as a Graffiti 2 stroke.
The default time-out value for goLcdPenTapMode is 15 system ticks, or 150 milliseconds.
When it enters goLcdGraffitiMode, GoLCD continuously interprets all pen events as Graffiti 2 strokes. There is a time-out value associated with goLcdGraffitiMode, however. If it does not receive a new pen event within the allotted time, it returns to goLcdPenTapMode.
The default time-out value for goLcdGraffitiMode is 150 system ticks, or 1500 milliseconds.
 UInt32 gCurrentTimeout = GoLcdGetTimeout(gGoLcdLibRefNum, goLcdPenTapMode);

See also:
GoLcdSetTimeout

Err GoLcdLibClose ( UInt16 libRefNum )

Closes the GoLCD library. This function should be called after your application has finished with the GoLCD library.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
Return values:
Err The error code returned from the library. If this is errNone, the function was sucessful.
 err = GoLcdLibClose(gGoLcdLibRefNum);
 if( err == errNone )
     err = SysLibRemove(gGoLcdLibRefNum);

See also:
GoLcdLibOpen

Err GoLcdLibOpen ( UInt16 libRefNum )

Opens the GoLCD library. This function should be called prior to calling the other GoLCD functions.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
Return values:
Err The error code returned from the library. If this is errNone, the function was sucessful.
 UInt16 gGoLcdLibRefNum = 0;
 err = SysLibFind(goLcdLibName, &gGoLcdLibRefNum);
 if( err == sysErrLibNotFound )
 {
     err = SysLibLoad(goLcdLibType, goLcdLibCreator, &gGoLcdLibRefNum);
         if( !err ) {
             err = GoLcdLibOpen(gGoLcdLibRefNum);
         }
 }

See also:
GoLcdLibClose

void GoLcdSetBounds | ( | UInt16 | libRefNum,
 |  | RectangleType * | rectP
 | ) |

Sets the bounds defined for use with GoLCD.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
rectP,: IN: Points to the rectangle value to set.
Remarks:
GoLCD ignores any succession of pen events (a series of penDownEvents followed by a penUpEvent) if the initial penDownEvent occurs outside its bounds. By default, its bounds are the entire display and users can start drawing full-screen writing characters anywhere except for the right-most scroll bar and the menu bar area.
 RectangleType gNewBounds = { { 0, 0 } , { 50, 50 } };
 GoLcdGetBounds(gGoLcdLibRefNum, &gNewBounds);

See also:
GoLcdGetBounds

void GoLcdSetGsiState | ( | UInt16 | libRefNum,
 |  | GoLcdGsiStateType | state,
 |  | GoLcdColorModeType | colorMode,
 |  | RGBColorType * | rgbP
 | ) |

Sets the GSI state associated with GoLCD.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
state,: IN: Sets the GoLCD GSI state.
colorMode,: IN: Sets the GoLCD color mode for GSI.
rgbP,: IN: Valid only if colorMode is set to goLcdColorOverride. Points to an RGB color value corresponding to the current color used for inking. (The RGBColorType is defined in the header file Bitmap.h.)
Remarks:
In normal operation, the GSI is drawn in the lower-right portion of the screen when the user enters the shift keystroke. The functionality of the GSI can be changed into an enable and disable control for GoLCD. This function determines whether the GSI is converted into a GoLCD control. This setting will apply to all GSIs in any active form.
 RGBColorType gNewColor = { 0, 255, 0, 0}; // Red
 GoLcdSetGsiState(gGoLcdLibRefNum, goLcdGsiOverride, goLcdColorOverride, &gNewColor);

See also:
GoLcdGetGsiState

void GoLcdSetInkState | ( | UInt16 | libRefNum,
 |  | GoLcdInkStateType | state,
 |  | GoLcdColorModeType | colorMode,
 |  | RGBColorType * | rgbP
 | ) |

Sets the state of GoLCD inking.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
state,: IN: Sets the new GoLCD ink state.
colorMode,: IN: Sets the new GoLCD color mode for ink.
rgbP,: IN: Valid only if colorMode is set to goLcdColorOverride. Points to an RGB color value corresponding to the current color used for inking. (The RGBColorType is defined in the header file Bitmap.h.)
Remarks:
Inking, also known as echoing, refers to the drawing of Graffiti 2 strokes in the application area of the display.
 RGBColorType gNewColor = { 0, 255, 0, 0}; // Red
 GoLcdSetInkState(gGoLcdLibRefNum, goLcdInkEnabled, goLcdColorOverride, &gNewColor);

See also:
GoLcdGetInkState

GoLcdStatusType GoLcdSetStatus | ( | UInt16 | libRefNum,
 |  | GoLcdStatusType | status
 | ) |

Enables or disables the GoLCD functionality.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
status IN: Sets the new GoLCD status.
Return values:
GoLcdStatusType Returns the previous GoLCD status.
 GoLcdStatusType gPreviousGoLcdStatus = goLcdNotAvailable;
 gPreviousGoLcdStatus = GoLcdSetStatus(gGoLcdLibRefNum, goLcdEnabled);

See also:
GoLcdGetStatus

UInt32 GoLcdSetTimeout | ( | UInt16 | libRefNum,
 |  | GoLcdModeType | mode,
 |  | UInt32 | ticks
 | ) |

Sets the length, in system ticks, of the time-out value of GoLCD.

Parameters:
libRefNum,: IN: Reference number of the GoLCD library.
mode,: IN: Specifies the GoLCD mode.
ticks,: IN: The new time-out length in system ticks.
Return values:
UInt32 Returns the length (in system ticks) of the previous time-out value.
Remarks:
GoLCD starts in goLcdPenTapMode. When a penDownEvent is received, a timer is started. If a penUpEvent is received before the timer reaches the time-out value for this mode, the pen events are passed on to the event handler for the application control. Otherwise, if the pen events exceed the time-out value and the x, y coordinates change significantly, GoLCD enters goLcdGraffitiMode and treats the pen events as a Graffiti 2 stroke.
The default time-out value for goLcdPenTapMode is 15 system ticks, or 150 milliseconds.
When it enters goLcdGraffitiMode, GoLCD continuously interprets all pen events as Graffiti 2 strokes. There is a time-out value associated with goLcdGraffitiMode, however. If it does not receive a new pen event within the allotted time, it returns to goLcdPenTapMode.
The default time-out value for goLcdGraffitiMode is 150 system ticks, or 1500 milliseconds.
 UInt32 gPreviousTimeout = GoLcdSetTimeout(gGoLcdLibRefNum, goLcdPenTapMode, 100);

See also:
GoLcdGetTimeout

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:03 2006 for Palm API Guide


PalmGoLCDCommon.h File Reference

Detailed Description

Public common header file for the GoLCD Library.

Version:
1.0
This file contains the library constants and structures that hold different states of the fullscreen feature, graffiti indicators, inking and the colors.

Include dependency graph for PalmGoLCDCommon.h:

Library Constants

  • #define goLcdLibName "GoLcdLib"
  • #define goLcdLibType 'libr'
  • #define goLcdLibCreator 'GAny'
  • #define goLcdLibFtrNum 0

Feature Status

  • #define goLcdNotAvailable -1
  • #define goLcdDisabled 0
  • #define goLcdEnabled 1

Ink States

  • #define goLcdInkDisabled 0
  • #define goLcdInkEnabled 1

Function Traps

  • #define kGoLcdLibTrapOpen sysLibTrapOpen
  • #define kGoLcdLibTrapClose sysLibTrapClose
  • #define kGoLcdLibTrapGetStatus (sysLibTrapCustom)
  • #define kGoLcdLibTrapSetStatus (sysLibTrapCustom+1)
  • #define kGoLcdLibTrapGetInkState (sysLibTrapCustom+2)
  • #define kGoLcdLibTrapSetInkState (sysLibTrapCustom+3)
  • #define kGoLcdLibTrapGetTimeout (sysLibTrapCustom+4)
  • #define kGoLcdLibTrapSetTimeout (sysLibTrapCustom+5)
  • #define kGoLcdLibTrapGetBounds (sysLibTrapCustom+6)
  • #define kGoLcdLibTrapSetBounds (sysLibTrapCustom+7)
  • #define kGoLcdLibTrapGetGsiState (sysLibTrapCustom+8)
  • #define kGoLcdLibTrapSetGsiState (sysLibTrapCustom+9)

Defines

  • #define goLcdCreator 'GAny'
  • #define goLcdFtrNumVersion 0
  • #define goLcdNotifyStatusEvent 'GAny'
  • #define goLcdGraffitiMode 0
  • #define goLcdPenTapMode 1
  • #define goLcdModeCount 2
  • #define goLcdGsiNormal 0
  • #define goLcdGsiOverride 1
  • #define goLcdColorDefault 0
  • #define goLcdColorOverride 1
  • #define goLcdColorInverted 2
  • #define GoLcdLibAPIVersion (sysMakeROMVersion(3, 6, 0, sysROMStageBeta, 0))

Typedefs

  • typedef Int32 GoLcdStatusType
  • typedef Int32 GoLcdInkStateType
  • typedef UInt32 GoLcdModeType
  • typedef UInt32 GoLcdGsiStateType
  • typedef UInt32 GoLcdColorModeType

Define Documentation

#define goLcdColorDefault 0

Use the default color scheme.

#define goLcdColorInverted 2

Use only with ink color. Inverts the color of the display area beneath the Graffiti 2 stroke.

#define goLcdColorOverride 1

Use the specified color (passed in as a separate argument).

#define goLcdCreator 'GAny'

Feature creator ID

#define goLcdDisabled 0

GoLCD functionality is disabled.

#define goLcdEnabled 1

GoLCD functionality is enabled.

#define goLcdFtrNumVersion 0

Current version of the supported features

#define goLcdGraffitiMode 0

When it enters goLcdGraffitiMode, GoLCD continuously interprets all pen events as Graffiti 2 strokes. There is a timeout value associated with goLcdGraffitiMode, however. If it does not receive a new pen event within the allotted time, it returns to goLcdPenTapMode.
The default time-out value for goLcdGraffitiMode is 150 system ticks, or 1500 milliseconds.

#define goLcdGsiNormal 0

GSI is handled as normal.

#define goLcdGsiOverride 1

GoLCD overrides the GSI with its own control.

#define goLcdInkDisabled 0

GoLCD inking is disabled.

#define goLcdInkEnabled 1

GoLCD inking is enabled.

#define GoLcdLibAPIVersion (sysMakeROMVersion(3, 6, 0, sysROMStageBeta, 0))

Current library version

#define goLcdLibCreator 'GAny'

GoLCD creator ID.

#define goLcdLibFtrNum 0

GoLCd feature number.

#define goLcdLibName "GoLcdLib"

GoLCD library name.

#define goLcdLibType 'libr'

GoLCD library type.

#define goLcdModeCount 2

Two modes are currently supported

#define goLcdNotAvailable -1

GoLCD not available on this device.

#define goLcdNotifyStatusEvent 'GAny'

Notification code that applications can register for when the status of Full Screen Writing (GoLCD) is changed.

#define goLcdPenTapMode 1

GoLCD starts in goLcdPenTapMode. When a penDownEvent is received, a timer is started. If a penUpEvent is received before the timer reaches the time-out value for this mode, the pen events are passed on to the event-handler for the application control. Otherwise, if the pen events exceed the time-out value and the x, y coordinates change significantly, GoLCD enters goLcdGraffitiMode and treats the pen events as a Graffiti 2 stroke.
The default time-out value for goLcdPenTapMode is 15 system ticks, or 150 milliseconds.

Typedef Documentation

typedef UInt32 GoLcdColorModeType

GoLCD Color Mode. One of the following: goLcdColorDefault, goLcdColorOverride, goLcdColorInverted

typedef UInt32 GoLcdGsiStateType

GoLCD GSI State. One of the following: goLcdGsiNormal, goLcdGsiOverride

typedef Int32 GoLcdInkStateType

GoLCD Ink State. One of the following: goLcdInkDisabled, goLcdInkEnabled

typedef UInt32 GoLcdModeType

GoLCD Timeout Mode. One of the following: goLcdGraffitiMode, goLcdPenTapMode

typedef Int32 GoLcdStatusType

GoLCD Status. One of the following: goLcdNotAvailable, goLcdDisabled, goLcdEnabled

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:04 2006 for Palm API Guide


PalmHiResTime.h File Reference

Detailed Description

Exported High Resolution timer definitions.

Version:
1.0

Include dependency graph for PalmHiResTime.h:

Type and creator of the Library

  • #define kHiResTimeLibType 'libr'
  • #define kHiResTimeLibCreator 'pHRT'

Library versionning

  • #define kHiResTimeLibVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)
  • #define kHiResTimeLibVersion kCamLibVersion1

Library trap

  • #define kHRLibTrapTimerTicksPerSecond (sysLibTrapCustom)
  • #define kHRLibTrapTimerGetTime (sysLibTrapCustom+1)

Defines

  • #define CAM_LIB_TRAP(trapNum) SYS_TRAP(trapNum)
  • #define kHiResTimeLibName "HRTimer-Lib"
  • #define kHiResTimeErrorClass (oemErrorClass + 0x100)

Functions

  • Err HRTimeLibOpen (UInt16 refNum)
    Standard library open function.
  • Err HRTimeLibClose (UInt16 refNum)
    Standard library close function.
  • Err HRTimeLibTicksPerSecond (UInt16 refNum, UInt32 *ticksP)
    Custom library API functions.
  • Err HRTimeLibGetTime (UInt16 refNum, UInt32 *ticksP, UInt32 *rolloverP)

Define Documentation

#define kHiResTimeErrorClass (oemErrorClass + 0x100)

HiRes Timer result codes

#define kHiResTimeLibCreator 'pHRT'

database creator

#define kHiResTimeLibName "HRTimer-Lib"

Internal library name which can be passed to SysLibFind()

#define kHiResTimeLibType 'libr'

database type

Function Documentation

Err HRTimeLibClose ( UInt16 refNum )

Standard library close function.

Parameters:
refNum,: IN:
Return values:
Err error code.

Err HRTimeLibGetTime | ( | UInt16 | refNum,
 |  | UInt32 * | ticksP,
 |  | UInt32 * | rolloverP
 | ) |

Parameters:
refNum,: IN:
*ticksP,: IN:
*rolloverP,: IN:
Return values:
Err error code.

Err HRTimeLibOpen ( UInt16 refNum )

Standard library open function.

Parameters:
refNum,: IN:
Return values:
Err error code.

Err HRTimeLibTicksPerSecond | ( | UInt16 | refNum,
 |  | UInt32 * | ticksP
 | ) |

Custom library API functions.

Parameters:
refNum,: IN:
*ticksP,: IN:
Return values:
Err error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:04 2006 for Palm API Guide


PalmLaunchCodes.h File Reference

Detailed Description

Device specific launch codes.

Version:
1.0
Date:
03/20/2003

Include dependency graph for PalmLaunchCodes.h:

Data Structures

  • struct DevAppLaunchCmdGenericCallType
    For devAppLaunchCmdGenericCall. More...

Launch commands

  • #define devAppLaunchCmdCustomBase (sysAppLaunchCmdCustomBase + 1)
  • #define devAppLaunchCmdGenericCall (devAppLaunchCmdCustomBase + 1)
  • #define devAppLaunchCmdIncomingCall (devAppLaunchCmdCustomBase + 2)
  • #define devAppLaunchCmdCallerId (devAppLaunchCmdCustomBase + 3)
  • #define devAppLaunchCmdTelPowerOn (devAppLaunchCmdCustomBase + 4)
  • #define devAppLaunchMyFavorite (devAppLaunchCmdCustomBase + 4)
  • #define devAppLaunchCmdIncomingCallTest (devAppLaunchCmdCustomBase + 5)
  • #define devAppLaunchCmdSliderOpened (devAppLaunchCmdCustomBase + 6)
  • #define devAppLaunchCmdSliderClosed (devAppLaunchCmdCustomBase + 7)
  • #define devAppLaunchLauncherDUBegin (devAppLaunchCmdCustomBase + 8)
  • #define devAppLaunchLauncherDUEnd (devAppLaunchCmdCustomBase + 9)
  • #define devAppLaunchLPCM_DUBegin (devAppLaunchCmdCustomBase + 10)
  • #define devAppLaunchLPCM_DUEnd (devAppLaunchCmdCustomBase + 11)
  • #define devAppLaunchWithCodeCheck (devAppLaunchCmdCustomBase + 12)
  • #define sysAppLaunchCmdFromSetupApp (devAppLaunchCmdCustomBase + 13)

Applicable operation code values:

  • #define devAppLaunchGenericCallOpSubcall ((UInt8)1)
  • #define devAppLaunchGenericCallOpExit ((UInt8)2)
  • #define devAppLaunchGenericCallOpReturn ((UInt8)3)
  • #define devAppLaunchGenericCallOpCustomBase ((UInt8)0x80)

Applicable response code values:

  • #define devAppLaunchGenericCallRetAccepted ((UInt8)1)
  • #define devAppLaunchGenericCallRetRejected ((UInt8)2)

Define Documentation

#define devAppLaunchCmdCallerId (devAppLaunchCmdCustomBase + 3)

Custom action code base

#define devAppLaunchCmdCustomBase (sysAppLaunchCmdCustomBase + 1)

Custom action code base

#define devAppLaunchCmdGenericCall (devAppLaunchCmdCustomBase + 1)

Used when an application wants to launch another application, then to be re-launched when the service is finished

#define devAppLaunchCmdIncomingCall (devAppLaunchCmdCustomBase + 2)

Custom action code base

#define devAppLaunchCmdIncomingCallTest (devAppLaunchCmdCustomBase + 5)

Custom action code base

#define devAppLaunchCmdSliderClosed (devAppLaunchCmdCustomBase + 7)

Custom action code base

#define devAppLaunchCmdSliderOpened (devAppLaunchCmdCustomBase + 6)

Custom action code base

#define devAppLaunchCmdTelPowerOn (devAppLaunchCmdCustomBase + 4)

Custom action code base

#define devAppLaunchGenericCallOpCustomBase ((UInt8)0x80)

custom operation code base (custom codes begin at this value)

#define devAppLaunchGenericCallOpExit ((UInt8)2)

the launched code resource replies that it won't launch the caller back

#define devAppLaunchGenericCallOpReturn ((UInt8)3)

the sub-call is finished, the launched code resource is ready to launch the caller back

#define devAppLaunchGenericCallOpSubcall ((UInt8)1)

the sender wishes to launch the handler

#define devAppLaunchGenericCallRetAccepted ((UInt8)1)

request accepted by the handler

#define devAppLaunchGenericCallRetRejected ((UInt8)2)

request rejected by the handler

#define devAppLaunchLauncherDUBegin (devAppLaunchCmdCustomBase + 8)

Custom action code base

#define devAppLaunchLauncherDUEnd (devAppLaunchCmdCustomBase + 9)

Custom action code base

#define devAppLaunchLPCM_DUBegin (devAppLaunchCmdCustomBase + 10)

Custom action code base

#define devAppLaunchLPCM_DUEnd (devAppLaunchCmdCustomBase + 11)

Custom action code base

#define devAppLaunchMyFavorite (devAppLaunchCmdCustomBase + 4)

Custom action code base

#define devAppLaunchWithCodeCheck (devAppLaunchCmdCustomBase + 12)

Custom action code base

#define sysAppLaunchCmdFromSetupApp (devAppLaunchCmdCustomBase + 13)

Used to lock a Panel (panel cannot stop except with Done)

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:05 2006 for Palm API Guide


PalmLcdOverlay.h File Reference

Detailed Description

Exported LCD Overlay functions.

Version:
1.0

Include dependency graph for PalmLcdOverlay.h:

Data Structures

  • struct LcdOverlayLibSettingTag
    Generic settings For settings without manual values, only type is used. More...

To Define when building the library

  • #define OVLY_LIB_TRAP(trapNum) SYS_TRAP(trapNum)

Type and creator of the Library

  • #define kLcdOverlayLibType 'libr'
  • #define kLcdOverlayLibCreator 'Povl'

Internal library name which can be passed to SysLibFind()

  • #define kLcdOverlayLibName "LcdOverlayManager"

Library versionning

  • #define kLcdOverlayLibVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)
  • #define kLcdOverlayLibVersion kLcdOverlayLibVersion1

LCD Overlay result codes

(appErrorClass is reserved for 3rd party apps/libraries. It is defined in SystemMgr.h)
  • #define kLcdOverlayLibErrorClass (oemErrorClass + 0x200)
  • #define kLcdOverlayLibErrBadParam (kLcdOverlayLibErrorClass | 0x01)
  • #define kLcdOverlayLibErrNoMemory (kLcdOverlayLibErrorClass | 0x02)
  • #define kLcdOverlayLibErrNotOpen (kLcdOverlayLibErrorClass | 0x03)
  • #define kLcdOverlayLibErrStillOpen (kLcdOverlayLibErrorClass | 0x04)
  • #define kLcdOverlayLibErrInternal (kLcdOverlayLibErrorClass | 0x05)
  • #define kLcdOverlayLibErrNotSupported (kLcdOverlayLibErrorClass | 0x06)
  • #define kLcdOverlayLibErrNotCompatible (kLcdOverlayLibErrorClass | 0x07)

Command definition

  • #define kLcdOverlayLibCtrlFormatSet 0x01
  • #define kLcdOverlayLibCtrlFormatGet 0x02
  • #define kLcdOverlayLibCtrlFormatQuery 0x03
  • #define kLcdOverlayLibCtrlRectSet 0x04
  • #define kLcdOverlayLibCtrlRectGet 0x05
  • #define kLcdOverlayLibCtrlStart 0x06
  • #define kLcdOverlayLibCtrlDraw 0x07
  • #define kLcdOverlayLibCtrlStop 0x08

Overlay data format

  • #define kLcdOverlayLibDataFormatYCbCr444 0x02
  • #define kLcdOverlayLibDataFormatYCbCr422 0x04
  • #define kLcdOverlayLibDataFormatYCbCr420 0x08
  • #define kLcdOverlayLibDataFormatYCbCr444Planar 0x10
  • #define kLcdOverlayLibDataFormatYCbCr422Planar 0x20
  • #define kLcdOverlayLibDataFormatYCbCr420Planar 0x40
  • #define kLcdOverlayLibDataFormatRGB565 0x80

Library trap

  • #define kLcdOverlayLibTrapGetVersion (sysLibTrapCustom + 0)
  • #define kLcdOverlayLibTrapControl (sysLibTrapCustom + 1)

Typedefs

  • typedef UInt16 LcdOverlayLibControlType
  • typedef LcdOverlayLibSettingTag LcdOverlayLibSettingType
    Generic settings For settings without manual values, only type is used.
  • typedef LcdOverlayLibSettingTag LcdOverlayLibFormatType

Functions

  • Err LcdOverlayLibOpen (UInt16 refNum)
    Standard library open function.
  • Err LcdOverlayLibClose (UInt16 refNum)
    Standard library close function.
  • Err LcdOverlayLibSleep (UInt16 refNum)
  • Err LcdOverlayLibWake (UInt16 refNum)
  • Err LcdOverlayLibGetVersion (UInt16 refNum, UInt32 sdkVersion, UInt32 *libVersionP)
    Custom library API functions.
  • Err LcdOverlayLibControl (UInt16 refNum, LcdOverlayLibControlType cmdId, void *parameterP)

Define Documentation

#define kLcdOverlayLibCreator 'Povl'

database creator

#define kLcdOverlayLibCtrlDraw 0x07

Parameter as void*

#define kLcdOverlayLibCtrlFormatGet 0x02

Parameter as LcdOverlayLibFormatType*

#define kLcdOverlayLibCtrlFormatQuery 0x03

Parameter as LcdOverlayLibFormatType*

#define kLcdOverlayLibCtrlFormatSet 0x01

Parameter as LcdOverlayLibFormatType*

#define kLcdOverlayLibCtrlRectGet 0x05

Parameter as RectangleType* (low res coords)

#define kLcdOverlayLibCtrlRectSet 0x04

Parameter as RectangleType* (low res coords)

#define kLcdOverlayLibCtrlStart 0x06

No parameter

#define kLcdOverlayLibCtrlStop 0x08

No parameter

#define kLcdOverlayLibErrBadParam (kLcdOverlayLibErrorClass | 0x01)

invalid parameter

#define kLcdOverlayLibErrInternal (kLcdOverlayLibErrorClass | 0x05)

Internal error

#define kLcdOverlayLibErrNoMemory (kLcdOverlayLibErrorClass | 0x02)

Memory error

#define kLcdOverlayLibErrNotCompatible (kLcdOverlayLibErrorClass | 0x07)

Bad Version

#define kLcdOverlayLibErrNotOpen (kLcdOverlayLibErrorClass | 0x03)

library is not open

#define kLcdOverlayLibErrNotSupported (kLcdOverlayLibErrorClass | 0x06)

Unsupported function

#define kLcdOverlayLibErrStillOpen (kLcdOverlayLibErrorClass | 0x04)

returned from LcdOverlayLibClose() if the library is still open

#define kLcdOverlayLibType 'libr'

database type

Typedef Documentation

typedef struct LcdOverlayLibSettingTag LcdOverlayLibSettingType

Generic settings For settings without manual values, only type is used.

Function Documentation

Err LcdOverlayLibClose ( UInt16 refNum )

Standard library close function.

Parameters:
refNum,: IN:
Return values:
Err error code.

Err LcdOverlayLibControl | ( | UInt16 | refNum,
 |  | LcdOverlayLibControlType | cmdId,
 |  | void * | parameterP
 | ) |

Parameters:
refNum,: IN:
cmdId,: IN:
parameterP,: IN:
Return values:
Err error code.

Err LcdOverlayLibGetVersion | ( | UInt16 | refNum,
 |  | UInt32 | sdkVersion,
 |  | UInt32 * | libVersionP
 | ) |

Custom library API functions.

Parameters:
refNum,: IN:
sdkVersion,: IN:
libVersionP,: IN:
Return values:
Err error code.

Err LcdOverlayLibOpen ( UInt16 refNum )

Standard library open function.

Parameters:
refNum,: IN:
Return values:
Err error code.

Err LcdOverlayLibSleep ( UInt16 refNum )

Parameters:
refNum,: IN:
Return values:
Err error code.

Err LcdOverlayLibWake ( UInt16 refNum )

Parameters:
refNum,: IN:
Return values:
Err error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:05 2006 for Palm API Guide


PalmLED.h File Reference

Detailed Description

Palm's Generic LED dirver.

Version:
1.0
Pledlib.prc, version 1.0 This file contains the Generic LED driver defines. This driver is a standard libr driver that supports the BT notificaiton led. the interface follows the standard palm unser notification interface.

Future drivers will support multiple Led's.

NOTE: Make sure to check the version number for this driver implementation.

Include dependency graph for PalmLED.h:

Type and creator of the Library

  • #define kPalmLedName "PalmLed"
  • #define kPalmLedType sysFileTLibrary
  • #define kPalmLedCreator 'Pled'
  • #define kPalmLedModule 195

Library version

  • #define kPalmLedVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)
  • #define kPalmLedVersion kPalmLedVersion1

Standard library functions

  • #define kPalmLedTrapGetAttributes (sysLibTrapCustom+0)
  • #define kPalmLedTrapSetAttributes (sysLibTrapCustom+1)

Get/Set Attribute

  • #define kHALLEDPropertyUnderSleep 10
  • #define kHALLEDPropertySleepOn 1
  • #define kHALLEDPropertySleepPattern 2
  • #define kHALLEDPropertySleepReserve 4
  • #define kHALLEDPropertySleepColorRed 8
  • #define kHALLEDPropertySleepColorGreen 0x10
  • #define kHALLEDPropertySleepColorBlue 0x20
  • #define kHALLEDPropertySleepColorAmberWhite 0x40
  • #define kHALLEDCapcityUnderSleep 11
  • #define kHALLEDCapcitySleepOn 1
  • #define kHALLEDCapcitySleepPattern 2
  • #define kHALLEDCapcitySleepPatternSetting 4
  • #define kHALLEDCapcitySleepMultiColor 8

Functions

  • Err PalmLedOpen (UInt16 refnum)
    Standard library function.
  • Err PalmLedClose (UInt16 refnum)
    Standard library function.
  • Err PalmLedSleep (UInt16 refnum)
    Standard library function.
  • Err PalmLedWake (UInt16 refnum)
    Standard library function.
  • Err HALAttnGetPalmLedAttributes (UInt16 refnum, UInt32 attr, void *dataP)
    Standard library function.
  • Err HALAttnSetPalmLedAttributes (UInt16 refnum, UInt32 attr, void *dataP)
    Standard library function.

Define Documentation

#define kHALLEDCapcitySleepMultiColor 8

bit 3 multi-color available bit 4-31 reserved

#define kHALLEDCapcitySleepOn 1

dataP points to a UInt32 that indicates how flexible the LED during Sleep is, as follows: bit 0 ON during Sleep available

#define kHALLEDCapcitySleepPattern 2

bit 1 pattern when sleep available.

#define kHALLEDCapcitySleepPatternSetting 4

bit 2 pattern setting available

#define kHALLEDPropertySleepColorAmberWhite 0x40

bit 6 - amber/white bit 7-31 reserved

#define kHALLEDPropertySleepColorBlue 0x20

bit 5 - blue

#define kHALLEDPropertySleepColorGreen 0x10

bit 4 - green

#define kHALLEDPropertySleepColorRed 8

bit 3 - red

#define kHALLEDPropertySleepOn 1

dataP points to a UInt32 that indicates how flexible the LED during Sleep is, as follows: bit 0 - ON during sleep

#define kHALLEDPropertySleepPattern 2

bit 1 - pattern on

#define kHALLEDPropertySleepReserve 4

bit 2 - reserve

Function Documentation

Err HALAttnGetPalmLedAttributes | ( | UInt16 | refnum,
 |  | UInt32 | attr,
 |  | void * | dataP
 | ) |

Standard library function.

Parameters:
refnum,: IN:
attr,: IN:
dataP,: IN:
Return values:
Err error code.

Err HALAttnSetPalmLedAttributes | ( | UInt16 | refnum,
 |  | UInt32 | attr,
 |  | void * | dataP
 | ) |

Standard library function.

Parameters:
refnum,: IN:
attr,: IN:
dataP,: IN:
Return values:
Err error code.

Err PalmLedClose ( UInt16 refnum )

Standard library function.

Parameters:
refnum,: IN:
Return values:
Err error code.

Err PalmLedOpen ( UInt16 refnum )

Standard library function.

Parameters:
refnum,: IN:
Return values:
Err error code.

Err PalmLedSleep ( UInt16 refnum )

Standard library function.

Parameters:
refnum,: IN:
Return values:
Err error code.

Err PalmLedWake ( UInt16 refnum )

Standard library function.

Parameters:
refnum,: IN:
Return values:
Err error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:06 2006 for Palm API Guide


PalmNative.h File Reference

Detailed Description

Functions and macros to help building ARM code.

Version:
1.0
Date:
10/28/2002

  • #define false 0
  • #define true 1

Defines

  • #define NATIVE_CODE
  • #define INLINE inline
  • #define NULL 0

Typedefs

  • typedef unsigned char UInt8
  • typedef unsigned short UInt16
  • typedef unsigned long UInt32
  • typedef signed char Int8
  • typedef signed short Int16
  • typedef signed long Int32
  • typedef signed char Char
  • typedef unsigned char Boolean
  • typedef UInt16 Err
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:06 2006 for Palm API Guide


PalmNetServices.h File Reference

Detailed Description

NetServices provides a set of API to access 802.11.

Version:
1.0

Data Structures

  • struct Net80211DeviceInfo
    Device information concerning Hardware and Firmware information for the "adapter". More...
  • struct NetServicesProfileInfo
    Data returned from NetServicesProfileGetInfo. More...
  • struct NetServicesProfile
    Profile entries for SmartConnect. More...
  • struct NetServicesProfileV1
    Profile entries version 1. More...
  • struct NetServicesProfileOrder
    Priority order to smart connect. More...

Function Trap Numbers

  • #define NetServicesLibTrapGetHWAddr (sysLibTrapCustom+0)
  • #define NetServicesLibTrapStartScan (sysLibTrapCustom+1)
  • #define NetServicesLibTrapGetScanResults (sysLibTrapCustom+2)
  • #define NetServicesLibTrapGetChannel (sysLibTrapCustom+3)
  • #define NetServicesLibTrapGetPowerState (sysLibTrapCustom+4)
  • #define NetServicesLibTrapGetCommsQuality (sysLibTrapCustom+5)
  • #define NetServicesLibTrapSetRadioState (sysLibTrapCustom+6)
  • #define NetServicesLibTrapGetRadioState (sysLibTrapCustom+7)
  • #define NetServicesLibTrapGetDeviceInfo (sysLibTrapCustom+10)
  • #define NetServicesLibTrapGetChannelList (sysLibTrapCustom+11)
  • #define NetServicesLibTrapProfileGetInfo (sysLibTrapCustom+0x10)
  • #define NetServicesLibTrapProfileRead (sysLibTrapCustom+0x11)
  • #define NetServicesLibTrapProfileWrite (sysLibTrapCustom+0x12)
  • #define NetServicesLibTrapProfileAdd (sysLibTrapCustom+0x13)
  • #define NetServicesLibTrapProfileDelete (sysLibTrapCustom+0x14)
  • #define NetServicesLibTrapProfileSetOrder (sysLibTrapCustom+0x15)
  • #define NetServicesLibTrapProfileGetOrder (sysLibTrapCustom+0x16)
  • #define NetServicesLibTrapProfileFind (sysLibTrapCustom+0x17)

Defines

  • #define ShlLibName "NetServLib"
  • #define ShlCreatorID 'NETs'
  • #define ShlLibType 'libr'
  • #define kNetDriverDateLength 16
  • #define kNetFWNameLength 16
  • #define kNetSerialNumberLength 16
  • #define MAX_ACTIVE_PROFILES 32
  • #define END_OF_LIST 0xFFFF
  • #define PRIORITY_LIST_SIZE (sizeof(UInt16) * (MAX_ACTIVE_PROFILES + 1))
  • #define INVALID_INDEX 0xFFFF

Typedefs

  • typedef Net80211DeviceInfo * Net80211DeviceInfoP
    Device information concerning Hardware and Firmware information for the "adapter".
  • typedef NetServicesProfileInfo * NetServicesProfileInfoP
    Data returned from NetServicesProfileGetInfo.
  • typedef NetServicesProfile * NetServicesProfileP
    Profile entries for SmartConnect.
  • typedef NetServicesProfileV1 * NetServicesProfileV1P
    Profile entries version 1.
  • typedef NetServicesProfileOrder * NetServicesProfileOrderP
    Priority order to smart connect.

Functions

  • Err NetServicesGetHWAddr (UInt16 refnum, UInt8 *hwAddrP)
  • Err NetServicesStartScan (UInt16 refnum)
  • Err NetServicesGetScanResults (UInt16 refnum, UInt8 *scanResultsP, UInt32 *scanBufSizeP)
  • Err NetServicesGetChannel (UInt16 refnum, UInt16 *channelP)
  • Err NetServicesGetPowerState (UInt16 refnum, UInt16 *modeP)
  • Err NetServicesGetCommsQuality (UInt16 refNum, UInt8 *strengthP, UInt8 *qualityP)
  • Err NetServicesSetRadioState (UInt16 refNum, UInt32 enable)
  • Err NetServicesGetRadioState (UInt16 libRef, UInt32 *radioStateP)
  • Err NetServicesGetDeviceInfo (UInt16 refNum, Net80211DeviceInfoP storageP)
  • Err NetServicesGetChannelList (UInt16 refNum, UInt16 *channelP)
  • Err NetServicesProfileGetInfo (UInt16 libRef, NetServicesProfileInfoP infoP)
  • Err NetServicesProfileRead (UInt16 libRef, UInt16 profIndex, NetServicesProfileP profileP)
  • Err NetServicesProfileWrite (UInt16 libRef, UInt16 profIndex, NetServicesProfileP profileP)
  • Err NetServicesProfileDelete (UInt16 libRef, UInt16 profIndex)
  • Err NetServicesProfileAdd (UInt16 libRef, NetServicesProfileP profileP)
  • Err NetServicesProfileSetOrder (UInt16 libRef, NetServicesProfileOrderP orderP)
  • Err NetServicesProfileGetOrder (UInt16 libRef, NetServicesProfileOrderP orderP)
  • UInt16 NetServicesProfileFind (UInt16 libRef, Char *profNameP)

Define Documentation

#define END_OF_LIST 0xFFFF

End of list marker.

#define INVALID_INDEX 0xFFFF

Invalid index tag.

#define kNetDriverDateLength 16

Length for the driver date info string.

#define kNetFWNameLength 16

Length for the firmware name info string.

#define kNetSerialNumberLength 16

Length for the serial number info string.

#define MAX_ACTIVE_PROFILES 32

Maximum number of profiles.

#define PRIORITY_LIST_SIZE (sizeof(UInt16) * (MAX_ACTIVE_PROFILES + 1))

Priority list size.

#define ShlCreatorID 'NETs'

PalmNetServices creator ID.

#define ShlLibName "NetServLib"

PalmNetServices library name.

#define ShlLibType 'libr'

PalmNetServices library type.

Typedef Documentation

typedef struct Net80211DeviceInfo * Net80211DeviceInfoP

Device information concerning Hardware and Firmware information for the "adapter".

Revision information and product name data is returned.

typedef struct NetServicesProfileInfo * NetServicesProfileInfoP

Data returned from NetServicesProfileGetInfo.

typedef struct NetServicesProfileOrder * NetServicesProfileOrderP

Priority order to smart connect.

Provided for ease of reference.

typedef struct NetServicesProfile * NetServicesProfileP

Profile entries for SmartConnect.

typedef struct NetServicesProfileV1 * NetServicesProfileV1P

Profile entries version 1.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:06 2006 for Palm API Guide


palmOne_68K.h File Reference

Detailed Description

Version:
1.0
Date:
03/05/2004
Main palmOne Palm OS API Header file

This is the main header file for all third party developers. A developer would include if they wanted to use any of the palmOne components. This includes all the extentions, libraries and any app components. This file is for api calls that will work only in 68K code. This file automatically includes the Common/palmOneCommon.h file so there is no need for a developer to include that file seperately. This is the ONLY file that should be needed for any of the palmOne specific components. This file includes all the other header files for the 68K space relative to this directory. It has to stay at the top of the Incs tree.

Copyright (c) 2004 palmOne Inc., All Rights Reserved

Include dependency graph for palmOne_68K.h:

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:07 2006 for Palm API Guide


palmOneCamera.h File Reference

Detailed Description

Public 68K include file for camera support for Treo 650 devices. This version of the library adds functionality for Zire72, and Treo 650.

Version:
3.0
Notes: The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application(ie, SysLibFind() returns a valid refnum). When the application is done with the library, it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal synchronization.

Include dependency graph for palmOneCamera.h:

Defines

  • #define CAM_LIB_TRAP(trapNum) SYS_TRAP(trapNum)

Functions

  • Err CamLibOpen (UInt16 refNum)
  • Err CamLibClose (UInt16 refNum)
  • Err CamLibSleep (UInt16 refNum)
  • Err CamLibWake (UInt16 refNum)
  • Err CamLibGetVersion (UInt16 refNum, UInt32 sdkVersion, UInt32 *libVersionP)
  • Err CamLibControl (UInt16 refNum, CamLibControlType cmdId, void *parameterP)

Function Documentation

Err CamLibClose ( UInt16 refNum )

Closes the Camera Manager.

Library should always be unloaded with SysLibRemove() after CamLibClose() is called. See note at top of file.

Parameters:
refNum,: IN: Library reference number.
Return values:
Err Error code.

Err CamLibControl | ( | UInt16 | refNum,
 |  | CamLibControlType | cmdId,
 |  | void * | parameterP
 | ) |

Check or set a Camera property.

Parameters:
refNum,: IN: Library reference number.
cmdId,: IN: The control command used to check or set the camera property.
parameterP,: IN: Pointer to a parameter based on the control command type.
Return values:
Err Error code.

Err CamLibGetVersion | ( | UInt16 | refNum,
 |  | UInt32 | sdkVersion,
 |  | UInt32 * | libVersionP
 | ) |

Checks the version of the Camera Manager Library.

Parameters:
refNum,: IN: Library reference number.
sdkVersion,: IN: The version the application expects.
libVersionP,: OUT: The actual version of the library.
Return values:
Err Error code.

Err CamLibOpen ( UInt16 refNum )

Standard library open routine.

Library should always be loaded with SysLibLoad()(not SysLibFind()) before calling CamLibOpen(). See note at top of file.

Parameters:
refNum,: IN: Library reference number.
Return values:
Err Error code.

Err CamLibSleep ( UInt16 refNum )

Standard library sleep function.

Parameters:
refNum,: IN: Library reference number.
Return values:
Err Error code.

Err CamLibWake ( UInt16 refNum )

Standard library wake function.

Parameters:
refNum,: IN: Library reference number.
Return values:
Err Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:07 2006 for Palm API Guide


palmOneCameraCommon.h File Reference

Detailed Description

Public 68K common header file for camera support for Zire 72 and Treo 650 devices.

Version:
3.0
This file contains the library constants and error codes used in the APIs.

Data Structures

  • struct CamLibStatusTag
    Container for the camera status kCamLibStatus*. More...
  • struct CamLibBitmapInfoTag
    Bitmap info structure for every format except PalmBMPV4. Data starts after the parameters. More...
  • struct CamLibCaptureTag
    Capture settings structure. The callback is called with userDataP passed. More...
  • struct CamLibStreamTag
    Video stream structure. Used for capturing a video stream. More...
  • struct CamLibSettingTag
    Settings Capabilities structure. For settings without manual values, only type is used. More...
  • struct CamLibColorSpaceTag
    Color Space structure. More...

Library Versions

  • #define kCamLibVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)
  • #define kCamLibVersion2 sysMakeROMVersion(2, 0, 0, sysROMStageRelease, 0)
  • #define kCamLibVersion3 sysMakeROMVersion(3, 0, 0, sysROMStageRelease, 0)
  • #define kCamLibVersion kCamLibVersion3

Features

  • #define kCamLibFtrCaptureVersion 0
  • #define kCamLibCaptureHwrVersion 0x10
  • #define kCamLibFtrVersionNum 0

Error Codes

  • #define kCamLibErrorClass (oemErrorClass + 0x100)
  • #define kCamLibErrBadParam (kCamLibErrorClass | 0x01)
  • #define kCamLibErrNoMemory (kCamLibErrorClass | 0x02)
  • #define kCamLibErrNotOpen (kCamLibErrorClass | 0x03)
  • #define kCamLibErrStillOpen (kCamLibErrorClass | 0x04)
  • #define kCamLibErrInternal (kCamLibErrorClass | 0x05)
  • #define kCamLibErrNotSupported (kCamLibErrorClass | 0x06)
  • #define kCamLibErrNotCompatible (kCamLibErrorClass | 0x07)
  • #define kCamLibErrNoPower (kCamLibErrorClass | 0x08)
  • #define kCamLibErrAllFramesLocked (kCamLibErrorClass | 0x09)

Control Commands

  • #define kCamLibCtrlPowerOn 0x01
  • #define kCamLibCtrlPowerOff 0x02
  • #define kCamLibCtrlHardwareSettingsDlg 0x03
  • #define kCamLibCtrlPreviewStart 0x04
  • #define kCamLibCtrlPreviewStop 0x05
  • #define kCamLibCtrlCaptureGetBitmapInfo 0x06
  • #define kCamLibCtrlCapture 0x07
  • #define kCamLibCtrlStatusGet 0x08
  • #define kCamLibCtrlStatusQuery 0x09
  • #define kCamLibCtrlCaptureFormatSet 0x10
  • #define kCamLibCtrlCaptureFormatGet 0x11
  • #define kCamLibCtrlCaptureFormatQuery 0x12
  • #define kCamLibCtrlCaptureSizeSet 0x13
  • #define kCamLibCtrlCaptureSizeGet 0x14
  • #define kCamLibCtrlCaptureSizeQuery 0x15
  • #define kCamLibCtrlCaptureAreaSet 0x16
  • #define kCamLibCtrlCaptureAreaGet 0x17
  • #define kCamLibCtrlPreviewSizeSet 0x20
  • #define kCamLibCtrlPreviewSizeGet 0x21
  • #define kCamLibCtrlPreviewSizeQuery 0x22
  • #define kCamLibCtrlPreviewRectSet 0x23
  • #define kCamLibCtrlPreviewRectGet 0x24
  • #define kCamLibCtrlPreviewAreaSet 0x26
  • #define kCamLibCtrlPreviewAreaGet 0x27
  • #define kCamLibCtrlWhiteBalanceSet 0x30
  • #define kCamLibCtrlWhiteBalanceGet 0x31
  • #define kCamLibCtrlWhiteBalanceQuery 0x32
  • #define kCamLibCtrlLightingSet 0x33
  • #define kCamLibCtrlLightingGet 0x34
  • #define kCamLibCtrlLightingQuery 0x35
  • #define kCamLibCtrlZoomSet 0x36
  • #define kCamLibCtrlZoomGet 0x37
  • #define kCamLibCtrlZoomQuery 0x38
  • #define kCamLibCtrlEffectsSet 0x39
  • #define kCamLibCtrlEffectsGet 0x3A
  • #define kCamLibCtrlEffectsQuery 0x3B
  • #define kCamLibCtrlSaturationSet 0x3C
  • #define kCamLibCtrlSaturationGet 0x3D
  • #define kCamLibCtrlSaturationQuery 0x3E
  • #define kCamLibCtrlExposureSet 0x40
  • #define kCamLibCtrlExposureGet 0x41
  • #define kCamLibCtrlExposureQuery 0x42
  • #define kCamLibCtrlContrastSet 0x43
  • #define kCamLibCtrlContrastGet 0x44
  • #define kCamLibCtrlContrastQuery 0x45
  • #define kCamLibCtrlSharpnessSet 0x46
  • #define kCamLibCtrlSharpnessGet 0x47
  • #define kCamLibCtrlSharpnessQuery 0x48
  • #define kCamLibCtrlStreamFormatSet 0x50
  • #define kCamLibCtrlStreamFormatGet 0x51
  • #define kCamLibCtrlStreamFormatQuery 0x52
  • #define kCamLibCtrlStreamSizeSet 0x53
  • #define kCamLibCtrlStreamSizeGet 0x54
  • #define kCamLibCtrlStreamSizeQuery 0x55
  • #define kCamLibCtrlStreamStart 0x56
  • #define kCamLibCtrlStreamStop 0x57
  • #define kCamLibCtrlStreamWaitForFrame 0x58
  • #define kCamLibCtrlStreamUnlockFrame 0x59
  • #define kCamLibCtrlStreamBufNumSet 0x60
  • #define kCamLibCtrlStreamBufNumGet 0x61
  • #define kCamLibCtrlStreamBufNumQuery 0x62
  • #define kCamLibCtrlStreamPreviewSet 0x63
  • #define kCamLibCtrlStreamPreviewGet 0x64
  • #define kCamLibCtrlStreamPreviewQuery 0x65
  • #define kCamLibCtrlColorSpaceSet 0x66
  • #define kCamLibCtrlColorSpaceGet 0x67
  • #define kCamLibCtrlColorSpaceQuery 0x68
  • #define kCamLibCtrlShutterSpeedSet 0x69
  • #define kCamLibCtrlShutterSpeedGet 0x6A
  • #define kCamLibCtrlShutterSpeedQuery 0x6B
  • #define kCamLibCtrlApertureValueSet 0x6C
  • #define kCamLibCtrlApertureValueGet 0x6D
  • #define kCamLibCtrlApertureValueQuery 0x6E

Camera Status

  • #define kCamLibStatusPoweredOn 0x01
  • #define kCamLibStatusInPreview 0x02
  • #define kCamLibStatusInStillCapture 0x04
  • #define kCamLibStatusInVideoCapture 0x08

Capture Formats

  • #define kCamLibCaptureDataFormatRGB565 0x0002
  • #define kCamLibCaptureDataFormatYUV422 0x0004
  • #define kCamLibCaptureDataFormatYCbCr422 0x0008
  • #define kCamLibCaptureDataFormatYUV422Planar 0x0010
  • #define kCamLibCaptureDataFormatYCbCr422Planar 0x0020
  • #define kCamLibCaptureDataFormatYUV420 0x0040
  • #define kCamLibCaptureDataFormatYCbCr420 0x0080
  • #define kCamLibCaptureDataFormatYUV420Planar 0x0100
  • #define kCamLibCaptureDataFormatYCbCr420Planar 0x0200

Image Resolution

  • #define kCamLibImageSizeQQVGA 0x02
  • #define kCamLibImageSizeQVGA 0x04
  • #define kCamLibImageSizeVGA 0x08
  • #define kCamLibImageSizeSXGA 0x10
  • #define kCamLibImageSizeQCIF 0x20
  • #define kCamLibImageSizeCIF 0x40
  • #define kCamLibImageSizeSXGA960 0x10
  • #define kCamLibImageSizeSXGA1024 0x80

White Balance Settings

  • #define kCamLibWhiteBalanceAuto 0x02
  • #define kCamLibWhiteBalanceIndoor 0x04
  • #define kCamLibWhiteBalanceIncandescent 0x04
  • #define kCamLibWhiteBalanceOutdoor 0x08
  • #define kCamLibWhiteBalanceSunny 0x08
  • #define kCamLibWhiteBalanceExtra 0x10
  • #define kCamLibWhiteBalanceFluorescent 0x10
  • #define kCamLibWhiteBalanceCloudy 0x20
  • #define kCamLibWhiteBalanceShade 0x40
  • #define kCamLibWhiteBalanceTwilight 0x80

Exposure Level Settings

  • #define kCamLibExposureManual 0x01
  • #define kCamLibExposureAuto 0x02

Contrast Setting

  • #define kCamLibContrastManual 0x01

Zoom Setting

  • #define kCamLibZoomManual 0x01

Lighting Settings

  • #define kCamLibLightingNormal 0x02
  • #define kCamLibLightingLow 0x04

Special Effects

  • #define kCamLibEffectsNormal 0x02
  • #define kCamLibEffectsBlackWhite 0x04
  • #define kCamLibEffectsSepia 0x08
  • #define kCamLibEffectsBluish 0x10
  • #define kCamLibEffectsNegative 0x20

Saturation Level

  • #define kCamLibSaturationManual 0x01

Sharpness Level

  • #define kCamLibSharpnessManual 0x01

Stream Preview Settings

  • #define kCamLibStreamPreviewOn 0x01
  • #define kCamLibStreamPreviewOff 0x02

Color Space Settings

  • #define kCamLibColorSpace_sRGB 0x02
  • #define kCamLibColorSpaceUncalibrated 0x04

Shutter Speed Settings

  • #define kCamLibShutterSpeedManual 0x01
  • #define kCamLibShutterSpeedAuto 0x02

Aperture Value Settings

  • #define kCamLibApertureValueManual 0x01
  • #define kCamLibApertureValueAuto 0x02

Function Traps

  • #define kCamLibTrapGetVersion (sysLibTrapCustom + 0)
  • #define kCamLibTrapControl (sysLibTrapCustom + 1)

Defines

  • #define kCamLibType 'libr'
  • #define kCamLibCreator 'camL'
  • #define kCamLibName "CameraLib-camL"
  • #define kCamLibBufNumManual 0x01

Typedefs

  • typedef UInt16 CamLibControlType
  • typedef CamLibStatusTag CamLibStatusType
    Container for the camera status kCamLibStatus*.
  • typedef CamLibBitmapInfoTag CamLibBitmapInfoType
    Bitmap info structure for every format except PalmBMPV4. Data starts after the parameters.
  • typedef Err CamLibCaptureCallbackFunc (void *bufP, UInt32 size, void *userDataP)
    Image capture callback function pointer.
  • typedef CamLibCaptureTag CamLibCaptureType
    Capture settings structure. The callback is called with userDataP passed.
  • typedef CamLibStreamTag CamLibStreamType
    Video stream structure. Used for capturing a video stream.
  • typedef CamLibSettingTag CamLibBufNumType
  • typedef CamLibSettingTag CamLibSettingType
    Settings Capabilities structure. For settings without manual values, only type is used.
  • typedef CamLibColorSpaceTag CamLibColorSpaceType
    Color Space structure.
  • typedef CamLibSettingTag CamLibCaptureFormatType
  • typedef CamLibSettingTag CamLibImageSizeType
  • typedef CamLibSettingTag CamLibWhiteBalanceType
  • typedef CamLibSettingTag CamLibExposureType
  • typedef CamLibSettingTag CamLibContrastType
  • typedef CamLibSettingTag CamLibZoomType
  • typedef CamLibSettingTag CamLibLightingType
  • typedef CamLibSettingTag CamLibEffectsType
  • typedef CamLibSettingTag CamLibSaturationType
  • typedef CamLibSettingTag CamLibSharpnessType
  • typedef CamLibSettingTag CamLibStreamPreviewType
  • typedef CamLibSettingTag CamLibShutterSpeedType
  • typedef CamLibSettingTag CamLibApertureValueType

Define Documentation

#define kCamLibApertureValueAuto 0x02

Sets the aperture value automatically.

#define kCamLibApertureValueManual 0x01

Sets the aperture value manually through an additional passed parameter with kCamLibCtrlApertureValueSet.For manual values, all values are x1000 of real aperture value i.e. ap val 1.4 is 1400.

#define kCamLibBufNumManual 0x01

Video Stream Capture buffers

#define kCamLibCaptureDataFormatRGB565 0x0002

Capture format in 16-bit RGB.

#define kCamLibCaptureDataFormatYCbCr420 0x0080

Capture format in 16-bit YCbCr420.

#define kCamLibCaptureDataFormatYCbCr420Planar 0x0200

Capture format in 16-bit YCbCr420 Planar.

#define kCamLibCaptureDataFormatYCbCr422 0x0008

Capture format in 16-bit YCbCr422.

#define kCamLibCaptureDataFormatYCbCr422Planar 0x0020

Capture format in 16-bit YCbCr422 Planar.

#define kCamLibCaptureDataFormatYUV420 0x0040

Capture format in 16-bit YUV420.

#define kCamLibCaptureDataFormatYUV420Planar 0x0100

Capture format in 16-bit YUV420 Planar.

#define kCamLibCaptureDataFormatYUV422 0x0004

Capture format in 16-bit YUV422.

#define kCamLibCaptureDataFormatYUV422Planar 0x0010

Capture format in 16-bit YUV422 Planar.

#define kCamLibCaptureHwrVersion 0x10

Feature value if capture h/w present.

#define kCamLibColorSpace_sRGB 0x02

color space sRGB.

#define kCamLibColorSpaceUncalibrated 0x04

color space uncalibrated.

#define kCamLibContrastManual 0x01

Sets the contrast value manually. Use kCamLibCtrlContrastGet to determine the minimum and maximum values allowed and the unit of measurement.

#define kCamLibCreator 'camL'

Camera Manager library creator ID

#define kCamLibCtrlApertureValueGet 0x6D

Gets the Aperture Value. Parameter is CamLibApertureValueType*.

#define kCamLibCtrlApertureValueQuery 0x6E

Queries for the Aperture Value. Parameter is CamLibApertureValueType*.

#define kCamLibCtrlApertureValueSet 0x6C

Sets the Aperture Value. Parameter is CamLibApertureValueType*.

#define kCamLibCtrlCapture 0x07

Captures the current image. Parameter is CamLibCaptureType*.

#define kCamLibCtrlCaptureAreaGet 0x17

Gets the capture area. Parameter is RectangleType*. Low-res value.

#define kCamLibCtrlCaptureAreaSet 0x16

Sets the capture area. Parameter is RectangleType*. Low-res value.

#define kCamLibCtrlCaptureFormatGet 0x11

Gets the current capture format. Parameter is CamLibCaptureFormatType*.

#define kCamLibCtrlCaptureFormatQuery 0x12

Queries the capture formats available. Parameter is CamLibCaptureFormatType*.

#define kCamLibCtrlCaptureFormatSet 0x10

Sets the capture format. Parameter is CamLibCaptureFormatType*.

#define kCamLibCtrlCaptureGetBitmapInfo 0x06

Used to determine the captured image properties. Parameter is CamLibBitmapInfoType*.

#define kCamLibCtrlCaptureSizeGet 0x14

Gets the current capture size. Parameter is CamLibImageSizeType*.

#define kCamLibCtrlCaptureSizeQuery 0x15

Queries the capture sizes available. Parameter is CamLibImageSizeType*.

#define kCamLibCtrlCaptureSizeSet 0x13

Sets the capture size. Parameter is CamLibImageSizeType*.

#define kCamLibCtrlColorSpaceGet 0x67

Gets the Color Space. Parameter is CamLibColorSpaceType*.

#define kCamLibCtrlColorSpaceQuery 0x68

Queries for the Color Space. Parameter is CamLibColorSpaceType*.

#define kCamLibCtrlColorSpaceSet 0x66

Sets the Color Space. Parameter is CamLibColorSpaceType*.

#define kCamLibCtrlContrastGet 0x44

Gets the current contrast. Parameter is CamLibContrastType*.

#define kCamLibCtrlContrastQuery 0x45

Checks the contrast values available. Parameter is CamLibContrastType*.

#define kCamLibCtrlContrastSet 0x43

Sets the contrast. Parameter is CamLibContrastType*.

#define kCamLibCtrlEffectsGet 0x3A

Gets the current camera effect. Parameter is CamLibEffectsType*.

#define kCamLibCtrlEffectsQuery 0x3B

Queries the camera effects available. Parameter is CamLibEffectsType*.

#define kCamLibCtrlEffectsSet 0x39

Sets the camera effect. Parameter is CamLibEffectsType*.

#define kCamLibCtrlExposureGet 0x41

Gets the exposure. Parameter is CamLibExposureType*.

#define kCamLibCtrlExposureQuery 0x42

Checks the exposure values available. Parameter is CamLibExposureType*.

#define kCamLibCtrlExposureSet 0x40

Sets the exposure. Parameter is CamLibExposureType*.

#define kCamLibCtrlHardwareSettingsDlg 0x03

Displays the hardware camera settings dialog. No parameter.

#define kCamLibCtrlLightingGet 0x34

Gets the current lighting setting. Parameter is CamLibLightingType*.

#define kCamLibCtrlLightingQuery 0x35

Queries the lighting settings available. Parameter is CamLibLightingType*.

#define kCamLibCtrlLightingSet 0x33

Sets the lighting setting. Parameter is CamLibLightingType*.

#define kCamLibCtrlPowerOff 0x02

Powers off the camera module. No parameter.

#define kCamLibCtrlPowerOn 0x01

Powers on and initialize the camera module. No parameter.

#define kCamLibCtrlPreviewAreaGet 0x27

Gets the preview area. Parameter is RectangleType*. Low-res value.

#define kCamLibCtrlPreviewAreaSet 0x26

Sets the preview area. Parameter is RectangleType*. Low-res value.

#define kCamLibCtrlPreviewRectGet 0x24

Gets the preview rectangle. Parameter is RectangleType*. Low-res value.

#define kCamLibCtrlPreviewRectSet 0x23

Sets the preview rectangle. Parameter is RectangleType*. Low-res value.

#define kCamLibCtrlPreviewSizeGet 0x21

Gets the preview size. Parameter is CamLibImageSizeType*.

#define kCamLibCtrlPreviewSizeQuery 0x22

Queries the preview sizes available. Parameter is CamLibImageSizeType*.

#define kCamLibCtrlPreviewSizeSet 0x20

Sets the preview size. Parameter is CamLibImageSizeType*.

#define kCamLibCtrlPreviewStart 0x04

Starts the camera preview mode. No parameter.

#define kCamLibCtrlPreviewStop 0x05

Stops the camera preview mode. No parameter.

#define kCamLibCtrlSaturationGet 0x3D

Gets the current saturation level. Parameter is CamLibSaturationType*.

#define kCamLibCtrlSaturationQuery 0x3E

Queries the saturation range. Parameter is CamLibSaturationType*.

#define kCamLibCtrlSaturationSet 0x3C

Sets the saturation level. Parameter is CamLibSaturationType*.

#define kCamLibCtrlSharpnessGet 0x47

Gets the sharpness. Parameter is CamLibSharpnessType*.

#define kCamLibCtrlSharpnessQuery 0x48

Queries the sharpness range. Parameter is CamLibSharpnessType*.

#define kCamLibCtrlSharpnessSet 0x46

Sets the sharpness. Parameter is CamLibSharpnessType*.

#define kCamLibCtrlShutterSpeedGet 0x6A

Gets the Shutter Speed. Parameter is CamLibShutterSpeedType*.

#define kCamLibCtrlShutterSpeedQuery 0x6B

Queries for the Shutter Speed. Parameter is CamLibShutterSpeedType*.

#define kCamLibCtrlShutterSpeedSet 0x69

Sets the Shutter Speed. Parameter is CamLibShutterSpeedType*.

#define kCamLibCtrlStatusGet 0x08

Used to determine if a certain camera status is currently in effect. Parameter is CamLibStatusType*.

#define kCamLibCtrlStatusQuery 0x09

Used to determine if a certain camera status is available. Parameter is CamLibStatusType*.

#define kCamLibCtrlStreamBufNumGet 0x61

Gets the number of video frame buffers. Parameter is CamLibBufNumType*.

#define kCamLibCtrlStreamBufNumQuery 0x62

Queries the number of video frame buffer range. Parameter is CamLibBufNumType*.

#define kCamLibCtrlStreamBufNumSet 0x60

Sets the number of video frame buffers. Parameter is CamLibBufNumType*.

#define kCamLibCtrlStreamFormatGet 0x51

Gets the video stream format. Parameter is CamLibCaptureFormatType*.

#define kCamLibCtrlStreamFormatQuery 0x52

Queries the video stream formats available. Parameter is CamLibCaptureFormatType*.

#define kCamLibCtrlStreamFormatSet 0x50

Sets the video stream format. Parameter is CamLibCaptureFormatType*.

#define kCamLibCtrlStreamPreviewGet 0x64

Gets the stream preview status (on or off). Parameter is CamLibStreamPreviewType*.

#define kCamLibCtrlStreamPreviewQuery 0x65

Queries the stream preview available. Parameter is CamLibStreamPreviewType*.

#define kCamLibCtrlStreamPreviewSet 0x63

Sets the stream preview on or off. Parameter is CamLibStreamPreviewType*.

#define kCamLibCtrlStreamSizeGet 0x54

Gets the video stream size. Parameter is CamLibCaptureSizeType*.

#define kCamLibCtrlStreamSizeQuery 0x55

Queries the video stream sizes available. Parameter is CamLibCaptureSizeType*.

#define kCamLibCtrlStreamSizeSet 0x53

Sets the video stream size. Parameter is CamLibCaptureSizeType*.

#define kCamLibCtrlStreamStart 0x56

Starts the video stream capture. Parameter is CamLibStreamType*.

#define kCamLibCtrlStreamStop 0x57

Stops the video stream capture. Parameter is CamLibStreamType*.

#define kCamLibCtrlStreamUnlockFrame 0x59

Unlocks a video frame. Parameter is CamLibStreamType*.

#define kCamLibCtrlStreamWaitForFrame 0x58

Waits and locks a video frame. Parameter is CamLibStreamType*.

#define kCamLibCtrlWhiteBalanceGet 0x31

Gets the current white balance. Parameter is CamLibWhiteBalanceType*.

#define kCamLibCtrlWhiteBalanceQuery 0x32

Queries the white balances available. Parameter is CamLibWhiteBalanceType*.

#define kCamLibCtrlWhiteBalanceSet 0x30

Sets the white balance. Parameter is CamLibWhiteBalanceType*.

#define kCamLibCtrlZoomGet 0x37

Gets the current zoom value. Parameter is CamLibZoomType*.

#define kCamLibCtrlZoomQuery 0x38

Queries the zoom range. Parameter is CamLibZoomType*.

#define kCamLibCtrlZoomSet 0x36

Sets the zoom value. Parameter is CamLibZoomType*.

#define kCamLibEffectsBlackWhite 0x04

Balck & white effect

#define kCamLibEffectsBluish 0x10

Bluish effect

#define kCamLibEffectsNegative 0x20

Negative effect

#define kCamLibEffectsNormal 0x02

No special effects

#define kCamLibEffectsSepia 0x08

Sepia effect

#define kCamLibErrAllFramesLocked (kCamLibErrorClass | 0x09)

All video frames are locked.

#define kCamLibErrBadParam (kCamLibErrorClass | 0x01)

Invalid parameter.

#define kCamLibErrInternal (kCamLibErrorClass | 0x05)

Internal error.

#define kCamLibErrNoMemory (kCamLibErrorClass | 0x02)

Memory error.

#define kCamLibErrNoPower (kCamLibErrorClass | 0x08)

Camera not powered.

#define kCamLibErrNotCompatible (kCamLibErrorClass | 0x07)

Bad Version.

#define kCamLibErrNotOpen (kCamLibErrorClass | 0x03)

Library is not open.

#define kCamLibErrNotSupported (kCamLibErrorClass | 0x06)

Unsupported function.

#define kCamLibErrStillOpen (kCamLibErrorClass | 0x04)

Returned from CamLibClose() if the library is still open.

#define kCamLibExposureAuto 0x02

Sets the exposure level automatically.

#define kCamLibExposureManual 0x01

Sets the exposure level manually through an additional passed parameter with kCamLibCtrlExposureSet. For manual values, all values are x1000 of real exposure i.e. exp 1.5 is 1500.

#define kCamLibFtrCaptureVersion 0

Feature id for capture h/w.

#define kCamLibFtrVersionNum 0

Feature version if camera is present.

#define kCamLibImageSizeCIF 0x40

354 x 288 High Resolution.

#define kCamLibImageSizeQCIF 0x20

177 x 144 High Resolution.

#define kCamLibImageSizeQQVGA 0x02

160 x 120 High Resolution.

#define kCamLibImageSizeQVGA 0x04

320 x 240 High Resolution.

#define kCamLibImageSizeSXGA 0x10

1280x 960 High Resolution.

#define kCamLibImageSizeSXGA1024 0x80

1280x 1024 High Resolution.

#define kCamLibImageSizeSXGA960 0x10

1280x 960 High Resolution.

#define kCamLibImageSizeVGA 0x08

640 x 480 High Resolution.

#define kCamLibLightingLow 0x04

The camera is set for low light.

#define kCamLibLightingNormal 0x02

The camera is set for normal light.

#define kCamLibName "CameraLib-camL"

Camera Manager library name

#define kCamLibSaturationManual 0x01

Sets the saturation level manually

#define kCamLibSharpnessManual 0x01

Sets the sharpness level manually.

#define kCamLibShutterSpeedAuto 0x02

Sets the shutter speed automatically.

#define kCamLibShutterSpeedManual 0x01

Sets the shutter speed manually through an additional passed parameter with kCamLibCtrlShutterSpeedSet.

#define kCamLibStatusInPreview 0x02

Is the camera in preview mode?

#define kCamLibStatusInStillCapture 0x04

Is the camera in still capture?

#define kCamLibStatusInVideoCapture 0x08

Is the camera in video capture?

#define kCamLibStatusPoweredOn 0x01

Is the camera powered on?

#define kCamLibStreamPreviewOff 0x02

Stream preview off.

#define kCamLibStreamPreviewOn 0x01

Stream preview on.

#define kCamLibType 'libr'

Default library type

#define kCamLibWhiteBalanceAuto 0x02

Automatically determines the correct white balance for capturing and previewing images.

#define kCamLibWhiteBalanceCloudy 0x20

Sets the white balance for cloudy lighting during capture and preview of images

#define kCamLibWhiteBalanceExtra 0x10

Sets the white balance for flourescent indoor capturing and previewing of images

#define kCamLibWhiteBalanceFluorescent 0x10

Sets the white balance for flourescent indoor capturing and previewing of images

#define kCamLibWhiteBalanceIncandescent 0x04

Sets the white balance for indoor capturing and previewing of images

#define kCamLibWhiteBalanceIndoor 0x04

Sets the white balance for indoor capturing and previewing of images

#define kCamLibWhiteBalanceOutdoor 0x08

Sets the white balance for outdoor capturing and previewing of images

#define kCamLibWhiteBalanceShade 0x40

Sets the white balance for shady lighting during capture and preview of images

#define kCamLibWhiteBalanceSunny 0x08

Sets the white balance for outdoor capturing and previewing of images

#define kCamLibWhiteBalanceTwilight 0x80

Sets the white balance for twilight lighting during capture and preview of images

#define kCamLibZoomManual 0x01

Sets the zoom value manually. All values here are x1000 of real zoom i.e. x2 is 2000.

Typedef Documentation

typedef struct CamLibSettingTag CamLibApertureValueType

See also:
CamLibSettingTag

typedef struct CamLibBitmapInfoTag CamLibBitmapInfoType

Bitmap info structure for every format except PalmBMPV4. Data starts after the parameters.

typedef struct CamLibSettingTag CamLibBufNumType

See also:
CamLibSettingTag

typedef Err CamLibCaptureCallbackFunc(void *bufP, UInt32 size, void *userDataP)

Image capture callback function pointer.

Parameters:
bufP | I/O Pointer to the image buffer
size | IN Size of the buffer
userDataP | OUT Pointer to the user data
Returns:
Error code or zero if no error occurs

typedef struct CamLibSettingTag CamLibCaptureFormatType

See also:
CamLibSettingTag

typedef struct CamLibCaptureTag CamLibCaptureType

Capture settings structure. The callback is called with userDataP passed.

typedef struct CamLibColorSpaceTag CamLibColorSpaceType

Color Space structure.

typedef struct CamLibSettingTag CamLibContrastType

See also:
CamLibSettingTag

typedef UInt16 CamLibControlType

Camera Manager library control structure

typedef struct CamLibSettingTag CamLibEffectsType

See also:
CamLibSettingTag

typedef struct CamLibSettingTag CamLibExposureType

See also:
CamLibSettingTag

typedef struct CamLibSettingTag CamLibImageSizeType

See also:
CamLibSettingTag

typedef struct CamLibSettingTag CamLibLightingType

See also:
CamLibSettingTag

typedef struct CamLibSettingTag CamLibSaturationType

See also:
CamLibSettingTag

typedef struct CamLibSettingTag CamLibSettingType

Settings Capabilities structure. For settings without manual values, only type is used.

typedef struct CamLibSettingTag CamLibSharpnessType

See also:
CamLibSettingTag

typedef struct CamLibSettingTag CamLibShutterSpeedType

See also:
CamLibSettingTag

typedef struct CamLibStatusTag CamLibStatusType

Container for the camera status kCamLibStatus*.

typedef struct CamLibSettingTag CamLibStreamPreviewType

See also:
CamLibSettingTag

typedef struct CamLibStreamTag CamLibStreamType

Video stream structure. Used for capturing a video stream.

When used with WaitfForFram, bufP will contain the full frame buffer.

typedef struct CamLibSettingTag CamLibWhiteBalanceType

See also:
CamLibSettingTag

typedef struct CamLibSettingTag CamLibZoomType

See also:
CamLibSettingTag

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:08 2006 for Palm API Guide


palmOneCameraSlider.h File Reference

Detailed Description

Public 68K file for camera slider notification for Zire 71 devices.

Version:
1.0
Contains the Slider notification and status information.

Any application can register to the notification to be nofity when the slider is opened or closed. Any application can also get the status of the slider by checking the feature. This is specific to the camera slider. The notifyDetailsP param in SysNotifyParamType is null in the notification. Application should check the status of the slider by using the Feature.

Include dependency graph for palmOneCameraSlider.h:

Defines

  • #define kCamSliderVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageDevelopment, 0)
  • #define kCamSliderVersion kCamSliderVersion1
  • #define kCamSliderFlagsOpened 0x00000001
  • #define kCamSliderCreator 'cslP'
  • #define kCamSliderNotifyEvent kCamSliderCreator
  • #define kCamSliderFtrVersionNum 0
  • #define kCamSliderFtrFlagsNum 1

Define Documentation

#define kCamSliderCreator 'cslP'

Camera Slider creator ID.

#define kCamSliderFlagsOpened 0x00000001

Feature for testing if the slider is open.

#define kCamSliderFtrFlagsNum 1

Feature value should be kCamSliderFlagsOpened or 0.

#define kCamSliderFtrVersionNum 0

Feature value should be kCamSliderVersion.

#define kCamSliderNotifyEvent kCamSliderCreator

Notification creator.

#define kCamSliderVersion kCamSliderVersion1

Version information for the camera slider.

#define kCamSliderVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageDevelopment, 0)

Version information for the camera slider.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:08 2006 for Palm API Guide


palmOneCodecFormat.h File Reference

Detailed Description

Public 68K common header file for Codec Plugin Manager API - Codec Formats.

Version:
1.0
This file contains the list of known codecs. The codecs listed below may not be implemented yet. Each format is identified with a 4-byte ID as an attempt to avoid collision and be human readable.

Include dependency graph for palmOneCodecFormat.h:

Data Structures

  • struct PalmImageParamType
    RAW image format parameters. More...
  • struct PalmImagePlanarType
    Planar image structure, passed during EncodeDecode. More...
  • struct PalmAudioPCMParamType
    PCM format parameters. More...
  • struct PalmAudioADPCMParamType
    IMA-ADPCM format parameters. More...
  • struct PalmAudioAACParamType
    AAC format parameters. More...
  • struct PalmAudioAACDecParamType
    AAC decoding parameters. More...
  • struct AacFileRef
  • struct PalmAudioAMRParamType
  • struct PalmAudioQCELPParamType
  • struct PalmAudioQCELPDecParamType
  • struct PalmAudioMP2ParamType
    MPEG-1 audio decoding parameters. More...
  • struct PalmFileFormatParamType
    File format parameters. More...
  • struct PalmImageBMPParamType
    BMP format parameters. More...
  • struct PalmImageJPEGEncodeParamType
    JPEG format encoding parameters. More...
  • struct PalmImageGIFFrameParamType
    GIF frame parameters. More...
  • struct PalmImageINDEXParamType
    Index image parameters. More...
  • struct PalmVideoMPEG1DecodeParamType
    MPEG-1 video decoding parameters. More...
  • struct PalmVideoMPEG4EncodeParamType
    MPEG-4 video format encoding parameters. More...
  • struct PalmVideoMPEG4DecodeParamType
    MPEG-4 video format decoding parameters. More...
  • struct PalmVideoAVCDecodeParamType
    AVC/H264 video format decoding parameters. More...
  • struct PalmVideoAVCCustomGetInfoType
    AVC/H264 Custom Control API structure for GetInfo about frame. More...
  • struct PalmVideoAVCCustomGetDecodedFrameType
    AVC/H264 Custom Control API structure for getting a decoded frame. More...
  • struct PalmVideoAVCCustomSetCropModeType
    AVC/H264 Custom Control API structure for getting a decoded frame. More...
  • struct PalmVideoAVCOutputBufferType
    AVC/H264 video format decoding parameters. More...

Audio Codecs

  • #define palmCodecAudioPCM 'PCM1'
  • #define palmCodecAudioAAC 'DAAC'
  • #define palmCodecAudioMP1 'MPG1'
  • #define palmCodecAudioMP2 'MPG2'
  • #define palmCodecAudioMP3 'MPG3'
  • #define palmCodecAudioVORBIS 'OGGV'
  • #define palmCodecAudioIMA_ADPCM 'APCM'
  • #define palmCodecAudioDVI_ADPCM 'DPCM'
  • #define palmCodecAudioALAW 'ALAW'
  • #define palmCodecAudioULAW 'ULAW'

Speech Codecs

  • #define palmCodecAudioAMR 'AMRS'
  • #define palmCodecAudioQCELP 'QCLP'
  • #define palmCodecAudioG711 'G711'
  • #define palmCodecAudioG722 'G722'
  • #define palmCodecAudioG726 'G726'
  • #define palmCodecAudioG728 'G728'

Video Codecs

  • #define palmCodecVideoMPEG4 'MPG4'
  • #define palmCodecVideoMPEG1 'Mpg1'
  • #define palmCodecVideoMPEG2 'Mpg2'
  • #define palmCodecVideoH263 'H263'
  • #define palmCodecVideoMJPEG 'MJPG'
  • #define palmCodecVideoDIVX 'DivX'
  • #define palmCodecVideoXVID 'XviD'
  • #define palmCodecVideoAVC 'AVCd'

Text Codecs

  • #define palmCodecText3G '3GTX'

Still Images Codecs

  • #define palmCodecImageJPEG 'JPEG'
  • #define palmCodecImageGIF87a 'GIF7'
  • #define palmCodecImageGIF89a 'GIF9'
  • #define palmCodecImagePNG 'PNGI'
  • #define palmCodecImageWBMP 'WBMP'
  • #define palmCodecImageTIFF 'TIFF'

Image File Formats

  • #define palmCodecImageJPEGFile 'JPEF'
  • #define palmCodecImageGIF87aFile 'GI7F'
  • #define palmCodecImageGIF89aFile 'GI9F'
  • #define palmCodecImagePNGFile 'PNGF'
  • #define palmCodecImageWBMPFile 'WBMF'
  • #define palmCodecImageTIFFFile 'TFFF'

Defines

  • #define palmCodecImageBase 'IM00'
  • #define MAX_PLANE_COUNT 5

Typedefs

  • typedef struct AacFileRef * AacFileRefPtr

Enumerations

  • enum {
    palmCodecImageARGB32 = palmCodecImageBase,
    palmCodecImageRGBA32,
    palmCodecImageRGB32,
    palmCodecImageRGB888,
    palmCodecImageRGB888Planar,
    palmCodecImageRGB565,
    palmCodecImageRGB555,
    palmCodecImageBGRA32,
    palmCodecImageBGR32,
    palmCodecImageBGR888,
    palmCodecImageBGR565,
    palmCodecImageBGR555,
    palmCodecImageYUV444,
    palmCodecImageYUV422,
    palmCodecImageYUV420,
    palmCodecImageYUV411,
    palmCodecImageYUV211,
    palmCodecImageYUV444Planar,
    palmCodecImageYUV422Planar,
    palmCodecImageYUV420Planar,
    palmCodecImageYUV411Planar,
    palmCodecImageYUV211Planar,
    palmCodecImageYCbCr444,
    palmCodecImageYCbCr422,
    palmCodecImageYCbCr420,
    palmCodecImageYCbCr411,
    palmCodecImageYCbCr211,
    palmCodecImageYCbCr444Planar,
    palmCodecImageYCbCr422Planar,
    palmCodecImageYCbCr420Planar,
    palmCodecImageYCbCr411Planar,
    palmCodecImageYCbCr211Planar,
    palmCodecImageRGBIndex16,
    palmCodecImageRGBIndex8,
    palmCodecImageRGBIndex4,
    palmCodecImageRGBIndex2,
    palmCodecImageRGBIndex1,
    palmCodecImageRGBIndex,
    palmCodecImageGRAY8,
    palmCodecImageGRAY4,
    palmCodecImageGRAY2,
    palmCodecImageGRAY1,
    palmCodecImageGIFFrame,
    palmCodecImageCMY,
    palmCodecImageCMYK,
    palmCodecImageHSL,
    palmCodecImageHSI,
    palmCodecImageHSV,
    palmCodecImageHCI
    }
  • enum PalmAudioChannelType {
    palmCodecMONO = 0x01,
    palmCodecSTEREO
    }
  • enum PalmBasicType {
    palmCodecINT8 = 0x01,
    palmCodecUINT8 = 0x11,
    palmCodecINT16Big = 0x02,
    palmCodecINT16Little = 0x12,
    palmCodecINT32Big = 0x04,
    palmCodecINT32Little = 0x14,
    palmCodecFloatBig = 0x24,
    palmCodecFloatLittle = 0x34,
    palmCodecUINT16Big,
    palmCodecUINT16Little,
    palmCodecINT24,
    palmCodecUINT24,
    palmCodecUINT32Big,
    palmCodecUINT32Little
    }
  • enum PalmEndianType {
    palmCodecBIG_ENDIAN,
    palmCodecLITTLE_ENDIAN
    }
  • enum PalmFileType {
    palmCodecVFSFile,
    palmCodecStreamFile
    }
  • enum PalmBMPCompressionType {
    palmCodecBMP_None,
    palmCodecBMP_RLE4,
    palmCodecBMP_RLE8
    }
  • enum PalmAACProfileType {
    palmCodecAACMainProfile,
    palmCodecAACLowComplexity,
    palmCodecAACScaleableSamplingRate
    }
  • enum PalmAMRMode {
    palmCodecAMR475,
    palmCodecAMR515,
    palmCodecAMR59,
    palmCodecAMRM67,
    palmCodecAMR74,
    palmCodecAMR795,
    palmCodecAMR102,
    palmCodecAMR122
    }
  • enum PalmAMRDtxMode {
    palmCodecAMRDtxDisable,
    palmCodecAMRDtxEnable
    }
  • enum PalmQCELPRate {
    palmCodecQCELPSilent,
    palmCodecQCELPEighth,
    palmCodecQCELPQuarter,
    palmCodecQCELPHalf,
    palmCodecQCELPFull
    }
  • enum PalmQCELPReducedRate {
    palmCodecQCELPReducedDisabled,
    palmCodecQCELPReducedEnabled
    }
  • enum AACHeaderType {
    palmCodecAAC_RAW,
    palmCodecAAC_ADIF,
    palmCodecAAC_ADTS,
    palmCodecAAC_MP4A,
    palmCodecAAC_LATM
    }
  • enum AACObjectType {
    MAIN = 1,
    LC,
    SSR,
    LTP,
    HE_AAC,
    ER_LC = 17,
    ER_LTP = 19,
    LD = 23,
    DRM_ER_LC = 27
    }
  • enum FileFlag {
    VFS = 1,
    FileStream = 2
    }
  • enum PalmMPEG4Algorithm {
    palmCodecMPEG4MVFAST,
    palmCodecMPEG4SEA
    }
  • enum PalmCodecControlType {
    palmCodecCtlGetVersion,
    palmCodecCtlGetAuthor,
    palmCodecCtlGetDate,
    palmCodecCtlGetComments,
    palmCodecCtlLastBuffer,
    palmCodecCtlCustomBase = 0x80000000,
    palmCodecCtlAVCGetInfo,
    palmCodecCtlAVCGetDecodedFrame,
    palmCodecCtlAVCSetCropMode,
    palmCodecCtlPutSeed,
    palmCodecCtlGetKey,
    palmCodecCtlPutKey,
    palmCodecCtlAACGetInfo
    }

Define Documentation

#define MAX_PLANE_COUNT 5

Maximum number of image planes

#define palmCodecAudioAAC 'DAAC'

AAC Audio Format.

#define palmCodecAudioALAW 'ALAW'

A-Law Audio Format.

#define palmCodecAudioAMR 'AMRS'

GSM-AMR Speech Format.

#define palmCodecAudioDVI_ADPCM 'DPCM'

Intel/MS/DVI ADPCM.

#define palmCodecAudioG711 'G711'

G.711 Speech Format.

#define palmCodecAudioG722 'G722'

G.722 Speech Format.

#define palmCodecAudioG726 'G726'

G.726 Speech Format.

#define palmCodecAudioG728 'G728'

G.728 Speech Format.

#define palmCodecAudioIMA_ADPCM 'APCM'

IMA ADPCM Audio Format.

#define palmCodecAudioMP1 'MPG1'

MPEG Layer 1 Audio Format.

#define palmCodecAudioMP2 'MPG2'

MPEG Layer 2 Audio Format.

#define palmCodecAudioMP3 'MPG3'

MPEG Layer 3 Audio Format.

#define palmCodecAudioPCM 'PCM1'

Raw PCM Audio Format.

#define palmCodecAudioQCELP 'QCLP'

CDMA-QCELP Speech Format.

#define palmCodecAudioULAW 'ULAW'

U-Law Audio Format.

#define palmCodecAudioVORBIS 'OGGV'

OGG Vorbis Audio Format.

#define palmCodecImageBase 'IM00'

Base code for Image formats.

#define palmCodecImageGIF87a 'GIF7'

GIF87a Image Format.

#define palmCodecImageGIF87aFile 'GI7F'

GIF87a Image File Format.

#define palmCodecImageGIF89a 'GIF9'

GIF89a Image Format.

#define palmCodecImageGIF89aFile 'GI9F'

GIF89a Image Format.

#define palmCodecImageJPEG 'JPEG'

JPEG Image Format.

#define palmCodecImageJPEGFile 'JPEF'

JPEG Image File Format.

#define palmCodecImagePNG 'PNGI'

Portable Network Graphics Image Format.

#define palmCodecImagePNGFile 'PNGF'

Portable Network Graphics Image File Format.

#define palmCodecImageTIFF 'TIFF'

TIFF Image Format.

#define palmCodecImageTIFFFile 'TFFF'

TIFF Image File Format.

#define palmCodecImageWBMP 'WBMP'

Windows Bitmap Image Format.

#define palmCodecImageWBMPFile 'WBMF'

Windows Bitmap Image File Format.

#define palmCodecText3G '3GTX'

3G Text Format.

#define palmCodecVideoAVC 'AVCd'

AVC(H.264) Video Format.

#define palmCodecVideoDIVX 'DivX'

DivX Video Format.

#define palmCodecVideoH263 'H263'

H263 Video Format.

#define palmCodecVideoMJPEG 'MJPG'

Motion JPEG Video Format.

#define palmCodecVideoMPEG1 'Mpg1'

MPEG-1 Video Format.

#define palmCodecVideoMPEG2 'Mpg2'

MPEG-2 Video Format.

#define palmCodecVideoMPEG4 'MPG4'

MPEG-4 Video Format.

#define palmCodecVideoXVID 'XviD'

XviD Video Format.

Enumeration Type Documentation

anonymous enum

Image Formats

Enumerator:
palmCodecImageARGB32 | 32 bit color with alpha channel.
palmCodecImageRGBA32 | ('IM01') 32 bit color with alpha channel.
palmCodecImageRGB32 | ('IM02') 32 bit RGB color without alpha channel.
palmCodecImageRGB888 | ('IM03') 24 bit RGB color.
palmCodecImageRGB888Planar | ('IM04') 24 bit RGB Planar color.
palmCodecImageRGB565 | ('IM05') 16 bit RGB color.
palmCodecImageRGB555 | ('IM06') 16 bit RGB color + don't care.
palmCodecImageBGRA32 | ('IM07') 32 bit BGR color with alpha channel.
palmCodecImageBGR32 | ('IM08') 32 bit BGR color without alpha channel.
palmCodecImageBGR888 | ('IM09') 24 bit BGR color.
palmCodecImageBGR565 | ('IM0:') 16 bit BGR color.
palmCodecImageBGR555 | ('IM0;') 16 bit BGR color + don't care.
palmCodecImageYUV444 | ('IM0<') 4:4:4 YUV format.
palmCodecImageYUV422 | ('IM0=') 4:2:2 YUV format.
palmCodecImageYUV420 | ('IM0>') 4:2:0 YUV format.
palmCodecImageYUV411 | ('IM0?') 4:1:1 YUV format.
palmCodecImageYUV211 | ('IM0@') 2:1:1 YUV format.
palmCodecImageYUV444Planar | ('IM0A') 4:4:4 Planar YUV format.
palmCodecImageYUV422Planar | ('IM0B') 4:2:2 Planar YUV format.
palmCodecImageYUV420Planar | ('IM0C') 4:2:0 Planar YUV format.
palmCodecImageYUV411Planar | ('IM0D') 4:1:1 Planar YUV format.
palmCodecImageYUV211Planar | ('IM0E') 2:1:1 Planar YUV format.
palmCodecImageYCbCr444 | ('IM0F') 4:4:4 YCbCr format.
palmCodecImageYCbCr422 | ('IM0G') 4:2:2 YCbCr format.
palmCodecImageYCbCr420 | ('IM0H') 4:2:0 YCbCr format.
palmCodecImageYCbCr411 | ('IM0I') 4:1:1 YCbCr format.
palmCodecImageYCbCr211 | ('IM0J') 2:1:1 YCbCr format.
palmCodecImageYCbCr444Planar | ('IM0K') 4:4:4 Planar YCbCr format.
palmCodecImageYCbCr422Planar | ('IM0L') 4:2:2 Planar YCbCr format.
palmCodecImageYCbCr420Planar | ('IM0M') 4:2:0 Planar YCbCr format.
palmCodecImageYCbCr411Planar | ('IM0N') 4:1:1 Planar YCbCr format.
palmCodecImageYCbCr211Planar | ('IM0O') 2:1:1 Planar YCbCr format.
palmCodecImageRGBIndex16 | ('IM0P') Palettized 16 bit RGB.
palmCodecImageRGBIndex8 | ('IM0Q') Palettized 8 bit RGB.
palmCodecImageRGBIndex4 | ('IM0R') Palettized 4 bit RGB.
palmCodecImageRGBIndex2 | ('IM0S') Palettized 2 bit RGB.
palmCodecImageRGBIndex1 | ('IM0T') Palettized 1 bit RGB.
palmCodecImageRGBIndex | ('IM0U') Palettized RGB (unknowm index size).
palmCodecImageGRAY8 | ('IM0V') Gray color 8 bit.
palmCodecImageGRAY4 | ('IM0W') Gray color 4 bit.
palmCodecImageGRAY2 | ('IM0X') Gray color 2 bit.
palmCodecImageGRAY1 | ('IM0Y') Gray color 1 bit.
palmCodecImageGIFFrame | ('IM0Z') GIF Frame format.
palmCodecImageCMY | ('IM0[') Cyan Magenta Yellow format.
palmCodecImageCMYK | ('IM0\') Cyan Magenta Yellow BlacK format.
palmCodecImageHSL | ('IM0]') Hue Saturation Lightness format.
palmCodecImageHSI | ('IM0^') Hue Saturation Intensity format.
palmCodecImageHSV | ('IM0_') Hue Saturation Value format.
palmCodecImageHCI | ('IM0`') Hue Chroma Intensity format.

enum AACHeaderType

AAC file formats

Enumerator:
palmCodecAAC_RAW | RAW format.
palmCodecAAC_ADIF | ADIF format.
palmCodecAAC_ADTS | ADTS format.
palmCodecAAC_MP4A | MP4A format.
palmCodecAAC_LATM | LATM format.

enum AACObjectType

AAC object type

enum FileFlag

File flags

Enumerator:
VFS | VFS.
FileStream | FileStream.

enum PalmAACProfileType

AAC profiles

Enumerator:
palmCodecAACMainProfile | Main Profile
palmCodecAACLowComplexity | Low Complexity Profile
palmCodecAACScaleableSamplingRate | SSR Profile

enum PalmAMRDtxMode

AMR transmission settings

Enumerator:
palmCodecAMRDtxDisable | Disable discontinuous transmission mode.
palmCodecAMRDtxEnable | Enable discontinuous transmission mode.

enum PalmAMRMode

AMR modes

Enumerator:
palmCodecAMR475 | 4.75 kBits/second.
palmCodecAMR515 | 5.15 kBits/second.
palmCodecAMR59 | 5.9 kBits/second.
palmCodecAMRM67 | 6.7 kBits/second.
palmCodecAMR74 | 7.4 kBits/second.
palmCodecAMR795 | 7.95 kBits/second.
palmCodecAMR102 | 10.2 kBits/second.
palmCodecAMR122 | 12.2 kBits/second.

enum PalmAudioChannelType

Audio channels

Enumerator:
palmCodecMONO | One channel.
palmCodecSTEREO | Two channels.

enum PalmBasicType

Basic data types

Enumerator:
palmCodecINT8 | Signed 8-bit.
palmCodecUINT8 | Unsigned 8-bit.
palmCodecINT16Big | Signed 16-bit big-endian.
palmCodecINT16Little | Signed 16-bit little-endian.
palmCodecINT32Big | Signed 32-bit big-endian.
palmCodecINT32Little | Signed 32-bit little-endian.
palmCodecFloatBig | Float big-endian.
palmCodecFloatLittle | Float little-endian.
palmCodecUINT16Big | Unsigned 16-bit big-endian.
palmCodecUINT16Little | Unsigned 16-bit little-endian.
palmCodecINT24 | Signed 24-bit.
palmCodecUINT24 | Unsigned 24-bit.
palmCodecUINT32Big | Unsigned 32-bit big-endian.
palmCodecUINT32Little | Unsigned 32-bit little-endian.

enum PalmBMPCompressionType

BMP compression

Enumerator:
palmCodecBMP_None | No compression.
palmCodecBMP_RLE4 | RLE 4bit compression.
palmCodecBMP_RLE8 | RLE 8bit compression.

enum PalmCodecControlType

Custom controls / API selectors

Enumerator:
palmCodecCtlGetVersion | Get the codec version. (UInt32 in SysMakeROM style)
palmCodecCtlGetAuthor | Get the codec author. (Char[64])
palmCodecCtlGetDate | Get the codec date. (Char[10] like "09/02/2003")
palmCodecCtlGetComments | Get comments about the codec. (Char[512])
palmCodecCtlLastBuffer | Next EncodeDecode call will get the last buffer.
palmCodecCtlCustomBase | Custom custom control base.
palmCodecCtlAVCGetInfo | Get the video frame width/ht info.
palmCodecCtlAVCGetDecodedFrame | Get the decoded frame.
palmCodecCtlAVCSetCropMode | Set the crop mode.
palmCodecCtlPutSeed | Give the codec a random number.
palmCodecCtlGetKey | Get the encoded key from the codec.
palmCodecCtlPutKey | Give the re-encoded key to the codec.
palmCodecCtlAACGetInfo | Get the audio frame freq/chan info.

enum PalmEndianType

Endianess

Enumerator:
palmCodecBIG_ENDIAN | Big endian.
palmCodecLITTLE_ENDIAN | Little endian.

enum PalmFileType

File types

Enumerator:
palmCodecVFSFile | VFS File.
palmCodecStreamFile | Stream File.

enum PalmMPEG4Algorithm

MPEG4 encoding algorithm

Enumerator:
palmCodecMPEG4MVFAST | Motion Vector Field Adaptation Search Technique.
palmCodecMPEG4SEA | Successive Elimination Algorithm.

enum PalmQCELPRate

QCELP rates

Enumerator:
palmCodecQCELPSilent | 0 Bits per packet.
palmCodecQCELPEighth | 20 Bits per packet.
palmCodecQCELPQuarter | 54 Bits per packet.
palmCodecQCELPHalf | 124 Bits per packet.
palmCodecQCELPFull | 266 Bits per packet.

enum PalmQCELPReducedRate

QCELP encoder settings

Enumerator:
palmCodecQCELPReducedDisabled | Disable reduced rate encoding.
palmCodecQCELPReducedEnabled | Enable reduced rate encoding.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:10 2006 for Palm API Guide


palmOneCodecPluginMgr.h File Reference

Detailed Description

The Codec Plugin Manager is used to unify all different type of codecs that are available for PalmOne devices and provide a generic API for developers to access these codecs.

Version:
3.0
A typical application would use the library the following way:
  • Check is an input/output format pair is supported [optional]
  • Create a CodecSession with parameters that match the formats
  • Call EncodeDecode()
  • ...
  • Delete the session.

Include dependency graph for palmOneCodecPluginMgr.h:

Functions

  • Err CodecMgrOpen (UInt16 refNum)
  • Err CodecMgrClose (UInt16 refNum)
  • Err CodecMgrSleep (UInt16 refNum)
  • Err CodecMgrWake (UInt16 refNum)
  • Err CodecMgrLibAPIVersion (UInt16 refNum, UInt32 codecMgrAPIVersion, UInt32 *codecMgrLibAPIVersionP)
  • Err CodecMgrCreateSession (UInt16 refNum, PalmCodecFormat inputFormat, void *inputParamP, PalmCodecFormat outputFormat, void *outputParamP, PalmCodecSession *sessionP)
  • Err CodecMgrCreateSessionByID (UInt16 refNum, PalmCodecFormat inputFormat, void *inputParamP, PalmCodecFormat outputFormat, void *outputParamP, UInt32 creatorID, UInt32 codecID, PalmCodecSession *sessionP)
  • Err CodecMgrDeleteSession (UInt16 refNum, PalmCodecSession *sessionP)
  • Err CodecMgrResetSession (UInt16 refNum, PalmCodecSession session)
  • Err CodecMgrGetMaxDestBufferSize (UInt16 refNum, PalmCodecSession session, void *srcBufferP, UInt32 srcBufferSize, UInt32 *destBufferSizeP)
  • Err CodecMgrEncodeDecode (UInt16 refNum, PalmCodecSession session, void *srcBufferP, UInt32 *srcBufferSizeP, void *destBufferP, UInt32 *destBufferSizeP)
  • Err CodecMgrCustomControl (UInt16 refNum, PalmCodecSession session, UInt32 apiCreator, UInt32 apiSelector, void *valueP, UInt32 *valueLenP)
  • Err CodecMgrEnumerateFormats (UInt16 refNum, UInt32 *formatIteratorP, PalmCodecFormat *inputFormatP, PalmCodecFormat *outputFormatP, UInt32 *creatorIDP, UInt32 *codecIDP)
  • Boolean CodecMgrIsFormatSupported (UInt16 refNum, PalmCodecFormat inputFormat, PalmCodecFormat outputFormat, UInt32 creatorID, UInt32 codecID)
  • Err CodecMgrGetSessionInfo (UInt16 refNum, PalmCodecSession session, PalmCodecFormat *inputFormatP, PalmCodecFormat *outputFormatP, UInt32 *creatorIDP, UInt32 *codecIDP)

Function Documentation

Err CodecMgrClose ( UInt16 refNum )

Closes the Codec Plugin Manager library.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
Return values:
Err The library is closed and errNone is returned. If another application is still using the library, a kCodecMgrLibStillOpen error is returned.

Err CodecMgrCreateSession | ( | UInt16 | refNum,
 |  | PalmCodecFormat | inputFormat,
 |  | void * | inputParamP,
 |  | PalmCodecFormat | outputFormat,
 |  | void * | outputParamP,
 |  | PalmCodecSession * | sessionP
 | ) |

Create a Codec Session. A session is Codec dependent, which means it is up to a Codec to define the structure (if any) pointed by the Session. This function is called by the CodecPluginMgr. At this stage, the CPM has already selected a known format pair from its codec list. The input and output parameters have to match the format they represent. E.g. palmCodecImageJPEG as input uses PalmJPEGEncodeType palmCodecImageJPEG as output uses PalmJPEGDecodeType etc.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
inputFormat,: IN: Input format for this session.
inputParamP,: IN: Parameter associated with the input format. NULL if not needed.
outputFormat,: IN: Output format for this session.
outputParamP,: IN: Parameter associated with the output format. NULL if not needed.
sessionP OUT: Receives the reference to the newly created session. This reference is passed into all future calls for this session.
Return values:
Err errNone if no error.

Err CodecMgrCreateSessionByID | ( | UInt16 | refNum,
 |  | PalmCodecFormat | inputFormat,
 |  | void * | inputParamP,
 |  | PalmCodecFormat | outputFormat,
 |  | void * | outputParamP,
 |  | UInt32 | creatorID,
 |  | UInt32 | codecID,
 |  | PalmCodecSession * | sessionP
 | ) |

Create a Codec Session using Creator and Codec ID. A session is Codec dependent, which means it is up to a Codec to define the structure (if any) pointed by the Session. This function is called by the CodecPluginMgr. At this stage, the CPM has already selected a known format pair from its codec list. The input and output parameters have to match the format they represent. E.g. palmCodecImageJPEG as input uses PalmJPEGEncodeType palmCodecImageJPEG as output uses PalmJPEGDecodeType etc.

This function is used to create a session when a multiple codecs using the same input and output format are available.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
inputFormat,: IN: Input format for this session.
inputParamP,: IN: Parameter associated with the input format. NULL if not needed.
outputFormat,: IN: Output format for this session.
outputParamP,: IN: Parameter associated with the output format. NULL if not needed.
creatorID,: IN: Creator ID of the module containing the codec.
codecID,: IN: Codec ID for a specific codec.
sessionP,: OUT: Receives the reference to the newly created session. This reference is passed into all future calls for this session.
Returns:
errNone if no error.

Err CodecMgrCustomControl | ( | UInt16 | refNum,
 |  | PalmCodecSession | session,
 |  | UInt32 | apiCreator,
 |  | UInt32 | apiSelector,
 |  | void * | valueP,
 |  | UInt32 * | valueLenP
 | ) |

Handle a custom call.

The codec identifies the call and its API by a registered creator code and a selector. This allows codec developers to extend the API by defining selectors for their creator code. It also allows driver developers to support selectors (and custom calls) defined by other driver developers.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
session,: IN: Codec session reference received from CodecCreateSession.
apiCreator,: IN: Registered creator code.
apiSelector,: IN: Custom operation to perform.
valueP,: IN: Buffer containing data specific to the operation.
valueLenP,: IN,OUT: Size of the valueP buffer on entry, size of data written to valueP on exit. If NULL, valueP is ignored.
Return values:
Err errNone if no error, kCodecMgrLibNotSupported if not supported.

Err CodecMgrDeleteSession | ( | UInt16 | refNum,
 |  | PalmCodecSession * | sessionP
 | ) |

Delete a session. This function has to delete any allocated memory and set the session reference to NULL.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
sessionP,: IN: Pointer to the Codec session reference received from CodecCreateSession.
Return values:
Err errNone if no error.

Err CodecMgrEncodeDecode | ( | UInt16 | refNum,
 |  | PalmCodecSession | session,
 |  | void * | srcBufferP,
 |  | UInt32 * | srcBufferSizeP,
 |  | void * | destBufferP,
 |  | UInt32 * | destBufferSizeP
 | ) |

Encode or decode a block of data. The format of the source and destination buffers are set in a preceding call to CodecCreateSession and possibly calls to CodecCustomControl. Is is legal for this function to not encode/decode the whole source buffer. For example, if the source buffer contains a non-round number of encoded blocks, and the encoding format requires whole blocks, this call should encode/decode the even number of blocks, and set srcBufferP appropriately to indicate how much of the source data was actually encoded. The caller should then pass the un-encoded piece of the last chunk in on the next call to this function with the next chunk of data appended to the end of it.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
session,: IN: Codec session reference received from CodecCreateSession.
srcBufferP,: IN: The source buffer to be processed.
srcBufferSizeP,: IN,OUT: On input, the size of srcBufferP in bytes. If the whole buffer is not processed, on output srcBufferP is set to the amount of source data that was processed.
destBufferP,: OUT: The destination buffer which receives the encoded/decoded data.
destBufferSizeP,: IN,OUT: On input, the size of destBufferP in bytes, on output the number of bytes of data written.
Return values:
Err errNone if no error

Err CodecMgrEnumerateFormats | ( | UInt16 | refNum,
 |  | UInt32 * | formatIteratorP,
 |  | PalmCodecFormat * | inputFormatP,
 |  | PalmCodecFormat * | outputFormatP,
 |  | UInt32 * | creatorIDP,
 |  | UInt32 * | codecIDP
 | ) |

Enumerate all supported input and output format pairs. A pair describes what input format is expected and what output format will come out of the Codec. Codecs can accept multiple format pairs. For example, an MP3 Codec might be able to decode only MP3, MP2, and MP1. In this case, the pairs are: [in: MP3 out: PCM codecID: 0] [in: MP2 out: PCM codecID: 0] [in: MP1 out: PCM codecID: 0]

The Codec ID is used if multiple codecs within the same PRC have the exact same input and output formats. For example, a DSP filter bank might specify PCM as both the input and output for every codec. Codec ID helps differentiate between these Codecs (Low-Pass, High-Pass, Band-Pass...). A Codec ID set to 0 (palmNULLCodecID) means that there is no need to look for a particular codec (for example, if there is only one codec in the PRC).

Pass a formatIteratorP of palmCodecIteratorStart to get the first pair. formatIteratorP will be updated to the next item. When returning the last format pair, the formatIteratorP will be set to palmCodecIteratorStop.

Sample:

PalmCodecFormat inputFormat, outputFormat; UInt32 codecID; UInt32 formatIterator = palmCodecIteratorStart; while (formatIterator != palmCodecIteratorStop) { if ((err = CodecEnumerateSupportedFormats(&formatIterator, &inputFormat, &outputFormat, &codecID)) != errNone) { // Do something with the format pair } else { // handle error... possibly by breaking out of the loop } }

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
formatIteratorP,: IN,OUT: Reference to the last entry enumerated Pass palmCodecIteratorStart to get the first entry. This is updated on return to reference the next entry or set to palmCodecIteratorStop if last directory entry.
inputFormatP,: IN: Receives the input format entry specified with formatIteratorP.
outputFormatP,: IN: Receives the output format entry specified with formatIteratorP.
creatorIDP,: IN: Pointer to the location where the creator ID associated with the current formatIteratorP entry is stored. Pass NULL to ignore this value for each codec.
codecIDP,: IN: Pointer to the location where the codec ID associated with the current formatIteratorP entry is stored. Pass NULL to ignore this value for each codec.
Return values:
Err errNone or kCodecErrBadParam

Err CodecMgrGetMaxDestBufferSize | ( | UInt16 | refNum,
 |  | PalmCodecSession | session,
 |  | void * | srcBufferP,
 |  | UInt32 | srcBufferSize,
 |  | UInt32 * | destBufferSizeP
 | ) |

Returns the output buffer size required given an input buffer. This function is not required, but rather is provided to try to help the caller allocate the appropriate amount of memory for a call to CodecEncodeDecode that takes the same parameters. It is recommended that you always return a number equal to or larger then the buffer that will be required to hold the output of the CodecEncodeDecode call.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
session,: IN: Codec session reference received from CodecCreateSession.
srcBufferP,: IN: Input buffer.
srcBufferSize,: IN: Size of the input buffer in bytes.
destBufferSizeP,: OUT: Receives that maximum buffer size.
Return values:
Err errNone if no error, kCodecMgrLibNotSupported if no implemented.

Err CodecMgrGetSessionInfo | ( | UInt16 | refNum,
 |  | PalmCodecSession | session,
 |  | PalmCodecFormat * | inputFormatP,
 |  | PalmCodecFormat * | outputFormatP,
 |  | UInt32 * | creatorIDP,
 |  | UInt32 * | codecIDP
 | ) |

Get information about a session.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
session,: IN: Session to reset.
inputFormatP,: OUT: Receives the input format entry specified with formatIteratorP.
outputFormatP,: OUT: Receives the output format entry specified with formatIteratorP.
creatorIDP,: OUT: Pointer to the location where the creator ID of the session is returned.
codecIDP,: OUT: Pointer to the location where the codec ID of the session is returned.
Return values:
Err errNone if no error.

Boolean CodecMgrIsFormatSupported | ( | UInt16 | refNum,
 |  | PalmCodecFormat | inputFormat,
 |  | PalmCodecFormat | outputFormat,
 |  | UInt32 | creatorID,
 |  | UInt32 | codecID
 | ) |

Checks whether an input and output format pair is supported by any codec or by a particular codec.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
inputFormat,: IN: Input format for this session.
outputFormat,: IN: Output format for this session.
creatorID,: IN: Creator ID of the codec checked. Pass palmCodecNullID to ignore this parameter and check whether any available codec supports the given input and output format pair.
codecID,: IN: Codec ID of the codec checked. Pass palmCodecNullID to ignore this parameter and check whether any available codec supports the given input and output format pair.
Return values:
Boolean true if the format is supported by a codec or the specified codec, false if the format pair is not supported by a codec or the specified codec.

Err CodecMgrLibAPIVersion | ( | UInt16 | refNum,
 |  | UInt32 | codecMgrAPIVersion,
 |  | UInt32 * | codecMgrLibAPIVersionP
 | ) |

Return the version of the Codec Plugin Manager library API to which this Codec was written. The API version of the manager that is loading this plugin is passed in, so that the plugin can either handle older managers, or return kCodecMgrLibNotSupported.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
codecMgrAPIVersion,: IN: The largest version of the codec API supported
codecMgrLibAPIVersionP,: IN: Receives the API version to which this plugin was written. If the plugin supports multiple API versions, this should be set to the same version as codecMgrAPIVersion.
Return values:
Err errNone if no error, kCodecMgrLibNotSupported if the manager is too old to handle this plugin

Err CodecMgrOpen ( UInt16 refNum )

Opens the Codec Plugin Manager library.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
Return values:
Err errNone if no error

Err CodecMgrResetSession | ( | UInt16 | refNum,
 |  | PalmCodecSession | session
 | ) |

Reset a session.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
session,: IN: Session to reset.
Return values:
Err errNone if no error.

Err CodecMgrSleep ( UInt16 refNum )

Standard Sleep function.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
Return values:
Err errNone if no error

Err CodecMgrWake ( UInt16 refNum )

Standard Wake function.

Parameters:
refNum,: IN: Reference number of the CodecPluginMgr library.
Return values:
Err errNone if no error

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:10 2006 for Palm API Guide


palmOneCodecPluginMgrCommon.h File Reference

Detailed Description

Public 68K common header file for Codec Plugin Manager API - Library Definitions.

Version:
3.0
This file contains the library constants and error codes used in the APIs.

Include dependency graph for palmOneCodecPluginMgrCommon.h:

Library Versions

  • #define kCodecMgrLibVersion3 sysMakeROMVersion(3, 0, 0, sysROMStageRelease, 0)
  • #define kCodecMgrLibVersion kCodecMgrLibVersion3

Library Error Codes

  • #define kCodecMgrLibErrStillOpen (kCodecMgrLibErrorClass | 0x01)
  • #define kCodecMgrLibErrInternal (kCodecMgrLibErrorClass | 0x02)
  • #define kCodecMgrLibErrBadParam (kCodecMgrLibErrorClass | 0x03)
  • #define kCodecMgrLibNotSupported (kCodecMgrLibErrorClass | 0x04)
  • #define kCodecMgrLibBadVersion (kCodecMgrLibErrorClass | 0x05)
  • #define kCodecMgrLibNoCodec (kCodecMgrLibErrorClass | 0x06)

Codec Session Error Codes

  • #define kCodecErrBadParam (kCodecPluginErrorClass | 0x01)
  • #define kCodecErrBufferOverrun (kCodecPluginErrorClass | 0x02)
  • #define kCodecErrBufferUnderrun (kCodecPluginErrorClass | 0x03)
  • #define kCodecErrFrameError (kCodecPluginErrorClass | 0x04)
  • #define kCodecErrInvalidHeader (kCodecPluginErrorClass | 0x05)
  • #define kCodecSyncNotFound (kCodecPluginErrorClass | 0x06)
  • #define kCodecErrInvalidState (kCodecPluginErrorClass | 0x07)
  • #define kCodecErrAlignment (kCodecPluginErrorClass | 0x08)
  • #define kCodecErrParsing (kCodecPluginErrorClass | 0x09)
  • #define kCodecErrNoMemory (kCodecPluginErrorClass | 0x10)
  • #define kCodecErrUnAuthorized (kCodecPluginErrorClass | 0x11)
  • #define kCodecErrUnknown (kCodecPluginErrorClass | 0xFF)

CodecSupportedFormatEnumerate Iterator

  • #define palmCodecIteratorStart (0xfffffffeL)
  • #define palmCodecIteratorStop (0xffffffffL)

Function Traps

  • #define kCodecMgrLibTrapLibAPIVersion (sysLibTrapCustom + 0)
  • #define kCodecMgrLibTrapCreateSession (sysLibTrapCustom + 1)
  • #define kCodecMgrLibTrapCreateSessionByID (sysLibTrapCustom + 2)
  • #define kCodecMgrLibTrapDeleteSession (sysLibTrapCustom + 3)
  • #define kCodecMgrLibTrapResetSession (sysLibTrapCustom + 4)
  • #define kCodecMgrLibTrapGetMaxDestBufferSize (sysLibTrapCustom + 5)
  • #define kCodecMgrLibTrapEncodeDecode (sysLibTrapCustom + 6)
  • #define kCodecMgrLibTrapCustomControl (sysLibTrapCustom + 7)
  • #define kCodecMgrLibTrapEnumerateFormats (sysLibTrapCustom + 8)
  • #define kCodecMgrLibTrapIsFormatSupported (sysLibTrapCustom + 9)
  • #define kCodecMgrLibTrapGetSessionInfo (sysLibTrapCustom + 10)

Defines

  • #define kCodecMgrLibName "CodecPluginMgr"
  • #define kCodecMgrLibType 'aext'
  • #define kCodecMgrLibCreator 'CdMg'
  • #define kCodecMgrLibErrorClass (oemErrorClass + 0x100)
  • #define kCodecPluginErrorClass (oemErrorClass + 0x300)
  • #define palmCodecNullID (0)
  • #define palmCodecInvalidSession (NULL)

Typedefs

  • typedef void * PalmCodecSession
  • typedef UInt32 PalmCodecFormat

Define Documentation

#define kCodecErrAlignment (kCodecPluginErrorClass | 0x08)

Alignment error.

#define kCodecErrBadParam (kCodecPluginErrorClass | 0x01)

Codec Plug-In Bad parameters.

#define kCodecErrBufferOverrun (kCodecPluginErrorClass | 0x02)

Buffer Over-run.

#define kCodecErrBufferUnderrun (kCodecPluginErrorClass | 0x03)

Buffer Under-run.

#define kCodecErrFrameError (kCodecPluginErrorClass | 0x04)

Frame Error.

#define kCodecErrInvalidHeader (kCodecPluginErrorClass | 0x05)

Invalid Header.

#define kCodecErrInvalidState (kCodecPluginErrorClass | 0x07)

Invalide decoding/encoding state.

#define kCodecErrNoMemory (kCodecPluginErrorClass | 0x10)

Out of memory.

#define kCodecErrParsing (kCodecPluginErrorClass | 0x09)

Parsing error.

#define kCodecErrUnAuthorized (kCodecPluginErrorClass | 0x11)

Not being authorized.

#define kCodecErrUnknown (kCodecPluginErrorClass | 0xFF)

Unknown error.

#define kCodecMgrLibBadVersion (kCodecMgrLibErrorClass | 0x05)

Bad Codec Manager version.

#define kCodecMgrLibCreator 'CdMg'

CodecPluginMgr creator ID.

#define kCodecMgrLibErrBadParam (kCodecMgrLibErrorClass | 0x03)

Bad parameters.

#define kCodecMgrLibErrInternal (kCodecMgrLibErrorClass | 0x02)

Internal error.

#define kCodecMgrLibErrorClass (oemErrorClass + 0x100)

Codec Plug-In Manager error codes.

#define kCodecMgrLibErrStillOpen (kCodecMgrLibErrorClass | 0x01)

Returned from CodecMgrLibClose() if the library is still open.

#define kCodecMgrLibName "CodecPluginMgr"

CodecPluginMgr library name.

#define kCodecMgrLibNoCodec (kCodecMgrLibErrorClass | 0x06)

No codec available.

#define kCodecMgrLibNotSupported (kCodecMgrLibErrorClass | 0x04)

API or Codec not supported.

#define kCodecMgrLibType 'aext'

CodecPluginMgr library type.

#define kCodecPluginErrorClass (oemErrorClass + 0x300)

Codec Plugins error codes.

#define kCodecSyncNotFound (kCodecPluginErrorClass | 0x06)

Sync not found.

#define palmCodecInvalidSession (NULL)

Invalid session.

#define palmCodecIteratorStart (0xfffffffeL)

Start iterator.

#define palmCodecIteratorStop (0xffffffffL)

Stop iterator.

#define palmCodecNullID (0)

Null ID.

Typedef Documentation

typedef UInt32 PalmCodecFormat

Palm Codec Format.

typedef void* PalmCodecSession

Palm Codec Session.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:11 2006 for Palm API Guide


palmOneCreators.h File Reference

Detailed Description

Contains Palm-specific creator codes.

Version:
1.0
Date:
02/29/2002

Include dependency graph for palmOneCreators.h:

  • #define sysFileCTelMgrLibOem 'toem'
  • #define sysFileCSimATDriverOem 'sims'
  • #define sysFileCSimOfficer 'sats'
  • #define sysFileCSimWatcherLib 'simw'
  • #define sysFileCProvisioning 'prov'
  • #define sysFileCMobileServices 'msvc'
  • #define sysFileCMyFavorite 'myfv'
  • #define sysFileCNotePad 'npad'
  • #define sysFileCMobileApp 'mobi'
  • #define kPalmCreatorIDNetSlipHack 'PNHk'
  • #define kPalmOneCreatorIDContacts 'PAdd'
  • #define kPalmOneCreatorIDCalendar 'PDat'
  • #define kPalmOneCreatorIDMemos 'PMem'
  • #define kPalmOneCreatorIDNotePad 'npad'
  • #define kPalmOneCreatorIDTasks 'PTod'
  • #define kPalmOneCreatorIDVoiceMemo 'Vpad'
  • #define kPalmOneCreatorIDFavorites 'Fave'
  • #define kPalmOneCreatorIDFileBrowser 'PFil'
  • #define kPalmCreatorIDLcdState 'PmLo'

Defines

  • #define expMediaType_HD 'HDSK'

Define Documentation

#define expMediaType_HD 'HDSK'

Media types

Media types for different media used on palmOne devices. Media type for the Hard Disk

#define kPalmCreatorIDLcdState 'PmLo'

Creator ID for the lcd broadcast of lcd on/off

#define kPalmCreatorIDNetSlipHack 'PNHk'

Creator ID for the bluetooth slip app panel hack

#define sysFileCMobileApp 'mobi'

Creator ID for the Mobile application

#define sysFileCMobileServices 'msvc'

Creator ID for the Mobile Service Library.

#define sysFileCMyFavorite 'myfv'

Creator ID for the MyFavorite App.

#define sysFileCNotePad 'npad'

Creator ID for the Notepad app.

#define sysFileCProvisioning 'prov'

Creator ID for the provisioning application.

#define sysFileCSimATDriverOem 'sims'

Creator ID for the SIM AT Driver.

#define sysFileCSimOfficer 'sats'

Creator ID for the SIM Application Toolkit client application.

#define sysFileCSimWatcherLib 'simw'

Creator ID for the SIM Watcher library.

#define sysFileCTelMgrLibOem 'toem'

Creator ID for the Telephony Manager Extension shared library.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:11 2006 for Palm API Guide


palmOneFeatures.h File Reference

Detailed Description

Contains Palm-specific feature definitions.

Version:
1.0
Date:
02/29/2002

  • #define screenFtrCreator 'scnP'
  • #define dpiFtrValue 1

Headset feature

  • #define headsetFtrCreator 'hseT'
  • #define headsetFtrVersion 0
  • #define sysExternalHeadsetInsertEvent 'hsiN'
  • #define sysExternalHeadsetRemoveEvent 'hsrM'

USB features

These features provide information on the USB capabilities of the device.
  • #define pmUsbFtrCreator 'pUSB'
  • #define pmUsbFtrVersion 0
  • #define USBFeatureCreator 'fUSB'
  • #define USBFeatureVersion 0
  • #define kUSBMTP 0x0001
  • #define kUSBTransfer 0x0002
  • #define kUSBHotSync 0x0004
  • #define kUSBDriveMode 0x0008
  • #define kUSBConsole 0x0010
  • #define kUSBDUN 0x0020
  • #define kUSBLogging 0x0040
  • #define USBSpeedCreator 'sUSB'
  • #define USBSpeedVersion 0
  • #define kUSBFSClient 0x0001
  • #define kUSBHSClient 0x0002
  • #define kUSBFSOnTheGo 0x0004
  • #define kUSBHSOnTheGo 0x0008
  • #define kUSBFSOnTheGoMultiDevice 0x0010
  • #define kUSBHSOnTheGoMultiDevice 0x0020
  • #define USBChargeCreator 'cUSB'
  • #define USBChargeVersion 0
  • #define kUSB500mACharge 0x0001
  • #define USBHwrCreator 'hUSB'
  • #define USBHwrVersion 0
  • #define kUSBMiniConnector 0x0001
  • #define kUSBMultiConnector 0x0002
  • #define irFtrVersionNumber 1
  • #define irFtrLowBatteryLevel 1

Defines

  • #define densityFtrCreator 'dnsT'
  • #define densityFtrVersion 0
  • #define sysNotifyHardDiskSpinup 'HSPU'
  • #define sysNotifyExternalDialogOpenedEvent 'edgO'
  • #define sysNotifyExternalDialogClosedEvent 'edgC'

Define Documentation

#define densityFtrCreator 'dnsT'

The following feature should be defined on all devices that support hi-res screens & include NotePad 2.0 or higher. As the OS does not yet provide a method for the desktop SW/conduits to query the handheld in order to determine the density capabilities of the device, this feature has been added. By testing the presence/content of this feature, the device can properly convert any old lo-density RLE data to be hi-density PNG data on the first hotsync to the device rather than have to do a note-by-note conversion at run time on the handheld the first time each old note has been opened.

#define dpiFtrValue 1

Screen DPI feature

#define irFtrLowBatteryLevel 1

Creator for USB feature

#define irFtrVersionNumber 1

Creator for USB feature

#define kUSB500mACharge 0x0001

Creator for USB feature

#define kUSBConsole 0x0010

Creator for USB feature

#define kUSBDriveMode 0x0008

Creator for USB feature

#define kUSBDUN 0x0020

Creator for USB feature

#define kUSBFSClient 0x0001

Creator for USB feature

#define kUSBFSOnTheGo 0x0004

Creator for USB feature

#define kUSBFSOnTheGoMultiDevice 0x0010

Creator for USB feature

#define kUSBHotSync 0x0004

Creator for USB feature

#define kUSBHSClient 0x0002

Creator for USB feature

#define kUSBHSOnTheGo 0x0008

Creator for USB feature

#define kUSBHSOnTheGoMultiDevice 0x0020

Creator for USB feature

#define kUSBLogging 0x0040

Creator for USB feature

#define kUSBMiniConnector 0x0001

Creator for USB feature

#define kUSBMTP 0x0001

Creator for USB feature

#define kUSBMultiConnector 0x0002

Creator for USB feature

#define kUSBTransfer 0x0002

Creator for USB feature

#define pmUsbFtrCreator 'pUSB'

Creator for USB feature

#define pmUsbFtrVersion 0

USB feature number

#define screenFtrCreator 'scnP'

Creator for screen feature

#define sysExternalHeadsetInsertEvent 'hsiN'

Broadcast when headset is inserted

#define sysExternalHeadsetRemoveEvent 'hsrM'

Broadcast when headset is removed

#define sysNotifyExternalDialogClosedEvent 'edgC'

Broadcast after closing the dialog

#define sysNotifyExternalDialogOpenedEvent 'edgO'

External dialog open/close from backgound task notification

These notifications should be sent by a background task if it wants to open a new/close a dialog. This notification should be used in conjunction with checking the SysUIBusy flag. The logic to be used is as follows: if (!SysUIBusy) display dialog else call SysNotifyBroadcast with sysNotifyExternalDialogOpenedEvent if (!SysUIBusy) display dialog

The foreground application should also be prepared to handle this event especially if it is using the LCD overlay. It should be prepared to receive more than one such notification by keeping a count of open dialog event. This count should be decremented for every sysNotifyExternalDialogClosedEvent. Only when this count becomes zero should the application restart using the display (LCD overlay). Broadcast before opening a dialog

#define sysNotifyHardDiskSpinup 'HSPU'

Hard Disk Spinup notification

Notification sent by the hard disk slot driver that the disk has spun up

#define USBChargeCreator 'cUSB'

Creator for USB feature

#define USBChargeVersion 0

Creator for USB feature

#define USBFeatureCreator 'fUSB'

Creator for USB feature

#define USBFeatureVersion 0

Creator for USB feature

#define USBHwrCreator 'hUSB'

Creator for USB feature

#define USBHwrVersion 0

Creator for USB feature

#define USBSpeedCreator 'sUSB'

Creator for USB feature

#define USBSpeedVersion 0

Creator for USB feature

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:12 2006 for Palm API Guide


palmOneHiResTimer.h File Reference

Detailed Description

Public 68k include file for Hi-Resolution timer for Palm OS.

Version:
1.0

Include dependency graph for palmOneHiResTimer.h:

Functions

  • Err HRTimeLibOpen (UInt16 refNum)
  • Err HRTimeLibClose (UInt16 refNum)
  • Err HRTimeLibTicksPerSecond (UInt16 refNum, UInt32 *ticksP)
  • Err HRTimeLibGetTime (UInt16 refNum, UInt32 *ticksP, UInt32 *rolloverP)

Function Documentation

Err HRTimeLibClose ( UInt16 refNum )

Closes the Hi-Res Timer library.

Parameters:
refNum,: IN: Library reference number.
Return values:
Err Error code.

Err HRTimeLibGetTime | ( | UInt16 | refNum,
 |  | UInt32 * | ticksP,
 |  | UInt32 * | rolloverP
 | ) |

Get the current ticks for Hi-Resolution Timer.

Parameters:
refNum,: IN: Library reference number.
ticksP,: OUT: Current ticks.
rolloverP,: OUT: Number of rollover since the timer started.
Return values:
Err Error code.

Err HRTimeLibOpen ( UInt16 refNum )

Opens the Hi-Res Timer library.

Parameters:
refNum,: IN: Library reference number.
Return values:
Err Error code.

Err HRTimeLibTicksPerSecond | ( | UInt16 | refNum,
 |  | UInt32 * | ticksP
 | ) |

Get the frequency of the Hi-Resolution Timer.

Parameters:
refNum,: IN: Library reference number.
ticksP,: OUT: Frequency of the timer.
Return values:
Err Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:12 2006 for Palm API Guide


palmOneHiResTimerCommon.h File Reference

Detailed Description

Public 68k common header file for Hi-Resolution Timer API.

Version:
1.0
This file contains the common library constants and error codes.

Include dependency graph for palmOneHiResTimerCommon.h:

Library Versions

  • #define kHiResTimeLibVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)
  • #define kHiResTimeLibVersion2 sysMakeROMVersion(2, 0, 0, sysROMStageRelease, 0)
  • #define kHiResTimeLibVersion kCamLibVersion2

Error Codes

  • #define kHiResTimeErrorClass (oemErrorClass + 0x100)
  • #define kHiResTimeLibErrBadParam (kHiResTimeErrorClass | 0x01)
  • #define kHiResTimeLibErrNotOpen (kHiResTimeErrorClass | 0x02)
  • #define kHiResTimeLibErrStillOpen (kHiResTimeErrorClass | 0x03)
  • #define kHiResTimeLibErrNotAvailable (kHiResTimeErrorClass | 0x04)

Function Traps

  • #define kHRLibTrapTimerTicksPerSecond (sysLibTrapCustom)
  • #define kHRLibTrapTimerGetTime (sysLibTrapCustom+1)

Defines

  • #define kHiResTimeLibType 'libr'
  • #define kHiResTimeLibCreator 'pHRT'
  • #define kHiResTimeLibName "HRTimer-Lib"

Define Documentation

#define kHiResTimeErrorClass (oemErrorClass + 0x100)

Hi-Res timer base error number

#define kHiResTimeLibCreator 'pHRT'

Hi-Res timer library database creator

#define kHiResTimeLibErrBadParam (kHiResTimeErrorClass | 0x01)

Bad Parameter

#define kHiResTimeLibErrNotAvailable (kHiResTimeErrorClass | 0x04)

Fucntion not availabe - If returned by HRTimeLibOpen, there is no HiRes Timer available.

#define kHiResTimeLibErrNotOpen (kHiResTimeErrorClass | 0x02)

Library is not open

#define kHiResTimeLibErrStillOpen (kHiResTimeErrorClass | 0x03)

Returned from HRTimeLibClose() if the library is still open

#define kHiResTimeLibName "HRTimer-Lib"

Hi-Res timer library name

#define kHiResTimeLibType 'libr'

Hi-Res timer library database type

#define kHiResTimeLibVersion kCamLibVersion2

Hi-Res timer library version 2

#define kHiResTimeLibVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)

Hi-Res timer library version 1

#define kHiResTimeLibVersion2 sysMakeROMVersion(2, 0, 0, sysROMStageRelease, 0)

Hi-Res timer library version 2

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:12 2006 for Palm API Guide


palmOneLcdOverlay.h File Reference

Detailed Description

Public 68k include file for LCDOverlay API that can be used to display YCbCr images directly on the screen.

Version:
1.0

Include dependency graph for palmOneLcdOverlay.h:

Functions

  • Err LcdOverlayLibOpen (UInt16 refNum)
  • Err LcdOverlayLibClose (UInt16 refNum)
  • Err LcdOverlayLibGetVersion (UInt16 refNum, UInt32 sdkVersion, UInt32 *libVersionP)
  • Err LcdOverlayLibControl (UInt16 refNum, LcdOverlayLibControlType cmdId, void *parameterP)

Function Documentation

Err LcdOverlayLibClose ( UInt16 refNum )

Closes LcdOverlay library.

Parameters:
refNum,: IN: Reference number of the LcdOverlay library.
Returns:
Err The error code returned from the library. If this is errNone, the function was sucessful.

Err LcdOverlayLibControl | ( | UInt16 | refNum,
 |  | LcdOverlayLibControlType | cmdId,
 |  | void * | parameterP
 | ) |

Control the setting of the LcdOverlay Library.

Parameters:
refNum,: IN: Reference number of the LcdOverlay library.
cmdId,: IN: The commandId. One of the above stated control commands.
parameterP,: OUT: Parameter associated with a command.
Return values:
Err The error code returned from the library. If this is errNone, the function was sucessful.

Err LcdOverlayLibGetVersion | ( | UInt16 | refNum,
 |  | UInt32 | sdkVersion,
 |  | UInt32 * | libVersionP
 | ) |

Returns version of the LcdOverlay Library.

Parameters:
refNum,: IN: Reference number of the LcdOverlay library.
sdkVersion,: IN: Expected version number.
libVersionP,: OUT: Pointer to version number returned.
Return values:
Err The error code returned from the library. If this is errNone, the function was sucessful.

Err LcdOverlayLibOpen ( UInt16 refNum )

Opens LcdOverlay library.

This function should be called prior to calling the other LcdOverlay functions.

Parameters:
refNum,: IN: Reference number of the LcdOverlay library.
Return values:
Err The error code returned from the library. If this is errNone, the function was sucessful.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:13 2006 for Palm API Guide


palmOneLcdOverlayCommon.h File Reference

Detailed Description

Public 68k common header file for LCDOverlay API.

Version:
1.0
This file contains the common constants and error codes for the LCDOverlay library.

Include dependency graph for palmOneLcdOverlayCommon.h:

Data Structures

  • struct LcdOverlayLibSettingTag
    Generic settings For settings without manual values, only type is used. More...

Function Traps

  • #define kLcdOverlayLibTrapGetVersion (sysLibTrapCustom + 0)
  • #define kLcdOverlayLibTrapControl (sysLibTrapCustom + 1)

Error Codes

  • #define kLcdOverlayLibErrorClass (oemErrorClass + 0x200)
  • #define kLcdOverlayLibErrBadParam (kLcdOverlayLibErrorClass | 0x01)
  • #define kLcdOverlayLibErrNoMemory (kLcdOverlayLibErrorClass | 0x02)
  • #define kLcdOverlayLibErrNotOpen (kLcdOverlayLibErrorClass | 0x03)
  • #define kLcdOverlayLibErrStillOpen (kLcdOverlayLibErrorClass | 0x04)
  • #define kLcdOverlayLibErrInternal (kLcdOverlayLibErrorClass | 0x05)
  • #define kLcdOverlayLibErrNotSupported (kLcdOverlayLibErrorClass | 0x06)
  • #define kLcdOverlayLibErrNotCompatible (kLcdOverlayLibErrorClass | 0x07)

Control Commands

  • #define kLcdOverlayLibCtrlFormatSet 0x01
  • #define kLcdOverlayLibCtrlFormatGet 0x02
  • #define kLcdOverlayLibCtrlFormatQuery 0x03
  • #define kLcdOverlayLibCtrlRectSet 0x04
  • #define kLcdOverlayLibCtrlRectGet 0x05
  • #define kLcdOverlayLibCtrlStart 0x06
  • #define kLcdOverlayLibCtrlDraw 0x07
  • #define kLcdOverlayLibCtrlStop 0x08

Data Formats

Format types for overlay.

Not all of the formats may be supported, please do a query to find the supported formats.

  • #define kLcdOverlayLibDataFormatYCbCr444 0x02
  • #define kLcdOverlayLibDataFormatYCbCr422 0x04
  • #define kLcdOverlayLibDataFormatYCbCr420 0x08
  • #define kLcdOverlayLibDataFormatYCbCr444Planar 0x10
  • #define kLcdOverlayLibDataFormatYCbCr422Planar 0x20
  • #define kLcdOverlayLibDataFormatYCbCr420Planar 0x40
  • #define kLcdOverlayLibDataFormatRGB565 0x80

Defines

  • #define kLcdOverlayLibName "LcdOverlayManager"
  • #define kLcdOverlayLibType 'libr'
  • #define kLcdOverlayLibCreator 'Povl'
  • #define kLcdOverlayLibVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)
  • #define kLcdOverlayLibVersion kLcdOverlayLibVersion1

Typedefs

  • typedef UInt16 LcdOverlayLibControlType
  • typedef LcdOverlayLibSettingTag LcdOverlayLibSettingType
    Structure used in LcdOverlayLibControl() for setting parameters Currently only type is used to specify the format type (seelist below) when used with kLcdOverlayLibCtrlFormatSet/Get/Query.
  • typedef LcdOverlayLibSettingTag LcdOverlayLibFormatType
    Struct used in LcdOverlayLibControl() calls.

Define Documentation

#define kLcdOverlayLibCreator 'Povl'

LcdOverlay Creator ID.

#define kLcdOverlayLibCtrlDraw 0x07

Draw picture using Overlay lib. void* pointer to image data

#define kLcdOverlayLibCtrlFormatGet 0x02

Parameter is LcdOverlayLibFormatType*. Get the format type of the overlay.

#define kLcdOverlayLibCtrlFormatQuery 0x03

Parameter is LcdOverlayLibFormatType*. Query the type of format types supported.

#define kLcdOverlayLibCtrlFormatSet 0x01

Parameter is LcdOverlayLibFormatType*. Set the format type of the overlay.

#define kLcdOverlayLibCtrlRectGet 0x05

Parameter is RectangleType* (low res coords). Get the overlay draw rectangle size

#define kLcdOverlayLibCtrlRectSet 0x04

Parameter is RectangleType* (low res coords). Set the overlay draw rectangle size

#define kLcdOverlayLibCtrlStart 0x06

Turn Overlay on before you do a draw. Takes no parameters

#define kLcdOverlayLibCtrlStop 0x08

Turn Overlay off usually after drawing is done. Takes no parameters

#define kLcdOverlayLibDataFormatRGB565 0x80

This is actually RGB555 with 1 bit for transperancy, may change in future

#define kLcdOverlayLibErrBadParam (kLcdOverlayLibErrorClass | 0x01)

invalid parameter

#define kLcdOverlayLibErrInternal (kLcdOverlayLibErrorClass | 0x05)

Internal error

#define kLcdOverlayLibErrNoMemory (kLcdOverlayLibErrorClass | 0x02)

Memory error

#define kLcdOverlayLibErrNotCompatible (kLcdOverlayLibErrorClass | 0x07)

Bad Version

#define kLcdOverlayLibErrNotOpen (kLcdOverlayLibErrorClass | 0x03)

library is not open

#define kLcdOverlayLibErrNotSupported (kLcdOverlayLibErrorClass | 0x06)

Unsupported function

#define kLcdOverlayLibErrorClass (oemErrorClass + 0x200)

Lcd Overlay error base number

#define kLcdOverlayLibErrStillOpen (kLcdOverlayLibErrorClass | 0x04)

returned from LcdOverlayLibClose() if the library is still open

#define kLcdOverlayLibName "LcdOverlayManager"

LcdOverlay library name.

#define kLcdOverlayLibType 'libr'

LcdOverlay Type.

#define kLcdOverlayLibVersion kLcdOverlayLibVersion1

LcdOverlay lib version

#define kLcdOverlayLibVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)

LcdOverlay lib version

Typedef Documentation

typedef UInt16 LcdOverlayLibControlType

Used with the kLcdOverlayLibCtrl defines

typedef struct LcdOverlayLibSettingTag LcdOverlayLibFormatType

Struct used in LcdOverlayLibControl() calls.

See also:
LcdOverlayLibSettingTag

typedef struct LcdOverlayLibSettingTag LcdOverlayLibSettingType

Structure used in LcdOverlayLibControl() for setting parameters Currently only type is used to specify the format type (seelist below) when used with kLcdOverlayLibCtrlFormatSet/Get/Query.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:13 2006 for Palm API Guide


palmOnePhoto.h File Reference

Detailed Description

Palm Photos API: This API is used to access Palm Photos database and manipulate images.

Version:
3.0
The database API provides users with the ability to:
  • Get the list of albums.
  • Create, delete and rename albums.
  • Get the list of photos in each album.
  • Add photos to albums.

The image manipulation API provides users with the ability to:

  • Create and capture images and video clips.
  • Read and write image data.
  • Convert images to different formats.
  • Display images.
  • Scale, rotate and crop images.

Update to be compliant with DCF

  • The notion of Unfiled folder has been removed
  • In PalmPhotoDeleteAlbum() setting the parameter moveToUnfiled moves the photos in the deleted album to DCIM/Palm instead of the Unfiled folder which was DCIM.

Include dependency graph for palmOnePhoto.h:

Data Structures

  • struct _PalmPhotoSelectionParam
    Photo selection dialog parameters. More...
  • struct _PalmPhotoReadWriteParam
    Photo image manipulation param. More...
  • struct _PalmPhotoDisplayParam
    Photo image display parameters. More...
  • struct _PalmPhotoCreateParam
    Photo image create parameters. More...
  • struct _PalmPhotoCaptureParamV2
    Photo/video image capture parameters. More...

Typedefs

  • typedef Err(* PalmPhotoReadWriteCallback )(void *bufferP, UInt32 *sizeP, void *userDataP)
  • typedef Boolean(* PalmPhotoFilterCallback )(PalmPhotoHandle imageH, void *userDataP)
  • typedef Boolean(* PalmPhotoDisplayCallback )(void *userDataP)
  • typedef Boolean(* PalmPhotoCaptureCallbackV2 )(void *userDataP)
  • typedef _PalmPhotoSelectionParam PalmPhotoSelectionParam
    Photo selection dialog parameters.
  • typedef _PalmPhotoReadWriteParam PalmPhotoReadWriteParam
    Photo image manipulation param.
  • typedef _PalmPhotoDisplayParam PalmPhotoDisplayParam
    Photo image display parameters.
  • typedef _PalmPhotoCreateParam PalmPhotoCreateParam
    Photo image create parameters.
  • typedef _PalmPhotoCaptureParamV2 PalmPhotoCaptureParamV2
    Photo/video image capture parameters.

Functions

  • Err PalmPhotoLibOpen (UInt16 refNum)
  • Err PalmPhotoLibClose (UInt16 refNum)
  • Err PalmPhotoLibSleep (UInt16 refNum)
  • Err PalmPhotoLibWake (UInt16 refNum)
  • UInt16 PalmPhotoAlbumCount (UInt16 refNum)
  • UInt16 PalmPhotoGetAlbumID (UInt16 refNum, UInt16 index)
  • Err PalmPhotoGetAlbumName (UInt16 refNum, UInt16 albumID, Char *nameP, UInt16 bufSize)
  • UInt16 PalmPhotoNewAlbum (UInt16 refNum, const Char *nameP, Err *errP)
  • Err PalmPhotoDeleteAlbum (UInt16 refNum, UInt16 albumID, Boolean moveToUnfiled)
  • Err PalmPhotoRenameAlbum (UInt16 refNum, UInt16 albumID, const Char *nameP)
  • UInt16 PalmPhotoImageCount (UInt16 refNum, UInt16 albumID)
  • Err PalmPhotoSelectImages (UInt16 refNum, PalmPhotoSelectionParam *photoSelectionP)
  • Err PalmPhotoSelectDlg (UInt16 refNum, PalmPhotoSelectionParam *photoSelectionP, PalmPhotoDlgType dlgType, Boolean handleCard)
  • void PalmPhotoFreeSelections (UInt16 refNum, PalmPhotoSelectionParam *photoSelectionP)
  • PalmPhotoHandle PalmPhotoCreateImage (UInt16 refNum, const PalmPhotoCreateParam *createParamP, Err *errP)
  • PalmPhotoHandle PalmPhotoOpenImage (UInt16 refNum, const PalmPhotoFileLocation *photoFileP, Err *errP)
  • void PalmPhotoCloseImage (UInt16 refNum, PalmPhotoHandle imageH)
  • Err PalmPhotoGetImageInfo (UInt16 refNum, PalmPhotoHandle imageH, PalmPhotoImageInfo *infoP)
  • UInt32 PalmPhotoGetImageExtraInfoSize (UInt16 refNum, PalmPhotoHandle imageH, PalmPhotoExtraInfoType infoType)
  • Err PalmPhotoGetImageExtraInfo (UInt16 refNum, PalmPhotoHandle imageH, PalmPhotoExtraInfoParam *extraInfoP)
  • Err PalmPhotoSetImageExtraInfo (UInt16 refNum, PalmPhotoHandle imageH, const PalmPhotoExtraInfoParam *extraInfoP)
  • Err PalmPhotoAddImage (UInt16 refNum, UInt16 albumID, PalmPhotoHandle imageH, PalmPhotoHandle *addedImageH, PalmPhotoQualityType imageQuality)
  • Err PalmPhotoDeleteImage (UInt16 refNum, PalmPhotoHandle imageH)
  • Err PalmPhotoReadImage (UInt16 refNum, PalmPhotoHandle imageH, const PalmPhotoReadWriteParam *readParamP)
  • Err PalmPhotoWriteImage (UInt16 refNum, PalmPhotoHandle imageH, const PalmPhotoReadWriteParam *writeParamP)
  • Err PalmPhotoDisplayImage (UInt16 refNum, PalmPhotoHandle imageH, const PalmPhotoDisplayParam *displayParamP)
  • Err PalmPhotoGetThumbSize (UInt16 refNum, PalmPhotoHandle imageH, UInt16 *widthP, UInt16 *heightP)
  • Err PalmPhotoLibGetVersion (UInt16 refNum, UInt32 sdkVersion, UInt32 *libVersionP)
  • Err PalmPhotoScaleImageV2 (UInt16 refNum, PalmPhotoHandle imageH, PalmPhotoHandle *scaledImageHP, UInt32 width, UInt32 height)
  • Err PalmPhotoRotateImageV2 (UInt16 refNum, PalmPhotoHandle imageH, PalmPhotoHandle *rotatedImageHP, Int16 rotation)
  • Err PalmPhotoCropImageV2 (UInt16 refNum, PalmPhotoHandle imageH, PalmPhotoHandle *croppedImageHP, RectangleType *cropRectP)
  • Err PalmPhotoConvertImageV2 (UInt16 refNum, PalmPhotoHandle imageH, PalmPhotoHandle *convertedImageHP, const PalmPhotoCreateParam *createParamP)
  • Err PalmPhotoGetLastErrV2 (UInt16 refNum)
  • UInt16 PalmPhotoAlbumCountV2 (UInt16 refNum, UInt16 volumeRef)
  • UInt16 PalmPhotoGetAlbumIDV2 (UInt16 refNum, UInt16 volumeRef, UInt16 index)
  • UInt16 PalmPhotoNewAlbumV2 (UInt16 refNum, UInt16 volumeRef, const Char *nameP)
  • Err PalmPhotoFreeSelectionsV2 (UInt16 refNum, PalmPhotoSelectionParam *photoSelectionP)
  • PalmPhotoHandle PalmPhotoCreateImageV2 (UInt16 refNum, const PalmPhotoCreateParam *createParamP)
  • PalmPhotoHandle PalmPhotoCaptureImageV2 (UInt16 refNum, const PalmPhotoCaptureParamV2 *captureParamP)
  • PalmPhotoHandle PalmPhotoOpenImageV2 (UInt16 refNum, const PalmPhotoFileLocation *photoFileP)
  • Err PalmPhotoCloseImageV2 (UInt16 refNum, PalmPhotoHandle imageH)
  • Err PalmPhotoAddImageV2 (UInt16 refNum, UInt16 albumID, PalmPhotoHandle imageH, PalmPhotoHandle *addedImageH)
  • Boolean PalmPhotoIsCameraAvailableV3 (UInt16 refNum)
  • PalmPhotoCaptureResolution PalmPhotoGetSupportedCaptureResolutionsV3 (UInt16 refNum, PalmPhotoMediaType mediaType)
  • Err PalmPhotoSelectDlgV3 (UInt16 refNum, PalmPhotoSelectionParam *photoSelectionP, const PalmPhotoCaptureParamV2 *captureParamP, PalmPhotoDlgType dlgType, PalmPhotoMediaType mediaType, Boolean handleCard)
  • Err PalmPhotoDisplayImageToSizeV3 (UInt16 refNum, PalmPhotoHandle imageH, const PalmPhotoDisplayParam *displayParamP)
  • Err PalmPhotoDisplayThumbnailV3 (UInt16 refNum, PalmPhotoHandle imageH, const PalmPhotoDisplayParam *displayParamP)

Typedef Documentation

typedef Boolean(* PalmPhotoCaptureCallbackV2)(void *userDataP)

Capture callback. This function is called during capture image if provided as a parameter. If the function returns false, the capture process will be canceled. New in v2.0.

Parameters:
userDataP,: IN: Pointer to user data set in PalmPhotoCaptureParamV2.
Return values:
Boolean True if the capture process should continue, false otherwise.

typedef struct _PalmPhotoCaptureParamV2 PalmPhotoCaptureParamV2

Photo/video image capture parameters.

The callback function allows the calling application to cancel the image capture operation. The user may cancel the operation by interacting with the capture application. New in v2.0.

typedef struct _PalmPhotoCreateParam PalmPhotoCreateParam

Photo image create parameters.

Set imageInfo can determines the type of the file. To create a JPEG image, set imageInfo.fileFormat to palmPhotoJPEGFileFormat.

typedef Boolean(* PalmPhotoDisplayCallback)(void *userDataP)

Display callback. This function is called during display image if provided as a parameter. If the function returns false, the display process will be canceled.

Parameters:
userDataP,: IN: Pointer to user data set in PalmPhotoDisplayParam.
Return values:
Boolean True if the display process should continue, false otherwise.

typedef struct _PalmPhotoDisplayParam PalmPhotoDisplayParam

Photo image display parameters.

The bounds might be ignored by the application. New in v2.0: If playing a video, winH and rect are ignored.

typedef Boolean(* PalmPhotoFilterCallback)(PalmPhotoHandle imageH, void *userDataP)

Selection filter callback. This function is called during a selection if provided as a parameter. Given an image handle, the filter decides whether or not and image should be selected. For example, a user might want to select only JPEG images.

Parameters:
imageH,: IN: Handle of the image to filter.
userDataP,: IN: Pointer to user data set in PalmPhotoSelectionParam.
Return values:
Boolean True if ok to select image, false otherwise.

typedef Err(* PalmPhotoReadWriteCallback)(void *bufferP, UInt32 *sizeP, void *userDataP)

File streaming callback. During read operations, *sizeP contains the size of the buffer passed to the callback. Setting sizeP before returning in this case is simply ingored. If the user doesn't read all the data in the buffer, the data left will be lost. During write operations, *sizeP contains the max size of the buffer used for writing. sizeP is set to the amount of data to write before the callback returns. Setting sizeP to 0 means no more data to write and the write process should stop. The read/write calllback can be stopped at any time by the callback returning the error code palmPhotoLibErrAbortReadWrite.

Parameters:
bufferP,: IN: Pointer to the buffer containing image data.
sizeP,: IN: Size of the buffer.
userDataP,: IN: Pointer to user data set in PalmPhotoReadWriteParam.
Return values:
Err Error code.

typedef struct _PalmPhotoReadWriteParam PalmPhotoReadWriteParam

Photo image manipulation param.

This parameter is used to set the callback for reading and writing data of an image. The imageFormat provides the user a way to convert images. For example, reading a JPEG image and setting imageFormat to RGB565 should convert the JPEG to RGB565.

typedef struct _PalmPhotoSelectionParam PalmPhotoSelectionParam

Photo selection dialog parameters.

This structure is used for the selection dialog and direct image selection. When using the PMPSelectImages API, selectionCount contains the maximum number of images that can be selected. If selectionCount is set to PALM_PHOTO_SELECT_ALL, the range would be [offset, end]. If albumID is set to PALM_PHOTO_ALBUM_ALL, all images can be selected.

NOTE: The API allocates memory inside of selectedImages. It is the caller's responsibility to free that memory via PalmPhotoFreeSelections().

Function Documentation

Err PalmPhotoAddImage | ( | UInt16 | refNum,
 |  | UInt16 | albumID,
 |  | PalmPhotoHandle | imageH,
 |  | PalmPhotoHandle * | addedImageH,
 |  | PalmPhotoQualityType | imageQuality
 | ) |

Add an image to a Palm Photos album. A new image is created and added to the Photos database, in the specified album. The image will be re-encoded in JPEG format at the specified quality. If album doesn't exist, the image will be added to the album named "Palm". In the previous versions if the album did not exist, the image was added to the "Unfiled" album. Passing albumID of PALM_PHOTO_ALBUM_ALL results in the image being added to the "Palm" album. In the previous versions passing albumID of PALM_PHOTO_ALBUM_ALL resulted in the image being added to the "Unfiled" album. For compatibility only; new development should use the V2 version.

Parameters:
refNum,: IN: Library reference number.
albumID,: IN: Album ID for the image.
imageH,: IN: Image handle.
addedImageH,: OUT: The new image added to the album.
imageQuality,: IN: Image quality.
Return values:
Err Error code.

Err PalmPhotoAddImageV2 | ( | UInt16 | refNum,
 |  | UInt16 | albumID,
 |  | PalmPhotoHandle | imageH,
 |  | PalmPhotoHandle * | addedImageH
 | ) |

Add an image to a Palm Photos album. The image is added to the indicated Photos album. If the album resides on a different volume than imageH, then the image is copied into the new volume. A handle to the image in the designated album is returned in addedImageH. No image conversion takes place. The content of the image in the album is identical to that of the original image. If album doesn't exist, the image will be added to the "Unfiled" album. Passing albumID of PALM_PHOTO_ALBUM_ALL results in the image being added to the "Unfiled" album.

Parameters:
refNum,: IN: Library reference number.
albumID,: IN: Album ID for the image.
imageH,: IN: Image handle.
addedImageH,: OUT: The new image added to the album.
Return values:
Err Error code.

UInt16 PalmPhotoAlbumCount ( UInt16 refNum )

Get the number of albums in Palm Photos. For compatibility only; new development should use the V2 version.

Parameters:
refNum,: IN: Library reference number.
Return values:
UInt16 Album count.

UInt16 PalmPhotoAlbumCountV2 | ( | UInt16 | refNum,
 |  | UInt16 | volumeRef
 | ) |

Get the number of albums in Palm Photos residing on the specified volume. If volumeRef is 0, then the location is on the handheld. Otherwise, it is in VFS.

Parameters:
refNum,: IN: Library reference number.
volumeRef,: IN: Volume to search for photo albums.
Return values:
UInt16 Album count.

PalmPhotoHandle PalmPhotoCaptureImageV2 | ( | UInt16 | refNum,
 |  | const PalmPhotoCaptureParamV2 * | captureParamP
 | ) |

Capture a new still image or video clip using the built-in camera.

New functionality added in 3.0: Can capture video as well as still images. (For video, height and width in captureParam.imageInfo must match a supported resolution as returned by PalmPhotoGetSupportedCaptureResolutionsV3. Location in captureParam.fileLocation must be a VFSFile.) Can limit size (in bytes) of captured media. (Set captureParam.imageInfo.fileSize to the desired limit. If fileSize = 0, no constraint s placed on ithe file size.)

Parameters:
refNum,: IN: Library reference number.
captureParamP,: IN: Palm Photo capture parameter.
Return values:
PalmPhotoHandle The newly created photo handle or NULL if unsuccessful.

void PalmPhotoCloseImage | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH
 | ) |

Close an image. For compatibility only; new development should use the V2 version.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.

Err PalmPhotoCloseImageV2 | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH
 | ) |

Close an image.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
Return values:
Err Error code.

Err PalmPhotoConvertImageV2 | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | PalmPhotoHandle * | convertedImageHP,
 |  | const PalmPhotoCreateParam * | createParamP
 | ) |

Convert an image. New in v2.0.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
convertedImageHP,: OUT: The new image converted.
createParamP,: IN: File information and location for the new image.
Return values:
Err Error code.

PalmPhotoHandle PalmPhotoCreateImage | ( | UInt16 | refNum,
 |  | const PalmPhotoCreateParam * | createParamP,
 |  | Err * | errP
 | ) |

Create a new image. For compatibility only; new development should use the V2 version.

Parameters:
refNum,: IN: Library reference number.
createParamP,: IN: Palm Photo create parameter.
errP,: OUT: Error code.
Return values:
PalmPhotoHandle The newly created photo handle or NULL if unsuccessful.

PalmPhotoHandle PalmPhotoCreateImageV2 | ( | UInt16 | refNum,
 |  | const PalmPhotoCreateParam * | createParamP
 | ) |

Create a new image.

Parameters:
refNum,: IN: Library reference number.
createParamP,: IN: Palm Photo create parameter.
Return values:
PalmPhotoHandle The newly created photo handle or NULL if unsuccessful.

Err PalmPhotoCropImageV2 | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | PalmPhotoHandle * | croppedImageHP,
 |  | RectangleType * | cropRectP
 | ) |

Return a cropped image. New in v2.0.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
croppedImageHP,: OUT: The new image cropped.
cropRectP,: IN: Cropping rectangle.
Return values:
Err Error code.

Err PalmPhotoDeleteAlbum | ( | UInt16 | refNum,
 |  | UInt16 | albumID,
 |  | Boolean | moveToUnfiled
 | ) |

Delete an album by album ID.

Parameters:
refNum,: IN: Library reference number.
albumID,: IN: ID of the Album to delete.
moveToUnfiled,: IN: If true, photos from the deleted album are moved to /DCIM/Palm folder. Otherwise, they are deleted. In previous versions the Unfiled album was mapped to the /DCIM folder.
Return values:
Err Error code.

Err PalmPhotoDeleteImage | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH
 | ) |

Delete an image.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
Return values:
Err Error code.

Err PalmPhotoDisplayImage | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | const PalmPhotoDisplayParam * | displayParamP
 | ) |

Display an image or play a video. A still image referenced by imageH will be drawn in the window and rectangle specified within *displayParamP. If the window handle is NULL, the current draw window is used. A video referenced by imageH will be played in the video player, and the window and rectangle will be ignored.

The image is displayed "shrink to fit" mode, where 100% of the image is represented on the handheld display. (See also PalmPhotoDisplayImageToSizeV3 for "best fit" scaling.)

If the callback function returns false, the Photo API will halt the draw or play operation.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
displayParamP,: IN: Display parameter.
Return values:
Err Error code.

Err PalmPhotoDisplayImageToSizeV3 | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | const PalmPhotoDisplayParam * | displayParamP
 | ) |

Display an image or play a video. A still image referenced by imageH will be drawn in the window and rectangle specified within *displayParamP. If the window handle is NULL, the current draw window is used. A video referenced by imageH will be played in the video player, and the window and rectangle will be ignored.

The image is displayed in "best fit" mode, scaled exactly so that the rectangle is completely filled, then cropping anything outside the rectangle. (See also PalmPhotoDisplayImage for shrink-to-fit scaling.)

If the callback function returns false, the Photo API will halt the draw or play operation.

New in v3.0.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
displayParamP,: IN: Display parameter.
Return values:
Err Error code.

Err PalmPhotoDisplayThumbnailV3 | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | const PalmPhotoDisplayParam * | displayParamP
 | ) |

Display thumbnail for still image or video.

Thumbnail for the image or video referenced by imageH will be drawn in the window and rectangle specified within *displayParamP. (In the case of video, displays the first frame.) Use PalmPhotoGetThumbSize() first to get the thumbnail size. If the window handle is NULL, the current draw window is used.

If the callback function returns false, the Photo API will halt the draw or play operation.

New in v3.0.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
displayParamP,: IN: Display parameter.
Return values:
Err Error code.

void PalmPhotoFreeSelections | ( | UInt16 | refNum,
 |  | PalmPhotoSelectionParam * | photoSelectionP
 | ) |

Free memory allocated during the photos selection. For compatibility only; new development should use the V2 version.

Parameters:
refNum,: IN: Library reference number.
photoSelectionP,: IN,OUT: Palm Photo selection parameter.

Err PalmPhotoFreeSelectionsV2 | ( | UInt16 | refNum,
 |  | PalmPhotoSelectionParam * | photoSelectionP
 | ) |

Free memory allocated during the photos selection.

Parameters:
refNum,: IN: Library reference number.
photoSelectionP,: IN,OUT: Palm Photo selection parameter.
Return values:
Err Error code.

UInt16 PalmPhotoGetAlbumID | ( | UInt16 | refNum,
 |  | UInt16 | index
 | ) |

Get an album ID given the album index. For compatibility only; new development should use the V2 version.

Parameters:
refNum,: IN: Library reference number.
index,: IN: Album index.
Return values:
UInt16 Album ID. If album doesn't exist, return PALM_PHOTO_ALBUM_ALL.

UInt16 PalmPhotoGetAlbumIDV2 | ( | UInt16 | refNum,
 |  | UInt16 | volumeRef,
 |  | UInt16 | index
 | ) |

Get an album ID given the album index and volume. If volumeRef is 0, then the location is on the handheld. Otherwise, it is in VFS.

Parameters:
refNum,: IN: Library reference number.
volumeRef,: IN: Volume to search for photo album.
index,: IN: Album index.
Return values:
UInt16 Album ID. If album doesn't exist, return PALM_PHOTO_ALBUM_ALL.

Err PalmPhotoGetAlbumName | ( | UInt16 | refNum,
 |  | UInt16 | albumID,
 |  | Char * | nameP,
 |  | UInt16 | bufSize
 | ) |

Get an album name given the album ID. The buffer that will hold the album name is allocated by the user.

Parameters:
refNum,: IN: Library reference number.
albumID,: IN: Album ID
nameP,: OUT: Buffer that will contain the name of the album.
bufSize,: IN: Size of the buffer pointed by nameP.
Return values:
Err Error code.

Err PalmPhotoGetImageExtraInfo | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | PalmPhotoExtraInfoParam * | extraInfoP
 | ) |

Get an image extra information.

Note: new info types (palmPhotoExtraInfoSound and palmPhotoExtraInfoUID) added in 3.0.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
extraInfoP,: OUT: Structure that will hold the extra info requested.
Return values:
Err Error code.

UInt32 PalmPhotoGetImageExtraInfoSize | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | PalmPhotoExtraInfoType | infoType
 | ) |

Get an image extra information size.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
infoType,: IN: Extra info type to retrieve the size from.
Return values:
UInt32 The size of the extra information of the specified type.

Err PalmPhotoGetImageInfo | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | PalmPhotoImageInfo * | infoP
 | ) |

Get an image information.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
infoP,: OUT: Image info structure.
Return values:
Err Error code.

Err PalmPhotoGetLastErrV2 ( UInt16 refNum )

Get the error code from the last Photo API function that executed. Sets the Photo API error code to errNone, if the library is open. If the library is not open, it does not set the error code and returns palmPhotoLibErrNotOpen. New in v2.0.

Parameters:
refNum,: IN: Library reference number.
Return values:
Err Error code.

PalmPhotoCaptureResolution PalmPhotoGetSupportedCaptureResolutionsV3 | ( | UInt16 | refNum,
 |  | PalmPhotoMediaType | mediaType
 | ) |

Returns resolutions that are supported by the still or video camera. Returns zero (palmPhotoCaptureResNone) if no camera, or camera disabled.

Parameters:
refNum,: IN: Library reference number.
mediaType,: IN: palmPhotoMediaTypePhoto or palmPhotoMediaTypeVideo
Return values:
PalmPhotoCaptureResolution Flags (bit is set for each resolution that camera supports).

Err PalmPhotoGetThumbSize | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | UInt16 * | widthP,
 |  | UInt16 * | heightP
 | ) |

Get an image thumbnail size.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
widthP,: OUT: Width of the thumbnail.
heightP,: OUT: Height of the thumbnail.
Return values:
Err Error code.

UInt16 PalmPhotoImageCount | ( | UInt16 | refNum,
 |  | UInt16 | albumID
 | ) |

Get image count for an album.

Parameters:
refNum,: IN: Library reference number.
albumID,: IN: ID of the Album to retrieve information from.
Return values:
Err Error code.

Boolean PalmPhotoIsCameraAvailableV3 ( UInt16 refNum )

Check for presence of an enabled camera.

Parameters:
refNum,: IN: Library reference number.
Return values:
Boolean false if no camera or camera is disabled.

Err PalmPhotoLibClose ( UInt16 refNum )

Standard library close function

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code.

Err PalmPhotoLibGetVersion | ( | UInt16 | refNum,
 |  | UInt32 | sdkVersion,
 |  | UInt32 * | libVersionP
 | ) |

Checks the version of the Palm Photo Library.

Parameters:
refNum,: IN: Library reference number.
sdkVersion,: IN: The version the application expects.
libVersionP,: OUT: The actual version of the library.
Return values:
Err Error code.

Err PalmPhotoLibOpen ( UInt16 refNum )

Standard library open function

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code.

Err PalmPhotoLibSleep ( UInt16 refNum )

Standard library sleep function

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code.

Err PalmPhotoLibWake ( UInt16 refNum )

Standard library wake function

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code.

UInt16 PalmPhotoNewAlbum | ( | UInt16 | refNum,
 |  | const Char * | nameP,
 |  | Err * | errP
 | ) |

Create a new album. For compatibility only; new development should use the V2 version.

Parameters:
refNum,: IN: Library reference number.
nameP,: IN: String that contains the name of the new album.
errP,: OUT: Error code.
Return values:
UInt16 If successful, returns the ID of the newly created album. Otherwise, returns PALM_PHOTO_ALBUM_ALL.

UInt16 PalmPhotoNewAlbumV2 | ( | UInt16 | refNum,
 |  | UInt16 | volumeRef,
 |  | const Char * | nameP
 | ) |

Create a new album in the selected volume. If volumeRef is 0, then the location is on the handheld. Otherwise, it is in VFS.

Parameters:
refNum,: IN: Library reference number.
volumeRef,: IN: Volume to search for photo album.
nameP,: IN: String that contains the name of the new album.
Return values:
UInt16 If successful, returns the ID of the newly created album. Otherwise, returns PALM_PHOTO_ALBUM_ALL.

PalmPhotoHandle PalmPhotoOpenImage | ( | UInt16 | refNum,
 |  | const PalmPhotoFileLocation * | photoFileP,
 |  | Err * | errP
 | ) |

Open an existing image. For compatibility only; new development should use the V2 version.

Parameters:
refNum,: IN: Library reference number.
photoFileP,: IN: Palm Photo file location.
errP,: OUT: Error code.
Return values:
PalmPhotoHandle The opened photo handle or NULL if unsuccessful.

PalmPhotoHandle PalmPhotoOpenImageV2 | ( | UInt16 | refNum,
 |  | const PalmPhotoFileLocation * | photoFileP
 | ) |

Open an existing image.

Parameters:
refNum,: IN: Library reference number.
photoFileP,: IN: Palm Photo file location.
Return values:
PalmPhotoHandle The opened photo handle or NULL if unsuccessful.

Err PalmPhotoReadImage | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | const PalmPhotoReadWriteParam * | readParamP
 | ) |

Read image data given an image handle. The image format specifies what type of buffer the user expects to copy read data into. For example, to convert a JPEG image to RBG565 data, open a JPEG image, and set readParamP->imageFormat to palmPhotoRGB565FileFormat. The callback function should copy the image data from *bufferP into a buffer referenced within readParamP->userDataP.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
readParamP,: IN,OUT: Read parameters.
Return values:
Err Error code.

Err PalmPhotoRenameAlbum | ( | UInt16 | refNum,
 |  | UInt16 | albumID,
 |  | const Char * | nameP
 | ) |

Rename an album. If Photos has "Camera" album, it also can't be renamed.

Parameters:
refNum,: IN: Library reference number.
albumID,: IN: ID of the Album to delete.
nameP,: IN: New album name.
Return values:
Err Error code.

Err PalmPhotoRotateImageV2 | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | PalmPhotoHandle * | rotatedImageHP,
 |  | Int16 | rotation
 | ) |

Return a rotated image. New in v2.0.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
rotatedImageHP,: OUT: The new image rotated.
rotation,: IN: Rotation angle (rotation is counter-clockwise).
Return values:
Err Error code.

Err PalmPhotoScaleImageV2 | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | PalmPhotoHandle * | scaledImageHP,
 |  | UInt32 | width,
 |  | UInt32 | height
 | ) |

Return a scaled image. New in v2.0.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
scaledImageHP,: OUT: The new image scaled.
width,: IN: New image width (must be <= existing width).
height,: IN: New image height (must be <= existing height).
Return values:
Err Error code.

Err PalmPhotoSelectDlg | ( | UInt16 | refNum,
 |  | PalmPhotoSelectionParam * | photoSelectionP,
 |  | PalmPhotoDlgType | dlgType,
 |  | Boolean | handleCard
 | ) |

Select images using the Media Selection/Deletion dialog. The selected images are passed in the selection parameter. To free the memory allocated, use the PalmPhotoFreeSelections() function.

Parameters:
refNum,: IN: Library reference number.
photoSelectionP,: IN,OUT: Palm Photo selection parameter. Contains array of selections on return.
dlgType,: IN: Selection dialog type (eg palmPhotoDlgSelection...)
handleCard,: IN: If true, the dialog with intercept card notifications.
Return values:
Err Error code.

Err PalmPhotoSelectDlgV3 | ( | UInt16 | refNum,
 |  | PalmPhotoSelectionParam * | photoSelectionP,
 |  | const PalmPhotoCaptureParamV2 * | captureParamP,
 |  | PalmPhotoDlgType | dlgType,
 |  | PalmPhotoMediaType | mediaType,
 |  | Boolean | handleCard
 | ) |

Select images using the Photo Selection/Deletion dialog, with optional camera support. The selected images are passed in the selection parameter. To free the memory allocated, use the PalmPhotoFreeSelections() function.

Parameters:
refNum,: IN:Library reference number.
photoSelectionP,: IN,OUT: Palm Photo selection parameter. Contains array of selections on return.
captureParamP,: IN: Palm Photo capture parameter. Set to null to suppress the camera. Camera only supported for single select dialog type. Camera only supported when media type is photo OR video (not all)
dlgType,: IN: Selection dialog type (eg palmPhotoDlgSelection...)
mediaType,: IN: Dialog displays only photos, only videos, or all media types.
handleCard,: IN: If true, the dialog with intercept card notifications.
Return values:
Err Error code.

Err PalmPhotoSelectImages | ( | UInt16 | refNum,
 |  | PalmPhotoSelectionParam * | photoSelectionP
 | ) |

Select images within a specific range. The selected images are passed in the selection parameter. To free the memory allocated, use the PalmPhotoFreeSelections() function.

Parameters:
refNum,: IN: Library reference number.
photoSelectionP,: IN,OUT: Palm Photo selection parameter. Contains array of selections on return.
Return values:
Err Error code.

Err PalmPhotoSetImageExtraInfo | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | const PalmPhotoExtraInfoParam * | extraInfoP
 | ) |

Set an image extra information. When user set palmPhotoExtraInfoLocation, if the file name contains illegal characters, the function will remove them. If the file name has an incorrect file extension, the function will add the correct one. For example, if the format is Jpeg, "*22.j" will be converted to "22.jpg".

Parameters:
refNum,: IN: Library reference number.
imageH,: IN: Image handle.
extraInfoP,: IN: Structure that the extra info the extra info to set.
Return values:
Err Error code.

Err PalmPhotoWriteImage | ( | UInt16 | refNum,
 |  | PalmPhotoHandle | imageH,
 |  | const PalmPhotoReadWriteParam * | writeParamP
 | ) |

Write image data given an image handle. The writeParamP->imageFormat parameter specifies the source format the calling application is providing to the API to write into storage. The only valid source formats are RGB565 and RGB888. For example, to convert an RGB565 image to a JPEG, you would create a JPEG image and pass its handle in imageH; then you would set writeParamP->imageFormat to palmPhotoRGB565FileFormat. The actual RGB image data would be referenced by a pointer inside writeParamP->userDataP. The callback function will pass the RGB data to the API by copying it into *bufferP.

Parameters:
refNum,: IN: Library reference number.
imageH,: IN,OUT: Image handle.
writeParamP,: IN: Write parameters.
Return values:
Err Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:14 2006 for Palm API Guide


palmOnePhotoCommon.h File Reference

Detailed Description

Palm Photos API: This file contains all the defines, enumerations, structures needed by PalmPhoto.h.

Version:
3.0

Include dependency graph for palmOnePhotoCommon.h:

Data Structures

  • struct _PalmPhotoFileLocation
    Photo file location. More...
  • struct _PalmPhotoImageInfo
    Photo information. More...
  • struct _PalmPhotoExtraInfo
    Photo image extra info parameters. More...
  • struct _PalmPhotoSelections
    Photo selections. More...

Library Versions

  • #define kPalmPhotoLibVersion1 sysMakeROMVersion(1, 0, 0, sysROMStageRelease, 0)
  • #define kPalmPhotoLibVersion2 sysMakeROMVersion(2, 0, 0, sysROMStageRelease, 0)
  • #define kPalmPhotoLibVersion3 sysMakeROMVersion(3, 0, 0, sysROMStageRelease, 1)
  • #define kPalmPhotoLibVersion kPalmPhotoLibVersion3

Error Codes

  • #define palmPhotoLibErrParam (oemErrorClass + 0x100)
  • #define palmPhotoLibErrNotOpen (palmPhotoLibErrParam | 1)
  • #define palmPhotoLibErrStillOpen (palmPhotoLibErrParam | 2)
  • #define palmPhotoLibErrNotPhotos (palmPhotoLibErrParam | 3)
  • #define palmPhotoLibErrNotOpenPhotos (palmPhotoLibErrParam | 4)
  • #define palmPhotoLibErrAlbumExist (palmPhotoLibErrParam | 5)
  • #define palmPhotoLibErrAlbumNotExist (palmPhotoLibErrParam | 6)
  • #define palmPhotoLibErrAlbumFull (palmPhotoLibErrParam | 7)
  • #define palmPhotoLibErrAlbumNameTooLong (palmPhotoLibErrParam | 8)
  • #define palmPhotoLibErrAlbumReadOnly (palmPhotoLibErrParam | 9)
  • #define palmPhotoLibErrLowHeap (palmPhotoLibErrParam | 10)
  • #define palmPhotoLibErrLowMemory (palmPhotoLibErrParam | 11)
  • #define palmPhotoLibErrImageExist (palmPhotoLibErrParam | 12)
  • #define palmPhotoLibErrImageNotFound (palmPhotoLibErrParam | 13)
  • #define palmPhotoLibErrFormatNotSupported (palmPhotoLibErrParam | 14)
  • #define palmPhotoLibErrImageNotInPhotos (palmPhotoLibErrParam | 15)
  • #define palmPhotoLibErrImageInvalidPath (palmPhotoLibErrParam | 16)
  • #define palmPhotoLibErrUserCancel (palmPhotoLibErrParam | 17)
  • #define palmPhotoLibErrScreenDepth (palmPhotoLibErrParam | 18)
  • #define palmPhotoLibErrSmallBuffer (palmPhotoLibErrParam | 19)
  • #define palmPhotoLibErrUnknown (palmPhotoLibErrParam | 20)
  • #define palmPhotoLibErrNoThumbnail (palmPhotoLibErrParam | 21)
  • #define palmPhotoLibErrAbortReadWrite (palmPhotoLibErrParam | 22)
  • #define palmPhotoLibErrUnsupportedRotation (palmPhotoLibErrParam | 23)
  • #define palmPhotoLibErrInvalidVolume (palmPhotoLibErrParam | 24)
  • #define palmPhotoLibErrNoCamera (palmPhotoLibErrParam | 25)
  • #define palmPhotoLibErrOldVersion (palmPhotoLibErrParam | 26)
  • #define palmPhotoLibErrProtectedMedia (palmPhotoLibErrParam | 27)
  • #define palmPhotoLibErrLowPower (palmPhotoLibErrParam | 28)

Old Constant Names

  • #define palmPhotoAVIM4AFileFormat palmPhotoFormat_AVI_ADPCM_MPEG4
  • #define palmPhotoAVIM43FileFormat palmPhotoFormat_AVI_MP3_MPEG4
  • #define palmPhotoASFM4AFileFormat palmPhotoFormat_ASF_ADPCM_MPEG4
  • #define palmPhotoASFM43FileFormat palmPhotoFormat_ASF_MP3_MPEG4

Defines

  • #define PMP_LIB_TRAP(trapNum) SYS_TRAP(trapNum)
  • #define PalmPhotoLibCreatorID 'PMPL'
  • #define PalmPhotoLibTypeID sysFileTLibrary
  • #define PalmPhotoLibName "PalmPhotoLib"
  • #define palmPhotoJPEGFileFormat (0x0001)
  • #define palmPhotoRGB888FileFormat (0x0002)
  • #define palmPhotoRGB565FileFormat (0x0003)
  • #define palmPhotoGIFFileFormat (0x0004)
  • #define palmPhotoBMPFileFormat (0x0005)
  • #define palmPhotoTIFFFileFormat (0x0006)
  • #define palmPhotoPNGFileFormat (0x0007)
  • #define palmPhotoWBMPFileFormat (0x0008)
  • #define palmPhotoMJPEGFileFormat (0x1001)
  • #define palmPhotoMPEG1FileFormat (0x1002)
  • #define palmPhotoMPEG4FileFormat (0x1003)
  • #define palmPhotoFormat_AVI_ADPCM_MPEG4 (0x1113)
  • #define palmPhotoFormat_AVI_MP3_MPEG4 (0x1123)
  • #define palmPhotoFormat_ASF_ADPCM_MPEG4 (0x1213)
  • #define palmPhotoFormat_ASF_MP3_MPEG4 (0x1223)
  • #define palmPhotoFormat_3GP_AMR_MPEG4 (0x1333)
  • #define palmPhotoFormat_3GP_AMR_H263 (0x1334)
  • #define palmPhotoFormat_3G2_QCELP_MPEG4 (0x1443)
  • #define palmPhotoFormat_3G2_QCELP_H263 (0x1444)
  • #define palmPhotoPreferredImageFormat (0xFFFD)
  • #define palmPhotoPreferredVideoFormat (0xFFFE)
  • #define palmPhotoUnsupportedFormat (0xFFFF)
  • #define palmPhotoCaptureResSUBQCIF (0x00000001)
  • #define palmPhotoCaptureResQQVGA (0x00000002)
  • #define palmPhotoCaptureResQCIF (0x00000004)
  • #define palmPhotoCaptureResQVGA (0x00000008)
  • #define palmPhotoCaptureResCIF (0x00000010)
  • #define palmPhotoCaptureResVGA (0x00000020)
  • #define palmPhotoCaptureResSVGA (0x00000040)
  • #define palmPhotoCaptureResXVGA (0x00000080)
  • #define palmPhotoCaptureResSXGA (0x00000100)
  • #define palmPhotoCaptureResSXGA960 (0x00000100)
  • #define palmPhotoCaptureResSXGA1024 (0x00000200)
  • #define palmPhotoCaptureResOther (0x80000000)
  • #define palmPhotoCaptureResNone (0x00000000)
  • #define palmPhotoStreamLocation (0x0000)
  • #define palmPhotoVFSLocation (0x0001)
  • #define palmPhotoMemoryLocation (0x0002)
  • #define palmPhotoExtraInfoLocation (0x0000)
  • #define palmPhotoExtraInfoDate (0x0001)
  • #define palmPhotoExtraInfoAlbum (0x0002)
  • #define palmPhotoExtraInfoNotes (0x0003)
  • #define palmPhotoExtraInfoSound (0x0004)
  • #define palmPhotoExtraInfoImageUID (0x0005)
  • #define palmPhotoExtraInfoSoundUID (0x0006)
  • #define palmPhotoExtraInfoCompositeUID (0x0007)
  • #define palmPhotoDlgSelection (0x0000)
  • #define palmPhotoDlgSingleSelection (0x0001)
  • #define palmPhotoDlgDeletion (0x0002)
  • #define palmPhotoMediaTypePhoto (0x0001)
  • #define palmPhotoMediaTypeVideo (0x0002)
  • #define palmPhotoMediaTypeAll (0xFFFF)
  • #define palmPhotoHighestQuality (0xFFFF)
  • #define palmPhotoHighQuality (0xFFFE)
  • #define palmPhotoMediumQuality (0xFFFD)
  • #define palmPhotoLowQuality (0xFFFC)
  • #define palmPhotoLowestQuality (0xFFFB)
  • #define PALM_PHOTO_MAX_PATH (255)
  • #define PALM_PHOTO_SELECT_ALL ((Int32)0xFFFFFFFF)
  • #define PALM_PHOTO_ALBUM_ALL ((UInt16)0xFFFF)
  • #define PALM_PHOTO_ALBUM_ALL_HANDHELD ((UInt16)0xFFFF)
  • #define PALM_PHOTO_ALBUM_ALL_VFS ((UInt16)0xFFFE)
  • #define PALM_PHOTO_ALBUM_MAX_NAME (255)

Typedefs

  • typedef UInt16 PalmPhotoFileFormat
  • typedef UInt32 PalmPhotoCaptureResolution
  • typedef UInt16 PalmPhotoLocationType
  • typedef UInt8 PalmPhotoUID [21]
  • typedef UInt16 PalmPhotoExtraInfoType
  • typedef UInt16 PalmPhotoDlgType
  • typedef UInt16 PalmPhotoMediaType
  • typedef UInt16 PalmPhotoQualityType
  • typedef _PalmPhotoFileLocation PalmPhotoFileLocation
    Photo file location.
  • typedef _PalmPhotoImageInfo PalmPhotoImageInfo
    Photo information.
  • typedef _PalmPhotoExtraInfo PalmPhotoExtraInfoParam
    Photo image extra info parameters.
  • typedef _PalmPhotoType * PalmPhotoHandle
  • typedef _PalmPhotoSelections PalmPhotoSelections
    Photo selections.

Define Documentation

#define PALM_PHOTO_ALBUM_ALL ((UInt16)0xFFFF)

Used to select all the albums at once.

#define PALM_PHOTO_ALBUM_ALL_HANDHELD ((UInt16)0xFFFF)

Used to select all the albums on the handheld at once.

#define PALM_PHOTO_ALBUM_ALL_VFS ((UInt16)0xFFFE)

Used to select all the albums on the VFS card at once.

#define PALM_PHOTO_ALBUM_MAX_NAME (255)

Maximum album name length on device. (Increased for v3.0.)

#define PALM_PHOTO_MAX_PATH (255)

Maximum file path length.

#define PALM_PHOTO_SELECT_ALL ((Int32)0xFFFFFFFF)

Used during selection to select maximum number of photos.

#define palmPhotoASFM43FileFormat palmPhotoFormat_ASF_MP3_MPEG4

Old (2.0) constant names for compatibility

#define palmPhotoASFM4AFileFormat palmPhotoFormat_ASF_ADPCM_MPEG4

Old (2.0) constant names for compatibility

#define palmPhotoAVIM43FileFormat palmPhotoFormat_AVI_MP3_MPEG4

Old (2.0) constant names for compatibility

#define palmPhotoAVIM4AFileFormat palmPhotoFormat_AVI_ADPCM_MPEG4

Old (2.0) constant names for compatibility

#define palmPhotoBMPFileFormat (0x0005)

BMP bitmap format New in v2.0.

#define palmPhotoCaptureResCIF (0x00000010)

CIF (352x288) New in v3.0.

#define palmPhotoCaptureResNone (0x00000000)

None (no camera or camera disabled)

#define palmPhotoCaptureResOther (0x80000000)

Unknown dimensions (caller must use CameraManager)

#define palmPhotoCaptureResQCIF (0x00000004)

QCIF (176x144) New in v3.0.

#define palmPhotoCaptureResQQVGA (0x00000002)

QQVGA (160x120) New in v3.0.

#define palmPhotoCaptureResQVGA (0x00000008)

QVGA (320x240) New in v3.0.

#define palmPhotoCaptureResSUBQCIF (0x00000001)

SUBQCIF (128x96) New in v3.0.

#define palmPhotoCaptureResSVGA (0x00000040)

SVGA (800x600) New in v3.0.

#define palmPhotoCaptureResSXGA (0x00000100)

SXGA (1280x960) New in v3.0.

#define palmPhotoCaptureResSXGA1024 (0x00000200)

SXGA (1280x1024) New in v3.0.

#define palmPhotoCaptureResSXGA960 (0x00000100)

SXGA (1280x960) New in v3.0.

#define palmPhotoCaptureResVGA (0x00000020)

VGA (640x480) New in v3.0.

#define palmPhotoCaptureResXVGA (0x00000080)

XVGA (1024x768) New in v3.0.

#define palmPhotoDlgDeletion (0x0002)

Deletion dialog.

#define palmPhotoDlgSelection (0x0000)

Mutiple selection dialog.

#define palmPhotoDlgSingleSelection (0x0001)

Single selection dialog.

#define palmPhotoExtraInfoAlbum (0x0002)

Album.infoP points to a (Char *).

#define palmPhotoExtraInfoCompositeUID (0x0007)

Notes.infoP points to a PalmPhotoUID. New in v3.0.

#define palmPhotoExtraInfoDate (0x0001)

Date.infoP points to a DateType.

#define palmPhotoExtraInfoImageUID (0x0005)

Notes.infoP points to a PalmPhotoUID. New in v3.0.

#define palmPhotoExtraInfoLocation (0x0000)

File location.infoP points to a PalmPhotoFileLocation.

#define palmPhotoExtraInfoNotes (0x0003)

Notes.infoP points to a (Char *).

#define palmPhotoExtraInfoSound (0x0004)

Notes.infoP points to a PalmPhotoFileLocation. New in v3.0.

#define palmPhotoExtraInfoSoundUID (0x0006)

Notes.infoP points to a PalmPhotoUID. New in v3.0.

#define palmPhotoFormat_3G2_QCELP_H263 (0x1444)

3G2 file with QCELP audio + H.263 video New in v3.0.

#define palmPhotoFormat_3G2_QCELP_MPEG4 (0x1443)

3G2 file with QCELP audio + MPEG4 video New in v3.0.

#define palmPhotoFormat_3GP_AMR_H263 (0x1334)

3GP file with AMR audio + H.263 video New in v3.0.

#define palmPhotoFormat_3GP_AMR_MPEG4 (0x1333)

3GP file with AMR audio + MPEG4 video New in v3.0.

#define palmPhotoFormat_ASF_ADPCM_MPEG4 (0x1213)

ASF file with ADPCM audio + MPEG4 video New in v2.0.

#define palmPhotoFormat_ASF_MP3_MPEG4 (0x1223)

ASF file with MP3 audio + MPEG4 video New in v2.0.

#define palmPhotoFormat_AVI_ADPCM_MPEG4 (0x1113)

AVI file with ADPCM audio + MPEG4 video New in v2.0.

#define palmPhotoFormat_AVI_MP3_MPEG4 (0x1123)

AVI file with MP3 audio + MPEG4 video New in v2.0.

#define palmPhotoGIFFileFormat (0x0004)

GIF 8-bit indexed color format New in v2.0.

#define palmPhotoHighestQuality (0xFFFF)

Highest quality compressed image.

#define palmPhotoHighQuality (0xFFFE)

High quality compressed image.

#define palmPhotoJPEGFileFormat (0x0001)

JPEG file format.

#define PalmPhotoLibCreatorID 'PMPL'

Palm Photo Library creator id

#define palmPhotoLibErrAbortReadWrite (palmPhotoLibErrParam | 22)

Abort a read or write operation. New in v2.0.

#define palmPhotoLibErrAlbumExist (palmPhotoLibErrParam | 5)

The album already exists.

#define palmPhotoLibErrAlbumFull (palmPhotoLibErrParam | 7)

The album is full.

#define palmPhotoLibErrAlbumNameTooLong (palmPhotoLibErrParam | 8)

The album name is too long.

#define palmPhotoLibErrAlbumNotExist (palmPhotoLibErrParam | 6)

The selected album does not exist.

#define palmPhotoLibErrAlbumReadOnly (palmPhotoLibErrParam | 9)

The album cannot be renamed or deleted.

#define palmPhotoLibErrFormatNotSupported (palmPhotoLibErrParam | 14)

Image format not supported for the attempted operation.

#define palmPhotoLibErrImageExist (palmPhotoLibErrParam | 12)

An image with that name already exists.

#define palmPhotoLibErrImageInvalidPath (palmPhotoLibErrParam | 16)

Invalid path/image name.

#define palmPhotoLibErrImageNotFound (palmPhotoLibErrParam | 13)

Specified image does not exist.

#define palmPhotoLibErrImageNotInPhotos (palmPhotoLibErrParam | 15)

Image is not in the Photos database.

#define palmPhotoLibErrInvalidVolume (palmPhotoLibErrParam | 24)

Invalid volume for operation. New in v2.0.

#define palmPhotoLibErrLowHeap (palmPhotoLibErrParam | 10)

Insufficient free space in dynamic heap.

#define palmPhotoLibErrLowMemory (palmPhotoLibErrParam | 11)

Insufficient free space in storage heap.

#define palmPhotoLibErrLowPower (palmPhotoLibErrParam | 28)

The Power too lower

#define palmPhotoLibErrNoCamera (palmPhotoLibErrParam | 25)

Device has no camera. New in v2.0.

#define palmPhotoLibErrNoThumbnail (palmPhotoLibErrParam | 21)

Image has no thumbnail.

#define palmPhotoLibErrNotOpen (palmPhotoLibErrParam | 1)

Library not open.

#define palmPhotoLibErrNotOpenPhotos (palmPhotoLibErrParam | 4)

Could not open Photos database.

#define palmPhotoLibErrNotPhotos (palmPhotoLibErrParam | 3)

Photos database does not exist on device.

#define palmPhotoLibErrOldVersion (palmPhotoLibErrParam | 26)

Library version is too old.

#define palmPhotoLibErrParam (oemErrorClass + 0x100)

Invalid parameter.

#define palmPhotoLibErrProtectedMedia (palmPhotoLibErrParam | 27)

Invalid operation for media protected by DRM

#define palmPhotoLibErrScreenDepth (palmPhotoLibErrParam | 18)

Unsupported handheld screen color depth.

#define palmPhotoLibErrSmallBuffer (palmPhotoLibErrParam | 19)

Buffer is too small.

#define palmPhotoLibErrStillOpen (palmPhotoLibErrParam | 2)

Library is still open.

#define palmPhotoLibErrUnknown (palmPhotoLibErrParam | 20)

Unknown or unclassifiable error.

#define palmPhotoLibErrUnsupportedRotation (palmPhotoLibErrParam | 23)

Rotation angle not supported. New in v2.0.

#define palmPhotoLibErrUserCancel (palmPhotoLibErrParam | 17)

User canceled operation.

#define PalmPhotoLibName "PalmPhotoLib"

Palm Photo Library database name

#define PalmPhotoLibTypeID sysFileTLibrary

Standard library type

#define palmPhotoLowestQuality (0xFFFB)

Lowest quality compressed image.

#define palmPhotoLowQuality (0xFFFC)

Low quality compressed image.

#define palmPhotoMediaTypeAll (0xFFFF)

All media types (in 3.0, limited to photos and video).

#define palmPhotoMediaTypePhoto (0x0001)

Select still image types

#define palmPhotoMediaTypeVideo (0x0002)

Select video types

#define palmPhotoMediumQuality (0xFFFD)

Normal quality compressed image.

#define palmPhotoMemoryLocation (0x0002)

Memory file. Read-Only images.

#define palmPhotoMJPEGFileFormat (0x1001)

M-JPEG video format New in v2.0.

#define palmPhotoMPEG1FileFormat (0x1002)

MPEG1 video format New in v2.0.

#define palmPhotoMPEG4FileFormat (0x1003)

MPEG4 video format New in v2.0.

#define palmPhotoPNGFileFormat (0x0007)

PNG bitmap format New in v2.0.

#define palmPhotoPreferredImageFormat (0xFFFD)

Default still capture format. New in v3.0.

#define palmPhotoPreferredVideoFormat (0xFFFE)

Default video capture format. New in v3.0.

#define palmPhotoRGB565FileFormat (0x0003)

Raw RGB 565 file format.

#define palmPhotoRGB888FileFormat (0x0002)

Raw RGB 888 file format.

#define palmPhotoStreamLocation (0x0000)

File stream on the device.

#define palmPhotoTIFFFileFormat (0x0006)

TIFF bitmap format New in v2.0.

#define palmPhotoUnsupportedFormat (0xFFFF)

Unsupported file format.

#define palmPhotoVFSLocation (0x0001)

VFS file.

#define palmPhotoWBMPFileFormat (0x0008)

WBMP bitmap format New in v2.0.

Typedef Documentation

typedef UInt32 PalmPhotoCaptureResolution

Used with palmPhotoCaptureRes defines

typedef UInt16 PalmPhotoDlgType

Palm Photo dialog type.

typedef struct _PalmPhotoExtraInfo PalmPhotoExtraInfoParam

Photo image extra info parameters.

Gets extra information on an image.

typedef UInt16 PalmPhotoExtraInfoType

Palm Photo extra information type.

typedef UInt16 PalmPhotoFileFormat

Palm Photo file format.

typedef struct _PalmPhotoFileLocation PalmPhotoFileLocation

Photo file location.

This structure is used to open, create and query location information of an image.

typedef struct _PalmPhotoType* PalmPhotoHandle

Palm Photo handle.

See also:
_PalmPhotoType

typedef struct _PalmPhotoImageInfo PalmPhotoImageInfo

Photo information.

This structure contains the basic image information.

typedef UInt16 PalmPhotoLocationType

Palm Photo file location type.

typedef UInt16 PalmPhotoMediaType

Palm Photo media type (used in PalmPhotoSelectDlgV3).

typedef UInt16 PalmPhotoQualityType

Palm Photo image quality type.

typedef struct _PalmPhotoSelections PalmPhotoSelections

Photo selections.

This strucutre is used during image selections, either by using the PalmPhotoSelectDlg() function of the PalmPhotoSelect() function.

typedef UInt8 PalmPhotoUID[21]

Unique ID

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:16 2006 for Palm API Guide


palmOneResources.h File Reference

Detailed Description

Palm-specific system types and resources.

Version:
1.0
Date:
02/29/2002

Company ID - registered creator

  • #define kPalmCompanyIDPalm 'Palm'
  • #define kPalmCompanyIDHandspring 'hspr'
  • #define kPalmCompanyIDOldPalm 'palm'

Device ID - registered creator

  • #define kPalmOneDeviceIDZire 'Cubs'
  • #define kPalmOneDeviceIDTungstenT 'Frg1'
  • #define kPalmOneDeviceIDTungstenW 'atlc'
  • #define kPalmOneDeviceIDTungstenC 'MT64'
  • #define kPalmOneDeviceIDZire71 'Zpth'
  • #define kPalmOneDeviceIDTungstenT2 'Frg2'
  • #define kPalmOneDeviceIDTungstenT3 'Arz1'
  • #define kPalmOneDeviceIDTungstenTE 'Cct1'
  • #define kPalmOneDeviceIDZire21 'Zi21'
  • #define kPalmOneDeviceIDTreo600 'H101'
  • #define kPalmOneDeviceIDTreo600Sim 'H201'
  • #define kPalmOneDeviceIDZire31 'Zi22'
  • #define kPalmOneDeviceIDZire72 'Zi72'
  • #define kPalmOneDeviceIDAngus 'TnT5'
  • #define kPalmOneDeviceIDTungstenT5 kPalmOneDeviceIDAngus
  • #define kPalmOneDeviceIDTreo650 'H102'
  • #define kPalmOneDeviceIDTreo650Sim 'H202'
  • #define kPalmOneDeviceIDTungstenE2 'Zir4'
  • #define kPalmOneDeviceIDTungstenX 'TunX'
  • #define kPalmDeviceIDTX 'D050'
  • #define kPalmDeviceIDZ22 'D051'
  • #define kPalmOneDeviceIDDevice3 'H103'
  • #define kPalmOneDeviceIDDevice4 'H104'
  • #define kPalmOneDeviceIDDevice5 'H105'
  • #define kPalmOneDeviceIDDevice6 'H106'
  • #define kPalmOneDeviceIDDevice7 'H107'
  • #define kPalmOneDeviceIDDevice8 'H108'
  • #define kPalmOneDeviceIDDevice9 'H109'
  • #define kPalmOneDeviceIDDeviceA 'H10A'
  • #define kPalmOneDeviceIDVentura 'D052'
  • #define kPalmOneDeviceIDLowrider 'D053'

Define Documentation

#define kPalmCompanyIDHandspring 'hspr'

Handspring company ID to be used with past products

#define kPalmCompanyIDOldPalm 'palm'

Old company ID. For Tungsten|W.

#define kPalmCompanyIDPalm 'Palm'

Company ID.

#define kPalmDeviceIDTX 'D050'

Device ID for Palm T|X

#define kPalmDeviceIDZ22 'D051'

Device ID for Palm Z22

#define kPalmOneDeviceIDAngus 'TnT5'

Device ID for Tungsten|T5.

#define kPalmOneDeviceIDDevice3 'H103'

Device ID reserved for future use.

#define kPalmOneDeviceIDDevice4 'H104'

Device ID reserved for future use.

#define kPalmOneDeviceIDDevice5 'H105'

Device ID reserved for future use.

#define kPalmOneDeviceIDDevice6 'H106'

Device ID reserved for future use.

#define kPalmOneDeviceIDDevice7 'H107'

Device ID reserved for future use.

#define kPalmOneDeviceIDDevice8 'H108'

Device ID reserved for future use.

#define kPalmOneDeviceIDDevice9 'H109'

Device ID reserved for future use.

#define kPalmOneDeviceIDDeviceA 'H10A'

Device ID reserved for future use.

#define kPalmOneDeviceIDLowrider 'D053'

Device ID for Lowrider.

#define kPalmOneDeviceIDTreo600 'H101'

Device ID for Treo600.

#define kPalmOneDeviceIDTreo600Sim 'H201'

Device ID for Treo600 Simulator.

#define kPalmOneDeviceIDTreo650 'H102'

Device ID for Treo650.

#define kPalmOneDeviceIDTreo650Sim 'H202'

Device ID for Treo650 Simulator.

#define kPalmOneDeviceIDTungstenC 'MT64'

Device ID for Tungsten|C.

#define kPalmOneDeviceIDTungstenE2 'Zir4'

Device ID for Tungsten E2.

#define kPalmOneDeviceIDTungstenT 'Frg1'

Device ID for Tungsten|T.

#define kPalmOneDeviceIDTungstenT2 'Frg2'

Device ID for Tungsten|T2.

#define kPalmOneDeviceIDTungstenT3 'Arz1'

Device ID for Tungsten|T3.

#define kPalmOneDeviceIDTungstenT5 kPalmOneDeviceIDAngus

Device ID for Tungsten|T5.

#define kPalmOneDeviceIDTungstenTE 'Cct1'

Device ID for Tungsten|E.

#define kPalmOneDeviceIDTungstenW 'atlc'

Device ID for Tungsten|W.

#define kPalmOneDeviceIDTungstenX 'TunX'

Device ID for LifeDrive

#define kPalmOneDeviceIDVentura 'D052'

Device ID for Ventura.

#define kPalmOneDeviceIDZire 'Cubs'

Device ID for Zire.

#define kPalmOneDeviceIDZire21 'Zi21'

Device ID for Zire21.

#define kPalmOneDeviceIDZire31 'Zi22'

Device ID for Zire31.

#define kPalmOneDeviceIDZire71 'Zpth'

Device ID for Zire71.

#define kPalmOneDeviceIDZire72 'Zi72'

Device ID for Zire72.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:16 2006 for Palm API Guide


palmOneSndFileStream.h File Reference

Detailed Description

Public 68K include file for sound files stream support for Treo 600 and Treo 650 smartphones.

This header file and associated header files support the specific sound functionality of the Treo smartphones. You should use the Palm OS Sound Manager APIs for most of your work.

Notes: The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application(ie, SysLibFind() returns a valid refnum). When the application is done with the library, it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal synchronization.

Include dependency graph for palmOneSndFileStream.h:

Data Structures

  • struct tagSndFileStreamData
    Holds data about a sound file stream. More...
  • struct tagSndFileStreamFileSpec
    Descriptions of the stream file. More...
  • struct tagSndFileStreamHsSoundCommandParam
    SndFileStreamDeviceControl param when cmd == hsSoundLibCreatorID. More...

Type and creator of the Sound File Stream library

Used with FtrGet.
  • #define kSndFileStreamLibType sysFileTLibrary
  • #define kSndFileStreamLibCreator 'sfsL'
  • #define kSndFileStreamLibName "SndFileStream-sfsL"
  • #define kSndFileStreamLibVersion sysMakeROMVersion(1, 4, 0, sysROMStageRelease, 20)

Utility macros

These macros take care of opening and closing the sound file stream library in various situations.
  • #define SndFileStreamOpenLibrary(refNum, err)
  • #define SndFileStreamCloseLibrary(refNum, err)

Error codes

These macros take care of opening and closing the sound file stream library in various situations.
  • #define kSndFileStreamLibErrNone errNone
  • #define kSndFileStreamLibErrAlreadyOpen 1
  • #define kSndFileStreamLibErrNotOpen 2
  • #define kSndFileStreamLibErrStillOpen 3
  • #define kSndFileStreamLibErrOutOfMemory 4
  • #define kSndFileStreamLibErrCantOpenFile 5
  • #define kSndFileStreamLibErrUnsupportedFile 6
  • #define kSndFileStreamLibErrCancel 7
  • #define kSndFileStreamLibErrOperationNotSupported 8

Play back sound file stream

Use for playbackCount parameter of tagSndFileStreamData to play back a stream indefinitely.
  • #define kSndFileStreamLibPlaybackForever 0xFFFF
  • #define sndFileStreamNotifyStreamComplete 'StrC'
  • #define sndFileStreamNotifyRecComplete 'RecC'

File Flags

  • #define kSndFileStreamFileSpecFlagVFS (0x0001)
  • #define kSndFileStreamFileSpecFlagFileStream (0x0002)

File stream database types

File stream databases opened using kSndFileStreamFileSpecFlagFileStream.
  • #define kSndFileTypeWAV 'WAVf'
  • #define kSndFileTypeQCP 'QCPf'
  • #define kSndFileTypeAMR 'AMRf'
  • #define kSndFileTypeMP3 'MP3f'
  • #define kSndFileTypeAAC 'AACf'

Library traps

  • #define kSndFileStreamLibTrapVersion (sysLibTrapCustom + 0)
  • #define kSndFileStreamLibTrapCreate (sysLibTrapCustom + 1)
  • #define kSndFileStreamLibTrapOpen (sysLibTrapCustom + 2)
  • #define kSndFileStreamLibTrapClose (sysLibTrapCustom + 3)
  • #define kSndFileStreamLibTrapStart (sysLibTrapCustom + 4)
  • #define kSndFileStreamLibTrapPause (sysLibTrapCustom + 5)
  • #define kSndFileStreamLibTrapStop (sysLibTrapCustom + 6)
  • #define kSndFileStreamLibTrapSeek (sysLibTrapCustom + 7)
  • #define kSndFileStreamLibTrapGetCurrentStreamData (sysLibTrapCustom + 8)
  • #define kSndFileStreamLibTrapDeviceControl (sysLibTrapCustom + 9)
  • #define kSndFileStreamLibTrapSetVolume (sysLibTrapCustom + 10)
  • #define kSndFileStreamLibTrapGetVolume (sysLibTrapCustom + 11)
  • #define kSndFileStreamLibTrapSetPan (sysLibTrapCustom + 12)
  • #define kSndFileStreamLibTrapGetPan (sysLibTrapCustom + 13)
  • #define kSndFileStreamLibTrapUIPlay (sysLibTrapCustom + 14)
  • #define kSndFileStreamLibTrapUIRecord (sysLibTrapCustom + 15)

Defines

  • #define SNDFILESTREAM_TRAP(x) SYS_TRAP( x )

Typedefs

  • typedef enum tagSndFileFormatEnum SndFileFormatType
  • typedef void * SndFileStreamRef
  • typedef tagSndFileStreamData SndFileStreamData
    Holds data about a sound file stream.
  • typedef tagSndFileStreamData * SndFileStreamDataPtr
    Holds data about a sound file stream.
  • typedef Err(* SndFileStreamCallbackPtr )(SndFileStreamRef stream, SndFileStreamDataPtr streamDataP, Boolean *customDataModified)
  • typedef tagSndFileStreamFileSpec SndFileStreamFileSpec
    Descriptions of the stream file.
  • typedef tagSndFileStreamFileSpec * SndFileStreamFileSpecPtr
    Descriptions of the stream file.
  • typedef tagSndFileStreamHsSoundCommandParam SndFileStreamHsSoundCommandParam
    SndFileStreamDeviceControl param when cmd == hsSoundLibCreatorID.
  • typedef tagSndFileStreamHsSoundCommandParam * SndFileStreamHsSoundCommandParamPtr
    SndFileStreamDeviceControl param when cmd == hsSoundLibCreatorID.

Enumerations

  • enum tagSndFileFormatEnum {
    kSndFileFormatRaw = 0,
    kSndFileFormatWAV,
    kSndFileFormatTreoQCP,
    kSndFileFormatTreoAMR,
    kSndFileFormatMP3,
    kSndFileFormatAAC
    }

Functions

  • Err SndFileStreamLibOpen (UInt16 libRefNum)(sysLibTrapOpen)
  • Err SndFileStreamLibClose (UInt16 libRefNum)(sysLibTrapClose)
  • Err SndFileStreamLibSleep (UInt16 libRefNum)(sysLibTrapSleep)
  • Err SndFileStreamLibWake (UInt16 libRefNum)(sysLibTrapWake)
  • Err SndFileStreamLibVersion (UInt16 libRefNum, UInt32 *versionP)(kSndFileStreamLibTrapVersion)
  • Err SndFileStreamCreate (UInt16 libRefNum, SndFileStreamRef *streamP, SndFileStreamDataPtr streamDataP, SndFileStreamFileSpecPtr fileSpecP, SndFileStreamCallbackPtr callbackP)(kSndFileStreamLibTrapCreate)
  • Err SndFileStreamOpen (UInt16 libRefNum, SndFileStreamRef *streamP, SndFileStreamDataPtr streamDataP, SndFileStreamFileSpecPtr fileSpecP, SndFileStreamCallbackPtr callbackP)(kSndFileStreamLibTrapOpen)
  • Err SndFileStreamClose (UInt16 libRefNum, SndFileStreamRef stream)(kSndFileStreamLibTrapClose)
  • Err SndFileStreamStart (UInt16 libRefNum, SndFileStreamRef stream)(kSndFileStreamLibTrapStart)
  • Err SndFileStreamPause (UInt16 libRefNum, SndFileStreamRef stream, Boolean pause)(kSndFileStreamLibTrapPause)
  • Err SndFileStreamStop (UInt16 libRefNum, SndFileStreamRef stream)(kSndFileStreamLibTrapStop)
  • Err SndFileStreamSeek (UInt16 libRefNum, SndFileStreamRef stream, UInt32 seekMilliseconds)(kSndFileStreamLibTrapSeek)
  • Err SndFileStreamGetCurrentStreamData (UInt16 libRefNum, SndFileStreamRef stream, SndFileStreamDataPtr streamDataP)(kSndFileStreamLibTrapGetCurrentStreamData)
  • Err SndFileStreamDeviceControl (UInt16 libRefNum, SndFileStreamRef stream, Int32 cmd, void *param, Int32 size)(kSndFileStreamLibTrapDeviceControl)
  • Err SndFileStreamSetVolume (UInt16 libRefNum, SndFileStreamRef stream, Int32 volume)(kSndFileStreamLibTrapSetVolume)
  • Err SndFileStreamGetVolume (UInt16 libRefNum, SndFileStreamRef stream, Int32 *volumeP)(kSndFileStreamLibTrapGetVolume)
  • Err SndFileStreamSetPan (UInt16 libRefNum, SndFileStreamRef stream, Int32 panPosition)(kSndFileStreamLibTrapSetPan)
  • Err SndFileStreamGetPan (UInt16 libRefNum, SndFileStreamRef stream, Int32 *panPositionP)(kSndFileStreamLibTrapGetPan)
  • Err SndFileStreamUIPlay (UInt16 libRefNum, SndFileStreamFileSpecPtr fileSpecP, Boolean allowRerecord)(kSndFileStreamLibTrapUIPlay)
  • Err SndFileStreamUIRecord (UInt16 libRefNum, SndFileStreamDataPtr streamDataP, SndFileStreamFileSpecPtr fileSpecP, Boolean allowRerecord)(kSndFileStreamLibTrapUIRecord)

Define Documentation

#define kSndFileStreamFileSpecFlagFileStream (0x0002)

File stream

#define kSndFileStreamFileSpecFlagVFS (0x0001)

VFS file

#define kSndFileStreamLibCreator 'sfsL'

Creator ID of the sound file stream library.

#define kSndFileStreamLibName "SndFileStream-sfsL"

Name of the sound file stream library.

#define kSndFileStreamLibType sysFileTLibrary

Type of the sound file stream library.

#define kSndFileStreamLibVersion sysMakeROMVersion(1, 4, 0, sysROMStageRelease, 20)

Version of the sound file stream library.

#define kSndFileTypeAAC 'AACf'

AAC file -> kSndFileFormatAAC

#define kSndFileTypeAMR 'AMRf'

AMR file -> kSndFileFormatTreoAMR.

#define kSndFileTypeMP3 'MP3f'

MP3 file -> kSndFileFormatMP3

#define kSndFileTypeQCP 'QCPf'

QCELP file -> kSndFileFormatTreoQCP.

#define kSndFileTypeWAV 'WAVf'

WAV file -> kSndFileFormatWAV .

#define SNDFILESTREAM_TRAP ( x ) SYS_TRAP( x )

Helper macro.

#define SndFileStreamCloseLibrary | ( | refNum,
 |  | err | )

Value:

{                                                           \
        if ( sysInvalidRefNum == (refNum) )                     \
        {                                                       \
            (err) = sysErrParamErr;                             \
        }                                                       \
        else                                                    \
        {                                                       \
            (err) = SndFileStreamLibClose( (refNum) );          \
            if ( errNone == (err) )                             \
            {                                                   \
                (err) = SysLibRemove( (refNum) );               \
                (refNum) = sysInvalidRefNum;                    \
            }                                                   \
            else if ( kSndFileStreamLibErrStillOpen == (err) )  \
            {                                                   \
                (err) = errNone;                                \
            }                                                   \
        }                                                       \
    }

#define sndFileStreamNotifyRecComplete 'RecC'

Notification broadcast by SndFileStream when it exceeds the recording limit. Currently this notification is handled by the libary itself, for example, stop the recording stream. The application should NOT expect to recieve this notification even it register it. Instead it should expect sndFileStreamNotifyStreamComplete notification to indicate that the recording limit has been reached.

#define sndFileStreamNotifyStreamComplete 'StrC'

Notification broadcast by SndFileStream when it has completed playing a stream. This is an alternative to using callbacks in the case where SndFileStream is used by an ARM app (eg. Blazer) or by a 68K app.

In playback mode, it means that the file has completely played. In recording mode, it means that it reaches the recording limit.

#define SndFileStreamOpenLibrary | ( | refNum,
 |  | err | )

Value:

{                                                           \
        Boolean loaded;                                         \
                                                                \
        loaded = false;                                         \
        (err) = SysLibFind( kSndFileStreamLibName, &(refNum) ); \
        if ( sysErrLibNotFound == (err) )                       \
        {                                                       \
            (err) = SysLibLoad( kSndFileStreamLibType,          \
                kSndFileStreamLibCreator, &(refNum) );          \
            loaded = true;                                      \
        }                                                       \
                                                                \
        if ( errNone == (err) )                                 \
        {                                                       \
            (err) = SndFileStreamLibOpen( (refNum) );           \
            if ( errNone != (err) )                             \
            {                                                   \
                if ( loaded )                                   \
                {                                               \
                    SysLibRemove( (refNum) );                   \
                }                                               \
                                                                \
                (refNum) = sysInvalidRefNum;                    \
            }                                                   \
        }                                                       \
        else                                                    \
        {                                                       \
            (refNum) = sysInvalidRefNum;                        \
        }                                                       \
    }

Typedef Documentation

typedef enum tagSndFileFormatEnum SndFileFormatType

Sound file format

The sound file format of the stream.

typedef Err(* SndFileStreamCallbackPtr)(SndFileStreamRef stream, SndFileStreamDataPtr streamDataP, Boolean *customDataModified)

Callback function passed when calling SndFileStreamCreate() and SndFileStreamOpen(). It will be called during playback and recording.

Parameters:
stream,: IN: Reference to stream returned by SndFileStreamCreate()/SndFileStreamOpen().
streamDataP,: IN:
See also:
SndFileStreamData
Parameters:
customDataModified,: OUT: If true, custom data has been modified.
Return values:
Err Error code.

typedef struct tagSndFileStreamData SndFileStreamData

Holds data about a sound file stream.

typedef struct tagSndFileStreamData * SndFileStreamDataPtr

Holds data about a sound file stream.

typedef struct tagSndFileStreamFileSpec SndFileStreamFileSpec

Descriptions of the stream file.

Used with SndFileStreamCreate()/SndFileStreamOpen()

typedef struct tagSndFileStreamFileSpec * SndFileStreamFileSpecPtr

Descriptions of the stream file.

Used with SndFileStreamCreate()/SndFileStreamOpen()

typedef struct tagSndFileStreamHsSoundCommandParam SndFileStreamHsSoundCommandParam

SndFileStreamDeviceControl param when cmd == hsSoundLibCreatorID.

Contains hsFormat/hsCmd pair to be used with PmSndStream() calls.

typedef struct tagSndFileStreamHsSoundCommandParam * SndFileStreamHsSoundCommandParamPtr

SndFileStreamDeviceControl param when cmd == hsSoundLibCreatorID.

Contains hsFormat/hsCmd pair to be used with PmSndStream() calls.

typedef void* SndFileStreamRef

Reference to sound file stream returned by SndFileStreamCreate()/Open()

Enumeration Type Documentation

enum tagSndFileFormatEnum

Sound file format

The sound file format of the stream.

Enumerator:
kSndFileFormatRaw | Raw bytes.
kSndFileFormatWAV | RIFF-WAVE.
kSndFileFormatTreoQCP | RIFF-QLCM.
kSndFileFormatTreoAMR | Raw RTP packets.
kSndFileFormatMP3 | MP3 format
kSndFileFormatAAC | AAC format

Function Documentation

Err SndFileStreamClose | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef | stream
 | ) |

Close the reference to the file stream.

Parameters:
libRefNum,: IN: Library reference number
stream,: IN: Reference to the sound stream, returned when creating/opening file stream.
Return values:
Err Error code.

Err SndFileStreamCreate | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef * | streamP,
 |  | SndFileStreamDataPtr | streamDataP,
 |  | SndFileStreamFileSpecPtr | fileSpecP,
 |  | SndFileStreamCallbackPtr | callbackP
 | ) |

Create a new sound file stream.

Parameters:
libRefNum,: IN: Library reference number
streamP,: OUT: Reference to the created sound stream
streamDataP,: IN:
See also:
SndFileStreamData
Parameters:
fileSpecP,: IN: Description of the file to be created
callbackP,: IN: User defined callback function, to be called on playback/recording.
Return values:
Err Error code.

Err SndFileStreamDeviceControl | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef | stream,
 |  | Int32 | cmd,
 |  | void * | param,
 |  | Int32 | size
 | ) |

Control device when streaming.

Parameters:
libRefNum,: IN: Library reference number
stream,: IN: Reference to the sound stream, returned when creating/opening stream.
cmd,: IN: No definition.
param,: IN: No definition.
size,: IN: No definition.
Return values:
Err Error code.

Err SndFileStreamGetCurrentStreamData | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef | stream,
 |  | SndFileStreamDataPtr | streamDataP
 | ) |

Get streaming data.

Parameters:
libRefNum,: IN: Library reference number
stream,: IN: Reference to the sound stream, returned when creating/opening stream.
streamDataP,: OUT:
See also:
SndFileStreamData
Return values:
Err Error code.

Err SndFileStreamGetPan | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef | stream,
 |  | Int32 * | panPositionP
 | ) |

Get stereo balance. See SndStreamGetPan() documented under Palm OS Sound Manager API.

Parameters:
libRefNum,: IN: Library reference number
stream,: IN: Reference to the sound stream.
panPositionP,: OUT: Range [-1024, 1024]
Return values:
Err Error code.

Err SndFileStreamGetVolume | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef | stream,
 |  | Int32 * | volumeP
 | ) |

See SndStreamGetVolume() documented under Palm OS Sound Manager API.

Parameters:
libRefNum,: IN: Library reference number
stream,: IN: Reference to the sound stream, returned when creating/opening stream.
volumeP,: OUT: Range 0 - 32k. See Palm OS SoundMgr API documentation for more details.
Return values:
Err Error code.

Err SndFileStreamLibClose ( UInt16 libRefNum )

Closes the Sound File Stream library.

Parameters:
libRefNum,: IN: Library reference number
Return values:
Err Error code.

Err SndFileStreamLibOpen ( UInt16 libRefNum )

Opens the Sound File Stream library.

Parameters:
libRefNum,: IN: Library reference number
Return values:
Err Error code.

Err SndFileStreamLibSleep ( UInt16 libRefNum )

Standard library sleep routine.

Parameters:
libRefNum,: IN: Library reference number
Return values:
Err Error code.

Err SndFileStreamLibVersion | ( | UInt16 | libRefNum,
 |  | UInt32 * | versionP
 | ) |

Retrieve the library version number.

Parameters:
libRefNum,: IN: Library reference number
*versionP,: OUT: Library version number.
Return values:
Err Error code.

Err SndFileStreamLibWake ( UInt16 libRefNum )

Standard library wake routine.

Parameters:
libRefNum,: IN: Library reference number
Return values:
Err Error code.

Err SndFileStreamOpen | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef * | streamP,
 |  | SndFileStreamDataPtr | streamDataP,
 |  | SndFileStreamFileSpecPtr | fileSpecP,
 |  | SndFileStreamCallbackPtr | callbackP
 | ) |

Open an already existing sound file stream.

Parameters:
libRefNum,: IN: Library reference number
streamP,: OUT: Reference to the opened sound stream.
streamDataP,: IN:
See also:
SndFileStreamData
Parameters:
fileSpecP,: IN: Description of the file to be opened.
callbackP,: IN: User defined callback function, to be called on playback/recording.
Return values:
Err Error code.

Err SndFileStreamPause | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef | stream,
 |  | Boolean | pause
 | ) |

Pause sound streaming.

Parameters:
libRefNum,: IN: Library reference number
stream,: IN: Reference to the sound stream, returned when creating/opening stream.
pause,: IN: If true, pause. Otherwise, resume.
Return values:
Err Error code.

Err SndFileStreamSeek | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef | stream,
 |  | UInt32 | seekMilliseconds
 | ) |

Move the pointer to the stream to a user-defined offset.

Parameters:
libRefNum,: IN: Library reference number
stream,: IN: Reference to the sound stream, returned when creating/opening stream.
seekMilliseconds IN: Offset in milliseconds.
Return values:
Err Error code.

Err SndFileStreamSetPan | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef | stream,
 |  | Int32 | panPosition
 | ) |

Set stereo balance. See SndStreamSetPan() documented under Palm OS Sound Manager API.

Parameters:
libRefNum,: IN: Library reference number
stream,: IN: Reference to the sound stream.
panPosition,: IN: Range [-1024, 1024]
Return values:
Err Error code.

Err SndFileStreamSetVolume | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef | stream,
 |  | Int32 | volume
 | ) |

See SndStreamSetVolume() documented under Palm OS Sound Manager API.

Parameters:
libRefNum,: IN: Library reference number
stream,: IN: Reference to the sound stream, returned when creating/opening stream.
volume,: IN: No definition.
Return values:
Err Error code.

Err SndFileStreamStart | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef | stream
 | ) |

Start streaming sound into file.

Parameters:
libRefNum,: IN: Library reference number
stream,: IN: Reference to the sound stream, returned when creating/opening stream.
Return values:
Err Error code.

Err SndFileStreamStop | ( | UInt16 | libRefNum,
 |  | SndFileStreamRef | stream
 | ) |

Stop sound streaming.

Parameters:
libRefNum,: IN: Library reference number
stream,: IN: Reference to the sound stream, returned when creating/opening stream.
Return values:
Err Error code.

Err SndFileStreamUIPlay | ( | UInt16 | libRefNum,
 |  | SndFileStreamFileSpecPtr | fileSpecP,
 |  | Boolean | allowRerecord
 | ) |

Play sound stream with UI

Parameters:
libRefNum,: IN: Library reference number
fileSpecP,: IN: Pointer to the sound file to be played.
allowRerecord,: IN: No definition.
Return values:
Err Error code.

Err SndFileStreamUIRecord | ( | UInt16 | libRefNum,
 |  | SndFileStreamDataPtr | streamDataP,
 |  | SndFileStreamFileSpecPtr | fileSpecP,
 |  | Boolean | allowRerecord
 | ) |

Record sound stream with UI

Parameters:
libRefNum,: IN: Library reference number
streamDataP,: IN: Stream data to be used for recording.
fileSpecP,: IN: Pointer to the sound file to be recorded.
allowRerecord,: IN: No definition.
Return values:
Err Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:17 2006 for Palm API Guide


palmOneStatusBar.h File Reference

Detailed Description

Public common header file for palmOne defined Status Bar library.

Version:
1.0
This file contains the function prototypes and constants for the palmOne Status Bar Library

Include dependency graph for palmOneStatusBar.h:

Library Constants

  • #define palmOneStatusBarLibName "StatusBarMgrLib"
  • #define palmOneStatusBarLibCreator 'sBar'
  • #define palmOneStatusBarLibType sysFileTLibrary
  • #define palmOneStatusBarFtrNumVersion (0)

Error Codes

  • #define palmOneStatusBarErrorClass (appErrorClass | 0x0900)
  • #define palmOneStatusBarErrNoStatusBar (palmOneStatusBarErrorClass | 1)
  • #define palmOneStatusBarErrInvalidSelector (palmOneStatusBarErrorClass | 2)
  • #define palmOneStatusBarErrInputWindowOpen (palmOneStatusBarErrorClass | 3)
  • #define palmOneStatusBarErrBadParam (palmOneStatusBarErrorClass | 101)
  • #define palmOneStatusBarErrInvalidState (palmOneStatusBarErrorClass | 102)

Function Traps

  • #define kPalmOneStatusBarMgrLibTrapOpen sysLibTrapOpen
  • #define kPalmOneStatusBarMgrLibTrapClose sysLibTrapClose
  • #define kPalmOneStatusBarMgrLibGetAttribute (sysLibTrapCustom)
  • #define kPalmOneStatusBarMgrLibHide (sysLibTrapCustom + 1)
  • #define kPalmOneStatusBarMgrLibShow (sysLibTrapCustom + 2)

Typedefs

  • typedef enum PalmOneStatAttrTypeTag PalmOneStatAttrType

Enumerations

  • enum PalmOneStatAttrTypeTag {
    palmOneStatusBarAttrExists = 0,
    palmOneStatusBarAttrBarVisible,
    palmOneStatusBarAttrDimension
    }

Functions

  • Err PalmOneStatusBarLibOpen (UInt16 refnum)
    Standard open library routine.
  • Err PalmOneStatusBarLibClose (UInt16 refnum)
    Standard close library routine.
  • Err PalmOneStatusBarGetAttribute (UInt16 refnum, PalmOneStatAttrType selector, UInt32 *dataP)
    Retrieve the current state of the status bar.
  • Err PalmOneStatusBarHide (UInt16 refnum)
    Hide the status bar from the bottom of the screen.
  • Err PalmOneStatusBarShow (UInt16 refnum)
    Unhide/show the status bar at the bottom of the screen.

Define Documentation

#define palmOneStatusBarFtrNumVersion (0)

Version of the currently supported features

#define palmOneStatusBarLibCreator 'sBar'

StatusBar library creator ID

#define palmOneStatusBarLibName "StatusBarMgrLib"

StatusBar library name

#define palmOneStatusBarLibType sysFileTLibrary

Default library type

Typedef Documentation

typedef enum PalmOneStatAttrTypeTag PalmOneStatAttrType

Status Bar Attributes

Enumeration Type Documentation

enum PalmOneStatAttrTypeTag

Status Bar Attributes

Enumerator:
palmOneStatusBarAttrExists | device supports the status bar
palmOneStatusBarAttrBarVisible | status bar is visible
palmOneStatusBarAttrDimension | bounds of status bar window

Function Documentation

Err PalmOneStatusBarGetAttribute | ( | UInt16 | refnum,
 |  | PalmOneStatAttrType | selector,
 |  | UInt32 * | dataP
 | ) |

Retrieve the current state of the status bar.

Parameters:
refnum,: IN: Library reference number
selector,: IN: Attribute selector (dimension or status)
*dataP,: IN: Pointer to the returned attribute value.
Returns:
Error code.

Err PalmOneStatusBarHide ( UInt16 refnum )

Hide the status bar from the bottom of the screen.

Parameters:
refnum,: IN: Library reference number
Returns:
Error code.

Err PalmOneStatusBarLibClose ( UInt16 refnum )

Standard close library routine.

Parameters:
refnum,: IN: Library reference number
Returns:
Error code.

Err PalmOneStatusBarLibOpen ( UInt16 refnum )

Standard open library routine.

Parameters:
refnum,: IN: Library reference number
Returns:
Error code.

Err PalmOneStatusBarShow ( UInt16 refnum )

Unhide/show the status bar at the bottom of the screen.

Parameters:
refnum,: IN: Library reference number
Returns:
Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:17 2006 for Palm API Guide


palmOneSystemCommon.h File Reference

Detailed Description

This is the common public header for palmOne system definitions.

Defines

  • #define sysMakeLibAPIVersion(major, minor)
  • #define sysGetLibAPIVersionMajor(libVer) (((UInt16)((libVer) >> 16)) & 0x0FFFF)
  • #define sysGetLibAPIVersionMinor(libVer) (((UInt16)(libVer)) & 0x0FFFF)

Define Documentation

#define sysMakeLibAPIVersion | ( | major,
 |  | minor | )

Value:

(                                                   \
        (((UInt32)((UInt16)(major) & 0x0FFFF)) << 16) |     \
        (((UInt32)((UInt16)(minor) & 0x0FFFF)))             \
        )

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:17 2006 for Palm API Guide


palmOneVMFontLib.h File Reference

Detailed Description

Defines APIs and structures for the Palm VersaMail Font Picker / Font Manager Service which lets users get / set font characteristics.

Version:
1.0

Include dependency graph for palmOneVMFontLib.h:

Defines

  • #define VMFONTLIB_TRAP(trapNum) SYS_TRAP( trapNum )

Functions

  • Err VMFontOpen (UInt16 libRefNum, UInt32 *clientContextP)
    This function should be called prior to calling the other Font Picker functions.
  • Err VMFontClose (UInt16 libRefNum, UInt32 clientContext)
    This function should be called after your application has finished with the Font Picker library.
  • Err VMFontVersion (UInt16 libRefNum, UInt32 *versionP)
  • UInt8 VMFontGetFont (UInt16 libRefNum, const VMFontPtr fontP)
  • UInt8 VMFontGetFontByID (UInt16 libRefNum, VMFontPtr targetP, UInt8 fontID)
  • Boolean VMFontExists (UInt16 libRefNum, const VMFontPtr fontP)
  • void VMFontToString (UInt16 libRefNum, const VMFontPtr fontP, char *stringP)
  • void VMFontCountStyleAndSize (UInt16 libRefNum, VMFontFace face, Int8 *sizeP, Int8 *styleP)
  • void InitFontUI (UInt16 libRefNum)
  • Boolean DoFontDialog (UInt16 libRefNum, UInt8 *fontIDP, UInt8 oldFontID)
  • void VMFontClearCache (UInt16 libRefNum)
  • void SetFontUIRules (UInt16 libRefNum, VMFontUIRules fontRules)
    Currently the only controllable UI components are.

Function Documentation

Boolean DoFontDialog | ( | UInt16 | libRefNum,
 |  | UInt8 * | fontIDP,
 |  | UInt8 | oldFontID
 | ) |

Popup the font picker dialog, and let the user pick a font from the list. Once the user taps OK, the selected font id will be copied into the target parameter.

Parameters:
libRefNum,: IN: Reference number of the Font Picker library.
fontIDP,: OUT: fontID that user has selected.
oldFontID : IN: The font picker will use this font to pre populate the font list. This is very useful when you have a previously saved font in the preference that you want to use when popping up the dialog. If no saved preference is used, then you can always pass in stdFont as the argument.
Return values:
Boolean True if user tapped OK false if user selected cancel

void InitFontUI ( UInt16 libRefNum )

Initialize the font picker UI internal data structure. Please note that it is very important that this function is called before any Font picker specific functions are called.

Parameters:
libRefNum,: IN: Reference number of the Font Picker library.
Return values:
Nothing

void SetFontUIRules | ( | UInt16 | libRefNum,
 |  | VMFontUIRules | fontRules
 | ) |

Currently the only controllable UI components are.

Define the UI rules, e.g.: hide style picker, do not show the style picker, show only small fonts, etc.

Components visibility controls

  • Font face picker: true/false
  • Font style picker: true/false
  • Font size picker: true/false List items controls
  • Font Size: allSize, smallFonts, largeFonts
  • Font Style: allStyle, plainOnly

Parameters:
libRefNum,: IN:Reference number of the Font Picker library.
fontRules,: IN:fontRules that need to be applied
Return values:
Nothing
 VMFontUIRules rules;
 UInt8 myFontID;
 UInt8 oldFontID;

 // let's hide style drop down list, and only display small fonts
 //(size 6 if available and size 9 fonts)
 rules.fontFaceVisible = true;
 rules.fontSizeVisible = true;
 rules.fontStyleVisible = true;
 rules.sizeRule = smallFonts;
 rules.styleRule = allStyle;

 InitFontUI( libRefNum );
 SetFontUIRules( libRefNum, rules ); // apply the rules
 if  (DoFontDialog( libRefNum, &myFontID, oldFontID ))
 {
    // do something with the font
 }
 else
 {
    // handle the case when user cancels out of the font picker UI
 }

void VMFontClearCache ( UInt16 libRefNum )

Clear the interal cache of the font library

Parameters:
libRefNum,: IN: library reference number.

Err VMFontClose | ( | UInt16 | libRefNum,
 |  | UInt32 | clientContext
 | ) |

This function should be called after your application has finished with the Font Picker library.

Closes the Font Picker library and perform cleanup.

Parameters:
libRefNum,: IN: Reference number of the Font Picker library.
clientContext,: IN: Library's client context number got during open.
Return values:
Err The error code returned from the library. If this is errNone, the function was sucessful.
 err = VMFontClose(fontPickerLibRefNum, context);

See also:
VMFontOpen

void VMFontCountStyleAndSize | ( | UInt16 | libRefNum,
 |  | VMFontFace | face,
 |  | Int8 * | sizeP,
 |  | Int8 * | styleP
 | ) |

Given a font face, find out how many size/styles were associated with it.

Parameters:
libRefNum,: IN: Reference number of the Font Picker library.
face,: IN: the font face we need details about.
sizeP,: OUT: contains total sizes for the font face
styleP,: OUT: contains total styles for the font face
Return values:
Nothing

Boolean VMFontExists | ( | UInt16 | libRefNum,
 |  | const VMFontPtr | fontP
 | ) |

Check to see if the specified font exists in the database.

Parameters:
libRefNum,: IN: Reference number of the Font Picker library.
fontP,: IN: the font characteristics we want to check.
Return values:
Boolean True if the font exists in the database, false otherwise.
 MemHandle handle;
 VMFontPtr fontP;
 Boolean exists = false;

 handle = MemHandleNew(sizeof( VMFontType ));
 fontP = (VMFontPtr) MemHandleLock(handle);

 fontP->face = segoe;
 fontP->size = size6;
 fontP->style = bold;

 exists = VMFontExists( gRefNum, fontP );

 MemHandleUnlock(handle);
 MemHandleFree(handle);

See also:
VMFontGetFont

UInt8 VMFontGetFont | ( | UInt16 | libRefNum,
 |  | const VMFontPtr | fontP
 | ) |

Get the font ID based on the given font characteristics. The returned font ID is NOT guaranteed to be always available. Therefore to avoid any error, please make sure that VMFontExists is used whenever a font is needed.

Parameters:
libRefNum,: IN: Reference number of the Font Picker library.
fontP,: IN: the font characteristics.
Return values:
UInt8 The defined font ID
 // get the font ID for gill Sans MT 9 pt Italic
 VMFontPtr fontP = (VMFontPtr) MemPtrNew (sizeof (VMFontType));
 fontP->face = gillSans;
 fontP->size = size6;
 fontP->style = italic;
 UInt8 myFontID = stdFont;
 if (VMFontExists( theRefNum, fontP ))
    {    myFontID = VMFontGetFont( theRefNum, fontP );   }

See also:
VMFontExists

UInt8 VMFontGetFontByID | ( | UInt16 | libRefNum,
 |  | VMFontPtr | targetP,
 |  | UInt8 | fontID
 | ) |

Get the Font characteristics based on a saved FontID

Parameters:
libRefNum,: IN: Reference number of the Font Picker library.
targetP,: IN: the font characteristics.
fontID,: IN: the font ID passed in.
Return values:
UInt8 The defined font ID
 UInt8 myOldID;
 UInt8 myFontID;
 MemHandle handle;
 VMFontPtr fontP;

 handle = MemHandleNew(sizeof(VMFontType));
 fontP = (VMFontPtr) MemHandleLock(handle);

 myOldID = GetFontIDFromPrefs(); // assume that we have a funct to get the old ID
 myFontID = VMFontGetFontByID( gRefNum, fontP, myOldID );

Err VMFontOpen | ( | UInt16 | libRefNum,
 |  | UInt32 * | clientContextP
 | ) |

This function should be called prior to calling the other Font Picker functions.

Opens the Font Picker library. Does Initialization of library.

Parameters:
libRefNum,: IN: Reference number of the Font Picker library.
clientContextP,: OUT: pointer to variable for returning client context. The client context is used to maintain client-specific data for multiple client support.The value returned here will be used as a parameter for other library functions which require a client context.
Return values:
Err The error code returned from the library. If this is errNone, the function was sucessful.
 UInt16 fontPickerLibRefNum = 0;
 UInt32 context;
 err = SysLibFind(fontPickerLibName, &fontPickerLibRefNum);
 if( err == sysErrLibNotFound )
 {
     err = SysLibLoad(fontPickerType, fontPickerCreatorID, &fontPickerLibRefNum);
         if( !err ) {
             err = VMFontOpen(fontPickerLibRefNum, &context);
         }
 }

See also:
VMFontClose

void VMFontToString | ( | UInt16 | libRefNum,
 |  | const VMFontPtr | fontP,
 |  | char * | stringP
 | ) |

Given a font characteristics (defined as VMFontPtr), get the human-readable font description of that font in the form of "<NAME> <SIZE> <STYLE>", e.g. "Gill Sans MT 9 Bold".

Parameters:
libRefNum,: IN: Reference number of the Font Picker library.
fontP,: IN: the font characteristics we want to check.
stringP,: OUT: Pointer to output string buffer.
Return values:
Nothing

Err VMFontVersion | ( | UInt16 | libRefNum,
 |  | UInt32 * | versionP
 | ) |

Get the Font Library Version

Parameters:
libRefNum,: IN: Reference number of the Font Picker library.
versionP,: OUT: Pointer to the version number
Return values:
Err Always errNone

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:18 2006 for Palm API Guide


PalmPin.h File Reference

Detailed Description

Public API for the Pen Input Manager Library.

Version:
1.0

Include dependency graph for PalmPin.h:

Data Structures

  • struct AiaExtentChangedEventDataType

Library type and creator

  • #define pinLibType sysFileTLibrary
  • #define pinLibCreator 'pinM'
  • #define pinLibName "PinLib"
  • #define pinFtrNumVersion 0

Pinlet IDs

  • #define pinClassic "Classic"
  • #define pinTriCell "Tri Cell"
  • #define pinStdKeyboard "StdKB"
  • #define pinletStdKbNum "StdKBNum"
  • #define pinletStdKbIntl "StdKBIntl"

PIN Manager Errors

  • #define pinErrorClass (appErrorClass | 0x0A00)
  • #define pinErrInvalidState (pinErrorClass + 1)
  • #define pinErrUnknownID (pinErrorClass + 2)
  • #define pinErrInvalidInputMode (pinErrorClass + 3)

Input area states

  • #define pinInputAreaNone 0
  • #define pinInputAreaShow 1
  • #define pinInputAreaHide 2
  • #define pinInputAreaLegacyMode 3
  • #define pinInputAreaFullScreen 4

Input Modes

  • #define pinInputModeNormal 0
  • #define pinInputModeShift 1
  • #define pinInputModeCapsLock 2
  • #define pinInputModePunctuation 3
  • #define pinInputModeNumeric 4
  • #define pinInputModeExtended 5
  • #define pinInputModeHiragana 6
  • #define pinInputModeKatakana 7

AIA event and notification

  • #define sysNotifyAiaEvent 'Aian'
  • #define AiaExtentChangedEvent 0x5000

Library Traps

  • #define kPinLibTrapOpen sysLibTrapOpen
  • #define kPinLibTrapClose sysLibTrapClose
  • #define kPinLibTrapPinGetInputAreaState (sysLibTrapCustom + 17)
  • #define kPinLibTrapPinSetInputAreaState (sysLibTrapCustom + 18)
  • #define kPinLibTrapPinResetInputState (sysLibTrapCustom + 24)
  • #define kPinLibTrapPinGetCurrentPinletID (sysLibTrapCustom + 20)
  • #define kPinLibTrapPinSwitchToPinlet (sysLibTrapCustom + 21)
  • #define kPinLibTrapPinGetInputMode (sysLibTrapCustom + 23)
  • #define kPinLibTrapPinSetInputMode (sysLibTrapCustom + 22)
  • #define kPinLibTrapPINShowReferenceDialog (sysLibTrapCustom + 25)

Defines

  • #define aiaExtentChangedData(eventP) ((AiaExtentChangedEventDataType *)(&((eventP)->data.generic)))

Functions

  • Err PinLibOpen (UInt16 refnum)
  • Err PinLibClose (UInt16 refnum)
  • UInt16 PinGetInputAreaState (UInt16 refnum)
  • Err PinSetInputAreaState (UInt16 refnum, UInt16 state)
  • void PinResetInputState (UInt16 refnum)
  • const char * PinGetCurrentPinletID (UInt16 refnum)
  • Err PinSwitchToPinlet (UInt16 refnum, const char *pinletID, UInt16 initialInputMode)
  • UInt16 PinGetInputMode (UInt16 refnum)
  • void PinSetInputMode (UInt16 refnum, UInt16 inputMode)

Define Documentation

#define aiaExtentChangedData ( eventP ) ((AiaExtentChangedEventDataType *)(&((eventP)->data.generic)))

Macro to simplify getting the data out of the event structure.

Example: yDiff = AiaExtentChangedData(eventP)->newDim->extent.y - aiaExtentChangedData(eventP)->oldDim->extent.y;

Function Documentation

const char* PinGetCurrentPinletID ( UInt16 refnum )

Parameters:
refnum,: IN:
Return values:
Err error code.

UInt16 PinGetInputAreaState ( UInt16 refnum )

Parameters:
refnum,: IN:
Return values:
Err error code.

UInt16 PinGetInputMode ( UInt16 refnum )

Parameters:
refnum,: IN:
Return values:
Err error code.

Err PinLibClose ( UInt16 refnum )

Parameters:
refnum,: IN:
Return values:
Err error code.

Err PinLibOpen ( UInt16 refnum )

Parameters:
refnum,: IN:
Return values:
Err error code.

void PinResetInputState ( UInt16 refnum )

Parameters:
refnum,: IN:
Return values:
Err error code.

Err PinSetInputAreaState | ( | UInt16 | refnum,
 |  | UInt16 | state
 | ) |

Parameters:
refnum,: IN:
state,: IN:
Return values:
Err error code.

void PinSetInputMode | ( | UInt16 | refnum,
 |  | UInt16 | inputMode
 | ) |

Parameters:
refnum,: IN:
inputMode,: IN:
Return values:
Err error code.

Err PinSwitchToPinlet | ( | UInt16 | refnum,
 |  | const char * | pinletID,
 |  | UInt16 | initialInputMode
 | ) |

Parameters:
refnum,: IN:
pinletID,: IN:
initialInputMode,: IN:
Return values:
Err error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:18 2006 for Palm API Guide


PalmPower.h File Reference

Detailed Description

Battery notification.

Version:
1.0
This contains the Battery state notification Any application can register for the notification to be notified when the of the various battery states

Battery state notification

  • #define kPwrBatteryStateBroadcaster 'bsbc'
  • #define kPwrBatteryStateNotifyEvent 'bsnt'

Define Documentation

#define kPwrBatteryStateBroadcaster 'bsbc'

Battery notification broadcaster.

#define kPwrBatteryStateNotifyEvent 'bsnt'

Battery notification notifyType

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:18 2006 for Palm API Guide


PalmShimSettings.h File Reference

Detailed Description

Shim settings for NetIFSettingGet()/Set().

Version:
1.0
Date:
10/28/2002

Data Structures

  • struct vpnNotifyVPNLibTag

Defines

  • #define vpnLibEventNotification 'pVPN'

Typedefs

  • typedef UInt8 VPNLibEventNotificationTypeEnum
  • typedef vpnNotifyVPNLibTag VPNNotifyEventType

Enumerations

  • enum NetIFSettingShimEnum {
    netIFSettingShimUp = 0xA000,
    netIFSettingShimHideProgress,
    netIFSettingShimConfig,
    netIFSettingShimLog,
    netIFSettingShimCreator,
    netIFSettingShimVersion,
    netIFSettingShimLibVersion,
    netIFSettingShimVPNStart,
    netIFSettingShimVPNStop
    }
  • enum VPNLibEventNotificationTypeEnum_ {
    vpnConnectionUp = 1,
    vpnConnectionDown
    }

Typedef Documentation

typedef struct vpnNotifyVPNLibTag VPNNotifyEventType

Notification structure sent in vpnLibEventNotification

Enumeration Type Documentation

enum NetIFSettingShimEnum

NetIFSettings for the shim. Used by NetIFSettingGet()/Set().

Enumerator:
netIFSettingShimUp | True if shim is up; read-only.
netIFSettingShimHideProgress | Defaults to false.
netIFSettingShimConfig | Mechanism for passing data between app & proto tasks.
netIFSettingShimLog | Copy the shim log; read-only.
netIFSettingShimCreator | Creator ID of shim; UInt32; read-only.
netIFSettingShimVersion | Version of the shim; Char[32]; read-only.
netIFSettingShimLibVersion | Version of the shim library; UInt32; little-endian; read-only; see sysMakeROMVersion() macro
netIFSettingShimVPNStart | Connect VPN
netIFSettingShimVPNStop | Disconnect VPN

enum VPNLibEventNotificationTypeEnum_

IFMediaEvent notifications types

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:18 2006 for Palm API Guide


PalmSoundCustomCtrl.h File Reference

Detailed Description

Public 68K include file for the Sound Manager custom controls for the IMA_ADPCM codec for Treo 600 and Treo 650 smartphones.

This header file and associated header files support the specific sound functionality of the Treo smartphones. You should use the Palm OS Sound Manager APIs for most of your work.

Notes: How to use the IMA_ADPCM code custom control:

When you create a stream, make sure you set the format to sndFormatIMA_ADPCM and that the type is set to 0.

Then use the custom control to set the block align paramter:

SndCodecCustomControlType ct; UInt16 blockAlign= Swap16(blockAlign); // This needs to be in little endian ct.apiCreator = Swap32(codecDriverIMAADPCM); ct.apiSelector = Swap32(codecIMAADPCMSetBlockSize); ct.valueP = (void*)Swap32(&blockAlign); ct.valueLenP = NULL; err = SndStreamDeviceControl(streamRef, sndControlCodecCustomControl, &ct, sizeof(ct));

The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application(ie, SysLibFind() returns a valid refnum). When the application is done with the library, it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal synchronization.

Data Structures

  • struct SndCodecCustomControlType
    Holds Custom Control type information for the Extended Sound Manager. More...

Custom Control for the IMA_ADPCM codec

  • #define codecDriverIMAADPCM 'APCM'
  • #define codecIMAADPCMSetBlockSize 0x0001

Enumerations

  • enum { sndControlCodecCustomControl = 12 }

Define Documentation

#define codecDriverIMAADPCM 'APCM'

IMA ADPCM codec driver.

#define codecIMAADPCMSetBlockSize 0x0001

IMA ADPCM block size set command.

Enumeration Type Documentation

anonymous enum

IMA_ADPCM codec Custom Control type

Enumerator:
sndControlCodecCustomControl Param is a SndCodecCustomControlType*.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:18 2006 for Palm API Guide


PalmSoundMgrExt.h File Reference

Detailed Description

Public 68K include file for the Extended Sound Manager.

Notes: You should check to see if you are using a version of Palm OS SDK that implements the Extended Sound API. For lack of a better check, look for the earlier of the system traps and hope that the rest is likewise defined.

The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application(ie, SysLibFind() returns a valid refnum). When the application is done with the library, it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal synchronization.

Include dependency graph for PalmSoundMgrExt.h:

Extended Sound library traps

  • #define sysTrapSndStreamCreateExtended 0xA466
  • #define sysTrapSndStreamDeviceControl 0xA467

Typedefs

  • typedef UInt32 SndFormatType
  • typedef Err(* SndStreamVariableBufferCallback )(void *userDataP, SndStreamRef streamRef, void *bufferP, UInt32 *bufferSizeP)

Enumerations

  • enum {
    sndFormatPCM = 0,
    sndFormatIMA_ADPCM = 'APCM',
    sndFormatDVI_ADPCM = 'DPCM',
    sndFormatMP3 = 'MPG3',
    sndFormatAAC = 'DAAC',
    sndFormatOGG = 'OGGV'
    }

Functions

  • Err SndStreamCreateExtended (SndStreamRef *streamP, SndStreamMode mode, SndFormatType format, UInt32 sampleRate, SndSampleType sampleType, SndStreamWidth width, SndStreamVariableBufferCallback sndCallback, void *userDataP, UInt32 bufferSize, Boolean armNative)
  • Err SndStreamDeviceControl (SndStreamRef stream, Int32 cmd, void *paramP, Int32 size)

Typedef Documentation

typedef UInt32 SndFormatType

Holds sound format type.

typedef Err(* SndStreamVariableBufferCallback)(void *userDataP, SndStreamRef streamRef, void *bufferP, UInt32 *bufferSizeP)

Extended Sound Manager callback.

Parameters:
userDataP,: IN: Pointer to the user data passed in SndStreamCreateExtended.
streamRef,: IN: Opaque reference to the stream returned by SndStreamCreateExtended.
bufferP,: IN: Data buffer.
bufferSizeP,: IN: Pointer to the buffer size in bytes. This MUST be set before returning to the number of bytes read or written.
Return values:
Err Error code.

Enumeration Type Documentation

anonymous enum

Sound format type

Enumerator:
sndFormatPCM | Raw PCM (Pulse Code Modulation), (attributes defined by type parameter).
sndFormatIMA_ADPCM | IMA ADPCM (Interactive Multimedia Association Adaptive Differential PCM).
sndFormatDVI_ADPCM | Intel/MS/DVI ADPCM.
sndFormatMP3 | Moving Picture Experts Group, Audio Layer III (MPEG-1 and MPEG-2 depending on bit-rate).
sndFormatAAC | Dolby Advanced Audio Coding.
sndFormatOGG | Ogg Vorbis.

Function Documentation

Err SndStreamCreateExtended | ( | SndStreamRef * | streamP,
 |  | SndStreamMode | mode,
 |  | SndFormatType | format,
 |  | UInt32 | sampleRate,
 |  | SndSampleType | sampleType,
 |  | SndStreamWidth | width,
 |  | SndStreamVariableBufferCallback | sndCallback,
 |  | void * | userDataP,
 |  | UInt32 | bufferSize,
 |  | Boolean | armNative
 | ) |

Creates a sound stream using the Extended Sound API.

Parameters:
streamP,: IN: Receives the opaque reference to the stream.
mode,: IN: Direction of the sream, either sndInput or sndOutput.
format,: IN: Sound format. (sndFormatPCM...)
sampleRate,: IN: Sampling rate, in frames-per-second. (8000, 44100,...)
sampleType,: IN: Sample size and endianness of the data. (sndInt16...)
width,: IN: The number of channels: sndMono for one channel, sndStrereo for two.
sndCallback,: IN: A callback function that gets called when another buffer for sound is needed.
userDataP,: IN: Caller-defined data that gets passed to SndStreamVariableBufferCallback.
bufferSize,: IN: Preferred size in bytes for the buffers that are passed to sndCallback.
armNative,: IN: Pass true if the callback function is written in ARM-native code. If it’s 68K, pass false.
Return values:
Err Error code.

Err SndStreamDeviceControl | ( | SndStreamRef | stream,
 |  | Int32 | cmd,
 |  | void * | paramP,
 |  | Int32 | size
 | ) |

An extended function to handle new or device specific custom sound controls.

Parameters:
stream,: IN: Opaque reference to the stream returned by SndStreamCreateExtended.
cmd,: IN: One of the defined custom control enums, such as sndControlCodecCustomControl.
paramP,: IN: Pointer to data specific to the specific custom control defined by cmd.
size,: IN: Size in bytes of the structure passed in paramP.
Return values:
Err Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:19 2006 for Palm API Guide


PalmVMLaunch.h File Reference

Detailed Description

Defines APIs and structures for launching VersaMail to add a new message from an application.

Version:
1.0

Include dependency graph for PalmVMLaunch.h:

Data Structures

  • struct MMProAttachStruct
    Structure for adding attachments in MMProLaunchStruct. More...
  • struct MMProLaunchStruct
    Structure to add a message + attachment passed with MMPRO_LAUNCH_CODE. More...
  • struct MMProAttachDataLinks
    Data links used in an attachment, used in MMProAttachStruct2. More...
  • struct MMProAttachStruct2
    Structure for adding attachments in MMProLaunchStruct2. More...
  • struct MMProLaunchStruct2
    Structure to add a message + attachment passed with MMPRO_LAUNCH_CODE. More...
  • struct MailAddRecordAttachment
    Structure to add attachment in MailAddRecordParamsTypePlus. More...
  • struct MailAddRecordParamsTypePlus
    Structure to add a message + attachment passed with MMPRO_ADD_MESSAGE_WITH_ATTACHMENT Categories & MailAddRecordParamsType are defined in AppLaunchCmd.h. More...

Launch Codes

  • #define MMPRO_LAUNCH_CODE (sysAppLaunchCmdCustomBase + 2)
  • #define MMPRO_ADD_MESSAGE_WITH_ATTACHMENT (sysAppLaunchCmdCustomBase + 16)
  • #define MM_MAX_ATTACHMENTS 10

Define Documentation

#define MM_MAX_ATTACHMENTS 10

Maximum no. of attach

#define MMPRO_ADD_MESSAGE_WITH_ATTACHMENT (sysAppLaunchCmdCustomBase + 16)

Launch for adding a message to VersaMail with attachments, more powerful than sysAppLaunchCmdAddRecord

#define MMPRO_LAUNCH_CODE (sysAppLaunchCmdCustomBase + 2)

Launch code for launching VersaMail through SysUIAppSwitch.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:19 2006 for Palm API Guide


PalmVMPlugin.h File Reference

Detailed Description

Defines APIs and structures for the VersaMail Plugin Service which lets users write plugins to view/send attachments.

Version:
1.0

Include dependency graph for PalmVMPlugin.h:

Data Structures

  • struct _pluginGetInfoParams
    Structure used for launch code MMPRO_PLUGIN_GET_INFO_LAUNCHCODE. More...
  • struct _dataLinks
    Structure used for datalinks while sending /rcving data. More...
  • struct _pluginParams
    Structure used for launch code MMPRO_PLUGIN_RECEIVE_LAUNCHCODE. More...
  • struct _pluginQueryParams
    Structure used for launch code MMPRO_PLUGIN_QUERY_LAUNCHCODE. More...
  • struct _pluginSendParams
    Structure used for launch code MMPRO_PLUGIN_SEND_LAUNCHCODE. More...
  • struct _pluginExtendedQueryParams
    Structure used for launch code MMPRO_PLUGIN_EXTENDED_QUERY_LAUNCHCODE. More...

Application Launch Codes

  • #define MMPRO_PLUGIN_LAUNCHCODE (sysAppLaunchCmdCustomBase + 2)
  • #define MMPRO_PLUGIN_RECEIVE_LAUNCHCODE MMPRO_PLUGIN_LAUNCHCODE
  • #define MMPRO_PLUGIN_QUERY_LAUNCHCODE (sysAppLaunchCmdCustomBase + 3)
  • #define MMPRO_PLUGIN_SEND_LAUNCHCODE (sysAppLaunchCmdCustomBase + 4)
  • #define MMPRO_PLUGIN_EXTENDED_QUERY_LAUNCHCODE (sysAppLaunchCmdCustomBase + 5)
  • #define MMPRO_PLUGIN_GET_INFO_LAUNCHCODE (sysAppLaunchCmdCustomBase + 8)

Defines

  • #define ATTYPE_MAX_NAME_LEN 32

Typedefs

  • typedef _pluginGetInfoParams pluginGetInfoParams
    Structure used for launch code MMPRO_PLUGIN_GET_INFO_LAUNCHCODE.
  • typedef _dataLinks dataLinks
    Structure used for datalinks while sending /rcving data.
  • typedef _pluginParams pluginParams
    Structure used for launch code MMPRO_PLUGIN_RECEIVE_LAUNCHCODE.
  • typedef _pluginQueryParams pluginQueryParams
    Structure used for launch code MMPRO_PLUGIN_QUERY_LAUNCHCODE.
  • typedef _pluginSendParams pluginSendParams
    Structure used for launch code MMPRO_PLUGIN_SEND_LAUNCHCODE.
  • typedef _pluginExtendedQueryParams pluginExtendedQueryParams
    Structure used for launch code MMPRO_PLUGIN_EXTENDED_QUERY_LAUNCHCODE.

Enumerations

  • enum PluginInfo {
    plugin_sendInfo,
    plugin_receiveInfo,
    plugin_allInfo
    }
    PluginInfo is specifies what plugin information is needed. More...

Define Documentation

#define ATTYPE_MAX_NAME_LEN 32

Maximum array size for name of an attachment in listSendNames pointer

#define MMPRO_PLUGIN_EXTENDED_QUERY_LAUNCHCODE (sysAppLaunchCmdCustomBase + 5)

Plugin should support selection of attachment and should return

#define MMPRO_PLUGIN_GET_INFO_LAUNCHCODE (sysAppLaunchCmdCustomBase + 8)

VersaMail queries the plugin to get the details of Plugin information

#define MMPRO_PLUGIN_LAUNCHCODE (sysAppLaunchCmdCustomBase + 2)

Plugin receives data from VersaMail and do whatever it deems appropriate with it.

#define MMPRO_PLUGIN_QUERY_LAUNCHCODE (sysAppLaunchCmdCustomBase + 3)

Plugin should return a list of attachments for the user to select from.

#define MMPRO_PLUGIN_RECEIVE_LAUNCHCODE MMPRO_PLUGIN_LAUNCHCODE

Plugin receives data from VersaMail and do whatever it deems appropriate with it.

#define MMPRO_PLUGIN_SEND_LAUNCHCODE (sysAppLaunchCmdCustomBase + 4)

The plugin should return the name of ? selected attachment for sending

Typedef Documentation

typedef struct _dataLinks dataLinks

Structure used for datalinks while sending /rcving data.

typedef struct _pluginExtendedQueryParams pluginExtendedQueryParams

Structure used for launch code MMPRO_PLUGIN_EXTENDED_QUERY_LAUNCHCODE.

typedef struct _pluginGetInfoParams pluginGetInfoParams

Structure used for launch code MMPRO_PLUGIN_GET_INFO_LAUNCHCODE.

typedef struct _pluginParams pluginParams

Structure used for launch code MMPRO_PLUGIN_RECEIVE_LAUNCHCODE.

typedef struct _pluginQueryParams pluginQueryParams

Structure used for launch code MMPRO_PLUGIN_QUERY_LAUNCHCODE.

typedef struct _pluginSendParams pluginSendParams

Structure used for launch code MMPRO_PLUGIN_SEND_LAUNCHCODE.

Enumeration Type Documentation

enum PluginInfo

PluginInfo is specifies what plugin information is needed.

Enumerator:
plugin_sendInfo | Provides info about what can be passed as an email attachment.
plugin_receiveInfo | Provides info about what file types can be viewed.
plugin_allInfo | Provides sendInfo and receiveInfo.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:20 2006 for Palm API Guide


PalmVPPI.h File Reference

Detailed Description

This is the API for VPN panel plug-ins (VPPIs).

Version:
1.0
The VPN panel allows the user to manage their VPN accounts. Each plug-in provides support for a specific VPN protocol such as PPTP or IPSec. A VPPI provides access to the user interface of a VPN client. An NPPI (Network panel plug-in) provides the underlying implementation as well as an alternate user interface.

Data Structures

  • struct VPNAccountType
    VPN Account structure. More...
  • struct SysVPPILaunchCmdGetAccountsType
    Structure used by the VPN Panel to query the account from a VPPI. More...
  • struct SysVPPILaunchCmdEditAccountType
    Structure used by the VPN Panel to edit an account. More...
  • struct SysVPPILaunchCmdDeleteAccountType
    Structure used by the VPN Panel to delete an account. More...
  • struct SysVPPILaunchCmdSetCurrentAccountType
    Structure used by the VPN Panel to set the current account. More...
  • struct SysVPPILaunchCmdPromptAndConfigureType
    Structure used by the VPN Panel to request the VPPI to display a dialog. More...
  • struct SysVPPILaunchCmdProgressPaintType
    Structure used by the VPN Panel to show the progess dialog. More...
  • struct SysVPPILaunchCmdErrorDialogType
    Structure used by the VPN Panel to show the error dialog. More...
  • struct SysVPPILaunchCmdClearPWCacheType
    Structure used by the VPN Panel to clear the password cache. More...
  • struct SysVPPILaunchCmdWillPWPromptType
    Structure used by the VPN Panel to determine is the VPPI will prompt for password. More...

Defines

  • #define sysFileTVPNPanelPlugin 'Vppi'
  • #define kMaxVPNAccountNameLength 31
  • #define sysVPPILaunchCmdGetAccounts sysAppLaunchCmdCustomBase
  • #define sysVPPILaunchCmdEditAccount (sysAppLaunchCmdCustomBase + 1)
  • #define sysVPPILaunchCmdDeleteAccount (sysAppLaunchCmdCustomBase + 2)
  • #define sysVPPILaunchCmdSetCurrentAccount (sysAppLaunchCmdCustomBase + 3)
  • #define sysVPPILaunchCmdPromptAndConfigure (sysAppLaunchCmdCustomBase + 4)
  • #define sysVPPILaunchCmdProgressPaint (sysAppLaunchCmdCustomBase + 5)
  • #define sysVPPILaunchCmdErrorDialog (sysAppLaunchCmdCustomBase + 6)
  • #define sysVPPILaunchCmdClearPWCache (sysAppLaunchCmdCustomBase + 7)
  • #define sysVPPILaunchCmdWillPWPrompt (sysAppLaunchCmdCustomBase + 8)

Define Documentation

#define kMaxVPNAccountNameLength 31

Account name maximum length.

#define sysFileTVPNPanelPlugin 'Vppi'

Database type for VPN panel plug-ins.

#define sysVPPILaunchCmdClearPWCache (sysAppLaunchCmdCustomBase + 7)

Launch code used by the VPN Panel to clear the password cache.

#define sysVPPILaunchCmdDeleteAccount (sysAppLaunchCmdCustomBase + 2)

Launch code used by the VPN Panel to delete an account.

#define sysVPPILaunchCmdEditAccount (sysAppLaunchCmdCustomBase + 1)

Launch code used by the VPN Panel to edit an account.

#define sysVPPILaunchCmdErrorDialog (sysAppLaunchCmdCustomBase + 6)

Launch code used by the VPN Panel to show the error dialog.

#define sysVPPILaunchCmdGetAccounts sysAppLaunchCmdCustomBase

Launch code used by the VPN Panel to get the account list.

#define sysVPPILaunchCmdProgressPaint (sysAppLaunchCmdCustomBase + 5)

Launch code used by the VPN Panel to show the progess dialog.

#define sysVPPILaunchCmdPromptAndConfigure (sysAppLaunchCmdCustomBase + 4)

Launch code used by the VPN Panel to request the VPPI to display a dialog.

#define sysVPPILaunchCmdSetCurrentAccount (sysAppLaunchCmdCustomBase + 3)

Launch code used by the VPN Panel to set the current account.

#define sysVPPILaunchCmdWillPWPrompt (sysAppLaunchCmdCustomBase + 8)

Launch code used by the VPN Panel to determine is the VPPI will prompt for password.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:20 2006 for Palm API Guide


PalmWiFiCommon.h File Reference

Detailed Description

Constants and structures common to the wifi network panel and driver.

Version:
1.0

Include dependency graph for PalmWiFiCommon.h:

Data Structures

  • struct NetBssInfoType
    Structure to hold BSS Info data. More...
  • struct NetworkDeviceQueryData
    Structure to hold network query data. More...
  • struct BSSListStruct
    BSS list. More...
  • struct NetSSID
    Structure used to get and set the current SSID for the driver (not the Network interface). More...
  • struct NetWepKey
    Structure used to set the wep keys. More...

Event Notifications

Event notifications from the WiFi -- can be used for SysNotifyRegister
  • #define WIFI_ASSOCIATED_EVENT 'WiAs'
  • #define WIFI_DISASSOCIATED_EVENT 'WiDi'
  • #define WIFI_SCAN_COMPLETE_EVENT 'WiSc'
  • #define WIFI_IF_UP_EVENT 'WiUp'
  • #define WIFI_IF_DOWN_EVENT 'WiDn'

Encryption Algorithm

  • #define AUTHENTICATION_ALGORITHM_OPEN_SYSTEM 1
  • #define AUTHENTICATION_ALGORITHM_SHARED_KEY 2
  • #define AUTHENTICATION_ALGORITHM_SHARED_KEY_128 3

ESS TX power mode.

  • #define AUTO_TX_POWER 0
  • #define ENHANCED_TX_POWER 1

AdHoc power modes.

  • #define FULL_TX_POWER 0
  • #define _30_MW_TX_POWER 1
  • #define _15_MW_TX_POWER 2
  • #define _5_MW_TX_POWER 3
  • #define _1_MW_TX_POWER 4

AP density constants.

Referred as netIFSetting80211Environment in configuration.
  • #define AP_DENSITY_LOW 0
  • #define AP_DENSITY_MED 1
  • #define AP_DENSITY_HIGH 2

Adapter Preamble

  • #define LONG_PREAMBLE 0
  • #define SHORT_PREAMBLE 1
  • #define AUTO_PREAMBLE 2

Network Device Driver Interface Error Codes

  • #define errNetQueryBufTooSmall 11
  • #define errNetOutOfMemory 12
  • #define errNetLibMissing 13
  • #define errNetInterfaceNotFound 14
  • #define BSSINFO_VFLAG 0
  • #define BSSINFO_VFLAG_SIZE 4
  • #define BSSINFO_MAC_ADDR_OFFSET (BSSINFO_VFLAG + BSSINFO_VFLAG_SIZE)
  • #define BSSINFO_MAC_ADDR_SIZE 8
  • #define BSSINFO_MAC_ADDR_VFLAG 0x00000001L
  • #define BSSINFO_SSIDLENGTH_OFFSET (BSSINFO_MAC_ADDR_OFFSET + BSSINFO_MAC_ADDR_SIZE)
  • #define BSSINFO_SSIDLENGTH_SIZE 4
  • #define BSSINFO_SSIDLENGTH_VFLAG 0x00000002L
  • #define BSSINFO_SSID_OFFSET (BSSINFO_SSIDLENGTH_OFFSET + BSSINFO_SSIDLENGTH_SIZE)
  • #define BSSINFO_SSID_SIZE netSSIDMaxLength
  • #define BSSINFO_SSID_VFLAG 0x00000004L
  • #define BSSINFO_WEP_OFFSET (BSSINFO_SSID_OFFSET + BSSINFO_SSID_SIZE)
  • #define BSSINFO_WEP_SIZE 4
  • #define BSSINFO_WEP_VFLAG 0x00000008L
  • #define BSSINFO_RSSI_OFFSET (BSSINFO_WEP_OFFSET + BSSINFO_WEP_SIZE)
  • #define BSSINFO_RSSI_SIZE 4
  • #define BSSINFO_RSSI_VFLAG 0x00000010L
  • #define BSSINFO_NETWORK_TYPE_OFFSET (BSSINFO_RSSI_OFFSET + BSSINFO_RSSI_SIZE)
  • #define BSSINFO_NETWORK_TYPE_SIZE 4
  • #define BSSINFO_NETWORK_TYPE_VFLAG 0x00000020L
  • #define BSSINFO_BEACON_PERIOD_OFFSET (BSSINFO_NETWORK_TYPE_OFFSET + BSSINFO_NETWORK_TYPE_SIZE)
  • #define BSSINFO_BEACON_PERIOD_SIZE 4
  • #define BSSINFO_BEACON_PERIOD_VFLAG 0x00000040L
  • #define BSSINFO_ATIM_WINDOW_OFFSET (BSSINFO_BEACON_PERIOD_OFFSET + BSSINFO_BEACON_PERIOD_SIZE)
  • #define BSSINFO_ATIM_WINDOW_SIZE 4
  • #define BSSINFO_ATIM_WINDOW_VFLAG 0x00000080L
  • #define BSSINFO_DSFREQ_OFFSET (BSSINFO_ATIM_WINDOW_OFFSET + BSSINFO_ATIM_WINDOW_SIZE)
  • #define BSSINFO_DSFREQ_SIZE 4
  • #define BSSINFO_DSFREQ_VFLAG 0x00000100L
  • #define BSSINFO_HOPPATTERN_OFFSET (BSSINFO_DSFREQ_OFFSET + BSSINFO_DSFREQ_SIZE)
  • #define BSSINFO_HOPPATTERN_SIZE 4
  • #define BSSINFO_HOPPATTERN_VFLAG 0x00000200L
  • #define BSSINFO_HOPSET_OFFSET (BSSINFO_HOPPATTERN_OFFSET + BSSINFO_HOPPATTERN_SIZE)
  • #define BSSINFO_HOPSET_SIZE 4
  • #define BSSINFO_HOPSET_VFLAG 0x00000400L
  • #define BSSINFO_HOPDWELL_OFFSET (BSSINFO_HOPSET_OFFSET + BSSINFO_HOPSET_SIZE)
  • #define BSSINFO_HOPDWELL_SIZE 4
  • #define BSSINFO_HOPDWELL_VFLAG 0x00000800L
  • #define BSSINFO_NETWORK_MODE_OFFSET (BSSINFO_HOPDWELL_OFFSET + BSSINFO_HOPDWELL_SIZE)
  • #define BSSINFO_NETWORK_MODE_SIZE 4
  • #define BSSINFO_NETWORK_MODE_VFLAG 0x00001000L
  • #define BSSINFO_SUPPORTED_RATES_OFFSET (BSSINFO_NETWORK_MODE_OFFSET + BSSINFO_NETWORK_MODE_SIZE)
  • #define BSSINFO_SUPPORTED_RATES_SIZE 8
  • #define BSSINFO_SUPPORTED_RATES_VFLAG 0x00002000L
  • #define BSSINFO_CHID_OFFSET (BSSINFO_SUPPORTED_RATES_OFFSET + BSSINFO_SUPPORTED_RATES_SIZE)
  • #define BSSINFO_CHID_SIZE 4
  • #define BSSINFO_CHID_VFLAG 0x00004000L
  • #define BSSINFO_ANL_OFFSET (BSSINFO_CHID_OFFSET + BSSINFO_CHID_SIZE)
  • #define BSSINFO_ANL_SIZE 4
  • #define BSSINFO_ANL_VFLAG 0x00008000L

Macros for accessing individual fields

  • #define BssInfoMacAddr(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_MAC_ADDR_OFFSET], BSSINFO_MAC_ADDR_SIZE )
  • #define BssInfoSsidLength(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_SSIDLENGTH_OFFSET], BSSINFO_SSIDLENGTH_SIZE )
  • #define BssInfoSsid(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_SSID_OFFSET], BSSINFO_SSID_SIZE )
  • #define BssInfoWep(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_WEP_OFFSET], BSSINFO_WEP_SIZE )
  • #define BssInfoRssi(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_RSSI_OFFSET], BSSINFO_RSSI_SIZE )
  • #define BssInfoNetworkType(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_NETWORK_TYPE_OFFSET], BSSINFO_NETWORK_TYPE_SIZE )
  • #define BssInfoBeaconPeriod(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_BEACON_PERIOD_OFFSET], BSSINFO_BEACON_PERIOD_SIZE )
  • #define BssInfoAtimWindow(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_ATIM_WINDOW_OFFSET], BSSINFO_ATIM_WINDOW_SIZE )
  • #define BssInfoDSFreq(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_DSFREQ_OFFSET], BSSINFO_DSFREQ_SIZE )
  • #define BssInfoHopPattern(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_HOPPATTERN_OFFSET], BSSINFO_HOPPATTERN_SIZE )
  • #define BssInfoHopSet(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_HOPSET_OFFSET], BSSINFO_HOPSET_SIZE )
  • #define BssInfoHopDwell(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_HOPDWELL_OFFSET], BSSINFO_HOPDWELL_SIZE )
  • #define BssInfoNetworkMode(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_NETWORK_MODE_OFFSET], BSSINFO_NETWORK_MODE_SIZE )
  • #define BssInfoSupportedRates(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_SUPPORTED_RATES_OFFSET], BSSINFO_SUPPORTED_RATES_SIZE )
  • #define BssInfoChannelId(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_CHID_OFFSET], BSSINFO_CHID_SIZE )
  • #define BssInfoANL(infoP, destP) MemMove( destP, &((UInt8 *) infoP)[BSSINFO_ANL_OFFSET], BSSINFO_ANL_SIZE )

Defines

  • #define WIFI_MIN_OS_VERSION sysMakeROMVersion(3,0,0,sysROMStageDevelopment,0)
  • #define PALM_OS_20_VERSION sysMakeROMVersion(2,0,0,sysROMStageDevelopment,0)
  • #define WIFI_CREATOR_ID 'WiFi'
  • #define WIFI_CONFIG_NAME "WiFi Config"
  • #define WIFI_DB_TYPE 'DATA'
  • #define WIFI_DB_NAME "WiFiDB"
  • #define WIFI_DRIVER_PREFIX "wi"
  • #define WIFI_DRIVER_NAME "WiFi Prism3"
  • #define ESS 1
  • #define IBSS 4
  • #define net80211ResetWepPasscode 0x41149339
  • #define netMediaDisconnected 0
  • #define netMediaConnected 1
  • #define netMacAddrLength 6
  • #define netSSIDMaxLength 32
  • #define netNum80211Rates 8
  • #define BSSINFO_SIZE (BSSINFO_ANL_OFFSET + BSSINFO_ANL_SIZE)

Typedefs

  • typedef NetBssInfoType * NetBssInfoTypeP
    Structure to hold BSS Info data.
  • typedef NetworkDeviceQueryData NetQueryType
    Structure to hold network query data.
  • typedef NetworkDeviceQueryData * NetQueryTypeP
    Structure to hold network query data.
  • typedef enum _80211NetworkTypeEnum Net80211NetworkType
  • typedef enum _80211InfrastructureEnum Net80211InfrastructureModeType
  • typedef BSSListStruct NetBssListType
    BSS list.
  • typedef NetSSID * NetSSIDP
    Structure used to get and set the current SSID for the driver (not the Network interface).
  • typedef NetWepKey * NetWepKeyP
    Structure used to set the wep keys.

Enumerations

  • enum NetQueryId {
    netQuery80211SignalStrength = 0x100,
    netQuery80211SignalQuality,
    netQuery80211AuthenticationMode,
    netQuery80211BssScan,
    netQuery80211BssScanList,
    netQuery80211Channel,
    netQuery80211PowerState,
    netQuery80211RadioState,
    netQuery80211SSID,
    netQuery80211Key,
    netQuery80211KeyIndex,
    netQuery80211ResetKeys,
    netQuery80211OperatingMode,
    netQuery80211WepStatus,
    netQuery80211FirmwareVersion,
    netQuery80211SerialNumber,
    netQuery80211FWName,
    netQuery80211DriverDate,
    netQuery80211WEPRequired,
    netQuery80211ChannelList,
    netQuery80211BSSID,
    netQueryCancel,
    netQuery80211MediaState,
    netQuery80211SecurityMode,
    netQuery80211StartConnection,
    netQuery80211Last
    }
  • enum IPAllocType {
    IPAllocType_DHCP = 0,
    IPAllocType_APIPA = 1,
    IPAllocType_STATIC = 2
    }
  • enum SecurityModeType {
    SecurityModeOpenSystem = 0,
    SecurityModeWEP,
    SecurityModeWPAPSK,
    SecurityModeLast
    }
  • enum WiFiCustomIFSettings {
    netIFSetting80211PowerMode = netIFSettingCustom,
    netIFSetting80211Diversity,
    netIFSetting80211Channel,
    netIFSetting80211EncryptionKey1,
    netIFSetting80211EncryptionKey2,
    netIFSetting80211EncryptionKey3,
    netIFSetting80211EncryptionKey4,
    netIFSetting80211EncryptionKeyID,
    netIFSetting80211MandatoryBSSId,
    netIFSetting80211MUEncryptionAlgorithm,
    netIFSetting80211PortType,
    netIFSetting80211EssTxPower,
    netIFSetting80211AdhocTxPower,
    netIFSetting80211StationName,
    netIFSetting80211Environment,
    netIFSetting80211LongPreamble,
    netIFSetting80211Gateway,
    netIFSettingPrimaryDNS,
    netIFSettingSecondaryDNS,
    netIFSettingDHCPRequestDNS,
    netIFSettingIPAllocType,
    netIFSetting80211SmartConnect,
    netIFSettingUIProgHoldOff,
    netIFSettingWiFiHideProgress,
    netIFSettingAutoPowerDownOnClose,
    netIFSettingInterfaceQSize,
    netIFSettingDriverQSize,
    netIFSetting8021x,
    netIFSetting80211MediaDisconnectLingerTime,
    netIFSetting80211MobileIP,
    netIFSetting80211Last
    }
  • enum NetWepStatus {
    netWEPEnabled,
    netWEPDisabled,
    netWEPKeyAbsent,
    netWEPNotSupported
    }
  • enum _80211NetworkTypeEnum {
    net80211_FH,
    net80211_DS,
    net80211_Max
    }
  • enum _80211InfrastructureEnum {
    net80211Bss,
    net80211Infrastructure,
    net80211AutoUnknown,
    net80211InfrastructureMax
    }

Define Documentation

#define BSSINFO_ANL_OFFSET (BSSINFO_CHID_OFFSET + BSSINFO_CHID_SIZE)

Offset = 96 (0x60). Channel ID

#define BSSINFO_ANL_SIZE 4

Offset = 96 (0x60). Channel ID

#define BSSINFO_ANL_VFLAG 0x00008000L

Offset = 96 (0x60). Channel ID

#define BSSINFO_ATIM_WINDOW_OFFSET (BSSINFO_BEACON_PERIOD_OFFSET + BSSINFO_BEACON_PERIOD_SIZE)

Offset = 64 (0x40). ATim window (in KuSec)

#define BSSINFO_ATIM_WINDOW_SIZE 4

Offset = 64 (0x40). ATim window (in KuSec)

#define BSSINFO_ATIM_WINDOW_VFLAG 0x00000080L

Offset = 64 (0x40). ATim window (in KuSec)

#define BSSINFO_BEACON_PERIOD_OFFSET (BSSINFO_NETWORK_TYPE_OFFSET + BSSINFO_NETWORK_TYPE_SIZE)

Offset = 60 (0x3C). Beacon period (in KuSec)

#define BSSINFO_BEACON_PERIOD_SIZE 4

Offset = 60 (0x3C). Beacon period (in KuSec)

#define BSSINFO_BEACON_PERIOD_VFLAG 0x00000040L

Offset = 60 (0x3C). Beacon period (in KuSec)

#define BSSINFO_CHID_OFFSET (BSSINFO_SUPPORTED_RATES_OFFSET + BSSINFO_SUPPORTED_RATES_SIZE)

Offset = 96 (0x60). Channel ID

#define BSSINFO_CHID_SIZE 4

Offset = 96 (0x60). Channel ID

#define BSSINFO_CHID_VFLAG 0x00004000L

Offset = 96 (0x60). Channel ID

#define BSSINFO_DSFREQ_OFFSET (BSSINFO_ATIM_WINDOW_OFFSET + BSSINFO_ATIM_WINDOW_SIZE)

Offset = 68 (0x44). DS frequency (in kHz)

#define BSSINFO_DSFREQ_SIZE 4

Offset = 68 (0x44). DS frequency (in kHz)

#define BSSINFO_DSFREQ_VFLAG 0x00000100L

Offset = 68 (0x44). DS frequency (in kHz)

#define BSSINFO_HOPDWELL_OFFSET (BSSINFO_HOPSET_OFFSET + BSSINFO_HOPSET_SIZE)

Offset = 80 (0x50). Frequency hopping dwell time

#define BSSINFO_HOPDWELL_SIZE 4

Offset = 80 (0x50). Frequency hopping dwell time

#define BSSINFO_HOPDWELL_VFLAG 0x00000800L

Offset = 80 (0x50). Frequency hopping dwell time

#define BSSINFO_HOPPATTERN_OFFSET (BSSINFO_DSFREQ_OFFSET + BSSINFO_DSFREQ_SIZE)

Offset = 72 (0x48). Frequency hopping pattern

#define BSSINFO_HOPPATTERN_SIZE 4

Offset = 72 (0x48). Frequency hopping pattern

#define BSSINFO_HOPPATTERN_VFLAG 0x00000200L

Offset = 72 (0x48). Frequency hopping pattern

#define BSSINFO_HOPSET_OFFSET (BSSINFO_HOPPATTERN_OFFSET + BSSINFO_HOPPATTERN_SIZE)

Offset = 76 (0x4C). Frequency hopping set

#define BSSINFO_HOPSET_SIZE 4

Offset = 76 (0x4C). Frequency hopping set

#define BSSINFO_HOPSET_VFLAG 0x00000400L

Offset = 76 (0x4C). Frequency hopping set

#define BSSINFO_MAC_ADDR_OFFSET (BSSINFO_VFLAG + BSSINFO_VFLAG_SIZE)

Offset = 4. MAC/HW Address for device.

#define BSSINFO_MAC_ADDR_SIZE 8

Offset = 4. MAC/HW Address for device.

#define BSSINFO_MAC_ADDR_VFLAG 0x00000001L

Offset = 4. MAC/HW Address for device.

#define BSSINFO_NETWORK_MODE_OFFSET (BSSINFO_HOPDWELL_OFFSET + BSSINFO_HOPDWELL_SIZE)

Offset = 84 (0x54). 802.11 network mode

#define BSSINFO_NETWORK_MODE_SIZE 4

Offset = 84 (0x54). 802.11 network mode

#define BSSINFO_NETWORK_MODE_VFLAG 0x00001000L

Offset = 84 (0x54). 802.11 network mode

#define BSSINFO_NETWORK_TYPE_OFFSET (BSSINFO_RSSI_OFFSET + BSSINFO_RSSI_SIZE)

Offset = 56 (0x38). Network type in use (Freq. hopping, DSS)

#define BSSINFO_NETWORK_TYPE_SIZE 4

Offset = 56 (0x38). Network type in use (Freq. hopping, DSS)

#define BSSINFO_NETWORK_TYPE_VFLAG 0x00000020L

Offset = 56 (0x38). Network type in use (Freq. hopping, DSS)

#define BSSINFO_RSSI_OFFSET (BSSINFO_WEP_OFFSET + BSSINFO_WEP_SIZE)

Offset = 52 (0x34). Received Signal Strength

#define BSSINFO_RSSI_SIZE 4

Offset = 52 (0x34). Received Signal Strength

#define BSSINFO_RSSI_VFLAG 0x00000010L

Offset = 52 (0x34). Received Signal Strength

#define BSSINFO_SIZE (BSSINFO_ANL_OFFSET + BSSINFO_ANL_SIZE)

Total size of the BSS info supplied.

#define BSSINFO_SSID_OFFSET (BSSINFO_SSIDLENGTH_OFFSET + BSSINFO_SSIDLENGTH_SIZE)

Offset = 16 (0x10). SSID

#define BSSINFO_SSID_SIZE netSSIDMaxLength

Offset = 16 (0x10). SSID

#define BSSINFO_SSID_VFLAG 0x00000004L

Offset = 16 (0x10). SSID

#define BSSINFO_SSIDLENGTH_OFFSET (BSSINFO_MAC_ADDR_OFFSET + BSSINFO_MAC_ADDR_SIZE)

Offset = 12. Length of the following SSID

#define BSSINFO_SSIDLENGTH_SIZE 4

Offset = 12. Length of the following SSID

#define BSSINFO_SSIDLENGTH_VFLAG 0x00000002L

Offset = 12. Length of the following SSID

#define BSSINFO_SUPPORTED_RATES_OFFSET (BSSINFO_NETWORK_MODE_OFFSET + BSSINFO_NETWORK_MODE_SIZE)

Offset = 88 (0x58). Supported rates on interface.

#define BSSINFO_SUPPORTED_RATES_SIZE 8

Offset = 88 (0x58). Supported rates on interface.

#define BSSINFO_SUPPORTED_RATES_VFLAG 0x00002000L

Offset = 88 (0x58). Supported rates on interface.

#define BSSINFO_VFLAG 0

Offset = 0. Present/validity flags for each of the entities defined below

#define BSSINFO_VFLAG_SIZE 4

Offset = 0. Present/validity flags for each of the entities defined below

#define BSSINFO_WEP_OFFSET (BSSINFO_SSID_OFFSET + BSSINFO_SSID_SIZE)

Offset = 48 (0x30). WEP enabled boolean

#define BSSINFO_WEP_SIZE 4

Offset = 48 (0x30). WEP enabled boolean

#define BSSINFO_WEP_VFLAG 0x00000008L

Offset = 48 (0x30). WEP enabled boolean

#define ESS 1

Operating mode, referred to as port type in the configuration.

#define net80211ResetWepPasscode 0x41149339

Special code required to be passed to reset wep keys

#define netMacAddrLength 6

max length MAC address

#define netMediaConnected 1

Definitions of media states returned from netQuery80211MediaState

#define netMediaDisconnected 0

Definitions of media states returned from netQuery80211MediaState

#define netNum80211Rates 8

no definition

#define netSSIDMaxLength 32

max length SSID

#define PALM_OS_20_VERSION sysMakeROMVersion(2,0,0,sysROMStageDevelopment,0)

Define the appropriate minimum OS version we support

#define WIFI_CONFIG_NAME "WiFi Config"

WiFi configuration name

#define WIFI_CREATOR_ID 'WiFi'

WiFi creator ID.

#define WIFI_DB_NAME "WiFiDB"

WiFi database name

#define WIFI_DB_TYPE 'DATA'

WiFi database type

#define WIFI_DRIVER_NAME "WiFi Prism3"

WiFi driver name

#define WIFI_DRIVER_PREFIX "wi"

WiFi driver prefix

#define WIFI_MIN_OS_VERSION sysMakeROMVersion(3,0,0,sysROMStageDevelopment,0)

Define the appropriate minimum OS version we support

Typedef Documentation

typedef enum _80211InfrastructureEnum Net80211InfrastructureModeType

Infrastructure mode info returned from a BSS scan

typedef struct NetBssInfoType * NetBssInfoTypeP

Structure to hold BSS Info data.

Accessing the BSS scan info returned via the network interface via the following structure needs to be verified for each specific toolchain and compiler. It has been verified with the combination of ADS V1.2 and CW 8.3. The data format has been done to be as toolchain/architecture/alignment independent as possible, however, if a different combination other than the one listed is used, the format must be verified. The macro's defined above can also be used to access the individual entities of the returned BSS scan data.

typedef struct BSSListStruct NetBssListType

BSS list.

This data structure is returned from a BSS scan. The count field indicates how many BSS structures are provide.

typedef struct NetworkDeviceQueryData NetQueryType

Structure to hold network query data.

typedef struct NetworkDeviceQueryData * NetQueryTypeP

Structure to hold network query data.

typedef struct NetSSID * NetSSIDP

Structure used to get and set the current SSID for the driver (not the Network interface).

typedef struct NetWepKey * NetWepKeyP

Structure used to set the wep keys.

The API's do not return the wep keys via a query.

Enumeration Type Documentation

enum _80211InfrastructureEnum

Infrastructure mode info returned from a BSS scan

enum IPAllocType

IP address allocation strategies

enum NetQueryId

Supported Query requests for WiFi driver.

enum NetWepStatus

Wep status codes

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:21 2006 for Palm API Guide


PalmWPPI.h File Reference

Detailed Description

This is the API for Wi-Fi panel plug-ins (WPPIs).

Version:
1.0
Date:
05/16/2003
The Wi-Fi panel allows the user to manage their network profiles. Each profile includes a plugin, an authentication method, and a cookie used to identify the user's credentials. Each plugin provides support for one or more authentication methods; e.g., LEAP, PEAP, etc. A WPPI provides access to the user interface of an 802.1x client.

Data Structures

  • struct WiFiAuthenticationMethodType
  • struct SysWPPILaunchCmdGetAuthenticationMethodsType
  • struct SysWPPILaunchCmdType
  • struct SysWPPILaunchCmdGetDescriptionType
  • struct SysWPPILaunchCmdPromptAndConfigureType
  • struct SysWPPILaunchCmdErrorDialogType
  • struct SysWPPILaunchCmdClearPWCache

Defines

  • #define sysFileTWiFiPanelPlugin 'Wppi'
  • #define sysWPPILaunchCmdGetAuthenticationMethods sysAppLaunchCmdCustomBase
  • #define kMaxWiFiAuthenticationMethodNameLength 31
  • #define kMaxWiFiCredentialsLabelLength 31
  • #define kMaxWiFiCredentialsSelectorTriggerLength 31
  • #define sysWPPILaunchCmdOpen sysAppLaunchCmdCustomBase + 1
  • #define sysWPPILaunchCmdClose sysAppLaunchCmdCustomBase + 2
  • #define sysWPPILaunchCmdDialog sysAppLaunchCmdCustomBase + 3
  • #define sysWPPILaunchCmdDelete sysAppLaunchCmdCustomBase + 4
  • #define sysWPPILaunchCmdGetDescription sysAppLaunchCmdCustomBase + 5
  • #define sysWPPILaunchCmdPromptAndConfigure (sysAppLaunchCmdCustomBase + 6)
  • #define sysWPPILaunchCmdErrorDialog (sysAppLaunchCmdCustomBase + 7)
  • #define sysWPPILaunchCmdClearPWCache (sysAppLaunchCmdCustomBase + 8)

Define Documentation

#define sysFileTWiFiPanelPlugin 'Wppi'

database type for Wi-Fi panel plug-ins

#define sysWPPILaunchCmdClearPWCache (sysAppLaunchCmdCustomBase + 8)

This is invoked to request a password cache clear. Removes temporary passwords from all accounts managed by the WPPI.

#define sysWPPILaunchCmdClose sysAppLaunchCmdCustomBase + 2

If a non-zero cookie is passed in, we're editing an existing network with existing credentials. The WPPI should find the credentials in its database and put them in a temporary location. If a zero cookie is passed in, we're either creating a new network, editing an existing network that didn't previous have credentials, or switching authentication methods. The WPPI should set the credentialsLabel and credentialsSelectorTrigger. Typically, the credentialsLabel is "Credentials:" and the credentialsSelectorTrigger is "-Assigned-" or "-Unassigned-". Every call to sysWPPILaunchCmdOpen is matched with a call to sysWPPILaunchCmdClose.

#define sysWPPILaunchCmdDelete sysAppLaunchCmdCustomBase + 4

The WPPI should open its dialog and allow the user to edit the credentials. It should read from the temporary location to initialize the username and password fields or other UI elements as appropriate. It should write to the temporary location when the user taps OK. It shouldn't access its database. Whether the user tapped Cancel should be stored in the cancel flag in the command parameter block. If the user taps OK and this changes the current credentials state (typically assigned/unassigned), the credentialsSelectorTrigger field should be updated by the WPPI. Note that the user may delete his credentials causing the state to change from assigned to unassigned.

#define sysWPPILaunchCmdDialog sysAppLaunchCmdCustomBase + 3

If the save flag is set, the WPPI should write the user's credentials to its database. If the cookie is zero, it should create a new record and save its unique ID in the cookie field of the command parameter block. If the cookie is non-zero, it should overwrite the old record.

#define sysWPPILaunchCmdErrorDialog (sysAppLaunchCmdCustomBase + 7)

This is invoked to put up an error dialog.

#define sysWPPILaunchCmdGetDescription sysAppLaunchCmdCustomBase + 5

Finally, the Wi-Fi Setup wizard displays a detailed description of the selected authentication method. To do this, it sublaunches the WPPI with the following launch code and command parameter block.

#define sysWPPILaunchCmdPromptAndConfigure (sysAppLaunchCmdCustomBase + 6)

This is invoked to bring up the prompt dialog (WPPI decides if prompt is necessary) or pass any kind of data to the WPPI. Optionally, before exiting, a WPPI can set the netIFSettingDot1XConfig setting to pass information back to the 802.1X plugin.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:21 2006 for Palm API Guide


PmConnectorLib.h File Reference

Detailed Description

palmOne library that exports multi-connector related APIs.

Include dependency graph for PmConnectorLib.h:

Defines

  • #define PMCONNECTOR_LIB_TRAP(trapNum) SYS_TRAP(trapNum)

Functions

  • Err PmConnectorLibOpen (UInt16 refNum)(kPmConnectorLibTrapOpen)
    Standard library open routine.
  • Err PmConnectorLibClose (UInt16 refNum)(kPmConnectorLibTrapClose)
    Standard library close routine.
  • Err PmConnectorLibSleep (UInt16 refNum)(kPmConnectorLibTrapSleep)
    Standard library sleep routine.
  • Err PmConnectorLibWake (UInt16 refNum)(kPmConnectorLibTrapWake)
    Standard library wake routine.
  • Err PmConnectorLibGetVersion (UInt16 refNum, UInt32 sdkVersion, UInt32 *LibVersionP)(kPmConnectorLibTrapGetVersion)
    Checks the version of the library present on the device.
  • Err PmConnectorLibControl (UInt16 refNum, UInt16 cmdId, void *parmP)(kPmConnectorLibTrapControl)
    Controls the pins on the connector. Currently supports power on and off.
  • Err PmConnectorLibSetAudioOutput (UInt16 refNum, PmConnectorAudioOutputSettingType outputSetting)(kPmConnectorLibTrapSetAudioOutput)
    Targets audio output to different audio peripherals.
  • Err PmConnectorLibSetAudioInput (UInt16 refNum, PmConnectorAudioInputSettingType inputSetting)(kPmConnectorLibTrapSetAudioInput)
    Targets audio input from different audio peripherals.

Function Documentation

Err PmConnectorLibClose ( UInt16 refNum )

Standard library close routine.

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code.

Err PmConnectorLibControl | ( | UInt16 | refNum,
 |  | UInt16 | cmdId,
 |  | void * | parmP
 | ) |

Controls the pins on the connector. Currently supports power on and off.

Parameters:
refNum,: IN: library reference number
cmdId,: IN: type of control.
See also:
PmConnectorLibControlType
Parameters:
parmP,: IN: contains the value needed depending on type of control
Return values:
Err Error code.

Err PmConnectorLibGetVersion | ( | UInt16 | refNum,
 |  | UInt32 | sdkVersion,
 |  | UInt32 * | LibVersionP
 | ) |

Checks the version of the library present on the device.

Parameters:
refNum,: IN: library reference number
sdkVersion,: IN: sdkVersion defined in the common header file
LibVersionP,: IN: version of the library on the device
Return values:
Err Error code. Function returns error when it finds incompatible library

Err PmConnectorLibOpen ( UInt16 refNum )

Standard library open routine.

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code.

Err PmConnectorLibSetAudioInput | ( | UInt16 | refNum,
 |  | PmConnectorAudioInputSettingType | inputSetting
 | ) |

Targets audio input from different audio peripherals.

Parameters:
refNum IN: library reference number
inputSetting,: IN: audio capabilities (headset etc)
Return values:
Err Error code.

Err PmConnectorLibSetAudioOutput | ( | UInt16 | refNum,
 |  | PmConnectorAudioOutputSettingType | outputSetting
 | ) |

Targets audio output to different audio peripherals.

Parameters:
refNum IN: library reference number
outputSetting,: IN: audio capabilities (headphone, speaker, etc)
Return values:
Err Error code.

Err PmConnectorLibSleep ( UInt16 refNum )

Standard library sleep routine.

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code.

Err PmConnectorLibWake ( UInt16 refNum )

Standard library wake routine.

Parameters:
refNum,: IN: library reference number
Return values:
Err Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:21 2006 for Palm API Guide


PmConnectorLibCommon.h File Reference

Detailed Description

Public 68k common header file for Multi-Connector Library for palmOne devices that use multi-connector.

This file contains common structures, types and defines for palmOne library that exports multi-connector related APIs.

Include dependency graph for PmConnectorLibCommon.h:

Data Structures

  • struct PmConnectorNotifyDataType
    Container for the notification details. More...

Function Traps

  • #define kPmConnectorLibTrapOpen sysLibTrapOpen
  • #define kPmConnectorLibTrapClose sysLibTrapClose
  • #define kPmConnectorLibTrapSleep sysLibTrapSleep
  • #define kPmConnectorLibTrapWake sysLibTrapWake
  • #define kPmConnectorLibTrapGetVersion (sysLibTrapCustom + 0)
  • #define kPmConnectorLibTrapControl (sysLibTrapCustom + 1)
  • #define kPmConnectorLibTrapSetAudioOutput (sysLibTrapCustom + 2)
  • #define kPmConnectorLibTrapSetAudioInput (sysLibTrapCustom + 3)

Error Codes

  • #define kPmConnectorLibErrorClass (oemErrorClass + 0x100)
  • #define kPmConnectorLibErrBadParam (kPmConnectorLibErrorClass | 0x01)
  • #define kPmConnectorLibErrNoMemory (kPmConnectorLibErrorClass | 0x02)
  • #define kPmConnectorLibErrNotOpen (kPmConnectorLibErrorClass | 0x03)
  • #define kPmConnectorLibErrStillOpen (kPmConnectorLibErrorClass | 0x04)
  • #define kPmConnectorLibErrInternal (kPmConnectorLibErrorClass | 0x05)
  • #define kPmConnectorLibErrNotSupported (kPmConnectorLibErrorClass | 0x06)
  • #define kPmConnectorLibErrNotCompatible (kPmConnectorLibErrorClass | 0x07)

Control commands for Connector

  • #define kPmConnectorLibCtrlPowerOn 0x01
  • #define kPmConnectorLibCtrlPowerOff 0x02
  • #define kPmConnectorLibCtrlGetDeviceClass 0x03

Notification Constants

  • #define kPmConnectorClassAudioWHeadset 0x05
  • #define kPmConnectorClassAudioNoHeadset 0x00
  • #define kPmConnectorClassCarkit 0x01
  • #define kPmConnectorClassGenericSerial 0x03
  • #define kPmConnectorClassSmartSerial 0x07
  • #define kPmConnectorClassSerial 0x10
  • #define kPmConnectorClassUSB 0xf0
  • #define kPmConnectorClassUnknown 0x00ff
  • #define kPmConnectorClassNoDevice 0x0fff
  • #define kPmConnectorClassMask 0x0fff

Defines

  • #define kPmConnectorLibType sysFileTLibrary
  • #define kPmConnectorLibCreator 'PmAt'
  • #define kPmConnectorLibName "PmConnector"
  • #define kPmConnectorNotifyType 'PmCo'
  • #define kPmConnectorNotifySysAttach sysExternalConnectorAttachEvent
  • #define kPmConnectorNotifySysDetach sysExternalConnectorDetachEvent
  • #define kPmDockStatusCharging 0x08
  • #define kPmDockStatusUSBCradle 0x10
  • #define kPmDockStatusSerialPeripheral 0x40
  • #define kPmConnectorLibVersion sysMakeROMVersion(1, 3, 2, sysROMStageRelease, 0)

Typedefs

  • typedef UInt16 PmConnectorStateType
  • typedef enum tagAudioOutputSetting ePmConnectorAudioOutputSettingsType
    Audio Output Routings.
  • typedef UInt16 PmConnectorAudioOutputSettingType
  • typedef enum tagAudioInputSetting ePmConnectorAudioInputSettingsType
  • typedef UInt16 PmConnectorAudioInputSettingType
  • typedef UInt16 PmConnectorLibControlType

Enumerations

  • enum ePmConnectorDeviceState {
    kPmConnectorDeviceAttach = 0x8000,
    kPmConnectorDeviceDetach = 0x4000
    }
    State of the connector. More...
  • enum tagAudioOutputSetting {
    kAudioOutputSettingDefault = 0,
    kAudioOutputSettingHeadphone,
    kAudioOutputSettingAthena,
    kAudioOutputSettingSpeaker
    }
    Audio Output Routings. More...
  • enum tagAudioInputSetting {
    kAudioInputDefault = 0,
    kAudioInputExternalMic,
    kAudioInputInternalMic
    }

Typedef Documentation

typedef enum tagAudioOutputSetting ePmConnectorAudioOutputSettingsType

Audio Output Routings.

typedef UInt16 PmConnectorAudioOutputSettingType

Audio Output setting type

typedef UInt16 PmConnectorLibControlType

Library control type

Enumeration Type Documentation

enum ePmConnectorDeviceState

State of the connector.

Enumerator:
kPmConnectorDeviceAttach | is currently attached
kPmConnectorDeviceDetach | is currently detached

enum tagAudioOutputSetting

Audio Output Routings.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:22 2006 for Palm API Guide


PmKeyLib.h File Reference

Detailed Description

System Library that exports key-related APIs.

This library is based on key APIs from HsExtensions and was broken apart from HsExtensions so the APIs could be ported to other platforms.

Include dependency graph for PmKeyLib.h:

Functions

  • Err PmKeyLibOpen (UInt16 refNum)
  • Err PmKeyLibClose (UInt16 refNum)
  • UInt16 PmKeyKeysPressed (UInt16 refNum, UInt16 count, const UInt16 keyCodes[], Boolean pressed[])
  • Err PmKeyStop (UInt16 refNum, UInt16 keyCode)
  • Boolean PmKeyEnableKey (UInt16 refNum, UInt16 keyCode, Boolean enabled)
  • UInt16 PmKeyChrCodeToKeyCode (UInt16 refNum, UInt16 chrCode)
  • void PmKeyKeyCodeToChrCode (UInt16 refNum, UInt16 keyCode, UInt16 modifiersIn, UInt16 *chrP, UInt16 *modifiersOutP)
  • Boolean PmKeyEventIsFromKeyboard (UInt16 refNum, EventPtr eventP)
  • Err PmKeyAttrGet (UInt16 refNum, UInt16 attr, UInt32 flags, UInt32 *valueP)
  • Err PmKeyAttrSet (UInt16 refNum, UInt16 attr, UInt32 flags, UInt32 value)

Function Documentation

Err PmKeyAttrGet | ( | UInt16 | refNum,
 |  | UInt16 | attr,
 |  | UInt32 | flags,
 |  | UInt32 * | valueP
 | ) |

Get any palmOne specific key attributes that aren't appropriate to be accessed through a feature. (e.g. dynamic information about device state)

The following code sample retrieves the keyguard state (active or inactive) and disables it accordingly.

///

Note that there are new attributes added for version 3 of the PmKeyAttrGet() function, so it is highly recommended that any application that calls this function does one or both of the following:

Check the return code. If its hsErrNotSupported, then the attribute that the function is looking for is NOT SUPPORTED using that particular version of the library!

  • OR -

Check the version number of the PmKeyLib. To do this, load the PmKeyLib and then get the feature with creator = kPmKeyLibCreator and featureNum = kPmKeyLibFtrValAPIVersion. Note that if the feature does not exist (and the library successfully loaded), they can assume that it's version 1.0 of PmKeyLib. If the feature does exist, then perform a check similar to the following:

///

Parameters:
refNum,: IN: library reference number (returned by SysLibFind() / SysLibLoad() )
attr,: IN: the attribute being retrieved
See also:
PmKeyAttrEnum
Parameters:
flags,: IN: depends on attr (currently implemented attributes only take 0 for this argument)
valueP,: OUT: cast depending on attr (refer to PmKeyAttrEnum for data type this argument should point to)
Return values:
Err error code. 0 if no error, hsErrNotSupported otherwise.

Err PmKeyAttrSet | ( | UInt16 | refNum,
 |  | UInt16 | attr,
 |  | UInt32 | flags,
 |  | UInt32 | value
 | ) |

Set palmOne specific attributes

Parameters:
attr,: IN: the attribute being set
flags,: IN: depends on attr (currently implemented attributes only take 0 for this argument)
value,: IN: cast depending on attr (refert to PmKeyAttrEnum for data type this argument should point to)
Return values:
Err error code. 0 if no error, hsErrNotSupported otherwise.

UInt16 PmKeyChrCodeToKeyCode | ( | UInt16 | refNum,
 |  | UInt16 | chrCode
 | ) |

Determine which key generates a certain character This is the complement of HALKeyKeyCodeToChrCode()

Parameters:
refNum,: IN: library reference number (returned by SysLibFind() / SysLibLoad() )
chrCode,: IN: the character to search for
Return values:
UInt16 the keycode returned.

Boolean PmKeyEnableKey | ( | UInt16 | refNum,
 |  | UInt16 | keyCode,
 |  | Boolean | enabled
 | ) |

Enable/disable a key from generating key events. This extends HALKeySetMask().

Parameters:
refNum,: IN: library reference number (returned by SysLibFind() / SysLibLoad() )
keyCode,: IN: the key to enable/disable
enabled,: IN: true to enable, false to disable
Return values:
Boolean true if previously enabled

Boolean PmKeyEventIsFromKeyboard | ( | UInt16 | refNum,
 |  | EventPtr | eventP
 | ) |

Determine if an event came from the physical keyboard

Parameters:
refNum,: IN: library reference number (returned by SysLibFind() / SysLibLoad() )
eventP,: IN: the event to check
Return values:
Boolean true if the event came from the keyboard

void PmKeyKeyCodeToChrCode | ( | UInt16 | refNum,
 |  | UInt16 | keyCode,
 |  | UInt16 | modifiersIn,
 |  | UInt16 * | chrP,
 |  | UInt16 * | modifiersOutP
 | ) |

Translate a key code to the character generated by that key. Each key can generate several different characters, depending on which modifier keys are held when it is pressed. The caller needs to specify which modified state of the key should be used to select the appropriate character. This is the complement of HALKeyChrCodeToKeyCode().

Parameters:
refNum,: IN: library reference number (returned by SysLibFind() / SysLibLoad() )
keyCode,: IN: the key to lookup
modifiersIn,: IN: Modifier mask indicating which character should be returned
chrP,: OUT: The character produced by the key
modifiersOutP,: OUT: The keyMask bits that must be set if a keyDown event is formed with the character. (Not including the bits set in modifiersIn)
Return values:
None.

UInt16 PmKeyKeysPressed | ( | UInt16 | refNum,
 |  | UInt16 | count,
 |  | const UInt16 | keyCodes[],
 |  | Boolean | pressed[]
 | ) |

Get the current state of specified keys

Parameters:
refNum,: IN: library reference number (returned by SysLibFind() / SysLibLoad() )
count,: IN: number of elements in keyCodes[] and pressed[]
keyCodes,: IN: array of keyCodes to test
pressed,: OUT: Each element is set to true if the key specified by the corresponding element in keyCodes[] is pressed, and set to false if it is not pressed. It is acceptable to pass NULL if only the return value is of interest.
Return values:
UInt16 count of keys that are pressed.

Err PmKeyLibClose ( UInt16 refNum )

Standard close library function

Parameters:
refNum,: IN: library reference number (returned by SysLibFind() / SysLibLoad() )
Return values:
Err error code.

Err PmKeyLibOpen ( UInt16 refNum )

Standard open library function

Parameters:
refNum,: IN: library reference number (returned by SysLibFind() / SysLibLoad() )
Return values:
Err error code.

Err PmKeyStop | ( | UInt16 | refNum,
 |  | UInt16 | keyCode
 | ) |

Stop a key from sending any more auto repeat events until it is released.

Parameters:
refNum,: IN: library reference number (returned by SysLibFind() / SysLibLoad() )
keyCode,: IN: key to stop
Return values:
Err errNone if the keyCode is the last key pressed and it is still held.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:22 2006 for Palm API Guide


PmKeyLibCommon.h File Reference

Detailed Description

Public 68k common header file for system library that exports key-related APIs.

This library is based on key APIs from HsExtensions and was broken apart from HsExtensions so the APIs could be ported to other platforms.

Include dependency graph for PmKeyLibCommon.h:

Feature values

  • #define kPmKeyLibFtrValAPIVersion 0

Function Traps

  • #define kPmKeyLibTrapOpen sysLibTrapOpen
  • #define kPmKeyLibTrapClose sysLibTrapClose
  • #define kPmKeyLibTrapKeysPressed (sysLibTrapCustom)
  • #define kPmKeyLibTrapStop (sysLibTrapCustom+1)
  • #define kPmKeyLibTrapEnableKey (sysLibTrapCustom+2)
  • #define kPmKeyLibTrapChrCodeToKeyCode (sysLibTrapCustom+3)
  • #define kPmKeyLibTrapKeyCodeToChrCode (sysLibTrapCustom+4)
  • #define kPmKeyLibTrapEventIsFromKeyboard (sysLibTrapCustom+5)
  • #define kPmKeyLibTrapAttrGet (sysLibTrapCustom+6)
  • #define kPmKeyLibTrapAttrSet (sysLibTrapCustom+7)

Defines

  • #define kPmKeyLibType sysFileTLibrary
  • #define kPmKeyLibCreator pmFileCKeyLib
  • #define kPmKeyLibName "PmKeyLib-PmKe"
  • #define kPmKeyLibAPIMajorVersion 3
  • #define kPmKeyLibAPIMinorVersion 0
  • #define kPmKeyLibAPIVersion sysMakeLibAPIVersion(kPmKeyLibAPIMajorVersion, kPmKeyLibAPIMinorVersion)

Typedefs

  • typedef UInt16 PmKeyAttrEnum

Enumerations

  • enum PmKeyAttrEnumTag {
    pmKeyAttrPagingMode,
    pmKeyAttrGetLauncherKeyCode,
    pmKeyAttrGetMenuKeyCode,
    pmKeyAttrGetSendKeyCode,
    pmKeyAttrGetEndKeyCode,
    pmKeyAttrGetPhoneKeyCode
    }

Define Documentation

#define kPmKeyLibAPIMajorVersion 3

Major version incremented when API changes

#define kPmKeyLibAPIMinorVersion 0

Minor version incremented with each release of library that doesn't change the API

#define kPmKeyLibCreator pmFileCKeyLib

PmKeyLib creator ID

#define kPmKeyLibFtrValAPIVersion 0

Feature value used to get/set library API version (kPmKeyLibAPIVersion). Note that the first release of the library did not set this feature. Therefore, if the library does exist but the feature does not, you can assume the major version of the library is 1. Note also that the feature is not set until library is loaded so you must load PmKeyLib before getting the feature

#define kPmKeyLibName "PmKeyLib-PmKe"

PmKeyLib database name

#define kPmKeyLibType sysFileTLibrary

standard library type

Enumeration Type Documentation

enum PmKeyAttrEnumTag

Enumerator:
pmKeyAttrPagingMode | Whether currently pressed key is in page mode
pmKeyAttrGetLauncherKeyCode | Returns the key code for the Launcher key
pmKeyAttrGetMenuKeyCode | Returns the key code for the Menu key
pmKeyAttrGetSendKeyCode | Returns the key code for the Send key
pmKeyAttrGetEndKeyCode | Returns the key code for the End key
pmKeyAttrGetPhoneKeyCode | Returns the key code for the Phone key

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:23 2006 for Palm API Guide


PmLibErrors.h File Reference

Detailed Description

Errors common to all our portable Pm Libraries.

Include dependency graph for PmLibErrors.h:

Defines

  • #define pmErrNotSupported (pmLibErrorClass | 0x01)
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:23 2006 for Palm API Guide


PmPalmOSNVFS.h File Reference

Detailed Description

Public 68k header file containing the definitions and API for NVFS devices.

Defines

  • #define sysFtrNumDmAutoBackup 31
  • #define vfsVolumeAttrNonRemovable (0x00000008UL)
  • #define expCapabilityNonRemovable 0x00000008
  • #define expCapabilityHidden 0x00000010
  • #define sysTrapDmSyncDatabase 0xA476
  • #define vfsIncludePrivateVolumes 0x80000000
  • #define expIncludePrivateSlots 0x80000000
  • #define dbCacheFlag 0x8000

Functions

  • Err DmSyncDatabase (DmOpenRef dbRef)
    Commit changes in the database to the non-volatile memory.

Define Documentation

#define dbCacheFlag 0x8000

Flag is used in query the DbCache size when ORd with Storage heap id

#define expCapabilityHidden 0x00000010

card is hidden

#define expCapabilityNonRemovable 0x00000008

card is non-removable

#define expIncludePrivateSlots 0x80000000

Use this flag to show hidden expansion slots if the device supports hidden slots

#define sysFtrNumDmAutoBackup 31

Is Data Manager Auto Backup supported?

#define vfsIncludePrivateVolumes 0x80000000

Use this flag to show hidden volumes if the device supports hidden volumes

#define vfsVolumeAttrNonRemovable (0x00000008UL)

media is non-removable

Function Documentation

Err DmSyncDatabase ( DmOpenRef dbRef )

Commit changes in the database to the non-volatile memory.

Parameters:
dbRef,: IN: Reference to the opened database to be synced/committed
Return values:
Err error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:23 2006 for Palm API Guide


PmSoundLibAudioGroup.h File Reference

Detailed Description

Public 68K header file used to associate sound channels with Audio groups on Treo 600 and Treo 650 smartphones.

We define the concept of Audio Groups to classify sounds depending on the relative importance to the user:

pmAudioGroupApp Audio normally generated by user applications such as games, MP3 players, and others. This is the default classification even if no audio group is assigned.

pmAudioGroupSystem Typical audio events generated by the system to give audible feedback to the user about system events. Most of the sounds produced through SndPlaySystemSound are classified internally as System.

pmAudioGroupAlert Alerts, Alarms, and Ringtones should be given this classification. If you depend on the Attention Manager to make a sound, it will also use this classification. The constant sndAlarm when calling SndPlaySystemSound is classified as an Alert.

pmAudioGroupHighPriority Sounds of great importance to the user and that are routed with the highest priority. We currently define hsSndBatLow and hsSndBatShutdown constants, when calling SndPlaySystemSound, as high priority sounds.

If you depend on PalmOS Attention Manager for audio alerts, or use PalmOS SndPlaySystemSound, then the audio group is automatically assigned, and there is nothing else you need to do.

However, if you directly play audio events using other PalmOS APIs such as SndPlayResource, or SndStreamCreate, for example, then you may want to assign the audio group, unless the default pmAudioGroupApp is sufficient for your purposes.

To assign an audio group we attach that additional information to the PalmOS volume parameter associated with many of the Sound Manager API calls. We have found this is the most effective way to associate the audio group to a sound channel, and have that information filter down, through PalmOS, to our Audio Driver in the Hardware Abstraction Layer (HAL). In this way, there is no need to modify PalmOS, and we can allow a variety of components and applications to take advantage of the behavior and custom routing we assign to the different audio group classifications.

The drawback is that when the audio group is attached to the volume parameter, then the volume is limited to a maximum of 8K - 1, in steps of 8 (which represents 128 levels to unity). In contrast PalmOS 5.x volume parameter is defined with a maximum of 32K - 1, in steps of 1 (which represents 1024 levels to unity). Our constrain is generally acceptable, since it represents granularity of about 1 dB step changes, with up to 8X amplification We currently use less precise granularity of > 10 db step changes, and a maximum of 6X amplification for the case of QCELP/AMR playback.

There is a risk that an existing application using the PalmOS API may apply a volume parameter that could be mistaken for a volume plus audio group designation, but this risk is fairly minimal as explained next.

The Audio Group uses a mark in the upper 3-bits of the volume parameter. If this mark is binary '011' which means a positive number >= 24K, then we will interpret the lower three bits as the audio group. The risk of mistaken interpretation from existing PalmOS applications will happen when the application request amplifications of 24X to 32X. In our experience we have Not seen any application going beyond the range of 2X to 8X amplification. In case such extremely rare condition do occurs, the effect would be that the range 24X to 32X will be treated as the lower range of 0X to 8X, and there is a chance the sound will be routed/treated as other than application audio.

One more thing to note is that PalmOS allows negative numbers in the volume parameter to mean one of the usual volume parameters the user may adjust through the preferences panel: system volume, game volume, and alarm volume. In our current implementation we do NOT change these values, and we do NOT assign any audio group designation to these preferences driven volume settings. In other words, they will be treated as application audio group.

The use of Audio Group in a device will be present when the feature is registered with the PalmOS Feature Manager. This feature will be available when:

FtrGet( pmSoundLibCreatorID, pmSoundLibAudioGroupFtr, &value );

return no error, and the UInt32 value is NOT:

pmSoundLibAudioGroupFtr_Off

It is important to always check for this feature, since this is a custom enhancement which could be turned off for some future device, or platform.

To assign an audio group to your volume parameter you will invoke the function PmSndAddAudioGroupToVolume (currently implemented as a macro for simplicity). Here is an example on how to use this:

      // Includes
      #include <FeatureMgr.h>
      #include <Common/Libraries/HsSoundLib/PmSoundLibAudioGroup.h>

      // Declarations
      UInt32 value  = 0;    // temporary variable for FtrGet
      Int32  volume = 1024; // default max amplitude in PalmOS 5.x, can also use sndMaxAmp with earlier PalmOS

      // Code Snippet
      if (   ( !FtrGet( pmSoundLibCreatorID, pmSoundLibAudioGroupFtr, &value ) ) // is the Audio Group feature supported?
          && ( value != pmSoundLibAudioGroupFtr_Off ) ) // is the Audio Group feature active?
      {
          volume = PmSndAddAudioGroupToVolume( volume, pmAudioGroupAlert ); // then, mark this sound as an alert
      }
      SndPlayResource( mySound, volume, sndFlagNormal );

Include dependency graph for PmSoundLibAudioGroup.h:

PmSoundLibAudioGroup information

  • #define pmSoundLibCreatorID hsSoundLibCreatorID
  • #define pmSoundLibAudioGroupFtr 0x0001
  • #define pmSoundLibAudioGroupFtr_Off 0
  • #define pmSoundLibAudioGroupFtr_On 1

Audio Group API functions

Implemented as macros.
  • #define PmSndAddAudioGroupToVolume(volume, audioGroup) (Int32) (((!audioGroup) || (((Int32)(volume)) <= -1))? (volume) : ((((((volume) & 0xE000) == 0x6000)? (volume):(volume)+7) & ~PM_AUDIOGROUP_MASK) | (audioGroup)))
  • #define PmSndRemoveAudioGroupFromVolume(volume) (Int32) ((((Int32)(volume)) < 0x6000)? (volume) : ((volume) & ~PM_AUDIOGROUP_MASK ))
  • #define PmSndGetAudioGroupFromVolume(volume) (PmAudioGroup)((((Int32)(volume)) < 0x6000)? (pmAudioGroupNone) : ((volume) & PM_AUDIOGROUP_MASK))

Defines

  • #define PM_AUDIOGROUP_MASK 0xE007

Typedefs

  • typedef UInt16 PmAudioGroup

Enumerations

  • enum PmAudioGroupEnum {
    pmAudioGroupNone = 0x0000,
    pmAudioGroupApp = 0x6000,
    pmAudioGroupSystem = 0x6001,
    pmAudioGroupAlert = 0x6002,
    pmAudioGroupHighPriority = 0x6003,
    pmAudioGroupInteractive = 0x6004,
    pmAudioGroupReserved1 = 0x6005,
    pmAudioGroupCall = 0x6006,
    pmAudioGroupAlertRingOff = 0x6007
    }

Define Documentation

#define PM_AUDIOGROUP_MASK 0xE007

No definition.

#define PmSndAddAudioGroupToVolume | ( | volume,
 |  | audioGroup | ) | (Int32) (((!audioGroup) || (((Int32)(volume)) <= -1))? (volume) : ((((((volume) & 0xE000) == 0x6000)? (volume):(volume)+7) & ~PM_AUDIOGROUP_MASK) | (audioGroup)))

Attaches an audio group designation to a PalmOS volume parameter.

Use this macro if you want your sound channel to be designated differently than application sound.

If this macro were implemented as a function, the prototype would be:

Int32 //returned volume // PmSndAddAudioGroupToVolume ( Int32 volume, PmAudioGroup audioGroup );

#define PmSndGetAudioGroupFromVolume ( volume ) (PmAudioGroup)((((Int32)(volume)) < 0x6000)? (pmAudioGroupNone) : ((volume) & PM_AUDIOGROUP_MASK))

Removes the volume component of a PalmOS volume parameter, leaving a pure audio group component.

Use this if you have already attached the audio group to a volume parameter and need to identify the audio group designation.

If this macro were implemented as a function, the prototype would be:

PmAudioGroup PmSndGetAudioGroupFromVolume ( Int32 volume );

#define PmSndRemoveAudioGroupFromVolume ( volume ) (Int32) ((((Int32)(volume)) < 0x6000)? (volume) : ((volume) & ~PM_AUDIOGROUP_MASK ))

Removes the audio group designation from a PalmOS volume parameter.

Use this if you previously attached a sound group designation and retrieve that volume again using PalmOS APIs. Or if you need to manipulate the overloaded volume parameter, as a volume only value.

If this macro were implemented as a function, the prototype would be:

Int32 //returned volume // PmSndRemoveAudioGroupFromVolume ( Int32 volume );

#define pmSoundLibAudioGroupFtr 0x0001

Use this as the featureNum passed to FtrGet.

#define pmSoundLibAudioGroupFtr_Off 0

Value returned in *valueP of FtrGet when Audio Group is disabled.

#define pmSoundLibAudioGroupFtr_On 1

Value returned in *valueP of FtrGet when Audio Group is enabled

#define pmSoundLibCreatorID hsSoundLibCreatorID

Pass this as the creator ID used in FtrGet.

Typedef Documentation

typedef UInt16 PmAudioGroup

See also:
PmAudioGroupEnum

Enumeration Type Documentation

enum PmAudioGroupEnum

Holds audio group information.

Enumerator:
pmAudioGroupNone | Default audio group when volume is less than 24K.
pmAudioGroupApp | Application audio, treated as pmAudioGroupNone, but group type saved.
pmAudioGroupSystem | System audio (as in SndPlaySystemSound).
pmAudioGroupAlert | Alert, alarms, ringtones that notify user of an event.
pmAudioGroupHighPriority | Extremely important event such as low battery shutdown.
pmAudioGroupInteractive | Application audio, but for interactive use such as with games.
pmAudioGroupReserved1 | For future use, DO NOT USE.
pmAudioGroupCall | Intended for digital phone call audio only. Used for internal purposes.
pmAudioGroupAlertRingOff | Same as pmAudioGroupAlert, but ignores Ringer switch position

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:24 2006 for Palm API Guide


PmSysGadgetLib.h File Reference

Detailed Description

System Library that exports status-related APIs.

Version:
1.0
This library is based on status gadgets APIs from HsExtensions and was broken apart from HsExtensions so the APIs could be ported to other platforms.

Include dependency graph for PmSysGadgetLib.h:

Functions

  • Err PmSysGadgetLibOpen (UInt16 refNum)
    Standard library open routine.
  • Err PmSysGadgetLibClose (UInt16 refNum)
    Standard library close routine.
  • Err PmSysGadgetStatusGadgetTypeSet (UInt16 refNum, void *frmP, UInt16 gadgetID, UInt16type)
    Tell the system that a gadget on the form is a certain type of status gadget so that the system can properly draw and update it.
  • void PmSysGadgetStatusGadgetsUpdate (UInt16 refNum)
    Explicitly update all status gadgets on the current form.
  • Err PmSysGadgetBbutInstallFromResource (UInt16 refNum, FormType *frmP)
  • void PmSysGadgetBbutInstallNewButton (UInt16 refNum, FormType *frmP, UInt16 gadgetID, const Char *textP, FontID font, UInt8 flags)
  • void PmSysGadgetBbutSetLabel (UInt16 refNum, FormType *frmP, UInt16 gadgetID, const Char *newLabel)
  • void PmSysGadgetBbutSetBitmap (UInt16 refNum, FormType *frmP, UInt16 gadgetID, const BitmapPtr bitmapP)
  • void PmSysGadgetBbutHitBigButton (UInt16 refNum, FormType *frmP, UInt16 gadgetIndex)

Function Documentation

void PmSysGadgetBbutHitBigButton | ( | UInt16 | refNum,
 |  | FormType * | frmP,
 |  | UInt16 | gadgetIndex
 | ) |

Like CtlHitControl, but for big buttons.

Notes: Due to the fact that PalmOS lacks accessors for gadgets directly, this function (and any others that refer to a big button's gadget) takes a form pointer and an index instead of a FormGadgetType*.

Parameters:
frmP,: IN: The form containing the big button's gadget.
gadgetIndex,: IN: The index of the big button's gadget.
Return values:
None.

Err PmSysGadgetBbutInstallFromResource | ( | UInt16 | refNum,
 |  | FormType * | frmP
 | ) |

Installs big buttons on the given form based on a 'bBut' resource with the same ID. A 'bBut' resource is basically just an array of HsBigButtonMappingType.

Once installed, the gadget will get events from PalmOS and will sent a 'gadgetMisc' event with the selector bbutGadgetMiscSelectSelector when selected.

IMPORTANT: The form must not be visible when you install the buttons, since we don't draw them (it turns out to be impossible to check whether the gadget is visible without peeking into its data structure, which we can only do from the event handler).

Parameters:
refNum,: IN: Library reference number
frmP,: IN: The form to install the big buttons on.
Return values:
Err Error code.

void PmSysGadgetBbutInstallNewButton | ( | UInt16 | refNum,
 |  | FormType * | frmP,
 |  | UInt16 | gadgetID,
 |  | const Char * | textP,
 |  | FontID | font,
 |  | UInt8 | flags
 | ) |

Set big button on a form.

Parameters:
refNum,: IN: Library reference number
frmP,: IN: The form to set the big button's gadget on.
gadgetID,: IN: The ID of the big button's gadget.
textP,: IN: Pointer to string to set on the gadget.
font,: IN: Font ID to be used for the text.
flags,: IN: Flags associated to the gadget.
Return values:
None.

void PmSysGadgetBbutSetBitmap | ( | UInt16 | refNum,
 |  | FormType * | frmP,
 |  | UInt16 | gadgetID,
 |  | const BitmapPtr | bitmapP
 | ) |

Set bitmap image on a big button gadget.

Parameters:
refNum,: IN: Library reference number
frmP,: IN: The form containing the big button's gadget.
gadgetID,: IN: The ID of the big button's gadget.
bitmapP,: IN: Pointer to the bitmap to set on the gadget.
Return values:
None.

void PmSysGadgetBbutSetLabel | ( | UInt16 | refNum,
 |  | FormType * | frmP,
 |  | UInt16 | gadgetID,
 |  | const Char * | newLabel
 | ) |

Set label on a big button gadget.

Parameters:
refNum,: IN: Library reference number
frmP,: IN: The form containing the big button's gadget.
gadgetID,: IN: The ID of the big button's gadget.
newLabel,: IN: Pointer to label string to set on the gadget.
Return values:
None.

Err PmSysGadgetLibClose ( UInt16 refNum )

Standard library close routine.

Parameters:
refNum,: IN: Library reference number
Return values:
Err Error Code

Err PmSysGadgetLibOpen ( UInt16 refNum )

Standard library open routine.

Parameters:
refNum,: IN: Library reference number
Return values:
Err Error Code

void PmSysGadgetStatusGadgetsUpdate ( UInt16 refNum )

Explicitly update all status gadgets on the current form.

Parameters:
refNum,: IN: Library reference number
Return values:
Nothing

Err PmSysGadgetStatusGadgetTypeSet | ( | UInt16 | refNum,
 |  | void * | frmP,
 |  | UInt16 | gadgetID,
 |  | UInt16type |
 | ) |

Tell the system that a gadget on the form is a certain type of status gadget so that the system can properly draw and update it.

Tell the system that a gadget on the form is a certain type of status gadget so that the system can properly draw and update it. A form can only have one gadget for each status type. If more than one gadget is set to a certain type, only the last one set will be recorded. This function can also be used to erase and release a gadget whose type has already been set. To do this, type should be set to 0.

Parameters:
refNum,: IN: Library reference number
frmP,: IN: Form to draw gadget on
gadgetID,: IN: Gadget resource ID
type,: IN: Gadget type (battery, signal, bluetooth, etc)
Return values:
Err Error code

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:24 2006 for Palm API Guide


PmSysGadgetLibCommon.h File Reference

Detailed Description

Public 68k header file for system Library that exports system gadget related APIs.

This file contains the common definitions and structures for the gadget-related APIs.

Data Structures

  • struct PmSysGadgetBbutMappingType
    This is the structure of a single big button mapping... More...
  • struct PmSysGadgetBbutResourceType
    This is the structure of a big button resource... More...
  • #define kPmSysGadgetFtrIDStatusGadgetRev 1
  • #define kPmSysGadgetFtrValStatusGadgetRev1 0x0001

Function Traps

  • #define kPmSysGadgetLibTrapOpen sysLibTrapOpen
  • #define kPmSysGadgetLibTrapClose sysLibTrapClose
  • #define kPmSysGadgetLibTrapStatusGadgetTypeSet (sysLibTrapCustom)
  • #define kPmSysGadgetLibTrapStatusGadgetsUpdate (sysLibTrapCustom+1)
  • #define kPmSysGadgetLibTrapBbutInstallFromResource (sysLibTrapCustom+2)
  • #define kPmSysGadgetLibTrapBbutInstallNewButton (sysLibTrapCustom+3)
  • #define kPmSysGadgetLibTrapBbutSetLabel (sysLibTrapCustom+4)
  • #define kPmSysGadgetLibTrapBbutSetBitmap (sysLibTrapCustom+5)
  • #define kPmSysGadgetLibTrapBbutHitBigButton (sysLibTrapCustom+6)

Defines

  • #define kPmSysGadgetLibType sysFileTLibrary
  • #define kPmSysGadgetLibCreator pmFileCSysGadgetLib
  • #define kPmSysGadgetLibName "PmSysGadgetLib-PmSg"
  • #define kPmSysGadgetBbutGadgetMiscSelectSelector 7014
  • #define kPmSysGadgetBbutGadgetMiscSelectData ((void*)0xBADC0DE1)
  • #define kPmSysGadgetBbutRscType 'bBut'

Enumerations

  • enum PmSysGadgetStatusGadgetTypeEnum {
    pmSysGadgetStatusGadgetNone = 0,
    pmSysGadgetStatusGadgetBattery = 1,
    pmSysGadgetStatusGadgetSignal = 2,
    pmSysGadgetStatusGadgetBt = 3,
    pmSysGadgetStatusGadgetEvdo = 4,
    pmSysGadgetStatusGadgetLine = 5,
    pmSysGadgetStatusGadgetRoaming = 6,
    pmSysGadgetStatusGadgetCallFwd = 7,
    pmSysGadgetStatusGadgetVm = 8,
    pmSysGadgetStatusGadgetOperator = 9,
    pmSysGadgetStatusGadgetTty = 10
    }
  • enum PmSysGadgetBtStatusTypeEnum {
    kIndicatorBtOff = 0x0700,
    kIndicatorBtOn,
    kIndicatorBtConnectHeadset,
    kIndicatorBtConnectOther,
    kIndicatorBtDUN,
    kIndicatorBtConnectAudio
    }

Define Documentation

#define kPmSysGadgetBbutGadgetMiscSelectData ((void*)0xBADC0DE1)

Magic # to make conflicts even less likely for detecting big button presses.

#define kPmSysGadgetBbutGadgetMiscSelectSelector 7014

This selector gets sent with a frmGadgetMiscEvent to let you know that the gadget has been selected. The numbers are picked semi-randomly so that generic code (like PmUIUtilFrmDoDialogWithCallback()) can tell that this is actually a button press without doing the wrong thing for other people's gadget events.

Note that in most code, you shouldn't need to worry about checking the data, since you know exactly what gadgets are on your form and what kind of events they send. Randomish number so people can easily detect big button presses

#define kPmSysGadgetBbutRscType 'bBut'

This is the type of big button resources. The ID should match the ID of the form... Registered: yes

#define kPmSysGadgetFtrIDStatusGadgetRev 1

Feature that says that status gadget API exists and what revision it is

#define kPmSysGadgetFtrValStatusGadgetRev1 0x0001

Feature that says that status gadget API exists and what revision it is

#define kPmSysGadgetLibCreator pmFileCSysGadgetLib

Library creator ID

#define kPmSysGadgetLibName "PmSysGadgetLib-PmSg"

Library name

#define kPmSysGadgetLibType sysFileTLibrary

Library type

Enumeration Type Documentation

enum PmSysGadgetBtStatusTypeEnum

Bluetooth radio status

Enumerator:
kIndicatorBtOff | Bt Radio turned off
kIndicatorBtOn | Bt radio turned on
kIndicatorBtConnectHeadset | Connected to Headset
kIndicatorBtConnectOther | Connected to other Bt devices
kIndicatorBtDUN | Connected to DUN
kIndicatorBtConnectAudio | Connected audio

enum PmSysGadgetStatusGadgetTypeEnum

Equates for supporting system handled status gadgets

Enumerator:
pmSysGadgetStatusGadgetNone | No type specified for status gadget
pmSysGadgetStatusGadgetBattery | Status gadget is a battery meter
pmSysGadgetStatusGadgetSignal | Status gadget is a signal strength indicator
pmSysGadgetStatusGadgetBt | Status gadget is a Bluetooth status indicator
pmSysGadgetStatusGadgetEvdo | Status gadget is an EVDO status indicator
pmSysGadgetStatusGadgetLine | Status gadget is an Active line status indicator
pmSysGadgetStatusGadgetRoaming | Status gadget is a Roaming status indicator
pmSysGadgetStatusGadgetCallFwd | Status gadget is a Call Forwarding status indicator
pmSysGadgetStatusGadgetVm | Status gadget is a Voicemail status indicator
pmSysGadgetStatusGadgetOperator | Status gadget is an Operator status indicator
pmSysGadgetStatusGadgetTty | Status gadget is a TTY status indicator

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:25 2006 for Palm API Guide


PmUIUtilLib.h File Reference

Detailed Description

This is the public header for PmUIUtil library.

This library contains general utility functions that supplement OS functionality. That is, it contains functions that are general enough to be useful to many applications but weren't included in the OS utility functions for whatever reason.

Include dependency graph for PmUIUtilLib.h:

Functions

  • Err PmUIUtilLibOpen (UInt16 refNum)
    Standard library open routine.
  • Err PmUIUtilLibClose (UInt16 refNum)
    Standard library close routine.
  • void PmUIUtilLstSetTempSelection (UInt16 refNum, const FormType *formP, UInt16 listID, Int16 itemNum)
  • Int16 PmUIUtilLstGetTempSelection (UInt16 refNum, const FormType *formP, UInt16 listID)
  • Err PmUIUtilAttrGet (UInt16 refNum, UInt16attr, UInt32 flags, UInt32 *valueP)
  • Err PmUIUtilAttrSet (UInt16 refNum, UInt16attr, UInt32 flags, UInt32 value)
  • void PmUIUtilNavGetFocusColor (UInt16 refNum, HsNavFocusColorEnum color, RGBColorType *rgbColorP)
  • void PmUIUtilNavSetFocusColor (UInt16 refNum, HsNavFocusColorEnum color, RGBColorType *rgbColorP, RGBColorType *oldRgbColorP)

Function Documentation

Err PmUIUtilLibClose ( UInt16 refNum )

Standard library close routine.

Parameters:
refNum,: IN: Library reference number
Return values:
Err Error code

Err PmUIUtilLibOpen ( UInt16 refNum )

Standard library open routine.

Parameters:
refNum,: IN: Library reference number
Return values:
Err Error code

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:25 2006 for Palm API Guide


PmUIUtilLibCommon.h File Reference

Detailed Description

Public 68k common header file for system Library that exports UI utility API functions.

This file contains the constants and definitions for the system UI-Util library.

Include dependency graph for PmUIUtilLibCommon.h:

Feature values

  • #define kPmUIUtilLibFtrValAPIVersion 0

Function Traps

  • #define kPmUIUtilLibTrapOpen sysLibTrapOpen
  • #define kPmUIUtilLibTrapClose sysLibTrapClose
  • #define kPmUIUtilLibTrapGetObjectUsable (sysLibTrapCustom)
  • #define kPmUIUtilLibTrapPutObjectAfterTitle (sysLibTrapCustom+1)
  • #define kPmUIUtilLibTrapFrmDoDialogWithCallback (sysLibTrapCustom+2)
  • #define kPmUIUtilLibTrapFrmDoDialog (sysLibTrapCustom+3)
  • #define kPmUIUtilLibTrapFrmDoTimedDialogEx (sysLibTrapCustom+4)
  • #define kPmUIUtilLibTrapFrmSetHelpID (sysLibTrapCustom+5)
  • #define kPmUIUtilLibTrapFrmSetLabel (sysLibTrapCustom+6)
  • #define kPmUIUtilLibTrapFrmSetLabelFont (sysLibTrapCustom+7)
  • #define kPmUIUtilLibTrapFrmGetDefaultButtonID (sysLibTrapCustom+8)
  • #define kPmUIUtilLibTrapFrmGetEventHandler (sysLibTrapCustom+9)
  • #define kPmUIUtilLibTrapCtlGetStyle (sysLibTrapCustom+10)
  • #define kPmUIUtilLibTrapCtlGetFont (sysLibTrapCustom+11)
  • #define kPmUIUtilLibTrapLstGetItemsText (sysLibTrapCustom+12)
  • #define kPmUIUtilLibTrapLstGetTopItem (sysLibTrapCustom+13)
  • #define kPmUIUtilLibTrapLstPopupListExt (sysLibTrapCustom+14)
  • #define kPmUIUtilLibTrapSclUpdateScrollBar (sysLibTrapCustom+15)
  • #define kPmUIUtilLibTrapSclScroll (sysLibTrapCustom+16)
  • #define kPmUIUtilLibTrapSclScrollPage (sysLibTrapCustom+17)
  • #define kPmUIUtilLibTrapSliHandleKeyDown (sysLibTrapCustom+18)
  • #define kPmUIUtilLibTrapWinGetMaxDepth (sysLibTrapCustom+19)
  • #define kPmUIUtilLibTrapAttnNagInfo (sysLibTrapCustom+20)
  • #define kPmUIUtilLibTrapAttnEnable (sysLibTrapCustom+21)
  • #define kPmUIUtilLibTrapAttnIndicatorAllow (sysLibTrapCustom+22)
  • #define kPmUIUtilLibTrapAttnGetAttentionExt (sysLibTrapCustom+23)
  • #define kPmUIUtilLibTrapAttnUpdateExt (sysLibTrapCustom+24)
  • #define kPmUIUtilLibTrapAttrGet (sysLibTrapCustom+25)
  • #define kPmUIUtilLibTrapAttrSet (sysLibTrapCustom+26)
  • #define kPmUIUtilLibTrapLstSetTempSelection (sysLibTrapCustom+27)
  • #define kPmUIUtilLibTrapLstGetTempSelection (sysLibTrapCustom+28)
  • #define kPmUIUtilLibTrapNavGetFocusColor (sysLibTrapCustom+29)
  • #define kPmUIUtilLibTrapNavSetFocusColor (sysLibTrapCustom+30)

Defines

  • #define kPmUIUtilLibType sysFileTLibrary
  • #define kPmUIUtilLibCreator pmFileCUIUtilLib
  • #define kPmUIUtilLibName "PmUIUtilLib-PmUU"
  • #define kPmUIUtilLibAPIMajorVersion 2
  • #define kPmUIUtilLibAPIMinorVersion 0
  • #define kPmUIUtilLibAPIVersion sysMakeLibAPIVersion(kPmUIUtilLibAPIMajorVersion, kPmUIUtilLibAPIMinorVersion)

Typedefs

  • typedef UInt16 PmUIUtilAttrEnum

Enumerations

  • enum PmUIUtilAttrEnumTag { pmUIUtilAttrAutoSnoozeAttns }

Define Documentation

#define kPmUIUtilLibAPIMajorVersion 2

Major version incremented when API changes

#define kPmUIUtilLibAPIMinorVersion 0

Minor version incremented with each release of library that doesn't change the API

#define kPmUIUtilLibCreator pmFileCUIUtilLib

Library creator ID

#define kPmUIUtilLibFtrValAPIVersion 0

Feature value used to get/set library version (kPmUIUtilLibAPIVersion). Note that the first release of the library did not set this feature. Therefore, if the library does exist but the feature does not, you can assume the major version of the library is 1. Note also that the feature is not set until library is loaded so you must load PmUIUtil before getting the feature

#define kPmUIUtilLibName "PmUIUtilLib-PmUU"

Library name

#define kPmUIUtilLibType sysFileTLibrary

Library type

Typedef Documentation

typedef UInt16 PmUIUtilAttrEnum

See also:
PmUIUtilAttrEnumTag

Enumeration Type Documentation

enum PmUIUtilAttrEnumTag

Enumerator:
pmUIUtilAttrAutoSnoozeAttns whether we want to auto snooze the current instance of the attn dialog

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:26 2006 for Palm API Guide


Slider.h File Reference

Detailed Description

Version:
1.0
Date:
04/03/2002
Header file for all Palm Devices Contains constants & structs necessary to access slider saved pref.

Author:
George Puckett

Include dependency graph for Slider.h:

Data Structures

  • struct PowerPanelAppPrefs

Defines

  • #define sysFileCPower 'Powr'
  • #define SLIDER_PREF_CHANGED_NOTIFY_TYPE 'spcn'
  • #define appPrefsVersion 0
  • #define appPrefsID 1
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:26 2006 for Palm API Guide


SmartTextEngine.h File Reference

Detailed Description

Public 68K include file for Smart Text Engine shared library.

The Smart Text Engine (STE) Library can be used to enable hyperlink in your application and display icon as defined in the Resource Header file.

It will enable user to tap on:

  • Phone number to dial using the phone application
  • URL to browse
  • Email to send an email by launching the default email application

The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application(ie, SysLibFind() returns a valid refnum). When the application is done with the library, it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal synchronization.

    Err LoadSmartTextEngine(UInt16* refNumP, Boolean* libLoadedP)
        {
        Err error = 0;

        // Routine is pointless without this parameter
        if (!refNumP)
            return memErrInvalidParam;

        // always load the library, so we have our own instance of the engine
        error = SysLibLoad(sysFileTLibrary, hsFileCSmartTextEngine, refNumP);
        if (error)
            return error;
        *libLoadedP = true;

        return error;
        }

Include dependency graph for SmartTextEngine.h:

Functions

  • STEErr STEOpen (UInt16 refNum)
  • STEErr STEClose (UInt16 refNum)
  • STEErr STEGetAPIVersion (UInt16 refNum, UInt32 *majVerP, UInt32 *minVerP)
  • STEErr STEInitializeEngine (UInt16 refNum, UInt16 *engineRefNum, RectangleType *listBounds, UInt16 scrollBarID, UInt32 flags, UInt8 phoneNumberColor, UInt8 urlColor, UInt8 emailColor)
  • STEErr STEResetEngine (UInt16 refNum, UInt16 engineRefNum)
  • STEErr STEReinitializeEngine (UInt16 refNum, UInt16 engineRefNum)
  • void STEAppendTextToEngine (UInt16 refNum, UInt16 engineRefNum, Char *textP, Boolean renderImmediate)
  • void STERemoveLastRecordFromEngine (UInt16 refNum, UInt16 engineRefNum)
  • void STERenderList (UInt16 refNum, UInt16 engineRefNum)
  • void STERerenderList (UInt16 refNum, UInt16 engineRefNum)
  • Boolean STEHandleEvent (UInt16 refNum, UInt16 engineRefNum, EventPtr eventP)
  • Boolean STEHandleSclRepeatEvent (UInt16 refNum, UInt16 engineRefNum, EventPtr eventP)
  • Boolean STEHandlePenDownEvent (UInt16 refNum, UInt16 engineRefNum, EventPtr eventP)
  • Boolean STEHandlePenMoveEvent (UInt16 refNum, UInt16 engineRefNum, EventPtr eventP)
  • Boolean STEHandlePenUpEvent (UInt16 refNum, UInt16 engineRefNum, EventPtr eventP)
  • Boolean STEHandleKeyDownEvent (UInt16 refNum, UInt16 engineRefNum, EventPtr eventP)
  • UInt16 STEGetScroll (UInt16 refNum, UInt16 engineRefNum)
  • void STESetScroll (UInt16 refNum, UInt16 engineRefNum, UInt16 scrollValue)
  • UInt16 STEGetScrollPct (UInt16 refNum, UInt16 engineRefNum)
  • void STESetScrollPct (UInt16 refNum, UInt16 engineRefNum, UInt16 scrollPct)
  • void STESetScrollToRecordNum (UInt16 refNum, UInt16 engineRefNum, UInt16 recordNum)
  • void STESetFlags (UInt16 refNum, UInt16 engineRefNum, UInt32 flagsToSet, UInt32 flagsToClear)
  • UInt32 STEGetFlags (UInt16 refNum, UInt16 engineRefNum)
  • UInt16 STEGetNumLines (UInt16 refNum, UInt16 engineRefNum)
  • UInt16 STEGetNumRecords (UInt16 refNum, UInt16 engineRefNum)
  • Boolean STEHasHotRectSelection (UInt16 refNum, UInt16 engineRefNum)
  • Boolean STEHasMessageSelection (UInt16 refNum, UInt16 engineRefNum)
  • Boolean STEHasTextSelection (UInt16 refNum, UInt16 engineRefNum)
  • void STEClearCurrentSelection (UInt16 refNum, UInt16 engineRefNum)
  • UInt16 STESetCurrentTextSelection (UInt16 refNum, UInt16 engineRefNum, UInt16 messageNumber, UInt32 startLocation, UInt32 selectionLength)
  • void STEGetCurrentTextSelection (UInt16 refNum, UInt16 engineRefNum, UInt16 *messageNumber, UInt16 *startLocation, UInt16 *selectionLength)
  • Char * STEGetSelectedText (UInt16 refNum, UInt16 engineRefNum)
  • void STECopySelectionToClipboard (UInt16 refNum, UInt16 engineRefNum)
  • void STEGetLastTapInfo (UInt16 refNum, UInt16 engineRefNum, UInt16 *messageNumber, UInt16 *tapLocation)
  • void STESetCustomHyperlinkCallback (UInt16 refNum, UInt16 engineRefNum, STECallbackType callback, Boolean armCallback)
  • void STEQuickRender (UInt16 refNum, RectangleType *listBounds, UInt32 flags, UInt8 phoneNumberColor, UInt8 urlColor, UInt8 emailColor, Char *msgP)
  • ParsedInfoList * STEGetParsedInformation (UInt16 refNum, Char *textP, UInt16 msgNumber, Boolean replaceLineFeeds, UInt32 flags)
  • void STEAppendParsedInfo (UInt16 refNum, MemHandle destParsedInfoH, ParsedInfoList *sourceParsedInfoP)

Function Documentation

void STEAppendParsedInfo | ( | UInt16 | refNum,
 |  | MemHandle | destParsedInfoH,
 |  | ParsedInfoList * | sourceParsedInfoP
 | ) |

This routine append a ParsedInfoList to another ParsedInfoList.

This does NOT require the STE to be initialized. This is used internally by the STE. You probably will not use this function.

Parameters:
refNum,: IN: The STE refNum
destParsedInfoH,: IN: A handle to the destination parsed info list
sourceParsedInfoP,: IN: The source parsed info list.
Return values:
-

void STEAppendTextToEngine | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | Char * | textP,
 |  | Boolean | renderImmediate
 | ) |

Function that is used to add text to the STE. Each text string that is appended is called a record. Record numbers are 1 based, meaning the first record is record 1.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
textP,: IN: The text to append to the STE, including any STE delimiters
renderImmediate,: IN: If true, the text will be displayed immediately. If false, it will not be displayed until STERenderList is called.
Return values:
-

void STEClearCurrentSelection | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |

This routine clears any currently selected text or hot rect.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
-

STEErr STEClose ( UInt16 refNum )

Standard library close routine. Library should always be unloaded with SysLibRemove() after STEClose() is called. See note at top of file.

Parameters:
refNum,: IN: Library reference number
Return values:
STEErr Error Code or zero if no error occurs

void STECopySelectionToClipboard | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |

This routine copies the selected text to the system's clipboard.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
-

STEErr STEGetAPIVersion | ( | UInt16 | refNum,
 |  | UInt32 * | majVerP,
 |  | UInt32 * | minVerP
 | ) |

Get Library API Version number.

Parameters:
refNum,: IN: Library reference number
majVerP,: OUT: Major version number
minVerP,: OUT: Minor version number
Return values:
STEErr Error Code or zero if no error occurs

void STEGetCurrentTextSelection | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | UInt16 * | messageNumber,
 |  | UInt16 * | startLocation,
 |  | UInt16 * | selectionLength
 | ) |

This routine will select the specified text selection. The display will be updated to show the selected text as highlighted.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
messageNumber,: OUT: The record number of the start the selection
startLocation,: OUT: The byte offset of the start the text selection
selectionLength,: OUT: The number of bytes in the text selection
Return values:
-

UInt32 STEGetFlags | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |

This routine returns the current STE flags

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
UInt32 The STE flags

void STEGetLastTapInfo | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | UInt16 * | messageNumber,
 |  | UInt16 * | tapLocation
 | ) |

This routine returns the location of the last tap. If the user drags the stylus, it is not a tap.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
messageNumber,: OUT: The record number of the text that was tapped
tapLocation,: OUT: The number of bytes offset from the start of the text to the location tapped
Return values:
-

UInt16 STEGetNumLines | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |

This routine returns the number of lines in the STE.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
UInt16 Number of lines in the STE

UInt16 STEGetNumRecords | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |

This routine returns the number of records in the STE.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
UInt16 Number of records in the STE

ParsedInfoList* STEGetParsedInformation | ( | UInt16 | refNum,
 |  | Char * | textP,
 |  | UInt16 | msgNumber,
 |  | Boolean | replaceLineFeeds,
 |  | UInt32 | flags
 | ) |

This routine will parse the text string for URLs, email addresses, and/or phone numbers.

This does NOT require the STE to be initialized.

Parameters:
refNum,: IN: The STE refNum
textP,: IN: The text string to parse
msgNumber,: IN: The message number of this text string (Used internally by the STE)
replaceLineFeeds,: IN: If true, any line feed will be replaced with a space, but a parsed item will be create that specifies a line feed to be at that location
flags,: IN: The flags indicating what type of item to parse out
Return values:
ParsedInfoList* A parsed info list that has each of the parsed items found in the text string.

UInt16 STEGetScroll | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |

This routine returns the current scroll position of the STE's scroll bar.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
UInt16 The position of the scroll bar.

UInt16 STEGetScrollPct | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |

This routine returns the current scroll position of the STE's scroll bar as a percentage of the entire scroll bar.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
UInt16 The position of the scroll bar in percentage.

Char* STEGetSelectedText | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |

This routine returns a copy of the actual text that is currently selected.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
Char* Returns a copy of the current text selection. This must be freed by the caller.

Boolean STEHandleEvent | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | EventPtr | eventP
 | ) |

This routine should be called in the form's event handler. If there is no special handling of events, then this routine can be used to handle all the different events that can affect the STE.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
eventP,: IN: A pointer to the event record.
Return values:
Boolean True if handled, False if not handled

Boolean STEHandleKeyDownEvent | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | EventPtr | eventP
 | ) |

This routine handles only the keyDown event. This routine should be used if there is special handling of the events by the application before (or after) the STE handles the event.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
eventP,: IN: A pointer to the event record.
Return values:
Boolean True if handled, False if not handled

Boolean STEHandlePenDownEvent | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | EventPtr | eventP
 | ) |

This routine handles only the penDown event. This routine should be used if there is special handling of the events by the application before (or after) the STE handles the event.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
eventP,: IN: A pointer to the event record.
Return values:
Boolean True if handled, False if not handled

Boolean STEHandlePenMoveEvent | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | EventPtr | eventP
 | ) |

This routine handles only the penMove event. This routine should be used if there is special handling of the events by the application before (or after) the STE handles the event.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
eventP,: IN: A pointer to the event record.
Return values:
Boolean True if handled, False if not handled

Boolean STEHandlePenUpEvent | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | EventPtr | eventP
 | ) |

This routine handles only the penUp event. This routine should be used if there is special handling of the events by the application before (or after) the STE handles the event.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
eventP,: IN: A pointer to the event record.
Return values:
Boolean True if handled, False if not handled

Boolean STEHandleSclRepeatEvent | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | EventPtr | eventP
 | ) |

This routine handles only the sclRepeat event. This routine should be used if there is special handling of the events by the application before (or after) the STE handles the event.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
eventP,: IN: A pointer to the event record.
Return values:
Boolean True if handled, False if not handled

Boolean STEHasHotRectSelection | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |

This routine checks if there is a current hot rect selection. A hot rect is a hyperlink that has been selected with the keyboard.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
Boolean True if there is a current hot rect selected

Boolean STEHasMessageSelection | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |

This routine checks if there is a current message selected.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
Boolean True if there is a current message selected

Boolean STEHasTextSelection | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |

This routine checks if there is any text currently selected.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
Boolean True if there is any text selected

STEErr STEInitializeEngine | ( | UInt16 | refNum,
 |  | UInt16 * | engineRefNum,
 |  | RectangleType * | listBounds,
 |  | UInt16 | scrollBarID,
 |  | UInt32 | flags,
 |  | UInt8 | phoneNumberColor,
 |  | UInt8 | urlColor,
 |  | UInt8 | emailColor
 | ) |

Styled Text Engine initialization function Before most of the STE can be used, it must be initialized. This function will return an engineRefNum which is to be used in the STE functions that require the STE to be initialized.

There are some functions that do not require the STE to be initialized. They are noted below.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: OUT: The STE engine refNum to be used in subsequent calls to the STE
listBounds,: IN: The bounds of the STE list that will be displayed
scrollBarID,: IN: The ID of the scroll used by the STE list. If this is 0, the list will not scroll. If there is more text than can be displayed, an ellipsis will be appended to the end.
flags,: IN: The flags for the STE
phoneNumberColor,: IN: The color of the phone number hyperlinks
urlColor,: IN: The color of the URL hyperlinks
emailColor,: IN: The color of the email hyperlinks
Return values:
STEErr Error Code or zero if no error occurs

STEErr STEOpen ( UInt16 refNum )

Standard library open routine. Library should always be loaded with SysLibLoad()(not SysLibFind()) before calling STEOpen(). See note at top of file.

Parameters:
refNum,: IN: Library reference number
Return values:
STEErr Error Code or zero if no error occurs

void STEQuickRender | ( | UInt16 | refNum,
 |  | RectangleType * | listBounds,
 |  | UInt32 | flags,
 |  | UInt8 | phoneNumberColor,
 |  | UInt8 | urlColor,
 |  | UInt8 | emailColor,
 |  | Char * | msgP
 | ) |

This routine will render the specified text as a "one shot deal". The text will not respond to any events, and hyperlinks do not work. This can be used to display rich text with graphics easily in your application.

This does NOT require the STE to be initialized.

Parameters:
refNum,: IN: The STE refNum
listBounds,: IN: The bounds of the STE list that will be displayed
flags,: IN: The flags for the STE
phoneNumberColor,: IN: The color of the phone number hyperlinks
urlColor,: IN: The color of the URL hyperlinks
emailColor,: IN: The color of the email hyperlinks
msgP,: IN: The text to display
Return values:
-

STEErr STEReinitializeEngine | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |

Initializes the STE to the initial state right after initializing it. This frees up any text that has been entered into the STE.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
STEErr Error Code or zero if no error occurs

void STERemoveLastRecordFromEngine | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |

Removes the last text that was appended to the engine. You must call STERenderList to update the display after removing the text.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
-

void STERenderList | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |

Renders the text that is currently in the STE.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
-

void STERerenderList | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |

Rerenders the text that is currently in the STE. This routine should be used if a change is made that can change the formatting (i.e. font size).

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
-

STEErr STEResetEngine | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum
 | ) |

Frees up the STE engine refNum. For each STEInitializeEngine, there must be a corresponding STEResetEngine.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
Return values:
STEErr Error Code or zero if no error occurs

UInt16 STESetCurrentTextSelection | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | UInt16 | messageNumber,
 |  | UInt32 | startLocation,
 |  | UInt32 | selectionLength
 | ) |

This routine will select the specified text selection. The display will be updated to show the selected text as highlighted.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
messageNumber,: IN: The record number to start the selection
startLocation,: IN: The byte offset to start the text selection
selectionLength,: IN: The number of bytes in the text selection
Return values:
UInt16 Returns the line number of the topmost line of the selection

void STESetCustomHyperlinkCallback | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | STECallbackType | callback,
 |  | Boolean | armCallback
 | ) |

This routine sets the procedure to call as a result of tapping a custom hyperlink

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
callback,: IN: The routine to call
armCallback,: IN: True if the callback routine is ARM code, false if it is 68K code
Return values:
-

void STESetFlags | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | UInt32 | flagsToSet,
 |  | UInt32 | flagsToClear
 | ) |

This routine sets the STE flags

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
flagsToSet,: IN: Bitmap representing the flags to set
flagsToClear,: IN: Bitmap representing the flags to clear
Return values:
-

void STESetScroll | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | UInt16 | scrollValue
 | ) |

This routine sets the current scroll position of the STE's scroll bar.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
scrollValue,: IN: The position to set the scroll bar
Return values:
-

void STESetScrollPct | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | UInt16 | scrollPct
 | ) |

This routine sets the current scroll position percentage of the STE's scroll bar.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
scrollPct,: IN: The position to set the scroll bar in percentage
Return values:
-

void STESetScrollToRecordNum | ( | UInt16 | refNum,
 |  | UInt16 | engineRefNum,
 |  | UInt16 | recordNum
 | ) |

This routine sets the current scroll bar position so that the specified record appears at the top of the list.

Parameters:
refNum,: IN: The STE refNum
engineRefNum,: IN: The STE engine refNum
recordNum,: IN: The record number to display at the top of the list.
Return values:
-

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:27 2006 for Palm API Guide


SmartTextEngineDef.h File Reference

Detailed Description

Public include file for Smart Text Engine shared library.

The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application(ie, SysLibFind() returns a valid refnum). When the application is done with the library, it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal

Include dependency graph for SmartTextEngineDef.h:

Data Structures

  • struct ParsedInfo
    Holds parsed item information. More...
  • struct ParsedInfoList
    Holds the list of parsed item information. More...

Parsed types

  • #define kParsedPhoneNumber 1
  • #define kParsedURL 2
  • #define kParsedEmail 3
  • #define kParsedDeviceURL 4
  • #define kParsedRtspURL 5

Font types

  • #define kSTEStdFont (kSmartTextBit | 0x00)
  • #define kSTEBoldFont (kSmartTextBit | 0x01)

Font colors

  • #define kSTECurrentFont (kSmartTextBit | 0x10)
  • #define kSTEBlackFont (kSmartTextBit | 0x11)
  • #define kSTEBlueFont (kSmartTextBit | 0x12)
  • #define kSTERedFont (kSmartTextBit | 0x13)
  • #define kSTEGreenFont (kSmartTextBit | 0x14)
  • #define kSTEYellowFont (kSmartTextBit | 0x15)
  • #define kSTEPurpleFont (kSmartTextBit | 0x16)
  • #define kSTEOrangeFont (kSmartTextBit | 0x17)
  • #define kSTEGrayFont (kSmartTextBit | 0x18)

Formating

  • #define kSTELineBreak (kSmartTextBit | 0x50)
  • #define kSTELeftIndent (kSmartTextBit | 0x51)
  • #define kSTERightAlign (kSmartTextBit | 0x52)
  • #define kSTECenterAlign (kSmartTextBit | 0x53)
  • #define kSTEHorizontalLine (kSmartTextBit | 0x60)
  • #define kSTEBitmap (kSmartTextBit | 0x70)
  • #define kSTESmileyBitmap (kSmartTextBit | 0x71)
  • #define kSTECharacterBitmap (kSmartTextBit | 0x72)
  • #define kSTEHyperlink (kSmartTextBit | 0x80)

Emoticons

  • #define kSmileSmiley (((UInt32)LargeSmiley00BitMap << 16) | Smiley00BitMap)
  • #define kWinkSmiley (((UInt32)LargeSmiley01BitMap << 16) | Smiley01BitMap)
  • #define kFrownSmiley (((UInt32)LargeSmiley02BitMap << 16) | Smiley02BitMap)
  • #define kBigTeethSmiley (((UInt32)LargeSmiley03BitMap << 16) | Smiley03BitMap)
  • #define kTongueSmiley (((UInt32)LargeSmiley04BitMap << 16) | Smiley04BitMap)
  • #define kDevilSmiley (((UInt32)LargeSmiley05BitMap << 16) | Smiley05BitMap)
  • #define kOMouthSmiley (((UInt32)LargeSmiley06BitMap << 16) | Smiley06BitMap)
  • #define kBigTongueSmiley (((UInt32)LargeSmiley07BitMap << 16) | Smiley07BitMap)
  • #define kHeartSmiley (((UInt32)LargeSmiley08BitMap << 16) | Smiley08BitMap)
  • #define kBigFrownSmiley (((UInt32)LargeSmiley09BitMap << 16) | Smiley09BitMap)
  • #define kQuestionSmiley (((UInt32)LargeSmiley10BitMap << 16) | Smiley10BitMap)
  • #define kPukeSmiley (((UInt32)LargeSmiley11BitMap << 16) | Smiley11BitMap)
  • #define kBigSmileSmiley (((UInt32)LargeSmiley12BitMap << 16) | Smiley12BitMap)
  • #define kBlushSmiley (((UInt32)LargeSmiley13BitMap << 16) | Smiley13BitMap)
  • #define kSmirkSmiley (((UInt32)LargeSmiley14BitMap << 16) | Smiley14BitMap)
  • #define kClownSmiley (((UInt32)LargeSmiley15BitMap << 16) | Smiley15BitMap)
  • #define kStraightMouthSmiley (((UInt32)LargeSmiley16BitMap << 16) | Smiley16BitMap)
  • #define kYinYangSmiley (((UInt32)LargeSmiley17BitMap << 16) | Smiley17BitMap)
  • #define kAngelSmiley (((UInt32)LargeSmiley18BitMap << 16) | Smiley18BitMap)
  • #define kCigarSmiley (((UInt32)LargeSmiley19BitMap << 16) | Smiley19BitMap)
  • #define kFlipSmiley (((UInt32)LargeSmiley20BitMap << 16) | Smiley20BitMap)
  • #define kUFlipSmiley (((UInt32)LargeSmiley21BitMap << 16) | Smiley21BitMap)
  • #define kLFlipSmiley (((UInt32)LargeSmiley22BitMap << 16) | Smiley22BitMap)
  • #define kRFlipSmiley (((UInt32)LargeSmiley23BitMap << 16) | Smiley23BitMap)
  • #define kDeltaCharacter (((UInt32)Delta14BitMap << 16) | Delta11BitMap)
  • #define kPhiCharacter (((UInt32)Phi14BitMap << 16) | Phi11BitMap)
  • #define kGammaCharacter (((UInt32)Gamma14BitMap << 16) | Gamma11BitMap)
  • #define kLambdaCharacter (((UInt32)Lambda14BitMap << 16) | Lambda11BitMap)
  • #define kOmegaCharacter (((UInt32)Omega14BitMap << 16) | Omega11BitMap)
  • #define kPiCharacter (((UInt32)Pi14BitMap << 16) | Pi11BitMap)
  • #define kPsiCharacter (((UInt32)Psi14BitMap << 16) | Psi11BitMap)
  • #define kSigmaCharacter (((UInt32)Sigma14BitMap << 16) | Sigma11BitMap)
  • #define kThetaCharacter (((UInt32)Theta14BitMap << 16) | Theta11BitMap)
  • #define kXiCharacter (((UInt32)Xi14BitMap << 16) | Xi11BitMap)

Link colors (from the CLUT)

  • #define kSTECurrent 254
  • #define kSTEBlack 255
  • #define kSTEBlue 95
  • #define kSTERed 125
  • #define kSTEGreen 210
  • #define kSTEYellow 120
  • #define kSTEPurple 23
  • #define kSTEOrange 116
  • #define kSTEGray 220

Inverse Color

  • #define kSTEBlackInverse 0
  • #define kSTEBlueInverse 114
  • #define kSTERedInverse 8
  • #define kSTEGreenInverse 18
  • #define kSTEYellowInverse 6
  • #define kSTEPurpleInverse 1
  • #define kSTEOrangeInverse 30
  • #define kSTEGrayInverse 25

Use standard or bold font

  • #define steStdFont "//STESTDFONT//"
  • #define steBoldFont "//STEBOLDFONT//"

Font colors

  • #define steCurrentFont "//STECURRENTFONT//"
  • #define steBlackFont "//STEBLACKFONT//"
  • #define steBlueFont "//STEBLUEFONT//"
  • #define steRedFont "//STEREDFONT//"
  • #define steGreenFont "//STEGREENFONT//"
  • #define steYellowFont "//STEYELLOWFONT//"
  • #define stePurpleFont "//STEPURPLEFONT//"
  • #define steOrangeFont "//STEORANGEFONT//"
  • #define steGrayFont "//STEGRAYFONT//"

Used for formatting

  • #define steLeftIndent "//STELEFTINDENT="
  • #define steRightAlign "//STERIGHTALIGN="
  • #define steCenterAlign "//STECENTERALIGN//"

Miscellaneous

  • #define steHorizontalLine "//STEHORIZONTALLINE//"
  • #define steLineBreak "//STELINEBREAK//"

Text Selection

  • #define kSelectUntilEndOfRecord 0xFFFFFFFE
  • #define kSelectUntilEnd 0xFFFFFFFF

Initializing the Smart Text Engine

  • #define steParsePhoneNumbers 0x00000001
  • #define steParseURLs 0x00000002
  • #define steParseEmail 0x00000004
  • #define steParseEmoticons 0x00000008
  • #define steLargeFont 0x00000010
  • #define steCannotSelectText 0x00000020
  • #define steParseMoreEmoticons 0x00000040
  • #define steScrollWalksLinks 0x00000080
  • #define steInvertHighlighting 0x00000100
  • #define steNoLinksBeforeColon 0x00000200
  • #define steAcceleratedScrolling 0x00000400
  • #define steAllowShortPhoneNumbers 0x00000800
  • #define steParseGSMGreekChars 0x00001000
  • #define steDoNotCenterVertically 0x00002000
  • #define steScrollWalksMessages 0x00004000
  • #define steTextMustBeVisible 0x00008000
  • #define steAllowPhoneNumberWords 0x00010000

Defines

  • #define steLibName "SmartTextEngine.lib"
  • #define steLibDBName "Smart Text Engine"
  • #define kSmartTextBit 0x4000
  • #define steBitmap "//STEBITMAP="
  • #define steHyperlink "//STEHYPERLINK="
  • #define kScrollToEnd 0xFFFF

Typedefs

  • typedef void(* STECallbackType )(UInt32 refNum)

Define Documentation

#define kAngelSmiley (((UInt32)LargeSmiley18BitMap << 16) | Smiley18BitMap)

Angel Smily

#define kBigFrownSmiley (((UInt32)LargeSmiley09BitMap << 16) | Smiley09BitMap)

Big Frown Smily

#define kBigSmileSmiley (((UInt32)LargeSmiley12BitMap << 16) | Smiley12BitMap)

Big Smile Smily

#define kBigTeethSmiley (((UInt32)LargeSmiley03BitMap << 16) | Smiley03BitMap)

Big Teeth Smily

#define kBigTongueSmiley (((UInt32)LargeSmiley07BitMap << 16) | Smiley07BitMap)

Big Tongue Smily

#define kBlushSmiley (((UInt32)LargeSmiley13BitMap << 16) | Smiley13BitMap)

Blush Smily

#define kCigarSmiley (((UInt32)LargeSmiley19BitMap << 16) | Smiley19BitMap)

Cigar Smily

#define kClownSmiley (((UInt32)LargeSmiley15BitMap << 16) | Smiley15BitMap)

Clown Smily

#define kDeltaCharacter (((UInt32)Delta14BitMap << 16) | Delta11BitMap)

Delta Character

#define kDevilSmiley (((UInt32)LargeSmiley05BitMap << 16) | Smiley05BitMap)

Devil Smily

#define kFlipSmiley (((UInt32)LargeSmiley20BitMap << 16) | Smiley20BitMap)

Flip Smily

#define kFrownSmiley (((UInt32)LargeSmiley02BitMap << 16) | Smiley02BitMap)

Frowning Smily

#define kGammaCharacter (((UInt32)Gamma14BitMap << 16) | Gamma11BitMap)

Gamma Character

#define kHeartSmiley (((UInt32)LargeSmiley08BitMap << 16) | Smiley08BitMap)

Heart Smily

#define kLambdaCharacter (((UInt32)Lambda14BitMap << 16) | Lambda11BitMap)

Lambda Character

#define kLFlipSmiley (((UInt32)LargeSmiley22BitMap << 16) | Smiley22BitMap)

Left Flip Smily

#define kOmegaCharacter (((UInt32)Omega14BitMap << 16) | Omega11BitMap)

Omega Character

#define kOMouthSmiley (((UInt32)LargeSmiley06BitMap << 16) | Smiley06BitMap)

O-mouth Smily

#define kPhiCharacter (((UInt32)Phi14BitMap << 16) | Phi11BitMap)

Phi Character

#define kPiCharacter (((UInt32)Pi14BitMap << 16) | Pi11BitMap)

Pi Character

#define kPsiCharacter (((UInt32)Psi14BitMap << 16) | Psi11BitMap)

Psi Character

#define kPukeSmiley (((UInt32)LargeSmiley11BitMap << 16) | Smiley11BitMap)

Puke Smily

#define kQuestionSmiley (((UInt32)LargeSmiley10BitMap << 16) | Smiley10BitMap)

Question Smily

#define kRFlipSmiley (((UInt32)LargeSmiley23BitMap << 16) | Smiley23BitMap)

Right Flip Smily

#define kScrollToEnd 0xFFFF

Used to scroll to end

#define kSelectUntilEnd 0xFFFFFFFF

Select until End

#define kSelectUntilEndOfRecord 0xFFFFFFFE

Select till end of record

#define kSigmaCharacter (((UInt32)Sigma14BitMap << 16) | Sigma11BitMap)

Sigma Character

#define kSmartTextBit 0x4000

No definition

#define kSmileSmiley (((UInt32)LargeSmiley00BitMap << 16) | Smiley00BitMap)

Smiling Smily

#define kSmirkSmiley (((UInt32)LargeSmiley14BitMap << 16) | Smiley14BitMap)

Smirk Smily

#define kSTEBitmap (kSmartTextBit | 0x70)

Bitmap

#define kSTEBlack 255

Black

#define kSTEBlackFont (kSmartTextBit | 0x11)

Black font color

#define kSTEBlackInverse 0

Black Inverse

#define kSTEBlue 95

Blue

#define kSTEBlueFont (kSmartTextBit | 0x12)

Blue font color

#define kSTEBlueInverse 114

Blue Inverse

#define kSTECenterAlign (kSmartTextBit | 0x53)

Center Alignment

#define kSTECharacterBitmap (kSmartTextBit | 0x72)

Character Bitmap

#define kSTECurrentFont (kSmartTextBit | 0x10)

Current font color

#define kSTEGray 220

Gray

#define kSTEGrayFont (kSmartTextBit | 0x18)

Gray font color

#define kSTEGrayInverse 25

Gray Inverse

#define kSTEGreen 210

Green

#define kSTEGreenFont (kSmartTextBit | 0x14)

Green font color

#define kSTEGreenInverse 18

Green Inverse

#define kSTEHorizontalLine (kSmartTextBit | 0x60)

Horizontal Line

#define kSTEHyperlink (kSmartTextBit | 0x80)

Hyperlink

#define kSTELeftIndent (kSmartTextBit | 0x51)

Left Indentation

#define kSTELineBreak (kSmartTextBit | 0x50)

Line Break

#define kSTEOrange 116

Orange

#define kSTEOrangeFont (kSmartTextBit | 0x17)

Orange font color

#define kSTEOrangeInverse 30

Orange Inverse

#define kSTEPurple 23

Purple

#define kSTEPurpleFont (kSmartTextBit | 0x16)

Purple font color

#define kSTEPurpleInverse 1

Purple Inverse

#define kSTERed 125

Red

#define kSTERedFont (kSmartTextBit | 0x13)

Red font color

#define kSTERedInverse 8

Red Inverse

#define kSTERightAlign (kSmartTextBit | 0x52)

Right Alignment

#define kSTESmileyBitmap (kSmartTextBit | 0x71)

Smiley Bitmap

#define kSTEYellow 120

Yellow

#define kSTEYellowFont (kSmartTextBit | 0x15)

Yellow font color

#define kSTEYellowInverse 6

Yellow Inverse

#define kStraightMouthSmiley (((UInt32)LargeSmiley16BitMap << 16) | Smiley16BitMap)

Straight Mouth Smily

#define kThetaCharacter (((UInt32)Theta14BitMap << 16) | Theta11BitMap)

Theta Character

#define kTongueSmiley (((UInt32)LargeSmiley04BitMap << 16) | Smiley04BitMap)

Tongue Smily

#define kUFlipSmiley (((UInt32)LargeSmiley21BitMap << 16) | Smiley21BitMap)

Up Flip Smily

#define kWinkSmiley (((UInt32)LargeSmiley01BitMap << 16) | Smiley01BitMap)

Winking Smily

#define kXiCharacter (((UInt32)Xi14BitMap << 16) | Xi11BitMap)

Xi Character

#define kYinYangSmiley (((UInt32)LargeSmiley17BitMap << 16) | Smiley17BitMap)

Yin Yang Smily

#define steAcceleratedScrolling 0x00000400

No Accelerated Scrolling

#define steAllowPhoneNumberWords 0x00010000

If true, then the phone number parser will allow numbers like 1-800-TESTING

#define steAllowShortPhoneNumbers 0x00000800

Allow Short Phone Numbers

#define steBitmap "//STEBITMAP="

Graphics support

#define steBlackFont "//STEBLACKFONT//"

Black font color

#define steBlueFont "//STEBLUEFONT//"

Blue font color

#define steBoldFont "//STEBOLDFONT//"

Bold Font

#define steCannotSelectText 0x00000020

Cannot Select Text

#define steCenterAlign "//STECENTERALIGN//"

Center Alignment

#define steCurrentFont "//STECURRENTFONT//"

Current font color

#define steDoNotCenterVertically 0x00002000

Do not center vertically

#define steGrayFont "//STEGRAYFONT//"

Gray font color

#define steGreenFont "//STEGREENFONT//"

Green font color

#define steHorizontalLine "//STEHORIZONTALLINE//"

Horizontal Line

#define steHyperlink "//STEHYPERLINK="

Hyperlink

#define steInvertHighlighting 0x00000100

Invert highlighting

#define steLargeFont 0x00000010

Large Font

#define steLeftIndent "//STELEFTINDENT="

Left Indentation

#define steLibDBName "Smart Text Engine"

Name used for DmFindDatabase

#define steLibName "SmartTextEngine.lib"

Internal library name which can(but shouldn't) be passed to SysLibFind()

#define steLineBreak "//STELINEBREAK//"

Line Break

#define steNoLinksBeforeColon 0x00000200

No links before colon

#define steOrangeFont "//STEORANGEFONT//"

Orange font color

#define steParseEmail 0x00000004

parse Email

#define steParseEmoticons 0x00000008

parse Emotions

#define steParseGSMGreekChars 0x00001000

Parse GSM Greek Characters

#define steParseMoreEmoticons 0x00000040

Parse More Emoticons

#define steParsePhoneNumbers 0x00000001

Parse Phone Numbers

#define steParseURLs 0x00000002

Parse URLs

#define stePurpleFont "//STEPURPLEFONT//"

Purple font color

#define steRedFont "//STEREDFONT//"

Red font color

#define steRightAlign "//STERIGHTALIGN="

Right Indentation

#define steScrollWalksLinks 0x00000080

Scroll Walks links

#define steScrollWalksMessages 0x00004000

Scroll walks messages

#define steStdFont "//STESTDFONT//"

Standard Font

#define steTextMustBeVisible 0x00008000

If true, then any routine that returns selected text must verify the text is visible first

#define steYellowFont "//STEYELLOWFONT//"

Yellow font color

Typedef Documentation

typedef void(* STECallbackType)(UInt32 refNum)

Used for custom hyperlinks

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:29 2006 for Palm API Guide


SmartTextEngineErrors.h File Reference

Detailed Description

Error codes for Smart Text Engine shared library.

Defines

  • #define steErrBase hsSTEErrorClass
  • #define steErrUnimplemented (steErrBase + 1)
  • #define steErrInternal (steErrBase + 2)
  • #define steErrDynamicMemory (steErrBase + 3)
  • #define steErrStorageMemory (steErrBase + 4)
  • #define steErrOperationNotAllowed (steErrBase + 5)
  • #define steErrInvalidArguments (steErrBase + 6)
  • #define steErrSTEInit (steErrBase + 7)

Typedefs

  • typedef UInt32 STEErr

Define Documentation

#define steErrBase hsSTEErrorClass

Error Code starting base

#define steErrDynamicMemory (steErrBase + 3)

Dynamic memory allocation failed

#define steErrInternal (steErrBase + 2)

Unspecified internal error

#define steErrInvalidArguments (steErrBase + 6)

Bad arguments

#define steErrOperationNotAllowed (steErrBase + 5)

Operation cannot be performed at this time

#define steErrSTEInit (steErrBase + 7)

STE initialization failed

#define steErrStorageMemory (steErrBase + 4)

Storage memory allocation failed

#define steErrUnimplemented (steErrBase + 1)

Functionality not currently implemented

Typedef Documentation

typedef UInt32 STEErr

Common define for Smart Text Engine Error Code return value

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:29 2006 for Palm API Guide


SmartTextEngineTraps.h File Reference

Detailed Description

Trap definitions for the Smart Text Engine shared library.

Defines

  • #define STETrapOpen sysLibTrapOpen
  • #define STETrapClose sysLibTrapClose
  • #define STETrapGetAPIVersion (sysLibTrapCustom + 0)
  • #define STETrapInitializeEngine (sysLibTrapCustom + 1)
  • #define STETrapResetEngine (sysLibTrapCustom + 2)
  • #define STETrapReinitializeEngine (sysLibTrapCustom + 3)
  • #define STETrapAppendTextToEngine (sysLibTrapCustom + 4)
  • #define STETrapRemoveLastRecordFromEngine (sysLibTrapCustom + 5)
  • #define STETrapRenderList (sysLibTrapCustom + 6)
  • #define STETrapRerenderList (sysLibTrapCustom + 7)
  • #define STETrapHandleEvent (sysLibTrapCustom + 8)
  • #define STETrapHandleSclRepeatEvent (sysLibTrapCustom + 9)
  • #define STETrapHandlePenDownEvent (sysLibTrapCustom + 10)
  • #define STETrapHandlePenMoveEvent (sysLibTrapCustom + 11)
  • #define STETrapHandlePenUpEvent (sysLibTrapCustom + 12)
  • #define STETrapHandleKeyDownEvent (sysLibTrapCustom + 13)
  • #define STETrapGetScroll (sysLibTrapCustom + 14)
  • #define STETrapSetScroll (sysLibTrapCustom + 15)
  • #define STETrapGetScrollPct (sysLibTrapCustom + 16)
  • #define STETrapSetScrollPct (sysLibTrapCustom + 17)
  • #define STETrapSetScrollToRecordNum (sysLibTrapCustom + 18)
  • #define STETrapSetFlags (sysLibTrapCustom + 19)
  • #define STETrapGetNumLines (sysLibTrapCustom + 20)
  • #define STETrapGetNumRecords (sysLibTrapCustom + 21)
  • #define STETrapHasHotRectSelection (sysLibTrapCustom + 22)
  • #define STETrapHasTextSelection (sysLibTrapCustom + 23)
  • #define STETrapClearCurrentSelection (sysLibTrapCustom + 24)
  • #define STETrapSetCurrentTextSelection (sysLibTrapCustom + 25)
  • #define STETrapGetCurrentTextSelection (sysLibTrapCustom + 26)
  • #define STETrapGetSelectedText (sysLibTrapCustom + 27)
  • #define STETrapCopySelectionToClipboard (sysLibTrapCustom + 28)
  • #define STETrapGetLastTapInfo (sysLibTrapCustom + 29)
  • #define STETrapSetCustomHyperlinkCallback (sysLibTrapCustom + 30)
  • #define STETrapGetFlags (sysLibTrapCustom + 31)
  • #define STETrapHasMessageSelection (sysLibTrapCustom + 32)
  • #define STETrapGetParsedInformation (sysLibTrapCustom + 33)
  • #define STETrapAppendParsedInfo (sysLibTrapCustom + 34)
  • #define STEDepracated5 (sysLibTrapCustom + 35)
  • #define STETrapQuickRender (sysLibTrapCustom + 36)

Define Documentation

#define STEDepracated5 (sysLibTrapCustom + 35)

Trap ID for Depracated5

#define STETrapAppendParsedInfo (sysLibTrapCustom + 34)

Trap ID for Append parsed info

#define STETrapAppendTextToEngine (sysLibTrapCustom + 4)

Trap ID for Append Text to Engine

#define STETrapClearCurrentSelection (sysLibTrapCustom + 24)

Trap ID for Clear current selection

#define STETrapClose sysLibTrapClose

Close Trap

#define STETrapCopySelectionToClipboard (sysLibTrapCustom + 28)

Trap ID for Copy selection clipboard

#define STETrapGetAPIVersion (sysLibTrapCustom + 0)

Trap ID for Get API function

#define STETrapGetCurrentTextSelection (sysLibTrapCustom + 26)

Trap ID for Get current selection

#define STETrapGetFlags (sysLibTrapCustom + 31)

Trap ID for Get flags

#define STETrapGetLastTapInfo (sysLibTrapCustom + 29)

Trap ID for Last Tap info

#define STETrapGetNumLines (sysLibTrapCustom + 20)

Trap ID for Get num lines

#define STETrapGetNumRecords (sysLibTrapCustom + 21)

Trap ID for Get num records

#define STETrapGetParsedInformation (sysLibTrapCustom + 33)

Trap ID for Get parsed information

#define STETrapGetScroll (sysLibTrapCustom + 14)

Trap ID for Get scroll

#define STETrapGetScrollPct (sysLibTrapCustom + 16)

Trap ID for Get scroll pct

#define STETrapGetSelectedText (sysLibTrapCustom + 27)

Trap ID for Get selected text

#define STETrapHandleEvent (sysLibTrapCustom + 8)

Trap ID for Handle Event

#define STETrapHandleKeyDownEvent (sysLibTrapCustom + 13)

Trap ID for Handle key down event

#define STETrapHandlePenDownEvent (sysLibTrapCustom + 10)

Trap ID for Handle pen down event

#define STETrapHandlePenMoveEvent (sysLibTrapCustom + 11)

Trap ID for Handle pen move event

#define STETrapHandlePenUpEvent (sysLibTrapCustom + 12)

Trap ID for Handle pen up event

#define STETrapHandleSclRepeatEvent (sysLibTrapCustom + 9)

Trap ID for Handle Scl repeat event

#define STETrapHasHotRectSelection (sysLibTrapCustom + 22)

Trap ID for Has hot rect selection

#define STETrapHasMessageSelection (sysLibTrapCustom + 32)

Trap ID for Has message selection

#define STETrapHasTextSelection (sysLibTrapCustom + 23)

Trap ID for Has text selection

#define STETrapInitializeEngine (sysLibTrapCustom + 1)

Trap ID for Initialize Engine function

#define STETrapOpen sysLibTrapOpen

Open Trap

#define STETrapQuickRender (sysLibTrapCustom + 36)

Trap ID for Quick Render

#define STETrapReinitializeEngine (sysLibTrapCustom + 3)

Trap ID for Reinitialize Engine function

#define STETrapRemoveLastRecordFromEngine (sysLibTrapCustom + 5)

Trap ID for Remove last record from engine

#define STETrapRenderList (sysLibTrapCustom + 6)

Trap ID for render list

#define STETrapRerenderList (sysLibTrapCustom + 7)

Trap ID for Rerender list

#define STETrapResetEngine (sysLibTrapCustom + 2)

Trap ID for Reset Engine function

#define STETrapSetCurrentTextSelection (sysLibTrapCustom + 25)

Trap ID for Set current text selection

#define STETrapSetCustomHyperlinkCallback (sysLibTrapCustom + 30)

Trap ID for Set custom hyperlink callback

#define STETrapSetFlags (sysLibTrapCustom + 19)

Trap ID for Set Flags

#define STETrapSetScroll (sysLibTrapCustom + 15)

Trap ID for Set scroll

#define STETrapSetScrollPct (sysLibTrapCustom + 17)

Trap ID for Set scroll pct

#define STETrapSetScrollToRecordNum (sysLibTrapCustom + 18)

Trap ID for Set scroll to record num

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:29 2006 for Palm API Guide


TonesLib.h File Reference

Detailed Description

Public 68K include file that controls the MIDI tones on a device.

Notes:

The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application(ie, SysLibFind() returns a valid refnum). When the application is done with the library, it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal synchronization.

Defines

  • #define kTonesLibVersionEscalation 10

Functions

  • Err TonesLibOpen (UInt16 refNum)
  • Err TonesLibClose (UInt16 refNum)
  • Err TonesLibWake (UInt16 refNum)
  • Err TonesLibSleep (UInt16 refNum)
  • Err TonesLibGetToneList (UInt16 refNum, ToneItemPtr *list, UInt16 *listLength)
  • Err TonesLibGetToneIDs (UInt16 refNum, ToneIdentifier **list, UInt16 *listLength)
  • Err TonesLibGetToneName (UInt16 refNum, ToneIdentifier toneId, CharPtr name, UInt16 maxLength)
  • Err TonesLibGetToneSize (UInt16 refNum, ToneIdentifier toneId, UInt32 *sizeP)
  • Err TonesLibPlayTone (UInt16 refNum, ToneIdentifier toneId, UInt16 playCount, ToneVolume volume, ToneVibrateType vibrate, Boolean blocking)
  • Err TonesLibAddMidiTone (UInt16 refNum, MemHandle midiTone, CharPtr toneName, Boolean protectedTone)
  • Err TonesLibToneCreate (UInt16 refNum, UInt32 *streamP, ToneType toneType, CharPtr toneName, Boolean protectedTone)
  • Err TonesLibToneWrite (UInt16 refNum, UInt32 stream, const void *dataP, Int32 size)
  • Err TonesLibToneClose (UInt16 refNum, UInt32 stream)
  • Err TonesLibManageTones (UInt16 refNum)
  • Err TonesLibDeleteTone (UInt16 refNum, ToneIdentifier toneId)
  • Err TonesLibInitTonesDB (UInt16 refNum)
  • Err TonesLibGetSoundPrefs (UInt16 refNum, SoundPrefType soundType, SoundPreference *soundPrefs)
  • Err TonesLibSetSoundPrefs (UInt16 refNum, SoundPrefType soundType, SoundPreference *soundPrefs)
  • Err TonesLibPickTone (UInt16 refNum, ToneType *toneType, MemHandle *toneH, Char *name)
  • Err TonesLibStopTone (UInt16 refNum)
  • Err TonesLibGetSoundOnVolume (UInt16 refNum, SoundPrefType soundType, ToneVolume *soundOnVolumeP)
  • Err TonesLibSetSoundOnVolume (UInt16 refNum, SoundPrefType soundType, ToneVolume soundOnVolume)
  • Err TonesLibDoDialog (UInt16 refNum, UInt32 flags)
  • Err TonesLibRecordTone (UInt16 refNum)
  • Err TonesLibEscalateRingTones (UInt16 refNum, Boolean set, Boolean *value)
  • Err TonesLibPlayRingTone (UInt16 refNum, ToneIdentifier toneId, UInt16 playCount, ToneVolume volume, ToneVibrateType vibrate, Boolean blocking)

Define Documentation

#define kTonesLibVersionEscalation 10

Minimum db version of TonesLibrary database that implements escalation Done this way since we have no GetLibVersion() API.

Function Documentation

Err TonesLibAddMidiTone | ( | UInt16 | refNum,
 |  | MemHandle | midiTone,
 |  | CharPtr | toneName,
 |  | Boolean | protectedTone
 | ) |

Add a MIDI tone to the system tone database.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
midiTone,: IN: The data buffer handle where the midi tone data is located.
toneName,: IN: Name of the tone.
protectedTone,: IN: Save tone as protected record in the tone database.
Returns:
Library error code.

Err TonesLibClose ( UInt16 refNum )

Close the Tones library instance.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
Returns:
Library error code.

Err TonesLibDeleteTone | ( | UInt16 | refNum,
 |  | ToneIdentifier | toneId
 | ) |

Delete a tone given its ID.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
toneId,: IN: ID of the tone to be deleted.
Returns:
Library error code.

Err TonesLibDoDialog | ( | UInt16 | refNum,
 |  | UInt32 | flags
 | ) |

Display the UI to create and/or manages tones.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
flags,: IN: Set to kTonesDialogFlagNonModal to hide the Done button from the dialog.
Returns:
Library error code.

Err TonesLibEscalateRingTones | ( | UInt16 | refNum,
 |  | Boolean | set,
 |  | Boolean * | value
 | ) |

Query or toggle whether ring tones are escalated in volume when played.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
set,: IN: true if setting, false if querying.
value,: IN: Value to set if setting, queried value if querying.
Returns:
Library error code.

Err TonesLibGetSoundOnVolume | ( | UInt16 | refNum,
 |  | SoundPrefType | soundType,
 |  | ToneVolume * | soundOnVolumeP
 | ) |

Get the sound-on volume of a sound type.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
soundType,: IN: Type of (application) sound.
soundOnVolumeP,: OUT: Volume of the sound.
Returns:
Library error code.

Err TonesLibGetSoundPrefs | ( | UInt16 | refNum,
 |  | SoundPrefType | soundType,
 |  | SoundPreference * | soundPrefs
 | ) |

Get the sound preference for a type of (application) sound.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
soundType,: IN: Type of (application: email, SMS, phone call, etc) sound.
soundPrefs,: OUT: Preference settings for a type of sound.
Returns:
Library error code.

Err TonesLibGetToneIDs | ( | UInt16 | refNum,
 |  | ToneIdentifier ** | list,
 |  | UInt16 * | listLength
 | ) |

Get the list of tone IDs.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
list,: IN: Pointer to the list of tone IDs to return.
listLength,: OUT: Count of how many tone IDs are in the list.
Returns:
Library error code.

Err TonesLibGetToneList | ( | UInt16 | refNum,
 |  | ToneItemPtr * | list,
 |  | UInt16 * | listLength
 | ) |

Get the list of tone names.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
list,: IN: Pointer to the list of tone names to return.
listLength,: OUT: Count of how many tone names are in the list.
Returns:
Library error code.

Err TonesLibGetToneName | ( | UInt16 | refNum,
 |  | ToneIdentifier | toneId,
 |  | CharPtr | name,
 |  | UInt16 | maxLength
 | ) |

Get the name of a certain tone given its ID.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
toneId,: IN: Tone ID of the tone name to get.
name,: I/O: Pointer to the returned tone name.
maxLength,: IN: Size of the name buffer in bytes.
Returns:
Library error code.

Err TonesLibGetToneSize | ( | UInt16 | refNum,
 |  | ToneIdentifier | toneId,
 |  | UInt32 * | sizeP
 | ) |

Get the tone data size given its ID.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
toneId,: IN: ID number of the tone.
sizeP,: OUT: Size of the specified tone.
Returns:
Library error code.

Err TonesLibInitTonesDB ( UInt16 refNum )

Create the default tone database if it does not exist, and verify that all the tones in a database are resident on the device.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
Returns:
Library error code.

Err TonesLibManageTones ( UInt16 refNum )

Display UI to manage tones. Users can delete, play, or send a tone from this UI.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
Returns:
Library error code.

Err TonesLibOpen ( UInt16 refNum )

Open and initialize the Tones library instance.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
Returns:
Library error code.

Err TonesLibPickTone | ( | UInt16 | refNum,
 |  | ToneType * | toneType,
 |  | MemHandle * | toneH,
 |  | Char * | name
 | ) |

Display the UI to select tones and return the tone type, tone name, and handle to the tone data.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
toneType,: OUT: Type of tone.
toneH,: OUT: Handle to the tone selected. Must be freed by the caller.
name,: OUT: Name of the tone.
Returns:
Library error code.

Err TonesLibPlayRingTone | ( | UInt16 | refNum,
 |  | ToneIdentifier | toneId,
 |  | UInt16 | playCount,
 |  | ToneVolume | volume,
 |  | ToneVibrateType | vibrate,
 |  | Boolean | blocking
 | ) |

Play a ring tone given its ID. The difference between this and PlayTone is that tones played this way are affected by TonesLibEscalateRingTones().

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
toneId,: IN: ID of the tone to play.
playCount,: IN: Number of times you want the tone repeated.
volume,: IN: Volume level at which you want the tone played.
vibrate,: IN: Vibrate mode to use when playing the tone.
blocking,: IN: Controls whether the tone play is a blocking call or play in the background and return immediately.
Returns:
Library error code.

Err TonesLibPlayTone | ( | UInt16 | refNum,
 |  | ToneIdentifier | toneId,
 |  | UInt16 | playCount,
 |  | ToneVolume | volume,
 |  | ToneVibrateType | vibrate,
 |  | Boolean | blocking
 | ) |

Play a tone given its ID.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
toneId,: IN: ID of the tone to play.
playCount,: IN: Number of times you want the tone repeated.
volume,: IN: Volume level at which you want the tone played.
vibrate,: IN: Vibrate mode to use when playing the tone.
blocking,: IN: Controls whether the tone play is a blocking call or play in the background and return immediately.
Returns:
Library error code.

Err TonesLibRecordTone ( UInt16 refNum )

No definition.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
Returns:
Library error code.

Err TonesLibSetSoundOnVolume | ( | UInt16 | refNum,
 |  | SoundPrefType | soundType,
 |  | ToneVolume | soundOnVolume
 | ) |

Set the sound-on volume of a sound type.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
soundType,: IN: Type of (application) sound.
soundOnVolume,: IN: Volume of the tone.
Returns:
Library error code.

Err TonesLibSetSoundPrefs | ( | UInt16 | refNum,
 |  | SoundPrefType | soundType,
 |  | SoundPreference * | soundPrefs
 | ) |

Set the sound preference for a type of (application) sound.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
soundType,: IN: Type of (application) sound.
soundPrefs,: IN: Preference settings for the type of sound.
Returns:
Library error code.

Err TonesLibSleep ( UInt16 refNum )

Standard function to receive Palm OS sleep notification.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
Returns:
Library error code.

Err TonesLibStopTone ( UInt16 refNum )

Stop the playback of the current tone.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
Returns:
Library error code.

Err TonesLibToneClose | ( | UInt16 | refNum,
 |  | UInt32 | stream
 | ) |

Close the reference to the tone stream.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
stream,: IN: Reference to the steam returned by TonesLibToneCreate().
Returns:
Library error code.

Err TonesLibToneCreate | ( | UInt16 | refNum,
 |  | UInt32 * | streamP,
 |  | ToneType | toneType,
 |  | CharPtr | toneName,
 |  | Boolean | protectedTone
 | ) |

Create new tone and return the pointer to the start of the sound stream.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
streamP,: OUT: Pointer to the sound stream of the new tone.
toneType,: IN: Type of the tone.
See also:
ToneType.
Parameters:
toneName,: IN: Name of the tone.
protectedTone,: IN: Save tone as protected record in the tone database.
Returns:
Library error code.

Err TonesLibToneWrite | ( | UInt16 | refNum,
 |  | UInt32 | stream,
 |  | const void * | dataP,
 |  | Int32 | size
 | ) |

Write sound data to the stream returned by TonesLibToneCreate().

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
stream,: IN: Reference to the steam returned by TonesLibToneCreate().
dataP,: IN: Pointer to the Tone(Sound) data.
size,: IN: Size of the data to be written.
Returns:
Library error code.

Err TonesLibWake ( UInt16 refNum )

Standard function to receive Palm OS wake up notification.

Parameters:
refNum,: IN: Library reference number from SysLibLoad.
Returns:
Library error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:30 2006 for Palm API Guide


TonesLibTypes.h File Reference

Detailed Description

Public 68K header file for the Ring Tone library on Treo devices.

This file contains the common constants for the tones and also the structure that contains the ring-tone related sound preferences.

Data Structures

  • struct ToneIdentifier
    No definition. More...
  • struct ToneItemType
    Tone characteristics. More...
  • struct SoundPreferenceIM
    Structure for IM Sound Pref. More...
  • struct SoundPreferencePhone
    Structure for Phone Sound Pref. More...
  • struct SoundPreferenceEmail
    Structure for Email Sound Pref. More...
  • struct SoundPreferenceCalendar
    Structure for Calendar Sound Pref. More...
  • struct SoundPreferenceSMS
    Structure for SMS Sound Pref. More...
  • struct SoundPreferenceMMS
    Structure for MMS Sound Pref. More...
  • struct SoundPreferenceNetworkSounds
    Structure for network related sounds. More...
  • struct SoundPreference
    Structure containing all the Sound Preference data. More...
  • union SoundPreference::_tonePrefs

Error Codes

  • #define tonesLibErrClass 0x9000
  • #define tonesLibErrCreateDBFailed tonesLibErrClass | 1
  • #define tonesLibErrNoMemory tonesLibErrClass | 2
  • #define tonesLibErrNoTone tonesLibErrClass | 3
  • #define tonesLibErrDBNotFound tonesLibErrClass | 4
  • #define tonesLibErrDBWriteFailed tonesLibErrClass | 5
  • #define tonesLibErrUserCancel tonesLibErrClass | 6
  • #define tonesLibErrBadParams tonesLibErrClass | 7
  • #define tonesLibErrUnknown tonesLibErrClass | 8
  • #define tonesLibErrNotAllowed tonesLibErrClass | 9
  • #define tonesLibErrAlreadyPlaying tonesLibErrClass | 10

Utility Macros

  • #define CompareToneIdentifiers(tone1, tone2) (tone1.id == tone2.id && tone1.toneType == tone2.toneType)
  • #define CopyToneIdentifier(destP, src)
  • #define CopyMIDIToneIdentifier(destP, src)

Function Traps

  • #define tonesLibTrapGetToneList sysLibTrapCustom
  • #define tonesLibTrapGetToneIDs sysLibTrapCustom+1
  • #define tonesLibTrapGetToneName sysLibTrapCustom+2
  • #define tonesLibTrapPlayTone sysLibTrapCustom+3
  • #define tonesLibTrapAddMidiTone sysLibTrapCustom+4
  • #define tonesLibTrapManageTones sysLibTrapCustom+5
  • #define tonesLibTrapDeleteTone sysLibTrapCustom+6
  • #define tonesLibTrapGetSoundPrefs sysLibTrapCustom+7
  • #define tonesLibTrapSetSoundPrefs sysLibTrapCustom+8
  • #define tonesLibTrapInitTonesDB sysLibTrapCustom+9
  • #define tonesLibTrapPickTone sysLibTrapCustom+10
  • #define tonesLibTrapStopTone sysLibTrapCustom+11
  • #define tonesLibTrapGetSoundOnVolume sysLibTrapCustom+12
  • #define tonesLibTrapSetSoundOnVolume sysLibTrapCustom+13
  • #define tonesLibTrapDoDialog sysLibTrapCustom+14
  • #define tonesLibTrapGetToneSize sysLibTrapCustom+15
  • #define tonesLibTrapToneCreate sysLibTrapCustom+16
  • #define tonesLibTrapToneWrite sysLibTrapCustom+17
  • #define tonesLibTrapToneClose sysLibTrapCustom+18
  • #define tonesLibTrapToneRecord sysLibTrapCustom+19
  • #define tonesLibTrapEscalateRingTones sysLibTrapCustom+20
  • #define tonesLibTrapPlayRingTone sysLibTrapCustom+21

Defines

  • #define tonesLibName "Tones Library"
  • #define tonesLibCreator hsFileCTonesLib
  • #define tonesLibType sysFileTLibrary
  • #define kMaxTonesNameSize 32
  • #define tonesLibPlayForever 0xFFFF
  • #define kTonesDialogFlagNonModal 0x00000001

Typedefs

  • typedef UInt16 ToneType
  • typedef UInt16 SoundPrefType
  • typedef UInt16 ToneVolume
  • typedef UInt8 TonePlayNumberTimes
  • typedef UInt8 ToneRepeatInterval
  • typedef UInt8 ToneTimeUnit
  • typedef UInt8 ToneVibrateType
  • typedef struct ToneItemType * ToneItemPtr

Enumerations

  • enum _ToneType {
    toneTypeMIDI,
    toneTypeWAV,
    toneTypeAMR,
    toneTypeSystemSound,
    toneTypeQCELP,
    toneTypeMP3,
    toneTypeAAC
    }
  • enum _SoundPrefType {
    soundPrefTypePhone,
    soundPrefTypeEmail,
    soundPrefTypeCalendar,
    soundPrefTypeIM,
    soundPrefTypeMMS,
    soundPrefTypeSMS,
    soundPrefTypeNetworkSounds,
    soundPrefTypeLast
    }
  • enum _ToneVolume {
    toneVolumeOff,
    toneVolume1,
    toneVolume2,
    toneVolume3,
    toneVolume4,
    toneVolume5,
    toneVolume6,
    toneVolume7
    }
  • enum _TonePlayNumberTimes {
    tonePlayOnce,
    tonePlayTwice,
    tonePlay3Times,
    tonePlay5Times,
    tonePlay10Times,
    tonePlay100Times
    }
  • enum _ToneRepeatInterval {
    toneRepeatEveryMinute,
    toneRepeatEvery5Minutes,
    toneRepeatEvery10Minutes,
    toneRepeatEvery30Minutes
    }
  • enum _ToneTimeUnit {
    toneTimeUnitMinutes,
    toneTimeUnitHours,
    toneTimeUnitDays
    }
  • enum _ToneVibrateType {
    toneVibrateNone,
    toneVibrateRing,
    toneVibrateAlert,
    toneVibrateMail,
    toneVibrateCalender,
    toneVibrateSMS,
    toneVibrateVoicemail,
    toneVibrateThenRing
    }

Define Documentation

#define CompareToneIdentifiers | ( | tone1,
 |  | tone2 | ) | (tone1.id == tone2.id && tone1.toneType == tone2.toneType)

No definition.

#define CopyMIDIToneIdentifier | ( | destP,
 |  | src | )

Value:

destP->id = src; \
             destP->toneType = toneTypeMIDI
No definition.

#define CopyToneIdentifier | ( | destP,
 |  | src | )

Value:

destP->id = src.id; \
             destP->toneType = src.toneType
No definition.

#define kMaxTonesNameSize 32

Maximum size of a tone name.

#define kTonesDialogFlagNonModal 0x00000001

Hides the Done button from the play tone dialog.

#define tonesLibCreator hsFileCTonesLib

Creator ID of the Tone Types library.

#define tonesLibErrAlreadyPlaying tonesLibErrClass | 10

No definition.

#define tonesLibErrBadParams tonesLibErrClass | 7

No definition.

#define tonesLibErrClass 0x9000

No definition.

#define tonesLibErrCreateDBFailed tonesLibErrClass | 1

No definition.

#define tonesLibErrDBNotFound tonesLibErrClass | 4

No definition.

#define tonesLibErrDBWriteFailed tonesLibErrClass | 5

No definition.

#define tonesLibErrNoMemory tonesLibErrClass | 2

No definition.

#define tonesLibErrNotAllowed tonesLibErrClass | 9

No definition.

#define tonesLibErrNoTone tonesLibErrClass | 3

No definition.

#define tonesLibErrUnknown tonesLibErrClass | 8

No definition.

#define tonesLibErrUserCancel tonesLibErrClass | 6

No definition.

#define tonesLibName "Tones Library"

Name of the Tone Types library.

#define tonesLibPlayForever 0xFFFF

Used to play a tone over and over indefinitely.

#define tonesLibTrapAddMidiTone sysLibTrapCustom+4

Trap ID for the function to add a MIDI tone. Note: This used to be tonesLibTrapAddTone. Leaving this trap number maintains binary compatability with existing applications. Recompiling older source code will fail since the new version of TonesLibAddTone takes toneType as an additional parameter.

#define tonesLibTrapDeleteTone sysLibTrapCustom+6

Trap ID for function to delete a tone.

#define tonesLibTrapDoDialog sysLibTrapCustom+14

Trap ID for function to display the tones list.

#define tonesLibTrapEscalateRingTones sysLibTrapCustom+20

Trap ID for function to set/query ringtone escalation.

#define tonesLibTrapGetSoundOnVolume sysLibTrapCustom+12

Trap ID for function to get the on volume of a sound type.

#define tonesLibTrapGetSoundPrefs sysLibTrapCustom+7

Trap ID for function to get a sound preference.

#define tonesLibTrapGetToneIDs sysLibTrapCustom+1

Trap ID for the function that gets the list of tone ids.

#define tonesLibTrapGetToneList sysLibTrapCustom

Trap ID for the function that gets the tone list.

#define tonesLibTrapGetToneName sysLibTrapCustom+2

Trap ID for the function that gets the name of a tone.

#define tonesLibTrapGetToneSize sysLibTrapCustom+15

Trap ID for function to get the size of a tone.

#define tonesLibTrapInitTonesDB sysLibTrapCustom+9

Trap ID for function to initialize the Tones database.

#define tonesLibTrapManageTones sysLibTrapCustom+5

Trap ID for function to manage tones.

#define tonesLibTrapPickTone sysLibTrapCustom+10

Trap ID for function to pick a tone to attach.

#define tonesLibTrapPlayRingTone sysLibTrapCustom+21

Trap ID for function to play a ringtone.

#define tonesLibTrapPlayTone sysLibTrapCustom+3

Trap ID for the function that plays a tone.

#define tonesLibTrapSetSoundOnVolume sysLibTrapCustom+13

Trap ID for function to set the on volume of a sound type.

#define tonesLibTrapSetSoundPrefs sysLibTrapCustom+8

Trap ID for function to set a sound preference.

#define tonesLibTrapStopTone sysLibTrapCustom+11

Trap ID for function to stop the playback of the current tone.

#define tonesLibTrapToneClose sysLibTrapCustom+18

Trap ID for function to finish adding a new tone.

#define tonesLibTrapToneCreate sysLibTrapCustom+16

Trap ID for function to begin adding a new tone.

#define tonesLibTrapToneRecord sysLibTrapCustom+19

Trap ID for function to record a new tone.

#define tonesLibTrapToneWrite sysLibTrapCustom+17

Trap ID for function to write data to a new tone.

#define tonesLibType sysFileTLibrary

Type of the Tone Types library.

Typedef Documentation

typedef UInt16 SoundPrefType

Holds sound preference type value

typedef UInt8 TonePlayNumberTimes

Holds number of times to play a tone value

typedef UInt8 ToneRepeatInterval

Holds the tone repeat interval value

typedef UInt8 ToneTimeUnit

Holds the tone time unit value

typedef UInt16 ToneType

Holds tone type value

typedef UInt8 ToneVibrateType

Holds the tone vibrate type value

typedef UInt16 ToneVolume

Holds tone volume value

Enumeration Type Documentation

enum _SoundPrefType

Sound preferences type

Enumerator:
soundPrefTypePhone | Tone pref for phone.
soundPrefTypeEmail | Tone pref for email.
soundPrefTypeCalendar | Tone pref for Calendar.
soundPrefTypeIM | Tone pref for IM.
soundPrefTypeMMS | Tone pref for MMS.
soundPrefTypeSMS | Tone pref for SMS.
soundPrefTypeNetworkSounds | Tone pref for SMS.
soundPrefTypeLast | Last item in enum. Please keep it as last item.

enum _TonePlayNumberTimes

Number of times to play tone

Enumerator:
tonePlayOnce | Play once.
tonePlayTwice | Play twice.
tonePlay3Times | Play three times.
tonePlay5Times | Play five times.
tonePlay10Times | Play ten times.
tonePlay100Times | Play one hundred times.

enum _ToneRepeatInterval

Tone repeat interval

Enumerator:
toneRepeatEveryMinute | Repeat every minute.
toneRepeatEvery5Minutes | Repeat every 5 minutes.
toneRepeatEvery10Minutes | Repeat every 10 minutes.
toneRepeatEvery30Minutes | Repeat every 30 minutes.

enum _ToneTimeUnit

Tone time unit

Enumerator:
toneTimeUnitMinutes | Minutes
toneTimeUnitHours | Hours
toneTimeUnitDays | Days

enum _ToneType

Tone types

Enumerator:
toneTypeMIDI | Record in MIDI Ring Tones DB.
toneTypeWAV | WAV in a SndFileStream.
toneTypeAMR | AMR in a SndFIleStream.
toneTypeSystemSound | Unused.
toneTypeQCELP | QCELP in a SndFileStream.
toneTypeMP3 | MP3 in a SndFileStream
toneTypeAAC | AAC in a SndFileStream

enum _ToneVibrateType

Tone vibrate type

Enumerator:
toneVibrateNone | None
toneVibrateRing | Phone ring event
toneVibrateAlert | Alert event
toneVibrateMail | New mail
toneVibrateCalender | Calendar event
toneVibrateSMS | New SMS
toneVibrateVoicemail | New Voicemail
toneVibrateThenRing | Phone vibrate-then-ring event

enum _ToneVolume

Tone volume

Enumerator:
toneVolumeOff | Volume off
toneVolume1 | Volume level 1
toneVolume2 | Volume level 2
toneVolume3 | Volume level 3
toneVolume4 | Volume level 4
toneVolume5 | Volume level 5
toneVolume6 | Volume level 6
toneVolume7 | Volume level 7

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


TransparencyLib.h File Reference

Detailed Description

Transparency Library that couples a Ccp channel and a serial port.

This library can be used to couple data between a Ccp channel and a serial port. It is meant to be used for diagnostics and tethered mode. Since it is a library, it can work without being in a certain application.

Functions

  • Err TransLibOpenConnection (UInt16 refNum, CcpChannelType portAChannel, UInt32 portB)
  • Err TransLibCloseConnection (UInt16 refNum)

Function Documentation

Err TransLibCloseConnection ( UInt16 refNum )

Close the Transparency Library previously open and set the radio module in the correct state.

Parameters:
refNum,: IN: Library Reference Number.
Return values:
Err Error code.

Err TransLibOpenConnection | ( | UInt16 | refNum,
 |  | CcpChannelType | portAChannel,
 |  | UInt32 | portB
 | ) |

Open the Transparency Library and connect the radio modem directly with a known port.

Parameters:
refNum,: IN: Library Reference Number.
portAChannel,: IN: CcpChannelType of radio port.
portB,: IN: Port ID of the second port. This is the serial or USB port.
Return values:
Err Error code.

///

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


TransparencyLibTypes.h File Reference

Detailed Description

Public common header file for the Transparency Library on Treo devices.

This file contains the common types of the Transparency Library.

Function Traps

  • #define transLibTrapOpenConnection sysLibTrapCustom
  • #define transLibTrapCloseConnection sysLibTrapCustom+1

Error Codes

  • #define transLibErrorClass 0x5000
  • #define transLibErrUnknown (transLibErrorClass | 1)
  • #define transLibErrNotOpen (transLibErrorClass | 2)
  • #define transLibErrAlreadyOpen (transLibErrorClass | 3)
  • #define transLibErrDockNotAttached (transLibErrorClass | 4)

Defines

  • #define transLibName "Transparency Library"
  • #define transLibCreator hsFileCTransparencyLib
  • #define transLibType sysFileTLibrary

Define Documentation

#define transLibCreator hsFileCTransparencyLib

Creator ID of Transparency Library - 'HsTL'

#define transLibErrAlreadyOpen (transLibErrorClass | 3)

Transparency library already open

#define transLibErrDockNotAttached (transLibErrorClass | 4)

Transparency library error when there is cradle not attached to the bottom port

#define transLibErrNotOpen (transLibErrorClass | 2)

No connection is open.

#define transLibErrorClass 0x5000

Error class for the transparency library

#define transLibErrUnknown (transLibErrorClass | 1)

Unkown command requested. For example, an unknown channel type was passed as a port.

#define transLibName "Transparency Library"

Transparency library names

#define transLibType sysFileTLibrary

Type ID of transparency library

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


VMFontLibCommon.h File Reference

Detailed Description

Public common header file for the Versamail Font Library.

Version:
1.0
This file contains the constants and structures for the palmOne VersaMail Font Picker / Font Manager Service.

Include dependency graph for VMFontLibCommon.h:

Data Structures

  • struct VMFontUIRules
    Font UI rules structure used for the font picker setting. More...
  • struct VMFontType
    Font characteristics structure used to describe a font. More...

Function Traps

  • #define flTrapAPIVersion (sysLibTrapCustom + 0)
  • #define flTrapAPIGetFont (sysLibTrapCustom + 1)
  • #define flTrapAPIGetFontByID (sysLibTrapCustom + 2)
  • #define flTrapAPIFontExists (sysLibTrapCustom + 3)
  • #define flTrapAPIFontToString (sysLibTrapCustom + 4)
  • #define flTrapAPIFontCountStyleAndSize (sysLibTrapCustom + 5)
  • #define flTrapAPISetFontUIRules (sysLibTrapCustom + 6)
  • #define flTrapAPIInitFontUI (sysLibTrapCustom + 7)
  • #define flTrapAPIDoFontDialog (sysLibTrapCustom + 8)
  • #define flTrapAPIClearCache (sysLibTrapCustom + 9)

Defines

  • #define fontPickerLibName "PalmSGFontLib.Lib"
  • #define fontPickerType 'appl'
  • #define fontPickerCreatorID 'MA10'
  • #define VMFontErrParam (appErrorClass | 1)
  • #define VMFontErrNotOpen (appErrorClass | 2)
  • #define VMFontErrStillOpen (appErrorClass | 3)

Typedefs

  • typedef UInt8 VMFontFace
  • typedef UInt8 VMFontSize
  • typedef UInt8 VMFontStyle
  • typedef UInt8 VMFontSizeRule
  • typedef UInt8 VMFontStyleRule
  • typedef VMFontUIRules * VMFontUIRulesPtr
  • typedef VMFontType * VMFontPtr

Enumerations

  • enum _VMFontFace {
    gillSans = 0,
    sabon,
    palm
    }
  • enum _VMFontSize {
    size6 = 0,
    size9 = 1,
    size12 = 2
    }
  • enum _VMFontStyle {
    normal = 0,
    bold = 1,
    italic = 2
    }
  • enum _VMFontSizeRule {
    allSize,
    smallFonts,
    largeFonts
    }
  • enum _VMFontStyleRule {
    allStyle,
    plainOnly
    }

Define Documentation

#define fontPickerCreatorID 'MA10'

Font library Creator ID.

#define fontPickerLibName "PalmSGFontLib.Lib"

Font library name.

#define fontPickerType 'appl'

Font library Type.

#define VMFontErrNotOpen (appErrorClass | 2)

Error meaning that the library is not open

#define VMFontErrParam (appErrorClass | 1)

A parameter passed was Invalid

#define VMFontErrStillOpen (appErrorClass | 3)

Error returned from VMFontClose() if the library is still open

Typedef Documentation

typedef UInt8 VMFontFace

Used with _VMFontFace

typedef UInt8 VMFontSize

Used with _VMFontSize

typedef UInt8 VMFontSizeRule

Used with _VMFontSizeRule

typedef UInt8 VMFontStyle

Used with _VMFontStyle

typedef UInt8 VMFontStyleRule

Used with _VMFontStyleRule

Enumeration Type Documentation

enum _VMFontFace

Font Face

Enumerator:
gillSans | Gill Sans MT Font
sabon | Sabon MT Font
palm | Palm

enum _VMFontSize

Font Size

Enumerator:
size6 | Size = 6
size9 | Size = 9
size12 | Size = 12

enum _VMFontSizeRule

Font Size Rule

Enumerator:
allSize | Both small and large fonts
smallFonts | Only Small fonts
largeFonts | Only large fonts

enum _VMFontStyle

Font Style

Enumerator:
normal | Normal Fonts
bold | Bold Fonts
italic | Italic Fonts

enum _VMFontStyleRule

Font Style Rule

Enumerator:
allStyle | All font Styles supported
plainOnly | Only Normal Fonts

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


Palm API Guide Data Structures

Here are the data structures with brief descriptions:
_dataLinks | Structure used for datalinks while sending /rcving data
_HelperServiceMMSDetailsType | Helpers of this Service Class send an MMS message
_HelperServiceMMSObjectType |
_PalmPhotoCaptureParamV2 | Photo/video image capture parameters
_PalmPhotoCreateParam | Photo image create parameters
_PalmPhotoDisplayParam | Photo image display parameters
_PalmPhotoExtraInfo | Photo image extra info parameters
_PalmPhotoFileLocation | Photo file location
_PalmPhotoImageInfo | Photo information
_PalmPhotoReadWriteParam | Photo image manipulation param
_PalmPhotoSelectionParam | Photo selection dialog parameters
_PalmPhotoSelections | Photo selections
_pluginExtendedQueryParams | Structure used for launch code MMPRO_PLUGIN_EXTENDED_QUERY_LAUNCHCODE
_pluginGetInfoParams | Structure used for launch code MMPRO_PLUGIN_GET_INFO_LAUNCHCODE
_pluginParams | Structure used for launch code MMPRO_PLUGIN_RECEIVE_LAUNCHCODE
_pluginQueryParams | Structure used for launch code MMPRO_PLUGIN_QUERY_LAUNCHCODE
_pluginSendParams | Structure used for launch code MMPRO_PLUGIN_SEND_LAUNCHCODE
AddrCallerIDParamsType |
AddrCreateNewRecordParamsType |
AddrDescriptor |
Address |
AddressAppRecord |
AddressAppRecordHeader |
AddressType |
AddrHsLookupUserDataType |
AddrListLookupTypeGetParamsType |
AddrPhonebookAppParamsType |
AddrPhotoCallerIDParamsType |
BGResult | Structure containing Result of response for a protocol request
BSSListStruct | BSS list
CamLibBitmapInfoTag | Bitmap info structure for every format except PalmBMPV4. Data starts after the parameters
CamLibCaptureTag | Capture settings structure. The callback is called with userDataP passed
CamLibColorSpaceTag | Color Space structure
CamLibSettingTag | Settings Capabilities structure. For settings without manual values, only type is used
CamLibStatusTag | Container for the camera status kCamLibStatus*
CamLibStreamTag | Video stream structure. Used for capturing a video stream
Coordinate |
DevAppLaunchCmdGenericCallType | For devAppLaunchCmdGenericCall
DialPnlDispatchDialParamsType |
DialPnlIsDialingAvailableParamsType |
HS_HTTPLibAppinfo_ |
HS_HTTPLibSplit_ |
HsBigButtonMappingType |
HsBigButtonReourceType |
HsDialPrefsUSDialingRulesType |
HsSndBufferData | Holds sound buffer information
HsSndPortInfo | Holds sound port information
HtmlLibFormWidgetProc | The following are necessary form widget creation/deletion routines that need to get set using HtmlLibSetFormWidgetProc. Please see sample code after looking at HtmlLibSetFormWidgetProc
LcdOverlayLibSettingTag | Generic settings For settings without manual values, only type is used
LocationDataTag |
LocDBInfoTag |
LocDBRecordTag |
LocsLibNotifyDataTag |
LocsLibNotifyLocsDataTag |
LocsLibSelLocsTag |
MailAddRecordAttachment | Structure to add attachment in MailAddRecordParamsTypePlus
MailAddRecordParamsTypePlus | Structure to add a message + attachment passed with MMPRO_ADD_MESSAGE_WITH_ATTACHMENT Categories & MailAddRecordParamsType are defined in AppLaunchCmd.h
MMProAttachDataLinks | Data links used in an attachment, used in MMProAttachStruct2
MMProAttachStruct | Structure for adding attachments in MMProLaunchStruct
MMProAttachStruct2 | Structure for adding attachments in MMProLaunchStruct2
MMProLaunchStruct | Structure to add a message + attachment passed with MMPRO_LAUNCH_CODE
MMProLaunchStruct2 | Structure to add a message + attachment passed with MMPRO_LAUNCH_CODE
NBSNotificationEventType |
Net80211DeviceInfo | Device information concerning Hardware and Firmware information for the "adapter"
NetBssInfoType | Structure to hold BSS Info data
NetMasterClientEventInfoType | This structure is passed as the 'detailsP' of the notification
NetMasterClientEventVPNConnInstallType | Data block for netMasterClientEventVPNConnInstall
NetPrefFallbackInfoType | Fallback info structure
NetPrefGPRSQOSType | NetPrefGPRSQOSType -- GPRS Quality Of Service (QOS) info
NetServicesProfile | Profile entries for SmartConnect
NetServicesProfileInfo | Data returned from NetServicesProfileGetInfo
NetServicesProfileOrder | Priority order to smart connect
NetServicesProfileV1 | Profile entries version 1
NetSSID | Structure used to get and set the current SSID for the driver (not the Network interface)
NetWepKey | Structure used to set the wep keys
NetworkDeviceQueryData | Structure to hold network query data
PalmAudioAACDecParamType | AAC decoding parameters
PalmAudioAACParamType | AAC format parameters
PalmAudioADPCMParamType | IMA-ADPCM format parameters
PalmAudioMP2ParamType | MPEG-1 audio decoding parameters
PalmAudioPCMParamType | PCM format parameters
PalmAudioPlaybackNotifyEventTypeTag |
PalmFileFormatParamType | File format parameters
PalmImageBMPParamType | BMP format parameters
PalmImageGIFFrameParamType | GIF frame parameters
PalmImageINDEXParamType | Index image parameters
PalmImageJPEGEncodeParamType | JPEG format encoding parameters
PalmImageParamType | RAW image format parameters
PalmImagePlanarType | Planar image structure, passed during EncodeDecode
PalmVideoAVCCustomGetDecodedFrameType | AVC/H264 Custom Control API structure for getting a decoded frame
PalmVideoAVCCustomGetInfoType | AVC/H264 Custom Control API structure for GetInfo about frame
PalmVideoAVCCustomSetCropModeType | AVC/H264 Custom Control API structure for getting a decoded frame
PalmVideoAVCDecodeParamType | AVC/H264 video format decoding parameters
PalmVideoAVCOutputBufferType | AVC/H264 video format decoding parameters
PalmVideoMPEG1DecodeParamType | MPEG-1 video decoding parameters
PalmVideoMPEG4DecodeParamType | MPEG-4 video format decoding parameters
PalmVideoMPEG4EncodeParamType | MPEG-4 video format encoding parameters
ParsedInfo | Holds parsed item information
ParsedInfoList | Holds the list of parsed item information
PhnCdmaSystemInfoType |
PhnConnectionType |
PhnEventType |
PhnGPRSPDPContextListNodeType |
PhnGPRSPDPContextType |
PhnIOTAPhnDlsLockType | Holds lock state of user's ability to change the download server URL address
PhnLibLengthInfoType |
PhnLineStateType |
PhnMMIEntryType | MMI Decode struct
PhnMMIResultType | MMI result struct
PhnOneXStatus |
PhnOperatorListType |
PhnPDPList |
PhnPDPPayload |
PhnRadioStateType |
PhnRingingInfoType |
PhnRoamPrefInfoType |
PhnSMSParams |
PhnSMSPrefType |
PhoneAppLaunchCmdCallerIDLookupType |
PhoneAppLaunchCmdDialType |
PhoneAppLaunchCmdGetALSLineNumberType |
PhoneAppLaunchCmdGetDialPrefFlagType |
PhoneAppLaunchCmdSendDTMFToneType |
PhoneAppLaunchCmdSetWallpaperType |
PmBroadcastNewMsgCountNotifyParamType | Param structure for pmNotifyBroadcastNewMsgCount notifications
PmConnectorNotifyDataType | Container for the notification details
PmGetNewMsgCountNotifyParamType | Param structure for pmNotifyGetNewMsgCountFromHelper notifications
PmSysGadgetBbutMappingType | This is the structure of a single big button mapping..
PmSysGadgetBbutResourceType | This is the structure of a big button resource..
PosType |
SndCodecCustomControlType | Holds Custom Control type information for the Extended Sound Manager
SoundPreference | Structure containing all the Sound Preference data
SoundPreference::_tonePrefs |
SoundPreferenceCalendar | Structure for Calendar Sound Pref
SoundPreferenceEmail | Structure for Email Sound Pref
SoundPreferenceIM | Structure for IM Sound Pref
SoundPreferenceMMS | Structure for MMS Sound Pref
SoundPreferenceNetworkSounds | Structure for network related sounds
SoundPreferencePhone | Structure for Phone Sound Pref
SoundPreferenceSMS | Structure for SMS Sound Pref
SoundPrefsLaunchCmdParamType |
SysVPPILaunchCmdClearPWCacheType | Structure used by the VPN Panel to clear the password cache
SysVPPILaunchCmdDeleteAccountType | Structure used by the VPN Panel to delete an account
SysVPPILaunchCmdEditAccountType | Structure used by the VPN Panel to edit an account
SysVPPILaunchCmdErrorDialogType | Structure used by the VPN Panel to show the error dialog
SysVPPILaunchCmdGetAccountsType | Structure used by the VPN Panel to query the account from a VPPI
SysVPPILaunchCmdProgressPaintType | Structure used by the VPN Panel to show the progess dialog
SysVPPILaunchCmdPromptAndConfigureType | Structure used by the VPN Panel to request the VPPI to display a dialog
SysVPPILaunchCmdSetCurrentAccountType | Structure used by the VPN Panel to set the current account
SysVPPILaunchCmdWillPWPromptType | Structure used by the VPN Panel to determine is the VPPI will prompt for password
tagIOTANotificationEventType |
tagSndFileStreamData | Holds data about a sound file stream
tagSndFileStreamFileSpec | Descriptions of the stream file
tagSndFileStreamHsSoundCommandParam | SndFileStreamDeviceControl param when cmd == hsSoundLibCreatorID
ToneIdentifier | No definition
ToneItemType | Tone characteristics
UPNotificationEventType |
VMFontType | Font characteristics structure used to describe a font
VMFontUIRules | Font UI rules structure used for the font picker setting
VPNAccountType | VPN Account structure
vpnNotifyVPNLibTag |
webBrowserMinimalModeLaunchInfo |
webBrowserURLWithSvcIDLaunchInfo |
WUNotificationEventType |
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


_dataLinks Struct Reference

Detailed Description

Structure used for datalinks while sending /rcving data.

Data Fields

  • CharPtr data
  • ULong size

Field Documentation

CharPtr data

pointer to data

ULong size

size of data

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


_HelperServiceMMSDetailsType Struct Reference

Collaboration diagram for _HelperServiceMMSDetailsType:

[legend]

Detailed Description

Helpers of this Service Class send an MMS message.

"To" address(es) are passed in the 'pData' element of the main structure (HelperNotifyExecuteType)

The 'pDetails' struct member may optionally point to HelperServiceMMSDetailsType for this service class.

Data Fields

  • UInt16 version
  • Char * cc
  • Char * subject
  • Char * message
  • HelperServiceMMSObjectType * object
  • Char * bcc
  • Boolean justSend

Field Documentation

Char* bcc

IN: blind carbon copy address string or NULL -- will be duplicated by helper if necessary; multiple addresses are separated by semicolon (ex. "john@host.com; jane@host.com")

Char* cc

IN: carbon copy address string or NULL -- will be duplicated by helper if necessary; multiple addresses are separated by semicolon (ex. "john@host.com; jane@host.com")

Boolean justSend

IN: Set this to true to send without invoking any UI

Char* message

IN: initial message body string or NULL -- will be duplicated by helper if necessary (ex. "Lets discuss the helper API tomorrow.") Message will be put on first page.

HelperServiceMMSObjectType* object

IN: Head of Linked list of objects to send or NULL

Char* subject

IN: subject string or NULL -- will be duplicated by helper if necessary (ex. "helper API")

UInt16 version

This is currently version 1

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


_HelperServiceMMSObjectType Struct Reference

Collaboration diagram for _HelperServiceMMSObjectType:

[legend]

Detailed Description

Structure to hold the MMS object. This structure is part of the linked list which is pointed by the object member of HelperServiceMMSDetailsType

Data Fields

  • Int16 pageNum
  • Char * mimeType
  • MemPtr bufferP
  • UInt32 bufferLen
  • Char * tempFileName
  • Boolean isVFSFileName
  • Boolean freeTempFile
  • Char * name
  • _HelperServiceMMSObjectType * nextP

Field Documentation

UInt32 bufferLen

IN: Length of the buffer

MemPtr bufferP

IN: The object is stored in a buffer if this is non-NULL

Boolean freeTempFile

IN: If set, the file should be deleted by the helper application

Boolean isVFSFileName

IN: Is the file local or under VFS e.g Memory card?

Char* mimeType

IN: IANA Mime type for this object (compulsory!) The object may be passed in a buffer or via a file. Either set bufferP and bufferLen or set tempFileName

Char* name

IN: the name of the object as sent to us (maybe the filename)

struct _HelperServiceMMSObjectType* nextP

IN: Linked list pointer of objects to send.

Int16 pageNum

IN: page of message this content should appear on.

Char* tempFileName

IN: The temporary file its stored in if bufferP is NULL

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


_PalmPhotoCaptureParamV2 Struct Reference

Collaboration diagram for _PalmPhotoCaptureParamV2:

[legend]

Detailed Description

Photo/video image capture parameters.

The callback function allows the calling application to cancel the image capture operation. The user may cancel the operation by interacting with the capture application. New in v2.0.

Data Fields

  • PalmPhotoFileLocation fileLocation
  • PalmPhotoImageInfo imageInfo
  • PalmPhotoCaptureCallbackV2 captureCallback
  • void * userDataP

Field Documentation

PalmPhotoCaptureCallbackV2 captureCallback

IN: capture callback.

PalmPhotoFileLocation fileLocation

IN: file location of new file.

PalmPhotoImageInfo imageInfo

supported for video) IN: file information.

void* userDataP

IN: User data.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:33 2006 for Palm API Guide


_PalmPhotoCreateParam Struct Reference

Collaboration diagram for _PalmPhotoCreateParam:

[legend]

Detailed Description

Photo image create parameters.

Set imageInfo can determines the type of the file. To create a JPEG image, set imageInfo.fileFormat to palmPhotoJPEGFileFormat.

Data Fields

  • PalmPhotoFileLocation fileLocation
  • PalmPhotoImageInfo imageInfo

Field Documentation

PalmPhotoFileLocation fileLocation

IN: file location of new file.

PalmPhotoImageInfo imageInfo

IN: file information.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:33 2006 for Palm API Guide


_PalmPhotoDisplayParam Struct Reference

Detailed Description

Photo image display parameters.

The bounds might be ignored by the application. New in v2.0: If playing a video, winH and rect are ignored.

Data Fields

  • WinHandle winH
  • RectangleType rect
  • PalmPhotoDisplayCallback displayCallback
  • void * userDataP

Field Documentation

PalmPhotoDisplayCallback displayCallback

IN: display callback.

RectangleType rect

IN: Display rectangle.

void* userDataP

IN: User data.

WinHandle winH

IN: WinHandle.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:33 2006 for Palm API Guide


_PalmPhotoExtraInfo Struct Reference

Detailed Description

Photo image extra info parameters.

Gets extra information on an image.

Data Fields

  • PalmPhotoExtraInfoType infoType
  • UInt16 reserved
  • void * infoP
  • UInt32 infoSize

Field Documentation

void* infoP

OUT: Points to the information selected.

UInt32 infoSize

OUT: Size of the buffer pointed by infoP.

PalmPhotoExtraInfoType infoType

IN: Image info type.

UInt16 reserved

reserved for future use

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:33 2006 for Palm API Guide


_PalmPhotoFileLocation Struct Reference

Detailed Description

Photo file location.

This structure is used to open, create and query location information of an image.

Data Fields

  • PalmPhotoLocationType fileLocationType
  • UInt16 reserved
  • union {
    • struct {
      • Char name [dmDBNameLength]
      • UInt32 type
      • UInt32 creator
    • } StreamFile
    • struct {
      • Char name [PALM_PHOTO_MAX_PATH+1]
      • UInt16 volumeRef
      • UInt16 reserved
    • } VFSFile
    • struct {
      • void * bufferP
      • UInt32 bufferSize
    • } MemoryFile
  • } file

Field Documentation

void* bufferP

Buffer holding the image.

UInt32 bufferSize

Size of the buffer.

UInt32 creator

Creator of the stream.

union { ... } file

Image location.

PalmPhotoLocationType fileLocationType

File location type.

struct { ... } MemoryFile

File format: Memory

Char name[PALM_PHOTO_MAX_PATH+1]

File name on the device.

UInt16 reserved

reserved for future use

struct { ... } StreamFile

File format: stream

UInt32 type

Type of the stream.

struct { ... } VFSFile

File format: VFS

UInt16 volumeRef

Volume where the file is located.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:33 2006 for Palm API Guide


_PalmPhotoImageInfo Struct Reference

Detailed Description

Photo information.

This structure contains the basic image information.

Data Fields

  • UInt32 width
  • UInt32 height
  • UInt32 bitsPerPixel
  • UInt32 filesize
  • PalmPhotoFileFormat fileFormat
  • PalmPhotoQualityType imageQuality

Field Documentation

UInt32 bitsPerPixel

Color depth of the image.

PalmPhotoFileFormat fileFormat

File format, e.g., JPEG, GIF.

UInt32 filesize

File size, in bytes.

UInt32 height

Height in pixels of the image.

PalmPhotoQualityType imageQuality

Image quality.

UInt32 width

Width in pixels of the image.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:33 2006 for Palm API Guide


_PalmPhotoReadWriteParam Struct Reference

Detailed Description

Photo image manipulation param.

This parameter is used to set the callback for reading and writing data of an image. The imageFormat provides the user a way to convert images. For example, reading a JPEG image and setting imageFormat to RGB565 should convert the JPEG to RGB565.

Data Fields

  • PalmPhotoFileFormat imageFormat
  • UInt16 reserved
  • PalmPhotoReadWriteCallback rwCallback
  • void * userDataP

Field Documentation

PalmPhotoFileFormat imageFormat

IN: Memory file image format.

UInt16 reserved

reserved for future use

PalmPhotoReadWriteCallback rwCallback

IN: Read/Write callback.

void* userDataP

IN: User data.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:33 2006 for Palm API Guide


_PalmPhotoSelectionParam Struct Reference

Collaboration diagram for _PalmPhotoSelectionParam:

[legend]

Detailed Description

Photo selection dialog parameters.

This structure is used for the selection dialog and direct image selection. When using the PMPSelectImages API, selectionCount contains the maximum number of images that can be selected. If selectionCount is set to PALM_PHOTO_SELECT_ALL, the range would be [offset, end]. If albumID is set to PALM_PHOTO_ALBUM_ALL, all images can be selected.

NOTE: The API allocates memory inside of selectedImages. It is the caller's responsibility to free that memory via PalmPhotoFreeSelections().

Data Fields

  • UInt16 albumID
  • UInt16 reserved
  • UInt32 offset
  • Int32 selectionCount
  • PalmPhotoFilterCallback filterCallback
  • void * userDataP
  • PalmPhotoSelections selectedImages

Field Documentation

UInt16 albumID

IN: Album ID for selection.

PalmPhotoFilterCallback filterCallback

IN: Callback to filter the selections.

UInt32 offset

IN: Range start.

UInt16 reserved

reserved for future use

PalmPhotoSelections selectedImages

OUT: Struct containing handle array.

Int32 selectionCount

IN: Number of images to select.

void* userDataP

IN: User data to be passed during callback.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:34 2006 for Palm API Guide


_PalmPhotoSelections Struct Reference

Detailed Description

Photo selections.

This strucutre is used during image selections, either by using the PalmPhotoSelectDlg() function of the PalmPhotoSelect() function.

Data Fields

  • UInt32 imageCount
  • PalmPhotoHandle * imageH

Field Documentation

UInt32 imageCount

Number of images.

PalmPhotoHandle* imageH

Array of image handles.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:34 2006 for Palm API Guide


_pluginExtendedQueryParams Struct Reference

Detailed Description

Structure used for launch code MMPRO_PLUGIN_EXTENDED_QUERY_LAUNCHCODE.

Data Fields

  • int type
  • Char * MIMEtype
  • Char * fileExt
  • DmOpenRef db
  • Boolean supported
  • int numItems
  • char ** listNames
  • char ** listPtrs
  • ULong ** size
  • UInt32 ret
  • Char Unused [50]

Field Documentation

DmOpenRef db

[in]reference to open database for large memory allocations

Char* fileExt

[in] attachment file extention

char** listNames

[out] name of the attachment files

char** listPtrs

[out] attachments renders and ready to send

Char* MIMEtype

[in] attachment MIME type

int numItems

[out] number of items selected

UInt32 ret

[out] return code for error handling and special cases;

ULong** size

[out] size for each attachment

Boolean supported

[out] we support this extension

int type

[in] attachment type

Char Unused[50]

unused space for future releases

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:34 2006 for Palm API Guide


_pluginGetInfoParams Struct Reference

Detailed Description

Structure used for launch code MMPRO_PLUGIN_GET_INFO_LAUNCHCODE.

Data Fields

  • PluginInfo getInfo
  • UInt32 version
  • Boolean supportsSending
  • Boolean supportsReceiving
  • char ** listSendNames
  • UInt16 numSendTypes
  • Int16 numReceiveTypes
  • char ** listSendFileExt
  • char ** listReceiveFileExt
  • UInt32 * listMaxSizeExt
  • char ** listSendMIMEtypes
  • char ** listReceiveMIMEtypes
  • UInt32 * listMaxSizeMime
  • UInt32 ret
  • Char Unused [50]

Field Documentation

PluginInfo getInfo

[in] what plugin information needed.

UInt32* listMaxSizeExt

lout] list of max file size supported for each file ext.

UInt32* listMaxSizeMime

lout] list of max file size supported for each MIME type.

char** listReceiveFileExt

[out] list of supported file extensions it can read.

char** listReceiveMIMEtypes

[out] list of supported MIME types it can read.

char** listSendFileExt

[out] list of supported file extensions to Send.

char** listSendMIMEtypes

[out] list of supported MIME types to Send.

char** listSendNames

[out] list of names of the types. (suitable for listing in popup)

Int16 numReceiveTypes

[out] the number of types it can receive

UInt16 numSendTypes

[out] the number of types it can send (each one should appear in popup)

UInt32 ret

[out] return code for error handling and special cases;

Boolean supportsReceiving

[out] can view files passed to it.

Boolean supportsSending

[out] can provide data to be passed as an email attachment.

Char Unused[50]

unused space for future releases

UInt32 version

[out] plugin version.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:34 2006 for Palm API Guide


_pluginParams Struct Reference

Collaboration diagram for _pluginParams:

[legend]

Detailed Description

Structure used for launch code MMPRO_PLUGIN_RECEIVE_LAUNCHCODE.

Data Fields

  • ULong version
  • Char * MIMEtype
  • Char * fileExt
  • ULong size
  • CharPtr fname
  • CharPtr data
  • DmOpenRef db
  • UInt numDataLinks
  • dataLinks * moreData
  • UInt32 ret
  • Char Unused [50]

Field Documentation

CharPtr data

[in] the data

DmOpenRef db

[in] reference to open database for large memory allocations

Char* fileExt

[in] attachment file extention

CharPtr fname

[in] filename of attachment

Char* MIMEtype

[in] attachment MIME type

dataLinks* moreData

[in] ptr to data links

UInt numDataLinks

[in] number of data links

UInt32 ret

[out] return code for error handling and special cases;

ULong size

[in] size of data

Char Unused[50]

unused space for future releases

ULong version

[in] plugin version

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:34 2006 for Palm API Guide


_pluginQueryParams Struct Reference

Detailed Description

Structure used for launch code MMPRO_PLUGIN_QUERY_LAUNCHCODE.

Data Fields

  • Char * fileExt
  • Char * MIMEtype
  • DmOpenRef db
  • int numItems
  • UInt32 * itemSizes
  • char ** listItems
  • void ** itemDescriptors
  • UInt32 ret
  • Char Unused [50]

Field Documentation

DmOpenRef db

[in]reference to open database for large memory allocations

Char* fileExt

[in] file extention of list of files requested

void** itemDescriptors

[out] private descriptors defined/recognized by plugin. This memory will be freed by VersaMail

UInt32* itemSizes

[out] size of items

char** listItems

[out] the items

Char* MIMEtype

[in] MIME type of list of files requested

int numItems

[out] number of items of this type

UInt32 ret

[out] return code for error handling and special cases;

Char Unused[50]

unused space for future releases

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:34 2006 for Palm API Guide


_pluginSendParams Struct Reference

Collaboration diagram for _pluginSendParams:

[legend]

Detailed Description

Structure used for launch code MMPRO_PLUGIN_SEND_LAUNCHCODE.

Data Fields

  • Char * MIMEtype
  • Char * fileExt
  • DmOpenRef db
  • int selectedItem
  • void * selectedDescriptor
  • char * item
  • char * name
  • char * ptr
  • ULong size
  • UInt numDataLinks
  • dataLinks * moreData
  • UInt32 ret
  • Char Unused [50]

Field Documentation

DmOpenRef db

[in]reference to open database for large memory allocations

Char* fileExt

[in] attachment file extention

char* item

[in] the item selected

Char* MIMEtype

[in] attachment MIME type

dataLinks* moreData

[out] ptr to data links

char* name

[out] name of the attachment file

UInt numDataLinks

[out] number of data links

char* ptr

[out] attachment rendered and ready to send! this memory will be freed by MMPRO

UInt32 ret

[out] return code for error handling and special cases;

void* selectedDescriptor

[in] descriptor of item that was selected

int selectedItem

[in] item number that was selected

ULong size

[out] size of attachment above

Char Unused[50]

unused space for future releases

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:34 2006 for Palm API Guide


AddrCallerIDParamsType Struct Reference

Detailed Description

Parameter block for addrAppLaunchCmdCallerID.

Data Fields

  • Char * lookupString
  • Char * formatString
  • Char * resultString
  • Boolean(* callback )(void *)
  • void * ref
  • UInt32 uniqueID
  • UInt16 flags
  • UInt16 recordNum

Field Documentation

Boolean(* callback)(void *)

Call back; Returns true to stop execution

UInt16 flags

Flags associated with the called ID

Char* formatString

Format of the output string like AddrLookupParamsPtr->formatString Example ^name ( ^phonetypelabel ) might result in "David ( work )"

Char* lookupString

Must be only digits and include country code. Example: 14085551212

UInt16 recordNum

record number of the matching record.

void* ref

Reference that gets passed to callbackFunc

Char* resultString

Returned heap allocated string resultStringH;

UInt32 uniqueID

Unique ID of the matching record 0 if no match

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:35 2006 for Palm API Guide


AddrCreateNewRecordParamsType Struct Reference

Detailed Description

Contains data when launching phone book with create new record view.

Data Fields

  • Char * data
  • UInt8 field

Field Documentation

Char* data

Data to save (Null terminated string)

UInt8 field

Phone number, URL, or email address field number. They are defined in ViewForm.c as follows: define kAddrDBRecMobileFld 5 // phone3 define kAddrDBRecEMailFld 7 // phone5 define kAddrDBRecURLFld 14 // custom1 The values are based on the field definition in AddressDB.h.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:35 2006 for Palm API Guide


AddrDescriptor Struct Reference

Detailed Description

Item description here

Data Fields

  • UInt16 count

Field Documentation

UInt16 count

Length of list

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:35 2006 for Palm API Guide


Address Struct Reference

Detailed Description

This should probably be private to the library

Data Fields

  • AddressAppPhoneLabelType kind
  • char filler
  • UInt32 uniqueID
  • UInt16 phoneBookIndex
  • UInt16 count [3]
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:35 2006 for Palm API Guide


AddressAppRecord Struct Reference

Collaboration diagram for AddressAppRecord:

[legend]

Detailed Description

Item description here

Data Fields

  • MemHandle mData
  • UInt32 mID
  • Boolean mLocked
  • Int8 reserved1
  • AddressAppRecordHeader * mHeader

Field Documentation

Int8 reserved1

padding

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:35 2006 for Palm API Guide


AddressAppRecordHeader Struct Reference

Detailed Description

Item description here

Data Fields

  • UInt32 options
  • UInt32 flags
  • UInt8 companyOffset
  • char data
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:35 2006 for Palm API Guide


AddressType Struct Reference

Collaboration diagram for AddressType:

[legend]

Detailed Description

Item description here

Data Fields

  • UInt16 addressSize
  • Address address
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:35 2006 for Palm API Guide


AddrHsLookupUserDataType Struct Reference

Detailed Description

Structure that contains the data used for looking up user info in address book app

Data Fields

  • UInt16 version
  • Boolean matchFound
  • Boolean useMultiFilter

Field Documentation

Boolean matchFound

OUT: TRUE if ANY match was found. (i.e. 1 or more matches were found) FALSE if NO match was found.

Boolean useMultiFilter

IN: TRUE if lookup should use multifilter. FALSE if lookup should NOT use multifilter.

UInt16 version

IN: Version of the userData structure

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:35 2006 for Palm API Guide


AddrListLookupTypeGetParamsType Struct Reference

Detailed Description

Contains data used when launching address book for contact lookup.

Data Fields

  • UInt16 version
  • AddrListLookupTypeEnum type

Field Documentation

AddrListLookupTypeEnum type

OUT: The type of phone lookup that will occur if you do a lookup by listName.

UInt16 version

IN/OUT: Should always be 0...

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:35 2006 for Palm API Guide


AddrPhonebookAppParamsType Struct Reference

Detailed Description

Parameter block for addrAppLaunchCmdHsPhonebook.

Data Fields

  • Char * lookupStrP
  • Boolean activeCall
  • Boolean lookup
  • Char * newPhoneNum

Field Documentation

Boolean activeCall

Whether the active call icon should be usable or not... could change in a sublaunch when a call is dropped

Boolean lookup

True if this notification is for a lookup false if it is for a new contact

Char* lookupStrP

The lookup string that should be preloaded in the lookup field

Char* newPhoneNum

Phone number of the new contact.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:35 2006 for Palm API Guide


AddrPhotoCallerIDParamsType Struct Reference

Detailed Description

Support for addrAppNotificationPhotoCallerID

Data Fields

  • UInt16 recordNum
  • Coord xExtent
  • Coord yExtent
  • void * imageBits

Field Documentation

void* imageBits

Bits that represent the caller id image. image size returned in xExtent & yExtent

UInt16 recordNum

Record for which we want to get the picture id

Coord xExtent

Dimension of the photo required. Pass 0 to get max size.

Coord yExtent

Dimension of the photo required. Pass 0 to get max size.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:35 2006 for Palm API Guide


BGResult Struct Reference

Detailed Description

Structure containing Result of response for a protocol request.

Data Fields

  • UInt32 majorResult
  • UInt32 protocolErr
  • char protocolErrString [IBG_MAXBUFSZ]

Field Documentation

UInt32 majorResult

One of the above defined return values

UInt32 protocolErr

Any protocol specific error code, if any

char protocolErrString[IBG_MAXBUFSZ]

Any protocol err response from the server

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:35 2006 for Palm API Guide


BSSListStruct Struct Reference

Collaboration diagram for BSSListStruct:

[legend]

Detailed Description

BSS list.

This data structure is returned from a BSS scan. The count field indicates how many BSS structures are provide.

Data Fields

  • UInt32 count
  • NetBssInfoType BSS [1]
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:36 2006 for Palm API Guide


CamLibBitmapInfoTag Struct Reference

Detailed Description

Bitmap info structure for every format except PalmBMPV4. Data starts after the parameters.

Data Fields

  • UInt16 width
  • UInt16 height
  • UInt32 numBytes
  • UInt8 bitsPerPixel
  • UInt8 reserved0
  • UInt16 reserved1

Field Documentation

UInt8 bitsPerPixel

Number of bits per pixel.

UInt16 height

Height of the bitmap.

UInt32 numBytes

Number or Bytes to be streamed.

UInt8 reserved0

For packing.

UInt16 reserved1

For packing.

UInt16 width

Width of the bitmap.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:36 2006 for Palm API Guide


CamLibCaptureTag Struct Reference

Detailed Description

Capture settings structure. The callback is called with userDataP passed.

Data Fields

  • CamLibCaptureCallbackFunc * callbackP
  • void * userDataP

Field Documentation

CamLibCaptureCallbackFunc* callbackP

Callback function.

void* userDataP

User data pointer.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:36 2006 for Palm API Guide


CamLibColorSpaceTag Struct Reference

Detailed Description

Color Space structure.

Data Fields

  • Int32 value

Field Documentation

Int32 value

Value.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:36 2006 for Palm API Guide


CamLibSettingTag Struct Reference

Detailed Description

Settings Capabilities structure. For settings without manual values, only type is used.

Data Fields

  • UInt32 type
  • Int32 value
  • Int32 minValue
  • Int32 maxValue

Field Documentation

Int32 maxValue

Used for Get/Query only and is valid for manual value.

Int32 minValue

Used for Get/Query only and is valid for manual value.

UInt32 type

Setting type.

Int32 value

For manual settings only.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:36 2006 for Palm API Guide


CamLibStatusTag Struct Reference

Detailed Description

Container for the camera status kCamLibStatus*.

Data Fields

  • UInt32 status

Field Documentation

UInt32 status

Camera status

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:36 2006 for Palm API Guide


CamLibStreamTag Struct Reference

Detailed Description

Video stream structure. Used for capturing a video stream.

When used with WaitfForFram, bufP will contain the full frame buffer.

Data Fields

  • void * lock
  • void * bufP
  • UInt32 size
  • UInt32 frameTime
  • UInt32 frameNum

Field Documentation

void* bufP

Pointer to base of frame buffer content.

UInt32 frameNum

Number of frames (relative to start) in stream.

UInt32 frameTime

Time-stamp when frame was captured.

void* lock

Reserved.

UInt32 size

Size in bytes of frame buffer.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:36 2006 for Palm API Guide


Coordinate Struct Reference

Detailed Description

Container to store degree and minute of a coordinate

Data Fields

  • Int16 degree
  • Int16 minute
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:36 2006 for Palm API Guide


DevAppLaunchCmdGenericCallType Struct Reference

Detailed Description

For devAppLaunchCmdGenericCall.

Data Fields

  • UInt32 senderCreatorId
  • void * userDataP
  • UInt8 operation
  • UInt8 response

Field Documentation

UInt8 operation

IN: one of the sysAppLaunchGenericCallOp<operation> codes

UInt8 response

IN: set to 0; OUT: one of the sysAppLaunchGenericCallRet<response> codes, or 0 if not handled

UInt32 senderCreatorId

IN: the creator ID of the calling code resource

void* userDataP

IN: pointer to custom data (optional)

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:36 2006 for Palm API Guide


DialPnlDispatchDialParamsType Struct Reference

Detailed Description

Use with the function DispatchDial (UInt16 service, void* paramP)

Data Fields

  • UInt32 serviceID
  • void * dataP
  • Char * descriptionStr
  • UInt8 handled
  • Err err

Field Documentation

void* dataP

IN: Basic Data to send to the helper...

Char* descriptionStr

IN: Description of data to dial...

Err err

OUT: Err code returned...

UInt8 handled

OUT: Non-zero if handled

UInt32 serviceID

IN: The service type to dial...

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:36 2006 for Palm API Guide


DialPnlIsDialingAvailableParamsType Struct Reference

Detailed Description

Support for dialPnlLaunchCmd... commands

Data Fields

  • Boolean result
  • UInt8 _reserved0
  • const UInt32 * serviceIDsP
  • UInt16 numServices

Field Documentation

UInt8 _reserved0

IN: Reserved byte--MUST BE 0.

UInt16 numServices

IN: Num elements in service IDs array.

Boolean result

OUT: Space for result...

const UInt32* serviceIDsP

IN: Array of services to check...

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:36 2006 for Palm API Guide


HS_HTTPLibAppinfo_ Struct Reference

Detailed Description

cookie info

Data Fields

  • UInt32 appCreator
  • Int32 maxSockets
  • Int32 isForeground
  • UInt32 recvBufferSize
  • Char * cookieDBName
  • UInt32 cookieDBCreator
  • UInt32 cookieDBType
  • UInt16 cookieDBVersion
  • Int32 cookieMaxJarSize
  • Char * certDBName
  • UInt32 certDBType
  • UInt16 certDBVersion
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:36 2006 for Palm API Guide


HS_HTTPLibSplit_ Struct Reference

Detailed Description

structure for glueing

Data Fields

  • Char * s
  • Int32 len
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:36 2006 for Palm API Guide


HsBigButtonMappingType Struct Reference

Detailed Description

This is the structure of a single big button mapping...

Data Fields

  • UInt8 flags
  • UInt8 font
  • UInt16 gadgetID
  • UInt16 bitmapID
  • UInt16 stringID
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:36 2006 for Palm API Guide


HsBigButtonReourceType Struct Reference

Collaboration diagram for HsBigButtonReourceType:

[legend]

Detailed Description

This is the structure of a big button resource...

Data Fields

  • UInt16 version
  • HsBigButtonMappingType mapArr [0]
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:36 2006 for Palm API Guide


HsDialPrefsUSDialingRulesType Struct Reference

Detailed Description

HsDialPrefsUSDialingRulesType

Data Fields

  • UInt8 rulesEnabled
  • UInt8 _reserved0
  • UInt8 areaCodeCtl
  • UInt8 add1BeforeAreaCode
  • char autoAreaCode [hsDialPrefsAutoAreaCodeLength]
  • UInt8 prefix6DigitCtl
  • UInt8 prefix5DigitCtl
  • UInt8 prefix4DigitCtl
  • char auto6DigitPrefix [hsDialPrefs6DigitPrefixLength]
  • char auto5DigitPrefix [hsDialPrefs5DigitPrefixLength]
  • char auto4DigitPrefix [hsDialPrefs4DigitPrefixLength]

Field Documentation

UInt8 _reserved0

caller must set to 0 (zero) -- for byte alignment, and reserved for future use by the DialPrefs API

UInt8 add1BeforeAreaCode

[OUT] if non-zero, automatically add "1" in front of the area code of US/Canada numbers; if zero -- don't. Default is to add the "1" in front of US/Canada area codes.

UInt8 areaCodeCtl

[OUT] one of hsDialPrefsAddAreaCodeUnknown, hsDialPrefsAddAreaCodeNo, or hsDialPrefsAddAreaCodeYes; default is hsDialPrefsAddAreaCodeUnknown

char autoAreaCode[hsDialPrefsAutoAreaCodeLength]

[OUT] the "auto" area code digits to add to 7-digit numbers if areaCodeCtl is hsDialPrefsAddAreaCodeYes; ignore otherwise;

UInt8 rulesEnabled

[OUT] if non-zero, then these should be be applied; if zero -- don't apply.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:36 2006 for Palm API Guide


HsSndBufferData Struct Reference

Detailed Description

Holds sound buffer information.

When using the hsSndCmdPlay command in function HsSndFormatPlay, you should pass a pointer to a properly filled HsSndBufferData structure. This structure provides information about the buffer of coded audio data that is going to be processed and played.

Data Fields

  • UInt32 signature
  • UInt32 flags
  • UInt32 amplitude
  • void * buffer
  • UInt32 bufferSize
  • HsSndBufferProc progress_callback
  • void * progress_userdata
  • HsSndBufferProc completion_callback
  • void * completion_userdata
  • UInt32 controls
  • UInt32 reserved1
  • UInt32 reserved2

Field Documentation

UInt32 amplitude

Volume level for playback. (Valid range from 0 to hsSndAmplitude_unity.)

void* buffer

Pointer to beginning of coded audio data to process and/or play.

UInt32 bufferSize

Size in bytes of the buffer of coded audio data.

HsSndBufferProc completion_callback

When Not NULL, it will be invoked when buffer processing completed.

void* completion_userdata

Passed to completion_callback when invoked.

UInt32 controls

Compound field with repeat count and end delay controls. Use HsSndBufControl_Set* macros with this field. Repeat Field: valid range from 1 to 254, or hsSndBufControl_repeatForever (255). The processing of the buffer will be looped according to this number. When repeatForever is used, then termination should be done by returning an error code from the progress callback. Alternatively, for non-blocking playback, the caller may issue another "Play" call with the "Stop" command. This field is valid and non-zero when hsSndBufFlags_yesRepeat is set in the buffer flags, otherwise this field must be set to zero. A repeat value of 1 means play one time. Values of 2 and greater will perform the requested number of playbacks by looping on the same buffer data. Use HsSndBufControl_SetRepeat macro to set values in this field. endDelay fld: Valid range from 1 to 255, each unit is a 1/50th second delay. Use HsSndBufControl_SetEndDelay macro to set values in this field. This field is valid and non-zero when hsSndBufFlags_yesEndDelay is set in the buffer flags, otherwise this field must be set to zero.

UInt32 flags

Flags and status bits for the buffer. Use the hsSndBufferFlags_* symbols appropriately. Set any undefined or unused flags to zero.

HsSndBufferProc progress_callback

When Not NULL, is invoked at regular intervals. If progress_callback returns an error, then the play session terminates.

void* progress_userdata

Passed to progress_callback when invoked.

UInt32 reserved1

reserved, must set to zero

UInt32 reserved2

reserved, must set to zero

UInt32 signature

Always set to hsSndBufferData_Signature or error returned.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:36 2006 for Palm API Guide


HsSndPortInfo Struct Reference

Detailed Description

Holds sound port information.

Data Fields

  • UInt32 signature
  • UInt32 flags
  • HsSndPortID portID
  • Int16 minVol
  • Int16 maxVol
  • Int16 unityVol
  • Int16 stepVol
  • Int16 currentVol
  • Int16 currentPan
  • UInt16 stepDB
  • UInt16 boostDB
  • UInt16 reserved1
  • UInt16 reserved2

Field Documentation

UInt16 boostDB

How many dBs with boost = (boostDB >> 8) / (boostDB & 0x0F).

Int16 currentPan

Pan control (0 is midpoint pan between L and R) max pan = maxVol - minVol.

Int16 currentVol

Tracks current volume setting.

UInt32 flags

Control and information about port.

Int16 maxVol

Top value of the volume range.

Int16 minVol

Bottom value of the volume range.

HsSndPortID portID

Identifies the portID.

UInt16 reserved1

Reserved field, set to zero

UInt16 reserved2

Reserved field, set to zero

UInt32 signature

Always set to hsSndPortInfo_Signature.

UInt16 stepDB

How many dBs per step = (stepDB >> 8) / (stepDB & 0x0F).

Int16 stepVol

Step size for volume changes within vol range.

Int16 unityVol

Volume value when there is no gain or dampening.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:36 2006 for Palm API Guide


HtmlLibFormWidgetProc Struct Reference

Detailed Description

The following are necessary form widget creation/deletion routines that need to get set using HtmlLibSetFormWidgetProc. Please see sample code after looking at HtmlLibSetFormWidgetProc.

See also:
HtmlLibSetFormWidgetProc

Data Fields

  • NewControlProc * newControlProc
  • NewListProc * newListProc
  • NewFieldProc * newFieldProc
  • DeleteObjectProc * deleteObjectProc
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:36 2006 for Palm API Guide


LcdOverlayLibSettingTag Struct Reference

Detailed Description

Generic settings For settings without manual values, only type is used.

Data Fields

  • UInt32 type
  • Int32 value
  • Int32 minValue
  • Int32 maxValue

Field Documentation

Int32 maxValue

This value is used for Get/Query Only and is valid for Manual value

Int32 minValue

This value is used for Get/Query Only and is valid for Manual value

UInt32 type

For Manual, use constant below

Int32 value

For manual only

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:36 2006 for Palm API Guide


LocationDataTag Struct Reference

Collaboration diagram for LocationDataTag:

[legend]

Detailed Description

Location data format

Data Fields

  • Int16 uTC
  • DSTType dSTStart
  • DSTType dSTEnd
  • Int16 dSTAdjustmentInMinutes
  • CountryType country
  • UInt8 custom: 1
  • UInt8 reserved: 7
  • Char * name
  • PosType position
  • Char * note

Field Documentation

CountryType country

see Palm OS documentation for values

UInt8 custom

not used

Int16 dSTAdjustmentInMinutes

0 = DST not observed, 60 = observed.

DSTType dSTEnd

date/time when DST end

DSTType dSTStart

date/time when DST begins, e.g. 31 Oct 2am

Char* name

for db record type use name[]

Char* note

Note for each City

PosType position

Position (Longitude & Latitude) values

UInt8 reserved

not used

Int16 uTC

timezone

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:37 2006 for Palm API Guide


LocDBInfoTag Struct Reference

Detailed Description

Helpful struct for passing db info as an argument

Data Fields

  • Char * dbName
  • UInt32 dbCreatorID
  • UInt32 dbType
  • UInt16 dbCardNum

Field Documentation

UInt16 dbCardNum

cardNo where database resides

UInt32 dbCreatorID

creator of the database

Char* dbName

name of location database

UInt32 dbType

database type

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:37 2006 for Palm API Guide


LocDBRecordTag Struct Reference

Detailed Description

Location database record format

Data Fields

  • Int16 uTC
  • DSTType dSTStart
  • DSTType dSTEnd
  • Int16 dSTAdjustmentInMinutes
  • CountryType country
  • UInt8 custom: 1
  • UInt8 reserved: 7
  • Char name [0]

Field Documentation

CountryType country

Country. See Palm OS documentation for values

UInt8 custom

not used

Int16 dSTAdjustmentInMinutes

0 = DST not observed, 60 = observed.

DSTType dSTEnd

time when DST end

DSTType dSTStart

time when DST begins e.g. 2am

Char name[0]

LocationType uses Char* name

UInt8 reserved

not used

Int16 uTC

timezone

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:37 2006 for Palm API Guide


LocsLibNotifyDataTag Struct Reference

Collaboration diagram for LocsLibNotifyDataTag:

[legend]

Detailed Description

Helpful struct for passing notification info as an arg

Data Fields

  • Boolean showWaitDialogue
  • UInt32 notifyType
  • LocsLibNotifyLocsDataType locationData

Field Documentation

LocsLibNotifyLocsDataType locationData

The location data to broadcast.

UInt32 notifyType

One of the Locs lib notification type constants.

Boolean showWaitDialogue

If true, a "Please Wait" dialogue will be displayed while waiting for broadcast completion

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:38 2006 for Palm API Guide


LocsLibNotifyLocsDataTag Struct Reference

Collaboration diagram for LocsLibNotifyLocsDataTag:

[legend]

Detailed Description

Struct used to pass notification location data to interested apps

Data Fields

  • LocationType locationDataNew
  • const Char * locationNameOldP

Field Documentation

LocationType locationDataNew

new location data

const Char* locationNameOldP

name of old location

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:38 2006 for Palm API Guide


LocsLibSelLocsTag Struct Reference

Collaboration diagram for LocsLibSelLocsTag:

[legend]

Detailed Description

Container for the selected location in the location database

Data Fields

  • LocationType * locationP
  • UInt32 dirtySelections
  • Boolean needSelLoc
  • Boolean warnIfLocExists
  • Boolean noEditOnSelect
  • Boolean preSelect
  • Boolean sendChangeNotify
  • Boolean noAddToCustomDB
  • UInt8 numSelLocs
  • UInt8 reserved
  • Char ** selLocsListP

Field Documentation

UInt32 dirtySelections

indicates which selections were modified e.g.: the 1st selection, element 0, would be indicated by dirtySelections & kLocsLibSel01

LocationType* locationP

Location data of the location selected from the Add Sel list. Caller must allocate the memory.

Boolean needSelLoc

true if the caller wants a location name being chosen from the Add Sel list to be saved in the selLocsList.

Boolean noAddToCustomDB

true if the caller doesn't want the selected location to be added to the custom db.

Boolean noEditOnSelect

true if the caller wants the "Edit Location" dialogue to NOT be displayed after user selects a location; only applies to LocsLibLaunchSelDialogue().

UInt8 numSelLocs

Number of items in the selLocsList

Boolean preSelect

true if the caller wants the current location to be preselected in the Add Sel list; only applies to ADD/SEL location dialogue (shows master default list of locations).

UInt8 reserved

Reserved, not used

Char** selLocsListP

List of locations names that are "selected" and the caller needs to know if they are changed.

Boolean sendChangeNotify

true if the caller wants the selected location data to be broadcast to all registered apps; only applies to LocsLibLaunchSelDialogue().

Boolean warnIfLocExists

false if the caller doesn't want the user warned if selecting a location that already exists in the custom db.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:39 2006 for Palm API Guide


MailAddRecordAttachment Struct Reference

Detailed Description

Structure to add attachment in MailAddRecordParamsTypePlus.

Data Fields

  • char * attachType
  • char * attachDescription
  • char * attachFileName
  • union {
    • char * attachData
    • LocalID attachDBID
  • } data
  • UInt32 attachSize

Field Documentation

char* attachData

Pointer to attachment data

LocalID attachDBID

Currently not supported

char* attachDescription

Attachment description

char* attachFileName

FileName of attachment

UInt32 attachSize

Size of attachment

char* attachType

Mime Type of attachment

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:39 2006 for Palm API Guide


MailAddRecordParamsTypePlus Struct Reference

Collaboration diagram for MailAddRecordParamsTypePlus:

[legend]

Detailed Description

Structure to add a message + attachment passed with MMPRO_ADD_MESSAGE_WITH_ATTACHMENT Categories & MailAddRecordParamsType are defined in AppLaunchCmd.h.

Data Fields

  • MailAddRecordParamsType mainParams
  • UInt8 category
  • MailAddRecordAttachment attachments [MM_MAX_ATTACHMENTS]
  • Int16 numAttachments

Field Documentation

MailAddRecordAttachment attachments[MM_MAX_ATTACHMENTS]

Pointer to array of attachments

UInt8 category

Mail Category usually Oubox / Draft

MailAddRecordParamsType mainParams

Email data

Int16 numAttachments

No. of attachments

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:40 2006 for Palm API Guide


MMProAttachDataLinks Struct Reference

Detailed Description

Data links used in an attachment, used in MMProAttachStruct2.

Data Fields

  • CharPtr data
  • ULong size

Field Documentation

CharPtr data

Pointer to the data link

ULong size

Size of data link

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:40 2006 for Palm API Guide


MMProAttachStruct Struct Reference

Detailed Description

Structure for adding attachments in MMProLaunchStruct.

Data Fields

  • int type
  • char * attachName
  • char * attachment
  • unsigned long aSize

Field Documentation

unsigned long aSize

Size of attachment

char* attachment

Pointer to attachment data

char* attachName

Name of attachment

int type

Type of attachment

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:40 2006 for Palm API Guide


MMProAttachStruct2 Struct Reference

Collaboration diagram for MMProAttachStruct2:

[legend]

Detailed Description

Structure for adding attachments in MMProLaunchStruct2.

Data Fields

  • int type
  • char * attachName
  • char * attachment
  • unsigned long aSize
  • UInt numDataLinks
  • MMProAttachDataLinks * moreData

Field Documentation

unsigned long aSize

Size of attachment

char* attachment

Pointer to attachment data

char* attachName

Name of attachment

MMProAttachDataLinks* moreData

Array of data link(s)

UInt numDataLinks

No. of datalinks

int type

Type of attachment

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:40 2006 for Palm API Guide


MMProLaunchStruct Struct Reference

Collaboration diagram for MMProLaunchStruct:

[legend]

Detailed Description

Structure to add a message + attachment passed with MMPRO_LAUNCH_CODE.

Data Fields

  • Boolean interactive
  • char * to
  • char * cc
  • char * bcc
  • char * subject
  • char * body
  • int numAttach
  • MMProAttachStruct * attachments

Field Documentation

MMProAttachStruct* attachments

Array of attachment(s)

char* bcc

bcc field

char* body

body field

char* cc

cc field

Boolean interactive

Not used

int numAttach

Number of attachments

char* subject

subject field

char* to

To field

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:40 2006 for Palm API Guide


MMProLaunchStruct2 Struct Reference

Collaboration diagram for MMProLaunchStruct2:

[legend]

Detailed Description

Structure to add a message + attachment passed with MMPRO_LAUNCH_CODE.

Data Fields

  • Boolean interactive
  • char * to
  • char * cc
  • char * bcc
  • char * subject
  • char * body
  • int numAttach
  • MMProAttachStruct2 * attachments

Field Documentation

MMProAttachStruct2* attachments

Pointer to attachment array

char* bcc

bcc field

char* body

body field

char* cc

cc field

int numAttach

Number of attachments

char* subject

subject field

char* to

To field

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:41 2006 for Palm API Guide


NBSNotificationEventType Struct Reference

Detailed Description

Structure passed to the callbacks registered for incoming NBS notifications

Data Fields

  • UInt16 version
  • Boolean NBSdatagram
  • Boolean binary
  • void * headerP
  • UInt8 headerLen
  • Int8 reserved0
  • void * dataP
  • UInt8 dataLen
  • UInt8 refNum
  • UInt8 maxNum
  • UInt8 seqNum
  • Int8 reserved1
  • Int8 reserved1a
  • UInt32 srcPort
  • UInt32 dstPort
  • UInt32 msgID
  • char * senderP
  • UInt32 datetime
  • Int32 reserved2
  • Int32 reserved3

Field Documentation

Boolean binary

true if binary data

UInt8 dataLen

length of dataP

void* dataP

pointer to data body

UInt32 datetime

date/time stamp

UInt32 dstPort

destination port

UInt8 headerLen

length of headerP

void* headerP

pointer to raw header

UInt8 maxNum

max segment number 1-255

UInt32 msgID

SMS related fields ID into the SMS database to reference this message this ID is not gauranteed to be valid once the notification callback returns. Users should make a copy of the msg if they want to work on it after the callback returns.

Boolean NBSdatagram

helper fields flag if it is an NBS datagram

UInt8 refNum

NBS datagram fields NBS reference number

Int8 reserved0

padding

Int8 reserved1

padding

Int8 reserved1a

mo padding

Int32 reserved2

reserved

Int32 reserved3

reserved

char* senderP

sender number - null terminated

UInt8 seqNum

sequence number 1-255, no more than maxNum

UInt32 srcPort

source port

UInt16 version

version number to provide future backwards compatibility

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:41 2006 for Palm API Guide


Net80211DeviceInfo Struct Reference

Detailed Description

Device information concerning Hardware and Firmware information for the "adapter".

Revision information and product name data is returned.

Data Fields

  • UInt32 validFlags
  • UInt32 fwRev [2]
  • Int32 serialNumberSize
  • UInt8 serialNumber [kNetSerialNumberLength]
  • Char driverDate [kNetDriverDateLength]
  • Char fwName [kNetFWNameLength]

Field Documentation

Char driverDate[kNetDriverDateLength]

Driver date. Valid is (validFlags & 2) == 1.

Char fwName[kNetFWNameLength]

Firmware name. Valid is (validFlags & 4) == 1.

UInt32 fwRev[2]

Firmware revision. STA/BB (32 bits), PRI/MAC (32 bits). Valid is (validFlags & 1) == 1.

UInt8 serialNumber[kNetSerialNumberLength]

Serial number. Valid is (validFlags & 8) == 1.

Int32 serialNumberSize

Serial number size. Valid is (validFlags & 8) == 1.

UInt32 validFlags

Bit flag indicating validity of fields.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:41 2006 for Palm API Guide


NetBssInfoType Struct Reference

Detailed Description

Structure to hold BSS Info data.

Accessing the BSS scan info returned via the network interface via the following structure needs to be verified for each specific toolchain and compiler. It has been verified with the combination of ADS V1.2 and CW 8.3. The data format has been done to be as toolchain/architecture/alignment independent as possible, however, if a different combination other than the one listed is used, the format must be verified. The macro's defined above can also be used to access the individual entities of the returned BSS scan data.

Data Fields

  • UInt32 validFlag
  • UInt8 bssMacAddr [BSSINFO_MAC_ADDR_SIZE]
  • UInt32 bssSsidLength
  • UInt8 bssSsid [BSSINFO_SSID_SIZE]
  • UInt32 bssWepEnabled
  • Int32 bssRssi
  • UInt32 bssNetworkType
  • UInt32 bssBeaconPeriod
  • UInt32 bssAtimWindow
  • UInt32 bssDSFreq
  • UInt32 bssHopPattern
  • UInt32 bssHopSet
  • UInt32 bssHopDwell
  • UInt32 bssNetworkMode
  • UInt8 bssSupportedRates [BSSINFO_SUPPORTED_RATES_SIZE]
  • UInt32 bssChannelId
  • Int32 bssANL
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:41 2006 for Palm API Guide


NetMasterClientEventInfoType Struct Reference

Collaboration diagram for NetMasterClientEventInfoType:

[legend]

Detailed Description

This structure is passed as the 'detailsP' of the notification.

See also:
Palm OS Notification Manager

Data Fields

  • UInt16 version
  • NetMasterClientEventEnum eventID
  • union {
    • void * genericEventDataP
    • NetMasterClientEventVPNConnInstallType * vpnConnInstallP
  • } eventData
  • UInt32 inReserved1
  • UInt32 inReserved2
  • UInt32 inReserved3
  • UInt32 inReserved4

Field Documentation

union { ... } eventData

Data corresponding to the event ID

NetMasterClientEventEnum eventID

Event ID

void* genericEventDataP

genericEventDataP is for the convenience of the internal code only.

UInt32 inReserved1

Reserved values; Set to 0 by NetMaster library

UInt32 inReserved2

Reserved values; Set to 0 by NetMaster library

UInt32 inReserved3

Reserved values; Set to 0 by NetMaster library

UInt32 inReserved4

Reserved values; Set to 0 by NetMaster library

UInt16 version

Version of this structure -- all future versions MUST define backward compatible Event structures. NetMaster Library sets this to netMasterClientCurrentEventVersion at the time the library was built.

NetMasterClientEventVPNConnInstallType* vpnConnInstallP

For netMasterClientEventVPNConnInstall

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:42 2006 for Palm API Guide


NetMasterClientEventVPNConnInstallType Struct Reference

Detailed Description

Data block for netMasterClientEventVPNConnInstall.

Data Fields

  • Char defaultConnProfileName [cncProfileNameSize]
  • UInt32 inReserved1
  • UInt32 inReserved2
  • Char vpnConnProfileOverrideName [cncProfileNameSize]

Field Documentation

Char defaultConnProfileName[cncProfileNameSize]

Name of the connection that NetLib will use unless the VPN client overrides it by setting vpnConnProfileOverrideName to a non-empty connection name string. Watch out for the case where the user inadvertently selected the VPN connection name itself as the connection name for the network profile. VPN vendors that choose to override this connection name, will likely wish to save this connection name so that their destination connection.

UInt32 inReserved1

set to zero by this lib

UInt32 inReserved2

set to zero by this lib

Char vpnConnProfileOverrideName[cncProfileNameSize]

The VPN vendor may override the default connection name that NetLib will use by setting this field to a non-empty string -- this string MUST be a valid connection name that presently exists in the connection panel!

If the VPN vendor presently does *not* wish to override the default connection (based on user settings in the VPN vendor's configuration UI), the VPN vendor should leave this field alone (don't modify it in any way in this case to avoid conflicts with other VPN vendor that may be currently installed on the same device).

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:42 2006 for Palm API Guide


NetPrefFallbackInfoType Struct Reference

Detailed Description

Fallback info structure.

Data Fields

  • NetPrefFallbackAlgrorithmEnum algorithm
  • NetPrefFallbackStatusFlagsType fbStatusFlags
  • union {
    • struct NetPrefMutexStickyFBAStatusTypeTag {
      • NetPrefMutexStickyFBAStatusEnum statusID
    • } mutexSticky
  • } status

Field Documentation

NetPrefFallbackAlgrorithmEnum algorithm

Fallback algorithm ID.

IMPORTANT: when changing fallback algorithm, the caller MUST zero-initialize the rest of the NetPrefFallbackInfoType structure.

NetPrefFallbackStatusFlagsType fbStatusFlags

Fallback algoritm status. There is a field here for every fallback algorithm that requires status to be maintained.

THIS STATUS STRUCTURE IS FOR USE BY THE HANDSPRING NetMaster LIBRARY ONLY!!!

struct { ... } ::NetPrefMutexStickyFBAStatusTypeTag mutexSticky

Status for netPrefFallbackAlgrorithmMutexSticky fallback algorithm

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:42 2006 for Palm API Guide


NetPrefGPRSQOSType Struct Reference

Detailed Description

NetPrefGPRSQOSType -- GPRS Quality Of Service (QOS) info.

Data Fields

  • Int8 qosReqPrecedenceClass
  • Int8 qosReqDelayClass
  • Int8 qosReqReliabilityClass
  • Int8 qosReqPeakThruClass
  • Int8 qosReqMeanThruClass
  • Int8 qosMinPrecedenceClass
  • Int8 qosMinDelayClass
  • Int8 qosMinReliabilityClass
  • Int8 qosMinPeakThruClass
  • Int8 qosMinMeanThruClass
  • Int8 pdpDataCompression
  • Int8 pdpHeaderCompression
  • UInt32 reserved [4]

Field Documentation

Int8 pdpDataCompression

see ccsmCS_PDPDataComprField

Int8 pdpHeaderCompression

see ccsmCS_PDPHeaderComprField

Int8 qosMinDelayClass

see ccsmCS_QOSMinDelayClassField

Int8 qosMinMeanThruClass

see ccsmCS_QOSMinMeanThruClassField

Int8 qosMinPeakThruClass

see ccsmCS_QOSMinPeakThruClassField

Int8 qosMinPrecedenceClass

see ccsmCS_QOSMinPrecClassField

Int8 qosMinReliabilityClass

see ccsmCS_QOSMinRelClassField

Int8 qosReqDelayClass

see ccsmCS_QOSReqDelayClassField

Int8 qosReqMeanThruClass

see ccsmCS_QOSReqMeanThruClassField

Int8 qosReqPeakThruClass

see ccsmCS_QOSReqPeakThruClassField

Int8 qosReqPrecedenceClass

see ccsmCS_QOSReqPrecClassField

Int8 qosReqReliabilityClass

see ccsmCS_QOSReqRelClassField

UInt32 reserved[4]

Reserved by Handspring -- init to zero

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:42 2006 for Palm API Guide


NetServicesProfile Struct Reference

Detailed Description

Profile entries for SmartConnect.

Data Fields

  • Char profileName [32]
  • UInt8 SSID [32]
  • UInt32 ssidLength
  • UInt16 ipAllocType
  • UInt16 preambleType
  • UInt16 keyIndex
  • UInt16 authentication
  • UInt32 opMode
  • UInt32 channel
  • UInt32 reqIP
  • UInt32 ipMask
  • UInt32 ipGateway
  • UInt32 ipPrimaryDNS
  • UInt32 ipSecondaryDNS
  • UInt8 wep [4][16]
  • UInt8 dhcpRequestDNS

Field Documentation

UInt16 authentication

OPEN / 64 bit / 128 bit.

UInt32 channel

DS Channel. Only used for ad-hoc.

UInt8 dhcpRequestDNS

0 = DNS info static, 1 = DNS from DHCP.

UInt16 ipAllocType

DHCP/STATIC/IPIPA.

UInt32 ipGateway

IP gateway.

UInt32 ipMask

IP mask.

UInt32 ipPrimaryDNS

IP primary DNS.

UInt32 ipSecondaryDNS

IP secondary DNS.

UInt16 keyIndex

WEP key index. Only valid if wep active.

UInt32 opMode

BSS, IBSS.

UInt16 preambleType

Long or short preamble.

Char profileName[32]

ASCII string - profile reference.

UInt32 reqIP

Static IP address.

UInt8 SSID[32]

SSID associated with this profile.

UInt32 ssidLength

Length of bytes of the SSID.

UInt8 wep[4][16]

WEP keys. Up to 5 keys.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:42 2006 for Palm API Guide


NetServicesProfileInfo Struct Reference

Detailed Description

Data returned from NetServicesProfileGetInfo.

Data Fields

  • UInt16 profileRev
  • UInt16 numProfiles
  • UInt16 profileEntrySize

Field Documentation

UInt16 numProfiles

Number of profiles contained in the database.

UInt16 profileEntrySize

Size of each individual profile entry.

UInt16 profileRev

Revision of profile database.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:42 2006 for Palm API Guide


NetServicesProfileOrder Struct Reference

Detailed Description

Priority order to smart connect.

Provided for ease of reference.

Data Fields

  • UInt16 order [MAX_ACTIVE_PROFILES+1]

Field Documentation

UInt16 order[MAX_ACTIVE_PROFILES+1]

Array of order for each active profiles.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:42 2006 for Palm API Guide


NetServicesProfileV1 Struct Reference

Detailed Description

Profile entries version 1.

Data Fields

  • Char profileName [32]
  • UInt8 SSID [32]
  • UInt32 ssidLength
  • UInt16 ipAllocType
  • UInt16 preambleType
  • UInt16 keyIndex
  • UInt16 authentication
  • UInt32 opMode
  • UInt32 channel
  • UInt32 reqIP
  • UInt32 ipMask
  • UInt32 ipGateway
  • UInt32 ipPrimaryDNS
  • UInt32 ipSecondaryDNS
  • UInt8 wep [4][16]
  • UInt8 dhcpRequestDNS

Field Documentation

UInt16 authentication

OPEN / 64 bit / 128 bit.

UInt32 channel

DS Channel. Only used for ad-hoc.

UInt8 dhcpRequestDNS

0 = DNS info static, 1 = DNS from DHCP.

UInt16 ipAllocType

DHCP/STATIC/IPIPA.

UInt32 ipGateway

IP gateway.

UInt32 ipMask

IP mask.

UInt32 ipPrimaryDNS

IP primary DNS.

UInt32 ipSecondaryDNS

IP secondary DNS.

UInt16 keyIndex

WEP key index. Only valid if wep active.

UInt32 opMode

BSS, IBSS.

UInt16 preambleType

Long or short preamble.

Char profileName[32]

ASCII string - profile reference.

UInt32 reqIP

Static IP address.

UInt8 SSID[32]

SSID associated with this profile.

UInt32 ssidLength

Length of bytes of the SSID.

UInt8 wep[4][16]

WEP keys. Up to 5 keys.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:42 2006 for Palm API Guide


NetSSID Struct Reference

Detailed Description

Structure used to get and set the current SSID for the driver (not the Network interface).

Data Fields

  • UInt32 ssidLength
  • UInt8 ssid [32]
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:42 2006 for Palm API Guide


NetWepKey Struct Reference

Detailed Description

Structure used to set the wep keys.

The API's do not return the wep keys via a query.

Data Fields

  • UInt32 keyIndex
  • UInt32 keyLength
  • UInt8 key [16]
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:42 2006 for Palm API Guide


NetworkDeviceQueryData Struct Reference

Collaboration diagram for NetworkDeviceQueryData:

[legend]

Detailed Description

Structure to hold network query data.

Data Fields

  • UInt32 qid
  • void * InfoBuffer
  • UInt32 InfoBufferLength
  • UInt32 InfoSize
  • UInt32 InfoSizeRequired
  • NetworkDeviceQueryData * linkP

Field Documentation

struct NetworkDeviceQueryData* linkP

Added a link pointer. This is required if the driver needs to provide an intermediate buffer space as a translation process.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:42 2006 for Palm API Guide


PalmAudioAACDecParamType Struct Reference

Detailed Description

AAC decoding parameters.

Data Fields

  • UInt32 fileFormat
  • union {
    • void * ascP
    • void * esdsP
  • } u
  • void * frameP
  • UInt32 frameSize
  • UInt32 sampleRate

Field Documentation

void* ascP

Parameter block for MP4A

void* esdsP

Parameter block for RAW

UInt32 fileFormat

RAW, ADTS, ADIF, MP4A and LATM

void* frameP

First AAC frame

UInt32 frameSize

Frame size

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:42 2006 for Palm API Guide


PalmAudioAACParamType Struct Reference

Detailed Description

AAC format parameters.

Data Fields

  • UInt32 bitRate
  • UInt32 sampleRate
  • UInt32 sampleWidth
  • UInt32 profile

Field Documentation

UInt32 bitRate

Bits per second.

UInt32 profile

Profile used if any.

UInt32 sampleRate

Sample rate (44100, 32000...).

UInt32 sampleWidth

Sample width (mono/stereo).

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:42 2006 for Palm API Guide


PalmAudioADPCMParamType Struct Reference

Detailed Description

IMA-ADPCM format parameters.

Data Fields

  • UInt32 sampleRate
  • UInt32 sampleWidth
  • UInt32 blockSize

Field Documentation

UInt32 blockSize

Block Size.

UInt32 sampleRate

Sample rate (44100, 32000...).

UInt32 sampleWidth

Sample width (mono/stereo).

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:42 2006 for Palm API Guide


PalmAudioMP2ParamType Struct Reference

Detailed Description

MPEG-1 audio decoding parameters.

Data Fields

  • UInt32 avgBytesPerSec
  • UInt32 bitsPerSample
  • UInt32 channels
  • UInt32 sampleRate
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:42 2006 for Palm API Guide


PalmAudioPCMParamType Struct Reference

Detailed Description

PCM format parameters.

Data Fields

  • UInt32 sampleRate
  • UInt32 sampleType
  • UInt32 sampleWidth

Field Documentation

UInt32 sampleRate

Sample rate (44100, 32000...).

UInt32 sampleType

Sample type (use the one one from Sound Manager).

UInt32 sampleWidth

Sample width (mono/stereo).

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:42 2006 for Palm API Guide


PalmAudioPlaybackNotifyEventTypeTag Struct Reference

Detailed Description

Audio playback notification structure.

Structure that is sent as part of notifyDetailsP when a kPalmAudioPlaybackNotifyEvent is thrown.

Data Fields

  • UInt32 version
  • PalmAudioPlaybackActionCodeType actionCode
  • void * dataP

Field Documentation

PalmAudioPlaybackActionCodeType actionCode

Action code.

void* dataP

Data for action code, currently NULL.

UInt32 version

Version.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:42 2006 for Palm API Guide


PalmFileFormatParamType Struct Reference

Detailed Description

File format parameters.

Data Fields

  • UInt32 fileLocationType
  • FileRef vfsFileRef
  • FileHand streamFileHandle

Field Documentation

UInt32 fileLocationType

File location type.

FileHand streamFileHandle

File Handle for File Stream type.

FileRef vfsFileRef

File Reference for VFS type.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:43 2006 for Palm API Guide


PalmImageBMPParamType Struct Reference

Detailed Description

BMP format parameters.

Data Fields

  • UInt32 xPixelsPerMeter
  • UInt32 yPixelsPerMeter
  • UInt32 colorUsed
  • UInt32 colorImportant
  • UInt32 compression

Field Documentation

UInt32 colorImportant

Number of color indices actually required. 0 = all colors required.

UInt32 colorUsed

Number of color indices actually used.

UInt32 compression

Bitmap compression.

UInt32 xPixelsPerMeter

Horizontal resolution.

UInt32 yPixelsPerMeter

Vertical resolution.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:43 2006 for Palm API Guide


PalmImageGIFFrameParamType Struct Reference

Detailed Description

GIF frame parameters.

Each GIF frame contains more info than a simple palette and image buffer.

Data Fields

  • UInt32 leftPosition
  • UInt32 topPosition
  • UInt32 imageWidth
  • UInt32 imageHeight
  • UInt32 localColorBits
  • UInt32 hasLocalColorTable
  • UInt32 isInterlaced
  • UInt32 hasTransparentColor
  • UInt32 transparentColorIndex
  • UInt32 disposalMethod
  • UInt32 delayTime
  • UInt8 localColorTable [256 *3]
  • UInt32 imageDataSize
  • UInt8 * imageDataP

Field Documentation

UInt32 delayTime

Delay for the current image.

UInt32 disposalMethod

Disposal method. (Refer to GIF standard)

UInt32 hasLocalColorTable

1 if has local color table, 0 otherwise.

UInt32 hasTransparentColor

1 if has transparency, 0 otherwise.

UInt8* imageDataP

Raw Image.

UInt32 imageDataSize

Size of the image buffer.

UInt32 imageHeight

Image height.

UInt32 imageWidth

Image width.

UInt32 isInterlaced

1 if interlaced, 0 otherwise.

UInt32 leftPosition

Left position of the image.

UInt32 localColorBits

Number of bits for the local color table.

UInt8 localColorTable[256 *3]

Local color table.

UInt32 topPosition

Top posistion of the image.

UInt32 transparentColorIndex

Transparency color index.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:43 2006 for Palm API Guide


PalmImageINDEXParamType Struct Reference

Detailed Description

Index image parameters.

Data Fields

  • UInt32 width
  • UInt32 height
  • UInt32 rowByte
  • UInt32 endianess
  • UInt32 colorBits
  • UInt8 * colorTable
  • UInt8 * imageDataP

Field Documentation

UInt32 colorBits

Number of bits for the color table.

UInt8* colorTable

Color table. Should have the size 4*2^(colorBits).

UInt32 endianess

Big Endian, Little Endian.

UInt32 height

Height of the image.

UInt8* imageDataP

Raw Image data.

UInt32 rowByte

Rowbyte of the image.

UInt32 width

Width of the image.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:43 2006 for Palm API Guide


PalmImageJPEGEncodeParamType Struct Reference

Detailed Description

JPEG format encoding parameters.

Data Fields

  • UInt32 quality
  • UInt32 restartInterval
  • UInt32 JPEGMode
  • UInt32 subSampling

Field Documentation

UInt32 JPEGMode

Baseline/Progressive...

UInt32 quality

JPEG quality between 0 and 100.

UInt32 restartInterval

Number of restart intervals.

UInt32 subSampling

SubSampling YCbCr (444, 422, 411).

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:43 2006 for Palm API Guide


PalmImageParamType Struct Reference

Detailed Description

RAW image format parameters.

Data Fields

  • UInt32 width
  • UInt32 height
  • UInt32 rowByte
  • UInt32 endianess

Field Documentation

UInt32 endianess

Big Endian, Little Endian.

UInt32 height

Height of the image.

UInt32 rowByte

Rowbyte of the image.

UInt32 width

Width of the image.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:43 2006 for Palm API Guide


PalmImagePlanarType Struct Reference

Detailed Description

Planar image structure, passed during EncodeDecode.

Data Fields

  • UInt32 width
  • UInt32 height
  • void * planeP [MAX_PLANE_COUNT]
  • UInt32 planeWidth [MAX_PLANE_COUNT]
  • UInt32 planeCount

Field Documentation

UInt32 height

Height of the image.

UInt32 planeCount

Number of planes used.

void* planeP[MAX_PLANE_COUNT]

Image planes.

UInt32 planeWidth[MAX_PLANE_COUNT]

Width of each plane.

UInt32 width

Width of the image.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:43 2006 for Palm API Guide


PalmVideoAVCCustomGetDecodedFrameType Struct Reference

Collaboration diagram for PalmVideoAVCCustomGetDecodedFrameType:

[legend]

Detailed Description

AVC/H264 Custom Control API structure for getting a decoded frame.

Data Fields

  • PalmImagePlanarType planarData
  • Int32 framesReady
  • UInt16 picWidth
  • UInt16 picWidthCropped
  • UInt16 picHeight
  • UInt16 picHeightCropped
  • UInt16 stride
  • UInt32 compositionTimestamp
  • double compositionTime

Field Documentation

double compositionTime

time describing moment in time decoded data to be played back

UInt32 compositionTimestamp

timestamp moment in time decoded data to be played back

UInt16 picHeight

Ht of lum. plane in pixels

UInt16 picHeightCropped

height of cropped lum. plane in pixels

UInt16 picWidth

width of lum. plane in pixels

UInt16 picWidthCropped

Width of cropped lum. plane in pixels

UInt16 stride

offset from start of one line of from to start of next

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:43 2006 for Palm API Guide


PalmVideoAVCCustomGetInfoType Struct Reference

Detailed Description

AVC/H264 Custom Control API structure for GetInfo about frame.

Data Fields

  • UInt16 frameWidth
  • UInt16 frameHeight
  • UInt16 frameWidthCropped
  • UInt16 frameHeightCropped
  • UInt16 horizontalOffset
  • UInt16 verticalOffset
  • UInt32 chromaFormat

Field Documentation

UInt32 chromaFormat

Chroma format, only YUV420 for now

UInt16 frameHeight

Ht of lum. plane in pixels

UInt16 frameHeightCropped

height of cropped lum. plane in pixels

UInt16 frameWidth

width of lum. plane in pixels

UInt16 frameWidthCropped

Width of cropped lum. plane in pixels

UInt16 horizontalOffset

Horizontal offset of cropped lum. plane

UInt16 verticalOffset

Vertical offset of cropped lum. plane

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:43 2006 for Palm API Guide


PalmVideoAVCCustomSetCropModeType Struct Reference

Detailed Description

AVC/H264 Custom Control API structure for getting a decoded frame.

Data Fields

  • Boolean bCroppedMode

Field Documentation

Boolean bCroppedMode

TRUE - output cropped size, FALSE - full size

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:43 2006 for Palm API Guide


PalmVideoAVCDecodeParamType Struct Reference

Detailed Description

AVC/H264 video format decoding parameters.

Data Fields

  • UInt8 * NALUnit
  • UInt32 NALUnitSize
  • UInt32 compositionTimestamp
  • double compositionTime
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:43 2006 for Palm API Guide


PalmVideoAVCOutputBufferType Struct Reference

Detailed Description

AVC/H264 video format decoding parameters.

Data Fields

  • Int32 framesReady

Field Documentation

Int32 framesReady

No. of avail. decoded frames

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:43 2006 for Palm API Guide


PalmVideoMPEG1DecodeParamType Struct Reference

Detailed Description

MPEG-1 video decoding parameters.

Data Fields

  • UInt32 width
  • UInt32 height
  • UInt32 skipBFrames

Field Documentation

UInt32 height

Height.

UInt32 skipBFrames

B Frame are very time consuming. If True skip B-Frames.

UInt32 width

Width.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:43 2006 for Palm API Guide


PalmVideoMPEG4DecodeParamType Struct Reference

Detailed Description

MPEG-4 video format decoding parameters.

Data Fields

  • UInt32 profile
  • UInt32 volWidth
  • UInt32 volHeight

Field Documentation

UInt32 profile

Profile used if any.

UInt32 volHeight

Video Object Layer width.

UInt32 volWidth

Video Object Layer width.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:43 2006 for Palm API Guide


PalmVideoMPEG4EncodeParamType Struct Reference

Detailed Description

MPEG-4 video format encoding parameters.

Data Fields

  • UInt32 profile
  • UInt32 volWidth
  • UInt32 volHeight
  • UInt32 keyFrame
  • UInt32 frameRate
  • UInt32 bitRate
  • UInt32 algorithm
  • UInt32 IVOPQuantization
  • UInt32 VOVOLVersionID
  • UInt32 searchRange

Field Documentation

UInt32 algorithm

MV_FAST, SEA...

UInt32 bitRate

Bit rate target.

UInt32 frameRate

Number of frames per second.

UInt32 IVOPQuantization

Quantization step in I-VOP frames.

UInt32 keyFrame

Number of P-Frames between two I-Frames.

UInt32 profile

Profile used if any.

UInt32 searchRange

Motion search range (in pixels).

UInt32 volHeight

Video Object Layer height.

UInt32 volWidth

Video Object Layer width.

UInt32 VOVOLVersionID

Version ID for VO & VOL header.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:44 2006 for Palm API Guide


ParsedInfo Struct Reference

Detailed Description

Holds parsed item information.

Given a message, or list of messages, this structure gives the locations of all parsed items.

Data Fields

  • UInt16 parsedType
  • UInt16 startLocation
  • UInt16 itemLength
  • UInt16 msgNumber
  • UInt16 color
  • UInt16 nameLength
  • UInt32 miscData

Field Documentation

UInt16 color

used to store the font color (for custom hyperlinks)

UInt16 itemLength

the character length of the parsed data we found

UInt32 miscData

used now to store left indentation and other info. Adapt as needed.

UInt16 msgNumber

when parsing a list of message, this is the message number, otherwise 0

UInt16 nameLength

used to store the length of the link name (for custom hyperlinks)

UInt16 parsedType

what kind of data did we find?

UInt16 startLocation

the starting location of the parsed data we found

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:44 2006 for Palm API Guide


ParsedInfoList Struct Reference

Collaboration diagram for ParsedInfoList:

[legend]

Detailed Description

Holds the list of parsed item information.

Data Fields

  • UInt16 size
  • UInt16 maxSize
  • ParsedInfo info [1]

Field Documentation

ParsedInfo info[1]

parsing info follows

UInt16 maxSize

maximum number of items that can be added without resizing

UInt16 size

how many items did we find in the text?

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:44 2006 for Palm API Guide


PhnCdmaSystemInfoType Struct Reference

Detailed Description

CDMA System info

Data Fields

  • UInt16 sid
  • UInt16 nid
  • UInt8 bandClass
  • UInt16 chNum
  • UInt8 wsCode
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:44 2006 for Palm API Guide


PhnConnectionType Struct Reference

Detailed Description

Phone connection info

Data Fields

  • PhnConnectionID id
  • PhnConnectStateType state
  • PhoneServiceClassType service
  • Boolean incoming
  • Boolean multiparty
  • PhnAddressHandle address
  • DWord owner
  • Int16 lineNumber
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:44 2006 for Palm API Guide


PhnEventType Struct Reference

Detailed Description

Phone Event Structure

Data Fields

  • UInt8 eventType
  • Boolean acknowledge
  • UInt16 connectionID
  • UInt16 launchCode
  • Ptr launchParams
  • PhnEventType::Data data

Data Structures

  • union Data

Field Documentation

UInt8 eventType

PhnEventCode

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:44 2006 for Palm API Guide


PhnGPRSPDPContextListNodeType Struct Reference

Collaboration diagram for PhnGPRSPDPContextListNodeType:

[legend]

Detailed Description

This is a list node that is returened when we retreive the current list of PDP contexts stored on the device

Data Fields

  • PhnGPRSPDPContextType type
  • PhnGPRSPDPContextListNodeType * nextP
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:44 2006 for Palm API Guide


PhnGPRSPDPContextType Struct Reference

Detailed Description

Used when we get a list of context that are currently stored on the radio.

Data Fields

  • UInt16 contextId
  • PhnGPRSPDPType pdpType
  • char * apn
  • char * pdpAddr
  • UInt16 pdpDataCompression
  • UInt16 pdpHdrCompression

Field Documentation

UInt16 pdpDataCompression

0 means OFF, 1 means ON

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:44 2006 for Palm API Guide


PhnIOTAPhnDlsLockType Struct Reference

Detailed Description

Holds lock state of user's ability to change the download server URL address.

Data Fields

  • Boolean iota_ph_dls_lock
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:44 2006 for Palm API Guide


PhnLibLengthInfoType Struct Reference

Detailed Description

SMS length information

Note:
For CDMA, this can be used to retrieve the SMS/EMS limits. length = max segment length. size = max EMS length

Data Fields

  • UInt16 size
  • Boolean substitution
  • UInt16 length
  • UInt16 segmentCount
  • Boolean requestSmsInfo

Field Documentation

UInt16 length

total length of message

Boolean requestSmsInfo

unused

UInt16 segmentCount

number of segments used

UInt16 size

unused

Boolean substitution

Substitute characters if needed (GSM ONLY)

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:44 2006 for Palm API Guide


PhnLineStateType Struct Reference

Detailed Description

Line State

Data Fields

  • UInt16 version
  • UInt16 size
  • Boolean activeLine
  • Boolean divertIndicator
  • Boolean voiceMailIndicator
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:44 2006 for Palm API Guide


PhnMMIEntryType Struct Reference

Detailed Description

MMI Decode struct.

Data Fields

  • UInt16 size
  • PhnMMIActionCode actionCode
  • PhnMMIServiceCode serviceCode
  • Boolean sendHit
  • char text [kMaxMMISequenceLen+1]
  • union {
    • struct {
      • char number [kMaxPhoneNumberLen+1]
      • PhnTeleserviceType type
      • UInt16 time
    • } mmiForwarding
    • struct {
      • PhnTeleserviceType type
      • char pwd [maxPasswordLen+1]
    • } mmiBarring
    • struct {
      • PhnTeleserviceType type
    • } mmiCallWaiting
    • struct {
      • char oldPwd [maxPasswordLen+1]
      • char newPwd [maxPasswordLen+1]
      • char repeatNewPwd [maxPasswordLen+1]
    • } mmiPassword
    • struct {
      • PhnCallControlType action
      • PhnConnectionID id
    • } mmiCallControl
    • struct {
      • char name [kMaxPhoneNumberLen+1]
      • char number [kMaxPhoneNumberLen+1]
      • GSMDialCLIRMode mode
    • } mmiPhoneNumber
  • } data
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:44 2006 for Palm API Guide


PhnMMIResultType Struct Reference

Detailed Description

MMI result struct.

Data Fields

  • UInt16 size
  • PhnMMIServiceCode serviceCode
  • union {
    • struct {
      • Boolean enabled
      • char number [kMaxPhoneNumberLen+1]
      • PhnTeleserviceType type
      • UInt16 time
    • } mmiForwarding
    • struct {
      • Boolean enabled
      • PhnTeleserviceType type
    • } mmiBarring
    • struct {
      • Boolean enabled
      • PhnTeleserviceType type
    • } mmiCallWaiting
    • struct {
      • Boolean enabled
    • } mmiCallerID
    • struct {
      • GSMCLIRDisplayStatus displayStatus
      • PhnCLIRStatus subscriptionStatus
    • } mmiNumberSent
    • struct {
      • Boolean enabled
    • } mmiColp
    • struct {
      • Boolean enabled
    • } mmiColr
    • struct {
      • char imei [kMaxImeiLen+1]
    • } mmiIMEI
  • } data
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:44 2006 for Palm API Guide


PhnOneXStatus Struct Reference

Detailed Description

This is now deprecated. It is only implemented to maintain backwards compatibility Currently, the only user is NetMaster and the Phone App

Data Fields

  • PhnOneXProtRevType oneXStatusPRev
  • PhnPacketDataSessionType pdSessionStatus
  • PhnMIPSessionType mipSessionType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:44 2006 for Palm API Guide


PhnOperatorListType Struct Reference

Detailed Description

Operator list

Data Fields

  • short count
  • PhnOperatorType opData [1]
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:44 2006 for Palm API Guide


PhnPDPList Struct Reference

Detailed Description

None of the PDP strings (like service string, dial string, passwords etc.) require null terminator and no need to count null terminator for the length.

PhnPDPList structure lists status of all the packet data profile slots

Data Fields

  • Boolean idx0_set
  • Boolean idx1_set
  • Boolean idx2_set
  • Boolean idx3_set
  • Boolean idx4_set
  • Boolean idx5_set
  • Boolean idx6_set
  • Boolean idx7_set
  • Boolean idx_RSVD8_set
  • Boolean idx_RSVD9_set
  • Boolean qnc_set
  • Boolean active_idx_set
  • UInt8 active_idx
  • UInt8 idx0_uid [phnPDPUidLen]
  • UInt8 idx1_uid [phnPDPUidLen]
  • UInt8 idx2_uid [phnPDPUidLen]
  • UInt8 idx3_uid [phnPDPUidLen]
  • UInt8 idx4_uid [phnPDPUidLen]
  • UInt8 idx5_uid [phnPDPUidLen]
  • UInt8 idx6_uid [phnPDPUidLen]
  • UInt8 idx7_uid [phnPDPUidLen]
  • UInt8 idx_rsvd8_uid [phnPDPUidLen]
  • UInt8 idx_rsvd9_uid [phnPDPUidLen]
  • UInt8 qnc_uid [phnPDPUidLen]
  • UInt8 num_stand_pdp_idxs
  • UInt8 first_stand_pdp_idx
  • UInt8 num_def_pdp_idxs
  • UInt8 first_def_pdp_idx
  • UInt8 num_tmp_pdp_idxs
  • UInt8 first_tmp_pdp_idx

Field Documentation

UInt8 active_idx

Indication of which index is currently the active index in the modem if ACTIVE_IDX_SET.

Boolean active_idx_set

Boolean indicating if there is currently an active index set in the modem.

UInt8 first_def_pdp_idx

IF NUM_DEF_PDP_IDXS is greater than zero, indicates the first default PDP index (assumes set of all default PDP indexes are sequential).

UInt8 first_stand_pdp_idx

IF NUM_STAND_PDP_IDXS is greater than zero, indicates the first standard PDP index (assumes set of all standard PDP indexes are sequential).

UInt8 first_tmp_pdp_idx

IF NUM_TMP_PDP_IDXS is greater than zero, indicates the first default PDP index (assumes set of all default PDP indexes are sequential).

Boolean idx0_set

Boolean indicating if index contains a valid PDP in the modem.

UInt8 idx0_uid[phnPDPUidLen]

The Unique ID for the PDP stored in index if index is set.

Boolean idx1_set

Boolean indicating if index contains a valid PDP in the modem.

UInt8 idx1_uid[phnPDPUidLen]

The Unique ID for the PDP stored in index if index is set.

Boolean idx2_set

Boolean indicating if index contains a valid PDP in the modem.

UInt8 idx2_uid[phnPDPUidLen]

The Unique ID for the PDP stored in index if index is set.

Boolean idx3_set

Boolean indicating if index contains a valid PDP in the modem.

UInt8 idx3_uid[phnPDPUidLen]

The Unique ID for the PDP stored in index if index is set.

Boolean idx4_set

Boolean indicating if index contains a valid PDP in the modem.

UInt8 idx4_uid[phnPDPUidLen]

The Unique ID for the PDP stored in index if index is set.

Boolean idx5_set

Boolean indicating if index contains a valid PDP in the modem.

UInt8 idx5_uid[phnPDPUidLen]

The Unique ID for the PDP stored in index if index is set.

Boolean idx6_set

Boolean indicating if index contains a valid PDP in the modem.

UInt8 idx6_uid[phnPDPUidLen]

The Unique ID for the PDP stored in index if index is set.

Boolean idx7_set

Boolean indicating if index contains a valid PDP in the modem.

UInt8 idx7_uid[phnPDPUidLen]

The Unique ID for the PDP stored in index if index is set.

Boolean idx_RSVD8_set

Reserved field.

UInt8 idx_rsvd8_uid[phnPDPUidLen]

Reserved field.

Boolean idx_RSVD9_set

Reserved field.

UInt8 idx_rsvd9_uid[phnPDPUidLen]

Reserved field.

UInt8 num_def_pdp_idxs

The number of default PDPs in the modem that cannot be modified by an IOTA session.

UInt8 num_stand_pdp_idxs

The number of standard PDPs in the modem.

UInt8 num_tmp_pdp_idxs

The Unique ID for the QNC profile stored in the modem.

Boolean qnc_set

Boolean indicating if a valid QNC profile is stored in the modem.

UInt8 qnc_uid[phnPDPUidLen]

The Unique ID for the QNC profile stored in the modem.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:45 2006 for Palm API Guide


PhnPDPPayload Struct Reference

Detailed Description

Packet data profile payload

Data Fields

  • UInt8 uid [phnPDPUidLen]
  • Boolean restrict_nai
  • UInt8 nai_length
  • UInt8 nai [phnMaxNAILen]
  • Boolean restrict_mn_aaa_ss
  • Boolean stored_mn_aaa_ss
  • UInt8 mn_aaa_ss_length
  • UInt8 mn_aaa_ss [phnMaxMNAAASharedSecretLen]
  • Boolean restrict_mn_ha_ss
  • UInt8 mn_ha_ss_length
  • UInt8 mn_ha_ss [phnMaxMNHASharedSecretLen]
  • Boolean restrict_mn_aaa_spi
  • Boolean set_mn_aaa_spi
  • DWord mn_aaa_spi
  • Boolean restrict_mn_ha_spi
  • Boolean set_mn_ha_spi
  • DWord mn_ha_spi
  • Boolean restrict_rev_tunnel_pref
  • Boolean rev_tunnel_pref
  • Boolean restrict_home_addr
  • DWord home_addr
  • Boolean restrict_ha_addr
  • DWord prim_ha_addr
  • DWord sec_ha_addr
  • UInt8 svc_str_length
  • UInt8 svc_str [phnMaxSvcStrLen]
  • UInt8 dial_str_length
  • UInt8 dial_str [phnMaxDialStrLen]
  • Boolean dns_server_assigned
  • DWord prim_dns_addr
  • DWord sec_dns_addr
  • PhnPDPConnectionType connection_type
  • PhnPDPService pdp_services

Field Documentation

PhnPDPConnectionType connection_type

Connection type of the PDP

UInt8 dial_str[phnMaxDialStrLen]

The dial string for this PDP.

UInt8 dial_str_length

The length of the dial string for this PDP.

Boolean dns_server_assigned

Boolean indicating if specific DNS server IP addresses are assigned for this PDP.

DWord home_addr

The home IP address of the modem for this PDP. An address of 0.0.0.0 indicates the IP address will be dynamically assigned by the PDSN for Mobile IP and Simple IP.

DWord mn_aaa_spi

Integer value of the SPI for MN-AAA authentication for this PDP.

UInt8 mn_aaa_ss[phnMaxMNAAASharedSecretLen]

Text/binary string of the MN-AAA shared secret parameter stored in the modem for this PDP.

UInt8 mn_aaa_ss_length

Length of the MN-AAA shared secret parameter for this PDP if the STORE_MN_AAA_SS field is set to FALSE. Maximum length shall be 16.

DWord mn_ha_spi

Integer value of the SPI for MN-HA authentication parameter for this PDP.

UInt8 mn_ha_ss[phnMaxMNHASharedSecretLen]

Text/binary string of the MN-HA shared secret parameter stored in the modem for this PDP.

UInt8 mn_ha_ss_length

Length of the MN-HA shared secret parameter stored in the modem for this PDP. Maximum length shall be 16.

UInt8 nai[phnMaxNAILen]

The user NAI character string in ASCII representation.

UInt8 nai_length

The number of characters in the NAI.

PhnPDPService pdp_services

Services for which this PDP should be used

DWord prim_dns_addr

The Primary DNS server IP address for this PDP if the DNS_SERVER_ASSIGNED field is set to TRUE.

DWord prim_ha_addr

The Primary Home Agent IP address for this PDP

Boolean restrict_ha_addr

Boolean indicating if the Home Agent IP address fields are restricted from being read from this PDP index. None of the following Home Agent IP address fields will contain valid data if set to TRUE.

Boolean restrict_home_addr

Boolean indicating if the modem's Home Address setting is restricted from being read from this PDP index. The HOME_ADDR field will not contain valid data if set to TRUE.

Boolean restrict_mn_aaa_spi

Boolean indicating if the SPI for MN-AAA authentication field is restricted from being read from this PDP index. None of the following SPI for MN-AAA authentication fields will contain valid data if set to TRUE.

Boolean restrict_mn_aaa_ss

Boolean indicating if the MN-AAA shared secret field is restricted from being read from this PDP index. None of the following MN-AAA shared secret fields will contain valid data if set to TRUE.

Boolean restrict_mn_ha_spi

Boolean indicating if the SPI for MN-HA authentication field is restricted from being read from this PDP index. None of the following SPI for MN-AAA authentication fields will contain valid data if set to TRUE.

Boolean restrict_mn_ha_ss

Boolean indicating if the MN-HA shared secret field is restricted from being read from this PDP index. None of the following MN-HA shared secret fields will contain valid data if set to TRUE.

Boolean restrict_nai

Boolean indicating if the NAI field is restricted from being read from this PDP index. None of the following NAI fields will contain valid data if set to TRUE.

Boolean restrict_rev_tunnel_pref

Boolean indicating if the reverse tunnel setting is restricted from being read from this PDP index. The REV_TUNNEL_PREF field will not contain valid data if set to TRUE.

Boolean rev_tunnel_pref

Boolean indicating if reverse tunnel is used for this PDP.

DWord sec_dns_addr

The Secondary DNS server IP address for this PDP if the DNS_SERVER_ASSIGNED field is set to TRUE.

DWord sec_ha_addr

The Secondary Home Agent IP address for this PDP

Boolean set_mn_aaa_spi

Boolean indicating if the SPI for MN-AAA authentication is set for this PDP

Boolean set_mn_ha_spi

Boolean indicating if the SPI for MN-HA authentication is set for this PDP.

Boolean stored_mn_aaa_ss

Boolean indicating if the MN-AAA shared secret parameter is stored with this PDP profile.

UInt8 svc_str[phnMaxSvcStrLen]

Text string of the service string for this PDP.

UInt8 svc_str_length

The length of the service string for this PDP.

UInt8 uid[phnPDPUidLen]

The binary UID for this PDP.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:45 2006 for Palm API Guide


PhnRadioStateType Struct Reference

Detailed Description

Radio state

Data Fields

  • UInt16 version
  • UInt32 size
  • UInt16 maxConnections
  • Boolean alsSupported
  • Int16 activeLineNumber

Field Documentation

Boolean alsSupported

GSM only feature. if False activeLineNumber should always be 1

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:45 2006 for Palm API Guide


PhnRingingInfoType Struct Reference

Detailed Description

Item description here

Data Fields

  • PhnRingingProfileType profiles [kSliderPositions]
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:45 2006 for Palm API Guide


PhnRoamPrefInfoType Struct Reference

Detailed Description

CDMA Roam Preferences

Data Fields

  • Boolean roamCallGuardEnable
  • Boolean roamRingerEnable
  • UInt8 roamRingerID
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:45 2006 for Palm API Guide


PhnSMSParams Struct Reference

Detailed Description

Struct that is sent when a new sms message event id - Unique id oldStatus - newStatus -

version - Version number of the struct size - Size of the struct msgType - Indicates if message should be discarded or replaced msgClass - Indicates msg class msgInd - True if msg contains an indicator msg indicator.store - True = store msg; False = may delete msg indicator.activate - True then activate indicator; False = deactivate indicator indicator.indType - Type of indicator to display trasactionID - timeStamp - Time in seconds serviceCenterNumber- Service Center Number senderNumber - Number of sender callbackAddress - CallBack number destPort - sourcePort -

Data Fields

  • UInt32 id
  • UInt8 oldStatus
  • UInt8 newStatus
  • UInt16 version
  • UInt16 size
  • PhnSMSType msgType
  • PhnSMSClass msgClass
  • Boolean moveRequested
  • Boolean msgInd
  • struct {
    • Boolean store
    • Boolean activate
    • PhnMsgBoxType indType
  • } indicator
  • UInt8 trasactionID
  • UInt32 timeStamp
  • char serviceCenterNumber [kMaxPhoneNumberLen+1]
  • char senderNumber [kMaxPhoneNumberLen+1]
  • char callbackAddress [kMaxPhoneNumberLen+1]
  • Int32 destPort
  • Int32 sourcePort
  • UInt16 networkMsgId
  • UInt8 priority
  • UInt8 privacy
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:45 2006 for Palm API Guide


PhnSMSPrefType Struct Reference

Detailed Description

CDMA SMS Preference ?

Data Fields

  • Boolean audioAlertEnable
  • Boolean confirmDeletion
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:45 2006 for Palm API Guide


PhoneAppLaunchCmdCallerIDLookupType Struct Reference

Detailed Description

Contains data used by phoneAppLaunchCmdCallerIDLookup

Data Fields

  • Char * numberP
  • Char * nameP

Field Documentation

Char* nameP

if not NULL, the view manager will pass this data block to the view once the view has been opened

Char* numberP

the view type to display be applied; if zero -- don't apply.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:45 2006 for Palm API Guide


PhoneAppLaunchCmdDialType Struct Reference

Detailed Description

Contains the data used by Phone app launch command dial.

Data Fields

  • UInt8 version
  • Boolean confirm
  • Char * name
  • Char * number
  • Char * extraDigits
  • UInt32 failLaunchCreator
  • UInt16 failLaunchCode
  • void * failLaunchParams
  • UInt16 dialMethod

Field Documentation

Boolean confirm

confirm before dialing.

UInt16 dialMethod

Method to use to dial the phone number See PhoneAppDialMethodEnum.

Char* extraDigits

optional

UInt16 failLaunchCode

launch code to use when relaunching

UInt32 failLaunchCreator

app to relaunch if dialling fails

void* failLaunchParams

params to use when relaunching

Char* name

optional

Char* number

optional

UInt8 version

version number, set to one

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:45 2006 for Palm API Guide


PhoneAppLaunchCmdGetALSLineNumberType Struct Reference

Detailed Description

Data structure that goes with phoneAppLaunchCmdGetALSLineNumber launch cmd

Data Fields

  • UInt8 lineNumber

Field Documentation

UInt8 lineNumber

ALS Line number

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:45 2006 for Palm API Guide


PhoneAppLaunchCmdGetDialPrefFlagType Struct Reference

Detailed Description

Contains data used by PhoneAppLaunchCmdGetDialPref

Data Fields

  • Boolean displayDialPrefs

Field Documentation

Boolean displayDialPrefs

If true Dial Preferences option is made available

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:45 2006 for Palm API Guide


PhoneAppLaunchCmdSendDTMFToneType Struct Reference

Detailed Description

Contains data used by PhoneAppLaunchCmdSendDTMFTone.

Data Fields

  • char tone
  • Boolean repeated

Field Documentation

Boolean repeated

true if the character was on autoRepeat

char tone

the key that was pressed to trigger the launch cmd

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:45 2006 for Palm API Guide


PhoneAppLaunchCmdSetWallpaperType Struct Reference

Collaboration diagram for PhoneAppLaunchCmdSetWallpaperType:

[legend]

Detailed Description

Contains data used by PhoneAppLaunchCmdSetWallpaper.

Data Fields

  • UInt32 wallpaperUID
  • PalmPhotoFileLocation wallpaperLocation

Field Documentation

PalmPhotoFileLocation wallpaperLocation

path to image

UInt32 wallpaperUID

OBSOLETE

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:46 2006 for Palm API Guide


PmBroadcastNewMsgCountNotifyParamType Struct Reference

Detailed Description

Param structure for pmNotifyBroadcastNewMsgCount notifications.

Data Fields

  • UInt32 helperServiceClass
  • UInt16 msgCount
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:46 2006 for Palm API Guide


PmConnectorNotifyDataType Struct Reference

Detailed Description

Container for the notification details.

Data Fields

  • UInt32 serialPortId
  • UInt32 deviceClass
  • UInt32 athenaDeviceCreatorCode
  • UInt32 reserved1
  • UInt32 reserved2
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:46 2006 for Palm API Guide


PmGetNewMsgCountNotifyParamType Struct Reference

Detailed Description

Param structure for pmNotifyGetNewMsgCountFromHelper notifications.

Data Fields

  • UInt32 helperServiceClass
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:46 2006 for Palm API Guide


PmSysGadgetBbutMappingType Struct Reference

Detailed Description

This is the structure of a single big button mapping...

Data Fields

  • UInt8 flags
  • UInt8 font
  • UInt16 gadgetID
  • UInt16 bitmapID
  • UInt16 stringID
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:46 2006 for Palm API Guide


PmSysGadgetBbutResourceType Struct Reference

Collaboration diagram for PmSysGadgetBbutResourceType:

[legend]

Detailed Description

This is the structure of a big button resource...

Data Fields

  • UInt16 version
  • PmSysGadgetBbutMappingType mapArr [0]
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:46 2006 for Palm API Guide


PosType Struct Reference

Collaboration diagram for PosType:

[legend]

Detailed Description

Container to store longitude and latitude of a specific location

Data Fields

  • Coordinate latitude
  • Coordinate longitude
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:47 2006 for Palm API Guide


SndCodecCustomControlType Struct Reference

Detailed Description

Holds Custom Control type information for the Extended Sound Manager.

This structure is used to set/get values specific to a codec. Note that if this custom control comes from a 68K app, it's the responsibility of the 68K app to flip and align the fields of the structure correctly. The fields are defined as being in little-endian format.

Data Fields

  • UInt32 apiCreator
  • UInt32 apiSelector
  • void * valueP
  • UInt16 * valueLenP

Field Documentation

UInt32 apiCreator

Codec creator. (codecDriverIMAADPCM...)

UInt32 apiSelector

Codec selector. (codecIMAADPCMSetBlockSize...)

UInt16* valueLenP

Size of the parameters to be passed to the codec.

void* valueP

Pointer to the parameters to be passed to the codec.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:47 2006 for Palm API Guide


SoundPreference Struct Reference

Collaboration diagram for SoundPreference:

[legend]

Detailed Description

Structure containing all the Sound Preference data.

Data Fields

  • SoundPreference::_tonePrefs tonePrefs
  • ToneVolume soundOnVolume
  • Boolean soundOnVibrate
  • Boolean soundOffVibrate

Data Structures

  • union _tonePrefs

Field Documentation

Boolean soundOffVibrate

No definition.

Boolean soundOnVibrate

No definition.

ToneVolume soundOnVolume

Volume of tone

union SoundPreference::_tonePrefs tonePrefs

union of various sound preferencesHolds data for various Sound Prefs

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:47 2006 for Palm API Guide


SoundPreference::_tonePrefs Union Reference

Collaboration diagram for SoundPreference::_tonePrefs:

[legend]

Detailed Description

union of various sound preferences

Data Fields

  • SoundPreferenceIM imSoundPrefs
  • SoundPreferencePhone phoneSoundPrefs
  • SoundPreferenceEmail emailSoundPrefs
  • SoundPreferenceCalendar calendarSoundPrefs
  • SoundPreferenceSMS smsSoundPrefs
  • SoundPreferenceMMS mmsSoundPrefs
  • SoundPreferenceNetworkSounds networkSoundPrefs

Field Documentation

SoundPreferenceCalendar calendarSoundPrefs

No definition.

SoundPreferenceEmail emailSoundPrefs

No definition.

SoundPreferenceIM imSoundPrefs

No definition.

SoundPreferenceMMS mmsSoundPrefs

No definition.

SoundPreferenceNetworkSounds networkSoundPrefs

No definition.

SoundPreferencePhone phoneSoundPrefs

No definition.

SoundPreferenceSMS smsSoundPrefs

No definition.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:48 2006 for Palm API Guide


SoundPreferenceCalendar Struct Reference

Collaboration diagram for SoundPreferenceCalendar:

[legend]

Detailed Description

Structure for Calendar Sound Pref.

Data Fields

  • ToneIdentifier alarmTone
  • ToneIdentifier reminderTone
  • TonePlayNumberTimes playSoundTimes
  • TonePlayNumberTimes repeatAlarmTimes
  • ToneRepeatInterval repeatInterval
  • UInt16 presetTime
  • ToneTimeUnit presetTimeUnit
  • Boolean alarmPreset

Field Documentation

Boolean alarmPreset

Preset alarm if true

ToneIdentifier alarmTone

Tone used for alarm

TonePlayNumberTimes playSoundTimes

Number of times tone should be played

UInt16 presetTime

Alarm preset time

ToneTimeUnit presetTimeUnit

Alarm preset time unit (minute, hour, day)

ToneIdentifier reminderTone

Tone used for event reminder

TonePlayNumberTimes repeatAlarmTimes

Number of time alarm should be repeated

ToneRepeatInterval repeatInterval

Alarm repeat interval

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:48 2006 for Palm API Guide


SoundPreferenceEmail Struct Reference

Collaboration diagram for SoundPreferenceEmail:

[legend]

Detailed Description

Structure for Email Sound Pref.

Data Fields

  • ToneIdentifier alertTone
  • Boolean newMailAlert

Field Documentation

ToneIdentifier alertTone

Tone used for new email alert

Boolean newMailAlert

Play tone if true

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:49 2006 for Palm API Guide


SoundPreferenceIM Struct Reference

Collaboration diagram for SoundPreferenceIM:

[legend]

Detailed Description

Structure for IM Sound Pref.

Data Fields

  • ToneIdentifier chatTone
  • ToneIdentifier messageTone

Field Documentation

ToneIdentifier chatTone

Tone used for chatting

ToneIdentifier messageTone

Tone used for messaging

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:49 2006 for Palm API Guide


SoundPreferenceMMS Struct Reference

Collaboration diagram for SoundPreferenceMMS:

[legend]

Detailed Description

Structure for MMS Sound Pref.

Data Fields

  • ToneIdentifier messageTone

Field Documentation

ToneIdentifier messageTone

Tone used when MMS arrives

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:49 2006 for Palm API Guide


SoundPreferenceNetworkSounds Struct Reference

Detailed Description

Structure for network related sounds.

Data Fields

  • Boolean signalFadedTone
  • Boolean eriStatusTone
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:49 2006 for Palm API Guide


SoundPreferencePhone Struct Reference

Collaboration diagram for SoundPreferencePhone:

[legend]

Detailed Description

Structure for Phone Sound Pref.

Data Fields

  • ToneIdentifier unknownCallerTone
  • ToneIdentifier knownCallerTone
  • ToneIdentifier roamingTone
  • ToneIdentifier voicemailTone
  • Boolean serviceTone

Field Documentation

ToneIdentifier knownCallerTone

Tone used when caller is known

ToneIdentifier roamingTone

Tone used when roaming

Boolean serviceTone

No definition.

ToneIdentifier unknownCallerTone

Tone used when caller is unknown

ToneIdentifier voicemailTone

Tone used for incoming voicemail

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:50 2006 for Palm API Guide


SoundPreferenceSMS Struct Reference

Collaboration diagram for SoundPreferenceSMS:

[legend]

Detailed Description

Structure for SMS Sound Pref.

Data Fields

  • ToneIdentifier messageTone
  • Boolean privacy
  • Boolean msgAlert
  • Boolean rcptAlert

Field Documentation

ToneIdentifier messageTone

Tone used for SMS

Boolean msgAlert

If true, alert when new SMS arrives

Boolean privacy

No definition.

Boolean rcptAlert

If true, alert when recipient receives SMS

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:50 2006 for Palm API Guide


SoundPrefsLaunchCmdParamType Struct Reference

Detailed Description

Contains data used by SoundPrefsLaunchCmd.

Data Fields

  • SoundPrefsView launchView

Field Documentation

SoundPrefsView launchView

Launch to the tones/volume view.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:50 2006 for Palm API Guide


SysVPPILaunchCmdClearPWCacheType Struct Reference

Detailed Description

Structure used by the VPN Panel to clear the password cache.

Data Fields

  • Err errOut

Field Documentation

Err errOut

Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:50 2006 for Palm API Guide


SysVPPILaunchCmdDeleteAccountType Struct Reference

Collaboration diagram for SysVPPILaunchCmdDeleteAccountType:

[legend]

Detailed Description

Structure used by the VPN Panel to delete an account.

Data Fields

  • VPNAccountType account
  • Err err

Field Documentation

VPNAccountType account

Account to delete.

Err err

Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:50 2006 for Palm API Guide


SysVPPILaunchCmdEditAccountType Struct Reference

Collaboration diagram for SysVPPILaunchCmdEditAccountType:

[legend]

Detailed Description

Structure used by the VPN Panel to edit an account.

Data Fields

  • Boolean useWizardUI
  • VPNAccountType account
  • Err err
  • Boolean useSavedAccount
  • Boolean dirtyBit

Field Documentation

VPNAccountType account

Account edited or created.

Boolean dirtyBit

Whether any account settings have been changed.

Err err

Return error.

Boolean useSavedAccount

Whether the account information is temporary (for saved state) or permanent.

Boolean useWizardUI

Whether to show Previous & Done buttons instead of OK & Cancel buttons.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:51 2006 for Palm API Guide


SysVPPILaunchCmdErrorDialogType Struct Reference

Detailed Description

Structure used by the VPN Panel to show the error dialog.

Data Fields

  • UInt32 error
  • Err errOut

Field Documentation

UInt32 error

Error value sent by the VPN Shim (in).

Err errOut

Error code (out).

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:51 2006 for Palm API Guide


SysVPPILaunchCmdGetAccountsType Struct Reference

Collaboration diagram for SysVPPILaunchCmdGetAccountsType:

[legend]

Detailed Description

Structure used by the VPN Panel to query the account from a VPPI.

Data Fields

  • UInt32 numAccounts
  • VPNAccountType * accounts
  • Err err

Field Documentation

VPNAccountType* accounts

Array of accounts.

Err err

Error set by the VPPI before returning the account list.

UInt32 numAccounts

Number of accounts.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:51 2006 for Palm API Guide


SysVPPILaunchCmdProgressPaintType Struct Reference

Detailed Description

Structure used by the VPN Panel to show the progess dialog.

Data Fields

  • UInt32 stage
  • RectangleType clientRect
  • Err errOut

Field Documentation

RectangleType clientRect

Rectangle in which the progress dialog box is displayed (in).

Err errOut

Error code (out).

UInt32 stage

Stage calue sent by the VPN Shim to the VPPI (in).

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:51 2006 for Palm API Guide


SysVPPILaunchCmdPromptAndConfigureType Struct Reference

Detailed Description

Structure used by the VPN Panel to request the VPPI to display a dialog.

Data Fields

  • UInt32 origCreator
  • UInt32 origInstance
  • Err errOut

Field Documentation

Err errOut

Error code (out).

UInt32 origCreator

Creator that launched the prompt dialog (in).

UInt32 origInstance

Instance that laucnhed the prompt dialog (in).

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:51 2006 for Palm API Guide


SysVPPILaunchCmdSetCurrentAccountType Struct Reference

Collaboration diagram for SysVPPILaunchCmdSetCurrentAccountType:

[legend]

Detailed Description

Structure used by the VPN Panel to set the current account.

Data Fields

  • VPNAccountType account
  • Err err

Field Documentation

VPNAccountType account

Account to set as current account.

Err err

Error code.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:52 2006 for Palm API Guide


SysVPPILaunchCmdWillPWPromptType Struct Reference

Detailed Description

Structure used by the VPN Panel to determine is the VPPI will prompt for password.

Data Fields

  • UInt32 secsFromNow
  • Err errOut

Field Documentation

Err errOut

Error code (out).

UInt32 secsFromNow

Seconds from now at which the VPPI will prompt for password (in).

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:52 2006 for Palm API Guide


tagIOTANotificationEventType Struct Reference

Detailed Description

Structure passed to the callbacks registered for incoming IOTA notifications

Data Fields

  • UInt16 version
  • void * headerP
  • UInt8 headerLen
  • void * dataP
  • UInt8 dataLen
  • UInt32 msgID
  • UInt32 datetime
  • Int32 reserved2
  • Int32 reserved3

Field Documentation

UInt8 dataLen

length of dataP

void* dataP

pointer to data body

UInt32 datetime

date/time stamp

UInt8 headerLen

length of headerP

void* headerP

pointer to raw header

UInt32 msgID

SMS related fields ID into the SMS database to reference this message this ID is not gauranteed to be valid once the notification callback returns. Users should make a copy of the msg if they want to work on it after the callback returns.

Int32 reserved2

reserved

Int32 reserved3

reserved

UInt16 version

version number to provide future backwards compatibility

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:52 2006 for Palm API Guide


tagSndFileStreamData Struct Reference

Detailed Description

Holds data about a sound file stream.

Data Fields

  • UInt16 streamFlags
  • UInt16 streamMode
  • UInt32 streamRefCon
  • UInt16 playbackCount
  • UInt16 streamComplete
  • UInt32 dataSize
  • UInt32 dataDuration
  • UInt32 customDataSize
  • UInt32 fileFormat
  • UInt32 sampleFormat
  • UInt32 sampleRate
  • UInt32 sampleType
  • UInt32 sampleWidth
  • UInt32 sampleBlockAlign
  • UInt32 maximumMilliseconds
  • UInt32 maximumBytes
  • UInt32 currentMillisecond
  • UInt32 lastByte
  • MemPtr customDataP

Field Documentation

UInt32 currentMillisecond

Current millisecond of audio.

MemPtr customDataP

Pointer to custom data.

UInt32 customDataSize

Size of custom data in bytes.

UInt32 dataDuration

Duration of the audio data in milliseconds.

UInt32 dataSize

Size of the audio data in bytes.

UInt32 fileFormat

Format of the sound file stream. For example, kSndFileFormatWAV.

UInt32 lastByte

Last byte played or recorded on channel,

UInt32 maximumBytes

Maximum value for lastPlayedBytes.

UInt32 maximumMilliseconds

Maximum milliseconds of play back.

UInt16 playbackCount

How many times to play the sound. Values of 0 and 1 both cause the sound to be played back one time. Is decremented each time play back of the sound is restarted.

UInt32 sampleBlockAlign

Block alignment of the sound file. For example, 256 for IMA ADPCM.

UInt32 sampleFormat

Format of the soud sample. Example: palmCodecAudioIMA_ADPCM

UInt32 sampleRate

Sample rate of hte sound file in frames/sec. For example, 8000.

UInt32 sampleType

Type of the sound file. For example, sndInt16.

UInt32 sampleWidth

Whether the sound is stereo, mono, and so forth. For example, sndMono.

UInt16 streamComplete

Set to true when the stream has stopped because the playbackCount has been decremented to zero, maximumBytes is reached, or maximumMilliseconds is reached

UInt16 streamFlags

Flag for the sound file stream.

UInt16 streamMode

Use mode sndInput or sndOutput for sound file stream.

UInt32 streamRefCon

Reserved for third party use.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:52 2006 for Palm API Guide


tagSndFileStreamFileSpec Struct Reference

Detailed Description

Descriptions of the stream file.

Used with SndFileStreamCreate()/SndFileStreamOpen()

Data Fields

  • UInt16 flags
  • UInt16 volRefNum
  • Char * fileNameP
  • UInt32 fileCreator
  • UInt32 fileType

Field Documentation

UInt32 fileCreator

Creator ID of the stream file

Char* fileNameP

Name of the stream file

UInt32 fileType

See File Stream Database Types

UInt16 flags

Set to kSndFileStreamFileSpecFlagVFS or kSndFileStreamFileSpecFlagFileStream

UInt16 volRefNum

The volume reference number returned from VFSVolumeEnumerate().

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:52 2006 for Palm API Guide


tagSndFileStreamHsSoundCommandParam Struct Reference

Detailed Description

SndFileStreamDeviceControl param when cmd == hsSoundLibCreatorID.

Contains hsFormat/hsCmd pair to be used with PmSndStream() calls.

Data Fields

  • UInt16 hsFormat
  • UInt16 hsCmd
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:52 2006 for Palm API Guide


ToneIdentifier Struct Reference

Detailed Description

No definition.

Data Fields

  • UInt32 id
  • ToneType toneType

Field Documentation

UInt32 id

Tone ID

ToneType toneType

Tony Type (AMR, MIDI, etc).

See also:
ToneType

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:52 2006 for Palm API Guide


ToneItemType Struct Reference

Collaboration diagram for ToneItemType:

[legend]

Detailed Description

Tone characteristics.

Data Fields

  • Char name [kMaxTonesNameSize]
  • ToneIdentifier identifier
  • Boolean protectedTone

Field Documentation

ToneIdentifier identifier

Unique ID for the ring tone.

Char name[kMaxTonesNameSize]

Name of the ring tone.

Boolean protectedTone

Whether Tone is protected and cannot be beamed or sent.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:52 2006 for Palm API Guide


UPNotificationEventType Struct Reference

Detailed Description

Structure passed to the callbacks registered for incoming UP notifications

Data Fields

  • UInt16 version
  • void * headerP
  • UInt8 headerLen
  • char UPData [UPDataSize+1]
  • UInt8 _filler100_
  • UInt32 msgID
  • UInt32 datetime
  • Int32 reserved2
  • Int32 reserved3

Field Documentation

UInt32 datetime

date/time stamp

UInt8 headerLen

length of headerP

void* headerP

pointer to raw header

UInt32 msgID

SMS related fields ID into the SMS database to reference this message this ID is not gauranteed to be valid once the notification callback returns. Users should make a copy of the msg if they want to work on it after the callback returns.

Int32 reserved2

reserved

Int32 reserved3

reserved

char UPData[UPDataSize+1]

Network wakeup fields stores the raw data

UInt16 version

version number to provide future backwards compatibility

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:52 2006 for Palm API Guide


VMFontType Struct Reference

Detailed Description

Font characteristics structure used to describe a font.

Data Fields

  • VMFontFace face
  • VMFontSize size
  • VMFontStyle style

Field Documentation

VMFontFace face

Font face.

VMFontSize size

Size of Font.

VMFontStyle style

Font Style

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


VMFontUIRules Struct Reference

Detailed Description

Font UI rules structure used for the font picker setting.

Data Fields

  • Boolean fontFaceVisible
  • Boolean fontStyleVisible
  • Boolean fontSizeVisible
  • VMFontSizeRule sizeRule
  • VMFontStyleRule styleRule

Field Documentation

Boolean fontFaceVisible

Shows/Hides Font face

Boolean fontSizeVisible

Shows/Hides Font Size

Boolean fontStyleVisible

Shows/Hides Font Style

VMFontSizeRule sizeRule

Shows the size selected: allSize, smallFonts, largeFonts

VMFontStyleRule styleRule

Shows the style selected: allStyle, plainOnly

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


VPNAccountType Struct Reference

Detailed Description

VPN Account structure.

Data Fields

  • UInt32 vppiCreator
  • UInt32 accountID
  • Char accountName [kMaxVPNAccountNameLength+1]

Field Documentation

UInt32 accountID

Arbitrary 32-bit ID used by the VPI to identify the account.

Char accountName[kMaxVPNAccountNameLength+1]

User-specified account name.

UInt32 vppiCreator

Creator ID of the VPPI that "owns" the account.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


vpnNotifyVPNLibTag Struct Reference

Detailed Description

Notification structure sent in vpnLibEventNotification

Data Fields

  • VPNLibEventNotificationTypeEnum eType
  • UInt8 padding1
  • UInt16 padding2
  • UInt32 ifCreator
  • UInt16 ifInstance
  • UInt16 padding3

Field Documentation

UInt32 ifCreator

interface creator

UInt16 ifInstance

interface instance

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


webBrowserMinimalModeLaunchInfo Struct Reference

Detailed Description

Contains data used when launching web browser in minimal mode.

Data Fields

  • Char * launchUrl
  • Char * doneButtonLabel

Field Documentation

Char* doneButtonLabel

Label on the Done button

Char* launchUrl

URL to browse when launching

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


webBrowserURLWithSvcIDLaunchInfo Struct Reference

Detailed Description

Contains data used when launching web browser with a specific SvcID.

Data Fields

  • UInt32 svcID
  • Char * launchUrl

Field Documentation

Char* launchUrl

URL to browse when launching

UInt32 svcID

Network SvcID from NetPref

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


WUNotificationEventType Struct Reference

Detailed Description

Structure passed to the callbacks registered for incoming wakeup notifications

Data Fields

  • UInt16 version
  • void * headerP
  • UInt8 headerLen
  • char NAI [NAITextSize]
  • char _filler1_
  • UInt32 netTimeStamp
  • UInt8 reasonCode
  • char _filler2_
  • char password [PasswordSize]
  • char _filler3_
  • UInt32 msgID
  • UInt32 datetime
  • Int32 reserved2
  • Int32 reserved3

Field Documentation

char _filler1_

for 16 bit allignment

char _filler2_

for 16 bit allignment

char _filler3_

for 16 bit allignment

UInt32 datetime

date/time stamp

UInt8 headerLen

length of headerP

void* headerP

pointer to raw header

UInt32 msgID

SMS related fields ID into the SMS database to reference this message this ID is not gauranteed to be valid once the notification callback returns. Users should make a copy of the msg if they want to work on it after the callback returns.

char NAI[NAITextSize]

Network wakeup fields stores the NAI

UInt32 netTimeStamp

timestamp from the message

char password[PasswordSize]

the password (encrypted)

UInt8 reasonCode

a reason code from the message

Int32 reserved2

reserved

Int32 reserved3

reserved

UInt16 version

version number to provide future backwards compatibility

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Palm API Guide Class Hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
  • _dataLinks
  • _HelperServiceMMSDetailsType
  • _HelperServiceMMSObjectType
  • _PalmPhotoCaptureParamV2
  • _PalmPhotoCreateParam
  • _PalmPhotoDisplayParam
  • _PalmPhotoExtraInfo
  • _PalmPhotoFileLocation
  • _PalmPhotoImageInfo
  • _PalmPhotoReadWriteParam
  • _PalmPhotoSelectionParam
  • _PalmPhotoSelections
  • _pluginExtendedQueryParams
  • _pluginGetInfoParams
  • _pluginParams
  • _pluginQueryParams
  • _pluginSendParams
  • AddrCallerIDParamsType
  • AddrCreateNewRecordParamsType
  • AddrDescriptor
  • Address
  • AddressAppRecord
  • AddressAppRecordHeader
  • AddressType
  • AddrHsLookupUserDataType
  • AddrListLookupTypeGetParamsType
  • AddrPhonebookAppParamsType
  • AddrPhotoCallerIDParamsType
  • BGResult
  • BSSListStruct
  • CamLibBitmapInfoTag
  • CamLibCaptureTag
  • CamLibColorSpaceTag
  • CamLibSettingTag
  • CamLibStatusTag
  • CamLibStreamTag
  • Coordinate
  • DevAppLaunchCmdGenericCallType
  • DialPnlDispatchDialParamsType
  • DialPnlIsDialingAvailableParamsType
  • HS_HTTPLibAppinfo_
  • HS_HTTPLibSplit_
  • HsBigButtonMappingType
  • HsBigButtonReourceType
  • HsDialPrefsUSDialingRulesType
  • HsSndBufferData
  • HsSndPortInfo
  • HtmlLibFormWidgetProc
  • LcdOverlayLibSettingTag
  • LocationDataTag
  • LocDBInfoTag
  • LocDBRecordTag
  • LocsLibNotifyDataTag
  • LocsLibNotifyLocsDataTag
  • LocsLibSelLocsTag
  • MailAddRecordAttachment
  • MailAddRecordParamsTypePlus
  • MMProAttachDataLinks
  • MMProAttachStruct
  • MMProAttachStruct2
  • MMProLaunchStruct
  • MMProLaunchStruct2
  • NBSNotificationEventType
  • Net80211DeviceInfo
  • NetBssInfoType
  • NetMasterClientEventInfoType
  • NetMasterClientEventVPNConnInstallType
  • NetPrefFallbackInfoType
  • NetPrefGPRSQOSType
  • NetServicesProfile
  • NetServicesProfileInfo
  • NetServicesProfileOrder
  • NetServicesProfileV1
  • NetSSID
  • NetWepKey
  • NetworkDeviceQueryData
  • PalmAudioAACDecParamType
  • PalmAudioAACParamType
  • PalmAudioADPCMParamType
  • PalmAudioMP2ParamType
  • PalmAudioPCMParamType
  • PalmAudioPlaybackNotifyEventTypeTag
  • PalmFileFormatParamType
  • PalmImageBMPParamType
  • PalmImageGIFFrameParamType
  • PalmImageINDEXParamType
  • PalmImageJPEGEncodeParamType
  • PalmImageParamType
  • PalmImagePlanarType
  • PalmVideoAVCCustomGetDecodedFrameType
  • PalmVideoAVCCustomGetInfoType
  • PalmVideoAVCCustomSetCropModeType
  • PalmVideoAVCDecodeParamType
  • PalmVideoAVCOutputBufferType
  • PalmVideoMPEG1DecodeParamType
  • PalmVideoMPEG4DecodeParamType
  • PalmVideoMPEG4EncodeParamType
  • ParsedInfo
  • ParsedInfoList
  • PhnCdmaSystemInfoType
  • PhnConnectionType
  • PhnEventType
  • PhnGPRSPDPContextListNodeType
  • PhnGPRSPDPContextType
  • PhnIOTAPhnDlsLockType
  • PhnLibLengthInfoType
  • PhnLineStateType
  • PhnMMIEntryType
  • PhnMMIResultType
  • PhnOneXStatus
  • PhnOperatorListType
  • PhnPDPList
  • PhnPDPPayload
  • PhnRadioStateType
  • PhnRingingInfoType
  • PhnRoamPrefInfoType
  • PhnSMSParams
  • PhnSMSPrefType
  • PhoneAppLaunchCmdCallerIDLookupType
  • PhoneAppLaunchCmdDialType
  • PhoneAppLaunchCmdGetALSLineNumberType
  • PhoneAppLaunchCmdGetDialPrefFlagType
  • PhoneAppLaunchCmdSendDTMFToneType
  • PhoneAppLaunchCmdSetWallpaperType
  • PmBroadcastNewMsgCountNotifyParamType
  • PmConnectorNotifyDataType
  • PmGetNewMsgCountNotifyParamType
  • PmSysGadgetBbutMappingType
  • PmSysGadgetBbutResourceType
  • PosType
  • SndCodecCustomControlType
  • SoundPreference
  • SoundPreference::_tonePrefs
  • SoundPreferenceCalendar
  • SoundPreferenceEmail
  • SoundPreferenceIM
  • SoundPreferenceMMS
  • SoundPreferenceNetworkSounds
  • SoundPreferencePhone
  • SoundPreferenceSMS
  • SoundPrefsLaunchCmdParamType
  • SysVPPILaunchCmdClearPWCacheType
  • SysVPPILaunchCmdDeleteAccountType
  • SysVPPILaunchCmdEditAccountType
  • SysVPPILaunchCmdErrorDialogType
  • SysVPPILaunchCmdGetAccountsType
  • SysVPPILaunchCmdProgressPaintType
  • SysVPPILaunchCmdPromptAndConfigureType
  • SysVPPILaunchCmdSetCurrentAccountType
  • SysVPPILaunchCmdWillPWPromptType
  • tagIOTANotificationEventType
  • tagSndFileStreamData
  • tagSndFileStreamFileSpec
  • tagSndFileStreamHsSoundCommandParam
  • ToneIdentifier
  • ToneItemType
  • UPNotificationEventType
  • VMFontType
  • VMFontUIRules
  • VPNAccountType
  • vpnNotifyVPNLibTag
  • webBrowserMinimalModeLaunchInfo
  • webBrowserURLWithSvcIDLaunchInfo
  • WUNotificationEventType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- _ -

  • _filler1_ : WUNotificationEventType
  • _filler2_ : WUNotificationEventType
  • _filler3_ : WUNotificationEventType
  • _reserved0 : HsDialPrefsUSDialingRulesType, DialPnlIsDialingAvailableParamsType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- j -

  • JPEGMode : PalmImageJPEGEncodeParamType
  • justSend : _HelperServiceMMSDetailsType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- k -

  • keyFrame : PalmVideoMPEG4EncodeParamType
  • keyIndex : NetServicesProfileV1, NetServicesProfile
  • knownCallerTone : SoundPreferencePhone
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- l -

  • lastByte : tagSndFileStreamData
  • launchUrl : webBrowserURLWithSvcIDLaunchInfo, webBrowserMinimalModeLaunchInfo
  • launchView : SoundPrefsLaunchCmdParamType
  • leftPosition : PalmImageGIFFrameParamType
  • length : PhnLibLengthInfoType
  • lineNumber : PhoneAppLaunchCmdGetALSLineNumberType
  • linkP : NetworkDeviceQueryData
  • listItems : _pluginQueryParams
  • listMaxSizeExt : _pluginGetInfoParams
  • listMaxSizeMime : _pluginGetInfoParams
  • listNames : _pluginExtendedQueryParams
  • listPtrs : _pluginExtendedQueryParams
  • listReceiveFileExt : _pluginGetInfoParams
  • listReceiveMIMEtypes : _pluginGetInfoParams
  • listSendFileExt : _pluginGetInfoParams
  • listSendMIMEtypes : _pluginGetInfoParams
  • listSendNames : _pluginGetInfoParams
  • localColorBits : PalmImageGIFFrameParamType
  • localColorTable : PalmImageGIFFrameParamType
  • locationData : LocsLibNotifyDataTag
  • locationDataNew : LocsLibNotifyLocsDataTag
  • locationNameOldP : LocsLibNotifyLocsDataTag
  • locationP : LocsLibSelLocsTag
  • lock : CamLibStreamTag
  • lookup : AddrPhonebookAppParamsType
  • lookupString : AddrCallerIDParamsType
  • lookupStrP : AddrPhonebookAppParamsType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- m -

  • mainParams : MailAddRecordParamsTypePlus
  • majorResult : BGResult
  • matchFound : AddrHsLookupUserDataType
  • maximumBytes : tagSndFileStreamData
  • maximumMilliseconds : tagSndFileStreamData
  • maxNum : NBSNotificationEventType
  • maxSize : ParsedInfoList
  • maxValue : CamLibSettingTag, LcdOverlayLibSettingTag
  • maxVol : HsSndPortInfo
  • MemoryFile : _PalmPhotoFileLocation
  • message : _HelperServiceMMSDetailsType
  • messageTone : SoundPreferenceMMS, SoundPreferenceSMS, SoundPreferenceIM
  • mimeType : _HelperServiceMMSObjectType
  • MIMEtype : _pluginExtendedQueryParams, _pluginSendParams, _pluginQueryParams, _pluginParams
  • minValue : CamLibSettingTag, LcdOverlayLibSettingTag
  • minVol : HsSndPortInfo
  • miscData : ParsedInfo
  • mmsSoundPrefs : SoundPreference::_tonePrefs
  • mn_aaa_spi : PhnPDPPayload
  • mn_aaa_ss : PhnPDPPayload
  • mn_aaa_ss_length : PhnPDPPayload
  • mn_ha_spi : PhnPDPPayload
  • mn_ha_ss : PhnPDPPayload
  • mn_ha_ss_length : PhnPDPPayload
  • moreData : _pluginSendParams, _pluginParams, MMProAttachStruct2
  • msgAlert : SoundPreferenceSMS
  • msgID : NBSNotificationEventType, tagIOTANotificationEventType, UPNotificationEventType, WUNotificationEventType
  • msgNumber : ParsedInfo
  • mutexSticky : NetPrefFallbackInfoType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- n -

  • nai : PhnPDPPayload
  • NAI : WUNotificationEventType
  • nai_length : PhnPDPPayload
  • name : PhoneAppLaunchCmdDialType, ToneItemType, _HelperServiceMMSObjectType, LocDBRecordTag, LocationDataTag, _PalmPhotoFileLocation, _pluginSendParams
  • nameLength : ParsedInfo
  • nameP : PhoneAppLaunchCmdCallerIDLookupType
  • NBSdatagram : NBSNotificationEventType
  • needSelLoc : LocsLibSelLocsTag
  • netTimeStamp : WUNotificationEventType
  • networkSoundPrefs : SoundPreference::_tonePrefs
  • newMailAlert : SoundPreferenceEmail
  • newPhoneNum : AddrPhonebookAppParamsType
  • nextP : _HelperServiceMMSObjectType
  • noAddToCustomDB : LocsLibSelLocsTag
  • noEditOnSelect : LocsLibSelLocsTag
  • note : LocationDataTag
  • notifyType : LocsLibNotifyDataTag
  • num_def_pdp_idxs : PhnPDPList
  • num_stand_pdp_idxs : PhnPDPList
  • num_tmp_pdp_idxs : PhnPDPList
  • numAccounts : SysVPPILaunchCmdGetAccountsType
  • numAttach : MMProLaunchStruct2, MMProLaunchStruct
  • numAttachments : MailAddRecordParamsTypePlus
  • number : PhoneAppLaunchCmdDialType
  • numberP : PhoneAppLaunchCmdCallerIDLookupType
  • numBytes : CamLibBitmapInfoTag
  • numDataLinks : _pluginSendParams, _pluginParams, MMProAttachStruct2
  • numItems : _pluginExtendedQueryParams, _pluginQueryParams
  • numProfiles : NetServicesProfileInfo
  • numReceiveTypes : _pluginGetInfoParams
  • numSelLocs : LocsLibSelLocsTag
  • numSendTypes : _pluginGetInfoParams
  • numServices : DialPnlIsDialingAvailableParamsType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- o -

  • object : _HelperServiceMMSDetailsType
  • offset : _PalmPhotoSelectionParam
  • operation : DevAppLaunchCmdGenericCallType
  • opMode : NetServicesProfileV1, NetServicesProfile
  • order : NetServicesProfileOrder
  • origCreator : SysVPPILaunchCmdPromptAndConfigureType
  • origInstance : SysVPPILaunchCmdPromptAndConfigureType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- a -

  • account : SysVPPILaunchCmdSetCurrentAccountType, SysVPPILaunchCmdDeleteAccountType, SysVPPILaunchCmdEditAccountType
  • accountID : VPNAccountType
  • accountName : VPNAccountType
  • accounts : SysVPPILaunchCmdGetAccountsType
  • actionCode : PalmAudioPlaybackNotifyEventTypeTag
  • active_idx : PhnPDPList
  • active_idx_set : PhnPDPList
  • activeCall : AddrPhonebookAppParamsType
  • add1BeforeAreaCode : HsDialPrefsUSDialingRulesType
  • alarmPreset : SoundPreferenceCalendar
  • alarmTone : SoundPreferenceCalendar
  • albumID : _PalmPhotoSelectionParam
  • alertTone : SoundPreferenceEmail
  • algorithm : PalmVideoMPEG4EncodeParamType, NetPrefFallbackInfoType
  • alsSupported : PhnRadioStateType
  • amplitude : HsSndBufferData
  • apiCreator : SndCodecCustomControlType
  • apiSelector : SndCodecCustomControlType
  • areaCodeCtl : HsDialPrefsUSDialingRulesType
  • ascP : PalmAudioAACDecParamType
  • aSize : MMProAttachStruct2, MMProAttachStruct
  • attachData : MailAddRecordAttachment
  • attachDBID : MailAddRecordAttachment
  • attachDescription : MailAddRecordAttachment
  • attachFileName : MailAddRecordAttachment
  • attachment : MMProAttachStruct2, MMProAttachStruct
  • attachments : MailAddRecordParamsTypePlus, MMProLaunchStruct2, MMProLaunchStruct
  • attachName : MMProAttachStruct2, MMProAttachStruct
  • attachSize : MailAddRecordAttachment
  • attachType : MailAddRecordAttachment
  • authentication : NetServicesProfileV1, NetServicesProfile
  • autoAreaCode : HsDialPrefsUSDialingRulesType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- b -

  • bcc : _HelperServiceMMSDetailsType, MMProLaunchStruct2, MMProLaunchStruct
  • bCroppedMode : PalmVideoAVCCustomSetCropModeType
  • binary : NBSNotificationEventType
  • bitRate : PalmVideoMPEG4EncodeParamType, PalmAudioAACParamType
  • bitsPerPixel : _PalmPhotoImageInfo, CamLibBitmapInfoTag
  • blockSize : PalmAudioADPCMParamType
  • body : MMProLaunchStruct2, MMProLaunchStruct
  • boostDB : HsSndPortInfo
  • buffer : HsSndBufferData
  • bufferLen : _HelperServiceMMSObjectType
  • bufferP : _HelperServiceMMSObjectType, _PalmPhotoFileLocation
  • bufferSize : _PalmPhotoFileLocation, HsSndBufferData
  • bufP : CamLibStreamTag
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- c -

  • calendarSoundPrefs : SoundPreference::_tonePrefs
  • callback : AddrCallerIDParamsType
  • callbackP : CamLibCaptureTag
  • captureCallback : _PalmPhotoCaptureParamV2
  • category : MailAddRecordParamsTypePlus
  • cc : _HelperServiceMMSDetailsType, MMProLaunchStruct2, MMProLaunchStruct
  • channel : NetServicesProfileV1, NetServicesProfile
  • chatTone : SoundPreferenceIM
  • chromaFormat : PalmVideoAVCCustomGetInfoType
  • clientRect : SysVPPILaunchCmdProgressPaintType
  • color : ParsedInfo
  • colorBits : PalmImageINDEXParamType
  • colorImportant : PalmImageBMPParamType
  • colorTable : PalmImageINDEXParamType
  • colorUsed : PalmImageBMPParamType
  • completion_callback : HsSndBufferData
  • completion_userdata : HsSndBufferData
  • compositionTime : PalmVideoAVCCustomGetDecodedFrameType
  • compositionTimestamp : PalmVideoAVCCustomGetDecodedFrameType
  • compression : PalmImageBMPParamType
  • confirm : PhoneAppLaunchCmdDialType
  • connection_type : PhnPDPPayload
  • controls : HsSndBufferData
  • count : AddrDescriptor
  • country : LocDBRecordTag, LocationDataTag
  • creator : _PalmPhotoFileLocation
  • currentMillisecond : tagSndFileStreamData
  • currentPan : HsSndPortInfo
  • currentVol : HsSndPortInfo
  • custom : LocDBRecordTag, LocationDataTag
  • customDataP : tagSndFileStreamData
  • customDataSize : tagSndFileStreamData
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- d -

  • data : AddrCreateNewRecordParamsType, _pluginParams, _dataLinks, MMProAttachDataLinks
  • dataDuration : tagSndFileStreamData
  • dataLen : NBSNotificationEventType, tagIOTANotificationEventType
  • dataP : DialPnlDispatchDialParamsType, NBSNotificationEventType, tagIOTANotificationEventType, PalmAudioPlaybackNotifyEventTypeTag
  • dataSize : tagSndFileStreamData
  • datetime : NBSNotificationEventType, tagIOTANotificationEventType, UPNotificationEventType, WUNotificationEventType
  • db : _pluginExtendedQueryParams, _pluginSendParams, _pluginQueryParams, _pluginParams
  • dbCardNum : LocDBInfoTag
  • dbCreatorID : LocDBInfoTag
  • dbName : LocDBInfoTag
  • dbType : LocDBInfoTag
  • defaultConnProfileName : NetMasterClientEventVPNConnInstallType
  • delayTime : PalmImageGIFFrameParamType
  • descriptionStr : DialPnlDispatchDialParamsType
  • dhcpRequestDNS : NetServicesProfileV1, NetServicesProfile
  • dial_str : PhnPDPPayload
  • dial_str_length : PhnPDPPayload
  • dialMethod : PhoneAppLaunchCmdDialType
  • dirtyBit : SysVPPILaunchCmdEditAccountType
  • dirtySelections : LocsLibSelLocsTag
  • displayCallback : _PalmPhotoDisplayParam
  • displayDialPrefs : PhoneAppLaunchCmdGetDialPrefFlagType
  • disposalMethod : PalmImageGIFFrameParamType
  • dns_server_assigned : PhnPDPPayload
  • doneButtonLabel : webBrowserMinimalModeLaunchInfo
  • driverDate : Net80211DeviceInfo
  • dSTAdjustmentInMinutes : LocDBRecordTag, LocationDataTag
  • dSTEnd : LocDBRecordTag, LocationDataTag
  • dstPort : NBSNotificationEventType
  • dSTStart : LocDBRecordTag, LocationDataTag
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- e -

  • emailSoundPrefs : SoundPreference::_tonePrefs
  • endianess : PalmImageINDEXParamType, PalmImageParamType
  • err : DialPnlDispatchDialParamsType, SysVPPILaunchCmdSetCurrentAccountType, SysVPPILaunchCmdDeleteAccountType, SysVPPILaunchCmdEditAccountType, SysVPPILaunchCmdGetAccountsType
  • error : SysVPPILaunchCmdErrorDialogType
  • errOut : SysVPPILaunchCmdWillPWPromptType, SysVPPILaunchCmdClearPWCacheType, SysVPPILaunchCmdErrorDialogType, SysVPPILaunchCmdProgressPaintType, SysVPPILaunchCmdPromptAndConfigureType
  • esdsP : PalmAudioAACDecParamType
  • eventData : NetMasterClientEventInfoType
  • eventID : NetMasterClientEventInfoType
  • eventType : PhnEventType
  • extraDigits : PhoneAppLaunchCmdDialType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- f -

  • face : VMFontType
  • failLaunchCode : PhoneAppLaunchCmdDialType
  • failLaunchCreator : PhoneAppLaunchCmdDialType
  • failLaunchParams : PhoneAppLaunchCmdDialType
  • fbStatusFlags : NetPrefFallbackInfoType
  • field : AddrCreateNewRecordParamsType
  • file : _PalmPhotoFileLocation
  • fileCreator : tagSndFileStreamFileSpec
  • fileExt : _pluginExtendedQueryParams, _pluginSendParams, _pluginQueryParams, _pluginParams
  • fileFormat : _PalmPhotoImageInfo, PalmAudioAACDecParamType, tagSndFileStreamData
  • fileLocation : _PalmPhotoCaptureParamV2, _PalmPhotoCreateParam
  • fileLocationType : _PalmPhotoFileLocation, PalmFileFormatParamType
  • fileNameP : tagSndFileStreamFileSpec
  • filesize : _PalmPhotoImageInfo
  • fileType : tagSndFileStreamFileSpec
  • filterCallback : _PalmPhotoSelectionParam
  • first_def_pdp_idx : PhnPDPList
  • first_stand_pdp_idx : PhnPDPList
  • first_tmp_pdp_idx : PhnPDPList
  • flags : AddrCallerIDParamsType, HsSndBufferData, HsSndPortInfo, tagSndFileStreamFileSpec
  • fname : _pluginParams
  • fontFaceVisible : VMFontUIRules
  • fontSizeVisible : VMFontUIRules
  • fontStyleVisible : VMFontUIRules
  • formatString : AddrCallerIDParamsType
  • frameHeight : PalmVideoAVCCustomGetInfoType
  • frameHeightCropped : PalmVideoAVCCustomGetInfoType
  • frameNum : CamLibStreamTag
  • frameP : PalmAudioAACDecParamType
  • frameRate : PalmVideoMPEG4EncodeParamType
  • frameSize : PalmAudioAACDecParamType
  • framesReady : PalmVideoAVCOutputBufferType
  • frameTime : CamLibStreamTag
  • frameWidth : PalmVideoAVCCustomGetInfoType
  • frameWidthCropped : PalmVideoAVCCustomGetInfoType
  • freeTempFile : _HelperServiceMMSObjectType
  • fwName : Net80211DeviceInfo
  • fwRev : Net80211DeviceInfo
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- g -

  • genericEventDataP : NetMasterClientEventInfoType
  • getInfo : _pluginGetInfoParams
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- h -

  • handled : DialPnlDispatchDialParamsType
  • hasLocalColorTable : PalmImageGIFFrameParamType
  • hasTransparentColor : PalmImageGIFFrameParamType
  • headerLen : NBSNotificationEventType, tagIOTANotificationEventType, UPNotificationEventType, WUNotificationEventType
  • headerP : NBSNotificationEventType, tagIOTANotificationEventType, UPNotificationEventType, WUNotificationEventType
  • height : _PalmPhotoImageInfo, PalmVideoMPEG1DecodeParamType, PalmImageINDEXParamType, PalmImagePlanarType, PalmImageParamType, CamLibBitmapInfoTag
  • home_addr : PhnPDPPayload
  • horizontalOffset : PalmVideoAVCCustomGetInfoType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- i -

  • id : ToneIdentifier
  • identifier : ToneItemType
  • idx0_set : PhnPDPList
  • idx0_uid : PhnPDPList
  • idx1_set : PhnPDPList
  • idx1_uid : PhnPDPList
  • idx2_set : PhnPDPList
  • idx2_uid : PhnPDPList
  • idx3_set : PhnPDPList
  • idx3_uid : PhnPDPList
  • idx4_set : PhnPDPList
  • idx4_uid : PhnPDPList
  • idx5_set : PhnPDPList
  • idx5_uid : PhnPDPList
  • idx6_set : PhnPDPList
  • idx6_uid : PhnPDPList
  • idx7_set : PhnPDPList
  • idx7_uid : PhnPDPList
  • idx_RSVD8_set : PhnPDPList
  • idx_rsvd8_uid : PhnPDPList
  • idx_RSVD9_set : PhnPDPList
  • idx_rsvd9_uid : PhnPDPList
  • ifCreator : vpnNotifyVPNLibTag
  • ifInstance : vpnNotifyVPNLibTag
  • imageBits : AddrPhotoCallerIDParamsType
  • imageCount : _PalmPhotoSelections
  • imageDataP : PalmImageINDEXParamType, PalmImageGIFFrameParamType
  • imageDataSize : PalmImageGIFFrameParamType
  • imageFormat : _PalmPhotoReadWriteParam
  • imageH : _PalmPhotoSelections
  • imageHeight : PalmImageGIFFrameParamType
  • imageInfo : _PalmPhotoCaptureParamV2, _PalmPhotoCreateParam
  • imageQuality : _PalmPhotoImageInfo
  • imageWidth : PalmImageGIFFrameParamType
  • imSoundPrefs : SoundPreference::_tonePrefs
  • info : ParsedInfoList
  • infoP : _PalmPhotoExtraInfo
  • infoSize : _PalmPhotoExtraInfo
  • infoType : _PalmPhotoExtraInfo
  • inReserved1 : NetMasterClientEventInfoType, NetMasterClientEventVPNConnInstallType
  • inReserved2 : NetMasterClientEventInfoType, NetMasterClientEventVPNConnInstallType
  • inReserved3 : NetMasterClientEventInfoType
  • inReserved4 : NetMasterClientEventInfoType
  • interactive : MMProLaunchStruct
  • ipAllocType : NetServicesProfileV1, NetServicesProfile
  • ipGateway : NetServicesProfileV1, NetServicesProfile
  • ipMask : NetServicesProfileV1, NetServicesProfile
  • ipPrimaryDNS : NetServicesProfileV1, NetServicesProfile
  • ipSecondaryDNS : NetServicesProfileV1, NetServicesProfile
  • isInterlaced : PalmImageGIFFrameParamType
  • isVFSFileName : _HelperServiceMMSObjectType
  • item : _pluginSendParams
  • itemDescriptors : _pluginQueryParams
  • itemLength : ParsedInfo
  • itemSizes : _pluginQueryParams
  • IVOPQuantization : PalmVideoMPEG4EncodeParamType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- p -

  • pageNum : _HelperServiceMMSObjectType
  • parsedType : ParsedInfo
  • password : WUNotificationEventType
  • pdp_services : PhnPDPPayload
  • pdpDataCompression : PhnGPRSPDPContextType, NetPrefGPRSQOSType
  • pdpHeaderCompression : NetPrefGPRSQOSType
  • phoneSoundPrefs : SoundPreference::_tonePrefs
  • picHeight : PalmVideoAVCCustomGetDecodedFrameType
  • picHeightCropped : PalmVideoAVCCustomGetDecodedFrameType
  • picWidth : PalmVideoAVCCustomGetDecodedFrameType
  • picWidthCropped : PalmVideoAVCCustomGetDecodedFrameType
  • planeCount : PalmImagePlanarType
  • planeP : PalmImagePlanarType
  • planeWidth : PalmImagePlanarType
  • playbackCount : tagSndFileStreamData
  • playSoundTimes : SoundPreferenceCalendar
  • portID : HsSndPortInfo
  • position : LocationDataTag
  • preambleType : NetServicesProfileV1, NetServicesProfile
  • preSelect : LocsLibSelLocsTag
  • presetTime : SoundPreferenceCalendar
  • presetTimeUnit : SoundPreferenceCalendar
  • prim_dns_addr : PhnPDPPayload
  • prim_ha_addr : PhnPDPPayload
  • privacy : SoundPreferenceSMS
  • profile : PalmVideoMPEG4DecodeParamType, PalmVideoMPEG4EncodeParamType, PalmAudioAACParamType
  • profileEntrySize : NetServicesProfileInfo
  • profileName : NetServicesProfileV1, NetServicesProfile
  • profileRev : NetServicesProfileInfo
  • progress_callback : HsSndBufferData
  • progress_userdata : HsSndBufferData
  • protectedTone : ToneItemType
  • protocolErr : BGResult
  • protocolErrString : BGResult
  • ptr : _pluginSendParams
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- q -

  • qnc_set : PhnPDPList
  • qnc_uid : PhnPDPList
  • qosMinDelayClass : NetPrefGPRSQOSType
  • qosMinMeanThruClass : NetPrefGPRSQOSType
  • qosMinPeakThruClass : NetPrefGPRSQOSType
  • qosMinPrecedenceClass : NetPrefGPRSQOSType
  • qosMinReliabilityClass : NetPrefGPRSQOSType
  • qosReqDelayClass : NetPrefGPRSQOSType
  • qosReqMeanThruClass : NetPrefGPRSQOSType
  • qosReqPeakThruClass : NetPrefGPRSQOSType
  • qosReqPrecedenceClass : NetPrefGPRSQOSType
  • qosReqReliabilityClass : NetPrefGPRSQOSType
  • quality : PalmImageJPEGEncodeParamType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- r -

  • rcptAlert : SoundPreferenceSMS
  • reasonCode : WUNotificationEventType
  • recordNum : AddrPhotoCallerIDParamsType, AddrCallerIDParamsType
  • rect : _PalmPhotoDisplayParam
  • ref : AddrCallerIDParamsType
  • refNum : NBSNotificationEventType
  • reminderTone : SoundPreferenceCalendar
  • repeatAlarmTimes : SoundPreferenceCalendar
  • repeated : PhoneAppLaunchCmdSendDTMFToneType
  • repeatInterval : SoundPreferenceCalendar
  • reqIP : NetServicesProfileV1, NetServicesProfile
  • requestSmsInfo : PhnLibLengthInfoType
  • reserved : LocsLibSelLocsTag, LocDBRecordTag, LocationDataTag, _PalmPhotoExtraInfo, _PalmPhotoFileLocation, NetPrefGPRSQOSType, _PalmPhotoReadWriteParam, _PalmPhotoSelectionParam
  • reserved0 : NBSNotificationEventType, CamLibBitmapInfoTag
  • reserved1 : NBSNotificationEventType, AddressAppRecord, HsSndBufferData, HsSndPortInfo, CamLibBitmapInfoTag
  • reserved1a : NBSNotificationEventType
  • reserved2 : NBSNotificationEventType, tagIOTANotificationEventType, UPNotificationEventType, WUNotificationEventType, HsSndBufferData, HsSndPortInfo
  • reserved3 : NBSNotificationEventType, tagIOTANotificationEventType, UPNotificationEventType, WUNotificationEventType
  • response : DevAppLaunchCmdGenericCallType
  • restartInterval : PalmImageJPEGEncodeParamType
  • restrict_ha_addr : PhnPDPPayload
  • restrict_home_addr : PhnPDPPayload
  • restrict_mn_aaa_spi : PhnPDPPayload
  • restrict_mn_aaa_ss : PhnPDPPayload
  • restrict_mn_ha_spi : PhnPDPPayload
  • restrict_mn_ha_ss : PhnPDPPayload
  • restrict_nai : PhnPDPPayload
  • restrict_rev_tunnel_pref : PhnPDPPayload
  • result : DialPnlIsDialingAvailableParamsType
  • resultString : AddrCallerIDParamsType
  • ret : _pluginExtendedQueryParams, _pluginSendParams, _pluginQueryParams, _pluginParams, _pluginGetInfoParams
  • rev_tunnel_pref : PhnPDPPayload
  • roamingTone : SoundPreferencePhone
  • rowByte : PalmImageINDEXParamType, PalmImageParamType
  • rulesEnabled : HsDialPrefsUSDialingRulesType
  • rwCallback : _PalmPhotoReadWriteParam
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- s -

  • sampleBlockAlign : tagSndFileStreamData
  • sampleFormat : tagSndFileStreamData
  • sampleRate : PalmAudioAACParamType, PalmAudioADPCMParamType, PalmAudioPCMParamType, tagSndFileStreamData
  • sampleType : PalmAudioPCMParamType, tagSndFileStreamData
  • sampleWidth : PalmAudioAACParamType, PalmAudioADPCMParamType, PalmAudioPCMParamType, tagSndFileStreamData
  • searchRange : PalmVideoMPEG4EncodeParamType
  • sec_dns_addr : PhnPDPPayload
  • sec_ha_addr : PhnPDPPayload
  • secsFromNow : SysVPPILaunchCmdWillPWPromptType
  • segmentCount : PhnLibLengthInfoType
  • selectedDescriptor : _pluginSendParams
  • selectedImages : _PalmPhotoSelectionParam
  • selectedItem : _pluginSendParams
  • selectionCount : _PalmPhotoSelectionParam
  • selLocsListP : LocsLibSelLocsTag
  • sendChangeNotify : LocsLibSelLocsTag
  • senderCreatorId : DevAppLaunchCmdGenericCallType
  • senderP : NBSNotificationEventType
  • seqNum : NBSNotificationEventType
  • serialNumber : Net80211DeviceInfo
  • serialNumberSize : Net80211DeviceInfo
  • serviceID : DialPnlDispatchDialParamsType
  • serviceIDsP : DialPnlIsDialingAvailableParamsType
  • serviceTone : SoundPreferencePhone
  • set_mn_aaa_spi : PhnPDPPayload
  • set_mn_ha_spi : PhnPDPPayload
  • showWaitDialogue : LocsLibNotifyDataTag
  • signature : HsSndBufferData, HsSndPortInfo
  • size : VMFontType, PhnLibLengthInfoType, ParsedInfoList, CamLibStreamTag, _pluginExtendedQueryParams, _pluginSendParams, _pluginParams, _dataLinks, MMProAttachDataLinks
  • sizeRule : VMFontUIRules
  • skipBFrames : PalmVideoMPEG1DecodeParamType
  • smsSoundPrefs : SoundPreference::_tonePrefs
  • soundOffVibrate : SoundPreference
  • soundOnVibrate : SoundPreference
  • soundOnVolume : SoundPreference
  • srcPort : NBSNotificationEventType
  • SSID : NetServicesProfileV1, NetServicesProfile
  • ssidLength : NetServicesProfileV1, NetServicesProfile
  • stage : SysVPPILaunchCmdProgressPaintType
  • startLocation : ParsedInfo
  • status : CamLibStatusTag
  • stepDB : HsSndPortInfo
  • stepVol : HsSndPortInfo
  • stored_mn_aaa_ss : PhnPDPPayload
  • streamComplete : tagSndFileStreamData
  • StreamFile : _PalmPhotoFileLocation
  • streamFileHandle : PalmFileFormatParamType
  • streamFlags : tagSndFileStreamData
  • streamMode : tagSndFileStreamData
  • streamRefCon : tagSndFileStreamData
  • stride : PalmVideoAVCCustomGetDecodedFrameType
  • style : VMFontType
  • styleRule : VMFontUIRules
  • subject : _HelperServiceMMSDetailsType, MMProLaunchStruct2, MMProLaunchStruct
  • subSampling : PalmImageJPEGEncodeParamType
  • substitution : PhnLibLengthInfoType
  • supported : _pluginExtendedQueryParams
  • supportsReceiving : _pluginGetInfoParams
  • supportsSending : _pluginGetInfoParams
  • svc_str : PhnPDPPayload
  • svc_str_length : PhnPDPPayload
  • svcID : webBrowserURLWithSvcIDLaunchInfo
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- t -

  • tempFileName : _HelperServiceMMSObjectType
  • to : MMProLaunchStruct2, MMProLaunchStruct
  • tone : PhoneAppLaunchCmdSendDTMFToneType
  • tonePrefs : SoundPreference
  • toneType : ToneIdentifier
  • topPosition : PalmImageGIFFrameParamType
  • transparentColorIndex : PalmImageGIFFrameParamType
  • type : AddrListLookupTypeGetParamsType, _PalmPhotoFileLocation, CamLibSettingTag, _pluginExtendedQueryParams, MMProAttachStruct2, MMProAttachStruct, LcdOverlayLibSettingTag
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- u -

  • uid : PhnPDPPayload
  • uniqueID : AddrCallerIDParamsType
  • unityVol : HsSndPortInfo
  • unknownCallerTone : SoundPreferencePhone
  • Unused : _pluginExtendedQueryParams, _pluginSendParams, _pluginQueryParams, _pluginParams, _pluginGetInfoParams
  • UPData : UPNotificationEventType
  • useMultiFilter : AddrHsLookupUserDataType
  • userDataP : CamLibCaptureTag, DevAppLaunchCmdGenericCallType, _PalmPhotoCaptureParamV2, _PalmPhotoDisplayParam, _PalmPhotoReadWriteParam, _PalmPhotoSelectionParam
  • useSavedAccount : SysVPPILaunchCmdEditAccountType
  • useWizardUI : SysVPPILaunchCmdEditAccountType
  • uTC : LocDBRecordTag, LocationDataTag
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- v -

  • validFlags : Net80211DeviceInfo
  • value : CamLibColorSpaceTag, CamLibSettingTag, LcdOverlayLibSettingTag
  • valueLenP : SndCodecCustomControlType
  • valueP : SndCodecCustomControlType
  • version : PhoneAppLaunchCmdDialType, AddrHsLookupUserDataType, AddrListLookupTypeGetParamsType, NBSNotificationEventType, tagIOTANotificationEventType, UPNotificationEventType, WUNotificationEventType, _HelperServiceMMSDetailsType, _pluginParams, _pluginGetInfoParams, NetMasterClientEventInfoType, PalmAudioPlaybackNotifyEventTypeTag
  • verticalOffset : PalmVideoAVCCustomGetInfoType
  • VFSFile : _PalmPhotoFileLocation
  • vfsFileRef : PalmFileFormatParamType
  • voicemailTone : SoundPreferencePhone
  • volHeight : PalmVideoMPEG4DecodeParamType, PalmVideoMPEG4EncodeParamType
  • volRefNum : tagSndFileStreamFileSpec
  • volumeRef : _PalmPhotoFileLocation
  • volWidth : PalmVideoMPEG4DecodeParamType, PalmVideoMPEG4EncodeParamType
  • VOVOLVersionID : PalmVideoMPEG4EncodeParamType
  • vpnConnInstallP : NetMasterClientEventInfoType
  • vpnConnProfileOverrideName : NetMasterClientEventVPNConnInstallType
  • vppiCreator : VPNAccountType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- w -

  • wallpaperLocation : PhoneAppLaunchCmdSetWallpaperType
  • wallpaperUID : PhoneAppLaunchCmdSetWallpaperType
  • warnIfLocExists : LocsLibSelLocsTag
  • wep : NetServicesProfileV1, NetServicesProfile
  • width : _PalmPhotoImageInfo, PalmVideoMPEG1DecodeParamType, PalmImageINDEXParamType, PalmImagePlanarType, PalmImageParamType, CamLibBitmapInfoTag
  • winH : _PalmPhotoDisplayParam
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- x -

  • xExtent : AddrPhotoCallerIDParamsType
  • xPixelsPerMeter : PalmImageBMPParamType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- y -

  • yExtent : AddrPhotoCallerIDParamsType
  • yPixelsPerMeter : PalmImageBMPParamType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- _ -

  • _filler1_ : WUNotificationEventType
  • _filler2_ : WUNotificationEventType
  • _filler3_ : WUNotificationEventType
  • _reserved0 : HsDialPrefsUSDialingRulesType, DialPnlIsDialingAvailableParamsType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- j -

  • JPEGMode : PalmImageJPEGEncodeParamType
  • justSend : _HelperServiceMMSDetailsType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- k -

  • keyFrame : PalmVideoMPEG4EncodeParamType
  • keyIndex : NetServicesProfileV1, NetServicesProfile
  • knownCallerTone : SoundPreferencePhone
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- l -

  • lastByte : tagSndFileStreamData
  • launchUrl : webBrowserURLWithSvcIDLaunchInfo, webBrowserMinimalModeLaunchInfo
  • launchView : SoundPrefsLaunchCmdParamType
  • leftPosition : PalmImageGIFFrameParamType
  • length : PhnLibLengthInfoType
  • lineNumber : PhoneAppLaunchCmdGetALSLineNumberType
  • linkP : NetworkDeviceQueryData
  • listItems : _pluginQueryParams
  • listMaxSizeExt : _pluginGetInfoParams
  • listMaxSizeMime : _pluginGetInfoParams
  • listNames : _pluginExtendedQueryParams
  • listPtrs : _pluginExtendedQueryParams
  • listReceiveFileExt : _pluginGetInfoParams
  • listReceiveMIMEtypes : _pluginGetInfoParams
  • listSendFileExt : _pluginGetInfoParams
  • listSendMIMEtypes : _pluginGetInfoParams
  • listSendNames : _pluginGetInfoParams
  • localColorBits : PalmImageGIFFrameParamType
  • localColorTable : PalmImageGIFFrameParamType
  • locationData : LocsLibNotifyDataTag
  • locationDataNew : LocsLibNotifyLocsDataTag
  • locationNameOldP : LocsLibNotifyLocsDataTag
  • locationP : LocsLibSelLocsTag
  • lock : CamLibStreamTag
  • lookup : AddrPhonebookAppParamsType
  • lookupString : AddrCallerIDParamsType
  • lookupStrP : AddrPhonebookAppParamsType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- m -

  • mainParams : MailAddRecordParamsTypePlus
  • majorResult : BGResult
  • matchFound : AddrHsLookupUserDataType
  • maximumBytes : tagSndFileStreamData
  • maximumMilliseconds : tagSndFileStreamData
  • maxNum : NBSNotificationEventType
  • maxSize : ParsedInfoList
  • maxValue : CamLibSettingTag, LcdOverlayLibSettingTag
  • maxVol : HsSndPortInfo
  • MemoryFile : _PalmPhotoFileLocation
  • message : _HelperServiceMMSDetailsType
  • messageTone : SoundPreferenceMMS, SoundPreferenceSMS, SoundPreferenceIM
  • mimeType : _HelperServiceMMSObjectType
  • MIMEtype : _pluginExtendedQueryParams, _pluginSendParams, _pluginQueryParams, _pluginParams
  • minValue : CamLibSettingTag, LcdOverlayLibSettingTag
  • minVol : HsSndPortInfo
  • miscData : ParsedInfo
  • mmsSoundPrefs : SoundPreference::_tonePrefs
  • mn_aaa_spi : PhnPDPPayload
  • mn_aaa_ss : PhnPDPPayload
  • mn_aaa_ss_length : PhnPDPPayload
  • mn_ha_spi : PhnPDPPayload
  • mn_ha_ss : PhnPDPPayload
  • mn_ha_ss_length : PhnPDPPayload
  • moreData : _pluginSendParams, _pluginParams, MMProAttachStruct2
  • msgAlert : SoundPreferenceSMS
  • msgID : NBSNotificationEventType, tagIOTANotificationEventType, UPNotificationEventType, WUNotificationEventType
  • msgNumber : ParsedInfo
  • mutexSticky : NetPrefFallbackInfoType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- n -

  • nai : PhnPDPPayload
  • NAI : WUNotificationEventType
  • nai_length : PhnPDPPayload
  • name : PhoneAppLaunchCmdDialType, ToneItemType, _HelperServiceMMSObjectType, LocDBRecordTag, LocationDataTag, _PalmPhotoFileLocation, _pluginSendParams
  • nameLength : ParsedInfo
  • nameP : PhoneAppLaunchCmdCallerIDLookupType
  • NBSdatagram : NBSNotificationEventType
  • needSelLoc : LocsLibSelLocsTag
  • netTimeStamp : WUNotificationEventType
  • networkSoundPrefs : SoundPreference::_tonePrefs
  • newMailAlert : SoundPreferenceEmail
  • newPhoneNum : AddrPhonebookAppParamsType
  • nextP : _HelperServiceMMSObjectType
  • noAddToCustomDB : LocsLibSelLocsTag
  • noEditOnSelect : LocsLibSelLocsTag
  • note : LocationDataTag
  • notifyType : LocsLibNotifyDataTag
  • num_def_pdp_idxs : PhnPDPList
  • num_stand_pdp_idxs : PhnPDPList
  • num_tmp_pdp_idxs : PhnPDPList
  • numAccounts : SysVPPILaunchCmdGetAccountsType
  • numAttach : MMProLaunchStruct2, MMProLaunchStruct
  • numAttachments : MailAddRecordParamsTypePlus
  • number : PhoneAppLaunchCmdDialType
  • numberP : PhoneAppLaunchCmdCallerIDLookupType
  • numBytes : CamLibBitmapInfoTag
  • numDataLinks : _pluginSendParams, _pluginParams, MMProAttachStruct2
  • numItems : _pluginExtendedQueryParams, _pluginQueryParams
  • numProfiles : NetServicesProfileInfo
  • numReceiveTypes : _pluginGetInfoParams
  • numSelLocs : LocsLibSelLocsTag
  • numSendTypes : _pluginGetInfoParams
  • numServices : DialPnlIsDialingAvailableParamsType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- o -

  • object : _HelperServiceMMSDetailsType
  • offset : _PalmPhotoSelectionParam
  • operation : DevAppLaunchCmdGenericCallType
  • opMode : NetServicesProfileV1, NetServicesProfile
  • order : NetServicesProfileOrder
  • origCreator : SysVPPILaunchCmdPromptAndConfigureType
  • origInstance : SysVPPILaunchCmdPromptAndConfigureType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- a -

  • account : SysVPPILaunchCmdSetCurrentAccountType, SysVPPILaunchCmdDeleteAccountType, SysVPPILaunchCmdEditAccountType
  • accountID : VPNAccountType
  • accountName : VPNAccountType
  • accounts : SysVPPILaunchCmdGetAccountsType
  • actionCode : PalmAudioPlaybackNotifyEventTypeTag
  • active_idx : PhnPDPList
  • active_idx_set : PhnPDPList
  • activeCall : AddrPhonebookAppParamsType
  • add1BeforeAreaCode : HsDialPrefsUSDialingRulesType
  • alarmPreset : SoundPreferenceCalendar
  • alarmTone : SoundPreferenceCalendar
  • albumID : _PalmPhotoSelectionParam
  • alertTone : SoundPreferenceEmail
  • algorithm : PalmVideoMPEG4EncodeParamType, NetPrefFallbackInfoType
  • alsSupported : PhnRadioStateType
  • amplitude : HsSndBufferData
  • apiCreator : SndCodecCustomControlType
  • apiSelector : SndCodecCustomControlType
  • areaCodeCtl : HsDialPrefsUSDialingRulesType
  • ascP : PalmAudioAACDecParamType
  • aSize : MMProAttachStruct2, MMProAttachStruct
  • attachData : MailAddRecordAttachment
  • attachDBID : MailAddRecordAttachment
  • attachDescription : MailAddRecordAttachment
  • attachFileName : MailAddRecordAttachment
  • attachment : MMProAttachStruct2, MMProAttachStruct
  • attachments : MailAddRecordParamsTypePlus, MMProLaunchStruct2, MMProLaunchStruct
  • attachName : MMProAttachStruct2, MMProAttachStruct
  • attachSize : MailAddRecordAttachment
  • attachType : MailAddRecordAttachment
  • authentication : NetServicesProfileV1, NetServicesProfile
  • autoAreaCode : HsDialPrefsUSDialingRulesType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- b -

  • bcc : _HelperServiceMMSDetailsType, MMProLaunchStruct2, MMProLaunchStruct
  • bCroppedMode : PalmVideoAVCCustomSetCropModeType
  • binary : NBSNotificationEventType
  • bitRate : PalmVideoMPEG4EncodeParamType, PalmAudioAACParamType
  • bitsPerPixel : _PalmPhotoImageInfo, CamLibBitmapInfoTag
  • blockSize : PalmAudioADPCMParamType
  • body : MMProLaunchStruct2, MMProLaunchStruct
  • boostDB : HsSndPortInfo
  • buffer : HsSndBufferData
  • bufferLen : _HelperServiceMMSObjectType
  • bufferP : _HelperServiceMMSObjectType, _PalmPhotoFileLocation
  • bufferSize : _PalmPhotoFileLocation, HsSndBufferData
  • bufP : CamLibStreamTag
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- c -

  • calendarSoundPrefs : SoundPreference::_tonePrefs
  • callback : AddrCallerIDParamsType
  • callbackP : CamLibCaptureTag
  • captureCallback : _PalmPhotoCaptureParamV2
  • category : MailAddRecordParamsTypePlus
  • cc : _HelperServiceMMSDetailsType, MMProLaunchStruct2, MMProLaunchStruct
  • channel : NetServicesProfileV1, NetServicesProfile
  • chatTone : SoundPreferenceIM
  • chromaFormat : PalmVideoAVCCustomGetInfoType
  • clientRect : SysVPPILaunchCmdProgressPaintType
  • color : ParsedInfo
  • colorBits : PalmImageINDEXParamType
  • colorImportant : PalmImageBMPParamType
  • colorTable : PalmImageINDEXParamType
  • colorUsed : PalmImageBMPParamType
  • completion_callback : HsSndBufferData
  • completion_userdata : HsSndBufferData
  • compositionTime : PalmVideoAVCCustomGetDecodedFrameType
  • compositionTimestamp : PalmVideoAVCCustomGetDecodedFrameType
  • compression : PalmImageBMPParamType
  • confirm : PhoneAppLaunchCmdDialType
  • connection_type : PhnPDPPayload
  • controls : HsSndBufferData
  • count : AddrDescriptor
  • country : LocDBRecordTag, LocationDataTag
  • creator : _PalmPhotoFileLocation
  • currentMillisecond : tagSndFileStreamData
  • currentPan : HsSndPortInfo
  • currentVol : HsSndPortInfo
  • custom : LocDBRecordTag, LocationDataTag
  • customDataP : tagSndFileStreamData
  • customDataSize : tagSndFileStreamData
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- d -

  • data : AddrCreateNewRecordParamsType, _pluginParams, _dataLinks, MMProAttachDataLinks
  • dataDuration : tagSndFileStreamData
  • dataLen : NBSNotificationEventType, tagIOTANotificationEventType
  • dataP : DialPnlDispatchDialParamsType, NBSNotificationEventType, tagIOTANotificationEventType, PalmAudioPlaybackNotifyEventTypeTag
  • dataSize : tagSndFileStreamData
  • datetime : NBSNotificationEventType, tagIOTANotificationEventType, UPNotificationEventType, WUNotificationEventType
  • db : _pluginExtendedQueryParams, _pluginSendParams, _pluginQueryParams, _pluginParams
  • dbCardNum : LocDBInfoTag
  • dbCreatorID : LocDBInfoTag
  • dbName : LocDBInfoTag
  • dbType : LocDBInfoTag
  • defaultConnProfileName : NetMasterClientEventVPNConnInstallType
  • delayTime : PalmImageGIFFrameParamType
  • descriptionStr : DialPnlDispatchDialParamsType
  • dhcpRequestDNS : NetServicesProfileV1, NetServicesProfile
  • dial_str : PhnPDPPayload
  • dial_str_length : PhnPDPPayload
  • dialMethod : PhoneAppLaunchCmdDialType
  • dirtyBit : SysVPPILaunchCmdEditAccountType
  • dirtySelections : LocsLibSelLocsTag
  • displayCallback : _PalmPhotoDisplayParam
  • displayDialPrefs : PhoneAppLaunchCmdGetDialPrefFlagType
  • disposalMethod : PalmImageGIFFrameParamType
  • dns_server_assigned : PhnPDPPayload
  • doneButtonLabel : webBrowserMinimalModeLaunchInfo
  • driverDate : Net80211DeviceInfo
  • dSTAdjustmentInMinutes : LocDBRecordTag, LocationDataTag
  • dSTEnd : LocDBRecordTag, LocationDataTag
  • dstPort : NBSNotificationEventType
  • dSTStart : LocDBRecordTag, LocationDataTag
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- e -

  • emailSoundPrefs : SoundPreference::_tonePrefs
  • endianess : PalmImageINDEXParamType, PalmImageParamType
  • err : DialPnlDispatchDialParamsType, SysVPPILaunchCmdSetCurrentAccountType, SysVPPILaunchCmdDeleteAccountType, SysVPPILaunchCmdEditAccountType, SysVPPILaunchCmdGetAccountsType
  • error : SysVPPILaunchCmdErrorDialogType
  • errOut : SysVPPILaunchCmdWillPWPromptType, SysVPPILaunchCmdClearPWCacheType, SysVPPILaunchCmdErrorDialogType, SysVPPILaunchCmdProgressPaintType, SysVPPILaunchCmdPromptAndConfigureType
  • esdsP : PalmAudioAACDecParamType
  • eventData : NetMasterClientEventInfoType
  • eventID : NetMasterClientEventInfoType
  • eventType : PhnEventType
  • extraDigits : PhoneAppLaunchCmdDialType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- f -

  • face : VMFontType
  • failLaunchCode : PhoneAppLaunchCmdDialType
  • failLaunchCreator : PhoneAppLaunchCmdDialType
  • failLaunchParams : PhoneAppLaunchCmdDialType
  • fbStatusFlags : NetPrefFallbackInfoType
  • field : AddrCreateNewRecordParamsType
  • file : _PalmPhotoFileLocation
  • fileCreator : tagSndFileStreamFileSpec
  • fileExt : _pluginExtendedQueryParams, _pluginSendParams, _pluginQueryParams, _pluginParams
  • fileFormat : _PalmPhotoImageInfo, PalmAudioAACDecParamType, tagSndFileStreamData
  • fileLocation : _PalmPhotoCaptureParamV2, _PalmPhotoCreateParam
  • fileLocationType : _PalmPhotoFileLocation, PalmFileFormatParamType
  • fileNameP : tagSndFileStreamFileSpec
  • filesize : _PalmPhotoImageInfo
  • fileType : tagSndFileStreamFileSpec
  • filterCallback : _PalmPhotoSelectionParam
  • first_def_pdp_idx : PhnPDPList
  • first_stand_pdp_idx : PhnPDPList
  • first_tmp_pdp_idx : PhnPDPList
  • flags : AddrCallerIDParamsType, HsSndBufferData, HsSndPortInfo, tagSndFileStreamFileSpec
  • fname : _pluginParams
  • fontFaceVisible : VMFontUIRules
  • fontSizeVisible : VMFontUIRules
  • fontStyleVisible : VMFontUIRules
  • formatString : AddrCallerIDParamsType
  • frameHeight : PalmVideoAVCCustomGetInfoType
  • frameHeightCropped : PalmVideoAVCCustomGetInfoType
  • frameNum : CamLibStreamTag
  • frameP : PalmAudioAACDecParamType
  • frameRate : PalmVideoMPEG4EncodeParamType
  • frameSize : PalmAudioAACDecParamType
  • framesReady : PalmVideoAVCOutputBufferType
  • frameTime : CamLibStreamTag
  • frameWidth : PalmVideoAVCCustomGetInfoType
  • frameWidthCropped : PalmVideoAVCCustomGetInfoType
  • freeTempFile : _HelperServiceMMSObjectType
  • fwName : Net80211DeviceInfo
  • fwRev : Net80211DeviceInfo
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- g -

  • genericEventDataP : NetMasterClientEventInfoType
  • getInfo : _pluginGetInfoParams
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- h -

  • handled : DialPnlDispatchDialParamsType
  • hasLocalColorTable : PalmImageGIFFrameParamType
  • hasTransparentColor : PalmImageGIFFrameParamType
  • headerLen : NBSNotificationEventType, tagIOTANotificationEventType, UPNotificationEventType, WUNotificationEventType
  • headerP : NBSNotificationEventType, tagIOTANotificationEventType, UPNotificationEventType, WUNotificationEventType
  • height : _PalmPhotoImageInfo, PalmVideoMPEG1DecodeParamType, PalmImageINDEXParamType, PalmImagePlanarType, PalmImageParamType, CamLibBitmapInfoTag
  • home_addr : PhnPDPPayload
  • horizontalOffset : PalmVideoAVCCustomGetInfoType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- i -

  • id : ToneIdentifier
  • identifier : ToneItemType
  • idx0_set : PhnPDPList
  • idx0_uid : PhnPDPList
  • idx1_set : PhnPDPList
  • idx1_uid : PhnPDPList
  • idx2_set : PhnPDPList
  • idx2_uid : PhnPDPList
  • idx3_set : PhnPDPList
  • idx3_uid : PhnPDPList
  • idx4_set : PhnPDPList
  • idx4_uid : PhnPDPList
  • idx5_set : PhnPDPList
  • idx5_uid : PhnPDPList
  • idx6_set : PhnPDPList
  • idx6_uid : PhnPDPList
  • idx7_set : PhnPDPList
  • idx7_uid : PhnPDPList
  • idx_RSVD8_set : PhnPDPList
  • idx_rsvd8_uid : PhnPDPList
  • idx_RSVD9_set : PhnPDPList
  • idx_rsvd9_uid : PhnPDPList
  • ifCreator : vpnNotifyVPNLibTag
  • ifInstance : vpnNotifyVPNLibTag
  • imageBits : AddrPhotoCallerIDParamsType
  • imageCount : _PalmPhotoSelections
  • imageDataP : PalmImageINDEXParamType, PalmImageGIFFrameParamType
  • imageDataSize : PalmImageGIFFrameParamType
  • imageFormat : _PalmPhotoReadWriteParam
  • imageH : _PalmPhotoSelections
  • imageHeight : PalmImageGIFFrameParamType
  • imageInfo : _PalmPhotoCaptureParamV2, _PalmPhotoCreateParam
  • imageQuality : _PalmPhotoImageInfo
  • imageWidth : PalmImageGIFFrameParamType
  • imSoundPrefs : SoundPreference::_tonePrefs
  • info : ParsedInfoList
  • infoP : _PalmPhotoExtraInfo
  • infoSize : _PalmPhotoExtraInfo
  • infoType : _PalmPhotoExtraInfo
  • inReserved1 : NetMasterClientEventInfoType, NetMasterClientEventVPNConnInstallType
  • inReserved2 : NetMasterClientEventInfoType, NetMasterClientEventVPNConnInstallType
  • inReserved3 : NetMasterClientEventInfoType
  • inReserved4 : NetMasterClientEventInfoType
  • interactive : MMProLaunchStruct
  • ipAllocType : NetServicesProfileV1, NetServicesProfile
  • ipGateway : NetServicesProfileV1, NetServicesProfile
  • ipMask : NetServicesProfileV1, NetServicesProfile
  • ipPrimaryDNS : NetServicesProfileV1, NetServicesProfile
  • ipSecondaryDNS : NetServicesProfileV1, NetServicesProfile
  • isInterlaced : PalmImageGIFFrameParamType
  • isVFSFileName : _HelperServiceMMSObjectType
  • item : _pluginSendParams
  • itemDescriptors : _pluginQueryParams
  • itemLength : ParsedInfo
  • itemSizes : _pluginQueryParams
  • IVOPQuantization : PalmVideoMPEG4EncodeParamType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- p -

  • pageNum : _HelperServiceMMSObjectType
  • parsedType : ParsedInfo
  • password : WUNotificationEventType
  • pdp_services : PhnPDPPayload
  • pdpDataCompression : PhnGPRSPDPContextType, NetPrefGPRSQOSType
  • pdpHeaderCompression : NetPrefGPRSQOSType
  • phoneSoundPrefs : SoundPreference::_tonePrefs
  • picHeight : PalmVideoAVCCustomGetDecodedFrameType
  • picHeightCropped : PalmVideoAVCCustomGetDecodedFrameType
  • picWidth : PalmVideoAVCCustomGetDecodedFrameType
  • picWidthCropped : PalmVideoAVCCustomGetDecodedFrameType
  • planeCount : PalmImagePlanarType
  • planeP : PalmImagePlanarType
  • planeWidth : PalmImagePlanarType
  • playbackCount : tagSndFileStreamData
  • playSoundTimes : SoundPreferenceCalendar
  • portID : HsSndPortInfo
  • position : LocationDataTag
  • preambleType : NetServicesProfileV1, NetServicesProfile
  • preSelect : LocsLibSelLocsTag
  • presetTime : SoundPreferenceCalendar
  • presetTimeUnit : SoundPreferenceCalendar
  • prim_dns_addr : PhnPDPPayload
  • prim_ha_addr : PhnPDPPayload
  • privacy : SoundPreferenceSMS
  • profile : PalmVideoMPEG4DecodeParamType, PalmVideoMPEG4EncodeParamType, PalmAudioAACParamType
  • profileEntrySize : NetServicesProfileInfo
  • profileName : NetServicesProfileV1, NetServicesProfile
  • profileRev : NetServicesProfileInfo
  • progress_callback : HsSndBufferData
  • progress_userdata : HsSndBufferData
  • protectedTone : ToneItemType
  • protocolErr : BGResult
  • protocolErrString : BGResult
  • ptr : _pluginSendParams
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- q -

  • qnc_set : PhnPDPList
  • qnc_uid : PhnPDPList
  • qosMinDelayClass : NetPrefGPRSQOSType
  • qosMinMeanThruClass : NetPrefGPRSQOSType
  • qosMinPeakThruClass : NetPrefGPRSQOSType
  • qosMinPrecedenceClass : NetPrefGPRSQOSType
  • qosMinReliabilityClass : NetPrefGPRSQOSType
  • qosReqDelayClass : NetPrefGPRSQOSType
  • qosReqMeanThruClass : NetPrefGPRSQOSType
  • qosReqPeakThruClass : NetPrefGPRSQOSType
  • qosReqPrecedenceClass : NetPrefGPRSQOSType
  • qosReqReliabilityClass : NetPrefGPRSQOSType
  • quality : PalmImageJPEGEncodeParamType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- r -

  • rcptAlert : SoundPreferenceSMS
  • reasonCode : WUNotificationEventType
  • recordNum : AddrPhotoCallerIDParamsType, AddrCallerIDParamsType
  • rect : _PalmPhotoDisplayParam
  • ref : AddrCallerIDParamsType
  • refNum : NBSNotificationEventType
  • reminderTone : SoundPreferenceCalendar
  • repeatAlarmTimes : SoundPreferenceCalendar
  • repeated : PhoneAppLaunchCmdSendDTMFToneType
  • repeatInterval : SoundPreferenceCalendar
  • reqIP : NetServicesProfileV1, NetServicesProfile
  • requestSmsInfo : PhnLibLengthInfoType
  • reserved : LocsLibSelLocsTag, LocDBRecordTag, LocationDataTag, _PalmPhotoExtraInfo, _PalmPhotoFileLocation, NetPrefGPRSQOSType, _PalmPhotoReadWriteParam, _PalmPhotoSelectionParam
  • reserved0 : NBSNotificationEventType, CamLibBitmapInfoTag
  • reserved1 : NBSNotificationEventType, AddressAppRecord, HsSndBufferData, HsSndPortInfo, CamLibBitmapInfoTag
  • reserved1a : NBSNotificationEventType
  • reserved2 : NBSNotificationEventType, tagIOTANotificationEventType, UPNotificationEventType, WUNotificationEventType, HsSndBufferData, HsSndPortInfo
  • reserved3 : NBSNotificationEventType, tagIOTANotificationEventType, UPNotificationEventType, WUNotificationEventType
  • response : DevAppLaunchCmdGenericCallType
  • restartInterval : PalmImageJPEGEncodeParamType
  • restrict_ha_addr : PhnPDPPayload
  • restrict_home_addr : PhnPDPPayload
  • restrict_mn_aaa_spi : PhnPDPPayload
  • restrict_mn_aaa_ss : PhnPDPPayload
  • restrict_mn_ha_spi : PhnPDPPayload
  • restrict_mn_ha_ss : PhnPDPPayload
  • restrict_nai : PhnPDPPayload
  • restrict_rev_tunnel_pref : PhnPDPPayload
  • result : DialPnlIsDialingAvailableParamsType
  • resultString : AddrCallerIDParamsType
  • ret : _pluginExtendedQueryParams, _pluginSendParams, _pluginQueryParams, _pluginParams, _pluginGetInfoParams
  • rev_tunnel_pref : PhnPDPPayload
  • roamingTone : SoundPreferencePhone
  • rowByte : PalmImageINDEXParamType, PalmImageParamType
  • rulesEnabled : HsDialPrefsUSDialingRulesType
  • rwCallback : _PalmPhotoReadWriteParam
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- s -

  • sampleBlockAlign : tagSndFileStreamData
  • sampleFormat : tagSndFileStreamData
  • sampleRate : PalmAudioAACParamType, PalmAudioADPCMParamType, PalmAudioPCMParamType, tagSndFileStreamData
  • sampleType : PalmAudioPCMParamType, tagSndFileStreamData
  • sampleWidth : PalmAudioAACParamType, PalmAudioADPCMParamType, PalmAudioPCMParamType, tagSndFileStreamData
  • searchRange : PalmVideoMPEG4EncodeParamType
  • sec_dns_addr : PhnPDPPayload
  • sec_ha_addr : PhnPDPPayload
  • secsFromNow : SysVPPILaunchCmdWillPWPromptType
  • segmentCount : PhnLibLengthInfoType
  • selectedDescriptor : _pluginSendParams
  • selectedImages : _PalmPhotoSelectionParam
  • selectedItem : _pluginSendParams
  • selectionCount : _PalmPhotoSelectionParam
  • selLocsListP : LocsLibSelLocsTag
  • sendChangeNotify : LocsLibSelLocsTag
  • senderCreatorId : DevAppLaunchCmdGenericCallType
  • senderP : NBSNotificationEventType
  • seqNum : NBSNotificationEventType
  • serialNumber : Net80211DeviceInfo
  • serialNumberSize : Net80211DeviceInfo
  • serviceID : DialPnlDispatchDialParamsType
  • serviceIDsP : DialPnlIsDialingAvailableParamsType
  • serviceTone : SoundPreferencePhone
  • set_mn_aaa_spi : PhnPDPPayload
  • set_mn_ha_spi : PhnPDPPayload
  • showWaitDialogue : LocsLibNotifyDataTag
  • signature : HsSndBufferData, HsSndPortInfo
  • size : VMFontType, PhnLibLengthInfoType, ParsedInfoList, CamLibStreamTag, _pluginExtendedQueryParams, _pluginSendParams, _pluginParams, _dataLinks, MMProAttachDataLinks
  • sizeRule : VMFontUIRules
  • skipBFrames : PalmVideoMPEG1DecodeParamType
  • smsSoundPrefs : SoundPreference::_tonePrefs
  • soundOffVibrate : SoundPreference
  • soundOnVibrate : SoundPreference
  • soundOnVolume : SoundPreference
  • srcPort : NBSNotificationEventType
  • SSID : NetServicesProfileV1, NetServicesProfile
  • ssidLength : NetServicesProfileV1, NetServicesProfile
  • stage : SysVPPILaunchCmdProgressPaintType
  • startLocation : ParsedInfo
  • status : CamLibStatusTag
  • stepDB : HsSndPortInfo
  • stepVol : HsSndPortInfo
  • stored_mn_aaa_ss : PhnPDPPayload
  • streamComplete : tagSndFileStreamData
  • StreamFile : _PalmPhotoFileLocation
  • streamFileHandle : PalmFileFormatParamType
  • streamFlags : tagSndFileStreamData
  • streamMode : tagSndFileStreamData
  • streamRefCon : tagSndFileStreamData
  • stride : PalmVideoAVCCustomGetDecodedFrameType
  • style : VMFontType
  • styleRule : VMFontUIRules
  • subject : _HelperServiceMMSDetailsType, MMProLaunchStruct2, MMProLaunchStruct
  • subSampling : PalmImageJPEGEncodeParamType
  • substitution : PhnLibLengthInfoType
  • supported : _pluginExtendedQueryParams
  • supportsReceiving : _pluginGetInfoParams
  • supportsSending : _pluginGetInfoParams
  • svc_str : PhnPDPPayload
  • svc_str_length : PhnPDPPayload
  • svcID : webBrowserURLWithSvcIDLaunchInfo
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- t -

  • tempFileName : _HelperServiceMMSObjectType
  • to : MMProLaunchStruct2, MMProLaunchStruct
  • tone : PhoneAppLaunchCmdSendDTMFToneType
  • tonePrefs : SoundPreference
  • toneType : ToneIdentifier
  • topPosition : PalmImageGIFFrameParamType
  • transparentColorIndex : PalmImageGIFFrameParamType
  • type : AddrListLookupTypeGetParamsType, _PalmPhotoFileLocation, CamLibSettingTag, _pluginExtendedQueryParams, MMProAttachStruct2, MMProAttachStruct, LcdOverlayLibSettingTag
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- u -

  • uid : PhnPDPPayload
  • uniqueID : AddrCallerIDParamsType
  • unityVol : HsSndPortInfo
  • unknownCallerTone : SoundPreferencePhone
  • Unused : _pluginExtendedQueryParams, _pluginSendParams, _pluginQueryParams, _pluginParams, _pluginGetInfoParams
  • UPData : UPNotificationEventType
  • useMultiFilter : AddrHsLookupUserDataType
  • userDataP : CamLibCaptureTag, DevAppLaunchCmdGenericCallType, _PalmPhotoCaptureParamV2, _PalmPhotoDisplayParam, _PalmPhotoReadWriteParam, _PalmPhotoSelectionParam
  • useSavedAccount : SysVPPILaunchCmdEditAccountType
  • useWizardUI : SysVPPILaunchCmdEditAccountType
  • uTC : LocDBRecordTag, LocationDataTag
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- v -

  • validFlags : Net80211DeviceInfo
  • value : CamLibColorSpaceTag, CamLibSettingTag, LcdOverlayLibSettingTag
  • valueLenP : SndCodecCustomControlType
  • valueP : SndCodecCustomControlType
  • version : PhoneAppLaunchCmdDialType, AddrHsLookupUserDataType, AddrListLookupTypeGetParamsType, NBSNotificationEventType, tagIOTANotificationEventType, UPNotificationEventType, WUNotificationEventType, _HelperServiceMMSDetailsType, _pluginParams, _pluginGetInfoParams, NetMasterClientEventInfoType, PalmAudioPlaybackNotifyEventTypeTag
  • verticalOffset : PalmVideoAVCCustomGetInfoType
  • VFSFile : _PalmPhotoFileLocation
  • vfsFileRef : PalmFileFormatParamType
  • voicemailTone : SoundPreferencePhone
  • volHeight : PalmVideoMPEG4DecodeParamType, PalmVideoMPEG4EncodeParamType
  • volRefNum : tagSndFileStreamFileSpec
  • volumeRef : _PalmPhotoFileLocation
  • volWidth : PalmVideoMPEG4DecodeParamType, PalmVideoMPEG4EncodeParamType
  • VOVOLVersionID : PalmVideoMPEG4EncodeParamType
  • vpnConnInstallP : NetMasterClientEventInfoType
  • vpnConnProfileOverrideName : NetMasterClientEventVPNConnInstallType
  • vppiCreator : VPNAccountType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- w -

  • wallpaperLocation : PhoneAppLaunchCmdSetWallpaperType
  • wallpaperUID : PhoneAppLaunchCmdSetWallpaperType
  • warnIfLocExists : LocsLibSelLocsTag
  • wep : NetServicesProfileV1, NetServicesProfile
  • width : _PalmPhotoImageInfo, PalmVideoMPEG1DecodeParamType, PalmImageINDEXParamType, PalmImagePlanarType, PalmImageParamType, CamLibBitmapInfoTag
  • winH : _PalmPhotoDisplayParam
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- x -

  • xExtent : AddrPhotoCallerIDParamsType
  • xPixelsPerMeter : PalmImageBMPParamType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


  • All
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- y -

  • yExtent : AddrPhotoCallerIDParamsType
  • yPixelsPerMeter : PalmImageBMPParamType
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:32 2006 for Palm API Guide


Palm API Guide Modules

Here is a list of all modules:
  • Carrier Customization Library
  • HTML Library
  • HTTP Library
  • NetMaster Library
  • NetPref Library
  • Network Library
  • Smart Text Engine Library
  • Telephony Library
  • Hardware Utility Library
  • Background Service Library
  • Display Extent Library
  • System API
  • Status Bar Library
  • Pen Input Manager Library
  • Camera Library
  • Codec Plugin Manager
  • Default Helper Library
  • Favorites Database Library
  • File Browser Library
  • Hi-Resolution Timer Library
  • Sound Library
  • Imaging Library
  • LCD Overlay Library
  • Locations Library
  • Multi Connector Library
  • Key Library
  • Gadget Library
  • UI Utility Library
  • Ring Tone Library
  • Transparency Library
  • Versamail Library
  • Handspring Extensions
  • 5-Way Navigation Library
  • Full Screen Writing API
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Carrier Customization Library

Files

  • file CarrierCustomLibErr.h
    This file contains the error codes for the Carrier Customization Library.

  • file CarrierCustomLibTraps.h
    This file contains the trap for the Carrier Customization Library.

  • file CarrierCustomLibTypes.h
    This file contains public data types exported by the Carrier Customization Library.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


HTML Library

Detailed Description

The HTML Library helps applications render data. Please note that there is a limit of 64K of text data for a single content data object, so it is recommended that you do appropriate checks when adding text data for rendering, especially when adding text data repeatedly. Additionally, the caller application is required to provide a set of form widget creation functions to the Html Library for dynamic UI creation. Please see the HtmlLibSetFormWidgetProc routine for details.

Note:
It is important to be aware that this library modifies the active form pointer, so make sure to NOT cache the form pointer, but re-get it before use.

Files

  • file HtmlLib68K.h
    Public 68K include file for HTML shared library.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


HTTP Library

Files

  • file HS_HTTPLib68K.h
    Public 68k include file for the HTTP Library.

  • file HS_HTTPLibApp.h
    Public 68k header file containing the structures used in HTTP Library.

  • file HS_HTTPLibConst.h
    Public 68k header file containing the constants used in HTTP Library.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


NetMaster Library

Files

  • file NetMasterLibrary.h
    This is the main header file for the NetMaster Library.

  • file NetMasterLibTypes.h
    This file contains public data types exported by the NetMaster Library.

  • file NetMasterLibErrors.h
    This is the error declarations file for the NetMaster Library.

  • file NetMasterLibTarget.h
    This is the target parameters file for the NetMaster Library.

  • file NetMasterLibTraps.h
    Trap definitions for the NetMaster Library.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


NetPref Library

Files

  • file NetPrefLibrary.h
    This is the main header file for the NetPref Library.

  • file NetPrefLibTypes.h
    This file contains public data types exported by the NetPref Library.

  • file NetPrefLibErrors.h
    This is the error declarations file for the NetPref Library.

  • file NetPrefLibTarget.h
    This is the target parameters file for the NetPref Library.

  • file NetPrefLibTraps.h
    Trap definitions for the NetPref Library.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Network Library

Files

  • file PalmNetServices.h
    NetServices provides a set of API to access 802.11.

  • file PalmVPPI.h
    This is the API for VPN panel plug-ins (VPPIs).

  • file PalmWiFiCommon.h
    Constants and structures common to the wifi network panel and driver.

  • file PalmWPPI.h
    This is the API for Wi-Fi panel plug-ins (WPPIs).

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Smart Text Engine Library

Files

  • file SmartTextEngineDef.h
    Public include file for Smart Text Engine shared library.

  • file SmartTextEngineErrors.h
    Error codes for Smart Text Engine shared library.

  • file SmartTextEngineTraps.h
    Trap definitions for the Smart Text Engine shared library.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Telephony Library

Files

  • file HsPhone.h
    Header file for the phone library (CDMA or GSM).

  • file HsPhoneAudio.h
    Header File for Phone Library API ---- AUDIO CATEGORY.

  • file HsPhoneCDMA.h
    Header File for Phone Library API ---- CDMA CATEGORY.

  • file HsPhoneGSM.h
    Header File for Phone Library API ---- GSM CATEGORY.

  • file HsPhoneIOTA.h
    Header File for Phone Library API ---- IOTA CATEGORY.

  • file HsPhoneLibrary.h
    Header File for Phone Library API ---- LIBRARY CATEGORY.

  • file HsPhoneMisc.h
    Header File for Phone Library API ---- MISC CATEGORY.

  • file HsPhoneNetwork.h
    Header File for Phone Library API ---- NETWORK CATEGORY.

  • file HsPhonePower.h
    Header File for Phone Library API ---- POWER CATEGORY.

  • file HsPhoneSecurity.h
    Header File for Phone Library API ---- SECURITY CATEGORY.

  • file HsPhoneSMS.h
    Header File for Phone Library API ---- SMS CATEGORY.

  • file HsPhoneAudioTypes.h
    File contains Phone Audio data types.

  • file HsPhoneCallControlTypes.h
    Types for Phone Library call control functionality.

  • file HsPhoneCDMATypes.h
    Header File for Phone Library API ---- NETWORK CATEGORY.

  • file HsPhoneErrors.h
    Errors returned by API function in GSM/CDMA Library.

  • file HsPhoneEvent.h
    Header file for the phone library (CDMA or GSM).

  • file HsPhoneGSMTypes.h
    Header File for Phone Library API ---- NETWORK CATEGORY.

  • file HsPhoneIOTATypes.h
    Header File for Phone Library API ---- IOTA CATEGORY.

  • file hsPhoneLocationTypes.h
    File contains Phone Location data types.

  • file HsPhoneMiscTypes.h
    Header File for Phone Library API ---- NETWORK CATEGORY.

  • file HsPhoneNetworkTypes.h
    Header File for Phone Library API ---- NETWORK CATEGORY.

  • file HsPhoneSecurityTypes.h
    Header File for Phone Library API ---- NETWORK CATEGORY.

  • file HsPhoneSMSTypes.h
    Header File for Phone Library API ---- NETWORK CATEGORY.

  • file HsPhoneTrace.h
    Trace constants, types, and definitions for Phone Library.

  • file HsPhoneTraps.h
    Traps of all functions exported by the Phone Library.

  • file HsPhoneTypes.h
    Telephony data types that are common between ARM and 68K.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Hardware Utility Library

Detailed Description

This library provides support for applications to control the state of certain pieces of hardware on the device.

This library currently allows the application to programmatically turn the display on/off as well as controling the behavior of the LED light if available.

Files

  • file HardwareUtils68K.h
    Public common header file to the Hardware Utilities Library used by 68K applications.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Background Service Library

Detailed Description

This library provides support for applications to perform background network request bypassing NetLib through the default connection.

Application can use this library to connect to a server on a network and perform network request by sending protocol-specific string and receiving the returned response. Applications can also utilize this library to make background HTTP request by connecting to a web server at port 80 and sending HTTP GET/POST string with specific URL.

Network requests are queued up and the responses are returned through the callback function that is passed to the network request API.

Files

  • file PalmBGService.h
    Public 68K header file for palmOne Background Network Service Library.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Display Extent Library

Files

  • file PalmDisplayExtent.h
    Public API for the Display Extent Library.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


System API

Files

  • file PalmErrorBase.h
    Include file for Error Management.

  • file PalmLaunchCodes.h
    Device specific launch codes.

  • file PalmLED.h
    Palm's Generic LED dirver.

  • file PalmNative.h
    Functions and macros to help building ARM code.

  • file PalmPower.h
    Battery notification.

  • file PmPalmOSNVFS.h
    Public 68k header file containing the definitions and API for NVFS devices.

  • file HsChars.h
  • file HsCreators.h
    Public header file for the creator IDs used by Handspring.

  • file HsErrors.h
  • file PalmCreators.h
    Contains Palm-specific creator codes.

  • file PalmFeatures.h
    Contains Palm-specific feature definitions.

  • file palmOneCreators.h
    Contains Palm-specific creator codes.

  • file palmOneFeatures.h
    Contains Palm-specific feature definitions.

  • file palmOneResources.h
    Palm-specific system types and resources.

  • file PalmShimSettings.h
    Shim settings for NetIFSettingGet()/Set().

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Status Bar Library

Detailed Description

This library provides support to manipulate the state of the status bar on devices that utilize the Dynamic Input Area (DIA).

Devices such as Tungsten T3 and Tungsten T5 allow users to collapse/expand the input area to support tall forms. This library allows the status/control bar to be hidden programmatically so that forms can be displayed full screen.

Most of the APIs in the library should already exist in Palm OS SDK, and applications that are developed for DIA-enabled OS should first try to use the PalmSource's status bar API.

Files

  • file palmOneStatusBar.h
    Public common header file for palmOne defined Status Bar library.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Pen Input Manager Library

Files

  • file PalmPin.h
    Public API for the Pen Input Manager Library.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Camera Library

Detailed Description

This library provides camera support for Zire 72 and Treo 650 devices.

Developers who want to provide camera support to their application on Zire 72 and Treo 650 devices should use Camera Manager Library API instead of the old Camera Library.

Files

  • file CameraLib.h
    Public 68K include file for camera support for Treo 600 devices.

  • file palmOneCamera.h
    Public 68K include file for camera support for Treo 650 devices. This version of the library adds functionality for Zire72, and Treo 650.

  • file palmOneCameraSlider.h
    Public 68K file for camera slider notification for Zire 71 devices.

  • file CameraLibCommon.h
    Public 68K common header file for camera support for Treo 600 devices.

  • file palmOneCameraCommon.h
    Public 68K common header file for camera support for Zire 72 and Treo 650 devices.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Codec Plugin Manager

Detailed Description

This library is used to provide support for audio/video/image codecs plugin and encoding/decoding routines.

The Codec Plugin Manager library is used to unify all different type of codecs that are available for palmOne devices and provide a generic API for developers to access these codecs for encoding/decoding.

A typical application would use the library the following way:

  • Check if an input/output format pair is supported [optional]
  • Create a CodecSession with parameters that match the formats
  • Call EncodeDecode()
  • ...
  • Delete the session

For more information, please also check the palmOne Developer Guide.

Files

  • file palmOneCodecPluginMgr.h
    The Codec Plugin Manager is used to unify all different type of codecs that are available for PalmOne devices and provide a generic API for developers to access these codecs.

  • file palmOneCodecFormat.h
    Public 68K common header file for Codec Plugin Manager API - Codec Formats.

  • file palmOneCodecPluginMgrCommon.h
    Public 68K common header file for Codec Plugin Manager API - Library Definitions.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Default Helper Library

Detailed Description

This library is used to provide support for applications to be the default handler for certain services on the device.

This library is used in conjunction with Helper API from the Palm OS SDK. Typically, an application which wants to be a default app to handle certain services (SMS, Email, etc) will register itself in the following way:

  • Check if the application is already the default handler for a particular service
  • Call DefaultHelperLibSetDefaultHelper() if it's not already the default app. Please refer to Palm OS Helper API Service Class ID Constants for service ID.

Files

  • file DefaultHelperLib.h
    Default Helper library owns control over the Default Helpers database.

  • file DefaultHelperLibTypes.h
    Public 68K common header file for Default Helper Library API.

  • file MmsHelperCommon.h
    Public 68k common header files to be used with Default Helper Library.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Favorites Database Library

Detailed Description

This library is used to provide support for applications to insert new entries to the Phone Favorites view on Treo 650 devices.

An application which wants to insert a new entry to the Phone application Favorites view programmatically can call the appropriate FavDBNew*() API depending on the favority type. Currently, this library supports adding new application, phone number, sms destination, web url, email address, and phone view.

Files

  • file FavoritesDBLib.h
    Contains the API to control the Favorites DB.

  • file FavoritesDBLibTypes.h
    Public 68K common header file for FavoritesDB library API.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


File Browser Library

Detailed Description

This library is used to provide support for Files application integration.

Applications which want to utilize the File Browser UI or register itself with the Files application on Tungsten devices should use this library to do so. Registration with the Files app has to be done in addition to registration with the Exchange Library.

Registering with the Files application is also done using Exchange Library but with palmOne defined registration IDs (exgRegEditCreatorID, etc). This will enable the application to be launched automatically when a certain file type or extension is selected on the Files app. Developers can also use the APIs available in this library to present File Browser UI in their own application to the user (open and save dialogs).

Files

  • file FileBrowserLib68K.h
    This file contains the FileBrowser Library APIs.

  • file FileBrowserLibCommon.h
    Public 68K common header file for File Browser library API.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Hi-Resolution Timer Library

Detailed Description

This library provides support for high resolution timer on Palm OS devices.

Applications which would like to use a more granular (higher resolution) timer than the standard Palm OS sysTicksPerSecond() can use this library to do so.

Files

  • file palmOneHiResTimer.h
    Public 68k include file for Hi-Resolution timer for Palm OS.

  • file PalmHiResTime.h
    Exported High Resolution timer definitions.

  • file palmOneHiResTimerCommon.h
    Public 68k common header file for Hi-Resolution Timer API.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Sound Library

Detailed Description

This library provides support for the specific sound functionality of the Treo smartphones.

Developers should be able to use Palm OS Sound Manager APIs for most of the work. The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application (ie. SysLibFind() returns a valid refNum). When the application is done with the library it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal synchronization.

Files

  • file PalmAudioPlayback.h
    Public 68K include file that supports the stopping of audio playback on Treo 600 and Treo 650 smartphones.

  • file PalmSoundCustomCtrl.h
    Public 68K include file for the Sound Manager custom controls for the IMA_ADPCM codec for Treo 600 and Treo 650 smartphones.

  • file PalmSoundMgrExt.h
    Public 68K include file for the Extended Sound Manager.

  • file HsSoundLib.h
    Public 68K include file for main sound support for Treo 600 and Treo 650 smartphones.

  • file palmOneSndFileStream.h
    Public 68K include file for sound files stream support for Treo 600 and Treo 650 smartphones.

  • file HsSoundLibCommon.h
    Public 68K common header file for sound support for Treo 600 and Treo 650 smartphones.

  • file PmSoundLibAudioGroup.h
    Public 68K header file used to associate sound channels with Audio groups on Treo 600 and Treo 650 smartphones.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Imaging Library

Detailed Description

This library provides support for image drawing and manipulation on Treo 600 devices.

Applications can use this library to draw JPEG images on the screen or create thumbnails and such on the Treo 600 devices. This library also allows some interaction with the camera within the 3rd party application itself. For the newer devices, developers should try to use palmOne Photo Library before using the Image Library.

palmOne Photo Library allows better integration with the built-in Media application and storing image on the device. Developers who would like to use this library should first check the version of the library and then make the appropriate API calls depending on the version.

The database API provides applications with the ability to:

  • Get the list of albums.
  • Create, delete and rename albums.
  • Get the list of photos in each album.
  • Add photos to albums.

The image manipulation API provides applications with the ability to:

  • Create and capture images and video clips.
  • Read and write image data.
  • Convert images to different formats.
  • Display images.
  • Scale, rotate and crop images.

Files

  • file ImageLib.h
    Public 68k include file for the Imaging Library.

  • file palmOnePhoto.h
    Palm Photos API: This API is used to access Palm Photos database and manipulate images.

  • file ImageLibCommon.h
    Public 68k common header file for the Image Library API on Treo 600 devices.

  • file palmOnePhotoCommon.h
    Palm Photos API: This file contains all the defines, enumerations, structures needed by PalmPhoto.h.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


LCD Overlay Library

Detailed Description

This library provide support for displaying YCbCr images directly on the screen.

Note that the image that is drawn on the screen will always sit on top of the form above everything else.

Files

  • file palmOneLcdOverlay.h
    Public 68k include file for LCDOverlay API that can be used to display YCbCr images directly on the screen.

  • file PalmLcdOverlay.h
    Exported LCD Overlay functions.

  • file palmOneLcdOverlayCommon.h
    Public 68k common header file for LCDOverlay API.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Locations Library

Detailed Description

This library provides location/timezone/DST support for applications.

Developers who want to provide location/timezone/DST or country information to their application on Palm devices should use Locations Library API.

Files

  • file LocsLib.h
    Public 68K include file for location/timezone/DST support on Palm devices.

  • file LocsLibCommon.h
    Public 68K common header file for locations library.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Multi Connector Library

Detailed Description

This library provides support for multi-connector related functionalities.

Applications can register itself to be notified when a peripheral is attached or detached to the multi-connector port. Applications can also use this library to enable/disable the power pin and to re-route audio output.

Files

  • file PmConnectorLib.h
    palmOne library that exports multi-connector related APIs.

  • file PmConnectorLibCommon.h
    Public 68k common header file for Multi-Connector Library for palmOne devices that use multi-connector.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Key Library

Detailed Description

This library provides support for the key-related functionalities.

Application can use this library to detect the state of particular keys, whether they are pressed or released. This library can also be used to enable/disable a certain key programmatically, translate keycodes to characters, and also manage the different settings of the keypad.

Files

  • file PmKeyLib.h
    System Library that exports key-related APIs.

  • file PmKeyLibCommon.h
    Public 68k common header file for system library that exports key-related APIs.

  • file HsKeyCodes.h
  • file HsKeyCommon.h
    Header file with additional keyboard related definitions.

  • file HsKeyTypes.h
    palmOne's key constant definitions shared by DAL and Palm OS (see Palm OS' CmnKeyTypes.h)

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Gadget Library

Detailed Description

This library provides supports for application that wants to manage system gadgets or support big buttons in the applications.

Application that wishes to update/ retrieve the status of system gadget such as the battery indicator, signal strength or bluetooth indicator can use this library to do so. This library also provides APIs for application that wants to include big button resource.

Files

  • file PmSysGadgetLib.h
    System Library that exports status-related APIs.

  • file PmSysGadgetLibCommon.h
    Public 68k header file for system Library that exports system gadget related APIs.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


UI Utility Library

Detailed Description

This library provides support for the misc. UI-related functionalities.

Applications can use this library API to retrieve the different layers of colors of the focus ring and use the colors to manually draw custom-shaped focus rings. Please also refer to the HsNav.h header file for more of the library constants and definitions.

Files

  • file PmUIUtilLib.h
    This is the public header for PmUIUtil library.

  • file PmUIUtilLibCommon.h
    Public 68k common header file for system Library that exports UI utility API functions.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Ring Tone Library

Detailed Description

This library provides support for application that wants to manage or play ring tones from within the application itself.

Applications that wish to play, manage or create ring tones from within the application themselves can use the APIs provided by this library. This library can also be used to set different ring tones preferences that are used by the system when there is, for example, an incoming call, email or sms alert, etc.

The calling application should always load this library with SysLibLoad() before use, even if it is already open by another application(ie, SysLibFind() returns a valid refnum). When the application is done with the library, it should be unloaded with SysLibRemove(). We do this because there is no good way to synchronize loading and unloading of libraries among multiple applications. It also greatly simplifies internal synchronization.

Files

  • file TonesLib.h
    Public 68K include file that controls the MIDI tones on a device.

  • file TonesLibTypes.h
    Public 68K header file for the Ring Tone library on Treo devices.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Transparency Library

Detailed Description

This library can be used to couple data between a Ccp channel and a serial port.

It is meant to be used for diagnostics and tethered mode. Since it is a library, it can work without being in a certain application.

Files

  • file TransparencyLib.h
    Transparency Library that couples a Ccp channel and a serial port.

  • file TransparencyLibTypes.h
    Public common header file for the Transparency Library on Treo devices.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Versamail Library

Detailed Description

This library provide supports for application that wish to provide users with the Versamail Font Picker dialog and support the font from with the app.

This library also allows application to programmatically manage style and size for the font types that Versamail support. Other VersaMail supports include launching VersaMail to add a new email with attachment and also the ability to create a plugin to send/view attachments.

Files

  • file palmOneVMFontLib.h
    Defines APIs and structures for the Palm VersaMail Font Picker / Font Manager Service which lets users get / set font characteristics.

  • file PalmVMLaunch.h
    Defines APIs and structures for launching VersaMail to add a new message from an application.

  • file PalmVMPlugin.h
    Defines APIs and structures for the VersaMail Plugin Service which lets users write plugins to view/send attachments.

  • file VMFontLibCommon.h
    Public common header file for the Versamail Font Library.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Handspring Extensions

Files

  • file HsExt.h
    Header file that 68K programs include to access Handspring Extensions functionality.

  • file HsExtCommon.h
    Common defines shared between HsExt.h (include for 68K programs) and HsExtArm.h (include for ARM programs).

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


5-Way Navigation Library

Detailed Description

This library provides 5-way navigation support for applications on the Treo 600 devices.

The 5-way navigation features and APIs described here have already existed in Palm OS SDK for Palm OS ver. 5.4.1 and above, and applications that are developed for newer devices should be using PalmSource's Palm OS definitions of these features and APIs. Developers can use palmOne defined features to extend support back to Treo 600 devices.

For more information on 5-way navigation support, please refer to palmOne Developer Guide and also the Palm OS Documentation.

Files

  • file HsNav.h
    Header file that 68K programs include to access HsNav functionality.

  • file HsNavCommon.h
    Public common header file for 5-way navigation support on Treo 600.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Full Screen Writing API

Detailed Description

This library provides support for applications to enable/disable full screen graffiti programmatically.

Applications can use the functions in this library to enable or disable fullscreen writing, enable and disable the Graffiti 2 shift indicator (GSI) as a control for fullscreen writing, enable and disable Graffiti 2 inking, and even change the colors of Graffiti 2 inking and the GSI.

Developers can check whether the GoLCD Manager is installed by examining its feature set. Call FtrGet as follows:

 err = FtrGet (goLcdCreator, goLcdFtrNumVersion, &value);

Files

  • file PalmGoLCD.h
    Public include header file for the GoLCD Library.

  • file PalmGoLCDCommon.h
    Public common header file for the GoLCD Library.

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- _ -

  • _80211InfrastructureEnum : PalmWiFiCommon.h
  • _GSMATEventInputEchoModeEnum : HsPhoneGSMTypes.h
  • _GSMDialCLIRMode : HsPhoneTypes.h
  • _GSMSATDataSvcTypeEnum : HsPhoneGSMTypes.h
  • _GSMSATEventInputFormatEnum : HsPhoneGSMTypes.h
  • _GSMSATEventMenuFlag : HsPhoneGSMTypes.h
  • _GSMSATEventSetupCallCallTypeEnum : HsPhoneGSMTypes.h
  • _GSMSATEventToneTimeUnitEnum : HsPhoneGSMTypes.h
  • _GSMSATEventToneTypeEnum : HsPhoneGSMTypes.h
  • _GSMSIMStatus : HsPhoneTypes.h
  • _LocDBSortOrderType : LocsLibCommon.h
  • _PhnAddressField : HsPhoneTypes.h
  • _PhnCDMAFirmwareType : HsPhoneCDMATypes.h
  • _PhnConnectStateType : HsPhoneCallControlTypes.h
  • _PhnDataServiceType : HsPhoneNetworkTypes.h
  • _PhnLibAttrType : HsPhoneMiscTypes.h
  • _PhnMIPSessionType : HsPhoneNetworkTypes.h
  • _PhnOneXProtRevType : HsPhoneNetworkTypes.h
  • _PhnOprtModeType : HsPhoneMiscTypes.h
  • _PhnPacketDataEndStatusEnum : HsPhoneNetworkTypes.h
  • _PhnPacketDataSessionType : HsPhoneNetworkTypes.h
  • _PhnPDPConnectionType : HsPhoneCDMATypes.h
  • _PhnPDPService : HsPhoneCDMATypes.h
  • _PhnPDSessionConfigParamType : hsPhoneLocationTypes.h
  • _PhnPowerType : HsPhoneTypes.h
  • _PhnRoamPrefSelectionTypeEnum : HsPhoneNetworkTypes.h
  • _PhnTTYSetting : HsPhoneAudioTypes.h
  • _PhoneServiceClassType : HsPhoneTypes.h
  • _SATDecisionType : HsPhoneGSMTypes.h
  • _SATNotificationType : HsPhoneGSMTypes.h
  • _SATRequestType : HsPhoneGSMTypes.h
  • _SmsCauseCode : HsPhoneSMSTypes.h
  • _SmsErrorCode : HsPhoneSMSTypes.h
  • _SoundPrefType : TonesLibTypes.h
  • _TonePlayNumberTimes : TonesLibTypes.h
  • _ToneRepeatInterval : TonesLibTypes.h
  • _ToneTimeUnit : TonesLibTypes.h
  • _ToneType : TonesLibTypes.h
  • _ToneVibrateType : TonesLibTypes.h
  • _ToneVolume : TonesLibTypes.h
  • _VMFontFace : VMFontLibCommon.h
  • _VMFontSize : VMFontLibCommon.h
  • _VMFontSizeRule : VMFontLibCommon.h
  • _VMFontStyle : VMFontLibCommon.h
  • _VMFontStyleRule : VMFontLibCommon.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- k -

  • kAngelSmiley : SmartTextEngineDef.h
  • kBigFrownSmiley : SmartTextEngineDef.h
  • kBigSmileSmiley : SmartTextEngineDef.h
  • kBigTeethSmiley : SmartTextEngineDef.h
  • kBigTongueSmiley : SmartTextEngineDef.h
  • kBlushSmiley : SmartTextEngineDef.h
  • kCameraImageFormatRGB1 : CameraLibCommon.h
  • kCameraImageFormatRGB16 : CameraLibCommon.h
  • kCameraImageFormatRGB24 : CameraLibCommon.h
  • kCameraImageFormatRGB32 : CameraLibCommon.h
  • kCameraImageFormatRGB4 : CameraLibCommon.h
  • kCameraImageFormatRGB8 : CameraLibCommon.h
  • kCameraImageFormatYCbCr : CameraLibCommon.h
  • kCameraImageFormatYCrCb : CameraLibCommon.h
  • kCameraImageLittleEndian : CameraLibCommon.h
  • kCameraLibCreator : CameraLibCommon.h
  • kCameraLibName : CameraLibCommon.h
  • kCameraLibType : CameraLibCommon.h
  • kCamLibApertureValueAuto : palmOneCameraCommon.h
  • kCamLibApertureValueManual : palmOneCameraCommon.h
  • kCamLibBufNumManual : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatRGB565 : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYCbCr420 : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYCbCr420Planar : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYCbCr422 : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYCbCr422Planar : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYUV420 : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYUV420Planar : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYUV422 : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYUV422Planar : palmOneCameraCommon.h
  • kCamLibCaptureHwrVersion : palmOneCameraCommon.h
  • kCamLibColorSpace_sRGB : palmOneCameraCommon.h
  • kCamLibColorSpaceUncalibrated : palmOneCameraCommon.h
  • kCamLibContrastManual : palmOneCameraCommon.h
  • kCamLibCreator : palmOneCameraCommon.h
  • kCamLibCtrlApertureValueGet : palmOneCameraCommon.h
  • kCamLibCtrlApertureValueQuery : palmOneCameraCommon.h
  • kCamLibCtrlApertureValueSet : palmOneCameraCommon.h
  • kCamLibCtrlCapture : palmOneCameraCommon.h
  • kCamLibCtrlCaptureAreaGet : palmOneCameraCommon.h
  • kCamLibCtrlCaptureAreaSet : palmOneCameraCommon.h
  • kCamLibCtrlCaptureFormatGet : palmOneCameraCommon.h
  • kCamLibCtrlCaptureFormatQuery : palmOneCameraCommon.h
  • kCamLibCtrlCaptureFormatSet : palmOneCameraCommon.h
  • kCamLibCtrlCaptureGetBitmapInfo : palmOneCameraCommon.h
  • kCamLibCtrlCaptureSizeGet : palmOneCameraCommon.h
  • kCamLibCtrlCaptureSizeQuery : palmOneCameraCommon.h
  • kCamLibCtrlCaptureSizeSet : palmOneCameraCommon.h
  • kCamLibCtrlColorSpaceGet : palmOneCameraCommon.h
  • kCamLibCtrlColorSpaceQuery : palmOneCameraCommon.h
  • kCamLibCtrlColorSpaceSet : palmOneCameraCommon.h
  • kCamLibCtrlContrastGet : palmOneCameraCommon.h
  • kCamLibCtrlContrastQuery : palmOneCameraCommon.h
  • kCamLibCtrlContrastSet : palmOneCameraCommon.h
  • kCamLibCtrlEffectsGet : palmOneCameraCommon.h
  • kCamLibCtrlEffectsQuery : palmOneCameraCommon.h
  • kCamLibCtrlEffectsSet : palmOneCameraCommon.h
  • kCamLibCtrlExposureGet : palmOneCameraCommon.h
  • kCamLibCtrlExposureQuery : palmOneCameraCommon.h
  • kCamLibCtrlExposureSet : palmOneCameraCommon.h
  • kCamLibCtrlHardwareSettingsDlg : palmOneCameraCommon.h
  • kCamLibCtrlLightingGet : palmOneCameraCommon.h
  • kCamLibCtrlLightingQuery : palmOneCameraCommon.h
  • kCamLibCtrlLightingSet : palmOneCameraCommon.h
  • kCamLibCtrlPowerOff : palmOneCameraCommon.h
  • kCamLibCtrlPowerOn : palmOneCameraCommon.h
  • kCamLibCtrlPreviewAreaGet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewAreaSet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewRectGet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewRectSet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewSizeGet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewSizeQuery : palmOneCameraCommon.h
  • kCamLibCtrlPreviewSizeSet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewStart : palmOneCameraCommon.h
  • kCamLibCtrlPreviewStop : palmOneCameraCommon.h
  • kCamLibCtrlSaturationGet : palmOneCameraCommon.h
  • kCamLibCtrlSaturationQuery : palmOneCameraCommon.h
  • kCamLibCtrlSaturationSet : palmOneCameraCommon.h
  • kCamLibCtrlSharpnessGet : palmOneCameraCommon.h
  • kCamLibCtrlSharpnessQuery : palmOneCameraCommon.h
  • kCamLibCtrlSharpnessSet : palmOneCameraCommon.h
  • kCamLibCtrlShutterSpeedGet : palmOneCameraCommon.h
  • kCamLibCtrlShutterSpeedQuery : palmOneCameraCommon.h
  • kCamLibCtrlShutterSpeedSet : palmOneCameraCommon.h
  • kCamLibCtrlStatusGet : palmOneCameraCommon.h
  • kCamLibCtrlStatusQuery : palmOneCameraCommon.h
  • kCamLibCtrlStreamBufNumGet : palmOneCameraCommon.h
  • kCamLibCtrlStreamBufNumQuery : palmOneCameraCommon.h
  • kCamLibCtrlStreamBufNumSet : palmOneCameraCommon.h
  • kCamLibCtrlStreamFormatGet : palmOneCameraCommon.h
  • kCamLibCtrlStreamFormatQuery : palmOneCameraCommon.h
  • kCamLibCtrlStreamFormatSet : palmOneCameraCommon.h
  • kCamLibCtrlStreamPreviewGet : palmOneCameraCommon.h
  • kCamLibCtrlStreamPreviewQuery : palmOneCameraCommon.h
  • kCamLibCtrlStreamPreviewSet : palmOneCameraCommon.h
  • kCamLibCtrlStreamSizeGet : palmOneCameraCommon.h
  • kCamLibCtrlStreamSizeQuery : palmOneCameraCommon.h
  • kCamLibCtrlStreamSizeSet : palmOneCameraCommon.h
  • kCamLibCtrlStreamStart : palmOneCameraCommon.h
  • kCamLibCtrlStreamStop : palmOneCameraCommon.h
  • kCamLibCtrlStreamUnlockFrame : palmOneCameraCommon.h
  • kCamLibCtrlStreamWaitForFrame : palmOneCameraCommon.h
  • kCamLibCtrlWhiteBalanceGet : palmOneCameraCommon.h
  • kCamLibCtrlWhiteBalanceQuery : palmOneCameraCommon.h
  • kCamLibCtrlWhiteBalanceSet : palmOneCameraCommon.h
  • kCamLibCtrlZoomGet : palmOneCameraCommon.h
  • kCamLibCtrlZoomQuery : palmOneCameraCommon.h
  • kCamLibCtrlZoomSet : palmOneCameraCommon.h
  • kCamLibEffectsBlackWhite : palmOneCameraCommon.h
  • kCamLibEffectsBluish : palmOneCameraCommon.h
  • kCamLibEffectsNegative : palmOneCameraCommon.h
  • kCamLibEffectsNormal : palmOneCameraCommon.h
  • kCamLibEffectsSepia : palmOneCameraCommon.h
  • kCamLibErrAllFramesLocked : palmOneCameraCommon.h
  • kCamLibErrBadParam : palmOneCameraCommon.h
  • kCamLibErrInternal : palmOneCameraCommon.h
  • kCamLibErrNoMemory : palmOneCameraCommon.h
  • kCamLibErrNoPower : palmOneCameraCommon.h
  • kCamLibErrNotCompatible : palmOneCameraCommon.h
  • kCamLibErrNotOpen : palmOneCameraCommon.h
  • kCamLibErrNotSupported : palmOneCameraCommon.h
  • kCamLibErrStillOpen : palmOneCameraCommon.h
  • kCamLibExposureAuto : palmOneCameraCommon.h
  • kCamLibExposureManual : palmOneCameraCommon.h
  • kCamLibFtrCaptureVersion : palmOneCameraCommon.h
  • kCamLibFtrVersionNum : palmOneCameraCommon.h
  • kCamLibImageSizeCIF : palmOneCameraCommon.h
  • kCamLibImageSizeQCIF : palmOneCameraCommon.h
  • kCamLibImageSizeQQVGA : palmOneCameraCommon.h
  • kCamLibImageSizeQVGA : palmOneCameraCommon.h
  • kCamLibImageSizeSXGA : palmOneCameraCommon.h
  • kCamLibImageSizeSXGA1024 : palmOneCameraCommon.h
  • kCamLibImageSizeSXGA960 : palmOneCameraCommon.h
  • kCamLibImageSizeVGA : palmOneCameraCommon.h
  • kCamLibLightingLow : palmOneCameraCommon.h
  • kCamLibLightingNormal : palmOneCameraCommon.h
  • kCamLibName : palmOneCameraCommon.h
  • kCamLibSaturationManual : palmOneCameraCommon.h
  • kCamLibSharpnessManual : palmOneCameraCommon.h
  • kCamLibShutterSpeedAuto : palmOneCameraCommon.h
  • kCamLibShutterSpeedManual : palmOneCameraCommon.h
  • kCamLibStatusInPreview : palmOneCameraCommon.h
  • kCamLibStatusInStillCapture : palmOneCameraCommon.h
  • kCamLibStatusInVideoCapture : palmOneCameraCommon.h
  • kCamLibStatusPoweredOn : palmOneCameraCommon.h
  • kCamLibStreamPreviewOff : palmOneCameraCommon.h
  • kCamLibStreamPreviewOn : palmOneCameraCommon.h
  • kCamLibType : palmOneCameraCommon.h
  • kCamLibWhiteBalanceAuto : palmOneCameraCommon.h
  • kCamLibWhiteBalanceCloudy : palmOneCameraCommon.h
  • kCamLibWhiteBalanceExtra : palmOneCameraCommon.h
  • kCamLibWhiteBalanceFluorescent : palmOneCameraCommon.h
  • kCamLibWhiteBalanceIncandescent : palmOneCameraCommon.h
  • kCamLibWhiteBalanceIndoor : palmOneCameraCommon.h
  • kCamLibWhiteBalanceOutdoor : palmOneCameraCommon.h
  • kCamLibWhiteBalanceShade : palmOneCameraCommon.h
  • kCamLibWhiteBalanceSunny : palmOneCameraCommon.h
  • kCamLibWhiteBalanceTwilight : palmOneCameraCommon.h
  • kCamLibZoomManual : palmOneCameraCommon.h
  • kCamSliderCreator : palmOneCameraSlider.h
  • kCamSliderFlagsOpened : palmOneCameraSlider.h
  • kCamSliderFtrFlagsNum : palmOneCameraSlider.h
  • kCamSliderFtrVersionNum : palmOneCameraSlider.h
  • kCamSliderNotifyEvent : palmOneCameraSlider.h
  • kCamSliderVersion : palmOneCameraSlider.h
  • kCamSliderVersion1 : palmOneCameraSlider.h
  • kCarrierCustomizationCLibName : CarrierCustomLibTypes.h
  • kCarrierListDBName : CarrierCustomLibTypes.h
  • kCCLibType : CarrierCustomLibTypes.h
  • kCCMSSettingsPrimaryTrustedDomain : CarrierCustomLibTypes.h
  • kCCMSSettingsSecondaryTrustedDomain : CarrierCustomLibTypes.h
  • kCCMSSettingsUAProfilingURL : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsCSDDisconnectOnExit : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsDormantOnExit : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsEncryptMSISDN : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsHideDisconnect : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsPDataDisconnectOnExit : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsReserved : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsVersionInWAPProfile : CarrierCustomLibTypes.h
  • kCCSMMessagingSettings11DigitRecipient : CarrierCustomLibTypes.h
  • kCCSMMessagingSettingsDisableMMSFallback : CarrierCustomLibTypes.h
  • kCCSMMessagingSettingsNormaliseMMSAddress : CarrierCustomLibTypes.h
  • kCCSMMessagingSettingsReserved : CarrierCustomLibTypes.h
  • kCCSMMessagingSettingsStripPhonePlus : CarrierCustomLibTypes.h
  • kCCSMMessagingSettingsWAPProtocol20 : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsEditMSISDN : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsEnableTTY : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsNetworkSelect : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsReserved : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsRoamingIndicator : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsShowEmergencyMode : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsUseEFSPN : CarrierCustomLibTypes.h
  • kCCSMPrimaryProxyAuthenticate : CarrierCustomLibTypes.h
  • kCCSMPrimaryProxyHide : CarrierCustomLibTypes.h
  • kCCSMPrimaryProxyLocked : CarrierCustomLibTypes.h
  • kCCSMRadioBandEurope : CarrierCustomLibTypes.h
  • kCCSMRadioBandNorthAmerica : CarrierCustomLibTypes.h
  • kCCSMRadioBandUnknown : CarrierCustomLibTypes.h
  • kCCSMSecondaryProxyAuthenticate : CarrierCustomLibTypes.h
  • kCCSMSecondaryProxyHide : CarrierCustomLibTypes.h
  • kCCSMSecondaryProxyLocked : CarrierCustomLibTypes.h
  • kCCSMSettingsBrowserFlags : CarrierCustomLibTypes.h
  • kCCSMSettingsBrowserProxyFlags : CarrierCustomLibTypes.h
  • kCCSMSettingsCarrierMSISDN : CarrierCustomLibTypes.h
  • kCCSMSettingsE911Timeout : CarrierCustomLibTypes.h
  • kCCSMSettingsEditableMSISDN : CarrierCustomLibTypes.h
  • kCCSMSettingsEmailSMTPServer : CarrierCustomLibTypes.h
  • kCCSMSettingsEncryptMSISDN : CarrierCustomLibTypes.h
  • kCCSMSettingsGPRSAutoAttach : CarrierCustomLibTypes.h
  • kCCSMSettingsHomepageURL : CarrierCustomLibTypes.h
  • kCCSMSettingsHTTPHeaders : CarrierCustomLibTypes.h
  • kCCSMSettingsIndicateRoaming : CarrierCustomLibTypes.h
  • kCCSMSettingsMessagingFlags : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSMaxMsgSize : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSMaxVideoSize : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSPort : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSUAProf : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSUAString : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSURL : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSVersionNumber : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSWAPGateway : CarrierCustomLibTypes.h
  • kCCSMSettingsMSISDNHeaderFormat : CarrierCustomLibTypes.h
  • kCCSMSettingsNAI : CarrierCustomLibTypes.h
  • kCCSMSettingsNAIHeaderFormat : CarrierCustomLibTypes.h
  • kCCSMSettingsPOP3Server : CarrierCustomLibTypes.h
  • kCCSMSettingsPrimaryProxyPort : CarrierCustomLibTypes.h
  • kCCSMSettingsPrimaryProxyServer : CarrierCustomLibTypes.h
  • kCCSMSettingsPrimarySecureProxyPort : CarrierCustomLibTypes.h
  • kCCSMSettingsPrimarySecureProxyServer : CarrierCustomLibTypes.h
  • kCCSMSettingsProxyPassword : CarrierCustomLibTypes.h
  • kCCSMSettingsProxyUsername : CarrierCustomLibTypes.h
  • kCCSMSettingsRadioBand : CarrierCustomLibTypes.h
  • kCCSMSettingsReserved : CarrierCustomLibTypes.h
  • kCCSMSettingsSecondaryProxyPort : CarrierCustomLibTypes.h
  • kCCSMSettingsSecondaryProxyServer : CarrierCustomLibTypes.h
  • kCCSMSettingsSecondarySecureProxyPort : CarrierCustomLibTypes.h
  • kCCSMSettingsSecondarySecureProxyServer : CarrierCustomLibTypes.h
  • kCCSMSettingsShowEmergencyMode : CarrierCustomLibTypes.h
  • kCCSMSettingsShowNetworkSelect : CarrierCustomLibTypes.h
  • kCCSMSettingsSMSCNumber : CarrierCustomLibTypes.h
  • kCCSMSettingsSMSEmailGateway : CarrierCustomLibTypes.h
  • kCCSMSettingsSMSMaxMsgSize : CarrierCustomLibTypes.h
  • kCCSMSettingsSMSValidityPeriod : CarrierCustomLibTypes.h
  • kCCSMSettingsSMTPServer : CarrierCustomLibTypes.h
  • kCCSMSettingsSPNSupported : CarrierCustomLibTypes.h
  • kCCSMSettingsSystemReserved : CarrierCustomLibTypes.h
  • kCCSMSettingsVoiceMailNumber : CarrierCustomLibTypes.h
  • kCCSMSystemSettingReserved : CarrierCustomLibTypes.h
  • kCigarSmiley : SmartTextEngineDef.h
  • kClownSmiley : SmartTextEngineDef.h
  • kCodecErrAlignment : palmOneCodecPluginMgrCommon.h
  • kCodecErrBadParam : palmOneCodecPluginMgrCommon.h
  • kCodecErrBufferOverrun : palmOneCodecPluginMgrCommon.h
  • kCodecErrBufferUnderrun : palmOneCodecPluginMgrCommon.h
  • kCodecErrFrameError : palmOneCodecPluginMgrCommon.h
  • kCodecErrInvalidHeader : palmOneCodecPluginMgrCommon.h
  • kCodecErrInvalidState : palmOneCodecPluginMgrCommon.h
  • kCodecErrNoMemory : palmOneCodecPluginMgrCommon.h
  • kCodecErrParsing : palmOneCodecPluginMgrCommon.h
  • kCodecErrUnAuthorized : palmOneCodecPluginMgrCommon.h
  • kCodecErrUnknown : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibBadVersion : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibCreator : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibErrBadParam : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibErrInternal : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibErrorClass : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibErrStillOpen : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibName : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibNoCodec : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibNotSupported : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibType : palmOneCodecPluginMgrCommon.h
  • kCodecPluginErrorClass : palmOneCodecPluginMgrCommon.h
  • kCodecSyncNotFound : palmOneCodecPluginMgrCommon.h
  • kDeltaCharacter : SmartTextEngineDef.h
  • kDevilSmiley : SmartTextEngineDef.h
  • kFileBrowserLibFlagNoDirChange : FileBrowserLibCommon.h
  • kFileBrowserLibFlagNoFiles : FileBrowserLibCommon.h
  • kFileBrowserLibFlagNoFolders : FileBrowserLibCommon.h
  • kFileBrowserLibFlagNoNewFolder : FileBrowserLibCommon.h
  • kFileBrowserLibFlagNoSubDir : FileBrowserLibCommon.h
  • kFileBrowserLibFlagOneVolume : FileBrowserLibCommon.h
  • kFileBrowserLibFlagPromptOverwrite : FileBrowserLibCommon.h
  • kFileBrowserLibFlagRequireExtension : FileBrowserLibCommon.h
  • kFileBrowserLibName : FileBrowserLibCommon.h
  • kFlipSmiley : SmartTextEngineDef.h
  • kFrownSmiley : SmartTextEngineDef.h
  • kGammaCharacter : SmartTextEngineDef.h
  • kHALLEDCapcitySleepMultiColor : PalmLED.h
  • kHALLEDCapcitySleepOn : PalmLED.h
  • kHALLEDCapcitySleepPattern : PalmLED.h
  • kHALLEDCapcitySleepPatternSetting : PalmLED.h
  • kHALLEDPropertySleepColorAmberWhite : PalmLED.h
  • kHALLEDPropertySleepColorBlue : PalmLED.h
  • kHALLEDPropertySleepColorGreen : PalmLED.h
  • kHALLEDPropertySleepColorRed : PalmLED.h
  • kHALLEDPropertySleepOn : PalmLED.h
  • kHALLEDPropertySleepPattern : PalmLED.h
  • kHALLEDPropertySleepReserve : PalmLED.h
  • kHeartSmiley : SmartTextEngineDef.h
  • kHelperServiceClassIDMMS : MmsHelperCommon.h
  • kHiResTimeErrorClass : palmOneHiResTimerCommon.h, PalmHiResTime.h
  • kHiResTimeLibCreator : palmOneHiResTimerCommon.h, PalmHiResTime.h
  • kHiResTimeLibErrBadParam : palmOneHiResTimerCommon.h
  • kHiResTimeLibErrNotAvailable : palmOneHiResTimerCommon.h
  • kHiResTimeLibErrNotOpen : palmOneHiResTimerCommon.h
  • kHiResTimeLibErrStillOpen : palmOneHiResTimerCommon.h
  • kHiResTimeLibName : palmOneHiResTimerCommon.h, PalmHiResTime.h
  • kHiResTimeLibType : palmOneHiResTimerCommon.h, PalmHiResTime.h
  • kHiResTimeLibVersion : palmOneHiResTimerCommon.h
  • kHiResTimeLibVersion1 : palmOneHiResTimerCommon.h
  • kHiResTimeLibVersion2 : palmOneHiResTimerCommon.h
  • kImageFilenameLength : ImageLibCommon.h
  • kIndicatorAlertAlert : HsExtCommon.h
  • kIndicatorAlertCalendar : HsExtCommon.h
  • kIndicatorAlertMail : HsExtCommon.h
  • kIndicatorAlertNone : HsExtCommon.h
  • kIndicatorAlertPending : HsExtCommon.h
  • kIndicatorAlertSMS : HsExtCommon.h
  • kIndicatorAlertVoicemail : HsExtCommon.h
  • kIndicatorBattCharge : HsExtCommon.h
  • kIndicatorBattFull : HsExtCommon.h
  • kIndicatorBattLow : HsExtCommon.h
  • kIndicatorBattNone : HsExtCommon.h
  • kIndicatorBattTrickle : HsExtCommon.h
  • kIndicatorBtConnectAudio : PmSysGadgetLibCommon.h
  • kIndicatorBtConnectHeadset : PmSysGadgetLibCommon.h
  • kIndicatorBtConnectOther : PmSysGadgetLibCommon.h
  • kIndicatorBtDUN : PmSysGadgetLibCommon.h
  • kIndicatorBtOff : PmSysGadgetLibCommon.h
  • kIndicatorBtOn : PmSysGadgetLibCommon.h
  • kIndicatorCountForever : HsExtCommon.h
  • kIndicatorCountGetState : HsExtCommon.h
  • kIndicatorForceGreen : HsExtCommon.h
  • kIndicatorForceNone : HsExtCommon.h
  • kIndicatorForceOff : HsExtCommon.h
  • kIndicatorForceOn : HsExtCommon.h
  • kIndicatorForceRed : HsExtCommon.h
  • kIndicatorForceRedGreen : HsExtCommon.h
  • kIndicatorRingActive : HsExtCommon.h
  • kIndicatorRingContact : HsExtCommon.h
  • kIndicatorRingNone : HsExtCommon.h
  • kIndicatorRingRoam : HsExtCommon.h
  • kIndicatorSignalBad : HsExtCommon.h
  • kIndicatorSignalGood : HsExtCommon.h
  • kIndicatorSignalNone : HsExtCommon.h
  • kIndicatorSignalRoam : HsExtCommon.h
  • kIndicatorUsageDataCall : HsExtCommon.h
  • kIndicatorUsageNone : HsExtCommon.h
  • kIndicatorUsageVoiceCall : HsExtCommon.h
  • kInvalidRecIndex : ImageLibCommon.h
  • kIOTACertMaxBlocks : HsPhoneIOTATypes.h
  • kLambdaCharacter : SmartTextEngineDef.h
  • kLcdOverlayLibCreator : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibCtrlDraw : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibCtrlFormatGet : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibCtrlFormatQuery : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibCtrlFormatSet : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibCtrlRectGet : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibCtrlRectSet : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibCtrlStart : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibCtrlStop : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibDataFormatRGB565 : palmOneLcdOverlayCommon.h
  • kLcdOverlayLibErrBadParam : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibErrInternal : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibErrNoMemory : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibErrNotCompatible : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibErrNotOpen : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibErrNotSupported : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibErrorClass : palmOneLcdOverlayCommon.h
  • kLcdOverlayLibErrStillOpen : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibName : palmOneLcdOverlayCommon.h
  • kLcdOverlayLibType : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibVersion : palmOneLcdOverlayCommon.h
  • kLcdOverlayLibVersion1 : palmOneLcdOverlayCommon.h
  • kLFlipSmiley : SmartTextEngineDef.h
  • kLocDBMaxLocNameLength : LocsLibCommon.h
  • kLocDBTypeCustom : LocsLibCommon.h
  • kLocDBTypeDefault : LocsLibCommon.h
  • kLocDBVersion : LocsLibCommon.h
  • kLocDisplayInCustom : LocsLibCommon.h
  • kLocNoDisplayInCustom : LocsLibCommon.h
  • kLocsFileCLocsLib : LocsLibCommon.h
  • kLocsLibFtrNumRefNum : LocsLibCommon.h
  • kLocsLibName : LocsLibCommon.h
  • kMaxPhnEvtSupported : HsPhoneEvent.h
  • kMaxPhoneNumberLen : HsPhoneNetworkTypes.h
  • kMaxTonesNameSize : TonesLibTypes.h
  • kMaxVPNAccountNameLength : PalmVPPI.h
  • kMMSPixPlaceMaxLen : HsPhoneSMSTypes.h
  • kMMSStringMaxLen : HsPhoneSMSTypes.h
  • kNetDriverDateLength : PalmNetServices.h
  • kNetFWNameLength : PalmNetServices.h
  • kNetSerialNumberLength : PalmNetServices.h
  • kNetworkListDBName : CarrierCustomLibTypes.h
  • kOmegaCharacter : SmartTextEngineDef.h
  • kOMouthSmiley : SmartTextEngineDef.h
  • kPalmAudioPlaybackActionCodeRequestResume : PalmAudioPlayback.h
  • kPalmAudioPlaybackActionCodeRequestStop : PalmAudioPlayback.h
  • kPalmAudioPlaybackCreator : PalmAudioPlayback.h
  • kPalmAudioPlaybackNotifyEvent : PalmAudioPlayback.h
  • kPalmAudioPlaybackNotifyVersion : PalmAudioPlayback.h
  • kPalmCompanyIDHandspring : palmOneResources.h
  • kPalmCompanyIDOldPalm : palmOneResources.h
  • kPalmCompanyIDPalm : palmOneResources.h
  • kPalmCreatorIDLcdState : palmOneCreators.h
  • kPalmCreatorIDNetSlipHack : palmOneCreators.h
  • kPalmDeviceIDTX : palmOneResources.h
  • kPalmDeviceIDZ22 : palmOneResources.h
  • kPalmOneDeviceIDAngus : palmOneResources.h
  • kPalmOneDeviceIDDevice3 : palmOneResources.h
  • kPalmOneDeviceIDDevice4 : palmOneResources.h
  • kPalmOneDeviceIDDevice5 : palmOneResources.h
  • kPalmOneDeviceIDDevice6 : palmOneResources.h
  • kPalmOneDeviceIDDevice7 : palmOneResources.h
  • kPalmOneDeviceIDDevice8 : palmOneResources.h
  • kPalmOneDeviceIDDevice9 : palmOneResources.h
  • kPalmOneDeviceIDDeviceA : palmOneResources.h
  • kPalmOneDeviceIDLowrider : palmOneResources.h
  • kPalmOneDeviceIDTreo600 : palmOneResources.h
  • kPalmOneDeviceIDTreo600Sim : palmOneResources.h
  • kPalmOneDeviceIDTreo650 : palmOneResources.h
  • kPalmOneDeviceIDTreo650Sim : palmOneResources.h
  • kPalmOneDeviceIDTungstenC : palmOneResources.h
  • kPalmOneDeviceIDTungstenE2 : palmOneResources.h
  • kPalmOneDeviceIDTungstenT : palmOneResources.h
  • kPalmOneDeviceIDTungstenT2 : palmOneResources.h
  • kPalmOneDeviceIDTungstenT3 : palmOneResources.h
  • kPalmOneDeviceIDTungstenT5 : palmOneResources.h
  • kPalmOneDeviceIDTungstenTE : palmOneResources.h
  • kPalmOneDeviceIDTungstenW : palmOneResources.h
  • kPalmOneDeviceIDTungstenX : palmOneResources.h
  • kPalmOneDeviceIDVentura : palmOneResources.h
  • kPalmOneDeviceIDZire : palmOneResources.h
  • kPalmOneDeviceIDZire21 : palmOneResources.h
  • kPalmOneDeviceIDZire31 : palmOneResources.h
  • kPalmOneDeviceIDZire71 : palmOneResources.h
  • kPalmOneDeviceIDZire72 : palmOneResources.h
  • kPhiCharacter : SmartTextEngineDef.h
  • kPiCharacter : SmartTextEngineDef.h
  • kPmConnectorDeviceAttach : PmConnectorLibCommon.h
  • kPmConnectorDeviceDetach : PmConnectorLibCommon.h
  • kPmKeyLibAPIMajorVersion : PmKeyLibCommon.h
  • kPmKeyLibAPIMinorVersion : PmKeyLibCommon.h
  • kPmKeyLibCreator : PmKeyLibCommon.h
  • kPmKeyLibFtrValAPIVersion : PmKeyLibCommon.h
  • kPmKeyLibName : PmKeyLibCommon.h
  • kPmKeyLibType : PmKeyLibCommon.h
  • kPmSysGadgetBbutGadgetMiscSelectData : PmSysGadgetLibCommon.h
  • kPmSysGadgetBbutGadgetMiscSelectSelector : PmSysGadgetLibCommon.h
  • kPmSysGadgetBbutRscType : PmSysGadgetLibCommon.h
  • kPmSysGadgetFtrIDStatusGadgetRev : PmSysGadgetLibCommon.h
  • kPmSysGadgetFtrValStatusGadgetRev1 : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibCreator : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibName : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibType : PmSysGadgetLibCommon.h
  • kPmUIUtilLibAPIMajorVersion : PmUIUtilLibCommon.h
  • kPmUIUtilLibAPIMinorVersion : PmUIUtilLibCommon.h
  • kPmUIUtilLibCreator : PmUIUtilLibCommon.h
  • kPmUIUtilLibFtrValAPIVersion : PmUIUtilLibCommon.h
  • kPmUIUtilLibName : PmUIUtilLibCommon.h
  • kPmUIUtilLibType : PmUIUtilLibCommon.h
  • kPsiCharacter : SmartTextEngineDef.h
  • kPukeSmiley : SmartTextEngineDef.h
  • kPwrBatteryStateBroadcaster : PalmPower.h
  • kPwrBatteryStateNotifyEvent : PalmPower.h
  • kQuestionSmiley : SmartTextEngineDef.h
  • kRecordFieldEnumCount : HsPhoneSMSTypes.h
  • kRFlipSmiley : SmartTextEngineDef.h
  • kSATRefresh : HsPhoneGSMTypes.h
  • kScrollToEnd : SmartTextEngineDef.h
  • kSelectUntilEnd : SmartTextEngineDef.h
  • kSelectUntilEndOfRecord : SmartTextEngineDef.h
  • kSigmaCharacter : SmartTextEngineDef.h
  • kSmartTextBit : SmartTextEngineDef.h
  • kSmileSmiley : SmartTextEngineDef.h
  • kSmirkSmiley : SmartTextEngineDef.h
  • kSndFileFormatAAC : palmOneSndFileStream.h
  • kSndFileFormatMP3 : palmOneSndFileStream.h
  • kSndFileFormatRaw : palmOneSndFileStream.h
  • kSndFileFormatTreoAMR : palmOneSndFileStream.h
  • kSndFileFormatTreoQCP : palmOneSndFileStream.h
  • kSndFileFormatWAV : palmOneSndFileStream.h
  • kSndFileStreamFileSpecFlagFileStream : palmOneSndFileStream.h
  • kSndFileStreamFileSpecFlagVFS : palmOneSndFileStream.h
  • kSndFileStreamLibCreator : palmOneSndFileStream.h
  • kSndFileStreamLibName : palmOneSndFileStream.h
  • kSndFileStreamLibType : palmOneSndFileStream.h
  • kSndFileStreamLibVersion : palmOneSndFileStream.h
  • kSndFileTypeAAC : palmOneSndFileStream.h
  • kSndFileTypeAMR : palmOneSndFileStream.h
  • kSndFileTypeMP3 : palmOneSndFileStream.h
  • kSndFileTypeQCP : palmOneSndFileStream.h
  • kSndFileTypeWAV : palmOneSndFileStream.h
  • kSTEBitmap : SmartTextEngineDef.h
  • kSTEBlack : SmartTextEngineDef.h
  • kSTEBlackFont : SmartTextEngineDef.h
  • kSTEBlackInverse : SmartTextEngineDef.h
  • kSTEBlue : SmartTextEngineDef.h
  • kSTEBlueFont : SmartTextEngineDef.h
  • kSTEBlueInverse : SmartTextEngineDef.h
  • kSTECenterAlign : SmartTextEngineDef.h
  • kSTECharacterBitmap : SmartTextEngineDef.h
  • kSTECurrentFont : SmartTextEngineDef.h
  • kSTEGray : SmartTextEngineDef.h
  • kSTEGrayFont : SmartTextEngineDef.h
  • kSTEGrayInverse : SmartTextEngineDef.h
  • kSTEGreen : SmartTextEngineDef.h
  • kSTEGreenFont : SmartTextEngineDef.h
  • kSTEGreenInverse : SmartTextEngineDef.h
  • kSTEHorizontalLine : SmartTextEngineDef.h
  • kSTEHyperlink : SmartTextEngineDef.h
  • kSTELeftIndent : SmartTextEngineDef.h
  • kSTELineBreak : SmartTextEngineDef.h
  • kSTEOrange : SmartTextEngineDef.h
  • kSTEOrangeFont : SmartTextEngineDef.h
  • kSTEOrangeInverse : SmartTextEngineDef.h
  • kSTEPurple : SmartTextEngineDef.h
  • kSTEPurpleFont : SmartTextEngineDef.h
  • kSTEPurpleInverse : SmartTextEngineDef.h
  • kSTERed : SmartTextEngineDef.h
  • kSTERedFont : SmartTextEngineDef.h
  • kSTERedInverse : SmartTextEngineDef.h
  • kSTERightAlign : SmartTextEngineDef.h
  • kSTESmileyBitmap : SmartTextEngineDef.h
  • kSTEYellow : SmartTextEngineDef.h
  • kSTEYellowFont : SmartTextEngineDef.h
  • kSTEYellowInverse : SmartTextEngineDef.h
  • kStraightMouthSmiley : SmartTextEngineDef.h
  • kThetaCharacter : SmartTextEngineDef.h
  • kTonesDialogFlagNonModal : TonesLibTypes.h
  • kTonesLibVersionEscalation : TonesLib.h
  • kTongueSmiley : SmartTextEngineDef.h
  • kUFlipSmiley : SmartTextEngineDef.h
  • kUndefinedPosition : LocsLibCommon.h
  • kUSB500mACharge : palmOneFeatures.h
  • kUSBConsole : palmOneFeatures.h
  • kUSBDriveMode : palmOneFeatures.h
  • kUSBDUN : palmOneFeatures.h
  • kUSBFSClient : palmOneFeatures.h
  • kUSBFSOnTheGo : palmOneFeatures.h
  • kUSBFSOnTheGoMultiDevice : palmOneFeatures.h
  • kUSBHotSync : palmOneFeatures.h
  • kUSBHSClient : palmOneFeatures.h
  • kUSBHSOnTheGo : palmOneFeatures.h
  • kUSBHSOnTheGoMultiDevice : palmOneFeatures.h
  • kUSBLogging : palmOneFeatures.h
  • kUSBMiniConnector : palmOneFeatures.h
  • kUSBMTP : palmOneFeatures.h
  • kUSBMultiConnector : palmOneFeatures.h
  • kUSBTransfer : palmOneFeatures.h
  • kWAPAnyApp : HsPhoneEvent.h
  • kWAPdocomoImodeMailUa : HsPhoneEvent.h
  • kWAPdocomoImodeMfUa : HsPhoneEvent.h
  • kWAPdocomoImodeMrUa : HsPhoneEvent.h
  • kWAPDrmUa : HsPhoneEvent.h
  • kWAPEmnUa : HsPhoneEvent.h
  • kWAPLocUa : HsPhoneEvent.h
  • kWAPMmsUa : HsPhoneEvent.h
  • kWAPMotorolaBrowserUa : HsPhoneEvent.h
  • kWAPMotorolaLocationUa : HsPhoneEvent.h
  • kWAPMotorolaNowUa : HsPhoneEvent.h
  • kWAPMotorolaOtaprovUa : HsPhoneEvent.h
  • kWAPMotorolaSplashUa : HsPhoneEvent.h
  • kWAPMsIMclientUa : HsPhoneEvent.h
  • kWAPMsLocalcontentUa : HsPhoneEvent.h
  • kWAPNaiMvswCommand : HsPhoneEvent.h
  • kWAPopenwaveIotaUa : HsPhoneEvent.h
  • kWAPPushSIA : HsPhoneEvent.h
  • kWAPPushSyncml : HsPhoneEvent.h
  • kWAPSyncmlDm : HsPhoneEvent.h
  • kWAPWmlUa : HsPhoneEvent.h
  • kWAPWtaUa : HsPhoneEvent.h
  • kWAPWvUa : HsPhoneEvent.h
  • kWinkSmiley : SmartTextEngineDef.h
  • kXiCharacter : SmartTextEngineDef.h
  • kYinYangSmiley : SmartTextEngineDef.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- l -

  • largeFonts : VMFontLibCommon.h
  • LaunchWithCommand : HsAppLaunchCmd.h
  • LcdOverlayLibClose() : PalmLcdOverlay.h, palmOneLcdOverlay.h
  • LcdOverlayLibControl() : PalmLcdOverlay.h, palmOneLcdOverlay.h
  • LcdOverlayLibControlType : palmOneLcdOverlayCommon.h
  • LcdOverlayLibFormatType : palmOneLcdOverlayCommon.h
  • LcdOverlayLibGetVersion() : PalmLcdOverlay.h, palmOneLcdOverlay.h
  • LcdOverlayLibOpen() : PalmLcdOverlay.h, palmOneLcdOverlay.h
  • LcdOverlayLibSettingType : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • LcdOverlayLibSleep() : PalmLcdOverlay.h
  • LcdOverlayLibWake() : PalmLcdOverlay.h
  • LocationCopy() : LocsLib.h
  • LocationCopyV20() : LocsLib.h
  • LocationFinal() : LocsLib.h
  • LocationFinalV20() : LocsLib.h
  • LocationGetSize() : LocsLib.h
  • LocationGetSizeV20() : LocsLib.h
  • LocationInit() : LocsLib.h
  • LocationInitV20() : LocsLib.h
  • LocationIsDSTPast() : LocsLib.h
  • LocationMakeGeneric() : LocsLib.h
  • LocationSetName() : LocsLib.h
  • LocationSetNote() : LocsLib.h
  • LocationSetPosition() : LocsLib.h
  • LocDBChangeRecord() : LocsLib.h
  • LocDBChangeRecordV20() : LocsLib.h
  • LocDBCompareRecordsSimple() : LocsLib.h
  • LocDBConvertRecord() : LocsLib.h
  • LocDBConvertRecordV20() : LocsLib.h
  • LocDBCopyLocation() : LocsLib.h
  • LocDBDeleteRecord() : LocsLib.h
  • LocDBFindCustomRecord() : LocsLib.h
  • LocDBFindCustomRecordV20() : LocsLib.h
  • LocDBFindFirst() : LocsLib.h
  • LocDBFindFirstByName() : LocsLib.h
  • LocDBFindFirstByUTCCountry() : LocsLib.h
  • LocDBFindFirstInList() : LocsLib.h
  • LocDBGetCustomList() : LocsLib.h
  • LocDBGetNearestLocation() : LocsLib.h
  • LocDBGetRecord() : LocsLib.h
  • LocDBGetRecordList() : LocsLib.h
  • LocDBGetRecordListV20() : LocsLib.h
  • LocDBGetRecordV20() : LocsLib.h
  • LocDBGetVersion() : LocsLib.h
  • LocDBInitDBs() : LocsLib.h
  • LocDBNewRecord() : LocsLib.h
  • LocDBNewRecordV20() : LocsLib.h
  • LocDBOpenCustom() : LocsLib.h
  • LocDBOpenDefault() : LocsLib.h
  • LocDBRecordSize() : LocsLib.h
  • LocDBSetRecordCustom() : LocsLib.h
  • LocDBSort() : LocsLib.h
  • LocsLibClose() : LocsLib.h
  • LocsLibDSTAlarmClear() : LocsLib.h
  • LocsLibDSTAlarmIsDST() : LocsLib.h
  • LocsLibDSTAlarmSet() : LocsLib.h
  • LocsLibGetVersion() : LocsLib.h
  • LocsLibLaunchEditListDialogue() : LocsLib.h
  • LocsLibLaunchSelDialogue() : LocsLib.h
  • LocsLibOpen() : LocsLib.h
  • LocsLibSleep() : LocsLib.h
  • LocsLibWake() : LocsLib.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- m -

  • MAX_ACTIVE_PROFILES : PalmNetServices.h
  • MAX_LONGOPERATORNAME_LENGTH : HsPhoneNetworkTypes.h
  • MAX_PLANE_COUNT : palmOneCodecFormat.h
  • maxDB4ecioLevel0 : HsPhoneTypes.h
  • maxDB4ecioLevel1 : HsPhoneTypes.h
  • maxDB4ecioLevel2 : HsPhoneTypes.h
  • maxDB4ecioLevel3 : HsPhoneTypes.h
  • maxDBm4signalLevel0 : HsPhoneTypes.h
  • maxDBm4signalLevel1 : HsPhoneTypes.h
  • maxDBm4signalLevel2 : HsPhoneTypes.h
  • maxDBm4signalLevel3 : HsPhoneTypes.h
  • maxPasswordLen : HsPhoneNetworkTypes.h
  • Minimum16bitTextHeader : HsPhoneSMSTypes.h
  • Minimum8bitTextHeader : HsPhoneSMSTypes.h
  • minPasswordLen : HsPhoneNetworkTypes.h
  • MM_MAX_ATTACHMENTS : PalmVMLaunch.h
  • mmiServiceAllBarringServ : HsPhoneNetworkTypes.h
  • mmiServiceAllInBarringServ : HsPhoneNetworkTypes.h
  • mmiServiceAllOutBarringServ : HsPhoneNetworkTypes.h
  • mmiServiceBAIC : HsPhoneNetworkTypes.h
  • mmiServiceBAICR : HsPhoneNetworkTypes.h
  • mmiServiceBAOC : HsPhoneNetworkTypes.h
  • mmiServiceBAOIC : HsPhoneNetworkTypes.h
  • mmiServiceBAOICX : HsPhoneNetworkTypes.h
  • mmiServiceChangeBarPwd : HsPhoneNetworkTypes.h
  • mmiServiceUnimplemented : HsPhoneNetworkTypes.h
  • MMPRO_ADD_MESSAGE_WITH_ATTACHMENT : PalmVMLaunch.h
  • MMPRO_LAUNCH_CODE : PalmVMLaunch.h
  • MMPRO_PLUGIN_EXTENDED_QUERY_LAUNCHCODE : PalmVMPlugin.h
  • MMPRO_PLUGIN_GET_INFO_LAUNCHCODE : PalmVMPlugin.h
  • MMPRO_PLUGIN_LAUNCHCODE : PalmVMPlugin.h
  • MMPRO_PLUGIN_QUERY_LAUNCHCODE : PalmVMPlugin.h
  • MMPRO_PLUGIN_RECEIVE_LAUNCHCODE : PalmVMPlugin.h
  • MMPRO_PLUGIN_SEND_LAUNCHCODE : PalmVMPlugin.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- n -

  • NBSHeaderEscapeSeq : HsPhoneSMSTypes.h
  • NBSHeaderID : HsPhoneSMSTypes.h
  • NBSHeaderIDLen : HsPhoneSMSTypes.h
  • NBSTextHeader : HsPhoneSMSTypes.h
  • NBSTextHeaderLength : HsPhoneSMSTypes.h
  • Net80211DeviceInfoP : PalmNetServices.h
  • Net80211InfrastructureModeType : PalmWiFiCommon.h
  • net80211ResetWepPasscode : PalmWiFiCommon.h
  • NetBssInfoTypeP : PalmWiFiCommon.h
  • NetBssListType : PalmWiFiCommon.h
  • netIFSettingShimConfig : PalmShimSettings.h
  • netIFSettingShimCreator : PalmShimSettings.h
  • NetIFSettingShimEnum : PalmShimSettings.h
  • netIFSettingShimHideProgress : PalmShimSettings.h
  • netIFSettingShimLibVersion : PalmShimSettings.h
  • netIFSettingShimLog : PalmShimSettings.h
  • netIFSettingShimUp : PalmShimSettings.h
  • netIFSettingShimVersion : PalmShimSettings.h
  • netIFSettingShimVPNStart : PalmShimSettings.h
  • netIFSettingShimVPNStop : PalmShimSettings.h
  • netMacAddrLength : PalmWiFiCommon.h
  • netMasterAnchorTimeoutDefault : NetMasterLibTypes.h
  • NetMasterAutoLoginSettingGet() : NetMasterLibrary.h
  • NetMasterAutoLoginSettingSet() : NetMasterLibrary.h
  • NetMasterAutoLoginType : NetMasterLibTypes.h
  • netMasterAutoLoginWhenWirelessOn : NetMasterLibTypes.h
  • netMasterClientCurrentEventVersion : NetMasterLibTypes.h
  • NetMasterClientEventEnum : NetMasterLibTypes.h
  • netMasterClientEventNotificationTypeID : NetMasterLibTypes.h
  • netMasterClientEventVPNConnInstall : NetMasterLibTypes.h
  • NetMasterDataContextIDType : NetMasterLibTypes.h
  • NetMasterDataSessionIDType : NetMasterLibTypes.h
  • netMasterErrAuthReqDuringBGLogin : NetMasterLibErrors.h
  • netMasterErrAutoLoginNotPossible : NetMasterLibErrors.h
  • netMasterErrBadArg : NetMasterLibErrors.h
  • netMasterErrBadPort : NetMasterLibErrors.h
  • netMasterErrCDMACarrierNetworkBusy : NetMasterLibErrors.h
  • netMasterErrClass : NetMasterLibErrors.h
  • netMasterErrConfigFailed : NetMasterLibErrors.h
  • netMasterErrConfigNotFound : NetMasterLibErrors.h
  • netMasterErrDispatchTable : NetMasterLibErrors.h
  • netMasterErrGPRSGenLoginErr : NetMasterLibErrors.h
  • netMasterErrInternalConnWouldBeImpossible : NetMasterLibErrors.h
  • netMasterErrMemory : NetMasterLibErrors.h
  • netMasterErrMIPFailed : NetMasterLibErrors.h
  • netMasterErrMIPReserved2 : NetMasterLibErrors.h
  • netMasterErrMIPReserved3 : NetMasterLibErrors.h
  • netMasterErrMIPReserved4 : NetMasterLibErrors.h
  • netMasterErrMIPUsernameSuspension801 : NetMasterLibErrors.h
  • netMasterErrNetGuardReqDuringBGLogin : NetMasterLibErrors.h
  • netMasterErrNetNotInstalled : NetMasterLibErrors.h
  • netMasterErrNo1xService : NetMasterLibErrors.h
  • netMasterErrNoNetPrefLib : NetMasterLibErrors.h
  • netMasterErrNoOneXServiceWhileRoaming : NetMasterLibErrors.h
  • netMasterErrOneXServiceNotEnabled : NetMasterLibErrors.h
  • netMasterErrOneXServiceUnavailable : NetMasterLibErrors.h
  • netMasterErrStorage : NetMasterLibErrors.h
  • netMasterErrUIRPCTimeout : NetMasterLibErrors.h
  • netMasterLibCreatorID : NetMasterLibTarget.h
  • netMasterLibName : NetMasterLibTarget.h
  • netMasterLibTypeID : NetMasterLibTarget.h
  • NetMasterLibVersionGet() : NetMasterLibrary.h
  • netMasterLoginNetGuardEnabled : NetMasterLibTypes.h
  • netMasterLoginPriorityDefault : NetMasterLibTypes.h
  • NetMasterLoginPriorityEnum : NetMasterLibTypes.h
  • netMasterLoginPriorityHigh : NetMasterLibTypes.h
  • netMasterLoginPriorityLow : NetMasterLibTypes.h
  • netMasterNetIFShutDownOptCurrentOnly : NetMasterLibTypes.h
  • netMasterNetIFShutDownOptDismissPrgDialog : NetMasterLibTypes.h
  • NetMasterNetIFShutDownOptionsType : NetMasterLibTypes.h
  • netMasterNetIFShutDownOptResetNetGuard : NetMasterLibTypes.h
  • NetMasterNetInterfacesShutDown() : NetMasterLibrary.h
  • NetMasterNetLibIsFullyUp() : NetMasterLibrary.h
  • NetMasterNetLibIsLoggingIn() : NetMasterLibrary.h
  • NetMasterNetLibOpenIfFullyUp() : NetMasterLibrary.h
  • netMasterNetLibOpenOptAutoDismiss : NetMasterLibTypes.h
  • netMasterNetLibOpenOptBypassNetGuard : NetMasterLibTypes.h
  • NetMasterNetLibOpenOptionsType : NetMasterLibTypes.h
  • netMasterNetLibOpenOptPrimaryProfileOnly : NetMasterLibTypes.h
  • NetMasterNetLibOpenWithOptions() : NetMasterLibrary.h
  • NetMasterSCContextAnchorTimeoutSet() : NetMasterLibrary.h
  • NetMasterSCNetAttach() : NetMasterLibrary.h
  • NetMasterSCNetDetach() : NetMasterLibrary.h
  • NetMasterSCSessionCountGet() : NetMasterLibrary.h
  • NetMasterSCSessionIDGetFromContext() : NetMasterLibrary.h
  • NetMasterSCSessionIsActive() : NetMasterLibrary.h
  • NetMasterSCSessionsEnumerate() : NetMasterLibrary.h
  • NetMasterSCSessionShutDown() : NetMasterLibrary.h
  • NetMasterSCSessionSvcRecIDGet() : NetMasterLibrary.h
  • netMediaConnected : PalmWiFiCommon.h
  • netMediaDisconnected : PalmWiFiCommon.h
  • netNum80211Rates : PalmWiFiCommon.h
  • netPref1xRTTTunnelingDefault : NetPrefLibTypes.h
  • NetPref1xRTTTunnelingEnum : NetPrefLibTypes.h
  • netPref1xRTTTunnelingForward : NetPrefLibTypes.h
  • netPref1xRTTTunnelingLAST : NetPrefLibTypes.h
  • netPref1xRTTTunnelingReverse : NetPrefLibTypes.h
  • netPref1xRTTTunnelingUnknown : NetPrefLibTypes.h
  • netPrefErrBadArg : NetPrefLibErrors.h
  • netPrefErrCCSMIncomplete : NetPrefLibErrors.h
  • netPrefErrCCSMNoCarrierMatch : NetPrefLibErrors.h
  • netPrefErrClass : NetPrefLibErrors.h
  • netPrefErrCSDNotAllowed : NetPrefLibErrors.h
  • netPrefErrFieldNotInSet : NetPrefLibErrors.h
  • netPrefErrMemory : NetPrefLibErrors.h
  • netPrefErrNoCCSMSettings : NetPrefLibErrors.h
  • netPrefErrNVRead : NetPrefLibErrors.h
  • netPrefErrNVSync : NetPrefLibErrors.h
  • netPrefErrNVWrite : NetPrefLibErrors.h
  • netPrefErrNVWritePDPInUse : NetPrefLibErrors.h
  • netPrefErrPhoneLibOpenFailed : NetPrefLibErrors.h
  • netPrefErrRadioIsOff : NetPrefLibErrors.h
  • netPrefErrReadOnlyField : NetPrefLibErrors.h
  • netPrefErrRecGone : NetPrefLibErrors.h
  • netPrefErrRecNotSaved : NetPrefLibErrors.h
  • netPrefErrStorage : NetPrefLibErrors.h
  • netPrefFallbackAlgrorithmBasic : NetPrefLibTypes.h
  • NetPrefFallbackAlgrorithmEnum : NetPrefLibTypes.h
  • netPrefFallbackAlgrorithmMutexSticky : NetPrefLibTypes.h
  • netPrefFieldSetDefineOptionNone : NetPrefLibTypes.h
  • NetPrefFieldSetDefineOptionsType : NetPrefLibTypes.h
  • netPrefFieldTypeBin : NetPrefLibTypes.h
  • NetPrefFieldTypeEnum : NetPrefLibTypes.h
  • netPrefFieldTypeStr : NetPrefLibTypes.h
  • netPrefFieldTypeZStrList : NetPrefLibTypes.h
  • NetPrefLibClose() : NetPrefLibrary.h
  • netPrefLibCreatorID : NetPrefLibTarget.h
  • netPrefLibName : NetPrefLibTarget.h
  • NetPrefLibOpen() : NetPrefLibrary.h
  • NetPrefLibSleep() : NetPrefLibrary.h
  • netPrefLibTypeID : NetPrefLibTarget.h
  • NetPrefLibVersionGet() : NetPrefLibrary.h
  • NetPrefLibWake() : NetPrefLibrary.h
  • netPrefMaxPhoneStringSize : NetPrefLibTypes.h
  • NetPrefMutexStickyFBAStatusEnum : NetPrefLibTypes.h
  • netPrefMutexStickyFBAStatusFailed : NetPrefLibTypes.h
  • netPrefMutexStickyFBAStatusSucceeded : NetPrefLibTypes.h
  • netPrefMutexStickyFBAStatusUnknown : NetPrefLibTypes.h
  • netPrefNetCloseWaitCarrierDefault : NetPrefLibTypes.h
  • netPrefNetCloseWaitEndOnPowerOff : NetPrefLibTypes.h
  • NetPrefNetCloseWaitEnum : NetPrefLibTypes.h
  • netPrefNetCloseWaitMaintainSession : NetPrefLibTypes.h
  • NetPrefNetIdleTimeoutEnum : NetPrefLibTypes.h
  • netPrefNetIdleTimeoutNever : NetPrefLibTypes.h
  • netPrefRecFieldAttrDirty : NetPrefLibTypes.h
  • netPrefRecFieldAttrInSet : NetPrefLibTypes.h
  • NetPrefRecFieldAttrType : NetPrefLibTypes.h
  • NetPrefRecFieldEnum : NetPrefLibTypes.h
  • netPrefRecFieldViewCache : NetPrefLibTypes.h
  • netPrefRecFieldViewClearAll : NetPrefLibTypes.h
  • netPrefRecFieldViewEditable : NetPrefLibTypes.h
  • netPrefRecFieldViewExternal : NetPrefLibTypes.h
  • netPrefRecFieldViewPrivate : NetPrefLibTypes.h
  • netPrefRecFieldViewRead : NetPrefLibTypes.h
  • NetPrefRecFieldViewType : NetPrefLibTypes.h
  • netPrefRecFieldViewVisible : NetPrefLibTypes.h
  • netPrefRecFieldViewWrite : NetPrefLibTypes.h
  • NetPrefRecIDType : NetPrefLibTypes.h
  • netPrefRecProtectionDeletionMask : NetPrefLibTypes.h
  • netPrefRecProtectionDuplicationMask : NetPrefLibTypes.h
  • netPrefRecProtectionEditingMask : NetPrefLibTypes.h
  • NetPrefRecProtectionType : NetPrefLibTypes.h
  • netPrefSvcBindingCCSM : NetPrefLibTypes.h
  • netPrefSvcBindingCustom : NetPrefLibTypes.h
  • NetPrefSvcBindingEnum : NetPrefLibTypes.h
  • netPrefSvcBindingIOTA : NetPrefLibTypes.h
  • netPrefSvcBindingLAST : NetPrefLibTypes.h
  • netPrefSvcBindingUnknown : NetPrefLibTypes.h
  • netPrefSvcGatewayBrowser : NetPrefLibTypes.h
  • netPrefSvcGatewayCorporate : NetPrefLibTypes.h
  • netPrefSvcGatewayDownloads : NetPrefLibTypes.h
  • netPrefSvcGatewayIM : NetPrefLibTypes.h
  • netPrefSvcGatewayInternet : NetPrefLibTypes.h
  • netPrefSvcGatewayLAST : NetPrefLibTypes.h
  • netPrefSvcGatewayMail : NetPrefLibTypes.h
  • netPrefSvcGatewayMMS : NetPrefLibTypes.h
  • netPrefSvcGatewayPictureMail : NetPrefLibTypes.h
  • netPrefSvcGatewayPrivate : NetPrefLibTypes.h
  • NetPrefSvcGatewayType : NetPrefLibTypes.h
  • netPrefSvcGatewayUnknown : NetPrefLibTypes.h
  • netPrefSvcGatewayWAP : NetPrefLibTypes.h
  • netPrefSvcMedium1xRTT : NetPrefLibTypes.h
  • netPrefSvcMediumCCSD : NetPrefLibTypes.h
  • netPrefSvcMediumDialUp : NetPrefLibTypes.h
  • netPrefSvcMediumDirect : NetPrefLibTypes.h
  • NetPrefSvcMediumEnum : NetPrefLibTypes.h
  • netPrefSvcMediumGCSD : NetPrefLibTypes.h
  • netPrefSvcMediumGISDN : NetPrefLibTypes.h
  • netPrefSvcMediumGPRS : NetPrefLibTypes.h
  • netPrefSvcMediumLAST : NetPrefLibTypes.h
  • netPrefSvcMediumOEM : NetPrefLibTypes.h
  • netPrefSvcMediumQNC : NetPrefLibTypes.h
  • netPrefSvcMediumUnknown : NetPrefLibTypes.h
  • netPrefSvcTargetBrowser : NetPrefLibTypes.h
  • netPrefSvcTargetCorporate : NetPrefLibTypes.h
  • netPrefSvcTargetDownloads : NetPrefLibTypes.h
  • NetPrefSvcTargetEnum : NetPrefLibTypes.h
  • netPrefSvcTargetIM : NetPrefLibTypes.h
  • netPrefSvcTargetInternet : NetPrefLibTypes.h
  • netPrefSvcTargetLAST : NetPrefLibTypes.h
  • netPrefSvcTargetMail : NetPrefLibTypes.h
  • netPrefSvcTargetMMS : NetPrefLibTypes.h
  • netPrefSvcTargetPictureMail : NetPrefLibTypes.h
  • netPrefSvcTargetReserved1 : NetPrefLibTypes.h
  • netPrefSvcTargetUnknown : NetPrefLibTypes.h
  • netPrefSvcTargetWAP : NetPrefLibTypes.h
  • NetQueryId : PalmWiFiCommon.h
  • NetQueryType : PalmWiFiCommon.h
  • NetQueryTypeP : PalmWiFiCommon.h
  • NetServicesProfileInfoP : PalmNetServices.h
  • NetServicesProfileOrderP : PalmNetServices.h
  • NetServicesProfileP : PalmNetServices.h
  • NetServicesProfileV1P : PalmNetServices.h
  • netSSIDMaxLength : PalmWiFiCommon.h
  • NetSSIDP : PalmWiFiCommon.h
  • NetWepKeyP : PalmWiFiCommon.h
  • NetWepStatus : PalmWiFiCommon.h
  • NewControlProc : HtmlLib68K.h
  • NewFieldProc : HtmlLib68K.h
  • NewListProc : HtmlLib68K.h
  • normal : VMFontLibCommon.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- o -

  • oemErrorClass : PalmErrorBase.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- a -

  • AACHeaderType : palmOneCodecFormat.h
  • AACObjectType : palmOneCodecFormat.h
  • addrAppLaunchCmdCallerID : HsAppLaunchCmd.h
  • addrAppLaunchCmdHsLookup : HsAppLaunchCmd.h
  • AddrCustomActionCodes : HsAppLaunchCmd.h
  • AddrCustomNotificationCodes : HsAppLaunchCmd.h
  • AddressAppPhoneLabel : HsPhoneSMSTypes.h
  • AddressAppRecordFieldEnum : HsPhoneSMSTypes.h
  • AddressHsLookupFields : HsAppLaunchCmd.h
  • Addressing16bitID : HsPhoneSMSTypes.h
  • Addressing16bitIDLen : HsPhoneSMSTypes.h
  • Addressing8bitID : HsPhoneSMSTypes.h
  • Addressing8bitIDLen : HsPhoneSMSTypes.h
  • AddrHsLookupParamsPtr : HsAppLaunchCmd.h
  • AddrHsLookupParamsType : HsAppLaunchCmd.h
  • AddrHsLookupUserDataVersion : HsAppLaunchCmd.h
  • AddrHsLookupUserDataVersion2 : HsAppLaunchCmd.h
  • addrListLookupTypeCompany : HsAppLaunchCmd.h
  • AddrListLookupTypeEnum : HsAppLaunchCmd.h
  • addrListLookupTypeFirstName : HsAppLaunchCmd.h
  • addrListLookupTypeIntelligent : HsAppLaunchCmd.h
  • addrListLookupTypeLastName : HsAppLaunchCmd.h
  • addrLookupAnyPhones : HsAppLaunchCmd.h
  • addrLookupNoMinLength : HsAppLaunchCmd.h
  • addrLookupSMSPhones : HsAppLaunchCmd.h
  • addrLookupSMSPhonesNoEmail : HsAppLaunchCmd.h
  • addrLookupVoicePhones : HsAppLaunchCmd.h
  • aiaExtentChangedData : PalmPin.h
  • allSize : VMFontLibCommon.h
  • allStyle : VMFontLibCommon.h
  • ATTYPE_MAX_NAME_LEN : PalmVMPlugin.h
  • autoLockMode : HsPhoneTypes.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- b -

  • bbutGadgetMiscSelectData : HsExtUtilBigButtonCommon.h
  • bbutGadgetMiscSelectSelector : HsExtUtilBigButtonCommon.h
  • BGRecvResponseFP : PalmBGService.h
  • BGServiceCancelRqst() : PalmBGService.h
  • BGServiceClose() : PalmBGService.h
  • bgServiceCreatorID : PalmBGService.h
  • BGServiceINetRqst() : PalmBGService.h
  • bgServiceLibName : PalmBGService.h
  • BGServiceNetRqst() : PalmBGService.h
  • BGServiceOpen() : PalmBGService.h
  • bgServiceType : PalmBGService.h
  • BGServiceVersion() : PalmBGService.h
  • bold : VMFontLibCommon.h
  • BSSINFO_ANL_OFFSET : PalmWiFiCommon.h
  • BSSINFO_ANL_SIZE : PalmWiFiCommon.h
  • BSSINFO_ANL_VFLAG : PalmWiFiCommon.h
  • BSSINFO_ATIM_WINDOW_OFFSET : PalmWiFiCommon.h
  • BSSINFO_ATIM_WINDOW_SIZE : PalmWiFiCommon.h
  • BSSINFO_ATIM_WINDOW_VFLAG : PalmWiFiCommon.h
  • BSSINFO_BEACON_PERIOD_OFFSET : PalmWiFiCommon.h
  • BSSINFO_BEACON_PERIOD_SIZE : PalmWiFiCommon.h
  • BSSINFO_BEACON_PERIOD_VFLAG : PalmWiFiCommon.h
  • BSSINFO_CHID_OFFSET : PalmWiFiCommon.h
  • BSSINFO_CHID_SIZE : PalmWiFiCommon.h
  • BSSINFO_CHID_VFLAG : PalmWiFiCommon.h
  • BSSINFO_DSFREQ_OFFSET : PalmWiFiCommon.h
  • BSSINFO_DSFREQ_SIZE : PalmWiFiCommon.h
  • BSSINFO_DSFREQ_VFLAG : PalmWiFiCommon.h
  • BSSINFO_HOPDWELL_OFFSET : PalmWiFiCommon.h
  • BSSINFO_HOPDWELL_SIZE : PalmWiFiCommon.h
  • BSSINFO_HOPDWELL_VFLAG : PalmWiFiCommon.h
  • BSSINFO_HOPPATTERN_OFFSET : PalmWiFiCommon.h
  • BSSINFO_HOPPATTERN_SIZE : PalmWiFiCommon.h
  • BSSINFO_HOPPATTERN_VFLAG : PalmWiFiCommon.h
  • BSSINFO_HOPSET_OFFSET : PalmWiFiCommon.h
  • BSSINFO_HOPSET_SIZE : PalmWiFiCommon.h
  • BSSINFO_HOPSET_VFLAG : PalmWiFiCommon.h
  • BSSINFO_MAC_ADDR_OFFSET : PalmWiFiCommon.h
  • BSSINFO_MAC_ADDR_SIZE : PalmWiFiCommon.h
  • BSSINFO_MAC_ADDR_VFLAG : PalmWiFiCommon.h
  • BSSINFO_NETWORK_MODE_OFFSET : PalmWiFiCommon.h
  • BSSINFO_NETWORK_MODE_SIZE : PalmWiFiCommon.h
  • BSSINFO_NETWORK_MODE_VFLAG : PalmWiFiCommon.h
  • BSSINFO_NETWORK_TYPE_OFFSET : PalmWiFiCommon.h
  • BSSINFO_NETWORK_TYPE_SIZE : PalmWiFiCommon.h
  • BSSINFO_NETWORK_TYPE_VFLAG : PalmWiFiCommon.h
  • BSSINFO_RSSI_OFFSET : PalmWiFiCommon.h
  • BSSINFO_RSSI_SIZE : PalmWiFiCommon.h
  • BSSINFO_RSSI_VFLAG : PalmWiFiCommon.h
  • BSSINFO_SIZE : PalmWiFiCommon.h
  • BSSINFO_SSID_OFFSET : PalmWiFiCommon.h
  • BSSINFO_SSID_SIZE : PalmWiFiCommon.h
  • BSSINFO_SSID_VFLAG : PalmWiFiCommon.h
  • BSSINFO_SSIDLENGTH_OFFSET : PalmWiFiCommon.h
  • BSSINFO_SSIDLENGTH_SIZE : PalmWiFiCommon.h
  • BSSINFO_SSIDLENGTH_VFLAG : PalmWiFiCommon.h
  • BSSINFO_SUPPORTED_RATES_OFFSET : PalmWiFiCommon.h
  • BSSINFO_SUPPORTED_RATES_SIZE : PalmWiFiCommon.h
  • BSSINFO_SUPPORTED_RATES_VFLAG : PalmWiFiCommon.h
  • BSSINFO_VFLAG : PalmWiFiCommon.h
  • BSSINFO_VFLAG_SIZE : PalmWiFiCommon.h
  • BSSINFO_WEP_OFFSET : PalmWiFiCommon.h
  • BSSINFO_WEP_SIZE : PalmWiFiCommon.h
  • BSSINFO_WEP_VFLAG : PalmWiFiCommon.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- c -

  • CallWithCommand : HsAppLaunchCmd.h
  • cameraAppLaunchCmdStopPreview : HsAppLaunchCmd.h
  • CameraLibCapture() : CameraLib.h
  • CameraLibClose() : CameraLib.h
  • CameraLibOpen() : CameraLib.h
  • CameraLibPreview() : CameraLib.h
  • CameraLibPreviewStart() : CameraLib.h
  • CameraLibPreviewStop() : CameraLib.h
  • CameraLibRegisterGet() : CameraLib.h
  • CameraLibRegisterSet() : CameraLib.h
  • CameraLibSleep() : CameraLib.h
  • CameraLibWake() : CameraLib.h
  • CamLibApertureValueType : palmOneCameraCommon.h
  • CamLibBitmapInfoType : palmOneCameraCommon.h
  • CamLibBufNumType : palmOneCameraCommon.h
  • CamLibCaptureCallbackFunc : palmOneCameraCommon.h
  • CamLibCaptureFormatType : palmOneCameraCommon.h
  • CamLibCaptureType : palmOneCameraCommon.h
  • CamLibClose() : palmOneCamera.h
  • CamLibColorSpaceType : palmOneCameraCommon.h
  • CamLibContrastType : palmOneCameraCommon.h
  • CamLibControl() : palmOneCamera.h
  • CamLibControlType : palmOneCameraCommon.h
  • CamLibEffectsType : palmOneCameraCommon.h
  • CamLibExposureType : palmOneCameraCommon.h
  • CamLibGetVersion() : palmOneCamera.h
  • CamLibImageSizeType : palmOneCameraCommon.h
  • CamLibLightingType : palmOneCameraCommon.h
  • CamLibOpen() : palmOneCamera.h
  • CamLibSaturationType : palmOneCameraCommon.h
  • CamLibSettingType : palmOneCameraCommon.h
  • CamLibSharpnessType : palmOneCameraCommon.h
  • CamLibShutterSpeedType : palmOneCameraCommon.h
  • CamLibSleep() : palmOneCamera.h
  • CamLibStatusType : palmOneCameraCommon.h
  • CamLibStreamPreviewType : palmOneCameraCommon.h
  • CamLibStreamType : palmOneCameraCommon.h
  • CamLibWake() : palmOneCamera.h
  • CamLibWhiteBalanceType : palmOneCameraCommon.h
  • CamLibZoomType : palmOneCameraCommon.h
  • CCSMBrowserFlagsType : CarrierCustomLibTypes.h
  • CCSMBrowserSettingsEnum : CarrierCustomLibTypes.h
  • CCSMCarrierHandle : CarrierCustomLibTypes.h
  • ccsmErrBufferTooSmall : CarrierCustomLibErr.h
  • ccsmErrClass : CarrierCustomLibErr.h
  • ccsmErrInvalidArg : CarrierCustomLibErr.h
  • ccsmErrLibUninitialized : CarrierCustomLibErr.h
  • ccsmErrMemory : CarrierCustomLibErr.h
  • ccsmErrNotRegistered : CarrierCustomLibErr.h
  • ccsmErrPhoneLibLoad : CarrierCustomLibErr.h
  • ccsmErrPhoneNotPowered : CarrierCustomLibErr.h
  • ccsmErrProfileUnspecified : CarrierCustomLibErr.h
  • ccsmErrUndefinedField : CarrierCustomLibErr.h
  • ccsmErrUnimplemented : CarrierCustomLibErr.h
  • ccsmErrUnknownCarrier : CarrierCustomLibErr.h
  • ccsmErrUnknownField : CarrierCustomLibErr.h
  • ccsmErrUnknownSetting : CarrierCustomLibErr.h
  • ccsmErrUnspecified : CarrierCustomLibErr.h
  • CCSMMessagingFlagsType : CarrierCustomLibTypes.h
  • CCSMMessagingSettingsEnum : CarrierCustomLibTypes.h
  • CCSMPhoneFlagsEnum : CarrierCustomLibTypes.h
  • CCSMPhoneFlagsType : CarrierCustomLibTypes.h
  • CCSMRadioBandEnum : CarrierCustomLibTypes.h
  • CCSMRadioBandType : CarrierCustomLibTypes.h
  • CCSMSettingsType : CarrierCustomLibTypes.h
  • CCSMSystemFlagsEnum : CarrierCustomLibTypes.h
  • CCSMSystemFlagsType : CarrierCustomLibTypes.h
  • CCustomLibClose() : CarrierCustomLib.h
  • CCustomLibGetCarrierCode() : CarrierCustomLib.h
  • CCustomLibGetCarrierCodeLength() : CarrierCustomLib.h
  • CCustomLibGetCarrierSetting() : CarrierCustomLib.h
  • CCustomLibOpen() : CarrierCustomLib.h
  • CCustomLibSleep() : CarrierCustomLib.h
  • CCustomLibVersionGet() : CarrierCustomLib.h
  • CCustomLibWake() : CarrierCustomLib.h
  • class0 : HsPhoneEvent.h
  • clirNotProvisioned : HsPhoneNetworkTypes.h
  • clirProvisioned : HsPhoneNetworkTypes.h
  • clirTemporaryAllowed : HsPhoneNetworkTypes.h
  • clirTemporaryRestricted : HsPhoneNetworkTypes.h
  • clirUnknown : HsPhoneNetworkTypes.h
  • codecDriverIMAADPCM : PalmSoundCustomCtrl.h
  • codecIMAADPCMSetBlockSize : PalmSoundCustomCtrl.h
  • CodecMgrClose() : palmOneCodecPluginMgr.h
  • CodecMgrCreateSession() : palmOneCodecPluginMgr.h
  • CodecMgrCreateSessionByID() : palmOneCodecPluginMgr.h
  • CodecMgrCustomControl() : palmOneCodecPluginMgr.h
  • CodecMgrDeleteSession() : palmOneCodecPluginMgr.h
  • CodecMgrEncodeDecode() : palmOneCodecPluginMgr.h
  • CodecMgrEnumerateFormats() : palmOneCodecPluginMgr.h
  • CodecMgrGetMaxDestBufferSize() : palmOneCodecPluginMgr.h
  • CodecMgrGetSessionInfo() : palmOneCodecPluginMgr.h
  • CodecMgrIsFormatSupported() : palmOneCodecPluginMgr.h
  • CodecMgrLibAPIVersion() : palmOneCodecPluginMgr.h
  • CodecMgrOpen() : palmOneCodecPluginMgr.h
  • CodecMgrResetSession() : palmOneCodecPluginMgr.h
  • CodecMgrSleep() : palmOneCodecPluginMgr.h
  • CodecMgrWake() : palmOneCodecPluginMgr.h
  • CompareToneIdentifiers : TonesLibTypes.h
  • CopyMIDIToneIdentifier : TonesLibTypes.h
  • CopyToneIdentifier : TonesLibTypes.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- d -

  • dataLinks : PalmVMPlugin.h
  • dbCacheFlag : PmPalmOSNVFS.h
  • DEFAULTHELPERLIB_TRAP : DefaultHelperLib.h
  • DefaultHelperLibClose() : DefaultHelperLib.h
  • defaultHelperLibCreator : DefaultHelperLibTypes.h
  • DefaultHelperLibGetDefaultHelper() : DefaultHelperLib.h
  • defaultHelperLibName : DefaultHelperLibTypes.h
  • DefaultHelperLibOpen() : DefaultHelperLib.h
  • DefaultHelperLibSetDefaultHelper() : DefaultHelperLib.h
  • DefaultHelperLibSleep() : DefaultHelperLib.h
  • defaultHelperLibType : DefaultHelperLibTypes.h
  • DefaultHelperLibWake() : DefaultHelperLib.h
  • DeleteObjectProc : HtmlLib68K.h
  • densityFtrCreator : palmOneFeatures.h
  • devAppLaunchCmdCallerId : PalmLaunchCodes.h
  • devAppLaunchCmdCustomBase : PalmLaunchCodes.h
  • devAppLaunchCmdGenericCall : PalmLaunchCodes.h
  • devAppLaunchCmdIncomingCall : PalmLaunchCodes.h
  • devAppLaunchCmdIncomingCallTest : PalmLaunchCodes.h
  • devAppLaunchCmdSliderClosed : PalmLaunchCodes.h
  • devAppLaunchCmdSliderOpened : PalmLaunchCodes.h
  • devAppLaunchCmdTelPowerOn : PalmLaunchCodes.h
  • devAppLaunchGenericCallOpCustomBase : PalmLaunchCodes.h
  • devAppLaunchGenericCallOpExit : PalmLaunchCodes.h
  • devAppLaunchGenericCallOpReturn : PalmLaunchCodes.h
  • devAppLaunchGenericCallOpSubcall : PalmLaunchCodes.h
  • devAppLaunchGenericCallRetAccepted : PalmLaunchCodes.h
  • devAppLaunchGenericCallRetRejected : PalmLaunchCodes.h
  • devAppLaunchLauncherDUBegin : PalmLaunchCodes.h
  • devAppLaunchLauncherDUEnd : PalmLaunchCodes.h
  • devAppLaunchLPCM_DUBegin : PalmLaunchCodes.h
  • devAppLaunchLPCM_DUEnd : PalmLaunchCodes.h
  • devAppLaunchMyFavorite : PalmLaunchCodes.h
  • devAppLaunchWithCodeCheck : PalmLaunchCodes.h
  • dexFtrNumVersion : PalmDisplayExtent.h
  • DexGetDisplayAddress() : PalmDisplayExtent.h
  • DexGetDisplayDimensions() : PalmDisplayExtent.h
  • dexLibCreator : PalmDisplayExtent.h
  • dexLibName : PalmDisplayExtent.h
  • dexLibType : PalmDisplayExtent.h
  • discardType0 : HsPhoneEvent.h
  • DmSyncDatabase() : PmPalmOSNVFS.h
  • DoFontDialog() : palmOneVMFontLib.h
  • dpiFtrValue : palmOneFeatures.h
  • DSTType : LocsLibCommon.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- e -

  • ENCRYPTED_DATABASE : CarrierCustomLib.h
  • END_OF_LIST : PalmNetServices.h
  • ePmConnectorAudioOutputSettingsType : PmConnectorLibCommon.h
  • ePmConnectorDeviceState : PmConnectorLibCommon.h
  • ESS : PalmWiFiCommon.h
  • expCapabilityHidden : PmPalmOSNVFS.h
  • expCapabilityNonRemovable : PmPalmOSNVFS.h
  • expIncludePrivateSlots : PmPalmOSNVFS.h
  • expMediaType_HD : palmOneCreators.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- f -

  • FavDBLibClose() : FavoritesDBLib.h
  • FavDBLibGetRecordId() : FavoritesDBLib.h
  • FavDBLibGetRecordLabel() : FavoritesDBLib.h
  • FavDBLibGetSpeedDialInfo() : FavoritesDBLib.h
  • FavDBLibIsFavoriteWithId() : FavoritesDBLib.h
  • FavDBLibLookupInSpeedDialDB() : FavoritesDBLib.h
  • FavDBLibNewAppFavorite() : FavoritesDBLib.h
  • FavDBLibNewEmailFavorite() : FavoritesDBLib.h
  • FavDBLibNewMsgFavorite() : FavoritesDBLib.h
  • FavDBLibNewPhoneFavorite() : FavoritesDBLib.h
  • FavDBLibNewPhoneViewFavorite() : FavoritesDBLib.h
  • FavDBLibNewWebFavorite() : FavoritesDBLib.h
  • FavDBLibOpen() : FavoritesDBLib.h
  • favDBLibPhoneViewCallLog : FavoritesDBLib.h
  • favDBLibPhoneViewContacts : FavoritesDBLib.h
  • favDBLibPhoneViewDialPad : FavoritesDBLib.h
  • FavDBLibPhoneViewEnum : FavoritesDBLib.h
  • FavDBLibResolveAddress() : FavoritesDBLib.h
  • FavDBLibSeekSpeedDialRecord() : FavoritesDBLib.h
  • FavDBLibSleep() : FavoritesDBLib.h
  • FavDBLibWake() : FavoritesDBLib.h
  • favoritesDBLibCreator : FavoritesDBLibTypes.h
  • favoritesDBLibName : FavoritesDBLibTypes.h
  • favoritesDBLibType : FavoritesDBLibTypes.h
  • FileBrowserLibAccept() : FileBrowserLib68K.h
  • FileBrowserLibClose() : FileBrowserLib68K.h
  • FileBrowserLibConnect() : FileBrowserLib68K.h
  • FileBrowserLibControl() : FileBrowserLib68K.h
  • FileBrowserLibDisconnect() : FileBrowserLib68K.h
  • FileBrowserLibGet() : FileBrowserLib68K.h
  • FileBrowserLibHandleEvent() : FileBrowserLib68K.h
  • FileBrowserLibOpen() : FileBrowserLib68K.h
  • FileBrowserLibParseFileURL() : FileBrowserLib68K.h
  • FileBrowserLibPut() : FileBrowserLib68K.h
  • FileBrowserLibReceive() : FileBrowserLib68K.h
  • FileBrowserLibRequest() : FileBrowserLib68K.h
  • FileBrowserLibSend() : FileBrowserLib68K.h
  • FileBrowserLibShowMultiselectDialog() : FileBrowserLib68K.h
  • FileBrowserLibShowOpenDialog() : FileBrowserLib68K.h
  • FileBrowserLibShowSaveAsDialog() : FileBrowserLib68K.h
  • FileBrowserLibSleep() : FileBrowserLib68K.h
  • FileBrowserLibWake() : FileBrowserLib68K.h
  • FileFlag : palmOneCodecFormat.h
  • FileStream : palmOneCodecFormat.h
  • fontPickerCreatorID : VMFontLibCommon.h
  • fontPickerLibName : VMFontLibCommon.h
  • fontPickerType : VMFontLibCommon.h
  • FrmCountObjectsInNavOrder() : HsNav.h
  • FrmGetNavEntry() : HsNav.h
  • FrmGetNavOrder() : HsNav.h
  • FrmGetNavState() : HsNav.h
  • FrmNavDrawFocusRing() : HsNav.h
  • FrmNavGetFocusRingInfo() : HsNav.h
  • FrmNavObjectTakeFocus() : HsNav.h
  • FrmNavRemoveFocusRing() : HsNav.h
  • FrmSetNavEntry() : HsNav.h
  • FrmSetNavOrder() : HsNav.h
  • FrmSetNavState() : HsNav.h
  • Full16bitTextHeader : HsPhoneSMSTypes.h
  • Full8bitTextHeader : HsPhoneSMSTypes.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- g -

  • gillSans : VMFontLibCommon.h
  • goLcdColorDefault : PalmGoLCDCommon.h
  • goLcdColorInverted : PalmGoLCDCommon.h
  • GoLcdColorModeType : PalmGoLCDCommon.h
  • goLcdColorOverride : PalmGoLCDCommon.h
  • goLcdCreator : PalmGoLCDCommon.h
  • goLcdDisabled : PalmGoLCDCommon.h
  • goLcdEnabled : PalmGoLCDCommon.h
  • goLcdFtrNumVersion : PalmGoLCDCommon.h
  • GoLcdGetBounds() : PalmGoLCD.h
  • GoLcdGetGsiState() : PalmGoLCD.h
  • GoLcdGetInkState() : PalmGoLCD.h
  • GoLcdGetStatus() : PalmGoLCD.h
  • GoLcdGetTimeout() : PalmGoLCD.h
  • goLcdGraffitiMode : PalmGoLCDCommon.h
  • goLcdGsiNormal : PalmGoLCDCommon.h
  • goLcdGsiOverride : PalmGoLCDCommon.h
  • GoLcdGsiStateType : PalmGoLCDCommon.h
  • goLcdInkDisabled : PalmGoLCDCommon.h
  • goLcdInkEnabled : PalmGoLCDCommon.h
  • GoLcdInkStateType : PalmGoLCDCommon.h
  • GoLcdLibAPIVersion : PalmGoLCDCommon.h
  • GoLcdLibClose() : PalmGoLCD.h
  • goLcdLibCreator : PalmGoLCDCommon.h
  • goLcdLibFtrNum : PalmGoLCDCommon.h
  • goLcdLibName : PalmGoLCDCommon.h
  • GoLcdLibOpen() : PalmGoLCD.h
  • goLcdLibType : PalmGoLCDCommon.h
  • goLcdModeCount : PalmGoLCDCommon.h
  • GoLcdModeType : PalmGoLCDCommon.h
  • goLcdNotAvailable : PalmGoLCDCommon.h
  • goLcdNotifyStatusEvent : PalmGoLCDCommon.h
  • goLcdPenTapMode : PalmGoLCDCommon.h
  • GoLcdSetBounds() : PalmGoLCD.h
  • GoLcdSetGsiState() : PalmGoLCD.h
  • GoLcdSetInkState() : PalmGoLCD.h
  • GoLcdSetStatus() : PalmGoLCD.h
  • GoLcdSetTimeout() : PalmGoLCD.h
  • GoLcdStatusType : PalmGoLCDCommon.h
  • GSMCLIPStatus : HsPhoneNetworkTypes.h
  • GSMCLIRDisplayStatus : HsPhoneNetworkTypes.h
  • gsmCLIRSubscription : HsPhoneNetworkTypes.h
  • GSMLibRingsDbName : HsPhoneGSMTypes.h
  • GSMReserved10 : HsPhoneTraps.h
  • GSMReserved11 : HsPhoneTraps.h
  • GSMReserved12 : HsPhoneTraps.h
  • GSMReserved13 : HsPhoneTraps.h
  • GSMReserved14 : HsPhoneTraps.h
  • GSMReserved15 : HsPhoneTraps.h
  • GSMReserved16 : HsPhoneTraps.h
  • GSMReserved17 : HsPhoneTraps.h
  • GSMReserved18 : HsPhoneTraps.h
  • GSMReserved19 : HsPhoneTraps.h
  • GSMReserved20 : HsPhoneTraps.h
  • GSMReserved21 : HsPhoneTraps.h
  • GSMReserved22 : HsPhoneTraps.h
  • GSMReserved7 : HsPhoneTraps.h
  • GSMReserved8 : HsPhoneTraps.h
  • GSMReserved9 : HsPhoneTraps.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- h -

  • HALAttnGetPalmLedAttributes() : PalmLED.h
  • HALAttnSetPalmLedAttributes() : PalmLED.h
  • HelperEnumerateEnqueueEntry : HsHelper.h
  • HelperServiceMMSDetailsType : MmsHelperCommon.h
  • HelperServiceMMSObjectType : MmsHelperCommon.h
  • HRTimeLibClose() : PalmHiResTime.h, palmOneHiResTimer.h
  • HRTimeLibGetTime() : PalmHiResTime.h, palmOneHiResTimer.h
  • HRTimeLibOpen() : PalmHiResTime.h, palmOneHiResTimer.h
  • HRTimeLibTicksPerSecond() : PalmHiResTime.h, palmOneHiResTimer.h
  • HS_AC97 : HsSoundLibCommon.h
  • HS_HTTPLibAuthCacheGetChallengeTokenSS() : HS_HTTPLib68K.h
  • HS_HTTPLibAuthInfoPass() : HS_HTTPLib68K.h
  • HS_HTTPLibAuthInfoRealm() : HS_HTTPLib68K.h
  • HS_HTTPLibAuthInfoTidy() : HS_HTTPLib68K.h
  • HS_HTTPLibAuthInfoUser() : HS_HTTPLib68K.h
  • HS_HTTPLibCertBeginPeekIssuerRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertBeginPeekSubjectRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertEndPeekIssuerRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertEndPeekSubjectRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListBeginDecode() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListClone() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListDelete() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListEndDecode() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListGetCipherInfo() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListImportCert() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListLength() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListLock() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListNew() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListType() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListUnlock() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekIssuerRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekIssuerRDNStrType() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekRSAPublicKeyBits() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekSerialNumber() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekSignAlgo() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekSubjectRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekSubjectRDNStrType() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekValidityEnd() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekValidityStart() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekVersion() : HS_HTTPLib68K.h
  • HS_HTTPLibClearDNSCache() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListClone() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListDelete() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListIsValid() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListLength() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListNew() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListSetValid() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertSelect() : HS_HTTPLib68K.h
  • HS_HTTPLibClose() : HS_HTTPLib68K.h
  • HS_HTTPLibCloseAllKeepAlive() : HS_HTTPLib68K.h
  • HS_HTTPLibCookieMakeEmpty() : HS_HTTPLib68K.h
  • HS_HTTPLibDataHandle_Delete() : HS_HTTPLib68K.h
  • HS_HTTPLibDataHandle_Length() : HS_HTTPLib68K.h
  • HS_HTTPLibDataHandle_Lock() : HS_HTTPLib68K.h
  • HS_HTTPLibDataHandle_Unlock() : HS_HTTPLib68K.h
  • HS_HTTPLibFinalize() : HS_HTTPLib68K.h
  • HS_HTTPLibFindAuthCandidate() : HS_HTTPLib68K.h
  • HS_HTTPLibFindAuthInfo() : HS_HTTPLib68K.h
  • HS_HTTPLibFixedString_Delete() : HS_HTTPLib68K.h
  • HS_HTTPLibFixedString_Length() : HS_HTTPLib68K.h
  • HS_HTTPLibFixedString_Lock() : HS_HTTPLib68K.h
  • HS_HTTPLibFixedString_Unlock() : HS_HTTPLib68K.h
  • HS_HTTPLibFixedStringNew() : HS_HTTPLib68K.h
  • HS_HTTPLibHandle : HS_HTTPLibApp.h
  • HS_HTTPLibHeaderSplitByX() : HS_HTTPLib68K.h
  • HS_HTTPLibInitialize() : HS_HTTPLib68K.h
  • HS_HTTPLibIsHTTP11OverProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibIsSendCookie() : HS_HTTPLib68K.h
  • HS_HTTPLibIsSendReferer() : HS_HTTPLib68K.h
  • HS_HTTPLibIsUseProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibLoadCookiesEntries() : HS_HTTPLib68K.h
  • HS_HTTPLibMakeAuthInfo() : HS_HTTPLib68K.h
  • HS_HTTPLibMakeCertList() : HS_HTTPLib68K.h
  • HS_HTTPLibMakeCookiesString() : HS_HTTPLib68K.h
  • HS_HTTPLibMakeProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibOpen() : HS_HTTPLib68K.h
  • HS_HTTPLibOpenCount() : HS_HTTPLib68K.h
  • HS_HTTPLibRegisterSSLClass() : HS_HTTPLib68K.h
  • HS_HTTPLibSaveCookiesEntries() : HS_HTTPLib68K.h
  • HS_HTTPLibServerCertConfirm() : HS_HTTPLib68K.h
  • HS_HTTPLibSetConnectTimeOut() : HS_HTTPLib68K.h
  • HS_HTTPLibSetCookie() : HS_HTTPLib68K.h
  • HS_HTTPLibSetCookieMax() : HS_HTTPLib68K.h
  • HS_HTTPLibSetCookieMode() : HS_HTTPLib68K.h
  • HS_HTTPLibSetCookieX() : HS_HTTPLib68K.h
  • HS_HTTPLibSetDefaultHeaders() : HS_HTTPLib68K.h
  • HS_HTTPLibSetDNSMaxRetry() : HS_HTTPLib68K.h
  • HS_HTTPLibSetDNSRetryInterval() : HS_HTTPLib68K.h
  • HS_HTTPLibSetHTTP11OverProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibSetHTTPPort() : HS_HTTPLib68K.h
  • HS_HTTPLibSetHTTPSPort() : HS_HTTPLib68K.h
  • HS_HTTPLibSetMaxKeepAliveTimeout() : HS_HTTPLib68K.h
  • HS_HTTPLibSetMaxRequestBody() : HS_HTTPLib68K.h
  • HS_HTTPLibSetMaxRequestHeader() : HS_HTTPLib68K.h
  • HS_HTTPLibSetNetLibProc() : HS_HTTPLib68K.h
  • HS_HTTPLibSetProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibSetReqTimeOut() : HS_HTTPLib68K.h
  • HS_HTTPLibSetRspTimeOut() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSendCookie() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSendProxyKeepAlive() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSendReferer() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSSLClientCertSelectProc() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSSLServerCertConfirmProc() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSSLVersionFlag() : HS_HTTPLib68K.h
  • HS_HTTPLibSetTunnelingCallback() : HS_HTTPLib68K.h
  • HS_HTTPLibSetUseProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibSetUserAgent() : HS_HTTPLib68K.h
  • HS_HTTPLibSetUseragentSelectionRule() : HS_HTTPLib68K.h
  • HS_HTTPLibSetUserPass() : HS_HTTPLib68K.h
  • HS_HTTPLibSetUserPassX() : HS_HTTPLib68K.h
  • HS_HTTPLibSetWakeUpCallback() : HS_HTTPLib68K.h
  • HS_HTTPLibSleep() : HS_HTTPLib68K.h
  • HS_HTTPLibSSLClass() : HS_HTTPLib68K.h
  • HS_HTTPLibSSLCloseCertDB() : HS_HTTPLib68K.h
  • HS_HTTPLibSSLOpenCertDB() : HS_HTTPLib68K.h
  • HS_HTTPLibSSLTimeout() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamAddHeader() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamAddHeaderLine() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamClose() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamCreateRequest() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamCreateRequestWithChunkEncoding() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamDelete() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetContentLength() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetEntityLength() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetFlag() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetHeader() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetHeaderWithOffset() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetRequestSent() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetResponseHeader() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetResponseHeaderLength() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetScheme() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetState() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetStatusCode() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamIsHeaderReceived() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamNew() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamReceiveResponse() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamResumeTimer() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamSendRequest() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamSendRequestWithChunkEncoding() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamSendRequestWithPostData() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamSetPostData() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamSuspendTimer() : HS_HTTPLib68K.h
  • HS_HTTPLibString_Delete() : HS_HTTPLib68K.h
  • HS_HTTPLibString_Length() : HS_HTTPLib68K.h
  • HS_HTTPLibString_Lock() : HS_HTTPLib68K.h
  • HS_HTTPLibString_Unlock() : HS_HTTPLib68K.h
  • HS_HTTPLibStringNew() : HS_HTTPLib68K.h
  • HS_HTTPLibURLString_Delete() : HS_HTTPLib68K.h
  • HS_HTTPLibURLString_Length() : HS_HTTPLib68K.h
  • HS_HTTPLibURLString_Lock() : HS_HTTPLib68K.h
  • HS_HTTPLibURLString_Unlock() : HS_HTTPLib68K.h
  • HS_HTTPLibURLStringNew() : HS_HTTPLib68K.h
  • HS_HTTPLibVHandle_Delete() : HS_HTTPLib68K.h
  • HS_HTTPLibVHandle_Length() : HS_HTTPLib68K.h
  • HS_HTTPLibVHandle_Lock() : HS_HTTPLib68K.h
  • HS_HTTPLibVHandle_Unlock() : HS_HTTPLib68K.h
  • HS_HTTPLibWake() : HS_HTTPLib68K.h
  • HS_RDIO : HsSoundLibCommon.h
  • HsAboutHandspringApp() : HsExt.h
  • hsAttr68KActiveCalls : HsExtCommon.h
  • hsAttr68KDisplayOn : HsExtCommon.h
  • hsAttr68KKeyboardLocked : HsExtCommon.h
  • hsAttr68KKeyLockNextWakeTicks : HsExtCommon.h
  • hsAttr68KLidOpen : HsExtCommon.h
  • hsAttr68KPhoneType : HsExtCommon.h
  • hsAttr68KPostProcessRsc : HsExtCommon.h
  • hsAttr68KRingSwitch : HsExtCommon.h
  • hsAttr68KSysActive : HsExtCommon.h
  • hsAttr68KSysSleepReason : HsExtCommon.h
  • hsAttrActiveCalls : HsExtCommon.h
  • hsAttrAllKeysWakeFromSleep : HsExtCommon.h
  • hsAttrDigitizerLock : HsExtCommon.h
  • hsAttrDisplayOn : HsExtCommon.h
  • hsAttrDitherSuppress : HsExtCommon.h
  • hsAttrE911Mode : HsExtCommon.h
  • HsAttrEnum : HsExtCommon.h
  • HsAttrGet() : HsExt.h
  • hsAttrHotSyncSuppress : HsExtCommon.h
  • hsAttrKeyboardDB : HsExtCommon.h
  • hsAttrKeyboardLocked : HsExtCommon.h
  • hsAttrKeyLockNextWakeTicks : HsExtCommon.h
  • hsAttrLidOpen : HsExtCommon.h
  • hsAttrPhoneRadioPowerState : HsExtCommon.h
  • hsAttrPhoneType : HsExtCommon.h
  • hsAttrPhoneTypeCDMA : HsExtCommon.h
  • hsAttrPhoneTypeGSM : HsExtCommon.h
  • hsAttrPostProcessRsc : HsExtCommon.h
  • hsAttrRingSwitch : HsExtCommon.h
  • hsAttrRingSwitchLoud : HsExtCommon.h
  • hsAttrRingSwitchMute : HsExtCommon.h
  • HsAttrSet() : HsExt.h
  • hsAttrSysActive : HsExtCommon.h
  • hsAttrSysActiveHotSync : HsExtCommon.h
  • hsAttrSysActiveProgress : HsExtCommon.h
  • hsAttrSysSleepReason : HsExtCommon.h
  • hsBigButtonRscType : HsExtUtilBigButtonCommon.h
  • HsBrowseUrl() : HsExt.h
  • HsCreateNewEmail() : HsExt.h
  • HsCreateNewMessage() : HsExt.h
  • hsDeviceIDTreo180 : HsExtCommon.h
  • hsDeviceIDTreo270 : HsExtCommon.h
  • hsDeviceIDTreo300 : HsExtCommon.h
  • hsDeviceIDTreo600 : HsExtCommon.h
  • hsDeviceIDTreo600Sim : HsExtCommon.h
  • hsDeviceIDTreo90 : HsExtCommon.h
  • hsDeviceIDVisor : HsExtCommon.h
  • hsDeviceIDVisorEdge : HsExtCommon.h
  • hsDeviceIDVisorNeo : HsExtCommon.h
  • hsDeviceIDVisorPlatinum : HsExtCommon.h
  • hsDeviceIDVisorPrism : HsExtCommon.h
  • hsDeviceIDVisorPro : HsExtCommon.h
  • hsDialPrefsAddAreaCodeNo : HsAppLaunchCmd.h
  • hsDialPrefsAddAreaCodeUnknown : HsAppLaunchCmd.h
  • hsDialPrefsAddAreaCodeYes : HsAppLaunchCmd.h
  • hsDialPrefsAutoAreaCodeLength : HsAppLaunchCmd.h
  • hsDispFtrCreator : HsExtCommon.h
  • hsDispFtrIDControllerShades : HsExtCommon.h
  • hsDispFtrIDDisplayAttributes : HsExtCommon.h
  • hsDispFtrValBulverdePxa27X : HsExtCommon.h
  • hsDispFtrValBwStn : HsExtCommon.h
  • hsDispFtrValColorOled : HsExtCommon.h
  • hsDispFtrValColorStn : HsExtCommon.h
  • hsDispFtrValColorTft : HsExtCommon.h
  • hsDispFtrValGrayOffset : HsExtCommon.h
  • hsDispFtrValOmapX10 : HsExtCommon.h
  • hsErrAppStopEvent : HsExtCommon.h
  • hsErrBufferTooSmall : HsExtCommon.h
  • hsErrCardNotInstalled : HsExtCommon.h
  • hsErrCardPatchAlreadyInstalled : HsExtCommon.h
  • hsErrCardPatchNotInstalled : HsExtCommon.h
  • hsErrFixedStorageRequired : HsExtCommon.h
  • hsErrGPRSNotAttached : HsExtCommon.h
  • hsErrIndicatorDisabled : HsExtCommon.h
  • hsErrIndicatorInvalidCap : HsExtCommon.h
  • hsErrIndicatorInvalidSequence : HsExtCommon.h
  • hsErrInUse : HsExtCommon.h
  • hsErrInvalidCardHdr : HsExtCommon.h
  • hsErrInvalidCardNum : HsExtCommon.h
  • hsErrInvalidParam : HsExtCommon.h
  • hsErrInvalidPeriod : HsExtCommon.h
  • hsErrNotEnoughPower : HsExtCommon.h
  • hsErrNotSupported : HsExtCommon.h
  • hsErrOutOfCoverage : HsExtCommon.h
  • hsErrOutOfMemory : HsExtCommon.h
  • hsErrPeriodicAlreadyInstalled : HsExtCommon.h
  • hsErrPeriodicNotInstalled : HsExtCommon.h
  • hsErrPhoneLocked : HsErrors.h
  • hsErrPhoneNotActivated : HsErrors.h
  • hsErrRadioNotRegistered : HsErrors.h
  • hsErrRadioOff : HsErrors.h
  • hsErrReadOnly : HsExtCommon.h
  • hsErrSIMMissing : HsExtCommon.h
  • hsErrSimNotReady : HsErrors.h
  • hsErrTimeOut : HsExtCommon.h
  • hsErrUnderflow : HsExtCommon.h
  • hsErrUserInterrupted : HsExtCommon.h
  • hsErrUserNoRadio : HsExtCommon.h
  • hsErrVoiceCallActive : HsErrors.h
  • HsEvtMetaEvent() : HsExt.h
  • HsExtDoSaveAsDialog() : HsExt.h
  • HsExtExgLocalAccept() : HsExgMgr.h
  • HsExtExgLocalDisconnect() : HsExgMgr.h
  • HsExtExgSelectTarget() : HsExgMgr.h
  • hsFtrCreator : HsExtCommon.h
  • hsFtrIDBugsFixed : HsExtCommon.h
  • hsFtrIDCurrentAppOnSleep : HsExtCommon.h
  • hsFtrIDGrfAreaDisabled : HsExtCommon.h
  • hsFtrIDHardwareApiRevision : HsExtCommon.h
  • hsFtrIDKeyboardLayout : HsExtCommon.h
  • hsFtrIDLdbMgrLibRefNum : HsExtCommon.h
  • hsFtrIDModDate : HsExtCommon.h
  • hsFtrIDNavigationSupported : HsExtCommon.h
  • hsFtrIDNoMemSemaphore : HsExtCommon.h
  • hsFtrIDPowerKeyResponse : HsExtCommon.h
  • hsFtrIDRadioAttributes : HsExtCommon.h
  • hsFtrIDStatusGadgetRev : HsExtCommon.h
  • hsFtrIDTestingBootMode : HsExtCommon.h
  • hsFtrIDToneOnLidOpen : HsExtCommon.h
  • hsFtrIDTypeOfKeyboard : HsExtCommon.h
  • hsFtrIDVersion : HsExtCommon.h
  • hsFtrValCurrentAppOnSleepPhoneAppSpeedDialView : HsExtCommon.h
  • hsFtrValKeyboardBasic : HsExtCommon.h
  • hsFtrValKeyboardCommCentric : HsExtCommon.h
  • hsFtrValKeyboardCustomApps : HsExtCommon.h
  • hsFtrValKeyboardJog : HsExtCommon.h
  • hsFtrValKeyboardLayout_deDE : HsExtCommon.h
  • hsFtrValKeyboardLayout_enUS : HsExtCommon.h
  • hsFtrValKeyboardLayout_frFR : HsExtCommon.h
  • hsFtrValKeyboardQwerty : HsExtCommon.h
  • hsFtrValPowerKeyDoubleClkBacklight : HsExtCommon.h
  • hsFtrValPowerKeyHoldRadioPower : HsExtCommon.h
  • hsFtrValPowerKeyTripleClkInvert : HsExtCommon.h
  • hsFtrValRadioAvailable : HsExtCommon.h
  • hsFtrValRadioBuiltin : HsExtCommon.h
  • hsFtrValStatusGadgetRev1 : HsExtCommon.h
  • HsGetPhoneLibrary() : HsExt.h
  • HsGetTrapAddress() : HsExt.h
  • HsGetVersionString() : HsExt.h
  • HsGrfGetStateExt() : HsExt.h
  • HsGrfSetStateExt() : HsExt.h
  • hsHALIDHandspringOs35_40 : HsExtCommon.h
  • hsHALIDHandspringOs5Rev1 : HsExtCommon.h
  • hsHALIDHandspringOs5Rev1Sim : HsExtCommon.h
  • hsHALIDHandspringOs5Rev2 : HsExtCommon.h
  • hsHALIDHandspringOs5Rev2Sim : HsExtCommon.h
  • hsHALIDHandspringOs5Rev3 : HsExtCommon.h
  • hsHALIDHandspringOs5Rev3Sim : HsExtCommon.h
  • hsHALIDHandspringOs5Rev4 : HsExtCommon.h
  • hsHALIDHandspringOs5Rev4Sim : HsExtCommon.h
  • HsIndicatorCountEnum : HsExtCommon.h
  • HsIndicatorState() : HsExt.h
  • HsIndicatorStateEnum : HsExtCommon.h
  • HsInfo() : HsExt.h
  • HsIsHTTPLibraryLoaded() : HsExt.h
  • HsKeyChrCodeToKeyCode() : HsExt.h
  • HsKeyCurrentStateExt() : HsExt.h
  • HsKeyEnableKey() : HsExt.h
  • HsKeyEventIsFromKeyboard() : HsExt.h
  • hsKeyguardAutoDisabled : HsExtCommon.h
  • hsKeyguardAutoPowerOff : HsExtCommon.h
  • hsKeyguardFlagPowerOnDialog : HsExtCommon.h
  • HsKeyKeyCodeToChrCode() : HsExt.h
  • HsKeySetMaskExt() : HsExt.h
  • HsKeysPressed() : HsExt.h
  • HsKeyStop() : HsExt.h
  • hsLibAliasConsole : HsExtCommon.h
  • hsLibAliasDefault : HsExtCommon.h
  • hsLibAliasHotSyncLocal : HsExtCommon.h
  • hsLibAliasHotSyncModem : HsExtCommon.h
  • hsLibAliasIrda : HsExtCommon.h
  • hsLibNameBuiltInSerial : HsExtCommon.h
  • HsLightCircumstance() : HsExt.h
  • hsLightCircumstanceAlertWokeDevice : HsExtCommon.h
  • HsLightCircumstanceEnum : HsExtCommon.h
  • hsLightCircumstanceNumCircumstances : HsExtCommon.h
  • hsLightCircumstanceQuickTyping : HsExtCommon.h
  • hsLightCircumstanceReserved : HsExtCommon.h
  • hsLightCircumstanceUserNotLooking : HsExtCommon.h
  • hsLightCircumstanceUserNotLookingLongTime : HsExtCommon.h
  • HsLightMode() : HsExt.h
  • HsLightModeEnum : HsExtCommon.h
  • hsLightModeNight : HsExtCommon.h
  • hsLightModeNormal : HsExtCommon.h
  • hsLightModeNumPresets : HsExtCommon.h
  • hsLightModeReserved : HsExtCommon.h
  • hsMaxSaveAsNameSize : HsExtCommon.h
  • HsNavDrawFocusRing() : HsExt.h
  • HsNavGetFocusColor() : HsExt.h
  • HsNavGetFocusRingInfo() : HsExt.h
  • HsNavLstGetTempSelection() : HsExt.h
  • HsNavLstSetTempSelection() : HsExt.h
  • HsNavObjectTakeFocus() : HsExt.h
  • HsNavRemoveFocusRing() : HsExt.h
  • HsNavSetFocusColor() : HsExt.h
  • HsNetworkDropConnection() : HsExt.h
  • hsOLDErrorClass : HsExtCommon.h
  • HsOpenDialNumberDialog() : HsExt.h
  • HsPostProcessPopupList() : HsExtKbdUtils.h
  • hsPrefBlinkGreenLEDInCoverage : HsExtCommon.h
  • HsPrefEnum : HsExtCommon.h
  • HsPrefGet() : HsExt.h
  • hsPrefHard11CharAppCreator : HsExtCommon.h
  • hsPrefJogScanCharAppCreator : HsExtCommon.h
  • hsPrefKeyguardAutoEnableAutoOffExtraTime : HsExtCommon.h
  • hsPrefKeyguardAutoEnableTime : HsExtCommon.h
  • hsPrefKeyguardFlags : HsExtCommon.h
  • hsPrefLCDRefreshRate : HsExtCommon.h
  • hsPrefLidClosedAutoOffSeconds : HsExtCommon.h
  • hsPrefLidStatusChgCharAppCreator : HsExtCommon.h
  • hsPrefNetworkTimeSelected : HsExtCommon.h
  • hsPrefNetworkTZSelected : HsExtCommon.h
  • hsPrefOptHard11CharAppCreator : HsExtCommon.h
  • hsPrefOptHard1CharAppCreator : HsExtCommon.h
  • hsPrefOptHard2CharAppCreator : HsExtCommon.h
  • hsPrefOptHard3CharAppCreator : HsExtCommon.h
  • hsPrefOptHard4CharAppCreator : HsExtCommon.h
  • hsPrefOptHardPowerCharAppCreator : HsExtCommon.h
  • hsPrefOptReservedCharAppCreator : HsExtCommon.h
  • hsPrefPowerOnAppCreator : HsExtCommon.h
  • hsPrefSerialLibConsole : HsExtCommon.h
  • hsPrefSerialLibDef : HsExtCommon.h
  • hsPrefSerialLibHotSyncLocal : HsExtCommon.h
  • hsPrefSerialLibHotSyncModem : HsExtCommon.h
  • hsPrefSerialLibIrda : HsExtCommon.h
  • HsPrefSet() : HsExt.h
  • hsPrefSideHardCharAppCreator : HsExtCommon.h
  • hsPrefTempShiftTimeOut : HsExtCommon.h
  • hsPrefTouchscreenDisableFlags : HsExtCommon.h
  • hsPrefUserNotLookingTime : HsExtCommon.h
  • HsPutObjectAfterTitle() : HsExt.h
  • hsSelDmCreateDatabasesFromImages : HsExtTraps.h
  • hsSelPrvLaunchDemoApp : HsExtTraps.h
  • hsSelPrvSetupGoToCustomForm : HsExtTraps.h
  • hsSelPrvSetupInstallFormEventHandler : HsExtTraps.h
  • hsSndAmplitude_silent : HsSoundLibCommon.h
  • hsSndAmplitude_unity : HsSoundLibCommon.h
  • hsSndBatFull : HsSoundLibCommon.h
  • hsSndBatLow : HsSoundLibCommon.h
  • hsSndBatShutdown : HsSoundLibCommon.h
  • hsSndBayID_AC97 : HsSoundLibCommon.h
  • hsSndBayID_Radio : HsSoundLibCommon.h
  • hsSndBoost_Disable : HsSoundLibCommon.h
  • hsSndBoost_Enable : HsSoundLibCommon.h
  • HsSndBufferProc : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvMask : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvNone : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvRings : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvVibeNone : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvVibeRings : HsSoundLibCommon.h
  • hsSndBufFlags_canInterrupt : HsSoundLibCommon.h
  • hsSndBufFlags_cannotInterrupt : HsSoundLibCommon.h
  • hsSndBufFlags_endDelayMask : HsSoundLibCommon.h
  • hsSndBufFlags_interruptMask : HsSoundLibCommon.h
  • hsSndBufFlags_noEndDelay : HsSoundLibCommon.h
  • hsSndBufFlags_noRepeat : HsSoundLibCommon.h
  • hsSndBufFlags_repeatMask : HsSoundLibCommon.h
  • hsSndBufFlags_yesEndDelay : HsSoundLibCommon.h
  • hsSndBufFlags_yesRepeat : HsSoundLibCommon.h
  • hsSndCardInsert : HsSoundLibCommon.h
  • hsSndCardRemove : HsSoundLibCommon.h
  • hsSndChargerAttach : HsSoundLibCommon.h
  • hsSndChargerDetach : HsSoundLibCommon.h
  • HsSndClose() : HsSoundLib.h
  • HsSndCmdEnumTag : HsSoundLibCommon.h
  • hsSndCmdFlags_noWait : HsSoundLibCommon.h
  • hsSndCmdFlags_waitMask : HsSoundLibCommon.h
  • hsSndCmdFlags_yesWait : HsSoundLibCommon.h
  • hsSndCmdPlay : HsSoundLibCommon.h
  • hsSndCmdStop : HsSoundLibCommon.h
  • HsSndCmdType : HsSoundLibCommon.h
  • hsSndDeepSleep : HsSoundLibCommon.h
  • hsSndDeepWake : HsSoundLibCommon.h
  • hsSndErr_DoMidiProgressMsg : HsSoundLibCommon.h
  • hsSndErr_Failed : HsSoundLibCommon.h
  • hsSndErr_InvalidPort : HsSoundLibCommon.h
  • hsSndErr_InvalidPrefValue : HsSoundLibCommon.h
  • hsSndErr_InvalidSwitch : HsSoundLibCommon.h
  • hsSndErr_LastPublicError : HsSoundLibCommon.h
  • hsSndErr_NotSupported : HsSoundLibCommon.h
  • hsSndErr_PortBoostLocked : HsSoundLibCommon.h
  • hsSndErr_PortCannotBoost : HsSoundLibCommon.h
  • hsSndErr_PortCannotMute : HsSoundLibCommon.h
  • hsSndErr_PortCannotPan : HsSoundLibCommon.h
  • hsSndErr_PortCannotVolume : HsSoundLibCommon.h
  • hsSndErr_PortIDNotInClass : HsSoundLibCommon.h
  • hsSndErr_PortMuteLocked : HsSoundLibCommon.h
  • hsSndErr_PortPanLocked : HsSoundLibCommon.h
  • hsSndErr_PortVolumeLocked : HsSoundLibCommon.h
  • hsSndErr_UnknownClkRef : HsSoundLibCommon.h
  • hsSndErr_UnknownPortClass : HsSoundLibCommon.h
  • hsSndErr_UnknownSndParam : HsSoundLibCommon.h
  • hsSndFormatAmr : HsSoundLibCommon.h
  • HsSndFormatEnumTag : HsSoundLibCommon.h
  • hsSndFormatMidi : HsSoundLibCommon.h
  • HsSndFormatPlay() : HsSoundLib.h
  • HsSndFormatRecord() : HsSoundLib.h
  • HsSndFormatType : HsSoundLibCommon.h
  • HsSndGetUserVolume() : HsSoundLib.h
  • HsSndGetVersion() : HsSoundLib.h
  • hsSndLibVersion : HsSoundLibCommon.h
  • HsSndMode : HsSoundLibCommon.h
  • hsSndMode_Carkit : HsSoundLibCommon.h
  • hsSndMode_Current : HsSoundLibCommon.h
  • hsSndMode_Headphones : HsSoundLibCommon.h
  • hsSndMode_HeadphonesHost : HsSoundLibCommon.h
  • hsSndMode_Headset : HsSoundLibCommon.h
  • hsSndMode_Receiver : HsSoundLibCommon.h
  • hsSndMode_Reserved : HsSoundLibCommon.h
  • hsSndMode_SpeakerHost : HsSoundLibCommon.h
  • hsSndMode_Speakerphone : HsSoundLibCommon.h
  • hsSndMute_Disable : HsSoundLibCommon.h
  • hsSndMute_Enable : HsSoundLibCommon.h
  • hsSndNotify : HsSoundLibCommon.h
  • hsSndNotifyAlert : HsSoundLibCommon.h
  • hsSndNotifyAnswerButton : HsSoundLibCommon.h
  • hsSndNotifyAnswerHold : HsSoundLibCommon.h
  • hsSndNotifyAnswerRelease : HsSoundLibCommon.h
  • hsSndNotifyAthenaAudio : HsSoundLibCommon.h
  • hsSndNotifyCarkitActive : HsSoundLibCommon.h
  • hsSndNotifyCarkitInactive : HsSoundLibCommon.h
  • hsSndNotifyHeadphones : HsSoundLibCommon.h
  • hsSndNotifyHeadset : HsSoundLibCommon.h
  • hsSndNotifyHighPriority : HsSoundLibCommon.h
  • hsSndNotifyHybrid : HsSoundLibCommon.h
  • hsSndNotifyRingerSwitchOff : HsSoundLibCommon.h
  • hsSndNotifyRingerSwitchOn : HsSoundLibCommon.h
  • hsSndNotifyUnplugged : HsSoundLibCommon.h
  • HsSndOpen() : HsSoundLib.h
  • hsSndPan_Left : HsSoundLibCommon.h
  • hsSndPan_LeftNormal : HsSoundLibCommon.h
  • hsSndPan_Middle : HsSoundLibCommon.h
  • hsSndPan_Right : HsSoundLibCommon.h
  • hsSndPan_RightNormal : HsSoundLibCommon.h
  • HsSndParam : HsSoundLibCommon.h
  • hsSndParam_Boost : HsSoundLibCommon.h
  • hsSndParam_Mute : HsSoundLibCommon.h
  • hsSndParam_Pan : HsSoundLibCommon.h
  • hsSndParam_Volume : HsSoundLibCommon.h
  • hsSndParamMode_LockParam : HsSoundLibCommon.h
  • hsSndParamMode_Mask : HsSoundLibCommon.h
  • hsSndParamMode_Normal : HsSoundLibCommon.h
  • hsSndParamMode_UnlockParam : HsSoundLibCommon.h
  • HsSndParamValue_RemoveMode : HsSoundLibCommon.h
  • HsSndParamValue_SetWithLock : HsSoundLibCommon.h
  • HsSndParamValue_SetWithUnlock : HsSoundLibCommon.h
  • HsSndPortClass : HsSoundLibCommon.h
  • hsSndPortClass_Anchor : HsSoundLibCommon.h
  • hsSndPortClass_BaseDefault : HsSoundLibCommon.h
  • hsSndPortClass_Real : HsSoundLibCommon.h
  • hsSndPortClass_Virtual : HsSoundLibCommon.h
  • hsSndPortFlags_Boost_Locked : HsSoundLibCommon.h
  • hsSndPortFlags_Boost_LockMask : HsSoundLibCommon.h
  • hsSndPortFlags_Boost_Unlocked : HsSoundLibCommon.h
  • hsSndPortFlags_BoostMask : HsSoundLibCommon.h
  • hsSndPortFlags_BoostOff : HsSoundLibCommon.h
  • hsSndPortFlags_BoostOn : HsSoundLibCommon.h
  • hsSndPortFlags_CanBoost_No : HsSoundLibCommon.h
  • hsSndPortFlags_CanBoost_Yes : HsSoundLibCommon.h
  • hsSndPortFlags_CanBoostMask : HsSoundLibCommon.h
  • hsSndPortFlags_CanInputOnly : HsSoundLibCommon.h
  • hsSndPortFlags_CanIOBothways : HsSoundLibCommon.h
  • hsSndPortFlags_CanIOMask : HsSoundLibCommon.h
  • hsSndPortFlags_CanIOSelect : HsSoundLibCommon.h
  • hsSndPortFlags_CanMute_No : HsSoundLibCommon.h
  • hsSndPortFlags_CanMute_Yes : HsSoundLibCommon.h
  • hsSndPortFlags_CanMuteMask : HsSoundLibCommon.h
  • hsSndPortFlags_CanOutputOnly : HsSoundLibCommon.h
  • hsSndPortFlags_CanPan_No : HsSoundLibCommon.h
  • hsSndPortFlags_CanPan_Yes : HsSoundLibCommon.h
  • hsSndPortFlags_CanPanMask : HsSoundLibCommon.h
  • hsSndPortFlags_CanVol_No : HsSoundLibCommon.h
  • hsSndPortFlags_CanVol_Yes : HsSoundLibCommon.h
  • hsSndPortFlags_CanVolMask : HsSoundLibCommon.h
  • hsSndPortFlags_Disabled : HsSoundLibCommon.h
  • hsSndPortFlags_Enabled : HsSoundLibCommon.h
  • hsSndPortFlags_EnableMask : HsSoundLibCommon.h
  • hsSndPortFlags_InputMask : HsSoundLibCommon.h
  • hsSndPortFlags_InputOff : HsSoundLibCommon.h
  • hsSndPortFlags_InputOn : HsSoundLibCommon.h
  • hsSndPortFlags_Mute_Locked : HsSoundLibCommon.h
  • hsSndPortFlags_Mute_LockMask : HsSoundLibCommon.h
  • hsSndPortFlags_Mute_Unlocked : HsSoundLibCommon.h
  • hsSndPortFlags_MuteMask : HsSoundLibCommon.h
  • hsSndPortFlags_MuteOff : HsSoundLibCommon.h
  • hsSndPortFlags_MuteOn : HsSoundLibCommon.h
  • hsSndPortFlags_OutputMask : HsSoundLibCommon.h
  • hsSndPortFlags_OutputOff : HsSoundLibCommon.h
  • hsSndPortFlags_OutputOn : HsSoundLibCommon.h
  • hsSndPortFlags_Pan_Locked : HsSoundLibCommon.h
  • hsSndPortFlags_Pan_LockMask : HsSoundLibCommon.h
  • hsSndPortFlags_Pan_Unlocked : HsSoundLibCommon.h
  • hsSndPortFlags_TypeAnalog : HsSoundLibCommon.h
  • hsSndPortFlags_TypeDigital : HsSoundLibCommon.h
  • hsSndPortFlags_TypeMask : HsSoundLibCommon.h
  • hsSndPortFlags_Vol_Locked : HsSoundLibCommon.h
  • hsSndPortFlags_Vol_LockMask : HsSoundLibCommon.h
  • hsSndPortFlags_Vol_Unlocked : HsSoundLibCommon.h
  • HsSndPortGetInfo() : HsSoundLib.h
  • HsSndPortID : HsSoundLibCommon.h
  • hsSndPortID_ConnectCall : HsSoundLibCommon.h
  • hsSndPortID_Current : HsSoundLibCommon.h
  • hsSndPortID_InBaseMic : HsSoundLibCommon.h
  • hsSndPortID_InCarkit : HsSoundLibCommon.h
  • hsSndPortID_InHeadsetMic : HsSoundLibCommon.h
  • hsSndPortID_InHostBaseMic : HsSoundLibCommon.h
  • hsSndPortID_InHostHeadsetMic : HsSoundLibCommon.h
  • hsSndPortID_InHostPhone : HsSoundLibCommon.h
  • hsSndPortID_InHostPlay : HsSoundLibCommon.h
  • hsSndPortID_InLineRec : HsSoundLibCommon.h
  • hsSndPortID_InMicAuto : HsSoundLibCommon.h
  • hsSndPortID_InRadioSpkr : HsSoundLibCommon.h
  • hsSndPortID_LastPort : HsSoundLibCommon.h
  • hsSndPortID_Off : HsSoundLibCommon.h
  • hsSndPortID_OutBtHandsfree : HsSoundLibCommon.h
  • hsSndPortID_OutBtHeadset : HsSoundLibCommon.h
  • hsSndPortID_OutCarkit : HsSoundLibCommon.h
  • hsSndPortID_OutHeadphones : HsSoundLibCommon.h
  • hsSndPortID_OutHeadset : HsSoundLibCommon.h
  • hsSndPortID_OutHostRec : HsSoundLibCommon.h
  • hsSndPortID_OutRadioMic : HsSoundLibCommon.h
  • hsSndPortID_OutReceiver : HsSoundLibCommon.h
  • hsSndPortID_OutSpeaker : HsSoundLibCommon.h
  • hsSndPortID_OutSpeakerAuto : HsSoundLibCommon.h
  • HsSndPortSetParam() : HsSoundLib.h
  • hsSndRadioInServiceArea : HsSoundLibCommon.h
  • hsSndRadioOff : HsSoundLibCommon.h
  • hsSndRadioOn : HsSoundLibCommon.h
  • hsSndRadioOutServiceArea : HsSoundLibCommon.h
  • hsSndRsrcAudioTableID : HsSoundLibCommon.h
  • hsSndRsrcAudioTableType : HsSoundLibCommon.h
  • HsSndSetUserVolume() : HsSoundLib.h
  • HsSndSwitchGetPort() : HsSoundLib.h
  • HsSndSwitchID : HsSoundLibCommon.h
  • hsSndSwitchID_InHostPlay : HsSoundLibCommon.h
  • hsSndSwitchID_InMic : HsSoundLibCommon.h
  • hsSndSwitchID_InRadioSpkr : HsSoundLibCommon.h
  • hsSndSwitchID_OutHostRec : HsSoundLibCommon.h
  • hsSndSwitchID_OutRadioMic : HsSoundLibCommon.h
  • hsSndSwitchID_RadioCall : HsSoundLibCommon.h
  • HsSndSwitchSetPort() : HsSoundLib.h
  • hsSndSyncStart : HsSoundLibCommon.h
  • hsSndSyncStop : HsSoundLibCommon.h
  • hsSndSysBeepTag : HsSoundLibCommon.h
  • hsSndSysBeepType : HsSoundLibCommon.h
  • HsSndTonePlay() : HsSoundLib.h
  • HsSndToneStop() : HsSoundLib.h
  • hsSndToneType_Square : HsSoundLibCommon.h
  • hsSoundLibCreatorID : HsSoundLibCommon.h
  • hsSoundLibName : HsSoundLibCommon.h
  • hsSoundLibTypeID : HsSoundLibCommon.h
  • HsSpringboardNotSupported() : HsExt.h
  • hsStatusGadgetBattery : HsExtCommon.h
  • hsStatusGadgetSignal : HsExtCommon.h
  • HsStatusGadgetTypeEnum : HsExtCommon.h
  • HsStatusSetGadgetType() : HsExt.h
  • HsStatusUpdateGadgets() : HsExt.h
  • HsTurnRadioOn() : HsExt.h
  • HsTwoFontSelect() : HsExt.h
  • HsTxtIsAscii() : HsExt.h
  • HsTxtNumChars() : HsExt.h
  • HsTxtPrepFindString() : HsExt.h
  • HsTxtTruncateString() : HsExt.h
  • HsUtilBbutHitBigButton() : HsExtUtilBigButton.h
  • HsUtilBbutInstallFromResource() : HsExtUtilBigButton.h
  • HsUtilBbutInstallNewButton() : HsExtUtilBigButton.h
  • HsUtilBbutSetBitmap() : HsExtUtilBigButton.h
  • HsUtilBbutSetLabel() : HsExtUtilBigButton.h
  • hsVerStrCarrierID : HsExtCommon.h
  • hsVerStrComplete : HsExtCommon.h
  • HsVerStrEnum : HsExtCommon.h
  • hsVerStrFirmwareVer : HsExtCommon.h
  • hsVerStrHardware : HsExtCommon.h
  • hsVerStrLifeTime : HsExtCommon.h
  • hsVerStrPalmOSVer : HsExtCommon.h
  • hsVerStrProductName : HsExtCommon.h
  • hsVerStrProductRev : HsExtCommon.h
  • hsVerStrROMBuild : HsExtCommon.h
  • hsVerStrSerialNo : HsExtCommon.h
  • hsWordCorrectMaxWordLen : HsExtCommon.h
  • HtmlLibAbortRenderData() : HtmlLib68K.h
  • HtmlLibAddImageData() : HtmlLib68K.h
  • HtmlLibAddTextData() : HtmlLib68K.h
  • HtmlLibCanScroll() : HtmlLib68K.h
  • HtmlLibClearScreen() : HtmlLib68K.h
  • HtmlLibClose() : HtmlLib68K.h
  • HtmlLibCreateContentObject() : HtmlLib68K.h
  • HtmlLibDestroyContentObject() : HtmlLib68K.h
  • HtmlLibFinalize() : HtmlLib68K.h
  • HtmlLibFindText() : HtmlLib68K.h
  • HtmlLibGetTextSelection() : HtmlLib68K.h
  • HtmlLibGetVScrollPosition() : HtmlLib68K.h
  • HtmlLibInclusionCallback : HtmlLib68K.h
  • HtmlLibInitialize() : HtmlLib68K.h
  • HtmlLibLinkSelCallback : HtmlLib68K.h
  • HtmlLibNotifyUIEvent() : HtmlLib68K.h
  • HtmlLibOpen() : HtmlLib68K.h
  • HtmlLibProgress() : HtmlLib68K.h
  • htmlLibProgressEvent : HtmlLib68K.h
  • HtmlLibRedrawScreen() : HtmlLib68K.h
  • HtmlLibRenderData() : HtmlLib68K.h
  • HtmlLibResizeScreen() : HtmlLib68K.h
  • HtmlLibScanPhoneNumberCallback : HtmlLib68K.h
  • HtmlLibSetBiggerFont() : HtmlLib68K.h
  • HtmlLibSetDisplayMode() : HtmlLib68K.h
  • HtmlLibSetFormWidgetProc() : HtmlLib68K.h
  • HtmlLibSetInclusionCallback() : HtmlLib68K.h
  • HtmlLibSetLinkSelectionCallback() : HtmlLib68K.h
  • HtmlLibSetScanPhoneNumberCallback() : HtmlLib68K.h
  • HtmlLibSetScrollbarMode() : HtmlLib68K.h
  • HtmlLibSetScrollbars() : HtmlLib68K.h
  • HtmlLibSetSubmitFormCallback() : HtmlLib68K.h
  • HtmlLibSetVScrollPosition() : HtmlLib68K.h
  • HtmlLibSleep() : HtmlLib68K.h
  • HtmlLibSubmitFormCallback : HtmlLib68K.h
  • HtmlLibWake() : HtmlLib68K.h
  • httpCookie_ : HS_HTTPLibConst.h
  • httpError_ : HS_HTTPLibConst.h
  • httpErrorReqBodySizeOver : HS_HTTPLibConst.h
  • httpErrorReqHeaderSizeOver : HS_HTTPLibConst.h
  • httpHeaderType_ : HS_HTTPLibConst.h
  • httpMethod_ : HS_HTTPLibConst.h
  • httpScheme_ : HS_HTTPLibConst.h
  • httpSSLFlagConnTLS : HS_HTTPLibConst.h
  • httpSSLFlagConnV2 : HS_HTTPLibConst.h
  • httpSSLFlagConnV2TLS : HS_HTTPLibConst.h
  • httpSSLFlagConnV2V3 : HS_HTTPLibConst.h
  • httpSSLFlagConnV2V3TLS : HS_HTTPLibConst.h
  • httpSSLFlagConnV3 : HS_HTTPLibConst.h
  • httpSSLFlagConnV3TLS : HS_HTTPLibConst.h
  • httpStatusCode_ : HS_HTTPLibConst.h
  • httpStreamState_ : HS_HTTPLibConst.h
  • httpVersion_ : HS_HTTPLibConst.h
  • HWUBlinkLED() : HardwareUtils68K.h
  • HWUClose() : HardwareUtils68K.h
  • HWUEnableDisplay() : HardwareUtils68K.h
  • HWUGetDisplayState() : HardwareUtils68K.h
  • HWUOpen() : HardwareUtils68K.h
  • HWUSetBlinkRate() : HardwareUtils68K.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- i -

  • IBG_ERRNOTPOSSIBLE : PalmBGService.h
  • IBG_ERRREQUEST : PalmBGService.h
  • IBG_ERRRQSTDONE : PalmBGService.h
  • IBG_ERRRSPTOOBIG : PalmBGService.h
  • IBG_ERRSHUTDOWN : PalmBGService.h
  • IBG_ERRTIMEOUT : PalmBGService.h
  • IBG_MAXBUFSZ : PalmBGService.h
  • IBG_SUCCESS : PalmBGService.h
  • ImageIteratorHandle : ImageLibCommon.h
  • ImageLibBitmapDelete() : ImageLib.h
  • ImageLibCameraExists() : ImageLib.h
  • ImageLibCheckLockedImages() : ImageLib.h
  • ImageLibClose() : ImageLib.h
  • ImageLibCopyImage() : ImageLib.h
  • ImageLibCopyImageFromVFS() : ImageLib.h
  • ImageLibCopyImageToBuffer() : ImageLib.h
  • ImageLibCopyImageToFile() : ImageLib.h
  • ImageLibCopyImageToVFS() : ImageLib.h
  • ImageLibCreatorID : ImageLibCommon.h
  • ImageLibDeleteImage() : ImageLib.h
  • ImageLibDoAttachImageDialog() : ImageLib.h
  • ImageLibDrawJPEG() : ImageLib.h
  • ImageLibFindImageByID() : ImageLib.h
  • ImageLibGetAveragePictureSize() : ImageLib.h
  • ImageLibGetDimensions() : ImageLib.h
  • ImageLibGetDimensionsJPEG() : ImageLib.h
  • ImageLibGetDimensionsVFS() : ImageLib.h
  • ImageLibGetImageDatabases() : ImageLib.h
  • ImageLibGetImageID() : ImageLib.h
  • ImageLibGetImageInfo() : ImageLib.h
  • ImageLibGetJPEGQuality() : ImageLib.h
  • ImageLibGetVersion() : ImageLib.h
  • ImageLibImageBitmapCreate() : ImageLib.h
  • ImageLibImageBitmapCreateFromVFS() : ImageLib.h
  • ImageLibImageBitmapFill() : ImageLib.h
  • ImageLibImageBitmapFillFromVFS() : ImageLib.h
  • ImageLibImageCapture() : ImageLib.h
  • ImageLibImageDraw() : ImageLib.h
  • ImageLibImageDrawFromVFS() : ImageLib.h
  • ImageLibImageSave() : ImageLib.h
  • ImageLibInsertImageFromBuffer() : ImageLib.h
  • ImageLibInsertImageFromFile() : ImageLib.h
  • ImageLibIterateImages() : ImageLib.h
  • ImageLibIterateVFSImages() : ImageLib.h
  • ImageLibIterDeleteImage() : ImageLib.h
  • ImageLibIterDrawImage() : ImageLib.h
  • ImageLibIterDrawThumbnail() : ImageLib.h
  • ImageLibIterFree() : ImageLib.h
  • ImagelibIterGetCount() : ImageLib.h
  • ImageLibIterGetDimensions() : ImageLib.h
  • ImageLibIterGetImageInfo() : ImageLib.h
  • ImageLibIterRefresh() : ImageLib.h
  • ImageLibIterRemoveImage() : ImageLib.h
  • ImageLibIterResize() : ImageLib.h
  • ImageLibIterSearch() : ImageLib.h
  • ImageLibIterSort() : ImageLib.h
  • ImageLibLockImage() : ImageLib.h
  • ImageLibName : ImageLibCommon.h
  • ImageLibOpen() : ImageLib.h
  • ImageLibPreviewBitmapCreate() : ImageLib.h
  • ImageLibPreviewBitmapFill() : ImageLib.h
  • ImageLibPreviewDraw() : ImageLib.h
  • ImageLibPreviewStart() : ImageLib.h
  • ImageLibPreviewStop() : ImageLib.h
  • ImageLibProgressCallbackType : ImageLibCommon.h
  • ImageLibResize() : ImageLib.h
  • ImageLibResizeImage() : ImageLib.h
  • ImageLibResizeJPEG() : ImageLib.h
  • ImageLibResizeVFS() : ImageLib.h
  • ImageLibSetImageID() : ImageLib.h
  • ImageLibSetImageInfo() : ImageLib.h
  • ImageLibSetJPEGQuality() : ImageLib.h
  • ImageLibSetProgressCallback() : ImageLib.h
  • ImageLibThumbnailBitmapCreate() : ImageLib.h
  • ImageLibThumbnailBitmapCreateFromVFS() : ImageLib.h
  • ImageLibThumbnailBitmapFill() : ImageLib.h
  • ImageLibThumbnailBitmapFillFromVFS() : ImageLib.h
  • ImageLibThumbnailDraw() : ImageLib.h
  • ImageLibThumbnailDrawFromVFS() : ImageLib.h
  • ImageLibTurnCameraOff() : ImageLib.h
  • ImageLibTypeID : ImageLibCommon.h
  • immediateLockMode : HsPhoneTypes.h
  • indicationAuthFailure : HsPhoneEvent.h
  • indicationInitComplete : HsPhoneEvent.h
  • indicationNetworkSearch : HsPhoneEvent.h
  • indicationOtaspMsg : HsPhoneEvent.h
  • indicationPoweringOffRadio : HsPhoneEvent.h
  • indicationResettingRadio : HsPhoneEvent.h
  • indicationSIMChanged : HsPhoneEvent.h
  • indicationStartingRadio : HsPhoneEvent.h
  • indicatorBlockedCallerIDChar : HsPhoneCDMATypes.h
  • indicatorNoCallerIDChar : HsPhoneCDMATypes.h
  • indicatorRemainingCallerIDChar : HsPhoneCDMATypes.h
  • InitFontUI() : palmOneVMFontLib.h
  • INVALID_INDEX : PalmNetServices.h
  • IOTAHeaderEscapeSeq : HsPhoneIOTATypes.h
  • IOTANotificationEventType : HsPhoneIOTATypes.h
  • IOTATextHeader : HsPhoneIOTATypes.h
  • IOTATextHeaderLength : HsPhoneIOTATypes.h
  • IOTATextHeaderTerminator : HsPhoneIOTATypes.h
  • IPAllocType : PalmWiFiCommon.h
  • irFtrLowBatteryLevel : palmOneFeatures.h
  • irFtrVersionNumber : palmOneFeatures.h
  • isValidPhnConnectStateType : HsPhoneCallControlTypes.h
  • isValidPhnIOTAStatus : HsPhoneIOTA.h
  • isValidPhnPasswordType : HsPhoneSecurityTypes.h
  • italic : VMFontLibCommon.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- p -

  • palm : VMFontLibCommon.h
  • PALM_OS_20_VERSION : PalmWiFiCommon.h
  • PALM_PHOTO_ALBUM_ALL : palmOnePhotoCommon.h
  • PALM_PHOTO_ALBUM_ALL_HANDHELD : palmOnePhotoCommon.h
  • PALM_PHOTO_ALBUM_ALL_VFS : palmOnePhotoCommon.h
  • PALM_PHOTO_ALBUM_MAX_NAME : palmOnePhotoCommon.h
  • PALM_PHOTO_MAX_PATH : palmOnePhotoCommon.h
  • PALM_PHOTO_SELECT_ALL : palmOnePhotoCommon.h
  • PalmAACProfileType : palmOneCodecFormat.h
  • PalmAMRDtxMode : palmOneCodecFormat.h
  • PalmAMRMode : palmOneCodecFormat.h
  • PalmAudioChannelType : palmOneCodecFormat.h
  • PalmAudioPlaybackActionCodeType : PalmAudioPlayback.h
  • PalmAudioPlaybackNotifyEventType : PalmAudioPlayback.h
  • PalmAudioPlaybackRequestResume : PalmAudioPlayback.h
  • PalmAudioPlaybackRequestStop : PalmAudioPlayback.h
  • PalmAudioPlaybackSendRequest : PalmAudioPlayback.h
  • PalmBasicType : palmOneCodecFormat.h
  • PalmBMPCompressionType : palmOneCodecFormat.h
  • palmCodecAAC_ADIF : palmOneCodecFormat.h
  • palmCodecAAC_ADTS : palmOneCodecFormat.h
  • palmCodecAAC_LATM : palmOneCodecFormat.h
  • palmCodecAAC_MP4A : palmOneCodecFormat.h
  • palmCodecAAC_RAW : palmOneCodecFormat.h
  • palmCodecAACLowComplexity : palmOneCodecFormat.h
  • palmCodecAACMainProfile : palmOneCodecFormat.h
  • palmCodecAACScaleableSamplingRate : palmOneCodecFormat.h
  • palmCodecAMR102 : palmOneCodecFormat.h
  • palmCodecAMR122 : palmOneCodecFormat.h
  • palmCodecAMR475 : palmOneCodecFormat.h
  • palmCodecAMR515 : palmOneCodecFormat.h
  • palmCodecAMR59 : palmOneCodecFormat.h
  • palmCodecAMR74 : palmOneCodecFormat.h
  • palmCodecAMR795 : palmOneCodecFormat.h
  • palmCodecAMRDtxDisable : palmOneCodecFormat.h
  • palmCodecAMRDtxEnable : palmOneCodecFormat.h
  • palmCodecAMRM67 : palmOneCodecFormat.h
  • palmCodecAudioAAC : palmOneCodecFormat.h
  • palmCodecAudioALAW : palmOneCodecFormat.h
  • palmCodecAudioAMR : palmOneCodecFormat.h
  • palmCodecAudioDVI_ADPCM : palmOneCodecFormat.h
  • palmCodecAudioG711 : palmOneCodecFormat.h
  • palmCodecAudioG722 : palmOneCodecFormat.h
  • palmCodecAudioG726 : palmOneCodecFormat.h
  • palmCodecAudioG728 : palmOneCodecFormat.h
  • palmCodecAudioIMA_ADPCM : palmOneCodecFormat.h
  • palmCodecAudioMP1 : palmOneCodecFormat.h
  • palmCodecAudioMP2 : palmOneCodecFormat.h
  • palmCodecAudioMP3 : palmOneCodecFormat.h
  • palmCodecAudioPCM : palmOneCodecFormat.h
  • palmCodecAudioQCELP : palmOneCodecFormat.h
  • palmCodecAudioULAW : palmOneCodecFormat.h
  • palmCodecAudioVORBIS : palmOneCodecFormat.h
  • palmCodecBIG_ENDIAN : palmOneCodecFormat.h
  • palmCodecBMP_None : palmOneCodecFormat.h
  • palmCodecBMP_RLE4 : palmOneCodecFormat.h
  • palmCodecBMP_RLE8 : palmOneCodecFormat.h
  • PalmCodecControlType : palmOneCodecFormat.h
  • palmCodecCtlAACGetInfo : palmOneCodecFormat.h
  • palmCodecCtlAVCGetDecodedFrame : palmOneCodecFormat.h
  • palmCodecCtlAVCGetInfo : palmOneCodecFormat.h
  • palmCodecCtlAVCSetCropMode : palmOneCodecFormat.h
  • palmCodecCtlCustomBase : palmOneCodecFormat.h
  • palmCodecCtlGetAuthor : palmOneCodecFormat.h
  • palmCodecCtlGetComments : palmOneCodecFormat.h
  • palmCodecCtlGetDate : palmOneCodecFormat.h
  • palmCodecCtlGetKey : palmOneCodecFormat.h
  • palmCodecCtlGetVersion : palmOneCodecFormat.h
  • palmCodecCtlLastBuffer : palmOneCodecFormat.h
  • palmCodecCtlPutKey : palmOneCodecFormat.h
  • palmCodecCtlPutSeed : palmOneCodecFormat.h
  • palmCodecFloatBig : palmOneCodecFormat.h
  • palmCodecFloatLittle : palmOneCodecFormat.h
  • PalmCodecFormat : palmOneCodecPluginMgrCommon.h
  • palmCodecImageARGB32 : palmOneCodecFormat.h
  • palmCodecImageBase : palmOneCodecFormat.h
  • palmCodecImageBGR32 : palmOneCodecFormat.h
  • palmCodecImageBGR555 : palmOneCodecFormat.h
  • palmCodecImageBGR565 : palmOneCodecFormat.h
  • palmCodecImageBGR888 : palmOneCodecFormat.h
  • palmCodecImageBGRA32 : palmOneCodecFormat.h
  • palmCodecImageCMY : palmOneCodecFormat.h
  • palmCodecImageCMYK : palmOneCodecFormat.h
  • palmCodecImageGIF87a : palmOneCodecFormat.h
  • palmCodecImageGIF87aFile : palmOneCodecFormat.h
  • palmCodecImageGIF89a : palmOneCodecFormat.h
  • palmCodecImageGIF89aFile : palmOneCodecFormat.h
  • palmCodecImageGIFFrame : palmOneCodecFormat.h
  • palmCodecImageGRAY1 : palmOneCodecFormat.h
  • palmCodecImageGRAY2 : palmOneCodecFormat.h
  • palmCodecImageGRAY4 : palmOneCodecFormat.h
  • palmCodecImageGRAY8 : palmOneCodecFormat.h
  • palmCodecImageHCI : palmOneCodecFormat.h
  • palmCodecImageHSI : palmOneCodecFormat.h
  • palmCodecImageHSL : palmOneCodecFormat.h
  • palmCodecImageHSV : palmOneCodecFormat.h
  • palmCodecImageJPEG : palmOneCodecFormat.h
  • palmCodecImageJPEGFile : palmOneCodecFormat.h
  • palmCodecImagePNG : palmOneCodecFormat.h
  • palmCodecImagePNGFile : palmOneCodecFormat.h
  • palmCodecImageRGB32 : palmOneCodecFormat.h
  • palmCodecImageRGB555 : palmOneCodecFormat.h
  • palmCodecImageRGB565 : palmOneCodecFormat.h
  • palmCodecImageRGB888 : palmOneCodecFormat.h
  • palmCodecImageRGB888Planar : palmOneCodecFormat.h
  • palmCodecImageRGBA32 : palmOneCodecFormat.h
  • palmCodecImageRGBIndex : palmOneCodecFormat.h
  • palmCodecImageRGBIndex1 : palmOneCodecFormat.h
  • palmCodecImageRGBIndex16 : palmOneCodecFormat.h
  • palmCodecImageRGBIndex2 : palmOneCodecFormat.h
  • palmCodecImageRGBIndex4 : palmOneCodecFormat.h
  • palmCodecImageRGBIndex8 : palmOneCodecFormat.h
  • palmCodecImageTIFF : palmOneCodecFormat.h
  • palmCodecImageTIFFFile : palmOneCodecFormat.h
  • palmCodecImageWBMP : palmOneCodecFormat.h
  • palmCodecImageWBMPFile : palmOneCodecFormat.h
  • palmCodecImageYCbCr211 : palmOneCodecFormat.h
  • palmCodecImageYCbCr211Planar : palmOneCodecFormat.h
  • palmCodecImageYCbCr411 : palmOneCodecFormat.h
  • palmCodecImageYCbCr411Planar : palmOneCodecFormat.h
  • palmCodecImageYCbCr420 : palmOneCodecFormat.h
  • palmCodecImageYCbCr420Planar : palmOneCodecFormat.h
  • palmCodecImageYCbCr422 : palmOneCodecFormat.h
  • palmCodecImageYCbCr422Planar : palmOneCodecFormat.h
  • palmCodecImageYCbCr444 : palmOneCodecFormat.h
  • palmCodecImageYCbCr444Planar : palmOneCodecFormat.h
  • palmCodecImageYUV211 : palmOneCodecFormat.h
  • palmCodecImageYUV211Planar : palmOneCodecFormat.h
  • palmCodecImageYUV411 : palmOneCodecFormat.h
  • palmCodecImageYUV411Planar : palmOneCodecFormat.h
  • palmCodecImageYUV420 : palmOneCodecFormat.h
  • palmCodecImageYUV420Planar : palmOneCodecFormat.h
  • palmCodecImageYUV422 : palmOneCodecFormat.h
  • palmCodecImageYUV422Planar : palmOneCodecFormat.h
  • palmCodecImageYUV444 : palmOneCodecFormat.h
  • palmCodecImageYUV444Planar : palmOneCodecFormat.h
  • palmCodecINT16Big : palmOneCodecFormat.h
  • palmCodecINT16Little : palmOneCodecFormat.h
  • palmCodecINT24 : palmOneCodecFormat.h
  • palmCodecINT32Big : palmOneCodecFormat.h
  • palmCodecINT32Little : palmOneCodecFormat.h
  • palmCodecINT8 : palmOneCodecFormat.h
  • palmCodecInvalidSession : palmOneCodecPluginMgrCommon.h
  • palmCodecIteratorStart : palmOneCodecPluginMgrCommon.h
  • palmCodecIteratorStop : palmOneCodecPluginMgrCommon.h
  • palmCodecLITTLE_ENDIAN : palmOneCodecFormat.h
  • palmCodecMONO : palmOneCodecFormat.h
  • palmCodecMPEG4MVFAST : palmOneCodecFormat.h
  • palmCodecMPEG4SEA : palmOneCodecFormat.h
  • palmCodecNullID : palmOneCodecPluginMgrCommon.h
  • palmCodecQCELPEighth : palmOneCodecFormat.h
  • palmCodecQCELPFull : palmOneCodecFormat.h
  • palmCodecQCELPHalf : palmOneCodecFormat.h
  • palmCodecQCELPQuarter : palmOneCodecFormat.h
  • palmCodecQCELPReducedDisabled : palmOneCodecFormat.h
  • palmCodecQCELPReducedEnabled : palmOneCodecFormat.h
  • palmCodecQCELPSilent : palmOneCodecFormat.h
  • PalmCodecSession : palmOneCodecPluginMgrCommon.h
  • palmCodecSTEREO : palmOneCodecFormat.h
  • palmCodecStreamFile : palmOneCodecFormat.h
  • palmCodecText3G : palmOneCodecFormat.h
  • palmCodecUINT16Big : palmOneCodecFormat.h
  • palmCodecUINT16Little : palmOneCodecFormat.h
  • palmCodecUINT24 : palmOneCodecFormat.h
  • palmCodecUINT32Big : palmOneCodecFormat.h
  • palmCodecUINT32Little : palmOneCodecFormat.h
  • palmCodecUINT8 : palmOneCodecFormat.h
  • palmCodecVFSFile : palmOneCodecFormat.h
  • palmCodecVideoAVC : palmOneCodecFormat.h
  • palmCodecVideoDIVX : palmOneCodecFormat.h
  • palmCodecVideoH263 : palmOneCodecFormat.h
  • palmCodecVideoMJPEG : palmOneCodecFormat.h
  • palmCodecVideoMPEG1 : palmOneCodecFormat.h
  • palmCodecVideoMPEG2 : palmOneCodecFormat.h
  • palmCodecVideoMPEG4 : palmOneCodecFormat.h
  • palmCodecVideoXVID : palmOneCodecFormat.h
  • PalmEndianType : palmOneCodecFormat.h
  • PalmFileType : palmOneCodecFormat.h
  • PalmLedClose() : PalmLED.h
  • PalmLedOpen() : PalmLED.h
  • PalmLedSleep() : PalmLED.h
  • PalmLedWake() : PalmLED.h
  • PalmMPEG4Algorithm : palmOneCodecFormat.h
  • PalmOneStatAttrType : palmOneStatusBar.h
  • PalmOneStatAttrTypeTag : palmOneStatusBar.h
  • palmOneStatusBarAttrBarVisible : palmOneStatusBar.h
  • palmOneStatusBarAttrDimension : palmOneStatusBar.h
  • palmOneStatusBarAttrExists : palmOneStatusBar.h
  • palmOneStatusBarFtrNumVersion : palmOneStatusBar.h
  • PalmOneStatusBarGetAttribute() : palmOneStatusBar.h
  • PalmOneStatusBarHide() : palmOneStatusBar.h
  • PalmOneStatusBarLibClose() : palmOneStatusBar.h
  • palmOneStatusBarLibCreator : palmOneStatusBar.h
  • palmOneStatusBarLibName : palmOneStatusBar.h
  • PalmOneStatusBarLibOpen() : palmOneStatusBar.h
  • palmOneStatusBarLibType : palmOneStatusBar.h
  • PalmOneStatusBarShow() : palmOneStatusBar.h
  • PalmPhotoAddImage() : palmOnePhoto.h
  • PalmPhotoAddImageV2() : palmOnePhoto.h
  • PalmPhotoAlbumCount() : palmOnePhoto.h
  • PalmPhotoAlbumCountV2() : palmOnePhoto.h
  • palmPhotoASFM43FileFormat : palmOnePhotoCommon.h
  • palmPhotoASFM4AFileFormat : palmOnePhotoCommon.h
  • palmPhotoAVIM43FileFormat : palmOnePhotoCommon.h
  • palmPhotoAVIM4AFileFormat : palmOnePhotoCommon.h
  • palmPhotoBMPFileFormat : palmOnePhotoCommon.h
  • PalmPhotoCaptureCallbackV2 : palmOnePhoto.h
  • PalmPhotoCaptureImageV2() : palmOnePhoto.h
  • PalmPhotoCaptureParamV2 : palmOnePhoto.h
  • palmPhotoCaptureResCIF : palmOnePhotoCommon.h
  • palmPhotoCaptureResNone : palmOnePhotoCommon.h
  • PalmPhotoCaptureResolution : palmOnePhotoCommon.h
  • palmPhotoCaptureResOther : palmOnePhotoCommon.h
  • palmPhotoCaptureResQCIF : palmOnePhotoCommon.h
  • palmPhotoCaptureResQQVGA : palmOnePhotoCommon.h
  • palmPhotoCaptureResQVGA : palmOnePhotoCommon.h
  • palmPhotoCaptureResSUBQCIF : palmOnePhotoCommon.h
  • palmPhotoCaptureResSVGA : palmOnePhotoCommon.h
  • palmPhotoCaptureResSXGA : palmOnePhotoCommon.h
  • palmPhotoCaptureResSXGA1024 : palmOnePhotoCommon.h
  • palmPhotoCaptureResSXGA960 : palmOnePhotoCommon.h
  • palmPhotoCaptureResVGA : palmOnePhotoCommon.h
  • palmPhotoCaptureResXVGA : palmOnePhotoCommon.h
  • PalmPhotoCloseImage() : palmOnePhoto.h
  • PalmPhotoCloseImageV2() : palmOnePhoto.h
  • PalmPhotoConvertImageV2() : palmOnePhoto.h
  • PalmPhotoCreateImage() : palmOnePhoto.h
  • PalmPhotoCreateImageV2() : palmOnePhoto.h
  • PalmPhotoCreateParam : palmOnePhoto.h
  • PalmPhotoCropImageV2() : palmOnePhoto.h
  • PalmPhotoDeleteAlbum() : palmOnePhoto.h
  • PalmPhotoDeleteImage() : palmOnePhoto.h
  • PalmPhotoDisplayCallback : palmOnePhoto.h
  • PalmPhotoDisplayImage() : palmOnePhoto.h
  • PalmPhotoDisplayImageToSizeV3() : palmOnePhoto.h
  • PalmPhotoDisplayParam : palmOnePhoto.h
  • PalmPhotoDisplayThumbnailV3() : palmOnePhoto.h
  • palmPhotoDlgDeletion : palmOnePhotoCommon.h
  • palmPhotoDlgSelection : palmOnePhotoCommon.h
  • palmPhotoDlgSingleSelection : palmOnePhotoCommon.h
  • PalmPhotoDlgType : palmOnePhotoCommon.h
  • palmPhotoExtraInfoAlbum : palmOnePhotoCommon.h
  • palmPhotoExtraInfoCompositeUID : palmOnePhotoCommon.h
  • palmPhotoExtraInfoDate : palmOnePhotoCommon.h
  • palmPhotoExtraInfoImageUID : palmOnePhotoCommon.h
  • palmPhotoExtraInfoLocation : palmOnePhotoCommon.h
  • palmPhotoExtraInfoNotes : palmOnePhotoCommon.h
  • PalmPhotoExtraInfoParam : palmOnePhotoCommon.h
  • palmPhotoExtraInfoSound : palmOnePhotoCommon.h
  • palmPhotoExtraInfoSoundUID : palmOnePhotoCommon.h
  • PalmPhotoExtraInfoType : palmOnePhotoCommon.h
  • PalmPhotoFileFormat : palmOnePhotoCommon.h
  • PalmPhotoFileLocation : palmOnePhotoCommon.h
  • PalmPhotoFilterCallback : palmOnePhoto.h
  • palmPhotoFormat_3G2_QCELP_H263 : palmOnePhotoCommon.h
  • palmPhotoFormat_3G2_QCELP_MPEG4 : palmOnePhotoCommon.h
  • palmPhotoFormat_3GP_AMR_H263 : palmOnePhotoCommon.h
  • palmPhotoFormat_3GP_AMR_MPEG4 : palmOnePhotoCommon.h
  • palmPhotoFormat_ASF_ADPCM_MPEG4 : palmOnePhotoCommon.h
  • palmPhotoFormat_ASF_MP3_MPEG4 : palmOnePhotoCommon.h
  • palmPhotoFormat_AVI_ADPCM_MPEG4 : palmOnePhotoCommon.h
  • palmPhotoFormat_AVI_MP3_MPEG4 : palmOnePhotoCommon.h
  • PalmPhotoFreeSelections() : palmOnePhoto.h
  • PalmPhotoFreeSelectionsV2() : palmOnePhoto.h
  • PalmPhotoGetAlbumID() : palmOnePhoto.h
  • PalmPhotoGetAlbumIDV2() : palmOnePhoto.h
  • PalmPhotoGetAlbumName() : palmOnePhoto.h
  • PalmPhotoGetImageExtraInfo() : palmOnePhoto.h
  • PalmPhotoGetImageExtraInfoSize() : palmOnePhoto.h
  • PalmPhotoGetImageInfo() : palmOnePhoto.h
  • PalmPhotoGetLastErrV2() : palmOnePhoto.h
  • PalmPhotoGetSupportedCaptureResolutionsV3() : palmOnePhoto.h
  • PalmPhotoGetThumbSize() : palmOnePhoto.h
  • palmPhotoGIFFileFormat : palmOnePhotoCommon.h
  • PalmPhotoHandle : palmOnePhotoCommon.h
  • palmPhotoHighestQuality : palmOnePhotoCommon.h
  • palmPhotoHighQuality : palmOnePhotoCommon.h
  • PalmPhotoImageCount() : palmOnePhoto.h
  • PalmPhotoImageInfo : palmOnePhotoCommon.h
  • PalmPhotoIsCameraAvailableV3() : palmOnePhoto.h
  • palmPhotoJPEGFileFormat : palmOnePhotoCommon.h
  • PalmPhotoLibClose() : palmOnePhoto.h
  • PalmPhotoLibCreatorID : palmOnePhotoCommon.h
  • palmPhotoLibErrAbortReadWrite : palmOnePhotoCommon.h
  • palmPhotoLibErrAlbumExist : palmOnePhotoCommon.h
  • palmPhotoLibErrAlbumFull : palmOnePhotoCommon.h
  • palmPhotoLibErrAlbumNameTooLong : palmOnePhotoCommon.h
  • palmPhotoLibErrAlbumNotExist : palmOnePhotoCommon.h
  • palmPhotoLibErrAlbumReadOnly : palmOnePhotoCommon.h
  • palmPhotoLibErrFormatNotSupported : palmOnePhotoCommon.h
  • palmPhotoLibErrImageExist : palmOnePhotoCommon.h
  • palmPhotoLibErrImageInvalidPath : palmOnePhotoCommon.h
  • palmPhotoLibErrImageNotFound : palmOnePhotoCommon.h
  • palmPhotoLibErrImageNotInPhotos : palmOnePhotoCommon.h
  • palmPhotoLibErrInvalidVolume : palmOnePhotoCommon.h
  • palmPhotoLibErrLowHeap : palmOnePhotoCommon.h
  • palmPhotoLibErrLowMemory : palmOnePhotoCommon.h
  • palmPhotoLibErrLowPower : palmOnePhotoCommon.h
  • palmPhotoLibErrNoCamera : palmOnePhotoCommon.h
  • palmPhotoLibErrNoThumbnail : palmOnePhotoCommon.h
  • palmPhotoLibErrNotOpen : palmOnePhotoCommon.h
  • palmPhotoLibErrNotOpenPhotos : palmOnePhotoCommon.h
  • palmPhotoLibErrNotPhotos : palmOnePhotoCommon.h
  • palmPhotoLibErrOldVersion : palmOnePhotoCommon.h
  • palmPhotoLibErrParam : palmOnePhotoCommon.h
  • palmPhotoLibErrProtectedMedia : palmOnePhotoCommon.h
  • palmPhotoLibErrScreenDepth : palmOnePhotoCommon.h
  • palmPhotoLibErrSmallBuffer : palmOnePhotoCommon.h
  • palmPhotoLibErrStillOpen : palmOnePhotoCommon.h
  • palmPhotoLibErrUnknown : palmOnePhotoCommon.h
  • palmPhotoLibErrUnsupportedRotation : palmOnePhotoCommon.h
  • palmPhotoLibErrUserCancel : palmOnePhotoCommon.h
  • PalmPhotoLibGetVersion() : palmOnePhoto.h
  • PalmPhotoLibName : palmOnePhotoCommon.h
  • PalmPhotoLibOpen() : palmOnePhoto.h
  • PalmPhotoLibSleep() : palmOnePhoto.h
  • PalmPhotoLibTypeID : palmOnePhotoCommon.h
  • PalmPhotoLibWake() : palmOnePhoto.h
  • PalmPhotoLocationType : palmOnePhotoCommon.h
  • palmPhotoLowestQuality : palmOnePhotoCommon.h
  • palmPhotoLowQuality : palmOnePhotoCommon.h
  • PalmPhotoMediaType : palmOnePhotoCommon.h
  • palmPhotoMediaTypeAll : palmOnePhotoCommon.h
  • palmPhotoMediaTypePhoto : palmOnePhotoCommon.h
  • palmPhotoMediaTypeVideo : palmOnePhotoCommon.h
  • palmPhotoMediumQuality : palmOnePhotoCommon.h
  • palmPhotoMemoryLocation : palmOnePhotoCommon.h
  • palmPhotoMJPEGFileFormat : palmOnePhotoCommon.h
  • palmPhotoMPEG1FileFormat : palmOnePhotoCommon.h
  • palmPhotoMPEG4FileFormat : palmOnePhotoCommon.h
  • PalmPhotoNewAlbum() : palmOnePhoto.h
  • PalmPhotoNewAlbumV2() : palmOnePhoto.h
  • PalmPhotoOpenImage() : palmOnePhoto.h
  • PalmPhotoOpenImageV2() : palmOnePhoto.h
  • palmPhotoPNGFileFormat : palmOnePhotoCommon.h
  • palmPhotoPreferredImageFormat : palmOnePhotoCommon.h
  • palmPhotoPreferredVideoFormat : palmOnePhotoCommon.h
  • PalmPhotoQualityType : palmOnePhotoCommon.h
  • PalmPhotoReadImage() : palmOnePhoto.h
  • PalmPhotoReadWriteCallback : palmOnePhoto.h
  • PalmPhotoReadWriteParam : palmOnePhoto.h
  • PalmPhotoRenameAlbum() : palmOnePhoto.h
  • palmPhotoRGB565FileFormat : palmOnePhotoCommon.h
  • palmPhotoRGB888FileFormat : palmOnePhotoCommon.h
  • PalmPhotoRotateImageV2() : palmOnePhoto.h
  • PalmPhotoScaleImageV2() : palmOnePhoto.h
  • PalmPhotoSelectDlg() : palmOnePhoto.h
  • PalmPhotoSelectDlgV3() : palmOnePhoto.h
  • PalmPhotoSelectImages() : palmOnePhoto.h
  • PalmPhotoSelectionParam : palmOnePhoto.h
  • PalmPhotoSelections : palmOnePhotoCommon.h
  • PalmPhotoSetImageExtraInfo() : palmOnePhoto.h
  • palmPhotoStreamLocation : palmOnePhotoCommon.h
  • palmPhotoTIFFFileFormat : palmOnePhotoCommon.h
  • PalmPhotoUID : palmOnePhotoCommon.h
  • palmPhotoUnsupportedFormat : palmOnePhotoCommon.h
  • palmPhotoVFSLocation : palmOnePhotoCommon.h
  • palmPhotoWBMPFileFormat : palmOnePhotoCommon.h
  • PalmPhotoWriteImage() : palmOnePhoto.h
  • PalmQCELPRate : palmOneCodecFormat.h
  • PalmQCELPReducedRate : palmOneCodecFormat.h
  • PHN_SUBCOMPONENTID_LIB : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_NOT : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_RDO : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_READ : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_SIM : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_SMS : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_STK : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_WRIT : HsPhoneTrace.h
  • phnAutoMode : HsPhoneMiscTypes.h
  • PhnBarFacilityTypeEnum : HsPhoneNetworkTypes.h
  • phnCall1StatusActive : HsPhoneTypes.h
  • phnCall1StatusAlerting : HsPhoneTypes.h
  • phnCall1StatusDialing : HsPhoneTypes.h
  • phnCall1StatusIncoming : HsPhoneTypes.h
  • phnCall2StatusActive : HsPhoneTypes.h
  • phnCall2StatusAlerting : HsPhoneTypes.h
  • phnCall2StatusDialing : HsPhoneTypes.h
  • phnCall2StatusIncoming : HsPhoneTypes.h
  • PhnCallControlTypeEnum : HsPhoneNetworkTypes.h
  • phnCarKitMode : HsPhoneMiscTypes.h
  • phnCDMAFirmwareCrowdy : HsPhoneCDMATypes.h
  • PhnCLIRStatus : HsPhoneNetworkTypes.h
  • PhnConnectionEnum : HsPhoneMiscTypes.h
  • PhnConnectionID : HsPhoneTypes.h
  • phnCSDCallActive : HsPhoneTypes.h
  • PhnDatabaseID : HsPhoneTypes.h
  • PhnDataChannelType : HsPhoneEvent.h
  • phnDataNotAvailable : HsPhoneEvent.h
  • PhnEquipmentMode : HsPhoneMiscTypes.h
  • phnErrACMLimitExceeded : HsPhoneErrors.h
  • phnErrAlphabetNotSupported : HsPhoneErrors.h
  • phnErrAuthenticationFailure : HsPhoneErrors.h
  • phnErrBadATCmd : HsPhoneErrors.h
  • phnErrBadATResult : HsPhoneErrors.h
  • phnErrBadCRC : HsPhoneErrors.h
  • phnErrBadServiceCode : HsPhoneErrors.h
  • phnErrBatteryCharging : HsPhoneErrors.h
  • phnErrBatteryLowAlert : HsPhoneErrors.h
  • phnErrBufferTooSmall : HsPhoneErrors.h
  • phnErrCallBarred : HsPhoneErrors.h
  • phnErrCancelled : HsPhoneErrors.h
  • phnErrCannotReplaceMsg : HsPhoneErrors.h
  • phnErrCauseCode16 : HsPhoneErrors.h
  • phnErrCmdCannotBeActioned : HsPhoneErrors.h
  • phnErrCmdUnsupported : HsPhoneErrors.h
  • phnErrCommandInProgress : HsPhoneErrors.h
  • phnErrCongestion : HsPhoneErrors.h
  • phnErrCOPSAbort : HsPhoneErrors.h
  • phnErrCorpPINRequired : HsPhoneErrors.h
  • phnErrCorpPUKRequired : HsPhoneErrors.h
  • phnErrCPError : HsPhoneErrors.h
  • phnErrCSDAccessInfoDiscarded : HsPhoneErrors.h
  • phnErrCSDACMOutOfRange : HsPhoneErrors.h
  • phnErrCSDBearerNotAvailable : HsPhoneErrors.h
  • phnErrCSDBearerNotCapable : HsPhoneErrors.h
  • phnErrCSDBearerNotImplemented : HsPhoneErrors.h
  • phnErrCSDCallBarringIncoming : HsPhoneErrors.h
  • phnErrCSDCallBarringOutgoing : HsPhoneErrors.h
  • phnErrCSDCallImpossible : HsPhoneErrors.h
  • phnErrCSDCallOperationNotAllowed : HsPhoneErrors.h
  • phnErrCSDCallRejected : HsPhoneErrors.h
  • phnErrCSDChannelUnacceptable : HsPhoneErrors.h
  • phnErrCSDDestinationOutOfOrder : HsPhoneErrors.h
  • phnErrCSDFacilityNotImplemented : HsPhoneErrors.h
  • phnErrCSDFacilityNotSubscribed : HsPhoneErrors.h
  • phnErrCSDFacilityRejected : HsPhoneErrors.h
  • phnErrCSDFDNError : HsPhoneErrors.h
  • phnErrCSDIEError : HsPhoneErrors.h
  • phnErrCSDIncomingCallsBarredCUG : HsPhoneErrors.h
  • phnErrCSDIncompatibleDestination : HsPhoneErrors.h
  • phnErrCSDInfoNotImplemented : HsPhoneErrors.h
  • phnErrCSDInvalidMandatoryInfo : HsPhoneErrors.h
  • phnErrCSDInvalidNumberFormat : HsPhoneErrors.h
  • phnErrCSDInvalidTransID : HsPhoneErrors.h
  • phnErrCSDInvalidTransitNetwork : HsPhoneErrors.h
  • phnErrCSDLowerLayerFailure : HsPhoneErrors.h
  • phnErrCSDMessageNotCompatible : HsPhoneErrors.h
  • phnErrCSDMessageTypeNotCompatible : HsPhoneErrors.h
  • phnErrCSDMessageTypeNotImplemented : HsPhoneErrors.h
  • phnErrCSDNetworkOutOfOrder : HsPhoneErrors.h
  • phnErrCSDNoAnswer : HsPhoneErrors.h
  • phnErrCSDNoCircuitAvailable : HsPhoneErrors.h
  • phnErrCSDNoRouteToDestination : HsPhoneErrors.h
  • phnErrCSDNoUserResponse : HsPhoneErrors.h
  • phnErrCSDNumberBusy : HsPhoneErrors.h
  • phnErrCSDNumberChanged : HsPhoneErrors.h
  • phnErrCSDOperatorBarring : HsPhoneErrors.h
  • phnErrCSDProtocolError : HsPhoneErrors.h
  • phnErrCSDQOSNotAvailable : HsPhoneErrors.h
  • phnErrCSDRecoveryOnTimerExpiry : HsPhoneErrors.h
  • phnErrCSDReqCircuitNotAvailable : HsPhoneErrors.h
  • phnErrCSDResourceNotAvailable : HsPhoneErrors.h
  • phnErrCSDRestrictedBearer : HsPhoneErrors.h
  • phnErrCSDSemanticallyIncorrectMessage : HsPhoneErrors.h
  • phnErrCSDServiceNotAvailble : HsPhoneErrors.h
  • phnErrCSDServiceNotImplented : HsPhoneErrors.h
  • phnErrCSDSwitchingCongestion : HsPhoneErrors.h
  • phnErrCSDTempFailure : HsPhoneErrors.h
  • phnErrCSDUnassignedNumber : HsPhoneErrors.h
  • phnErrCSDUserNotMemberCUG : HsPhoneErrors.h
  • phnErrDenied : HsPhoneErrors.h
  • phnErrDestOutOfService : HsPhoneErrors.h
  • phnErrDestSMEBarred : HsPhoneErrors.h
  • phnErrDialStringTooLong : HsPhoneErrors.h
  • phnErrDuplicatePage : HsPhoneErrors.h
  • phnErrDuplicatePlaceHoldler : HsPhoneErrors.h
  • phnErrEmergencyCallsOnly : HsPhoneErrors.h
  • phnErrErrorInMS : HsPhoneErrors.h
  • phnErrFacRejected : HsPhoneErrors.h
  • phnErrFDNMismatch : HsPhoneErrors.h
  • phnErrFiller : HsPhoneErrors.h
  • phnErrFiller2 : HsPhoneErrors.h
  • phnErrFiller3 : HsPhoneErrors.h
  • phnErrFiller4 : HsPhoneErrors.h
  • phnErrFiller5 : HsPhoneErrors.h
  • phnErrFiller6 : HsPhoneErrors.h
  • phnErrFirmwareBootInprogress : HsPhoneErrors.h
  • phnErrFirmwareBootNotInprogress : HsPhoneErrors.h
  • phnErrGPRSAPNMissing : HsPhoneErrors.h
  • phnErrGPRSNetworkRequestDetach : HsPhoneErrors.h
  • phnErrGPRSNetworkRequestPDPDeactivate : HsPhoneErrors.h
  • phnErrGPRSNoAccess : HsPhoneErrors.h
  • phnErrGPRSNoService : HsPhoneErrors.h
  • phnErrGPRSNotAllowed : HsPhoneErrors.h
  • phnErrGPRSPDPActivateFailGMMError : HsPhoneErrors.h
  • phnErrGPRSPDPActivateFailNetReject : HsPhoneErrors.h
  • phnErrGPRSPDPActivateFailNoNSAPI : HsPhoneErrors.h
  • phnErrGPRSPDPActivateFailSMRefuse : HsPhoneErrors.h
  • phnErrGPRSPDPDactivateGMMAbort : HsPhoneErrors.h
  • phnErrGPRSPDPDactivateLCCLinkActivation : HsPhoneErrors.h
  • phnErrGPRSPDPDeactivateNwkRactivate : HsPhoneErrors.h
  • phnErrGPRSPDPDeactivateSNDCPFailure : HsPhoneErrors.h
  • phnErrGPRSRoamingNotAllowed : HsPhoneErrors.h
  • phnErrGPRSServiceRefused : HsPhoneErrors.h
  • phnErrHoldError : HsPhoneErrors.h
  • phnErrIllegalChars : HsPhoneErrors.h
  • phnErrIllegalCondition : HsPhoneErrors.h
  • phnErrIllegalFacility : HsPhoneErrors.h
  • phnErrIllegalIndex : HsPhoneErrors.h
  • phnErrIllegalME : HsPhoneErrors.h
  • phnErrIllegalMS : HsPhoneErrors.h
  • phnErrIllegalMsg : HsPhoneErrors.h
  • phnErrIllegalNumber : HsPhoneErrors.h
  • phnErrIllegalStatus : HsPhoneErrors.h
  • phnErrIllegalType : HsPhoneErrors.h
  • phnErrIncorrectPassword : HsPhoneErrors.h
  • phnErrInfoElemNonExistent : HsPhoneErrors.h
  • phnErrIntermediateResult : HsPhoneErrors.h
  • phnErrInterworking : HsPhoneErrors.h
  • phnErrInvalidDialChars : HsPhoneErrors.h
  • phnErrInvalidMandInfo : HsPhoneErrors.h
  • phnErrInvalidMemIndex : HsPhoneErrors.h
  • phnErrInvalidMobileClass : HsPhoneErrors.h
  • phnErrInvalidMsg : HsPhoneErrors.h
  • phnErrInvalidNAM : HsPhoneErrors.h
  • phnErrInvalidParameter : HsPhoneErrors.h
  • phnErrInvalidSMEAddr : HsPhoneErrors.h
  • phnErrInvalidSMSReference : HsPhoneErrors.h
  • phnErrInvalidTextChars : HsPhoneErrors.h
  • phnErrIOTACommitFailed : HsPhoneErrors.h
  • phnErrIOTACommitInProgress : HsPhoneErrors.h
  • phnErrIOTANoSession : HsPhoneErrors.h
  • phnErrIOTASessionActive : HsPhoneErrors.h
  • phnErrIS683ProtRevNotSupported : HsPhoneErrors.h
  • phnErrLAST_1 : HsPhoneErrors.h
  • phnErrLidClosed : HsPhoneErrors.h
  • phnErrLocAreaNotAllowed : HsPhoneErrors.h
  • phnErrLowerLayer : HsPhoneErrors.h
  • phnErrMEFailure : HsPhoneErrors.h
  • phnErrMemFailure : HsPhoneErrors.h
  • phnErrMemory : HsPhoneErrors.h
  • phnErrMemoryFailure : HsPhoneErrors.h
  • phnErrMemoryFull : HsPhoneErrors.h
  • phnErrMissingCarKitDriver : HsPhoneErrors.h
  • phnErrMMFailed : HsPhoneErrors.h
  • phnErrModemBusy : HsPhoneErrors.h
  • phnErrModemOffline : HsPhoneErrors.h
  • phnErrMsgClassNotSupported : HsPhoneErrors.h
  • phnErrMsgNoCompatible : HsPhoneErrors.h
  • phnErrMsgTypeNonExistent : HsPhoneErrors.h
  • phnErrNAMMismatched : HsPhoneErrors.h
  • phnErrNeedResetModule : HsPhoneErrors.h
  • phnErrNetPINRequired : HsPhoneErrors.h
  • phnErrNetPUKRequired : HsPhoneErrors.h
  • phnErrNetSubPINRequired : HsPhoneErrors.h
  • phnErrNetSubPUKRequired : HsPhoneErrors.h
  • phnErrNetworkNotAllowed : HsPhoneErrors.h
  • phnErrNetworkOutOfOrder : HsPhoneErrors.h
  • phnErrNetworkTimeout : HsPhoneErrors.h
  • phnErrNoAppRegistered : HsPhoneErrors.h
  • phnErrNoCarrier : HsPhoneErrors.h
  • phnErrNoCNMAAckExpected : HsPhoneErrors.h
  • phnErrNoConnection : HsPhoneErrors.h
  • phnErrNoNetwork : HsPhoneErrors.h
  • phnErrNoNetworkService : HsPhoneErrors.h
  • phnErrNoPower : HsPhoneErrors.h
  • phnErrNoRecipient : HsPhoneErrors.h
  • phnErrNoResponse : HsPhoneErrors.h
  • phnErrNoSCSubscription : HsPhoneErrors.h
  • phnErrNoSIM : HsPhoneErrors.h
  • phnErrNoSMSStorage : HsPhoneErrors.h
  • phnErrNotAllowed : HsPhoneErrors.h
  • phnErrNotFound : HsPhoneErrors.h
  • phnErrNotOpen : HsPhoneErrors.h
  • phnErrNotSupported : HsPhoneErrors.h
  • phnErrNotYetSupported : HsPhoneErrors.h
  • phnErrNullParam : HsPhoneErrors.h
  • phnErrNumberBlacklisted : HsPhoneErrors.h
  • phnErrNvBadItem : HsPhoneErrors.h
  • phnErrNVUnInitialized : HsPhoneErrors.h
  • phnErrOperDeterminedBarring : HsPhoneErrors.h
  • phnErrOptionNotSupported : HsPhoneErrors.h
  • phnErrOptionTempOutOfOrder : HsPhoneErrors.h
  • PHNErrorCode : HsPhoneErrors.h
  • PHNErrorCodeRange_1 : HsPhoneErrors.h
  • PHNErrorCodeRange_2 : HsPhoneErrors.h
  • phnErrParam : HsPhoneErrors.h
  • phnErrPasswordRequired : HsPhoneErrors.h
  • phnErrPhFPINRequired : HsPhoneErrors.h
  • phnErrPhFPUKRequired : HsPhoneErrors.h
  • phnErrPhoneAdaptorLinkReserved : HsPhoneErrors.h
  • phnErrPhoneFailure : HsPhoneErrors.h
  • phnErrPhoneNotConnected : HsPhoneErrors.h
  • phnErrPhPINRequired : HsPhoneErrors.h
  • phnErrPIN2Required : HsPhoneErrors.h
  • phnErrPINRequired : HsPhoneErrors.h
  • phnErrPLMNNotAllowed : HsPhoneErrors.h
  • phnErrPoweringDown : HsPhoneErrors.h
  • phnErrProtocolError : HsPhoneErrors.h
  • phnErrPUK2Required : HsPhoneErrors.h
  • phnErrPUKRequired : HsPhoneErrors.h
  • phnErrRadioNotAvailable : HsPhoneErrors.h
  • phnErrReadNV : HsPhoneErrors.h
  • phnErrReqFacNotImplemented : HsPhoneErrors.h
  • phnErrReqFacNotSubscribed : HsPhoneErrors.h
  • phnErrReqOptionNotSubscribed : HsPhoneErrors.h
  • phnErrResourcesUnavailable : HsPhoneErrors.h
  • phnErrResponsePending : HsPhoneErrors.h
  • phnErrRoamingNotAllowed : HsPhoneErrors.h
  • phnErrSATInactive : HsPhoneErrors.h
  • phnErrSATNoInd : HsPhoneErrors.h
  • phnErrSATNotSupported : HsPhoneErrors.h
  • phnErrSATUnavailable : HsPhoneErrors.h
  • phnErrSaveNV : HsPhoneErrors.h
  • phnErrSCAddrUnknown : HsPhoneErrors.h
  • phnErrSCBusy : HsPhoneErrors.h
  • phnErrSCSystemFailure : HsPhoneErrors.h
  • phnErrSIMApplToolkitBusy : HsPhoneErrors.h
  • phnErrSIMBusy : HsPhoneErrors.h
  • phnErrSIMDataDownload : HsPhoneErrors.h
  • phnErrSIMFailure : HsPhoneErrors.h
  • phnErrSIMWrong : HsPhoneErrors.h
  • phnErrSMRejectedDuplicate : HsPhoneErrors.h
  • phnErrSMSFDNError : HsPhoneErrors.h
  • phnErrSMSMemoryFull : HsPhoneErrors.h
  • phnErrSMSMemoryOK : HsPhoneErrors.h
  • phnErrSMSServReserved : HsPhoneErrors.h
  • phnErrSMSStorageFull : HsPhoneErrors.h
  • phnErrSMSXferRejected : HsPhoneErrors.h
  • phnErrSMType0NotSupported : HsPhoneErrors.h
  • phnErrSndDelClass : HsPhoneErrors.h
  • phnErrSndDelInternalMdmError : HsPhoneErrors.h
  • phnErrSndDelInvalidRingerID : HsPhoneErrors.h
  • phnErrSndDelUndeletableRingerID : HsPhoneErrors.h
  • phnErrSndDelUnusedRingerID : HsPhoneErrors.h
  • phnErrSndSaveBadDataLen : HsPhoneErrors.h
  • phnErrSndSaveBadRingerID : HsPhoneErrors.h
  • phnErrSndSaveBadRsp : HsPhoneErrors.h
  • phnErrSndSaveBadSoundType : HsPhoneErrors.h
  • phnErrSndSaveClass : HsPhoneErrors.h
  • phnErrSndSaveContBadDataLen : HsPhoneErrors.h
  • phnErrSndSaveContClass : HsPhoneErrors.h
  • phnErrSndSaveContInternalModem : HsPhoneErrors.h
  • phnErrSndSaveContOutOfMem : HsPhoneErrors.h
  • phnErrSndSaveContSeqNum : HsPhoneErrors.h
  • phnErrSndSaveFileNameInvalid : HsPhoneErrors.h
  • phnErrSndSaveInternalModem : HsPhoneErrors.h
  • phnErrSndSaveOutOfMem : HsPhoneErrors.h
  • phnErrSPPINRequired : HsPhoneErrors.h
  • phnErrSPPUKRequired : HsPhoneErrors.h
  • phnErrStillOpen : HsPhoneErrors.h
  • phnErrStringTooLong : HsPhoneErrors.h
  • phnErrTelematicIWNotSupported : HsPhoneErrors.h
  • phnErrTemporaryFailure : HsPhoneErrors.h
  • phnErrTimeout : HsPhoneErrors.h
  • phnErrTPDUNotSupported : HsPhoneErrors.h
  • phnErrTPVPFNotSupported : HsPhoneErrors.h
  • phnErrTPVPNotSupported : HsPhoneErrors.h
  • phnErrUnassignedNumber : HsPhoneErrors.h
  • phnErrUnexpectedResponse : HsPhoneErrors.h
  • phnErrUnidentifedSubscriber : HsPhoneErrors.h
  • phnErrUnknownApp : HsPhoneErrors.h
  • phnErrUnknownError : HsPhoneErrors.h
  • phnErrUnknownID : HsPhoneErrors.h
  • phnErrUnknownNumber : HsPhoneErrors.h
  • phnErrUnknownSubscriber : HsPhoneErrors.h
  • phnErrUnspecifiedGPSRError : HsPhoneErrors.h
  • phnErrUnspecifiedTPCmdError : HsPhoneErrors.h
  • phnErrUnspecifiedTPDCSError : HsPhoneErrors.h
  • phnErrUnspecifiedTPPIDError : HsPhoneErrors.h
  • phnErrUNUSED : HsPhoneErrors.h
  • PhnEventCode : HsPhoneEvent.h
  • phnEvtAlerting : HsPhoneEvent.h
  • phnEvtAlertingPreConnected : HsPhoneEvent.h
  • phnEvtBusy : HsPhoneEvent.h
  • phnEvtCardInsertion : HsPhoneEvent.h
  • phnEvtConference : HsPhoneEvent.h
  • phnEvtConnectConf : HsPhoneEvent.h
  • phnEvtConnectInd : HsPhoneEvent.h
  • phnEvtDataChannel : HsPhoneEvent.h
  • phnEvtDataSessionDisconnected : HsPhoneEvent.h
  • phnEvtDataSessionStatus : HsPhoneEvent.h
  • phnEvtDebugReport : HsPhoneEvent.h
  • phnEvtDisconnectConf : HsPhoneEvent.h
  • phnEvtDisconnectInd : HsPhoneEvent.h
  • phnEvtError : HsPhoneEvent.h
  • phnEvtGPRSRegistration : HsPhoneEvent.h
  • phnEvtIndication : HsPhoneEvent.h
  • phnEvtIOTAStatus : HsPhoneEvent.h
  • phnEvtKeyPress : HsPhoneEvent.h
  • phnEvtMemoryFull : HsPhoneEvent.h
  • phnEvtMemoryOK : HsPhoneEvent.h
  • phnEvtMessageDel : HsPhoneEvent.h
  • phnEvtMessageInd : HsPhoneEvent.h
  • phnEvtMessageMoved : HsPhoneEvent.h
  • phnEvtMessageStat : HsPhoneEvent.h
  • phnEvtMIPFailed : HsPhoneEvent.h
  • phnEvtMMSInd : HsPhoneEvent.h
  • phnEvtNetworkTime : HsPhoneEvent.h
  • phnEvtOneXDataFail : HsPhoneEvent.h
  • phnEvtOneXMipRRQInd : HsPhoneEvent.h
  • phnEvtOneXStatus : HsPhoneEvent.h
  • phnEvtPassword : HsPhoneEvent.h
  • phnEvtPDDataChanged : HsPhoneEvent.h
  • phnEvtPhoneEquipmentMode : HsPhoneEvent.h
  • phnEvtPower : HsPhoneEvent.h
  • phnEvtPreConnected : HsPhoneEvent.h
  • phnEvtProgress : HsPhoneEvent.h
  • phnEvtRegistration : HsPhoneEvent.h
  • phnEvtSATNotification : HsPhoneEvent.h
  • phnEvtSegmentInd : HsPhoneEvent.h
  • phnEvtSSModeChanged : HsPhoneEvent.h
  • phnEvtStartDial : HsPhoneEvent.h
  • phnEvtStartIncomingCall : HsPhoneEvent.h
  • phnEvtSubscriber : HsPhoneEvent.h
  • phnEvtUpdate : HsPhoneEvent.h
  • phnEvtUSSDInd : HsPhoneEvent.h
  • phnEvtVoiceMail : HsPhoneEvent.h
  • phnEvtWAPInd : HsPhoneEvent.h
  • PhnForwardModeType : HsPhoneNetworkTypes.h
  • PhnForwardType : HsPhoneNetworkTypes.h
  • phnGPRSCallActive : HsPhoneTypes.h
  • phnHandsetMode : HsPhoneMiscTypes.h
  • phnHeadsetMode : HsPhoneMiscTypes.h
  • PhnIndicationKind : HsPhoneEvent.h
  • phnInvalidEquipmentMode : HsPhoneMiscTypes.h
  • phnIOTAItemBootNAIURL : HsPhoneIOTATypes.h
  • phnIOTAItemBootURL : HsPhoneIOTATypes.h
  • phnIOTAItemConnectionTimeout : HsPhoneIOTATypes.h
  • phnIOTAItemDownloadServerLock : HsPhoneIOTATypes.h
  • phnIOTAItemDownloadServerURL : HsPhoneIOTATypes.h
  • PhnIOTAItemEnum : HsPhoneIOTATypes.h
  • phnIOTAItemHomepageURL : HsPhoneIOTATypes.h
  • phnIOTAItemLastNVItem : HsPhoneIOTATypes.h
  • phnIOTAItemPriDataExchangeURL : HsPhoneIOTATypes.h
  • phnIOTAItemPriDataGatewayURL : HsPhoneIOTATypes.h
  • phnIOTAItemPriIMMessageStore : HsPhoneIOTATypes.h
  • phnIOTAItemPriProxyWDPAddress : HsPhoneIOTATypes.h
  • phnIOTAItemPriSIPConfigServer : HsPhoneIOTATypes.h
  • phnIOTAItemPriSIPEdgeProxyGateway : HsPhoneIOTATypes.h
  • phnIOTAItemPriSIPRetryCount : HsPhoneIOTATypes.h
  • phnIOTAItemPriSIPRetryTimer : HsPhoneIOTATypes.h
  • phnIOTAItemPriWAPPushProxyGatewayURL : HsPhoneIOTATypes.h
  • phnIOTAItemPRLStorageSize : HsPhoneIOTATypes.h
  • phnIOTAItemRootCertificate1 : HsPhoneIOTATypes.h
  • phnIOTAItemRootCertificate2 : HsPhoneIOTATypes.h
  • phnIOTAItemRootCertificate3 : HsPhoneIOTATypes.h
  • phnIOTAItemRootCertificate4 : HsPhoneIOTATypes.h
  • phnIOTAItemSecDataExchangeURL : HsPhoneIOTATypes.h
  • phnIOTAItemSecDataGatewayURL : HsPhoneIOTATypes.h
  • phnIOTAItemSecIMMessageStore : HsPhoneIOTATypes.h
  • phnIOTAItemSecProxyWDPAddress : HsPhoneIOTATypes.h
  • phnIOTAItemSecSIPConfigServer : HsPhoneIOTATypes.h
  • phnIOTAItemSecSIPEdgeProxyGateway : HsPhoneIOTATypes.h
  • phnIOTAItemSecSIPRetryCount : HsPhoneIOTATypes.h
  • phnIOTAItemSecSIPRetryTimer : HsPhoneIOTATypes.h
  • phnIOTAItemSecWAPPushProxyGatewayURL : HsPhoneIOTATypes.h
  • phnIOTAItemSIPPassword : HsPhoneIOTATypes.h
  • phnIOTAItemSIPUsername : HsPhoneIOTATypes.h
  • phnIOTAItemTrustedDomain : HsPhoneIOTATypes.h
  • PhnIOTAItemType : HsPhoneIOTATypes.h
  • phnIOTAItemUnknown : HsPhoneIOTATypes.h
  • phnIOTAItemVendingURL : HsPhoneIOTATypes.h
  • PhnLibAddAddress() : HsPhoneSMS.h
  • PhnLibAddressToText() : HsPhoneSMS.h
  • PhnLibAPGetField() : HsPhoneCDMA.h
  • PhnLibAPGetNth() : HsPhoneSMS.h
  • PhnLibAttrGet() : HsPhoneMisc.h
  • PhnLibAttrSet() : HsPhoneMisc.h
  • PhnLibBoxInformation() : HsPhoneNetwork.h
  • PhnLibBoxInformationEx() : HsPhoneNetwork.h
  • PhnLibCardInfo() : HsPhoneMisc.h
  • PhnLibCardInfoEx() : HsPhoneMisc.h
  • phnLibCDMADbCreator : HsPhoneTypes.h
  • phnLibCDMAName : HsPhoneTypes.h
  • PhnLibClose() : HsPhoneLibrary.h
  • PhnLibConnectionAvailable() : HsPhoneMisc.h
  • PhnLibContinuePhonePowerOff() : HsPhonePower.h
  • PhnLibContinuePhonePowerOn() : HsPhonePower.h
  • PhnLibCount() : HsPhoneSMS.h
  • PhnLibCurrentOperator() : HsPhoneNetwork.h
  • PhnLibCurrentOperatorID() : HsPhoneNetwork.h
  • PhnLibCurrentProvider() : HsPhoneNetwork.h
  • phnLibDbType : HsPhoneTypes.h
  • PhnLibDeactivateBarring() : HsPhoneNetwork.h
  • PhnLibDeleteMessage() : HsPhoneSMS.h
  • PhnLibDisposeAddressList() : HsPhoneSMS.h
  • PhnLibEqual() : HsPhoneSMS.h
  • PhnLibErrorRate() : HsPhoneMisc.h
  • PhnLibGetAddresses() : HsPhoneSMS.h
  • PhnLibGetBarring() : HsPhoneNetwork.h
  • PhnLibGetBoxNumber() : HsPhoneNetwork.h
  • PhnLibGetCallCountByService() : HsPhoneMisc.h
  • PhnLibGetCallWaiting() : HsPhoneNetwork.h
  • PhnLibGetCLIP() : HsPhoneNetwork.h
  • PhnLibGetCLIR() : HsPhoneNetwork.h
  • PhnLibGetDataSessionInfo() : HsPhoneNetwork.h
  • PhnLibGetDate() : HsPhoneSMS.h
  • PhnLibGetDBRef() : HsPhoneSMS.h
  • PhnLibGetDeviceID() : HsPhoneMisc.h
  • PhnLibGetEchoCancellation() : HsPhoneMisc.h
  • PhnLibGetEnhancedRoamIndicator() : HsPhoneNetwork.h
  • PhnLibGetEquipmentMode() : HsPhoneMisc.h
  • PhnLibGetErrorText() : HsPhoneMisc.h
  • PhnLibGetFDNList() : HsPhoneGSM.h
  • PhnLibGetField() : HsPhoneSMS.h
  • PhnLibGetFlags() : HsPhoneSMS.h
  • PhnLibGetForwarding() : HsPhoneNetwork.h
  • PhnLibGetHeadsetConnectedInfo() : HsPhoneMisc.h
  • PhnLibGetICCID() : HsPhoneGSM.h
  • PhnLibGetID() : HsPhoneSMS.h
  • PhnLibGetLengthDetails() : HsPhoneSMS.h
  • PhnLibGetLibAPIVersion() : HsPhoneLibrary.h
  • PhnLibGetLineState() : HsPhoneMisc.h
  • PhnLibGetMicrophone() : HsPhoneMisc.h
  • PhnLibGetNoiseCancellation() : HsPhoneMisc.h
  • PhnLibGetNth() : HsPhoneSMS.h
  • PhnLibGetOperatorList() : HsPhoneNetwork.h
  • PhnLibGetOperatorLock() : HsPhoneNetwork.h
  • PhnLibGetOptions() : HsPhoneSMS.h
  • PhnLibGetOwner() : HsPhoneSMS.h
  • PhnLibGetOwnNumbers() : HsPhoneNetwork.h
  • PhnLibGetPhoneBook() : HsPhoneGSM.h
  • PhnLibGetPhoneBookIndex() : HsPhoneGSM.h
  • PhnLibGetPhoneCallStatus() : HsPhoneMisc.h
  • PhnLibGetPhoneLock() : HsPhoneSecurity.h
  • PhnLibGetRadioState() : HsPhoneMisc.h
  • PhnLibGetRoamPrefMode() : HsPhoneNetwork.h
  • PhnLibGetSDNList() : HsPhoneGSM.h
  • PhnLibGetServiceCentreAddress() : HsPhoneSMS.h
  • PhnLibGetSIMStatus() : HsPhoneGSM.h
  • PhnLibGetSMSGateway() : HsPhoneSMS.h
  • PhnLibGetSMSPreference() : HsPhoneSMS.h
  • PhnLibGetSMSRingInfo() : HsPhoneSMS.h
  • PhnLibGetSpn() : HsPhoneGSM.h
  • PhnLibGetStatus() : HsPhoneSMS.h
  • PhnLibGetSubstitution() : HsPhoneSMS.h
  • PhnLibGetText() : HsPhoneSMS.h
  • PhnLibGetType() : HsPhoneSMS.h
  • PhnLibGPRSAttached() : HsPhoneGSM.h
  • PhnLibGPRSPDPContextDefine() : HsPhoneGSM.h
  • PhnLibGPRSPDPContextListConstruct() : HsPhoneGSM.h
  • PhnLibGPRSPDPContextListDestruct() : HsPhoneGSM.h
  • PhnLibGPRSQualityOfServiceGet() : HsPhoneGSM.h
  • PhnLibGPRSQualityOfServiceSet() : HsPhoneGSM.h
  • phnLibGSMDbCreator : HsPhoneTypes.h
  • phnLibGSMDbName : HsPhoneTypes.h
  • phnLibGSMName : HsPhoneTypes.h
  • PhnLibHasName() : HsPhoneSMS.h
  • PhnLibHomeOperatorID() : HsPhoneNetwork.h
  • PhnLibIsCallMuted() : HsPhoneMisc.h
  • PhnLibIsLegalCharacter() : HsPhoneSMS.h
  • PhnLibIsPhoneActivated() : HsPhoneMisc.h
  • phnLibLaunchCmdEvent : HsPhoneEvent.h
  • phnLibLaunchCmdRegister : HsPhoneEvent.h
  • PhnLibLength() : HsPhoneSMS.h
  • PhnLibMapCharacter() : HsPhoneSMS.h
  • PhnLibMiscDebugInfo() : HsPhoneMisc.h
  • PhnLibModulePowered() : HsPhonePower.h
  • PhnLibMute() : HsPhoneMisc.h
  • PhnLibNetworkAvailable() : HsPhoneNetwork.h
  • PhnLibNewAddress() : HsPhoneSMS.h
  • PhnLibNewAddressList() : HsPhoneSMS.h
  • PhnLibNewMessage() : HsPhoneSMS.h
  • phnLibOldCDMADbCreator : HsPhoneTypes.h
  • phnLibOldCDMAName : HsPhoneTypes.h
  • PhnLibOpen() : HsPhoneLibrary.h
  • PhnLibQuerySMSMT() : HsPhoneSMS.h
  • PhnLibRegister() : HsPhoneLibrary.h
  • PhnLibRegistered() : HsPhoneNetwork.h
  • PhnLibReleaseDBRef() : HsPhoneSMS.h
  • PhnLibRoaming() : HsPhoneNetwork.h
  • PhnLibSATEndSession() : HsPhoneGSM.h
  • PhnLibSATGetMainMenu() : HsPhoneGSM.h
  • PhnLibSATSendRequest() : HsPhoneGSM.h
  • PhnLibSendLongDTMF() : HsPhoneGSM.h
  • PhnLibSendMessage() : HsPhoneSMS.h
  • PhnLibSendPendingMessages() : HsPhoneSMS.h
  • PhnLibSendSMSMTAck() : HsPhoneSMS.h
  • PhnLibSendUSSD() : HsPhoneGSM.h
  • PhnLibSetActiveLine() : HsPhoneGSM.h
  • PhnLibSetAddresses() : HsPhoneSMS.h
  • PhnLibSetBarring() : HsPhoneNetwork.h
  • PhnLibSetCallWaiting() : HsPhoneNetwork.h
  • PhnLibSetCLIP() : HsPhoneNetwork.h
  • PhnLibSetCLIR() : HsPhoneNetwork.h
  • PhnLibSetDate() : HsPhoneSMS.h
  • PhnLibSetEchoCancellation() : HsPhoneMisc.h
  • PhnLibSetEquipmentMode() : HsPhoneMisc.h
  • PhnLibSetFDNEntry() : HsPhoneGSM.h
  • PhnLibSetField() : HsPhoneSMS.h
  • PhnLibSetFlags() : HsPhoneSMS.h
  • PhnLibSetForwarding() : HsPhoneNetwork.h
  • PhnLibSetID() : HsPhoneSMS.h
  • PhnLibSetMicrophone() : HsPhoneMisc.h
  • PhnLibSetModulePower() : HsPhonePower.h
  • PhnLibSetNoiseCancellation() : HsPhoneMisc.h
  • PhnLibSetNth() : HsPhoneSMS.h
  • PhnLibSetNumber() : HsPhoneSMS.h
  • PhnLibSetOperator() : HsPhoneNetwork.h
  • PhnLibSetOptions() : HsPhoneSMS.h
  • PhnLibSetOwner() : HsPhoneSMS.h
  • PhnLibSetOwnNumbers() : HsPhoneNetwork.h
  • PhnLibSetPhoneBook() : HsPhoneGSM.h
  • PhnLibSetPhoneBookEntry() : HsPhoneGSM.h
  • PhnLibSetRoamPrefInfo() : HsPhoneNetwork.h
  • PhnLibSetRoamPrefMode() : HsPhoneNetwork.h
  • PhnLibSetServiceCentreAddress() : HsPhoneSMS.h
  • PhnLibSetSMSCallbackNumber() : HsPhoneSMS.h
  • PhnLibSetSMSPreference() : HsPhoneSMS.h
  • PhnLibSetSMSRingInfo() : HsPhoneSMS.h
  • PhnLibSetStatus() : HsPhoneSMS.h
  • PhnLibSetText() : HsPhoneSMS.h
  • PhnLibSignalQuality() : HsPhoneNetwork.h
  • PhnLibSignalQualityEx() : HsPhoneNetwork.h
  • PhnLibSIMInfo() : HsPhoneGSM.h
  • PhnLibSleep() : HsPhoneLibrary.h
  • PhnLibStartVibrate() : HsPhoneMisc.h
  • PhnLibStopVibrate() : HsPhoneMisc.h
  • PhnLibTrapActivate : HsPhoneTraps.h
  • PhnLibTrapAddAddress : HsPhoneTraps.h
  • PhnLibTrapAddressToText : HsPhoneTraps.h
  • PhnLibTrapAPGetField : HsPhoneTraps.h
  • PhnLibTrapAPGetNth : HsPhoneTraps.h
  • PhnLibTrapAPNewAddress : HsPhoneTraps.h
  • PhnLibTrapAttrGet : HsPhoneTraps.h
  • PhnLibTrapAttrSet : HsPhoneTraps.h
  • PhnLibTrapBattery : HsPhoneTraps.h
  • PhnLibTrapBatteryCharge : HsPhoneTraps.h
  • PhnLibTrapBoxInformation : HsPhoneTraps.h
  • PhnLibTrapBoxInformationEx : HsPhoneTraps.h
  • PhnLibTrapCardInfo : HsPhoneTraps.h
  • PhnLibTrapCardInfoEx : HsPhoneTraps.h
  • PhnLibTrapChangePassword : HsPhoneTraps.h
  • PhnLibTrapCloseNetIF : HsPhoneTraps.h
  • PhnLibTrapCommitIOTAParams : HsPhoneTraps.h
  • PhnLibTrapConference : HsPhoneTraps.h
  • PhnLibTrapConnectionAvailable : HsPhoneTraps.h
  • PhnLibTrapContinuePhonePowerOff : HsPhoneTraps.h
  • PhnLibTrapContinuePhonePowerOn : HsPhoneTraps.h
  • PhnLibTrapCopyPDP : HsPhoneTraps.h
  • PhnLibTrapCount : HsPhoneTraps.h
  • PhnLibTrapCRSM : HsPhoneTraps.h
  • PhnLibTrapCurrentOperator : HsPhoneTraps.h
  • PhnLibTrapCurrentOperatorID : HsPhoneTraps.h
  • PhnLibTrapCurrentProvider : HsPhoneTraps.h
  • PhnLibTrapDeactivateBarring : HsPhoneTraps.h
  • PhnLibTrapDebug : HsPhoneTraps.h
  • PhnLibTrapDebugHook : HsPhoneTraps.h
  • PhnLibTrapDecodeMMI : HsPhoneTraps.h
  • PhnLibTrapDeleteMessage : HsPhoneTraps.h
  • PhnLibTrapDeletePDP : HsPhoneTraps.h
  • PhnLibTrapDial : HsPhoneTraps.h
  • PhnLibTrapDisconnect : HsPhoneTraps.h
  • PhnLibTrapDisposeAddressList : HsPhoneTraps.h
  • PhnLibTrapEnableDM : HsPhoneTraps.h
  • PhnLibTrapEndIOTASession : HsPhoneTraps.h
  • PhnLibTrapEnhancedRoamIndicator : HsPhoneTraps.h
  • PhnLibTrapEqual : HsPhoneTraps.h
  • PhnLibTrapErrorRate : HsPhoneTraps.h
  • PhnLibTrapExecuteMMI : HsPhoneTraps.h
  • PhnLibTrapExit911Mode : HsPhoneTraps.h
  • PhnLibTrapExitPowerSaveMode : HsPhoneTraps.h
  • PhnLibTrapFindEntry : HsPhoneTraps.h
  • PhnLibTrapFirstAppForService : HsPhoneTraps.h
  • PhnLibTrapForceDataDormant : HsPhoneTraps.h
  • PhnLibTrapGetAddresses : HsPhoneTraps.h
  • PhnLibTrapGetBand : HsPhoneTraps.h
  • PhnLibTrapGetBarring : HsPhoneTraps.h
  • PhnLibTrapGetBinary : HsPhoneTraps.h
  • PhnLibTrapGetBoxNumber : HsPhoneTraps.h
  • PhnLibTrapGetCallCountByService : HsPhoneTraps.h
  • PhnLibTrapGetCallWaiting : HsPhoneTraps.h
  • PhnLibTrapGetCDMASystemInfo : HsPhoneTraps.h
  • PhnLibTrapGetCktSwitchProfile : HsPhoneTraps.h
  • PhnLibTrapGetCLIP : HsPhoneTraps.h
  • PhnLibTrapGetCLIR : HsPhoneTraps.h
  • PhnLibTrapGetConnectionInfo : HsPhoneTraps.h
  • PhnLibTrapGetCustomServiceProfile : HsPhoneTraps.h
  • PhnLibTrapGetDataApplication : HsPhoneTraps.h
  • PhnLibTrapGetDataLife : HsPhoneTraps.h
  • PhnLibTrapGetDataSessionInfo : HsPhoneTraps.h
  • PhnLibTrapGetDate : HsPhoneTraps.h
  • PhnLibTrapGetDBRef : HsPhoneTraps.h
  • PhnLibTrapGetDedicatedDataMode : HsPhoneTraps.h
  • PhnLibTrapGetDefaultDataApps : HsPhoneTraps.h
  • PhnLibTrapGetDeviceId : HsPhoneTraps.h
  • PhnLibTrapGetDialPrefix : HsPhoneTraps.h
  • PhnLibTrapGetDTMFburstMode : HsPhoneTraps.h
  • PhnLibTrapGetEchoCancellation : HsPhoneTraps.h
  • PhnLibTrapGetEquipmentMode : HsPhoneTraps.h
  • PhnLibTrapGetErrorText : HsPhoneTraps.h
  • PhnLibTrapGetFDNList : HsPhoneTraps.h
  • PhnLibTrapGetField : HsPhoneTraps.h
  • PhnLibTrapGetFlags : HsPhoneTraps.h
  • PhnLibTrapGetForwarding : HsPhoneTraps.h
  • PhnLibTrapGetGenericCDMAPreference : HsPhoneTraps.h
  • PhnLibTrapGetHeadsetConnectedInfo : HsPhoneTraps.h
  • PhnLibTrapGetHomepageFromRadio : HsPhoneTraps.h
  • PhnLibTrapGetICCID : HsPhoneTraps.h
  • PhnLibTrapGetID : HsPhoneTraps.h
  • PhnLibTrapGetIOTAStatus : HsPhoneTraps.h
  • PhnLibTrapGetLengthDetails : HsPhoneTraps.h
  • PhnLibTrapGetLibAPIVersion : HsPhoneTraps.h
  • PhnLibTrapGetLifeTimer : HsPhoneTraps.h
  • PhnLibTrapGetLineState : HsPhoneTraps.h
  • PhnLibTrapGetMdmPosition : HsPhoneTraps.h
  • PhnLibTrapGetMediaTVSettings : HsPhoneTraps.h
  • PhnLibTrapGetMicrophone : HsPhoneTraps.h
  • PhnLibTrapGetMMSServerInfo : HsPhoneTraps.h
  • PhnLibTrapGetMMSServerInfoEx : HsPhoneTraps.h
  • PhnLibTrapGetMSID : HsPhoneTraps.h
  • PhnLibTrapGetMVNOName : HsPhoneTraps.h
  • PhnLibTrapGetNAMInUse : HsPhoneTraps.h
  • PhnLibTrapGetNoiseCancellation : HsPhoneTraps.h
  • PhnLibTrapGetNth : HsPhoneTraps.h
  • PhnLibTrapGetOneXStatus : HsPhoneTraps.h
  • PhnLibTrapGetOperatorList : HsPhoneTraps.h
  • PhnLibTrapGetOperatorLock : HsPhoneTraps.h
  • PhnLibTrapGetOptions : HsPhoneTraps.h
  • PhnLibTrapGetOwner : HsPhoneTraps.h
  • PhnLibTrapGetOwnNumbers : HsPhoneTraps.h
  • PhnLibTrapGetPDP : HsPhoneTraps.h
  • PhnLibTrapGetPDPIndexRange : HsPhoneTraps.h
  • PhnLibTrapGetPDSessionConfigParam : HsPhoneTraps.h
  • PhnLibTrapGetPhnOprtMode : HsPhoneTraps.h
  • PhnLibTrapGetPhoneBook : HsPhoneTraps.h
  • PhnLibTrapGetPhoneBookIndex : HsPhoneTraps.h
  • PhnLibTrapGetPhoneCallStatus : HsPhoneTraps.h
  • PhnLibTrapGetPhoneLock : HsPhoneTraps.h
  • PhnLibTrapGetPhoneSSMode : HsPhoneTraps.h
  • PhnLibTrapGetPicturesServerInfo : HsPhoneTraps.h
  • PhnLibTrapGetPicturesToken : HsPhoneTraps.h
  • PhnLibTrapGetProxyInfo : HsPhoneTraps.h
  • PhnLibTrapGetRadioState : HsPhoneTraps.h
  • PhnLibTrapGetRemainingPasswordTries : HsPhoneTraps.h
  • PhnLibTrapGetRingingInfo : HsPhoneTraps.h
  • PhnLibTrapGetRoamPrefInfo : HsPhoneTraps.h
  • PhnLibTrapGetRoamPrefMode : HsPhoneTraps.h
  • PhnLibTrapGetSDNList : HsPhoneTraps.h
  • PhnLibTrapGetServiceCentreAddress : HsPhoneTraps.h
  • PhnLibTrapGetSIMStatus : HsPhoneTraps.h
  • PhnLibTrapGetSMSGateway : HsPhoneTraps.h
  • PhnLibTrapGetSMSPreference : HsPhoneTraps.h
  • PhnLibTrapGetSMSRingInfo : HsPhoneTraps.h
  • PhnLibTrapGetSMSSegmentInfo : HsPhoneTraps.h
  • PhnLibTrapGetSpecialNumbers : HsPhoneTraps.h
  • PhnLibTrapGetSpMode : HsPhoneTraps.h
  • PhnLibTrapGetSpn : HsPhoneTraps.h
  • PhnLibTrapGetStatus : HsPhoneTraps.h
  • PhnLibTrapGetSubstitution : HsPhoneTraps.h
  • PhnLibTrapGetSysPrefMode : HsPhoneTraps.h
  • PhnLibTrapGetText : HsPhoneTraps.h
  • PhnLibTrapGetToneIDs : HsPhoneTraps.h
  • PhnLibTrapGetToneIDsEx : HsPhoneTraps.h
  • PhnLibTrapGetToneLength : HsPhoneTraps.h
  • PhnLibTrapGetToneName : HsPhoneTraps.h
  • PhnLibTrapGetTotalDataRxBytes : HsPhoneTraps.h
  • PhnLibTrapGetTotalDataTxBytes : HsPhoneTraps.h
  • PhnLibTrapGetTotalPDPs : HsPhoneTraps.h
  • PhnLibTrapGetTTYSetting : HsPhoneTraps.h
  • PhnLibTrapGetType : HsPhoneTraps.h
  • PhnLibTrapGetVoicePrivacyMode : HsPhoneTraps.h
  • PhnLibTrapGetVolume : HsPhoneTraps.h
  • PhnLibTrapGPRSAttached : HsPhoneTraps.h
  • PhnLibTrapGPRSAttachRequest : HsPhoneTraps.h
  • PhnLibTrapGPRSPDPContextDefine : HsPhoneTraps.h
  • PhnLibTrapGPRSPDPContextListConstruct : HsPhoneTraps.h
  • PhnLibTrapGPRSPDPContextListDestruct : HsPhoneTraps.h
  • PhnLibTrapGPRSQualityOfServiceGet : HsPhoneTraps.h
  • PhnLibTrapGPRSQualityOfServiceSet : HsPhoneTraps.h
  • PhnLibTrapHasName : HsPhoneTraps.h
  • PhnLibTrapHold : HsPhoneTraps.h
  • PhnLibTrapHomeOperatorID : HsPhoneTraps.h
  • PhnLibTrapIsCallMuted : HsPhoneTraps.h
  • PhnLibTrapIsCarrierDefinedEmergencyNumber : HsPhoneTraps.h
  • PhnLibTrapIsEmergencyNumber : HsPhoneTraps.h
  • PhnLibTrapIsLegalCharacter : HsPhoneTraps.h
  • PhnLibTrapIsPhoneActivated : HsPhoneTraps.h
  • PhnLibTrapIsRadioGenericCDMA : HsPhoneTraps.h
  • PhnLibTrapIsSpecialNumber : HsPhoneTraps.h
  • PhnLibTrapLast : HsPhoneTraps.h
  • PhnLibTrapLedAlert : HsPhoneTraps.h
  • PhnLibTrapLength : HsPhoneTraps.h
  • PhnLibTrapListPDP : HsPhoneTraps.h
  • PhnLibTrapLoadCDMATime : HsPhoneTraps.h
  • PhnLibTrapMapCharacter : HsPhoneTraps.h
  • PhnLibTrapMiscDebugInfo : HsPhoneTraps.h
  • PhnLibTrapModemIssueResetInfo : HsPhoneTraps.h
  • PhnLibTrapModuleButtonDown : HsPhoneTraps.h
  • PhnLibTrapModulePowered : HsPhoneTraps.h
  • PhnLibTrapMute : HsPhoneTraps.h
  • PhnLibTrapNetworkAvailable : HsPhoneTraps.h
  • PhnLibTrapNewAddress : HsPhoneTraps.h
  • PhnLibTrapNewAddressList : HsPhoneTraps.h
  • PhnLibTrapNewMessage : HsPhoneTraps.h
  • PhnLibTrapNewMOMessage : HsPhoneTraps.h
  • PhnLibTrapOffHold : HsPhoneTraps.h
  • PhnLibTrapParamText : HsPhoneTraps.h
  • PhnLibTrapPasswordDialog : HsPhoneTraps.h
  • PhnLibTrapPDPLockUnlock : HsPhoneTraps.h
  • PhnLibTrapPhoneRestore : HsPhoneTraps.h
  • PhnLibTrapPlayDTMF : HsPhoneTraps.h
  • PhnLibTrapPlayTone : HsPhoneTraps.h
  • PhnLibTrapPlayToneEx : HsPhoneTraps.h
  • PhnLibTrapPowerSaveDisable : HsPhoneTraps.h
  • PhnLibTrapQuerySMSMT : HsPhoneTraps.h
  • PhnLibTrapReadIOTAItem : HsPhoneTraps.h
  • PhnLibTrapRegister : HsPhoneTraps.h
  • PhnLibTrapRegistered : HsPhoneTraps.h
  • PhnLibTrapReleaseDBRef : HsPhoneTraps.h
  • PhnLibTrapReplacePDPNAI : HsPhoneTraps.h
  • PhnLibTrapReplacePDPPassword : HsPhoneTraps.h
  • PhnLibTrapReplacePDPSvcString : HsPhoneTraps.h
  • PhnLibTrapRoaming : HsPhoneTraps.h
  • PhnLibTrapSATEndSession : HsPhoneTraps.h
  • PhnLibTrapSATGetMainMenu : HsPhoneTraps.h
  • PhnLibTrapSATSendRequest : HsPhoneTraps.h
  • PhnLibTrapSelectAddress : HsPhoneTraps.h
  • PhnLibTrapSelectNAM : HsPhoneTraps.h
  • PhnLibTrapSendDTMF : HsPhoneTraps.h
  • PhnLibTrapSendDTMFBurst : HsPhoneTraps.h
  • PhnLibTrapSendFlash : HsPhoneTraps.h
  • PhnLibTrapSendLongDTMF : HsPhoneTraps.h
  • PhnLibTrapSendMessage : HsPhoneTraps.h
  • PhnLibTrapSendPendingMessages : HsPhoneTraps.h
  • PhnLibTrapSendSilentDTMF : HsPhoneTraps.h
  • PhnLibTrapSendSMSMTAck : HsPhoneTraps.h
  • PhnLibTrapSendUSSD : HsPhoneTraps.h
  • PhnLibTrapSetActiveLine : HsPhoneTraps.h
  • PhnLibTrapSetAddresses : HsPhoneTraps.h
  • PhnLibTrapSetBand : HsPhoneTraps.h
  • PhnLibTrapSetBarring : HsPhoneTraps.h
  • PhnLibTrapSetBoxNumber : HsPhoneTraps.h
  • PhnLibTrapSetCallWaiting : HsPhoneTraps.h
  • PhnLibTrapSetCLIP : HsPhoneTraps.h
  • PhnLibTrapSetCLIR : HsPhoneTraps.h
  • PhnLibTrapSetCurrentUsageHandler : HsPhoneTraps.h
  • PhnLibTrapSetDataApplication : HsPhoneTraps.h
  • PhnLibTrapSetDate : HsPhoneTraps.h
  • PhnLibTrapSetDedicatedDataMode : HsPhoneTraps.h
  • PhnLibTrapSetDialPrefix : HsPhoneTraps.h
  • PhnLibTrapSetDTMFburstMode : HsPhoneTraps.h
  • PhnLibTrapSetEchoCancellation : HsPhoneTraps.h
  • PhnLibTrapSetEquipmentMode : HsPhoneTraps.h
  • PhnLibTrapSetFDNEntry : HsPhoneTraps.h
  • PhnLibTrapSetField : HsPhoneTraps.h
  • PhnLibTrapSetFlags : HsPhoneTraps.h
  • PhnLibTrapSetForwarding : HsPhoneTraps.h
  • PhnLibTrapSetID : HsPhoneTraps.h
  • PhnLibTrapSetMdmAutoMsgMask : HsPhoneTraps.h
  • PhnLibTrapSetMicrophone : HsPhoneTraps.h
  • PhnLibTrapSetModulePower : HsPhoneTraps.h
  • PhnLibTrapSetNoiseCancellation : HsPhoneTraps.h
  • PhnLibTrapSetNth : HsPhoneTraps.h
  • PhnLibTrapSetNumber : HsPhoneTraps.h
  • PhnLibTrapSetOperator : HsPhoneTraps.h
  • PhnLibTrapSetOperatorLock : HsPhoneTraps.h
  • PhnLibTrapSetOptions : HsPhoneTraps.h
  • PhnLibTrapSetOwner : HsPhoneTraps.h
  • PhnLibTrapSetOwnNumbers : HsPhoneTraps.h
  • PhnLibTrapSetPDP : HsPhoneTraps.h
  • PhnLibTrapSetPDSessionConfigParam : HsPhoneTraps.h
  • PhnLibTrapSetPhnOprtMode : HsPhoneTraps.h
  • PhnLibTrapSetPhoneBook : HsPhoneTraps.h
  • PhnLibTrapSetPhoneBookEntry : HsPhoneTraps.h
  • PhnLibTrapSetPhoneLock : HsPhoneTraps.h
  • PhnLibTrapSetPhoneSSMode : HsPhoneTraps.h
  • PhnLibTrapSetPicturesToken : HsPhoneTraps.h
  • PhnLibTrapSetRingingInfo : HsPhoneTraps.h
  • PhnLibTrapSetRoamPrefInfo : HsPhoneTraps.h
  • PhnLibTrapSetRoamPrefMode : HsPhoneTraps.h
  • PhnLibTrapSetServiceCentreAddress : HsPhoneTraps.h
  • PhnLibTrapSetSMSCallbackNumber : HsPhoneTraps.h
  • PhnLibTrapSetSMSPreference : HsPhoneTraps.h
  • PhnLibTrapSetSMSRingInfo : HsPhoneTraps.h
  • PhnLibTrapSetSpecialNumbers : HsPhoneTraps.h
  • PhnLibTrapSetStatus : HsPhoneTraps.h
  • PhnLibTrapSetSysPrefMode : HsPhoneTraps.h
  • PhnLibTrapSetText : HsPhoneTraps.h
  • PhnLibTrapSetToneLength : HsPhoneTraps.h
  • PhnLibTrapSetTTYSetting : HsPhoneTraps.h
  • PhnLibTrapSetupDataConfig : HsPhoneTraps.h
  • PhnLibTrapSetVoicePrivacyMode : HsPhoneTraps.h
  • PhnLibTrapSetVolume : HsPhoneTraps.h
  • PhnLibTrapSignalQuality : HsPhoneTraps.h
  • PhnLibTrapSignalQualityEx : HsPhoneTraps.h
  • PhnLibTrapSIMInfo : HsPhoneTraps.h
  • PhnLibTrapSndDelete : HsPhoneTraps.h
  • PhnLibTrapSndSave : HsPhoneTraps.h
  • PhnLibTrapStartIOTASession : HsPhoneTraps.h
  • PhnLibTrapStartVibrate : HsPhoneTraps.h
  • PhnLibTrapStopPDSession : HsPhoneTraps.h
  • PhnLibTrapStopTone : HsPhoneTraps.h
  • PhnLibTrapStopVibrate : HsPhoneTraps.h
  • PhnLibTrapTunnelIS683ReqMsg : HsPhoneTraps.h
  • PhnLibTrapUninstall : HsPhoneTraps.h
  • PhnLibTrapUnlockPhoneLock : HsPhoneTraps.h
  • PhnLibTrapUpdateCustomizedNV : HsPhoneTraps.h
  • PhnLibTrapUpdateMessageCount : HsPhoneTraps.h
  • PhnLibTrapUsableSignalStrengthThreshold : HsPhoneTraps.h
  • PhnLibTrapVerifyICDVer : HsPhoneTraps.h
  • PhnLibTrapWriteIOTAItem : HsPhoneTraps.h
  • PhnLibUninstall() : HsPhoneLibrary.h
  • PhnLibUsableSignalStrengthThreshold() : HsPhoneNetwork.h
  • PhnLibWake() : HsPhoneLibrary.h
  • PhnLockModeEnum : HsPhoneTypes.h
  • phnMaxDialStrLen : HsPhoneCDMATypes.h
  • phnMaxMNAAASharedSecretLen : HsPhoneCDMATypes.h
  • phnMaxMNHASharedSecretLen : HsPhoneCDMATypes.h
  • phnMaxMslLen : HsPhoneCDMATypes.h
  • phnMaxNAILen : HsPhoneCDMATypes.h
  • phnMaxSvcStrLen : HsPhoneCDMATypes.h
  • phnMaxUrlLen : HsPhoneCDMATypes.h
  • phnMIPSession : HsPhoneNetworkTypes.h
  • PhnMMIActionCodeEnum : HsPhoneNetworkTypes.h
  • PhnMMIServiceCodeEnum : HsPhoneNetworkTypes.h
  • PhnModuleButtonType : HsPhoneEvent.h
  • PhnMsgBoxEnum : HsPhoneNetworkTypes.h
  • PhnMsgBoxTypeMAX : HsPhoneNetworkTypes.h
  • phnNotifyEquipMode : HsPhoneEvent.h
  • phnNotifySubscriber : HsPhoneEvent.h
  • PhnOneXDataFailType : HsPhoneCDMATypes.h
  • phnOneXFailModemSORej : HsPhoneCDMATypes.h
  • phnOneXFailNetworkBusy : HsPhoneCDMATypes.h
  • phnOneXFailNetworkSORej : HsPhoneCDMATypes.h
  • phnOneXFailNoSrv : HsPhoneCDMATypes.h
  • phnOneXFailPrev : HsPhoneCDMATypes.h
  • phnOneXStatusPRev1 : HsPhoneNetworkTypes.h
  • phnOneXStatusPRev3 : HsPhoneNetworkTypes.h
  • phnOneXStatusPRev4 : HsPhoneNetworkTypes.h
  • phnOneXStatusPRev6 : HsPhoneNetworkTypes.h
  • phnOneXStatusPRev7 : HsPhoneNetworkTypes.h
  • phnOneXStatusPRevNoSvc : HsPhoneNetworkTypes.h
  • PhnOperatorStatus : HsPhoneNetworkTypes.h
  • phnOprtModeLPM : HsPhoneMiscTypes.h
  • phnOprtModeNone : HsPhoneMiscTypes.h
  • phnOprtModeOffline : HsPhoneMiscTypes.h
  • phnOprtModeOfflineA : HsPhoneMiscTypes.h
  • phnOprtModeOnline : HsPhoneMiscTypes.h
  • phnOprtModePwroff : HsPhoneMiscTypes.h
  • phnOprtModeReset : HsPhoneMiscTypes.h
  • phnPacketDataCallActive : HsPhoneTypes.h
  • phnPacketDataCallDormant : HsPhoneTypes.h
  • phnPacketDataEndStatusAuthFailed : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusDropped : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusIntercept : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusLast : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusNoReason : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusNormal : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusReject : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusReorder : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusRetry : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusTimeout : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusUnknown : HsPhoneNetworkTypes.h
  • phnPacketDataSessionActive : HsPhoneNetworkTypes.h
  • phnPacketDataSessionDormant : HsPhoneNetworkTypes.h
  • phnPacketDataSessionNone : HsPhoneNetworkTypes.h
  • phnPasswordBarrAB : HsPhoneSecurityTypes.h
  • phnPasswordBarrAC : HsPhoneSecurityTypes.h
  • phnPasswordBarrAG : HsPhoneSecurityTypes.h
  • phnPasswordBarrAI : HsPhoneSecurityTypes.h
  • phnPasswordBarrAO : HsPhoneSecurityTypes.h
  • phnPasswordBarrIR : HsPhoneSecurityTypes.h
  • phnPasswordBarrOI : HsPhoneSecurityTypes.h
  • phnPasswordBarrOX : HsPhoneSecurityTypes.h
  • phnPasswordCorporatePIN : HsPhoneSecurityTypes.h
  • phnPasswordCorporatePUK : HsPhoneSecurityTypes.h
  • phnPasswordNetworkPIN : HsPhoneSecurityTypes.h
  • phnPasswordNetworkPUK : HsPhoneSecurityTypes.h
  • phnPasswordNetworkSubsetPIN : HsPhoneSecurityTypes.h
  • phnPasswordNetworkSubsetPUK : HsPhoneSecurityTypes.h
  • phnPasswordNone : HsPhoneSecurityTypes.h
  • phnPasswordPh1SIMPIN : HsPhoneSecurityTypes.h
  • phnPasswordPh1SIMPUK : HsPhoneSecurityTypes.h
  • phnPasswordPhSIMPIN : HsPhoneSecurityTypes.h
  • phnPasswordServiceProviderPIN : HsPhoneSecurityTypes.h
  • phnPasswordServiceProviderPUK : HsPhoneSecurityTypes.h
  • phnPasswordSIMPIN : HsPhoneSecurityTypes.h
  • phnPasswordSIMPIN2 : HsPhoneSecurityTypes.h
  • phnPasswordSIMPUK : HsPhoneSecurityTypes.h
  • phnPasswordSIMPUK2 : HsPhoneSecurityTypes.h
  • PhnPasswordTypeEnum : HsPhoneSecurityTypes.h
  • phnPasswordUnknown : HsPhoneSecurityTypes.h
  • PhnPDConfigGPSLock : hsPhoneLocationTypes.h
  • PhnPDConfigIPAddr : hsPhoneLocationTypes.h
  • PhnPDConfigPortID : hsPhoneLocationTypes.h
  • PhnPDConfigPTLMMode : hsPhoneLocationTypes.h
  • PhnPDPAUncert0_5_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert0_75_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert1024_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert12288_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert128_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert12_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert1536_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert16_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert192_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert1_5_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert1_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert2048_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert24_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert256_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert2_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert3072_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert32_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert384_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert3_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert4096_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert48_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert4_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert512_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert6144_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert64_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert6_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert768_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert8192_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert8_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert96_M : HsPhoneCDMATypes.h
  • PhnPDPAUncertGREATER_12288_M : HsPhoneCDMATypes.h
  • PhnPDPAUncertNOT_COMPUTABLE_M : HsPhoneCDMATypes.h
  • PhnPDPAUncerttype : HsPhoneCDMATypes.h
  • phnPDPConnectionTypeMIP : HsPhoneCDMATypes.h
  • phnPDPConnectionTypeMIPWithSIPFallback : HsPhoneCDMATypes.h
  • phnPDPConnectionTypeSIP : HsPhoneCDMATypes.h
  • phnPDPServiceBrowser : HsPhoneCDMATypes.h
  • phnPDPServiceCorporateGateway : HsPhoneCDMATypes.h
  • phnPDPServiceDownloads : HsPhoneCDMATypes.h
  • phnPDPServiceIM : HsPhoneCDMATypes.h
  • phnPDPServiceInternet : HsPhoneCDMATypes.h
  • phnPDPServiceMail : HsPhoneCDMATypes.h
  • phnPDPServiceMMS : HsPhoneCDMATypes.h
  • phnPDPServicePictureMail : HsPhoneCDMATypes.h
  • phnPDPServicePrivate : HsPhoneCDMATypes.h
  • phnPDPServiceWAP : HsPhoneCDMATypes.h
  • phnPDPUidLen : HsPhoneCDMATypes.h
  • PhnPDSessionConfigParamType : hsPhoneLocationTypes.h
  • phnPowerSave : HsPhoneTypes.h
  • phnRoamPrefAny : HsPhoneNetworkTypes.h
  • phnRoamPrefHomeOnly : HsPhoneNetworkTypes.h
  • phnRoamPrefLast : HsPhoneNetworkTypes.h
  • phnRoamPrefRoamOnly : HsPhoneNetworkTypes.h
  • PhnRoamStatus : HsPhoneNetworkTypes.h
  • PhnRoamStatusEnhancedIndicator : HsPhoneNetworkTypes.h
  • PhnRoamStatusEnum : HsPhoneNetworkTypes.h
  • phnSATEventInputEchoModeHideInput : HsPhoneGSMTypes.h
  • phnSATEventInputEchoModeShowInput : HsPhoneGSMTypes.h
  • phnSATEventInputFormatDigit : HsPhoneGSMTypes.h
  • phnSATEventInputFormatPacked : HsPhoneGSMTypes.h
  • phnSATEventInputFormatSMSChar : HsPhoneGSMTypes.h
  • phnSATEventInputFormatUCS2 : HsPhoneGSMTypes.h
  • phnSATEventInputFormatUnknown : HsPhoneGSMTypes.h
  • phnSATEventInputFormatUnpacked : HsPhoneGSMTypes.h
  • phnSATEventInputFormatYesNo : HsPhoneGSMTypes.h
  • phnSATEventMenuFlagHelp : HsPhoneGSMTypes.h
  • phnSATEventMenuFlagNextAct : HsPhoneGSMTypes.h
  • phnSATEventSetupCallCallTypeData : HsPhoneGSMTypes.h
  • phnSATEventSetupCallCallTypeFax : HsPhoneGSMTypes.h
  • phnSATEventSetupCallCallTypeVoice : HsPhoneGSMTypes.h
  • phnSATEventToneTimeUnitDeciSeconds : HsPhoneGSMTypes.h
  • phnSATEventToneTimeUnitMinutes : HsPhoneGSMTypes.h
  • phnSATEventToneTimeUnitSeconds : HsPhoneGSMTypes.h
  • phnSATEventToneTypeNoneSpecified : HsPhoneGSMTypes.h
  • phnServiceActivation : HsPhoneTypes.h
  • phnServiceAFLT : HsPhoneTypes.h
  • phnServiceData : HsPhoneTypes.h
  • phnServiceEssentials : HsPhoneTypes.h
  • phnServiceIOTA : HsPhoneTypes.h
  • phnServiceMax : HsPhoneTypes.h
  • phnServiceMisc : HsPhoneTypes.h
  • phnServiceMMS : HsPhoneTypes.h
  • phnServiceSIMToolkit : HsPhoneTypes.h
  • phnServiceSMS : HsPhoneTypes.h
  • phnServiceVoice : HsPhoneTypes.h
  • phnServiceWAP : HsPhoneTypes.h
  • PhnSMSClass : HsPhoneEvent.h
  • PhnSMSClassEnum : HsPhoneEvent.h
  • PhnSMSType : HsPhoneEvent.h
  • PhnSMSTypeEnum : HsPhoneEvent.h
  • phnSpeakerPhoneMode : HsPhoneMiscTypes.h
  • phnTeleserviceDefault : HsPhoneNetworkTypes.h
  • PhnTeleserviceMmiCodeType : HsPhoneNetworkTypes.h
  • PhnTeleserviceType : HsPhoneNetworkTypes.h
  • phnTTYSettingAll : HsPhoneAudioTypes.h
  • phnTTYSettingHearCarryOver : HsPhoneAudioTypes.h
  • phnTTYSettingOff : HsPhoneAudioTypes.h
  • phnTTYSettingVoiceCarryOver : HsPhoneAudioTypes.h
  • phnUPEvent : HsPhoneEvent.h
  • PhnVibrateType : HsPhoneMiscTypes.h
  • phnVoiceCall1Active : HsPhoneTypes.h
  • phnVoiceCall2Active : HsPhoneTypes.h
  • phnVolumeMax : HsPhoneTypes.h
  • phnVolumeMin : HsPhoneTypes.h
  • PhnWAPPushAppIdType : HsPhoneEvent.h
  • PhnWAPPushContentType : HsPhoneEvent.h
  • phnWUEvent : HsPhoneEvent.h
  • PhoneAppDialMethodEnum : HsAppLaunchCmd.h
  • PhoneAppDialMethodNormal : HsAppLaunchCmd.h
  • PhoneAppDialMethodSATSetupCall : HsAppLaunchCmd.h
  • phoneAppLaunchCmdActivation : HsAppLaunchCmd.h
  • phoneAppLaunchCmdDial : HsAppLaunchCmd.h
  • phoneAppLaunchCmdDialSTKSETUPCALL : HsAppLaunchCmd.h
  • phoneAppLaunchCmdDialVoiceMail : HsAppLaunchCmd.h
  • phoneAppLaunchCmdDisplayDialPrefs : HsAppLaunchCmd.h
  • phoneAppLaunchCmdGetALSLineNumber : HsAppLaunchCmd.h
  • phoneAppLaunchCmdGetDialPrefFlag : HsAppLaunchCmd.h
  • phoneAppLaunchCmdGetUSDialingRules : HsAppLaunchCmd.h
  • phoneAppLaunchCmdNetworkSearch : HsAppLaunchCmd.h
  • phoneAppLaunchCmdPowerOn : HsAppLaunchCmd.h
  • phoneAppLaunchCmdRedial : HsAppLaunchCmd.h
  • phoneAppLaunchCmdSendDTMFTone : HsAppLaunchCmd.h
  • phoneAppLaunchCmdSetWallpaper : HsAppLaunchCmd.h
  • phoneAppLaunchCmdStartNetInitUSSD : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewCalls : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewHistory : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewKeypad : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewMissedCalls : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewPhoneHome : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewSpeed : HsAppLaunchCmd.h
  • phoneAppLaunchOptionsMenu : HsAppLaunchCmd.h
  • PinGetCurrentPinletID() : PalmPin.h
  • PinGetInputAreaState() : PalmPin.h
  • PinGetInputMode() : PalmPin.h
  • PinLibClose() : PalmPin.h
  • PinLibOpen() : PalmPin.h
  • PinResetInputState() : PalmPin.h
  • PinSetInputAreaState() : PalmPin.h
  • PinSetInputMode() : PalmPin.h
  • PinSwitchToPinlet() : PalmPin.h
  • plainOnly : VMFontLibCommon.h
  • plugin_allInfo : PalmVMPlugin.h
  • plugin_receiveInfo : PalmVMPlugin.h
  • plugin_sendInfo : PalmVMPlugin.h
  • pluginExtendedQueryParams : PalmVMPlugin.h
  • pluginGetInfoParams : PalmVMPlugin.h
  • PluginInfo : PalmVMPlugin.h
  • pluginParams : PalmVMPlugin.h
  • pluginQueryParams : PalmVMPlugin.h
  • pluginSendParams : PalmVMPlugin.h
  • PM_AUDIOGROUP_MASK : PmSoundLibAudioGroup.h
  • PM_AUDP : HsSoundLibCommon.h
  • PM_AUDP_CLASS : HsSoundLibCommon.h
  • PM_AUDP_CLASS_MASK : HsSoundLibCommon.h
  • pmAudioClkTickRef : HsSoundLibCommon.h
  • PmAudioGroup : PmSoundLibAudioGroup.h
  • pmAudioGroupAlert : PmSoundLibAudioGroup.h
  • pmAudioGroupAlertRingOff : PmSoundLibAudioGroup.h
  • pmAudioGroupApp : PmSoundLibAudioGroup.h
  • pmAudioGroupCall : PmSoundLibAudioGroup.h
  • PmAudioGroupEnum : PmSoundLibAudioGroup.h
  • pmAudioGroupHighPriority : PmSoundLibAudioGroup.h
  • pmAudioGroupInteractive : PmSoundLibAudioGroup.h
  • pmAudioGroupNone : PmSoundLibAudioGroup.h
  • pmAudioGroupReserved1 : PmSoundLibAudioGroup.h
  • pmAudioGroupSystem : PmSoundLibAudioGroup.h
  • PmClkTickRef : HsSoundLibCommon.h
  • PmConnectorAudioOutputSettingType : PmConnectorLibCommon.h
  • PmConnectorLibClose() : PmConnectorLib.h
  • PmConnectorLibControl() : PmConnectorLib.h
  • PmConnectorLibControlType : PmConnectorLibCommon.h
  • PmConnectorLibGetVersion() : PmConnectorLib.h
  • PmConnectorLibOpen() : PmConnectorLib.h
  • PmConnectorLibSetAudioInput() : PmConnectorLib.h
  • PmConnectorLibSetAudioOutput() : PmConnectorLib.h
  • PmConnectorLibSleep() : PmConnectorLib.h
  • PmConnectorLibWake() : PmConnectorLib.h
  • PmKeyAttrEnumTag : PmKeyLibCommon.h
  • PmKeyAttrGet() : PmKeyLib.h
  • pmKeyAttrGetEndKeyCode : PmKeyLibCommon.h
  • pmKeyAttrGetLauncherKeyCode : PmKeyLibCommon.h
  • pmKeyAttrGetMenuKeyCode : PmKeyLibCommon.h
  • pmKeyAttrGetPhoneKeyCode : PmKeyLibCommon.h
  • pmKeyAttrGetSendKeyCode : PmKeyLibCommon.h
  • pmKeyAttrPagingMode : PmKeyLibCommon.h
  • PmKeyAttrSet() : PmKeyLib.h
  • PmKeyChrCodeToKeyCode() : PmKeyLib.h
  • PmKeyEnableKey() : PmKeyLib.h
  • PmKeyEventIsFromKeyboard() : PmKeyLib.h
  • PmKeyKeyCodeToChrCode() : PmKeyLib.h
  • PmKeyKeysPressed() : PmKeyLib.h
  • PmKeyLibClose() : PmKeyLib.h
  • PmKeyLibOpen() : PmKeyLib.h
  • PmKeyStop() : PmKeyLib.h
  • pmNotifyHighPriorityAudioTask : HsAppLaunchCmd.h
  • pmNotifyHighPriorityUITask : HsAppLaunchCmd.h
  • pmPhoneAppNotifyHomeAppEvent : HsAppLaunchCmd.h
  • pmPhoneAppNotifySetWallpaper : HsAppLaunchCmd.h
  • PmSndAddAudioGroupToVolume : PmSoundLibAudioGroup.h
  • pmSndAttackEnvIDRings : HsSoundLibCommon.h
  • pmSndAttackEnvIDVibeRing : HsSoundLibCommon.h
  • pmSndBayID_AUDP : HsSoundLibCommon.h
  • PmSndClkGetTickCount() : HsSoundLib.h
  • PmSndClkGetTicksPerSecond() : HsSoundLib.h
  • pmSndFormatPauseStream : HsSoundLibCommon.h
  • pmSndFormatResumeStream : HsSoundLibCommon.h
  • pmSndFormatSetAttackEnvID : HsSoundLibCommon.h
  • pmSndFormatSetStoppable : HsSoundLibCommon.h
  • PmSndGetAudioGroupFromVolume : PmSoundLibAudioGroup.h
  • PmSndGetPosition() : HsSoundLib.h
  • pmSndPref_AthenaActive_No : HsSoundLibCommon.h
  • pmSndPref_AthenaActive_Yes : HsSoundLibCommon.h
  • pmSndPref_AthenaAudio_IfMicPresent : HsSoundLibCommon.h
  • pmSndPref_AthenaAudio_NoRouting : HsSoundLibCommon.h
  • pmSndPref_AthenaAudio_Unconditional : HsSoundLibCommon.h
  • pmSndPref_WakeOnAnswerBtn_Disable : HsSoundLibCommon.h
  • pmSndPref_WakeOnAnswerBtn_Enable : HsSoundLibCommon.h
  • PmSndPrefID : HsSoundLibCommon.h
  • pmSndPrefID_AGCEvent : HsSoundLibCommon.h
  • pmSndPrefID_AppsGroupHoldType : HsSoundLibCommon.h
  • pmSndPrefID_AthenaActive : HsSoundLibCommon.h
  • pmSndPrefID_AthenaAudio : HsSoundLibCommon.h
  • pmSndPrefID_AudioTable : HsSoundLibCommon.h
  • pmSndPrefID_GsmMccArray : HsSoundLibCommon.h
  • pmSndPrefID_JackOutIfMicUnused : HsSoundLibCommon.h
  • pmSndPrefID_PhoneRxGainLimit : HsSoundLibCommon.h
  • pmSndPrefID_SleepMode : HsSoundLibCommon.h
  • pmSndPrefID_WakeOnAnswerBtn : HsSoundLibCommon.h
  • PmSndRemoveAudioGroupFromVolume : PmSoundLibAudioGroup.h
  • pmSndSwitchID_Preferences : HsSoundLibCommon.h
  • pmSoundLibAudioGroupFtr : PmSoundLibAudioGroup.h
  • pmSoundLibAudioGroupFtr_Off : PmSoundLibAudioGroup.h
  • pmSoundLibAudioGroupFtr_On : PmSoundLibAudioGroup.h
  • pmSoundLibCreatorID : PmSoundLibAudioGroup.h
  • PmSysGadgetBbutHitBigButton() : PmSysGadgetLib.h
  • PmSysGadgetBbutInstallFromResource() : PmSysGadgetLib.h
  • PmSysGadgetBbutInstallNewButton() : PmSysGadgetLib.h
  • PmSysGadgetBbutSetBitmap() : PmSysGadgetLib.h
  • PmSysGadgetBbutSetLabel() : PmSysGadgetLib.h
  • PmSysGadgetBtStatusTypeEnum : PmSysGadgetLibCommon.h
  • PmSysGadgetLibClose() : PmSysGadgetLib.h
  • PmSysGadgetLibOpen() : PmSysGadgetLib.h
  • pmSysGadgetStatusGadgetBattery : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetBt : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetCallFwd : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetEvdo : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetLine : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetNone : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetOperator : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetRoaming : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetSignal : PmSysGadgetLibCommon.h
  • PmSysGadgetStatusGadgetsUpdate() : PmSysGadgetLib.h
  • pmSysGadgetStatusGadgetTty : PmSysGadgetLibCommon.h
  • PmSysGadgetStatusGadgetTypeEnum : PmSysGadgetLibCommon.h
  • PmSysGadgetStatusGadgetTypeSet() : PmSysGadgetLib.h
  • pmSysGadgetStatusGadgetVm : PmSysGadgetLibCommon.h
  • pmUIUtilAttrAutoSnoozeAttns : PmUIUtilLibCommon.h
  • PmUIUtilAttrEnum : PmUIUtilLibCommon.h
  • PmUIUtilAttrEnumTag : PmUIUtilLibCommon.h
  • PmUIUtilLibClose() : PmUIUtilLib.h
  • PmUIUtilLibOpen() : PmUIUtilLib.h
  • pmUsbFtrCreator : palmOneFeatures.h
  • pmUsbFtrVersion : palmOneFeatures.h
  • PRIORITY_LIST_SIZE : PalmNetServices.h
  • PrvPhnLibTrapCheckPowerSync : HsPhoneTraps.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- r -

  • replaceType1 : HsPhoneEvent.h
  • replaceType2 : HsPhoneEvent.h
  • replaceType3 : HsPhoneEvent.h
  • replaceType4 : HsPhoneEvent.h
  • replaceType5 : HsPhoneEvent.h
  • replaceType6 : HsPhoneEvent.h
  • replaceType7 : HsPhoneEvent.h
  • Reserved2 : HsPhoneTraps.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- s -

  • sabon : VMFontLibCommon.h
  • screenFtrCreator : palmOneFeatures.h
  • SetFontUIRules() : palmOneVMFontLib.h
  • ShlCreatorID : PalmNetServices.h
  • ShlLibName : PalmNetServices.h
  • ShlLibType : PalmNetServices.h
  • size12 : VMFontLibCommon.h
  • size6 : VMFontLibCommon.h
  • size9 : VMFontLibCommon.h
  • smallFonts : VMFontLibCommon.h
  • SMSMessageStatus : HsPhoneSMSTypes.h
  • SMSMessageType : HsPhoneSMSTypes.h
  • sndControlCodecCustomControl : PalmSoundCustomCtrl.h
  • SndFileFormatType : palmOneSndFileStream.h
  • SNDFILESTREAM_TRAP : palmOneSndFileStream.h
  • SndFileStreamCallbackPtr : palmOneSndFileStream.h
  • SndFileStreamClose() : palmOneSndFileStream.h
  • SndFileStreamCreate() : palmOneSndFileStream.h
  • SndFileStreamData : palmOneSndFileStream.h
  • SndFileStreamDataPtr : palmOneSndFileStream.h
  • SndFileStreamDeviceControl() : palmOneSndFileStream.h
  • SndFileStreamFileSpec : palmOneSndFileStream.h
  • SndFileStreamFileSpecPtr : palmOneSndFileStream.h
  • SndFileStreamGetCurrentStreamData() : palmOneSndFileStream.h
  • SndFileStreamGetPan() : palmOneSndFileStream.h
  • SndFileStreamGetVolume() : palmOneSndFileStream.h
  • SndFileStreamHsSoundCommandParam : palmOneSndFileStream.h
  • SndFileStreamHsSoundCommandParamPtr : palmOneSndFileStream.h
  • SndFileStreamLibClose() : palmOneSndFileStream.h
  • SndFileStreamLibOpen() : palmOneSndFileStream.h
  • SndFileStreamLibSleep() : palmOneSndFileStream.h
  • SndFileStreamLibVersion() : palmOneSndFileStream.h
  • SndFileStreamLibWake() : palmOneSndFileStream.h
  • sndFileStreamNotifyRecComplete : palmOneSndFileStream.h
  • sndFileStreamNotifyStreamComplete : palmOneSndFileStream.h
  • SndFileStreamOpen() : palmOneSndFileStream.h
  • SndFileStreamPause() : palmOneSndFileStream.h
  • SndFileStreamRef : palmOneSndFileStream.h
  • SndFileStreamSeek() : palmOneSndFileStream.h
  • SndFileStreamSetPan() : palmOneSndFileStream.h
  • SndFileStreamSetVolume() : palmOneSndFileStream.h
  • SndFileStreamStart() : palmOneSndFileStream.h
  • SndFileStreamStop() : palmOneSndFileStream.h
  • SndFileStreamUIPlay() : palmOneSndFileStream.h
  • SndFileStreamUIRecord() : palmOneSndFileStream.h
  • sndFormatAAC : PalmSoundMgrExt.h
  • sndFormatDVI_ADPCM : PalmSoundMgrExt.h
  • sndFormatIMA_ADPCM : PalmSoundMgrExt.h
  • sndFormatMP3 : PalmSoundMgrExt.h
  • sndFormatOGG : PalmSoundMgrExt.h
  • sndFormatPCM : PalmSoundMgrExt.h
  • SndFormatType : PalmSoundMgrExt.h
  • SndStreamCreateExtended() : PalmSoundMgrExt.h
  • SndStreamDeviceControl() : PalmSoundMgrExt.h
  • SndStreamVariableBufferCallback : PalmSoundMgrExt.h
  • soundPrefsLaunchCmdCalendar : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdEmail : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdGeneral : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdIM : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdMMS : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdPhone : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdSMS : HsAppLaunchCmd.h
  • SoundPrefsView : HsAppLaunchCmd.h
  • SoundPrefType : TonesLibTypes.h
  • soundPrefTypeCalendar : TonesLibTypes.h
  • soundPrefTypeEmail : TonesLibTypes.h
  • soundPrefTypeIM : TonesLibTypes.h
  • soundPrefTypeLast : TonesLibTypes.h
  • soundPrefTypeMMS : TonesLibTypes.h
  • soundPrefTypeNetworkSounds : TonesLibTypes.h
  • soundPrefTypePhone : TonesLibTypes.h
  • soundPrefTypeSMS : TonesLibTypes.h
  • steAcceleratedScrolling : SmartTextEngineDef.h
  • steAllowPhoneNumberWords : SmartTextEngineDef.h
  • steAllowShortPhoneNumbers : SmartTextEngineDef.h
  • STEAppendParsedInfo() : SmartTextEngine.h
  • STEAppendTextToEngine() : SmartTextEngine.h
  • steBitmap : SmartTextEngineDef.h
  • steBlackFont : SmartTextEngineDef.h
  • steBlueFont : SmartTextEngineDef.h
  • steBoldFont : SmartTextEngineDef.h
  • STECallbackType : SmartTextEngineDef.h
  • steCannotSelectText : SmartTextEngineDef.h
  • steCenterAlign : SmartTextEngineDef.h
  • STEClearCurrentSelection() : SmartTextEngine.h
  • STEClose() : SmartTextEngine.h
  • STECopySelectionToClipboard() : SmartTextEngine.h
  • steCurrentFont : SmartTextEngineDef.h
  • STEDepracated5 : SmartTextEngineTraps.h
  • steDoNotCenterVertically : SmartTextEngineDef.h
  • STEErr : SmartTextEngineErrors.h
  • steErrBase : SmartTextEngineErrors.h
  • steErrDynamicMemory : SmartTextEngineErrors.h
  • steErrInternal : SmartTextEngineErrors.h
  • steErrInvalidArguments : SmartTextEngineErrors.h
  • steErrOperationNotAllowed : SmartTextEngineErrors.h
  • steErrSTEInit : SmartTextEngineErrors.h
  • steErrStorageMemory : SmartTextEngineErrors.h
  • steErrUnimplemented : SmartTextEngineErrors.h
  • STEGetAPIVersion() : SmartTextEngine.h
  • STEGetCurrentTextSelection() : SmartTextEngine.h
  • STEGetFlags() : SmartTextEngine.h
  • STEGetLastTapInfo() : SmartTextEngine.h
  • STEGetNumLines() : SmartTextEngine.h
  • STEGetNumRecords() : SmartTextEngine.h
  • STEGetParsedInformation() : SmartTextEngine.h
  • STEGetScroll() : SmartTextEngine.h
  • STEGetScrollPct() : SmartTextEngine.h
  • STEGetSelectedText() : SmartTextEngine.h
  • steGrayFont : SmartTextEngineDef.h
  • steGreenFont : SmartTextEngineDef.h
  • STEHandleEvent() : SmartTextEngine.h
  • STEHandleKeyDownEvent() : SmartTextEngine.h
  • STEHandlePenDownEvent() : SmartTextEngine.h
  • STEHandlePenMoveEvent() : SmartTextEngine.h
  • STEHandlePenUpEvent() : SmartTextEngine.h
  • STEHandleSclRepeatEvent() : SmartTextEngine.h
  • STEHasHotRectSelection() : SmartTextEngine.h
  • STEHasMessageSelection() : SmartTextEngine.h
  • STEHasTextSelection() : SmartTextEngine.h
  • steHorizontalLine : SmartTextEngineDef.h
  • steHyperlink : SmartTextEngineDef.h
  • STEInitializeEngine() : SmartTextEngine.h
  • steInvertHighlighting : SmartTextEngineDef.h
  • steLargeFont : SmartTextEngineDef.h
  • steLeftIndent : SmartTextEngineDef.h
  • steLibDBName : SmartTextEngineDef.h
  • steLibName : SmartTextEngineDef.h
  • steLineBreak : SmartTextEngineDef.h
  • steNoLinksBeforeColon : SmartTextEngineDef.h
  • STEOpen() : SmartTextEngine.h
  • steOrangeFont : SmartTextEngineDef.h
  • steParseEmail : SmartTextEngineDef.h
  • steParseEmoticons : SmartTextEngineDef.h
  • steParseGSMGreekChars : SmartTextEngineDef.h
  • steParseMoreEmoticons : SmartTextEngineDef.h
  • steParsePhoneNumbers : SmartTextEngineDef.h
  • steParseURLs : SmartTextEngineDef.h
  • stePurpleFont : SmartTextEngineDef.h
  • STEQuickRender() : SmartTextEngine.h
  • steRedFont : SmartTextEngineDef.h
  • STEReinitializeEngine() : SmartTextEngine.h
  • STERemoveLastRecordFromEngine() : SmartTextEngine.h
  • STERenderList() : SmartTextEngine.h
  • STERerenderList() : SmartTextEngine.h
  • STEResetEngine() : SmartTextEngine.h
  • steRightAlign : SmartTextEngineDef.h
  • steScrollWalksLinks : SmartTextEngineDef.h
  • steScrollWalksMessages : SmartTextEngineDef.h
  • STESetCurrentTextSelection() : SmartTextEngine.h
  • STESetCustomHyperlinkCallback() : SmartTextEngine.h
  • STESetFlags() : SmartTextEngine.h
  • STESetScroll() : SmartTextEngine.h
  • STESetScrollPct() : SmartTextEngine.h
  • STESetScrollToRecordNum() : SmartTextEngine.h
  • steStdFont : SmartTextEngineDef.h
  • steTextMustBeVisible : SmartTextEngineDef.h
  • STETrapAppendParsedInfo : SmartTextEngineTraps.h
  • STETrapAppendTextToEngine : SmartTextEngineTraps.h
  • STETrapClearCurrentSelection : SmartTextEngineTraps.h
  • STETrapClose : SmartTextEngineTraps.h
  • STETrapCopySelectionToClipboard : SmartTextEngineTraps.h
  • STETrapGetAPIVersion : SmartTextEngineTraps.h
  • STETrapGetCurrentTextSelection : SmartTextEngineTraps.h
  • STETrapGetFlags : SmartTextEngineTraps.h
  • STETrapGetLastTapInfo : SmartTextEngineTraps.h
  • STETrapGetNumLines : SmartTextEngineTraps.h
  • STETrapGetNumRecords : SmartTextEngineTraps.h
  • STETrapGetParsedInformation : SmartTextEngineTraps.h
  • STETrapGetScroll : SmartTextEngineTraps.h
  • STETrapGetScrollPct : SmartTextEngineTraps.h
  • STETrapGetSelectedText : SmartTextEngineTraps.h
  • STETrapHandleEvent : SmartTextEngineTraps.h
  • STETrapHandleKeyDownEvent : SmartTextEngineTraps.h
  • STETrapHandlePenDownEvent : SmartTextEngineTraps.h
  • STETrapHandlePenMoveEvent : SmartTextEngineTraps.h
  • STETrapHandlePenUpEvent : SmartTextEngineTraps.h
  • STETrapHandleSclRepeatEvent : SmartTextEngineTraps.h
  • STETrapHasHotRectSelection : SmartTextEngineTraps.h
  • STETrapHasMessageSelection : SmartTextEngineTraps.h
  • STETrapHasTextSelection : SmartTextEngineTraps.h
  • STETrapInitializeEngine : SmartTextEngineTraps.h
  • STETrapOpen : SmartTextEngineTraps.h
  • STETrapQuickRender : SmartTextEngineTraps.h
  • STETrapReinitializeEngine : SmartTextEngineTraps.h
  • STETrapRemoveLastRecordFromEngine : SmartTextEngineTraps.h
  • STETrapRenderList : SmartTextEngineTraps.h
  • STETrapRerenderList : SmartTextEngineTraps.h
  • STETrapResetEngine : SmartTextEngineTraps.h
  • STETrapSetCurrentTextSelection : SmartTextEngineTraps.h
  • STETrapSetCustomHyperlinkCallback : SmartTextEngineTraps.h
  • STETrapSetFlags : SmartTextEngineTraps.h
  • STETrapSetScroll : SmartTextEngineTraps.h
  • STETrapSetScrollPct : SmartTextEngineTraps.h
  • STETrapSetScrollToRecordNum : SmartTextEngineTraps.h
  • steYellowFont : SmartTextEngineDef.h
  • sysAppLaunchCmdFromSetupApp : PalmLaunchCodes.h
  • sysAppLaunchWebBrowserAutoCrawl : HsAppLaunchCmd.h
  • sysAppLaunchWebBrowserGetHomePage : HsAppLaunchCmd.h
  • sysAppLaunchWebBrowserLaunchBookmarkDialog : HsAppLaunchCmd.h
  • sysAppLaunchWebBrowserMinimalMode : HsAppLaunchCmd.h
  • sysAppLaunchWebBrowserSetHomePage : HsAppLaunchCmd.h
  • sysAppLaunchWebBrowserTutorialMode : HsAppLaunchCmd.h
  • sysExternalHeadsetInsertEvent : palmOneFeatures.h
  • sysExternalHeadsetRemoveEvent : palmOneFeatures.h
  • sysFileCMobileApp : palmOneCreators.h
  • sysFileCMobileServices : palmOneCreators.h
  • sysFileCMyFavorite : palmOneCreators.h
  • sysFileCNotePad : palmOneCreators.h
  • sysFileCProvisioning : palmOneCreators.h
  • sysFileCSimATDriverOem : palmOneCreators.h
  • sysFileCSimOfficer : palmOneCreators.h
  • sysFileCSimWatcherLib : palmOneCreators.h
  • sysFileCTelMgrLibOem : palmOneCreators.h
  • sysFileTVPNPanelPlugin : PalmVPPI.h
  • sysFileTWiFiPanelPlugin : PalmWPPI.h
  • sysFtrNumDmAutoBackup : PmPalmOSNVFS.h
  • sysNotifyExternalDialogClosedEvent : palmOneFeatures.h
  • sysNotifyExternalDialogOpenedEvent : palmOneFeatures.h
  • sysNotifyHardDiskSpinup : palmOneFeatures.h
  • sysTrapOEMDispatch : HsExtTraps.h
  • sysVPPILaunchCmdClearPWCache : PalmVPPI.h
  • sysVPPILaunchCmdDeleteAccount : PalmVPPI.h
  • sysVPPILaunchCmdEditAccount : PalmVPPI.h
  • sysVPPILaunchCmdErrorDialog : PalmVPPI.h
  • sysVPPILaunchCmdGetAccounts : PalmVPPI.h
  • sysVPPILaunchCmdProgressPaint : PalmVPPI.h
  • sysVPPILaunchCmdPromptAndConfigure : PalmVPPI.h
  • sysVPPILaunchCmdSetCurrentAccount : PalmVPPI.h
  • sysVPPILaunchCmdWillPWPrompt : PalmVPPI.h
  • sysWPPILaunchCmdClearPWCache : PalmWPPI.h
  • sysWPPILaunchCmdClose : PalmWPPI.h
  • sysWPPILaunchCmdDelete : PalmWPPI.h
  • sysWPPILaunchCmdDialog : PalmWPPI.h
  • sysWPPILaunchCmdErrorDialog : PalmWPPI.h
  • sysWPPILaunchCmdGetDescription : PalmWPPI.h
  • sysWPPILaunchCmdPromptAndConfigure : PalmWPPI.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- t -

  • tagAudioOutputSetting : PmConnectorLibCommon.h
  • tagSndFileFormatEnum : palmOneSndFileStream.h
  • TextHeaderTerminator : HsPhoneSMSTypes.h
  • tonePlay100Times : TonesLibTypes.h
  • tonePlay10Times : TonesLibTypes.h
  • tonePlay3Times : TonesLibTypes.h
  • tonePlay5Times : TonesLibTypes.h
  • TonePlayNumberTimes : TonesLibTypes.h
  • tonePlayOnce : TonesLibTypes.h
  • tonePlayTwice : TonesLibTypes.h
  • toneRepeatEvery10Minutes : TonesLibTypes.h
  • toneRepeatEvery30Minutes : TonesLibTypes.h
  • toneRepeatEvery5Minutes : TonesLibTypes.h
  • toneRepeatEveryMinute : TonesLibTypes.h
  • ToneRepeatInterval : TonesLibTypes.h
  • TonesLibAddMidiTone() : TonesLib.h
  • TonesLibClose() : TonesLib.h
  • tonesLibCreator : TonesLibTypes.h
  • TonesLibDeleteTone() : TonesLib.h
  • TonesLibDoDialog() : TonesLib.h
  • tonesLibErrAlreadyPlaying : TonesLibTypes.h
  • tonesLibErrBadParams : TonesLibTypes.h
  • tonesLibErrClass : TonesLibTypes.h
  • tonesLibErrCreateDBFailed : TonesLibTypes.h
  • tonesLibErrDBNotFound : TonesLibTypes.h
  • tonesLibErrDBWriteFailed : TonesLibTypes.h
  • tonesLibErrNoMemory : TonesLibTypes.h
  • tonesLibErrNotAllowed : TonesLibTypes.h
  • tonesLibErrNoTone : TonesLibTypes.h
  • tonesLibErrUnknown : TonesLibTypes.h
  • tonesLibErrUserCancel : TonesLibTypes.h
  • TonesLibEscalateRingTones() : TonesLib.h
  • TonesLibGetSoundOnVolume() : TonesLib.h
  • TonesLibGetSoundPrefs() : TonesLib.h
  • TonesLibGetToneIDs() : TonesLib.h
  • TonesLibGetToneList() : TonesLib.h
  • TonesLibGetToneName() : TonesLib.h
  • TonesLibGetToneSize() : TonesLib.h
  • TonesLibInitTonesDB() : TonesLib.h
  • TonesLibManageTones() : TonesLib.h
  • tonesLibName : TonesLibTypes.h
  • TonesLibOpen() : TonesLib.h
  • TonesLibPickTone() : TonesLib.h
  • tonesLibPlayForever : TonesLibTypes.h
  • TonesLibPlayRingTone() : TonesLib.h
  • TonesLibPlayTone() : TonesLib.h
  • TonesLibRecordTone() : TonesLib.h
  • TonesLibSetSoundOnVolume() : TonesLib.h
  • TonesLibSetSoundPrefs() : TonesLib.h
  • TonesLibSleep() : TonesLib.h
  • TonesLibStopTone() : TonesLib.h
  • TonesLibToneClose() : TonesLib.h
  • TonesLibToneCreate() : TonesLib.h
  • TonesLibToneWrite() : TonesLib.h
  • tonesLibTrapAddMidiTone : TonesLibTypes.h
  • tonesLibTrapDeleteTone : TonesLibTypes.h
  • tonesLibTrapDoDialog : TonesLibTypes.h
  • tonesLibTrapEscalateRingTones : TonesLibTypes.h
  • tonesLibTrapGetSoundOnVolume : TonesLibTypes.h
  • tonesLibTrapGetSoundPrefs : TonesLibTypes.h
  • tonesLibTrapGetToneIDs : TonesLibTypes.h
  • tonesLibTrapGetToneList : TonesLibTypes.h
  • tonesLibTrapGetToneName : TonesLibTypes.h
  • tonesLibTrapGetToneSize : TonesLibTypes.h
  • tonesLibTrapInitTonesDB : TonesLibTypes.h
  • tonesLibTrapManageTones : TonesLibTypes.h
  • tonesLibTrapPickTone : TonesLibTypes.h
  • tonesLibTrapPlayRingTone : TonesLibTypes.h
  • tonesLibTrapPlayTone : TonesLibTypes.h
  • tonesLibTrapSetSoundOnVolume : TonesLibTypes.h
  • tonesLibTrapSetSoundPrefs : TonesLibTypes.h
  • tonesLibTrapStopTone : TonesLibTypes.h
  • tonesLibTrapToneClose : TonesLibTypes.h
  • tonesLibTrapToneCreate : TonesLibTypes.h
  • tonesLibTrapToneRecord : TonesLibTypes.h
  • tonesLibTrapToneWrite : TonesLibTypes.h
  • tonesLibType : TonesLibTypes.h
  • TonesLibWake() : TonesLib.h
  • ToneTimeUnit : TonesLibTypes.h
  • toneTimeUnitDays : TonesLibTypes.h
  • toneTimeUnitHours : TonesLibTypes.h
  • toneTimeUnitMinutes : TonesLibTypes.h
  • ToneType : TonesLibTypes.h
  • toneTypeAAC : TonesLibTypes.h
  • toneTypeAMR : TonesLibTypes.h
  • toneTypeMIDI : TonesLibTypes.h
  • toneTypeMP3 : TonesLibTypes.h
  • toneTypeQCELP : TonesLibTypes.h
  • toneTypeSystemSound : TonesLibTypes.h
  • toneTypeWAV : TonesLibTypes.h
  • toneVibrateAlert : TonesLibTypes.h
  • toneVibrateCalender : TonesLibTypes.h
  • toneVibrateMail : TonesLibTypes.h
  • toneVibrateNone : TonesLibTypes.h
  • toneVibrateRing : TonesLibTypes.h
  • toneVibrateSMS : TonesLibTypes.h
  • toneVibrateThenRing : TonesLibTypes.h
  • ToneVibrateType : TonesLibTypes.h
  • toneVibrateVoicemail : TonesLibTypes.h
  • ToneVolume : TonesLibTypes.h
  • toneVolume1 : TonesLibTypes.h
  • toneVolume2 : TonesLibTypes.h
  • toneVolume3 : TonesLibTypes.h
  • toneVolume4 : TonesLibTypes.h
  • toneVolume5 : TonesLibTypes.h
  • toneVolume6 : TonesLibTypes.h
  • toneVolume7 : TonesLibTypes.h
  • toneVolumeOff : TonesLibTypes.h
  • TransLibCloseConnection() : TransparencyLib.h
  • transLibCreator : TransparencyLibTypes.h
  • transLibErrAlreadyOpen : TransparencyLibTypes.h
  • transLibErrDockNotAttached : TransparencyLibTypes.h
  • transLibErrNotOpen : TransparencyLibTypes.h
  • transLibErrorClass : TransparencyLibTypes.h
  • transLibErrUnknown : TransparencyLibTypes.h
  • transLibName : TransparencyLibTypes.h
  • TransLibOpenConnection() : TransparencyLib.h
  • transLibType : TransparencyLibTypes.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- u -

  • UPDataSize : HsPhoneEvent.h
  • UPHeaderEscapeSeq : HsPhoneEvent.h
  • UPTextHeader : HsPhoneEvent.h
  • UPTextHeaderLength : HsPhoneEvent.h
  • USBChargeCreator : palmOneFeatures.h
  • USBChargeVersion : palmOneFeatures.h
  • USBFeatureCreator : palmOneFeatures.h
  • USBFeatureVersion : palmOneFeatures.h
  • USBHwrCreator : palmOneFeatures.h
  • USBHwrVersion : palmOneFeatures.h
  • USBSpeedCreator : palmOneFeatures.h
  • USBSpeedVersion : palmOneFeatures.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- v -

  • VFS : palmOneCodecFormat.h
  • vfsIncludePrivateVolumes : PmPalmOSNVFS.h
  • vfsVolumeAttrNonRemovable : PmPalmOSNVFS.h
  • VMFontClearCache() : palmOneVMFontLib.h
  • VMFontClose() : palmOneVMFontLib.h
  • VMFontCountStyleAndSize() : palmOneVMFontLib.h
  • VMFontErrNotOpen : VMFontLibCommon.h
  • VMFontErrParam : VMFontLibCommon.h
  • VMFontErrStillOpen : VMFontLibCommon.h
  • VMFontExists() : palmOneVMFontLib.h
  • VMFontFace : VMFontLibCommon.h
  • VMFontGetFont() : palmOneVMFontLib.h
  • VMFontGetFontByID() : palmOneVMFontLib.h
  • VMFontOpen() : palmOneVMFontLib.h
  • VMFontSize : VMFontLibCommon.h
  • VMFontSizeRule : VMFontLibCommon.h
  • VMFontStyle : VMFontLibCommon.h
  • VMFontStyleRule : VMFontLibCommon.h
  • VMFontToString() : palmOneVMFontLib.h
  • VMFontVersion() : palmOneVMFontLib.h
  • VPNLibEventNotificationTypeEnum_ : PalmShimSettings.h
  • VPNNotifyEventType : PalmShimSettings.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- w -

  • WAPNotificationTypeVersion : HsPhoneEvent.h
  • WIFI_CONFIG_NAME : PalmWiFiCommon.h
  • WIFI_CREATOR_ID : PalmWiFiCommon.h
  • WIFI_DB_NAME : PalmWiFiCommon.h
  • WIFI_DB_TYPE : PalmWiFiCommon.h
  • WIFI_DRIVER_NAME : PalmWiFiCommon.h
  • WIFI_DRIVER_PREFIX : PalmWiFiCommon.h
  • WIFI_MIN_OS_VERSION : PalmWiFiCommon.h
  • WUFieldDelimiter : HsPhoneEvent.h
  • WUHeaderEscapeSeq : HsPhoneEvent.h
  • WUTextHeader : HsPhoneEvent.h
  • WUTextHeaderLength : HsPhoneEvent.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • Addressing16bitID : HsPhoneSMSTypes.h
  • Addressing16bitIDLen : HsPhoneSMSTypes.h
  • Addressing8bitID : HsPhoneSMSTypes.h
  • Addressing8bitIDLen : HsPhoneSMSTypes.h
  • AddrHsLookupUserDataVersion : HsAppLaunchCmd.h
  • AddrHsLookupUserDataVersion2 : HsAppLaunchCmd.h
  • addrLookupNoMinLength : HsAppLaunchCmd.h
  • aiaExtentChangedData : PalmPin.h
  • ATTYPE_MAX_NAME_LEN : PalmVMPlugin.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- k -

  • kAngelSmiley : SmartTextEngineDef.h
  • kBigFrownSmiley : SmartTextEngineDef.h
  • kBigSmileSmiley : SmartTextEngineDef.h
  • kBigTeethSmiley : SmartTextEngineDef.h
  • kBigTongueSmiley : SmartTextEngineDef.h
  • kBlushSmiley : SmartTextEngineDef.h
  • kCameraImageFormatRGB1 : CameraLibCommon.h
  • kCameraImageFormatRGB16 : CameraLibCommon.h
  • kCameraImageFormatRGB24 : CameraLibCommon.h
  • kCameraImageFormatRGB32 : CameraLibCommon.h
  • kCameraImageFormatRGB4 : CameraLibCommon.h
  • kCameraImageFormatRGB8 : CameraLibCommon.h
  • kCameraImageFormatYCbCr : CameraLibCommon.h
  • kCameraImageFormatYCrCb : CameraLibCommon.h
  • kCameraImageLittleEndian : CameraLibCommon.h
  • kCameraLibCreator : CameraLibCommon.h
  • kCameraLibName : CameraLibCommon.h
  • kCameraLibType : CameraLibCommon.h
  • kCamLibApertureValueAuto : palmOneCameraCommon.h
  • kCamLibApertureValueManual : palmOneCameraCommon.h
  • kCamLibBufNumManual : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatRGB565 : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYCbCr420 : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYCbCr420Planar : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYCbCr422 : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYCbCr422Planar : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYUV420 : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYUV420Planar : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYUV422 : palmOneCameraCommon.h
  • kCamLibCaptureDataFormatYUV422Planar : palmOneCameraCommon.h
  • kCamLibCaptureHwrVersion : palmOneCameraCommon.h
  • kCamLibColorSpace_sRGB : palmOneCameraCommon.h
  • kCamLibColorSpaceUncalibrated : palmOneCameraCommon.h
  • kCamLibContrastManual : palmOneCameraCommon.h
  • kCamLibCreator : palmOneCameraCommon.h
  • kCamLibCtrlApertureValueGet : palmOneCameraCommon.h
  • kCamLibCtrlApertureValueQuery : palmOneCameraCommon.h
  • kCamLibCtrlApertureValueSet : palmOneCameraCommon.h
  • kCamLibCtrlCapture : palmOneCameraCommon.h
  • kCamLibCtrlCaptureAreaGet : palmOneCameraCommon.h
  • kCamLibCtrlCaptureAreaSet : palmOneCameraCommon.h
  • kCamLibCtrlCaptureFormatGet : palmOneCameraCommon.h
  • kCamLibCtrlCaptureFormatQuery : palmOneCameraCommon.h
  • kCamLibCtrlCaptureFormatSet : palmOneCameraCommon.h
  • kCamLibCtrlCaptureGetBitmapInfo : palmOneCameraCommon.h
  • kCamLibCtrlCaptureSizeGet : palmOneCameraCommon.h
  • kCamLibCtrlCaptureSizeQuery : palmOneCameraCommon.h
  • kCamLibCtrlCaptureSizeSet : palmOneCameraCommon.h
  • kCamLibCtrlColorSpaceGet : palmOneCameraCommon.h
  • kCamLibCtrlColorSpaceQuery : palmOneCameraCommon.h
  • kCamLibCtrlColorSpaceSet : palmOneCameraCommon.h
  • kCamLibCtrlContrastGet : palmOneCameraCommon.h
  • kCamLibCtrlContrastQuery : palmOneCameraCommon.h
  • kCamLibCtrlContrastSet : palmOneCameraCommon.h
  • kCamLibCtrlEffectsGet : palmOneCameraCommon.h
  • kCamLibCtrlEffectsQuery : palmOneCameraCommon.h
  • kCamLibCtrlEffectsSet : palmOneCameraCommon.h
  • kCamLibCtrlExposureGet : palmOneCameraCommon.h
  • kCamLibCtrlExposureQuery : palmOneCameraCommon.h
  • kCamLibCtrlExposureSet : palmOneCameraCommon.h
  • kCamLibCtrlHardwareSettingsDlg : palmOneCameraCommon.h
  • kCamLibCtrlLightingGet : palmOneCameraCommon.h
  • kCamLibCtrlLightingQuery : palmOneCameraCommon.h
  • kCamLibCtrlLightingSet : palmOneCameraCommon.h
  • kCamLibCtrlPowerOff : palmOneCameraCommon.h
  • kCamLibCtrlPowerOn : palmOneCameraCommon.h
  • kCamLibCtrlPreviewAreaGet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewAreaSet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewRectGet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewRectSet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewSizeGet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewSizeQuery : palmOneCameraCommon.h
  • kCamLibCtrlPreviewSizeSet : palmOneCameraCommon.h
  • kCamLibCtrlPreviewStart : palmOneCameraCommon.h
  • kCamLibCtrlPreviewStop : palmOneCameraCommon.h
  • kCamLibCtrlSaturationGet : palmOneCameraCommon.h
  • kCamLibCtrlSaturationQuery : palmOneCameraCommon.h
  • kCamLibCtrlSaturationSet : palmOneCameraCommon.h
  • kCamLibCtrlSharpnessGet : palmOneCameraCommon.h
  • kCamLibCtrlSharpnessQuery : palmOneCameraCommon.h
  • kCamLibCtrlSharpnessSet : palmOneCameraCommon.h
  • kCamLibCtrlShutterSpeedGet : palmOneCameraCommon.h
  • kCamLibCtrlShutterSpeedQuery : palmOneCameraCommon.h
  • kCamLibCtrlShutterSpeedSet : palmOneCameraCommon.h
  • kCamLibCtrlStatusGet : palmOneCameraCommon.h
  • kCamLibCtrlStatusQuery : palmOneCameraCommon.h
  • kCamLibCtrlStreamBufNumGet : palmOneCameraCommon.h
  • kCamLibCtrlStreamBufNumQuery : palmOneCameraCommon.h
  • kCamLibCtrlStreamBufNumSet : palmOneCameraCommon.h
  • kCamLibCtrlStreamFormatGet : palmOneCameraCommon.h
  • kCamLibCtrlStreamFormatQuery : palmOneCameraCommon.h
  • kCamLibCtrlStreamFormatSet : palmOneCameraCommon.h
  • kCamLibCtrlStreamPreviewGet : palmOneCameraCommon.h
  • kCamLibCtrlStreamPreviewQuery : palmOneCameraCommon.h
  • kCamLibCtrlStreamPreviewSet : palmOneCameraCommon.h
  • kCamLibCtrlStreamSizeGet : palmOneCameraCommon.h
  • kCamLibCtrlStreamSizeQuery : palmOneCameraCommon.h
  • kCamLibCtrlStreamSizeSet : palmOneCameraCommon.h
  • kCamLibCtrlStreamStart : palmOneCameraCommon.h
  • kCamLibCtrlStreamStop : palmOneCameraCommon.h
  • kCamLibCtrlStreamUnlockFrame : palmOneCameraCommon.h
  • kCamLibCtrlStreamWaitForFrame : palmOneCameraCommon.h
  • kCamLibCtrlWhiteBalanceGet : palmOneCameraCommon.h
  • kCamLibCtrlWhiteBalanceQuery : palmOneCameraCommon.h
  • kCamLibCtrlWhiteBalanceSet : palmOneCameraCommon.h
  • kCamLibCtrlZoomGet : palmOneCameraCommon.h
  • kCamLibCtrlZoomQuery : palmOneCameraCommon.h
  • kCamLibCtrlZoomSet : palmOneCameraCommon.h
  • kCamLibEffectsBlackWhite : palmOneCameraCommon.h
  • kCamLibEffectsBluish : palmOneCameraCommon.h
  • kCamLibEffectsNegative : palmOneCameraCommon.h
  • kCamLibEffectsNormal : palmOneCameraCommon.h
  • kCamLibEffectsSepia : palmOneCameraCommon.h
  • kCamLibErrAllFramesLocked : palmOneCameraCommon.h
  • kCamLibErrBadParam : palmOneCameraCommon.h
  • kCamLibErrInternal : palmOneCameraCommon.h
  • kCamLibErrNoMemory : palmOneCameraCommon.h
  • kCamLibErrNoPower : palmOneCameraCommon.h
  • kCamLibErrNotCompatible : palmOneCameraCommon.h
  • kCamLibErrNotOpen : palmOneCameraCommon.h
  • kCamLibErrNotSupported : palmOneCameraCommon.h
  • kCamLibErrStillOpen : palmOneCameraCommon.h
  • kCamLibExposureAuto : palmOneCameraCommon.h
  • kCamLibExposureManual : palmOneCameraCommon.h
  • kCamLibFtrCaptureVersion : palmOneCameraCommon.h
  • kCamLibFtrVersionNum : palmOneCameraCommon.h
  • kCamLibImageSizeCIF : palmOneCameraCommon.h
  • kCamLibImageSizeQCIF : palmOneCameraCommon.h
  • kCamLibImageSizeQQVGA : palmOneCameraCommon.h
  • kCamLibImageSizeQVGA : palmOneCameraCommon.h
  • kCamLibImageSizeSXGA : palmOneCameraCommon.h
  • kCamLibImageSizeSXGA1024 : palmOneCameraCommon.h
  • kCamLibImageSizeSXGA960 : palmOneCameraCommon.h
  • kCamLibImageSizeVGA : palmOneCameraCommon.h
  • kCamLibLightingLow : palmOneCameraCommon.h
  • kCamLibLightingNormal : palmOneCameraCommon.h
  • kCamLibName : palmOneCameraCommon.h
  • kCamLibSaturationManual : palmOneCameraCommon.h
  • kCamLibSharpnessManual : palmOneCameraCommon.h
  • kCamLibShutterSpeedAuto : palmOneCameraCommon.h
  • kCamLibShutterSpeedManual : palmOneCameraCommon.h
  • kCamLibStatusInPreview : palmOneCameraCommon.h
  • kCamLibStatusInStillCapture : palmOneCameraCommon.h
  • kCamLibStatusInVideoCapture : palmOneCameraCommon.h
  • kCamLibStatusPoweredOn : palmOneCameraCommon.h
  • kCamLibStreamPreviewOff : palmOneCameraCommon.h
  • kCamLibStreamPreviewOn : palmOneCameraCommon.h
  • kCamLibType : palmOneCameraCommon.h
  • kCamLibWhiteBalanceAuto : palmOneCameraCommon.h
  • kCamLibWhiteBalanceCloudy : palmOneCameraCommon.h
  • kCamLibWhiteBalanceExtra : palmOneCameraCommon.h
  • kCamLibWhiteBalanceFluorescent : palmOneCameraCommon.h
  • kCamLibWhiteBalanceIncandescent : palmOneCameraCommon.h
  • kCamLibWhiteBalanceIndoor : palmOneCameraCommon.h
  • kCamLibWhiteBalanceOutdoor : palmOneCameraCommon.h
  • kCamLibWhiteBalanceShade : palmOneCameraCommon.h
  • kCamLibWhiteBalanceSunny : palmOneCameraCommon.h
  • kCamLibWhiteBalanceTwilight : palmOneCameraCommon.h
  • kCamLibZoomManual : palmOneCameraCommon.h
  • kCamSliderCreator : palmOneCameraSlider.h
  • kCamSliderFlagsOpened : palmOneCameraSlider.h
  • kCamSliderFtrFlagsNum : palmOneCameraSlider.h
  • kCamSliderFtrVersionNum : palmOneCameraSlider.h
  • kCamSliderNotifyEvent : palmOneCameraSlider.h
  • kCamSliderVersion : palmOneCameraSlider.h
  • kCamSliderVersion1 : palmOneCameraSlider.h
  • kCarrierCustomizationCLibName : CarrierCustomLibTypes.h
  • kCarrierListDBName : CarrierCustomLibTypes.h
  • kCCLibType : CarrierCustomLibTypes.h
  • kCigarSmiley : SmartTextEngineDef.h
  • kClownSmiley : SmartTextEngineDef.h
  • kCodecErrAlignment : palmOneCodecPluginMgrCommon.h
  • kCodecErrBadParam : palmOneCodecPluginMgrCommon.h
  • kCodecErrBufferOverrun : palmOneCodecPluginMgrCommon.h
  • kCodecErrBufferUnderrun : palmOneCodecPluginMgrCommon.h
  • kCodecErrFrameError : palmOneCodecPluginMgrCommon.h
  • kCodecErrInvalidHeader : palmOneCodecPluginMgrCommon.h
  • kCodecErrInvalidState : palmOneCodecPluginMgrCommon.h
  • kCodecErrNoMemory : palmOneCodecPluginMgrCommon.h
  • kCodecErrParsing : palmOneCodecPluginMgrCommon.h
  • kCodecErrUnAuthorized : palmOneCodecPluginMgrCommon.h
  • kCodecErrUnknown : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibBadVersion : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibCreator : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibErrBadParam : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibErrInternal : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibErrorClass : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibErrStillOpen : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibName : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibNoCodec : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibNotSupported : palmOneCodecPluginMgrCommon.h
  • kCodecMgrLibType : palmOneCodecPluginMgrCommon.h
  • kCodecPluginErrorClass : palmOneCodecPluginMgrCommon.h
  • kCodecSyncNotFound : palmOneCodecPluginMgrCommon.h
  • kDeltaCharacter : SmartTextEngineDef.h
  • kDevilSmiley : SmartTextEngineDef.h
  • kFileBrowserLibFlagNoDirChange : FileBrowserLibCommon.h
  • kFileBrowserLibFlagNoFiles : FileBrowserLibCommon.h
  • kFileBrowserLibFlagNoFolders : FileBrowserLibCommon.h
  • kFileBrowserLibFlagNoNewFolder : FileBrowserLibCommon.h
  • kFileBrowserLibFlagNoSubDir : FileBrowserLibCommon.h
  • kFileBrowserLibFlagOneVolume : FileBrowserLibCommon.h
  • kFileBrowserLibFlagPromptOverwrite : FileBrowserLibCommon.h
  • kFileBrowserLibFlagRequireExtension : FileBrowserLibCommon.h
  • kFileBrowserLibName : FileBrowserLibCommon.h
  • kFlipSmiley : SmartTextEngineDef.h
  • kFrownSmiley : SmartTextEngineDef.h
  • kGammaCharacter : SmartTextEngineDef.h
  • kHALLEDCapcitySleepMultiColor : PalmLED.h
  • kHALLEDCapcitySleepOn : PalmLED.h
  • kHALLEDCapcitySleepPattern : PalmLED.h
  • kHALLEDCapcitySleepPatternSetting : PalmLED.h
  • kHALLEDPropertySleepColorAmberWhite : PalmLED.h
  • kHALLEDPropertySleepColorBlue : PalmLED.h
  • kHALLEDPropertySleepColorGreen : PalmLED.h
  • kHALLEDPropertySleepColorRed : PalmLED.h
  • kHALLEDPropertySleepOn : PalmLED.h
  • kHALLEDPropertySleepPattern : PalmLED.h
  • kHALLEDPropertySleepReserve : PalmLED.h
  • kHeartSmiley : SmartTextEngineDef.h
  • kHelperServiceClassIDMMS : MmsHelperCommon.h
  • kHiResTimeErrorClass : palmOneHiResTimerCommon.h, PalmHiResTime.h
  • kHiResTimeLibCreator : palmOneHiResTimerCommon.h, PalmHiResTime.h
  • kHiResTimeLibErrBadParam : palmOneHiResTimerCommon.h
  • kHiResTimeLibErrNotAvailable : palmOneHiResTimerCommon.h
  • kHiResTimeLibErrNotOpen : palmOneHiResTimerCommon.h
  • kHiResTimeLibErrStillOpen : palmOneHiResTimerCommon.h
  • kHiResTimeLibName : palmOneHiResTimerCommon.h, PalmHiResTime.h
  • kHiResTimeLibType : palmOneHiResTimerCommon.h, PalmHiResTime.h
  • kHiResTimeLibVersion : palmOneHiResTimerCommon.h
  • kHiResTimeLibVersion1 : palmOneHiResTimerCommon.h
  • kHiResTimeLibVersion2 : palmOneHiResTimerCommon.h
  • kImageFilenameLength : ImageLibCommon.h
  • kInvalidRecIndex : ImageLibCommon.h
  • kIOTACertMaxBlocks : HsPhoneIOTATypes.h
  • kLambdaCharacter : SmartTextEngineDef.h
  • kLcdOverlayLibCreator : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibCtrlDraw : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibCtrlFormatGet : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibCtrlFormatQuery : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibCtrlFormatSet : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibCtrlRectGet : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibCtrlRectSet : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibCtrlStart : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibCtrlStop : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibDataFormatRGB565 : palmOneLcdOverlayCommon.h
  • kLcdOverlayLibErrBadParam : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibErrInternal : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibErrNoMemory : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibErrNotCompatible : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibErrNotOpen : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibErrNotSupported : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibErrorClass : palmOneLcdOverlayCommon.h
  • kLcdOverlayLibErrStillOpen : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibName : palmOneLcdOverlayCommon.h
  • kLcdOverlayLibType : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h
  • kLcdOverlayLibVersion : palmOneLcdOverlayCommon.h
  • kLcdOverlayLibVersion1 : palmOneLcdOverlayCommon.h
  • kLFlipSmiley : SmartTextEngineDef.h
  • kLocDBMaxLocNameLength : LocsLibCommon.h
  • kLocDBTypeCustom : LocsLibCommon.h
  • kLocDBTypeDefault : LocsLibCommon.h
  • kLocDBVersion : LocsLibCommon.h
  • kLocDisplayInCustom : LocsLibCommon.h
  • kLocNoDisplayInCustom : LocsLibCommon.h
  • kLocsFileCLocsLib : LocsLibCommon.h
  • kLocsLibFtrNumRefNum : LocsLibCommon.h
  • kLocsLibName : LocsLibCommon.h
  • kMaxPhoneNumberLen : HsPhoneNetworkTypes.h
  • kMaxTonesNameSize : TonesLibTypes.h
  • kMaxVPNAccountNameLength : PalmVPPI.h
  • kMMSPixPlaceMaxLen : HsPhoneSMSTypes.h
  • kMMSStringMaxLen : HsPhoneSMSTypes.h
  • kNetDriverDateLength : PalmNetServices.h
  • kNetFWNameLength : PalmNetServices.h
  • kNetSerialNumberLength : PalmNetServices.h
  • kNetworkListDBName : CarrierCustomLibTypes.h
  • kOmegaCharacter : SmartTextEngineDef.h
  • kOMouthSmiley : SmartTextEngineDef.h
  • kPalmAudioPlaybackActionCodeRequestResume : PalmAudioPlayback.h
  • kPalmAudioPlaybackActionCodeRequestStop : PalmAudioPlayback.h
  • kPalmAudioPlaybackCreator : PalmAudioPlayback.h
  • kPalmAudioPlaybackNotifyEvent : PalmAudioPlayback.h
  • kPalmAudioPlaybackNotifyVersion : PalmAudioPlayback.h
  • kPalmCompanyIDHandspring : palmOneResources.h
  • kPalmCompanyIDOldPalm : palmOneResources.h
  • kPalmCompanyIDPalm : palmOneResources.h
  • kPalmCreatorIDLcdState : palmOneCreators.h
  • kPalmCreatorIDNetSlipHack : palmOneCreators.h
  • kPalmDeviceIDTX : palmOneResources.h
  • kPalmDeviceIDZ22 : palmOneResources.h
  • kPalmOneDeviceIDAngus : palmOneResources.h
  • kPalmOneDeviceIDDevice3 : palmOneResources.h
  • kPalmOneDeviceIDDevice4 : palmOneResources.h
  • kPalmOneDeviceIDDevice5 : palmOneResources.h
  • kPalmOneDeviceIDDevice6 : palmOneResources.h
  • kPalmOneDeviceIDDevice7 : palmOneResources.h
  • kPalmOneDeviceIDDevice8 : palmOneResources.h
  • kPalmOneDeviceIDDevice9 : palmOneResources.h
  • kPalmOneDeviceIDDeviceA : palmOneResources.h
  • kPalmOneDeviceIDLowrider : palmOneResources.h
  • kPalmOneDeviceIDTreo600 : palmOneResources.h
  • kPalmOneDeviceIDTreo600Sim : palmOneResources.h
  • kPalmOneDeviceIDTreo650 : palmOneResources.h
  • kPalmOneDeviceIDTreo650Sim : palmOneResources.h
  • kPalmOneDeviceIDTungstenC : palmOneResources.h
  • kPalmOneDeviceIDTungstenE2 : palmOneResources.h
  • kPalmOneDeviceIDTungstenT : palmOneResources.h
  • kPalmOneDeviceIDTungstenT2 : palmOneResources.h
  • kPalmOneDeviceIDTungstenT3 : palmOneResources.h
  • kPalmOneDeviceIDTungstenT5 : palmOneResources.h
  • kPalmOneDeviceIDTungstenTE : palmOneResources.h
  • kPalmOneDeviceIDTungstenW : palmOneResources.h
  • kPalmOneDeviceIDTungstenX : palmOneResources.h
  • kPalmOneDeviceIDVentura : palmOneResources.h
  • kPalmOneDeviceIDZire : palmOneResources.h
  • kPalmOneDeviceIDZire21 : palmOneResources.h
  • kPalmOneDeviceIDZire31 : palmOneResources.h
  • kPalmOneDeviceIDZire71 : palmOneResources.h
  • kPalmOneDeviceIDZire72 : palmOneResources.h
  • kPhiCharacter : SmartTextEngineDef.h
  • kPiCharacter : SmartTextEngineDef.h
  • kPmKeyLibAPIMajorVersion : PmKeyLibCommon.h
  • kPmKeyLibAPIMinorVersion : PmKeyLibCommon.h
  • kPmKeyLibCreator : PmKeyLibCommon.h
  • kPmKeyLibFtrValAPIVersion : PmKeyLibCommon.h
  • kPmKeyLibName : PmKeyLibCommon.h
  • kPmKeyLibType : PmKeyLibCommon.h
  • kPmSysGadgetBbutGadgetMiscSelectData : PmSysGadgetLibCommon.h
  • kPmSysGadgetBbutGadgetMiscSelectSelector : PmSysGadgetLibCommon.h
  • kPmSysGadgetBbutRscType : PmSysGadgetLibCommon.h
  • kPmSysGadgetFtrIDStatusGadgetRev : PmSysGadgetLibCommon.h
  • kPmSysGadgetFtrValStatusGadgetRev1 : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibCreator : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibName : PmSysGadgetLibCommon.h
  • kPmSysGadgetLibType : PmSysGadgetLibCommon.h
  • kPmUIUtilLibAPIMajorVersion : PmUIUtilLibCommon.h
  • kPmUIUtilLibAPIMinorVersion : PmUIUtilLibCommon.h
  • kPmUIUtilLibCreator : PmUIUtilLibCommon.h
  • kPmUIUtilLibFtrValAPIVersion : PmUIUtilLibCommon.h
  • kPmUIUtilLibName : PmUIUtilLibCommon.h
  • kPmUIUtilLibType : PmUIUtilLibCommon.h
  • kPsiCharacter : SmartTextEngineDef.h
  • kPukeSmiley : SmartTextEngineDef.h
  • kPwrBatteryStateBroadcaster : PalmPower.h
  • kPwrBatteryStateNotifyEvent : PalmPower.h
  • kQuestionSmiley : SmartTextEngineDef.h
  • kRFlipSmiley : SmartTextEngineDef.h
  • kScrollToEnd : SmartTextEngineDef.h
  • kSelectUntilEnd : SmartTextEngineDef.h
  • kSelectUntilEndOfRecord : SmartTextEngineDef.h
  • kSigmaCharacter : SmartTextEngineDef.h
  • kSmartTextBit : SmartTextEngineDef.h
  • kSmileSmiley : SmartTextEngineDef.h
  • kSmirkSmiley : SmartTextEngineDef.h
  • kSndFileStreamFileSpecFlagFileStream : palmOneSndFileStream.h
  • kSndFileStreamFileSpecFlagVFS : palmOneSndFileStream.h
  • kSndFileStreamLibCreator : palmOneSndFileStream.h
  • kSndFileStreamLibName : palmOneSndFileStream.h
  • kSndFileStreamLibType : palmOneSndFileStream.h
  • kSndFileStreamLibVersion : palmOneSndFileStream.h
  • kSndFileTypeAAC : palmOneSndFileStream.h
  • kSndFileTypeAMR : palmOneSndFileStream.h
  • kSndFileTypeMP3 : palmOneSndFileStream.h
  • kSndFileTypeQCP : palmOneSndFileStream.h
  • kSndFileTypeWAV : palmOneSndFileStream.h
  • kSTEBitmap : SmartTextEngineDef.h
  • kSTEBlack : SmartTextEngineDef.h
  • kSTEBlackFont : SmartTextEngineDef.h
  • kSTEBlackInverse : SmartTextEngineDef.h
  • kSTEBlue : SmartTextEngineDef.h
  • kSTEBlueFont : SmartTextEngineDef.h
  • kSTEBlueInverse : SmartTextEngineDef.h
  • kSTECenterAlign : SmartTextEngineDef.h
  • kSTECharacterBitmap : SmartTextEngineDef.h
  • kSTECurrentFont : SmartTextEngineDef.h
  • kSTEGray : SmartTextEngineDef.h
  • kSTEGrayFont : SmartTextEngineDef.h
  • kSTEGrayInverse : SmartTextEngineDef.h
  • kSTEGreen : SmartTextEngineDef.h
  • kSTEGreenFont : SmartTextEngineDef.h
  • kSTEGreenInverse : SmartTextEngineDef.h
  • kSTEHorizontalLine : SmartTextEngineDef.h
  • kSTEHyperlink : SmartTextEngineDef.h
  • kSTELeftIndent : SmartTextEngineDef.h
  • kSTELineBreak : SmartTextEngineDef.h
  • kSTEOrange : SmartTextEngineDef.h
  • kSTEOrangeFont : SmartTextEngineDef.h
  • kSTEOrangeInverse : SmartTextEngineDef.h
  • kSTEPurple : SmartTextEngineDef.h
  • kSTEPurpleFont : SmartTextEngineDef.h
  • kSTEPurpleInverse : SmartTextEngineDef.h
  • kSTERed : SmartTextEngineDef.h
  • kSTERedFont : SmartTextEngineDef.h
  • kSTERedInverse : SmartTextEngineDef.h
  • kSTERightAlign : SmartTextEngineDef.h
  • kSTESmileyBitmap : SmartTextEngineDef.h
  • kSTEYellow : SmartTextEngineDef.h
  • kSTEYellowFont : SmartTextEngineDef.h
  • kSTEYellowInverse : SmartTextEngineDef.h
  • kStraightMouthSmiley : SmartTextEngineDef.h
  • kThetaCharacter : SmartTextEngineDef.h
  • kTonesDialogFlagNonModal : TonesLibTypes.h
  • kTonesLibVersionEscalation : TonesLib.h
  • kTongueSmiley : SmartTextEngineDef.h
  • kUFlipSmiley : SmartTextEngineDef.h
  • kUndefinedPosition : LocsLibCommon.h
  • kUSB500mACharge : palmOneFeatures.h
  • kUSBConsole : palmOneFeatures.h
  • kUSBDriveMode : palmOneFeatures.h
  • kUSBDUN : palmOneFeatures.h
  • kUSBFSClient : palmOneFeatures.h
  • kUSBFSOnTheGo : palmOneFeatures.h
  • kUSBFSOnTheGoMultiDevice : palmOneFeatures.h
  • kUSBHotSync : palmOneFeatures.h
  • kUSBHSClient : palmOneFeatures.h
  • kUSBHSOnTheGo : palmOneFeatures.h
  • kUSBHSOnTheGoMultiDevice : palmOneFeatures.h
  • kUSBLogging : palmOneFeatures.h
  • kUSBMiniConnector : palmOneFeatures.h
  • kUSBMTP : palmOneFeatures.h
  • kUSBMultiConnector : palmOneFeatures.h
  • kUSBTransfer : palmOneFeatures.h
  • kWinkSmiley : SmartTextEngineDef.h
  • kXiCharacter : SmartTextEngineDef.h
  • kYinYangSmiley : SmartTextEngineDef.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- l -

  • LaunchWithCommand : HsAppLaunchCmd.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- m -

  • MAX_ACTIVE_PROFILES : PalmNetServices.h
  • MAX_LONGOPERATORNAME_LENGTH : HsPhoneNetworkTypes.h
  • MAX_PLANE_COUNT : palmOneCodecFormat.h
  • maxDB4ecioLevel0 : HsPhoneTypes.h
  • maxDB4ecioLevel1 : HsPhoneTypes.h
  • maxDB4ecioLevel2 : HsPhoneTypes.h
  • maxDB4ecioLevel3 : HsPhoneTypes.h
  • maxDBm4signalLevel0 : HsPhoneTypes.h
  • maxDBm4signalLevel1 : HsPhoneTypes.h
  • maxDBm4signalLevel2 : HsPhoneTypes.h
  • maxDBm4signalLevel3 : HsPhoneTypes.h
  • maxPasswordLen : HsPhoneNetworkTypes.h
  • Minimum16bitTextHeader : HsPhoneSMSTypes.h
  • Minimum8bitTextHeader : HsPhoneSMSTypes.h
  • minPasswordLen : HsPhoneNetworkTypes.h
  • MM_MAX_ATTACHMENTS : PalmVMLaunch.h
  • MMPRO_ADD_MESSAGE_WITH_ATTACHMENT : PalmVMLaunch.h
  • MMPRO_LAUNCH_CODE : PalmVMLaunch.h
  • MMPRO_PLUGIN_EXTENDED_QUERY_LAUNCHCODE : PalmVMPlugin.h
  • MMPRO_PLUGIN_GET_INFO_LAUNCHCODE : PalmVMPlugin.h
  • MMPRO_PLUGIN_LAUNCHCODE : PalmVMPlugin.h
  • MMPRO_PLUGIN_QUERY_LAUNCHCODE : PalmVMPlugin.h
  • MMPRO_PLUGIN_RECEIVE_LAUNCHCODE : PalmVMPlugin.h
  • MMPRO_PLUGIN_SEND_LAUNCHCODE : PalmVMPlugin.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- n -

  • NBSHeaderEscapeSeq : HsPhoneSMSTypes.h
  • NBSHeaderID : HsPhoneSMSTypes.h
  • NBSHeaderIDLen : HsPhoneSMSTypes.h
  • NBSTextHeader : HsPhoneSMSTypes.h
  • NBSTextHeaderLength : HsPhoneSMSTypes.h
  • net80211ResetWepPasscode : PalmWiFiCommon.h
  • netMacAddrLength : PalmWiFiCommon.h
  • netMasterAnchorTimeoutDefault : NetMasterLibTypes.h
  • netMasterClientCurrentEventVersion : NetMasterLibTypes.h
  • netMasterClientEventNotificationTypeID : NetMasterLibTypes.h
  • netMasterErrAuthReqDuringBGLogin : NetMasterLibErrors.h
  • netMasterErrAutoLoginNotPossible : NetMasterLibErrors.h
  • netMasterErrBadArg : NetMasterLibErrors.h
  • netMasterErrBadPort : NetMasterLibErrors.h
  • netMasterErrCDMACarrierNetworkBusy : NetMasterLibErrors.h
  • netMasterErrClass : NetMasterLibErrors.h
  • netMasterErrConfigFailed : NetMasterLibErrors.h
  • netMasterErrConfigNotFound : NetMasterLibErrors.h
  • netMasterErrDispatchTable : NetMasterLibErrors.h
  • netMasterErrGPRSGenLoginErr : NetMasterLibErrors.h
  • netMasterErrInternalConnWouldBeImpossible : NetMasterLibErrors.h
  • netMasterErrMemory : NetMasterLibErrors.h
  • netMasterErrMIPFailed : NetMasterLibErrors.h
  • netMasterErrMIPReserved2 : NetMasterLibErrors.h
  • netMasterErrMIPReserved3 : NetMasterLibErrors.h
  • netMasterErrMIPReserved4 : NetMasterLibErrors.h
  • netMasterErrMIPUsernameSuspension801 : NetMasterLibErrors.h
  • netMasterErrNetGuardReqDuringBGLogin : NetMasterLibErrors.h
  • netMasterErrNetNotInstalled : NetMasterLibErrors.h
  • netMasterErrNo1xService : NetMasterLibErrors.h
  • netMasterErrNoNetPrefLib : NetMasterLibErrors.h
  • netMasterErrNoOneXServiceWhileRoaming : NetMasterLibErrors.h
  • netMasterErrOneXServiceNotEnabled : NetMasterLibErrors.h
  • netMasterErrOneXServiceUnavailable : NetMasterLibErrors.h
  • netMasterErrStorage : NetMasterLibErrors.h
  • netMasterErrUIRPCTimeout : NetMasterLibErrors.h
  • netMasterLibCreatorID : NetMasterLibTarget.h
  • netMasterLibName : NetMasterLibTarget.h
  • netMasterLibTypeID : NetMasterLibTarget.h
  • netMediaConnected : PalmWiFiCommon.h
  • netMediaDisconnected : PalmWiFiCommon.h
  • netNum80211Rates : PalmWiFiCommon.h
  • netPref1xRTTTunnelingDefault : NetPrefLibTypes.h
  • netPrefErrBadArg : NetPrefLibErrors.h
  • netPrefErrCCSMIncomplete : NetPrefLibErrors.h
  • netPrefErrCCSMNoCarrierMatch : NetPrefLibErrors.h
  • netPrefErrClass : NetPrefLibErrors.h
  • netPrefErrCSDNotAllowed : NetPrefLibErrors.h
  • netPrefErrFieldNotInSet : NetPrefLibErrors.h
  • netPrefErrMemory : NetPrefLibErrors.h
  • netPrefErrNoCCSMSettings : NetPrefLibErrors.h
  • netPrefErrNVRead : NetPrefLibErrors.h
  • netPrefErrNVSync : NetPrefLibErrors.h
  • netPrefErrNVWrite : NetPrefLibErrors.h
  • netPrefErrNVWritePDPInUse : NetPrefLibErrors.h
  • netPrefErrPhoneLibOpenFailed : NetPrefLibErrors.h
  • netPrefErrRadioIsOff : NetPrefLibErrors.h
  • netPrefErrReadOnlyField : NetPrefLibErrors.h
  • netPrefErrRecGone : NetPrefLibErrors.h
  • netPrefErrRecNotSaved : NetPrefLibErrors.h
  • netPrefErrStorage : NetPrefLibErrors.h
  • netPrefLibCreatorID : NetPrefLibTarget.h
  • netPrefLibName : NetPrefLibTarget.h
  • netPrefLibTypeID : NetPrefLibTarget.h
  • netPrefMaxPhoneStringSize : NetPrefLibTypes.h
  • netPrefRecFieldAttrDirty : NetPrefLibTypes.h
  • netPrefRecFieldAttrInSet : NetPrefLibTypes.h
  • netPrefRecFieldViewCache : NetPrefLibTypes.h
  • netPrefRecFieldViewClearAll : NetPrefLibTypes.h
  • netPrefRecFieldViewEditable : NetPrefLibTypes.h
  • netPrefRecFieldViewExternal : NetPrefLibTypes.h
  • netPrefRecFieldViewPrivate : NetPrefLibTypes.h
  • netPrefRecFieldViewRead : NetPrefLibTypes.h
  • netPrefRecFieldViewVisible : NetPrefLibTypes.h
  • netPrefRecFieldViewWrite : NetPrefLibTypes.h
  • netSSIDMaxLength : PalmWiFiCommon.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- o -

  • oemErrorClass : PalmErrorBase.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- b -

  • bbutGadgetMiscSelectData : HsExtUtilBigButtonCommon.h
  • bbutGadgetMiscSelectSelector : HsExtUtilBigButtonCommon.h
  • bgServiceCreatorID : PalmBGService.h
  • bgServiceLibName : PalmBGService.h
  • bgServiceType : PalmBGService.h
  • BSSINFO_ANL_OFFSET : PalmWiFiCommon.h
  • BSSINFO_ANL_SIZE : PalmWiFiCommon.h
  • BSSINFO_ANL_VFLAG : PalmWiFiCommon.h
  • BSSINFO_ATIM_WINDOW_OFFSET : PalmWiFiCommon.h
  • BSSINFO_ATIM_WINDOW_SIZE : PalmWiFiCommon.h
  • BSSINFO_ATIM_WINDOW_VFLAG : PalmWiFiCommon.h
  • BSSINFO_BEACON_PERIOD_OFFSET : PalmWiFiCommon.h
  • BSSINFO_BEACON_PERIOD_SIZE : PalmWiFiCommon.h
  • BSSINFO_BEACON_PERIOD_VFLAG : PalmWiFiCommon.h
  • BSSINFO_CHID_OFFSET : PalmWiFiCommon.h
  • BSSINFO_CHID_SIZE : PalmWiFiCommon.h
  • BSSINFO_CHID_VFLAG : PalmWiFiCommon.h
  • BSSINFO_DSFREQ_OFFSET : PalmWiFiCommon.h
  • BSSINFO_DSFREQ_SIZE : PalmWiFiCommon.h
  • BSSINFO_DSFREQ_VFLAG : PalmWiFiCommon.h
  • BSSINFO_HOPDWELL_OFFSET : PalmWiFiCommon.h
  • BSSINFO_HOPDWELL_SIZE : PalmWiFiCommon.h
  • BSSINFO_HOPDWELL_VFLAG : PalmWiFiCommon.h
  • BSSINFO_HOPPATTERN_OFFSET : PalmWiFiCommon.h
  • BSSINFO_HOPPATTERN_SIZE : PalmWiFiCommon.h
  • BSSINFO_HOPPATTERN_VFLAG : PalmWiFiCommon.h
  • BSSINFO_HOPSET_OFFSET : PalmWiFiCommon.h
  • BSSINFO_HOPSET_SIZE : PalmWiFiCommon.h
  • BSSINFO_HOPSET_VFLAG : PalmWiFiCommon.h
  • BSSINFO_MAC_ADDR_OFFSET : PalmWiFiCommon.h
  • BSSINFO_MAC_ADDR_SIZE : PalmWiFiCommon.h
  • BSSINFO_MAC_ADDR_VFLAG : PalmWiFiCommon.h
  • BSSINFO_NETWORK_MODE_OFFSET : PalmWiFiCommon.h
  • BSSINFO_NETWORK_MODE_SIZE : PalmWiFiCommon.h
  • BSSINFO_NETWORK_MODE_VFLAG : PalmWiFiCommon.h
  • BSSINFO_NETWORK_TYPE_OFFSET : PalmWiFiCommon.h
  • BSSINFO_NETWORK_TYPE_SIZE : PalmWiFiCommon.h
  • BSSINFO_NETWORK_TYPE_VFLAG : PalmWiFiCommon.h
  • BSSINFO_RSSI_OFFSET : PalmWiFiCommon.h
  • BSSINFO_RSSI_SIZE : PalmWiFiCommon.h
  • BSSINFO_RSSI_VFLAG : PalmWiFiCommon.h
  • BSSINFO_SIZE : PalmWiFiCommon.h
  • BSSINFO_SSID_OFFSET : PalmWiFiCommon.h
  • BSSINFO_SSID_SIZE : PalmWiFiCommon.h
  • BSSINFO_SSID_VFLAG : PalmWiFiCommon.h
  • BSSINFO_SSIDLENGTH_OFFSET : PalmWiFiCommon.h
  • BSSINFO_SSIDLENGTH_SIZE : PalmWiFiCommon.h
  • BSSINFO_SSIDLENGTH_VFLAG : PalmWiFiCommon.h
  • BSSINFO_SUPPORTED_RATES_OFFSET : PalmWiFiCommon.h
  • BSSINFO_SUPPORTED_RATES_SIZE : PalmWiFiCommon.h
  • BSSINFO_SUPPORTED_RATES_VFLAG : PalmWiFiCommon.h
  • BSSINFO_VFLAG : PalmWiFiCommon.h
  • BSSINFO_VFLAG_SIZE : PalmWiFiCommon.h
  • BSSINFO_WEP_OFFSET : PalmWiFiCommon.h
  • BSSINFO_WEP_SIZE : PalmWiFiCommon.h
  • BSSINFO_WEP_VFLAG : PalmWiFiCommon.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- c -

  • CallWithCommand : HsAppLaunchCmd.h
  • cameraAppLaunchCmdStopPreview : HsAppLaunchCmd.h
  • ccsmErrBufferTooSmall : CarrierCustomLibErr.h
  • ccsmErrClass : CarrierCustomLibErr.h
  • ccsmErrInvalidArg : CarrierCustomLibErr.h
  • ccsmErrLibUninitialized : CarrierCustomLibErr.h
  • ccsmErrMemory : CarrierCustomLibErr.h
  • ccsmErrNotRegistered : CarrierCustomLibErr.h
  • ccsmErrPhoneLibLoad : CarrierCustomLibErr.h
  • ccsmErrPhoneNotPowered : CarrierCustomLibErr.h
  • ccsmErrProfileUnspecified : CarrierCustomLibErr.h
  • ccsmErrUndefinedField : CarrierCustomLibErr.h
  • ccsmErrUnimplemented : CarrierCustomLibErr.h
  • ccsmErrUnknownCarrier : CarrierCustomLibErr.h
  • ccsmErrUnknownField : CarrierCustomLibErr.h
  • ccsmErrUnknownSetting : CarrierCustomLibErr.h
  • ccsmErrUnspecified : CarrierCustomLibErr.h
  • codecDriverIMAADPCM : PalmSoundCustomCtrl.h
  • codecIMAADPCMSetBlockSize : PalmSoundCustomCtrl.h
  • CompareToneIdentifiers : TonesLibTypes.h
  • CopyMIDIToneIdentifier : TonesLibTypes.h
  • CopyToneIdentifier : TonesLibTypes.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- d -

  • dbCacheFlag : PmPalmOSNVFS.h
  • DEFAULTHELPERLIB_TRAP : DefaultHelperLib.h
  • defaultHelperLibCreator : DefaultHelperLibTypes.h
  • defaultHelperLibName : DefaultHelperLibTypes.h
  • defaultHelperLibType : DefaultHelperLibTypes.h
  • densityFtrCreator : palmOneFeatures.h
  • devAppLaunchCmdCallerId : PalmLaunchCodes.h
  • devAppLaunchCmdCustomBase : PalmLaunchCodes.h
  • devAppLaunchCmdGenericCall : PalmLaunchCodes.h
  • devAppLaunchCmdIncomingCall : PalmLaunchCodes.h
  • devAppLaunchCmdIncomingCallTest : PalmLaunchCodes.h
  • devAppLaunchCmdSliderClosed : PalmLaunchCodes.h
  • devAppLaunchCmdSliderOpened : PalmLaunchCodes.h
  • devAppLaunchCmdTelPowerOn : PalmLaunchCodes.h
  • devAppLaunchGenericCallOpCustomBase : PalmLaunchCodes.h
  • devAppLaunchGenericCallOpExit : PalmLaunchCodes.h
  • devAppLaunchGenericCallOpReturn : PalmLaunchCodes.h
  • devAppLaunchGenericCallOpSubcall : PalmLaunchCodes.h
  • devAppLaunchGenericCallRetAccepted : PalmLaunchCodes.h
  • devAppLaunchGenericCallRetRejected : PalmLaunchCodes.h
  • devAppLaunchLauncherDUBegin : PalmLaunchCodes.h
  • devAppLaunchLauncherDUEnd : PalmLaunchCodes.h
  • devAppLaunchLPCM_DUBegin : PalmLaunchCodes.h
  • devAppLaunchLPCM_DUEnd : PalmLaunchCodes.h
  • devAppLaunchMyFavorite : PalmLaunchCodes.h
  • devAppLaunchWithCodeCheck : PalmLaunchCodes.h
  • dexFtrNumVersion : PalmDisplayExtent.h
  • dexLibCreator : PalmDisplayExtent.h
  • dexLibName : PalmDisplayExtent.h
  • dexLibType : PalmDisplayExtent.h
  • dpiFtrValue : palmOneFeatures.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- e -

  • ENCRYPTED_DATABASE : CarrierCustomLib.h
  • END_OF_LIST : PalmNetServices.h
  • ESS : PalmWiFiCommon.h
  • expCapabilityHidden : PmPalmOSNVFS.h
  • expCapabilityNonRemovable : PmPalmOSNVFS.h
  • expIncludePrivateSlots : PmPalmOSNVFS.h
  • expMediaType_HD : palmOneCreators.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- f -

  • favoritesDBLibCreator : FavoritesDBLibTypes.h
  • favoritesDBLibName : FavoritesDBLibTypes.h
  • favoritesDBLibType : FavoritesDBLibTypes.h
  • fontPickerCreatorID : VMFontLibCommon.h
  • fontPickerLibName : VMFontLibCommon.h
  • fontPickerType : VMFontLibCommon.h
  • Full16bitTextHeader : HsPhoneSMSTypes.h
  • Full8bitTextHeader : HsPhoneSMSTypes.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- g -

  • goLcdColorDefault : PalmGoLCDCommon.h
  • goLcdColorInverted : PalmGoLCDCommon.h
  • goLcdColorOverride : PalmGoLCDCommon.h
  • goLcdCreator : PalmGoLCDCommon.h
  • goLcdDisabled : PalmGoLCDCommon.h
  • goLcdEnabled : PalmGoLCDCommon.h
  • goLcdFtrNumVersion : PalmGoLCDCommon.h
  • goLcdGraffitiMode : PalmGoLCDCommon.h
  • goLcdGsiNormal : PalmGoLCDCommon.h
  • goLcdGsiOverride : PalmGoLCDCommon.h
  • goLcdInkDisabled : PalmGoLCDCommon.h
  • goLcdInkEnabled : PalmGoLCDCommon.h
  • GoLcdLibAPIVersion : PalmGoLCDCommon.h
  • goLcdLibCreator : PalmGoLCDCommon.h
  • goLcdLibFtrNum : PalmGoLCDCommon.h
  • goLcdLibName : PalmGoLCDCommon.h
  • goLcdLibType : PalmGoLCDCommon.h
  • goLcdModeCount : PalmGoLCDCommon.h
  • goLcdNotAvailable : PalmGoLCDCommon.h
  • goLcdNotifyStatusEvent : PalmGoLCDCommon.h
  • goLcdPenTapMode : PalmGoLCDCommon.h
  • GSMLibRingsDbName : HsPhoneGSMTypes.h
  • GSMReserved10 : HsPhoneTraps.h
  • GSMReserved11 : HsPhoneTraps.h
  • GSMReserved12 : HsPhoneTraps.h
  • GSMReserved13 : HsPhoneTraps.h
  • GSMReserved14 : HsPhoneTraps.h
  • GSMReserved15 : HsPhoneTraps.h
  • GSMReserved16 : HsPhoneTraps.h
  • GSMReserved17 : HsPhoneTraps.h
  • GSMReserved18 : HsPhoneTraps.h
  • GSMReserved19 : HsPhoneTraps.h
  • GSMReserved20 : HsPhoneTraps.h
  • GSMReserved21 : HsPhoneTraps.h
  • GSMReserved22 : HsPhoneTraps.h
  • GSMReserved7 : HsPhoneTraps.h
  • GSMReserved8 : HsPhoneTraps.h
  • GSMReserved9 : HsPhoneTraps.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- h -

  • HelperEnumerateEnqueueEntry : HsHelper.h
  • HS_AC97 : HsSoundLibCommon.h
  • HS_RDIO : HsSoundLibCommon.h
  • hsAttrPhoneTypeCDMA : HsExtCommon.h
  • hsAttrPhoneTypeGSM : HsExtCommon.h
  • hsAttrRingSwitchLoud : HsExtCommon.h
  • hsAttrRingSwitchMute : HsExtCommon.h
  • hsAttrSysActiveHotSync : HsExtCommon.h
  • hsAttrSysActiveProgress : HsExtCommon.h
  • hsBigButtonRscType : HsExtUtilBigButtonCommon.h
  • hsDeviceIDTreo180 : HsExtCommon.h
  • hsDeviceIDTreo270 : HsExtCommon.h
  • hsDeviceIDTreo300 : HsExtCommon.h
  • hsDeviceIDTreo600 : HsExtCommon.h
  • hsDeviceIDTreo600Sim : HsExtCommon.h
  • hsDeviceIDTreo90 : HsExtCommon.h
  • hsDeviceIDVisor : HsExtCommon.h
  • hsDeviceIDVisorEdge : HsExtCommon.h
  • hsDeviceIDVisorNeo : HsExtCommon.h
  • hsDeviceIDVisorPlatinum : HsExtCommon.h
  • hsDeviceIDVisorPrism : HsExtCommon.h
  • hsDeviceIDVisorPro : HsExtCommon.h
  • hsDialPrefsAutoAreaCodeLength : HsAppLaunchCmd.h
  • hsDispFtrCreator : HsExtCommon.h
  • hsDispFtrIDControllerShades : HsExtCommon.h
  • hsDispFtrIDDisplayAttributes : HsExtCommon.h
  • hsDispFtrValBulverdePxa27X : HsExtCommon.h
  • hsDispFtrValBwStn : HsExtCommon.h
  • hsDispFtrValColorOled : HsExtCommon.h
  • hsDispFtrValColorStn : HsExtCommon.h
  • hsDispFtrValColorTft : HsExtCommon.h
  • hsDispFtrValGrayOffset : HsExtCommon.h
  • hsDispFtrValOmapX10 : HsExtCommon.h
  • hsErrAppStopEvent : HsExtCommon.h
  • hsErrBufferTooSmall : HsExtCommon.h
  • hsErrCardNotInstalled : HsExtCommon.h
  • hsErrCardPatchAlreadyInstalled : HsExtCommon.h
  • hsErrCardPatchNotInstalled : HsExtCommon.h
  • hsErrFixedStorageRequired : HsExtCommon.h
  • hsErrGPRSNotAttached : HsExtCommon.h
  • hsErrIndicatorDisabled : HsExtCommon.h
  • hsErrIndicatorInvalidCap : HsExtCommon.h
  • hsErrIndicatorInvalidSequence : HsExtCommon.h
  • hsErrInUse : HsExtCommon.h
  • hsErrInvalidCardHdr : HsExtCommon.h
  • hsErrInvalidCardNum : HsExtCommon.h
  • hsErrInvalidParam : HsExtCommon.h
  • hsErrInvalidPeriod : HsExtCommon.h
  • hsErrNotEnoughPower : HsExtCommon.h
  • hsErrNotSupported : HsExtCommon.h
  • hsErrOutOfCoverage : HsExtCommon.h
  • hsErrOutOfMemory : HsExtCommon.h
  • hsErrPeriodicAlreadyInstalled : HsExtCommon.h
  • hsErrPeriodicNotInstalled : HsExtCommon.h
  • hsErrPhoneLocked : HsErrors.h
  • hsErrPhoneNotActivated : HsErrors.h
  • hsErrRadioNotRegistered : HsErrors.h
  • hsErrRadioOff : HsErrors.h
  • hsErrReadOnly : HsExtCommon.h
  • hsErrSIMMissing : HsExtCommon.h
  • hsErrSimNotReady : HsErrors.h
  • hsErrTimeOut : HsExtCommon.h
  • hsErrUnderflow : HsExtCommon.h
  • hsErrUserInterrupted : HsExtCommon.h
  • hsErrUserNoRadio : HsExtCommon.h
  • hsErrVoiceCallActive : HsErrors.h
  • hsFtrCreator : HsExtCommon.h
  • hsFtrIDBugsFixed : HsExtCommon.h
  • hsFtrIDCurrentAppOnSleep : HsExtCommon.h
  • hsFtrIDGrfAreaDisabled : HsExtCommon.h
  • hsFtrIDHardwareApiRevision : HsExtCommon.h
  • hsFtrIDKeyboardLayout : HsExtCommon.h
  • hsFtrIDLdbMgrLibRefNum : HsExtCommon.h
  • hsFtrIDModDate : HsExtCommon.h
  • hsFtrIDNavigationSupported : HsExtCommon.h
  • hsFtrIDNoMemSemaphore : HsExtCommon.h
  • hsFtrIDPowerKeyResponse : HsExtCommon.h
  • hsFtrIDRadioAttributes : HsExtCommon.h
  • hsFtrIDStatusGadgetRev : HsExtCommon.h
  • hsFtrIDTestingBootMode : HsExtCommon.h
  • hsFtrIDToneOnLidOpen : HsExtCommon.h
  • hsFtrIDTypeOfKeyboard : HsExtCommon.h
  • hsFtrIDVersion : HsExtCommon.h
  • hsFtrValCurrentAppOnSleepPhoneAppSpeedDialView : HsExtCommon.h
  • hsFtrValKeyboardBasic : HsExtCommon.h
  • hsFtrValKeyboardCommCentric : HsExtCommon.h
  • hsFtrValKeyboardCustomApps : HsExtCommon.h
  • hsFtrValKeyboardJog : HsExtCommon.h
  • hsFtrValKeyboardLayout_deDE : HsExtCommon.h
  • hsFtrValKeyboardLayout_enUS : HsExtCommon.h
  • hsFtrValKeyboardLayout_frFR : HsExtCommon.h
  • hsFtrValKeyboardQwerty : HsExtCommon.h
  • hsFtrValPowerKeyDoubleClkBacklight : HsExtCommon.h
  • hsFtrValPowerKeyHoldRadioPower : HsExtCommon.h
  • hsFtrValPowerKeyTripleClkInvert : HsExtCommon.h
  • hsFtrValRadioAvailable : HsExtCommon.h
  • hsFtrValRadioBuiltin : HsExtCommon.h
  • hsFtrValStatusGadgetRev1 : HsExtCommon.h
  • hsHALIDHandspringOs35_40 : HsExtCommon.h
  • hsHALIDHandspringOs5Rev1 : HsExtCommon.h
  • hsHALIDHandspringOs5Rev1Sim : HsExtCommon.h
  • hsHALIDHandspringOs5Rev2 : HsExtCommon.h
  • hsHALIDHandspringOs5Rev2Sim : HsExtCommon.h
  • hsHALIDHandspringOs5Rev3 : HsExtCommon.h
  • hsHALIDHandspringOs5Rev3Sim : HsExtCommon.h
  • hsHALIDHandspringOs5Rev4 : HsExtCommon.h
  • hsHALIDHandspringOs5Rev4Sim : HsExtCommon.h
  • hsKeyguardAutoDisabled : HsExtCommon.h
  • hsKeyguardAutoPowerOff : HsExtCommon.h
  • hsKeyguardFlagPowerOnDialog : HsExtCommon.h
  • hsLibAliasConsole : HsExtCommon.h
  • hsLibAliasDefault : HsExtCommon.h
  • hsLibAliasHotSyncLocal : HsExtCommon.h
  • hsLibAliasHotSyncModem : HsExtCommon.h
  • hsLibAliasIrda : HsExtCommon.h
  • hsLibNameBuiltInSerial : HsExtCommon.h
  • hsMaxSaveAsNameSize : HsExtCommon.h
  • hsOLDErrorClass : HsExtCommon.h
  • hsSelDmCreateDatabasesFromImages : HsExtTraps.h
  • hsSelPrvLaunchDemoApp : HsExtTraps.h
  • hsSelPrvSetupGoToCustomForm : HsExtTraps.h
  • hsSelPrvSetupInstallFormEventHandler : HsExtTraps.h
  • hsSndAmplitude_silent : HsSoundLibCommon.h
  • hsSndAmplitude_unity : HsSoundLibCommon.h
  • hsSndBayID_AC97 : HsSoundLibCommon.h
  • hsSndBayID_Radio : HsSoundLibCommon.h
  • hsSndBoost_Disable : HsSoundLibCommon.h
  • hsSndBoost_Enable : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvMask : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvNone : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvRings : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvVibeNone : HsSoundLibCommon.h
  • hsSndBufFlags_attackEnvVibeRings : HsSoundLibCommon.h
  • hsSndBufFlags_canInterrupt : HsSoundLibCommon.h
  • hsSndBufFlags_cannotInterrupt : HsSoundLibCommon.h
  • hsSndBufFlags_endDelayMask : HsSoundLibCommon.h
  • hsSndBufFlags_interruptMask : HsSoundLibCommon.h
  • hsSndBufFlags_noEndDelay : HsSoundLibCommon.h
  • hsSndBufFlags_noRepeat : HsSoundLibCommon.h
  • hsSndBufFlags_repeatMask : HsSoundLibCommon.h
  • hsSndBufFlags_yesEndDelay : HsSoundLibCommon.h
  • hsSndBufFlags_yesRepeat : HsSoundLibCommon.h
  • hsSndCmdFlags_noWait : HsSoundLibCommon.h
  • hsSndCmdFlags_waitMask : HsSoundLibCommon.h
  • hsSndCmdFlags_yesWait : HsSoundLibCommon.h
  • hsSndErr_DoMidiProgressMsg : HsSoundLibCommon.h
  • hsSndErr_Failed : HsSoundLibCommon.h
  • hsSndErr_InvalidPort : HsSoundLibCommon.h
  • hsSndErr_InvalidPrefValue : HsSoundLibCommon.h
  • hsSndErr_InvalidSwitch : HsSoundLibCommon.h
  • hsSndErr_LastPublicError : HsSoundLibCommon.h
  • hsSndErr_NotSupported : HsSoundLibCommon.h
  • hsSndErr_PortBoostLocked : HsSoundLibCommon.h
  • hsSndErr_PortCannotBoost : HsSoundLibCommon.h
  • hsSndErr_PortCannotMute : HsSoundLibCommon.h
  • hsSndErr_PortCannotPan : HsSoundLibCommon.h
  • hsSndErr_PortCannotVolume : HsSoundLibCommon.h
  • hsSndErr_PortIDNotInClass : HsSoundLibCommon.h
  • hsSndErr_PortMuteLocked : HsSoundLibCommon.h
  • hsSndErr_PortPanLocked : HsSoundLibCommon.h
  • hsSndErr_PortVolumeLocked : HsSoundLibCommon.h
  • hsSndErr_UnknownClkRef : HsSoundLibCommon.h
  • hsSndErr_UnknownPortClass : HsSoundLibCommon.h
  • hsSndErr_UnknownSndParam : HsSoundLibCommon.h
  • hsSndLibVersion : HsSoundLibCommon.h
  • hsSndMode_Carkit : HsSoundLibCommon.h
  • hsSndMode_Current : HsSoundLibCommon.h
  • hsSndMode_Headphones : HsSoundLibCommon.h
  • hsSndMode_HeadphonesHost : HsSoundLibCommon.h
  • hsSndMode_Headset : HsSoundLibCommon.h
  • hsSndMode_Receiver : HsSoundLibCommon.h
  • hsSndMode_Reserved : HsSoundLibCommon.h
  • hsSndMode_SpeakerHost : HsSoundLibCommon.h
  • hsSndMode_Speakerphone : HsSoundLibCommon.h
  • hsSndMute_Disable : HsSoundLibCommon.h
  • hsSndMute_Enable : HsSoundLibCommon.h
  • hsSndNotify : HsSoundLibCommon.h
  • hsSndNotifyAlert : HsSoundLibCommon.h
  • hsSndNotifyAnswerButton : HsSoundLibCommon.h
  • hsSndNotifyAnswerHold : HsSoundLibCommon.h
  • hsSndNotifyAnswerRelease : HsSoundLibCommon.h
  • hsSndNotifyAthenaAudio : HsSoundLibCommon.h
  • hsSndNotifyCarkitActive : HsSoundLibCommon.h
  • hsSndNotifyCarkitInactive : HsSoundLibCommon.h
  • hsSndNotifyHeadphones : HsSoundLibCommon.h
  • hsSndNotifyHeadset : HsSoundLibCommon.h
  • hsSndNotifyHighPriority : HsSoundLibCommon.h
  • hsSndNotifyHybrid : HsSoundLibCommon.h
  • hsSndNotifyRingerSwitchOff : HsSoundLibCommon.h
  • hsSndNotifyRingerSwitchOn : HsSoundLibCommon.h
  • hsSndNotifyUnplugged : HsSoundLibCommon.h
  • hsSndPan_Left : HsSoundLibCommon.h
  • hsSndPan_LeftNormal : HsSoundLibCommon.h
  • hsSndPan_Middle : HsSoundLibCommon.h
  • hsSndPan_Right : HsSoundLibCommon.h
  • hsSndPan_RightNormal : HsSoundLibCommon.h
  • hsSndParam_Boost : HsSoundLibCommon.h
  • hsSndParam_Mute : HsSoundLibCommon.h
  • hsSndParam_Pan : HsSoundLibCommon.h
  • hsSndParam_Volume : HsSoundLibCommon.h
  • hsSndParamMode_LockParam : HsSoundLibCommon.h
  • hsSndParamMode_Mask : HsSoundLibCommon.h
  • hsSndParamMode_Normal : HsSoundLibCommon.h
  • hsSndParamMode_UnlockParam : HsSoundLibCommon.h
  • HsSndParamValue_RemoveMode : HsSoundLibCommon.h
  • HsSndParamValue_SetWithLock : HsSoundLibCommon.h
  • HsSndParamValue_SetWithUnlock : HsSoundLibCommon.h
  • hsSndPortClass_Anchor : HsSoundLibCommon.h
  • hsSndPortClass_BaseDefault : HsSoundLibCommon.h
  • hsSndPortClass_Real : HsSoundLibCommon.h
  • hsSndPortClass_Virtual : HsSoundLibCommon.h
  • hsSndPortFlags_Boost_Locked : HsSoundLibCommon.h
  • hsSndPortFlags_Boost_LockMask : HsSoundLibCommon.h
  • hsSndPortFlags_Boost_Unlocked : HsSoundLibCommon.h
  • hsSndPortFlags_BoostMask : HsSoundLibCommon.h
  • hsSndPortFlags_BoostOff : HsSoundLibCommon.h
  • hsSndPortFlags_BoostOn : HsSoundLibCommon.h
  • hsSndPortFlags_CanBoost_No : HsSoundLibCommon.h
  • hsSndPortFlags_CanBoost_Yes : HsSoundLibCommon.h
  • hsSndPortFlags_CanBoostMask : HsSoundLibCommon.h
  • hsSndPortFlags_CanInputOnly : HsSoundLibCommon.h
  • hsSndPortFlags_CanIOBothways : HsSoundLibCommon.h
  • hsSndPortFlags_CanIOMask : HsSoundLibCommon.h
  • hsSndPortFlags_CanIOSelect : HsSoundLibCommon.h
  • hsSndPortFlags_CanMute_No : HsSoundLibCommon.h
  • hsSndPortFlags_CanMute_Yes : HsSoundLibCommon.h
  • hsSndPortFlags_CanMuteMask : HsSoundLibCommon.h
  • hsSndPortFlags_CanOutputOnly : HsSoundLibCommon.h
  • hsSndPortFlags_CanPan_No : HsSoundLibCommon.h
  • hsSndPortFlags_CanPan_Yes : HsSoundLibCommon.h
  • hsSndPortFlags_CanPanMask : HsSoundLibCommon.h
  • hsSndPortFlags_CanVol_No : HsSoundLibCommon.h
  • hsSndPortFlags_CanVol_Yes : HsSoundLibCommon.h
  • hsSndPortFlags_CanVolMask : HsSoundLibCommon.h
  • hsSndPortFlags_Disabled : HsSoundLibCommon.h
  • hsSndPortFlags_Enabled : HsSoundLibCommon.h
  • hsSndPortFlags_EnableMask : HsSoundLibCommon.h
  • hsSndPortFlags_InputMask : HsSoundLibCommon.h
  • hsSndPortFlags_InputOff : HsSoundLibCommon.h
  • hsSndPortFlags_InputOn : HsSoundLibCommon.h
  • hsSndPortFlags_Mute_Locked : HsSoundLibCommon.h
  • hsSndPortFlags_Mute_LockMask : HsSoundLibCommon.h
  • hsSndPortFlags_Mute_Unlocked : HsSoundLibCommon.h
  • hsSndPortFlags_MuteMask : HsSoundLibCommon.h
  • hsSndPortFlags_MuteOff : HsSoundLibCommon.h
  • hsSndPortFlags_MuteOn : HsSoundLibCommon.h
  • hsSndPortFlags_OutputMask : HsSoundLibCommon.h
  • hsSndPortFlags_OutputOff : HsSoundLibCommon.h
  • hsSndPortFlags_OutputOn : HsSoundLibCommon.h
  • hsSndPortFlags_Pan_Locked : HsSoundLibCommon.h
  • hsSndPortFlags_Pan_LockMask : HsSoundLibCommon.h
  • hsSndPortFlags_Pan_Unlocked : HsSoundLibCommon.h
  • hsSndPortFlags_TypeAnalog : HsSoundLibCommon.h
  • hsSndPortFlags_TypeDigital : HsSoundLibCommon.h
  • hsSndPortFlags_TypeMask : HsSoundLibCommon.h
  • hsSndPortFlags_Vol_Locked : HsSoundLibCommon.h
  • hsSndPortFlags_Vol_LockMask : HsSoundLibCommon.h
  • hsSndPortFlags_Vol_Unlocked : HsSoundLibCommon.h
  • hsSndPortID_ConnectCall : HsSoundLibCommon.h
  • hsSndPortID_Current : HsSoundLibCommon.h
  • hsSndPortID_InBaseMic : HsSoundLibCommon.h
  • hsSndPortID_InCarkit : HsSoundLibCommon.h
  • hsSndPortID_InHeadsetMic : HsSoundLibCommon.h
  • hsSndPortID_InHostBaseMic : HsSoundLibCommon.h
  • hsSndPortID_InHostHeadsetMic : HsSoundLibCommon.h
  • hsSndPortID_InHostPhone : HsSoundLibCommon.h
  • hsSndPortID_InHostPlay : HsSoundLibCommon.h
  • hsSndPortID_InLineRec : HsSoundLibCommon.h
  • hsSndPortID_InMicAuto : HsSoundLibCommon.h
  • hsSndPortID_InRadioSpkr : HsSoundLibCommon.h
  • hsSndPortID_LastPort : HsSoundLibCommon.h
  • hsSndPortID_Off : HsSoundLibCommon.h
  • hsSndPortID_OutBtHandsfree : HsSoundLibCommon.h
  • hsSndPortID_OutBtHeadset : HsSoundLibCommon.h
  • hsSndPortID_OutCarkit : HsSoundLibCommon.h
  • hsSndPortID_OutHeadphones : HsSoundLibCommon.h
  • hsSndPortID_OutHeadset : HsSoundLibCommon.h
  • hsSndPortID_OutHostRec : HsSoundLibCommon.h
  • hsSndPortID_OutRadioMic : HsSoundLibCommon.h
  • hsSndPortID_OutReceiver : HsSoundLibCommon.h
  • hsSndPortID_OutSpeaker : HsSoundLibCommon.h
  • hsSndPortID_OutSpeakerAuto : HsSoundLibCommon.h
  • hsSndRsrcAudioTableID : HsSoundLibCommon.h
  • hsSndRsrcAudioTableType : HsSoundLibCommon.h
  • hsSndSwitchID_InHostPlay : HsSoundLibCommon.h
  • hsSndSwitchID_InMic : HsSoundLibCommon.h
  • hsSndSwitchID_InRadioSpkr : HsSoundLibCommon.h
  • hsSndSwitchID_OutHostRec : HsSoundLibCommon.h
  • hsSndSwitchID_OutRadioMic : HsSoundLibCommon.h
  • hsSndSwitchID_RadioCall : HsSoundLibCommon.h
  • hsSndToneType_Square : HsSoundLibCommon.h
  • hsSoundLibCreatorID : HsSoundLibCommon.h
  • hsSoundLibName : HsSoundLibCommon.h
  • hsSoundLibTypeID : HsSoundLibCommon.h
  • hsWordCorrectMaxWordLen : HsExtCommon.h
  • htmlLibProgressEvent : HtmlLib68K.h
  • httpSSLFlagConnTLS : HS_HTTPLibConst.h
  • httpSSLFlagConnV2 : HS_HTTPLibConst.h
  • httpSSLFlagConnV2TLS : HS_HTTPLibConst.h
  • httpSSLFlagConnV2V3 : HS_HTTPLibConst.h
  • httpSSLFlagConnV2V3TLS : HS_HTTPLibConst.h
  • httpSSLFlagConnV3 : HS_HTTPLibConst.h
  • httpSSLFlagConnV3TLS : HS_HTTPLibConst.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- i -

  • IBG_ERRNOTPOSSIBLE : PalmBGService.h
  • IBG_ERRREQUEST : PalmBGService.h
  • IBG_ERRRQSTDONE : PalmBGService.h
  • IBG_ERRRSPTOOBIG : PalmBGService.h
  • IBG_ERRSHUTDOWN : PalmBGService.h
  • IBG_ERRTIMEOUT : PalmBGService.h
  • IBG_MAXBUFSZ : PalmBGService.h
  • IBG_SUCCESS : PalmBGService.h
  • ImageLibCreatorID : ImageLibCommon.h
  • ImageLibName : ImageLibCommon.h
  • ImageLibTypeID : ImageLibCommon.h
  • indicatorBlockedCallerIDChar : HsPhoneCDMATypes.h
  • indicatorNoCallerIDChar : HsPhoneCDMATypes.h
  • indicatorRemainingCallerIDChar : HsPhoneCDMATypes.h
  • INVALID_INDEX : PalmNetServices.h
  • IOTAHeaderEscapeSeq : HsPhoneIOTATypes.h
  • IOTATextHeader : HsPhoneIOTATypes.h
  • IOTATextHeaderLength : HsPhoneIOTATypes.h
  • IOTATextHeaderTerminator : HsPhoneIOTATypes.h
  • irFtrLowBatteryLevel : palmOneFeatures.h
  • irFtrVersionNumber : palmOneFeatures.h
  • isValidPhnConnectStateType : HsPhoneCallControlTypes.h
  • isValidPhnIOTAStatus : HsPhoneIOTA.h
  • isValidPhnPasswordType : HsPhoneSecurityTypes.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- p -

  • PALM_OS_20_VERSION : PalmWiFiCommon.h
  • PALM_PHOTO_ALBUM_ALL : palmOnePhotoCommon.h
  • PALM_PHOTO_ALBUM_ALL_HANDHELD : palmOnePhotoCommon.h
  • PALM_PHOTO_ALBUM_ALL_VFS : palmOnePhotoCommon.h
  • PALM_PHOTO_ALBUM_MAX_NAME : palmOnePhotoCommon.h
  • PALM_PHOTO_MAX_PATH : palmOnePhotoCommon.h
  • PALM_PHOTO_SELECT_ALL : palmOnePhotoCommon.h
  • PalmAudioPlaybackRequestResume : PalmAudioPlayback.h
  • PalmAudioPlaybackRequestStop : PalmAudioPlayback.h
  • PalmAudioPlaybackSendRequest : PalmAudioPlayback.h
  • palmCodecAudioAAC : palmOneCodecFormat.h
  • palmCodecAudioALAW : palmOneCodecFormat.h
  • palmCodecAudioAMR : palmOneCodecFormat.h
  • palmCodecAudioDVI_ADPCM : palmOneCodecFormat.h
  • palmCodecAudioG711 : palmOneCodecFormat.h
  • palmCodecAudioG722 : palmOneCodecFormat.h
  • palmCodecAudioG726 : palmOneCodecFormat.h
  • palmCodecAudioG728 : palmOneCodecFormat.h
  • palmCodecAudioIMA_ADPCM : palmOneCodecFormat.h
  • palmCodecAudioMP1 : palmOneCodecFormat.h
  • palmCodecAudioMP2 : palmOneCodecFormat.h
  • palmCodecAudioMP3 : palmOneCodecFormat.h
  • palmCodecAudioPCM : palmOneCodecFormat.h
  • palmCodecAudioQCELP : palmOneCodecFormat.h
  • palmCodecAudioULAW : palmOneCodecFormat.h
  • palmCodecAudioVORBIS : palmOneCodecFormat.h
  • palmCodecImageBase : palmOneCodecFormat.h
  • palmCodecImageGIF87a : palmOneCodecFormat.h
  • palmCodecImageGIF87aFile : palmOneCodecFormat.h
  • palmCodecImageGIF89a : palmOneCodecFormat.h
  • palmCodecImageGIF89aFile : palmOneCodecFormat.h
  • palmCodecImageJPEG : palmOneCodecFormat.h
  • palmCodecImageJPEGFile : palmOneCodecFormat.h
  • palmCodecImagePNG : palmOneCodecFormat.h
  • palmCodecImagePNGFile : palmOneCodecFormat.h
  • palmCodecImageTIFF : palmOneCodecFormat.h
  • palmCodecImageTIFFFile : palmOneCodecFormat.h
  • palmCodecImageWBMP : palmOneCodecFormat.h
  • palmCodecImageWBMPFile : palmOneCodecFormat.h
  • palmCodecInvalidSession : palmOneCodecPluginMgrCommon.h
  • palmCodecIteratorStart : palmOneCodecPluginMgrCommon.h
  • palmCodecIteratorStop : palmOneCodecPluginMgrCommon.h
  • palmCodecNullID : palmOneCodecPluginMgrCommon.h
  • palmCodecText3G : palmOneCodecFormat.h
  • palmCodecVideoAVC : palmOneCodecFormat.h
  • palmCodecVideoDIVX : palmOneCodecFormat.h
  • palmCodecVideoH263 : palmOneCodecFormat.h
  • palmCodecVideoMJPEG : palmOneCodecFormat.h
  • palmCodecVideoMPEG1 : palmOneCodecFormat.h
  • palmCodecVideoMPEG2 : palmOneCodecFormat.h
  • palmCodecVideoMPEG4 : palmOneCodecFormat.h
  • palmCodecVideoXVID : palmOneCodecFormat.h
  • palmOneStatusBarFtrNumVersion : palmOneStatusBar.h
  • palmOneStatusBarLibCreator : palmOneStatusBar.h
  • palmOneStatusBarLibName : palmOneStatusBar.h
  • palmOneStatusBarLibType : palmOneStatusBar.h
  • palmPhotoASFM43FileFormat : palmOnePhotoCommon.h
  • palmPhotoASFM4AFileFormat : palmOnePhotoCommon.h
  • palmPhotoAVIM43FileFormat : palmOnePhotoCommon.h
  • palmPhotoAVIM4AFileFormat : palmOnePhotoCommon.h
  • palmPhotoBMPFileFormat : palmOnePhotoCommon.h
  • palmPhotoCaptureResCIF : palmOnePhotoCommon.h
  • palmPhotoCaptureResNone : palmOnePhotoCommon.h
  • palmPhotoCaptureResOther : palmOnePhotoCommon.h
  • palmPhotoCaptureResQCIF : palmOnePhotoCommon.h
  • palmPhotoCaptureResQQVGA : palmOnePhotoCommon.h
  • palmPhotoCaptureResQVGA : palmOnePhotoCommon.h
  • palmPhotoCaptureResSUBQCIF : palmOnePhotoCommon.h
  • palmPhotoCaptureResSVGA : palmOnePhotoCommon.h
  • palmPhotoCaptureResSXGA : palmOnePhotoCommon.h
  • palmPhotoCaptureResSXGA1024 : palmOnePhotoCommon.h
  • palmPhotoCaptureResSXGA960 : palmOnePhotoCommon.h
  • palmPhotoCaptureResVGA : palmOnePhotoCommon.h
  • palmPhotoCaptureResXVGA : palmOnePhotoCommon.h
  • palmPhotoDlgDeletion : palmOnePhotoCommon.h
  • palmPhotoDlgSelection : palmOnePhotoCommon.h
  • palmPhotoDlgSingleSelection : palmOnePhotoCommon.h
  • palmPhotoExtraInfoAlbum : palmOnePhotoCommon.h
  • palmPhotoExtraInfoCompositeUID : palmOnePhotoCommon.h
  • palmPhotoExtraInfoDate : palmOnePhotoCommon.h
  • palmPhotoExtraInfoImageUID : palmOnePhotoCommon.h
  • palmPhotoExtraInfoLocation : palmOnePhotoCommon.h
  • palmPhotoExtraInfoNotes : palmOnePhotoCommon.h
  • palmPhotoExtraInfoSound : palmOnePhotoCommon.h
  • palmPhotoExtraInfoSoundUID : palmOnePhotoCommon.h
  • palmPhotoFormat_3G2_QCELP_H263 : palmOnePhotoCommon.h
  • palmPhotoFormat_3G2_QCELP_MPEG4 : palmOnePhotoCommon.h
  • palmPhotoFormat_3GP_AMR_H263 : palmOnePhotoCommon.h
  • palmPhotoFormat_3GP_AMR_MPEG4 : palmOnePhotoCommon.h
  • palmPhotoFormat_ASF_ADPCM_MPEG4 : palmOnePhotoCommon.h
  • palmPhotoFormat_ASF_MP3_MPEG4 : palmOnePhotoCommon.h
  • palmPhotoFormat_AVI_ADPCM_MPEG4 : palmOnePhotoCommon.h
  • palmPhotoFormat_AVI_MP3_MPEG4 : palmOnePhotoCommon.h
  • palmPhotoGIFFileFormat : palmOnePhotoCommon.h
  • palmPhotoHighestQuality : palmOnePhotoCommon.h
  • palmPhotoHighQuality : palmOnePhotoCommon.h
  • palmPhotoJPEGFileFormat : palmOnePhotoCommon.h
  • PalmPhotoLibCreatorID : palmOnePhotoCommon.h
  • palmPhotoLibErrAbortReadWrite : palmOnePhotoCommon.h
  • palmPhotoLibErrAlbumExist : palmOnePhotoCommon.h
  • palmPhotoLibErrAlbumFull : palmOnePhotoCommon.h
  • palmPhotoLibErrAlbumNameTooLong : palmOnePhotoCommon.h
  • palmPhotoLibErrAlbumNotExist : palmOnePhotoCommon.h
  • palmPhotoLibErrAlbumReadOnly : palmOnePhotoCommon.h
  • palmPhotoLibErrFormatNotSupported : palmOnePhotoCommon.h
  • palmPhotoLibErrImageExist : palmOnePhotoCommon.h
  • palmPhotoLibErrImageInvalidPath : palmOnePhotoCommon.h
  • palmPhotoLibErrImageNotFound : palmOnePhotoCommon.h
  • palmPhotoLibErrImageNotInPhotos : palmOnePhotoCommon.h
  • palmPhotoLibErrInvalidVolume : palmOnePhotoCommon.h
  • palmPhotoLibErrLowHeap : palmOnePhotoCommon.h
  • palmPhotoLibErrLowMemory : palmOnePhotoCommon.h
  • palmPhotoLibErrLowPower : palmOnePhotoCommon.h
  • palmPhotoLibErrNoCamera : palmOnePhotoCommon.h
  • palmPhotoLibErrNoThumbnail : palmOnePhotoCommon.h
  • palmPhotoLibErrNotOpen : palmOnePhotoCommon.h
  • palmPhotoLibErrNotOpenPhotos : palmOnePhotoCommon.h
  • palmPhotoLibErrNotPhotos : palmOnePhotoCommon.h
  • palmPhotoLibErrOldVersion : palmOnePhotoCommon.h
  • palmPhotoLibErrParam : palmOnePhotoCommon.h
  • palmPhotoLibErrProtectedMedia : palmOnePhotoCommon.h
  • palmPhotoLibErrScreenDepth : palmOnePhotoCommon.h
  • palmPhotoLibErrSmallBuffer : palmOnePhotoCommon.h
  • palmPhotoLibErrStillOpen : palmOnePhotoCommon.h
  • palmPhotoLibErrUnknown : palmOnePhotoCommon.h
  • palmPhotoLibErrUnsupportedRotation : palmOnePhotoCommon.h
  • palmPhotoLibErrUserCancel : palmOnePhotoCommon.h
  • PalmPhotoLibName : palmOnePhotoCommon.h
  • PalmPhotoLibTypeID : palmOnePhotoCommon.h
  • palmPhotoLowestQuality : palmOnePhotoCommon.h
  • palmPhotoLowQuality : palmOnePhotoCommon.h
  • palmPhotoMediaTypeAll : palmOnePhotoCommon.h
  • palmPhotoMediaTypePhoto : palmOnePhotoCommon.h
  • palmPhotoMediaTypeVideo : palmOnePhotoCommon.h
  • palmPhotoMediumQuality : palmOnePhotoCommon.h
  • palmPhotoMemoryLocation : palmOnePhotoCommon.h
  • palmPhotoMJPEGFileFormat : palmOnePhotoCommon.h
  • palmPhotoMPEG1FileFormat : palmOnePhotoCommon.h
  • palmPhotoMPEG4FileFormat : palmOnePhotoCommon.h
  • palmPhotoPNGFileFormat : palmOnePhotoCommon.h
  • palmPhotoPreferredImageFormat : palmOnePhotoCommon.h
  • palmPhotoPreferredVideoFormat : palmOnePhotoCommon.h
  • palmPhotoRGB565FileFormat : palmOnePhotoCommon.h
  • palmPhotoRGB888FileFormat : palmOnePhotoCommon.h
  • palmPhotoStreamLocation : palmOnePhotoCommon.h
  • palmPhotoTIFFFileFormat : palmOnePhotoCommon.h
  • palmPhotoUnsupportedFormat : palmOnePhotoCommon.h
  • palmPhotoVFSLocation : palmOnePhotoCommon.h
  • palmPhotoWBMPFileFormat : palmOnePhotoCommon.h
  • PHN_SUBCOMPONENTID_LIB : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_NOT : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_RDO : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_READ : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_SIM : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_SMS : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_STK : HsPhoneTrace.h
  • PHN_SUBCOMPONENTID_WRIT : HsPhoneTrace.h
  • phnCall1StatusActive : HsPhoneTypes.h
  • phnCall1StatusAlerting : HsPhoneTypes.h
  • phnCall1StatusDialing : HsPhoneTypes.h
  • phnCall1StatusIncoming : HsPhoneTypes.h
  • phnCall2StatusActive : HsPhoneTypes.h
  • phnCall2StatusAlerting : HsPhoneTypes.h
  • phnCall2StatusDialing : HsPhoneTypes.h
  • phnCall2StatusIncoming : HsPhoneTypes.h
  • phnCSDCallActive : HsPhoneTypes.h
  • phnGPRSCallActive : HsPhoneTypes.h
  • phnLibCDMADbCreator : HsPhoneTypes.h
  • phnLibCDMAName : HsPhoneTypes.h
  • phnLibDbType : HsPhoneTypes.h
  • phnLibGSMDbCreator : HsPhoneTypes.h
  • phnLibGSMDbName : HsPhoneTypes.h
  • phnLibGSMName : HsPhoneTypes.h
  • phnLibLaunchCmdEvent : HsPhoneEvent.h
  • phnLibLaunchCmdRegister : HsPhoneEvent.h
  • phnLibOldCDMADbCreator : HsPhoneTypes.h
  • phnLibOldCDMAName : HsPhoneTypes.h
  • PhnLibTrapActivate : HsPhoneTraps.h
  • PhnLibTrapAddAddress : HsPhoneTraps.h
  • PhnLibTrapAddressToText : HsPhoneTraps.h
  • PhnLibTrapAPGetField : HsPhoneTraps.h
  • PhnLibTrapAPGetNth : HsPhoneTraps.h
  • PhnLibTrapAPNewAddress : HsPhoneTraps.h
  • PhnLibTrapAttrGet : HsPhoneTraps.h
  • PhnLibTrapAttrSet : HsPhoneTraps.h
  • PhnLibTrapBattery : HsPhoneTraps.h
  • PhnLibTrapBatteryCharge : HsPhoneTraps.h
  • PhnLibTrapBoxInformation : HsPhoneTraps.h
  • PhnLibTrapBoxInformationEx : HsPhoneTraps.h
  • PhnLibTrapCardInfo : HsPhoneTraps.h
  • PhnLibTrapCardInfoEx : HsPhoneTraps.h
  • PhnLibTrapChangePassword : HsPhoneTraps.h
  • PhnLibTrapCloseNetIF : HsPhoneTraps.h
  • PhnLibTrapCommitIOTAParams : HsPhoneTraps.h
  • PhnLibTrapConference : HsPhoneTraps.h
  • PhnLibTrapConnectionAvailable : HsPhoneTraps.h
  • PhnLibTrapContinuePhonePowerOff : HsPhoneTraps.h
  • PhnLibTrapContinuePhonePowerOn : HsPhoneTraps.h
  • PhnLibTrapCopyPDP : HsPhoneTraps.h
  • PhnLibTrapCount : HsPhoneTraps.h
  • PhnLibTrapCRSM : HsPhoneTraps.h
  • PhnLibTrapCurrentOperator : HsPhoneTraps.h
  • PhnLibTrapCurrentOperatorID : HsPhoneTraps.h
  • PhnLibTrapCurrentProvider : HsPhoneTraps.h
  • PhnLibTrapDeactivateBarring : HsPhoneTraps.h
  • PhnLibTrapDebug : HsPhoneTraps.h
  • PhnLibTrapDebugHook : HsPhoneTraps.h
  • PhnLibTrapDecodeMMI : HsPhoneTraps.h
  • PhnLibTrapDeleteMessage : HsPhoneTraps.h
  • PhnLibTrapDeletePDP : HsPhoneTraps.h
  • PhnLibTrapDial : HsPhoneTraps.h
  • PhnLibTrapDisconnect : HsPhoneTraps.h
  • PhnLibTrapDisposeAddressList : HsPhoneTraps.h
  • PhnLibTrapEnableDM : HsPhoneTraps.h
  • PhnLibTrapEndIOTASession : HsPhoneTraps.h
  • PhnLibTrapEnhancedRoamIndicator : HsPhoneTraps.h
  • PhnLibTrapEqual : HsPhoneTraps.h
  • PhnLibTrapErrorRate : HsPhoneTraps.h
  • PhnLibTrapExecuteMMI : HsPhoneTraps.h
  • PhnLibTrapExit911Mode : HsPhoneTraps.h
  • PhnLibTrapExitPowerSaveMode : HsPhoneTraps.h
  • PhnLibTrapFindEntry : HsPhoneTraps.h
  • PhnLibTrapFirstAppForService : HsPhoneTraps.h
  • PhnLibTrapForceDataDormant : HsPhoneTraps.h
  • PhnLibTrapGetAddresses : HsPhoneTraps.h
  • PhnLibTrapGetBand : HsPhoneTraps.h
  • PhnLibTrapGetBarring : HsPhoneTraps.h
  • PhnLibTrapGetBinary : HsPhoneTraps.h
  • PhnLibTrapGetBoxNumber : HsPhoneTraps.h
  • PhnLibTrapGetCallCountByService : HsPhoneTraps.h
  • PhnLibTrapGetCallWaiting : HsPhoneTraps.h
  • PhnLibTrapGetCDMASystemInfo : HsPhoneTraps.h
  • PhnLibTrapGetCktSwitchProfile : HsPhoneTraps.h
  • PhnLibTrapGetCLIP : HsPhoneTraps.h
  • PhnLibTrapGetCLIR : HsPhoneTraps.h
  • PhnLibTrapGetConnectionInfo : HsPhoneTraps.h
  • PhnLibTrapGetCustomServiceProfile : HsPhoneTraps.h
  • PhnLibTrapGetDataApplication : HsPhoneTraps.h
  • PhnLibTrapGetDataLife : HsPhoneTraps.h
  • PhnLibTrapGetDataSessionInfo : HsPhoneTraps.h
  • PhnLibTrapGetDate : HsPhoneTraps.h
  • PhnLibTrapGetDBRef : HsPhoneTraps.h
  • PhnLibTrapGetDedicatedDataMode : HsPhoneTraps.h
  • PhnLibTrapGetDefaultDataApps : HsPhoneTraps.h
  • PhnLibTrapGetDeviceId : HsPhoneTraps.h
  • PhnLibTrapGetDialPrefix : HsPhoneTraps.h
  • PhnLibTrapGetDTMFburstMode : HsPhoneTraps.h
  • PhnLibTrapGetEchoCancellation : HsPhoneTraps.h
  • PhnLibTrapGetEquipmentMode : HsPhoneTraps.h
  • PhnLibTrapGetErrorText : HsPhoneTraps.h
  • PhnLibTrapGetFDNList : HsPhoneTraps.h
  • PhnLibTrapGetField : HsPhoneTraps.h
  • PhnLibTrapGetFlags : HsPhoneTraps.h
  • PhnLibTrapGetForwarding : HsPhoneTraps.h
  • PhnLibTrapGetGenericCDMAPreference : HsPhoneTraps.h
  • PhnLibTrapGetHeadsetConnectedInfo : HsPhoneTraps.h
  • PhnLibTrapGetHomepageFromRadio : HsPhoneTraps.h
  • PhnLibTrapGetICCID : HsPhoneTraps.h
  • PhnLibTrapGetID : HsPhoneTraps.h
  • PhnLibTrapGetIOTAStatus : HsPhoneTraps.h
  • PhnLibTrapGetLengthDetails : HsPhoneTraps.h
  • PhnLibTrapGetLibAPIVersion : HsPhoneTraps.h
  • PhnLibTrapGetLifeTimer : HsPhoneTraps.h
  • PhnLibTrapGetLineState : HsPhoneTraps.h
  • PhnLibTrapGetMdmPosition : HsPhoneTraps.h
  • PhnLibTrapGetMediaTVSettings : HsPhoneTraps.h
  • PhnLibTrapGetMicrophone : HsPhoneTraps.h
  • PhnLibTrapGetMMSServerInfo : HsPhoneTraps.h
  • PhnLibTrapGetMMSServerInfoEx : HsPhoneTraps.h
  • PhnLibTrapGetMSID : HsPhoneTraps.h
  • PhnLibTrapGetMVNOName : HsPhoneTraps.h
  • PhnLibTrapGetNAMInUse : HsPhoneTraps.h
  • PhnLibTrapGetNoiseCancellation : HsPhoneTraps.h
  • PhnLibTrapGetNth : HsPhoneTraps.h
  • PhnLibTrapGetOneXStatus : HsPhoneTraps.h
  • PhnLibTrapGetOperatorList : HsPhoneTraps.h
  • PhnLibTrapGetOperatorLock : HsPhoneTraps.h
  • PhnLibTrapGetOptions : HsPhoneTraps.h
  • PhnLibTrapGetOwner : HsPhoneTraps.h
  • PhnLibTrapGetOwnNumbers : HsPhoneTraps.h
  • PhnLibTrapGetPDP : HsPhoneTraps.h
  • PhnLibTrapGetPDPIndexRange : HsPhoneTraps.h
  • PhnLibTrapGetPDSessionConfigParam : HsPhoneTraps.h
  • PhnLibTrapGetPhnOprtMode : HsPhoneTraps.h
  • PhnLibTrapGetPhoneBook : HsPhoneTraps.h
  • PhnLibTrapGetPhoneBookIndex : HsPhoneTraps.h
  • PhnLibTrapGetPhoneCallStatus : HsPhoneTraps.h
  • PhnLibTrapGetPhoneLock : HsPhoneTraps.h
  • PhnLibTrapGetPhoneSSMode : HsPhoneTraps.h
  • PhnLibTrapGetPicturesServerInfo : HsPhoneTraps.h
  • PhnLibTrapGetPicturesToken : HsPhoneTraps.h
  • PhnLibTrapGetProxyInfo : HsPhoneTraps.h
  • PhnLibTrapGetRadioState : HsPhoneTraps.h
  • PhnLibTrapGetRemainingPasswordTries : HsPhoneTraps.h
  • PhnLibTrapGetRingingInfo : HsPhoneTraps.h
  • PhnLibTrapGetRoamPrefInfo : HsPhoneTraps.h
  • PhnLibTrapGetRoamPrefMode : HsPhoneTraps.h
  • PhnLibTrapGetSDNList : HsPhoneTraps.h
  • PhnLibTrapGetServiceCentreAddress : HsPhoneTraps.h
  • PhnLibTrapGetSIMStatus : HsPhoneTraps.h
  • PhnLibTrapGetSMSGateway : HsPhoneTraps.h
  • PhnLibTrapGetSMSPreference : HsPhoneTraps.h
  • PhnLibTrapGetSMSRingInfo : HsPhoneTraps.h
  • PhnLibTrapGetSMSSegmentInfo : HsPhoneTraps.h
  • PhnLibTrapGetSpecialNumbers : HsPhoneTraps.h
  • PhnLibTrapGetSpMode : HsPhoneTraps.h
  • PhnLibTrapGetSpn : HsPhoneTraps.h
  • PhnLibTrapGetStatus : HsPhoneTraps.h
  • PhnLibTrapGetSubstitution : HsPhoneTraps.h
  • PhnLibTrapGetSysPrefMode : HsPhoneTraps.h
  • PhnLibTrapGetText : HsPhoneTraps.h
  • PhnLibTrapGetToneIDs : HsPhoneTraps.h
  • PhnLibTrapGetToneIDsEx : HsPhoneTraps.h
  • PhnLibTrapGetToneLength : HsPhoneTraps.h
  • PhnLibTrapGetToneName : HsPhoneTraps.h
  • PhnLibTrapGetTotalDataRxBytes : HsPhoneTraps.h
  • PhnLibTrapGetTotalDataTxBytes : HsPhoneTraps.h
  • PhnLibTrapGetTotalPDPs : HsPhoneTraps.h
  • PhnLibTrapGetTTYSetting : HsPhoneTraps.h
  • PhnLibTrapGetType : HsPhoneTraps.h
  • PhnLibTrapGetVoicePrivacyMode : HsPhoneTraps.h
  • PhnLibTrapGetVolume : HsPhoneTraps.h
  • PhnLibTrapGPRSAttached : HsPhoneTraps.h
  • PhnLibTrapGPRSAttachRequest : HsPhoneTraps.h
  • PhnLibTrapGPRSPDPContextDefine : HsPhoneTraps.h
  • PhnLibTrapGPRSPDPContextListConstruct : HsPhoneTraps.h
  • PhnLibTrapGPRSPDPContextListDestruct : HsPhoneTraps.h
  • PhnLibTrapGPRSQualityOfServiceGet : HsPhoneTraps.h
  • PhnLibTrapGPRSQualityOfServiceSet : HsPhoneTraps.h
  • PhnLibTrapHasName : HsPhoneTraps.h
  • PhnLibTrapHold : HsPhoneTraps.h
  • PhnLibTrapHomeOperatorID : HsPhoneTraps.h
  • PhnLibTrapIsCallMuted : HsPhoneTraps.h
  • PhnLibTrapIsCarrierDefinedEmergencyNumber : HsPhoneTraps.h
  • PhnLibTrapIsEmergencyNumber : HsPhoneTraps.h
  • PhnLibTrapIsLegalCharacter : HsPhoneTraps.h
  • PhnLibTrapIsPhoneActivated : HsPhoneTraps.h
  • PhnLibTrapIsRadioGenericCDMA : HsPhoneTraps.h
  • PhnLibTrapIsSpecialNumber : HsPhoneTraps.h
  • PhnLibTrapLast : HsPhoneTraps.h
  • PhnLibTrapLedAlert : HsPhoneTraps.h
  • PhnLibTrapLength : HsPhoneTraps.h
  • PhnLibTrapListPDP : HsPhoneTraps.h
  • PhnLibTrapLoadCDMATime : HsPhoneTraps.h
  • PhnLibTrapMapCharacter : HsPhoneTraps.h
  • PhnLibTrapMiscDebugInfo : HsPhoneTraps.h
  • PhnLibTrapModemIssueResetInfo : HsPhoneTraps.h
  • PhnLibTrapModuleButtonDown : HsPhoneTraps.h
  • PhnLibTrapModulePowered : HsPhoneTraps.h
  • PhnLibTrapMute : HsPhoneTraps.h
  • PhnLibTrapNetworkAvailable : HsPhoneTraps.h
  • PhnLibTrapNewAddress : HsPhoneTraps.h
  • PhnLibTrapNewAddressList : HsPhoneTraps.h
  • PhnLibTrapNewMessage : HsPhoneTraps.h
  • PhnLibTrapNewMOMessage : HsPhoneTraps.h
  • PhnLibTrapOffHold : HsPhoneTraps.h
  • PhnLibTrapParamText : HsPhoneTraps.h
  • PhnLibTrapPasswordDialog : HsPhoneTraps.h
  • PhnLibTrapPDPLockUnlock : HsPhoneTraps.h
  • PhnLibTrapPhoneRestore : HsPhoneTraps.h
  • PhnLibTrapPlayDTMF : HsPhoneTraps.h
  • PhnLibTrapPlayTone : HsPhoneTraps.h
  • PhnLibTrapPlayToneEx : HsPhoneTraps.h
  • PhnLibTrapPowerSaveDisable : HsPhoneTraps.h
  • PhnLibTrapQuerySMSMT : HsPhoneTraps.h
  • PhnLibTrapReadIOTAItem : HsPhoneTraps.h
  • PhnLibTrapRegister : HsPhoneTraps.h
  • PhnLibTrapRegistered : HsPhoneTraps.h
  • PhnLibTrapReleaseDBRef : HsPhoneTraps.h
  • PhnLibTrapReplacePDPNAI : HsPhoneTraps.h
  • PhnLibTrapReplacePDPPassword : HsPhoneTraps.h
  • PhnLibTrapReplacePDPSvcString : HsPhoneTraps.h
  • PhnLibTrapRoaming : HsPhoneTraps.h
  • PhnLibTrapSATEndSession : HsPhoneTraps.h
  • PhnLibTrapSATGetMainMenu : HsPhoneTraps.h
  • PhnLibTrapSATSendRequest : HsPhoneTraps.h
  • PhnLibTrapSelectAddress : HsPhoneTraps.h
  • PhnLibTrapSelectNAM : HsPhoneTraps.h
  • PhnLibTrapSendDTMF : HsPhoneTraps.h
  • PhnLibTrapSendDTMFBurst : HsPhoneTraps.h
  • PhnLibTrapSendFlash : HsPhoneTraps.h
  • PhnLibTrapSendLongDTMF : HsPhoneTraps.h
  • PhnLibTrapSendMessage : HsPhoneTraps.h
  • PhnLibTrapSendPendingMessages : HsPhoneTraps.h
  • PhnLibTrapSendSilentDTMF : HsPhoneTraps.h
  • PhnLibTrapSendSMSMTAck : HsPhoneTraps.h
  • PhnLibTrapSendUSSD : HsPhoneTraps.h
  • PhnLibTrapSetActiveLine : HsPhoneTraps.h
  • PhnLibTrapSetAddresses : HsPhoneTraps.h
  • PhnLibTrapSetBand : HsPhoneTraps.h
  • PhnLibTrapSetBarring : HsPhoneTraps.h
  • PhnLibTrapSetBoxNumber : HsPhoneTraps.h
  • PhnLibTrapSetCallWaiting : HsPhoneTraps.h
  • PhnLibTrapSetCLIP : HsPhoneTraps.h
  • PhnLibTrapSetCLIR : HsPhoneTraps.h
  • PhnLibTrapSetCurrentUsageHandler : HsPhoneTraps.h
  • PhnLibTrapSetDataApplication : HsPhoneTraps.h
  • PhnLibTrapSetDate : HsPhoneTraps.h
  • PhnLibTrapSetDedicatedDataMode : HsPhoneTraps.h
  • PhnLibTrapSetDialPrefix : HsPhoneTraps.h
  • PhnLibTrapSetDTMFburstMode : HsPhoneTraps.h
  • PhnLibTrapSetEchoCancellation : HsPhoneTraps.h
  • PhnLibTrapSetEquipmentMode : HsPhoneTraps.h
  • PhnLibTrapSetFDNEntry : HsPhoneTraps.h
  • PhnLibTrapSetField : HsPhoneTraps.h
  • PhnLibTrapSetFlags : HsPhoneTraps.h
  • PhnLibTrapSetForwarding : HsPhoneTraps.h
  • PhnLibTrapSetID : HsPhoneTraps.h
  • PhnLibTrapSetMdmAutoMsgMask : HsPhoneTraps.h
  • PhnLibTrapSetMicrophone : HsPhoneTraps.h
  • PhnLibTrapSetModulePower : HsPhoneTraps.h
  • PhnLibTrapSetNoiseCancellation : HsPhoneTraps.h
  • PhnLibTrapSetNth : HsPhoneTraps.h
  • PhnLibTrapSetNumber : HsPhoneTraps.h
  • PhnLibTrapSetOperator : HsPhoneTraps.h
  • PhnLibTrapSetOperatorLock : HsPhoneTraps.h
  • PhnLibTrapSetOptions : HsPhoneTraps.h
  • PhnLibTrapSetOwner : HsPhoneTraps.h
  • PhnLibTrapSetOwnNumbers : HsPhoneTraps.h
  • PhnLibTrapSetPDP : HsPhoneTraps.h
  • PhnLibTrapSetPDSessionConfigParam : HsPhoneTraps.h
  • PhnLibTrapSetPhnOprtMode : HsPhoneTraps.h
  • PhnLibTrapSetPhoneBook : HsPhoneTraps.h
  • PhnLibTrapSetPhoneBookEntry : HsPhoneTraps.h
  • PhnLibTrapSetPhoneLock : HsPhoneTraps.h
  • PhnLibTrapSetPhoneSSMode : HsPhoneTraps.h
  • PhnLibTrapSetPicturesToken : HsPhoneTraps.h
  • PhnLibTrapSetRingingInfo : HsPhoneTraps.h
  • PhnLibTrapSetRoamPrefInfo : HsPhoneTraps.h
  • PhnLibTrapSetRoamPrefMode : HsPhoneTraps.h
  • PhnLibTrapSetServiceCentreAddress : HsPhoneTraps.h
  • PhnLibTrapSetSMSCallbackNumber : HsPhoneTraps.h
  • PhnLibTrapSetSMSPreference : HsPhoneTraps.h
  • PhnLibTrapSetSMSRingInfo : HsPhoneTraps.h
  • PhnLibTrapSetSpecialNumbers : HsPhoneTraps.h
  • PhnLibTrapSetStatus : HsPhoneTraps.h
  • PhnLibTrapSetSysPrefMode : HsPhoneTraps.h
  • PhnLibTrapSetText : HsPhoneTraps.h
  • PhnLibTrapSetToneLength : HsPhoneTraps.h
  • PhnLibTrapSetTTYSetting : HsPhoneTraps.h
  • PhnLibTrapSetupDataConfig : HsPhoneTraps.h
  • PhnLibTrapSetVoicePrivacyMode : HsPhoneTraps.h
  • PhnLibTrapSetVolume : HsPhoneTraps.h
  • PhnLibTrapSignalQuality : HsPhoneTraps.h
  • PhnLibTrapSignalQualityEx : HsPhoneTraps.h
  • PhnLibTrapSIMInfo : HsPhoneTraps.h
  • PhnLibTrapSndDelete : HsPhoneTraps.h
  • PhnLibTrapSndSave : HsPhoneTraps.h
  • PhnLibTrapStartIOTASession : HsPhoneTraps.h
  • PhnLibTrapStartVibrate : HsPhoneTraps.h
  • PhnLibTrapStopPDSession : HsPhoneTraps.h
  • PhnLibTrapStopTone : HsPhoneTraps.h
  • PhnLibTrapStopVibrate : HsPhoneTraps.h
  • PhnLibTrapTunnelIS683ReqMsg : HsPhoneTraps.h
  • PhnLibTrapUninstall : HsPhoneTraps.h
  • PhnLibTrapUnlockPhoneLock : HsPhoneTraps.h
  • PhnLibTrapUpdateCustomizedNV : HsPhoneTraps.h
  • PhnLibTrapUpdateMessageCount : HsPhoneTraps.h
  • PhnLibTrapUsableSignalStrengthThreshold : HsPhoneTraps.h
  • PhnLibTrapVerifyICDVer : HsPhoneTraps.h
  • PhnLibTrapWriteIOTAItem : HsPhoneTraps.h
  • phnMaxDialStrLen : HsPhoneCDMATypes.h
  • phnMaxMNAAASharedSecretLen : HsPhoneCDMATypes.h
  • phnMaxMNHASharedSecretLen : HsPhoneCDMATypes.h
  • phnMaxMslLen : HsPhoneCDMATypes.h
  • phnMaxNAILen : HsPhoneCDMATypes.h
  • phnMaxSvcStrLen : HsPhoneCDMATypes.h
  • phnMaxUrlLen : HsPhoneCDMATypes.h
  • phnNotifyEquipMode : HsPhoneEvent.h
  • phnNotifySubscriber : HsPhoneEvent.h
  • phnPacketDataCallActive : HsPhoneTypes.h
  • phnPacketDataCallDormant : HsPhoneTypes.h
  • phnPDPUidLen : HsPhoneCDMATypes.h
  • phnUPEvent : HsPhoneEvent.h
  • phnVoiceCall1Active : HsPhoneTypes.h
  • phnVoiceCall2Active : HsPhoneTypes.h
  • phnVolumeMax : HsPhoneTypes.h
  • phnVolumeMin : HsPhoneTypes.h
  • phnWUEvent : HsPhoneEvent.h
  • phoneAppLaunchCmdActivation : HsAppLaunchCmd.h
  • phoneAppLaunchCmdDial : HsAppLaunchCmd.h
  • phoneAppLaunchCmdDialSTKSETUPCALL : HsAppLaunchCmd.h
  • phoneAppLaunchCmdDialVoiceMail : HsAppLaunchCmd.h
  • phoneAppLaunchCmdDisplayDialPrefs : HsAppLaunchCmd.h
  • phoneAppLaunchCmdGetALSLineNumber : HsAppLaunchCmd.h
  • phoneAppLaunchCmdGetDialPrefFlag : HsAppLaunchCmd.h
  • phoneAppLaunchCmdGetUSDialingRules : HsAppLaunchCmd.h
  • phoneAppLaunchCmdNetworkSearch : HsAppLaunchCmd.h
  • phoneAppLaunchCmdPowerOn : HsAppLaunchCmd.h
  • phoneAppLaunchCmdRedial : HsAppLaunchCmd.h
  • phoneAppLaunchCmdSendDTMFTone : HsAppLaunchCmd.h
  • phoneAppLaunchCmdSetWallpaper : HsAppLaunchCmd.h
  • phoneAppLaunchCmdStartNetInitUSSD : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewCalls : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewHistory : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewKeypad : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewMissedCalls : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewPhoneHome : HsAppLaunchCmd.h
  • phoneAppLaunchCmdViewSpeed : HsAppLaunchCmd.h
  • phoneAppLaunchOptionsMenu : HsAppLaunchCmd.h
  • PM_AUDIOGROUP_MASK : PmSoundLibAudioGroup.h
  • PM_AUDP : HsSoundLibCommon.h
  • PM_AUDP_CLASS : HsSoundLibCommon.h
  • PM_AUDP_CLASS_MASK : HsSoundLibCommon.h
  • pmAudioClkTickRef : HsSoundLibCommon.h
  • pmNotifyHighPriorityAudioTask : HsAppLaunchCmd.h
  • pmNotifyHighPriorityUITask : HsAppLaunchCmd.h
  • pmPhoneAppNotifyHomeAppEvent : HsAppLaunchCmd.h
  • pmPhoneAppNotifySetWallpaper : HsAppLaunchCmd.h
  • PmSndAddAudioGroupToVolume : PmSoundLibAudioGroup.h
  • pmSndAttackEnvIDRings : HsSoundLibCommon.h
  • pmSndAttackEnvIDVibeRing : HsSoundLibCommon.h
  • pmSndBayID_AUDP : HsSoundLibCommon.h
  • PmSndGetAudioGroupFromVolume : PmSoundLibAudioGroup.h
  • pmSndPref_AthenaActive_No : HsSoundLibCommon.h
  • pmSndPref_AthenaActive_Yes : HsSoundLibCommon.h
  • pmSndPref_AthenaAudio_IfMicPresent : HsSoundLibCommon.h
  • pmSndPref_AthenaAudio_NoRouting : HsSoundLibCommon.h
  • pmSndPref_AthenaAudio_Unconditional : HsSoundLibCommon.h
  • pmSndPref_WakeOnAnswerBtn_Disable : HsSoundLibCommon.h
  • pmSndPref_WakeOnAnswerBtn_Enable : HsSoundLibCommon.h
  • pmSndPrefID_AGCEvent : HsSoundLibCommon.h
  • pmSndPrefID_AppsGroupHoldType : HsSoundLibCommon.h
  • pmSndPrefID_AthenaActive : HsSoundLibCommon.h
  • pmSndPrefID_AthenaAudio : HsSoundLibCommon.h
  • pmSndPrefID_AudioTable : HsSoundLibCommon.h
  • pmSndPrefID_GsmMccArray : HsSoundLibCommon.h
  • pmSndPrefID_JackOutIfMicUnused : HsSoundLibCommon.h
  • pmSndPrefID_PhoneRxGainLimit : HsSoundLibCommon.h
  • pmSndPrefID_SleepMode : HsSoundLibCommon.h
  • pmSndPrefID_WakeOnAnswerBtn : HsSoundLibCommon.h
  • PmSndRemoveAudioGroupFromVolume : PmSoundLibAudioGroup.h
  • pmSndSwitchID_Preferences : HsSoundLibCommon.h
  • pmSoundLibAudioGroupFtr : PmSoundLibAudioGroup.h
  • pmSoundLibAudioGroupFtr_Off : PmSoundLibAudioGroup.h
  • pmSoundLibAudioGroupFtr_On : PmSoundLibAudioGroup.h
  • pmSoundLibCreatorID : PmSoundLibAudioGroup.h
  • pmUsbFtrCreator : palmOneFeatures.h
  • pmUsbFtrVersion : palmOneFeatures.h
  • PRIORITY_LIST_SIZE : PalmNetServices.h
  • PrvPhnLibTrapCheckPowerSync : HsPhoneTraps.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- r -

  • Reserved2 : HsPhoneTraps.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- s -

  • screenFtrCreator : palmOneFeatures.h
  • ShlCreatorID : PalmNetServices.h
  • ShlLibName : PalmNetServices.h
  • ShlLibType : PalmNetServices.h
  • SNDFILESTREAM_TRAP : palmOneSndFileStream.h
  • sndFileStreamNotifyRecComplete : palmOneSndFileStream.h
  • sndFileStreamNotifyStreamComplete : palmOneSndFileStream.h
  • soundPrefsLaunchCmdCalendar : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdEmail : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdGeneral : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdIM : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdMMS : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdPhone : HsAppLaunchCmd.h
  • soundPrefsLaunchCmdSMS : HsAppLaunchCmd.h
  • steAcceleratedScrolling : SmartTextEngineDef.h
  • steAllowPhoneNumberWords : SmartTextEngineDef.h
  • steAllowShortPhoneNumbers : SmartTextEngineDef.h
  • steBitmap : SmartTextEngineDef.h
  • steBlackFont : SmartTextEngineDef.h
  • steBlueFont : SmartTextEngineDef.h
  • steBoldFont : SmartTextEngineDef.h
  • steCannotSelectText : SmartTextEngineDef.h
  • steCenterAlign : SmartTextEngineDef.h
  • steCurrentFont : SmartTextEngineDef.h
  • STEDepracated5 : SmartTextEngineTraps.h
  • steDoNotCenterVertically : SmartTextEngineDef.h
  • steErrBase : SmartTextEngineErrors.h
  • steErrDynamicMemory : SmartTextEngineErrors.h
  • steErrInternal : SmartTextEngineErrors.h
  • steErrInvalidArguments : SmartTextEngineErrors.h
  • steErrOperationNotAllowed : SmartTextEngineErrors.h
  • steErrSTEInit : SmartTextEngineErrors.h
  • steErrStorageMemory : SmartTextEngineErrors.h
  • steErrUnimplemented : SmartTextEngineErrors.h
  • steGrayFont : SmartTextEngineDef.h
  • steGreenFont : SmartTextEngineDef.h
  • steHorizontalLine : SmartTextEngineDef.h
  • steHyperlink : SmartTextEngineDef.h
  • steInvertHighlighting : SmartTextEngineDef.h
  • steLargeFont : SmartTextEngineDef.h
  • steLeftIndent : SmartTextEngineDef.h
  • steLibDBName : SmartTextEngineDef.h
  • steLibName : SmartTextEngineDef.h
  • steLineBreak : SmartTextEngineDef.h
  • steNoLinksBeforeColon : SmartTextEngineDef.h
  • steOrangeFont : SmartTextEngineDef.h
  • steParseEmail : SmartTextEngineDef.h
  • steParseEmoticons : SmartTextEngineDef.h
  • steParseGSMGreekChars : SmartTextEngineDef.h
  • steParseMoreEmoticons : SmartTextEngineDef.h
  • steParsePhoneNumbers : SmartTextEngineDef.h
  • steParseURLs : SmartTextEngineDef.h
  • stePurpleFont : SmartTextEngineDef.h
  • steRedFont : SmartTextEngineDef.h
  • steRightAlign : SmartTextEngineDef.h
  • steScrollWalksLinks : SmartTextEngineDef.h
  • steScrollWalksMessages : SmartTextEngineDef.h
  • steStdFont : SmartTextEngineDef.h
  • steTextMustBeVisible : SmartTextEngineDef.h
  • STETrapAppendParsedInfo : SmartTextEngineTraps.h
  • STETrapAppendTextToEngine : SmartTextEngineTraps.h
  • STETrapClearCurrentSelection : SmartTextEngineTraps.h
  • STETrapClose : SmartTextEngineTraps.h
  • STETrapCopySelectionToClipboard : SmartTextEngineTraps.h
  • STETrapGetAPIVersion : SmartTextEngineTraps.h
  • STETrapGetCurrentTextSelection : SmartTextEngineTraps.h
  • STETrapGetFlags : SmartTextEngineTraps.h
  • STETrapGetLastTapInfo : SmartTextEngineTraps.h
  • STETrapGetNumLines : SmartTextEngineTraps.h
  • STETrapGetNumRecords : SmartTextEngineTraps.h
  • STETrapGetParsedInformation : SmartTextEngineTraps.h
  • STETrapGetScroll : SmartTextEngineTraps.h
  • STETrapGetScrollPct : SmartTextEngineTraps.h
  • STETrapGetSelectedText : SmartTextEngineTraps.h
  • STETrapHandleEvent : SmartTextEngineTraps.h
  • STETrapHandleKeyDownEvent : SmartTextEngineTraps.h
  • STETrapHandlePenDownEvent : SmartTextEngineTraps.h
  • STETrapHandlePenMoveEvent : SmartTextEngineTraps.h
  • STETrapHandlePenUpEvent : SmartTextEngineTraps.h
  • STETrapHandleSclRepeatEvent : SmartTextEngineTraps.h
  • STETrapHasHotRectSelection : SmartTextEngineTraps.h
  • STETrapHasMessageSelection : SmartTextEngineTraps.h
  • STETrapHasTextSelection : SmartTextEngineTraps.h
  • STETrapInitializeEngine : SmartTextEngineTraps.h
  • STETrapOpen : SmartTextEngineTraps.h
  • STETrapQuickRender : SmartTextEngineTraps.h
  • STETrapReinitializeEngine : SmartTextEngineTraps.h
  • STETrapRemoveLastRecordFromEngine : SmartTextEngineTraps.h
  • STETrapRenderList : SmartTextEngineTraps.h
  • STETrapRerenderList : SmartTextEngineTraps.h
  • STETrapResetEngine : SmartTextEngineTraps.h
  • STETrapSetCurrentTextSelection : SmartTextEngineTraps.h
  • STETrapSetCustomHyperlinkCallback : SmartTextEngineTraps.h
  • STETrapSetFlags : SmartTextEngineTraps.h
  • STETrapSetScroll : SmartTextEngineTraps.h
  • STETrapSetScrollPct : SmartTextEngineTraps.h
  • STETrapSetScrollToRecordNum : SmartTextEngineTraps.h
  • steYellowFont : SmartTextEngineDef.h
  • sysAppLaunchCmdFromSetupApp : PalmLaunchCodes.h
  • sysAppLaunchWebBrowserAutoCrawl : HsAppLaunchCmd.h
  • sysAppLaunchWebBrowserGetHomePage : HsAppLaunchCmd.h
  • sysAppLaunchWebBrowserLaunchBookmarkDialog : HsAppLaunchCmd.h
  • sysAppLaunchWebBrowserMinimalMode : HsAppLaunchCmd.h
  • sysAppLaunchWebBrowserSetHomePage : HsAppLaunchCmd.h
  • sysAppLaunchWebBrowserTutorialMode : HsAppLaunchCmd.h
  • sysExternalHeadsetInsertEvent : palmOneFeatures.h
  • sysExternalHeadsetRemoveEvent : palmOneFeatures.h
  • sysFileCMobileApp : palmOneCreators.h
  • sysFileCMobileServices : palmOneCreators.h
  • sysFileCMyFavorite : palmOneCreators.h
  • sysFileCNotePad : palmOneCreators.h
  • sysFileCProvisioning : palmOneCreators.h
  • sysFileCSimATDriverOem : palmOneCreators.h
  • sysFileCSimOfficer : palmOneCreators.h
  • sysFileCSimWatcherLib : palmOneCreators.h
  • sysFileCTelMgrLibOem : palmOneCreators.h
  • sysFileTVPNPanelPlugin : PalmVPPI.h
  • sysFileTWiFiPanelPlugin : PalmWPPI.h
  • sysFtrNumDmAutoBackup : PmPalmOSNVFS.h
  • sysNotifyExternalDialogClosedEvent : palmOneFeatures.h
  • sysNotifyExternalDialogOpenedEvent : palmOneFeatures.h
  • sysNotifyHardDiskSpinup : palmOneFeatures.h
  • sysTrapOEMDispatch : HsExtTraps.h
  • sysVPPILaunchCmdClearPWCache : PalmVPPI.h
  • sysVPPILaunchCmdDeleteAccount : PalmVPPI.h
  • sysVPPILaunchCmdEditAccount : PalmVPPI.h
  • sysVPPILaunchCmdErrorDialog : PalmVPPI.h
  • sysVPPILaunchCmdGetAccounts : PalmVPPI.h
  • sysVPPILaunchCmdProgressPaint : PalmVPPI.h
  • sysVPPILaunchCmdPromptAndConfigure : PalmVPPI.h
  • sysVPPILaunchCmdSetCurrentAccount : PalmVPPI.h
  • sysVPPILaunchCmdWillPWPrompt : PalmVPPI.h
  • sysWPPILaunchCmdClearPWCache : PalmWPPI.h
  • sysWPPILaunchCmdClose : PalmWPPI.h
  • sysWPPILaunchCmdDelete : PalmWPPI.h
  • sysWPPILaunchCmdDialog : PalmWPPI.h
  • sysWPPILaunchCmdErrorDialog : PalmWPPI.h
  • sysWPPILaunchCmdGetDescription : PalmWPPI.h
  • sysWPPILaunchCmdPromptAndConfigure : PalmWPPI.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:54 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- t -

  • TextHeaderTerminator : HsPhoneSMSTypes.h
  • tonesLibCreator : TonesLibTypes.h
  • tonesLibErrAlreadyPlaying : TonesLibTypes.h
  • tonesLibErrBadParams : TonesLibTypes.h
  • tonesLibErrClass : TonesLibTypes.h
  • tonesLibErrCreateDBFailed : TonesLibTypes.h
  • tonesLibErrDBNotFound : TonesLibTypes.h
  • tonesLibErrDBWriteFailed : TonesLibTypes.h
  • tonesLibErrNoMemory : TonesLibTypes.h
  • tonesLibErrNotAllowed : TonesLibTypes.h
  • tonesLibErrNoTone : TonesLibTypes.h
  • tonesLibErrUnknown : TonesLibTypes.h
  • tonesLibErrUserCancel : TonesLibTypes.h
  • tonesLibName : TonesLibTypes.h
  • tonesLibPlayForever : TonesLibTypes.h
  • tonesLibTrapAddMidiTone : TonesLibTypes.h
  • tonesLibTrapDeleteTone : TonesLibTypes.h
  • tonesLibTrapDoDialog : TonesLibTypes.h
  • tonesLibTrapEscalateRingTones : TonesLibTypes.h
  • tonesLibTrapGetSoundOnVolume : TonesLibTypes.h
  • tonesLibTrapGetSoundPrefs : TonesLibTypes.h
  • tonesLibTrapGetToneIDs : TonesLibTypes.h
  • tonesLibTrapGetToneList : TonesLibTypes.h
  • tonesLibTrapGetToneName : TonesLibTypes.h
  • tonesLibTrapGetToneSize : TonesLibTypes.h
  • tonesLibTrapInitTonesDB : TonesLibTypes.h
  • tonesLibTrapManageTones : TonesLibTypes.h
  • tonesLibTrapPickTone : TonesLibTypes.h
  • tonesLibTrapPlayRingTone : TonesLibTypes.h
  • tonesLibTrapPlayTone : TonesLibTypes.h
  • tonesLibTrapSetSoundOnVolume : TonesLibTypes.h
  • tonesLibTrapSetSoundPrefs : TonesLibTypes.h
  • tonesLibTrapStopTone : TonesLibTypes.h
  • tonesLibTrapToneClose : TonesLibTypes.h
  • tonesLibTrapToneCreate : TonesLibTypes.h
  • tonesLibTrapToneRecord : TonesLibTypes.h
  • tonesLibTrapToneWrite : TonesLibTypes.h
  • tonesLibType : TonesLibTypes.h
  • transLibCreator : TransparencyLibTypes.h
  • transLibErrAlreadyOpen : TransparencyLibTypes.h
  • transLibErrDockNotAttached : TransparencyLibTypes.h
  • transLibErrNotOpen : TransparencyLibTypes.h
  • transLibErrorClass : TransparencyLibTypes.h
  • transLibErrUnknown : TransparencyLibTypes.h
  • transLibName : TransparencyLibTypes.h
  • transLibType : TransparencyLibTypes.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:54 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- u -

  • UPDataSize : HsPhoneEvent.h
  • UPHeaderEscapeSeq : HsPhoneEvent.h
  • UPTextHeader : HsPhoneEvent.h
  • UPTextHeaderLength : HsPhoneEvent.h
  • USBChargeCreator : palmOneFeatures.h
  • USBChargeVersion : palmOneFeatures.h
  • USBFeatureCreator : palmOneFeatures.h
  • USBFeatureVersion : palmOneFeatures.h
  • USBHwrCreator : palmOneFeatures.h
  • USBHwrVersion : palmOneFeatures.h
  • USBSpeedCreator : palmOneFeatures.h
  • USBSpeedVersion : palmOneFeatures.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:54 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- v -

  • vfsIncludePrivateVolumes : PmPalmOSNVFS.h
  • vfsVolumeAttrNonRemovable : PmPalmOSNVFS.h
  • VMFontErrNotOpen : VMFontLibCommon.h
  • VMFontErrParam : VMFontLibCommon.h
  • VMFontErrStillOpen : VMFontLibCommon.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:54 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- w -

  • WAPNotificationTypeVersion : HsPhoneEvent.h
  • WIFI_CONFIG_NAME : PalmWiFiCommon.h
  • WIFI_CREATOR_ID : PalmWiFiCommon.h
  • WIFI_DB_NAME : PalmWiFiCommon.h
  • WIFI_DB_TYPE : PalmWiFiCommon.h
  • WIFI_DRIVER_NAME : PalmWiFiCommon.h
  • WIFI_DRIVER_PREFIX : PalmWiFiCommon.h
  • WIFI_MIN_OS_VERSION : PalmWiFiCommon.h
  • WUFieldDelimiter : HsPhoneEvent.h
  • WUHeaderEscapeSeq : HsPhoneEvent.h
  • WUTextHeader : HsPhoneEvent.h
  • WUTextHeaderLength : HsPhoneEvent.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:54 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • c
  • e
  • f
  • g
  • h
  • i
  • n
  • p
  • s
  • t
  • v

- _ -

  • _80211InfrastructureEnum : PalmWiFiCommon.h
  • _GSMATEventInputEchoModeEnum : HsPhoneGSMTypes.h
  • _GSMDialCLIRMode : HsPhoneTypes.h
  • _GSMSATDataSvcTypeEnum : HsPhoneGSMTypes.h
  • _GSMSATEventInputFormatEnum : HsPhoneGSMTypes.h
  • _GSMSATEventMenuFlag : HsPhoneGSMTypes.h
  • _GSMSATEventSetupCallCallTypeEnum : HsPhoneGSMTypes.h
  • _GSMSATEventToneTimeUnitEnum : HsPhoneGSMTypes.h
  • _GSMSATEventToneTypeEnum : HsPhoneGSMTypes.h
  • _GSMSIMStatus : HsPhoneTypes.h
  • _LocDBSortOrderType : LocsLibCommon.h
  • _PhnAddressField : HsPhoneTypes.h
  • _PhnCDMAFirmwareType : HsPhoneCDMATypes.h
  • _PhnConnectStateType : HsPhoneCallControlTypes.h
  • _PhnDataServiceType : HsPhoneNetworkTypes.h
  • _PhnLibAttrType : HsPhoneMiscTypes.h
  • _PhnMIPSessionType : HsPhoneNetworkTypes.h
  • _PhnOneXProtRevType : HsPhoneNetworkTypes.h
  • _PhnOprtModeType : HsPhoneMiscTypes.h
  • _PhnPacketDataEndStatusEnum : HsPhoneNetworkTypes.h
  • _PhnPacketDataSessionType : HsPhoneNetworkTypes.h
  • _PhnPDPConnectionType : HsPhoneCDMATypes.h
  • _PhnPDPService : HsPhoneCDMATypes.h
  • _PhnPDSessionConfigParamType : hsPhoneLocationTypes.h
  • _PhnPowerType : HsPhoneTypes.h
  • _PhnRoamPrefSelectionTypeEnum : HsPhoneNetworkTypes.h
  • _PhnTTYSetting : HsPhoneAudioTypes.h
  • _PhoneServiceClassType : HsPhoneTypes.h
  • _SATDecisionType : HsPhoneGSMTypes.h
  • _SATNotificationType : HsPhoneGSMTypes.h
  • _SATRequestType : HsPhoneGSMTypes.h
  • _SmsCauseCode : HsPhoneSMSTypes.h
  • _SmsErrorCode : HsPhoneSMSTypes.h
  • _SoundPrefType : TonesLibTypes.h
  • _TonePlayNumberTimes : TonesLibTypes.h
  • _ToneRepeatInterval : TonesLibTypes.h
  • _ToneTimeUnit : TonesLibTypes.h
  • _ToneType : TonesLibTypes.h
  • _ToneVibrateType : TonesLibTypes.h
  • _ToneVolume : TonesLibTypes.h
  • _VMFontFace : VMFontLibCommon.h
  • _VMFontSize : VMFontLibCommon.h
  • _VMFontSizeRule : VMFontLibCommon.h
  • _VMFontStyle : VMFontLibCommon.h
  • _VMFontStyleRule : VMFontLibCommon.h

- a -

  • AACHeaderType : palmOneCodecFormat.h
  • AACObjectType : palmOneCodecFormat.h
  • AddrCustomActionCodes : HsAppLaunchCmd.h
  • AddrCustomNotificationCodes : HsAppLaunchCmd.h
  • AddressAppPhoneLabel : HsPhoneSMSTypes.h
  • AddressAppRecordFieldEnum : HsPhoneSMSTypes.h
  • AddressHsLookupFields : HsAppLaunchCmd.h

- c -

  • CCSMBrowserSettingsEnum : CarrierCustomLibTypes.h
  • CCSMMessagingSettingsEnum : CarrierCustomLibTypes.h
  • CCSMPhoneFlagsEnum : CarrierCustomLibTypes.h
  • CCSMRadioBandEnum : CarrierCustomLibTypes.h
  • CCSMSystemFlagsEnum : CarrierCustomLibTypes.h

- e -

  • ePmConnectorDeviceState : PmConnectorLibCommon.h

- f -

  • FavDBLibPhoneViewEnum : FavoritesDBLib.h
  • FileFlag : palmOneCodecFormat.h

- g -

  • GSMCLIPStatus : HsPhoneNetworkTypes.h
  • GSMCLIRDisplayStatus : HsPhoneNetworkTypes.h

- h -

  • HsAttrEnum : HsExtCommon.h
  • HsIndicatorCountEnum : HsExtCommon.h
  • HsIndicatorStateEnum : HsExtCommon.h
  • HsLightCircumstanceEnum : HsExtCommon.h
  • HsLightModeEnum : HsExtCommon.h
  • HsPrefEnum : HsExtCommon.h
  • HsSndCmdEnumTag : HsSoundLibCommon.h
  • HsSndFormatEnumTag : HsSoundLibCommon.h
  • hsSndSysBeepTag : HsSoundLibCommon.h
  • HsStatusGadgetTypeEnum : HsExtCommon.h
  • HsVerStrEnum : HsExtCommon.h
  • httpCookie_ : HS_HTTPLibConst.h
  • httpError_ : HS_HTTPLibConst.h
  • httpHeaderType_ : HS_HTTPLibConst.h
  • httpMethod_ : HS_HTTPLibConst.h
  • httpScheme_ : HS_HTTPLibConst.h
  • httpStatusCode_ : HS_HTTPLibConst.h
  • httpStreamState_ : HS_HTTPLibConst.h
  • httpVersion_ : HS_HTTPLibConst.h

- i -

  • IPAllocType : PalmWiFiCommon.h

- n -

  • NetIFSettingShimEnum : PalmShimSettings.h
  • NetQueryId : PalmWiFiCommon.h
  • NetWepStatus : PalmWiFiCommon.h

- p -

  • PalmAACProfileType : palmOneCodecFormat.h
  • PalmAMRDtxMode : palmOneCodecFormat.h
  • PalmAMRMode : palmOneCodecFormat.h
  • PalmAudioChannelType : palmOneCodecFormat.h
  • PalmBasicType : palmOneCodecFormat.h
  • PalmBMPCompressionType : palmOneCodecFormat.h
  • PalmCodecControlType : palmOneCodecFormat.h
  • PalmEndianType : palmOneCodecFormat.h
  • PalmFileType : palmOneCodecFormat.h
  • PalmMPEG4Algorithm : palmOneCodecFormat.h
  • PalmOneStatAttrTypeTag : palmOneStatusBar.h
  • PalmQCELPRate : palmOneCodecFormat.h
  • PalmQCELPReducedRate : palmOneCodecFormat.h
  • PhnBarFacilityTypeEnum : HsPhoneNetworkTypes.h
  • PhnCallControlTypeEnum : HsPhoneNetworkTypes.h
  • PhnCLIRStatus : HsPhoneNetworkTypes.h
  • PhnConnectionEnum : HsPhoneMiscTypes.h
  • PhnDataChannelType : HsPhoneEvent.h
  • PhnEquipmentMode : HsPhoneMiscTypes.h
  • PHNErrorCodeRange_1 : HsPhoneErrors.h
  • PHNErrorCodeRange_2 : HsPhoneErrors.h
  • PhnEventCode : HsPhoneEvent.h
  • PhnIndicationKind : HsPhoneEvent.h
  • PhnIOTAItemEnum : HsPhoneIOTATypes.h
  • PhnLockModeEnum : HsPhoneTypes.h
  • PhnMMIActionCodeEnum : HsPhoneNetworkTypes.h
  • PhnMMIServiceCodeEnum : HsPhoneNetworkTypes.h
  • PhnModuleButtonType : HsPhoneEvent.h
  • PhnMsgBoxEnum : HsPhoneNetworkTypes.h
  • PhnOneXDataFailType : HsPhoneCDMATypes.h
  • PhnOperatorStatus : HsPhoneNetworkTypes.h
  • PhnPasswordTypeEnum : HsPhoneSecurityTypes.h
  • PhnPDPAUncerttype : HsPhoneCDMATypes.h
  • PhnRoamStatusEnum : HsPhoneNetworkTypes.h
  • PhnSMSClassEnum : HsPhoneEvent.h
  • PhnSMSTypeEnum : HsPhoneEvent.h
  • PhnTeleserviceMmiCodeType : HsPhoneNetworkTypes.h
  • PhnTeleserviceType : HsPhoneNetworkTypes.h
  • PhnVibrateType : HsPhoneMiscTypes.h
  • PhnWAPPushAppIdType : HsPhoneEvent.h
  • PhnWAPPushContentType : HsPhoneEvent.h
  • PhoneAppDialMethodEnum : HsAppLaunchCmd.h
  • PluginInfo : PalmVMPlugin.h
  • PmAudioGroupEnum : PmSoundLibAudioGroup.h
  • PmKeyAttrEnumTag : PmKeyLibCommon.h
  • PmSysGadgetBtStatusTypeEnum : PmSysGadgetLibCommon.h
  • PmSysGadgetStatusGadgetTypeEnum : PmSysGadgetLibCommon.h
  • PmUIUtilAttrEnumTag : PmUIUtilLibCommon.h

- s -

  • SMSMessageStatus : HsPhoneSMSTypes.h
  • SMSMessageType : HsPhoneSMSTypes.h
  • SoundPrefsView : HsAppLaunchCmd.h

- t -

  • tagAudioOutputSetting : PmConnectorLibCommon.h
  • tagSndFileFormatEnum : palmOneSndFileStream.h

- v -

  • VPNLibEventNotificationTypeEnum_ : PalmShimSettings.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v

- a -

  • addrAppLaunchCmdCallerID : HsAppLaunchCmd.h
  • addrAppLaunchCmdHsLookup : HsAppLaunchCmd.h
  • addrListLookupTypeCompany : HsAppLaunchCmd.h
  • addrListLookupTypeFirstName : HsAppLaunchCmd.h
  • addrListLookupTypeIntelligent : HsAppLaunchCmd.h
  • addrListLookupTypeLastName : HsAppLaunchCmd.h
  • addrLookupAnyPhones : HsAppLaunchCmd.h
  • addrLookupSMSPhones : HsAppLaunchCmd.h
  • addrLookupSMSPhonesNoEmail : HsAppLaunchCmd.h
  • addrLookupVoicePhones : HsAppLaunchCmd.h
  • allSize : VMFontLibCommon.h
  • allStyle : VMFontLibCommon.h
  • autoLockMode : HsPhoneTypes.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v

- k -

  • kCCMSSettingsPrimaryTrustedDomain : CarrierCustomLibTypes.h
  • kCCMSSettingsSecondaryTrustedDomain : CarrierCustomLibTypes.h
  • kCCMSSettingsUAProfilingURL : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsCSDDisconnectOnExit : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsDormantOnExit : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsEncryptMSISDN : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsHideDisconnect : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsPDataDisconnectOnExit : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsReserved : CarrierCustomLibTypes.h
  • kCCSMBrowserSettingsVersionInWAPProfile : CarrierCustomLibTypes.h
  • kCCSMMessagingSettings11DigitRecipient : CarrierCustomLibTypes.h
  • kCCSMMessagingSettingsDisableMMSFallback : CarrierCustomLibTypes.h
  • kCCSMMessagingSettingsNormaliseMMSAddress : CarrierCustomLibTypes.h
  • kCCSMMessagingSettingsReserved : CarrierCustomLibTypes.h
  • kCCSMMessagingSettingsStripPhonePlus : CarrierCustomLibTypes.h
  • kCCSMMessagingSettingsWAPProtocol20 : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsEditMSISDN : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsEnableTTY : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsNetworkSelect : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsReserved : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsRoamingIndicator : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsShowEmergencyMode : CarrierCustomLibTypes.h
  • kCCSMPhoneSettingsUseEFSPN : CarrierCustomLibTypes.h
  • kCCSMPrimaryProxyAuthenticate : CarrierCustomLibTypes.h
  • kCCSMPrimaryProxyHide : CarrierCustomLibTypes.h
  • kCCSMPrimaryProxyLocked : CarrierCustomLibTypes.h
  • kCCSMRadioBandEurope : CarrierCustomLibTypes.h
  • kCCSMRadioBandNorthAmerica : CarrierCustomLibTypes.h
  • kCCSMRadioBandUnknown : CarrierCustomLibTypes.h
  • kCCSMSecondaryProxyAuthenticate : CarrierCustomLibTypes.h
  • kCCSMSecondaryProxyHide : CarrierCustomLibTypes.h
  • kCCSMSecondaryProxyLocked : CarrierCustomLibTypes.h
  • kCCSMSettingsBrowserFlags : CarrierCustomLibTypes.h
  • kCCSMSettingsBrowserProxyFlags : CarrierCustomLibTypes.h
  • kCCSMSettingsCarrierMSISDN : CarrierCustomLibTypes.h
  • kCCSMSettingsE911Timeout : CarrierCustomLibTypes.h
  • kCCSMSettingsEditableMSISDN : CarrierCustomLibTypes.h
  • kCCSMSettingsEmailSMTPServer : CarrierCustomLibTypes.h
  • kCCSMSettingsEncryptMSISDN : CarrierCustomLibTypes.h
  • kCCSMSettingsGPRSAutoAttach : CarrierCustomLibTypes.h
  • kCCSMSettingsHomepageURL : CarrierCustomLibTypes.h
  • kCCSMSettingsHTTPHeaders : CarrierCustomLibTypes.h
  • kCCSMSettingsIndicateRoaming : CarrierCustomLibTypes.h
  • kCCSMSettingsMessagingFlags : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSMaxMsgSize : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSMaxVideoSize : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSPort : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSUAProf : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSUAString : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSURL : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSVersionNumber : CarrierCustomLibTypes.h
  • kCCSMSettingsMMSWAPGateway : CarrierCustomLibTypes.h
  • kCCSMSettingsMSISDNHeaderFormat : CarrierCustomLibTypes.h
  • kCCSMSettingsNAI : CarrierCustomLibTypes.h
  • kCCSMSettingsNAIHeaderFormat : CarrierCustomLibTypes.h
  • kCCSMSettingsPOP3Server : CarrierCustomLibTypes.h
  • kCCSMSettingsPrimaryProxyPort : CarrierCustomLibTypes.h
  • kCCSMSettingsPrimaryProxyServer : CarrierCustomLibTypes.h
  • kCCSMSettingsPrimarySecureProxyPort : CarrierCustomLibTypes.h
  • kCCSMSettingsPrimarySecureProxyServer : CarrierCustomLibTypes.h
  • kCCSMSettingsProxyPassword : CarrierCustomLibTypes.h
  • kCCSMSettingsProxyUsername : CarrierCustomLibTypes.h
  • kCCSMSettingsRadioBand : CarrierCustomLibTypes.h
  • kCCSMSettingsReserved : CarrierCustomLibTypes.h
  • kCCSMSettingsSecondaryProxyPort : CarrierCustomLibTypes.h
  • kCCSMSettingsSecondaryProxyServer : CarrierCustomLibTypes.h
  • kCCSMSettingsSecondarySecureProxyPort : CarrierCustomLibTypes.h
  • kCCSMSettingsSecondarySecureProxyServer : CarrierCustomLibTypes.h
  • kCCSMSettingsShowEmergencyMode : CarrierCustomLibTypes.h
  • kCCSMSettingsShowNetworkSelect : CarrierCustomLibTypes.h
  • kCCSMSettingsSMSCNumber : CarrierCustomLibTypes.h
  • kCCSMSettingsSMSEmailGateway : CarrierCustomLibTypes.h
  • kCCSMSettingsSMSMaxMsgSize : CarrierCustomLibTypes.h
  • kCCSMSettingsSMSValidityPeriod : CarrierCustomLibTypes.h
  • kCCSMSettingsSMTPServer : CarrierCustomLibTypes.h
  • kCCSMSettingsSPNSupported : CarrierCustomLibTypes.h
  • kCCSMSettingsSystemReserved : CarrierCustomLibTypes.h
  • kCCSMSettingsVoiceMailNumber : CarrierCustomLibTypes.h
  • kCCSMSystemSettingReserved : CarrierCustomLibTypes.h
  • kIndicatorAlertAlert : HsExtCommon.h
  • kIndicatorAlertCalendar : HsExtCommon.h
  • kIndicatorAlertMail : HsExtCommon.h
  • kIndicatorAlertNone : HsExtCommon.h
  • kIndicatorAlertPending : HsExtCommon.h
  • kIndicatorAlertSMS : HsExtCommon.h
  • kIndicatorAlertVoicemail : HsExtCommon.h
  • kIndicatorBattCharge : HsExtCommon.h
  • kIndicatorBattFull : HsExtCommon.h
  • kIndicatorBattLow : HsExtCommon.h
  • kIndicatorBattNone : HsExtCommon.h
  • kIndicatorBattTrickle : HsExtCommon.h
  • kIndicatorBtConnectAudio : PmSysGadgetLibCommon.h
  • kIndicatorBtConnectHeadset : PmSysGadgetLibCommon.h
  • kIndicatorBtConnectOther : PmSysGadgetLibCommon.h
  • kIndicatorBtDUN : PmSysGadgetLibCommon.h
  • kIndicatorBtOff : PmSysGadgetLibCommon.h
  • kIndicatorBtOn : PmSysGadgetLibCommon.h
  • kIndicatorCountForever : HsExtCommon.h
  • kIndicatorCountGetState : HsExtCommon.h
  • kIndicatorForceGreen : HsExtCommon.h
  • kIndicatorForceNone : HsExtCommon.h
  • kIndicatorForceOff : HsExtCommon.h
  • kIndicatorForceOn : HsExtCommon.h
  • kIndicatorForceRed : HsExtCommon.h
  • kIndicatorForceRedGreen : HsExtCommon.h
  • kIndicatorRingActive : HsExtCommon.h
  • kIndicatorRingContact : HsExtCommon.h
  • kIndicatorRingNone : HsExtCommon.h
  • kIndicatorRingRoam : HsExtCommon.h
  • kIndicatorSignalBad : HsExtCommon.h
  • kIndicatorSignalGood : HsExtCommon.h
  • kIndicatorSignalNone : HsExtCommon.h
  • kIndicatorSignalRoam : HsExtCommon.h
  • kIndicatorUsageDataCall : HsExtCommon.h
  • kIndicatorUsageNone : HsExtCommon.h
  • kIndicatorUsageVoiceCall : HsExtCommon.h
  • kMaxPhnEvtSupported : HsPhoneEvent.h
  • kPmConnectorDeviceAttach : PmConnectorLibCommon.h
  • kPmConnectorDeviceDetach : PmConnectorLibCommon.h
  • kRecordFieldEnumCount : HsPhoneSMSTypes.h
  • kSATRefresh : HsPhoneGSMTypes.h
  • kSndFileFormatAAC : palmOneSndFileStream.h
  • kSndFileFormatMP3 : palmOneSndFileStream.h
  • kSndFileFormatRaw : palmOneSndFileStream.h
  • kSndFileFormatTreoAMR : palmOneSndFileStream.h
  • kSndFileFormatTreoQCP : palmOneSndFileStream.h
  • kSndFileFormatWAV : palmOneSndFileStream.h
  • kWAPAnyApp : HsPhoneEvent.h
  • kWAPdocomoImodeMailUa : HsPhoneEvent.h
  • kWAPdocomoImodeMfUa : HsPhoneEvent.h
  • kWAPdocomoImodeMrUa : HsPhoneEvent.h
  • kWAPDrmUa : HsPhoneEvent.h
  • kWAPEmnUa : HsPhoneEvent.h
  • kWAPLocUa : HsPhoneEvent.h
  • kWAPMmsUa : HsPhoneEvent.h
  • kWAPMotorolaBrowserUa : HsPhoneEvent.h
  • kWAPMotorolaLocationUa : HsPhoneEvent.h
  • kWAPMotorolaNowUa : HsPhoneEvent.h
  • kWAPMotorolaOtaprovUa : HsPhoneEvent.h
  • kWAPMotorolaSplashUa : HsPhoneEvent.h
  • kWAPMsIMclientUa : HsPhoneEvent.h
  • kWAPMsLocalcontentUa : HsPhoneEvent.h
  • kWAPNaiMvswCommand : HsPhoneEvent.h
  • kWAPopenwaveIotaUa : HsPhoneEvent.h
  • kWAPPushSIA : HsPhoneEvent.h
  • kWAPPushSyncml : HsPhoneEvent.h
  • kWAPSyncmlDm : HsPhoneEvent.h
  • kWAPWmlUa : HsPhoneEvent.h
  • kWAPWtaUa : HsPhoneEvent.h
  • kWAPWvUa : HsPhoneEvent.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v

- l -

  • largeFonts : VMFontLibCommon.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v

- m -

  • mmiServiceAllBarringServ : HsPhoneNetworkTypes.h
  • mmiServiceAllInBarringServ : HsPhoneNetworkTypes.h
  • mmiServiceAllOutBarringServ : HsPhoneNetworkTypes.h
  • mmiServiceBAIC : HsPhoneNetworkTypes.h
  • mmiServiceBAICR : HsPhoneNetworkTypes.h
  • mmiServiceBAOC : HsPhoneNetworkTypes.h
  • mmiServiceBAOIC : HsPhoneNetworkTypes.h
  • mmiServiceBAOICX : HsPhoneNetworkTypes.h
  • mmiServiceChangeBarPwd : HsPhoneNetworkTypes.h
  • mmiServiceUnimplemented : HsPhoneNetworkTypes.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v

- n -

  • netIFSettingShimConfig : PalmShimSettings.h
  • netIFSettingShimCreator : PalmShimSettings.h
  • netIFSettingShimHideProgress : PalmShimSettings.h
  • netIFSettingShimLibVersion : PalmShimSettings.h
  • netIFSettingShimLog : PalmShimSettings.h
  • netIFSettingShimUp : PalmShimSettings.h
  • netIFSettingShimVersion : PalmShimSettings.h
  • netIFSettingShimVPNStart : PalmShimSettings.h
  • netIFSettingShimVPNStop : PalmShimSettings.h
  • netMasterAutoLoginWhenWirelessOn : NetMasterLibTypes.h
  • netMasterClientEventVPNConnInstall : NetMasterLibTypes.h
  • netMasterLoginNetGuardEnabled : NetMasterLibTypes.h
  • netMasterLoginPriorityDefault : NetMasterLibTypes.h
  • netMasterLoginPriorityHigh : NetMasterLibTypes.h
  • netMasterLoginPriorityLow : NetMasterLibTypes.h
  • netMasterNetIFShutDownOptCurrentOnly : NetMasterLibTypes.h
  • netMasterNetIFShutDownOptDismissPrgDialog : NetMasterLibTypes.h
  • netMasterNetIFShutDownOptResetNetGuard : NetMasterLibTypes.h
  • netMasterNetLibOpenOptAutoDismiss : NetMasterLibTypes.h
  • netMasterNetLibOpenOptBypassNetGuard : NetMasterLibTypes.h
  • netMasterNetLibOpenOptPrimaryProfileOnly : NetMasterLibTypes.h
  • netPref1xRTTTunnelingForward : NetPrefLibTypes.h
  • netPref1xRTTTunnelingLAST : NetPrefLibTypes.h
  • netPref1xRTTTunnelingReverse : NetPrefLibTypes.h
  • netPref1xRTTTunnelingUnknown : NetPrefLibTypes.h
  • netPrefFallbackAlgrorithmBasic : NetPrefLibTypes.h
  • netPrefFallbackAlgrorithmMutexSticky : NetPrefLibTypes.h
  • netPrefFieldSetDefineOptionNone : NetPrefLibTypes.h
  • netPrefFieldTypeBin : NetPrefLibTypes.h
  • netPrefFieldTypeStr : NetPrefLibTypes.h
  • netPrefFieldTypeZStrList : NetPrefLibTypes.h
  • netPrefMutexStickyFBAStatusFailed : NetPrefLibTypes.h
  • netPrefMutexStickyFBAStatusSucceeded : NetPrefLibTypes.h
  • netPrefMutexStickyFBAStatusUnknown : NetPrefLibTypes.h
  • netPrefNetCloseWaitCarrierDefault : NetPrefLibTypes.h
  • netPrefNetCloseWaitEndOnPowerOff : NetPrefLibTypes.h
  • netPrefNetCloseWaitMaintainSession : NetPrefLibTypes.h
  • netPrefNetIdleTimeoutNever : NetPrefLibTypes.h
  • netPrefRecProtectionDeletionMask : NetPrefLibTypes.h
  • netPrefRecProtectionDuplicationMask : NetPrefLibTypes.h
  • netPrefRecProtectionEditingMask : NetPrefLibTypes.h
  • netPrefSvcBindingCCSM : NetPrefLibTypes.h
  • netPrefSvcBindingCustom : NetPrefLibTypes.h
  • netPrefSvcBindingIOTA : NetPrefLibTypes.h
  • netPrefSvcBindingLAST : NetPrefLibTypes.h
  • netPrefSvcBindingUnknown : NetPrefLibTypes.h
  • netPrefSvcGatewayBrowser : NetPrefLibTypes.h
  • netPrefSvcGatewayCorporate : NetPrefLibTypes.h
  • netPrefSvcGatewayDownloads : NetPrefLibTypes.h
  • netPrefSvcGatewayIM : NetPrefLibTypes.h
  • netPrefSvcGatewayInternet : NetPrefLibTypes.h
  • netPrefSvcGatewayLAST : NetPrefLibTypes.h
  • netPrefSvcGatewayMail : NetPrefLibTypes.h
  • netPrefSvcGatewayMMS : NetPrefLibTypes.h
  • netPrefSvcGatewayPictureMail : NetPrefLibTypes.h
  • netPrefSvcGatewayPrivate : NetPrefLibTypes.h
  • netPrefSvcGatewayUnknown : NetPrefLibTypes.h
  • netPrefSvcGatewayWAP : NetPrefLibTypes.h
  • netPrefSvcMedium1xRTT : NetPrefLibTypes.h
  • netPrefSvcMediumCCSD : NetPrefLibTypes.h
  • netPrefSvcMediumDialUp : NetPrefLibTypes.h
  • netPrefSvcMediumDirect : NetPrefLibTypes.h
  • netPrefSvcMediumGCSD : NetPrefLibTypes.h
  • netPrefSvcMediumGISDN : NetPrefLibTypes.h
  • netPrefSvcMediumGPRS : NetPrefLibTypes.h
  • netPrefSvcMediumLAST : NetPrefLibTypes.h
  • netPrefSvcMediumOEM : NetPrefLibTypes.h
  • netPrefSvcMediumQNC : NetPrefLibTypes.h
  • netPrefSvcMediumUnknown : NetPrefLibTypes.h
  • netPrefSvcTargetBrowser : NetPrefLibTypes.h
  • netPrefSvcTargetCorporate : NetPrefLibTypes.h
  • netPrefSvcTargetDownloads : NetPrefLibTypes.h
  • netPrefSvcTargetIM : NetPrefLibTypes.h
  • netPrefSvcTargetInternet : NetPrefLibTypes.h
  • netPrefSvcTargetLAST : NetPrefLibTypes.h
  • netPrefSvcTargetMail : NetPrefLibTypes.h
  • netPrefSvcTargetMMS : NetPrefLibTypes.h
  • netPrefSvcTargetPictureMail : NetPrefLibTypes.h
  • netPrefSvcTargetReserved1 : NetPrefLibTypes.h
  • netPrefSvcTargetUnknown : NetPrefLibTypes.h
  • netPrefSvcTargetWAP : NetPrefLibTypes.h
  • normal : VMFontLibCommon.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v

- b -

  • bold : VMFontLibCommon.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v

- c -

  • class0 : HsPhoneEvent.h
  • clirNotProvisioned : HsPhoneNetworkTypes.h
  • clirProvisioned : HsPhoneNetworkTypes.h
  • clirTemporaryAllowed : HsPhoneNetworkTypes.h
  • clirTemporaryRestricted : HsPhoneNetworkTypes.h
  • clirUnknown : HsPhoneNetworkTypes.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v

- d -

  • discardType0 : HsPhoneEvent.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v

- f -

  • favDBLibPhoneViewCallLog : FavoritesDBLib.h
  • favDBLibPhoneViewContacts : FavoritesDBLib.h
  • favDBLibPhoneViewDialPad : FavoritesDBLib.h
  • FileStream : palmOneCodecFormat.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v

- g -

  • gillSans : VMFontLibCommon.h
  • gsmCLIRSubscription : HsPhoneNetworkTypes.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v

- h -

  • hsAttr68KActiveCalls : HsExtCommon.h
  • hsAttr68KDisplayOn : HsExtCommon.h
  • hsAttr68KKeyboardLocked : HsExtCommon.h
  • hsAttr68KKeyLockNextWakeTicks : HsExtCommon.h
  • hsAttr68KLidOpen : HsExtCommon.h
  • hsAttr68KPhoneType : HsExtCommon.h
  • hsAttr68KPostProcessRsc : HsExtCommon.h
  • hsAttr68KRingSwitch : HsExtCommon.h
  • hsAttr68KSysActive : HsExtCommon.h
  • hsAttr68KSysSleepReason : HsExtCommon.h
  • hsAttrActiveCalls : HsExtCommon.h
  • hsAttrAllKeysWakeFromSleep : HsExtCommon.h
  • hsAttrDigitizerLock : HsExtCommon.h
  • hsAttrDisplayOn : HsExtCommon.h
  • hsAttrDitherSuppress : HsExtCommon.h
  • hsAttrE911Mode : HsExtCommon.h
  • hsAttrHotSyncSuppress : HsExtCommon.h
  • hsAttrKeyboardDB : HsExtCommon.h
  • hsAttrKeyboardLocked : HsExtCommon.h
  • hsAttrKeyLockNextWakeTicks : HsExtCommon.h
  • hsAttrLidOpen : HsExtCommon.h
  • hsAttrPhoneRadioPowerState : HsExtCommon.h
  • hsAttrPhoneType : HsExtCommon.h
  • hsAttrPostProcessRsc : HsExtCommon.h
  • hsAttrRingSwitch : HsExtCommon.h
  • hsAttrSysActive : HsExtCommon.h
  • hsAttrSysSleepReason : HsExtCommon.h
  • hsDialPrefsAddAreaCodeNo : HsAppLaunchCmd.h
  • hsDialPrefsAddAreaCodeUnknown : HsAppLaunchCmd.h
  • hsDialPrefsAddAreaCodeYes : HsAppLaunchCmd.h
  • hsLightCircumstanceAlertWokeDevice : HsExtCommon.h
  • hsLightCircumstanceNumCircumstances : HsExtCommon.h
  • hsLightCircumstanceQuickTyping : HsExtCommon.h
  • hsLightCircumstanceReserved : HsExtCommon.h
  • hsLightCircumstanceUserNotLooking : HsExtCommon.h
  • hsLightCircumstanceUserNotLookingLongTime : HsExtCommon.h
  • hsLightModeNight : HsExtCommon.h
  • hsLightModeNormal : HsExtCommon.h
  • hsLightModeNumPresets : HsExtCommon.h
  • hsLightModeReserved : HsExtCommon.h
  • hsPrefBlinkGreenLEDInCoverage : HsExtCommon.h
  • hsPrefHard11CharAppCreator : HsExtCommon.h
  • hsPrefJogScanCharAppCreator : HsExtCommon.h
  • hsPrefKeyguardAutoEnableAutoOffExtraTime : HsExtCommon.h
  • hsPrefKeyguardAutoEnableTime : HsExtCommon.h
  • hsPrefKeyguardFlags : HsExtCommon.h
  • hsPrefLCDRefreshRate : HsExtCommon.h
  • hsPrefLidClosedAutoOffSeconds : HsExtCommon.h
  • hsPrefLidStatusChgCharAppCreator : HsExtCommon.h
  • hsPrefNetworkTimeSelected : HsExtCommon.h
  • hsPrefNetworkTZSelected : HsExtCommon.h
  • hsPrefOptHard11CharAppCreator : HsExtCommon.h
  • hsPrefOptHard1CharAppCreator : HsExtCommon.h
  • hsPrefOptHard2CharAppCreator : HsExtCommon.h
  • hsPrefOptHard3CharAppCreator : HsExtCommon.h
  • hsPrefOptHard4CharAppCreator : HsExtCommon.h
  • hsPrefOptHardPowerCharAppCreator : HsExtCommon.h
  • hsPrefOptReservedCharAppCreator : HsExtCommon.h
  • hsPrefPowerOnAppCreator : HsExtCommon.h
  • hsPrefSerialLibConsole : HsExtCommon.h
  • hsPrefSerialLibDef : HsExtCommon.h
  • hsPrefSerialLibHotSyncLocal : HsExtCommon.h
  • hsPrefSerialLibHotSyncModem : HsExtCommon.h
  • hsPrefSerialLibIrda : HsExtCommon.h
  • hsPrefSideHardCharAppCreator : HsExtCommon.h
  • hsPrefTempShiftTimeOut : HsExtCommon.h
  • hsPrefTouchscreenDisableFlags : HsExtCommon.h
  • hsPrefUserNotLookingTime : HsExtCommon.h
  • hsSndBatFull : HsSoundLibCommon.h
  • hsSndBatLow : HsSoundLibCommon.h
  • hsSndBatShutdown : HsSoundLibCommon.h
  • hsSndCardInsert : HsSoundLibCommon.h
  • hsSndCardRemove : HsSoundLibCommon.h
  • hsSndChargerAttach : HsSoundLibCommon.h
  • hsSndChargerDetach : HsSoundLibCommon.h
  • hsSndCmdPlay : HsSoundLibCommon.h
  • hsSndCmdStop : HsSoundLibCommon.h
  • hsSndDeepSleep : HsSoundLibCommon.h
  • hsSndDeepWake : HsSoundLibCommon.h
  • hsSndFormatAmr : HsSoundLibCommon.h
  • hsSndFormatMidi : HsSoundLibCommon.h
  • hsSndRadioInServiceArea : HsSoundLibCommon.h
  • hsSndRadioOff : HsSoundLibCommon.h
  • hsSndRadioOn : HsSoundLibCommon.h
  • hsSndRadioOutServiceArea : HsSoundLibCommon.h
  • hsSndSyncStart : HsSoundLibCommon.h
  • hsSndSyncStop : HsSoundLibCommon.h
  • hsStatusGadgetBattery : HsExtCommon.h
  • hsStatusGadgetSignal : HsExtCommon.h
  • hsVerStrCarrierID : HsExtCommon.h
  • hsVerStrComplete : HsExtCommon.h
  • hsVerStrFirmwareVer : HsExtCommon.h
  • hsVerStrHardware : HsExtCommon.h
  • hsVerStrLifeTime : HsExtCommon.h
  • hsVerStrPalmOSVer : HsExtCommon.h
  • hsVerStrProductName : HsExtCommon.h
  • hsVerStrProductRev : HsExtCommon.h
  • hsVerStrROMBuild : HsExtCommon.h
  • hsVerStrSerialNo : HsExtCommon.h
  • httpErrorReqBodySizeOver : HS_HTTPLibConst.h
  • httpErrorReqHeaderSizeOver : HS_HTTPLibConst.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v

- i -

  • immediateLockMode : HsPhoneTypes.h
  • indicationAuthFailure : HsPhoneEvent.h
  • indicationInitComplete : HsPhoneEvent.h
  • indicationNetworkSearch : HsPhoneEvent.h
  • indicationOtaspMsg : HsPhoneEvent.h
  • indicationPoweringOffRadio : HsPhoneEvent.h
  • indicationResettingRadio : HsPhoneEvent.h
  • indicationSIMChanged : HsPhoneEvent.h
  • indicationStartingRadio : HsPhoneEvent.h
  • italic : VMFontLibCommon.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v

- p -

  • palm : VMFontLibCommon.h
  • palmCodecAAC_ADIF : palmOneCodecFormat.h
  • palmCodecAAC_ADTS : palmOneCodecFormat.h
  • palmCodecAAC_LATM : palmOneCodecFormat.h
  • palmCodecAAC_MP4A : palmOneCodecFormat.h
  • palmCodecAAC_RAW : palmOneCodecFormat.h
  • palmCodecAACLowComplexity : palmOneCodecFormat.h
  • palmCodecAACMainProfile : palmOneCodecFormat.h
  • palmCodecAACScaleableSamplingRate : palmOneCodecFormat.h
  • palmCodecAMR102 : palmOneCodecFormat.h
  • palmCodecAMR122 : palmOneCodecFormat.h
  • palmCodecAMR475 : palmOneCodecFormat.h
  • palmCodecAMR515 : palmOneCodecFormat.h
  • palmCodecAMR59 : palmOneCodecFormat.h
  • palmCodecAMR74 : palmOneCodecFormat.h
  • palmCodecAMR795 : palmOneCodecFormat.h
  • palmCodecAMRDtxDisable : palmOneCodecFormat.h
  • palmCodecAMRDtxEnable : palmOneCodecFormat.h
  • palmCodecAMRM67 : palmOneCodecFormat.h
  • palmCodecBIG_ENDIAN : palmOneCodecFormat.h
  • palmCodecBMP_None : palmOneCodecFormat.h
  • palmCodecBMP_RLE4 : palmOneCodecFormat.h
  • palmCodecBMP_RLE8 : palmOneCodecFormat.h
  • palmCodecCtlAACGetInfo : palmOneCodecFormat.h
  • palmCodecCtlAVCGetDecodedFrame : palmOneCodecFormat.h
  • palmCodecCtlAVCGetInfo : palmOneCodecFormat.h
  • palmCodecCtlAVCSetCropMode : palmOneCodecFormat.h
  • palmCodecCtlCustomBase : palmOneCodecFormat.h
  • palmCodecCtlGetAuthor : palmOneCodecFormat.h
  • palmCodecCtlGetComments : palmOneCodecFormat.h
  • palmCodecCtlGetDate : palmOneCodecFormat.h
  • palmCodecCtlGetKey : palmOneCodecFormat.h
  • palmCodecCtlGetVersion : palmOneCodecFormat.h
  • palmCodecCtlLastBuffer : palmOneCodecFormat.h
  • palmCodecCtlPutKey : palmOneCodecFormat.h
  • palmCodecCtlPutSeed : palmOneCodecFormat.h
  • palmCodecFloatBig : palmOneCodecFormat.h
  • palmCodecFloatLittle : palmOneCodecFormat.h
  • palmCodecImageARGB32 : palmOneCodecFormat.h
  • palmCodecImageBGR32 : palmOneCodecFormat.h
  • palmCodecImageBGR555 : palmOneCodecFormat.h
  • palmCodecImageBGR565 : palmOneCodecFormat.h
  • palmCodecImageBGR888 : palmOneCodecFormat.h
  • palmCodecImageBGRA32 : palmOneCodecFormat.h
  • palmCodecImageCMY : palmOneCodecFormat.h
  • palmCodecImageCMYK : palmOneCodecFormat.h
  • palmCodecImageGIFFrame : palmOneCodecFormat.h
  • palmCodecImageGRAY1 : palmOneCodecFormat.h
  • palmCodecImageGRAY2 : palmOneCodecFormat.h
  • palmCodecImageGRAY4 : palmOneCodecFormat.h
  • palmCodecImageGRAY8 : palmOneCodecFormat.h
  • palmCodecImageHCI : palmOneCodecFormat.h
  • palmCodecImageHSI : palmOneCodecFormat.h
  • palmCodecImageHSL : palmOneCodecFormat.h
  • palmCodecImageHSV : palmOneCodecFormat.h
  • palmCodecImageRGB32 : palmOneCodecFormat.h
  • palmCodecImageRGB555 : palmOneCodecFormat.h
  • palmCodecImageRGB565 : palmOneCodecFormat.h
  • palmCodecImageRGB888 : palmOneCodecFormat.h
  • palmCodecImageRGB888Planar : palmOneCodecFormat.h
  • palmCodecImageRGBA32 : palmOneCodecFormat.h
  • palmCodecImageRGBIndex : palmOneCodecFormat.h
  • palmCodecImageRGBIndex1 : palmOneCodecFormat.h
  • palmCodecImageRGBIndex16 : palmOneCodecFormat.h
  • palmCodecImageRGBIndex2 : palmOneCodecFormat.h
  • palmCodecImageRGBIndex4 : palmOneCodecFormat.h
  • palmCodecImageRGBIndex8 : palmOneCodecFormat.h
  • palmCodecImageYCbCr211 : palmOneCodecFormat.h
  • palmCodecImageYCbCr211Planar : palmOneCodecFormat.h
  • palmCodecImageYCbCr411 : palmOneCodecFormat.h
  • palmCodecImageYCbCr411Planar : palmOneCodecFormat.h
  • palmCodecImageYCbCr420 : palmOneCodecFormat.h
  • palmCodecImageYCbCr420Planar : palmOneCodecFormat.h
  • palmCodecImageYCbCr422 : palmOneCodecFormat.h
  • palmCodecImageYCbCr422Planar : palmOneCodecFormat.h
  • palmCodecImageYCbCr444 : palmOneCodecFormat.h
  • palmCodecImageYCbCr444Planar : palmOneCodecFormat.h
  • palmCodecImageYUV211 : palmOneCodecFormat.h
  • palmCodecImageYUV211Planar : palmOneCodecFormat.h
  • palmCodecImageYUV411 : palmOneCodecFormat.h
  • palmCodecImageYUV411Planar : palmOneCodecFormat.h
  • palmCodecImageYUV420 : palmOneCodecFormat.h
  • palmCodecImageYUV420Planar : palmOneCodecFormat.h
  • palmCodecImageYUV422 : palmOneCodecFormat.h
  • palmCodecImageYUV422Planar : palmOneCodecFormat.h
  • palmCodecImageYUV444 : palmOneCodecFormat.h
  • palmCodecImageYUV444Planar : palmOneCodecFormat.h
  • palmCodecINT16Big : palmOneCodecFormat.h
  • palmCodecINT16Little : palmOneCodecFormat.h
  • palmCodecINT24 : palmOneCodecFormat.h
  • palmCodecINT32Big : palmOneCodecFormat.h
  • palmCodecINT32Little : palmOneCodecFormat.h
  • palmCodecINT8 : palmOneCodecFormat.h
  • palmCodecLITTLE_ENDIAN : palmOneCodecFormat.h
  • palmCodecMONO : palmOneCodecFormat.h
  • palmCodecMPEG4MVFAST : palmOneCodecFormat.h
  • palmCodecMPEG4SEA : palmOneCodecFormat.h
  • palmCodecQCELPEighth : palmOneCodecFormat.h
  • palmCodecQCELPFull : palmOneCodecFormat.h
  • palmCodecQCELPHalf : palmOneCodecFormat.h
  • palmCodecQCELPQuarter : palmOneCodecFormat.h
  • palmCodecQCELPReducedDisabled : palmOneCodecFormat.h
  • palmCodecQCELPReducedEnabled : palmOneCodecFormat.h
  • palmCodecQCELPSilent : palmOneCodecFormat.h
  • palmCodecSTEREO : palmOneCodecFormat.h
  • palmCodecStreamFile : palmOneCodecFormat.h
  • palmCodecUINT16Big : palmOneCodecFormat.h
  • palmCodecUINT16Little : palmOneCodecFormat.h
  • palmCodecUINT24 : palmOneCodecFormat.h
  • palmCodecUINT32Big : palmOneCodecFormat.h
  • palmCodecUINT32Little : palmOneCodecFormat.h
  • palmCodecUINT8 : palmOneCodecFormat.h
  • palmCodecVFSFile : palmOneCodecFormat.h
  • palmOneStatusBarAttrBarVisible : palmOneStatusBar.h
  • palmOneStatusBarAttrDimension : palmOneStatusBar.h
  • palmOneStatusBarAttrExists : palmOneStatusBar.h
  • phnAutoMode : HsPhoneMiscTypes.h
  • phnCarKitMode : HsPhoneMiscTypes.h
  • phnCDMAFirmwareCrowdy : HsPhoneCDMATypes.h
  • phnDataNotAvailable : HsPhoneEvent.h
  • phnErrACMLimitExceeded : HsPhoneErrors.h
  • phnErrAlphabetNotSupported : HsPhoneErrors.h
  • phnErrAuthenticationFailure : HsPhoneErrors.h
  • phnErrBadATCmd : HsPhoneErrors.h
  • phnErrBadATResult : HsPhoneErrors.h
  • phnErrBadCRC : HsPhoneErrors.h
  • phnErrBadServiceCode : HsPhoneErrors.h
  • phnErrBatteryCharging : HsPhoneErrors.h
  • phnErrBatteryLowAlert : HsPhoneErrors.h
  • phnErrBufferTooSmall : HsPhoneErrors.h
  • phnErrCallBarred : HsPhoneErrors.h
  • phnErrCancelled : HsPhoneErrors.h
  • phnErrCannotReplaceMsg : HsPhoneErrors.h
  • phnErrCauseCode16 : HsPhoneErrors.h
  • phnErrCmdCannotBeActioned : HsPhoneErrors.h
  • phnErrCmdUnsupported : HsPhoneErrors.h
  • phnErrCommandInProgress : HsPhoneErrors.h
  • phnErrCongestion : HsPhoneErrors.h
  • phnErrCOPSAbort : HsPhoneErrors.h
  • phnErrCorpPINRequired : HsPhoneErrors.h
  • phnErrCorpPUKRequired : HsPhoneErrors.h
  • phnErrCPError : HsPhoneErrors.h
  • phnErrCSDAccessInfoDiscarded : HsPhoneErrors.h
  • phnErrCSDACMOutOfRange : HsPhoneErrors.h
  • phnErrCSDBearerNotAvailable : HsPhoneErrors.h
  • phnErrCSDBearerNotCapable : HsPhoneErrors.h
  • phnErrCSDBearerNotImplemented : HsPhoneErrors.h
  • phnErrCSDCallBarringIncoming : HsPhoneErrors.h
  • phnErrCSDCallBarringOutgoing : HsPhoneErrors.h
  • phnErrCSDCallImpossible : HsPhoneErrors.h
  • phnErrCSDCallOperationNotAllowed : HsPhoneErrors.h
  • phnErrCSDCallRejected : HsPhoneErrors.h
  • phnErrCSDChannelUnacceptable : HsPhoneErrors.h
  • phnErrCSDDestinationOutOfOrder : HsPhoneErrors.h
  • phnErrCSDFacilityNotImplemented : HsPhoneErrors.h
  • phnErrCSDFacilityNotSubscribed : HsPhoneErrors.h
  • phnErrCSDFacilityRejected : HsPhoneErrors.h
  • phnErrCSDFDNError : HsPhoneErrors.h
  • phnErrCSDIEError : HsPhoneErrors.h
  • phnErrCSDIncomingCallsBarredCUG : HsPhoneErrors.h
  • phnErrCSDIncompatibleDestination : HsPhoneErrors.h
  • phnErrCSDInfoNotImplemented : HsPhoneErrors.h
  • phnErrCSDInvalidMandatoryInfo : HsPhoneErrors.h
  • phnErrCSDInvalidNumberFormat : HsPhoneErrors.h
  • phnErrCSDInvalidTransID : HsPhoneErrors.h
  • phnErrCSDInvalidTransitNetwork : HsPhoneErrors.h
  • phnErrCSDLowerLayerFailure : HsPhoneErrors.h
  • phnErrCSDMessageNotCompatible : HsPhoneErrors.h
  • phnErrCSDMessageTypeNotCompatible : HsPhoneErrors.h
  • phnErrCSDMessageTypeNotImplemented : HsPhoneErrors.h
  • phnErrCSDNetworkOutOfOrder : HsPhoneErrors.h
  • phnErrCSDNoAnswer : HsPhoneErrors.h
  • phnErrCSDNoCircuitAvailable : HsPhoneErrors.h
  • phnErrCSDNoRouteToDestination : HsPhoneErrors.h
  • phnErrCSDNoUserResponse : HsPhoneErrors.h
  • phnErrCSDNumberBusy : HsPhoneErrors.h
  • phnErrCSDNumberChanged : HsPhoneErrors.h
  • phnErrCSDOperatorBarring : HsPhoneErrors.h
  • phnErrCSDProtocolError : HsPhoneErrors.h
  • phnErrCSDQOSNotAvailable : HsPhoneErrors.h
  • phnErrCSDRecoveryOnTimerExpiry : HsPhoneErrors.h
  • phnErrCSDReqCircuitNotAvailable : HsPhoneErrors.h
  • phnErrCSDResourceNotAvailable : HsPhoneErrors.h
  • phnErrCSDRestrictedBearer : HsPhoneErrors.h
  • phnErrCSDSemanticallyIncorrectMessage : HsPhoneErrors.h
  • phnErrCSDServiceNotAvailble : HsPhoneErrors.h
  • phnErrCSDServiceNotImplented : HsPhoneErrors.h
  • phnErrCSDSwitchingCongestion : HsPhoneErrors.h
  • phnErrCSDTempFailure : HsPhoneErrors.h
  • phnErrCSDUnassignedNumber : HsPhoneErrors.h
  • phnErrCSDUserNotMemberCUG : HsPhoneErrors.h
  • phnErrDenied : HsPhoneErrors.h
  • phnErrDestOutOfService : HsPhoneErrors.h
  • phnErrDestSMEBarred : HsPhoneErrors.h
  • phnErrDialStringTooLong : HsPhoneErrors.h
  • phnErrDuplicatePage : HsPhoneErrors.h
  • phnErrDuplicatePlaceHoldler : HsPhoneErrors.h
  • phnErrEmergencyCallsOnly : HsPhoneErrors.h
  • phnErrErrorInMS : HsPhoneErrors.h
  • phnErrFacRejected : HsPhoneErrors.h
  • phnErrFDNMismatch : HsPhoneErrors.h
  • phnErrFiller : HsPhoneErrors.h
  • phnErrFiller2 : HsPhoneErrors.h
  • phnErrFiller3 : HsPhoneErrors.h
  • phnErrFiller4 : HsPhoneErrors.h
  • phnErrFiller5 : HsPhoneErrors.h
  • phnErrFiller6 : HsPhoneErrors.h
  • phnErrFirmwareBootInprogress : HsPhoneErrors.h
  • phnErrFirmwareBootNotInprogress : HsPhoneErrors.h
  • phnErrGPRSAPNMissing : HsPhoneErrors.h
  • phnErrGPRSNetworkRequestDetach : HsPhoneErrors.h
  • phnErrGPRSNetworkRequestPDPDeactivate : HsPhoneErrors.h
  • phnErrGPRSNoAccess : HsPhoneErrors.h
  • phnErrGPRSNoService : HsPhoneErrors.h
  • phnErrGPRSNotAllowed : HsPhoneErrors.h
  • phnErrGPRSPDPActivateFailGMMError : HsPhoneErrors.h
  • phnErrGPRSPDPActivateFailNetReject : HsPhoneErrors.h
  • phnErrGPRSPDPActivateFailNoNSAPI : HsPhoneErrors.h
  • phnErrGPRSPDPActivateFailSMRefuse : HsPhoneErrors.h
  • phnErrGPRSPDPDactivateGMMAbort : HsPhoneErrors.h
  • phnErrGPRSPDPDactivateLCCLinkActivation : HsPhoneErrors.h
  • phnErrGPRSPDPDeactivateNwkRactivate : HsPhoneErrors.h
  • phnErrGPRSPDPDeactivateSNDCPFailure : HsPhoneErrors.h
  • phnErrGPRSRoamingNotAllowed : HsPhoneErrors.h
  • phnErrGPRSServiceRefused : HsPhoneErrors.h
  • phnErrHoldError : HsPhoneErrors.h
  • phnErrIllegalChars : HsPhoneErrors.h
  • phnErrIllegalCondition : HsPhoneErrors.h
  • phnErrIllegalFacility : HsPhoneErrors.h
  • phnErrIllegalIndex : HsPhoneErrors.h
  • phnErrIllegalME : HsPhoneErrors.h
  • phnErrIllegalMS : HsPhoneErrors.h
  • phnErrIllegalMsg : HsPhoneErrors.h
  • phnErrIllegalNumber : HsPhoneErrors.h
  • phnErrIllegalStatus : HsPhoneErrors.h
  • phnErrIllegalType : HsPhoneErrors.h
  • phnErrIncorrectPassword : HsPhoneErrors.h
  • phnErrInfoElemNonExistent : HsPhoneErrors.h
  • phnErrIntermediateResult : HsPhoneErrors.h
  • phnErrInterworking : HsPhoneErrors.h
  • phnErrInvalidDialChars : HsPhoneErrors.h
  • phnErrInvalidMandInfo : HsPhoneErrors.h
  • phnErrInvalidMemIndex : HsPhoneErrors.h
  • phnErrInvalidMobileClass : HsPhoneErrors.h
  • phnErrInvalidMsg : HsPhoneErrors.h
  • phnErrInvalidNAM : HsPhoneErrors.h
  • phnErrInvalidParameter : HsPhoneErrors.h
  • phnErrInvalidSMEAddr : HsPhoneErrors.h
  • phnErrInvalidSMSReference : HsPhoneErrors.h
  • phnErrInvalidTextChars : HsPhoneErrors.h
  • phnErrIOTACommitFailed : HsPhoneErrors.h
  • phnErrIOTACommitInProgress : HsPhoneErrors.h
  • phnErrIOTANoSession : HsPhoneErrors.h
  • phnErrIOTASessionActive : HsPhoneErrors.h
  • phnErrIS683ProtRevNotSupported : HsPhoneErrors.h
  • phnErrLAST_1 : HsPhoneErrors.h
  • phnErrLidClosed : HsPhoneErrors.h
  • phnErrLocAreaNotAllowed : HsPhoneErrors.h
  • phnErrLowerLayer : HsPhoneErrors.h
  • phnErrMEFailure : HsPhoneErrors.h
  • phnErrMemFailure : HsPhoneErrors.h
  • phnErrMemory : HsPhoneErrors.h
  • phnErrMemoryFailure : HsPhoneErrors.h
  • phnErrMemoryFull : HsPhoneErrors.h
  • phnErrMissingCarKitDriver : HsPhoneErrors.h
  • phnErrMMFailed : HsPhoneErrors.h
  • phnErrModemBusy : HsPhoneErrors.h
  • phnErrModemOffline : HsPhoneErrors.h
  • phnErrMsgClassNotSupported : HsPhoneErrors.h
  • phnErrMsgNoCompatible : HsPhoneErrors.h
  • phnErrMsgTypeNonExistent : HsPhoneErrors.h
  • phnErrNAMMismatched : HsPhoneErrors.h
  • phnErrNeedResetModule : HsPhoneErrors.h
  • phnErrNetPINRequired : HsPhoneErrors.h
  • phnErrNetPUKRequired : HsPhoneErrors.h
  • phnErrNetSubPINRequired : HsPhoneErrors.h
  • phnErrNetSubPUKRequired : HsPhoneErrors.h
  • phnErrNetworkNotAllowed : HsPhoneErrors.h
  • phnErrNetworkOutOfOrder : HsPhoneErrors.h
  • phnErrNetworkTimeout : HsPhoneErrors.h
  • phnErrNoAppRegistered : HsPhoneErrors.h
  • phnErrNoCarrier : HsPhoneErrors.h
  • phnErrNoCNMAAckExpected : HsPhoneErrors.h
  • phnErrNoConnection : HsPhoneErrors.h
  • phnErrNoNetwork : HsPhoneErrors.h
  • phnErrNoNetworkService : HsPhoneErrors.h
  • phnErrNoPower : HsPhoneErrors.h
  • phnErrNoRecipient : HsPhoneErrors.h
  • phnErrNoResponse : HsPhoneErrors.h
  • phnErrNoSCSubscription : HsPhoneErrors.h
  • phnErrNoSIM : HsPhoneErrors.h
  • phnErrNoSMSStorage : HsPhoneErrors.h
  • phnErrNotAllowed : HsPhoneErrors.h
  • phnErrNotFound : HsPhoneErrors.h
  • phnErrNotOpen : HsPhoneErrors.h
  • phnErrNotSupported : HsPhoneErrors.h
  • phnErrNotYetSupported : HsPhoneErrors.h
  • phnErrNullParam : HsPhoneErrors.h
  • phnErrNumberBlacklisted : HsPhoneErrors.h
  • phnErrNvBadItem : HsPhoneErrors.h
  • phnErrNVUnInitialized : HsPhoneErrors.h
  • phnErrOperDeterminedBarring : HsPhoneErrors.h
  • phnErrOptionNotSupported : HsPhoneErrors.h
  • phnErrOptionTempOutOfOrder : HsPhoneErrors.h
  • phnErrParam : HsPhoneErrors.h
  • phnErrPasswordRequired : HsPhoneErrors.h
  • phnErrPhFPINRequired : HsPhoneErrors.h
  • phnErrPhFPUKRequired : HsPhoneErrors.h
  • phnErrPhoneAdaptorLinkReserved : HsPhoneErrors.h
  • phnErrPhoneFailure : HsPhoneErrors.h
  • phnErrPhoneNotConnected : HsPhoneErrors.h
  • phnErrPhPINRequired : HsPhoneErrors.h
  • phnErrPIN2Required : HsPhoneErrors.h
  • phnErrPINRequired : HsPhoneErrors.h
  • phnErrPLMNNotAllowed : HsPhoneErrors.h
  • phnErrPoweringDown : HsPhoneErrors.h
  • phnErrProtocolError : HsPhoneErrors.h
  • phnErrPUK2Required : HsPhoneErrors.h
  • phnErrPUKRequired : HsPhoneErrors.h
  • phnErrRadioNotAvailable : HsPhoneErrors.h
  • phnErrReadNV : HsPhoneErrors.h
  • phnErrReqFacNotImplemented : HsPhoneErrors.h
  • phnErrReqFacNotSubscribed : HsPhoneErrors.h
  • phnErrReqOptionNotSubscribed : HsPhoneErrors.h
  • phnErrResourcesUnavailable : HsPhoneErrors.h
  • phnErrResponsePending : HsPhoneErrors.h
  • phnErrRoamingNotAllowed : HsPhoneErrors.h
  • phnErrSATInactive : HsPhoneErrors.h
  • phnErrSATNoInd : HsPhoneErrors.h
  • phnErrSATNotSupported : HsPhoneErrors.h
  • phnErrSATUnavailable : HsPhoneErrors.h
  • phnErrSaveNV : HsPhoneErrors.h
  • phnErrSCAddrUnknown : HsPhoneErrors.h
  • phnErrSCBusy : HsPhoneErrors.h
  • phnErrSCSystemFailure : HsPhoneErrors.h
  • phnErrSIMApplToolkitBusy : HsPhoneErrors.h
  • phnErrSIMBusy : HsPhoneErrors.h
  • phnErrSIMDataDownload : HsPhoneErrors.h
  • phnErrSIMFailure : HsPhoneErrors.h
  • phnErrSIMWrong : HsPhoneErrors.h
  • phnErrSMRejectedDuplicate : HsPhoneErrors.h
  • phnErrSMSFDNError : HsPhoneErrors.h
  • phnErrSMSMemoryFull : HsPhoneErrors.h
  • phnErrSMSMemoryOK : HsPhoneErrors.h
  • phnErrSMSServReserved : HsPhoneErrors.h
  • phnErrSMSStorageFull : HsPhoneErrors.h
  • phnErrSMSXferRejected : HsPhoneErrors.h
  • phnErrSMType0NotSupported : HsPhoneErrors.h
  • phnErrSndDelClass : HsPhoneErrors.h
  • phnErrSndDelInternalMdmError : HsPhoneErrors.h
  • phnErrSndDelInvalidRingerID : HsPhoneErrors.h
  • phnErrSndDelUndeletableRingerID : HsPhoneErrors.h
  • phnErrSndDelUnusedRingerID : HsPhoneErrors.h
  • phnErrSndSaveBadDataLen : HsPhoneErrors.h
  • phnErrSndSaveBadRingerID : HsPhoneErrors.h
  • phnErrSndSaveBadRsp : HsPhoneErrors.h
  • phnErrSndSaveBadSoundType : HsPhoneErrors.h
  • phnErrSndSaveClass : HsPhoneErrors.h
  • phnErrSndSaveContBadDataLen : HsPhoneErrors.h
  • phnErrSndSaveContClass : HsPhoneErrors.h
  • phnErrSndSaveContInternalModem : HsPhoneErrors.h
  • phnErrSndSaveContOutOfMem : HsPhoneErrors.h
  • phnErrSndSaveContSeqNum : HsPhoneErrors.h
  • phnErrSndSaveFileNameInvalid : HsPhoneErrors.h
  • phnErrSndSaveInternalModem : HsPhoneErrors.h
  • phnErrSndSaveOutOfMem : HsPhoneErrors.h
  • phnErrSPPINRequired : HsPhoneErrors.h
  • phnErrSPPUKRequired : HsPhoneErrors.h
  • phnErrStillOpen : HsPhoneErrors.h
  • phnErrStringTooLong : HsPhoneErrors.h
  • phnErrTelematicIWNotSupported : HsPhoneErrors.h
  • phnErrTemporaryFailure : HsPhoneErrors.h
  • phnErrTimeout : HsPhoneErrors.h
  • phnErrTPDUNotSupported : HsPhoneErrors.h
  • phnErrTPVPFNotSupported : HsPhoneErrors.h
  • phnErrTPVPNotSupported : HsPhoneErrors.h
  • phnErrUnassignedNumber : HsPhoneErrors.h
  • phnErrUnexpectedResponse : HsPhoneErrors.h
  • phnErrUnidentifedSubscriber : HsPhoneErrors.h
  • phnErrUnknownApp : HsPhoneErrors.h
  • phnErrUnknownError : HsPhoneErrors.h
  • phnErrUnknownID : HsPhoneErrors.h
  • phnErrUnknownNumber : HsPhoneErrors.h
  • phnErrUnknownSubscriber : HsPhoneErrors.h
  • phnErrUnspecifiedGPSRError : HsPhoneErrors.h
  • phnErrUnspecifiedTPCmdError : HsPhoneErrors.h
  • phnErrUnspecifiedTPDCSError : HsPhoneErrors.h
  • phnErrUnspecifiedTPPIDError : HsPhoneErrors.h
  • phnErrUNUSED : HsPhoneErrors.h
  • phnEvtAlerting : HsPhoneEvent.h
  • phnEvtAlertingPreConnected : HsPhoneEvent.h
  • phnEvtBusy : HsPhoneEvent.h
  • phnEvtCardInsertion : HsPhoneEvent.h
  • phnEvtConference : HsPhoneEvent.h
  • phnEvtConnectConf : HsPhoneEvent.h
  • phnEvtConnectInd : HsPhoneEvent.h
  • phnEvtDataChannel : HsPhoneEvent.h
  • phnEvtDataSessionDisconnected : HsPhoneEvent.h
  • phnEvtDataSessionStatus : HsPhoneEvent.h
  • phnEvtDebugReport : HsPhoneEvent.h
  • phnEvtDisconnectConf : HsPhoneEvent.h
  • phnEvtDisconnectInd : HsPhoneEvent.h
  • phnEvtError : HsPhoneEvent.h
  • phnEvtGPRSRegistration : HsPhoneEvent.h
  • phnEvtIndication : HsPhoneEvent.h
  • phnEvtIOTAStatus : HsPhoneEvent.h
  • phnEvtKeyPress : HsPhoneEvent.h
  • phnEvtMemoryFull : HsPhoneEvent.h
  • phnEvtMemoryOK : HsPhoneEvent.h
  • phnEvtMessageDel : HsPhoneEvent.h
  • phnEvtMessageInd : HsPhoneEvent.h
  • phnEvtMessageMoved : HsPhoneEvent.h
  • phnEvtMessageStat : HsPhoneEvent.h
  • phnEvtMIPFailed : HsPhoneEvent.h
  • phnEvtMMSInd : HsPhoneEvent.h
  • phnEvtNetworkTime : HsPhoneEvent.h
  • phnEvtOneXDataFail : HsPhoneEvent.h
  • phnEvtOneXMipRRQInd : HsPhoneEvent.h
  • phnEvtOneXStatus : HsPhoneEvent.h
  • phnEvtPassword : HsPhoneEvent.h
  • phnEvtPDDataChanged : HsPhoneEvent.h
  • phnEvtPhoneEquipmentMode : HsPhoneEvent.h
  • phnEvtPower : HsPhoneEvent.h
  • phnEvtPreConnected : HsPhoneEvent.h
  • phnEvtProgress : HsPhoneEvent.h
  • phnEvtRegistration : HsPhoneEvent.h
  • phnEvtSATNotification : HsPhoneEvent.h
  • phnEvtSegmentInd : HsPhoneEvent.h
  • phnEvtSSModeChanged : HsPhoneEvent.h
  • phnEvtStartDial : HsPhoneEvent.h
  • phnEvtStartIncomingCall : HsPhoneEvent.h
  • phnEvtSubscriber : HsPhoneEvent.h
  • phnEvtUpdate : HsPhoneEvent.h
  • phnEvtUSSDInd : HsPhoneEvent.h
  • phnEvtVoiceMail : HsPhoneEvent.h
  • phnEvtWAPInd : HsPhoneEvent.h
  • phnHandsetMode : HsPhoneMiscTypes.h
  • phnHeadsetMode : HsPhoneMiscTypes.h
  • phnInvalidEquipmentMode : HsPhoneMiscTypes.h
  • phnIOTAItemBootNAIURL : HsPhoneIOTATypes.h
  • phnIOTAItemBootURL : HsPhoneIOTATypes.h
  • phnIOTAItemConnectionTimeout : HsPhoneIOTATypes.h
  • phnIOTAItemDownloadServerLock : HsPhoneIOTATypes.h
  • phnIOTAItemDownloadServerURL : HsPhoneIOTATypes.h
  • phnIOTAItemHomepageURL : HsPhoneIOTATypes.h
  • phnIOTAItemLastNVItem : HsPhoneIOTATypes.h
  • phnIOTAItemPriDataExchangeURL : HsPhoneIOTATypes.h
  • phnIOTAItemPriDataGatewayURL : HsPhoneIOTATypes.h
  • phnIOTAItemPriIMMessageStore : HsPhoneIOTATypes.h
  • phnIOTAItemPriProxyWDPAddress : HsPhoneIOTATypes.h
  • phnIOTAItemPriSIPConfigServer : HsPhoneIOTATypes.h
  • phnIOTAItemPriSIPEdgeProxyGateway : HsPhoneIOTATypes.h
  • phnIOTAItemPriSIPRetryCount : HsPhoneIOTATypes.h
  • phnIOTAItemPriSIPRetryTimer : HsPhoneIOTATypes.h
  • phnIOTAItemPriWAPPushProxyGatewayURL : HsPhoneIOTATypes.h
  • phnIOTAItemPRLStorageSize : HsPhoneIOTATypes.h
  • phnIOTAItemRootCertificate1 : HsPhoneIOTATypes.h
  • phnIOTAItemRootCertificate2 : HsPhoneIOTATypes.h
  • phnIOTAItemRootCertificate3 : HsPhoneIOTATypes.h
  • phnIOTAItemRootCertificate4 : HsPhoneIOTATypes.h
  • phnIOTAItemSecDataExchangeURL : HsPhoneIOTATypes.h
  • phnIOTAItemSecDataGatewayURL : HsPhoneIOTATypes.h
  • phnIOTAItemSecIMMessageStore : HsPhoneIOTATypes.h
  • phnIOTAItemSecProxyWDPAddress : HsPhoneIOTATypes.h
  • phnIOTAItemSecSIPConfigServer : HsPhoneIOTATypes.h
  • phnIOTAItemSecSIPEdgeProxyGateway : HsPhoneIOTATypes.h
  • phnIOTAItemSecSIPRetryCount : HsPhoneIOTATypes.h
  • phnIOTAItemSecSIPRetryTimer : HsPhoneIOTATypes.h
  • phnIOTAItemSecWAPPushProxyGatewayURL : HsPhoneIOTATypes.h
  • phnIOTAItemSIPPassword : HsPhoneIOTATypes.h
  • phnIOTAItemSIPUsername : HsPhoneIOTATypes.h
  • phnIOTAItemTrustedDomain : HsPhoneIOTATypes.h
  • phnIOTAItemUnknown : HsPhoneIOTATypes.h
  • phnIOTAItemVendingURL : HsPhoneIOTATypes.h
  • phnMIPSession : HsPhoneNetworkTypes.h
  • PhnMsgBoxTypeMAX : HsPhoneNetworkTypes.h
  • phnOneXFailModemSORej : HsPhoneCDMATypes.h
  • phnOneXFailNetworkBusy : HsPhoneCDMATypes.h
  • phnOneXFailNetworkSORej : HsPhoneCDMATypes.h
  • phnOneXFailNoSrv : HsPhoneCDMATypes.h
  • phnOneXFailPrev : HsPhoneCDMATypes.h
  • phnOneXStatusPRev1 : HsPhoneNetworkTypes.h
  • phnOneXStatusPRev3 : HsPhoneNetworkTypes.h
  • phnOneXStatusPRev4 : HsPhoneNetworkTypes.h
  • phnOneXStatusPRev6 : HsPhoneNetworkTypes.h
  • phnOneXStatusPRev7 : HsPhoneNetworkTypes.h
  • phnOneXStatusPRevNoSvc : HsPhoneNetworkTypes.h
  • phnOprtModeLPM : HsPhoneMiscTypes.h
  • phnOprtModeNone : HsPhoneMiscTypes.h
  • phnOprtModeOffline : HsPhoneMiscTypes.h
  • phnOprtModeOfflineA : HsPhoneMiscTypes.h
  • phnOprtModeOnline : HsPhoneMiscTypes.h
  • phnOprtModePwroff : HsPhoneMiscTypes.h
  • phnOprtModeReset : HsPhoneMiscTypes.h
  • phnPacketDataEndStatusAuthFailed : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusDropped : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusIntercept : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusLast : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusNoReason : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusNormal : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusReject : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusReorder : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusRetry : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusTimeout : HsPhoneNetworkTypes.h
  • phnPacketDataEndStatusUnknown : HsPhoneNetworkTypes.h
  • phnPacketDataSessionActive : HsPhoneNetworkTypes.h
  • phnPacketDataSessionDormant : HsPhoneNetworkTypes.h
  • phnPacketDataSessionNone : HsPhoneNetworkTypes.h
  • phnPasswordBarrAB : HsPhoneSecurityTypes.h
  • phnPasswordBarrAC : HsPhoneSecurityTypes.h
  • phnPasswordBarrAG : HsPhoneSecurityTypes.h
  • phnPasswordBarrAI : HsPhoneSecurityTypes.h
  • phnPasswordBarrAO : HsPhoneSecurityTypes.h
  • phnPasswordBarrIR : HsPhoneSecurityTypes.h
  • phnPasswordBarrOI : HsPhoneSecurityTypes.h
  • phnPasswordBarrOX : HsPhoneSecurityTypes.h
  • phnPasswordCorporatePIN : HsPhoneSecurityTypes.h
  • phnPasswordCorporatePUK : HsPhoneSecurityTypes.h
  • phnPasswordNetworkPIN : HsPhoneSecurityTypes.h
  • phnPasswordNetworkPUK : HsPhoneSecurityTypes.h
  • phnPasswordNetworkSubsetPIN : HsPhoneSecurityTypes.h
  • phnPasswordNetworkSubsetPUK : HsPhoneSecurityTypes.h
  • phnPasswordNone : HsPhoneSecurityTypes.h
  • phnPasswordPh1SIMPIN : HsPhoneSecurityTypes.h
  • phnPasswordPh1SIMPUK : HsPhoneSecurityTypes.h
  • phnPasswordPhSIMPIN : HsPhoneSecurityTypes.h
  • phnPasswordServiceProviderPIN : HsPhoneSecurityTypes.h
  • phnPasswordServiceProviderPUK : HsPhoneSecurityTypes.h
  • phnPasswordSIMPIN : HsPhoneSecurityTypes.h
  • phnPasswordSIMPIN2 : HsPhoneSecurityTypes.h
  • phnPasswordSIMPUK : HsPhoneSecurityTypes.h
  • phnPasswordSIMPUK2 : HsPhoneSecurityTypes.h
  • phnPasswordUnknown : HsPhoneSecurityTypes.h
  • PhnPDConfigGPSLock : hsPhoneLocationTypes.h
  • PhnPDConfigIPAddr : hsPhoneLocationTypes.h
  • PhnPDConfigPortID : hsPhoneLocationTypes.h
  • PhnPDConfigPTLMMode : hsPhoneLocationTypes.h
  • PhnPDPAUncert0_5_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert0_75_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert1024_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert12288_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert128_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert12_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert1536_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert16_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert192_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert1_5_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert1_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert2048_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert24_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert256_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert2_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert3072_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert32_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert384_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert3_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert4096_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert48_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert4_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert512_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert6144_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert64_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert6_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert768_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert8192_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert8_M : HsPhoneCDMATypes.h
  • PhnPDPAUncert96_M : HsPhoneCDMATypes.h
  • PhnPDPAUncertGREATER_12288_M : HsPhoneCDMATypes.h
  • PhnPDPAUncertNOT_COMPUTABLE_M : HsPhoneCDMATypes.h
  • phnPDPConnectionTypeMIP : HsPhoneCDMATypes.h
  • phnPDPConnectionTypeMIPWithSIPFallback : HsPhoneCDMATypes.h
  • phnPDPConnectionTypeSIP : HsPhoneCDMATypes.h
  • phnPDPServiceBrowser : HsPhoneCDMATypes.h
  • phnPDPServiceCorporateGateway : HsPhoneCDMATypes.h
  • phnPDPServiceDownloads : HsPhoneCDMATypes.h
  • phnPDPServiceIM : HsPhoneCDMATypes.h
  • phnPDPServiceInternet : HsPhoneCDMATypes.h
  • phnPDPServiceMail : HsPhoneCDMATypes.h
  • phnPDPServiceMMS : HsPhoneCDMATypes.h
  • phnPDPServicePictureMail : HsPhoneCDMATypes.h
  • phnPDPServicePrivate : HsPhoneCDMATypes.h
  • phnPDPServiceWAP : HsPhoneCDMATypes.h
  • phnPowerSave : HsPhoneTypes.h
  • phnRoamPrefAny : HsPhoneNetworkTypes.h
  • phnRoamPrefHomeOnly : HsPhoneNetworkTypes.h
  • phnRoamPrefLast : HsPhoneNetworkTypes.h
  • phnRoamPrefRoamOnly : HsPhoneNetworkTypes.h
  • PhnRoamStatusEnhancedIndicator : HsPhoneNetworkTypes.h
  • phnSATEventInputEchoModeHideInput : HsPhoneGSMTypes.h
  • phnSATEventInputEchoModeShowInput : HsPhoneGSMTypes.h
  • phnSATEventInputFormatDigit : HsPhoneGSMTypes.h
  • phnSATEventInputFormatPacked : HsPhoneGSMTypes.h
  • phnSATEventInputFormatSMSChar : HsPhoneGSMTypes.h
  • phnSATEventInputFormatUCS2 : HsPhoneGSMTypes.h
  • phnSATEventInputFormatUnknown : HsPhoneGSMTypes.h
  • phnSATEventInputFormatUnpacked : HsPhoneGSMTypes.h
  • phnSATEventInputFormatYesNo : HsPhoneGSMTypes.h
  • phnSATEventMenuFlagHelp : HsPhoneGSMTypes.h
  • phnSATEventMenuFlagNextAct : HsPhoneGSMTypes.h
  • phnSATEventSetupCallCallTypeData : HsPhoneGSMTypes.h
  • phnSATEventSetupCallCallTypeFax : HsPhoneGSMTypes.h
  • phnSATEventSetupCallCallTypeVoice : HsPhoneGSMTypes.h
  • phnSATEventToneTimeUnitDeciSeconds : HsPhoneGSMTypes.h
  • phnSATEventToneTimeUnitMinutes : HsPhoneGSMTypes.h
  • phnSATEventToneTimeUnitSeconds : HsPhoneGSMTypes.h
  • phnSATEventToneTypeNoneSpecified : HsPhoneGSMTypes.h
  • phnServiceActivation : HsPhoneTypes.h
  • phnServiceAFLT : HsPhoneTypes.h
  • phnServiceData : HsPhoneTypes.h
  • phnServiceEssentials : HsPhoneTypes.h
  • phnServiceIOTA : HsPhoneTypes.h
  • phnServiceMax : HsPhoneTypes.h
  • phnServiceMisc : HsPhoneTypes.h
  • phnServiceMMS : HsPhoneTypes.h
  • phnServiceSIMToolkit : HsPhoneTypes.h
  • phnServiceSMS : HsPhoneTypes.h
  • phnServiceVoice : HsPhoneTypes.h
  • phnServiceWAP : HsPhoneTypes.h
  • phnSpeakerPhoneMode : HsPhoneMiscTypes.h
  • phnTeleserviceDefault : HsPhoneNetworkTypes.h
  • phnTTYSettingAll : HsPhoneAudioTypes.h
  • phnTTYSettingHearCarryOver : HsPhoneAudioTypes.h
  • phnTTYSettingOff : HsPhoneAudioTypes.h
  • phnTTYSettingVoiceCarryOver : HsPhoneAudioTypes.h
  • PhoneAppDialMethodNormal : HsAppLaunchCmd.h
  • PhoneAppDialMethodSATSetupCall : HsAppLaunchCmd.h
  • plainOnly : VMFontLibCommon.h
  • plugin_allInfo : PalmVMPlugin.h
  • plugin_receiveInfo : PalmVMPlugin.h
  • plugin_sendInfo : PalmVMPlugin.h
  • pmAudioGroupAlert : PmSoundLibAudioGroup.h
  • pmAudioGroupAlertRingOff : PmSoundLibAudioGroup.h
  • pmAudioGroupApp : PmSoundLibAudioGroup.h
  • pmAudioGroupCall : PmSoundLibAudioGroup.h
  • pmAudioGroupHighPriority : PmSoundLibAudioGroup.h
  • pmAudioGroupInteractive : PmSoundLibAudioGroup.h
  • pmAudioGroupNone : PmSoundLibAudioGroup.h
  • pmAudioGroupReserved1 : PmSoundLibAudioGroup.h
  • pmAudioGroupSystem : PmSoundLibAudioGroup.h
  • pmKeyAttrGetEndKeyCode : PmKeyLibCommon.h
  • pmKeyAttrGetLauncherKeyCode : PmKeyLibCommon.h
  • pmKeyAttrGetMenuKeyCode : PmKeyLibCommon.h
  • pmKeyAttrGetPhoneKeyCode : PmKeyLibCommon.h
  • pmKeyAttrGetSendKeyCode : PmKeyLibCommon.h
  • pmKeyAttrPagingMode : PmKeyLibCommon.h
  • pmSndFormatPauseStream : HsSoundLibCommon.h
  • pmSndFormatResumeStream : HsSoundLibCommon.h
  • pmSndFormatSetAttackEnvID : HsSoundLibCommon.h
  • pmSndFormatSetStoppable : HsSoundLibCommon.h
  • pmSysGadgetStatusGadgetBattery : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetBt : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetCallFwd : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetEvdo : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetLine : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetNone : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetOperator : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetRoaming : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetSignal : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetTty : PmSysGadgetLibCommon.h
  • pmSysGadgetStatusGadgetVm : PmSysGadgetLibCommon.h
  • pmUIUtilAttrAutoSnoozeAttns : PmUIUtilLibCommon.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v

- r -

  • replaceType1 : HsPhoneEvent.h
  • replaceType2 : HsPhoneEvent.h
  • replaceType3 : HsPhoneEvent.h
  • replaceType4 : HsPhoneEvent.h
  • replaceType5 : HsPhoneEvent.h
  • replaceType6 : HsPhoneEvent.h
  • replaceType7 : HsPhoneEvent.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v

- s -

  • sabon : VMFontLibCommon.h
  • size12 : VMFontLibCommon.h
  • size6 : VMFontLibCommon.h
  • size9 : VMFontLibCommon.h
  • smallFonts : VMFontLibCommon.h
  • sndControlCodecCustomControl : PalmSoundCustomCtrl.h
  • sndFormatAAC : PalmSoundMgrExt.h
  • sndFormatDVI_ADPCM : PalmSoundMgrExt.h
  • sndFormatIMA_ADPCM : PalmSoundMgrExt.h
  • sndFormatMP3 : PalmSoundMgrExt.h
  • sndFormatOGG : PalmSoundMgrExt.h
  • sndFormatPCM : PalmSoundMgrExt.h
  • soundPrefTypeCalendar : TonesLibTypes.h
  • soundPrefTypeEmail : TonesLibTypes.h
  • soundPrefTypeIM : TonesLibTypes.h
  • soundPrefTypeLast : TonesLibTypes.h
  • soundPrefTypeMMS : TonesLibTypes.h
  • soundPrefTypeNetworkSounds : TonesLibTypes.h
  • soundPrefTypePhone : TonesLibTypes.h
  • soundPrefTypeSMS : TonesLibTypes.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v

- t -

  • tonePlay100Times : TonesLibTypes.h
  • tonePlay10Times : TonesLibTypes.h
  • tonePlay3Times : TonesLibTypes.h
  • tonePlay5Times : TonesLibTypes.h
  • tonePlayOnce : TonesLibTypes.h
  • tonePlayTwice : TonesLibTypes.h
  • toneRepeatEvery10Minutes : TonesLibTypes.h
  • toneRepeatEvery30Minutes : TonesLibTypes.h
  • toneRepeatEvery5Minutes : TonesLibTypes.h
  • toneRepeatEveryMinute : TonesLibTypes.h
  • toneTimeUnitDays : TonesLibTypes.h
  • toneTimeUnitHours : TonesLibTypes.h
  • toneTimeUnitMinutes : TonesLibTypes.h
  • toneTypeAAC : TonesLibTypes.h
  • toneTypeAMR : TonesLibTypes.h
  • toneTypeMIDI : TonesLibTypes.h
  • toneTypeMP3 : TonesLibTypes.h
  • toneTypeQCELP : TonesLibTypes.h
  • toneTypeSystemSound : TonesLibTypes.h
  • toneTypeWAV : TonesLibTypes.h
  • toneVibrateAlert : TonesLibTypes.h
  • toneVibrateCalender : TonesLibTypes.h
  • toneVibrateMail : TonesLibTypes.h
  • toneVibrateNone : TonesLibTypes.h
  • toneVibrateRing : TonesLibTypes.h
  • toneVibrateSMS : TonesLibTypes.h
  • toneVibrateThenRing : TonesLibTypes.h
  • toneVibrateVoicemail : TonesLibTypes.h
  • toneVolume1 : TonesLibTypes.h
  • toneVolume2 : TonesLibTypes.h
  • toneVolume3 : TonesLibTypes.h
  • toneVolume4 : TonesLibTypes.h
  • toneVolume5 : TonesLibTypes.h
  • toneVolume6 : TonesLibTypes.h
  • toneVolume7 : TonesLibTypes.h
  • toneVolumeOff : TonesLibTypes.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v

- v -

  • VFS : palmOneCodecFormat.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- b -

  • BGServiceCancelRqst() : PalmBGService.h
  • BGServiceClose() : PalmBGService.h
  • BGServiceINetRqst() : PalmBGService.h
  • BGServiceNetRqst() : PalmBGService.h
  • BGServiceOpen() : PalmBGService.h
  • BGServiceVersion() : PalmBGService.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- l -

  • LcdOverlayLibClose() : PalmLcdOverlay.h, palmOneLcdOverlay.h
  • LcdOverlayLibControl() : PalmLcdOverlay.h, palmOneLcdOverlay.h
  • LcdOverlayLibGetVersion() : PalmLcdOverlay.h, palmOneLcdOverlay.h
  • LcdOverlayLibOpen() : PalmLcdOverlay.h, palmOneLcdOverlay.h
  • LcdOverlayLibSleep() : PalmLcdOverlay.h
  • LcdOverlayLibWake() : PalmLcdOverlay.h
  • LocationCopy() : LocsLib.h
  • LocationCopyV20() : LocsLib.h
  • LocationFinal() : LocsLib.h
  • LocationFinalV20() : LocsLib.h
  • LocationGetSize() : LocsLib.h
  • LocationGetSizeV20() : LocsLib.h
  • LocationInit() : LocsLib.h
  • LocationInitV20() : LocsLib.h
  • LocationIsDSTPast() : LocsLib.h
  • LocationMakeGeneric() : LocsLib.h
  • LocationSetName() : LocsLib.h
  • LocationSetNote() : LocsLib.h
  • LocationSetPosition() : LocsLib.h
  • LocDBChangeRecord() : LocsLib.h
  • LocDBChangeRecordV20() : LocsLib.h
  • LocDBCompareRecordsSimple() : LocsLib.h
  • LocDBConvertRecord() : LocsLib.h
  • LocDBConvertRecordV20() : LocsLib.h
  • LocDBCopyLocation() : LocsLib.h
  • LocDBDeleteRecord() : LocsLib.h
  • LocDBFindCustomRecord() : LocsLib.h
  • LocDBFindCustomRecordV20() : LocsLib.h
  • LocDBFindFirst() : LocsLib.h
  • LocDBFindFirstByName() : LocsLib.h
  • LocDBFindFirstByUTCCountry() : LocsLib.h
  • LocDBFindFirstInList() : LocsLib.h
  • LocDBGetCustomList() : LocsLib.h
  • LocDBGetNearestLocation() : LocsLib.h
  • LocDBGetRecord() : LocsLib.h
  • LocDBGetRecordList() : LocsLib.h
  • LocDBGetRecordListV20() : LocsLib.h
  • LocDBGetRecordV20() : LocsLib.h
  • LocDBGetVersion() : LocsLib.h
  • LocDBInitDBs() : LocsLib.h
  • LocDBNewRecord() : LocsLib.h
  • LocDBNewRecordV20() : LocsLib.h
  • LocDBOpenCustom() : LocsLib.h
  • LocDBOpenDefault() : LocsLib.h
  • LocDBRecordSize() : LocsLib.h
  • LocDBSetRecordCustom() : LocsLib.h
  • LocDBSort() : LocsLib.h
  • LocsLibClose() : LocsLib.h
  • LocsLibDSTAlarmClear() : LocsLib.h
  • LocsLibDSTAlarmIsDST() : LocsLib.h
  • LocsLibDSTAlarmSet() : LocsLib.h
  • LocsLibGetVersion() : LocsLib.h
  • LocsLibLaunchEditListDialogue() : LocsLib.h
  • LocsLibLaunchSelDialogue() : LocsLib.h
  • LocsLibOpen() : LocsLib.h
  • LocsLibSleep() : LocsLib.h
  • LocsLibWake() : LocsLib.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- n -

  • NetMasterAutoLoginSettingGet() : NetMasterLibrary.h
  • NetMasterAutoLoginSettingSet() : NetMasterLibrary.h
  • NetMasterLibVersionGet() : NetMasterLibrary.h
  • NetMasterNetInterfacesShutDown() : NetMasterLibrary.h
  • NetMasterNetLibIsFullyUp() : NetMasterLibrary.h
  • NetMasterNetLibIsLoggingIn() : NetMasterLibrary.h
  • NetMasterNetLibOpenIfFullyUp() : NetMasterLibrary.h
  • NetMasterNetLibOpenWithOptions() : NetMasterLibrary.h
  • NetMasterSCContextAnchorTimeoutSet() : NetMasterLibrary.h
  • NetMasterSCNetAttach() : NetMasterLibrary.h
  • NetMasterSCNetDetach() : NetMasterLibrary.h
  • NetMasterSCSessionCountGet() : NetMasterLibrary.h
  • NetMasterSCSessionIDGetFromContext() : NetMasterLibrary.h
  • NetMasterSCSessionIsActive() : NetMasterLibrary.h
  • NetMasterSCSessionsEnumerate() : NetMasterLibrary.h
  • NetMasterSCSessionShutDown() : NetMasterLibrary.h
  • NetMasterSCSessionSvcRecIDGet() : NetMasterLibrary.h
  • NetPrefLibClose() : NetPrefLibrary.h
  • NetPrefLibOpen() : NetPrefLibrary.h
  • NetPrefLibSleep() : NetPrefLibrary.h
  • NetPrefLibVersionGet() : NetPrefLibrary.h
  • NetPrefLibWake() : NetPrefLibrary.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- c -

  • CameraLibCapture() : CameraLib.h
  • CameraLibClose() : CameraLib.h
  • CameraLibOpen() : CameraLib.h
  • CameraLibPreview() : CameraLib.h
  • CameraLibPreviewStart() : CameraLib.h
  • CameraLibPreviewStop() : CameraLib.h
  • CameraLibRegisterGet() : CameraLib.h
  • CameraLibRegisterSet() : CameraLib.h
  • CameraLibSleep() : CameraLib.h
  • CameraLibWake() : CameraLib.h
  • CamLibClose() : palmOneCamera.h
  • CamLibControl() : palmOneCamera.h
  • CamLibGetVersion() : palmOneCamera.h
  • CamLibOpen() : palmOneCamera.h
  • CamLibSleep() : palmOneCamera.h
  • CamLibWake() : palmOneCamera.h
  • CCustomLibClose() : CarrierCustomLib.h
  • CCustomLibGetCarrierCode() : CarrierCustomLib.h
  • CCustomLibGetCarrierCodeLength() : CarrierCustomLib.h
  • CCustomLibGetCarrierSetting() : CarrierCustomLib.h
  • CCustomLibOpen() : CarrierCustomLib.h
  • CCustomLibSleep() : CarrierCustomLib.h
  • CCustomLibVersionGet() : CarrierCustomLib.h
  • CCustomLibWake() : CarrierCustomLib.h
  • CodecMgrClose() : palmOneCodecPluginMgr.h
  • CodecMgrCreateSession() : palmOneCodecPluginMgr.h
  • CodecMgrCreateSessionByID() : palmOneCodecPluginMgr.h
  • CodecMgrCustomControl() : palmOneCodecPluginMgr.h
  • CodecMgrDeleteSession() : palmOneCodecPluginMgr.h
  • CodecMgrEncodeDecode() : palmOneCodecPluginMgr.h
  • CodecMgrEnumerateFormats() : palmOneCodecPluginMgr.h
  • CodecMgrGetMaxDestBufferSize() : palmOneCodecPluginMgr.h
  • CodecMgrGetSessionInfo() : palmOneCodecPluginMgr.h
  • CodecMgrIsFormatSupported() : palmOneCodecPluginMgr.h
  • CodecMgrLibAPIVersion() : palmOneCodecPluginMgr.h
  • CodecMgrOpen() : palmOneCodecPluginMgr.h
  • CodecMgrResetSession() : palmOneCodecPluginMgr.h
  • CodecMgrSleep() : palmOneCodecPluginMgr.h
  • CodecMgrWake() : palmOneCodecPluginMgr.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- d -

  • DefaultHelperLibClose() : DefaultHelperLib.h
  • DefaultHelperLibGetDefaultHelper() : DefaultHelperLib.h
  • DefaultHelperLibOpen() : DefaultHelperLib.h
  • DefaultHelperLibSetDefaultHelper() : DefaultHelperLib.h
  • DefaultHelperLibSleep() : DefaultHelperLib.h
  • DefaultHelperLibWake() : DefaultHelperLib.h
  • DexGetDisplayAddress() : PalmDisplayExtent.h
  • DexGetDisplayDimensions() : PalmDisplayExtent.h
  • DmSyncDatabase() : PmPalmOSNVFS.h
  • DoFontDialog() : palmOneVMFontLib.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- f -

  • FavDBLibClose() : FavoritesDBLib.h
  • FavDBLibGetRecordId() : FavoritesDBLib.h
  • FavDBLibGetRecordLabel() : FavoritesDBLib.h
  • FavDBLibGetSpeedDialInfo() : FavoritesDBLib.h
  • FavDBLibIsFavoriteWithId() : FavoritesDBLib.h
  • FavDBLibLookupInSpeedDialDB() : FavoritesDBLib.h
  • FavDBLibNewAppFavorite() : FavoritesDBLib.h
  • FavDBLibNewEmailFavorite() : FavoritesDBLib.h
  • FavDBLibNewMsgFavorite() : FavoritesDBLib.h
  • FavDBLibNewPhoneFavorite() : FavoritesDBLib.h
  • FavDBLibNewPhoneViewFavorite() : FavoritesDBLib.h
  • FavDBLibNewWebFavorite() : FavoritesDBLib.h
  • FavDBLibOpen() : FavoritesDBLib.h
  • FavDBLibResolveAddress() : FavoritesDBLib.h
  • FavDBLibSeekSpeedDialRecord() : FavoritesDBLib.h
  • FavDBLibSleep() : FavoritesDBLib.h
  • FavDBLibWake() : FavoritesDBLib.h
  • FileBrowserLibAccept() : FileBrowserLib68K.h
  • FileBrowserLibClose() : FileBrowserLib68K.h
  • FileBrowserLibConnect() : FileBrowserLib68K.h
  • FileBrowserLibControl() : FileBrowserLib68K.h
  • FileBrowserLibDisconnect() : FileBrowserLib68K.h
  • FileBrowserLibGet() : FileBrowserLib68K.h
  • FileBrowserLibHandleEvent() : FileBrowserLib68K.h
  • FileBrowserLibOpen() : FileBrowserLib68K.h
  • FileBrowserLibParseFileURL() : FileBrowserLib68K.h
  • FileBrowserLibPut() : FileBrowserLib68K.h
  • FileBrowserLibReceive() : FileBrowserLib68K.h
  • FileBrowserLibRequest() : FileBrowserLib68K.h
  • FileBrowserLibSend() : FileBrowserLib68K.h
  • FileBrowserLibShowMultiselectDialog() : FileBrowserLib68K.h
  • FileBrowserLibShowOpenDialog() : FileBrowserLib68K.h
  • FileBrowserLibShowSaveAsDialog() : FileBrowserLib68K.h
  • FileBrowserLibSleep() : FileBrowserLib68K.h
  • FileBrowserLibWake() : FileBrowserLib68K.h
  • FrmCountObjectsInNavOrder() : HsNav.h
  • FrmGetNavEntry() : HsNav.h
  • FrmGetNavOrder() : HsNav.h
  • FrmGetNavState() : HsNav.h
  • FrmNavDrawFocusRing() : HsNav.h
  • FrmNavGetFocusRingInfo() : HsNav.h
  • FrmNavObjectTakeFocus() : HsNav.h
  • FrmNavRemoveFocusRing() : HsNav.h
  • FrmSetNavEntry() : HsNav.h
  • FrmSetNavOrder() : HsNav.h
  • FrmSetNavState() : HsNav.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- g -

  • GoLcdGetBounds() : PalmGoLCD.h
  • GoLcdGetGsiState() : PalmGoLCD.h
  • GoLcdGetInkState() : PalmGoLCD.h
  • GoLcdGetStatus() : PalmGoLCD.h
  • GoLcdGetTimeout() : PalmGoLCD.h
  • GoLcdLibClose() : PalmGoLCD.h
  • GoLcdLibOpen() : PalmGoLCD.h
  • GoLcdSetBounds() : PalmGoLCD.h
  • GoLcdSetGsiState() : PalmGoLCD.h
  • GoLcdSetInkState() : PalmGoLCD.h
  • GoLcdSetStatus() : PalmGoLCD.h
  • GoLcdSetTimeout() : PalmGoLCD.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- h -

  • HALAttnGetPalmLedAttributes() : PalmLED.h
  • HALAttnSetPalmLedAttributes() : PalmLED.h
  • HRTimeLibClose() : PalmHiResTime.h, palmOneHiResTimer.h
  • HRTimeLibGetTime() : PalmHiResTime.h, palmOneHiResTimer.h
  • HRTimeLibOpen() : PalmHiResTime.h, palmOneHiResTimer.h
  • HRTimeLibTicksPerSecond() : PalmHiResTime.h, palmOneHiResTimer.h
  • HS_HTTPLibAuthCacheGetChallengeTokenSS() : HS_HTTPLib68K.h
  • HS_HTTPLibAuthInfoPass() : HS_HTTPLib68K.h
  • HS_HTTPLibAuthInfoRealm() : HS_HTTPLib68K.h
  • HS_HTTPLibAuthInfoTidy() : HS_HTTPLib68K.h
  • HS_HTTPLibAuthInfoUser() : HS_HTTPLib68K.h
  • HS_HTTPLibCertBeginPeekIssuerRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertBeginPeekSubjectRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertEndPeekIssuerRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertEndPeekSubjectRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListBeginDecode() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListClone() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListDelete() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListEndDecode() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListGetCipherInfo() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListImportCert() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListLength() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListLock() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListNew() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListType() : HS_HTTPLib68K.h
  • HS_HTTPLibCertListUnlock() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekIssuerRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekIssuerRDNStrType() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekRSAPublicKeyBits() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekSerialNumber() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekSignAlgo() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekSubjectRDN() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekSubjectRDNStrType() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekValidityEnd() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekValidityStart() : HS_HTTPLib68K.h
  • HS_HTTPLibCertPeekVersion() : HS_HTTPLib68K.h
  • HS_HTTPLibClearDNSCache() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListClone() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListDelete() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListIsValid() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListLength() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListNew() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertListSetValid() : HS_HTTPLib68K.h
  • HS_HTTPLibClientCertSelect() : HS_HTTPLib68K.h
  • HS_HTTPLibClose() : HS_HTTPLib68K.h
  • HS_HTTPLibCloseAllKeepAlive() : HS_HTTPLib68K.h
  • HS_HTTPLibCookieMakeEmpty() : HS_HTTPLib68K.h
  • HS_HTTPLibDataHandle_Delete() : HS_HTTPLib68K.h
  • HS_HTTPLibDataHandle_Length() : HS_HTTPLib68K.h
  • HS_HTTPLibDataHandle_Lock() : HS_HTTPLib68K.h
  • HS_HTTPLibDataHandle_Unlock() : HS_HTTPLib68K.h
  • HS_HTTPLibFinalize() : HS_HTTPLib68K.h
  • HS_HTTPLibFindAuthCandidate() : HS_HTTPLib68K.h
  • HS_HTTPLibFindAuthInfo() : HS_HTTPLib68K.h
  • HS_HTTPLibFixedString_Delete() : HS_HTTPLib68K.h
  • HS_HTTPLibFixedString_Length() : HS_HTTPLib68K.h
  • HS_HTTPLibFixedString_Lock() : HS_HTTPLib68K.h
  • HS_HTTPLibFixedString_Unlock() : HS_HTTPLib68K.h
  • HS_HTTPLibFixedStringNew() : HS_HTTPLib68K.h
  • HS_HTTPLibHeaderSplitByX() : HS_HTTPLib68K.h
  • HS_HTTPLibInitialize() : HS_HTTPLib68K.h
  • HS_HTTPLibIsHTTP11OverProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibIsSendCookie() : HS_HTTPLib68K.h
  • HS_HTTPLibIsSendReferer() : HS_HTTPLib68K.h
  • HS_HTTPLibIsUseProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibLoadCookiesEntries() : HS_HTTPLib68K.h
  • HS_HTTPLibMakeAuthInfo() : HS_HTTPLib68K.h
  • HS_HTTPLibMakeCertList() : HS_HTTPLib68K.h
  • HS_HTTPLibMakeCookiesString() : HS_HTTPLib68K.h
  • HS_HTTPLibMakeProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibOpen() : HS_HTTPLib68K.h
  • HS_HTTPLibOpenCount() : HS_HTTPLib68K.h
  • HS_HTTPLibRegisterSSLClass() : HS_HTTPLib68K.h
  • HS_HTTPLibSaveCookiesEntries() : HS_HTTPLib68K.h
  • HS_HTTPLibServerCertConfirm() : HS_HTTPLib68K.h
  • HS_HTTPLibSetConnectTimeOut() : HS_HTTPLib68K.h
  • HS_HTTPLibSetCookie() : HS_HTTPLib68K.h
  • HS_HTTPLibSetCookieMax() : HS_HTTPLib68K.h
  • HS_HTTPLibSetCookieMode() : HS_HTTPLib68K.h
  • HS_HTTPLibSetCookieX() : HS_HTTPLib68K.h
  • HS_HTTPLibSetDefaultHeaders() : HS_HTTPLib68K.h
  • HS_HTTPLibSetDNSMaxRetry() : HS_HTTPLib68K.h
  • HS_HTTPLibSetDNSRetryInterval() : HS_HTTPLib68K.h
  • HS_HTTPLibSetHTTP11OverProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibSetHTTPPort() : HS_HTTPLib68K.h
  • HS_HTTPLibSetHTTPSPort() : HS_HTTPLib68K.h
  • HS_HTTPLibSetMaxKeepAliveTimeout() : HS_HTTPLib68K.h
  • HS_HTTPLibSetMaxRequestBody() : HS_HTTPLib68K.h
  • HS_HTTPLibSetMaxRequestHeader() : HS_HTTPLib68K.h
  • HS_HTTPLibSetNetLibProc() : HS_HTTPLib68K.h
  • HS_HTTPLibSetProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibSetReqTimeOut() : HS_HTTPLib68K.h
  • HS_HTTPLibSetRspTimeOut() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSendCookie() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSendProxyKeepAlive() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSendReferer() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSSLClientCertSelectProc() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSSLServerCertConfirmProc() : HS_HTTPLib68K.h
  • HS_HTTPLibSetSSLVersionFlag() : HS_HTTPLib68K.h
  • HS_HTTPLibSetTunnelingCallback() : HS_HTTPLib68K.h
  • HS_HTTPLibSetUseProxy() : HS_HTTPLib68K.h
  • HS_HTTPLibSetUserAgent() : HS_HTTPLib68K.h
  • HS_HTTPLibSetUseragentSelectionRule() : HS_HTTPLib68K.h
  • HS_HTTPLibSetUserPass() : HS_HTTPLib68K.h
  • HS_HTTPLibSetUserPassX() : HS_HTTPLib68K.h
  • HS_HTTPLibSetWakeUpCallback() : HS_HTTPLib68K.h
  • HS_HTTPLibSleep() : HS_HTTPLib68K.h
  • HS_HTTPLibSSLClass() : HS_HTTPLib68K.h
  • HS_HTTPLibSSLCloseCertDB() : HS_HTTPLib68K.h
  • HS_HTTPLibSSLOpenCertDB() : HS_HTTPLib68K.h
  • HS_HTTPLibSSLTimeout() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamAddHeader() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamAddHeaderLine() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamClose() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamCreateRequest() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamCreateRequestWithChunkEncoding() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamDelete() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetContentLength() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetEntityLength() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetFlag() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetHeader() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetHeaderWithOffset() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetRequestSent() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetResponseHeader() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetResponseHeaderLength() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetScheme() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetState() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamGetStatusCode() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamIsHeaderReceived() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamNew() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamReceiveResponse() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamResumeTimer() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamSendRequest() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamSendRequestWithChunkEncoding() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamSendRequestWithPostData() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamSetPostData() : HS_HTTPLib68K.h
  • HS_HTTPLibStreamSuspendTimer() : HS_HTTPLib68K.h
  • HS_HTTPLibString_Delete() : HS_HTTPLib68K.h
  • HS_HTTPLibString_Length() : HS_HTTPLib68K.h
  • HS_HTTPLibString_Lock() : HS_HTTPLib68K.h
  • HS_HTTPLibString_Unlock() : HS_HTTPLib68K.h
  • HS_HTTPLibStringNew() : HS_HTTPLib68K.h
  • HS_HTTPLibURLString_Delete() : HS_HTTPLib68K.h
  • HS_HTTPLibURLString_Length() : HS_HTTPLib68K.h
  • HS_HTTPLibURLString_Lock() : HS_HTTPLib68K.h
  • HS_HTTPLibURLString_Unlock() : HS_HTTPLib68K.h
  • HS_HTTPLibURLStringNew() : HS_HTTPLib68K.h
  • HS_HTTPLibVHandle_Delete() : HS_HTTPLib68K.h
  • HS_HTTPLibVHandle_Length() : HS_HTTPLib68K.h
  • HS_HTTPLibVHandle_Lock() : HS_HTTPLib68K.h
  • HS_HTTPLibVHandle_Unlock() : HS_HTTPLib68K.h
  • HS_HTTPLibWake() : HS_HTTPLib68K.h
  • HsAboutHandspringApp() : HsExt.h
  • HsAttrGet() : HsExt.h
  • HsAttrSet() : HsExt.h
  • HsBrowseUrl() : HsExt.h
  • HsCreateNewEmail() : HsExt.h
  • HsCreateNewMessage() : HsExt.h
  • HsEvtMetaEvent() : HsExt.h
  • HsExtDoSaveAsDialog() : HsExt.h
  • HsExtExgLocalAccept() : HsExgMgr.h
  • HsExtExgLocalDisconnect() : HsExgMgr.h
  • HsExtExgSelectTarget() : HsExgMgr.h
  • HsGetPhoneLibrary() : HsExt.h
  • HsGetTrapAddress() : HsExt.h
  • HsGetVersionString() : HsExt.h
  • HsGrfGetStateExt() : HsExt.h
  • HsGrfSetStateExt() : HsExt.h
  • HsIndicatorState() : HsExt.h
  • HsInfo() : HsExt.h
  • HsIsHTTPLibraryLoaded() : HsExt.h
  • HsKeyChrCodeToKeyCode() : HsExt.h
  • HsKeyCurrentStateExt() : HsExt.h
  • HsKeyEnableKey() : HsExt.h
  • HsKeyEventIsFromKeyboard() : HsExt.h
  • HsKeyKeyCodeToChrCode() : HsExt.h
  • HsKeySetMaskExt() : HsExt.h
  • HsKeysPressed() : HsExt.h
  • HsKeyStop() : HsExt.h
  • HsLightCircumstance() : HsExt.h
  • HsLightMode() : HsExt.h
  • HsNavDrawFocusRing() : HsExt.h
  • HsNavGetFocusColor() : HsExt.h
  • HsNavGetFocusRingInfo() : HsExt.h
  • HsNavLstGetTempSelection() : HsExt.h
  • HsNavLstSetTempSelection() : HsExt.h
  • HsNavObjectTakeFocus() : HsExt.h
  • HsNavRemoveFocusRing() : HsExt.h
  • HsNavSetFocusColor() : HsExt.h
  • HsNetworkDropConnection() : HsExt.h
  • HsOpenDialNumberDialog() : HsExt.h
  • HsPostProcessPopupList() : HsExtKbdUtils.h
  • HsPrefGet() : HsExt.h
  • HsPrefSet() : HsExt.h
  • HsPutObjectAfterTitle() : HsExt.h
  • HsSndClose() : HsSoundLib.h
  • HsSndFormatPlay() : HsSoundLib.h
  • HsSndFormatRecord() : HsSoundLib.h
  • HsSndGetUserVolume() : HsSoundLib.h
  • HsSndGetVersion() : HsSoundLib.h
  • HsSndOpen() : HsSoundLib.h
  • HsSndPortGetInfo() : HsSoundLib.h
  • HsSndPortSetParam() : HsSoundLib.h
  • HsSndSetUserVolume() : HsSoundLib.h
  • HsSndSwitchGetPort() : HsSoundLib.h
  • HsSndSwitchSetPort() : HsSoundLib.h
  • HsSndTonePlay() : HsSoundLib.h
  • HsSndToneStop() : HsSoundLib.h
  • HsSpringboardNotSupported() : HsExt.h
  • HsStatusSetGadgetType() : HsExt.h
  • HsStatusUpdateGadgets() : HsExt.h
  • HsTurnRadioOn() : HsExt.h
  • HsTwoFontSelect() : HsExt.h
  • HsTxtIsAscii() : HsExt.h
  • HsTxtNumChars() : HsExt.h
  • HsTxtPrepFindString() : HsExt.h
  • HsTxtTruncateString() : HsExt.h
  • HsUtilBbutHitBigButton() : HsExtUtilBigButton.h
  • HsUtilBbutInstallFromResource() : HsExtUtilBigButton.h
  • HsUtilBbutInstallNewButton() : HsExtUtilBigButton.h
  • HsUtilBbutSetBitmap() : HsExtUtilBigButton.h
  • HsUtilBbutSetLabel() : HsExtUtilBigButton.h
  • HtmlLibAbortRenderData() : HtmlLib68K.h
  • HtmlLibAddImageData() : HtmlLib68K.h
  • HtmlLibAddTextData() : HtmlLib68K.h
  • HtmlLibCanScroll() : HtmlLib68K.h
  • HtmlLibClearScreen() : HtmlLib68K.h
  • HtmlLibClose() : HtmlLib68K.h
  • HtmlLibCreateContentObject() : HtmlLib68K.h
  • HtmlLibDestroyContentObject() : HtmlLib68K.h
  • HtmlLibFinalize() : HtmlLib68K.h
  • HtmlLibFindText() : HtmlLib68K.h
  • HtmlLibGetTextSelection() : HtmlLib68K.h
  • HtmlLibGetVScrollPosition() : HtmlLib68K.h
  • HtmlLibInitialize() : HtmlLib68K.h
  • HtmlLibNotifyUIEvent() : HtmlLib68K.h
  • HtmlLibOpen() : HtmlLib68K.h
  • HtmlLibProgress() : HtmlLib68K.h
  • HtmlLibRedrawScreen() : HtmlLib68K.h
  • HtmlLibRenderData() : HtmlLib68K.h
  • HtmlLibResizeScreen() : HtmlLib68K.h
  • HtmlLibSetBiggerFont() : HtmlLib68K.h
  • HtmlLibSetDisplayMode() : HtmlLib68K.h
  • HtmlLibSetFormWidgetProc() : HtmlLib68K.h
  • HtmlLibSetInclusionCallback() : HtmlLib68K.h
  • HtmlLibSetLinkSelectionCallback() : HtmlLib68K.h
  • HtmlLibSetScanPhoneNumberCallback() : HtmlLib68K.h
  • HtmlLibSetScrollbarMode() : HtmlLib68K.h
  • HtmlLibSetScrollbars() : HtmlLib68K.h
  • HtmlLibSetSubmitFormCallback() : HtmlLib68K.h
  • HtmlLibSetVScrollPosition() : HtmlLib68K.h
  • HtmlLibSleep() : HtmlLib68K.h
  • HtmlLibWake() : HtmlLib68K.h
  • HWUBlinkLED() : HardwareUtils68K.h
  • HWUClose() : HardwareUtils68K.h
  • HWUEnableDisplay() : HardwareUtils68K.h
  • HWUGetDisplayState() : HardwareUtils68K.h
  • HWUOpen() : HardwareUtils68K.h
  • HWUSetBlinkRate() : HardwareUtils68K.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- i -

  • ImageLibBitmapDelete() : ImageLib.h
  • ImageLibCameraExists() : ImageLib.h
  • ImageLibCheckLockedImages() : ImageLib.h
  • ImageLibClose() : ImageLib.h
  • ImageLibCopyImage() : ImageLib.h
  • ImageLibCopyImageFromVFS() : ImageLib.h
  • ImageLibCopyImageToBuffer() : ImageLib.h
  • ImageLibCopyImageToFile() : ImageLib.h
  • ImageLibCopyImageToVFS() : ImageLib.h
  • ImageLibDeleteImage() : ImageLib.h
  • ImageLibDoAttachImageDialog() : ImageLib.h
  • ImageLibDrawJPEG() : ImageLib.h
  • ImageLibFindImageByID() : ImageLib.h
  • ImageLibGetAveragePictureSize() : ImageLib.h
  • ImageLibGetDimensions() : ImageLib.h
  • ImageLibGetDimensionsJPEG() : ImageLib.h
  • ImageLibGetDimensionsVFS() : ImageLib.h
  • ImageLibGetImageDatabases() : ImageLib.h
  • ImageLibGetImageID() : ImageLib.h
  • ImageLibGetImageInfo() : ImageLib.h
  • ImageLibGetJPEGQuality() : ImageLib.h
  • ImageLibGetVersion() : ImageLib.h
  • ImageLibImageBitmapCreate() : ImageLib.h
  • ImageLibImageBitmapCreateFromVFS() : ImageLib.h
  • ImageLibImageBitmapFill() : ImageLib.h
  • ImageLibImageBitmapFillFromVFS() : ImageLib.h
  • ImageLibImageCapture() : ImageLib.h
  • ImageLibImageDraw() : ImageLib.h
  • ImageLibImageDrawFromVFS() : ImageLib.h
  • ImageLibImageSave() : ImageLib.h
  • ImageLibInsertImageFromBuffer() : ImageLib.h
  • ImageLibInsertImageFromFile() : ImageLib.h
  • ImageLibIterateImages() : ImageLib.h
  • ImageLibIterateVFSImages() : ImageLib.h
  • ImageLibIterDeleteImage() : ImageLib.h
  • ImageLibIterDrawImage() : ImageLib.h
  • ImageLibIterDrawThumbnail() : ImageLib.h
  • ImageLibIterFree() : ImageLib.h
  • ImagelibIterGetCount() : ImageLib.h
  • ImageLibIterGetDimensions() : ImageLib.h
  • ImageLibIterGetImageInfo() : ImageLib.h
  • ImageLibIterRefresh() : ImageLib.h
  • ImageLibIterRemoveImage() : ImageLib.h
  • ImageLibIterResize() : ImageLib.h
  • ImageLibIterSearch() : ImageLib.h
  • ImageLibIterSort() : ImageLib.h
  • ImageLibLockImage() : ImageLib.h
  • ImageLibOpen() : ImageLib.h
  • ImageLibPreviewBitmapCreate() : ImageLib.h
  • ImageLibPreviewBitmapFill() : ImageLib.h
  • ImageLibPreviewDraw() : ImageLib.h
  • ImageLibPreviewStart() : ImageLib.h
  • ImageLibPreviewStop() : ImageLib.h
  • ImageLibResize() : ImageLib.h
  • ImageLibResizeImage() : ImageLib.h
  • ImageLibResizeJPEG() : ImageLib.h
  • ImageLibResizeVFS() : ImageLib.h
  • ImageLibSetImageID() : ImageLib.h
  • ImageLibSetImageInfo() : ImageLib.h
  • ImageLibSetJPEGQuality() : ImageLib.h
  • ImageLibSetProgressCallback() : ImageLib.h
  • ImageLibThumbnailBitmapCreate() : ImageLib.h
  • ImageLibThumbnailBitmapCreateFromVFS() : ImageLib.h
  • ImageLibThumbnailBitmapFill() : ImageLib.h
  • ImageLibThumbnailBitmapFillFromVFS() : ImageLib.h
  • ImageLibThumbnailDraw() : ImageLib.h
  • ImageLibThumbnailDrawFromVFS() : ImageLib.h
  • ImageLibTurnCameraOff() : ImageLib.h
  • InitFontUI() : palmOneVMFontLib.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- p -

  • PalmLedClose() : PalmLED.h
  • PalmLedOpen() : PalmLED.h
  • PalmLedSleep() : PalmLED.h
  • PalmLedWake() : PalmLED.h
  • PalmOneStatusBarGetAttribute() : palmOneStatusBar.h
  • PalmOneStatusBarHide() : palmOneStatusBar.h
  • PalmOneStatusBarLibClose() : palmOneStatusBar.h
  • PalmOneStatusBarLibOpen() : palmOneStatusBar.h
  • PalmOneStatusBarShow() : palmOneStatusBar.h
  • PalmPhotoAddImage() : palmOnePhoto.h
  • PalmPhotoAddImageV2() : palmOnePhoto.h
  • PalmPhotoAlbumCount() : palmOnePhoto.h
  • PalmPhotoAlbumCountV2() : palmOnePhoto.h
  • PalmPhotoCaptureImageV2() : palmOnePhoto.h
  • PalmPhotoCloseImage() : palmOnePhoto.h
  • PalmPhotoCloseImageV2() : palmOnePhoto.h
  • PalmPhotoConvertImageV2() : palmOnePhoto.h
  • PalmPhotoCreateImage() : palmOnePhoto.h
  • PalmPhotoCreateImageV2() : palmOnePhoto.h
  • PalmPhotoCropImageV2() : palmOnePhoto.h
  • PalmPhotoDeleteAlbum() : palmOnePhoto.h
  • PalmPhotoDeleteImage() : palmOnePhoto.h
  • PalmPhotoDisplayImage() : palmOnePhoto.h
  • PalmPhotoDisplayImageToSizeV3() : palmOnePhoto.h
  • PalmPhotoDisplayThumbnailV3() : palmOnePhoto.h
  • PalmPhotoFreeSelections() : palmOnePhoto.h
  • PalmPhotoFreeSelectionsV2() : palmOnePhoto.h
  • PalmPhotoGetAlbumID() : palmOnePhoto.h
  • PalmPhotoGetAlbumIDV2() : palmOnePhoto.h
  • PalmPhotoGetAlbumName() : palmOnePhoto.h
  • PalmPhotoGetImageExtraInfo() : palmOnePhoto.h
  • PalmPhotoGetImageExtraInfoSize() : palmOnePhoto.h
  • PalmPhotoGetImageInfo() : palmOnePhoto.h
  • PalmPhotoGetLastErrV2() : palmOnePhoto.h
  • PalmPhotoGetSupportedCaptureResolutionsV3() : palmOnePhoto.h
  • PalmPhotoGetThumbSize() : palmOnePhoto.h
  • PalmPhotoImageCount() : palmOnePhoto.h
  • PalmPhotoIsCameraAvailableV3() : palmOnePhoto.h
  • PalmPhotoLibClose() : palmOnePhoto.h
  • PalmPhotoLibGetVersion() : palmOnePhoto.h
  • PalmPhotoLibOpen() : palmOnePhoto.h
  • PalmPhotoLibSleep() : palmOnePhoto.h
  • PalmPhotoLibWake() : palmOnePhoto.h
  • PalmPhotoNewAlbum() : palmOnePhoto.h
  • PalmPhotoNewAlbumV2() : palmOnePhoto.h
  • PalmPhotoOpenImage() : palmOnePhoto.h
  • PalmPhotoOpenImageV2() : palmOnePhoto.h
  • PalmPhotoReadImage() : palmOnePhoto.h
  • PalmPhotoRenameAlbum() : palmOnePhoto.h
  • PalmPhotoRotateImageV2() : palmOnePhoto.h
  • PalmPhotoScaleImageV2() : palmOnePhoto.h
  • PalmPhotoSelectDlg() : palmOnePhoto.h
  • PalmPhotoSelectDlgV3() : palmOnePhoto.h
  • PalmPhotoSelectImages() : palmOnePhoto.h
  • PalmPhotoSetImageExtraInfo() : palmOnePhoto.h
  • PalmPhotoWriteImage() : palmOnePhoto.h
  • PhnLibAddAddress() : HsPhoneSMS.h
  • PhnLibAddressToText() : HsPhoneSMS.h
  • PhnLibAPGetField() : HsPhoneCDMA.h
  • PhnLibAPGetNth() : HsPhoneSMS.h
  • PhnLibAttrGet() : HsPhoneMisc.h
  • PhnLibAttrSet() : HsPhoneMisc.h
  • PhnLibBoxInformation() : HsPhoneNetwork.h
  • PhnLibBoxInformationEx() : HsPhoneNetwork.h
  • PhnLibCardInfo() : HsPhoneMisc.h
  • PhnLibCardInfoEx() : HsPhoneMisc.h
  • PhnLibClose() : HsPhoneLibrary.h
  • PhnLibConnectionAvailable() : HsPhoneMisc.h
  • PhnLibContinuePhonePowerOff() : HsPhonePower.h
  • PhnLibContinuePhonePowerOn() : HsPhonePower.h
  • PhnLibCount() : HsPhoneSMS.h
  • PhnLibCurrentOperator() : HsPhoneNetwork.h
  • PhnLibCurrentOperatorID() : HsPhoneNetwork.h
  • PhnLibCurrentProvider() : HsPhoneNetwork.h
  • PhnLibDeactivateBarring() : HsPhoneNetwork.h
  • PhnLibDeleteMessage() : HsPhoneSMS.h
  • PhnLibDisposeAddressList() : HsPhoneSMS.h
  • PhnLibEqual() : HsPhoneSMS.h
  • PhnLibErrorRate() : HsPhoneMisc.h
  • PhnLibGetAddresses() : HsPhoneSMS.h
  • PhnLibGetBarring() : HsPhoneNetwork.h
  • PhnLibGetBoxNumber() : HsPhoneNetwork.h
  • PhnLibGetCallCountByService() : HsPhoneMisc.h
  • PhnLibGetCallWaiting() : HsPhoneNetwork.h
  • PhnLibGetCLIP() : HsPhoneNetwork.h
  • PhnLibGetCLIR() : HsPhoneNetwork.h
  • PhnLibGetDataSessionInfo() : HsPhoneNetwork.h
  • PhnLibGetDate() : HsPhoneSMS.h
  • PhnLibGetDBRef() : HsPhoneSMS.h
  • PhnLibGetDeviceID() : HsPhoneMisc.h
  • PhnLibGetEchoCancellation() : HsPhoneMisc.h
  • PhnLibGetEnhancedRoamIndicator() : HsPhoneNetwork.h
  • PhnLibGetEquipmentMode() : HsPhoneMisc.h
  • PhnLibGetErrorText() : HsPhoneMisc.h
  • PhnLibGetFDNList() : HsPhoneGSM.h
  • PhnLibGetField() : HsPhoneSMS.h
  • PhnLibGetFlags() : HsPhoneSMS.h
  • PhnLibGetForwarding() : HsPhoneNetwork.h
  • PhnLibGetHeadsetConnectedInfo() : HsPhoneMisc.h
  • PhnLibGetICCID() : HsPhoneGSM.h
  • PhnLibGetID() : HsPhoneSMS.h
  • PhnLibGetLengthDetails() : HsPhoneSMS.h
  • PhnLibGetLibAPIVersion() : HsPhoneLibrary.h
  • PhnLibGetLineState() : HsPhoneMisc.h
  • PhnLibGetMicrophone() : HsPhoneMisc.h
  • PhnLibGetNoiseCancellation() : HsPhoneMisc.h
  • PhnLibGetNth() : HsPhoneSMS.h
  • PhnLibGetOperatorList() : HsPhoneNetwork.h
  • PhnLibGetOperatorLock() : HsPhoneNetwork.h
  • PhnLibGetOptions() : HsPhoneSMS.h
  • PhnLibGetOwner() : HsPhoneSMS.h
  • PhnLibGetOwnNumbers() : HsPhoneNetwork.h
  • PhnLibGetPhoneBook() : HsPhoneGSM.h
  • PhnLibGetPhoneBookIndex() : HsPhoneGSM.h
  • PhnLibGetPhoneCallStatus() : HsPhoneMisc.h
  • PhnLibGetPhoneLock() : HsPhoneSecurity.h
  • PhnLibGetRadioState() : HsPhoneMisc.h
  • PhnLibGetRoamPrefMode() : HsPhoneNetwork.h
  • PhnLibGetSDNList() : HsPhoneGSM.h
  • PhnLibGetServiceCentreAddress() : HsPhoneSMS.h
  • PhnLibGetSIMStatus() : HsPhoneGSM.h
  • PhnLibGetSMSGateway() : HsPhoneSMS.h
  • PhnLibGetSMSPreference() : HsPhoneSMS.h
  • PhnLibGetSMSRingInfo() : HsPhoneSMS.h
  • PhnLibGetSpn() : HsPhoneGSM.h
  • PhnLibGetStatus() : HsPhoneSMS.h
  • PhnLibGetSubstitution() : HsPhoneSMS.h
  • PhnLibGetText() : HsPhoneSMS.h
  • PhnLibGetType() : HsPhoneSMS.h
  • PhnLibGPRSAttached() : HsPhoneGSM.h
  • PhnLibGPRSPDPContextDefine() : HsPhoneGSM.h
  • PhnLibGPRSPDPContextListConstruct() : HsPhoneGSM.h
  • PhnLibGPRSPDPContextListDestruct() : HsPhoneGSM.h
  • PhnLibGPRSQualityOfServiceGet() : HsPhoneGSM.h
  • PhnLibGPRSQualityOfServiceSet() : HsPhoneGSM.h
  • PhnLibHasName() : HsPhoneSMS.h
  • PhnLibHomeOperatorID() : HsPhoneNetwork.h
  • PhnLibIsCallMuted() : HsPhoneMisc.h
  • PhnLibIsLegalCharacter() : HsPhoneSMS.h
  • PhnLibIsPhoneActivated() : HsPhoneMisc.h
  • PhnLibLength() : HsPhoneSMS.h
  • PhnLibMapCharacter() : HsPhoneSMS.h
  • PhnLibMiscDebugInfo() : HsPhoneMisc.h
  • PhnLibModulePowered() : HsPhonePower.h
  • PhnLibMute() : HsPhoneMisc.h
  • PhnLibNetworkAvailable() : HsPhoneNetwork.h
  • PhnLibNewAddress() : HsPhoneSMS.h
  • PhnLibNewAddressList() : HsPhoneSMS.h
  • PhnLibNewMessage() : HsPhoneSMS.h
  • PhnLibOpen() : HsPhoneLibrary.h
  • PhnLibQuerySMSMT() : HsPhoneSMS.h
  • PhnLibRegister() : HsPhoneLibrary.h
  • PhnLibRegistered() : HsPhoneNetwork.h
  • PhnLibReleaseDBRef() : HsPhoneSMS.h
  • PhnLibRoaming() : HsPhoneNetwork.h
  • PhnLibSATEndSession() : HsPhoneGSM.h
  • PhnLibSATGetMainMenu() : HsPhoneGSM.h
  • PhnLibSATSendRequest() : HsPhoneGSM.h
  • PhnLibSendLongDTMF() : HsPhoneGSM.h
  • PhnLibSendMessage() : HsPhoneSMS.h
  • PhnLibSendPendingMessages() : HsPhoneSMS.h
  • PhnLibSendSMSMTAck() : HsPhoneSMS.h
  • PhnLibSendUSSD() : HsPhoneGSM.h
  • PhnLibSetActiveLine() : HsPhoneGSM.h
  • PhnLibSetAddresses() : HsPhoneSMS.h
  • PhnLibSetBarring() : HsPhoneNetwork.h
  • PhnLibSetCallWaiting() : HsPhoneNetwork.h
  • PhnLibSetCLIP() : HsPhoneNetwork.h
  • PhnLibSetCLIR() : HsPhoneNetwork.h
  • PhnLibSetDate() : HsPhoneSMS.h
  • PhnLibSetEchoCancellation() : HsPhoneMisc.h
  • PhnLibSetEquipmentMode() : HsPhoneMisc.h
  • PhnLibSetFDNEntry() : HsPhoneGSM.h
  • PhnLibSetField() : HsPhoneSMS.h
  • PhnLibSetFlags() : HsPhoneSMS.h
  • PhnLibSetForwarding() : HsPhoneNetwork.h
  • PhnLibSetID() : HsPhoneSMS.h
  • PhnLibSetMicrophone() : HsPhoneMisc.h
  • PhnLibSetModulePower() : HsPhonePower.h
  • PhnLibSetNoiseCancellation() : HsPhoneMisc.h
  • PhnLibSetNth() : HsPhoneSMS.h
  • PhnLibSetNumber() : HsPhoneSMS.h
  • PhnLibSetOperator() : HsPhoneNetwork.h
  • PhnLibSetOptions() : HsPhoneSMS.h
  • PhnLibSetOwner() : HsPhoneSMS.h
  • PhnLibSetOwnNumbers() : HsPhoneNetwork.h
  • PhnLibSetPhoneBook() : HsPhoneGSM.h
  • PhnLibSetPhoneBookEntry() : HsPhoneGSM.h
  • PhnLibSetRoamPrefInfo() : HsPhoneNetwork.h
  • PhnLibSetRoamPrefMode() : HsPhoneNetwork.h
  • PhnLibSetServiceCentreAddress() : HsPhoneSMS.h
  • PhnLibSetSMSCallbackNumber() : HsPhoneSMS.h
  • PhnLibSetSMSPreference() : HsPhoneSMS.h
  • PhnLibSetSMSRingInfo() : HsPhoneSMS.h
  • PhnLibSetStatus() : HsPhoneSMS.h
  • PhnLibSetText() : HsPhoneSMS.h
  • PhnLibSignalQuality() : HsPhoneNetwork.h
  • PhnLibSignalQualityEx() : HsPhoneNetwork.h
  • PhnLibSIMInfo() : HsPhoneGSM.h
  • PhnLibSleep() : HsPhoneLibrary.h
  • PhnLibStartVibrate() : HsPhoneMisc.h
  • PhnLibStopVibrate() : HsPhoneMisc.h
  • PhnLibUninstall() : HsPhoneLibrary.h
  • PhnLibUsableSignalStrengthThreshold() : HsPhoneNetwork.h
  • PhnLibWake() : HsPhoneLibrary.h
  • PinGetCurrentPinletID() : PalmPin.h
  • PinGetInputAreaState() : PalmPin.h
  • PinGetInputMode() : PalmPin.h
  • PinLibClose() : PalmPin.h
  • PinLibOpen() : PalmPin.h
  • PinResetInputState() : PalmPin.h
  • PinSetInputAreaState() : PalmPin.h
  • PinSetInputMode() : PalmPin.h
  • PinSwitchToPinlet() : PalmPin.h
  • PmConnectorLibClose() : PmConnectorLib.h
  • PmConnectorLibControl() : PmConnectorLib.h
  • PmConnectorLibGetVersion() : PmConnectorLib.h
  • PmConnectorLibOpen() : PmConnectorLib.h
  • PmConnectorLibSetAudioInput() : PmConnectorLib.h
  • PmConnectorLibSetAudioOutput() : PmConnectorLib.h
  • PmConnectorLibSleep() : PmConnectorLib.h
  • PmConnectorLibWake() : PmConnectorLib.h
  • PmKeyAttrGet() : PmKeyLib.h
  • PmKeyAttrSet() : PmKeyLib.h
  • PmKeyChrCodeToKeyCode() : PmKeyLib.h
  • PmKeyEnableKey() : PmKeyLib.h
  • PmKeyEventIsFromKeyboard() : PmKeyLib.h
  • PmKeyKeyCodeToChrCode() : PmKeyLib.h
  • PmKeyKeysPressed() : PmKeyLib.h
  • PmKeyLibClose() : PmKeyLib.h
  • PmKeyLibOpen() : PmKeyLib.h
  • PmKeyStop() : PmKeyLib.h
  • PmSndClkGetTickCount() : HsSoundLib.h
  • PmSndClkGetTicksPerSecond() : HsSoundLib.h
  • PmSndGetPosition() : HsSoundLib.h
  • PmSysGadgetBbutHitBigButton() : PmSysGadgetLib.h
  • PmSysGadgetBbutInstallFromResource() : PmSysGadgetLib.h
  • PmSysGadgetBbutInstallNewButton() : PmSysGadgetLib.h
  • PmSysGadgetBbutSetBitmap() : PmSysGadgetLib.h
  • PmSysGadgetBbutSetLabel() : PmSysGadgetLib.h
  • PmSysGadgetLibClose() : PmSysGadgetLib.h
  • PmSysGadgetLibOpen() : PmSysGadgetLib.h
  • PmSysGadgetStatusGadgetsUpdate() : PmSysGadgetLib.h
  • PmSysGadgetStatusGadgetTypeSet() : PmSysGadgetLib.h
  • PmUIUtilLibClose() : PmUIUtilLib.h
  • PmUIUtilLibOpen() : PmUIUtilLib.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- s -

  • SetFontUIRules() : palmOneVMFontLib.h
  • SndFileStreamClose() : palmOneSndFileStream.h
  • SndFileStreamCreate() : palmOneSndFileStream.h
  • SndFileStreamDeviceControl() : palmOneSndFileStream.h
  • SndFileStreamGetCurrentStreamData() : palmOneSndFileStream.h
  • SndFileStreamGetPan() : palmOneSndFileStream.h
  • SndFileStreamGetVolume() : palmOneSndFileStream.h
  • SndFileStreamLibClose() : palmOneSndFileStream.h
  • SndFileStreamLibOpen() : palmOneSndFileStream.h
  • SndFileStreamLibSleep() : palmOneSndFileStream.h
  • SndFileStreamLibVersion() : palmOneSndFileStream.h
  • SndFileStreamLibWake() : palmOneSndFileStream.h
  • SndFileStreamOpen() : palmOneSndFileStream.h
  • SndFileStreamPause() : palmOneSndFileStream.h
  • SndFileStreamSeek() : palmOneSndFileStream.h
  • SndFileStreamSetPan() : palmOneSndFileStream.h
  • SndFileStreamSetVolume() : palmOneSndFileStream.h
  • SndFileStreamStart() : palmOneSndFileStream.h
  • SndFileStreamStop() : palmOneSndFileStream.h
  • SndFileStreamUIPlay() : palmOneSndFileStream.h
  • SndFileStreamUIRecord() : palmOneSndFileStream.h
  • SndStreamCreateExtended() : PalmSoundMgrExt.h
  • SndStreamDeviceControl() : PalmSoundMgrExt.h
  • STEAppendParsedInfo() : SmartTextEngine.h
  • STEAppendTextToEngine() : SmartTextEngine.h
  • STEClearCurrentSelection() : SmartTextEngine.h
  • STEClose() : SmartTextEngine.h
  • STECopySelectionToClipboard() : SmartTextEngine.h
  • STEGetAPIVersion() : SmartTextEngine.h
  • STEGetCurrentTextSelection() : SmartTextEngine.h
  • STEGetFlags() : SmartTextEngine.h
  • STEGetLastTapInfo() : SmartTextEngine.h
  • STEGetNumLines() : SmartTextEngine.h
  • STEGetNumRecords() : SmartTextEngine.h
  • STEGetParsedInformation() : SmartTextEngine.h
  • STEGetScroll() : SmartTextEngine.h
  • STEGetScrollPct() : SmartTextEngine.h
  • STEGetSelectedText() : SmartTextEngine.h
  • STEHandleEvent() : SmartTextEngine.h
  • STEHandleKeyDownEvent() : SmartTextEngine.h
  • STEHandlePenDownEvent() : SmartTextEngine.h
  • STEHandlePenMoveEvent() : SmartTextEngine.h
  • STEHandlePenUpEvent() : SmartTextEngine.h
  • STEHandleSclRepeatEvent() : SmartTextEngine.h
  • STEHasHotRectSelection() : SmartTextEngine.h
  • STEHasMessageSelection() : SmartTextEngine.h
  • STEHasTextSelection() : SmartTextEngine.h
  • STEInitializeEngine() : SmartTextEngine.h
  • STEOpen() : SmartTextEngine.h
  • STEQuickRender() : SmartTextEngine.h
  • STEReinitializeEngine() : SmartTextEngine.h
  • STERemoveLastRecordFromEngine() : SmartTextEngine.h
  • STERenderList() : SmartTextEngine.h
  • STERerenderList() : SmartTextEngine.h
  • STEResetEngine() : SmartTextEngine.h
  • STESetCurrentTextSelection() : SmartTextEngine.h
  • STESetCustomHyperlinkCallback() : SmartTextEngine.h
  • STESetFlags() : SmartTextEngine.h
  • STESetScroll() : SmartTextEngine.h
  • STESetScrollPct() : SmartTextEngine.h
  • STESetScrollToRecordNum() : SmartTextEngine.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- t -

  • TonesLibAddMidiTone() : TonesLib.h
  • TonesLibClose() : TonesLib.h
  • TonesLibDeleteTone() : TonesLib.h
  • TonesLibDoDialog() : TonesLib.h
  • TonesLibEscalateRingTones() : TonesLib.h
  • TonesLibGetSoundOnVolume() : TonesLib.h
  • TonesLibGetSoundPrefs() : TonesLib.h
  • TonesLibGetToneIDs() : TonesLib.h
  • TonesLibGetToneList() : TonesLib.h
  • TonesLibGetToneName() : TonesLib.h
  • TonesLibGetToneSize() : TonesLib.h
  • TonesLibInitTonesDB() : TonesLib.h
  • TonesLibManageTones() : TonesLib.h
  • TonesLibOpen() : TonesLib.h
  • TonesLibPickTone() : TonesLib.h
  • TonesLibPlayRingTone() : TonesLib.h
  • TonesLibPlayTone() : TonesLib.h
  • TonesLibRecordTone() : TonesLib.h
  • TonesLibSetSoundOnVolume() : TonesLib.h
  • TonesLibSetSoundPrefs() : TonesLib.h
  • TonesLibSleep() : TonesLib.h
  • TonesLibStopTone() : TonesLib.h
  • TonesLibToneClose() : TonesLib.h
  • TonesLibToneCreate() : TonesLib.h
  • TonesLibToneWrite() : TonesLib.h
  • TonesLibWake() : TonesLib.h
  • TransLibCloseConnection() : TransparencyLib.h
  • TransLibOpenConnection() : TransparencyLib.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- v -

  • VMFontClearCache() : palmOneVMFontLib.h
  • VMFontClose() : palmOneVMFontLib.h
  • VMFontCountStyleAndSize() : palmOneVMFontLib.h
  • VMFontExists() : palmOneVMFontLib.h
  • VMFontGetFont() : palmOneVMFontLib.h
  • VMFontGetFontByID() : palmOneVMFontLib.h
  • VMFontOpen() : palmOneVMFontLib.h
  • VMFontToString() : palmOneVMFontLib.h
  • VMFontVersion() : palmOneVMFontLib.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • n
  • p
  • s
  • t
  • v

- a -

  • AddrHsLookupParamsPtr : HsAppLaunchCmd.h
  • AddrHsLookupParamsType : HsAppLaunchCmd.h
  • AddrListLookupTypeEnum : HsAppLaunchCmd.h

- b -

  • BGRecvResponseFP : PalmBGService.h

- c -

  • CamLibApertureValueType : palmOneCameraCommon.h
  • CamLibBitmapInfoType : palmOneCameraCommon.h
  • CamLibBufNumType : palmOneCameraCommon.h
  • CamLibCaptureCallbackFunc : palmOneCameraCommon.h
  • CamLibCaptureFormatType : palmOneCameraCommon.h
  • CamLibCaptureType : palmOneCameraCommon.h
  • CamLibColorSpaceType : palmOneCameraCommon.h
  • CamLibContrastType : palmOneCameraCommon.h
  • CamLibControlType : palmOneCameraCommon.h
  • CamLibEffectsType : palmOneCameraCommon.h
  • CamLibExposureType : palmOneCameraCommon.h
  • CamLibImageSizeType : palmOneCameraCommon.h
  • CamLibLightingType : palmOneCameraCommon.h
  • CamLibSaturationType : palmOneCameraCommon.h
  • CamLibSettingType : palmOneCameraCommon.h
  • CamLibSharpnessType : palmOneCameraCommon.h
  • CamLibShutterSpeedType : palmOneCameraCommon.h
  • CamLibStatusType : palmOneCameraCommon.h
  • CamLibStreamPreviewType : palmOneCameraCommon.h
  • CamLibStreamType : palmOneCameraCommon.h
  • CamLibWhiteBalanceType : palmOneCameraCommon.h
  • CamLibZoomType : palmOneCameraCommon.h
  • CCSMBrowserFlagsType : CarrierCustomLibTypes.h
  • CCSMCarrierHandle : CarrierCustomLibTypes.h
  • CCSMMessagingFlagsType : CarrierCustomLibTypes.h
  • CCSMPhoneFlagsType : CarrierCustomLibTypes.h
  • CCSMRadioBandType : CarrierCustomLibTypes.h
  • CCSMSettingsType : CarrierCustomLibTypes.h
  • CCSMSystemFlagsType : CarrierCustomLibTypes.h

- d -

  • dataLinks : PalmVMPlugin.h
  • DeleteObjectProc : HtmlLib68K.h
  • DSTType : LocsLibCommon.h

- e -

  • ePmConnectorAudioOutputSettingsType : PmConnectorLibCommon.h

- g -

  • GoLcdColorModeType : PalmGoLCDCommon.h
  • GoLcdGsiStateType : PalmGoLCDCommon.h
  • GoLcdInkStateType : PalmGoLCDCommon.h
  • GoLcdModeType : PalmGoLCDCommon.h
  • GoLcdStatusType : PalmGoLCDCommon.h

- h -

  • HelperServiceMMSDetailsType : MmsHelperCommon.h
  • HelperServiceMMSObjectType : MmsHelperCommon.h
  • HS_HTTPLibHandle : HS_HTTPLibApp.h
  • HsSndBufferProc : HsSoundLibCommon.h
  • HsSndCmdType : HsSoundLibCommon.h
  • HsSndFormatType : HsSoundLibCommon.h
  • HsSndMode : HsSoundLibCommon.h
  • HsSndParam : HsSoundLibCommon.h
  • HsSndPortClass : HsSoundLibCommon.h
  • HsSndPortID : HsSoundLibCommon.h
  • HsSndSwitchID : HsSoundLibCommon.h
  • hsSndSysBeepType : HsSoundLibCommon.h
  • HtmlLibInclusionCallback : HtmlLib68K.h
  • HtmlLibLinkSelCallback : HtmlLib68K.h
  • HtmlLibScanPhoneNumberCallback : HtmlLib68K.h
  • HtmlLibSubmitFormCallback : HtmlLib68K.h

- i -

  • ImageIteratorHandle : ImageLibCommon.h
  • ImageLibProgressCallbackType : ImageLibCommon.h
  • IOTANotificationEventType : HsPhoneIOTATypes.h

- l -

  • LcdOverlayLibControlType : palmOneLcdOverlayCommon.h
  • LcdOverlayLibFormatType : palmOneLcdOverlayCommon.h
  • LcdOverlayLibSettingType : palmOneLcdOverlayCommon.h, PalmLcdOverlay.h

- n -

  • Net80211DeviceInfoP : PalmNetServices.h
  • Net80211InfrastructureModeType : PalmWiFiCommon.h
  • NetBssInfoTypeP : PalmWiFiCommon.h
  • NetBssListType : PalmWiFiCommon.h
  • NetMasterAutoLoginType : NetMasterLibTypes.h
  • NetMasterClientEventEnum : NetMasterLibTypes.h
  • NetMasterDataContextIDType : NetMasterLibTypes.h
  • NetMasterDataSessionIDType : NetMasterLibTypes.h
  • NetMasterLoginPriorityEnum : NetMasterLibTypes.h
  • NetMasterNetIFShutDownOptionsType : NetMasterLibTypes.h
  • NetMasterNetLibOpenOptionsType : NetMasterLibTypes.h
  • NetPref1xRTTTunnelingEnum : NetPrefLibTypes.h
  • NetPrefFallbackAlgrorithmEnum : NetPrefLibTypes.h
  • NetPrefFieldSetDefineOptionsType : NetPrefLibTypes.h
  • NetPrefFieldTypeEnum : NetPrefLibTypes.h
  • NetPrefMutexStickyFBAStatusEnum : NetPrefLibTypes.h
  • NetPrefNetCloseWaitEnum : NetPrefLibTypes.h
  • NetPrefNetIdleTimeoutEnum : NetPrefLibTypes.h
  • NetPrefRecFieldAttrType : NetPrefLibTypes.h
  • NetPrefRecFieldEnum : NetPrefLibTypes.h
  • NetPrefRecFieldViewType : NetPrefLibTypes.h
  • NetPrefRecIDType : NetPrefLibTypes.h
  • NetPrefRecProtectionType : NetPrefLibTypes.h
  • NetPrefSvcBindingEnum : NetPrefLibTypes.h
  • NetPrefSvcGatewayType : NetPrefLibTypes.h
  • NetPrefSvcMediumEnum : NetPrefLibTypes.h
  • NetPrefSvcTargetEnum : NetPrefLibTypes.h
  • NetQueryType : PalmWiFiCommon.h
  • NetQueryTypeP : PalmWiFiCommon.h
  • NetServicesProfileInfoP : PalmNetServices.h
  • NetServicesProfileOrderP : PalmNetServices.h
  • NetServicesProfileP : PalmNetServices.h
  • NetServicesProfileV1P : PalmNetServices.h
  • NetSSIDP : PalmWiFiCommon.h
  • NetWepKeyP : PalmWiFiCommon.h
  • NewControlProc : HtmlLib68K.h
  • NewFieldProc : HtmlLib68K.h
  • NewListProc : HtmlLib68K.h

- p -

  • PalmAudioPlaybackActionCodeType : PalmAudioPlayback.h
  • PalmAudioPlaybackNotifyEventType : PalmAudioPlayback.h
  • PalmCodecFormat : palmOneCodecPluginMgrCommon.h
  • PalmCodecSession : palmOneCodecPluginMgrCommon.h
  • PalmOneStatAttrType : palmOneStatusBar.h
  • PalmPhotoCaptureCallbackV2 : palmOnePhoto.h
  • PalmPhotoCaptureParamV2 : palmOnePhoto.h
  • PalmPhotoCaptureResolution : palmOnePhotoCommon.h
  • PalmPhotoCreateParam : palmOnePhoto.h
  • PalmPhotoDisplayCallback : palmOnePhoto.h
  • PalmPhotoDisplayParam : palmOnePhoto.h
  • PalmPhotoDlgType : palmOnePhotoCommon.h
  • PalmPhotoExtraInfoParam : palmOnePhotoCommon.h
  • PalmPhotoExtraInfoType : palmOnePhotoCommon.h
  • PalmPhotoFileFormat : palmOnePhotoCommon.h
  • PalmPhotoFileLocation : palmOnePhotoCommon.h
  • PalmPhotoFilterCallback : palmOnePhoto.h
  • PalmPhotoHandle : palmOnePhotoCommon.h
  • PalmPhotoImageInfo : palmOnePhotoCommon.h
  • PalmPhotoLocationType : palmOnePhotoCommon.h
  • PalmPhotoMediaType : palmOnePhotoCommon.h
  • PalmPhotoQualityType : palmOnePhotoCommon.h
  • PalmPhotoReadWriteCallback : palmOnePhoto.h
  • PalmPhotoReadWriteParam : palmOnePhoto.h
  • PalmPhotoSelectionParam : palmOnePhoto.h
  • PalmPhotoSelections : palmOnePhotoCommon.h
  • PalmPhotoUID : palmOnePhotoCommon.h
  • PhnConnectionID : HsPhoneTypes.h
  • PhnDatabaseID : HsPhoneTypes.h
  • PHNErrorCode : HsPhoneErrors.h
  • PhnForwardModeType : HsPhoneNetworkTypes.h
  • PhnForwardType : HsPhoneNetworkTypes.h
  • PhnIOTAItemType : HsPhoneIOTATypes.h
  • PhnPDSessionConfigParamType : hsPhoneLocationTypes.h
  • PhnRoamStatus : HsPhoneNetworkTypes.h
  • PhnSMSClass : HsPhoneEvent.h
  • PhnSMSType : HsPhoneEvent.h
  • pluginExtendedQueryParams : PalmVMPlugin.h
  • pluginGetInfoParams : PalmVMPlugin.h
  • pluginParams : PalmVMPlugin.h
  • pluginQueryParams : PalmVMPlugin.h
  • pluginSendParams : PalmVMPlugin.h
  • PmAudioGroup : PmSoundLibAudioGroup.h
  • PmClkTickRef : HsSoundLibCommon.h
  • PmConnectorAudioOutputSettingType : PmConnectorLibCommon.h
  • PmConnectorLibControlType : PmConnectorLibCommon.h
  • PmSndPrefID : HsSoundLibCommon.h
  • PmUIUtilAttrEnum : PmUIUtilLibCommon.h

- s -

  • SndFileFormatType : palmOneSndFileStream.h
  • SndFileStreamCallbackPtr : palmOneSndFileStream.h
  • SndFileStreamData : palmOneSndFileStream.h
  • SndFileStreamDataPtr : palmOneSndFileStream.h
  • SndFileStreamFileSpec : palmOneSndFileStream.h
  • SndFileStreamFileSpecPtr : palmOneSndFileStream.h
  • SndFileStreamHsSoundCommandParam : palmOneSndFileStream.h
  • SndFileStreamHsSoundCommandParamPtr : palmOneSndFileStream.h
  • SndFileStreamRef : palmOneSndFileStream.h
  • SndFormatType : PalmSoundMgrExt.h
  • SndStreamVariableBufferCallback : PalmSoundMgrExt.h
  • SoundPrefType : TonesLibTypes.h
  • STECallbackType : SmartTextEngineDef.h
  • STEErr : SmartTextEngineErrors.h

- t -

  • TonePlayNumberTimes : TonesLibTypes.h
  • ToneRepeatInterval : TonesLibTypes.h
  • ToneTimeUnit : TonesLibTypes.h
  • ToneType : TonesLibTypes.h
  • ToneVibrateType : TonesLibTypes.h
  • ToneVolume : TonesLibTypes.h

- v -

  • VMFontFace : VMFontLibCommon.h
  • VMFontSize : VMFontLibCommon.h
  • VMFontSizeRule : VMFontLibCommon.h
  • VMFontStyle : VMFontLibCommon.h
  • VMFontStyleRule : VMFontLibCommon.h
  • VPNNotifyEventType : PalmShimSettings.h
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Palm API Guide Related Pages

Here is a list of all related documentation pages:
  • Deprecated List
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:54 2006 for Palm API Guide


Deprecated List

Global ImageLibResizeImage

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:53 2006 for Palm API Guide


Palm API Guide Data Structure Index

A | B | C | D | H | L | M | N | P | S | T | U | V | W | _

A
AddrCallerIDParamsType
AddrCreateNewRecordParamsType
AddrDescriptor
Address
AddressAppRecord
AddressAppRecordHeader
AddressType
AddrHsLookupUserDataType
AddrListLookupTypeGetParamsType
AddrPhonebookAppParamsType
AddrPhotoCallerIDParamsType
B
BGResult
BSSListStruct
C
CamLibBitmapInfoTag
CamLibCaptureTag
CamLibColorSpaceTag
CamLibSettingTag
CamLibStatusTag
CamLibStreamTag
Coordinate
D
DevAppLaunchCmdGenericCallType
DialPnlDispatchDialParamsType
DialPnlIsDialingAvailableParamsType
H
HS_HTTPLibAppinfo_
HS_HTTPLibSplit_
HsBigButtonMappingType
HsBigButtonReourceType
HsDialPrefsUSDialingRulesType
HsSndBufferData
HsSndPortInfo
HtmlLibFormWidgetProc
L
LcdOverlayLibSettingTag
LocationDataTag
LocDBInfoTag
LocDBRecordTag
LocsLibNotifyDataTag
LocsLibNotifyLocsDataTag
LocsLibSelLocsTag
M
MailAddRecordAttachment
MailAddRecordParamsTypePlus
MMProAttachDataLinks
MMProAttachStruct
MMProAttachStruct2
MMProLaunchStruct
MMProLaunchStruct2
N
NBSNotificationEventType
Net80211DeviceInfo
NetBssInfoType
NetMasterClientEventInfoType
NetMasterClientEventVPNConnInstallType
NetPrefFallbackInfoType
NetPrefGPRSQOSType
NetServicesProfile
NetServicesProfileInfo
NetServicesProfileOrder
NetServicesProfileV1
NetSSID
NetWepKey
NetworkDeviceQueryData
P
PalmAudioAACDecParamType
PalmAudioAACParamType
PalmAudioADPCMParamType
PalmAudioMP2ParamType
PalmAudioPCMParamType
PalmAudioPlaybackNotifyEventTypeTag
PalmFileFormatParamType
PalmImageBMPParamType
PalmImageGIFFrameParamType
PalmImageINDEXParamType
PalmImageJPEGEncodeParamType
PalmImageParamType
PalmImagePlanarType
PalmVideoAVCCustomGetDecodedFrameType
PalmVideoAVCCustomGetInfoType
PalmVideoAVCCustomSetCropModeType
PalmVideoAVCDecodeParamType
PalmVideoAVCOutputBufferType
PalmVideoMPEG1DecodeParamType
PalmVideoMPEG4DecodeParamType
PalmVideoMPEG4EncodeParamType
ParsedInfo
ParsedInfoList
PhnCdmaSystemInfoType
PhnConnectionType
PhnEventType
PhnGPRSPDPContextListNodeType
PhnGPRSPDPContextType
PhnIOTAPhnDlsLockType
PhnLibLengthInfoType
PhnLineStateType
PhnMMIEntryType
PhnMMIResultType
PhnOneXStatus
PhnOperatorListType
PhnPDPList
PhnPDPPayload
PhnRadioStateType
PhnRingingInfoType
PhnRoamPrefInfoType
PhnSMSParams
PhnSMSPrefType
PhoneAppLaunchCmdCallerIDLookupType
PhoneAppLaunchCmdDialType
PhoneAppLaunchCmdGetALSLineNumberType
PhoneAppLaunchCmdGetDialPrefFlagType
PhoneAppLaunchCmdSendDTMFToneType
PhoneAppLaunchCmdSetWallpaperType
PmBroadcastNewMsgCountNotifyParamType
PmConnectorNotifyDataType
PmGetNewMsgCountNotifyParamType
PmSysGadgetBbutMappingType
PmSysGadgetBbutResourceType
PosType
S
SndCodecCustomControlType
SoundPreference
SoundPreference::_tonePrefs
SoundPreferenceCalendar
SoundPreferenceEmail
SoundPreferenceIM
SoundPreferenceMMS
SoundPreferenceNetworkSounds
SoundPreferencePhone
SoundPreferenceSMS
SoundPrefsLaunchCmdParamType
SysVPPILaunchCmdClearPWCacheType
SysVPPILaunchCmdDeleteAccountType
SysVPPILaunchCmdEditAccountType
SysVPPILaunchCmdErrorDialogType
SysVPPILaunchCmdGetAccountsType
SysVPPILaunchCmdProgressPaintType
SysVPPILaunchCmdPromptAndConfigureType
SysVPPILaunchCmdSetCurrentAccountType
SysVPPILaunchCmdWillPWPromptType
T
tagIOTANotificationEventType
tagSndFileStreamData
tagSndFileStreamFileSpec
tagSndFileStreamHsSoundCommandParam
ToneIdentifier
ToneItemType
U
UPNotificationEventType
V
VMFontType
VMFontUIRules
VPNAccountType
vpnNotifyVPNLibTag
W
webBrowserMinimalModeLaunchInfo
webBrowserURLWithSvcIDLaunchInfo
WUNotificationEventType
_
_dataLinks
_HelperServiceMMSDetailsType
_HelperServiceMMSObjectType
_PalmPhotoCaptureParamV2
_PalmPhotoCreateParam
_PalmPhotoDisplayParam
_PalmPhotoExtraInfo
_PalmPhotoFileLocation
_PalmPhotoImageInfo
_PalmPhotoReadWriteParam
_PalmPhotoSelectionParam
_PalmPhotoSelections
_pluginExtendedQueryParams
_pluginGetInfoParams
_pluginParams
_pluginQueryParams
_pluginSendParams

A | B | C | D | H | L | M | N | P | S | T | U | V | W | _

Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:31 2006 for Palm API Guide


Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};
If the MAX_DOT_GRAPH_HEIGHT tag in the configuration file is set to 240 this will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled black box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.
The arrows have the following meaning:
  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.
Top Developer Home
© 2004-2006, Palm, Inc. All rights reserved.
Generated on Wed Nov 22 14:05:54 2006 for Palm API Guide


Sample Codes

The table below provides the list of sample codes that are available for each of the Palm library. The sample codes can be downloaded from the Palm PluggedIn website under Development Resources or through the Quick Links.

Note: The API Guide must be located under the same directory as Samples to allow the links below to work.

Library/Feature Name | Sample Code Name
HTTP Library | HTTPLibTest
HTML Library | HtmlLibTest68k
NetPref Library | NetSelector
Camera | CameraV2, CameraV3, PalmPhotoCapturePreview
Codec Plugin Manager | MiniGIF, MiniMP3
Default Helper | MMSCounter, MMSReceiver, HelperSender
File Browser | FileBrowserSample
Sound | ExtendedSound, MiniBuzzer
Imaging | FotoFinish
Multi Connector | Treo650PowerOut, TungstenT5SwitchAudio
Key Library | Keyguard
Favorites DB | CustomFav
Smart Text Engine | STETest
Telephony | GSMStatus, PhoneEventReceiver, RadioSample, Simple SMS, TickStock, PhoneInfo
Ring Tone | RingTone
Versamail | AddEmailtoVersaMail
5-Way Navigation | FiveWayV2, NavExample
Full Screen Writing | FullScreenWriting
REM Sleep | REMTimer
System | MemoryInfo, NVFSTest, StatusBar, SerialCommunication
Tungsten T5 | TungstenT5FlowControl, TungstenT5SwitchAudio, TungstenT5SwitchAudioAlt
Synchronization | Conduit

Top

Developer Home
© 2004-2006, Palm, Inc. All rights reserved.